the DirectX eXperience

  • DirectSound news group - Udo Giacomozzi 12:05:51 9/30/98 (0)
  • New Programmer - Matt Rogers 02:16:40 9/30/98 (0)
  • 3D math - Clay 18:14:20 9/29/98 (1)
    • Re: 3D math - Fragmo 02:24:25 9/30/98 (0)
  • Moving Around - dolce 14:50:49 9/29/98 (0)
  • C or C++ - Pegleg 13:10:40 9/29/98 (1)
    • Re: C or C++ - Clay 15:33:29 9/29/98 (0)
  • Dinput and Ddraw - Stevie W. 09:13:06 9/28/98 (0)
  • Newbie at Direct3D - BJ Neilsen 02:31:05 9/27/98 (0)
  • link errors - Fragmo 19:24:00 9/26/98 (0)
  • Announcement: New DirectX Library - Matt Fausey 01:44:33 9/26/98 (0)
  • DDraw/Dialog-Problem particular solved - Danny Oneway 09:00:11 9/25/98 (0)
  • "Ever used dialogs in exclusive-mode" it continues - Danny Oneway 04:58:11 9/25/98 (0)
  • Locking and blting - Septim 17:01:06 9/24/98 (5)
    • Re: Locking and blting - Danny Oneway 19:03:32 9/24/98 (4)
      • Re: Locking and blting - Septim 19:54:57 9/24/98 (3)
        • Re: Locking and blting - Clay 22:10:08 9/24/98 (2)
          • Re: Locking and blting - Danny Oneway 07:07:23 9/28/98 (1)
            • Re: Locking and blting+ asm32 - Spikes 08:29:11 9/28/98 (0)
  • Ever used Dialogs in exclusive-mode? - Danny Oneway 15:32:57 9/24/98 (2)
    • Re: Ever used Dialogs in exclusive-mode? - Clay 21:51:20 9/24/98 (0)
    • Re: Ever used Dialogs in exclusive-mode? - Clay 21:49:58 9/24/98 (0)
  • Need info on compatible sound cards - Steve 12:36:45 9/24/98 (0)
  • Direct3D RM Alpha blending - David Adams 12:32:03 9/24/98 (1)
    • Anyone knows how to do 2D transparency with DD?? - Crusader X 09:53:48 9/29/98 (0)
  • Direct3D IM Framework Tutorials - Wolfgang Engel 02:46:41 9/24/98 (0)
  • DirectSound & ACM - Ben Lazo 20:59:42 9/23/98 (0)
  • Q: RIVA TNT - Pablo de Heras 16:26:41 9/23/98 (1)
    • Re: Q: RIVA TNT - Clay 18:53:56 9/23/98 (0)
  • Need some answers!!! - JBarrett 10:05:41 9/23/98 (0)
  • OffscreenPlain backbuffer for 3DDevice fails with 8-bit color - Luke 13:51:13 9/22/98 (0)
  • Debugging with DIRECT DRAW! 2 Monitors - Bardya 10:26:47 9/21/98 (1)
    • Re: Debugging with DIRECT DRAW! 2 Monitors - Myopic Rhino 18:02:32 9/21/98 (0)
  • Locking when Cooperative level is NORMAL!? - Bardya 10:23:02 9/21/98 (0)
  • BACKBUFFER problem - Michel Lequim 14:31:50 9/20/98 (2)
    • Re: BACKBUFFER problem - Clay 07:39:39 9/21/98 (1)
      • Re: BACKBUFFER problem - Michel Lequim 16:45:38 9/23/98 (0)
  • Shouldn't 300Mhz make things a little faster? - Pegleg 20:39:42 9/19/98 (7)
    • It's Page-Flipping, but why so slow? - Pegleg 22:30:10 9/22/98 (6)
      • Re: It's Page-Flipping, but why so slow? - Clay 22:18:41 9/23/98 (5)
        • Re: Use while....WASSTILLDRAWING - Pegleg 17:40:49 9/26/98 (4)
          • Re: Use while....WASSTILLDRAWING - Clay 22:19:29 9/27/98 (3)
            • Re: Use while....WASSTILLDRAWING - Pegleg 20:42:08 9/28/98 (2)
              • Re: Use while....WASSTILLDRAWING - Clay 15:29:15 9/29/98 (1)
                • Re: Use while....WASSTILLDRAWING - Pegleg 01:08:08 9/30/98 (0)
  • Learning DirectX programming in C - Andrew Ritchie 21:24:06 9/18/98 (1)
    • Re: Learning DirectX programming in C - David Wright 00:58:00 9/30/98 (0)
  • DirectX Media (Direct Show) and Borland C++ Builder 3.0 - Mihail Mouhlov 07:12:49 9/18/98 (0)
  • DirectX Media (Direct Show) and Borland C++ Builder 3.0 - Mihail Mouhlov 07:11:04 9/18/98 (0)
  • Where is all the direct play info? - Jeff 00:59:11 9/18/98 (0)
  • windowed and mfc - Marco Trive 18:52:07 9/17/98 (1)
    • Re: windowed and mfc - Clay 22:15:32 9/23/98 (0)
  • Problem Linking Digital FX Demo. - Mark 17:19:32 9/17/98 (0)
  • Question on DirectSound !!! - JImmy 10:45:43 9/17/98 (0)
  • Setecting a Voodoo2 Driver in code - Karl Fisher 19:08:18 9/15/98 (0)
  • Alpha Blending w/ DX5.0 - Owen Davis 18:36:05 9/14/98 (4)
    • Re: Alpha Blending w/ DX5.0 - Yang Huan 21:50:41 9/19/98 (3)
      • Re: Alpha Blending w/ DX5.0 - Owen Davis 18:04:34 9/20/98 (0)
      • Re: Alpha Blending w/ DX5.0 - Owen Davis 18:04:23 9/20/98 (0)
      • Re: Alpha Blending w/ DX5.0 - Owen Davis 18:03:28 9/20/98 (0)
  • direct x fatal error - john 22:03:08 9/13/98 (0)
  • direct draw - PegLeg 19:06:46 9/13/98 (6)
    • Re: direct draw - Fred Fol 06:07:56 9/14/98 (4)
      • Re: Update DX6 - Pegleg 20:25:43 9/14/98 (3)
        • Re: Update DX6 - Clay 09:00:41 9/16/98 (2)
          • Re: Thanks Clay - Pegleg 20:25:11 9/19/98 (0)
          • Re: Update DX6 - gfdgdfg 10:21:40 9/18/98 (0)
    • My program runs fine on my old PC but not my new one - Pegleg 19:12:21 9/13/98 (0)
  • Rotation - Snowman 17:57:22 9/13/98 (0)
  • I can't get DirectX to work! - Neil 13:48:39 9/13/98 (1)
    • Re: I can't get DirectX to work! - Clay 12:07:32 9/14/98 (0)
  • i need help - Jason Wilkens 02:38:02 9/13/98 (1)
    • Re: i need help - Shannon 03:48:10 9/13/98 (0)
  • new programming web page - Hexman 01:23:43 9/13/98 (0)
  • Linking Error - X Newbie 23:25:10 9/12/98 (2)
    • Re: Linking Error - Snowman 16:27:56 9/13/98 (1)
      • Re: Linking Error - X Newbie 19:27:31 9/13/98 (0)
  • Help! - Angeon 14:39:39 9/12/98 (1)
    • Re: Help! - Snowman 16:23:13 9/12/98 (0)
  • What's a .X file and How create? - Younger 13:23:03 9/10/98 (4)
    • Re: What's a .X file and How create? - zipht 23:08:26 9/14/98 (0)
    • Re: What's a .X file and How create? - Takahiko Watanabe 17:04:45 9/12/98 (0)
    • Re: What's a .X file and How create? - Younger 13:27:59 9/10/98 (1)
      • Re: What's a .X file and How create? - Lennard Feddersen 19:31:20 9/21/98 (0)
  • Disabling taskbar in directdraw - Fred Fol 08:18:25 9/10/98 (0)
  • DirectX 6 and Diamond Monster 3d II - Karl Fisher 21:59:11 9/09/98 (2)
    • Re: DirectX 6 and Diamond Monster 3d II - Clay 11:25:08 9/10/98 (1)
      • Re: DirectX 6 and Diamond Monster 3d II THANKS CLAY - Karl Fisher 15:17:48 9/10/98 (0)
  • HeLp - Eugene V. 16:19:27 9/08/98 (1)
    • Yeah, right - Myopic Rhino 11:12:10 9/09/98 (0)
  • Loading Bitmaps from the samples included with DX5SDK - Chris Clements 12:40:38 9/08/98 (1)
    • Re: Loading Bitmaps from the samples included with DX5SDK - Ravi Joshi 00:48:09 9/14/98 (0)
  • Loading Bitmaps from the samples included with DX5SDK - Chris Clements 12:39:06 9/08/98 (0)
  • problems with games $%§"&%/( - Gilly 08:12:02 9/08/98 (0)
  • Getting sound for Nascar Racing Game - Jeannie 09:52:01 9/07/98 (1)
    • Re: Getting sound for Nascar Racing Game - Shannon 22:15:36 9/07/98 (0)
  • Hi Can I Complain Some More? - Qwertie 23:14:21 9/06/98 (0)
  • Learning DirectX - Qwertie 22:23:15 9/06/98 (0)
  • errr message when compiling - Agent X 20:38:31 9/06/98 (1)
    • Re: errr message when compiling - Clay 08:50:23 9/07/98 (0)
  • GetNamedObject and RM3 - Pablo de Heras 11:39:01 9/06/98 (2)
    • Re: GetNamedObject and RM3 - Fred 12:01:27 9/07/98 (0)
    • email adress corrected - Pablo de Heras 11:42:03 9/06/98 (0)
  • 3ds max for VC++ - difabs 20:52:11 9/04/98 (1)
    • Re: 3ds max for VC++ - tim 10:31:24 9/08/98 (0)
  • Getting Started - AKBishop 16:25:20 9/04/98 (3)
    • Re: Getting Started - Myopic Rhino 18:18:50 9/04/98 (1)
      • DirectX 6.0 - Myopic Rhino 18:24:24 9/04/98 (0)
    • Re: Getting Started - Book Advice - That Guy 18:06:01 9/04/98 (0)
  • Got milk? - Schitz 02:56:59 9/04/98 (0)
  • Blitting sprites - That Guy 22:41:54 9/03/98 (0)
  • Direct X 6 Book coming out soon? - Dwight Yachuk 10:04:54 9/03/98 (1)
    • Re: Direct X 6 Book coming out soon? - Myopic Rhino 15:29:46 9/04/98 (0)
  • THIS IS URGENT PLEASE READ !!!!! - .oOGrimm ReaperOo. 10:01:46 9/03/98 (0)
  • Having a problem whne trying to link SDK example. unresolvable external symbol... - Direct X Newbie... 08:54:02 9/03/98 (2)
    • Re: Having a problem whne trying to link SDK example. unresolvable external symbol... - champi 11:17:41 9/03/98 (0)
    • Re: Having a problem whne trying to link SDK example. unresolvable external symbol... - Dark Blade 11:09:29 9/03/98 (0)
  • Why does d3drm alpha blending look so awful? - Boller 21:34:57 9/02/98 (0)
  • Its possible scale and rotate a sprite with blt? how? - champi 15:23:35 9/02/98 (1)
    • It's not possible - Myopic Rhino 12:16:11 9/04/98 (0)
  • DirectX+Assembler? - Spikes 16:40:04 9/01/98 (1)
    • Re: DirectX+Assembler? - Dave Burrows 04:25:53 9/02/98 (0)
  • Im working on final fight type game and i need help - champi 15:38:14 9/01/98 (2)
    • Re: Im working on final fight type game and i need help - Tim Wright(MainFrame) 00:00:24 9/06/98 (0)
    • Re: Im working on final fight type game and i need help - Agent X 04:11:40 9/03/98 (0)
  • DirectX beginner... - Ed Fear 07:17:06 9/01/98 (3)
    • Re: DirectX beginner... - That Guy 22:46:54 9/03/98 (1)
      • Re: DirectX beginner... WGPDummies - Ed Fear 04:37:03 9/04/98 (0)
    • Re: DirectX beginner... - champi 15:23:27 9/01/98 (0)
  • DirectPlay Lobby Client Help - Gary Mace 10:41:03 8/31/98 (0)
  • HELP!! - Nick 13:57:22 8/30/98 (1)
    • Re: HELP!! - Clay 07:30:14 8/31/98 (0)
  • Problem with DirectDraw setup - Red 06:28:46 8/30/98 (0)
  • Viewing files in Direct X object files - Luey 03:24:21 8/30/98 (0)
  • I NEED HELP WITH DIRECT3D IMMEDIATE MODE, IT'S URGENT!!!!!!!!!!!!! - Kovax 14:40:11 8/29/98 (0)
  • Is it possible to get sound data directly from mic using DirectSound ? - Wing Ho Leung 22:52:53 8/28/98 (1)
    • Re: Is it possible to get sound data directly from mic using DirectSound ? - William Gate 02:13:17 8/29/98 (0)
  • Meshbuilder - Travis 20:07:03 8/28/98 (1)
    • Re: Meshbuilder - Clay 09:27:11 8/30/98 (0)
  • Does anyone If DirectX6 will work on Borland v4.5? - Narshe 14:13:37 8/28/98 (1)
    • Re: Does anyone If DirectX6 will work on Borland v4.5? - MainFrame 00:53:22 9/06/98 (0)
  • Direct X and Watcom - Chuck Wardlaw 18:50:57 8/27/98 (0)
  • lpVtbl is not a member of 'IDirect3DRM'?!?!?!?!?!?!?! - Jonathan 18:12:00 8/27/98 (1)
    • Re: lpVtbl is not a member of 'IDirect3DRM'?!?!?!?!?!?!?! - Jeremy 00:29:50 8/28/98 (0)
  • Custom made blt problem... please help - Martin 14:46:22 8/27/98 (2)
    • Re: Custom made blt problem... please help - Clay 16:46:50 8/27/98 (1)
      • Re: Custom made blt problem... please help - Martin 07:28:44 8/28/98 (0)
  • DirectShow - Reverse Play? - Kjell 13:38:40 8/26/98 (0)
  • No direct X setup.( DSETUP.DLL) - Clifton Peirce 13:38:25 8/26/98 (0)
  • AWE32 and direct-x 5 don't work together ?? - Kristel 15:29:31 8/25/98 (1)
    • Re: AWE32 and direct-x 5 don't work together ?? - Gilly 07:47:09 9/08/98 (0)
  • 24bit rendering in D3DRM - Pablo de Herad 15:16:29 8/25/98 (0)
  • To Anybody who knows JAVA.. ?! - SDK Novice 15:01:08 8/25/98 (3)
    • This had nothing to do with Java but hey who cares... - William Gate 02:22:34 8/29/98 (1)
      • Re: This had nothing to do with Java but hey who cares... - Pablo de Heras 12:58:25 8/29/98 (0)
    • Re: To Anybody who knows JAVA.. ?! - Pablo de Heras 15:23:31 8/25/98 (0)
  • Z Buffering problem (simmilar to earlier sz/rhw prob.) - Matthew Cloy 11:27:26 8/25/98 (0)
  • How do I rotate a bitmap with Blt? - Jay Bee 07:11:40 8/25/98 (4)
    • Re: How do I rotate a bitmap with Blt? - Jonas Eriksson 06:42:22 8/26/98 (2)
      • Re: How do I rotate a bitmap with Blt? - Jay Bee 11:13:10 8/26/98 (1)
        • Re: How do I rotate a bitmap with Blt? - Clay 06:36:43 8/27/98 (0)
    • Re: How do I rotate a bitmap with Blt? - Jeremy 03:43:14 8/26/98 (0)
  • Anyone could help me to resolve a problem With D3D immediate mode,please? - Kovax 09:00:26 8/24/98 (2)
    • Re: Anyone could help me to resolve a problem With D3D immediate mode,please? - Nat 17:53:41 8/25/98 (1)
      • Re: Anyone could help me to resolve a problem With D3D immediate mode,please? - Kovax 19:32:59 8/25/98 (0)
  • DirectX/Quicktime 3 - Greg Smith 18:14:08 8/23/98 (0)
  • D3DRM and multipass texturing - Pablo de Heras 10:30:39 8/23/98 (2)
    • Re: D3DRM and multipass texturing - fred 11:13:35 8/23/98 (1)
      • Re: D3DRM and multipass texturing - Pablo de Heras 15:29:41 8/23/98 (0)
  • DirectX 6 texture handles - jnz 14:53:15 8/21/98 (2)
    • Re: DirectX 6 texture handles - Clay 06:38:47 8/27/98 (1)
      • oops - Clay 06:39:52 8/27/98 (0)
  • DX6 graphics chat transcript: Copies of animationsets - Pablo de Heras 12:44:34 8/21/98 (1)
    • Re: DX6 graphics chat transcript: Copies of animationsets - fred 10:17:02 8/22/98 (0)
  • C++/DirectX Programmierer gesucht - Glamus GmbH Ulrich Santo 04:03:03 8/21/98 (0)
  • What does this error messga mean? - Jones 03:29:53 8/21/98 (1)
    • Re: What does this error messga mean? - Snowman 20:55:46 8/22/98 (0)
  • vbasic 6.0 and directx support - peter harrison 11:28:15 8/20/98 (0)
  • CreateDevice doesn't work with Voodoo2??? - Dark Blade 11:15:18 8/20/98 (1)
    • Re: CreateDevice doesn't work with Voodoo2??? - Clay 07:05:34 8/21/98 (0)
  • Palettes and Lost surfaces - Mike Lindegarde 19:27:01 8/19/98 (0)
  • DirectSound won't work in a DLL -- NT problem - Lance Durham 11:30:01 8/19/98 (0)
  • BltFast - Bardya 10:37:17 8/19/98 (1)
    • Re: BltFast - Jonas 21:06:26 8/19/98 (0)
  • I can't get colorkeying working with texturing ! - Stéphane Pouyet 10:01:37 8/19/98 (0)
  • A ready to compile sample ... please - Guillaume APOSTOLY 03:36:43 8/18/98 (3)
    • Re: A ready to compile sample ... please - EvAcLeAr 22:48:55 8/18/98 (2)
      • Re: A ready to compile sample ... please - Snowman 17:00:44 8/20/98 (1)
        • Re: A ready to compile sample ... please - EvAcLeAr 03:30:56 8/21/98 (0)
  • DirectX 5.0 - Luke 21:32:35 8/15/98 (2)
    • Re: DirectX 5.0 - Martin 14:09:22 9/27/98 (1)
      • Re: DirectX 5.0 - Greg 04:07:41 9/28/98 (0)
  • Small Problem With Direct Draw Surfaces... - Laikos 16:32:40 8/15/98 (0)
  • voodoo2 and fill rate - Clay 09:36:05 8/15/98 (0)
  • DIRECTX.CPL : file is missing - Gary 19:51:52 8/14/98 (2)
    • Re: DIRECTX.CPL : file is missing - ding@ 09:48:43 8/15/98 (1)
      • Re: DIRECTX 5.0 : file is missing - KENT COUSINS 15:25:53 8/17/98 (0)
  • DX6 RM. Where are the docs? - Pablo de Heras 12:36:30 8/14/98 (1)
    • Re: DX6 RM. Where are the docs? - ding@ 09:44:14 8/15/98 (0)
  • How to properly minimize a full screen directX app? - Karsten Wilson 11:47:40 8/14/98 (1)
    • Re: How to properly minimize a full screen directX app? - BoxMan 16:34:30 8/19/98 (0)
  • I'VE MODIFIED AN EXISTING CLASS TO MAKE TEXTURE, BUT THAT DON'T WORK????????????? - kovax 09:09:43 8/14/98 (1)
    • Re: I'VE MODIFIED AN EXISTING CLASS TO MAKE TEXTURE, BUT THAT DON'T WORK????????????? - Fragmo 22:01:25 8/14/98 (0)
  • How to programm a DirectShow Application in Visual C++ ? - Jochen 23:17:39 8/13/98 (1)
    • Re: How to programm a DirectShow Application in Visual C++ ? - John Giors 15:03:38 8/17/98 (0)
  • DOES ANYBODY NOW HOW TO FIX MY DIRECT SOURCE MEDIA??? NT - Tex Murphy 20:52:42 8/13/98 (1)
    • Re: DOES ANYBODY NOW HOW TO FIX MY DIRECT SOURCE MEDIA??? NT - ding@ 09:42:30 8/15/98 (0)
  • Problems with Direct3dRM in direct X 6 - Travis 16:55:45 8/13/98 (0)
  • Error Handling in DirectDraw - Berk 16:27:07 8/13/98 (1)
    • Re: Error Handling in DirectDraw - Ludovic Tirtiaux 09:51:26 8/18/98 (0)
  • DDSurface Locking? - Nick Weihs 14:34:45 8/13/98 (2)
    • Re: DDSurface Locking? - Ravi Joshi 12:00:09 8/14/98 (0)
    • Re: DDSurface Locking? - Fragmo 15:56:19 8/13/98 (0)
  • Getting DirectSoundBuffer Notification Interface - Gilles Pommereuil 13:57:41 8/13/98 (1)
    • Re: Getting DirectSoundBuffer Notification Interface - Denny Bromley 14:51:52 9/02/98 (0)
  • international versions of the DirectShow runtime - Gregg Plummer 10:27:40 8/13/98 (0)
  • I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? - Tex Murphy 01:07:17 8/13/98 (4)
    • Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? - Walla Walla 22:58:43 8/18/98 (0)
    • Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? - Ha ha, a dead meat 06:44:17 8/13/98 (2)
      • Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? - Tex Murphy 13:08:44 8/13/98 (1)
        • Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? - Ha ha ha, what a dumb ass 09:40:57 8/15/98 (0)
  • DirectDraw 5 Problem! Please Help - As Evil As They Come 19:42:26 8/12/98 (0)
  • Format of BMP files - Pet Monster 18:33:12 8/12/98 (1)
    • Re: Format of BMP files - Fragmo 03:39:49 8/13/98 (0)
  • How can i use d3d primary surface in retained mode - Flipper 04:09:05 8/12/98 (0)
  • Unresolved external symbol - Luey 19:42:07 8/10/98 (2)
    • Re: Unresolved external symbol - Jeremy 21:44:24 8/10/98 (1)
      • Sorry, goofed - Jeremy 21:47:24 8/10/98 (0)
  • Rotating bitmaps using DirectX6 - Jeremy 15:50:35 8/10/98 (0)
  • Need help with a 3dsmax to DX converter for meshes - Leathrewulfe 13:53:44 8/10/98 (0)
  • Direct3D 6.0 IM Framework tutorial - Wolfgang Engel 04:25:35 8/10/98 (0)
  • I NEED HELP ON DDRAW and D3D, PLEASE!! - Kovax 18:20:35 8/09/98 (0)
  • I NEED HELP ON DDRAW and D3D, PLEASE!! - Kovax 18:19:56 8/09/98 (0)
  • Turning left, right, etc - Seve Bryndin 15:16:02 8/09/98 (0)
  • Help Iam not so good as you are!! Evrything is fucked like earth.. - ExTaZ 13:18:09 8/09/98 (0)
  • Help Please Direct 3D - Karl Fisher 15:32:04 8/07/98 (8)
    • Re: Help Please Direct 3D - Dave Burrows 05:37:11 8/10/98 (0)
    • Re: Help Please Direct 3D - Fragmo 17:27:26 8/07/98 (6)
      • Re: Help Please Direct 3D - Karl Fisher 09:06:11 8/08/98 (5)
        • Re: Help Please Direct 3D - Fragmo 16:53:46 8/08/98 (4)
          • Re: Help Please Direct 3D - Shai'tan [ Nth ] 16:57:19 8/09/98 (3)
            • Re: Help Please Direct 3D - Fragmo 20:30:48 8/09/98 (2)
              • correct me if I'm wrong... - Clay 08:04:41 8/11/98 (1)
                • Re: correct me if I'm wrong... - Fragmo 21:07:57 8/11/98 (0)
  • Direct Play Lobby Server - Michael Dauria 14:19:46 8/07/98 (0)
  • Where is "DirectMusic Producer" - Kentamanos 17:19:31 8/06/98 (1)
    • Re: Where is "DirectMusic Producer" - Kentamanos 21:06:14 8/06/98 (0)
  • This board is waaaaaaay to long. - 0x1CE 15:33:38 8/06/98 (0)
  • Special effects, help meeee :- ( !!!!!!!! - Pauline 11:49:48 8/06/98 (1)
    • Re: Special effects, help meeee :- ( !!!!!!!! - Snowman 13:14:22 8/06/98 (0)
  • About the ftp site... - Snowman 15:45:41 8/05/98 (0)
  • Q: How Can I read DirectX6.0 Help File??? - Soph 04:59:42 8/05/98 (1)
    • Re: Q: How Can I read DirectX6.0 Help File??? - John Giors 16:26:48 8/05/98 (0)
  • Does Anyone HERE HAVE A IBM MWAVE AUDIO FOR YOUR AUDIO DRIVER? IF SO, PLEASE HELP!!!!! - dIRECTxSuCKEr 22:25:54 8/04/98 (0)
  • Need Advice....Newto Windows programming - Fritz 19:56:27 8/04/98 (0)
  • |=-Not about DirectX-=| - Clay 13:29:40 8/04/98 (4)
    • Bad Language and Filtering. - Ravi Joshi 01:50:37 8/05/98 (2)
      • ftp site - Clay 14:56:16 8/05/98 (1)
        • Re: ftp site - why only direct-acces on warezpagez to DirectX 6.0 22:25:57 8/08/98 (0)
    • Re: |=-Not about DirectX-=| - Snowman 21:50:26 8/04/98 (0)
  • OH COME ON GUYS, HELP ME WITH MY DIRECTDRAW PROBLEM!!!!!!!!!!!!!!!!!! IT SHOULD BE VERY SIMPLE FOR YOU eXPERTS OUT THERE!!!!!! - DirectX-=NeWbIe=- 12:23:40 8/04/98 (2)
    • Re: OH COME ON GUYS, HELP ME WITH MY DIRECTDRAW PROBLEM!!!!!!!!!!!!!!!!!! IT SHOULD BE VERY SIMPLE FOR YOU eXPERTS OUT THERE!!!!!! - Walla Walla 23:03:02 8/18/98 (0)
    • Re: OH COME ON GUYS, HELP ME WITH MY DIRECTDRAW PROBLEM!!!!!!!!!!!!!!!!!! IT SHOULD BE VERY SIMPLE FOR YOU eXPERTS OUT THERE!!!!!! - Snowman 14:07:11 8/04/98 (0)
  • direct 3d header - udi 07:33:37 8/04/98 (0)
  • DirectX 6 totally screwed my Monster 3dII accelerator card - Monster 3d II owner 22:43:37 8/03/98 (5)
    • Re: DirectX 6 totally screwed my Monster 3dII accelerator card - ding@ 00:56:18 8/04/98 (4)
      • Re: DirectX 6 totally screwed my Monster 3dII accelerator card - Monster 3d II owner 02:13:54 8/04/98 (3)
        • Re: DirectX 6 totally screwed my Monster 3dII accelerator card - ding@ 06:46:50 8/04/98 (2)
          • I tried all that stuff :( - Monster 3d II owner 07:35:52 8/04/98 (1)
            • Re: I tried all that stuff :( - Matthew Wright 04:11:28 9/06/98 (0)
  • I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* - Tex Murphy 19:54:59 8/03/98 (8)
    • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* - Clay 20:33:08 8/03/98 (7)
      • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* - Dave Burrows 04:17:27 8/04/98 (0)
      • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* - Tex Murphy 21:23:19 8/03/98 (5)
        • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* - ding@ 01:01:47 8/04/98 (4)
          • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* - Tex Murphy 13:22:59 8/04/98 (3)
            • advice for newbie - owlsley 00:06:12 8/07/98 (2)
              • Re: advice for newbie - Tex Murphy 12:09:06 8/07/98 (1)
                • Re: advice for newbie - satan 15:22:41 8/10/98 (0)
  • Error loading DirectDraw... PLEASE HELP!! :) - DirectX-=nEwBiE=- 12:45:57 8/03/98 (1)
    • Re: Error loading DirectDraw... PLEASE HELP!! :) - Sompong Rattanasang 07:48:48 8/31/98 (0)
  • How to use colorkey between Overlay surface and Primary surface? - Bond Chen 06:21:32 8/03/98 (0)
  • Call for online editors - Wolfgang Engel 05:53:43 8/03/98 (0)
  • BIG FUCKING DIRECTX 5.2 PROBLEM - Donald Ames 13:58:04 8/02/98 (0)
  • How to loop samples from an offset - Qinglai 12:01:59 8/02/98 (1)
    • Re: How to loop samples from an offset - Jonas 21:38:21 8/03/98 (0)
  • PLEASE HELP ME!!!!!!!!!! - Tex Murphy 01:33:32 8/02/98 (0)
  • Help Me Now Please - Tyler Smith 21:13:23 8/01/98 (1)
    • Re: Help Me Now Please - Tobias Minich 22:10:47 8/01/98 (0)
  • IM vs RM - Snowman 18:55:08 8/01/98 (0)
  • Newbie needs DirectDraw help - Jeremy 01:31:12 7/31/98 (1)
    • Re: Newbie needs DirectDraw help - Clay 20:26:31 8/03/98 (0)
  • 2D Tile Game Source Code - Johnny Rotten 01:25:52 7/31/98 (1)
    • Source Code Page back up!! - Johnny 15:44:45 8/05/98 (0)
  • DirectX6 FINAL RELEASE! - A DX6 beta tester 00:30:54 7/31/98 (17)
    • DirectX6 FINAL RELEASE! - ttt 17:38:47 9/24/98 (0)
    • Re: DirectX6 FINAL RELEASE! - michael d. henning 22:11:16 9/22/98 (0)
    • Re: DirectX6 FINAL RELEASE! - dxptt 01:00:14 8/28/98 (2)
      • Re: DirectX6 FINAL RELEASE! - t.sato 09:25:18 8/28/98 (1)
        • Re: DirectX6 FINAL RELEASE! - vincenzo 07:08:37 9/08/98 (0)
    • Re: DirectX6 FINAL RELEASE! - Pujanias 12:04:17 8/27/98 (0)
    • Re: DirectX6 FINAL RELEASE! - mikael 11:12:52 8/09/98 (10)
      • Re: DirectX6 FINAL RELEASE! - Rick Larew 15:16:59 9/30/98 (0)
      • Re: DirectX6 FINAL RELEASE! - rtr 17:36:31 9/24/98 (0)
      • Re: DirectX6 FINAL RELEASE! - Vladimir Mitev 16:29:20 9/02/98 (2)
        • Re: DirectX6 FINAL RELEASE! - David Mendes 15:40:18 9/28/98 (0)
        • Re: DirectX6 FINAL RELEASE! - Niki 17:55:01 9/03/98 (0)
      • Re: DirectX6 FINAL RELEASE! - JOHN 21:03:11 9/01/98 (1)
        • Re: DirectX6 FINAL RELEASE! - john reece 22:56:55 9/01/98 (0)
      • Re: DirectX6 FINAL RELEASE! - STAS MIDURA 14:20:46 9/01/98 (0)
      • Re: DirectX6 FINAL RELEASE! - Steve Borman 06:34:57 8/29/98 (1)
        • Re: DirectX6 FINAL RELEASE! - Roxanne Bryant 14:56:03 8/30/98 (0)
  • DirectShow Destroys Window - Ken Moore 18:04:43 7/30/98 (0)
  • 3D Objects - Emil Diego 16:18:05 7/30/98 (1)
    • Re: 3D Objects - mikael 11:14:35 8/09/98 (0)
  • HELP! DirectShow lousy from CD-ROM! - John Giors 15:01:32 7/30/98 (0)
  • Question about Visual C++ and DirectX - Bob 11:08:32 7/30/98 (6)
    • Re: Question - I may have the solution - Travis 14:37:09 9/07/98 (0)
    • Re: Question about Visual C++ and DirectX - Dave Burrows 04:14:52 8/03/98 (0)
    • Re: Question about Visual C++ and DirectX - Rob 21:10:41 7/31/98 (0)
    • Re: Question about Visual C++ and DirectX - David Naughton 14:50:24 7/31/98 (0)
    • Re: Question about Visual C++ and DirectX - Nat 16:32:46 7/30/98 (1)
      • Re: Question about Visual C++ and DirectX - bob 10:22:30 8/05/98 (0)
  • I am the biggest debutant you have ever seen - Joachim Sene 05:28:33 7/30/98 (0)
  • How do I create DD surfaces out of array buffer? - HeXeR 17:52:05 7/29/98 (0)
  • off topic - anyone tried gamepc.com - John 17:29:10 7/29/98 (0)
  • Sharing Code - Clay 07:59:30 7/29/98 (2)
    • Sharing Code and knowledge - Ravi Joshi 02:17:44 7/30/98 (0)
    • Re: Sharing Code - Snowman 15:06:25 7/29/98 (0)
  • How does one write text on the screen in a windowed application with directdraw and direct3d initialised? - Jumicor 01:36:33 7/29/98 (2)
    • Re: How does one write text on the screen in a windowed application with directdraw and direct3d initialised? - Jumicor 10:43:44 7/29/98 (1)
      • Oooops... The previous post is from Johnny, not Jumicor! - Johnny 10:45:58 7/29/98 (0)
  • Offscreen Plain Surfaces: Is it fast? Or is is dumb? - HeXeR 00:29:45 7/29/98 (1)
    • Re: Offscreen Plain Surfaces: Is it fast? Or is is dumb? - Clay 07:49:52 7/29/98 (0)
  • Hello...Clay....Are you there... - Snowman 21:30:39 7/28/98 (2)
    • Re: Hello...Clay....Are you there... - Jumicor 01:23:05 7/29/98 (1)
      • Re: Hello...Clay....Are you there... - Snowman 14:55:26 7/29/98 (0)
  • Hey Jumicor! - Snowman 21:07:51 7/28/98 (2)
    • Re: Hey Jumicor! - Jumicor 01:42:15 7/29/98 (1)
      • Re: Hey Jumicor! - Snowman 14:19:46 7/29/98 (0)
  • Intro to DirectX 5.0 - Defender 20:33:00 7/28/98 (0)
  • Transparent Bitmaps in 16, 24 or 32bit colour - Ragman 15:33:33 7/28/98 (1)
    • You specify the color yourself, in any color Depth. - HeXeR 00:48:07 7/29/98 (0)
  • Where is DirectX5.0 That will not conflict with Diamond video card - Stoney Cook 12:09:22 7/28/98 (0)
  • Direct Animation - SANDAL 07:43:14 7/28/98 (1)
    • Re: Direct Animation - mikael 11:16:48 8/09/98 (0)
  • Please help with D3D HAL Device - Snowman 21:14:25 7/27/98 (0)
  • Help with 2D scrolling - Jason Rego 20:21:21 7/27/98 (3)
    • Source code on the way! - Johnny Rotten 10:54:42 7/29/98 (0)
    • Re: Help with 2D scrolling - Johnny Rotten 10:19:14 7/28/98 (0)
    • Re: Help with 2D scrolling - Clay 10:02:12 7/28/98 (0)
  • Newbie with a problem with DCs - Eas-man 16:16:56 7/27/98 (2)
    • Re: Newbie with a problem with DCs - Dave Burrows 04:52:28 7/28/98 (1)
      • Re: Newbie with a problem with DCs - Eas-man 19:56:13 7/28/98 (0)
  • HELP! PALETTES! - Anton 14:46:51 7/27/98 (1)
    • Re: HELP! PALETTES! - Nathanael Weiss 18:00:48 8/25/98 (0)
  • Not a DirectX question! Basic C help - Johnny Rotten 11:26:39 7/27/98 (4)
    • Re: Not a DirectX question! Basic C help - Dave Burrows 04:49:47 7/28/98 (0)
    • Re: Not a DirectX question! Basic C help - Jumicor 23:58:26 7/27/98 (1)
      • Setting array to 0 during main loop - Johnny Rotten 10:41:55 7/28/98 (0)
    • Re: Not a DirectX question! Basic C help - Bardya 11:33:53 7/27/98 (0)
  • Need help to dynamically Create Sprites - Jason Millard 09:53:54 7/27/98 (0)
  • Lost Surface and failing restore command! Help Needed! Thx - bardya 09:39:23 7/27/98 (1)
    • Re: Lost Surface and failing restore command! Help Needed! Thx - Dave Burrows 04:44:10 7/28/98 (0)
  • Problems with Watcomc++ and directx 5.0 - Hölmut 08:35:24 7/27/98 (0)
  • ALIENS HAVE LANDED ON THE MOON AND ARE PLOTTING THEIR ATTACK AGAINST EARTH!! - Jumicor 00:57:46 7/27/98 (0)
  • CAN ANYONE DIRECT ME TO DIRECTPLAY INFO? - Fragmo 02:12:56 7/26/98 (0)
  • Snowman: - Jumicor 00:21:09 7/26/98 (6)
    • Re: Snowman: - Snowman 20:47:56 7/26/98 (5)
      • Re: Snowman: - Jumicor 00:51:50 7/27/98 (4)
        • Re: Snowman: - Snowman 13:58:42 7/27/98 (2)
          • Re: Snowman: - Jumicor 14:07:50 7/27/98 (1)
            • Re: Snowman: - Snowman 20:09:13 7/27/98 (0)
        • Oops - Clay 07:20:32 7/27/98 (0)
  • I need Urgent Help with DirectX and Windows 98- Please Read - Craig Edelstein 18:46:24 7/25/98 (3)
    • Re: I need Urgent Help with DirectX and Windows 98- Please Read - fred 01:43:26 7/26/98 (2)
      • Re: I need Urgent Help with DirectX and Windows 98- Please Read - Craig Edelstein 14:53:37 7/26/98 (1)
        • Re: I need Urgent Help with DirectX and Windows 98- Please Read - fred 10:41:18 7/29/98 (0)
  • Selecting video card - Jumicor 11:46:09 7/25/98 (0)
  • How do you use fog? - Snowman 19:19:08 7/24/98 (0)
  • To: Clay - Snowman 19:13:48 7/24/98 (0)
  • Direct 3D hardware question! - Jumicor 17:26:58 7/24/98 (1)
    • Re: Direct 3D hardware question! - Mman1118 23:18:23 8/27/98 (0)
  • Direct3D, DirectDraw and Win98 shutdown - Karl Fisher 13:42:35 7/24/98 (0)
  • Q: How make 3D game tool? - Chang 12:59:59 7/24/98 (0)
  • Releasing Back Buff and COM part of DirectX - Ravi Joshi 02:40:22 7/24/98 (1)
    • Re: Releasing Back Buff and COM part of DirectX - Clay 08:29:18 7/24/98 (0)
  • DirectSound... ALT-TAB... other apps say "Another app is using audio" - Nathanael Weiss 02:02:42 7/24/98 (0)
  • I need help wrapping a texture properly to a box. PLEASE HELP!! - Jumicor 23:03:55 7/23/98 (0)
  • gamming DIRECTX - Zack 21:00:37 7/23/98 (2)
    • Re: gaming DIRECTX - Jumicor 22:59:13 7/23/98 (1)
      • Re: gaming DIRECTX - Snowman 14:30:34 7/24/98 (0)
  • DIRECT INPUT PROBLEM! - Martin K. 13:24:30 7/23/98 (3)
    • Re: DIRECT INPUT PROBLEM! - 0x1CE 14:59:48 7/23/98 (2)
      • Re: DIRECT INPUT PROBLEM! - Martin K. 13:43:03 7/24/98 (1)
        • Re: DIRECT INPUT PROBLEM! - 0x1CE 14:14:51 7/24/98 (0)
  • Colors System, Palettes in VGA RAM?? - Gunnar 09:41:54 7/23/98 (0)
  • directdrawsurface2, 3, what is the difference? - michaelb 15:55:52 7/22/98 (0)
  • 16 bit alpha-blit here - michaelb 14:46:46 7/22/98 (3)
    • This is it, honest! - Michael Black 14:56:31 7/22/98 (0)
    • 3'rd times a charm - Michael Black 14:55:13 7/22/98 (0)
    • Well, that didn't work! TRY HERE. - Michael Black 14:53:55 7/22/98 (0)
  • Q: How do I render with D3D and ramp mode - Joe Chang 14:10:26 7/22/98 (2)
    • Re: Q: How do I render with D3D and ramp mode - Steve Dykes 14:58:45 7/23/98 (1)
      • Re: Q: How do I render with D3D and ramp mode - Steve Dykes 15:01:18 7/23/98 (0)
  • ListServer at New Direct3D site is up and running - Wolfgang Engel 06:59:41 7/22/98 (0)
  • Why aren't you all rich software developers? - Jumicor 01:19:20 7/22/98 (1)
    • Re: Why aren't you all rich software developers? - Clay 07:44:57 7/22/98 (0)
  • A Little AI question: How to predict the next position? - Jones 22:41:35 7/21/98 (3)
    • Re: A Little AI question: How to predict the next position? - Clay 10:55:33 7/22/98 (2)
      • Re:Re: A Little AI question: How to predict the next position? - Jones 01:08:27 7/23/98 (1)
        • Re:Re: A Little AI question: How to predict the next position? - Clay 13:29:31 7/23/98 (0)
  • Putting Labels on 3d Objects? - LT 12:42:06 7/21/98 (0)
  • 3DFX DDER_OUTOFVIDEOMEMORY - HELP! - Marc Palma 12:31:38 7/21/98 (5)
    • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! - Clay 13:41:54 7/21/98 (4)
      • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! - Marc Palma 15:30:08 7/21/98 (3)
        • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! - Clay 18:21:26 7/21/98 (2)
          • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! - Marc Palma 22:04:52 7/21/98 (1)
            • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! - Clay 07:50:35 7/22/98 (0)
  • Is there a DirectX course i can take? - Chris Crane 10:45:45 7/21/98 (1)
    • Re: Is there a DirectX course i can take? - Jumicor 23:06:46 7/23/98 (0)
  • Helpp !!! Directx 6 with win98 Problems.... - Roal Jhonson 10:03:54 7/21/98 (4)
    • Re: Helpp !!! Directx 6 with win98 Problems.... - laporte 14:05:26 8/26/98 (0)
    • Re: Helpp !!! Directx 6 with win98 Problems.... - ding@ 10:25:22 7/21/98 (2)
      • Re: Helpp !!! Directx 6 with win98 Problems.... - Juan Luis Aguilar Alamo 19:46:16 9/04/98 (0)
      • Re: Helpp !!! Directx 6 with win98 Problems.... - Roal Jhonson 10:30:50 7/21/98 (0)
  • Directx 6 - Weising 22:17:27 7/20/98 (3)
    • Re: Directx 6 - Shamsul A. Khan. 21:48:13 9/25/98 (0)
    • Re: Directx 6 - Doug 22:31:51 7/20/98 (1)
      • Re: Directx 6 - choris 13:15:09 7/21/98 (0)
  • Difference between dynamic and static linking- Save me some money please! - Jumicor 22:15:22 7/20/98 (3)
    • Re: Difference between dynamic and static linking- Save me some money please! - 0x1CE 23:13:54 7/20/98 (2)
      • Thanks! and I'm still curious - Jumicor 01:23:28 7/21/98 (1)
        • Re: Thanks! and I'm still curious - 0x1CE 02:19:43 7/21/98 (0)
  • HELP!!! I REALLY NEED SOME HELP!!! AND FAST!! - Randy 19:53:31 7/20/98 (2)
    • Re: HELP!!! I REALLY NEED SOME HELP!!! AND FAST!! - Jumicor 22:06:58 7/20/98 (1)
      • Re: DirectX 5.2 - Doug 22:23:20 7/20/98 (0)
  • HELP!!! I REALLY NEED SOME HELP!!! AND FAST!! - Randy 19:53:27 7/20/98 (1)
    • Re: HELP!!! I REALLY NEED SOME HELP!!! AND FAST!! - Dave Burrows 04:39:56 7/21/98 (0)
  • Implementing Directx(DirectDraw) into a MFC - Sphire 13:28:12 7/20/98 (3)
    • Re: Implementing Directx(DirectDraw) into a MFC - Mr. Mike 03:16:19 9/01/98 (0)
    • I'm a newbie too - but I know the perfect resource for you - Jumicor 22:21:23 7/20/98 (1)
      • Re: I'm a newbie too - but I know the perfect resource for you - Sphire 00:18:01 7/21/98 (0)
  • IDirect3DRMViewportArray - Eric Fournier 11:23:05 7/20/98 (0)
  • Fast Plot / fade in truecolor ? DirectX - Junior Mcmillan 06:17:35 7/20/98 (4)
    • Re: Fast Plot / fade in truecolor ? DirectX - Dave Burrows 04:36:11 7/21/98 (0)
    • Re: Fast Plot / fade in truecolor ? DirectX - FunkSlice 19:30:08 7/20/98 (2)
      • Re: Don;t read one pixel at a time?? - Gunnar 11:46:39 7/25/98 (1)
        • Re: Don;t read one pixel at a time?? - Junior McMillan 08:56:09 7/29/98 (0)
  • alternatives to downloading the sdk - Jumicor 23:16:05 7/19/98 (1)
    • Re: alternatives to downloading the sdk - 0x1CE 23:52:12 7/19/98 (0)
  • I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!! - Jumicor 12:16:38 7/19/98 (3)
    • Re: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!! - Wolfgang Engel 18:14:49 7/19/98 (2)
      • Re: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!! - Clay 18:45:26 7/19/98 (1)
        • Re: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!! - Jumicor 23:13:19 7/19/98 (0)
  • New Direct3D Site - Wolfgang Engel 03:28:33 7/18/98 (0)
  • Directsound 3D support under NT? - Ben Buckwalter 19:41:27 7/17/98 (0)
  • Modem-Question - Chris 13:13:50 7/17/98 (0)
  • D3D Texture GetDC() troubles - Steve Dykes 10:49:08 7/17/98 (1)
    • Re: D3D Texture GetDC() troubles - jason 23:34:55 9/04/98 (0)
  • Why is FlipToGDISurface() is used? - Ravi Joshi 06:42:12 7/17/98 (7)
    • Re: Why is FlipToGDISurface() is used? - Clay 08:06:53 7/17/98 (6)
      • The primary surface pointer doesn't change. - Ravi Joshi 11:13:36 7/17/98 (5)
        • Re: The primary surface pointer doesn't change. - Dave Burrows 05:37:48 7/20/98 (2)
          • Re: The primary surface pointer doesn't change. - Clay 11:20:30 7/21/98 (1)
            • The Pointers never change - Ravi Joshi 02:10:08 7/23/98 (0)
        • Re: The primary surface pointer doesn't change. - Clay 13:06:46 7/17/98 (0)
        • Re: The primary surface pointer doesn't change. - Ravi Joshi 11:18:41 7/17/98 (0)
  • Please help RE DirectDraw - Gooze 23:12:27 7/16/98 (0)
  • Can anyone help me with playing a movie? - Stan Collymore 22:27:57 7/16/98 (1)
    • Re: Can anyone help me with playing a movie? - Snowman 20:48:11 7/27/98 (0)
  • Fast keyboard access, directinput ?? - Gunnar 19:41:09 7/16/98 (0)
  • DirectX 6 - Kevin Cline 17:04:50 7/16/98 (0)
  • BITMASK CHANGED VALUE - Carlo Lentini 11:14:03 7/16/98 (1)
    • Re: BITMASK CHANGED VALUE - Fragmo 16:58:38 7/16/98 (0)
  • Where I can get the Direct Music or Direct X 6.0 ? - Mr_Pooyan 03:35:26 7/16/98 (1)
    • Re: Where I can get the Direct Music or Direct X 6.0 ? - Charles Stevens 18:53:48 7/16/98 (0)
  • Where I Can get a Tracker Player for Direct X 5.0 ? - Mr_Pooyan 03:34:29 7/16/98 (0)
  • SIMPLE simple directx - Goodlife 21:28:12 7/15/98 (0)
  • Distance between two points? - LT 10:07:15 7/15/98 (12)
    • smart optimisation, beat it if you can - Gunnar 23:06:45 7/16/98 (5)
      • this is a good one... - Clay 08:43:45 7/17/98 (4)
        • If that code doesn't look right... - Clay 08:49:20 7/17/98 (3)
          • Re: Small optimisation, more accuracy - Gunnar 11:23:57 7/17/98 (2)
            • Re: Small optimisation, more accuracy - Clay 13:13:04 7/17/98 (1)
              • Re: Pipelines, floats - Gunnar 19:24:33 7/17/98 (0)
    • Re: Distance between two points? - Dave Burrows 11:17:17 7/15/98 (1)
      • Thanks for the help! - LT 17:10:51 7/15/98 (0)
    • Re: Distance between two points? - Clay 11:16:26 7/15/98 (3)
      • Re: Distance between two points? - Clay 11:26:11 7/15/98 (2)
        • Re: Distance between two points? - Dave Burrows 12:27:25 7/15/98 (1)
          • Re: Distance between two points? - Clay 09:47:42 7/16/98 (0)
  • Capture the images Using External Camera with DirectX - Yogesh M Deshpande 02:44:17 7/15/98 (0)
  • Problem with Exclusive and Windowed - Sorrow The Prince 18:40:33 7/14/98 (3)
    • Re: Problem with Exclusive and Windowed - Shai'tan 18:53:02 7/14/98 (2)
      • Re: Problem with Exclusive and Windowed - Clay 12:06:36 7/16/98 (0)
      • Re: Problem with Exclusive and Windowed - michael 01:38:15 7/16/98 (0)
  • Multiplayer games - Johnny Rotten 10:28:19 7/14/98 (1)
    • Re: Multiplayer games - Ravi Joshi 08:38:40 7/15/98 (0)
  • Accessing second display via DirectDraw? - Nils Frielinghaus 03:14:57 7/14/98 (1)
    • Re: Accessing second display via DirectDraw? - 0x1CE 06:16:35 7/14/98 (0)
  • Wet behind the ears... - SstrangeE 01:08:03 7/14/98 (4)
    • Re: Wet behind the ears... - 0x1CE 01:31:18 7/14/98 (3)
      • Re: Alrighty, heres another question... - SstrangeE 02:18:08 7/14/98 (2)
        • Re: Alrighty, heres another question... - Dave Burrows 06:04:48 7/15/98 (0)
        • Re: Alrighty, heres another question... - 0x1CE 06:11:18 7/14/98 (0)
  • Osprey board - Benjamín Gómez Tagle 14:28:19 7/13/98 (0)
  • Using HAL with Monster3D - Zak 10:44:55 7/13/98 (3)
    • Re: Using HAL with Monster3D - Dave Burrows 11:55:16 7/13/98 (2)
      • Re: Using HAL with Monster3D - Zak 14:45:22 7/13/98 (1)
        • Re: Using HAL with Monster3D - Dave Burrows 05:52:01 7/15/98 (0)
  • D3D IM : D3DOP_TEXTURELOAD - Dave Burrows 09:35:28 7/13/98 (0)
  • MFC and DirectX... - Nick Weihs 03:35:38 7/13/98 (0)
  • IID_IDirect3DHALDevice - Zak 20:37:01 7/12/98 (2)
    • Re: IID_IDirect3DHALDevice - Dave Burrows 09:43:09 7/13/98 (0)
    • Re: IID_IDirect3DHALDevice - Fragmo 02:11:00 7/13/98 (0)
  • HELP!! Texture perspective correction - Konrad 11:32:15 7/12/98 (0)
  • need help with display driver - Zak 20:05:53 7/11/98 (2)
    • Re: need help with display driver - Konrad 11:47:58 7/12/98 (0)
    • Re: need help with display driver - Konrad 11:43:19 7/12/98 (0)
  • Please help...Newbie question about DDraw SDK samples - Newbie 19:21:59 7/11/98 (9)
    • Welcome Aboard - Ravi Joshi 02:33:57 7/13/98 (0)
    • Re: Please help...Newbie question about DDraw SDK samples - Fragmo 19:34:38 7/11/98 (7)
      • Re: Please help...Newbie question about DDraw SDK samples - newbie 19:50:05 7/11/98 (6)
        • Re: Please help...Newbie question about DDraw SDK samples - Carlos2 00:11:11 7/16/98 (0)
        • Re: Please help...Newbie question about DDraw SDK samples - Fragmo 21:53:51 7/11/98 (4)
          • Re: Please help...Newbie question about DDraw SDK samples - Shai'tan 05:36:26 7/12/98 (3)
            • Re: Please help...Newbie question about DDraw SDK samples - 0x1CE 00:39:08 7/14/98 (0)
            • Re: Please help...Newbie question about DDraw SDK samples - GettinThere 17:46:00 7/13/98 (1)
              • Re: Please help...Newbie question about DDraw SDK samples - Carlos 23:55:50 7/15/98 (0)
  • DirectX's other versions - Augusto Guedes 10:33:33 7/11/98 (0)
  • My Screen isn't centered !?!?!? - Phil 09:43:57 7/11/98 (0)
  • why doesn't it work? - JOshua Karjala 06:58:16 7/11/98 (0)
  • !!!! Z-BUFFER PROBLEM SOLVED !!!! - Shai'tan 00:16:05 7/11/98 (1)
    • Re: Shai'tan !!!! Z-BUFFER PROBLEM SOLVED !!!! - Karl Fisher 12:28:53 7/11/98 (0)
  • Is there a way to specify the length of sides of an object? - Snowman 20:12:11 7/10/98 (0)
  • RayPick - Michael Crowns 14:08:25 7/10/98 (2)
    • Re: RayPick - MAgDI 22:25:11 7/11/98 (1)
      • Re: RayPick - Michael Crowns 10:33:30 7/14/98 (0)
  • Only DDraw, not D3D. How? - Ravi Joshi 03:07:45 7/10/98 (4)
    • Re: Only DDraw, not D3D. How? - 0x1CE 17:26:08 7/10/98 (0)
    • take us back to 1980s! - Clay 10:14:34 7/10/98 (2)
      • Where do I get info on Hardware Acceleration? - Ravi Joshi 03:04:46 7/13/98 (1)
        • Re: Where do I get info on Hardware Acceleration? - 0x1CE 21:51:44 7/13/98 (0)
  • Loading DXF files in DirectX - chump 18:33:37 7/09/98 (1)
    • Re: Loading DXF files in DirectX - MAgDI 22:45:52 7/11/98 (0)
  • DrawPrimitive in RM. READ THIS!!!!! - Kevin Cline 16:18:45 7/09/98 (0)
  • What will happen? - James Martin 01:46:47 7/09/98 (3)
    • Re: You need to WAIT - Shai'tan 02:16:32 7/09/98 (2)
      • Re: You need to WAIT - Fragmo 23:45:05 7/09/98 (1)
        • Need some more info - Ravi Joshi 02:42:37 7/10/98 (0)
  • This Z-Buffer is going to KILLLL me! - Shai'tan 00:47:46 7/09/98 (1)
    • Re: This Z-Buffer is going to KILLLL me! - Fragmo 02:13:06 7/09/98 (0)
  • Alpha Blending source code - Doug Linley 16:08:07 7/08/98 (0)
  • DrawPrimitive returns -2005531937 - Kevin Cline 14:41:01 7/08/98 (2)
    • Re: Create youself an error handler. - Jason G 16:42:56 7/08/98 (1)
      • Re: D3DERR_INVALIDCURRENTVIEWPORT - Kevin Cline 22:38:59 7/08/98 (0)
  • To Clay, Fragmo, Shai'tan - Karl Fisher 08:58:36 7/08/98 (9)
    • Re: To Clay, Fragmo, Shai'tan - Fragmo 19:11:45 7/08/98 (8)
      • Re: To Fragmo - Karl Fisher 22:03:05 7/08/98 (7)
        • Re: To Fragmo - Fragmo 02:36:05 7/09/98 (1)
          • Re: To Fragmo - Fragmo 02:48:03 7/09/98 (0)
        • Re: What the hell is going on? - Shai'tan 22:44:59 7/08/98 (0)
        • Re: Hehe...online development :) - Shai'tan 22:36:16 7/08/98 (3)
          • Re: Hehe...online development :) - Karl Fisher 19:57:47 7/09/98 (2)
            • Re: Z-Buffer code in SDK samples - Shai'tan 02:16:59 7/10/98 (1)
              • Re: Z-Buffer code in SDK samples - Karl Fisher 12:44:37 7/10/98 (0)
  • Ok, Z-Buffer works...but transformed verts are now WAY off - Shai'tan 03:47:35 7/08/98 (4)
    • Re: Ok, Z-Buffer works...but transformed verts are now WAY off - Clay 08:09:55 7/08/98 (3)
      • Re: Ok, Z-Buffer works...but transformed verts are now WAY off - Shai'tan 08:29:11 7/08/98 (2)
        • Re: Ok, Z-Buffer works...but transformed verts are now WAY off - Fragmo 19:26:31 7/08/98 (0)
        • Re: Ok, Z-Buffer works...but transformed verts are now WAY off - Shai'tan 09:35:39 7/08/98 (0)
  • D3D Sample Tunnel Source code - Shai'tan 21:37:35 7/07/98 (0)
  • File writer filter in DirectShow - andrew 21:25:33 7/07/98 (0)
  • Mmmm....RGB, HAL, MMX or Ramp? - Shai'tan 19:52:20 7/07/98 (0)
  • DirectX 6.0 Beta and Alpha blitting - Andreas Kühne 15:31:15 7/07/98 (1)
    • Re: DirectX 6.0 Beta and Alpha blitting - fred 06:44:53 7/08/98 (0)
  • HELP!!!! How do you use DrawPrimitive in user visuals? - Kevin Cline 13:31:05 7/07/98 (0)
  • DirectSound 5.0 & MIDI - Avner 07:40:11 7/07/98 (0)
  • HELP!!! Writing Wav file in DirectShow - andrew 02:44:16 7/07/98 (
  • Help!How to edit wav file in DirectShow - andrew 01:34:46 7/07/98 (0)
  • Urgent need help. How to load a mech with hirarchy? - Magdi 21:34:01 7/06/98 (0)
  • Draw Primitive ZBuffer - Karl Fisher 19:42:53 7/06/98 (0)
  • DrawPrimitive in user visuals - Kevin Cline 15:26:38 7/06/98 (0)
  • Sprites clipping on edge of screen! - Pet Monster 13:52:16 7/06/98 (5)
    • Re: Sprites clipping on edge of screen! - michael 01:41:31 7/16/98 (0)
    • Re: Sprites clipping on edge of screen! - Pet Monster 11:24:21 7/08/98 (0)
    • Re: Sprites clipping on edge of screen! - Johnny Rotten 10:29:36 7/07/98 (0)
    • Re: Sprites clipping on edge of screen! - Errant 07:07:45 7/07/98 (0)
    • Re: READ THIS ONE! - Pet Monster 13:53:45 7/06/98 (0)
  • Linker Error with Direct Input - Chris Goetschius 13:22:20 7/06/98 (1)
    • Re: Linker Error with Direct Input - Gunnar 19:29:21 7/16/98 (0)
  • Please help with Retained Mode. - LT 22:25:28 7/05/98 (1)
    • Re: Please help with Retained Mode. - LT 20:49:13 7/06/98 (0)
  • Please help me move the camera in D3DRM? - LT 22:19:01 7/05/98 (3)
    • Re: Please help me move the camera in D3DRM? - Snowman 23:35:07 7/05/98 (2)
      • Re: Please help me move the camera in D3DRM? - LT 20:47:47 7/06/98 (1)
        • Solved. - LT 00:11:38 7/07/98 (0)
  • Need help with Z-Buffers! Please!! - Shai'tan 21:39:10 7/05/98 (4)
    • Re: Need help with Z-Buffers! Please!! - Fragmo 22:33:59 7/05/98 (3)
      • Re: Thanks, but still need help :) - Shai'tan 00:55:12 7/06/98 (2)
        • Re: Thanks, but still need help :) - Fragmo 01:12:57 7/06/98 (1)
          • If you still need help - Clay 07:48:12 7/06/98 (0)
  • DirectShow?? - Snowman 16:22:10 7/05/98 (0)
  • x-pert wanted for direct sound - jobb 22:44:58 7/04/98 (0)
  • Ddrawex.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12 - Spikes 10:18:39 7/03/98 (1)
    • Re: Ddrawex.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12 - arrr 22:28:17 7/03/98 (0)
  • DrawPrimitive InverseTransform? - Doug 22:43:26 7/02/98 (0)
  • drawing sprites - Gabriel 20:10:30 7/02/98 (0)
  • Z-Buffers!!! - Shai'tan [Nth] 00:32:57 7/02/98 (0)
  • TIP: DrawPrimitive in RM - Frenchy FADGE 17:17:25 7/01/98 (0)
  • I realy need a frame::save() - Joe Michael 16:12:25 7/01/98 (0)
  • Windows NT 4.0 Support for Direct X - Juan 15:14:23 7/01/98 (1)
    • Re: Windows NT 4.0 Support for Direct X - G. Bereznicki 14:31:10 7/07/98 (0)
  • How to control all the file with a DirectShow Filter - Laurent TAUPIN 11:38:08 7/01/98 (0)
  • How to create a simply filter in Delphi ? - Laurent TAUPIN 11:34:16 7/01/98 (0)
  • What's with my frame rate?? - Clay 07:40:50 7/01/98 (0)
  • How do you save the texture on a face? - Snowman 22:28:36 6/30/98 (0)
  • DrawPrimitive Mouse To World? - Doug 21:52:36 6/30/98 (0)
  • DDERR_NOEXLCUSIVE??? WHY??? - Doug Linley 21:33:10 6/30/98 (2)
    • Re: DDERR_NOEXLCUSIVE??? WHY??? - Clay 07:33:49 7/01/98 (1)
      • Re: DDERR_NOEXLCUSIVE??? WHY??? - Doug Linley 08:48:01 7/01/98 (0)
  • D3D Help! - Marc 15:55:40 6/30/98 (1)
    • Re: D3D Help! - Roger Schuttelaar 07:24:47 9/02/98 (0)
  • Frame Orientation - Greger Ohlson 09:41:39 6/30/98 (0)
  • FlipToGDISurface : How to use this function? - Ravi Joshi 02:22:34 6/30/98 (0)
  • DirectDraw Beginner Problems - Tails 02:06:59 6/30/98 (2)
    • Re: DirectDraw Beginner Problems - Fragmo 06:35:04 6/30/98 (1)
      • Re: DirectDraw Beginner Problems (still) - Tails 12:38:17 6/30/98 (0)
  • Fill a color to a directdraw surface - Bob 18:34:36 6/29/98 (1)
    • Re: Fill a color to a directdraw surface - Ravi Joshi 02:29:15 6/30/98 (0)
  • DirectX with VC++ 2.1?? - Laurent 16:10:22 6/29/98 (1)
    • Re: DirectX with VC++ 2.1?? - Clay 15:01:08 6/30/98 (0)
  • DrawPrimitives ??? - Frenchy FADGE 10:29:57 6/29/98 (6)
    • Re: DrawPrimitives ??? - Clay 11:39:58 6/29/98 (5)
      • Re: DrawPrimitives ??? - Frenchy FADGE 04:50:59 6/30/98 (4)
        • Re: DrawPrimitives ??? - Clay 07:15:34 6/30/98 (3)
          • Re: DrawPrimitives ??? - Frenchy FADGE 09:00:28 6/30/98 (2)
            • Re: DrawPrimitives ??? - Clay 07:29:55 7/01/98 (1)
              • THE solution - Frenchy FADGE 17:00:01 7/01/98 (0)
  • DirectPlay player targetted messages - Dominic Mathers 09:43:48 6/29/98 (0)
  • DirectPlay lobby servers - Dominic Mathers 07:29:44 6/29/98 (0)
  • DirectShow - IBasicVideo->GetCurrentImage - Avner 07:06:41 6/29/98 (0)
  • MessageBoard Archiving - Yo 04:54:53 6/29/98 (1)
    • Re: MessageBoard Archiving - Clay 07:32:38 6/29/98 (0)
  • I need DirectX5 - Denton Duncan 12:41:27 6/28/98 (11)
    • Re: I need DirectX5 - Shah Smith 06:13:42 8/22/98 (1)
      • Re: I need DirectX5 - eric 02:24:17 8/23/98 (0)
    • Re: I need DirectX5 - MOGA 13:45:39 7/15/98 (0)
    • Re: I need DirectX5 - LYNN FOWLER 00:13:02 7/07/98 (2)
      • Re: I need DirectX5 - shawn lee harvey 17:52:58 7/20/98 (1)
        • Re: I need DirectX5 - Shawn lee Harvey 17:54:36 7/20/98 (0)
    • Re: I need DirectX5 - Roger Perez 03:09:15 7/02/98 (1)
      • Re: I need DirectX5 - ³s®Ê 21:51:42 7/03/98 (0)
    • Re: I need DirectX5 - terri 21:01:06 6/29/98 (0)
    • Re: I need DirectX5 - Julian Thatcher 22:30:27 6/28/98 (0)
    • Re: I need DirectX5 - Doug 19:29:33 6/28/98 (0)
  • DirectX 5.0 Control Panel that will not die! - Dave 04:00:42 6/28/98 (1)
    • Re: DirectX 5.0 Control Panel that will not die! - MOGA ALEXANDRU 13:40:29 7/15/98 (0)
  • speed of DirecSound mixing ? - Pontus Lundwall 19:23:39 6/27/98 (0)
  • IDirect3DDevice2 No Pick(), Mouse To World? - Doug 19:04:08 6/27/98 (0)
  • Textures in Immediate Mode - Shai'tan 02:52:13 6/27/98 (1)
    • Re: Textures in Immediate Mode - Doug 20:05:17 6/28/98 (0)
  • Finding Screen Coordinates of Mesh Vertices - Tycho 18:47:26 6/26/98 (1)
    • Re: Finding Screen Coordinates of Mesh Vertices - Doug 19:24:33 6/28/98 (0)
  • GetSurfaceDesc on offscreen surfaces - Ravi Joshi 04:54:09 6/26/98 (0)
  • Midi files, DirectMusic, Header files - Johnny Rotten 17:39:03 6/25/98 (0)
  • Getting DC on Offscreen surf doesn't work, Why? - Ravi Joshi 06:13:43 6/25/98 (3)
    • Re: Getting DC on Offscreen surf doesn't work, Why? - Doug 20:21:41 6/28/98 (2)
      • Re: How about BltFast? - Ravi Joshi 05:27:00 6/29/98 (1)
        • Re: How about BltFast? - Ravi Joshi 05:42:12 6/29/98 (0)
  • I can't get Borland C++ to work with the DirectX SDK! - Jonathan 19:35:25 6/23/98 (1)
    • Re: I can't get Borland C++ to work with the DirectX SDK! - Doug 20:33:01 6/28/98 (0)
  • ESS drivers - Karen D. 19:30:36 6/23/98 (0)
  • ESS drivers - Karen D. 19:21:56 6/23/98 (0)
  • UGH PLEASE QUIT! - Rod 16:48:08 6/23/98 (0)
  • PROGRESSIVE MESHES & TEXTURE MAPPING - Frenchy FADGE 09:41:08 6/23/98 (0)
  • Z BUFFER Precision ????? - Frenchy FADGE 09:30:34 6/23/98 (3)
    • Re: Z BUFFER Precision ????? - Frenchy FADGE 09:31:34 6/23/98 (2)
      • Re: Z BUFFER Precision ????? - Sietze 16:04:56 6/23/98 (1)
        • Thanks but ... - Frenchy FADGE 08:33:21 6/24/98 (0)
  • RM / IM : DRAW PRIMITIVES - Frenchy FADGE 09:22:45 6/23/98 (1)
    • Re: RM / IM : DRAW PRIMITIVES - Doug 20:44:26 6/28/98 (0)
  • Changing the resolution in D3D?? - Shai'tan 23:51:39 6/22/98 (4)
    • Re: Changing the resolution in D3D?? - Clay 06:33:34 6/24/98 (3)
      • I always forget something! - Clay 06:35:15 6/24/98 (2)
        • Thanks dude! - Shai'tan 20:59:43 6/24/98 (1)
          • Re: Thanks dude! - Clay 07:22:37 6/29/98 (0)
  • dx5 notworking - bb 22:01:13 6/22/98 (0)
  • Writing ActiveX ctrl:DirectSound, DirectShow on NT4. - andrew 01:29:13 6/22/98 (1)
    • Re: Writing ActiveX ctrl:DirectSound, DirectShow on NT4. - Ken Moore 16:15:26 6/28/98 (0)
  • How do you sav the texture on a face? - Snowman 14:21:39 6/21/98 (0)
  • DirecT3D, Vertices - JS 08:09:25 6/20/98 (0)
  • Any DirectX... - Johnny 08:53:27 6/19/98 (0)
  • About DPID struct - Gayathri.Kamath 00:43:36 6/19/98 (0)
  • Probs with Lobby - Gayathri.Kamath 00:23:04 6/19/98 (0)
  • DirectSound crashes in MFC - Daniel 20:58:31 6/18/98 (0)
  • How can I load Same Animation Multiple times from *.x file - zain 16:13:28 6/18/98 (0)
  • How do you use Hardware Acceleration? - Snowman 13:53:29 6/18/98 (3)
    • Re: How do you use Hardware Acceleration? - Fred 12:52:13 6/21/98 (2)
      • Re: How do you use Hardware Acceleration? - Snowman 14:13:37 6/21/98 (1)
        • Re: How do you use Hardware Acceleration? - Fred 01:36:23 6/22/98 (0)
  • Installing Jaton Video 77TV card and having problems - PK 01:49:00 6/18/98 (0)
  • Dialog Boxes in DirectX - Dan 23:01:35 6/17/98 (1)
    • Re: Dialog Boxes in DirectX - Andreas 15:27:49 7/07/98 (0)
  • I need drivers!!!! - Wade 20:24:54 6/17/98 (0)
  • from rm to rm2 - Eric Fournier 00:16:24 6/17/98 (1)
    • Re: from rm to rm2 - Fred 12:35:03 6/21/98 (0)
  • The GetVertices function - Me 20:59:03 6/16/98 (1)
    • Re: The GetVertices function - Billy 00:24:58 6/19/98 (0)
  • FAST Input Read from Mouse - Mehmet Gokturk 01:21:47 6/16/98 (2)
    • Re: FAST Input Read from Mouse - 0x1CE 03:38:50 6/18/98 (1)
      • Re: FAST Input Read from Mouse - Gunnar Holm 08:42:25 7/05/98 (0)
  • Retained Mode Texture Loading, Part II - Larry Weinstein 21:14:12 6/15/98 (2)
    • Re: Retained Mode Texture Loading, Part II - Fred 12:01:05 6/21/98 (1)
      • Re: Retained Mode Texture Loading, Part II - Larry Weinstein 09:41:51 6/26/98 (0)
  • Games - Me 13:51:25 6/15/98 (5)
    • Re: Games - chump 16:21:29 7/06/98 (0)
    • Re: Games - 0x1CE 03:43:15 6/18/98 (2)
      • Re: Games - Fred 12:18:45 6/21/98 (1)
        • Re: Games - 0x1CE 23:25:43 6/22/98 (0)
    • Re: Games - fragmo 03:07:05 6/16/98 (0)
  • Is non-alpha transparency possible? - Fragmo 00:47:03 6/15/98 (1)
    • Re: Is non-alpha transparency possible? - Fred 11:46:46 6/21/98 (0)
  • Scaling meshes - Me 13:52:24 6/14/98 (0)
  • D3D Books - Me 13:23:55 6/14/98 (0)
  • Does DirectX have a storage file format? - Anthony Villena 21:04:05 6/13/98 (0)
  • Does DirectX a storage file format? - Anthony Villena 21:03:24 6/13/98 (0)
  • My First DirectX Program - Dodit W 17:11:08 6/13/98 (0)
  • DirectX 6.0 - Major Tom 12:30:25 6/13/98 (4)
    • Re: DirectX 6.0 - Max Kovacs 06:00:00 6/27/98 (1)
      • Re: DirectX 6.0 - hj 04:37:12 7/07/98 (0)
    • Re: DirectX 6.0 - Michael 19:22:46 6/19/98 (0)
    • Re: DirectX 6.0 - KENG 00:50:31 6/16/98 (0)
  • How do I create a command bar - Jeroen Bulters 06:33:25 6/13/98 (0)
  • help: capture card - image processing algorithm - James A.T. Rice 21:04:41 6/12/98 (0)
  • Converting files - Me 19:06:54 6/12/98 (3)
    • Re: Converting files - fred 12:11:21 6/21/98 (2)
      • Re: Converting files - Me 16:54:07 6/23/98 (1)
        • Re: Converting files - KC 17:10:52 7/06/98 (0)
  • Direct 3D modes - Me 17:09:07 6/12/98 (6)
    • some sample code - Clay 21:27:36 6/12/98 (5)
      • Clay? Are you still there buddy? Please help me... - Me 00:19:28 6/19/98 (2)
        • busy at work... - Clay 07:22:16 6/23/98 (1)
          • Re: busy at work... - Me 23:32:12 7/05/98 (0)
      • Re: some sample code - Me 22:03:05 6/13/98 (0)
      • an addendum - Clay 21:29:38 6/12/98 (0)
  • Program crashes when an object leaves viewport - KC 13:46:54 6/12/98 (0)
  • help with DirectDraw2::SetDisplayMode() - Pontus Lundwall 12:12:50 6/12/98 (2)
    • Re: help with DirectDraw2::SetDisplayMode() - Ravi Joshi 01:37:32 6/16/98 (1)
      • Re: help with DirectDraw2::SetDisplayMode() - Pontus Lundwall 12:29:56 6/16/98 (0)
  • Desperately Seeking Good Examples - knoone 16:39:18 6/11/98 (0)
  • Won't Run Old Game... - Dave 14:39:51 6/11/98 (0)
  • D3D GetBox() - Me 19:10:37 6/10/98 (0)
  • D3D Collision detection - Me 19:07:47 6/10/98 (0)
  • D3D Faces - Me 18:03:56 6/10/98 (6)
    • Re: D3D Faces - Clay 08:20:25 6/11/98 (5)
      • Re:D3D Faces - Me 17:14:37 6/11/98 (4)
        • Re:D3D Faces - Clay 20:44:17 6/11/98 (3)
          • Re:D3D Faces - Me 19:13:49 6/12/98 (2)
            • Re:D3D Faces - Clay 21:19:51 6/12/98 (1)
              • Re:D3D Faces - Me 20:39:14 6/13/98 (0)
  • Help with in Memory DIBs - Allen Pauna 12:48:25 6/10/98 (0)
  • Rotating in DirectDraw - Peter 10:44:54 6/10/98 (0)
  • Clipper:Help,Help, I Desperately need help - Ravi Joshi 05:29:35 6/10/98 (4)
    • Re: Clipper:Help,Help, I Desperately need help - 0x1CE 18:17:17 6/11/98 (3)
      • Re: Clipper:Help,Help, I Desperately need help - Ravi Joshi 00:29:01 6/16/98 (2)
        • Re: Clipper:Help,Help, I Desperately need help - 0x1CE 03:36:17 6/18/98 (1)
          • Re: Clipper:Help,Help, I Desperately need help - 0x1CE 19:02:12 6/18/98 (0)
  • OWL and Direct Draw - Mehmet Gokturk 00:57:06 6/10/98 (0)
  • Visual Basic and Direct X - David 22:27:41 6/09/98 (2)
    • Re: Visual Basic and Direct X - Frenchy FADGE 11:42:39 6/24/98 (0)
    • Re: Visual Basic and Direct X - Gustavo Herrera Molina 19:46:51 6/17/98 (0)
  • IDirect3DDevice2::EndScene - Fragmo 21:50:00 6/09/98 (1)
    • Re: IDirect3DDevice2::EndScene - Clay 08:30:55 6/11/98 (0)
  • DirectX 5 and Borland C++ - Adrian Hirst 16:49:25 6/09/98 (1)
    • Re: DirectX 5 and Borland C++ - 0x1CE 18:00:42 6/11/98 (0)
  • To Merlin or anybody: DirectX uninstall - Mike 16:03:17 6/09/98 (0)
  • Surfaces with different pixel formats - Ravi Joshi 09:36:07 6/09/98 (0)
  • Draw Primitive Please Help - Karl Fisher 18:54:10 6/08/98 (1)
    • Re: Draw Primitive Please Help - Fragmo 21:38:38 6/09/98 (0)
  • I need directx 6.0--my uin is 6042905 - wicked 14:37:22 6/08/98 (2)
    • Re: I need directx 6.0--my uin is 6042905 - marc 16:11:41 6/08/98 (0)
    • Re: I need directx 6.0--my uin is 6042905 - Marc Curiel 16:01:25 6/08/98 (0)
  • DirectSound and Input Focus - John Croft 11:27:01 6/08/98 (0)
  • PLEASE HELP!! Direct3D is wierd! - Sanghyun Lee 10:26:55 6/08/98 (1)
    • Re: PLEASE HELP!! Direct3D is wierd! - Fred 12:45:12 6/21/98 (0)
  • Direct - alan 17:15:23 6/07/98 (0)
  • first IDirectDrawSurface3::Lock is slow? - Anthony Steele 16:04:10 6/07/98 (0)
  • Mixing Triangle Colors and RGB Lighting - Fragmo 15:28:36 6/07/98 (0)
  • How do you load a Direct3D *.x file? - Me 15:26:41 6/07/98 (1)
    • Re: How do you load a Direct3D *.x file? - ding@ 22:36:34 6/07/98 (0)
  • directX5.0 - jhony 02:43:37 6/07/98 (2)
    • Re: directX5.0 - Jacques Wolf 17:44:11 6/14/98 (0)
    • Re: directX5.0 - Tom Goody 22:09:43 6/08/98 (0)
  • Forcing DDPIXELFORMAT 8bpp on CreateSurface? - Ed Halley 02:11:14 6/07/98 (1)
    • Re: Forcing DDPIXELFORMAT 8bpp on CreateSurface? - Doug Wheeler 14:29:18 6/09/98 (0)
  • RE: How do you load multiple meshes? - Me 22:13:31 6/06/98 (1)
    • Re: RE: How do you load multiple meshes? - Joe Michael 16:01:54 7/01/98 (0)
  • How do you get two D3D meshes to scale the same? - Boller 05:37:14 6/06/98 (0)
  • ActiveMovie 2.0 - Ken Moore 19:16:01 6/05/98 (2)
    • Re: ActiveMovie 2.0 - fog 16:10:03 6/08/98 (1)
      • Re: ActiveMovie 2.0 - Ken Moore 20:46:49 6/10/98 (0)
  • Direct3D in STEREOSCOPIC modes - Wes Thierry 15:19:37 6/05/98 (0)
  • DirectX vs. OpenGL - Matt 15:21:28 6/04/98 (3)
    • Re: DirectX vs. OpenGL - Tim Astle 23:14:44 6/04/98 (2)
      • Re: DirectX vs. OpenGL - Andy Sy 14:12:06 6/07/98 (0)
      • Re: DirectX vs. OpenGL - Matt 10:26:00 6/05/98 (0)
  • 32bit surfaces - HBios 14:59:17 6/04/98 (0)
  • Direct Play: DirectPlayCreate call - Paul Hunter 12:19:41 6/04/98 (1)
    • Re: Direct Play: DirectPlayCreate call - Paul Hunter 08:32:11 6/09/98 (0)
  • Accessing DX objects in a VC++ DLL from VB - D.R.Pemberton 09:07:33 6/04/98 (1)
    • Re: Accessing DX objects in a VC++ DLL from VB - D.R.Pemberton 09:11:27 6/04/98 (0)
  • directX5.0 please - mie 08:56:31 6/03/98 (3)
    • Re: directX5.0 please - Marc Curiel 16:03:26 6/08/98 (0)
    • Re: directX5.0 please - Rick 21:02:14 6/05/98 (1)
      • Re: directX5.0 please - Bill 09:23:33 9/25/98 (0)
  • Visual Basic 5.0 and DirectX ( DirectInput ) - robert diosi 06:58:52 6/03/98 (0)
  • Visual Basic 5.0 and DirectX ( DirectInput ) - robert diosi 06:57:35 6/03/98 (0)
  • high pitch noise in Direct Sound - Fragmo 17:15:42 6/02/98 (0)
  • info on IDirect3DViewport2::TransformVertices????? - Fragmo 17:06:39 6/02/98 (3)
    • Re: info on IDirect3DViewport2::TransformVertices????? - frodo 07:48:08 6/04/98 (2)
      • Re: info on IDirect3DViewport2::TransformVertices????? - Fragmo 17:11:52 6/07/98 (1)
        • Re: info on IDirect3DViewport2::TransformVertices????? - Ken Chan 04:37:52 6/12/98 (0)
  • DDraw Rotation Code - Dallas Nutsc 15:37:06 6/02/98 (0)
  • .x files - zain 14:45:10 6/02/98 (1)
    • Re: .x files - fred 12:14:15 6/21/98 (0)
  • Invert display on windows 95 / directdraw / dirvid - Bigjohn 10:51:36 6/02/98 (1)
    • Re: Invert display on windows 95 / directdraw / dirvid - Ravi Joshi 03:56:32 6/25/98 (0)
  • (no) AlphaBLT in DX6 (OH NO, NOT AGAIN!!!) - Sietze 10:40:12 6/02/98 (1)
    • Re: (no) AlphaBLT in DX6 (OH NO, NOT AGAIN!!!) - Tim Astle 23:08:56 6/04/98 (0)
  • DDERR_NOEXCLUSIVEMODE - Sajid Khan 05:43:04 6/02/98 (1)
    • Check this!! - Clay 09:06:59 6/02/98 (0)
  • Anyone else get messed up TEXTURES on CLIPPED polygons in HAL mode? - Hana 00:37:03 6/02/98 (1)
    • Re: Anyone else get messed up TEXTURES on CLIPPED polygons in HAL mode? - sietze 11:03:38 6/02/98 (0)
  • and assembly language - Rob 12:12:26 6/01/98 (1)
    • Re: and assembly language - Sietze 10:51:26 6/02/98 (0)
  • Creating DLL's in VC++ for VBasic - Rob Pemberton 09:16:37 6/01/98 (1)
    • Re: Creating DLL's in VC++ for VBasic - Cyber Optik 18:35:33 6/02/98 (0)
  • Does D3DRMLOAD_INSTANCEBYREFERENCE actually do anything? - Mike 18:09:54 5/31/98 (0)
  • TIP: Don't use default texture loads with Load() (D3DRM) - Mike 18:07:21 5/31/98 (0)
  • Creating 3d images for direct x - Lloyd Nickens 19:27:29 5/30/98 (1)
    • Re: Creating 3d images for direct x - marino 11:09:50 6/02/98 (0)
  • Protein Data Bank (PDB) conversion to DXF or 3DS - Jared Kuemmerle 12:35:40 5/30/98 (0)
  • force feed back - Sváb, Sándor 05:30:34 5/30/98 (0)
  • Picking in D3DIM D3DVERTEX - Ken Chan 22:52:46 5/28/98 (0)
  • Getting a DirectSoundNotify Interface - Footh 15:52:34 5/28/98 (2)
    • Re: Getting a DirectSoundNotify Interface - Gilles Pommereuil 13:50:36 8/13/98 (0)
    • Re: Getting a DirectSoundNotify Interface - syn 14:57:23 7/27/98 (0)
  • Bad Z-BUFFER... - LeeKafka 14:57:21 5/28/98 (0)
  • TLVERTEX supporting FOG??? - LeeKafka 14:53:29 5/28/98 (0)
  • DirectDraw and Overlay Surfaces - Jagmohan S Nanaware 02:52:19 5/28/98 (1)
    • Re: DirectDraw and Overlay Surfaces - Angie Kucmierz 22:07:30 7/13/98 (0)
  • directNT - as1 00:09:00 5/28/98 (1)
    • Re: directNT - Steve 02:02:57 5/31/98 (0)
  • PNG file format with DirectX - Cyrille Wagner 17:57:47 5/27/98 (0)
  • Help with Direct X? - Ben Mangus 16:17:02 5/27/98 (0)
  • Scrolling TeXt - Damon 15:07:38 5/27/98 (0)
  • Delphi DirectX articles wanted! - Dean Ellis 10:56:48 5/27/98 (1)
    • Re: Delphi DirectX articles wanted! - Christopher Özbek 08:00:13 6/24/98 (0)
  • Where can I get DirectX5.0 SDK. OR Microsoft Suck. - Crispin Wellington 08:09:29 5/27/98 (11)
    • Get DirectX 5.0 SDK here. Anybody know where to get 5.2? - M. Wagner 00:56:21 5/28/98 (10)
      • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? - R.JONES 19:09:12 7/06/98 (0)
      • thank you - Cesar 14:04:40 6/29/98 (0)
      • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? - Steven Weesner 08:47:23 6/29/98 (0)
      • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? - Robert Vaillancourt 22:18:07 6/28/98 (0)
      • I know where to get 5.2 - Ashley Fisher 03:12:45 6/28/98 (0)
      • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? - Jay (the answer) 23:40:11 6/23/98 (0)
      • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? - chris peters 01:14:58 6/07/98 (1)
        • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? - karen 18:06:40 6/28/98 (0)
      • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? - chris peters 01:13:34 6/07/98 (0)
      • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? - chris peters 01:09:45 6/07/98 (0)
  • Direct Show "How can I play a movie in full-screen?" - Seong Wan Kim 22:59:13 5/26/98 (1)
    • Re: Direct Show "How can I play a movie in full-screen?" - Laurent TAUPIN 10:35:47 6/18/98 (0)
  • Multimedia Streaming - robert tomlin 11:11:12 5/26/98 (1)
    • Re: Multimedia Streaming - Laurent TAUPIN 10:39:21 6/18/98 (0)
  • DirectX 5.0 problems - Barry 09:59:25 5/26/98 (2)
    • Re: DirectX 5.0 problems - Joel Morgovsky 09:07:11 6/15/98 (0)
    • Re: DirectX 5.0 problems - EvAcLeAr 23:57:45 5/28/98 (0)
  • How to rotate a point around another point in 2-D space - Emil Diego 23:19:11 5/25/98 (1)
    • Re: How to rotate a point around another point in 2-D space - Captain Conan 00:26:53 6/24/98 (0)
  • Retained Mode Texture Loading - Larry Weinstein 09:34:35 5/25/98 (1)
    • Re: Retained Mode Texture Loading - Fred 08:25:57 5/28/98 (0)
  • DX 5.0 & AVI Troubles (Examples Don't Work Well at all!!) - EvAcLeAr 03:59:47 5/25/98 (1)
    • Re: DX 5.0 & AVI Troubles (Examples Don't Work Well at all!!) - BoxMan 21:02:25 6/08/98 (0)
  • Texture Wrapping Function What is it for - Sajid Khan 03:29:13 5/25/98 (0)
  • Compiler - Torin 13:08:50 5/24/98 (1)
    • Re: Compiler - EvAcLeAr 04:20:36 5/25/98 (0)
  • Alpha-Blending / Lens-Flare - Chris 06:00:23 5/24/98 (1)
    • Re: Alpha-Blending / Lens-Flare - Sietze 11:17:08 6/02/98 (0)
  • help with directx and presario 2220.....!!! - Jim W. 12:53:58 5/23/98 (3)
    • Re: help with directx and presario 2220.....!!! - EvAcLeAr 04:31:33 5/25/98 (2)
      • Re: my star trek game wont work please help - Kent Peterson 23:19:48 7/07/98 (1)
        • Re: my star trek game wont work please help - Kent Peterson 23:20:59 7/07/98 (0)
  • polygon near klipping - Robert 09:18:15 5/22/98 (0)
  • Sprite Collisions - Eduardo Meza 18:59:22 5/21/98 (2)
    • Re: Sprite Collisions - EvAcLeAr 03:34:33 5/30/98 (0)
    • Re: Sprite Collisions - EvAcLeAr 05:01:38 5/25/98 (0)
  • HELP! my lights don't work properly! - sietze 17:02:07 5/21/98 (2)
    • Re: HELP! my lights don't work properly! - Clay 07:35:21 5/22/98 (1)
      • OK shoot me, i'm stupid - Sietze 06:34:21 5/23/98 (0)
  • D3DTLVERTEX sz & rhw fields - Serge Plagnol 10:34:02 5/21/98 (1)
    • Re: D3DTLVERTEX sz & rhw fields - Robert 14:01:32 5/21/98 (0)
  • Meshes - Herbert Schuster 04:51:28 5/21/98 (1)
    • Re: Meshes - MAgDI 21:16:03 7/06/98 (0)
  • How do I uninstall DirectX? - A. Chan 19:12:10 5/20/98 (1)
    • Re: How do I uninstall DirectX? - EvAcLeAr 04:10:45 5/25/98 (0)
  • ddraw linkin error please help - menasius 16:45:30 5/17/98 (3)
    • Re: ddraw linkin error please help - Ravi Joshi 09:04:36 6/02/98 (0)
    • Re: ddraw linkin error please help - EvAcLeAr 19:01:10 5/18/98 (1)
      • Re: ddraw linkin error please help - C1pher 22:17:42 5/23/98 (0)
  • releasing DDraw objects causes hang - morris 00:36:43 5/17/98 (2)
    • Re: releasing DDraw objects causes hang - Clay 07:48:35 5/22/98 (1)
      • One more thing - Clay 07:49:48 5/22/98 (0)
  • Direct X pixel plotting - menasius 23:41:32 5/15/98 (1)
    • Re: Direct X pixel plotting - qIz 05:07:02 5/18/98 (0)
  • DPID_SERVERPLAYER doesn't change - Peter Ohlmann 14:19:14 5/15/98 (3)
    • Re: DPID_SERVERPLAYER doesn't change - Dominic Mathers 04:04:22 6/30/98 (0)
    • Re: DPID_SERVERPLAYER doesn't change - Dominic Mathers 04:00:59 6/30/98 (0)
    • Re: DPID_SERVERPLAYER doesn't change - Dominic Mathers 04:00:13 6/30/98 (0)
  • Problem with the IDirect3DRMAnimationSet::Load - Fred 09:25:51 5/15/98 (7)
    • Re: Problem with the IDirect3DRMAnimationSet::Load - Andreas 20:28:47 6/30/98 (1)
      • Re: Problem with the IDirect3DRMAnimationSet::Load - Fred 12:35:07 8/18/98 (0)
    • Re: Problem with the IDirect3DRMAnimationSet::Load - Lee 18:47:02 5/27/98 (0)
    • Re: Problem with the IDirect3DRMAnimationSet::Load - Larry Velasquez 01:06:05 5/23/98 (0)
    • Re: Problem with the IDirect3DRMAnimationSet::Load - Larry Velasquez 01:05:40 5/23/98 (0)
    • Re: Problem with the IDirect3DRMAnimationSet::Load - Larry Velasquez 01:03:48 5/23/98 (0)
    • Re: Problem with the IDirect3DRMAnimationSet::Load - Larry Velasquez 01:02:45 5/23/98 (0)
  • Help! - Chris and Terry, Homeschoolers 11:33:12 5/14/98 (2)
    • Re: Help! - fog 16:08:17 6/08/98 (0)
    • Re: Help! - Fred 08:58:20 5/15/98 (0)
  • > - Heddwyn A. Jones 07:26:45 5/14/98 (1)
    • Re: > - Clay 14:10:47 5/15/98 (0)
  • DirectDraw and video Overlay - Michael Uman 13:39:45 5/13/98 (0)
  • D3D gives floating point errors for no detecable reason - Luke Ryan 01:29:56 5/13/98 (1)
    • Re: D3D gives floating point errors for no detecable reason - Clay 07:41:18 5/22/98 (0)
  • How do you get a console apps window handle - E. J. Thayer 12:24:06 5/11/98 (0)
  • Antialiasing Enable - Dorian Averbuh 10:41:34 5/11/98 (0)
  • Directx 5.2 SDK - iguane 09:13:21 5/11/98 (2)
    • Re: Directx 5.2 SDK - ¶À¦³°¶ 05:19:27 5/15/98 (1)
      • Re: Directx 5.2 SDK - Ulle 09:21:20 6/06/98 (0)
  • Direct3D: how to create control buttons - MAgDI 00:22:32 5/11/98 (0)
  • Soundblaster AWE32 and DirectX 5 problems - Jesus Giraut 11:33:06 5/10/98 (1)
    • Re: Soundblaster AWE32 and DirectX 5 problems - Adele 03:18:43 7/11/98 (0)
  • Reverse playback of video via DirectShow - Thomas Krim 04:53:42 5/10/98 (4)
    • Re: Reverse playback of video via DirectShow - Robert Tomlin 08:54:40 6/17/98 (0)
    • Re: Reverse playback of video via DirectShow - Robert Tomlin 05:17:45 5/11/98 (2)
      • Re: Reverse playback of video via DirectShow - Thomas Krim 05:06:00 5/21/98 (1)
        • Re: Reverse playback of video via DirectShow - Thomas Krim 05:07:33 5/21/98 (0)
  • Need help for DirectPlay! - Peter Ohlmann 22:17:48 5/08/98 (0)
  • Fog help! - Hana 18:51:16 5/08/98 (1)
    • Re: Fog help! - Robert 14:14:17 5/21/98 (0)
  • alpha blending in RM - Clay 08:04:03 5/08/98 (3)
    • Been there (, allmost jumped off a tall building), done that - sietze 12:10:44 5/08/98 (2)
      • Retained mode translucency - Al 04:26:39 7/06/98 (0)
      • Re: Been there (, allmost jumped off a tall building), done that - Clay 17:00:23 5/08/98 (0)
  • 8bpp24bpp - cappa luca 07:32:14 5/08/98 (2)
    • Re: 8bpp24bpp - Brian Shea 12:25:36 5/08/98 (1)
      • Re: 8bpp24bpp - cappa luca 12:48:09 5/22/98 (0)
  • AlphaSrcConstOverride... - Jonathan Klein 19:48:41 5/07/98 (1)
    • Re: AlphaSrcConstOverride... - Brian Shea 12:23:49 5/08/98 (0)
  • directX5 - mike 13:50:12 5/07/98 (9)
    • Re: directX5 - Mr.Goodbar 01:09:50 5/23/98 (1)
      • Re: directX5 - Matt 17:10:24 6/06/98 (0)
    • Re: directX5 - Mr.Goodbar 01:08:15 5/23/98 (5)
      • Re: directX5 - ³s®Ê 21:45:08 7/03/98 (1)
        • Re: directX5 - ³s®Ê 21:48:27 7/03/98 (0)
      • Re: directX5 - ³s®Ê 21:44:48 7/03/98 (0)
      • Re: directX5 - ³s®Ê 21:44:16 7/03/98 (0)
      • Re: directX5 - n 07:21:39 6/24/98 (0)
    • Re: directX5 - mike 13:52:58 5/07/98 (0)
  • Retained Mode: AddGroup?? #!@#$!!! please help! - Shai'tan 06:25:45 5/07/98 (1)
    • Re: Retained Mode: AddGroup?? #!@#$!!! please help! - Lou 09:03:59 5/16/98 (0)
  • clipping: at what stage to do it? - gravedancer 17:37:44 5/06/98 (0)
  • trident / jaton video cards and dd - Robert 15:45:19 5/06/98 (0)
  • Overlays with Direct - X - David Johnson 14:47:04 5/05/98 (0)
  • Exclusive mode - navin 06:24:30 5/04/98 (6)
    • Re: Exclusive mode - Clay 07:40:33 5/04/98 (5)
      • Still.... - Navin 05:21:37 5/06/98 (0)
      • Still.... - Navin 05:21:20 5/06/98 (3)
        • Hmmm.... - Clay 07:51:36 5/06/98 (2)
          • Re: Hmmm.... - Navin 07:37:36 5/09/98 (1)
            • E-Mail - Navin 07:41:56 5/09/98 (0)
  • C++ Builder/Delphi and DirectDraw hint - Jack Strohm 20:47:41 5/02/98 (1)
    • Direct Draw Memory - Levi Womack 13:05:11 9/04/98 (0)
  • Help! I can't build the dsshow3d example. - Chris Derry 03:32:51 5/02/98 (2)
    • Oops (Help! I can't build the dsshow3d example) - Chris Derry 03:40:00 5/02/98 (1)
      • Re: Oops (Help! I can't build the dsshow3d example) - Brian Shea 01:43:37 5/03/98 (0)
  • dxsetup can't see my card... - Shep Ryen 23:27:45 4/30/98 (1)
    • Re: dxsetup can't see my card... - EvAcLeAr 04:28:40 5/25/98 (0)
  • DirectShow doesn't get the message... - sietze 12:57:58 4/30/98 (0)
  • Out of Video Memory?? - Clay 09:45:27 4/30/98 (4)
    • ah ha! - Clay 09:32:46 5/02/98 (0)
    • Re: Out of Video Memory?? - Robert 10:28:51 5/01/98 (0)
    • same problem, different symptoms - sietze 07:41:28 5/01/98 (1)
      • have you tried... - Clay 12:33:53 5/01/98 (0)
  • ActiveMovie flash - Robert Tomlin 06:56:30 4/30/98 (1)
    • Re: ActiveMovie flash related point - Robert Tomlin 11:49:56 4/30/98 (0)
  • 3D Map Editor For Direct3D - eXact 06:43:52 4/30/98 (0)
  • DirectPlay problems after 3-5 h - Peter Ohlmann 11:32:28 4/29/98 (0)
  • HELP! My game is choking on its sounds! - Sietze Dijkstra 05:07:24 4/29/98 (3)
    • Re: HELP! My game is choking on its sounds! - Peter Ohlmann 11:42:36 4/29/98 (2)
      • You're not serious, right? Oh, you are! (AAAAAARGH!) - sietze 13:02:33 4/30/98 (1)
        • let me get back on that... - sietze 13:06:06 4/30/98 (0)
  • 3D `Splitter Window' - Rainer M. Domingo 04:42:57 4/29/98 (1)
    • Re: 3D `Splitter Window' - Corrected scrdow' - Corrected screen - Rainer M. Domingo 04:49:20 4/29/98 (0)
  • ZBuffer problem in DirectX5 - SIV 08:08:24 4/28/98 (0)
  • DirectX5.0 in VB5.0 - JP Nachtwey 18:33:24 4/27/98 (2)
    • Re: DirectX5.0 in VB5.0 - GutterPunk 13:10:50 4/30/98 (1)
      • Re: DirectX5.0 in VB5.0 - carlos 11:45:46 5/10/98 (0)
  • Direct3DRM LookAt function: how does it do that? - Max McCollister 01:02:20 4/26/98 (1)
    • Re: Direct3DRM LookAt function: how does it do that? - Brian Marshall 16:11:34 5/15/98 (0)
  • 12 second sequence to display - Mehmet Bugra 19:54:50 4/25/98 (0)
  • how to transform RGB values to YUV - Ersin ESEN 05:33:35 4/25/98 (0)
  • Bitmap Rotation - Graham P 10:44:28 4/24/98 (1)
    • Re: Bitmap Rotation - EvAcLeAr 04:53:02 5/25/98 (0)
  • Windowed Immediate Mode - Eugene Duvenage 10:00:10 4/24/98 (1)
    • Re: Windowed Immediate Mode - NooTe 11:05:45 4/24/98 (0)
  • ActiveMovie and IMediaSeeking::SetRate() - Robert Tomlin 09:59:09 4/23/98 (0)
  • DirectX and DirectShow Redistrubables - Robert Tomlin 06:21:01 4/23/98 (0)
  • DirectX 5.0 and TB soundcards - Dave Cook 15:18:04 4/22/98 (1)
    • Re: DirectX 5.0 and TB soundcards - fere 12:09:13 4/24/98 (0)
  • Z-buffer-detection - Dorian Averbuh 12:47:51 4/22/98 (0)
  • How use lightmap with non-alphablend ! - NooTe 10:36:45 4/22/98 (0)
  • Directx 5.0 - Joshua Lee 01:19:07 4/22/98 (2)
    • Re: D3DRM.DLL - David Goss 08:46:23 6/10/98 (0)
    • Re: Directx 5.0 - eddie 20:12:09 4/22/98 (0)
  • leaving an extra pixel on the side? (Blt) - James 22:06:54 4/21/98 (0)
  • Line of sight - Johnny Rotten 16:23:13 4/21/98 (0)
  • DirectDraw in an ActiveX control... Is it possible? - Scott Prigge 15:35:17 4/21/98 (0)
  • HELP--PUTTING TEXTURED MESH ON ANOTHER TEXTURED MESH - Chris 13:15:17 4/21/98 (0)
  • video cards are not all alike - Robert Carra 10:34:21 4/21/98 (0)
  • Balance, Harmony, Docs, and Direct X - Steven M 20:49:53 4/20/98 (1)
    • Re: Balance, Harmony, Docs, and Direct X - Johnny Rotten 11:23:27 4/21/98 (0)
  • Opinions wanted of the best <$200 modeler/renderer/animator for Direct3D - Boller 20:48:55 4/20/98 (2)
    • Re: Opinions wanted of the best <$200 modeler/renderer/animator for Direct3D - EvAcLeAr 19:15:36 5/18/98 (0)
    • Re: Opinions wanted of the best <$200 modeler/renderer/animator for Direct3D - Lou 09:16:36 5/16/98 (0)
  • DirectX plugins? - Tommi Prami 03:52:33 4/20/98 (0)
  • 2 questions... - BoxMan 02:37:59 4/20/98 (1)
    • Re: 2 questions... - Brian Shea 02:59:07 4/20/98 (0)
  • Snycronisation of 3D-Hardware - Christoph Stüber 21:05:04 4/19/98 (0)
  • DXF and DirectX - Frank 17:36:13 4/19/98 (0)
  • Newbie - Brent 15:41:52 4/19/98 (2)
    • Re: Newbie - Sheath 16:22:57 4/19/98 (1)
      • Re: Newbie - BoxMan 02:23:55 4/20/98 (0)
  • Where to find landscape meshes - Joe 23:08:38 4/18/98 (2)
    • Re: Where to find landscape meshes - EvAcLeAr 19:27:00 5/18/98 (0)
    • Re: Where to find landscape meshes - Navin 04:59:30 5/18/98 (0)
  • unresolved external symbol _main with SDK - Steve M 22:33:30 4/18/98 (3)
    • Re: unresolved external symbol _main with SDK - Brian Shea 02:49:45 4/20/98 (1)
      • Thanks I'll check it out - Steven M 20:32:03 4/20/98 (0)
    • Re: unresolved external symbol _main with SDK - BoxMan 02:20:14 4/20/98 (0)
  • DirectX 5.0 - Guy Lanzone 21:57:55 4/17/98 (5)
    • Re: DirectX 5.0 - David 12:07:33 5/01/98 (0)
    • Re: DirectX 5.0 - nam ki min 20:19:45 4/21/98 (0)
    • Re: DirectX 5.0 - Pavel Bure 21:27:59 4/19/98 (0)
    • Re: DirectX 5.0 - Juliano F. Ferreira 22:30:05 4/18/98 (0)
    • Re: DirectX 5.0 - Brian Shea 14:55:39 4/18/98 (0)
  • How Do I Use IID's (for cloning) In C? Or Can't I? - sietze 20:26:33 4/17/98 (1)
    • Re: How Do I Use IID's (for cloning) In C? Or Can't I? - markus 14:46:52 5/18/98 (0)
  • Rotation - Inf 18:20:33 4/17/98 (1)
    • Re: Rotation - Johnny Rotten 16:11:41 4/21/98 (0)
  • MAX material to D3DMATERIAL conversion - gravedancer 16:56:06 4/17/98 (0)
  • Watcom and DirectX - Marco 13:06:40 4/17/98 (1)
    • Re: Watcom and DirectX - Ron Bakker 17:29:54 4/17/98 (0)
  • DirectX input - David Carter 01:23:33 4/17/98 (2)
    • Re: DirectX input - Johnny Rotten 10:01:30 4/17/98 (1)
      • Re: DirectX input - David Carter 02:44:36 4/18/98 (0)
  • smoke and flames - gravedancer 17:59:33 4/16/98 (1)
    • Re: smoke and flames - Sheath 16:27:13 4/19/98 (0)
  • My APP locks up with Alt-Tab - BoxMan 20:39:12 4/15/98 (2)
    • Re: My APP locks up with Alt-Tab - Brian Shea 00:26:33 4/17/98 (0)
    • Re: My APP locks up with Alt-Tab - gravedancer 18:09:04 4/16/98 (0)
  • DirectPlay - Shane Wheeler 18:09:09 4/15/98 (0)
  • How do I use Clone? (object in D3DRM) - Lee Sandberg 17:45:56 4/15/98 (1)
    • Re: How do I use Clone? (object in D3DRM) - Brian Marshall 15:40:57 5/15/98 (0)
  • I downt want much from DirectX but I need Help - Caine 07:40:08 4/15/98 (1)
    • Re: I downt want much from DirectX but I need Help - BoxMan 02:08:16 4/16/98 (0)
  • Error on rotating surface when blitting - Clay 23:05:43 4/14/98 (1)
    • Re: Error on rotating surface when blitting - Madant 09:47:41 4/19/98 (0)
  • newbie here - Senan 18:31:51 4/14/98 (1)
    • Re: newbie here - Brian Shea 19:46:25 4/14/98 (0)
  • DelphiX / Blitting - Ray 18:02:50 4/14/98 (0)
  • Directx 5.0 for NT??? - Rok 14:00:21 4/14/98 (1)
    • Re: Directx 5.0 for NT??? - Reefer 03:07:13 4/30/98 (0)
  • ... - Rok 13:55:44 4/14/98 (0)
  • Screen turns white using DirectDraw - David Naughton 11:47:13 4/14/98 (2)
    • Re: Screen turns white using DirectDraw - Brian Shea 19:42:09 4/14/98 (1)
      • Thanks - David Naughton 05:34:43 4/17/98 (0)
  • D3D Retained Mode and BC++ Builder - Frédéric LUCE 04:31:56 4/14/98 (0)
  • How do I convert POV 3.0 files to *any* other format? - Jeff Boller 22:50:10 4/13/98 (1)
    • Re: How do I convert POV 3.0 files to *any* other format? - BoxMan 02:14:22 4/16/98 (0)
  • Blitting DirectDraw surfaces onto Direct3D surfaces - John 15:03:51 4/13/98 (1)
    • Re: Blitting DirectDraw surfaces onto Direct3D surfaces - Eason 22:15:40 4/17/98 (0)
  • How do I convert 3dstudioMAX to .x format? - Christoffer Schrøder 07:54:41 4/13/98 (1)
    • Re: How do I convert 3dstudioMAX to .x format? - Roger 12:01:02 4/29/98 (0)
  • JPEG - Wolfgang Rössler 09:37:45 4/12/98 (1)
    • Re: JPEG - Johnny Rotten 10:26:36 4/13/98 (0)
  • MFC and directx. - FooSi 23:23:42 4/11/98 (1)
    • Re: MFC and directx. - Joe 13:06:51 4/16/98 (0)
  • DirectX5 with Visual c++ 4.0 - Mike 21:46:51 4/11/98 (1)
    • Re: DirectX5 with Visual c++ 4.0 - Falcon 11:02:28 4/12/98 (0)
  • Need help writing Bitmaps from a Direct Draw Surface to file! - Vlad 20:40:15 4/11/98 (0)
  • read two key at once - Sen Tran 04:14:28 4/11/98 (1)
    • Re: read two key at once - Madant 09:52:56 4/19/98 (0)
  • Memory Access errors (help a stupid newbie) - Nick Weihs 18:18:55 4/10/98 (1)
    • Re: Memory Access errors (help a stupid newbie) - Mitch Christian 21:48:27 5/17/98 (0)
  • Where can I find Direct X SDK - Martin Weiner 02:52:28 4/10/98 (2)
    • Re: Where can I find Direct X SDK - Valorian 03:00:09 4/11/98 (0)
    • Re: Where can I find Direct X SDK - Nick Weihs 11:47:30 4/10/98 (0)
  • Help, I'm a stupid newbie - Aron Yu 16:57:47 4/09/98 (8)
    • What compiler? - AIR_TIME 22:49:32 4/09/98 (2)
      • Yeah, It was VC++ 5.0, but.... - Aron Yu 05:15:56 4/10/98 (1)
        • Re: Yeah, It was VC++ 5.0, but.... - AIR_TIME 16:13:58 4/10/98 (0)
    • Re: Help, I'm a stupid newbie - Roger 19:52:32 4/09/98 (4)
      • Help - David Carter 01:30:55 4/17/98 (0)
      • Re: Help, I'm a stupid newbie - Aron Yu 05:12:52 4/10/98 (2)
        • Did you include SDK\SAMPLES\MISC\ - AIR_TIME 16:15:53 4/10/98 (0)
        • Also a stupid newbie... - Nick Weihs 11:43:34 4/10/98 (0)
  • Getting DDHelp.exe caused error in 546x.drv! - Lance 12:56:51 4/09/98 (0)
  • Need Help on Wraps - Chris 12:36:01 4/09/98 (0)
  • Quake - zap 10:14:33 4/09/98 (0)
  • Beginners question about blitting bitmaps - Red 08:29:33 4/09/98 (0)
  • DirectX Surfaces and Windows GDI - Robert Tomlin 06:47:47 4/09/98 (2)
    • Re: DirectX Surfaces and Windows GDI - Martijn Segers 17:43:55 4/09/98 (1)
      • Re: DirectX Surfaces and Windows GDI - Robert Tomlin 11:47:19 4/30/98 (0)
  • CDX question - Nick Weihs 18:38:41 4/08/98 (2)
    • Where can I get CDX? - AIR_TIME 00:29:53 4/09/98 (1)
      • Re: Where can I get CDX? - Nick Weihs 09:53:23 4/09/98 (0)
  • Borland C++ Builder 3.0 and DirectX - Jack Strohm 16:19:32 4/08/98 (2)
    • Me Too but VC++Re: Borland C++ Builder 3.0 and DirectX - AIR_TIME 16:48:21 4/08/98 (1)
      • Re: Me Too but VC++Re: Borland C++ Builder 3.0 and DirectX - Rodney Martin 17:51:24 4/10/98 (0)
  • Z-buffer direct Access - Dorian Averbuh 11:19:00 4/08/98 (1)
    • Re: Z-buffer direct Access - Roger 20:01:26 4/09/98 (0)
  • Z-buffer direct Access - Dorian Averbuh 11:11:58 4/08/98 (0)
  • Samples - Dave 01:42:20 4/08/98 (1)
    • Re: Samples - Roger 19:59:16 4/09/98 (0)
  • How can I check on which 3D card is used by DirectX? - Greg Kable 00:38:23 4/08/98 (1)
    • short answer, more questions - Clay 09:12:47 4/08/98 (0)
  • Anyone have any good tile-based engine links? - Ryan Fenton 21:59:37 4/07/98 (5)
    • Tile based games - Johnny Rotten 10:13:36 4/08/98 (3)
      • Cool... - Ryan Fenton 12:03:20 4/08/98 (2)
        • Engine - Johnny Rotten 12:23:34 4/08/98 (1)
          • Very Cool... - Ryan Fenton 23:53:43 4/09/98 (0)
    • Re: Anyone have any good tile-based engine links? - Brian Shea 00:40:15 4/08/98 (0)
  • simple DriectDraw question - Oliver Hauth 17:43:22 4/07/98 (1)
    • Re: simple DriectDraw question - Brian Shea 00:37:51 4/08/98 (0)
  • D3DRM textures get upside down - Pablo de Heras 12:19:11 4/07/98 (4)
    • Re: D3DRM textures get upside down - Brian Shea 13:40:46 4/07/98 (3)
      • Re: D3DRM textures get upside down - Pablo de Heras 16:30:38 4/07/98 (2)
        • Re: D3DRM textures get upside down - Ludovic Tirtiaux 12:01:00 4/08/98 (1)
          • THANKS! Re: D3DRM textures get upside down - Pablo de Heras 12:34:02 4/08/98 (0)
  • Triple buffering - Jon 09:48:19 4/07/98 (1)
    • Re: Triple buffering - Brian Shea 13:38:07 4/07/98 (0)
  • spectrum analyzer - Justin 21:21:12 4/06/98 (0)
  • HOW TO UNISTALL ALL VERSIONS OF DIRECTX - merlin 18:31:01 4/06/98 (0)
  • MYSTERIOUS BLIT DELAY/WAVE DISTORTION ?? HELP !! - Martijn Segers 17:21:09 4/06/98 (0)
  • DrawPrimitive HAL - Greg 10:01:50 4/06/98 (0)
  • Spotlights not lighting flat polygons! - Andy Capon 06:25:31 4/06/98 (4)
    • Re: Spotlights not lighting flat polygons! - Clay 13:51:13 4/06/98 (3)
      • Re: Spotlights not lighting flat polygons! - Andy Capon 15:30:31 4/06/98 (2)
        • Re: Spotlights not lighting flat polygons! - Fred 18:32:21 5/29/98 (0)
        • Re: Spotlights not lighting flat polygons! - Clay 07:38:53 4/07/98 (0)
  • Direct3D DrawPrimitive - Andréas Kühne 03:07:57 4/06/98 (1)
    • Re: Direct3D DrawPrimitive - Serge Plagnol 10:23:32 5/21/98 (0)
  • Rotation of an object - Mike 19:58:50 4/05/98 (0)
  • problems with dinput and joystick - H.p. 17:15:12 4/05/98 (0)
  • Direct X Sample question. - EvAcLeAr 05:05:58 4/05/98 (0)
  • MSVC++ 5.0 / Direct X...Im new..please help me. - AIR_TIME 01:28:57 4/05/98 (8)
    • Re: MSVC++ 5.0 / Direct X...Im new..please help me. - Serg 16:27:16 4/05/98 (0)
    • Re: MSVC++ 5.0 / Direct X...Im new..please help me. - Clay 15:42:21 4/05/98 (5)
      • But the problem with this book is...... - AIR_TIME 21:13:39 4/05/98 (4)
        • A little explanation - Clay 11:44:35 4/07/98 (3)
          • I got a new book...(Spells of Fury) - AIR_TIME 23:28:56 4/07/98 (2)
            • Have you checked out "Windows Programming for Dummies?" - Ryan Fenton 19:50:53 4/10/98 (1)
              • No I haven't, and I don't think I will need to. - AIR_TIME 02:19:08 4/20/98 (0)
    • Re: MSVC++ 5.0 / Direct X...Im new..please help me. - Brian Shea 15:38:09 4/05/98 (0)
  • Program freezes with DirectDraw - David Salsman 20:14:15 4/04/98 (1)
    • Re: Program freezes with DirectDraw - BoxMan 19:56:27 4/15/98 (0)
  • Transparent blt:ing - Andréas Kühne 12:50:38 4/04/98 (2)
    • Re: Transparent blt:ing - Selvakumar 23:26:08 6/22/98 (0)
    • Re: Transparent blt:ing - Roger 20:04:22 4/09/98 (0)
  • DX SDK!!! - The Gilb 11:26:14 4/04/98 (2)
    • Re: DX SDK!!! - Brian P. Shea 19:35:44 4/04/98 (1)
      • The SDK... - The Gilb 10:27:22 4/05/98 (0)
  • 3DFXV2 problem - Clay 10:16:20 4/04/98 (1)
    • Re: 3DFXV2 problem - nasty exceptions..... - Shai'tan 18:53:34 4/04/98 (0)
  • D3DRM Texturing!! - Shai'tan 06:42:24 4/04/98 (2)
    • Re: D3DRM Texturing!! - Jason 23:30:42 4/16/98 (1)
      • Re: D3DRM Texturing!! - Lou 09:26:00 5/16/98 (0)
  • Here is a site you can download DirectX 5.0 end-user release - Paulo Brasko Ferreira 01:00:32 4/04/98 (4)
    • Re: Here is a site you can download DirectX 5.0 end-user release - JOE 22:19:53 4/05/98 (0)
    • Re: Here is a site you can download DirectX 5.0 end-user release - Joost Brouwer 05:37:44 4/04/98 (2)
      • Re: Here is a site you can download DirectX 5.0 end-user release - nusius 16:38:08 5/31/98 (0)
      • Re: Here is a site you can download DirectX 5.0 end-user release - chet horne 09:02:08 4/09/98 (0)
  • DirectX algorithm help needed. - Konstantin Koton 23:46:02 4/03/98 (1)
    • Re: DirectPlay - god bless MS :) - Shai'tan 19:01:07 4/04/98 (0)
  • Compress wave files with directsound - Clinckart Stephane 04:17:10 4/03/98 (2)
    • Re: Compress wave files with directsound - Richard Kvalsvik ( TJ/Crusaders ) 06:53:30 4/22/98 (1)
      • Re: Compress wave files with directsound - Noel Carlos 12:23:51 5/07/98 (0)
  • Shadows - CodeX 20:56:53 4/02/98 (0)
  • Collision Detection in Direct3D RM - Christian Rahmen 12:28:48 4/02/98 (2)
    • Re: Collision Detection in Direct3D RM - Paulo Brasko 00:09:03 4/04/98 (1)
      • Re: Collision Detection in Direct3D RM - Marco Pesce 02:07:44 4/09/98 (0)
  • ARGH !!!! DIRECT SOUND 3D HATE ME !!! - dANIEL 11:54:16 4/02/98 (0)
  • How to write in DRM - Navin 05:39:54 4/02/98 (1)
    • Re: How to write in DRM - Sietze 07:40:22 4/02/98 (0)
  • Dialog Boxes/User Input - Johnny Rotten 11:56:34 4/01/98 (4)
    • Re: Dialog Boxes/User Input - Brian Shea 02:12:49 4/02/98 (3)
      • Dialog Boxes shouldn't be this hard - Johnny Rotten 12:33:12 4/02/98 (2)
        • Re: Dialog Boxes shouldn't be this hard - Brian Shea 01:27:13 4/04/98 (1)
          • Pseudo Dialog Boxes - Johnny Rotten 10:23:10 4/06/98 (0)
  • HW Blitting FIFO - dmitry sychov 10:21:32 4/01/98 (0)
  • system lockup on alt-tab when renderer video - Ben Simanek 17:22:22 3/31/98 (0)
  • i can not hear my music back!!!!!!! - wilson suarez 11:31:27 3/30/98 (0)
  • Direct Play and Visual Studio. - Greg 08:03:49 3/30/98 (0)
  • Need Direct X!! - NightFlyer 10:52:24 3/29/98 (1)
    • Re: Need Direct X!! - Nirvana 20:39:01 4/06/98 (0)
  • 3D Math Question (Or Am I Just Plain Stupid?) - Sietze 18:57:31 3/28/98 (4)
    • Hope I answered the right question! - Clay 18:43:11 3/29/98 (3)
      • Lemme add a note to that - Clay 08:01:19 3/30/98 (2)
        • thanks (I also found another way) - Sietze 10:37:19 3/30/98 (1)
          • Re: thanks (I also found another way) - Clay 11:21:30 3/30/98 (0)
  • Transparency in DirectDraw ?!!?? HELP! HELP! - Martijn Segers 11:26:30 3/28/98 (3)
    • Hope this'll help... - Sietze 04:48:47 3/31/98 (2)
      • It didn't...(HEEELP!!) - Sietze 18:04:10 4/01/98 (1)
        • Re: It didn't...(HEEELP!!) - Doc 13:13:12 5/19/98 (0)
  • uninstallation of DX5 - Chris Tough 02:51:38 3/28/98 (3)
    • Re: uninstallation of DX5 - Merlin 18:31:02 4/06/98 (0)
    • HOW TO UNISTALL ALL VERSIONS OF DIRECTX - Merlin 18:29:22 4/06/98 (0)
    • Re: uninstallation of DX5 - Serg 07:16:02 3/28/98 (0)
  • Can't get blt to work - Rob 22:46:48 3/25/98 (2)
    • Re: Can't get blt to work - Rob 22:07:28 3/26/98 (0)
    • Re: Can't get blt to work - Brian Shea 09:19:23 3/26/98 (0)
  • DirectInput Mouse Sensitivity - Matt 16:23:36 3/25/98 (1)
    • Re: DirectInput Mouse Sensitivity - Brian Shea 09:24:34 3/26/98 (0)
  • DirectInput with Keyboard. How do it? - Heinz, the bard 11:03:40 3/25/98 (0)
  • How can i use Rop in Blt - Carlos 20:01:57 3/24/98 (0)
  • DDEX2 will not compile correctly for me. - Ryan Fenton 12:54:06 3/24/98 (0)
  • Special effects - Matti Kosunen 10:23:38 3/24/98 (0)
  • How to rotate a point - Navin 09:29:38 3/24/98 (4)
    • Re: How to rotate a point - Mike Hansen 04:34:52 5/09/98 (0)
    • Re: How to rotate a point - Navin 06:43:01 3/26/98 (0)
    • Re: How to rotate a point - sss 16:10:24 3/24/98 (0)
    • Re: How to rotate a point - Serg 16:08:13 3/24/98 (0)
  • Performance II - Stiba 15:09:42 3/23/98 (1)
    • Re: Performance II - Clay 20:15:13 3/23/98 (0)
  • Help with Vertex Coloring - Mark Palange 17:53:57 3/22/98 (0)
  • Performance problem - Stiba 15:51:12 3/22/98 (0)
  • Retained Mode, MFC and Fullscreen ?? - Michael Lacher 09:42:32 3/21/98 (1)
    • Re: Retained Mode, MFC and Fullscreen ?? - Frank Lomabard 13:58:19 3/21/98 (0)
  • RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!) - Sietze 08:47:11 3/21/98 (3)
    • Re: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!) - Clay 07:55:51 3/26/98 (2)
      • Re: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!) - Sietze 10:45:07 3/30/98 (1)
        • Re: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!) - Clay 11:31:20 3/30/98 (0)
  • Traversing frame heirakies of animationsets - Lee Sandberg 06:50:14 3/21/98 (1)
    • Re: Traversing frame heirakies of animationsets - Lee Sandberg 10:54:31 3/22/98 (0)
  • [Help] simple DirectDraw program - Chendi Zhang 12:23:36 3/20/98 (0)
  • How do I get the 'C' samples with winmain to compile as win32 projects? - Ryan Fenton 12:54:50 3/19/98 (4)
    • Re: How do I get the 'C' samples with winmain to compile as win32 projects? - Clay 20:20:51 3/19/98 (3)
      • Darn that's just what I was trying to avoid! Oh well. - Ryan Fenton 23:45:37 3/19/98 (2)
        • Re: Darn that's just what I was trying to avoid! Oh well. - Clay 07:05:01 3/20/98 (1)
          • Thanks, perhaps I should think of compiling something else. - Ryan Fenton 12:52:55 3/20/98 (0)
  • Directx driver for opti930 sound card - Scott 19:46:24 3/18/98 (0)
  • Alpha Vertices - Wolfgang Rössler 12:46:34 3/18/98 (0)
  • D3D in Desktop Window? - Andre Hinkenjann 12:07:00 3/18/98 (2)
    • Re: D3D in Desktop Window? - Clay 17:55:21 3/18/98 (1)
      • Re: D3D in Desktop Window? - Voisin 07:57:23 3/25/98 (0)
  • DirectX & Dialogs - Janne Makela 15:10:51 3/17/98 (2)
    • Re: DirectX & Dialogs - Ludovic Tirtiaux 04:53:01 3/18/98 (0)
    • Re: DirectX & Dialogs - Greg MacKay 03:43:38 3/18/98 (0)
  • IDirect3DRMFrame2::Save() - Clay 07:36:51 3/17/98 (3)
    • Re: IDirect3DRMFrame2::Save() - Ron Bakker 17:00:35 3/17/98 (2)
      • Re: IDirect3DRMFrame2::Save() - menachem 21:29:54 3/17/98 (0)
      • Re: IDirect3DRMFrame2::Save() - menachem 21:27:16 3/17/98 (0)
  • Using DirectPlay -- how to specify a PORT - Derrick Schommer 04:12:22 3/17/98 (2)
    • Re: Using DirectPlay -- how to specify a PORT - Jimbo Bob Briggs 10:07:40 3/17/98 (1)
      • Re: Using DirectPlay -- how to specify a PORT - Derrick Schommer 00:51:51 3/18/98 (0)
  • Does D.X.5 go to WinNT 4.0?? - CrackHacker 16:12:43 3/16/98 (2)
    • Re: Does D.X.5 go to WinNT 4.0?? - Clay 18:44:05 3/16/98 (1)
      • Re: Does D.X.5 go to WinNT 4.0?? - Sean 09:35:25 4/08/98 (0)
  • D3DRM in fullscreen? - Niklas Elmqvist 14:21:49 3/16/98 (2)
    • Re: D3DRM in fullscreen? - Lou 09:33:21 5/16/98 (0)
    • Re: D3DRM in fullscreen? - Sietze 08:19:12 3/21/98 (0)
  • DirectX Type files for VB - Erik 11:39:15 3/16/98 (1)
    • Re: DirectX Type files for VB - Sietze 08:22:22 3/21/98 (0)
  • DirectDraw - Getcaps init problem?? - Albert Koelmans 06:26:30 3/16/98 (1)
    • Re: DirectDraw - Getcaps init problem?? - Clay 07:41:16 3/16/98 (0)
  • DirectX mutes Presario 2120 - Rey Rito 00:24:46 3/16/98 (2)
    • Re: DirectX mutes Presario 2120 - V.L. smith 10:18:19 6/28/98 (0)
    • Re: DirectX mutes Presario 2120 - EvAcLeAr 05:14:59 4/05/98 (0)
  • Can someone suggest a Win32 Programming Reference? - Todd Ogrin 12:38:41 3/15/98 (2)
    • Re: Can someone suggest a Win32 Programming Reference? - Sean 01:59:40 3/16/98 (1)
      • Re: DirectX and MFC - Robert Tomliin 06:36:04 4/09/98 (0)
  • Help!!!DirectX Linked List Programming..... - Yoon 06:38:51 3/15/98 (1)
    • Re: Help!!!DirectX Linked List Programming..... - Niklas Elmqvist 06:33:44 3/17/98 (0)
  • Somebody with a fast connection... - Jean-Sebastien Payette 00:51:35 3/15/98 (0)
  • Random (rand()) stinks, need help - Hank Lee 19:59:21 3/14/98 (4)
    • Re: Random (rand()) stinks, need help - Sean 03:43:51 3/15/98 (0)
    • Re: Random (rand()) stinks, need help - Roger 20:24:50 3/14/98 (2)
      • seeding - Hank Lee 22:57:40 3/14/98 (1)
        • Re: seeding - Ryan Geiss 14:38:06 3/26/98 (0)
  • Can't have the DX 5 SDK anymore - Jean-Sebastien Payette 15:57:19 3/14/98 (0)
  • Blitting a Sprite as a Different Color - John Sabean 11:48:35 3/14/98 (2)
    • Perhaps a custom blit with an altered transparancy code. (NT) - Ryan Fenton 23:55:47 3/26/98 (0)
    • Re: Blitting a Sprite as a Different Color - Johnny Rotten 10:15:44 3/18/98 (0)
  • Looking for someone with a fast internet connection. - Bueller 11:02:56 3/14/98 (0)
  • Direct3D RM v5.0 - Russell Wild 04:07:05 3/14/98 (0)
  • directdraw, help!!!!!!!!!!!!!!!!!!!!!!!! - mike 02:24:31 3/14/98 (0)
  • dx5eng can't play MPEG sound clips - Peter Brunovsky 01:24:31 3/14/98 (0)
  • Loading Textures - Frank 01:12:19 3/14/98 (1)
    • Re: Loading Textures - Lou 08:24:33 5/16/98 (0)
  • PLEASE HELP! ddraw question - Romalis 22:49:52 3/13/98 (1)
    • Re: PLEASE HELP! ddraw question - Johnny Rotten 10:24:11 3/18/98 (0)
  • dxsetup not registering diamond viper 330 video card - Bob Shultz 15:40:52 3/13/98 (1)
    • Re: dxsetup not registering diamond viper 330 video card - joe manning 17:52:28 9/19/98 (0)
  • DirectX 5.0 SDK cannot be downloaded anymore - cObBiE 15:36:14 3/13/98 (23)
    • Re: DirectX 5.0 SDK cannot be downloaded anymore - Chad 16:16:09 3/27/98 (0)
    • Re: DirectX 5.0 SDK cannot be downloaded anymore - Mehrab 15:12:59 3/14/98 (19)
      • Re: DirectX 5.0 SDK cannot be downloaded anymore - hpayne BERT PAYNE 01:16:05 9/02/98 (0)
      • Re: DirectX 5.0 SDK cannot be downloaded anymore - camp bug 11:14:00 6/04/98 (0)
      • Re: DirectX 5.0 SDK cannot be downloaded anymore - camp bug 11:12:05 6/04/98 (0)
      • DirectX 5.0 Download - Mehrab 15:14:04 3/14/98 (15)
        • Re: DirectX 5.0 Download - jhony 02:36:53 6/07/98 (0)
        • Re: This is the URL to get Direct X 5.2 - Bigstar2001 01:47:00 6/05/98 (0)
        • Re: DirectX 5.0 Download - suhaimi 08:46:54 6/03/98 (1)
          • Re: DirectX 5.0 Download - jean sims 21:55:28 9/27/98 (0)
        • Re: DirectX 5.0 Download - Thomas Sah 10:02:44 3/28/98 (0)
        • Re: DirectX 5.0 Download - Dani Llenas (FacOne) 16:09:59 3/18/98 (2)
          • Re: DirectX 5.0 Download - Joe 12:40:16 4/15/98 (0)
          • Re: DirectX 5.0 Download - Jorgen olesen 11:39:42 3/31/98 (0)
        • Re: DirectX 5.0 Download - Ricardo Balam 15:24:03 3/15/98 (6)
          • Re: DirectX 5.0 Download - Lucas 08:41:21 3/16/98 (3)
            • Re: DirectX 5.0 Download - mike poliszuk 23:26:25 9/18/98 (0)
            • Re: DirectX 5.0 Download - j.boschert 09:52:19 3/18/98 (1)
              • Re: DirectX 5.0 Download - ddc; 05:22:42 9/11/98 (0)
          • Re: DirectX 5.0 Download - James Hurdle 20:10:44 3/15/98 (1)
            • Re: DirectX 5.0 Download - Ahmad Emad 21:15:31 5/29/98 (0)
    • Re: DirectX 5.0 SDK cannot be downloaded anymore - John Sabean 11:51:17 3/14/98 (1)
      • Re: DirectX 5.0 SDK cannot be downloaded anymore - Dinh Ba 11:30:24 3/25/98 (0)
  • ddraw question - Romalis 12:04:43 3/13/98 (5)
    • Re: ddraw question - Brian Shea 12:32:39 3/13/98 (4)
      • Re: ddraw question - Ron 13:55:04 3/13/98 (3)
        • Re: ddraw question - Brian Shea 15:38:15 3/16/98 (0)
        • Re: ddraw question - Clay 08:39:45 3/14/98 (1)
          • Re: ddraw question - BoxMan 20:21:06 4/15/98 (0)
  • DirectX/OpenGL - James Simpson 07:29:11 3/13/98 (1)
    • Re: DirectX/OpenGL - Clay 08:43:45 3/14/98 (0)
    • I think the FAQ link is broken. (NT) - Ryan Fenton 21:23:51 3/12/98 (0)
    • windows protection error on restart - William E. Irving 10:40:10 3/12/98 (0)
    • getting dx5 games to work under nt4 - John Evans 10:21:37 3/12/98 (0)
    • Shadows with Immediate Mode - Wolfgang Rössler 06:08:46 3/12/98 (1)
      • Re: Shadows with Immediate Mode - Clay 07:39:08 3/12/98 (0)
    • How to Display Multiple Overlay Surfaces - He jiangang 04:43:30 3/12/98 (0)
    • Animation Data question. - Zerg 02:20:32 3/12/98 (0)
    • Help point a newbie(me) to greater awareness.(please) - Ryan Fenton 20:34:51 3/11/98 (7)
      • Re: Help point a newbie(me) to greater awareness.(please) - Clay 22:29:48 3/11/98 (6)
        • Thanks a lot! I'm still going to have a long way to go! - Ryan Fenton 10:45:11 3/12/98 (5)
          • How to learn - Memet Bilgin 15:02:20 3/12/98 (4)
            • My current mad schemes. - Ryan Fenton 16:56:47 3/12/98 (3)
              • You also might want to check out... - Jay Atkinson 13:24:50 3/18/98 (2)
                • Hey, thanks, a definite "Will-do!" - Ryan Fenton 22:09:23 3/18/98 (1)
                  • Re: Hey, thanks, a definite "Will-do!" - Johnny Rotten 10:17:38 3/19/98 (0)
    • How to play avi files?? - Seether Dragon 20:19:26 3/11/98 (0)
    • D3DRM::CreateTextureFromSurface - Fran Avilés 19:44:40 3/11/98 (0)
    • free porn - larry 19:37:56 3/11/98 (1)
      • Re: free porn - Larrys Cunt 19:22:53 3/14/98 (0)
    • Pixel Format Question - Joe Chang 14:47:23 3/11/98 (0)
    • Link error - Navin 07:45:49 3/11/98 (1)
      • Re: Link error - Dallas Nutsch 18:20:52 3/11/98 (0)
    • Shadows with Immediate Mode - Wolfgang Rössler 06:22:21 3/11/98 (0)
    • How do I use MFC Document/view and Direct3D? - Christoffer Schrøder 15:58:09 3/09/98 (4)
      • Re: How do I use MFC Document/view and Direct3D? - Brian Shea 05:50:21 3/11/98 (1)
        • Re: How do I use MFC Document/view and Direct3D? - Brian Shea 05:52:16 3/11/98 (0)
      • Re: How do I use MFC Document/view and Direct3D? - Serg 17:04:26 3/10/98 (1)
        • Re: How do I use MFC Document/view and Direct3D? - Navin 04:37:17 3/11/98 (0)
    • Using DirectShow to capture video in a worker thread - Howard Lin 12:38:05 3/09/98 (0)
    • Differences between Conv3ds in DX3 and DX5 - Fran Avilés 18:02:37 3/08/98 (0)
    • Using bmp textures - Fran Avilés 18:00:15 3/08/98 (0)
    • RayPick Question - Josh Weier 21:45:34 3/07/98 (1)
      • Re: RayPick Question - Clay 07:46:03 3/12/98 (0)
    • DirectSound and Edson's Article - A. Laska 14:49:49 3/07/98 (1)
      • Re: DirectSound and Edson's Article - Brian Shea 14:38:53 3/09/98 (0)
    • ? - Asim Demirag 06:26:08 3/07/98 (1)
      • Re: ? - Johnny Rotten 10:30:18 3/09/98 (0)
    • Mouse handling - Matti Kosunen 17:27:53 3/06/98 (2)
      • Re: Mouse handling - Brian Shea 14:36:46 3/09/98 (1)
        • Re: Mouse handling - Clay 07:50:57 3/12/98 (0)
    • D3D, transparency and D3DFILTER_LINEAR - Joe Chang 15:36:40 3/06/98 (0)
    • Panzer General 2, DirectX 5 and NT4.0 - Pete Smith 06:34:41 3/06/98 (0)
    • HOW CAN I USE ALPHA WITH DIRECT DRAW - Steibl Andreas 22:18:18 3/05/98 (0)
    • NEED HELP! - Matti Kosunen 16:00:16 3/05/98 (2)
      • Re: NEED HELP! - Cristían Tornería 14:45:58 4/16/98 (0)
      • Re: NEED HELP! - Serg 08:07:24 3/07/98 (0)
    • DirectX and AppWizard? - Todd Ogrin 14:09:40 3/05/98 (1)
      • Re: DirectX and AppWizard? - Rainer M. Domingo 03:12:25 3/08/98 (0)
    • D3D 5 immediate mode (D3DVERTEX) - Matti Kosunen 12:04:18 3/05/98 (3)
      • Re: D3D 5 immediate mode (D3DVERTEX) - Serg 15:58:18 3/05/98 (2)
        • Re: D3D 5 immediate mode (D3DVERTEX) - Matti Kosunen 16:03:14 3/05/98 (1)
          • Re: D3D 5 immediate mode (D3DVERTEX) - Serg 08:01:53 3/07/98 (0)
    • I get missing decl-spec from dsound.h...how can that be? - Jacques 02:36:57 3/05/98 (6)
      • Re: I get missing decl-spec from dsound.h...how can that be? - A. Laska 18:43:47 3/08/98 (0)
      • Re: I get missing decl-spec from dsound.h...how can that be? - Brian Shea 12:26:58 3/05/98 (3)
        • Re: I get missing decl-spec from dsound.h...how can that be? - Brian Shea 12:29:48 3/05/98 (2)
          • Re: I get missing decl-spec from dsound.h...how can that be? - Brian Shea 12:32:24 3/05/98 (1)
            • Re: I get missing decl-spec from dsound.h...how can that be? - Jacques 12:49:10 3/13/98 (0)
      • Re: I get missing decl-spec from dsound.h...how can that be? - Brian Shea 12:26:10 3/05/98 (0)
    • help running DX w/ STB Velocity128 - John J 02:33:15 3/05/98 (2)
      • Re: help running DX w/ STB Velocity128 - Joe Drago 13:15:55 3/18/98 (0)
      • Re: help running DX w/ STB Velocity128 - Brian Shea 12:24:07 3/05/98 (0)
    • Using a color mouse cursor in directx 5 ??? - Alex Alvarez 23:51:40 3/04/98 (2)
      • Re: Using a color mouse cursor in directx 5 ??? - Johnny Rotten 10:13:42 3/05/98 (1)
        • Re: Using a color mouse cursor in directx 5 ??? - Alex Alvarez 20:36:29 3/14/98 (0)
    • How can I speed up 16bpp mode..? - Aleks Kozyrev 17:59:30 3/04/98 (1)
      • Re: How can I speed up 16bpp mode..? - Brian Shea 12:20:45 3/05/98 (0)
    • DirectSound with Borland Builder - Marc 17:58:33 3/04/98 (0)
    • DirectX wont reload video drivers - Tom Walko 10:00:12 3/04/98 (1)
      • Re: DirectX wont reload video drivers - Jim Scharf 06:24:55 3/05/98 (0)
    • Texture and Graphic Card - Dorian Averbuh 08:36:27 3/04/98 (0)
    • DirectX AppWizards? (corrected) - Jason Millard 21:56:25 3/03/98 (2)
      • URL address - Rainer M. Domingo 03:20:38 3/08/98 (0)
      • Re: DirectX AppWizards? (corrected) - Rainer M. Domingo 03:18:51 3/08/98 (0)
    • DirectX AppWizards? - Jason Millard 21:55:00 3/03/98 (0)
    • MeshBuilder problems - Eugene Polonsky 20:57:35 3/03/98 (1)
      • Re: MeshBuilder problems - Lou 09:42:02 5/16/98 (0)
    • fatal exceptions - MARK 08:53:45 3/03/98 (1)
      • Re: fatal exceptions - Eugene polonsky 20:59:52 3/03/98 (0)
    • The x file format - Navin 05:31:28 3/03/98 (1)
      • Re: The x file format - Eugene Polonsky 21:03:28 3/03/98 (0)
    • Drawing to directly to directx surface memory - Daniel Moss 16:48:03 2/26/98 (2)
      • Re: Drawing to directly to directx surface memory - Martin Rystrand 03:16:41 2/27/98 (0)
      • Re: Drawing to directly to directx surface memory - Johnny Rotten 17:54:35 2/26/98 (0)
    • How do i do collision detection in d3d RM ???? - Shanat Krishnamurti 13:56:42 2/26/98 (1)
      • Re: How do i do collision detection in d3d RM ???? - Eugene Polonsky 21:05:08 3/03/98 (0)
    • Blur-Motion with DirectX5 - Wolfgang Rössler 08:58:54 2/26/98 (3)
      • Re: Blur-Motion with DirectX5 - ÇÏ±¤¼® 09:05:09 2/26/98 (2)
        • Re: Blur-Motion with DirectX5 - morten 12:19:41 3/12/98 (0)
        • Re: Blur-Motion with DirectX5 - Rick Huang 05:22:08 3/11/98 (0)
    • Delphi and DirectX - Frank 00:22:39 2/26/98 (0)
    • Symantec C++ 7.5 and DirectX 5 - Dean Kusler 22:38:47 2/25/98 (3)
      • Re: Symantec C++ 7.5 and DirectX 5 - info 14:44:17 3/22/98 (0)
      • Re: Symantec C++ 7.5 and DirectX 5 - Tommy Kreska 20:12:16 3/03/98 (0)
      • Re: Symantec C++ 7.5 and DirectX 5 - Brian Shea 09:12:51 2/26/98 (0)
    • Alpha-blending decals in Retained Mode - Larry Weinstein 21:31:56 2/25/98 (5)
      • Re: Alpha-blending decals in Retained Mode - Brian Shea 09:11:02 2/26/98 (4)
        • Re: Alpha-blending decals in Retained Mode - Roger 20:26:52 2/26/98 (3)
          • Late Re: Alpha-blending decals in Retained Mode - Mr Moo 15:48:06 4/22/98 (2)
            • Re: Late Re: Alpha-blending decals in Retained Mode - boller 02:44:07 9/03/98 (1)
              • Re: Late Re: Alpha-blending decals in Retained Mode - Tim Brubaker 22:24:35 9/09/98 (0)
    • Converting to .x format - Christoffer Schrøder 16:42:37 2/25/98 (0)
    • consulting job availble in DirectX - mike Feng 10:40:02 2/25/98 (0)
    • exception 10h hhhhelp - Sean Plumb 02:00:05 2/25/98 (0)
    • Anybody knows when its comming Directx6 - Seether Dragon 22:02:00 2/24/98 (1)
      • Re: Anybody knows when its comming Directx6 - Dorian Averbuh 07:46:32 3/04/98 (0)
    • How to read audio in Async Mode? - Alberto Cobre 18:40:40 2/24/98 (1)
      • Re: How to read audio in Async Mode? - Brian Shea 09:08:29 2/26/98 (0)
    • Creating Multiple Instances of an Object - Bill Torla 20:01:35 2/23/98 (1)
      • Re: Creating Multiple Instances of an Object - Lee Sandberg 08:29:49 3/27/98 (0)
    • Direct x workshop - M. Hotrum 15:45:42 2/23/98 (0)
    • Help me please, somebody - George Lingèr 10:26:26 2/23/98 (2)
      • How can I make a simple game? - Joshua Ripley 20:19:20 2/24/98 (1)
        • Re: How can I make a simple game? - Johnny Rotten 13:28:50 2/25/98 (0)
    • ring buffer with direct draw - Eric 09:59:22 2/23/98 (0)
    • D3DRM: How to pick an object which is half in the viewport? - Ron Bakker 03:33:37 2/23/98 (0)
    • Direct X 5.0 and sound card - James Kong 00:31:05 2/23/98 (1)
      • Re: Direct X 5.0 and sound card - HAHAHA 09:36:22 2/25/98 (0)
    • Picking at texture level - Josh Weier 21:56:21 2/22/98 (1)
      • Re: Picking at texture level - Chao Yu 11:47:21 2/24/98 (0)
    • build sphere and texture map the interior of spher - Toong See Wan 17:55:27 2/22/98 (0)
    • IM - lighting - Shane Clark 12:55:12 2/22/98 (3)
      • Re: IM - lighting - Serg 16:28:16 2/23/98 (2)
        • Re: IM - lighting - Shane Clark 14:30:59 2/24/98 (0)
        • Re: IM - lighting - Shane Clark 14:30:33 2/24/98 (0)
    • Borlan's C++ Builder - Henry G. 17:24:16 2/21/98 (1)
      • Just wondering - kytel 01:12:55 2/22/98 (0)
    • About C++ Builder - Weng 20:54:28 2/20/98 (1)
      • About C++ Builder - Weng 20:56:04 2/20/98 (0)
    • Thread stopped... error - Johnny Rotten 15:48:38 2/20/98 (0)
    • need multiple texture sample or getting it to work on one mesh!!!! - Robert 12:54:21 2/20/98 (0)
    • Overlay Surface Support - He jiangang 04:02:25 2/20/98 (1)
      • Re: Overlay Surface Support - Michael Czybor 19:40:23 2/25/98 (0)
    • Direct3D: Load 2 or more animated objects from same .x file - Chris McCanna 00:17:17 2/20/98 (1)
      • Re: Direct3D: Load 2 or more animated objects from same .x file - Sean Barton 22:08:25 2/20/98 (0)
    • Direct Draw Error ? - John 17:59:03 2/19/98 (2)
      • Re: Direct Draw Error ? - John Giors 00:51:24 2/20/98 (1)
        • Re: Direct Draw Error ? - John 01:11:35 2/20/98 (0)
    • How can I use Direct3D in Delphi - Delphi Lover 06:06:36 2/19/98 (0)
    • libcd.lib(crt0.obj) error LNK2001: unresolved external symbol _main - Fuzzy Bunny 19:09:46 2/18/98 (2)
      • Re: libcd.lib(crt0.obj) error LNK2001: unresolved external symbol _main - Brian Shea 16:47:32 2/19/98 (0)
      • Re: libcd.lib(crt0.obj) error LNK2001: unresolved external symbol _main - fuzzy bunny 19:18:14 2/18/98 (0)
    • D3D texture load - Spika 17:50:12 2/18/98 (0)
    • D3D texture load - Spika 17:44:56 2/18/98 (0)
    • D3D texture load - Spika 17:36:51 2/18/98 (0)
    • D3D texture load - Spika 17:30:36 2/18/98 (0)
    • D3D texture load - Spika 17:27:15 2/18/98 (0)
    • D3D texture load - Spika 17:23:57 2/18/98 (0)
    • D3D texture load - Spika 17:19:43 2/18/98 (0)
    • WebStealth's DirectX Development Page - Rainer M. Domingo 13:52:08 2/18/98 (0)
    • Borland C++ 5.0 and Direct Input - Johnny Rotten 23:49:55 2/17/98 (2)
      • Re: Borland C++ 5.0 and Direct Input - Mocihi Seya 00:10:20 2/18/98 (1)
        • That helps, but..... - Johnny Rotten 00:11:03 2/19/98 (0)
    • 3D Drawing Software for D3D - Larry Weinstein 21:17:56 2/17/98 (1)
      • Re: 3D Drawing Software for D3D - Sean Barton 13:20:34 2/19/98 (0)
    • Miro Media Online and Directx 5.0 - Andreas 16:19:36 2/17/98 (0)
    • DirectX5 - Lois Nicholls 16:15:39 2/17/98 (15)
      • Re: DirectX5 - eduard 16:59:13 9/17/98 (0)
      • Re: DirectX5 - William 09:06:31 9/10/98 (0)
      • Re: DirectX5 - ziv 06:21:01 6/11/98 (0)
      • Re: DirectX5 - warren goodman 05:26:15 6/07/98 (0)
      • Re: DirectX5 - serge poirier 22:09:24 2/19/98 (7)
        • Re: DirectX5 - head hunter 05:33:46 6/03/98 (1)
          • Re: DirectX5 - Ratchet 15:38:41 9/13/98 (0)
        • directx5 needed for download - THOMAS KURT 09:13:58 3/24/98 (3)
          • Re: directx5 needed for download - mohd amri 19:35:30 9/26/98 (0)
          • Re: directx5 needed for download - Matthew Broyles 19:22:06 6/11/98 (0)
          • Re: directx5 needed for download - Leon Martin 13:48:53 6/06/98 (0)
        • Re: DirectX5 - nuno 19:11:41 3/20/98 (0)
      • Re: DirectX5 - serge poirier 22:07:28 2/19/98 (2)
        • Re: DirectX5 - ZAMIR FAQIRYAR 21:54:57 6/18/98 (0)
        • Re: DirectX5 - U Myint Oo 00:31:16 2/26/98 (0)
    • DirectPlay and MM100PCTV card - Keith Crilly 08:59:38 2/17/98 (1)
      • Re: DirectPlay and MM100PCTV card - Keith Crilly 04:45:02 2/18/98 (0)
    • what's the safe way to uninstall directX 5 - chau kwok 02:36:39 2/17/98 (0)
    • Directx 5.0 - Jason Haley 20:44:13 2/16/98 (0)
    • How do you set up a direct draw surface so that OpenGl can render to it? - Thomas Mauer 21:09:51 2/15/98 (0)
    • DIRECTX 5.0 - BRIAN 19:12:09 2/15/98 (0)
    • DIRECTX 5.0 - BRIAN 19:11:02 2/15/98 (0)
    • Desktop ZX - DirectX desktop software - Rainer M. Domingo 12:09:58 2/15/98 (0)
    • How do i work with DIRECTX SDK 5 with VC++ ver 1.0? - Roni Winik 13:41:12 2/14/98 (1)
      • Re: How do i work with DIRECTX SDK 5 with VC++ ver 1.0? - kalrithian 20:52:21 2/22/98 (0)
    • Helping me to playing FIFA98 fast - Wirawan Salim 08:50:03 2/14/98 (0)
    • Helping me to playing FIFA98 fast - Wirawan Salim 08:46:45 2/14/98 (0)
    • Help with optimizations - Johnny Wood 01:48:03 2/14/98 (2)
      • Re: Help with optimizations - Nick Caldwell 12:55:58 2/16/98 (0)
      • Re: Help with optimizations - Sean Barton 03:35:51 2/14/98 (0)
    • Porting MS-DOS 3d Engine to DirectX - Daniel Mori 18:11:27 2/13/98 (1)
      • Re: Porting MS-DOS 3d Engine to DirectX - Sean Barton 19:46:21 2/13/98 (0)
    • Texturemaps loaded with IDirect3DRM::Load() not visible - John Giors 02:14:27 2/13/98 (1)
      • Re: Texturemaps loaded with IDirect3DRM::Load() not visible - Fran Avilés 19:41:48 3/11/98 (0)
    • Help with LPDIRECT3DRMFACE::GetVertices() - Sean Barton 15:08:27 2/12/98 (0)
    • NT 4.0 ? - Steve Jones 14:06:40 2/12/98 (1)
      • Re: NT 4.0 ? - Brian Shea 14:09:32 2/12/98 (0)
    • HELP! I'll do anything for help with DirectPlay - Johnny Wood 10:57:19 2/12/98 (1)
      • Nevermind... - Johnny Wood 12:34:57 2/13/98 (0)
    • How to make .x file for Direct3D - William Chan 21:59:27 2/11/98 (0)
    • Direct memory access in DirectDraw - Nick Pleis 15:59:14 2/10/98 (2)
      • Re: Direct memory access in DirectDraw - Brian Shea 08:08:10 2/11/98 (1)
        • Re: Direct memory access in DirectDraw - Brian Shea 08:12:56 2/11/98 (0)
    • I know where you can download DIRECTX 5.0 !!!! - Luiz Guilherme Krause de Salles 15:21:57 2/10/98 (4)
      • Re: I know where you can download DIRECTX 5.0 !!!! - joe 18:13:47 9/02/98 (0)
      • Re: I know where you can download DIRECTX 5.0 !!!! - kmc 22:31:09 5/29/98 (0)
      • Why can't I decompress the SDK??? - Shaofei 01:32:05 2/12/98 (0)
      • Re: I know where you can download DIRECTX 5.0 !!!! - rick 21:58:03 2/10/98 (0)
    • This DirectX 5.0 is a complete fuck!!!!! - Alberto Danilo 23:04:08 2/09/98 (5)
      • Re: This DirectX 5.0 is a complete fuck!!!!! - William E. Irving 09:25:42 3/12/98 (0)
      • Re: This DirectX 5.0 is a complete fuck!!!!! - Jim Lister 16:32:47 3/11/98 (0)
      • Re: This DirectX 5.0 is a complete fuck!!!!! - Brian Shea 10:16:25 2/10/98 (1)
        • Re: This DirectX 5.0 is a complete fuck!!!!! - john 01:24:01 2/24/98 (0)
      • Re: This DirectX 5.0 is a complete fuck!!!!! - hey stupid! 01:46:31 2/10/98 (0)
    • How do you have a Direct3D scene rendered with null pasting? - Stumped 23:00:52 2/09/98 (1)
      • Re: How do you have a Direct3D scene rendered with null pasting? - Brian Shea 10:13:29 2/10/98 (0)
    • Need help with Direct X - Jeff Linder 22:52:37 2/09/98 (1)
      • Re: Need help with Direct X - Brian Shea 10:10:23 2/10/98 (0)
    • Switching Resolution - Rodney Smith 21:41:47 2/09/98 (1)
      • Re: Switching Resolution - Brian Shea 10:19:07 2/10/98 (0)
    • RM Texture Problem - Larry 20:00:23 2/09/98 (0)
    • DirectX Audio Driver - Jennifer 18:45:08 2/09/98 (2)
      • Re: DirectX Audio Driver - John 23:03:22 2/09/98 (1)
        • Re: dx5eng - Peter Brunovsky 01:10:42 3/14/98 (0)
    • About mailling list - Chen Shen 06:20:04 2/09/98 (1)
      • Re: About mailling list - Brian Shea 09:41:44 2/09/98 (0)
    • JAMES! Where are you? DirectX book reply - Sean Barton 00:54:42 2/09/98 (0)
    • Debug Directx 5.0 with BC++ 5.0 or MSVC++ 5.0 - Paulo Egidio 16:49:19 2/08/98 (1)
      • Re: Debug Directx 5.0 with BC++ 5.0 or MSVC++ 5.0 - Brian Shea 09:40:07 2/09/98 (0)
    • About DDER_NOEXCLUSIVE - Chen Shen 02:29:31 2/08/98 (4)
      • Re: About DDER_NOEXCLUSIVE - David Salsman 21:40:14 4/04/98 (0)
      • Re: About DDER_NOEXCLUSIVE - Brian Shea 09:35:28 2/09/98 (2)
        • Re: About DDER_NOEXCLUSIVE - Chen Shen 04:54:05 2/11/98 (1)
          • Re: About DDER_NOEXCLUSIVE - Brian Shea 14:13:21 2/12/98 (0)
    • Can't get DirectSound to link - James 17:17:04 2/07/98 (5)
      • Re: Can't get DirectSound to link - jason lucking 10:35:58 6/16/98 (0)
      • Re: Can't get DirectSound to link - jason lucking 10:35:56 6/16/98 (0)
      • Re: Can't get DirectSound to link - KayPeng 03:52:53 2/17/98 (0)
      • Re: Can't get DirectSound to link - Sean Barton 00:50:59 2/09/98 (0)
      • Re: Can't get DirectSound to link - Sean Barton 00:50:05 2/09/98 (0)
    • About reference count - Chen Shen 00:45:32 2/07/98 (2)
      • Re: About reference count - Brian Shea 09:37:48 2/09/98 (1)
        • Re: About reference count - Chen Shen 05:01:35 2/11/98 (0)
    • where can I download direct X 5.0 - Yves Lavoie 23:01:14 2/06/98 (19)
      • Re: where can I download direct X 5.0 - IP Freely 13:14:13 7/29/98 (0)
      • Re: where can I download direct X 5.0 - asdfasdf 15:14:01 7/24/98 (1)
        • Re: where can I download direct X 5.0 - Carlos 14:47:31 7/27/98 (0)
      • Where Can I Download DirectX 5.0? I need it for Microsoft Flight Simulator 98 - KB 06:37:59 7/23/98 (0)
      • Re: where can I download direct X 5.0 - Luke Halley 19:55:50 7/20/98 (0)
      • Re: where can I download direct X 5.0 - steve 14:12:08 7/16/98 (2)
        • Re: where can I download direct X 5.0 - gui 17:30:25 7/18/98 (1)
          • Re: where can I download direct X 5.0 - Gui 3954882 17:32:56 7/18/98 (0)
      • Re: where can I download direct X 5.0 - jeff1 08:44:34 7/09/98 (0)
      • Re: where can I download direct X 5.0 - Brian Parsons 14:06:47 2/15/98 (0)
      • Re: where can I download direct X 5.0 - marc grace 14:26:45 2/08/98 (1)
        • Re: where can I download direct X 5.0 - john grace 14:28:14 2/08/98 (0)
      • Re: where can I download direct X 5.0 - cheng 11:31:51 2/07/98 (3)
        • Re: where can I download direct X 5.0 - Gunyruss 23:20:14 6/15/98 (0)
        • Re: where can I download direct X 5.0 - saiyan2000 23:30:22 6/06/98 (0)
        • Re: where can I download direct X 5.0 - Cheng 11:35:54 2/07/98 (0)
      • Re: where can I download direct X 5.0 - cheng 11:31:34 2/07/98 (1)
        • Re: where can I download direct X 5.0 - fgfg 14:29:27 2/08/98 (0)
      • Re: where can I download direct X 5.0 - Roni 10:20:58 2/07/98 (0)
    • Do visual c++ ver 1.0 works on directx 5.0? - roni 14:44:02 2/06/98 (0)
    • "hello World" from tutorials with teapot.x - J Treeby 08:52:48 2/06/98 (0)
    • "hello World" from tutorials with teapot.x - J Treeby 08:44:56 2/06/98 (0)
    • about coordinate - Chen Shen 02:57:50 2/06/98 (2)
      • Re: about coordinate - Sean Barton 03:54:34 2/06/98 (1)
        • Re: about coordinate - Chen Shen 00:39:28 2/07/98 (0)
    • Animating imported animations with AnimationSet - Bradley Elfman 19:46:56 2/05/98 (1)
      • Re: Animating imported animations with AnimationSet - Bill Torla 22:21:15 2/13/98 (0)
    • Uninstallation of DirectX version 4 - Keith Kelchner 18:12:47 2/05/98 (0)
    • Retained Mode or Immediate Mode - Snailslug 17:39:18 2/05/98 (1)
      • Re: Retained Mode or Immediate Mode - Sean Barton 23:30:11 2/05/98 (0)
    • DirectX and OpenGL - Umut Demirhan 16:19:13 2/04/98 (3)
      • Re: DirectX and OpenGL - Dan Holland 18:19:00 2/27/98 (0)
      • Re: DirectX and OpenGL - Sean Barton 00:40:31 2/05/98 (1)
        • Re: DirectX and OpenGL - Andy Sy 09:39:01 2/05/98 (0)
    • Reading from the Primary DirectSoundBuffer - Jeff Lee 15:08:12 2/04/98 (0)
    • scrolling - Serge Roy 22:04:09 2/03/98 (2)
      • Re: scrolling - Brian Shea 10:49:00 2/04/98 (0)
      • Re: scrolling - Sean Barton 23:05:00 2/03/98 (0)
    • getting hooked up w/ directx - tommy 17:31:23 2/03/98 (2)
      • Re: getting hooked up w/ directx - Juanita Garcia 23:51:26 6/29/98 (0)
      • Re: getting hooked up w/ directx - Brian Shea 10:46:05 2/04/98 (0)
    • MAY-DAY//MAY-DAY//MAY-DAY//NEED HELP W/CODE - Roddy ARnold 21:35:11 2/02/98 (1)
      • Re: MAY-DAY//MAY-DAY//MAY-DAY//NEED HELP W/CODE - Brian Shea 11:43:15 2/03/98 (0)
    • HElp with Directsound - Pas 13:03:59 2/02/98 (1)
      • Re: HElp with Directsound - Brian Shea 14:22:04 2/02/98 (0)
    • Disabling Alt-Tab and the Win95 key - Gary Huff 12:31:19 2/02/98 (1)
      • Re: Disabling Alt-Tab and the Win95 key - Brian Shea 14:30:20 2/02/98 (0)
    • I need help with guestbook signers... - Mike Kerr 13:58:18 2/01/98 (0)
    • Clippers, cliplists, how? - Senior Project Group (PLANEFUN) 20:03:02 1/31/98 (2)
      • Re: Clippers, cliplists, how? - Chen Shen 03:10:26 2/06/98 (0)
      • Re: Clippers, cliplists, how? - Brian Shea 14:20:20 2/02/98 (0)
    • D3D help - victor 13:16:54 1/31/98 (0)
    • How to install DirectX 5.0 properly with Visual C++ 5.0 - Kelvin Iu 23:54:53 1/30/98 (4)
      • Re: How to install DirectX 5.0 properly with Visual C++ 5.0 - john grace 14:41:26 2/08/98 (0)
      • Re: How to install DirectX 5.0 properly with Visual C++ 5.0 - Brian Shea 14:16:45 2/02/98 (2)
        • Re: How to install DirectX 5.0 properly with Visual C++ 5.0 - Natin Lupua 19:44:55 2/03/98 (1)
          • Re: How to install DirectX 5.0 properly with Visual C++ 5.0 - Brian Shea 10:42:53 2/04/98 (0)
    • Direct X slowdowns - Greg MacKay 21:39:08 1/30/98 (1)
      • Re: Direct X slowdowns - Brian Shea 14:15:22 2/02/98 (0)
    • Im Stpuid I know, I cant get DX5 under MSVC5 to work!!! Still!!! - Natin 21:33:52 1/30/98 (1)
      • Re: Im Stpuid I know, I cant get DX5 under MSVC5 to work!!! Still!!! - Brian Shea 14:12:58 2/02/98 (0)
    • Help! Can't get textures on 3dfx. - Jonathan Klein 21:02:15 1/30/98 (1)
      • Re: Help! Can't get textures on 3dfx. - franko 20:11:08 1/31/98 (0)
    • 4:2:2 video display under directX - mike Johnson 18:17:03 1/30/98 (1)
      • Re: 4:2:2 video display under directX - Jagmohan S Nanaware 05:48:18 5/28/98 (0)
    • Help ! Fatal Exception Error when using DirectX 5.0 - Tim Wilson 15:11:08 1/30/98 (1)
      • Re: Help ! Fatal Exception Error when using DirectX 5.0 - Tom Piraino 10:54:58 2/06/98 (0)
    • Specifying Refresh Rate in DirectX - Jon Munshi 13:53:02 1/30/98 (0)
    • DirectSound - Titus Winters 13:51:16 1/30/98 (1)
      • Re: DirectSound - Brian Shea 14:00:25 2/02/98 (0)
    • DISPLAY VIDEO for DIRECTX - mike Feng 13:03:20 1/30/98 (1)
      • Re: DISPLAY VIDEO for DIRECTX - mike Feng 13:06:12 1/30/98 (0)
    • CD Roms and DirectX - Bill 11:17:31 1/30/98 (1)
      • Re: CD Roms and DirectX - Brian Shea 12:52:27 1/30/98 (0)
    • Graphics - KHahn 08:48:27 1/30/98 (1)
      • Re: Graphics - Brian Shea 12:51:09 1/30/98 (0)
    • DirectX v5.0 for Windows NT 4 - Sir Shadow 05:49:39 1/30/98 (1)
      • Re: DirectX v5.0 for Windows NT 4 - Brian Shea 12:47:37 1/30/98 (0)
    • Yamaha Sound Card-Direct X incompatability! - C.S. Palmer 21:29:41 1/29/98 (0)
    • Load 3DS files - Rafael Alvarado 23:41:09 1/28/98 (2)
      • Re: Load 3DS files - Bradley Elfman 20:02:05 2/05/98 (0)
      • Re: Load 3DS files - Brian Shea 12:51:06 1/29/98 (0)
    • direct x5 - ronnie 20:17:46 1/28/98 (0)
    • DirectX Jobs Available - Dennis Withey 12:10:31 1/28/98 (0)
    • Problems with Wireframe using Right Handed Projection - Steve Howard 03:59:22 1/28/98 (0)
    • GIF files - Adriano Oliveira 08:00:11 1/27/98 (2)
      • Re: GIF files - Fussel 11:44:12 2/07/98 (0)
      • Re: GIF files - Brian Shea 09:01:06 1/27/98 (0)
    • Does 3D-Studio MAX run with Direct 3D 5.0 ? - Feix Bender 23:42:36 1/26/98 (1)
      • Re: Does 3D-Studio MAX run with Direct 3D 5.0 ? - Scott 19:56:28 1/29/98 (0)
    • Win16Lock Overhead - Tony Di Croce 18:14:01 1/26/98 (5)
      • Re: Win16Lock Overhead & BltFast - Jesse Rosenzweig 16:32:52 1/28/98 (1)
        • Re: Win16Lock Overhead & BltFast - franko 18:08:35 1/28/98 (0)
      • Re: Win16.. HEY use blt!! - franko 18:46:09 1/27/98 (1)
        • Re: Win16.. HEY use blt!! - Jimbo Jones 00:14:00 2/21/98 (0)
      • Re: Win16Lock Overhead - Nick Caldwell 19:35:36 1/26/98 (0)
    • GAMEDEV list!!! - JORDAN 13:57:13 1/26/98 (3)
      • Re: GAMEDEV list!!! - Brian Shea 08:53:53 1/27/98 (0)
      • Re: GAMEDEV list!!! - Don Martin 19:53:42 1/26/98 (1)
        • No, but i'll try this one... fur now... - JORDAN 22:10:54 1/26/98 (0)
    • Volume control with MCI - Gary Huff 13:43:30 1/26/98 (0)
    • Problem with S3 Trio64V+ - Eduardo 11:38:49 1/26/98 (2)
      • Re: Problem with S3 Trio64V+ - yuekaihui 00:18:11 3/25/98 (0)
      • Re: Problem with S3 Trio64V+ - Don Martin 19:57:38 1/26/98 (0)
    • How to switch between two Hardwareaccelators - Niels Schroeter 10:54:04 1/26/98 (2)
      • Re: How to switch between two Hardwareaccelators - Brian Shea 08:57:16 1/27/98 (1)
        • Re: How to switch between two Hardwareaccelators - Mark E. Stanley 22:41:30 3/30/98 (0)
    • DirectSound, ESS 1888, no sound out speakers - Karen Rivers 09:12:07 1/26/98 (1)
      • Re: DirectSound, ESS 1888, no sound out speakers - Don Martin 20:02:47 1/26/98 (0)
    • Another "where do I start" post - Rachel Lewis 04:24:28 1/26/98 (2)
      • Re: Another "where do I start" post - Don Martin 05:54:54 1/26/98 (1)
        • Wow, another Wrox Press fan! - Rachel Lewis 13:10:52 1/26/98 (0)
    • How can i plot pixels under DX5? - duong 02:13:26 1/26/98 (1)
      • Re: How can i plot pixels under DX5? - Brian Shea 09:07:35 1/27/98 (0)
    • DirectX 5.0 and MSVC 5 pro - Natin Lapua 19:39:44 1/25/98 (5)
      • Re: DirectX 5.0 and MSVC 5 pro - Scott 13:52:59 1/26/98 (1)
        • Re: DirectX 5.0 and MSVC 5 pro - Richard Drennen 22:55:31 6/15/98 (0)
      • Re: DirectX 5.0 and MSVC 5 pro - Don Martin 06:01:50 1/26/98 (0)
      • Re: DirectX 5.0 and MSVC 5 pro - Sean 20:44:07 1/25/98 (1)
        • Re: DirectX 5.0 and MSVC 5 pro - Natin Lapua 22:49:07 1/25/98 (0)
    • HELP: Editor - KHahn 17:26:58 1/25/98 (0)
    • All my DirectX games won't run. HELP!! This one - Chester 15:41:06 1/25/98 (2)
      • Re: All my DirectX games won't run. HELP!! This one - Mr. Magoo 16:59:57 1/26/98 (0)
      • Re: All my DirectX games won't run. HELP!! This one - Don Martin 06:07:44 1/26/98 (0)
    • All my DirectX games won't run. HELP!! - Chester 15:40:01 1/25/98 (1)
      • Re: All my DirectX games won't run. HELP!! - EvAcLeAr 04:08:23 5/25/98 (0)
    • No ddutil files! - Mr. Magoo 20:26:23 1/24/98 (0)
    • Using DirectX with Borland C++ 5 - David 19:09:20 1/24/98 (0)
    • help for directx 5.0 - Fred Dings 14:19:53 1/24/98 (1)
      • Re: help for directx 5.0 - Don Martin 06:09:34 1/26/98 (0)
    • i just wanna decent book - Shaun 11:23:28 1/24/98 (1)
      • Re: i just wanna decent book - Nick Caldwell 17:35:20 1/24/98 (0)
    • IS directX5.0 compatible with the matrox millenium videocard? - Davy Weynants 10:18:23 1/24/98 (2)
      • Re: IS directX5.0 compatible with the matrox millenium videocard? - Mr.Goodbar 01:12:32 5/23/98 (0)
      • Re: IS directX5.0 compatible with the matrox millenium videocard? - DW 20:53:44 4/21/98 (0)
    • Massive Desparity - Available and RealWorld Source - Don Martin 06:18:22 1/24/98 (0)
    • DirectX And MFC - Arrowhead 03:18:19 1/24/98 (1)
      • Re: DirectX And MFC - CHRIS! 17:41:14 1/28/98 (0)
    • NT40 Real SoundBlaster or ESS direct sound driver required - Guillermo Hdz 19:57:14 1/23/98 (0)
    • DirectX and NT 4.0 - Carlos 19:10:19 1/23/98 (1)
      • Re: DirectX and NT 4.0 - Brian Shea 14:01:35 1/25/98 (0)
    • How do I copy a 8bpp palettized matrix onto a 16bpp surface? - Fredrik Andersson 13:51:38 1/23/98 (2)
      • Re: How do I copy a 8bpp palettized matrix onto a 16bpp surface? - Nick Caldwell 22:28:51 1/23/98 (0)
      • Re: How do I copy a 8bpp palettized matrix onto a 16bpp surface? - franko 18:51:12 1/23/98 (0)
    • RIVA 128 AGP - textures - Serg 08:18:50 1/23/98 (0)
    • Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help? - Jeff 23:27:23 1/22/98 (4)
      • Re: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help? - Bob 05:37:54 6/06/98 (0)
      • Re: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help? - EvAcLeAr 19:21:18 5/18/98 (0)
      • Re: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help? - Ian butler 08:58:01 2/02/98 (1)
        • Re: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help? - Dušan 02:44:41 2/20/98 (0)
    • How can I use the DirectX with DELPHI ? - (sorry, I don´t speak English well) - Soul 10:13:36 1/22/98 (2)
      • Re: How can I use the DirectX with DELPHI ? - (sorry, I don´t speak English well) - Dennis Muller 13:57:59 1/22/98 (1)
        • Re: How can I use the DirectX with DELPHI ? - (sorry, I don´t speak English well) - Fussel 09:11:13 2/07/98 (0)
    • Textures & Video Memory... - Daniele Trambusti 07:54:56 1/22/98 (2)
      • Re: Textures & Video Memory... - Jordan 14:05:35 1/22/98 (1)
        • Re: Textures & Video Memory... - Daniele Trambusti 09:57:50 1/26/98 (0)
    • Removal of a FACE from MESHBUILDER object - Jordan 05:55:14 1/22/98 (2)
      • Re: Removal of a FACE from MESHBUILDER object - Sean 20:39:23 1/25/98 (1)
        • Re: Removal of a FACE from MESHBUILDER object - Thanx sean, Maybe DirectX6 eh? 13:47:30 1/26/98 (0)
    • Retained mode AND Immediate mode? - jordan 05:44:41 1/22/98 (0)
    • D3DRM2 using new VC5 AppWizard project, (stupid link error!) - Jordan 05:37:05 1/22/98 (2)
      • Re: D3DRM2 using new VC5 AppWizard project, (stupid link error!) - Bartron 19:42:56 1/22/98 (1)
        • Re: D3DRM2 using new VC5 AppWizard project, (stupid link error!) - Jordan :) 23:02:14 1/22/98 (0)
    • DirectPlay samples - Eugene 04:49:50 1/22/98 (0)
    • BocaResearch Modem/SoundCard - Leigh 15:55:35 1/21/98 (0)
    • I can program with directx starting from the Visual basic - Fabio Augusto 13:33:48 1/21/98 (0)
    • 16bpp 2D Special Effects - Rob 08:52:41 1/21/98 (0)
    • directx5b - sean lusk 16:01:44 1/20/98 (0)
    • DirectX and MFC. - Joris Timmermans (Mad Keith) 12:22:40 1/20/98 (6)
      • Re: DirectX and MFC. - if you read this you are gay 10:40:41 3/19/98 (0)
      • Re: DirectX and MFC. - Bartron 16:08:07 1/20/98 (4)
        • Re: DirectX and MFC. - Serg 08:15:27 1/23/98 (3)
          • Re: DirectX and MFC. - Jeff Thelen 16:08:56 1/24/98 (2)
            • Re: DirectX and MFC. - CHRIS! 17:47:46 1/28/98 (1)
              • Re: DirectX and MFC. - Joris Timmermans 13:31:33 3/03/98 (0)
    • Help: Need D3D info/samples involving Animation, keyframe etc - Max McCollister 11:49:22 1/19/98 (0)
    • DirectX5.0 and game input - SuperD 05:34:41 1/19/98 (4)
      • Re: DirectX5.0 and game input - Fred Dings 14:24:54 1/24/98 (3)
        • Re: DirectX5.0 and game input - justin 23:42:18 1/30/98 (1)
          • Re: DirectX5.0 and game input - cheng 11:41:16 2/07/98 (0)
        • Re: DirectX5.0 and game input - Don Martin 20:28:55 1/26/98 (0)
    • Error #9 - Guloo 04:39:53 1/19/98 (0)
    • Direct3DRM: Mouse Coordinates to Window Coordinates - Sean Barton 01:46:49 1/19/98 (0)
    • DirectX... I wanna learn... but need a starting point - James 01:08:41 1/19/98 (1)
      • Re: DirectX... I wanna learn... but need a starting point - Sean Barton 01:56:44 1/19/98 (0)
    • WHICH COMPILER IS BEST 4 DIRECTX5? - J Heggie 21:05:37 1/18/98 (4)
      • Re: WHICH COMPILER IS BEST 4 DIRECTX5? - Nick Caldwell 16:46:46 1/20/98 (3)
        • Re: WHICH COMPILER IS BEST 4 DIRECTX5? - Wolfgang Rössler 06:25:35 3/11/98 (2)
          • Re: WHICH COMPILER IS BEST 4 DIRECTX5? - PAULO MARTINHO 20:24:00 6/17/98 (0)
          • Re: WHICH COMPILER IS BEST 4 DIRECTX5? - JORGE 16:04:32 6/09/98 (0)
    • Where Can I download DirectX 5.0 - Michale Chambers 15:35:17 1/17/98 (90)
      • Re: Where Can I download DirectX 5.0 - Keith Peaerson 14:59:20 9/08/98 (0)
      • Re: Where Can I download DirectX 5.0 - Tuesday Assassin 21:27:17 8/18/98 (0)
      • Re: Where Can I download DirectX 5.0 - mauricio rojas 22:16:45 7/30/98 (1)
        • Re: Where Can I download DirectX 5.0 - mauricio rojas 22:21:16 7/30/98 (0)
      • Re: Where Can I download DirectX 5.0 - wayne hansen 19:10:48 7/28/98 (0)
      • Re: Where Can I download DirectX 5.0 - chris wilson 15:44:37 7/27/98 (0)
      • Re: Where Can I download DirectX 5.0 - Chris 23:18:30 7/22/98 (0)
      • Re: Where Can I download DirectX 5.0 - gail 20:27:29 7/20/98 (1)
        • Re: Where Can I download DirectX 5.0 - orlando rodriguez 00:27:13 7/22/98 (0)
      • Re: Where Can I download DirectX 5.0 - alan cohen 17:28:32 7/15/98 (2)
        • Re: Where Can I download DirectX 5.0 - shawn lee harvey 17:45:05 7/20/98 (0)
        • Re: Where Can I download DirectX 5.0 - Alexander 00:19:43 7/18/98 (0)
      • Re: Where Can I download DirectX 5.0 - Brian Maurer 17:59:58 3/27/98 (1)
        • Re: Where Can I download DirectX 5.0 - Piyushgiri 11:27:24 7/08/98 (0)
      • Re: Where Can I download DirectX 5.0 - Leonardo D. Otero 11:50:55 3/26/98 (2)
        • Re: Where Can I download DirectX 5.0 - MM 17:56:44 3/27/98 (0)
        • Re: Where Can I download DirectX 5.0 - PSMD 08:11:13 3/27/98 (0)
      • Re: Where Can I download DirectX 5.0 - Luis ALberto Urra 12:50:38 3/25/98 (1)
        • Re: Where Can I download DirectX 5.0 - victor reyes 19:52:08 3/25/98 (0)
      • Re: Where Can I download DirectX 5.0 - pace 22:37:47 3/22/98 (5)
        • Re: Where Can I download DirectX 5.0 - dean eccles 08:35:01 9/18/98 (0)
        • Re: Where Can I download DirectX 5.0 - Christer Johnson 14:03:03 3/23/98 (3)
          • Re: Where Can I download DirectX 5.0 - Micheal antez 12:30:30 7/23/98 (0)
          • download DirectX 5.0 - Roman Kaykov 21:14:29 7/16/98 (1)
            • Re: download DirectX 5.0 - KEBIR 13:40:54 7/29/98 (0)
      • Re: Where Can I download DirectX 5.0 - Edwina 13:16:18 3/21/98 (3)
        • Re: Where Can I download DirectX 5.0 - hilary king 16:24:22 3/24/98 (0)
        • Re: Where Can I download DirectX 5.0 - Jean-Louis 12:27:23 3/22/98 (0)
        • Re: Where Can I download DirectX 5.0 - james Bravo 09:02:32 3/22/98 (0)
      • Re: Where Can I download DirectX 5.0 - me 23:03:48 3/20/98 (0)
      • Re: Where Can I download DirectX 5.0 - Dale 17:29:20 3/18/98 (1)
        • Re: Where Can I download DirectX 5.0 - bing 18:52:19 3/20/98 (0)
      • Re: Where Can I download DirectX 5.0 - yýltan deveci 16:59:19 3/14/98 (0)
      • Re: Where Can I download DirectX 5.0 - Rodrigo Valdes Ascencio 16:40:05 1/30/98 (0)
      • Re: Where Can I download DirectX 5.0 - Dave Schweiger 10:27:05 1/25/98 (2)
        • Re: Where Can I download DirectX 5.0 - mike 20:36:18 8/22/98 (0)
        • Re: Where Can I download DirectX 5.0 - wezzas wilkins 19:55:24 1/26/98 (0)
      • Re: Where Can I download DirectX 5.0 - Harold 20:37:49 1/18/98 (51)
        • Re: Where Can I download DirectX 5.0 - Jay Carnegie 12:52:32 7/28/98 (0)
        • Re: Where Can I download DirectX 5.0 - GREG GREULING 22:29:29 7/27/98 (0)
        • Where Can I find the dialer that works with NO MODEM ? - Johnny Kim 09:43:36 7/23/98 (0)
        • Re: Where Can I download DirectX 5.0 - Brian Stanger 12:22:35 7/19/98 (2)
          • Re: Where Can I download DirectX 5.0 - bmone 15:21:44 7/19/98 (1)
            • Re: Where Can I download DirectX 5.0 - justin 07:21:17 7/28/98 (0)
        • Re: Where Can I download DirectX 5.0 - Jessica Andrews 21:30:27 7/17/98 (0)
        • Re: Where Can I download DirectX 5.0 - Igor 00:12:52 3/25/98 (15)
          • Re: Where Can I download DirectX 5.0 - César Arce 12:56:58 9/06/98 (0)
          • Re: Where Can I download DirectX 5.0 answer - James Kremer 16:16:51 9/04/98 (0)
          • Re: Where Can I download DirectX 5.0 - krupesh 06:40:03 9/01/98 (0)
          • Re: Where Can I download DirectX 5.0 - lap hing 03:39:32 7/25/98 (0)
          • Re: Where Can I download DirectX 5.0 - fernando i barrola 19:46:09 7/10/98 (4)
            • Re: Where Can I download DirectX 5.0 - Dan Cedric T. Delima 11:42:31 7/26/98 (0)
            • Re: Where Can I download DirectX 6.0 - Josee Oliviero 10:38:35 7/23/98 (2)
              • Re: Where Can I download DirectX 6.0 - Nancy Jaggers 15:04:56 9/07/98 (0)
              • Re: Where Can I download DirectX 6.0 - zmc 08:15:56 8/30/98 (0)
          • Re: Where Can I download DirectX 5.0 - VICTOR HUERTA 10:21:14 7/10/98 (3)
            • Re: Where Can I download DirectX 5.0 - Antonio DaSilva 21:50:08 7/10/98 (2)
              • Re: Where Can I download DirectX 5.0 - wu z 22:13:19 7/21/98 (1)
                • Re: Where Can I download DirectX 5.0 - Susan Johnson 03:02:21 7/28/98 (0)
          • Re: Where Can I download DirectX 5.0 - Fauzea 13:04:34 7/09/98 (1)
            • Re: Where Can I download DirectX 5.0 - bo 19:52:24 9/07/98 (0)
        • Re: Where Can I download DirectX 5.0 - DANIEL POTVIN 12:10:15 3/19/98 (2)
          • Re: Where Can I download DirectX 5.0 - jygf 16:31:53 3/24/98 (0)
          • Re: Where Can I download DirectX 5.0 - ewrqe3 15:54:26 3/22/98 (0)
        • Re: Where Can I download DirectX 5.0 - jlz 02:39:10 3/19/98 (1)
          • Re: Where Can I download DirectX 5.0 - asddd 15:56:07 3/22/98 (0)
        • Re: Where Can I download DirectX 5.0 - Denny 18:13:25 3/17/98 (5)
          • Re: Where Can I download DirectX 5.0 - Shawn Salerno 16:28:32 6/12/98 (1)
            • Re: Where Can I download DirectX 5.0 - Alan Cohen 17:16:52 7/15/98 (0)
          • Re: Where Can I download DirectX 5.0 - Matthew G. Czarnecki 16:05:27 3/18/98 (2)
            • Re: Where Can I download DirectX 5.0 - Kandi nelson 21:52:00 3/18/98 (1)
              • Re: Where Can I download DirectX 5.0 - Kandi 21:57:30 3/18/98 (0)
        • Re: Where Can I download DirectX 5.0 - Eric 13:20:09 3/15/98 (3)
          • Re: Where Can I download DirectX 5.0 - Liviu Drugus 01:19:32 3/17/98 (1)
            • Re: Where Can I download DirectX 5.0 - Ernesto Ibarra 03:35:03 3/17/98 (0)
          • Re: Where Can I download DirectX 5.0 - Liviu Drugus 01:18:36 3/17/98 (0)
        • Re: Where Can I download DirectX 5.0 - Darryl Brown 20:14:54 1/25/98 (3)
          • Re: Where Can I download DirectX 5.0 - David Craig-Smith 10:25:20 3/13/98 (0)
          • Re: Where Can I download DirectX 5.0 - David Craig-Smith 10:25:01 3/13/98 (1)
            • Re: Where Can I download DirectX 5.0 - derrick paul 20:23:20 3/17/98 (0)
        • Re: Where Can I download DirectX 5.0 - ajs 19:16:31 1/24/98 (2)
          • Re: Where Can I download DirectX 5.0 - an ji won 21:51:51 1/24/98 (1)
            • Re: Where Can I download DirectX 5.0 - arno spruijt 04:41:50 1/26/98 (0)
        • Re: Where Can I download DirectX 5.0 - tfg 09:38:49 1/24/98 (5)
          • Re: Where Can I download DirectX 5.0 - lars 04:19:20 2/25/98 (1)
            • Re: Where Can I download DirectX 5.0 - Stalker 14:17:54 7/16/98 (0)
          • Re: Where Can I download DirectX 5.0 - Kevin 11:18:57 1/24/98 (2)
            • Where Can I download DirectX 5.0 - Matthew Stiller 04:22:10 7/17/98 (1)
              • Re: Where Can I download DirectX 5.0 - Simon Partington 20:58:10 9/01/98 (0)
      • Re: Where Can I download DirectX 5.0 - Fredrik 17:04:31 1/17/98 (0)
    • Keep getting "illegal operation" messages - Ryan Chun 03:16:24 1/17/98 (0)
    • the game im installing says no direct3d how do i get it? - kevin 00:02:24 1/17/98 (0)
    • Where can I get directX5.0 - Last Seanachi 19:52:17 1/16/98 (2)
      • Re: Where can I get directX5.0 - oxi 14:29:20 1/17/98 (1)
        • Re: Where can I get directX5.0 - Max McCollister 11:51:17 1/19/98 (0)
    • Directdraw rotation - Nick 17:44:08 1/16/98 (1)
      • Re: Directdraw rotation - Jack Strohm 18:47:24 2/04/98 (0)
    • This is a very good page! - Marcus 12:36:46 1/16/98 (0)
    • Sample - Vincent Bilodeau 19:32:57 1/15/98 (1)
      • Re: Sample - Adriano Oliveira 08:14:24 1/23/98 (0)
    • D3DTLVERTEX - Gerk 17:51:00 1/15/98 (0)
    • Directx5 debug + AGP execution model = ??? - Serg 16:34:19 1/15/98 (0)
    • Borland C++ Builder - Tony Leotta 12:40:30 1/15/98 (1)
      • Re: Borland C++ Builder - Jack Strohm 13:39:12 1/22/98 (0)
    • Drawing overlays over video - jerry maresca 11:02:58 1/15/98 (1)
      • Re: Drawing overlays over video - Stas 07:33:53 2/18/98 (0)
    • DJGPP with DirectX? - Pierpa 10:27:27 1/15/98 (4)
      • Re: DJGPP with DirectX? - Dominik Scherer 08:24:03 7/26/98 (0)
      • Re: DJGPP with DirectX? - odie 23:41:20 4/30/98 (0)
      • Re: DJGPP with DirectX? - pierpa 10:29:38 1/15/98 (1)
        • Re: DJGPP with DirectX? - Fussel 09:03:46 2/07/98 (0)
    • How do I use 16-bpp surfaces? - Fredrik Andersson 13:53:09 1/14/98 (2)
      • Re: How do I use 16-bpp surfaces? - Dennis Muller 22:11:33 1/20/98 (0)
      • Re: How do I use 16-bpp surfaces? - Nick Caldwell 10:18:54 1/15/98 (0)
    • re: H E L P - c. wincote 08:14:24 1/14/98 (0)
    • re: H E L P - c. wincote 08:06:43 1/14/98 (0)
    • Delphi DirectX Examples - George Pasparakis 15:07:44 1/13/98 (1)
      • Re: Delphi DirectX Examples - Joakim Strom 03:21:32 6/29/98 (0)
    • Delphi DirectX Examples - George Pasparakis 15:07:20 1/13/98 (0)
    • Starnge error message from QueryInterface - wizard 13:41:57 1/13/98 (1)
      • Re: Starnge error message from QueryInterface - Brian Shea 15:18:20 1/13/98 (0)
    • DirectX 5.0 locks up the system!!! - David Boardman 11:37:47 1/13/98 (2)
      • Re: DirectX 5.0 locks up the system!!! - Me 22:49:40 1/13/98 (1)
        • Re: DirectX 5.0 locks up the system!!! - tr 19:36:35 1/19/98 (0)
    • CreateDeviceFromD3D - George Lancaster 00:32:17 1/13/98 (0)
    • Help!!!!! - kin 22:57:35 1/12/98 (1)
      • Re: Help!!!!! - Jay 02:00:34 1/13/98 (0)
    • Welcome to the DirectX eXperience Forum - Adam Perer 16:30:30 1/12/98 (4)
      • Re: Welcome to the DirectX eXperience Forum - Wolfgang Engel 06:08:43 1/14/98 (3)
        • Re: Where is DirectX5.0 - Last Seanachi 19:49:34 1/16/98 (2)
          • Re: Where is DirectX5.0 - Chen Shen 04:35:56 2/08/98 (1)
            • Re: Where is DirectX5.0 - michelle bacque 20:33:57 3/26/98 (0)


Welcome to the DirectX eXperience Forum

[ Follow Ups ] [ Post Followup ] [ the DirectX eXperience Forum ]

Posted by Adam Perer on January 12, 1998 at 16:30:30:

Hey guys!

Feel free to make use of this forum.

Its for you to get all your questions answered.

Please help out if you know the answer to some
of the questions.

Thanks,
Adam Perer

Follow Ups:

  • Re: Welcome to the DirectX eXperience Forum Wolfgang Engel 06:08:43 1/14/98 (3)
    • Re: Where is DirectX5.0 Last Seanachi 19:49:34 1/16/98 (2)
      • Re: Where is DirectX5.0 Chen Shen 04:35:56 2/08/98 (1)
        • Re: Where is DirectX5.0 michelle bacque 20:33:57 3/26/98 (0)

Post a Followup

Name:
E-Mail:

Subject:

Comments:

Optional Link URL:
Link Title:
Optional Image URL:


Help!!!!!

Posted by kin on January 12, 1998 at 22:57:35:

were do i download directX????????????????????????

Follow Ups:

  • Re: Help!!!!! Jay 02:00:34 1/13/98 (0)

Post a Followup

Name:
E-Mail:


CreateDeviceFromD3D

Posted by George Lancaster on January 13, 1998 at 00:32:17:

I am now using the directx 5 Retained Mode
implementations. CreateDeviceFromD3D does not work.
Am I smokin crack or is there something wonderfully
weird I have to do to get it going.

Follow Ups:

Post a Followup

Name:


Re: Help!!!!!

Posted by Jay on January 13, 1998 at 02:00:34:

In Reply to: Help!!!!! posted by kin on January 12, 1998 at 22:57:35:

You can get the directx sdk from www.microsoft.com/directx

Follow Ups:

Post a Followup

Name:


DirectX 5.0 locks up the system!!!

Posted by David Boardman on January 13, 1998 at 11:37:47:

I'm having a true problem. I'm trying to play
Age of Empires (and other games using DirectX 5.0).
Every so often, an event will occur causing a sound
event to play, and the system locks up completely!
I can hear the sound in audio RAM playing over and
over again, but the CPU doesn't respond to anything!
Any ideas?

I've got a P233 MMX/ with Creative Lab Vibra 16,
running Win 95 (unfortunately).

I'm going to go out on a limb and say: Microsoft programmers/
programming is THE MOST mediocre I've EVER seen!! I've
never seen stuff so unreliable, with so little support
and so little responsability taken to correct problems.

Follow Ups:

  • Re: DirectX 5.0 locks up the system!!! Me 22:49:40 1/13/98 (1)
    • Re: DirectX 5.0 locks up the system!!! tr 19:36:35 1/19/98 (0)

Post a Followup

Name:


Starnge error message from QueryInterface

Posted by wizard on January 13, 1998 at 13:41:57:

Hi,
I'm trying to develope an utility that plays sounds
with DirectSound 5.0. When I try to set the notification positions for a secondary buffer i get a
0x80004002 value as HRESULT. I don't know what is it!

Please help and be clear!

Thank you

Wizard of Dark Era.

Follow Ups:

  • Re: Starnge error message from QueryInterface Brian Shea 15:18:20 1/13/98 (0)

Post a Followup

Name:


Delphi DirectX Examples

Posted by George Pasparakis on January 13, 1998 at 15:07:20:

I try to compile the examples and i get Fatal error
ddirectdraw.pas not found.
I searched for this file but I cant find it.

Any help?

Follow Ups:

Post a Followup

Name:


Delphi DirectX Examples

Posted by George Pasparakis on January 13, 1998 at 15:07:44:

I try to compile the examples and i get Fatal error
ddirectdraw.pas not found.
I searched for this file but I cant find it.

Any help?

Follow Ups:

  • Re: Delphi DirectX Examples Joakim Strom 03:21:32 6/29/98 (0)

Post a Followup

Name:


Re: Starnge error message from QueryInterface

Posted by Brian Shea on January 13, 1998 at 15:18:20:

In Reply to: Starnge error message from QueryInterface posted by wizard on January 13, 1998 at 13:41:57:

The message for that error is:
"No such interface supported"
I.e. the GUID you passed does not seem valid.

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 locks up the system!!!

Posted by Me on January 13, 1998 at 22:49:40:

In Reply to: DirectX 5.0 locks up the system!!! posted by David Boardman on January 13, 1998 at 11:37:47:

: I'm having a true problem. I'm trying to play
: Age of Empires (and other games using DirectX 5.0).
: Every so often, an event will occur causing a sound
: event to play, and the system locks up completely!
: I can hear the sound in audio RAM playing over and
: over again, but the CPU doesn't respond to anything!
: Any ideas?

: I've got a P233 MMX/ with Creative Lab Vibra 16,
: running Win 95 (unfortunately).

: I'm going to go out on a limb and say: Microsoft programmers/
: programming is THE MOST mediocre I've EVER seen!! I've
: never seen stuff so unreliable, with so little support
: and so little responsability taken to correct problems.

Quit whining!
Why dont you try playing some of your games under something like Solaris.. See how long it takes you to figure how to even get your soundcard working.. Ever heard of recompiling a kernel ? I didn't think so! You whining little maggot of a computer-illiterate piece of shit. Go snivel elsewhere!

Follow Ups:

  • Re: DirectX 5.0 locks up the system!!! tr 19:36:35 1/19/98 (0)

Post a Followup

Name:


Re: Welcome to the DirectX eXperience Forum

Posted by Wolfgang Engel on January 14, 1998 at 06:08:43:

In Reply to: Welcome to the DirectX eXperience Forum posted by Adam Perer on January 12, 1998 at 16:30:30:

Hey Adam !
Great work !!!!

Wolf

Follow Ups:

  • Re: Where is DirectX5.0 Last Seanachi 19:49:34 1/16/98 (2)
    • Re: Where is DirectX5.0 Chen Shen 04:35:56 2/08/98 (1)
      • Re: Where is DirectX5.0 michelle bacque 20:33:57 3/26/98 (0)

Post a Followup

Name:


re: H E L P

Posted by c. wincote on January 14, 1998 at 08:06:43:

I've got 'moto racer' which requires directX 3.0, I installed version 5.0 and the joypad controls in the game are now completely buggered up! I went into control panel and re-calibrated it and everything but it's still messed up! CAN ANYONE HELP? PLEASE E-MAIL ME!!!!!

Follow Ups:

Post a Followup

Name:


re: H E L P

Posted by c. wincote on January 14, 1998 at 08:14:24:

I've got 'moto racer' which requires directX 3.0, I installed version 5.0 and the joypad controls in the game are now completely buggered up! I went into control panel and re-calibrated it and everything but it's still messed up! CAN ANYONE HELP? PLEASE E-MAIL ME!!!!!

Follow Ups:

Post a Followup

Name:


How do I use 16-bpp surfaces?

Posted by Fredrik Andersson on January 14, 1998 at 13:53:09:

I got a problem with 16-bits-per-pixel DirectDraw surfaces.
When I try to use the Lock() function to put individual
pixels in my 16bpp surface, they all go to the left half
of the surface. Also, they get strange, random-looking colors.
I tried to use the RGB macro, but it dosen't help.
As far as I see, the Lock() function returns an
8-bit pointer (char*). Can that be used in 16bpp surfaces?
And, what's the difference between 16bpp and 24bpp,
except for the color depth?
Can I use RGB values to specify pixels in a 16bpp
surface as well? Which mode would you recommend?

I will be very happy for any help I get! Thanks!

Follow Ups:

  • Re: How do I use 16-bpp surfaces? Dennis Muller 22:11:33 1/20/98 (0)
  • Re: How do I use 16-bpp surfaces? Nick Caldwell 10:18:54 1/15/98 (0)

Post a Followup

Name:


Re: How do I use 16-bpp surfaces?

Posted by Nick Caldwell on January 15, 1998 at 10:18:54:

In Reply to: How do I use 16-bpp surfaces? posted by Fredrik Andersson on January 14, 1998 at 13:53:09:

You are reading the pointer incorrectly. You
should cast the surface pointer to a WORD instead
of an unsigned char. Something like:

WORD *surface = (WORD *)SurfaceDesc.SurfacePtr

Also, you can't use the RGB macro outside of GDI.
Here is an RGB macro that I use for 16bpp:

#define RGB2(r,g,b) ((WORD) ((BYTE) (r) << __SHIFT | (BYTE) (g) << 5 | (BYTE) (b)))

__SHIFT is 10 or 11 depending on your video card.
Read the DDraw help topic on pixel bitmasks for
more info. The major difference between 16bpp
and 24bpp is that in 16 your RGB values
can be a max of RGB(31,31,31), in 24bpp they
can be RGB(255,255,255). Obviously, this is
because 24bpp uses more memory. Again, read the
DDraw pixel bitmask topic, it explains this
fully.

Follow Ups:

Post a Followup

Name:


DJGPP with DirectX?

Posted by Pierpa on January 15, 1998 at 10:27:27:

It is possible to use the Direct3D with the DJGPP C++ compiler?
If yes, where I can found all the necessary tool and documentation to start?

Follow Ups:

  • Re: DJGPP with DirectX? Dominik Scherer 08:24:03 7/26/98 (0)
  • Re: DJGPP with DirectX? odie 23:41:20 4/30/98 (0)
  • Re: DJGPP with DirectX? pierpa 10:29:38 1/15/98 (1)
    • Re: DJGPP with DirectX? Fussel 09:03:46 2/07/98 (0)

Post a Followup

Name:


Re: DJGPP with DirectX?

Posted by pierpa on January 15, 1998 at 10:29:38:

In Reply to: DJGPP with DirectX? posted by Pierpa on January 15, 1998 at 10:27:27:

: It is possible to use the Direct3D with the DJGPP C++ compiler?
Sorry! I've made an error: the right question is:
Is it possible to use the Direct3D with the DJGPP C++ compiler?

Follow Ups:

  • Re: DJGPP with DirectX? Fussel 09:03:46 2/07/98 (0)

Post a Followup

Name:


Drawing overlays over video

Posted by jerry maresca on January 15, 1998 at 11:02:58:

Hello,

I am working with some active movie displays and need to overlay some text and graphics over the video. I would like to know the most efficient way to do this. There are up to four separate windows displaying video simultaneously. I tried using DirectDraw with a separate backbuffer for each window, and letting each blit to the primary buffer with the video, but this brought the refresh rates down to under 20fps and I need 30. I can sustain 30fps by using GDI, but this results in flickery overlays. Anyone got any ideas???

Many Thanks.

Follow Ups:

  • Re: Drawing overlays over video Stas 07:33:53 2/18/98 (0)

Post a Followup

Name:


Borland C++ Builder

Posted by Tony Leotta on January 15, 1998 at 12:40:30:

Is anyone doing anything with Borland C++ Builder?
I've tried to get some sample apps running
with no luck.

Do Direct X apps run under Borland C++ Builder?

Follow Ups:

  • Re: Borland C++ Builder Jack Strohm 13:39:12 1/22/98 (0)

Post a Followup

Name:


Directx5 debug + AGP execution model = ???

Posted by Serg on January 15, 1998 at 16:34:19:

I've suspition that DX5 debug v. doesn't recognize
AGP exec. model - at least at RIVA 128
Say something like : AGP-avare driver fails set
LOCALVIDMEM or NONLOCALVIDMEN(it can't set phisical
mem pointer also but I think it's OK)
Can somebody clear this situation for me ?

Thanks

Serg

Follow Ups:

Post a Followup

Name:


D3DTLVERTEX

Posted by Gerk on January 15, 1998 at 17:51:00:

I can't for the life of me figure out TLVERTEXS.. I finally got something to show up on the screen but its all skewerd and crazy lookin..

Could someone tell me

1. values to plug in a projection matrix
2. values to plug in a d3dviewport

that they know works..? An explanation would be nice too.

Follow Ups:

Post a Followup

Name:


Sample

Posted by Vincent Bilodeau on January 15, 1998 at 19:32:57:

Does anybody have a simple Direct 3D retained mode fullscreen sample with a device created from a surface so I can check if I'm wrong or my compiler is wrong.

Follow Ups:

  • Re: Sample Adriano Oliveira 08:14:24 1/23/98 (0)

Post a Followup

Name:


This is a very good page!

Posted by Marcus on January 16, 1998 at 12:36:46:

I am a beginer, and this Site has helped me very much!!!
Thanks Thanks Thanks.

Follow Ups:

Post a Followup

Name:


Directdraw rotation

Posted by Nick on January 16, 1998 at 17:44:08:

Can anyone point me to a resource that explains how
to rotate Bitmaps in DirectX??? Or post some info here:)
I can't seem to get it to work properly.

Nick

Follow Ups:

  • Re: Directdraw rotation Jack Strohm 18:47:24 2/04/98 (0)

Post a Followup

Name:


Re: Where is DirectX5.0

Posted by Last Seanachi on January 16, 1998 at 19:49:34:

In Reply to: Re: Welcome to the DirectX eXperience Forum posted by Wolfgang Engel on January 14, 1998 at 06:08:43:

Where can I get DIRECTX5.0? I keep playing Diablo, and it keeps freezing up. I am told from Battlenet chat that directx5.0 may solve this problem. But where can I download the software from???

seanachi@nternet.net

Follow Ups:

  • Re: Where is DirectX5.0 Chen Shen 04:35:56 2/08/98 (1)
    • Re: Where is DirectX5.0 michelle bacque 20:33:57 3/26/98 (0)

Post a Followup

Name:


Where can I get directX5.0

Posted by Last Seanachi on January 16, 1998 at 19:52:17:

I have a problem with Diablo crashing. I am told that DirectX5.0 may solve this, but I can't seem to find where I can download the software?

-Can anyone help me with where to look?

seanachi@nternet.net

Follow Ups:

  • Re: Where can I get directX5.0 oxi 14:29:20 1/17/98 (1)
    • Re: Where can I get directX5.0 Max McCollister 11:51:17 1/19/98 (0)

Post a Followup

Name:


the game im installing says no direct3d how do i get it?

Posted by kevin on January 17, 1998 at 00:02:24:

thx..........

Follow Ups:

Post a Followup

Name:


Keep getting "illegal operation" messages

Posted by Ryan Chun on January 17, 1998 at 03:16:24:

Hi,

I recently purchased two games, Blade Runner and Fallout for my IBM 365X
ThinkPad and had problems running both of them. In running both games,
I keep getting "illegal Operation" messages on my screen. I am wondering whether
it is the DirectX 5 that could be causing this problem. My ThinkPad is 100 MHz,
24 RAM and has a 6X CD-rom (External). Here are the messages I got from
running Blade Runner and Fallout.

BLADE caused an invalid page fault in
module BLADE.EXE at 0157:004390e5.
Registers:
EAX=006cf99c CS=0157 EIP=004390e5 EFLGS=00010246
EBX=00000000 SS=015f ESP=006cf920 EBP=006cf958
ECX=00000000 DS=015f ESI=00000000 FS=0dc7
EDX=00000000 ES=015f EDI=006cf99c GS=0000
Bytes at CS:EIP:
8b 0e 8d 14 1b 8b c2 c1 e0 05 03 d0 8b 44 0a 1e
Stack dump:
006cf99c 0049107c 006cf940 006cf980 006cf99c 00000000 004801d9 00410590 00000000 006cf99c 006cf95c 006cf958 0071ba5c 006cf980 006cf980 004104f8

FALLOUTW caused an invalid page fault in
module KERNEL32.DLL at 0157:bff9a14d.
Registers:
EAX=00820010 CS=0157 EIP=bff9a14d EFLGS=00010202
EBX=bff859d9 SS=015f ESP=00820000 EBP=00820130
ECX=008200dc DS=015f ESI=00820228 FS=0d27
EDX=00820288 ES=015f EDI=00820140 GS=0000
Bytes at CS:EIP:
ff 75 0c e8 2e ff ff ff 85 c0 75 05 8b 45 fc eb
Stack dump:
00820010 00820228 008200dc 0082012c 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000

I will appreciate any help you can give me. Thank you in advance.

-Bryan

Follow Ups:

Post a Followup

Name:


Re: Where can I get directX5.0

Posted by oxi on January 17, 1998 at 14:29:20:

In Reply to: Where can I get directX5.0 posted by Last Seanachi on January 16, 1998 at 19:52:17:

: I have a problem with Diablo crashing. I am told that DirectX5.0 may solve this, but I can't seem to find where I can download the software?

: -Can anyone help me with where to look?

: seanachi@nternet.net

Follow Ups:

  • Re: Where can I get directX5.0 Max McCollister 11:51:17 1/19/98 (0)

Post a Followup

Name:


Where Can I download DirectX 5.0

Posted by Michale Chambers on January 17, 1998 at 15:35:17:

Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Keith Peaerson 14:59:20 9/08/98 (0)
  • Re: Where Can I download DirectX 5.0 Tuesday Assassin 21:27:17 8/18/98 (0)
  • Re: Where Can I download DirectX 5.0 mauricio rojas 22:16:45 7/30/98 (1)
    • Re: Where Can I download DirectX 5.0 mauricio rojas 22:21:16 7/30/98 (0)
  • Re: Where Can I download DirectX 5.0 wayne hansen 19:10:48 7/28/98 (0)
  • Re: Where Can I download DirectX 5.0 chris wilson 15:44:37 7/27/98 (0)
  • Re: Where Can I download DirectX 5.0 Chris 23:18:30 7/22/98 (0)
  • Re: Where Can I download DirectX 5.0 gail 20:27:29 7/20/98 (1)
    • Re: Where Can I download DirectX 5.0 orlando rodriguez 00:27:13 7/22/98 (0)
  • Re: Where Can I download DirectX 5.0 alan cohen 17:28:32 7/15/98 (2)
    • Re: Where Can I download DirectX 5.0 shawn lee harvey 17:45:05 7/20/98 (0)
    • Re: Where Can I download DirectX 5.0 Alexander 00:19:43 7/18/98 (0)
  • Re: Where Can I download DirectX 5.0 Brian Maurer 17:59:58 3/27/98 (1)
    • Re: Where Can I download DirectX 5.0 Piyushgiri 11:27:24 7/08/98 (0)
  • Re: Where Can I download DirectX 5.0 Leonardo D. Otero 11:50:55 3/26/98 (2)
    • Re: Where Can I download DirectX 5.0 MM 17:56:44 3/27/98 (0)
    • Re: Where Can I download DirectX 5.0 PSMD 08:11:13 3/27/98 (0)
  • Re: Where Can I download DirectX 5.0 Luis ALberto Urra 12:50:38 3/25/98 (1)
    • Re: Where Can I download DirectX 5.0 victor reyes 19:52:08 3/25/98 (0)
  • Re: Where Can I download DirectX 5.0 pace 22:37:47 3/22/98 (5)
    • Re: Where Can I download DirectX 5.0 dean eccles 08:35:01 9/18/98 (0)
    • Re: Where Can I download DirectX 5.0 Christer Johnson 14:03:03 3/23/98 (3)
      • Re: Where Can I download DirectX 5.0 Micheal antez 12:30:30 7/23/98 (0)
      • download DirectX 5.0 Roman Kaykov 21:14:29 7/16/98 (1)
        • Re: download DirectX 5.0 KEBIR 13:40:54 7/29/98 (0)
  • Re: Where Can I download DirectX 5.0 Edwina 13:16:18 3/21/98 (3)
    • Re: Where Can I download DirectX 5.0 hilary king 16:24:22 3/24/98 (0)
    • Re: Where Can I download DirectX 5.0 Jean-Louis 12:27:23 3/22/98 (0)
    • Re: Where Can I download DirectX 5.0 james Bravo 09:02:32 3/22/98 (0)
  • Re: Where Can I download DirectX 5.0 me 23:03:48 3/20/98 (0)
  • Re: Where Can I download DirectX 5.0 Dale 17:29:20 3/18/98 (1)
    • Re: Where Can I download DirectX 5.0 bing 18:52:19 3/20/98 (0)
  • Re: Where Can I download DirectX 5.0 y�ltan deveci 16:59:19 3/14/98 (0)
  • Re: Where Can I download DirectX 5.0 Rodrigo Valdes Ascencio 16:40:05 1/30/98 (0)
  • Re: Where Can I download DirectX 5.0 Dave Schweiger 10:27:05 1/25/98 (2)
    • Re: Where Can I download DirectX 5.0 mike 20:36:18 8/22/98 (0)
    • Re: Where Can I download DirectX 5.0 wezzas wilkins 19:55:24 1/26/98 (0)
  • Re: Where Can I download DirectX 5.0 Harold 20:37:49 1/18/98 (51)
    • Re: Where Can I download DirectX 5.0 Jay Carnegie 12:52:32 7/28/98 (0)
    • Re: Where Can I download DirectX 5.0 GREG GREULING 22:29:29 7/27/98 (0)
    • Where Can I find the dialer that works with NO MODEM ? Johnny Kim 09:43:36 7/23/98 (0)
    • Re: Where Can I download DirectX 5.0 Brian Stanger 12:22:35 7/19/98 (2)
      • Re: Where Can I download DirectX 5.0 bmone 15:21:44 7/19/98 (1)
        • Re: Where Can I download DirectX 5.0 justin 07:21:17 7/28/98 (0)
    • Re: Where Can I download DirectX 5.0 Jessica Andrews 21:30:27 7/17/98 (0)
    • Re: Where Can I download DirectX 5.0 Igor 00:12:52 3/25/98 (15)
      • Re: Where Can I download DirectX 5.0 C�sar Arce 12:56:58 9/06/98 (0)
      • Re: Where Can I download DirectX 5.0 answer James Kremer 16:16:51 9/04/98 (0)
      • Re: Where Can I download DirectX 5.0 krupesh 06:40:03 9/01/98 (0)
      • Re: Where Can I download DirectX 5.0 lap hing 03:39:32 7/25/98 (0)
      • Re: Where Can I download DirectX 5.0 fernando i barrola 19:46:09 7/10/98 (4)
        • Re: Where Can I download DirectX 5.0 Dan Cedric T. Delima 11:42:31 7/26/98 (0)
        • Re: Where Can I download DirectX 6.0 Josee Oliviero 10:38:35 7/23/98 (2)
          • Re: Where Can I download DirectX 6.0 Nancy Jaggers 15:04:56 9/07/98 (0)
          • Re: Where Can I download DirectX 6.0 zmc 08:15:56 8/30/98 (0)
      • Re: Where Can I download DirectX 5.0 VICTOR HUERTA 10:21:14 7/10/98 (3)
        • Re: Where Can I download DirectX 5.0 Antonio DaSilva 21:50:08 7/10/98 (2)
          • Re: Where Can I download DirectX 5.0 wu z 22:13:19 7/21/98 (1)
            • Re: Where Can I download DirectX 5.0 Susan Johnson 03:02:21 7/28/98 (0)
      • Re: Where Can I download DirectX 5.0 Fauzea 13:04:34 7/09/98 (1)
        • Re: Where Can I download DirectX 5.0 bo 19:52:24 9/07/98 (0)
    • Re: Where Can I download DirectX 5.0 DANIEL POTVIN 12:10:15 3/19/98 (2)
      • Re: Where Can I download DirectX 5.0 jygf 16:31:53 3/24/98 (0)
      • Re: Where Can I download DirectX 5.0 ewrqe3 15:54:26 3/22/98 (0)
    • Re: Where Can I download DirectX 5.0 jlz 02:39:10 3/19/98 (1)
      • Re: Where Can I download DirectX 5.0 asddd 15:56:07 3/22/98 (0)
    • Re: Where Can I download DirectX 5.0 Denny 18:13:25 3/17/98 (5)
      • Re: Where Can I download DirectX 5.0 Shawn Salerno 16:28:32 6/12/98 (1)
        • Re: Where Can I download DirectX 5.0 Alan Cohen 17:16:52 7/15/98 (0)
      • Re: Where Can I download DirectX 5.0 Matthew G. Czarnecki 16:05:27 3/18/98 (2)
        • Re: Where Can I download DirectX 5.0 Kandi nelson 21:52:00 3/18/98 (1)
          • Re: Where Can I download DirectX 5.0 Kandi 21:57:30 3/18/98 (0)
    • Re: Where Can I download DirectX 5.0 Eric 13:20:09 3/15/98 (3)
      • Re: Where Can I download DirectX 5.0 Liviu Drugus 01:19:32 3/17/98 (1)
        • Re: Where Can I download DirectX 5.0 Ernesto Ibarra 03:35:03 3/17/98 (0)
      • Re: Where Can I download DirectX 5.0 Liviu Drugus 01:18:36 3/17/98 (0)
    • Re: Where Can I download DirectX 5.0 Darryl Brown 20:14:54 1/25/98 (3)
      • Re: Where Can I download DirectX 5.0 David Craig-Smith 10:25:20 3/13/98 (0)
      • Re: Where Can I download DirectX 5.0 David Craig-Smith 10:25:01 3/13/98 (1)
        • Re: Where Can I download DirectX 5.0 derrick paul 20:23:20 3/17/98 (0)
    • Re: Where Can I download DirectX 5.0 ajs 19:16:31 1/24/98 (2)
      • Re: Where Can I download DirectX 5.0 an ji won 21:51:51 1/24/98 (1)
        • Re: Where Can I download DirectX 5.0 arno spruijt 04:41:50 1/26/98 (0)
    • Re: Where Can I download DirectX 5.0 tfg 09:38:49 1/24/98 (5)
      • Re: Where Can I download DirectX 5.0 lars 04:19:20 2/25/98 (1)
        • Re: Where Can I download DirectX 5.0 Stalker 14:17:54 7/16/98 (0)
      • Re: Where Can I download DirectX 5.0 Kevin 11:18:57 1/24/98 (2)
        • Where Can I download DirectX 5.0 Matthew Stiller 04:22:10 7/17/98 (1)
          • Re: Where Can I download DirectX 5.0 Simon Partington 20:58:10 9/01/98 (0)
  • Re: Where Can I download DirectX 5.0 Fredrik 17:04:31 1/17/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Fredrik on January 17, 1998 at 17:04:31:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an emulator.

DirectX can be downloaded from
www.microsoft.com/directx

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Harold on January 18, 1998 at 20:37:49:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Jay Carnegie 12:52:32 7/28/98 (0)
  • Re: Where Can I download DirectX 5.0 GREG GREULING 22:29:29 7/27/98 (0)
  • Where Can I find the dialer that works with NO MODEM ? Johnny Kim 09:43:36 7/23/98 (0)
  • Re: Where Can I download DirectX 5.0 Brian Stanger 12:22:35 7/19/98 (2)
    • Re: Where Can I download DirectX 5.0 bmone 15:21:44 7/19/98 (1)
      • Re: Where Can I download DirectX 5.0 justin 07:21:17 7/28/98 (0)
  • Re: Where Can I download DirectX 5.0 Jessica Andrews 21:30:27 7/17/98 (0)
  • Re: Where Can I download DirectX 5.0 Igor 00:12:52 3/25/98 (15)
    • Re: Where Can I download DirectX 5.0 C�sar Arce 12:56:58 9/06/98 (0)
    • Re: Where Can I download DirectX 5.0 answer James Kremer 16:16:51 9/04/98 (0)
    • Re: Where Can I download DirectX 5.0 krupesh 06:40:03 9/01/98 (0)
    • Re: Where Can I download DirectX 5.0 lap hing 03:39:32 7/25/98 (0)
    • Re: Where Can I download DirectX 5.0 fernando i barrola 19:46:09 7/10/98 (4)
      • Re: Where Can I download DirectX 5.0 Dan Cedric T. Delima 11:42:31 7/26/98 (0)
      • Re: Where Can I download DirectX 6.0 Josee Oliviero 10:38:35 7/23/98 (2)
        • Re: Where Can I download DirectX 6.0 Nancy Jaggers 15:04:56 9/07/98 (0)
        • Re: Where Can I download DirectX 6.0 zmc 08:15:56 8/30/98 (0)
    • Re: Where Can I download DirectX 5.0 VICTOR HUERTA 10:21:14 7/10/98 (3)
      • Re: Where Can I download DirectX 5.0 Antonio DaSilva 21:50:08 7/10/98 (2)
        • Re: Where Can I download DirectX 5.0 wu z 22:13:19 7/21/98 (1)
          • Re: Where Can I download DirectX 5.0 Susan Johnson 03:02:21 7/28/98 (0)
    • Re: Where Can I download DirectX 5.0 Fauzea 13:04:34 7/09/98 (1)
      • Re: Where Can I download DirectX 5.0 bo 19:52:24 9/07/98 (0)
  • Re: Where Can I download DirectX 5.0 DANIEL POTVIN 12:10:15 3/19/98 (2)
    • Re: Where Can I download DirectX 5.0 jygf 16:31:53 3/24/98 (0)
    • Re: Where Can I download DirectX 5.0 ewrqe3 15:54:26 3/22/98 (0)
  • Re: Where Can I download DirectX 5.0 jlz 02:39:10 3/19/98 (1)
    • Re: Where Can I download DirectX 5.0 asddd 15:56:07 3/22/98 (0)
  • Re: Where Can I download DirectX 5.0 Denny 18:13:25 3/17/98 (5)
    • Re: Where Can I download DirectX 5.0 Shawn Salerno 16:28:32 6/12/98 (1)
      • Re: Where Can I download DirectX 5.0 Alan Cohen 17:16:52 7/15/98 (0)
    • Re: Where Can I download DirectX 5.0 Matthew G. Czarnecki 16:05:27 3/18/98 (2)
      • Re: Where Can I download DirectX 5.0 Kandi nelson 21:52:00 3/18/98 (1)
        • Re: Where Can I download DirectX 5.0 Kandi 21:57:30 3/18/98 (0)
  • Re: Where Can I download DirectX 5.0 Eric 13:20:09 3/15/98 (3)
    • Re: Where Can I download DirectX 5.0 Liviu Drugus 01:19:32 3/17/98 (1)
      • Re: Where Can I download DirectX 5.0 Ernesto Ibarra 03:35:03 3/17/98 (0)
    • Re: Where Can I download DirectX 5.0 Liviu Drugus 01:18:36 3/17/98 (0)
  • Re: Where Can I download DirectX 5.0 Darryl Brown 20:14:54 1/25/98 (3)
    • Re: Where Can I download DirectX 5.0 David Craig-Smith 10:25:20 3/13/98 (0)
    • Re: Where Can I download DirectX 5.0 David Craig-Smith 10:25:01 3/13/98 (1)
      • Re: Where Can I download DirectX 5.0 derrick paul 20:23:20 3/17/98 (0)
  • Re: Where Can I download DirectX 5.0 ajs 19:16:31 1/24/98 (2)
    • Re: Where Can I download DirectX 5.0 an ji won 21:51:51 1/24/98 (1)
      • Re: Where Can I download DirectX 5.0 arno spruijt 04:41:50 1/26/98 (0)
  • Re: Where Can I download DirectX 5.0 tfg 09:38:49 1/24/98 (5)
    • Re: Where Can I download DirectX 5.0 lars 04:19:20 2/25/98 (1)
      • Re: Where Can I download DirectX 5.0 Stalker 14:17:54 7/16/98 (0)
    • Re: Where Can I download DirectX 5.0 Kevin 11:18:57 1/24/98 (2)
      • Where Can I download DirectX 5.0 Matthew Stiller 04:22:10 7/17/98 (1)
        • Re: Where Can I download DirectX 5.0 Simon Partington 20:58:10 9/01/98 (0)

Post a Followup

Name:


WHICH COMPILER IS BEST 4 DIRECTX5?

Posted by J Heggie on January 18, 1998 at 21:05:37:

OK guys simple one.... Which is the best, most compatable compiler for DIRECT X 5?

Microsoft Visual C++ V5 PRO looks like the best...

Replies would be greatly appreciated....

Follow Ups:

  • Re: WHICH COMPILER IS BEST 4 DIRECTX5? Nick Caldwell 16:46:46 1/20/98 (3)
    • Re: WHICH COMPILER IS BEST 4 DIRECTX5? Wolfgang R�ssler 06:25:35 3/11/98 (2)
      • Re: WHICH COMPILER IS BEST 4 DIRECTX5? PAULO MARTINHO 20:24:00 6/17/98 (0)
      • Re: WHICH COMPILER IS BEST 4 DIRECTX5? JORGE 16:04:32 6/09/98 (0)

Post a Followup

Name:


DirectX... I wanna learn... but need a starting point

Posted by James on January 19, 1998 at 01:08:41:

I am 16 years old and programmed in VB for a while until
i realized that there were bigger and better things for
me to do. I have learned C++ (using VC++) and havn't
programmed for weeks beceause i just don't know where to
start... I am hoping someone can point me in the right
direction to learn a bit of DirectSound or draw or
anything pretaining to DirectX. Remember that i am
JUST starting DirectX so if you could donate a simple
bit of code or a URL to a nice site I would be VERY
greatfull!

Thanks a LOT,
--James

Follow Ups:

  • Re: DirectX... I wanna learn... but need a starting point Sean Barton 01:56:44 1/19/98 (0)

Post a Followup

Name:


Direct3DRM: Mouse Coordinates to Window Coordinates

Posted by Sean Barton on January 19, 1998 at 01:46:49:

Using Direct3d Retained Mode:

Does anyone know how to effectively transform the mouse cursor coordinates to world coordinates pertaining to the scene? I want to display the coordinates of the vertex I am selecting with the mouse on a status window.
I've tried using IDIRECT3DRMVIEWPORT::Transform and InverseTransform functions, but I am getting unexpecting results (what the hell is a D3DRMVECTOR4D anyway?).

Any help would be appreciated!

-Sean Barton (aka Bartron)

Follow Ups:

Post a Followup

Name:


Re: DirectX... I wanna learn... but need a starting point

Posted by Sean Barton on January 19, 1998 at 01:56:44:

In Reply to: DirectX... I wanna learn... but need a starting point posted by James on January 19, 1998 at 01:08:41:

James,
I was in the same boat about a year ago (I know how frustrating it is to get started).
Anyway, I think the best thing you can do now is get a good book on DirectX and another on Win32 programming and practice, practice, practice! There is a learning curve of about 10 months ahead of you before you can program anything interesting with confidence, so you'll have to be patient (but hey, your 16, so don't worry).

The following is a collection of books that every DirectX/Windows programmer should have:

-Spells of Fury (by Michael Norton, Waite Group Press)

-Programming Windows 95 (Charles Petzold, Microsoft Press)

-Win32 Programming API Bible - Book 1 (Richard Simon, Waite Group Press)

- good luck!
Sean Barton (aka Bartron)

: I am 16 years old and programmed in VB for a while until
: i realized that there were bigger and better things for
: me to do. I have learned C++ (using VC++) and havn't
: programmed for weeks beceause i just don't know where to
: start... I am hoping someone can point me in the right
: direction to learn a bit of DirectSound or draw or
: anything pretaining to DirectX. Remember that i am
: JUST starting DirectX so if you could donate a simple
: bit of code or a URL to a nice site I would be VERY
: greatfull!

: Thanks a LOT,
: --James

Follow Ups:

Post a Followup

Name:


Error #9

Posted by Guloo on January 19, 1998 at 04:39:53:

Why does DirectX fail to install on my machine?
Why does system display error #9?
These all happen only with DirectX 5.Why?

Follow Ups:

Post a Followup

Name:


DirectX5.0 and game input

Posted by SuperD on January 19, 1998 at 05:34:41:

I have a y adapter that connects 2 gamepads to my sound card's gameport. I had no problem setting up two joysticks under DirectX 3.0. However, after I installed 5.0 it no longer recognizes that I have a second joystick connected. Any suggestions?

SuperD!

Follow Ups:

  • Re: DirectX5.0 and game input Fred Dings 14:24:54 1/24/98 (3)
    • Re: DirectX5.0 and game input justin 23:42:18 1/30/98 (1)
      • Re: DirectX5.0 and game input cheng 11:41:16 2/07/98 (0)
    • Re: DirectX5.0 and game input Don Martin 20:28:55 1/26/98 (0)

Post a Followup

Name:


Help: Need D3D info/samples involving Animation, keyframe etc

Posted by Max McCollister on January 19, 1998 at 11:49:22:

I have been working on Direct 3D stuff lately and have been having some problems using Animated Models that I created in 3D Studio Max 2.0 and converted using the conv3ds.exe file that comes with the DirectX SDK. I have looked through the DirectX help files but they don't give me a very good undersatanding of it.

If you know where I can get some more detailed info on using Animated meshs or if you know where to get some working samples, I would be very thankfull.

-Max McCollister

toloquta@ionet.net

Follow Ups:

Post a Followup

Name:


Re: Where can I get directX5.0

Posted by Max McCollister on January 19, 1998 at 11:51:17:

In Reply to: Re: Where can I get directX5.0 posted by oxi on January 17, 1998 at 14:29:20:

DOWNLOAD DIRECTX 5.0 SDK and USER VERSIONs at http://www.microsoft.com/directx/

  • MICROSOFT DIRECTX PAGE

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 locks up the system!!!

Posted by tr on January 19, 1998 at 19:36:35:

In Reply to: Re: DirectX 5.0 locks up the system!!! posted by Me on January 13, 1998 at 22:49:40:

: : I'm having a true problem. I'm trying to play
: : Age of Empires (and other games using DirectX 5.0).
: : Every so often, an event will occur causing a sound
: : event to play, and the system locks up completely!
: : I can hear the sound in audio RAM playing over and
: : over again, but the CPU doesn't respond to anything!
: : Any ideas?

: : I've got a P233 MMX/ with Creative Lab Vibra 16,
: : running Win 95 (unfortunately).
: : I'm going to go out on a limb and say: Microsoft programmers/
: : programming is THE MOST mediocre I've EVER seen!! I've
: : never seen stuff so unreliable, with so little support
: : and so little responsability taken to correct problems.

try restoring your old display and sound card drivers, that was the problem that i had when Age of Empires crashed on my system.

Follow Ups:

Post a Followup

Name:


DirectX and MFC.

Posted by Joris Timmermans (Mad Keith) on January 20, 1998 at 12:22:40:

Has anyone got any info on programming directx in MFC?
My attempts are all failing in GPF's.

Follow Ups:

  • Re: DirectX and MFC. if you read this you are gay 10:40:41 3/19/98 (0)
  • Re: DirectX and MFC. Bartron 16:08:07 1/20/98 (4)
    • Re: DirectX and MFC. Serg 08:15:27 1/23/98 (3)
      • Re: DirectX and MFC. Jeff Thelen 16:08:56 1/24/98 (2)
        • Re: DirectX and MFC. CHRIS! 17:47:46 1/28/98 (1)
          • Re: DirectX and MFC. Joris Timmermans 13:31:33 3/03/98 (0)

Post a Followup

Name:


directx5b

Posted by sean lusk on January 20, 1998 at 16:01:44:

Where is it?! I incorrectly installed DirectX
and this has corrupted my sound and video cards.
Someone has told me the remedy is DirectX5B. How
can I find it PLEASE?

Follow Ups:

Post a Followup

Name:


Re: DirectX and MFC.

Posted by Bartron on January 20, 1998 at 16:08:07:

In Reply to: DirectX and MFC. posted by Joris Timmermans (Mad Keith) on January 20, 1998 at 12:22:40:

Some DirectX books teach you to program DirectX exclusively in MFC (such as Cutting Edge Direct3D Programming, by Stan Trujillo, Coriolis Group Books).

I recommend NOT programming DirectX applicatons in MFC as it will significantly slow down your application. You should really consider using Win32 as it is faster and puts you in more control of your application. Besides, it is something that every windows programmer should know.

-Sean

: Has anyone got any info on programming directx in MFC?
: My attempts are all failing in GPF's.

Follow Ups:

  • Re: DirectX and MFC. Serg 08:15:27 1/23/98 (3)
    • Re: DirectX and MFC. Jeff Thelen 16:08:56 1/24/98 (2)
      • Re: DirectX and MFC. CHRIS! 17:47:46 1/28/98 (1)
        • Re: DirectX and MFC. Joris Timmermans 13:31:33 3/03/98 (0)

Post a Followup

Name:


Re: WHICH COMPILER IS BEST 4 DIRECTX5?

Posted by Nick Caldwell on January 20, 1998 at 16:46:46:

In Reply to: WHICH COMPILER IS BEST 4 DIRECTX5? posted by J Heggie on January 18, 1998 at 21:05:37:

: OK guys simple one.... Which is the best, most compatable compiler for DIRECT X 5?

: Microsoft Visual C++ V5 PRO looks like the best...

: Replies would be greatly appreciated....

I am using MSVC5 pro, it is the best compiler
I have used in terms of user interface. I have
read that it generates inferior code compared
to other compilers though (I can't say I've
noticed a difference). Anyways, Microsoft
makes the OS, MFC, and DirectX so I figure I
might as well go all the way and use their
compiler too.

Follow Ups:

  • Re: WHICH COMPILER IS BEST 4 DIRECTX5? Wolfgang R�ssler 06:25:35 3/11/98 (2)
    • Re: WHICH COMPILER IS BEST 4 DIRECTX5? PAULO MARTINHO 20:24:00 6/17/98 (0)
    • Re: WHICH COMPILER IS BEST 4 DIRECTX5? JORGE 16:04:32 6/09/98 (0)

Post a Followup

Name:


Re: How do I use 16-bpp surfaces?

Posted by Dennis Muller on January 20, 1998 at 22:11:33:

In Reply to: How do I use 16-bpp surfaces? posted by Fredrik Andersson on January 14, 1998 at 13:53:09:

: I got a problem with 16-bits-per-pixel DirectDraw surfaces.
: When I try to use the Lock() function to put individual
: pixels in my 16bpp surface, they all go to the left half
: of the surface. Also, they get strange, random-looking colors.
: I tried to use the RGB macro, but it dosen't help.
: As far as I see, the Lock() function returns an
: 8-bit pointer (char*). Can that be used in 16bpp surfaces?
: And, what's the difference between 16bpp and 24bpp,
: except for the color depth?
: Can I use RGB values to specify pixels in a 16bpp
: surface as well? Which mode would you recommend?

: I will be very happy for any help I get! Thanks!

I too once had trouble with the 16 bit pixel depth and had
someone clue me in on my mistakes. Here is some code that I
use. The LowBitPos, HighBitPos, and GetPixelFormat is modified
code from the book Windows Graphics Programming by Stan Trujillo.
Sorry not many comments but email me if you have any questions.

// public variables
LPDIRECTDRAW lpDD; // DirectDraw object
LPDIRECTDRAWSURFACE lpDDSPrimary; // DirectDraw primary surface
LPDIRECTDRAWSURFACE lpDDSBack; // DirectDraw back surface
DDSURFACEDESC ddsd;
WORD numRedBits;
WORD numGreenBits;
WORD numBlueBits;

WORD LowBitPos( DWORD dword )
{
DWORD test=1;
for (WORD i=0;i>=1;
}
return 0;
}

void GetPixelFormat(void)
{
DDPIXELFORMAT format;

ZeroMemory(&format, sizeof(format));
format.dwSize = sizeof(format);
if (lpDDSPrimary->GetPixelFormat(&format) == DD_OK)
{
//WORD loRedBit = LowBitPos(format.dwRBitMask);
//WORD hiRedBit = HighBitPos(format.dwRBitMask);
//numRedBits = (hiRedBit - loRedBit + 1 );

WORD loGreenBit = LowBitPos(format.dwGBitMask);
WORD hiGreenBit = HighBitPos(format.dwGBitMask);
numGreenBits = (hiGreenBit - loGreenBit + 1 );

if (numGreenBits == 5)
{
numRedBits = 10;
}
else
numRedBits = 11;

//WORD loBlueBit = LowBitPos(format.dwBBitMask);
//WORD hiBlueBit = HighBitPos(format.dwBBitMask);
//numBlueBits = (hiBlueBit - loBlueBit + 1 );
}
}

WORD RGB16(int iRed, int iGreen, int iBlue)
{
WORD Color = ((iRed > 1) + X);
*lpDDMemory = Color;
}

void LockBackBuffer(void)
{
HRESULT ddrval;

// LOCK BACKBUFFER
ZeroMemory(&ddsd, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ddrval = lpDDSBack->Lock(0, &ddsd, DDLOCK_WAIT, 0);
}

void UnlockBackBuffer(void)
{
// UNLOCK BACKBUFFER
lpDDSBack->Unlock(&ddsd);
}

To use, getpixelformat then lock surface, draw pixels, unlock
surface, flip or blit surface.

Follow Ups:

Post a Followup

Name:


16bpp 2D Special Effects

Posted by Rob on January 21, 1998 at 08:52:41:

anyone out there know if you can apply special affects to surfaces as you blit them onto the screen. my screen is a 16bpp mode, I am currently using 256 colour images and blitting them onto my screen surface, but I want to be able to fade the screen/images and also if possible shade the images as they are placed on the screen to represent light sourcing. anyone out there with any ideas? thanks for any help you can provide..

Follow Ups:

Post a Followup

Name:


I can program with directx starting from the Visual basic

Posted by Fabio Augusto on January 21, 1998 at 13:33:48:

I can program with directx starting from the Visual basic

Follow Ups:

Post a Followup

Name:


BocaResearch Modem/SoundCard

Posted by Leigh on January 21, 1998 at 15:55:35:

I have a Boca Research se34srs Modem/Soundcard.
When I installed DirectSound off of Directx 5.0 it screwed everything up.
Now All I get is stuttering with all of my wave files.
Is there a patch for this??
Any help would be much appreciated!

Thanks!!
LH

Follow Ups:

Post a Followup

Name:


DirectPlay samples

Posted by Eugene on January 22, 1998 at 04:49:50:

Hello fellows,

I am looking for DirectPlay samples on the net.
Does anybody know where I can find them ??

Thanks !

Follow Ups:

Post a Followup

Name:


D3DRM2 using new VC5 AppWizard project, (stupid link error!)

Posted by Jordan on January 22, 1998 at 05:37:05:

What special code do you need to put into a newly created
AppWizard MFC project (VC5), so that it doesn't give link erros
like 2001, doesn't recognise ...d3drm2 object.

I use that guys D3Dwizard usually, but it's too junky,
so I switched to appwizard, but right when I try creating
a d3drm2 object or something using QueryInterface, I get
link errors... I'm dying here, I'm to stuburn to turn back,
but to stupid to overcome this one...

Follow Ups:

  • Re: D3DRM2 using new VC5 AppWizard project, (stupid link error!) Bartron 19:42:56 1/22/98 (1)
    • Re: D3DRM2 using new VC5 AppWizard project, (stupid link error!) Jordan :) 23:02:14 1/22/98 (0)

Post a Followup

Name:


Retained mode AND Immediate mode?

Posted by jordan on January 22, 1998 at 05:44:41:

I'm using retained mode to create a windowed 3D program
but I want some of the features that immediate mode has to offer.

-like RENDERSTATES...

Is there a way of using my device created with RM and change
the renderstates of it.

I tried ::GetDirect3DDevice2 to get what I thought was the
base of LPDIRECT3DRMDEVIEC2, but when I changed the renderstates
of it, I GOT NOTHING...

Follow Ups:

Post a Followup

Name:


Removal of a FACE from MESHBUILDER object

Posted by Jordan on January 22, 1998 at 05:55:14:

How do you go about removing a face from a MESHBUILDER
object?

Follow Ups:

  • Re: Removal of a FACE from MESHBUILDER object Sean 20:39:23 1/25/98 (1)
    • Re: Removal of a FACE from MESHBUILDER object Thanx sean, Maybe DirectX6 eh? 13:47:30 1/26/98 (0)

Post a Followup

Name:


Textures & Video Memory...

Posted by Daniele Trambusti on January 22, 1998 at 07:54:56:

I have a Matrox Mistique. With this card all
the texture must be in video memory when using HAL.
Problem: There is not enough memory to store in
video memory all the textures I use to render
the frame. Any suggest?

Thanks!!

Follow Ups:

  • Re: Textures & Video Memory... Jordan 14:05:35 1/22/98 (1)
    • Re: Textures & Video Memory... Daniele Trambusti 09:57:50 1/26/98 (0)

Post a Followup

Name:


How can I use the DirectX with DELPHI ? - (sorry, I don큧 speak English well)

Posted by Soul on January 22, 1998 at 10:13:36:

Please, If anybody use DELPHI with DIRECTX
tell me how!

What is the DirectX SDK? I must Donwload from MS
is I want use the DirectX functions in DELPHI?
(sure I have the simple DirectX5 but not the SDK)

Please if you can, help me! Thanks....

If you have experient with Delphi and the DirectX,
please send me a letter or an example.

Follow Ups:

  • Re: How can I use the DirectX with DELPHI ? - (sorry, I don큧 speak English well) Dennis Muller 13:57:59 1/22/98 (1)
    • Re: How can I use the DirectX with DELPHI ? - (sorry, I don큧 speak English well) Fussel 09:11:13 2/07/98 (0)

Post a Followup

Name:


Re: Borland C++ Builder

Posted by Jack Strohm on January 22, 1998 at 13:39:12:

In Reply to: Borland C++ Builder posted by Tony Leotta on January 15, 1998 at 12:40:30:

: Is anyone doing anything with Borland C++ Builder?
: I've tried to get some sample apps running
: with no luck.

: Do Direct X apps run under Borland C++ Builder?

I've been writing some DirectX apps with Borland C++ Builder, in fact that is all that I use.

If you haven't found any sites yet that help you out I can email you some C++ Builder code for you
to look at.

Give me an email if you are interested.

Follow Ups:

Post a Followup

Name:


Re: How can I use the DirectX with DELPHI ? - (sorry, I don큧 speak English well)

Posted by Dennis Muller on January 22, 1998 at 13:57:59:

In Reply to: How can I use the DirectX with DELPHI ? - (sorry, I don큧 speak English well) posted by Soul on January 22, 1998 at 10:13:36:

: Please, If anybody use DELPHI with DIRECTX
: tell me how!

: What is the DirectX SDK? I must Donwload from MS
: is I want use the DirectX functions in DELPHI?
: (sure I have the simple DirectX5 but not the SDK)

: Please if you can, help me! Thanks....

:
: If you have experient with Delphi and the DirectX,
: please send me a letter or an example.

Here is an URL for you to check out.
http://www.ex.ac.uk/~PMBearne/DGC.html
It has some free ware components to use and
also the source code for the components. The
components use the delphi directx units converted by Blake Stone. He has the latest
units on his web site. Do a search on delphi and directx should turn up Blake Stone's page.

Follow Ups:

  • Re: How can I use the DirectX with DELPHI ? - (sorry, I don큧 speak English well) Fussel 09:11:13 2/07/98 (0)

Post a Followup

Name:


Re: Textures & Video Memory...

Posted by Jordan on January 22, 1998 at 14:05:35:

In Reply to: Textures & Video Memory... posted by Daniele Trambusti on January 22, 1998 at 07:54:56:

I had an 8MEG mystique, I used retained mode though and
shit loads of textures, I didn't have any problems when
using HAL, exept once, I loaded more than normal textures
and the textures looked to be pixelated, (lowered in resolution)
the quality of the textures were bad, but it was still
excelerated, but it did work.

solutions, if you have cash..

-get the 8meg card,
-but get a better card, the mystique is nice for high resolution
windowed mode 3d but if that's what u need, get a xpert@play 8meg
it'll give you up to 1280x1024, full buffered, bilinear filtered,
alpha stippled effect, and good fog and better speed....
-or get an AGP version of xpert@... so you'll never have texture
buffer shortage, it'll access your system ram...

I thought the mystique was rockin' when I first got it long time ago
but now, it just bights...

: I have a Matrox Mistique. With this card all
: the texture must be in video memory when using HAL.
: Problem: There is not enough memory to store in
: video memory all the textures I use to render
: the frame. Any suggest?

: Thanks!!

Follow Ups:

  • Re: Textures & Video Memory... Daniele Trambusti 09:57:50 1/26/98 (0)

Post a Followup

Name:


Re: D3DRM2 using new VC5 AppWizard project, (stupid link error!)

Posted by Bartron on January 22, 1998 at 19:42:56:

In Reply to: D3DRM2 using new VC5 AppWizard project, (stupid link error!) posted by Jordan on January 22, 1998 at 05:37:05:

Do you have dxguid.lib linked into your project?
Are you using the lib files that pertain to DirectX 5.0?
Usually, when I have a link error, it's because I failed to link one of the following files to my project... dxguid.lib, ddraw.lib, d3drm.lib

-hope this helps
-Bartron

: What special code do you need to put into a newly created
: AppWizard MFC project (VC5), so that it doesn't give link erros
: like 2001, doesn't recognise ...d3drm2 object.

: I use that guys D3Dwizard usually, but it's too junky,
: so I switched to appwizard, but right when I try creating
: a d3drm2 object or something using QueryInterface, I get
: link errors... I'm dying here, I'm to stuburn to turn back,
: but to stupid to overcome this one...

Follow Ups:

  • Re: D3DRM2 using new VC5 AppWizard project, (stupid link error!) Jordan :) 23:02:14 1/22/98 (0)

Post a Followup

Name:


Re: D3DRM2 using new VC5 AppWizard project, (stupid link error!)

Posted by Jordan :) on January 22, 1998 at 23:02:14:

In Reply to: Re: D3DRM2 using new VC5 AppWizard project, (stupid link error!) posted by Bartron on January 22, 1998 at 19:42:56:

Shit, thanx G, I got pissed, took all my lib files and
put them in my project immediate directory and included
dxguid.lib to my implementation (cpp) file folder in
vc... COMPILE 0 ERRORS 0 WARNINGS, I luv seeing that!

thanx again..

: Do you have dxguid.lib linked into your project?
: Are you using the lib files that pertain to DirectX 5.0?
: Usually, when I have a link error, it's because I failed to link one of the following files to my project... dxguid.lib, ddraw.lib, d3drm.lib

: -hope this helps
: -Bartron

Follow Ups:

Post a Followup

Name:


Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help?

Posted by Jeff on January 22, 1998 at 23:27:23:

Hey guys and girls, I've got this really horrible problem. I hope somebody knows the solution to this, or has had this happen to them before. Here is the problem:
Ever since I installed Direct X 5.0, my computer keeps locking up. I'm not sure if it is locked up, because it keeps playing the same sound effect over and over again. Say I'm playing Diablo, and I click on something. I hear the sword swinging, but that's ALL I hear. It keeps repeating the sword's sound effect over and over and over...until I have to turn my volume down. And also, my screen freezes, and I can't do anything about it. I don't know what's wrong...but here is my system info:
Pentium 233 MMX, Sound Blaster 16, and S3 ViRGE Video Card, with 32 Mb RAM and 4.3 GB Hard Drive.
Can anyone tell me how to fix this problem?? My computer cost so much, like $1400 and I thought it would be really good. But I think there's something wrong with Direct X 5. Can anyone help me??? Maybe someone had this happen to them, and will help me fix it. Or else, if nothing works, can anyone tell me how to Uninstall Direct X 5, because when I go to Add/Remove Programs in the Control Panel, I click on "Uninstall DirectX". It brings me up to a menu that says "Restore Audio/Display Drivers" I restored both of them, but my computer keeps freezing still. And Direct X 5.0 is not uninstalled!! If anyone can help me, please respond!! Thanks

Follow Ups:

  • Re: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help? Bob 05:37:54 6/06/98 (0)
  • Re: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help? EvAcLeAr 19:21:18 5/18/98 (0)
  • Re: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help? Ian butler 08:58:01 2/02/98 (1)
    • Re: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help? Du쉆n 02:44:41 2/20/98 (0)

Post a Followup

Name:


Re: Sample

Posted by Adriano Oliveira on January 23, 1998 at 08:14:24:

In Reply to: Sample posted by Vincent Bilodeau on January 15, 1998 at 19:32:57:

: Does anybody have a simple Direct 3D retained mode fullscreen sample with a device created from a surface so I can check if I'm wrong or my compiler is wrong.

See

http://www.maidex.demon.co.uk/cdxrm.htm

Follow Ups:

Post a Followup

Name:


Re: DirectX and MFC.

Posted by Serg on January 23, 1998 at 08:15:27:

In Reply to: Re: DirectX and MFC. posted by Bartron on January 20, 1998 at 16:08:07:

I disagree. On medium-end stuff like PMMX -166,200,233
or PII there isn't any difference in performence.
If u writing windowed app it's easer to use MFC

Follow Ups:

  • Re: DirectX and MFC. Jeff Thelen 16:08:56 1/24/98 (2)
    • Re: DirectX and MFC. CHRIS! 17:47:46 1/28/98 (1)
      • Re: DirectX and MFC. Joris Timmermans 13:31:33 3/03/98 (0)

Post a Followup

Name:


RIVA 128 AGP - textures

Posted by Serg on January 23, 1998 at 08:18:50:

Did somebody tried nonlocal textures with RIVA 128 AGP?
I got some veird msg from DX5 debug
Serg

Follow Ups:

Post a Followup

Name:


How do I copy a 8bpp palettized matrix onto a 16bpp surface?

Posted by Fredrik Andersson on January 23, 1998 at 13:51:38:

How do I copy a matrix of 8bpp palettized pixels
onto a 16bpp surface? I don't seem to get the Lock()
function right. Anyone with some code describing how to load
an 8bpp image from disk and show it on a 16bpp surface?
I would very much appreciate any help!

Follow Ups:

  • Re: How do I copy a 8bpp palettized matrix onto a 16bpp surface? Nick Caldwell 22:28:51 1/23/98 (0)
  • Re: How do I copy a 8bpp palettized matrix onto a 16bpp surface? franko 18:51:12 1/23/98 (0)

Post a Followup

Name:


Re: How do I copy a 8bpp palettized matrix onto a 16bpp surface?

Posted by franko on January 23, 1998 at 18:51:12:

In Reply to: How do I copy a 8bpp palettized matrix onto a 16bpp surface? posted by Fredrik Andersson on January 23, 1998 at 13:51:38:

Well you are going to have to convert the palettized 8bpp image to 16bpp.. The easiest way to do this is with the GDI. Do a ->GetDC on both of your direct draw surfaces, then do a GDI Blt from the 8bpp to the 16bpp. This can be quite slow however. This other way is to write your own color conversion code using surface ->Lock's.

I've never converted from palette 8 to 16, but it should be pretty simple (going the other way is hard cause you have to optimize a palette).

try something like this:

FOR all pixels:
Get an 8bpp pixel,
Look up its RGB color in the palette,
Convert this to a 16bpp color,
Put this pixel into destination 16bpp surface

So lets say you grab BYTE 124 in 8bpp; You look it up in palette and palette[124] = RGB(128, 128, 128); RGB are all 8bit, you want to convert them to 5bit and pack them into a WORD. so 128/256 = what/32?? 16. pack 3 16's into a WORD and store it in the 16bpp surface, onto next pixel...

Note, I assumed 555 rgb. there are also 565 16bpp surfaces, so the green has an extra bit and would be in the range 0..64.

Make sense?

: How do I copy a matrix of 8bpp palettized pixels
: onto a 16bpp surface? I don't seem to get the Lock()
: function right. Anyone with some code describing how to load
: an 8bpp image from disk and show it on a 16bpp surface?
: I would very much appreciate any help!

Follow Ups:

Post a Followup

Name:


DirectX and NT 4.0

Posted by Carlos on January 23, 1998 at 19:10:19:

Does anyone knows how to put DirectX and NT 4.0 in the same bag?

Tanks!!

Follow Ups:

  • Re: DirectX and NT 4.0 Brian Shea 14:01:35 1/25/98 (0)

Post a Followup

Name:


NT40 Real SoundBlaster or ESS direct sound driver required

Posted by Guillermo Hdz on January 23, 1998 at 19:57:14:

Plase let me know where can I find a driver to test Direct Sound on Windows NT40..I have Sound Blasters and ESS cards to test it...

Please.....

Follow Ups:

Post a Followup

Name:


Re: How do I copy a 8bpp palettized matrix onto a 16bpp surface?

Posted by Nick Caldwell on January 23, 1998 at 22:28:51:

In Reply to: How do I copy a 8bpp palettized matrix onto a 16bpp surface? posted by Fredrik Andersson on January 23, 1998 at 13:51:38:

Make a 16 bit surface, load your
8 bit image onto it using DDLoadBitmap from
ddutil.c that comes \w DX SDK. It
automatically converts the 8 bit palette to
it's 16 bit equivalent. The code would be something
like:

//Load Bitmap (automatically converts to 16 bit)
LPDDSURFACE Surf16Bit = DDLoadBitmap(lpDD, "bitmap", 0,0);

Follow Ups:

Post a Followup

Name:


DirectX And MFC

Posted by Arrowhead on January 24, 1998 at 03:18:19:

Don't plan on creating an application on top of MFC.
After weeding out all the MFC references in an app
I was working on, I compiled as a plainy old Win32 app.
The speedup was incredible. So if you think the MFC
overhead is worth having classes such as CString, CArray,
or CPoint. Stop thinking, it isn't.

Just a note

Follow Ups:

  • Re: DirectX And MFC CHRIS! 17:41:14 1/28/98 (0)

Post a Followup

Name:


Massive Desparity - Available and RealWorld Source

Posted by Don Martin on January 24, 1998 at 06:18:22:

As I read through these messages... it's painfully
obvious that everyone else is in the same boat that I am.
There is nothing worthwhile available to the public in
the way of source code for DirectX programming. It
seems to me that the gap between Fox & Bear and Total Annihilation
in terms of what source code is available to study and learn from, is massive.

Surely someone out there has a heart and can cough up
some decent code for people to toy with, and with a lot
of help from God, get over this initial learning hump.
I've been playing around with DirectX for about 3 months
now... scouring the web continuously for any sign of worthy
source code, and have found nothing, and still can't put
a nice 3D object on a background image map and make it move.

I have every book published on DirectX and several CD's with example
code and such - this is rediculous. Most of this crap won't
even compile or was written for DirectX2.

The owner of the site: Dude, if you have some decent code
from prior posts or whatever... for pete's sake - put it up.

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by tfg on January 24, 1998 at 09:38:49:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Harold on January 18, 1998 at 20:37:49:

: : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 lars 04:19:20 2/25/98 (1)
    • Re: Where Can I download DirectX 5.0 Stalker 14:17:54 7/16/98 (0)
  • Re: Where Can I download DirectX 5.0 Kevin 11:18:57 1/24/98 (2)
    • Where Can I download DirectX 5.0 Matthew Stiller 04:22:10 7/17/98 (1)
      • Re: Where Can I download DirectX 5.0 Simon Partington 20:58:10 9/01/98 (0)

Post a Followup

Name:


IS directX5.0 compatible with the matrox millenium videocard?

Posted by Davy Weynants on January 24, 1998 at 10:18:23:

I would like to know something about directX5.0.
Last month I've bought TOMBRAIDER 2 but when I play
the quality of the images are very bad. I have a Matrox Millenium videocard. Is directX5.0 compatible with this card??????????????

P.S.:My system requirements are OK
(pentium133,48MBram,2MBVRAM)

Follow Ups:

  • Re: IS directX5.0 compatible with the matrox millenium videocard? Mr.Goodbar 01:12:32 5/23/98 (0)
  • Re: IS directX5.0 compatible with the matrox millenium videocard? DW 20:53:44 4/21/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Kevin on January 24, 1998 at 11:18:57:

In Reply to: Re: Where Can I download DirectX 5.0 posted by tfg on January 24, 1998 at 09:38:49:

: : : Where Can I download DirectX 5.0. I need it for a game.

The dutch version pleas.

Follow Ups:

  • Where Can I download DirectX 5.0 Matthew Stiller 04:22:10 7/17/98 (1)
    • Re: Where Can I download DirectX 5.0 Simon Partington 20:58:10 9/01/98 (0)

Post a Followup

Name:


i just wanna decent book

Posted by Shaun on January 24, 1998 at 11:23:28:

can anyone recommend a book that covers DirectX without
focusing so much on Direct3D? and something that covers
more than DirectDraw Programming(the worst book I've
ever read)... like scrolling, sprites, etc...
thank u =)

Follow Ups:

  • Re: i just wanna decent book Nick Caldwell 17:35:20 1/24/98 (0)

Post a Followup

Name:


help for directx 5.0

Posted by Fred Dings on January 24, 1998 at 14:19:53:

I have an stb 128 video card on my new computer, which
dell told me was the best 3D card available at the
time, 12/8/97.

I just got a disk from PC world with demos on it.
The Shipwreckers demo says I do not have enough
3d acceleration hardware. The TombII demo says I need
directx 5.0

I did a search on directx 5.0 and came here.
Microsoft home page does not list a download for this.

Can you make me less ignorant?

VTY

Fred

Follow Ups:

  • Re: help for directx 5.0 Don Martin 06:09:34 1/26/98 (0)

Post a Followup

Name:


Re: DirectX5.0 and game input

Posted by Fred Dings on January 24, 1998 at 14:24:54:

In Reply to: DirectX5.0 and game input posted by SuperD on January 19, 1998 at 05:34:41:

: I have a y adapter that connects 2 gamepads to my sound card's gameport. I had no problem setting up two joysticks under DirectX 3.0. However, after I installed 5.0 it no longer recognizes that I have a second joystick connected. Any suggestions?

: SuperD!

Sorry I can,t help you with your problem, but maybe you can help me. Where do I go for Directx 5???

Fred

Follow Ups:

  • Re: DirectX5.0 and game input justin 23:42:18 1/30/98 (1)
    • Re: DirectX5.0 and game input cheng 11:41:16 2/07/98 (0)
  • Re: DirectX5.0 and game input Don Martin 20:28:55 1/26/98 (0)

Post a Followup

Name:


Re: DirectX and MFC.

Posted by Jeff Thelen on January 24, 1998 at 16:08:56:

In Reply to: Re: DirectX and MFC. posted by Serg on January 23, 1998 at 08:15:27:

: I disagree. On medium-end stuff like PMMX -166,200,233
: or PII there isn't any difference in performence.
: If u writing windowed app it's easer to use MFC

See also Nigel Thompson's "3d Graphics programming for Windows 95" (Microsoft Press) on how to do DirectX with MFC. I agree: the only noticeable difference between MFC and Win32 on a fast pentium is the clarity and ease of the code.

Follow Ups:

  • Re: DirectX and MFC. CHRIS! 17:47:46 1/28/98 (1)
    • Re: DirectX and MFC. Joris Timmermans 13:31:33 3/03/98 (0)

Post a Followup

Name:


Re: i just wanna decent book

Posted by Nick Caldwell on January 24, 1998 at 17:35:20:

In Reply to: i just wanna decent book posted by Shaun on January 24, 1998 at 11:23:28:

: can anyone recommend a book that covers DirectX without
: focusing so much on Direct3D? and something that covers
: more than DirectDraw Programming(the worst book I've
: ever read)... like scrolling, sprites, etc...
: thank u =)

Spells of Fury covers the basic directX topics.
But for real game programming I recommend:
Game Programming in 21 Days,
Tricks of the Game Programming Gurus,
More Tricks....

All 3 books come in a set from SAMS publishing,
it costs about $140 for the whole set but
it is well worth the money. The 3 books
cover everything from putting a pixel to making
DOOM type games. The source is easily
convertable to DX.

Follow Ups:

Post a Followup

Name:


Using DirectX with Borland C++ 5

Posted by David on January 24, 1998 at 19:09:20:

Can anyone help me out with getting info?
I can't get any of the samples with the DirectX 5 sdk
to compile.

Please E-Mail.

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by ajs on January 24, 1998 at 19:16:31:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Harold on January 18, 1998 at 20:37:49:

: : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 an ji won 21:51:51 1/24/98 (1)
    • Re: Where Can I download DirectX 5.0 arno spruijt 04:41:50 1/26/98 (0)

Post a Followup

Name:


No ddutil files!

Posted by Mr. Magoo on January 24, 1998 at 20:26:23:

For some reason, every time I've installed the directx
sdk from whatever source, I still get errors with my
Metrowerks CodeWarrior Pro 2 compiler like
"unidentified symbol DDReLoadBitmap". Then I found out
ddutil.h and ddutil.cpp are missing, along with some
others! I even downloaded the sdk from microsoft's
site and I'm still getting errors. Please help me!

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by an ji won on January 24, 1998 at 21:51:51:

In Reply to: Re: Where Can I download DirectX 5.0 posted by ajs on January 24, 1998 at 19:16:31:

: : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 arno spruijt 04:41:50 1/26/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Dave Schweiger on January 25, 1998 at 10:27:05:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for NHL97.

Follow Ups:

  • Re: Where Can I download DirectX 5.0 mike 20:36:18 8/22/98 (0)
  • Re: Where Can I download DirectX 5.0 wezzas wilkins 19:55:24 1/26/98 (0)

Post a Followup

Name:


Re: DirectX and NT 4.0

Posted by Brian Shea on January 25, 1998 at 14:01:35:

In Reply to: DirectX and NT 4.0 posted by Carlos on January 23, 1998 at 19:10:19:

Well, first thing you should do is download
SP3 for NT. Then, you can use anything that
was in DX 3.0 on your NT box. You may need
to download the SDK to get the header files
if they didn't come with your compiler.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


All my DirectX games won't run. HELP!!

Posted by Chester on January 25, 1998 at 15:40:01:

All of my games that use DirectX won't run.Red Alert,JediKnight, Motoracer..
When I click to run the game it begins to load, screen goes black, and then returns to windows again
, no error message or anything.. Like I never done it... If anyone can help, Please e mail me

Follow Ups:

  • Re: All my DirectX games won't run. HELP!! EvAcLeAr 04:08:23 5/25/98 (0)

Post a Followup

Name:


All my DirectX games won't run. HELP!! This one

Posted by Chester on January 25, 1998 at 15:41:06:

All of my games that use DirectX won't run.Red Alert,JediKnight, Motoracer..
When I click to run the game it begins to load, screen goes black, and then returns to windows again
, no error message or anything.. Like I never done it... If anyone can help, Please e mail me

Follow Ups:

  • Re: All my DirectX games won't run. HELP!! This one Mr. Magoo 16:59:57 1/26/98 (0)
  • Re: All my DirectX games won't run. HELP!! This one Don Martin 06:07:44 1/26/98 (0)

Post a Followup

Name:


HELP: Editor

Posted by KHahn on January 25, 1998 at 17:26:58:

Does any one know of a good DirectX file editor?

Follow Ups:

Post a Followup

Name:


DirectX 5.0 and MSVC 5 pro

Posted by Natin Lapua on January 25, 1998 at 19:39:44:

Ive just started out using MSVC 5 and Im having some problems compiling sample DirectX code that came with the DX5 SDK. I keep getting a 'LNK2001: unresolved external symbol' on some major DX symbols. I made sure that I had all of the DX5 headers in the include directory and all the new libs in the libs dir. This is probaly a stupid question but I could really appreciate help, thanx!

Follow Ups:

  • Re: DirectX 5.0 and MSVC 5 pro Scott 13:52:59 1/26/98 (1)
    • Re: DirectX 5.0 and MSVC 5 pro Richard Drennen 22:55:31 6/15/98 (0)
  • Re: DirectX 5.0 and MSVC 5 pro Don Martin 06:01:50 1/26/98 (0)
  • Re: DirectX 5.0 and MSVC 5 pro Sean 20:44:07 1/25/98 (1)
    • Re: DirectX 5.0 and MSVC 5 pro Natin Lapua 22:49:07 1/25/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Darryl Brown on January 25, 1998 at 20:14:54:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Harold on January 18, 1998 at 20:37:49:

: : Where Can I download DirectX 5.0. I need it for a game.
I kneed it for the Demo of Age Of Empires

Follow Ups:

  • Re: Where Can I download DirectX 5.0 David Craig-Smith 10:25:20 3/13/98 (0)
  • Re: Where Can I download DirectX 5.0 David Craig-Smith 10:25:01 3/13/98 (1)
    • Re: Where Can I download DirectX 5.0 derrick paul 20:23:20 3/17/98 (0)

Post a Followup

Name:


Re: Removal of a FACE from MESHBUILDER object

Posted by Sean on January 25, 1998 at 20:39:23:

In Reply to: Removal of a FACE from MESHBUILDER object posted by Jordan on January 22, 1998 at 05:55:14:

Jordan,

I've had the same problem, and unfortunately Direct3D does not provide a handy LPDIRECT3DRMMESHBUILDER::DeleteFace function.

Anyway, below is my own function that deletes a face by erasing the meshbuilder object then rebuilding it face by face, ommitting the face that we want erased.

DeleteFace(HWND hwnd, LPDIRECT3DRMFRAME2 lpFrame, LPDIRECT3DRMMESHBUILDER2 lpMeshbuilder, LPD3DRMFACEARRAY lpFaceArray, int iFace);

You will need to provide the following parameters:

-Your applications handle to the window (hwnd). Used to repaint the window
-The frame which contains your meshbuilder object
-The meshbuilder obect itself
-An array of Faces (LPDIRECT3DRMFACEARRAY). This array can be made using the Meshbuilder's GetFaces or AddFaces functions
-the index of the face we want to erase (this is a zero index)

I used LPDIRECT3DRMFRAME2 and LPDIRECT3DRMMESHBUILDER2 objects but you can get by with only LPDIRECT3DRMFRAME and LPDIRECT3DRMMESHBUILDER

It is not perfect, but I hope it helps. You will most likely have questions about it, so email me freely at seanbarton@hotmail.com .

Here it is...

BOOL DeleteFace(HWND hwnd, LPDIRECT3DRMFRAME2 lpFrame, LPDIRECT3DRMMESHBUILDER2 lpMeshbuilder,
LPDIRECT3DRMFACEARRAY lpFaceArray, int iFace)
{
LPDIRECT3DRMMESHBUILDER2 lpMeshTemp = NULL;
D3DRMRENDERQUALITY oldQuality;
int faceCount = 0;
int i,j;
HRESULT hr;

// if there are no faces in the mesh, then there are none to erase, just exit
if (!lpMeshbuilder->GetFaceCount())
return TRUE;

// if we are requesting to erase a face index which does not exist, then exit
// remember that iFace is zero indexed so we must add 1 to it
if (lpMeshbuilder->GetFaceCount() GetQuality();

// have to clone the meshbuilder before we destroy it, since we'll lose all face info
hr = lpMeshbuilder->Clone(0, IID_IDirect3DRMMeshBuilder2, (void**)&lpMeshTemp);

if (hr != D3DRM_OK)
return FALSE;

// get the array of faces in the meshbuilder object we are taking a face from
lpMeshTemp->GetFaces(&lpFaceArray);

// get the number of faces in the meshbuilder
faceCount = lpMeshTemp->GetFaceCount();

// delete the meshbuilder visually
lpFrame->DeleteVisual((LPDIRECT3DRMVISUAL)lpMeshbuilder);
lpMeshbuilder->Release();

// re-create the meshbuilder2 object (with no faces)
lpD3DRM->CreateMeshBuilder(&lpMeshbuilder);

// now rebuild the object face by face, not including iFace
for(i = 0; i CreateFace(&lpFace);
lpD3DRM->CreateFace(&lpFace2);

// get the face from the old mesh
lpFaceArray->GetElement(i, &lpFace);

// get the number of vertices in the face
vertexCount = lpFace->GetVertexCount();

// add the vertices to our lpFace2 object, add normal to the meshbuilder
// we have to add the vertices to another face since a face can exist in
// only ONE meshbuilder at a time
for (j = 0; j GetVertex(j, &vecFace[j], &vecNormal[j]);
lpFace2->AddVertex(vecFace[j].x, vecFace[j].y, vecFace[j].z);
lpMeshbuilder->AddNormal(vecNormal[j].x, vecNormal[j].y, vecNormal[j].z);
}

// add he face to the meshbuilder object
hr = lpMeshbuilder->AddFace(lpFace2);

if (hr != D3DRM_OK)
return FALSE;

lpFace->Release();
lpFace2->Release();
}
}

// set the rendering quality of the meshbuilder
lpMeshbuilder->SetQuality(oldQuality);

// reset the lpFaceArray for future use
hr = lpMeshbuilder->GetFaces(&lpFaceArray);

if (hr != D3DRM_OK)
return FALSE;

// now, make the meshbuilder visual again
hr = lpFrame->AddVisual(lpMeshbuilder);

if (hr != D3DRM_OK)
return FALSE;

// release the unwanted objects
lpMeshTemp->Release();

// repaint the screen by sending an Invalidate message
InvalidateRect(hwnd, NULL, FALSE);

// whew! We successfully erased the face!
return TRUE;
}

Good luck,
Sean

Follow Ups:

  • Re: Removal of a FACE from MESHBUILDER object Thanx sean, Maybe DirectX6 eh? 13:47:30 1/26/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 and MSVC 5 pro

Posted by Sean on January 25, 1998 at 20:44:07:

In Reply to: DirectX 5.0 and MSVC 5 pro posted by Natin Lapua on January 25, 1998 at 19:39:44:

Did you link dxguid.lib to your project?

Follow Ups:

  • Re: DirectX 5.0 and MSVC 5 pro Natin Lapua 22:49:07 1/25/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 and MSVC 5 pro

Posted by Natin Lapua on January 25, 1998 at 22:49:07:

In Reply to: Re: DirectX 5.0 and MSVC 5 pro posted by Sean on January 25, 1998 at 20:44:07:

Yeah, I linked all of the *.lib files.

Thanx anyway!

Follow Ups:

Post a Followup

Name:


How can i plot pixels under DX5?

Posted by duong on January 26, 1998 at 02:13:26:

Hi, yep another newbie here 8^) I'm just getting into direct x and can get the grasp of all the blitting and buffering for simple sprite animation but how about just plain old pixel plotting? Like say i was going to make a graphing program and wanted to plot pixel not spites nor single pixel sprites. It seems kinda of slow to call the blitting function for every pixel, so i doubt that's how it's done. Can anyone help me?
thanks in advane 8^)

-ddn

Follow Ups:

  • Re: How can i plot pixels under DX5? Brian Shea 09:07:35 1/27/98 (0)

Post a Followup

Name:


Another "where do I start" post

Posted by Rachel Lewis on January 26, 1998 at 04:24:28:

I want to learn to program videogames in DirectX, but alas, I find the books written on the topic are woefully inadequete.

I have Petzold's "Windows '95 Programming." It's a great book, but it only talks about the GDI. I tried "The Win32 Developer's Guide to DirectX 3" but was disappointed to find it was just a bunch of nice wrappers. I also tried "The Awesome Power of Direct3D/DirectX." It's more of the type of book I'm looking for, but the CD doesn't contain all the .mak files or source code, and the author didn't write the complete code in the book. Hence, it's rendered useless. I also have LaMothe's various books, and while they're nice for general game programming conceptes, I want to learn about DirectX programming, not DOS.

Has anyone here had any luck with a DirectX book or website? I use MSDEV 4.0 for my compiler. Any help would be appreciated. Thanks.

Rh

Follow Ups:

  • Re: Another "where do I start" post Don Martin 05:54:54 1/26/98 (1)
    • Wow, another Wrox Press fan! Rachel Lewis 13:10:52 1/26/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by arno spruijt on January 26, 1998 at 04:41:50:

In Reply to: Re: Where Can I download DirectX 5.0 posted by an ji won on January 24, 1998 at 21:51:51:

: : : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


Re: Another "where do I start" post

Posted by Don Martin on January 26, 1998 at 05:54:54:

In Reply to: Another "where do I start" post posted by Rachel Lewis on January 26, 1998 at 04:24:28:

Here is the books I have that are a bit better.

Direct3D Professional Reference by Michael L. Stein, Eric Bowman, and Gregory Pierce. This book is an excellent reference guide to the API with all the functions defined and documented.

DirectDraw Programming by Bret Timmins. A pretty neat book, sort of a walk thru for DD programming. I haven't gone through the entire book yet, but the examples look interesting, and it seems to skip all the crap the rest of the books have in abundance.

Cutting Edge Direct 3D Programming by Stan Trujillo. This book looks fairly good as well and focuses on the technical aspects of D3D programming with some good code examples on rendering and such.

I originally bought Petzold's book in 1990 I think - not much has changed since. I hate this book, the same lame examples as he used for Windows 3.1, none of them are useful.

Try this book instead... Beginning Visual C++5 by Ivor Horton. I can't say enough about this book... it's perfect. This guy starts with some basic stuff, but gets into the full gambit of C++, and he seperates out the MFC crap so the book is readable and you can work on that later if you want. This is a BIG red book... and is very good.

Hidden deep beneath one of the web sites, is a tiny link to a d3d supporter/developer with some good instroductory level stuff... http://www.angelic-coders.com/bpshea/

I'm in the same boat as you... this is what I've discovered so far... hope it helps.

Follow Ups:

  • Wow, another Wrox Press fan! Rachel Lewis 13:10:52 1/26/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 and MSVC 5 pro

Posted by Don Martin on January 26, 1998 at 06:01:50:

In Reply to: DirectX 5.0 and MSVC 5 pro posted by Natin Lapua on January 25, 1998 at 19:39:44:

You've not linked a .lib file or necessary program or header file to your project. In some cases... ddutil.c and ddutil.h are necessary and are found in the samples/misc directory I believe. There are several other programs that are missing from the examples. On the error line, copy the specific function tag that is referenced. In your windows explorer, use the find files option and search the entire dx5_sdk directory for that tag. You'll find everything that references it... some playing around, and you'll find the necessary compenent that is missing.

Along these lines.... surely there is some easy method to specify which libray files are required within the source, and link them automatically???????

This is a stupid short-coming it seems.

Follow Ups:

Post a Followup

Name:


Re: All my DirectX games won't run. HELP!! This one

Posted by Don Martin on January 26, 1998 at 06:07:44:

In Reply to: All my DirectX games won't run. HELP!! This one posted by Chester on January 25, 1998 at 15:41:06:

I thought this was a developers forum, but...

Your most likely missing a specific DirectX component function being certified... your monitor, or video card, or sound card must not be functioning with DirectX.

Go to the "program files\directx\setup\" directory and run dxsetup. It will show you which hardware device is not certified currently.

Then re-install DirectX, after you've corrected the driver for the specific hardware device not currently supported.... try different device drivers if it still won't certify, and you can also check the hardware manufacturers web sties for upgraded drivers. In some rare cases, it's impossible to remove directx or fix the problem, and I've had to re-install the operating system itself to correct the problem.

Follow Ups:

Post a Followup

Name:


Re: help for directx 5.0

Posted by Don Martin on January 26, 1998 at 06:09:34:

In Reply to: help for directx 5.0 posted by Fred Dings on January 24, 1998 at 14:19:53:

microsoft.com/directx/

Follow Ups:

Post a Followup

Name:


DirectSound, ESS 1888, no sound out speakers

Posted by Karen Rivers on January 26, 1998 at 09:12:07:

My Dell Laptop comes with ESS 1888 audio driver.
Dell claims that the driver works with DirectSound.
I have the driver, xpcdaud2.exe, from Dell, made 2/97.

However, I get NO SOUND out my PC with two different
methods. One is using the DirectX 5.0 SDK (see below
for post to newsgroup that got NO answer), and
the other is using Intel's RSX in DirectSound mode
instead of wave mode.

I My Dell Laptop comes with ESS 1888 audio driver.
Dell claims that the driver works with DirectSound.
I have the driver, xpcdaud2.exe, from Dell, made 2/97.

However, I get NO SOUND out my PC with two different
methods. One is using the DirectX 5.0 SDK (see below
for post to newsgroup that got NO answer), and
the other is using Intel's RSX in DirectSound mode
instead of wave mode.

I have installed DirectX 5 SDK.
My code creates a DirectSound object.
DirectSoundCreate(NULL, &_pDirectSound, NULL)
_pDirectSound->SetCooperativeLevel (m_hwnd, DSSCL_EXCLUSIVE)
When I get its capabilities, they are:
dwFlags==15
dwMinSecondarySampleRate==0
dwMaxSecondarySampleRate==0

I create a DirectSoundCapture object
DirectSoundCaptureCreate(NULL, &_pDirectSoundCapture, NULL)
and its capabilities are:
dwFormats=4095

Why am I getting these unexpected values for capabilities?

Thanks for your help.
Karen Rivers
riversk@nortel.com

Follow Ups:

  • Re: DirectSound, ESS 1888, no sound out speakers Don Martin 20:02:47 1/26/98 (0)

Post a Followup

Name:


Re: Textures & Video Memory...

Posted by Daniele Trambusti on January 26, 1998 at 09:57:50:

In Reply to: Re: Textures & Video Memory... posted by Jordan on January 22, 1998 at 14:05:35:

Ok, I know that the Mystique suxx but the problem
is: I try to release a texture located in video memory
and to load another one but it doesn't seem to work.
What's wrong? Thanx!

Follow Ups:

Post a Followup

Name:


How to switch between two Hardwareaccelators

Posted by Niels Schroeter on January 26, 1998 at 10:54:04:

I have a matrox mystique and a 3dfx card.
I just want to know, which changes I have
to make in the hello world example of the
d3drm tutorial that it works in 3dfx fullscreen
mode.

Thanks

Follow Ups:

  • Re: How to switch between two Hardwareaccelators Brian Shea 08:57:16 1/27/98 (1)
    • Re: How to switch between two Hardwareaccelators Mark E. Stanley 22:41:30 3/30/98 (0)

Post a Followup

Name:


Problem with S3 Trio64V+

Posted by Eduardo on January 26, 1998 at 11:38:49:

I have a problem with my S3 Trio64V+ and Fifa 98.
Where I can get the S3 Trio64v+'s driver for DirectX 5.0?

Follow Ups:

  • Re: Problem with S3 Trio64V+ yuekaihui 00:18:11 3/25/98 (0)
  • Re: Problem with S3 Trio64V+ Don Martin 19:57:38 1/26/98 (0)

Post a Followup

Name:


Wow, another Wrox Press fan!

Posted by Rachel Lewis on January 26, 1998 at 13:10:52:

In Reply to: Re: Another "where do I start" post posted by Don Martin on January 26, 1998 at 05:54:54:

Thanks a lot, I'll try some of those books you mentioned.

: Try this book instead... Beginning Visual C++5 by Ivor Horton. I can't say enough about this book... it's perfect. This guy starts with some basic stuff, but gets into the full gambit of C++, and he seperates out the MFC crap so the book is readable and you can work on that later if you want. This is a BIG red book... and is very good.
Indeed it is. Like I said, I only have VC4 (I can't afford to set aside the 250+ megs of HD space VC5 requires), but his Beginner's Guide to Visual C++ 4 is terrific. I love Wrox Press! Too bad they don't write a DirectX book...

: Hidden deep beneath one of the web sites, is a tiny link to a d3d supporter/developer with some good instroductory level stuff... http://www.angelic-coders.com/bpshea/

: I'm in the same boat as you... this is what I've discovered so far... hope it helps.
Thank you! I'll try it.

Rh

Follow Ups:

Post a Followup

Name:


Volume control with MCI

Posted by Gary Huff on January 26, 1998 at 13:43:30:

Could anyone point me in the right direction to where I could find information on changing the volume of MIDI and CD Audio devices? I have two classes that manage this type of audio, and have tried to add volume control functions but I am stumped as to what to do. I cannot find info anywhere! Please respond via email. Thanks in advance.

Follow Ups:

Post a Followup

Name:


Re: Removal of a FACE from MESHBUILDER object

Posted by Thanx sean, Maybe DirectX6 eh? on January 26, 1998 at 13:47:30:

In Reply to: Re: Removal of a FACE from MESHBUILDER object posted by Sean on January 25, 1998 at 20:39:23:

I'm building a visualization,Paint,modeling app,
so I need to delete faces, on the fly, I was thinking
about doing that as last resort, but it must be damn
slow... I'll try it for the heck of it...

I don't understand why they didn't add a function for
this in DX5 yet, I don't think it would be one of
the taugher ones to implement...

thanx for da info sean, will try it...

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 and MSVC 5 pro

Posted by Scott on January 26, 1998 at 13:52:59:

In Reply to: DirectX 5.0 and MSVC 5 pro posted by Natin Lapua on January 25, 1998 at 19:39:44:

I had exactly that problem, I needed to put,
#define INITGUID at the top of your main cpp file,
and I was getting other 2001 link errors, so I just
some of the lib file and shuved them in my project
directory, and added the file dxguid.lib, to the cpp
folder in my project with the rest of the cpp files...

worked for me,

Follow Ups:

  • Re: DirectX 5.0 and MSVC 5 pro Richard Drennen 22:55:31 6/15/98 (0)

Post a Followup

Name:


GAMEDEV list!!!

Posted by JORDAN on January 26, 1998 at 13:57:13:

I used to be on that gamedev list, and now I forgot
what the site was that had the mailing list info,
it's something like gamedev.poly.org or something...
if you guys are on it, please refresh my memory..
I can't find it with these damn search engins, all I
get is smut links... go figure!

thanx

Follow Ups:

  • Re: GAMEDEV list!!! Brian Shea 08:53:53 1/27/98 (0)
  • Re: GAMEDEV list!!! Don Martin 19:53:42 1/26/98 (1)
    • No, but i'll try this one... fur now... JORDAN 22:10:54 1/26/98 (0)

Post a Followup

Name:


Re: All my DirectX games won't run. HELP!! This one

Posted by Mr. Magoo on January 26, 1998 at 16:59:57:

In Reply to: All my DirectX games won't run. HELP!! This one posted by Chester on January 25, 1998 at 15:41:06:

Either you don't have the right DirectX version, or your hardware isn't working with DirectX (like Chester said). The latest version of DirectX is version 5. Go to www.microsoft.com and look for it.

Follow Ups:

Post a Followup

Name:


Win16Lock Overhead

Posted by Tony Di Croce on January 26, 1998 at 18:14:01:

I recently read the articles on this site that
reccomend using doing a Lock and then doing memcpys
for you're own bliting, rather that calling blit.
The argument is that Blit does a Lock and unlock
and every blit must do this, so you waste a lot of
time... Anyway, my question, is this true of queued
blits... I seem to remember a way to queue up blits
with DD and then blit all at once... In this scenario
how many lock's are performed?

Tony

Follow Ups:

  • Re: Win16Lock Overhead & BltFast Jesse Rosenzweig 16:32:52 1/28/98 (1)
    • Re: Win16Lock Overhead & BltFast franko 18:08:35 1/28/98 (0)
  • Re: Win16.. HEY use blt!! franko 18:46:09 1/27/98 (1)
    • Re: Win16.. HEY use blt!! Jimbo Jones 00:14:00 2/21/98 (0)
  • Re: Win16Lock Overhead Nick Caldwell 19:35:36 1/26/98 (0)

Post a Followup

Name:


Re: Win16Lock Overhead

Posted by Nick Caldwell on January 26, 1998 at 19:35:36:

In Reply to: Win16Lock Overhead posted by Tony Di Croce on January 26, 1998 at 18:14:01:

The BlitBatch function would let you
blit more than once (if it was implemented).
When it is implemented it will probably use
only 1 Win16Lock.

Follow Ups:

Post a Followup

Name:


Re: GAMEDEV list!!!

Posted by Don Martin on January 26, 1998 at 19:53:42:

In Reply to: GAMEDEV list!!! posted by JORDAN on January 26, 1998 at 13:57:13:

This one?

mailto:DirectXDev.List@mx01.erols.com

Follow Ups:

  • No, but i'll try this one... fur now... JORDAN 22:10:54 1/26/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by wezzas wilkins on January 26, 1998 at 19:55:24:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Dave Schweiger on January 25, 1998 at 10:27:05:

:
: : Where Can I download DirectX 5.0. I need it for NBA LIVE 98.

Follow Ups:

Post a Followup

Name:


Re: Problem with S3 Trio64V+

Posted by Don Martin on January 26, 1998 at 19:57:38:

In Reply to: Problem with S3 Trio64V+ posted by Eduardo on January 26, 1998 at 11:38:49:

You'll have to get that driver from the manufacturers web site. If they haven't yet developed one, you'll have to try using another video card driver - I believe the Diamond Stealth 64 might be compatible... or try a lessor S3 Trio driver.

Follow Ups:

Post a Followup

Name:


Re: DirectSound, ESS 1888, no sound out speakers

Posted by Don Martin on January 26, 1998 at 20:02:47:

In Reply to: DirectSound, ESS 1888, no sound out speakers posted by Karen Rivers on January 26, 1998 at 09:12:07:

I believe that sound card is made by Yamaha... and I've been through this as well.

You never mentioned if DirectX has certified the driver for your sound card?

2/97 is rather old for a DirectX5 driver... there must be a newer one somewhere?

I was able to get my Toshiba notebook working with DirectX 5, which used that same sound card. You might even try the drivers located on toshiba's web site if Dell is not providing adequate support.

Follow Ups:

Post a Followup

Name:


Re: DirectX5.0 and game input

Posted by Don Martin on January 26, 1998 at 20:28:55:

In Reply to: Re: DirectX5.0 and game input posted by Fred Dings on January 24, 1998 at 14:24:54:

Classic Fred... very nice.

Any idea why my jaz drive won't work while concurrently connected to two seperate UW SCSI buses?

Follow Ups:

Post a Followup

Name:


No, but i'll try this one... fur now...

Posted by JORDAN on January 26, 1998 at 22:10:54:

In Reply to: Re: GAMEDEV list!!! posted by Don Martin on January 26, 1998 at 19:53:42:

The other one was from a huge page with every DX link
known to man kind, it was a great page, I just can't find it..

Oh ya, the mailling list would get like 50 emails a day, good reading
from some of the top develeppers talkin' techno...

Follow Ups:

Post a Followup

Name:


Does 3D-Studio MAX run with Direct 3D 5.0 ?

Posted by Feix Bender on January 26, 1998 at 23:42:36:

When I select the Direct3D Driver for the
Viewport-Display of Autodesk 3D Studio MAX
there is always an error message:
"Cannot create Z-Buffer"
Also when I check my DirectX installation
the first line of the Infobox says:
"Direct3D not installed"
Where do I get Direct3D, is it a Component of the
graphic drivers of my GFX card or Microsoft?

Can anyone help?

Fx

Follow Ups:

  • Re: Does 3D-Studio MAX run with Direct 3D 5.0 ? Scott 19:56:28 1/29/98 (0)

Post a Followup

Name:


GIF files

Posted by Adriano Oliveira on January 27, 1998 at 08:00:11:

Does DirectDraw work with .GIF files?
All examples i've seen use .BMP files.

Follow Ups:

  • Re: GIF files Fussel 11:44:12 2/07/98 (0)
  • Re: GIF files Brian Shea 09:01:06 1/27/98 (0)

Post a Followup

Name:


Re: GAMEDEV list!!!

Posted by Brian Shea on January 27, 1998 at 08:53:53:

In Reply to: GAMEDEV list!!! posted by JORDAN on January 26, 1998 at 13:57:13:

The DirectX dev mailing list that used to
by on poly has moved. You can join here:
http://www.angelic-coders.com/bpshea/

There is also a game design mailing list,
but it has no traffic and has no technical
info, so I assume you don't mean that one.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: How to switch between two Hardwareaccelators

Posted by Brian Shea on January 27, 1998 at 08:57:16:

In Reply to: How to switch between two Hardwareaccelators posted by Niels Schroeter on January 26, 1998 at 10:54:04:

: I have a matrox mystique and a 3dfx card.
: I just want to know, which changes I have
: to make in the hello world example of the
: d3drm tutorial that it works in 3dfx fullscreen
: mode.

You have to enumerate the drivers and let the
user pick which one they would like to use.
I have not written code to do this, but I am
sure someone on the DX mailing list has.

Brian

BTW, you can join the mailing list via:
http://www.angelic-coders.com/

  • Journals of a DX Junkie

Follow Ups:

  • Re: How to switch between two Hardwareaccelators Mark E. Stanley 22:41:30 3/30/98 (0)

Post a Followup

Name:


Re: GIF files

Posted by Brian Shea on January 27, 1998 at 09:01:06:

In Reply to: GIF files posted by Adriano Oliveira on January 27, 1998 at 08:00:11:

: Does DirectDraw work with .GIF files?
: All examples i've seen use .BMP files.

To be honest, DirectX does not even work
with .BMP files. It is just that all of
the examples use bitmaps for the graphics.

Loading a .GIF or .JPG or .PCX would really
be no more or less difficult, except for the
fact that you would have to write it yourself.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: How can i plot pixels under DX5?

Posted by Brian Shea on January 27, 1998 at 09:07:35:

In Reply to: How can i plot pixels under DX5? posted by duong on January 26, 1998 at 02:13:26:

The basic technique you want is to:
1. Create a primary surface.
2. Create an offscreen surface.
3. Lock the offscreen surface.
3. Plot pixels on it.
4. Unlock it.
5. Blit the offscreen surface to the primary.
6. Jump to #3 and repeat.

I have example code for all but #3 on my
page. Plotting pixels is a lot trickier
than it sounds at first, especially if you
have to deal with both 8-bit and 16-bit
display depths. For examples on plotting
pixels, try looking at the articles at:
http://www.angelic-coders.com/

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: Win16.. HEY use blt!!

Posted by franko on January 27, 1998 at 18:46:09:

In Reply to: Win16Lock Overhead posted by Tony Di Croce on January 26, 1998 at 18:14:01:

: I recently read the articles on this site that
: reccomend using doing a Lock and then doing memcpys
: for you're own bliting, rather that calling blit.
: The argument is that Blit does a Lock and unlock
: and every blit must do this, so you waste a lot of
: time...

Uhh, I don't recommend this. Maybe in the case of software blitting... But if the hardware supports blits, use it. It will be faster in more ways then one...

Follow Ups:

  • Re: Win16.. HEY use blt!! Jimbo Jones 00:14:00 2/21/98 (0)

Post a Followup

Name:


Problems with Wireframe using Right Handed Projection

Posted by Steve Howard on January 28, 1998 at 03:59:22:

I can get this to work fine with the standard left
handed projection, however when I try to project it
after setting it to right handed projection I stops
working and I get nothing. All other projection types
work fine.

Does anyone know if this is a known problem or am I just
doing everything wrong

Follow Ups:

Post a Followup

Name:


DirectX Jobs Available

Posted by Dennis Withey on January 28, 1998 at 12:10:31:

I am currently staffing a project in Los Angeles with a major software development company.
We are cuirrently seeking individuals with DirectX experience. We will be aiding in the development
of some new games. I am interested in speaking with any qualified individuals who may be interested
in such a position. We are a highly recognized company and offer excellent compensation and benefits.
Feel free to call or email me at any time. My numbers are as follows.

Dennis Withey
Maxim Group
1 800 743-1225 ext 2035
dwithey@maximgroup.com
Fax: 310 217-2418

Follow Ups:

Post a Followup

Name:


Re: Win16Lock Overhead & BltFast

Posted by Jesse Rosenzweig on January 28, 1998 at 16:32:52:

In Reply to: Win16Lock Overhead posted by Tony Di Croce on January 26, 1998 at 18:14:01:

This is in addition to Tony's question...

My understanding of BltFast is that is returns immediately
after queueing the Blt to the hardware. Is this not correct?
If this is the case, then shouldn't the BltFast routine be
"faster" than the Lock/Unlock method because it returns
control to the CPU right away?

I was thinking of writing my own Blt to take care of some 2D special
effects for 16bpp sprites (transloucency,fading, overlays, etc...), and am
interested in how exactly the Blt/BltFast works.

Thanks,
Senior Project Team. University of Colorado

Follow Ups:

  • Re: Win16Lock Overhead & BltFast franko 18:08:35 1/28/98 (0)

Post a Followup

Name:


Re: DirectX And MFC

Posted by CHRIS! on January 28, 1998 at 17:41:14:

In Reply to: DirectX And MFC posted by Arrowhead on January 24, 1998 at 03:18:19:

: Don't plan on creating an application on top of MFC.
: After weeding out all the MFC references in an app
: I was working on, I compiled as a plainy old Win32 app.
: The speedup was incredible. So if you think the MFC
: overhead is worth having classes such as CString, CArray,
: or CPoint. Stop thinking, it isn't.

: Just a note

I haven't done any real performance tests, but I
do use the MFC framework and, on a 133 MHz Pentium with a #9 Motion 771 (s3 978 chip) I get 50-60 flips per sec (full screen, 8-bit 640x480).. and it can't go higher than 60 since that is my monitors refresh rate in that mode...

I can easily see that Win32 -vs- MFC will favor straight Win32 code, but I don't see that much of an overhead with MFC -- at least, not the way I am coding things.

The game I am working on is a DirectDraw/DirectSound/WinSock TCP/IP shoot-em-up like SubSpace. Server, client, and level editor.

Follow Ups:

Post a Followup

Name:


Re: DirectX and MFC.

Posted by CHRIS! on January 28, 1998 at 17:47:46:

In Reply to: Re: DirectX and MFC. posted by Jeff Thelen on January 24, 1998 at 16:08:56:

: : I disagree. On medium-end stuff like PMMX -166,200,233
: : or PII there isn't any difference in performence.
: : If u writing windowed app it's easer to use MFC

: See also Nigel Thompson's "3d Graphics programming for Windows 95" (Microsoft Press) on how to do DirectX with MFC. I agree: the only noticeable difference between MFC and Win32 on a fast pentium is the clarity and ease of the code.

I pretty much agree on that. Besides, by the end of this year alone you'll probably see the 'average home pc bundle' come with a 233MHz Pentium or faster. And soon after that there will only be the 233 & 266MHz MMX chips and the P-II.. with horse-power like that, I would rather use MFC over a straight Win32 implementation.

// CHRIS!

Follow Ups:

  • Re: DirectX and MFC. Joris Timmermans 13:31:33 3/03/98 (0)

Post a Followup

Name:


Re: Win16Lock Overhead & BltFast

Posted by franko on January 28, 1998 at 18:08:35:

In Reply to: Re: Win16Lock Overhead & BltFast posted by Jesse Rosenzweig on January 28, 1998 at 16:32:52:

: This is in addition to Tony's question...

: My understanding of BltFast is that is returns immediately
: after queueing the Blt to the hardware. Is this not correct?
: If this is the case, then shouldn't the BltFast routine be
: "faster" than the Lock/Unlock method because it returns
: control to the CPU right away?

: I was thinking of writing my own Blt to take care of some 2D special
: effects for 16bpp sprites (transloucency,fading, overlays, etc...), and am
: interested in how exactly the Blt/BltFast works.

: Thanks,
: Senior Project Team. University of Colorado

Only if blt hardware is present. If it isn't the blt is handled by software. If blt hardware is present Blt and BltFast should be the same speed. Personally I have found that there are gaping holes in what functions and capabilities all the different boards support, so I have ended up writing all my own blt functions anyway. For example one board may support HW blt, but not streching, or system to video blt, but not video to system... annoying

Follow Ups:

Post a Followup

Name:


direct x5

Posted by ronnie on January 28, 1998 at 20:17:46:

I installed ea sports hockey 98 is contains directx5
I have ring central installed since I installed hockey
i have had all sorts of problems with my inteernet
connection and fax, also ring central no longer opens.
Ring Zero the makers of ring central say there is some
kind of problem with the way directx interacts with
crystal sound cards and modems. I found this at
ringzeros web site. I don't understand what their talking
about. maybe someone can figure it out.

Follow Ups:

Post a Followup

Name:


Load 3DS files

Posted by Rafael Alvarado on January 28, 1998 at 23:41:09:

How can I load 3DS files into DirectX Format.

Thanks
Rafael - AZ

Follow Ups:

  • Re: Load 3DS files Bradley Elfman 20:02:05 2/05/98 (0)
  • Re: Load 3DS files Brian Shea 12:51:06 1/29/98 (0)

Post a Followup

Name:


Re: Load 3DS files

Posted by Brian Shea on January 29, 1998 at 12:51:06:

In Reply to: Load 3DS files posted by Rafael Alvarado on January 28, 1998 at 23:41:09:

There is a program called conv3ds that converts
a .3DS file to a .X file. It comes with the
SDK and can be found in the bin directory,
I believe.

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: Does 3D-Studio MAX run with Direct 3D 5.0 ?

Posted by Scott on January 29, 1998 at 19:56:28:

In Reply to: Does 3D-Studio MAX run with Direct 3D 5.0 ? posted by Feix Bender on January 26, 1998 at 23:42:36:

: When I select the Direct3D Driver for the
: Viewport-Display of Autodesk 3D Studio MAX
: there is always an error message:
: "Cannot create Z-Buffer"
: Also when I check my DirectX installation
: the first line of the Infobox says:
: "Direct3D not installed"
: Where do I get Direct3D, is it a Component of the
: graphic drivers of my GFX card or Microsoft?

: Can anyone help?

: Fx

I get that error, with mine it's because I have my desktop mode in 1024x768 and with a 4 meg gfx card there's not enough ram on the card to create a z buffer as well.

Either run in HEIDI mode or reduce your desktop resolution down a lot.

Follow Ups:

Post a Followup

Name:


Yamaha Sound Card-Direct X incompatability!

Posted by C.S. Palmer on January 29, 1998 at 21:29:41:

Someone help! I can't run Microsoft's Age of Empires without a DirectX 5.0 compatible driver for my Yamaha OPL-SAx sound board. I've scoured the web, and there doesn't seem to be any updated drivers available for download. Are there any ways around this problem...I want to play my game!

Follow Ups:

Post a Followup

Name:


DirectX v5.0 for Windows NT 4

Posted by Sir Shadow on January 30, 1998 at 05:49:39:

I have DirectX v5 for Windows 95, but i'm upgrading my
system to Win NT 4, and i wonder if anyone know of a
working DX v5 for NT4, please submit answers,
because i haven't found any yet...
//Shadow

Follow Ups:

  • Re: DirectX v5.0 for Windows NT 4 Brian Shea 12:47:37 1/30/98 (0)

Post a Followup

Name:


Graphics

Posted by KHahn on January 30, 1998 at 08:48:27:

Does any one know of a good directX file editor?

Follow Ups:

  • Re: Graphics Brian Shea 12:51:09 1/30/98 (0)

Post a Followup

Name:


CD Roms and DirectX

Posted by Bill on January 30, 1998 at 11:17:31:

i've noticed over the past few months that many of the computers I work with have been receiving "CD may be dirty or bad" errors on random cdroms. These same cd's may work on another system, and others won't work on my system. Does DirectX have anything to do with this or is it a Windows95 issue? I utilize all the latest drivers, sometimes removal and reinsertion of the cd clear up the problems.

Follow Ups:

  • Re: CD Roms and DirectX Brian Shea 12:52:27 1/30/98 (0)

Post a Followup

Name:


Re: DirectX v5.0 for Windows NT 4

Posted by Brian Shea on January 30, 1998 at 12:47:37:

In Reply to: DirectX v5.0 for Windows NT 4 posted by Sir Shadow on January 30, 1998 at 05:49:39:

There is not DirectX 5.0 for NT 4.0. There
is only Service Pack 3 for NT, which brings
NT up to DirectX 3.0.

The beta version of NT 5.0 has DX5 support,
but it probably will not be released until
sometime in 1999.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: Graphics

Posted by Brian Shea on January 30, 1998 at 12:51:09:

In Reply to: Graphics posted by KHahn on January 30, 1998 at 08:48:27:

:Does any one know of a good directX file editor?

What is a directx file editor? If you mean a
file editor written in DirectX, I have never
come across anything like that. If you mean a
file editor to create DirectX applications, then
you are really asking about compilers. The only
decent free compiler I have heard of is DJGPP.
I think that is the name, at least. Or, if you
are talking about a free model builder for D3D,
then I do not know of any of those, either.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: CD Roms and DirectX

Posted by Brian Shea on January 30, 1998 at 12:52:27:

In Reply to: CD Roms and DirectX posted by Bill on January 30, 1998 at 11:17:31:

I can not imagine this being related to DirectX.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


DISPLAY VIDEO for DIRECTX

Posted by mike Feng on January 30, 1998 at 13:03:20:

Can DIRECTX display 720*480 (or 640*480) YUV 4:2:2 file and audio sound together (44k, 16 bit, 2 channel)

Follow Ups:

  • Re: DISPLAY VIDEO for DIRECTX mike Feng 13:06:12 1/30/98 (0)

Post a Followup

Name:


Re: DISPLAY VIDEO for DIRECTX

Posted by mike Feng on January 30, 1998 at 13:06:12:

In Reply to: DISPLAY VIDEO for DIRECTX posted by mike Feng on January 30, 1998 at 13:03:20:

: Can DIRECTX display 720*480 (or 640*480) YUV 4:2:2 file and audio sound together (44k, 16 bit, 2 channel)
Video need 30 frame or 24 frame or NTSC ?

Follow Ups:

Post a Followup

Name:


DirectSound

Posted by Titus Winters on January 30, 1998 at 13:51:16:

I am trying to do directSound using the examples from the SDK download as a basis. I've got everything set up correctly, but it won't find the .WAV files included as resources. Is there a bug that I don't know about or am I missing something simple? Any help would be very much appreciated.

-Titus Winters

Follow Ups:

  • Re: DirectSound Brian Shea 14:00:25 2/02/98 (0)

Post a Followup

Name:


Specifying Refresh Rate in DirectX

Posted by Jon Munshi on January 30, 1998 at 13:53:02:

Can I specify vertical refresh rate for DirectX apps? Here's why I need to know: everytime I install DirectX 5.0, it either picks the "default" (60Hz) or the "optimal" (100Hz) rate to use. As a result, my display is either very "jittery", or is badly distorted. (aAlso, video won't dispaly at those rates.) I'd like to be able to pick the "best" refresh rate for my system which is 75Hz.

Follow Ups:

Post a Followup

Name:


Help ! Fatal Exception Error when using DirectX 5.0

Posted by Tim Wilson on January 30, 1998 at 15:11:08:

Whenever I try to run a game that needs DirectX 5.0 or when I try to reinstall DirectX, I get the following error. Everything stops and the following blue screen appears:

A fatal exception OE has occurred at 0028:C003028E in VXD VPICD(01) + 00001ACA.

Please tell me what's going on and how can I this sucker running again.

Thanks

Follow Ups:

  • Re: Help ! Fatal Exception Error when using DirectX 5.0 Tom Piraino 10:54:58 2/06/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Rodrigo Valdes Ascencio on January 30, 1998 at 16:40:05:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


4:2:2 video display under directX

Posted by mike Johnson on January 30, 1998 at 18:17:03:

Can directX display 4:2:2 YUV file in 30 frame or 24 frame/sec plus audio (48k, 16bit)?

Follow Ups:

  • Re: 4:2:2 video display under directX Jagmohan S Nanaware 05:48:18 5/28/98 (0)

Post a Followup

Name:


Help! Can't get textures on 3dfx.

Posted by Jonathan Klein on January 30, 1998 at 21:02:15:

Help!

When I create a texture surface via
IDirectDraw2::CreateSurface (CAPS = DDSCAPS_TEXTURE |
DDSCAPS_VIDEOMEMORY), the GetDC() method fails. The
name of the resulting error code is VERY helpful:
DDERR_CANTCREATEDC. The debug libraries of DX5 also
inform me very well: "Can't create DC". I love micro-
soft. They never tell WHY something went wrong...
But I get this error only on Monster3D. Matrox
Mystique works fine...

To repeat it once again: HEEELP! ;)

CU

Jon

Follow Ups:

  • Re: Help! Can't get textures on 3dfx. franko 20:11:08 1/31/98 (0)

Post a Followup

Name:


Im Stpuid I know, I cant get DX5 under MSVC5 to work!!! Still!!!

Posted by Natin on January 30, 1998 at 21:33:52:

I thought i tried everything , there must be a copy of the DX5 libs in every directory in my computer, and I link everything! Can someone give me a concise detailed answer?? Thanx!!!!

Follow Ups:

  • Re: Im Stpuid I know, I cant get DX5 under MSVC5 to work!!! Still!!! Brian Shea 14:12:58 2/02/98 (0)

Post a Followup

Name:


Direct X slowdowns

Posted by Greg MacKay on January 30, 1998 at 21:39:08:

When I first installed DirectX 5 the game
I play often ran very slow.
Someone told me disable directdraw hardware
acceleration in the DirectX driver Tool program
which can be found in the DirectX directory under
Program Files.
And it worked! All non-3D applications that use
blits run incredibly fast including my own programs.

I'm still able to create surfaces and blit as usual.
Only the memory appears as 0K when I check for it.

Why is this so?

Follow Ups:

  • Re: Direct X slowdowns Brian Shea 14:15:22 2/02/98 (0)

Post a Followup

Name:


Re: DirectX5.0 and game input

Posted by justin on January 30, 1998 at 23:42:18:

In Reply to: Re: DirectX5.0 and game input posted by Fred Dings on January 24, 1998 at 14:24:54:

: : I have a y adapter that connects 2 gamepads to my sound card's gameport. I had no problem setting up two joysticks under DirectX 3.0. However, after I installed 5.0 it no longer recognizes that I have a second joystick connected. Any suggestions?

: : SuperD!

: Sorry I can,t help you with your problem, but maybe you can help me. Where do I go for Directx 5???

: Fred

Follow Ups:

  • Re: DirectX5.0 and game input cheng 11:41:16 2/07/98 (0)

Post a Followup

Name:


How to install DirectX 5.0 properly with Visual C++ 5.0

Posted by Kelvin Iu on January 30, 1998 at 23:54:53:

Hi,

I am a beginner in Visual C++ and also new to DirectX,
I just wondering if anyone can give me some clear step-by-step
instructions on how to install the DirectX 5.0 SDK with
Visual C++ 5.0. Like what setting and stuff.

Thanks.

Kelvin Iu
kiu1@po-box.mcgill.ca

Follow Ups:

  • Re: How to install DirectX 5.0 properly with Visual C++ 5.0 john grace 14:41:26 2/08/98 (0)
  • Re: How to install DirectX 5.0 properly with Visual C++ 5.0 Brian Shea 14:16:45 2/02/98 (2)
    • Re: How to install DirectX 5.0 properly with Visual C++ 5.0 Natin Lupua 19:44:55 2/03/98 (1)
      • Re: How to install DirectX 5.0 properly with Visual C++ 5.0 Brian Shea 10:42:53 2/04/98 (0)

Post a Followup

Name:


D3D help

Posted by victor on January 31, 1998 at 13:16:54:

Hi ,I'm a newbie the D3D. Does anybody knows how to move a
frame together with its axes when rotating or
translating? What does the D3DRMCOMBINE_REPLACE, AFTER
and BEFORE really mean?? Can anyone explain it to me?

Follow Ups:

Post a Followup

Name:


Clippers, cliplists, how?

Posted by Senior Project Group (PLANEFUN) on January 31, 1998 at 20:03:02:

Hi,
We are trying to put multiple clippers on a surface. All we want is a way to specify a RECT on a surface
that will be added to the cliplist. Is there a way to do this? All we can do right now
is assign the window region as the clipper with SetHwnd(), but we can't create different clipping "windows" on the surface.
It looks like SetClipList is the function we need, but don't understand how to use it.

Follow Ups:

  • Re: Clippers, cliplists, how? Chen Shen 03:10:26 2/06/98 (0)
  • Re: Clippers, cliplists, how? Brian Shea 14:20:20 2/02/98 (0)

Post a Followup

Name:


Re: Help! Can't get textures on 3dfx.

Posted by franko on January 31, 1998 at 20:11:08:

In Reply to: Help! Can't get textures on 3dfx. posted by Jonathan Klein on January 30, 1998 at 21:02:15:

lessee now.. I think your problem is just what it said, CANTCREATEDC. :) :) heheh, no. The monster3d (which is a 3dfx board) does not allow you to Create a devicecontext on its texture surfaces. A texture surface on 3dfx is kinda special.. about all you can do to it is Blt(), or Load(). You can't even Lock() it.

Some boards are like this, so you can't depend on being able to access the texture surface.. you'l have to find another way to do whatever you're doing..

: Help!

: When I create a texture surface via
: IDirectDraw2::CreateSurface (CAPS = DDSCAPS_TEXTURE |
: DDSCAPS_VIDEOMEMORY), the GetDC() method fails. The
: name of the resulting error code is VERY helpful:
: DDERR_CANTCREATEDC. The debug libraries of DX5 also
: inform me very well: "Can't create DC". I love micro-
: soft. They never tell WHY something went wrong...
: But I get this error only on Monster3D. Matrox
: Mystique works fine...

: To repeat it once again: HEEELP! ;)

: CU

: Jon

Follow Ups:

Post a Followup

Name:


I need help with guestbook signers...

Posted by Mike Kerr on February 01, 1998 at 13:58:18:

Hi, I was wondering if anyone knew how to make a page identify someone who visits a page, like to get their name without them knowing, or their ISP, or their email address.
I have people signing nasty thing in my guestbook, and I have no way to catch who they are....
If someone could help me, I'm sure I could find a way to reward you....
Thank you,'
Mike Kerr

  • Welcome to Solanco

Follow Ups:

Post a Followup

Name:


Re: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help?

Posted by Ian butler on February 02, 1998 at 08:58:01:

In Reply to: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help? posted by Jeff on January 22, 1998 at 23:27:23:

- i've got the same problem ever since i installed
tomb raider 11

Follow Ups:

  • Re: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help? Du쉆n 02:44:41 2/20/98 (0)

Post a Followup

Name:


Disabling Alt-Tab and the Win95 key

Posted by Gary Huff on February 02, 1998 at 12:31:19:

How can I disable Alt-Tab and the Win95 key for a fullscreen DX app? I
would like to forget about lost surfaces and lost buffers by disabling task
swapping. I know there is a way to do this? Can anyone help me or point me
to some docs?

Follow Ups:

  • Re: Disabling Alt-Tab and the Win95 key Brian Shea 14:30:20 2/02/98 (0)

Post a Followup

Name:


HElp with Directsound

Posted by Pas on February 02, 1998 at 13:03:59:

Can somebody send me an example where directSound works? I cant get it to work at all, and the samples don't work without the project workspaces that they didn't include. If you could send me a program w/ project files that worked, I'd be REALLY greatful.

Follow Ups:

  • Re: HElp with Directsound Brian Shea 14:22:04 2/02/98 (0)

Post a Followup

Name:


Re: DirectSound

Posted by Brian Shea on February 02, 1998 at 14:00:25:

In Reply to: DirectSound posted by Titus Winters on January 30, 1998 at 13:51:16:

From what I remember, unless you put the sound
files into your resource (the .rc file), it will
not find it as a resource.

If you want some sample code, check out my
web pages. Pretty basic stuff, I hope.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: Im Stpuid I know, I cant get DX5 under MSVC5 to work!!! Still!!!

Posted by Brian Shea on February 02, 1998 at 14:12:58:

In Reply to: Im Stpuid I know, I cant get DX5 under MSVC5 to work!!! Still!!! posted by Natin on January 30, 1998 at 21:33:52:

Ok. I hope these steps are clear:

1. Click on Tools/Options.
2. Under the Directories tab:
a. Add "c:\dxsdk\sdk\inc" to the include files.
b. Add "c:\dxsdk\sdk\lib" to the library files.
3. Create a new workspace and project.
4. Under Project/Settings:
a. Select your project.
b. Change the selection to "All Configurations"
c. Select the Link tab.
d. Add "ddraw.lib" to "Object/Library modules"

That should do it. I recommend you simple
try a very simple WinMain that just calls
DirectDrawCreate and then exits.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: Direct X slowdowns

Posted by Brian Shea on February 02, 1998 at 14:15:22:

In Reply to: Direct X slowdowns posted by Greg MacKay on January 30, 1998 at 21:39:08:

If I remember correctly, asking about the
available video memory has always been flaky.
Try using a IDirectDraw2 interface to get
the information, that might work better.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: How to install DirectX 5.0 properly with Visual C++ 5.0

Posted by Brian Shea on February 02, 1998 at 14:16:45:

In Reply to: How to install DirectX 5.0 properly with Visual C++ 5.0 posted by Kelvin Iu on January 30, 1998 at 23:54:53:

Ok. I hope these steps are clear:

1. Click on Tools/Options.
2. Under the Directories tab:
a. Add "c:\dxsdk\sdk\inc" to the include files.
b. Add "c:\dxsdk\sdk\lib" to the library files.
3. Create a new workspace and project.
4. Under Project/Settings:
a. Select your project.
b. Change the selection to "All Configurations"
c. Select the Link tab.
d. Add "ddraw.lib" to "Object/Library modules"

That should do it. I recommend you simple
try a very simple WinMain that just calls
DirectDrawCreate and then exits.

  • Journals of a DX Junkie

Follow Ups:

  • Re: How to install DirectX 5.0 properly with Visual C++ 5.0 Natin Lupua 19:44:55 2/03/98 (1)
    • Re: How to install DirectX 5.0 properly with Visual C++ 5.0 Brian Shea 10:42:53 2/04/98 (0)

Post a Followup

Name:


Re: Clippers, cliplists, how?

Posted by Brian Shea on February 02, 1998 at 14:20:20:

In Reply to: Clippers, cliplists, how? posted by Senior Project Group (PLANEFUN) on January 31, 1998 at 20:03:02:

I have some simple example code here:
http://www.angelic-coders.com/bpshea/loader.htm?/bpshea/code/ddraw.htm

The above link is simply a jump into my code
section under DirectDraw, in case it does not
quite work for you. Anyway, I hope you find
it helpful.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: HElp with Directsound

Posted by Brian Shea on February 02, 1998 at 14:22:04:

In Reply to: HElp with Directsound posted by Pas on February 02, 1998 at 13:03:59:

You can download my wrapper files, which come
with projects and workspaces and such for VC5.

Just follow my link.
Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: Disabling Alt-Tab and the Win95 key

Posted by Brian Shea on February 02, 1998 at 14:30:20:

In Reply to: Disabling Alt-Tab and the Win95 key posted by Gary Huff on February 02, 1998 at 12:31:19:

There is an answer on this page:
http://www.angelic-coders.com/QA.asp

I have not tried this myself, so I do not know
if it really works. That said, do not do this.
It is a really bad idea to disallow Alt-Tab.
I will skip the preaching, but think about it.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


MAY-DAY//MAY-DAY//MAY-DAY//NEED HELP W/CODE

Posted by Roddy ARnold on February 02, 1998 at 21:35:11:

I NEED HELP WITH VB5.0. I WOULD LIKE TO ASSEMBLE A "MIST" LIKE GAME. cAN YOU GIVE ME ANY SUGGESTIONS ON THE CODE AND HOW TO SET IT UP
tHANK YOU,

RODDY ARNOLD
roddy@vacation-hawaii.com

Follow Ups:

  • Re: MAY-DAY//MAY-DAY//MAY-DAY//NEED HELP W/CODE Brian Shea 11:43:15 2/03/98 (0)

Post a Followup

Name:


Re: MAY-DAY//MAY-DAY//MAY-DAY//NEED HELP W/CODE

Posted by Brian Shea on February 03, 1998 at 11:43:15:

In Reply to: MAY-DAY//MAY-DAY//MAY-DAY//NEED HELP W/CODE posted by Roddy ARnold on February 02, 1998 at 21:35:11:

I do not use Visual Basic, but this site may help.
http://members.aol.com/supersamat/index.htm

Good luck and happy coding,
Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


getting hooked up w/ directx

Posted by tommy on February 03, 1998 at 17:31:23:

I am trying to run a game that I bought and it says that I need directx to run it. What do I have to do to get it and what do I do to install it?

Follow Ups:

  • Re: getting hooked up w/ directx Juanita Garcia 23:51:26 6/29/98 (0)
  • Re: getting hooked up w/ directx Brian Shea 10:46:05 2/04/98 (0)

Post a Followup

Name:


Re: How to install DirectX 5.0 properly with Visual C++ 5.0

Posted by Natin Lupua on February 03, 1998 at 19:44:55:

In Reply to: Re: How to install DirectX 5.0 properly with Visual C++ 5.0 posted by Brian Shea on February 02, 1998 at 14:16:45:

: Ok. I hope these steps are clear:

: 1. Click on Tools/Options.
: 2. Under the Directories tab:
: a. Add "c:\dxsdk\sdk\inc" to the include files.
: b. Add "c:\dxsdk\sdk\lib" to the library files.
: 3. Create a new workspace and project.
: 4. Under Project/Settings:
: a. Select your project.
: b. Change the selection to "All Configurations"
: c. Select the Link tab.
: d. Add "ddraw.lib" to "Object/Library modules"

: That should do it. I recommend you simple
: try a very simple WinMain that just calls
: DirectDrawCreate and then exits.

hmm... I did these steps accuratly, I think but I get these errors when I try to compile the sample "Donuts" game code:
Deleting intermediate files and output files for project 'Dunoot - Win32 Debug'.
--------------------Configuration: Dunoot - Win32 Debug--------------------
Compiling...
donuts.c
input.c
dsutil.c
ddutil2.cpp
Linking...
donuts.obj : error LNK2001: unresolved external symbol __imp__timeGetTime@0
donuts.obj : error LNK2001: unresolved external symbol _DDCopyBitmap
donuts.obj : error LNK2001: unresolved external symbol _DDSetColorKey
donuts.obj : error LNK2001: unresolved external symbol _DDColorMatch
donuts.obj : error LNK2001: unresolved external symbol _DDLoadPalette
input.obj : error LNK2001: unresolved external symbol _c_dfDIKeyboard
input.obj : error LNK2001: unresolved external symbol _c_dfDIJoystick
input.obj : error LNK2001: unresolved external symbol _DirectInputCreateA@16
Debug/Dunoot.exe : fatal error LNK1120: 8 unresolved externals
Error executing link.exe.

Dunoot.exe - 9 error(s), 0 warning(s)

Follow Ups:

  • Re: How to install DirectX 5.0 properly with Visual C++ 5.0 Brian Shea 10:42:53 2/04/98 (0)

Post a Followup

Name:


scrolling

Posted by Serge Roy on February 03, 1998 at 22:04:09:

Could somebody tell me how I would scroll a entire screen as a side scroller style.

Follow Ups:

  • Re: scrolling Brian Shea 10:49:00 2/04/98 (0)
  • Re: scrolling Sean Barton 23:05:00 2/03/98 (0)

Post a Followup

Name:


Re: scrolling

Posted by Sean Barton on February 03, 1998 at 23:05:00:

In Reply to: scrolling posted by Serge Roy on February 03, 1998 at 22:04:09:

The process is too complex to try to explain throught one message. If you are planning on making a scrolling game with DirectX, I HIGHLY recommend the book "Spells of Fury" by Michael J. Norton. He goes into scrolling quite extensively and shows optimization methods which help your game run at a fast frame rate. Don't kid yourself, if you are a novice programmer, you need a book like this, it's just too much to try to re-invent on your own.

Good luck,

Sean

Follow Ups:

Post a Followup

Name:


Re: How to install DirectX 5.0 properly with Visual C++ 5.0

Posted by Brian Shea on February 04, 1998 at 10:42:53:

In Reply to: Re: How to install DirectX 5.0 properly with Visual C++ 5.0 posted by Natin Lupua on February 03, 1998 at 19:44:55:

: donuts.obj : error LNK2001: unresolved external symbol __imp__timeGetTime@0

I believe you need to add winmm.lib for this
function. Look up the function in help and
click on the quick info button, it tells you
what lib you need.

: donuts.obj : error LNK2001: unresolved external symbol _DDCopyBitmap
: donuts.obj : error LNK2001: unresolved external symbol _DDSetColorKey
: donuts.obj : error LNK2001: unresolved external symbol _DDColorMatch
: donuts.obj : error LNK2001: unresolved external symbol _DDLoadPalette

Try adding ddutil.cpp (not ddutil2.cpp) as well.

: input.obj : error LNK2001: unresolved external symbol _c_dfDIKeyboard
: input.obj : error LNK2001: unresolved external symbol _c_dfDIJoystick
: input.obj : error LNK2001: unresolved external symbol _DirectInputCreateA@16

You need to include the DirectInput library,
"dinput.lib". I think that should do it.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: getting hooked up w/ directx

Posted by Brian Shea on February 04, 1998 at 10:46:05:

In Reply to: getting hooked up w/ directx posted by tommy on February 03, 1998 at 17:31:23:

You can check out:
http://www.microsoft.com/DirectX/default.asp

You most likely want the "end user" download.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: scrolling

Posted by Brian Shea on February 04, 1998 at 10:49:00:

In Reply to: scrolling posted by Serge Roy on February 03, 1998 at 22:04:09:

There are also some good sites on the web.
I recommend these two to start with.

CDX is a DirectX wrapper concentrating on games
that scroll. It has tiles, maps, and the usual.
http://www.maidex.demon.co.uk/

Game Programming Galaxy is a site with some
FAQs on tiles, hex or square, and various
tips and tricks on implementing them.
http://www.geocities.com/SiliconValley/Vista/6774/

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Reading from the Primary DirectSoundBuffer

Posted by Jeff Lee on February 04, 1998 at 15:08:12:

Hey, is there a way to read from the Primary DirectSoundBuffer? What I'm trying to do is not ONLY have the mixed audio be played over the speakers, but also save that info to disk as a .wav file. Any ideas? Is this even possible?

- Jeff

Follow Ups:

Post a Followup

Name:


DirectX and OpenGL

Posted by Umut Demirhan on February 04, 1998 at 16:19:13:

I want to learn the relationship btw Direct3D and OpenGL.
Can I use them together ? How ?
If not which one is better ?

I am trying to code a simulation (with VC++ 5p) which will use TCP and Graphics (of course on Win95)

For full screen graphics which SDK should I prefer ?

Thanks.

Follow Ups:

  • Re: DirectX and OpenGL Dan Holland 18:19:00 2/27/98 (0)
  • Re: DirectX and OpenGL Sean Barton 00:40:31 2/05/98 (1)
    • Re: DirectX and OpenGL Andy Sy 09:39:01 2/05/98 (0)

Post a Followup

Name:


Re: Directdraw rotation

Posted by Jack Strohm on February 04, 1998 at 18:47:24:

In Reply to: Directdraw rotation posted by Nick on January 16, 1998 at 17:44:08:

Does your hardware support bitmap rotation?
If it doesn't I that might be the problem you are having.

: Can anyone point me to a resource that explains how
: to rotate Bitmaps in DirectX??? Or post some info here:)
: I can't seem to get it to work properly.

: Nick

Follow Ups:

Post a Followup

Name:


Re: DirectX and OpenGL

Posted by Sean Barton on February 05, 1998 at 00:40:31:

In Reply to: DirectX and OpenGL posted by Umut Demirhan on February 04, 1998 at 16:19:13:

I'm not sure if you can use OpenGL and Direct3D together (you probably could, but I imagine it would be quite complex, so why bother?)

As for which API is better, that is an ongoing debate. They both run at pretty well the same speed but Direct3D Hardware Accelerators are cheaper. If you are using 3D graphics in a game I would recommend using Direct3D since it took a mensa like John Carmack (creator of Doom, Quake, etc) to successfully pull off a good 3D game using OpenGL.

: I want to learn the relationship btw Direct3D and OpenGL.
: Can I use them together ? How ?
: If not which one is better ?

: I am trying to code a simulation (with VC++ 5p) which will use TCP and Graphics (of course on Win95)

: For full screen graphics which SDK should I prefer ?

: Thanks.

Follow Ups:

  • Re: DirectX and OpenGL Andy Sy 09:39:01 2/05/98 (0)

Post a Followup

Name:


Re: DirectX and OpenGL

Posted by Andy Sy on February 05, 1998 at 09:39:01:

In Reply to: Re: DirectX and OpenGL posted by Sean Barton on February 05, 1998 at 00:40:31:

:it took a mensa like John Carmack (creator of Doom,
:Quake, etc) to successfully pull off a good 3D game using OpenGL.

Right... but a mensa like John Carmack complained
that trying to code in Direct3d was a horrible
experience and that he found OpenGL easier to code
in.

Still, Direct3d is likely to be
better integrated with the rest of DirectX than
OpenGL. Which is unfortunate.

A lot of people are petitioning
Microsoft to give better support to OpenGL.
Carmack himself has said Microsoft should just
dump Direct3d immediate mode and replace it
with OpenGL. (Note that DirectX 5 addresses
some of the issues that caused Carmack to
seriously bashed the DirectX 3 version, but I
think he still retains his original opinion.)

I have yet to try either... but based on the
press I've been reading, and the fact that once
you learn OpenGL you can take your experience
with it to other platforms, I'd prefer that
Microsoft followed Carmack's suggestion (although
I doubt that would happen).

As it is, I can only hope that using OpenGL under
DirectX does not impose any serious performance
disadvantages or coding difficulties vs Direct3D
because I'd prefer to use the former.

  • Carmack's .plan file where he discussed Direct3D

Follow Ups:

Post a Followup

Name:


Retained Mode or Immediate Mode

Posted by Snailslug on February 05, 1998 at 17:39:18:

Should I use Retainde Mode or Immediate Mode? I am making a football game. We are going to have motion capture and 3d Studio Max models. The game will require a 3d graphics accellerator.

Snailslug

Follow Ups:

  • Re: Retained Mode or Immediate Mode Sean Barton 23:30:11 2/05/98 (0)

Post a Followup

Name:


Uninstallation of DirectX version 4

Posted by Keith Kelchner on February 05, 1998 at 18:12:47:

I installed DirectX version 4 and, after having problems with the drivers (had to revert to original drivers), wish to uninstall DirectX.

Attempts to remove/uninstall DirectX through the Windows 95 Control Panel have failed.

What can I do?

Follow Ups:

Post a Followup

Name:


Animating imported animations with AnimationSet

Posted by Bradley Elfman on February 05, 1998 at 19:46:56:

I have imported a .3ds animation via Poly Trans into
DirectX using the required AnimationSet::Load() function.
I have no problem viewing the object and scenes but
but am at a loss as to how to proceed to animate via
AnimationSet which has one useful function to be:
AnimationSet::SetTime().

All the developers at Microsoft I have contacted
claim they only use Immediate Mode, but I can't
imagine creating a game with using a 3rd party
software, such as 3DStudio Max.

I would certainly appreciate any responses from
anyone who has any ideas as to how I might animate
my animation loaded with AnimationSet.

Bradley Elfman
elf@world-net.net

Follow Ups:

  • Re: Animating imported animations with AnimationSet Bill Torla 22:21:15 2/13/98 (0)

Post a Followup

Name:


Re: Load 3DS files

Posted by Bradley Elfman on February 05, 1998 at 20:02:05:

In Reply to: Load 3DS files posted by Rafael Alvarado on January 28, 1998 at 23:41:09:

: How can I load 3DS files into DirectX Format.

: Thanks
: Rafael - AZ

You can use conv .3ds via a DOS command line. The options are given at the end of the Direct3D Retained Mode Reference, and must be read first. I have used this utility and it works fine. Now I use Poly Trans. You can download an excellent! working version of Poly Trans at www.Okino.com.
I have just now posted an inquiry as to how to animate an imported .3ds animation. It is imported from .3ds via Poly Trans using AnimationSet::Load(), and show fine but doesn't do anything.
Also, Poly Trans has an really excellent dialog and help for exporting to .x file format for use in DirectX.
I still have some problem with scale and lighting my imported .3ds file, which I assume has to do with how much info is imported into the .x file.

Bradley Elfman
elf@world-net.net

Follow Ups:

Post a Followup

Name:


Re: Retained Mode or Immediate Mode

Posted by Sean Barton on February 05, 1998 at 23:30:11:

In Reply to: Retained Mode or Immediate Mode posted by Snailslug on February 05, 1998 at 17:39:18:

If you know a lot of 3D programming, I would suggest Immediate Mode since you are in complete control of the rendering pipeline and have the ability to make the game run faster. If you are a begginner, than Retainded Mode would be the way to go.

Good luck,
Sean

: Should I use Retainde Mode or Immediate Mode? I am making a football game. We are going to have motion capture and 3d Studio Max models. The game will require a 3d graphics accellerator.

: Snailslug

Follow Ups:

Post a Followup

Name:


about coordinate

Posted by Chen Shen on February 06, 1998 at 02:57:50:

Hello:
What kind of coordinate directx use?
logical or device or both?
Have a nice day.
Chen Shen

Follow Ups:

  • Re: about coordinate Sean Barton 03:54:34 2/06/98 (1)
    • Re: about coordinate Chen Shen 00:39:28 2/07/98 (0)

Post a Followup

Name:


Re: Clippers, cliplists, how?

Posted by Chen Shen on February 06, 1998 at 03:10:26:

In Reply to: Clippers, cliplists, how? posted by Senior Project Group (PLANEFUN) on January 31, 1998 at 20:03:02:

Hello:
If you are using mfc please go on.
You can initilize on object with the
CWnd class and then call the createex()
member function and specify this object
as a child window, then try to set another clipper to this child window using setclipper.
Hope this will work for you.
Good luck.
Chen Shen

Follow Ups:

Post a Followup

Name:


Re: about coordinate

Posted by Sean Barton on February 06, 1998 at 03:54:34:

In Reply to: about coordinate posted by Chen Shen on February 06, 1998 at 02:57:50:

Chen,
I'm sorry, but I don't understand your question. Are you talking about 3D coordinates? Please try to be more specific and I'll try to help.

-Sean

: Hello:
: What kind of coordinate directx use?
: logical or device or both?
: Have a nice day.
: Chen Shen

Follow Ups:

  • Re: about coordinate Chen Shen 00:39:28 2/07/98 (0)

Post a Followup

Name:


"hello World" from tutorials with teapot.x

Posted by J Treeby on February 06, 1998 at 08:44:56:

using the tutorial i constructed the hello world program
but when i changed the object from a sphere to teapot.x
(which comes with the sdk) it rotated 360 and then crashed
I now have a 3d card and now it just takes more rotations for
it to crash.
Another program i wrote based on "hello World" allows you
to move objects and this also crashes when they are in some
rotations and certain positions near the corners of the window

it never crashes with wire frame models only with flat or gourad
shading.

My friend also has the same problem using hello world independantly
from me so my using of the hello world program i think is correct.
The only thing i can think of is that it does not set something
up needed for objects near the edges.

none of the books i have read seem to set up differently
from "hello world" so i do not know why it is crashing.

Thank you for your time i hope you can help

Jamin

Follow Ups:

Post a Followup

Name:


"hello World" from tutorials with teapot.x

Posted by J Treeby on February 06, 1998 at 08:52:48:

using the tutorial i constructed the hello world program
but when i changed the object from a sphere to teapot.x
(which comes with the sdk) it rotated 360 and then crashed
I now have a 3d card and now it just takes more rotations for
it to crash.
Another program i wrote based on "hello World" allows you
to move objects and this also crashes when they are in some
rotations and certain positions near the corners of the window

it never crashes with wire frame models only with flat or gourad
shading.

My friend also has the same problem using hello world independantly
from me so my using of the hello world program i think is correct.
The only thing i can think of is that it does not set something
up needed for objects near the edges.

none of the books i have read seem to set up differently
from "hello world" so i do not know why it is crashing.

Thank you for your time i hope you can help

Jamin

Follow Ups:

Post a Followup

Name:


Re: Help ! Fatal Exception Error when using DirectX 5.0

Posted by Tom Piraino on February 06, 1998 at 10:54:58:

In Reply to: Help ! Fatal Exception Error when using DirectX 5.0 posted by Tim Wilson on January 30, 1998 at 15:11:08:

: Whenever I try to run a game that needs DirectX 5.0 or when I try to reinstall DirectX, I get the following error. Everything stops and the following blue screen appears:

: A fatal exception OE has occurred at 0028:C003028E in VXD VPICD(01) + 00001ACA.

: Please tell me what's going on and how can I this sucker running again.

: Thanks

Tim

I'm no expert, but I had the same problem. Turns out some vidieo and sound cards
are not compatitable with directX 5. I have a compaq 1020 laptop with a Neo Magic vidieo
card and a ESS1688 sound card that DirectX 5 screws with the configuration. You may want
to start there. Hope I could help, I'm still trying to figure out what I can do????

Talk To Ya
Tom

Follow Ups:

Post a Followup

Name:


Do visual c++ ver 1.0 works on directx 5.0?

Posted by roni on February 06, 1998 at 14:44:02:

if you know the answer please contact me!
and how it's will work?

Follow Ups:

Post a Followup

Name:


where can I download direct X 5.0

Posted by Yves Lavoie on February 06, 1998 at 23:01:14:

where I can get direct X 5.0 please a answer

Follow Ups:

  • Re: where can I download direct X 5.0 IP Freely 13:14:13 7/29/98 (0)
  • Re: where can I download direct X 5.0 asdfasdf 15:14:01 7/24/98 (1)
    • Re: where can I download direct X 5.0 Carlos 14:47:31 7/27/98 (0)
  • Where Can I Download DirectX 5.0? I need it for Microsoft Flight Simulator 98 KB 06:37:59 7/23/98 (0)
  • Re: where can I download direct X 5.0 Luke Halley 19:55:50 7/20/98 (0)
  • Re: where can I download direct X 5.0 steve 14:12:08 7/16/98 (2)
    • Re: where can I download direct X 5.0 gui 17:30:25 7/18/98 (1)
      • Re: where can I download direct X 5.0 Gui 3954882 17:32:56 7/18/98 (0)
  • Re: where can I download direct X 5.0 jeff1 08:44:34 7/09/98 (0)
  • Re: where can I download direct X 5.0 Brian Parsons 14:06:47 2/15/98 (0)
  • Re: where can I download direct X 5.0 marc grace 14:26:45 2/08/98 (1)
    • Re: where can I download direct X 5.0 john grace 14:28:14 2/08/98 (0)
  • Re: where can I download direct X 5.0 cheng 11:31:51 2/07/98 (3)
    • Re: where can I download direct X 5.0 Gunyruss 23:20:14 6/15/98 (0)
    • Re: where can I download direct X 5.0 saiyan2000 23:30:22 6/06/98 (0)
    • Re: where can I download direct X 5.0 Cheng 11:35:54 2/07/98 (0)
  • Re: where can I download direct X 5.0 cheng 11:31:34 2/07/98 (1)
    • Re: where can I download direct X 5.0 fgfg 14:29:27 2/08/98 (0)
  • Re: where can I download direct X 5.0 Roni 10:20:58 2/07/98 (0)

Post a Followup

Name:


Re: about coordinate

Posted by Chen Shen on February 07, 1998 at 00:39:28:

In Reply to: Re: about coordinate posted by Sean Barton on February 06, 1998 at 03:54:34:

: Chen,
: I'm sorry, but I don't understand your question. Are you talking about 3D coordinates? Please try to be more specific and I'll try to help.

: -Sean

: : Hello:
: : What kind of coordinate directx use?
: : logical or device or both?
: : Have a nice day.
: : Chen Shen

Hello Sean
In the Windows programming, you have
several map modes that define the fransformation from logical unit to device unit. for example the MM_TEXT mode means one logical unit equals to one pixel.
If I call lpDirectDrawSurface->GetDC(&hDC);
and then LineTo(hDC, 0, 10);
this line is drawn in device coordinate or
logical coordinate?

Follow Ups:

Post a Followup

Name:


About reference count

Posted by Chen Shen on February 07, 1998 at 00:45:32:

Hello:
Which directx API increase reference count and which don't?
If I call CreatePalette() first and then call
SetPalette to associate it with a surface object. What will be the reference count? 2?
Thanks for any message on this.
Chen Shen

Follow Ups:

  • Re: About reference count Brian Shea 09:37:48 2/09/98 (1)
    • Re: About reference count Chen Shen 05:01:35 2/11/98 (0)

Post a Followup

Name:


Re: DJGPP with DirectX?

Posted by Fussel on February 07, 1998 at 09:03:46:

In Reply to: Re: DJGPP with DirectX? posted by pierpa on January 15, 1998 at 10:29:38:

:
: : It is possible to use the Direct3D with the DJGPP C++ compiler?
: Sorry! I've made an error: the right question is:
: Is it possible to use the Direct3D with the DJGPP C++ compiler?

You'll need a Win32 - Compiler such as Cygwin32 or Jan-Jaap's
gcc. As these are GNU-tools, you can dl them free, e.g. at
http://agnes.dida.physik.uni-essen.de/~janjaap/mingw32/download.html
You'll also need the DirectX-SDK (33 MB !) which you can find at
Microsofts Website. Note that the compilers both are NOT DJGPP,
but quite similar to it.

  • Fussel's Gfx-Coding page (german !)

Follow Ups:

Post a Followup

Name:


Re: How can I use the DirectX with DELPHI ? - (sorry, I don큧 speak English well)

Posted by Fussel on February 07, 1998 at 09:11:13:

In Reply to: Re: How can I use the DirectX with DELPHI ? - (sorry, I don큧 speak English well) posted by Dennis Muller on January 22, 1998 at 13:57:59:

:
: : Please, If anybody use DELPHI with DIRECTX
: : tell me how!

: : What is the DirectX SDK? I must Donwload from MS
: : is I want use the DirectX functions in DELPHI?
: : (sure I have the simple DirectX5 but not the SDK)

SDKs in general are tools for coders. The DirectX SDK
is a tool by MS to support C/C++ Coders who want to
develop Direct-X apps. E.g. this includes all the
needed libraries and include-files (libraries and
include-files are most comparable with Delphies/Pascals units).

: : Please if you can, help me! Thanks....

: :
: : If you have experient with Delphi and the DirectX,
: : please send me a letter or an example.

: Here is an URL for you to check out.
: http://www.ex.ac.uk/~PMBearne/DGC.html
: It has some free ware components to use and
: also the source code for the components. The
: components use the delphi directx units converted by Blake Stone. He has the latest
: units on his web site. Do a search on delphi and directx should turn up Blake Stone's page.

  • Fussels Gfx-Coding Page (German)

Follow Ups:

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by Roni on February 07, 1998 at 10:20:58:

In Reply to: where can I download direct X 5.0 posted by Yves Lavoie on February 06, 1998 at 23:01:14:

: where I can get direct X 5.0 please a answer

you can download directx 5.0 from microsoft.

Follow Ups:

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by cheng on February 07, 1998 at 11:31:34:

In Reply to: where can I download direct X 5.0 posted by Yves Lavoie on February 06, 1998 at 23:01:14:

: where I can get direct X 5.0 please a answer

Follow Ups:

  • Re: where can I download direct X 5.0 fgfg 14:29:27 2/08/98 (0)

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by cheng on February 07, 1998 at 11:31:51:

In Reply to: where can I download direct X 5.0 posted by Yves Lavoie on February 06, 1998 at 23:01:14:

: where I can get direct X 5.0 please a answer

Follow Ups:

  • Re: where can I download direct X 5.0 Gunyruss 23:20:14 6/15/98 (0)
  • Re: where can I download direct X 5.0 saiyan2000 23:30:22 6/06/98 (0)
  • Re: where can I download direct X 5.0 Cheng 11:35:54 2/07/98 (0)

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by Cheng on February 07, 1998 at 11:35:54:

In Reply to: Re: where can I download direct X 5.0 posted by cheng on February 07, 1998 at 11:31:51:

: : where I can get direct X 5.0 please a answer

Follow Ups:

Post a Followup

Name:


Re: DirectX5.0 and game input

Posted by cheng on February 07, 1998 at 11:41:16:

In Reply to: Re: DirectX5.0 and game input posted by justin on January 30, 1998 at 23:42:18:

: : : I have a y adapter that connects 2 gamepads to my sound card's gameport. I had no problem setting up two joysticks under DirectX 3.0. However, after I installed 5.0 it no longer recognizes that I have a second joystick connected. Any suggestions?

: : : SuperD!

: : Sorry I can,t help you with your problem, but maybe you can help me. Where do I go for Directx 5???

: : Fred

Follow Ups:

Post a Followup

Name:


Re: GIF files

Posted by Fussel on February 07, 1998 at 11:44:12:

In Reply to: GIF files posted by Adriano Oliveira on January 27, 1998 at 08:00:11:

: Does DirectDraw work with .GIF files?
: All examples i've seen use .BMP files.

Check out this URL for specs of nearly all
Bitmap-formats: http://www.dcs.ed.ac.uk/%7Emxr/gfx/

  • Fussels Gfx-Coding Page (German)

Follow Ups:

Post a Followup

Name:


Can't get DirectSound to link

Posted by James on February 07, 1998 at 17:17:04:

Im having a problem getting the DirectSound library
to link correctly. i linked DSound.lib into my project
and #include but it starts out by saying:
'LPWAVEFORMATEX' : missing decl-specifiers
and then goes on to do 46 more errors many of which
look like D3D stuff. im compiling with VC++4 using MFC.
Any help would be greatly appreciated.
Also i can't find many plases to find stuff on
DirectSound on the web... anyone got any URLs or good
books?
Thanks a LOT,
--James

Follow Ups:

  • Re: Can't get DirectSound to link jason lucking 10:35:58 6/16/98 (0)
  • Re: Can't get DirectSound to link jason lucking 10:35:56 6/16/98 (0)
  • Re: Can't get DirectSound to link KayPeng 03:52:53 2/17/98 (0)
  • Re: Can't get DirectSound to link Sean Barton 00:50:59 2/09/98 (0)
  • Re: Can't get DirectSound to link Sean Barton 00:50:05 2/09/98 (0)

Post a Followup

Name:


About DDER_NOEXCLUSIVE

Posted by Chen Shen on February 08, 1998 at 02:29:31:

I've set the DirectDraw object to be exclusive
using setcooperativelevel() but when I'm going to create a surface I've got this error.
Why?
Thanks for your message
Chen Shen

Follow Ups:

  • Re: About DDER_NOEXCLUSIVE David Salsman 21:40:14 4/04/98 (0)
  • Re: About DDER_NOEXCLUSIVE Brian Shea 09:35:28 2/09/98 (2)
    • Re: About DDER_NOEXCLUSIVE Chen Shen 04:54:05 2/11/98 (1)
      • Re: About DDER_NOEXCLUSIVE Brian Shea 14:13:21 2/12/98 (0)

Post a Followup

Name:


Re: Where is DirectX5.0

Posted by Chen Shen on February 08, 1998 at 04:35:56:

In Reply to: Re: Where is DirectX5.0 posted by Last Seanachi on January 16, 1998 at 19:49:34:

: Where can I get DIRECTX5.0? I keep playing Diablo, and it keeps freezing up. I am told from Battlenet chat that directx5.0 may solve this problem. But where can I download the software from???

:
: seanachi@nternet.net
It comes with a lot game CDs.

Follow Ups:

  • Re: Where is DirectX5.0 michelle bacque 20:33:57 3/26/98 (0)

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by marc grace on February 08, 1998 at 14:26:45:

In Reply to: where can I download direct X 5.0 posted by Yves Lavoie on February 06, 1998 at 23:01:14:

: where I can get direct X 5.0 please a answer

Follow Ups:

  • Re: where can I download direct X 5.0 john grace 14:28:14 2/08/98 (0)

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by john grace on February 08, 1998 at 14:28:14:

In Reply to: Re: where can I download direct X 5.0 posted by marc grace on February 08, 1998 at 14:26:45:

: : where I can get direct X 5.0 please a answer

Follow Ups:

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by fgfg on February 08, 1998 at 14:29:27:

In Reply to: Re: where can I download direct X 5.0 posted by cheng on February 07, 1998 at 11:31:34:

: : where I can get direct X 5.0 please a answer

Follow Ups:

Post a Followup

Name:


Re: How to install DirectX 5.0 properly with Visual C++ 5.0

Posted by john grace on February 08, 1998 at 14:41:26:

In Reply to: How to install DirectX 5.0 properly with Visual C++ 5.0 posted by Kelvin Iu on January 30, 1998 at 23:54:53:

: Hi,

: I am a beginner in Visual C++ and also new to DirectX,
: I just wondering if anyone can give me some clear step-by-step
: instructions on how to install the DirectX 5.0 SDK with
: Visual C++ 5.0. Like what setting and stuff.

: Thanks.

: Kelvin Iu
: kiu1@po-box.mcgill.ca

Follow Ups:

Post a Followup

Name:


Debug Directx 5.0 with BC++ 5.0 or MSVC++ 5.0

Posted by Paulo Egidio on February 08, 1998 at 16:49:19:

Hi!

Does anybody know how to debug (step in) FullScreen
Directx code with bc++ or msvc++?

I try to debug the simple file ddex1 and Both debuggers
simply crash the machine.

Thanks!

paulo.egidio@mandic.com.br

Follow Ups:

  • Re: Debug Directx 5.0 with BC++ 5.0 or MSVC++ 5.0 Brian Shea 09:40:07 2/09/98 (0)

Post a Followup

Name:


Re: Can't get DirectSound to link

Posted by Sean Barton on February 09, 1998 at 00:50:05:

In Reply to: Can't get DirectSound to link posted by James on February 07, 1998 at 17:17:04:

The problem is that LPWAVEFORMATEX is not defined in the DirectSound libraries, it is a structure contained in the windows multimedia sdk.
I think if you #include , it will solve your dilema.

Happy coding,
Sean

: Im having a problem getting the DirectSound library
: to link correctly. i linked DSound.lib into my project
: and #include but it starts out by saying:
: 'LPWAVEFORMATEX' : missing decl-specifiers
: and then goes on to do 46 more errors many of which
: look like D3D stuff. im compiling with VC++4 using MFC.
: Any help would be greatly appreciated.
: Also i can't find many plases to find stuff on
: DirectSound on the web... anyone got any URLs or good
: books?
: Thanks a LOT,
: --James

Follow Ups:

Post a Followup

Name:


Re: Can't get DirectSound to link

Posted by Sean Barton on February 09, 1998 at 00:50:59:

In Reply to: Can't get DirectSound to link posted by James on February 07, 1998 at 17:17:04:

The problem is that LPWAVEFORMATEX is not defined in the DirectSound libraries, it is a structure contained in the windows multimedia sdk.
I think if you #include the file mmsystem.h, it will solve your dilema.

Happy coding,
Sean

: Im having a problem getting the DirectSound library
: to link correctly. i linked DSound.lib into my project
: and #include but it starts out by saying:
: 'LPWAVEFORMATEX' : missing decl-specifiers
: and then goes on to do 46 more errors many of which
: look like D3D stuff. im compiling with VC++4 using MFC.
: Any help would be greatly appreciated.
: Also i can't find many plases to find stuff on
: DirectSound on the web... anyone got any URLs or good
: books?
: Thanks a LOT,
: --James

Follow Ups:

Post a Followup

Name:


JAMES! Where are you? DirectX book reply

Posted by Sean Barton on February 09, 1998 at 00:54:42:

James, I tried to email you back several times in reply to your question about DirectX books but I keep getting a mail error. I hope you get this message through the forum.

James,

Hmmm, I would have a tough choice in suggesting a single DirectX book.
It sort of depends on what you want to do. " Spells of Fury" is an
excellent place to start but it doesn't have any Direct3D stuff. If you
want to do Direct3D as well, "Win32 Game Developer's Guide with DirectX
3" (the first book I used) isn't bad either (except not much in the ways
of DirectSound).

If you absolutely have to use MFC, Cutting Edge Direct3D Programming is
a great way to start in Direct3D (no DirectDraw or DirectSound though).

Avoid the books "The Awesome Power of Direct3D/DirectX" and "DirectDraw
Programming". These books are way to complicated for the beginner.

Unfortunately, because DirectX has so many great features, it's hard to
find a single book that satifies programmers in all areas.

Now, as far as your own programs, I've had similar problems using
DirectX and MFC and in turn have abanded MFC completely. I suggest not
using it, its buggy and DirectX will run ALOT faster without it.

As far as your own ideas, I'd say don't sweat it. Once you know what
your doing with DirectX the ideas will fly (once again, just be patient).

Your very welcome for the encouragement. I remeber only too well what it's like to get started.

Email me if you have any questions.

Good-luck James,
Sean

Follow Ups:

Post a Followup

Name:


About mailling list

Posted by Chen Shen on February 09, 1998 at 06:20:04:

Hello:
Did you know any good directx mailling list
please tell me. If you also know how to solve the DDERR_NOECLUSIVEMODE error(I've set the cooperative level to exclusive and full screen)please give a hint.
Have a lucky day. Everyone!

Follow Ups:

  • Re: About mailling list Brian Shea 09:41:44 2/09/98 (0)

Post a Followup

Name:


Re: About DDER_NOEXCLUSIVE

Posted by Brian Shea on February 09, 1998 at 09:35:28:

In Reply to: About DDER_NOEXCLUSIVE posted by Chen Shen on February 08, 1998 at 02:29:31:

Make sure you create your window before you
set your cooperative level.

Brian

  • Journals of a DX Junkie

Follow Ups:

  • Re: About DDER_NOEXCLUSIVE Chen Shen 04:54:05 2/11/98 (1)
    • Re: About DDER_NOEXCLUSIVE Brian Shea 14:13:21 2/12/98 (0)

Post a Followup

Name:


Re: About reference count

Posted by Brian Shea on February 09, 1998 at 09:37:48:

In Reply to: About reference count posted by Chen Shen on February 07, 1998 at 00:45:32:

Undocumented, so who knows? In general I have
found the behavior strange and unpredictable.

Just expect all of your objects to go away
when your DirectDraw object does. You may
be able to control this by AddRef'ing the
objects that you create, but who knows?

  • Journals of a DX Junkie

Follow Ups:

  • Re: About reference count Chen Shen 05:01:35 2/11/98 (0)

Post a Followup

Name:


Re: Debug Directx 5.0 with BC++ 5.0 or MSVC++ 5.0

Posted by Brian Shea on February 09, 1998 at 09:40:07:

In Reply to: Debug Directx 5.0 with BC++ 5.0 or MSVC++ 5.0 posted by Paulo Egidio on February 08, 1998 at 16:49:19:

Since you are fullscreen, you can not debug
your app on the same machine using the same
monitor. Your solutions are to run the
debugger off of another monitor or another
machine. Or not run fullscreen. Or not
use the debugger.

I have some single machine with a single
monitor techniques on my pages. They
all boil down to simple "printf" style
debugging, just a matter of where the
output goes.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: About mailling list

Posted by Brian Shea on February 09, 1998 at 09:41:44:

In Reply to: About mailling list posted by Chen Shen on February 09, 1998 at 06:20:04:

There is only one DX mailing list that I know of.
You can join via this page:
http://www.angelic-coders.com/

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


DirectX Audio Driver

Posted by Jennifer on February 09, 1998 at 18:45:08:

Does anyone know where I can download an audio driver for DirectX 5 for my Compaq? Compaq says that they don't have one that is compatible with the 4824 but that I could download one from MicroSoft's home page. I looked for it but could not find it. My husband's dying to play StarFleet Academy, but we've had no luck so far.

Follow Ups:

  • Re: DirectX Audio Driver John 23:03:22 2/09/98 (1)
    • Re: dx5eng Peter Brunovsky 01:10:42 3/14/98 (0)

Post a Followup

Name:


RM Texture Problem

Posted by Larry on February 09, 1998 at 20:00:23:

I have found that when doing a flat wrap of a texture in Retained Mode there is a "wrap around" effect. For example, the top row of pixels will appear at the bottom of the texture. This is not obvious unless two different textures are on adjacent faces. This prevents tiling a scene with different textures in a seamless fashion, even if the textures are designed with this in mind. If anyone has heard of this, knows any work-arounds, or has sufficient expertise to help and is willing to hear more details, I would appreciate a response.

Follow Ups:

Post a Followup

Name:


Switching Resolution

Posted by Rodney Smith on February 09, 1998 at 21:41:47:

I am having problems switching screen resolutions. I have a game running in 640x480x16 and want to switch to 1024x768x16 for layout. I am getting "access violations" reported in the debugger output window, eventhough the program continues to run. After several of these "violations" CodeWright will usually crash with a message indicating memory problems.

I am running fullscreen (exclusive). When I want to change resolutions, I release all the surfaces, restore the display mode and set cooperative level to NORMAL then release the direct draw interface. The access violation occurs when the cooperative level is changed from exclusive to normal.

I could use some help, I'm running out of hair...
Thanks,
Rodney

Follow Ups:

  • Re: Switching Resolution Brian Shea 10:19:07 2/10/98 (0)

Post a Followup

Name:


Need help with Direct X

Posted by Jeff Linder on February 09, 1998 at 22:52:37:

New at this. Downloaded several arcade style games but they won't run withput Direct X (5.0?)

Is Direct X available from a free download site??

If not, how else can I obtain the files necessary to run these games?

Any help would be greatly appreciated.

THANX.

Follow Ups:

  • Re: Need help with Direct X Brian Shea 10:10:23 2/10/98 (0)

Post a Followup

Name:


How do you have a Direct3D scene rendered with null pasting?

Posted by Stumped on February 09, 1998 at 23:00:52:

I need to be able to draw things to the back buffer then have the rendered 3D object overlayed on top but it always has a big black square around all the 3D objects. Any Info on this would help.

Thanks.

Follow Ups:

  • Re: How do you have a Direct3D scene rendered with null pasting? Brian Shea 10:13:29 2/10/98 (0)

Post a Followup

Name:


Re: DirectX Audio Driver

Posted by John on February 09, 1998 at 23:03:22:

In Reply to: DirectX Audio Driver posted by Jennifer on February 09, 1998 at 18:45:08:

You should just download the dx5eng.exe. That should have sound drivers for most sound cards in there.

Follow Ups:

  • Re: dx5eng Peter Brunovsky 01:10:42 3/14/98 (0)

Post a Followup

Name:


This DirectX 5.0 is a complete fuck!!!!!

Posted by Alberto Danilo on February 09, 1998 at 23:04:08:

Put this fuckin' program in your ass!! This fuck locks up the system!!!
How can u build a site about a program which locks ups the system???

Follow Ups:

  • Re: This DirectX 5.0 is a complete fuck!!!!! William E. Irving 09:25:42 3/12/98 (0)
  • Re: This DirectX 5.0 is a complete fuck!!!!! Jim Lister 16:32:47 3/11/98 (0)
  • Re: This DirectX 5.0 is a complete fuck!!!!! Brian Shea 10:16:25 2/10/98 (1)
    • Re: This DirectX 5.0 is a complete fuck!!!!! john 01:24:01 2/24/98 (0)
  • Re: This DirectX 5.0 is a complete fuck!!!!! hey stupid! 01:46:31 2/10/98 (0)

Post a Followup

Name:


Re: This DirectX 5.0 is a complete fuck!!!!!

Posted by hey stupid! on February 10, 1998 at 01:46:31:

In Reply to: This DirectX 5.0 is a complete fuck!!!!! posted by Alberto Danilo on February 09, 1998 at 23:04:08:

The program does not lock up your system as much as the unknowledged user does.
Chill.

: Put this fuckin' program in your ass!! This fuck locks up the system!!!
: How can u build a site about a program which locks ups the system???

Follow Ups:

Post a Followup

Name:


Re: Need help with Direct X

Posted by Brian Shea on February 10, 1998 at 10:10:23:

In Reply to: Need help with Direct X posted by Jeff Linder on February 09, 1998 at 22:52:37:

You want the end user download via:
http://www.microsoft.com/DirectX/

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: How do you have a Direct3D scene rendered with null pasting?

Posted by Brian Shea on February 10, 1998 at 10:13:29:

In Reply to: How do you have a Direct3D scene rendered with null pasting? posted by Stumped on February 09, 1998 at 23:00:52:

You need to do a blit with the transparent flag
set. And you need to set the color key for the
surface. If you are already doing this, try
using Blt() instead of BltFast(). Or, if you
are keying on anything besides black and using
16-bit surfaces, make sure you are constructing
the color value properly. Hope this gives you
a place to start.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: This DirectX 5.0 is a complete fuck!!!!!

Posted by Brian Shea on February 10, 1998 at 10:16:25:

In Reply to: This DirectX 5.0 is a complete fuck!!!!! posted by Alberto Danilo on February 09, 1998 at 23:04:08:

The site, in general, is about how not to lock
up a system with DirectX. At least from the
programmer's point of view. We did not write
DirectX, we just try to use it.

It is not a site dedicated to technical support
for end users, but we are usually happy to help.

Brian

  • Journals of a DX Junkie

Follow Ups:

  • Re: This DirectX 5.0 is a complete fuck!!!!! john 01:24:01 2/24/98 (0)

Post a Followup

Name:


Re: Switching Resolution

Posted by Brian Shea on February 10, 1998 at 10:19:07:

In Reply to: Switching Resolution posted by Rodney Smith on February 09, 1998 at 21:41:47:

If you are getting access violations, maybe the
operation is async, but you release the ddraw
object before the operation completes and get
the violation when the operation finally starts.

Try not releasing the ddraw object. You can
keep using it even if you are switching modes.

Or, if you are exiting, try putting a sleep(50)
between the mode change and the release of the
object.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


I know where you can download DIRECTX 5.0 !!!!

Posted by Luiz Guilherme Krause de Salles on February 10, 1998 at 15:21:57:

U can download rthe DIRECTX 5.0 in this site:
"http://microsoft.com/directx/download.asp"!!!
It was my pleasure!!!

Follow Ups:

  • Re: I know where you can download DIRECTX 5.0 !!!! joe 18:13:47 9/02/98 (0)
  • Re: I know where you can download DIRECTX 5.0 !!!! kmc 22:31:09 5/29/98 (0)
  • Why can't I decompress the SDK??? Shaofei 01:32:05 2/12/98 (0)
  • Re: I know where you can download DIRECTX 5.0 !!!! rick 21:58:03 2/10/98 (0)

Post a Followup

Name:


Direct memory access in DirectDraw

Posted by Nick Pleis on February 10, 1998 at 15:59:14:

Hey,

I'm currently working on a bitmap rotation algorithm
using directdraw(because no 2d accelerators seem
to support the hardware rotation that DirectDraw
supports)

I have the algorithm all nice and ready to go and now
I need to figure out how to actually move the pixels
around to rotate the bitmap.

I know that I need to lock the surfaces that I want to
access...and I understand the whole width and pitch
thing:). Now I need to figure out how to actually
read the pixel from one surface and write it to new surface...

Any help you can give me is appreciated..and if possible
could you also reply to my e-mail?(npleis@cei.net)

Thanks

Nick

Follow Ups:

  • Re: Direct memory access in DirectDraw Brian Shea 08:08:10 2/11/98 (1)
    • Re: Direct memory access in DirectDraw Brian Shea 08:12:56 2/11/98 (0)

Post a Followup

Name:


Re: I know where you can download DIRECTX 5.0 !!!!

Posted by rick on February 10, 1998 at 21:58:03:

In Reply to: I know where you can download DIRECTX 5.0 !!!! posted by Luiz Guilherme Krause de Salles on February 10, 1998 at 15:21:57:

: U can download rthe DIRECTX 5.0 in this site:
: "http://microsoft.com/directx/download.asp"!!!
: It was my pleasure!!!

Follow Ups:

Post a Followup

Name:


Re: About DDER_NOEXCLUSIVE

Posted by Chen Shen on February 11, 1998 at 04:54:05:

In Reply to: Re: About DDER_NOEXCLUSIVE posted by Brian Shea on February 09, 1998 at 09:35:28:

: Make sure you create your window before you
: set your cooperative level.

: Brian

Hello Brian:
I use the ASSERT_VALID(this);
to check the CMainFrame object and it's ok.
What I got is first the display mode changed and I saw my window than the
DDERR_NOEXCLUSIVEMODE error.
Thanks for your message.
Chen.Shen

Follow Ups:

  • Re: About DDER_NOEXCLUSIVE Brian Shea 14:13:21 2/12/98 (0)

Post a Followup

Name:


Re: About reference count

Posted by Chen Shen on February 11, 1998 at 05:01:35:

In Reply to: Re: About reference count posted by Brian Shea on February 09, 1998 at 09:37:48:

: Undocumented, so who knows? In general I have
: found the behavior strange and unpredictable.

: Just expect all of your objects to go away
: when your DirectDraw object does. You may
: be able to control this by AddRef'ing the
: objects that you create, but who knows?
Hello Brian
What a easy life would it be if microsoft had put some function like
int IUnKnow::GetReferenceCount()
{
return m_nCount;
}
and
void IUnKnow::DeleteObject()
{
if(m_nCount>0)
{
delete this;
}
}

Follow Ups:

Post a Followup

Name:


Re: Direct memory access in DirectDraw

Posted by Brian Shea on February 11, 1998 at 08:08:10:

In Reply to: Direct memory access in DirectDraw posted by Nick Pleis on February 10, 1998 at 15:59:14:

Here is a simple example that gets the first
pixel. You need to expand upon this to get
the address of an arbitrary pixel. Really
just a pointer indexed into the array by
(width*y+x)*(bitdepth/8), assuming it is
an array of bytes.

// Lock the buffer.
HRESULT hr = surface->Lock(0, &ddsd, flags, 0);
if (FAILED(hr)) { return false; }

// Get the first pixel and mask it to bpp.
unsigned long color = *(unsigned long *)ddsd.lpSurface;
color &= (1 > 8);
}

Basically writing each byte of the color
to the destination surface, assuming that
destination is a char pointer. All of this
code is *so* much easier if you can hard
code what the target and destination bit
depths are. For example, if you assume
8-bit they are just char arrays that you
copy around. If you assume both are 16-bit,
then they are just arrays of ints.

Brian

  • Journals of a DX Junkie

Follow Ups:

  • Re: Direct memory access in DirectDraw Brian Shea 08:12:56 2/11/98 (0)

Post a Followup

Name:


Re: Direct memory access in DirectDraw

Posted by Brian Shea on February 11, 1998 at 08:12:56:

In Reply to: Re: Direct memory access in DirectDraw posted by Brian Shea on February 11, 1998 at 08:08:10:

My message got munged, probably due to the
shift operator. Here it is again:

Here is a simple example that gets the first
pixel. You need to expand upon this to get
the address of an arbitrary pixel. Really
just a pointer indexed into the array by
(width*y+x)*(bitdepth/8), assuming it is
an array of bytes.

// Lock the buffer.
HRESULT hr = surface->Lock(0, &ddsd, flags, 0);
if (FAILED(hr)) { return false; }

// Get the first pixel and mask it to bpp.
unsigned long color = *(unsigned long *)ddsd.lpSurface;
color &= (1 << ddsd.ddpfPixelFormat.dwRGBBitCount)-1;

After you get the value you need to write it
into the destination surface. Pseudo-code
would be something like:

unsigned long color = ...;
for (int i = 0 ; i < bitDepth / 8 ; ++i) {
destination++ = (unsigned char)color;
color = (color >> 8);
}
Basically writing each byte of the color
to the destination surface, assuming that
destination is a char pointer. All of this
code is *so* much easier if you can hard
code what the target and destination bit
depths are. For example, if you assume
8-bit they are just char arrays that you
copy around. If you assume both are 16-bit,
then they are just arrays of ints.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


How to make .x file for Direct3D

Posted by William Chan on February 11, 1998 at 21:59:27:

I only know using cons3ds to convert .3ds file to
.x file.
Is there any other program can convert another file
format to .x file ?
Thank you ^_^

Follow Ups:

Post a Followup

Name:


Why can't I decompress the SDK???

Posted by Shaofei on February 12, 1998 at 01:32:05:

In Reply to: I know where you can download DIRECTX 5.0 !!!! posted by Luiz Guilherme Krause de Salles on February 10, 1998 at 15:21:57:

When I install the SDK, the program say "Can't decompress the EXE" , then I can only exit!
Why ????

Follow Ups:

Post a Followup

Name:


HELP! I'll do anything for help with DirectPlay

Posted by Johnny Wood on February 12, 1998 at 10:57:19:

First of all, I'm using Borland C++5.0. I'm trying to install DPChat and it keeps telling me I have unresolved externals. They are:

CoCreateInstance
_GUID_NULL
CoInitialize
CoUninitialize

I know that these are the gateway to the COM object - but what do I need to link to? I've linked to the dplayx.lib file? Is there a .lib or .dll file I'm leaving out?

Any help is greatly appreciated!

Johnny

Follow Ups:

  • Nevermind... Johnny Wood 12:34:57 2/13/98 (0)

Post a Followup

Name:


NT 4.0 ?

Posted by Steve Jones on February 12, 1998 at 14:06:40:

Currently I only know of directx 3 for Windows NT 4.0
Is there a directx 5.0 for Win NT Server / Workstation

Follow Ups:

  • Re: NT 4.0 ? Brian Shea 14:09:32 2/12/98 (0)

Post a Followup

Name:


Re: NT 4.0 ?

Posted by Brian Shea on February 12, 1998 at 14:09:32:

In Reply to: NT 4.0 ? posted by Steve Jones on February 12, 1998 at 14:06:40:

DirectX 3.0 is as high as NT 4.0 is likely to
ever go. When NT 5.0 comes up, it should include
DirectX 6.0.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: About DDER_NOEXCLUSIVE

Posted by Brian Shea on February 12, 1998 at 14:13:21:

In Reply to: Re: About DDER_NOEXCLUSIVE posted by Chen Shen on February 11, 1998 at 04:54:05:

Actually, I should have said to make sure that
your window is created and *visible* before
setting the exclusive mode. But if I read
your message correctly, you are doing that.
Feel free to email me for faster responses.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Help with LPDIRECT3DRMFACE::GetVertices()

Posted by Sean Barton on February 12, 1998 at 15:08:27:

Several times now, I've tried to get the vertices of a face by using the function GetVertices(), but the values copied to my Vertex array are definetly wrong (sometimes all zeros, sometimes VERY big numbers).

I've eventually given up and resorted to getting the number of vertices in my Face object (through GetVertexCount) and calling GerVertex() in a loop (receiving one vertex for each vertex in my Face).

Although this method works fine, I was wondering if anyone out there had any insight on how I could successfully use GetVertices() instead (is this function flawed)?

Thanks,
Sean

Follow Ups:

Post a Followup

Name:


Texturemaps loaded with IDirect3DRM::Load() not visible

Posted by John Giors on February 13, 1998 at 02:14:27:

I'm working on a game demo using Direct3D. I am loading .X objects with IDirect3DRM::Load(), but the surface of the rendered object is not textured.

I have placed debug code in my loadTextures() callback (which calls the IDirect3DRM::LoadTexture() function), so I know that the callback is being called with the valid filename when the object is loaded.

Is this due to the rendering device not supporting texture maps? When I create the device, I request the default device, which I thought always supported bitmaps, please inform me if this is incorrect. I HAVE tried setting the render quality attributes of the D3D device, but this seems to have no effect.

I am not completely certain that this is a code failure. I am using Caligari trueSpace 2 for object creation, and have tried converting the output files in several ways: converting with the demo version of PolyTrans, converting with another program I found, converting from trueSpace format to .3DS format followed with a conversion using conv3ds, etc. Nothing has worked. I've noticed that PolyTrans has an option to set all surfaces to white (which I thought might remove testures), so I turned it off, but that did not work, either.

If anyone can help me out, it is GREATLY appreciated. Thanks.

Follow Ups:

  • Re: Texturemaps loaded with IDirect3DRM::Load() not visible Fran Avil�s 19:41:48 3/11/98 (0)

Post a Followup

Name:


Nevermind...

Posted by Johnny Wood on February 13, 1998 at 12:34:57:

In Reply to: HELP! I'll do anything for help with DirectPlay posted by Johnny Wood on February 12, 1998 at 10:57:19:

The file BORLAND 5.0 users need to link with the COM interface is OLE2W32.LIB. How could I have been so stupid? Hope that helps other people out.

Follow Ups:

Post a Followup

Name:


Porting MS-DOS 3d Engine to DirectX

Posted by Daniel Mori on February 13, 1998 at 18:11:27:

I have wrote a protected mode 3d-engine in c/c++ for MS-DOS. I want to try to port this over to directX but I need to know if I will need to use direct3d, and if so what mode; retained or immediate or a combination of both.

Any help with this and any other advice would be very much welcomed! Thanx!

Follow Ups:

  • Re: Porting MS-DOS 3d Engine to DirectX Sean Barton 19:46:21 2/13/98 (0)

Post a Followup

Name:


Re: Porting MS-DOS 3d Engine to DirectX

Posted by Sean Barton on February 13, 1998 at 19:46:21:

In Reply to: Porting MS-DOS 3d Engine to DirectX posted by Daniel Mori on February 13, 1998 at 18:11:27:

If you're using your own 3D library, then you'll want to use Immediate mode.

: I have wrote a protected mode 3d-engine in c/c++ for MS-DOS. I want to try to port this over to directX but I need to know if I will need to use direct3d, and if so what mode; retained or immediate or a combination of both.

: Any help with this and any other advice would be very much welcomed! Thanx!

Follow Ups:

Post a Followup

Name:


Re: Animating imported animations with AnimationSet

Posted by Bill Torla on February 13, 1998 at 22:21:15:

In Reply to: Animating imported animations with AnimationSet posted by Bradley Elfman on February 05, 1998 at 19:46:56:

: I have imported a .3ds animation via Poly Trans into
: DirectX using the required AnimationSet::Load() function.
: I have no problem viewing the object and scenes but
: but am at a loss as to how to proceed to animate via
: AnimationSet which has one useful function to be:
: AnimationSet::SetTime().

I am currently having the EXACT same problem as you!
(At least I'm not alone!) I use 3D Studio Max and have
animated objects with that. I export the files as .3DS
files and then use 'conv3ds' to convert them. I don't
get any errors when I import the animation via
AnimationSet::Load() but for some reason I can't play
the animation. 'SetTime()' doesn't seem to do anything.
I have a book on Direct3D but that doesn't help because
all the examples always create everything from scratch
and never load anything from a file! I wish I could help
you more than that! How are you doing with loading the
rest of the data: frames, meshes, textures, etc.? Please
contact me via email so we may further discuss this or
exchange any ideas. Thanks!

Follow Ups:

Post a Followup

Name:


Help with optimizations

Posted by Johnny Wood on February 14, 1998 at 01:48:03:

I have an isometric tile engine that has smooth scrolling. The problem is, when you hold down a key and the WM_(KEY) message is processed, the scrolling is very slow. However, if scrolling is performed automatically without user input, the scrolling is super fast. Why is the keyboard input slowing down the scrolling so much and what are ways to optimize this? Someone once mentioned using another method of keytrapping instead of the windows messenger. They also said something about using a different timer than the WM_TIMER message.
Can anyone sock it to me? Thanks for any input.

Johnny

Follow Ups:

  • Re: Help with optimizations Nick Caldwell 12:55:58 2/16/98 (0)
  • Re: Help with optimizations Sean Barton 03:35:51 2/14/98 (0)

Post a Followup

Name:


Re: Help with optimizations

Posted by Sean Barton on February 14, 1998 at 03:35:51:

In Reply to: Help with optimizations posted by Johnny Wood on February 14, 1998 at 01:48:03:

You should definetly stay away from using window messages when it comes down to games. As an alternative, use DirectInput or GetAsyncKeyState(). I've used both and they are very fast. As to which method you may want to use, that's up to you. I prefer using DirectInput calls, but GetAsyncKeyState is definetly easier to use (if you are only conerned with keyboard input, then use this).

Good luck,
Sean

: I have an isometric tile engine that has smooth scrolling. The problem is, when you hold down a key and the WM_(KEY) message is processed, the scrolling is very slow. However, if scrolling is performed automatically without user input, the scrolling is super fast. Why is the keyboard input slowing down the scrolling so much and what are ways to optimize this? Someone once mentioned using another method of keytrapping instead of the windows messenger. They also said something about using a different timer than the WM_TIMER message.
: Can anyone sock it to me? Thanks for any input.

: Johnny

Follow Ups:

Post a Followup

Name:


Helping me to playing FIFA98 fast

Posted by Wirawan Salim on February 14, 1998 at 08:46:45:

Can you tell me where can I get directx 5.0 or something
that can make me play FIFA98 faster !!!
I'm playing with PC-Intel Pentium 90, Memory 24 Mb.
But it's run very slowly
Please give information !!!!

Follow Ups:

Post a Followup

Name:


Helping me to playing FIFA98 fast

Posted by Wirawan Salim on February 14, 1998 at 08:50:03:

Can you tell me where can I get directx 5.0 or something
that can make me play FIFA98 faster !!!
I'm playing with PC-Intel Pentium 90, Memory 24 Mb.
But it's run very slowly
Please give information !!!!

Follow Ups:

Post a Followup

Name:


How do i work with DIRECTX SDK 5 with VC++ ver 1.0?

Posted by Roni Winik on February 14, 1998 at 13:41:12:

How cam i work with derctx sdk 5 with visual c++ 1.0 because it's the only c++ that i have?

Follow Ups:

  • Re: How do i work with DIRECTX SDK 5 with VC++ ver 1.0? kalrithian 20:52:21 2/22/98 (0)

Post a Followup

Name:


Desktop ZX - DirectX desktop software

Posted by Rainer M. Domingo on February 15, 1998 at 12:09:58:

Hi there,

Looking for an interesting DirectX product? Try
Desktop ZX, it lets you design your primary desktop
interface using your own graphics and text. It's 100%
pure DirectX. Knowledge or use of HTML, Java or
ActiveX is not required.

If you get a change, stop by the site and let us know
what you think.

Rainer M. Domingo
WebStealth
Honolulu, Hawaii

  • Desktop ZX by WebStealth

Follow Ups:

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by Brian Parsons on February 15, 1998 at 14:06:47:

In Reply to: where can I download direct X 5.0 posted by Yves Lavoie on February 06, 1998 at 23:01:14:

: where I can get direct X 5.0 please a answer

Follow Ups:

Post a Followup

Name:


DIRECTX 5.0

Posted by BRIAN on February 15, 1998 at 19:11:02:

IS THERE AN UPGRADE FOR DIRECTX 4.0 TO 5.0
USING THE OILCHANGE PROGRAM???
PLEASE HELP.

Follow Ups:

Post a Followup

Name:


DIRECTX 5.0

Posted by BRIAN on February 15, 1998 at 19:12:09:

IS THERE AN UPGRADE FOR DIRECTX 4.0 TO 5.0
USING THE OILCHANGE PROGRAM???
PLEASE HELP.

Follow Ups:

Post a Followup

Name:


How do you set up a direct draw surface so that OpenGl can render to it?

Posted by Thomas Mauer on February 15, 1998 at 21:09:51:

I am trying to write a program usung DirectDraw and
OpenGl. I'm using OpenGL because I am in Windows NT
and D3D version 3 sucks and version 5 is not supported.

My Problem:
I need OpenGL to be able to render to a
DirectDrawSurface. Is this posible and does anyone
know how to do it?

Thomas Mauer

Follow Ups:

Post a Followup

Name:


Re: Help with optimizations

Posted by Nick Caldwell on February 16, 1998 at 12:55:58:

In Reply to: Help with optimizations posted by Johnny Wood on February 14, 1998 at 01:48:03:

Don't use window messages for keyboard input!! It
is slower than dirt. Use DirectInput instead. Also,
don't use the windows timer message, instead use
multimedia timers. If you want even more speed
use peekmessage instead of getmessage.

Follow Ups:

Post a Followup

Name:


Directx 5.0

Posted by Jason Haley on February 16, 1998 at 20:44:13:

I currently have directx 5.0 installed on my computer. But when I run the program dxsetup.exe it shows that my primary display driver is not certified. Can anyone help me out as to how I can get this problem fixed?

Follow Ups:

Post a Followup

Name:


what's the safe way to uninstall directX 5

Posted by chau kwok on February 17, 1998 at 02:36:39:

Please help!
The directX 5 is not compatible with my computer,
and it takes up alot of my memory so I've been trying
to uninstall it but unsucessful. Any advise? thanks
chau

Follow Ups:

Post a Followup

Name:


Re: Can't get DirectSound to link

Posted by KayPeng on February 17, 1998 at 03:52:53:

In Reply to: Can't get DirectSound to link posted by James on February 07, 1998 at 17:17:04:

: Im having a problem getting the DirectSound library
: to link correctly. i linked DSound.lib into my project
: and #include but it starts out by saying:
: 'LPWAVEFORMATEX' : missing decl-specifiers
: and then goes on to do 46 more errors many of which
: look like D3D stuff. im compiling with VC++4 using MFC.
: Any help would be greatly appreciated.
: Also i can't find many plases to find stuff on
: DirectSound on the web... anyone got any URLs or good
: books?
: Thanks a LOT,
: --James

add these
#include
#include

and the following library files are present
winmm.lib
dsound.lib

(I am using VC 5++)

Follow Ups:

Post a Followup

Name:


DirectPlay and MM100PCTV card

Posted by Keith Crilly on February 17, 1998 at 08:59:38:

I have installed a MM100PCTV card in my pc and it states it need DirectX5.0 to run.
I downloaded and installed DX5.0 but when I try to run the Tv card it comes back with no DirectDraw providor Overlay disabled??
Can someone help. I am running WIn95 on Pentium MMX200

Follow Ups:

  • Re: DirectPlay and MM100PCTV card Keith Crilly 04:45:02 2/18/98 (0)

Post a Followup

Name:


DirectX5

Posted by Lois Nicholls on February 17, 1998 at 16:15:39:

I downloaded a demo version of Curse of Monkey Island
with DirectX5 download included and it worked fine.
I then purchased the game, uninstalled the demo as per
instructions but the purchased game freezes my whole
system, screen, keyboard, mouse et al. Checking for
compatability with DirectX5 indicates there is no hard-
ware support for the Primary Display Driver, Primary
sound Driver and Sound System Player. Why did the first
DirectX5 download work but this one won't and what do I
do about the problem?
Thank you, any help would be greatly appreciated.
Lois Nicholls

Follow Ups:

  • Re: DirectX5 eduard 16:59:13 9/17/98 (0)
  • Re: DirectX5 William 09:06:31 9/10/98 (0)
  • Re: DirectX5 ziv 06:21:01 6/11/98 (0)
  • Re: DirectX5 warren goodman 05:26:15 6/07/98 (0)
  • Re: DirectX5 serge poirier 22:09:24 2/19/98 (7)
    • Re: DirectX5 head hunter 05:33:46 6/03/98 (1)
      • Re: DirectX5 Ratchet 15:38:41 9/13/98 (0)
    • directx5 needed for download THOMAS KURT 09:13:58 3/24/98 (3)
      • Re: directx5 needed for download mohd amri 19:35:30 9/26/98 (0)
      • Re: directx5 needed for download Matthew Broyles 19:22:06 6/11/98 (0)
      • Re: directx5 needed for download Leon Martin 13:48:53 6/06/98 (0)
    • Re: DirectX5 nuno 19:11:41 3/20/98 (0)
  • Re: DirectX5 serge poirier 22:07:28 2/19/98 (2)
    • Re: DirectX5 ZAMIR FAQIRYAR 21:54:57 6/18/98 (0)
    • Re: DirectX5 U Myint Oo 00:31:16 2/26/98 (0)

Post a Followup

Name:


Miro Media Online and Directx 5.0

Posted by Andreas on February 17, 1998 at 16:19:36:

Hello, I need some help!

Everytime I install Directx 5.0� on my computer the system doesn큧 know anymore my Gameport-Joystick. Its on a Miro MediaOnline Card.

Does anybody know this problem?

Please mail me!

Thanks a lot

Follow Ups:

Post a Followup

Name:


3D Drawing Software for D3D

Posted by Larry Weinstein on February 17, 1998 at 21:17:56:

Can someone recommend 3D drawing software for Direct3D use? I want to be able to design 3D objects and then edit their textures. Is 3D Studio Max the only choice -- and will it do a good job? Keep in mind that I only wish to design objects, not scenes. With real-time Direct3D as the target, vertex counts must be kept reasonable, textures dimensions must be in powers of 2, data on nomals must be maintained, etc. Thanks!
(weinstei@cs.fsu.edu)

Follow Ups:

  • Re: 3D Drawing Software for D3D Sean Barton 13:20:34 2/19/98 (0)

Post a Followup

Name:


Borland C++ 5.0 and Direct Input

Posted by Johnny Rotten on February 17, 1998 at 23:49:55:

First off, thanks to Nick Caldwell and Sean Barton for giving optimization advice.

On to the next problem....

I am trying to use Direct Input, but I am getting the message "unresolved external 'c_dfDIKeyboard' referenced from module...". I've taken a look at the original DINPUT.LIB and 'c_dfDIKeyboard' is there. However, in the Borland .LIB file that I created using IMPLIB, 'c_dfDIKeyboard' is not there. What do I do now? Does anyone know of a place to get complete & tested DirectX .LIB files for Borland compilers.

Thanks in advance for any help!

Johnny

Follow Ups:

  • Re: Borland C++ 5.0 and Direct Input Mocihi Seya 00:10:20 2/18/98 (1)
    • That helps, but..... Johnny Rotten 00:11:03 2/19/98 (0)

Post a Followup

Name:


Re: Borland C++ 5.0 and Direct Input

Posted by Mocihi Seya on February 18, 1998 at 00:10:20:

In Reply to: Borland C++ 5.0 and Direct Input posted by Johnny Rotten on February 17, 1998 at 23:49:55:

Hello, Mr.Rotten.

I reproduced the definition of c_dfDIKeyboard.
Please check below file.
http://www.geocities.co.jp/SiliconValley/7242/dikeyboard.html

Cheers,

Moichi Seya
bbx@geocities.co.jp

: First off, thanks to Nick Caldwell and Sean Barton for giving optimization advice.

: On to the next problem....

: I am trying to use Direct Input, but I am getting the message "unresolved external 'c_dfDIKeyboard' referenced from module...". I've taken a look at the original DINPUT.LIB and 'c_dfDIKeyboard' is there. However, in the Borland .LIB file that I created using IMPLIB, 'c_dfDIKeyboard' is not there. What do I do now? Does anyone know of a place to get complete & tested DirectX .LIB files for Borland compilers.

: Thanks in advance for any help!

: Johnny

Follow Ups:

  • That helps, but..... Johnny Rotten 00:11:03 2/19/98 (0)

Post a Followup

Name:


Re: DirectPlay and MM100PCTV card

Posted by Keith Crilly on February 18, 1998 at 04:45:02:

In Reply to: DirectPlay and MM100PCTV card posted by Keith Crilly on February 17, 1998 at 08:59:38:

: I have installed a MM100PCTV card in my pc and it states it need DirectX5.0 to run.
: I downloaded and installed DX5.0 but when I try to run the Tv card it comes back with no DirectDraw providor Overlay disabled??
: Can someone help. I am running WIn95 on Pentium MMX200

I have fixed my own problem. I had a SPEA SHOWTIME graphics card installed. I removed this and installed a S3 VIRGE/DX and now all works fine.

Follow Ups:

Post a Followup

Name:


Re: Drawing overlays over video

Posted by Stas on February 18, 1998 at 07:33:53:

In Reply to: Drawing overlays over video posted by jerry maresca on January 15, 1998 at 11:02:58:

: Hello,

: I am working with some active movie displays and need to overlay some text and graphics over the video. I would like to know the most efficient way to do this. There are up to four separate windows displaying video simultaneously. I tried using DirectDraw with a separate backbuffer for each window, and letting each blit to the primary buffer with the video, but this brought the refresh rates down to under 20fps and I need 30. I can sustain 30fps by using GDI, but this results in flickery overlays. Anyone got any ideas???

: Many Thanks.

You have several options:
1) Overwrite video renderer. (hard way)
2) Obtain IVideoWindow interface and try to write over it(bad way).

3) Use stream interfaces of DirectShow (Example: showstrm)
There you have DX surfaces which you blt by your litle self
so you can get hdc of a source surface which IStreamSample creates for you
and write whatever you want on it and then blit it to primary surface.

Regards,
Stas.

Follow Ups:

Post a Followup

Name:


WebStealth's DirectX Development Page

Posted by Rainer M. Domingo on February 18, 1998 at 13:52:08:

We've started a DirectX Development Page in response to
some of the email we sent out. It's just one page,
but it includes our suggestions for DirectX development.

The URL address is listed below.

Rainer M. Domingo
WebStealth
Honolulu, Hawaii

  • WebStealth's DirectX Development Page

Follow Ups:

Post a Followup

Name:


D3D texture load

Posted by Spika on February 18, 1998 at 17:19:43:

Hello,

I'm trying to use d3d hardware acceleration in our game, it must download lots of
textures (64K on average, 200K peak, per frame). All the textures are the same size,
say 64x64, and I pre-allocate all the surfaces in video memory and get texture
interfaces and handles for HAL for all the surfaces (I use a 3Dfx board with 2Mb of
texture memory, so it can hold 512 64x64 texture surfaces simultaneously, and it does).
This way I can re-use the surfaces and only have to Load() textures in real time
saving time for freeing and re-creating the surfaces and getting interfaces and handles.

The problem is, it's the Load() call that slows everything down to an unacceptable fps.
I tried to figure out what is the processing that d3d does when I call Load()
before the data eventually gets into 3Dfx texture memory. I got a system-wide profile
with Intel's V-Tune and it showed that most of time CPU spends in some routine in
DIBENG.DLL and several times less in 3Dfx driver.

I allocate textures in video memory in PAL8 format, and the palette is pre-attached to
each surface. The transit system memory surface from which I Load() the textures has
the same pixel format and the same palette, so is any processing required before downloading the data into the board? How can I reduce the overhead?

I would really appreciate your help.

====================================================================================

Here's my (simplified) code:

// Transit texture surface
LPDIRECTDRAWSURFACE lpDDSTransitTex; // Transit texture surface (in system memory)
LPDIRECT3DTEXTURE2 lpTransitTex; // Transit texture d3d texture interface

// DirectDraw palette shared among all video memory texture surfaces
// and the transit system memory texture surface
LPDIRECTDRAWPALETTE lpBitmapPalette;

// Surface, texture interface and handle for the video memory texture
LPDIRECTDRAWSURFACE lpDDSTex;
LPDIRECT3DTEXTURE2 lpTex;
D3DTEXTUREHANDLE hTex;

...
...
...

// Create a DirectDraw palette for the texture
LastError = lpDD->CreatePalette(DDPCAPS_8BIT | DDPCAPS_ALLOW256,
(PALETTEENTRY *)adw,
&lpBitmapPalette, NULL);
if (LastError != DD_OK) {
...
}

...
...
...

// Create the transit texture surface in system memory

memset(&ddsd, 0, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT;
ddsd.ddsCaps.dwCaps = DDSCAPS_TEXTURE | DDSCAPS_SYSTEMMEMORY;
// ddsdTexture is a surface description I got when enumerating texture formats
memcpy(&ddsd.ddpfPixelFormat, &ddsdTexture.ddpfPixelFormat, sizeof(DDPIXELFORMAT));
ddsd.dwHeight = TEX_SIZE; // =64
ddsd.dwWidth = TEX_SIZE;

LastError = lpDD->CreateSurface(&ddsd, &lpDDSTransitTex, NULL);
if (LastError != DD_OK) {
...
}

// Get texture interface for the transit texture

LastError = lpDDSTransitTex->QueryInterface( IID_IDirect3DTexture2, (LPVOID*)&lpTransitTex);
if (LastError != DD_OK) {
...
}

// Associate the palette with transit tex surface

LastError = lpDDSTransitTex->SetPalette( lpBitmapPalette );
if (LastError != D3D_OK) {
...
}

...
...
...

// Create a texture surface in video mem

memset(&ddsd, 0, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT;
ddsd.ddsCaps.dwCaps = DDSCAPS_TEXTURE | DDSCAPS_VIDEO

Follow Ups:

Post a Followup

Name:


D3D texture load

Posted by Spika on February 18, 1998 at 17:23:57:

Hello,

I'm trying to use d3d hardware acceleration in our game, it must download lots of
textures (64K on average, 200K peak, per frame). All the textures are the same size,
say 64x64, and I pre-allocate all the surfaces in video memory and get texture
interfaces and handles for HAL for all the surfaces (I use a 3Dfx board with 2Mb of
texture memory, so it can hold 512 64x64 texture surfaces simultaneously, and it does).
This way I can re-use the surfaces and only have to Load() textures in real time
saving time for freeing and re-creating the surfaces and getting interfaces and handles.

The problem is, it's the Load() call that slows everything down to an unacceptable fps.
I tried to figure out what is the processing that d3d does when I call Load()
before the data eventually gets into 3Dfx texture memory. I got a system-wide profile
with Intel's V-Tune and it showed that most of time CPU spends in some routine in
DIBENG.DLL and several times less in 3Dfx driver.

I allocate textures in video memory in PAL8 format, and the palette is pre-attached to
each surface. The transit system memory surface from which I Load() the textures has
the same pixel format and the same palette, so is any processing required before downloading the data into the board? How can I reduce the overhead?

I would really appreciate your help.

====================================================================================

Here's my (simplified) code:

// Transit texture surface
LPDIRECTDRAWSURFACE lpDDSTransitTex; // Transit texture surface (in system memory)
LPDIRECT3DTEXTURE2 lpTransitTex; // Transit texture d3d texture interface

// DirectDraw palette shared among all video memory texture surfaces
// and the transit system memory texture surface
LPDIRECTDRAWPALETTE lpBitmapPalette;

// Surface, texture interface and handle for the video memory texture
LPDIRECTDRAWSURFACE lpDDSTex;
LPDIRECT3DTEXTURE2 lpTex;
D3DTEXTUREHANDLE hTex;

...
...
...

// Create a DirectDraw palette for the texture
LastError = lpDD->CreatePalette(DDPCAPS_8BIT | DDPCAPS_ALLOW256,
(PALETTEENTRY *)adw,
&lpBitmapPalette, NULL);
if (LastError != DD_OK) {
...
}

...
...
...

// Create the transit texture surface in system memory

memset(&ddsd, 0, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT;
ddsd.ddsCaps.dwCaps = DDSCAPS_TEXTURE | DDSCAPS_SYSTEMMEMORY;
// ddsdTexture is a surface description I got when enumerating texture formats
memcpy(&ddsd.ddpfPixelFormat, &ddsdTexture.ddpfPixelFormat, sizeof(DDPIXELFORMAT));
ddsd.dwHeight = TEX_SIZE; // =64
ddsd.dwWidth = TEX_SIZE;

LastError = lpDD->CreateSurface(&ddsd, &lpDDSTransitTex, NULL);
if (LastError != DD_OK) {
...
}

// Get texture interface for the transit texture

LastError = lpDDSTransitTex->QueryInterface( IID_IDirect3DTexture2, (LPVOID*)&lpTransitTex);
if (LastError != DD_OK) {
...
}

// Associate the palette with transit tex surface

LastError = lpDDSTransitTex->SetPalette( lpBitmapPalette );
if (LastError != D3D_OK) {
...
}

...
...
...

// Create a texture surface in video mem

memset(&ddsd, 0, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT;
ddsd.ddsCaps.dwCaps = DDSCAPS_TEXTURE | DDSCAPS_VIDEO

Follow Ups:

Post a Followup

Name:


D3D texture load

Posted by Spika on February 18, 1998 at 17:27:15:

Hello,

I'm trying to use d3d hardware acceleration in our game, it must download lots of
textures (64K on average, 200K peak, per frame). All the textures are the same size,
say 64x64, and I pre-allocate all the surfaces in video memory and get texture
interfaces and handles for HAL for all the surfaces (I use a 3Dfx board with 2Mb of
texture memory, so it can hold 512 64x64 texture surfaces simultaneously, and it does).
This way I can re-use the surfaces and only have to Load() textures in real time
saving time for freeing and re-creating the surfaces and getting interfaces and handles.

The problem is, it's the Load() call that slows everything down to an unacceptable fps.
I tried to figure out what is the processing that d3d does when I call Load()
before the data eventually gets into 3Dfx texture memory. I got a system-wide profile
with Intel's V-Tune and it showed that most of time CPU spends in some routine in
DIBENG.DLL and several times less in 3Dfx driver.

I allocate textures in video memory in PAL8 format, and the palette is pre-attached to
each surface. The transit system memory surface from which I Load() the textures has
the same pixel format and the same palette, so is any processing required before downloading the data into the board? How can I reduce the overhead?

I would really appreciate your help.

====================================================================================

Here's my (simplified) code:

// Transit texture surface
LPDIRECTDRAWSURFACE lpDDS

Follow Ups:

Post a Followup

Name:


D3D texture load

Posted by Spika on February 18, 1998 at 17:30:36:

Hello,

I'm trying to use d3d hardware acceleration in our game, it must download lots of
textures (64K on average, 200K peak, per frame). All the textures are the same size,
say 64x64, and I pre-allocate all the surfaces in video memory and get texture
interfaces and handles for HAL for all the surfaces (I use a 3Dfx board with 2Mb of
texture memory, so it can hold 512 64x64 texture surfaces simultaneously, and it does).
This way I can re-use the surfaces and only have to Load() textures in real time
saving time for freeing and re-creating the surfaces and getting interfaces and handles.

The problem is, it's the Load() call that slows everything down to an unacceptable fps.
I tried to figure out what is the processing that d3d does when I call Load()
before the data eventually gets into 3Dfx texture memory. I got a system-wide profile
with Intel's V-Tune and it showed that most of time CPU spends in some routine in
DIBENG.DLL and several times less in 3Dfx driver.

I allocate textures in video memory in PAL8 format, and the palette is pre-attached to
each surface. The transit system memory surface from which I Load() the textures has
the same pixel format and the same palette, so is any processing required before downloading the data into the board? How can I reduce the overhead?

I would really appreciate your help.

====================================================================================

Here's my (simplified) code:

// Transit texture surface
LPDIRECTDRAWSURFACE lpDDSTransitTex; // Transit texture surface (in system memory)
LPDIRECT3DTEXTURE2 lpTransitTex; // Transit texture d3d texture interface

// DirectDraw palette shared among all video memory texture surfaces
// and the transit system memory texture surface
LPDIRECTDRAWPALETTE lpBitmapPalette;

// Surface, texture interface and handle for the video memory texture
LPDIRECTDRAWSURFACE lpDDSTex;
LPDIRECT3DTEXTURE2 lpTex;
D3DTEXTUREHANDLE hTex;

...
...
...

// Create a DirectDraw palette for the texture
LastError = lpDD->CreatePalette(DDPCAPS_8BIT | DDPCAPS_ALLOW256,
(PALETTEENTRY *)adw,
&lpBitmapPalette, NULL);
if (LastError != DD_OK) {
...
}

...
...
...

// Create the transit texture surface in system memory

memset(&ddsd, 0, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT;
ddsd.ddsCaps.dwCaps = DDSCAPS_TEXTURE | DDSCAPS_SYSTEMMEMORY;
// ddsdTexture is a surface description I got when enumerating texture formats
memcpy(&ddsd.ddpfPixelFormat, &ddsdTexture.ddpfPixelFormat, sizeof(DDPIXELFORMAT));
ddsd.dwHeight = TEX_SIZE; // =64
ddsd.dwWidth = TEX_SIZE;

LastError = lpDD->CreateSurface(&ddsd, &lpDDSTransitTex, NULL);
if (LastError != DD_OK) {
...
}

// Get texture interface for the transit texture

LastError = lpDDSTransitTex->QueryInterface( IID_IDirect3DTexture2, (LPVOID*)&lpTransitTex);
if (LastError != DD_OK) {
...
}

// Associate the palette with transit tex surface

LastError = lpDDSTransitTex->SetPalette( lpBitmapPalette );
if (LastError != D3D_OK) {
...
}

...
...
...

// Create a texture surface in video mem

memset(&ddsd, 0, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT;
ddsd.ddsCaps.dwCaps = DDSCAPS_TEXTURE | DDSCAPS_VIDEO

Follow Ups:

Post a Followup

Name:


D3D texture load

Posted by Spika on February 18, 1998 at 17:36:51:

Hello,

I'm trying to use d3d hardware acceleration in our game, it must download lots of
textures (64K on average, 200K peak, per frame). All the textures are the same size,
say 64x64, and I pre-allocate all the surfaces in video memory and get texture
interfaces and handles for HAL for all the surfaces (I use a 3Dfx board with 2Mb of
texture memory, so it can hold 512 64x64 texture surfaces simultaneously, and it does).
This way I can re-use the surfaces and only have to Load() textures in real time
saving time for freeing and re-creating the surfaces and getting interfaces and handles.

The problem is, it's the Load() call that slows everything down to an unacceptable fps.
I tried to figure out what is the processing that d3d does when I call Load()
before the data eventually gets into 3Dfx texture memory. I got a system-wide profile
with Intel's V-Tune and it showed that most of time CPU spends in some routine in
DIBENG.DLL and several times less in 3Dfx driver.

I allocate textures in video memory in PAL8 format, and the palette is pre-attached to
each surface. The transit system memory surface from which I Load() the textures has
the same pixel format and the same palette, so is any processing required before downloading the data into the board? How can I reduce the overhead?

I would really appreciate your help.

====================================================================================

Here's my (simplified) code:

// Transit texture surface
LPDIRECTDRAWSURFACE lpDDSTransitTex; // Transit texture surface (in system memory)
LPDIRECT3DTEXTURE2 lpTransitTex; // Transit texture d3d texture interface

// DirectDraw palette shared among all video memory texture surfaces
// and the transit system memory texture surface
LPDIRECTDRAWPALETTE lpBitmapPalette;

// Surface, texture interface and handle for the video memory texture
L

Follow Ups:

Post a Followup

Name:


D3D texture load

Posted by Spika on February 18, 1998 at 17:44:56:

Hello,

I'm trying to use d3d hardware acceleration in our game, it must download lots of
textures (64K on average, 200K peak, per frame). All the textures are the same size,
say 64x64, and I pre-allocate all the surfaces in video memory and get texture
interfaces and handles for HAL for all the surfaces (I use a 3Dfx board with 2Mb of
texture memory, so it can hold 512 64x64 texture surfaces simultaneously, and it does).
This way I can re-use the surfaces and only have to Load() textures in real time
saving time for freeing and re-creating the surfaces and getting interfaces and handles.

The problem is, it's the Load() call that slows everything down to an unacceptable fps.
I tried to figure out what is the processing that d3d does when I call Load()
before the data eventually gets into 3Dfx texture memory. I got a system-wide profile
with Intel's V-Tune and it showed that most of time CPU spends in some routine in
DIBENG.DLL and several times less in 3Dfx driver.

I allocate textures in video memory in PAL8 format, and the palette is pre-attached to
each surface. The transit system memory surface from which I Load() the textures has
the same pixel format and the same palette, so is any processing required before downloading the data into the board? How can I reduce the overhead?

I would really appreciate your help.

====================================================================================

Here's my (simplified) code:

// Transit texture surface
LPDIRECTDRAWSURFACE lpDDSTransitTex; // Transit texture surface (in system memory)
LPDIRECT3DTEXTURE2 lpTransitTex; // Transit texture d3d texture interface

// DirectDraw palette shared among all video memory texture surfaces
// and the transit system memory texture surface
LPDIRECTDRAWPALETTE lpBitmapPalette;

// Surface, texture interface and handle for the video memory texture
LPDIRECTDRAWSURFACE lpDDSTex;
LPDIRECT3DTEXTURE2 lpTex;
D3DTEXTUREHANDLE hTex;

...
...
...

// Create a DirectDraw palette for the texture
LastError = lpDD->CreatePalette(DDPCAPS_8BIT | DDPCAPS_ALLOW256,
(PALETTEENTRY *)adw,
&lpBitmapPalette, NULL);
if (LastError != DD_OK) {
...
}

...
...
...

// Create the transit texture surface in system memory

memset(&ddsd, 0, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT;
ddsd.ddsCaps.dwCaps = DDSCAPS_TEXTURE | DDSCAPS_SYSTEMMEMORY;
// ddsdTexture is a surface description I got when enumerating texture formats
memcpy(&ddsd.ddpfPixelFormat, &ddsdTexture.ddpfPixelFormat, sizeof(DDPIXELFORMAT));
ddsd.dwHeight = TEX_SIZE; // =64
ddsd.dwWidth = TEX_SIZE;

LastError = lpDD->CreateSurface(&ddsd, &lpDDSTransitTex, NULL);
if (LastError != DD_OK) {
...
}

// Get texture interface for the transit texture

LastError = lpDDSTransitTex->QueryInterface( IID_IDirect3DTexture2, (LPVOID*)&lpTransitTex);
if (LastError != DD_OK) {
...
}

// Associate the palette with transit tex surface

LastError = lpDDSTransitTex->SetPalette( lpBitmapPalette );
if (LastError != D3D_OK) {
...
}

...
...
...

// Create a texture surface in video mem

memset(&ddsd, 0, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT;
ddsd.ddsCaps.dwCaps = DDSCAPS_TEXTURE | DDSCAPS_VIDEO

Follow Ups:

Post a Followup

Name:


D3D texture load

Posted by Spika on February 18, 1998 at 17:50:12:

Hello,

I'm trying to use d3d hardware acceleration in our game, it must download lots of
textures (64K on average, 200K peak, per frame). All the textures are the same size,
say 64x64, and I pre-allocate all the surfaces in video memory and get texture
interfaces and handles for HAL for all the surfaces (I use a 3Dfx board with 2Mb of
texture memory, so it can hold 512 64x64 texture surfaces simultaneously, and it does).
This way I can re-use the surfaces and only have to Load() textures in real time
saving time for freeing and re-creating the surfaces and getting interfaces and handles.

The problem is, it's the Load() call that slows everything down to an unacceptable fps.
I tried to figure out what is the processing that d3d does when I call Load()
before the data eventually gets into 3Dfx texture memory. I got a system-wide profile
with Intel's V-Tune and it showed that most of time CPU spends in some routine in
DIBENG.DLL and several times less in 3Dfx driver.

I allocate textures in video memory in PAL8 format, and the palette is pre-attached to
each surface. The transit system memory surface from which I Load() the textures has
the same pixel format and the same palette, so is any processing required before downloading the data into the board? How can I reduce the overhead?

I would really appreciate your help.

====================================================================================

Here's my (simplified) code:

// Transit texture surface
LPDIRECTDRAWSURFACE lpDDSTransitTex; // Transit texture surface (in system memory)
LPDIRECT3DTEXTURE2 lpTransitTex; // Transit texture d3d texture interface

// DirectDraw palette shared among all video memory texture surfaces
// and the transit system memory texture surface
LPDIRECTDRAWPALETTE lpBitmapPalette;

// Surface, texture interface and handle for the video memory texture
LPDIRECTDRAWSURFACE lpDDSTex;
LPDIRECT3DTEXTURE2 lpTex;
D3DTEXTUREHANDLE hTex;

...
...
...

// Create a DirectDraw palette for the texture
LastError = lpDD->CreatePalette(DDPCAPS_8BIT | DDPCAPS_ALLOW256,
(PALETTEENTRY *)adw,
&lpBitmapPalette, NULL);
if (LastError != DD_OK) {
...
}

...
...
...

// Create the transit texture surface in system memory

memset(&ddsd, 0, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT;
ddsd.ddsCaps.dwCaps = DDSCAPS_TEXTURE | DDSCAPS_SYSTEMMEMORY;
// ddsdTexture is a surface description I got when enumerating texture formats
memcpy(&ddsd.ddpfPixelFormat, &ddsdTexture.ddpfPixelFormat, sizeof(DDPIXELFORMAT));
ddsd.dwHeight = TEX_SIZE; // =64
ddsd.dwWidth = TEX_SIZE;

LastError = lpDD->CreateSurface(&ddsd, &lpDDSTransitTex, NULL);
if (LastError != DD_OK) {
...
}

// Get texture interface for the transit texture

LastError = lpDDSTransitTex->QueryInterface( IID_IDirect3DTexture2, (LPVOID*)&lpTransitTex);
if (LastError != DD_OK) {
...
}

// Associate the palette with transit tex surface

LastError = lpDDSTransitTex->SetPalette( lpBitmapPalette );
if (LastError != D3D_OK) {
...
}

...
...
...

// Create a texture surface in video mem

memset(&ddsd, 0, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT;
ddsd.ddsCaps.dwCaps = DDSCAPS_TEXTURE | DDSCAPS_VIDEO

Follow Ups:

Post a Followup

Name:


libcd.lib(crt0.obj) error LNK2001: unresolved external symbol _main

Posted by Fuzzy Bunny on February 18, 1998 at 19:09:46:

Can anyone help me solve this build error when building tutorial2.cpp from Peter Kovach's book, "The Awesome Power of Direct3D/DirectX.
libcd.lib(crt0.obj) error LNK2001: unresolved external symbol _main
which results in an error executing link.exe...
This is my first DirectX build and I'm using VC++ 5. Brian, I followed your steps from the previous postings, but that doesn't fix the problem.
I believe Kovach wrote the samples for VC++ 4.2, if that helps.

Follow Ups:

  • Re: libcd.lib(crt0.obj) error LNK2001: unresolved external symbol _main Brian Shea 16:47:32 2/19/98 (0)
  • Re: libcd.lib(crt0.obj) error LNK2001: unresolved external symbol _main fuzzy bunny 19:18:14 2/18/98 (0)

Post a Followup

Name:


Re: libcd.lib(crt0.obj) error LNK2001: unresolved external symbol _main

Posted by fuzzy bunny on February 18, 1998 at 19:18:14:

In Reply to: libcd.lib(crt0.obj) error LNK2001: unresolved external symbol _main posted by Fuzzy Bunny on February 18, 1998 at 19:09:46:

also, I'm using DirectX 5 SDK...

Follow Ups:

Post a Followup

Name:


That helps, but.....

Posted by Johnny Rotten on February 19, 1998 at 00:11:03:

In Reply to: Re: Borland C++ 5.0 and Direct Input posted by Mocihi Seya on February 18, 1998 at 00:10:20:

Thanks, Moichi.

I've now got my DirectInput up and running, but I have several questions/problems. First of all, what do I do about Windows Messages? Where is the best place to check for them in my main loop? Also, now that my game is running a lot faster, I keep getting "Thread stopped..." errors on my Blt lines and I have to reboot. What is causing this? I have all my Blt lines checking testing the blit status before blitting.

Can anyone help?

Johnny

Follow Ups:

Post a Followup

Name:


How can I use Direct3D in Delphi

Posted by Delphi Lover on February 19, 1998 at 06:06:36:

I have downloaded a wonderful DirectX package
for Delphi called DGC "Delphi Games Creator".
It includes a number of components supporting
the functionality of DirectX.

Is there anyone who knows how to get going with
Direct3D in Delphi ?

Follow Ups:

Post a Followup

Name:


Re: 3D Drawing Software for D3D

Posted by Sean Barton on February 19, 1998 at 13:20:34:

In Reply to: 3D Drawing Software for D3D posted by Larry Weinstein on February 17, 1998 at 21:17:56:

Unfortunately, 3D Studio is the only choice available, be careful though as the Academic version is not compatible with con3ds and therefore is not compatible with Direct3D (thanks a lot!).

Unless you have $3000 or so to spend, I would recommend holding out until someone creates a Direct3D modeller (I know of atleast 3 people working on their own). I did hear that Calagari True-Space 3.2 WILL create Direct3D meshes (without having to use con3ds). It should be out soon as well with a price tag of about $600.

: Can someone recommend 3D drawing software for Direct3D use? I want to be able to design 3D objects and then edit their textures. Is 3D Studio Max the only choice -- and will it do a good job? Keep in mind that I only wish to design objects, not scenes. With real-time Direct3D as the target, vertex counts must be kept reasonable, textures dimensions must be in powers of 2, data on nomals must be maintained, etc. Thanks!
: (weinstei@cs.fsu.edu)

Follow Ups:

Post a Followup

Name:


Re: libcd.lib(crt0.obj) error LNK2001: unresolved external symbol _main

Posted by Brian Shea on February 19, 1998 at 16:47:32:

In Reply to: libcd.lib(crt0.obj) error LNK2001: unresolved external symbol _main posted by Fuzzy Bunny on February 18, 1998 at 19:09:46:

It looks like you are creating a graphical
application but Visual C++ thinks you want
it to be a console application.

Try creating a new project from scratch and
make sure to choose "Win32 Application", not
a console application.

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Direct Draw Error ?

Posted by John on February 19, 1998 at 17:59:03:

I am also a newbie and am getting an error similar to a previous post. The error is: Game.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12 Debug/Game.exe : fatal error LNK1120: 1 unresolved externals
I am using VC++ 5.0 and DirectX 5 SDK. I did make a Windows 32 bit Application and not a console application and included ddraw.h. I was wondering if anyone knew the source of this error and how to fix it. Thank you for your help.

Follow Ups:

  • Re: Direct Draw Error ? John Giors 00:51:24 2/20/98 (1)
    • Re: Direct Draw Error ? John 01:11:35 2/20/98 (0)

Post a Followup

Name:


Re: DirectX5

Posted by serge poirier on February 19, 1998 at 22:07:28:

In Reply to: DirectX5 posted by Lois Nicholls on February 17, 1998 at 16:15:39:

: I downloaded a demo version of Curse of Monkey Island
: with DirectX5 download included and it worked fine.
: I then purchased the game, uninstalled the demo as per
: instructions but the purchased game freezes my whole
: system, screen, keyboard, mouse et al. Checking for
: compatability with DirectX5 indicates there is no hard-
: ware support for the Primary Display Driver, Primary
: sound Driver and Sound System Player. Why did the first
: DirectX5 download work but this one won't and what do I
: do about the problem?
: Thank you, any help would be greatly appreciated.
: Lois Nicholls

Follow Ups:

  • Re: DirectX5 ZAMIR FAQIRYAR 21:54:57 6/18/98 (0)
  • Re: DirectX5 U Myint Oo 00:31:16 2/26/98 (0)

Post a Followup

Name:


Re: DirectX5

Posted by serge poirier on February 19, 1998 at 22:09:24:

In Reply to: DirectX5 posted by Lois Nicholls on February 17, 1998 at 16:15:39:

: I downloaded a demo version of Curse of Monkey Island
: with DirectX5 download included and it worked fine.
: I then purchased the game, uninstalled the demo as per
: instructions but the purchased game freezes my whole
: system, screen, keyboard, mouse et al. Checking for
: compatability with DirectX5 indicates there is no hard-
: ware support for the Primary Display Driver, Primary
: sound Driver and Sound System Player. Why did the first
: DirectX5 download work but this one won't and what do I
: do about the problem?
: Thank you, any help would be greatly appreciated.
: Lois Nicholls

Follow Ups:

  • Re: DirectX5 head hunter 05:33:46 6/03/98 (1)
    • Re: DirectX5 Ratchet 15:38:41 9/13/98 (0)
  • directx5 needed for download THOMAS KURT 09:13:58 3/24/98 (3)
    • Re: directx5 needed for download mohd amri 19:35:30 9/26/98 (0)
    • Re: directx5 needed for download Matthew Broyles 19:22:06 6/11/98 (0)
    • Re: directx5 needed for download Leon Martin 13:48:53 6/06/98 (0)
  • Re: DirectX5 nuno 19:11:41 3/20/98 (0)

Post a Followup

Name:


Direct3D: Load 2 or more animated objects from same .x file

Posted by Chris McCanna on February 20, 1998 at 00:17:17:

I am writing a game in which I want two or more copies of
an animated character in the scene. The character's mesh
and animation set data are stored in "character.x". Here is
my function for loading the character.

LPDIRECT3DRMANIMATIONSET LoadCharacter(LPDIRECT3DRM RMObject, LPDIRECT3DRMFRAME ParentFrame)
{
LPDIRECT3DRMANIMATIONSET AnimSet;
LPDIRECT3DRMFRAME Frame;

RMObject->CreateFrame(ParentFrame, &Frame);

RMObject->CreateAnimationSet(&AnimSet);

AnimSet->Load("character.x", NULL, D3DRMLOAD_FROMFILE, NULL,
NULL, Frame);

Frame->Release();

return AnimSet;
}

The first call succeeds and the character appears. However,
subsequent calls do not produce visible, independent copies.
Does anyone know how I can acheive this?

Follow Ups:

  • Re: Direct3D: Load 2 or more animated objects from same .x file Sean Barton 22:08:25 2/20/98 (0)

Post a Followup

Name:


Re: Direct Draw Error ?

Posted by John Giors on February 20, 1998 at 00:51:24:

In Reply to: Direct Draw Error ? posted by John on February 19, 1998 at 17:59:03:

I think that the problem is due to not having the correct libraries (.LIB files) included in your linker settings. I had this problem when I first started using DirectX, too.

Anyway, I'm sorry I won't have the nitty-gritty details exactly correct (I don't have time to look them up, but I'm sure you'll figure them out--also, I'm using VC++ 4.0). Anyway, you need to do the following:

1. Copy the .LIB files from the SDK to the library directory of your VC++ compiler (the files have names like DDRAW.LIB, etc., and the VC++ directory is called something like C:\MSDEV\LIB).
2. Open your MS VC++ Developer Studio application and select "Build->Settings" from the pull-down menus (it may be a different name in VC++ 5.0), then select the dialog tab that reads "Link".
3. Inside the linker options dialog, there should be a text box labelled "Object/library modules". Type the names of the libraries you want to include, SEPARATED BY SPACES (don't use commas or semicolons). You probably need at least "DDRAW.LIB DXGUID.LIB" in the text box.

That's really about it. Just remember that, when you get linker errors regarding operating system functions, it's because a library isn't included. You usually don't run into this error if you use standard GUI/MFC stuff because the Developer Studio automatically includes the Win32s/MFC libraries.

Good luck.

Follow Ups:

  • Re: Direct Draw Error ? John 01:11:35 2/20/98 (0)

Post a Followup

Name:


Re: Direct Draw Error ?

Posted by John on February 20, 1998 at 01:11:35:

In Reply to: Re: Direct Draw Error ? posted by John Giors on February 20, 1998 at 00:51:24:

That solved it!
Thanks a lot John.

Follow Ups:

Post a Followup

Name:


Re: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help?

Posted by Du쉆n on February 20, 1998 at 02:44:41:

In Reply to: Re: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help? posted by Ian butler on February 02, 1998 at 08:58:01:

: - i've got the same problem and in the control panel of DirectX under the sound card it's written 'no hardware support'

Follow Ups:

Post a Followup

Name:


Overlay Surface Support

Posted by He jiangang on February 20, 1998 at 04:02:25:

Overlay surface support is provided entirely by hardware. Any graphic card available in the market supports overlay surface ?

Help!

Follow Ups:

  • Re: Overlay Surface Support Michael Czybor 19:40:23 2/25/98 (0)

Post a Followup

Name:


need multiple texture sample or getting it to work on one mesh!!!!

Posted by Robert on February 20, 1998 at 12:54:21:

UAAAAHHHHHHHHH!!!

Am I or we (my friends ) the only one here who wants to use multiple textures with in a mesh.
Because I can't find a sample for this. We have tried to do it by the buffer system from direct X 3.0 and with this primitive mode (Direct X 5.0) neither of these versions seem to simply fy our problem. Now to the problem description:

Direct X 3.0

Using execute buffers, By giving new op commands for the render states to change textures with in certain triangles works fine on hardware mode but fails on emulation mode (CrAcHeS Like #�%#@%@#) why ?????
Have we missed out on something here? Is there any samples I can use to sort out our problem here.

I just want to have full control over a mesh, this mesh is face mapped by a 3D program and all the textures should be there J i have done this on the PLAYSTATION with out any problems at all, and on other rendering engines (ours) now to the point. This is a basic issue and I have to get it sorted out, WHY THE HELL SHOULD IT BE SO HARD TO MAKE ANYTHING SO COMPLEX for such a damn easy matter.I am pissed off, because We have been working hard for a week now with out any progress�

Direct x 5.0
same problem occours with the primitive mode :)

DESPERATELY NEED SOME HELP!
//Robert

Follow Ups:

Post a Followup

Name:


Thread stopped... error

Posted by Johnny Rotten on February 20, 1998 at 15:48:38:

Does anyone know what causes a program to get a "Thread stopped" error message upon program termination. My program works just fine until I exit. Then that error message pops up and I can't run the program again until I reboot the computer.

Johnny

Follow Ups:

Post a Followup

Name:


About C++ Builder

Posted by Weng on February 20, 1998 at 20:54:28:

How can I DirectX Game by using C++ Builder?
Any site I can visit or book..? Thanks.

Follow Ups:

  • About C++ Builder Weng 20:56:04 2/20/98 (0)

Post a Followup

Name:


About C++ Builder

Posted by Weng on February 20, 1998 at 20:56:04:

In Reply to: About C++ Builder posted by Weng on February 20, 1998 at 20:54:28:

: How can I create DirectX Game by using C++
: Builder?
: Any site I can visit or book..? Thanks.

Follow Ups:

Post a Followup

Name:


Re: Direct3D: Load 2 or more animated objects from same .x file

Posted by Sean Barton on February 20, 1998 at 22:08:25:

In Reply to: Direct3D: Load 2 or more animated objects from same .x file posted by Chris McCanna on February 20, 1998 at 00:17:17:

hmm...perhaps you should try messing around with the D3DRMLOADOPTIONS part of the Load command (the third paramter in the function).
If you pass D3DRMLOAD_INSTANCEBYCOPING, direct3D will check if a copy of that objec already exists and will copy that object.
Using D3DRMLOAD_INSTANCEBYREFERENCE will do the same except it will create another instance of your object instead of copying the original.

I haven't done this yet myself, but I hope it helps.
Cheers,

Sean

: I am writing a game in which I want two or more copies of
: an animated character in the scene. The character's mesh
: and animation set data are stored in "character.x". Here is
: my function for loading the character.

: LPDIRECT3DRMANIMATIONSET LoadCharacter(LPDIRECT3DRM RMObject, LPDIRECT3DRMFRAME ParentFrame)
: {
: LPDIRECT3DRMANIMATIONSET AnimSet;
: LPDIRECT3DRMFRAME Frame;

: RMObject->CreateFrame(ParentFrame, &Frame);

: RMObject->CreateAnimationSet(&AnimSet);

: AnimSet->Load("character.x", NULL, D3DRMLOAD_FROMFILE, NULL,
: NULL, Frame);

: Frame->Release();

: return AnimSet;
: }

: The first call succeeds and the character appears. However,
: subsequent calls do not produce visible, independent copies.
: Does anyone know how I can acheive this?

Follow Ups:

Post a Followup

Name:


Re: Win16.. HEY use blt!!

Posted by Jimbo Jones on February 21, 1998 at 00:14:00:

In Reply to: Re: Win16.. HEY use blt!! posted by franko on January 27, 1998 at 18:46:09:

: Uhh, I don't recommend this. Maybe in the case of software blitting... But if the hardware supports blits, use it. It will be faster in more ways then one...

If you aren't using Video memory the DirectX Blt and BltFast functions are just pathetic. You have to make your own blit procedures to get any decent speed. Don't even think about trying to use color keys \w DX's crap blitters, the thing must use an if statement on every pixel. It is horrendous.

Follow Ups:

Post a Followup

Name:


Borlan's C++ Builder

Posted by Henry G. on February 21, 1998 at 17:24:16:

I have just started coding a 3D game engine using DirectX and Borlan's C++ Builder. I am having following problems:

1. Including DXGUID.LIB has no effect on the INITGUID problem. I am using this init code and it works, but it seems that I need Borland specific version.
#include
#include
2. I only found DLLs to rebuild libs for the following. Where can I find the rest? Like DXGUID.DLL
implib d3drm d3drm.dll
implib ddraw ddraw.dll
implib dinput dinput.dll
implib dsound dsound.dll
implib dplayx dplayx.dll
3. My code is running in software mode using device and driver GUIDs for DirectDrawCreate() and CreateDeviceFromSurface() accordingly. But when I switch to HAL GUID driver I get a "Generic failure" when I try to get Direc3D device!
4. When I try to run the same code but instead of CreateDeviceFromSurface() to obtain D3D device I use QueryInterface() even the software-mode won't run.
5. I have added this code too with no effect:
#if defined( __BORLANDC__ ) && defined( __WIN32__ )
#undef _WIN32
#define _WIN32
#endif

It seems that I get proper GUIDs and my code looks good BUT %$#@^* I am stuck :( HELP!

Follow Ups:

  • Just wondering kytel 01:12:55 2/22/98 (0)

Post a Followup

Name:


Just wondering

Posted by kytel on February 22, 1998 at 01:12:55:

In Reply to: Borlan's C++ Builder posted by Henry G. on February 21, 1998 at 17:24:16:

I've been reading a lot about Direct X lately and
have decided to choose it for any graphic needs
later. Some questions come up and here they are:

-If we have to include the directx library files
at compile time then why do the users have to
to have DirectX installed?

-How do I check what version of DirectX is
installed in my user's machine?

-Will my Direct3D game automatically accelerate
when it is ran on a system with 3d accelerator
or do I have to change the code some way?

I have more questions to be asked if these get
answered. That would be greatly appreciated.
thank you kindly.
-khuong

Follow Ups:

Post a Followup

Name:


IM - lighting

Posted by Shane Clark on February 22, 1998 at 12:55:12:

Hello,
Could someone please tell me how to get textures to actually go
brighter when i add a colour values to the vertex, as i can make the
texture go darker but not brighter.
I am using TLVERTEX and when i set the colour of the vertex to
RGB_MAKE(255,255,255) it come's through at the normal colours and i can
make the texture fade to black but not any brighter.
I am using D3DTBLEND_MODULATE but i have also tried using
D3DTBLEND_ADD, without any success, any help on this would be greatly
appreciated.. Cheers
Shane Clark

Follow Ups:

  • Re: IM - lighting Serg 16:28:16 2/23/98 (2)
    • Re: IM - lighting Shane Clark 14:30:59 2/24/98 (0)
    • Re: IM - lighting Shane Clark 14:30:33 2/24/98 (0)

Post a Followup

Name:


build sphere and texture map the interior of spher

Posted by Toong See Wan on February 22, 1998 at 17:55:27:

How to buiild a speher in direct3d than ytexture map the
interior of the sphere and view from inside the spher. Can textured
map be antialised as u zoom in?

Follow Ups:

Post a Followup

Name:


Re: How do i work with DIRECTX SDK 5 with VC++ ver 1.0?

Posted by kalrithian on February 22, 1998 at 20:52:21:

In Reply to: How do i work with DIRECTX SDK 5 with VC++ ver 1.0? posted by Roni Winik on February 14, 1998 at 13:41:12:

: How cam i work with derctx sdk 5 with visual c++ 1.0 because it's the only c++ that i have?

You can't. Visual C++ 1.0 is a 16-bit compiler for Windows 3.1; DirectX is a 32-bit API that only runs on Windows 95.

Follow Ups:

Post a Followup

Name:


Picking at texture level

Posted by Josh Weier on February 22, 1998 at 21:56:21:

I'm wondering what the best way might be to find out which pixel of a texture map
a user has clicked on. I'm using a straight mesh, not meshbuilder. Right
now I'm thinking I'll just find the face that was clicked on, project the points of that
face to screen coords, then run the texture mapper backwards to find out what point
the mouse click's x and y were on the texture. The only thing is, if my math doesn't
line up with theirs, the pixel may be wrong. Is there an easier/safer way?

Follow Ups:

  • Re: Picking at texture level Chao Yu 11:47:21 2/24/98 (0)

Post a Followup

Name:


Direct X 5.0 and sound card

Posted by James Kong on February 23, 1998 at 00:31:05:

My sound card is not supported according to microsoft. It is a ESS1868 sound card. Would direct x games still work even though it doesn't have a direct x driver? Please respond by e-mail to jkong@isd.net.
Thank you

Follow Ups:

  • Re: Direct X 5.0 and sound card HAHAHA 09:36:22 2/25/98 (0)

Post a Followup

Name:


D3DRM: How to pick an object which is half in the viewport?

Posted by Ron Bakker on February 23, 1998 at 03:33:37:

I've noticed this:

When you display an object (visual) that is half in and half out of the viewport and you want to pick it .. it isn't available in the LPDIRECT3DRMPICKARRAY that I get returned through a call off Pick().

Does anybody have an idea what I might be doing wrong or how I can tweak the viewport or the accompagnying clipper to get the object picked?

Thanx in advance,
Ron (madrigal@gmx.net)

Follow Ups:

Post a Followup

Name:


ring buffer with direct draw

Posted by Eric on February 23, 1998 at 09:59:22:

Hi,
A few questions about the way ddraw handles surfaces.

1/
I created multiple surfaces (attached to the primary surface), and I tried to use the Flip function.
Of course, It works well with one backbuffer. With more than one , not at all.

I just want to know if someone has ever managed to make a circular buffer, and displayed it with "Flip"?

2/
why can "Flip()" only be used with a primary surface?

3/
Does "Duplicate" blit surfaces, or use the same portion of memory?

4/
Is there a way to swap two surfaces of the same kind without any blitting?
I tried to deal with the surfaces pointers myself, but I haven't succeeded in swapping yet.

Thanks.
Eric.

Follow Ups:

Post a Followup

Name:


Help me please, somebody

Posted by George Ling�r on February 23, 1998 at 10:26:26:

After installing dx5, win95 can't recognize my Logitech
Wingman (not connected).
Before installing the system did see my stick.

Can somebody help me?

George

Follow Ups:

  • How can I make a simple game? Joshua Ripley 20:19:20 2/24/98 (1)
    • Re: How can I make a simple game? Johnny Rotten 13:28:50 2/25/98 (0)

Post a Followup

Name:


Direct x workshop

Posted by M. Hotrum on February 23, 1998 at 15:45:42:

Our electronic video game students want a workshop on DirectX.
Anyone able to come to Miramichi, New Brunswick Canada and teach
a 1-2 week session on DirectX and toolset? Rates negotiable,
expenses paid.

Students are in second year of a two year program
in Electronic Game Design. They are now programming
their games and need help in DirectX.

Michael Hotrum
Miramichi College, Miramichi N.B.
(506) 778-5373

Follow Ups:

Post a Followup

Name:


Re: IM - lighting

Posted by Serg on February 23, 1998 at 16:28:16:

In Reply to: IM - lighting posted by Shane Clark on February 22, 1998 at 12:55:12:

Did u tried D3DRGBA() ?
Serg

Follow Ups:

  • Re: IM - lighting Shane Clark 14:30:59 2/24/98 (0)
  • Re: IM - lighting Shane Clark 14:30:33 2/24/98 (0)

Post a Followup

Name:


Creating Multiple Instances of an Object

Posted by Bill Torla on February 23, 1998 at 20:01:35:

Hi,

I'm loading X files via AnimationSet::Load(), this
works great. My problem is creating "copies" of an object
in memory without loading the same data twice. I've
tried setting my load options to
'D3DRMLOAD_INSTANCEBYREFERENCE' & 'D3DRMLOAD_INSTANCEBYCOPYING
but niether work. What else could I try?

Thanks! ~Bill T.

Follow Ups:

  • Re: Creating Multiple Instances of an Object Lee Sandberg 08:29:49 3/27/98 (0)

Post a Followup

Name:


Re: This DirectX 5.0 is a complete fuck!!!!!

Posted by john on February 24, 1998 at 01:24:01:

In Reply to: Re: This DirectX 5.0 is a complete fuck!!!!! posted by Brian Shea on February 10, 1998 at 10:16:25:

: The site, in general, is about how not to lock
: up a system with DirectX. At least from the
: programmer's point of view. We did not write
: DirectX, we just try to use it.

: It is not a site dedicated to technical support
: for end users, but we are usually happy to help.

: Brian

i need direct x 5.0 please

Follow Ups:

Post a Followup

Name:


Re: Picking at texture level

Posted by Chao Yu on February 24, 1998 at 11:47:21:

In Reply to: Picking at texture level posted by Josh Weier on February 22, 1998 at 21:56:21:

: I'm wondering what the best way might be to find out which pixel of a texture map
: a user has clicked on. I'm using a straight mesh, not meshbuilder. Right
: now I'm thinking I'll just find the face that was clicked on, project the points of that
: face to screen coords, then run the texture mapper backwards to find out what point
: the mouse click's x and y were on the texture. The only thing is, if my math doesn't
: line up with theirs, the pixel may be wrong. Is there an easier/safer way?

The picked texture coordinates can probably be acquired through IDirect3DRMFrame2::RayPick, the data is stored in D3DRMPICKDESC2. I am also trying to solve this problem, but is currently at a lost as to how to make the call to RayPick. I would appreciate it if anyone can shed some light regarding this.

Follow Ups:

Post a Followup

Name:


Re: IM - lighting

Posted by Shane Clark on February 24, 1998 at 14:30:33:

In Reply to: Re: IM - lighting posted by Serg on February 23, 1998 at 16:28:16:

yeah i've tried that and just about everything else, i've just not got a clue anymore???

Follow Ups:

Post a Followup

Name:


Re: IM - lighting

Posted by Shane Clark on February 24, 1998 at 14:30:59:

In Reply to: Re: IM - lighting posted by Serg on February 23, 1998 at 16:28:16:

yeah i've tried that and just about everything else, i've just not got a clue anymore???

Follow Ups:

Post a Followup

Name:


How to read audio in Async Mode?

Posted by Alberto Cobre on February 24, 1998 at 18:40:40:

In Windows NT obviously ther's no probles. NTFS allow asyncronous read move via CreateFile-ReadFile. Anyone knows a C++ library or a tecnology to use asyncronous reads in Windows 95. This function is very useful to eliminate the idle state when reding streaming audio, for example, or any file to a buffer....

-sorry for my english

Follow Ups:

  • Re: How to read audio in Async Mode? Brian Shea 09:08:29 2/26/98 (0)

Post a Followup

Name:


How can I make a simple game?

Posted by Joshua Ripley on February 24, 1998 at 20:19:20:

In Reply to: Help me please, somebody posted by George Ling�r on February 23, 1998 at 10:26:26:

I have Borland C++ and I have have been trying to get directX but I haven't been able to find it or get it yet. can you please e-mail me and tell me how I can make a simple game and send me the stuff I'll need to make the game?I would appreciate it alot.

Thank you

Follow Ups:

  • Re: How can I make a simple game? Johnny Rotten 13:28:50 2/25/98 (0)

Post a Followup

Name:


Anybody knows when its comming Directx6

Posted by Seether Dragon on February 24, 1998 at 22:02:00:

Any realese date for the developemt kit for dx6?

Follow Ups:

  • Re: Anybody knows when its comming Directx6 Dorian Averbuh 07:46:32 3/04/98 (0)

Post a Followup

Name:


exception 10h hhhhelp

Posted by Sean Plumb on February 25, 1998 at 02:00:05:

Please help. I am using borland 5 C++ & the borland libs
from the directx5 sdk. The prog's are written in retained
mode.
If i run the prog's on a machine with hardware acceleration
they work fine. But if run them on a computer without
, as soon as an object starts to go off screen, It
performs an exception 10H in module D3DRM16F.DLL.
Yes i am enumerating my drivers, also if I make it use
software emulation on my computer it still crashes.

Any help will be most gratefully received. Thanks Sean

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by lars on February 25, 1998 at 04:19:20:

In Reply to: Re: Where Can I download DirectX 5.0 posted by tfg on January 24, 1998 at 09:38:49:

: : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Stalker 14:17:54 7/16/98 (0)

Post a Followup

Name:


Re: Direct X 5.0 and sound card

Posted by HAHAHA on February 25, 1998 at 09:36:22:

In Reply to: Direct X 5.0 and sound card posted by James Kong on February 23, 1998 at 00:31:05:

: My sound card is not supported according to microsoft. It is a ESS1868 sound card. Would direct x games still work even though it doesn't have a direct x driver? Please respond by e-mail to jkong@isd.net.
: Thank you

Follow Ups:

Post a Followup

Name:


consulting job availble in DirectX

Posted by mike Feng on February 25, 1998 at 10:40:02:

a project to display 4:2:2 YUV video file and play a sound (stero or 6 channel) at 30 frame/sec or 60 field/sec at resolution 720*480 or 640*480 plus some MMX instruction (parallel processing on addition function),at real time basis
interested send me e-mail at winfeng@hotmail.com

Follow Ups:

Post a Followup

Name:


Re: How can I make a simple game?

Posted by Johnny Rotten on February 25, 1998 at 13:28:50:

In Reply to: How can I make a simple game? posted by Joshua Ripley on February 24, 1998 at 20:19:20:

: I have Borland C++ and I have have been trying to get directX but I haven't been able to find it or get it yet. can you please e-mail me and tell me how I can make a simple game and send me the stuff I'll need to make the game?I would appreciate it alot.

: Thank you

You should be able to download the SDK at http://microsoft.com/directx/download.asp, that is, if it's still there.

Once you have the SDK downloaded and installed, you'll be overwhelmed with documentation and samples for creating games. Enjoy.

Johnny

Follow Ups:

Post a Followup

Name:


Converting to .x format

Posted by Christoffer Schr�der on February 25, 1998 at 16:42:37:

I was wondering if anybody knows how one can convert
from one of the many 3ddesign programs to directx format?
I'm using Simply 3D 2 and I would like to know if anybody
has a converter for this program, or knows how to
convert 'manually'?
I'm just learning, so any help is greatly appreciated :)

Yours

Chris.

Follow Ups:

Post a Followup

Name:


Re: Overlay Surface Support

Posted by Michael Czybor on February 25, 1998 at 19:40:23:

In Reply to: Overlay Surface Support posted by He jiangang on February 20, 1998 at 04:02:25:

: Overlay surface support is provided entirely by hardware. Any graphic card available in the market supports overlay surface ?

: Help!

No, not all chipsets supports Overlay!
Try these chipsets:
S3 TRIOV+, S3 Virge 3d, ATI 264 GT, VT, CL 5446

Follow Ups:

Post a Followup

Name:


Alpha-blending decals in Retained Mode

Posted by Larry Weinstein on February 25, 1998 at 21:31:56:

The note accompanying DirectX 5.0 indicated that texture2 could do alpha blending. Unfortunately, there are no "how to" details or examples that I have been able to find.
I would like to be able to create a decal from a .bmp file that alpha-blends with the 3D scene background. I can accomplish this manually by reading the surface and doing a pixel-by-pixel combination, but it would be much nicer (and probably faster) if Direct3D would do this for me. Any help would be much appreciated.

Follow Ups:

  • Re: Alpha-blending decals in Retained Mode Brian Shea 09:11:02 2/26/98 (4)
    • Re: Alpha-blending decals in Retained Mode Roger 20:26:52 2/26/98 (3)
      • Late Re: Alpha-blending decals in Retained Mode Mr Moo 15:48:06 4/22/98 (2)
        • Re: Late Re: Alpha-blending decals in Retained Mode boller 02:44:07 9/03/98 (1)
          • Re: Late Re: Alpha-blending decals in Retained Mode Tim Brubaker 22:24:35 9/09/98 (0)

Post a Followup

Name:


Symantec C++ 7.5 and DirectX 5

Posted by Dean Kusler on February 25, 1998 at 22:38:47:

I'm using Symantec C++, and am trying to make a DirectX-based game. When trying to link my project, it gives me an error saying that the DirectX lib files (ddraw.lib, dxguid.lib, etc.) are not valid library files. If anyone knows why this is or knows any way to use DirectX 5 with Symantec C++, please let me know!
Thanks,
Dean Kusler

Follow Ups:

  • Re: Symantec C++ 7.5 and DirectX 5 info 14:44:17 3/22/98 (0)
  • Re: Symantec C++ 7.5 and DirectX 5 Tommy Kreska 20:12:16 3/03/98 (0)
  • Re: Symantec C++ 7.5 and DirectX 5 Brian Shea 09:12:51 2/26/98 (0)

Post a Followup

Name:


Delphi and DirectX

Posted by Frank on February 26, 1998 at 00:22:39:

Does anyone know of any books that cover object Pascal or Delphi and DirectX? Also does anyone know of a well documented library of DirectX APIs for C++ or Delphi?

Follow Ups:

Post a Followup

Name:


Re: DirectX5

Posted by U Myint Oo on February 26, 1998 at 00:31:16:

In Reply to: Re: DirectX5 posted by serge poirier on February 19, 1998 at 22:07:28:

: : I downloaded a demo version of Curse of Monkey Island
: : with DirectX5 download included and it worked fine.
: : I then purchased the game, uninstalled the demo as per
: : instructions but the purchased game freezes my whole
: : system, screen, keyboard, mouse et al. Checking for
: : compatability with DirectX5 indicates there is no hard-
: : ware support for the Primary Display Driver, Primary
: : sound Driver and Sound System Player. Why did the first
: : DirectX5 download work but this one won't and what do I
: : do about the problem?
: : Thank you, any help would be greatly appreciated.
: : Lois Nicholls

Follow Ups:

Post a Followup

Name:


Blur-Motion with DirectX5

Posted by Wolfgang R�ssler on February 26, 1998 at 08:58:54:

Does anyone known how code a blur motion effect with DirectX 5?

Thank you!

Wolfgang

Follow Ups:

  • Re: Blur-Motion with DirectX5 하광석 09:05:09 2/26/98 (2)
    • Re: Blur-Motion with DirectX5 morten 12:19:41 3/12/98 (0)
    • Re: Blur-Motion with DirectX5 Rick Huang 05:22:08 3/11/98 (0)

Post a Followup

Name:


Re: Blur-Motion with DirectX5

Posted by 하광석 on February 26, 1998 at 09:05:09:

In Reply to: Blur-Motion with DirectX5 posted by Wolfgang R�ssler on February 26, 1998 at 08:58:54:

: Does anyone known how code a blur motion effect with DirectX 5?

: Thank you!

: Wolfgang

Follow Ups:

  • Re: Blur-Motion with DirectX5 morten 12:19:41 3/12/98 (0)
  • Re: Blur-Motion with DirectX5 Rick Huang 05:22:08 3/11/98 (0)

Post a Followup

Name:


Re: How to read audio in Async Mode?

Posted by Brian Shea on February 26, 1998 at 09:08:29:

In Reply to: How to read audio in Async Mode? posted by Alberto Cobre on February 24, 1998 at 18:40:40:

Use threads.

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: Alpha-blending decals in Retained Mode

Posted by Brian Shea on February 26, 1998 at 09:11:02:

In Reply to: Alpha-blending decals in Retained Mode posted by Larry Weinstein on February 25, 1998 at 21:31:56:

There are some extra samples on the Microsoft
DirectX site that do things like fog, alpha
blending, lens flare, and some other neat things.
Comes with source.

  • Journals of a DX Junkie

Follow Ups:

  • Re: Alpha-blending decals in Retained Mode Roger 20:26:52 2/26/98 (3)
    • Late Re: Alpha-blending decals in Retained Mode Mr Moo 15:48:06 4/22/98 (2)
      • Re: Late Re: Alpha-blending decals in Retained Mode boller 02:44:07 9/03/98 (1)
        • Re: Late Re: Alpha-blending decals in Retained Mode Tim Brubaker 22:24:35 9/09/98 (0)

Post a Followup

Name:


Re: Symantec C++ 7.5 and DirectX 5

Posted by Brian Shea on February 26, 1998 at 09:12:51:

In Reply to: Symantec C++ 7.5 and DirectX 5 posted by Dean Kusler on February 25, 1998 at 22:38:47:

Well, you can take a look at my pages for ways
to use DirectX without needing to use any of
the libs that Microsoft ships. Actually, this
is only mostly true since DirectInput is slightly
broken on NT and you have to use their create
function.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


How do i do collision detection in d3d RM ????

Posted by Shanat Krishnamurti on February 26, 1998 at 13:56:42:

Please help me,
i just cant seem to figure out how it is done
send me a mail if you can.
Thank you
Shanat

Follow Ups:

  • Re: How do i do collision detection in d3d RM ???? Eugene Polonsky 21:05:08 3/03/98 (0)

Post a Followup

Name:


Drawing to directly to directx surface memory

Posted by Daniel Moss on February 26, 1998 at 16:48:03:

How do i draw directly to directx surface memmory - will direct x allow it - I only want to use directx as a convenient video dirver support handler.
(please email)
thanks

Follow Ups:

  • Re: Drawing to directly to directx surface memory Martin Rystrand 03:16:41 2/27/98 (0)
  • Re: Drawing to directly to directx surface memory Johnny Rotten 17:54:35 2/26/98 (0)

Post a Followup

Name:


Re: Drawing to directly to directx surface memory

Posted by Johnny Rotten on February 26, 1998 at 17:54:35:

In Reply to: Drawing to directly to directx surface memory posted by Daniel Moss on February 26, 1998 at 16:48:03:

: How do i draw directly to directx surface memmory - will direct x allow it - I only want to use directx as a convenient video dirver support handler.
: (please email)
: thanks

When you blt just point to your primary surface instead of your back buffer.

hresult = ddprimary->blt (.......)

No need to do a flip();

Follow Ups:

Post a Followup

Name:


Re: Alpha-blending decals in Retained Mode

Posted by Roger on February 26, 1998 at 20:26:52:

In Reply to: Re: Alpha-blending decals in Retained Mode posted by Brian Shea on February 26, 1998 at 09:11:02:

The problem with the samples at Microsoft is that they are all Immediate mode examples. There seems to be alot of things that can't be done in retained mode.

Follow Ups:

  • Late Re: Alpha-blending decals in Retained Mode Mr Moo 15:48:06 4/22/98 (2)
    • Re: Late Re: Alpha-blending decals in Retained Mode boller 02:44:07 9/03/98 (1)
      • Re: Late Re: Alpha-blending decals in Retained Mode Tim Brubaker 22:24:35 9/09/98 (0)

Post a Followup

Name:


Re: Drawing to directly to directx surface memory

Posted by Martin Rystrand on February 27, 1998 at 03:16:41:

In Reply to: Drawing to directly to directx surface memory posted by Daniel Moss on February 26, 1998 at 16:48:03:

: How do i draw directly to directx surface memmory - will direct x allow it - I only want to use directx as a convenient video dirver support handler.
: (please email)
: thanks

You could use Lock() to obtain a pointer to the surface.
DDfront->Lock(), or DDback->Lock() if you wish to use flicker-free video.
The pointer is in the DDSURFACEDESC-struct - ddsd.lpSurface

Remember to Unlock() the surface when done!
When the surface is locked, the debugger doesn't
work properly due the win16-lock is used.
See the DX5-help-file for further info.

Follow Ups:

Post a Followup

Name:


Re: DirectX and OpenGL

Posted by Dan Holland on February 27, 1998 at 18:19:00:

In Reply to: DirectX and OpenGL posted by Umut Demirhan on February 04, 1998 at 16:19:13:

: I want to learn the relationship btw Direct3D and OpenGL.
: Can I use them together ? How ?
: If not which one is better ?

: I am trying to code a simulation (with VC++ 5p) which will use TCP and Graphics (of course on Win95)

: For full screen graphics which SDK should I prefer ?

: Thanks.

I think before you start deciding which API you want to use
you may want to start out deciding where you are going to
target your app.

From what I understand so far - you don't want to attempt
using them together. There really is no benefit from it
and you will lose machine cycles that are best facilitated
elsewhere. Now using DirectDraw and OpenGL may be another
story worth looking into. In that case you would be using
OpenGL to do all of your 3D pipelining and rendering and
then just use DirectDraw to flip the scenes in video memory.

If you are going to do Hardware acceleration I would consider
a few things:

#1. Since there is no direct pipe for hardware acceleration
for OpenGl (windows Oses) to hardware you will need to use a
OpenGl psuedo language. For example - Glide is the API for
using the 3Dfx rush and voodoo accelerator. It is NOT a full
graphics API like OpenGl but it essentially looks the same. Just
think of Glide as a subset of OpenGl that only covers functionality
that the cards can do.

#2. In the case above - the code written with the Glide API is
probably (wont...) not going to work for other chipsets (M3D..).
In that case you will need to consider what chipset you want to support.

#3. Some accelerators will support 3D accelereation straight off of
the D3D pipeline (M3d) but it aint that quick.

If you are just doing a software renderer, some additional points -

OpenGl is MUCH easier to program with. It's a lot easier to learn
as well.

D3D seems somewhat easy to work with and has A great deal of support
to work with.

OpenGl probably isn't worth using (depending on the app) unless you
are targeting fast machines or using 3d Aceleration.

So this probably isn't a real good answer but it's some of the things
that I considered before starting a few projects. If I were you I would
try writing a few demos with each API a then decide what YOU prefer
since I am sure you can find favor and disfavor on both sides of the
fence.

Dan Holland
Lead Developer AntiVirus SDK

Follow Ups:

Post a Followup

Name:


The x file format

Posted by Navin on March 03, 1998 at 05:31:28:

Does anyone have a simple x-file or a link from which I can learn how to specify my 3D objects. Thanks for helping.

Follow Ups:

  • Re: The x file format Eugene Polonsky 21:03:28 3/03/98 (0)

Post a Followup

Name:


fatal exceptions

Posted by MARK on March 03, 1998 at 08:53:45:

directx is always causing a fatal exception in 0E at
0028:C0EFFE6B
HELP!!!!!!!!!!!!!
WHAT CAN I DO??????????
THANX

Follow Ups:

  • Re: fatal exceptions Eugene polonsky 20:59:52 3/03/98 (0)

Post a Followup

Name:


Re: DirectX and MFC.

Posted by Joris Timmermans on March 03, 1998 at 13:31:33:

In Reply to: Re: DirectX and MFC. posted by CHRIS! on January 28, 1998 at 17:47:46:

I'm back after a while of absence....
(Bloody phone got cut off.)

I've managed to implement an mfc-version of my project now (without Doc/view though). And the reason I wanted to do it was because I'm working in a team of six programmers none of whom know anything about DirectX, and I didn't want to force THEM to program incomprehensible code just because I wanted a few more frames/sec.
Performance wasn't all that critical anyway (I seem to be the only programmer in the team that ever does any optimising.)

But, as far as MFC slowdown is concerned, where would you EVER encounter slowdown? If you don't throw messages around like a maniac, or simply lock out windows most of the time, you have all the CPU power you could possibly want. I'm really interested in serious answers to this question, being a computer science student.

Follow Ups:

Post a Followup

Name:


Re: Symantec C++ 7.5 and DirectX 5

Posted by Tommy Kreska on March 03, 1998 at 20:12:16:

In Reply to: Symantec C++ 7.5 and DirectX 5 posted by Dean Kusler on February 25, 1998 at 22:38:47:

: I'm using Symantec C++, and am trying to make a DirectX-based game. When trying to link my project, it gives me an error saying that the DirectX lib files (ddraw.lib, dxguid.lib, etc.) are not valid library files. If anyone knows why this is or knows any way to use DirectX 5 with Symantec C++, please let me know!
: Thanks,
: Dean Kusler

Follow Ups:

Post a Followup

Name:


MeshBuilder problems

Posted by Eugene Polonsky on March 03, 1998 at 20:57:35:

I'm not sure if you guys want me to go into the nitty gritty of what's going on. I'll try to phrase the question concisely first, then elaborate. That way if you don't want ot read any further you won't have to.

I need to be able to select a group of vertices in a meshbuilder landscape and change them. How do I do that?

Nitty gritty:

I've got two data structures controlling the landscape. One is a land x by y array with Z values. I've got an algorithm that'll take that array and convert it to triangles, and put out a vertices and faces arrays so that I can use AddFaces call on the meshbuilder. The catch is the array is (hypothetically) 88X88 units, and the final output is (88*sampling)X(88*sampling). That way I can make the final square of land as large as I want.

Now, I've got a shot fired at a section of this landscape. It'll be a spherical shot, with a certain radius, say 25. I need to 1) make a spherical indentation in the landscape at the point the shot is fired, and 2) change the texture of all the triangles affected. I figured to do that I need to use AddGroup, but I don't know how to gather the faces data out of the structures I already have.

I've already figured out the mechanism for changing the vertices. I'll create a square array of value modifiers, so that all I got to do is add the modifier to the Z value of the vertice. That's not a problem. Basically I need to some way to loop through the coordinates involved and apply the values from that array to every vertice. Then I need to change their texture.

If anyone could help me (preferably email, or here's fine too) I'd really appreciate it.

Also, if anyone is interested in making this game together with me, that's fine too. I'm only making this game as a way to impress a potential employer, I have no commercial interest in it. If anyone wants to help, email me.

Thanks.

Follow Ups:

  • Re: MeshBuilder problems Lou 09:42:02 5/16/98 (0)

Post a Followup

Name:


Re: fatal exceptions

Posted by Eugene polonsky on March 03, 1998 at 20:59:52:

In Reply to: fatal exceptions posted by MARK on March 03, 1998 at 08:53:45:

You've given us no information whatsoever. What are you doing when this occurs? Which version of directX are you using? What kind of computer are you using? What kind of a video card? How much RAM? What EXACTLY does the error message say? Is it "DirectX Caused a Fatal Error"???

I'm not sure I'm entirely qualified to help, but I'm pretty certain nobody else can without that information.

Email me if you'd like.

Mangy

: directx is always causing a fatal exception in 0E at
: 0028:C0EFFE6B
: HELP!!!!!!!!!!!!!
: WHAT CAN I DO??????????
: THANX

Follow Ups:

Post a Followup

Name:


Re: The x file format

Posted by Eugene Polonsky on March 03, 1998 at 21:03:28:

In Reply to: The x file format posted by Navin on March 03, 1998 at 05:31:28:

From what I hear it's not very simple to create a 3d object from a text file. The easiest way is to use 3DStudioMax and then convert the result to the X format. If you still want to try creating them from scratch, check out
http://cjc1.tiac.net/direct3d/
you will find a number of useful objects there.

Mangy

: Does anyone have a simple x-file or a link from which I can learn how to specify my 3D objects. Thanks for helping.

Follow Ups:

Post a Followup

Name:


Re: How do i do collision detection in d3d RM ????

Posted by Eugene Polonsky on March 03, 1998 at 21:05:08:

In Reply to: How do i do collision detection in d3d RM ???? posted by Shanat Krishnamurti on February 26, 1998 at 13:56:42:

The simplest way I know of is to use the GetBox method on your object. That'll give you the bounding box of the object. Then just compare what you're colliding with the bounding box.

Mangy

: Please help me,
: i just cant seem to figure out how it is done
: send me a mail if you can.
: Thank you
: Shanat

Follow Ups:

Post a Followup

Name:


DirectX AppWizards?

Posted by Jason Millard on March 03, 1998 at 21:55:00:

Hello,

I'm pretty new to this forum.

I was wondering if someone could tell me if there
are any DirectX AppWizards available for Visual C++?
(like the MFC
I have an upcoming project where I want to use VC++,
and MFC. I now how to set up the display, but I'm not
sure if I'm setting up things in the proper places.

Anyhelp

Follow Ups:

Post a Followup

Name:


DirectX AppWizards? (corrected)

Posted by Jason Millard on March 03, 1998 at 21:56:25:

Hello,

I'm pretty new to this forum.

I was wondering if someone could tell me if there are any DirectX AppWizards available for Visual C++? (like the MFC AppWizard)

I have an upcoming project where I want to use VC++, and MFC. I now how to set up the display, but I'm not
sure if I'm setting up things in the proper places.

Any help/ideas would be greatly appreciated...

-- Jason Millard
-- jsm174@psu.edu

Follow Ups:

  • URL address Rainer M. Domingo 03:20:38 3/08/98 (0)
  • Re: DirectX AppWizards? (corrected) Rainer M. Domingo 03:18:51 3/08/98 (0)

Post a Followup

Name:


Re: Anybody knows when its comming Directx6

Posted by Dorian Averbuh on March 04, 1998 at 07:46:32:

In Reply to: Anybody knows when its comming Directx6 posted by Seether Dragon on February 24, 1998 at 22:02:00:

: Any realese date for the developemt kit for dx6?

At Spring of 1998
March- Beta Version,
May-June - Final Version

Follow Ups:

Post a Followup

Name:


Texture and Graphic Card

Posted by Dorian Averbuh on March 04, 1998 at 08:36:27:

I have 2 general questions to ask.
1) The card I'm working on is STB Velocity 3D.
��� My current texture restrictions are 3 tex of 256x256.

2) I'm required to use the textures of 1024x1024 with paging if possible
or 4 textures of 512x512 at least.
��� The frequency should be 12-15 frames per second - Important.
��� The polygons number: 100000 polygons per frame - Prefered.
���
The 2 questions are:
1) What are the most important parameters of Graphic Card to use?
2) What Graphic Card would you advise?
3) Do you think that required polygons per frame number should be reduced? If so, to what number?

Follow Ups:

Post a Followup

Name:


DirectX wont reload video drivers

Posted by Tom Walko on March 04, 1998 at 10:00:12:

Howdy all,

For some reason, when I check my DirectX Setup,
there are no video drivers loaded. I have tried
re-installing DirectX, loading DirectX 5.0, and tried
getting drivers from my computer manufacturer.

Any ideas what I need to do?

Thanks in advance,

T. Walko

Follow Ups:

  • Re: DirectX wont reload video drivers Jim Scharf 06:24:55 3/05/98 (0)

Post a Followup

Name:


DirectSound with Borland Builder

Posted by Marc on March 04, 1998 at 17:58:33:

Has anyone successfully used DirectSound with Borland
Builder?? I cannot get the dsutil.h file to compile!

Any help would be appreciated,
Marc

--email me!

Follow Ups:

Post a Followup

Name:


How can I speed up 16bpp mode..?

Posted by Aleks Kozyrev on March 04, 1998 at 17:59:30:

I'm making a game in 640x480x16bpp mode and on my 4mb Video Card it has a good perfomance, but on cards that have 2mb of video memory (or less) it is too slow.
I use 2-page fliping. Will it be better to move Back Buffer in system mem?

Follow Ups:

  • Re: How can I speed up 16bpp mode..? Brian Shea 12:20:45 3/05/98 (0)

Post a Followup

Name:


Using a color mouse cursor in directx 5 ???

Posted by Alex Alvarez on March 04, 1998 at 23:51:40:

Hiya all,

Does anyone know how to use a colored mouse in a full
screen 640x480, 8bit game. I have a .CUR file with three configurations, one for mono, one for 16 colors and one for 256 colors, but when I set the cursor (SetCursor) it always take the mono cursor by default,
it should take the 256 color, right?

Does this mean I'll have to do my own mouse blitting routines with WM_ messages? Am I overlooking something?

Thanks,

-a

Follow Ups:

  • Re: Using a color mouse cursor in directx 5 ??? Johnny Rotten 10:13:42 3/05/98 (1)
    • Re: Using a color mouse cursor in directx 5 ??? Alex Alvarez 20:36:29 3/14/98 (0)

Post a Followup

Name:


help running DX w/ STB Velocity128

Posted by John J on March 05, 1998 at 02:33:15:

I know this is a developer board, but I'm completely stuck.
I loaded Abe's Oddessey on my 200MHZ pent. along with DirectX 5.0.
Now all of my graphics are screwed. I get anything from doubl-ish to sixteen-ish
images across the screen. No big deal, except ALL of my games are messed up.
I can switch to 640x480 in the Control Panel and use the games, but to switch I have to go through a completely
garbled screen to "accept changes". Then re-boot the computer. I have a STB Velocity 128.
Any help would be greatly appreciated.

Thanks,
John

Feel free to e-mail me if you don't want to respond on the board.

Follow Ups:

  • Re: help running DX w/ STB Velocity128 Joe Drago 13:15:55 3/18/98 (0)
  • Re: help running DX w/ STB Velocity128 Brian Shea 12:24:07 3/05/98 (0)

Post a Followup

Name:


I get missing decl-spec from dsound.h...how can that be?

Posted by Jacques on March 05, 1998 at 02:36:57:

//this is the message i get from VC5, when trying to compile..
//I dont understand how that can be... (i'm using directX 3.0)

F:\DEVSTUDIO\VC\INCLUDE\dsound.h(96) :
error C2501: 'LPWAVEFORMATEX' :
missing decl-specifiers

//in reference to :

typedef struct _DSBUFFERDESC
{
DWORD dwSize;
DWORD dwFlags;
DWORD dwBufferBytes;
DWORD dwReserved;
WAVEFORMATEX lpwfxFormat;
} DSBUFFERDESC, *LPDSBUFFERDESC;

which is in dsound.h

Follow Ups:

  • Re: I get missing decl-spec from dsound.h...how can that be? A. Laska 18:43:47 3/08/98 (0)
  • Re: I get missing decl-spec from dsound.h...how can that be? Brian Shea 12:26:58 3/05/98 (3)
    • Re: I get missing decl-spec from dsound.h...how can that be? Brian Shea 12:29:48 3/05/98 (2)
      • Re: I get missing decl-spec from dsound.h...how can that be? Brian Shea 12:32:24 3/05/98 (1)
        • Re: I get missing decl-spec from dsound.h...how can that be? Jacques 12:49:10 3/13/98 (0)
  • Re: I get missing decl-spec from dsound.h...how can that be? Brian Shea 12:26:10 3/05/98 (0)

Post a Followup

Name:


Re: DirectX wont reload video drivers

Posted by Jim Scharf on March 05, 1998 at 06:24:55:

In Reply to: DirectX wont reload video drivers posted by Tom Walko on March 04, 1998 at 10:00:12:

: Howdy all,

: For some reason, when I check my DirectX Setup,
: there are no video drivers loaded. I have tried
: re-installing DirectX, loading DirectX 5.0, and tried
: getting drivers from my computer manufacturer.

: Any ideas what I need to do?

:
: Thanks in advance,

: T. Walko

Tom:

I've just had the same thing happen to me. I'm using
an HP 166Mhz Vectra machine and the drivers refuse to load.
(These are the DX5 drivers.) Although, the DX3 drivers
don't seem to have any problem at all.

I'm using Win95 by the way, and no graphics card. However,
if you check with microsoft at microsoft.com you can read
about DX5, both sound and video. URL is:

http://www.microsoft.com/directx/pavilion/hardware/vidcardlist.htm
/soundcardlist.htm

If you get any info please email me at:

jscharf@indo.net.id

thanks.

Follow Ups:

Post a Followup

Name:


Re: Using a color mouse cursor in directx 5 ???

Posted by Johnny Rotten on March 05, 1998 at 10:13:42:

In Reply to: Using a color mouse cursor in directx 5 ??? posted by Alex Alvarez on March 04, 1998 at 23:51:40:

I don't know if this will help or not, but anytime you are in full screen mode you have to do your own cursor handling. You can probably do this as a WM_CURSOR message, but I think(?) DirectInput would be much better suited to your needs. Someone please correct me if I'm wrong.

Follow Ups:

  • Re: Using a color mouse cursor in directx 5 ??? Alex Alvarez 20:36:29 3/14/98 (0)

Post a Followup

Name:


D3D 5 immediate mode (D3DVERTEX)

Posted by Matti Kosunen on March 05, 1998 at 12:04:18:

Can someone tell where could i get example on D3D 5
immediate mode (drawprimitive method) and that
uses D3DVERTEX type vertices. I made a program that
uses D3DLVERTEX type vertices and it works fine.. but
when i try use D3DVERTEX type i can't make it 'work' at
all.. (i mean i don't see anything).
I have made material and light (and put ambien to 100)
but it still won't 'work'.

And if you try to suggest Flip3D example i can
allready say that it uses lvertices and don't help me
at all.

Follow Ups:

  • Re: D3D 5 immediate mode (D3DVERTEX) Serg 15:58:18 3/05/98 (2)
    • Re: D3D 5 immediate mode (D3DVERTEX) Matti Kosunen 16:03:14 3/05/98 (1)
      • Re: D3D 5 immediate mode (D3DVERTEX) Serg 08:01:53 3/07/98 (0)

Post a Followup

Name:


Re: How can I speed up 16bpp mode..?

Posted by Brian Shea on March 05, 1998 at 12:20:45:

In Reply to: How can I speed up 16bpp mode..? posted by Aleks Kozyrev on March 04, 1998 at 17:59:30:

: I'm making a game in 640x480x16bpp mode and on my 4mb Video Card it has a good perfomance, but on cards that have 2mb of video memory (or less) it is too slow.
: I use 2-page fliping. Will it be better to move Back Buffer in system mem?

Think of it this way. Every time you have to
cross from system to video memory you take a hit.
If all of your artwork is in system memory, then
building up the backbuffer in video memory is
very expensive. If you can not fit all of your
artwork in video memory, put it all in system
memory along with your backbuffer. Or create
a new surface to compose each scene and blt
this to the backbuffer.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: help running DX w/ STB Velocity128

Posted by Brian Shea on March 05, 1998 at 12:24:07:

In Reply to: help running DX w/ STB Velocity128 posted by John J on March 05, 1998 at 02:33:15:

Make sure you have the latest drivers from STB.
Also, this is a pretty good site for nVidia cards.
http://www.rivazone.com/index.html

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: I get missing decl-spec from dsound.h...how can that be?

Posted by Brian Shea on March 05, 1998 at 12:26:10:

In Reply to: I get missing decl-spec from dsound.h...how can that be? posted by Jacques on March 05, 1998 at 02:36:57:

#include
That should do it.

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: I get missing decl-spec from dsound.h...how can that be?

Posted by Brian Shea on March 05, 1998 at 12:26:58:

In Reply to: I get missing decl-spec from dsound.h...how can that be? posted by Jacques on March 05, 1998 at 02:36:57:

[Repost because HTML hates me.]

#include
That should do it.

  • Journals of a DX Junkie

Follow Ups:

  • Re: I get missing decl-spec from dsound.h...how can that be? Brian Shea 12:29:48 3/05/98 (2)
    • Re: I get missing decl-spec from dsound.h...how can that be? Brian Shea 12:32:24 3/05/98 (1)
      • Re: I get missing decl-spec from dsound.h...how can that be? Jacques 12:49:10 3/13/98 (0)

Post a Followup

Name:


Re: I get missing decl-spec from dsound.h...how can that be?

Posted by Brian Shea on March 05, 1998 at 12:29:48:

In Reply to: Re: I get missing decl-spec from dsound.h...how can that be? posted by Brian Shea on March 05, 1998 at 12:26:58:

: [Repost because HTML hates me a LOT.]

: #include
: That should do it.

That should be:
#include

And, for my own sanity, a test:

[PRE TAG OPENED JUST ABOVE]
#include
[PRE TAG CLOSED JUST BELOW]

  • Journals of a DX Junkie

Follow Ups:

  • Re: I get missing decl-spec from dsound.h...how can that be? Brian Shea 12:32:24 3/05/98 (1)
    • Re: I get missing decl-spec from dsound.h...how can that be? Jacques 12:49:10 3/13/98 (0)

Post a Followup

Name:


Re: I get missing decl-spec from dsound.h...how can that be?

Posted by Brian Shea on March 05, 1998 at 12:32:24:

In Reply to: Re: I get missing decl-spec from dsound.h...how can that be? posted by Brian Shea on March 05, 1998 at 12:29:48:

Someone nuke this board, its implementation sucks.
That should be (for the last time):
#include "mmsystem.h"

Except the quotes should be less than and greater
than signs which this damn board refuses to accept.

  • Journals of a DX Junkie

Follow Ups:

  • Re: I get missing decl-spec from dsound.h...how can that be? Jacques 12:49:10 3/13/98 (0)

Post a Followup

Name:


DirectX and AppWizard?

Posted by Todd Ogrin on March 05, 1998 at 14:09:40:

This is my first post, and I'm an extreme newbie to DirectX
programming. (Just thought I'd qualify in case I sound like
a buffoon to all the rest of you..!)

I built a sample program that bounces a little square around
the screen using page-flipping techniques. I used the MFC
AppWizard to come up with the framework of the app, and then
built in some DX5 calls for the page-flipping.

Should I be using AppWizard at all? I understand that there
has been some debate as to whether or not to use MFC, but it
seems that the AppWizard route is probably not the best way
to go. I plan on rebuilding it with a non-AppWizard framework
tonight.

bugs in it, and I'm wondering if it's because i generate the
code using AppWizard (VC++ 5.0, by the way).

Follow Ups:

  • Re: DirectX and AppWizard? Rainer M. Domingo 03:12:25 3/08/98 (0)

Post a Followup

Name:


Re: D3D 5 immediate mode (D3DVERTEX)

Posted by Serg on March 05, 1998 at 15:58:18:

In Reply to: D3D 5 immediate mode (D3DVERTEX) posted by Matti Kosunen on March 05, 1998 at 12:04:18:

Most probable u forgot to set a light. As i remember
most of smpl from DX microsoft site use d3dvertex
and drawprim (not from SDK but pavilion)-BOIDS
ATEST and so on.
. there is a lot of smpl around on the
web also

Serg

Follow Ups:

  • Re: D3D 5 immediate mode (D3DVERTEX) Matti Kosunen 16:03:14 3/05/98 (1)
    • Re: D3D 5 immediate mode (D3DVERTEX) Serg 08:01:53 3/07/98 (0)

Post a Followup

Name:


NEED HELP!

Posted by Matti Kosunen on March 05, 1998 at 16:00:16:

I was just wondering is here anywhere example or have
any of you made D3D immediate (drawprimitive) program
where all initialization is made in ONE function..
Trying to follow those MESSY sdk samples is IMPOSIBLE!

I would be really happy if anyone has or could make for
me a simple prog (witch uses d3dvertex/drawprimitive/
(ambient/spot)light) where could i learn what is wrong
in my current project.

Now i have really BIG problem on it because i can't
make any d3dvertex object visible. I can make one
triangle using d3dlvertex and it works fine and is
visible in viewport, after that i try to do same
triangle with d3dvertex (even same cordinates) and
it isn't visible by some reason i don't know. I have
made a light (it has been almost copied from sdk helps)
and set ambient level to 100,100,100 and still it isn't
visible.

Then i would like to know if setrenderstate/
setlightstate and so on have to be called between
beginscene - endscene

Follow Ups:

  • Re: NEED HELP! Crist�an Torner�a 14:45:58 4/16/98 (0)
  • Re: NEED HELP! Serg 08:07:24 3/07/98 (0)

Post a Followup

Name:


Re: D3D 5 immediate mode (D3DVERTEX)

Posted by Matti Kosunen on March 05, 1998 at 16:03:14:

In Reply to: Re: D3D 5 immediate mode (D3DVERTEX) posted by Serg on March 05, 1998 at 15:58:18:

: Most probable u forgot to set a light.
No i don't..

: As i remember
: most of smpl from DX microsoft site use d3dvertex
: and drawprim (not from SDK but pavilion)-BOIDS
: ATEST and so on.
I have them .. yes yes.. but they are so messy i
can't get anything out of them.. and allmost all
of them is made of couple classes and i HATE em =)
: . there is a lot of smpl around on the
: web also
Could you tell me where..
: Serg

Follow Ups:

  • Re: D3D 5 immediate mode (D3DVERTEX) Serg 08:01:53 3/07/98 (0)

Post a Followup

Name:


HOW CAN I USE ALPHA WITH DIRECT DRAW

Posted by Steibl Andreas on March 05, 1998 at 22:18:18:

I am writting a little Game and I need an Alpha Blitter. But the DirectDraw BltFast doesn't support Alpha.

How can I programm this manually without loss of Performance ??

Both the Source and the Destination Surface are inthe VRAM.

Follow Ups:

Post a Followup

Name:


Panzer General 2, DirectX 5 and NT4.0

Posted by Pete Smith on March 06, 1998 at 06:34:41:

My system is a PC Server 325 which has a S3 Trio64V+
video chip. It is loaded with NT 4.0
Game loads and runs until the map needs to be displayed
then it drops the application.
Anybody know of a fix to allow it to work? I suspect
its the DirectX 5 requirement that is causing the
problem.

Follow Ups:

Post a Followup

Name:


D3D, transparency and D3DFILTER_LINEAR

Posted by Joe Chang on March 06, 1998 at 15:36:40:

I've setup my direct draw surface to handle tranparency (magenta). I've also set D3DRENDERSTATE_TEXTURE[MAG/MIN] to D3DFILTER_LINEAR to blur out the pixels. Unfortunately, the transparency (magneta) gets blurred and then gets displayed. Is there a way to avoid this?

Thanks,
Joe

Follow Ups:

Post a Followup

Name:


Mouse handling

Posted by Matti Kosunen on March 06, 1998 at 17:27:53:

How can i make for my program mouse handler that would
show how much its position has moved since last test.
Windows normal callback stuff (wm_mousemove and so on)
don't do what i like to have, because with those can
i read mouse movement only in window, and i need to
have 'free' mouse movement.

I found some things like mouse_event from win32 help
(without MOUSEEVENTF_ABSOLUTE) but i have no idea
how to use that..
Or could it be done with accelerators?

please help me..

Follow Ups:

  • Re: Mouse handling Brian Shea 14:36:46 3/09/98 (1)
    • Re: Mouse handling Clay 07:50:57 3/12/98 (0)

Post a Followup

Name:


?

Posted by Asim Demirag on March 07, 1998 at 06:26:08:

Can I use DirectX in my programs with DirectX 5.0 for users

Follow Ups:

  • Re: ? Johnny Rotten 10:30:18 3/09/98 (0)

Post a Followup

Name:


Re: D3D 5 immediate mode (D3DVERTEX)

Posted by Serg on March 07, 1998 at 08:01:53:

In Reply to: Re: D3D 5 immediate mode (D3DVERTEX) posted by Matti Kosunen on March 05, 1998 at 16:03:14:

: : Most probable u forgot to set a light.
: No i don't..
Check Your material also
: Could you tell me where..
cannot find anyfthing in the moment -
try to use some of this chunks if u want :(
this code use util from microsoft smpl

void CWddView::InitScene()
{

// Set the render states
m_pDevice->SetRenderState(D3DRENDERSTATE_ANTIALIAS,D3DANTIALIAS_SORTINDEPENDENT);
m_pDevice->SetRenderState(D3DRENDERSTATE_TEXTUREADDRESS,D3DTADDRESS_WRAP);
m_pDevice->SetRenderState(D3DRENDERSTATE_TEXTUREPERSPECTIVE, TRUE);
m_pDevice->SetRenderState(D3DRENDERSTATE_ZENABLE, TRUE);
m_pDevice->SetRenderState(D3DRENDERSTATE_FILLMODE,D3DFILL_SOLID);
m_pDevice->SetRenderState(D3DRENDERSTATE_SHADEMODE,D3DSHADE_GOURAUD);
m_pDevice->SetRenderState(D3DRENDERSTATE_ZWRITEENABLE,TRUE);
m_pDevice->SetRenderState(D3DRENDERSTATE_ZFUNC, D3DCMP_LESSEQUAL);
m_pDevice->SetRenderState(D3DRENDERSTATE_TEXTUREMAG, D3DFILTER_LINEAR);
m_pDevice->SetRenderState(D3DRENDERSTATE_CULLMODE, D3DCULL_NONE);//CCW);
m_pDevice->SetRenderState(D3DRENDERSTATE_DITHERENABLE, TRUE);
m_pDevice->SetRenderState(D3DRENDERSTATE_SPECULARENABLE, TRUE);
//m_pDevice->SetRenderState(D3DRENDERSTATE_ZVISIBLE,FALSE);
m_pDevice->SetRenderState(D3DRENDERSTATE_SUBPIXEL,TRUE);

WList = new ObjList;
IList = new ItemList;

D3DLIGHT2 light;
memset(&light, 0, sizeof(D3DLIGHT2));
light.dwSize = sizeof(D3DLIGHT2);
light.dltType =D3DLIGHT_DIRECTIONAL;//POINT;
light.dcvColor.r = D3DVAL(.8);
light.dcvColor.g = D3DVAL(.7);
light.dcvColor.b = D3DVAL(.3);
light.dcvColor.a = D3DVAL(1);
light.dvPosition.x = D3DVAL(3);
light.dvPosition.y = D3DVAL(3);
light.dvPosition.z = D3DVAL(3);
light.dvDirection.x = D3DVALP(0);
light.dvDirection.y = D3DVALP(0);
light.dvDirection.z = D3DVALP(0.5);
light.dvRange = 10.0f;
light.dvAttenuation0 = 1.0; // set linear attenuation
light.dvAttenuation1 = 1.;
light.dvAttenuation2 = 0.0;
light.dwFlags = D3DLIGHT_ACTIVE;
m_pDevice->SetLightState(D3DLIGHTSTATE_AMBIENT, RGBA_MAKE(80, 80, 80, 100));
l0 = new Light(&light, m_pViewport, m_pD3D);

CreateMat();
/*
BuildObj1(m_pDevice);
PlaceShips();
*/
MInit(m_pDevice);
block1 = new T3dblock(&D3DVECTOR(0,0,0) ,5, 0);
// Initialize and set the matrices
m_World = IdentityMatrix();
m_World = MatrixMult(RotateZ(3), m_World);
m_View = ViewMatrix(D3DVECTOR(0,0,4), D3DVECTOR(0,0,0), D3DVECTOR(0,1,0), 0);
m_Projection = ProjectionMatrix(0.01f, 200.0f, (float)(45*PI/180)); // 45 degree FOV
m_pDevice->SetTransform(D3DTRANSFORMSTATE_WORLD, &m_World);
m_pDevice->SetTransform(D3DTRANSFORMSTATE_VIEW, &m_View);
m_pDevice->SetTransform(D3DTRANSFORMSTATE_PROJECTION, &m_Projection);
}

void CWddView::CreateMat()
{
// Create a texture
TRACE("DrawPrim Demo: Creating a texture\n");
m_pTexture = CreateBitmapSurface("TEXTURE", TRUE);
// Get the texture handle
LPDIRECT3DTEXTURE2 texture;
m_pTexture->QueryInterface(IID_IDirect3DTexture2, (LPVOID *)&texture);
texture->GetHandle(m_pDevice, &TH1);
texture->Release();

atext = new D3DTexture;
atext->LoadAlpha(m_pDevice, m_pDD);

m_pD3D->CreateMaterial(&lpMat2, NULL);
D3DMATERIAL bmat;
memset(&bmat, 0, sizeof(D3DMATERIAL));
bmat.dwSize = sizeof(D3DMATERIAL);
bmat.diffuse.r = (D3DVALUE).8;
bmat.diffuse.g = (D3DVALUE).8;
bmat.diffuse.b = (D3DVALUE).8;
bmat.diffuse.a = (D3DVALUE).8;
bmat.ambient.r = (D3DVALUE).8;
bmat.ambient.g = (D3DVALUE).8;
bmat.ambient.b = (D3DVALUE).8;
bmat.specular.r = (D3DVALUE).0;
bmat.specular.g = (D3DVALUE).0;
bmat.specular.b = (D3DVALUE).0;
bmat.power = (float)0;
bmat.hTexture = atext->Handle;

HRESULT res;
res = lpMat2->SetMaterial(&bmat);
res = lpMat2->GetHandle(m_pDevice, &hMat2);

m_pD3D->CreateMaterial(&lpMat1, NULL);

memset(&bmat, 0, sizeof(D3DMATERIAL));
bmat.dwSize = sizeof(D3DMATERIAL);
bmat.diffuse.r = (D3DVALUE).8;
bmat.diffuse.g = (D3DVALUE).8;
bmat.diffuse.b = (D3DVALUE).8;
bmat.diffuse.a = (D3DVALUE).8;
bmat.ambient.r = (D3DVALUE).8;
bmat.ambient.g = (D3DVALUE).8;
bmat.ambient.b = (D3DVALUE).8;
bmat.specular.r = (D3DVALUE).0;
bmat.specular.g = (D3DVALUE).2;
bmat.specular.b = (D3DVALUE).0;
bmat.power = (float)2.0;
bmat.hTexture = m_TextureHandle;

res = lpMat1->SetMaterial(&bmat);
res = lpMat1->GetHandle(m_pDevice, &hMat1);

}

void CWddView::Render()
{

//TrList->init();
//WList->Turn();

//block1->Use();

UpdateCamera();
ClearBackBuffer(NULL);

m_pDevice->BeginScene();

m_pDevice->SetRenderState(D3DRENDERSTATE_CULLMODE, D3DCULL_CCW);
m_pDevice->SetRenderState(D3DRENDERSTATE_TEXTUREMAPBLEND,D3DTBLEND_MODULATE);
m_pDevice->SetRenderState(D3DRENDERSTATE_ALPHABLENDENABLE, FALSE);
Prim0->Show();
....

void Prim::Show()
{
if (mat != CMH){
dev->SetLightState(D3DLIGHTSTATE_MATERIAL, mat);
CMH = mat;
}
if (tex != CTH){
dev->SetRenderState(D3DRENDERSTATE_TEXTUREHANDLE, tex);
CTH = tex;
}
int i;
i=0;
dev->DrawIndexedPrimitive(D3DPT_TRIANGLELIST, D3DVT_VERTEX,(LPVOID)lpV, num_v,
Istruct, num_i, NULL);
};

Serg

Follow Ups:

Post a Followup

Name:


Re: NEED HELP!

Posted by Serg on March 07, 1998 at 08:07:24:

In Reply to: NEED HELP! posted by Matti Kosunen on March 05, 1998 at 16:00:16:

look on my follow up of previos post
(but it use d3dutil from microsoft smpl)
Serg

Follow Ups:

Post a Followup

Name:


DirectSound and Edson's Article

Posted by A. Laska on March 07, 1998 at 14:49:49:

In Dave Edson's article "Get World-Class Noise and Total Joy from Your Games with DirectSound and DirectInput" he has some sample code that
mentions a file called 'windonut.h'

Where can I get this file?

Does anybody know of any other straight forward examples of directsound code?

Thanks a million!
Andrew

Follow Ups:

  • Re: DirectSound and Edson's Article Brian Shea 14:38:53 3/09/98 (0)

Post a Followup

Name:


RayPick Question

Posted by Josh Weier on March 07, 1998 at 21:45:34:

I've been trying to use RayPick in a editor I'm currently
working on, and I've run into a problem. Although I'm
able to call the function, I always get a "bad parameter type"
on the return. I've passed all the parameters they outlined
in the documentation.

Has anyone gotten this function to work? If so, did you have to
do something weird to make it work?

Follow Ups:

  • Re: RayPick Question Clay 07:46:03 3/12/98 (0)

Post a Followup

Name:


Re: DirectX and AppWizard?

Posted by Rainer M. Domingo on March 08, 1998 at 03:12:25:

In Reply to: DirectX and AppWizard? posted by Todd Ogrin on March 05, 1998 at 14:09:40:

Hi there,

We've successfully built an application using
VC++ 5.0, App Wizard and MFC. Although the debate
will rage on forever, it really depends on what
you are developing and performance considerations.
Follow the link below to our DirectX development
page for more info.

Rainer

  • WebStealth's DirectX development page

Follow Ups:

Post a Followup

Name:


Re: DirectX AppWizards? (corrected)

Posted by Rainer M. Domingo on March 08, 1998 at 03:18:51:

In Reply to: DirectX AppWizards? (corrected) posted by Jason Millard on March 03, 1998 at 21:56:25:

Jason,

Follow the link below to our DirectX development
page. It includes a link to a MFC-DirectX-VC++
sample you can download that includes the source
code.

Hope this helps.

Rainer

Follow Ups:

Post a Followup

Name:


URL address

Posted by Rainer M. Domingo on March 08, 1998 at 03:20:38:

In Reply to: DirectX AppWizards? (corrected) posted by Jason Millard on March 03, 1998 at 21:56:25:

..see below (Sorry)

  • WebStealth's DirectX Development Page

Follow Ups:

Post a Followup

Name:


Using bmp textures

Posted by Fran Avil�s on March 08, 1998 at 18:00:15:

Does anybody knows how to do bmps textures to map not rotated?

Follow Ups:

Post a Followup

Name:


Differences between Conv3ds in DX3 and DX5

Posted by Fran Avil�s on March 08, 1998 at 18:02:37:

Does anybody knows why some objects converted with the conv3ds.exe which is in DirectX 3 , don큧 appear in DX-systems based on DX5?

Follow Ups:

Post a Followup

Name:


Re: I get missing decl-spec from dsound.h...how can that be?

Posted by A. Laska on March 08, 1998 at 18:43:47:

In Reply to: I get missing decl-spec from dsound.h...how can that be? posted by Jacques on March 05, 1998 at 02:36:57:

: //this is the message i get from VC5, when trying to compile..
: //I dont understand how that can be... (i'm using directX 3.0)

: F:\DEVSTUDIO\VC\INCLUDE\dsound.h(96) :
: error C2501: 'LPWAVEFORMATEX' :
: missing decl-specifiers

: //in reference to :

: typedef struct _DSBUFFERDESC
: {
: DWORD dwSize;
: DWORD dwFlags;
: DWORD dwBufferBytes;
: DWORD dwReserved;
: WAVEFORMATEX lpwfxFormat;
: } DSBUFFERDESC, *LPDSBUFFERDESC;

: which is in dsound.h

What you need to do is go to your default include directory path setup and put the paths for the .lib and .h files from the sdk AT THE TOP OF THE LIST.

In VC++ 5.0 this is found under Tools->Options and under the directories tab.

This will do it.

A. Laska

Follow Ups:

Post a Followup

Name:


Re: ?

Posted by Johnny Rotten on March 09, 1998 at 10:30:18:

In Reply to: ? posted by Asim Demirag on March 07, 1998 at 06:26:08:

: Can I use DirectX in my programs with DirectX 5.0 for users

Yes and no.

First of all, you have the DLLs so it's possible to create your libraries from them. However, you aren't going to have the include files or documentation, so I'm afraid you'll be a little lost in that department.

Why not get the development version?

Follow Ups:

Post a Followup

Name:


Using DirectShow to capture video in a worker thread

Posted by Howard Lin on March 09, 1998 at 12:38:05:

Hi, I am trying to add video capture capability to a Windows game. The game has two thread, one is main thread with top most window, the other is worker thread. I used DirectShow API to add video capture in the worker thread (without preview), following the AMCAP sample in DirectX Media SDK. The capture seems working fine, except that it always missing last few seconds of video, depending on the machine. For example, if I captured 10 seconds video, the first 6 seconds is fine and the last 4 seconds are still images of the last frame in the first 6 second video. The avi file size seems OK. I suspect that this is due to the capture is in a worker thread. I'm wondering if anybody has similar experience. I also want to know if it's a good idea to put DirectShow or DirectX in a worker thread. I'm new to Windows Game programming and I want to know if anybody using threads in their game.

Thanks.

Howard

Follow Ups:

Post a Followup

Name:


Re: Mouse handling

Posted by Brian Shea on March 09, 1998 at 14:36:46:

In Reply to: Mouse handling posted by Matti Kosunen on March 06, 1998 at 17:27:53:

Try looking up the help for SetCapture.
Or consider using DirectInput. I have
some example DirectInput code on my webpage
for using the mouse in fullscreen exclusive mode.

Brian

  • Journals of a DX Junkie

Follow Ups:

  • Re: Mouse handling Clay 07:50:57 3/12/98 (0)

Post a Followup

Name:


Re: DirectSound and Edson's Article

Posted by Brian Shea on March 09, 1998 at 14:38:53:

In Reply to: DirectSound and Edson's Article posted by A. Laska on March 07, 1998 at 14:49:49:

It should be in the SDK/samples directory
somewhere, probably in the donut directory.

I have some sample DirectSound stuff on my page.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


How do I use MFC Document/view and Direct3D?

Posted by Christoffer Schr�der on March 09, 1998 at 15:58:09:

I'm new to directX developing, and I need help with an
application I'm writing.
I need to know how I incoporate Direct3D (setup, displaying
etc.) with the Document/view architecture, so I would like to
hear if anybody have tried this, and maybe have some
(simple) sample code I could peek at, please?
Any sample code can be mailed to me at my address:
mcs@get2net.dk

Thank you
Chris.

Follow Ups:

  • Re: How do I use MFC Document/view and Direct3D? Brian Shea 05:50:21 3/11/98 (1)
    • Re: How do I use MFC Document/view and Direct3D? Brian Shea 05:52:16 3/11/98 (0)
  • Re: How do I use MFC Document/view and Direct3D? Serg 17:04:26 3/10/98 (1)
    • Re: How do I use MFC Document/view and Direct3D? Navin 04:37:17 3/11/98 (0)

Post a Followup

Name:


Re: How do I use MFC Document/view and Direct3D?

Posted by Serg on March 10, 1998 at 17:04:26:

In Reply to: How do I use MFC Document/view and Direct3D? posted by Christoffer Schr�der on March 09, 1998 at 15:58:09:

absolutly the same as with mainFrame. I'll post
code if found some simple ver. Why don't u
like MainFrame ?

Serg

Follow Ups:

  • Re: How do I use MFC Document/view and Direct3D? Navin 04:37:17 3/11/98 (0)

Post a Followup

Name:


Re: How do I use MFC Document/view and Direct3D?

Posted by Navin on March 11, 1998 at 04:37:17:

In Reply to: Re: How do I use MFC Document/view and Direct3D? posted by Serg on March 10, 1998 at 17:04:26:

: absolutly the same as with mainFrame. I'll post
: code if found some simple ver. Why don't u
: like MainFrame ?

: Serg

Could you please send the code to me, too.
That would be nice. Thanks. Navin.

Follow Ups:

Post a Followup

Name:


Re: Blur-Motion with DirectX5

Posted by Rick Huang on March 11, 1998 at 05:22:08:

In Reply to: Re: Blur-Motion with DirectX5 posted by 하광석 on February 26, 1998 at 09:05:09:

You can do it by align the axis of texture mapping (the lower resolution direction)
toward the motion dir. While yet the effects
depend on youself.

BTW, we are here developing a new graphics
architecture that does use DX w/ hardware,
while we have a good motion blur effect.

Andsoft, China

: : Does anyone known how code a blur motion effect with DirectX 5?

: : Thank you!

: : Wolfgang

Follow Ups:

Post a Followup

Name:


Re: How do I use MFC Document/view and Direct3D?

Posted by Brian Shea on March 11, 1998 at 05:50:21:

In Reply to: How do I use MFC Document/view and Direct3D? posted by Christoffer Schr�der on March 09, 1998 at 15:58:09:

Not 3D, but maybe this will help:

DirectDraw Within the MFC Document/View Framework

  • Journals of a DX Junkie

Follow Ups:

  • Re: How do I use MFC Document/view and Direct3D? Brian Shea 05:52:16 3/11/98 (0)

Post a Followup

Name:


Re: How do I use MFC Document/view and Direct3D?

Posted by Brian Shea on March 11, 1998 at 05:52:16:

In Reply to: Re: How do I use MFC Document/view and Direct3D? posted by Brian Shea on March 11, 1998 at 05:50:21:

I hate this forum.
The link was:
http://www.vcdj.com/vcdj/jun97/dirdraw.htm

Join the DirectXDev mailing list.
http://www.angelic-coders.com/DirectXDev_signup.asp

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Shadows with Immediate Mode

Posted by Wolfgang R�ssler on March 11, 1998 at 06:22:21:

How can I do Shadows on a floor with Immediate Mode?

Follow Ups:

Post a Followup

Name:


Re: WHICH COMPILER IS BEST 4 DIRECTX5?

Posted by Wolfgang R�ssler on March 11, 1998 at 06:25:35:

In Reply to: Re: WHICH COMPILER IS BEST 4 DIRECTX5? posted by Nick Caldwell on January 20, 1998 at 16:46:46:

: : OK guys simple one.... Which is the best, most compatable compiler for DIRECT X 5?

I'm using Watcom C/C++ 11.0. In my opinion the Watcom-Compiler is the best one. It generates the fastest code I've ever seen.

Follow Ups:

  • Re: WHICH COMPILER IS BEST 4 DIRECTX5? PAULO MARTINHO 20:24:00 6/17/98 (0)
  • Re: WHICH COMPILER IS BEST 4 DIRECTX5? JORGE 16:04:32 6/09/98 (0)

Post a Followup

Name:


Link error

Posted by Navin on March 11, 1998 at 07:45:49:

Does anyone know how to fix the following error that
occurs when using a Visual C++ 5.0 Application (
MFC AppWizard (exe)) with this code:

LPDIRECTDRAW lpDD; LPDIRECT3D lpD3D;

// Create a DirectDraw object and query for the Direct3D interface
// to use to enumerate the drivers.

DirectDrawCreate(NULL, &lpDD, NULL);

lpDD->QueryInterface(IID_IDirect3D, (void**) &lpD3D);

error LNK2001: unsolved extern symbol _IID_IDirect3D
fatal error LNK1120: one unsolved extern query

Follow Ups:

  • Re: Link error Dallas Nutsch 18:20:52 3/11/98 (0)

Post a Followup

Name:


Pixel Format Question

Posted by Joe Chang on March 11, 1998 at 14:47:23:

I am calling lpD3DDevice2->EnumTextureFormats to see all of the available texture formats. Does anyone know how to set one of these texture formats to the direct draw surfaces that I'm using?

Thanks,
Joe

Follow Ups:

Post a Followup

Name:


Re: This DirectX 5.0 is a complete fuck!!!!!

Posted by Jim Lister on March 11, 1998 at 16:32:47:

In Reply to: This DirectX 5.0 is a complete fuck!!!!! posted by Alberto Danilo on February 09, 1998 at 23:04:08:

: Put this fuckin' program in your ass!! This fuck locks up the system!!!
: How can u build a site about a program which locks ups the system???

1> As I see it, this site was put up to HELP programmers out using direct-x.. this isn't MICROSOFT!
2> Direct-X 5.0 works perfectly on almost every system I've seen
3> I've tested MANY video cards (including shitty ones) and machines, and with the correct drivers anything will work with DX5.
4> If your system still locks up, its your windows or bad hardware.

I don't care for Microsoft and most of their ideas, but the recent Direct-X has turned out extremely useful and benificial to programmers and end-user gamers.

Please don't bitch at the people on this side of the fence, who are trying to help others out. No one here wants to hear whinners complain about something we're all trying to work together on.
If you have a question or problem with direct-x.. just ask, its easy. I'm sure most of the people here are more than happy to help out.

J. Lister

Follow Ups:

Post a Followup

Name:


Re: Link error

Posted by Dallas Nutsch on March 11, 1998 at 18:20:52:

In Reply to: Link error posted by Navin on March 11, 1998 at 07:45:49:

: Does anyone know how to fix the following error that
: occurs when using a Visual C++ 5.0 Application (
: MFC AppWizard (exe)) with this code:

: LPDIRECTDRAW lpDD; LPDIRECT3D lpD3D;

: // Create a DirectDraw object and query for the Direct3D interface
: // to use to enumerate the drivers.
:
: DirectDrawCreate(NULL, &lpDD, NULL);
:
: lpDD->QueryInterface(IID_IDirect3D, (void**) &lpD3D);

:
: error LNK2001: unsolved extern symbol _IID_IDirect3D
: fatal error LNK1120: one unsolved extern query

_IID_IDirect3d is the GUID for the Direct3d interface
The Global Unique Identifier is just a real big number that
is assigned to each component object in COM and should
be in DDGUID.LIB. Link this file in and see if it works

Follow Ups:

Post a Followup

Name:


free porn

Posted by larry on March 11, 1998 at 19:37:56:

free hot porn

Follow Ups:

  • Re: free porn Larrys Cunt 19:22:53 3/14/98 (0)

Post a Followup

Name:


Re: Texturemaps loaded with IDirect3DRM::Load() not visible

Posted by Fran Avil�s on March 11, 1998 at 19:41:48:

In Reply to: Texturemaps loaded with IDirect3DRM::Load() not visible posted by John Giors on February 13, 1998 at 02:14:27:

: I'm working on a game demo using Direct3D. I am loading .X objects with IDirect3DRM::Load(), but the surface of the rendered object is not textured.

: I have placed debug code in my loadTextures() callback (which calls the IDirect3DRM::LoadTexture() function), so I know that the callback is being called with the valid filename when the object is loaded.

: Is this due to the rendering device not supporting texture maps? When I create the device, I request the default device, which I thought always supported bitmaps, please inform me if this is incorrect. I HAVE tried setting the render quality attributes of the D3D device, but this seems to have no effect.

: I am not completely certain that this is a code failure. I am using Caligari trueSpace 2 for object creation, and have tried converting the output files in several ways: converting with the demo version of PolyTrans, converting with another program I found, converting from trueSpace format to .3DS format followed with a conversion using conv3ds, etc. Nothing has worked. I've noticed that PolyTrans has an option to set all surfaces to white (which I thought might remove testures), so I turned it off, but that did not work, either.

: If anyone can help me out, it is GREATLY appreciated. Thanks.

..............................................
The textures which you want to use with D3D must be power of 2 . E.g. 8x8,16x16,256x256,256x512 ... and so on.
Do you know that?
I hope it will be useful for you.

Follow Ups:

Post a Followup

Name:


D3DRM::CreateTextureFromSurface

Posted by Fran Avil�s on March 11, 1998 at 19:44:40:

How it works? Have anybody some examples?

Follow Ups:

Post a Followup

Name:


How to play avi files??

Posted by Seether Dragon on March 11, 1998 at 20:19:26:

How do I play avi files, in a directx program. (sort of to play introduction to my game)?

Follow Ups:

Post a Followup

Name:


Help point a newbie(me) to greater awareness.(please)

Posted by Ryan Fenton on March 11, 1998 at 20:34:51:

Please forgive the groveling.

Where to start? I am a junior college student in CS, and, of course, now realize how little any college is going to teach you. Don't worry, I have been learning C++ on my own, but have been able to produce very little outside of text adventures and good homework grades. Now I've been reading every single book I can get ahold of, and still am nowhere close to being the actually productive lame-game developer I want to be. My recent tactics for advancing as a programmer have included looking at the scribble app, reading more of the directx help/source, back to scribble app, back to directx help/sourse, and so on. I'm not quite frustrated yet (It's actually a bit fun) but I can't help but think that there's gotta be someone elses experience I can draw on while I attempt to find out what I still have to learn. I know nothing of COM, DCOM, or anything like that, a little MFC, a spattering of windows terminology, can barely decode hungarian notation, and am trying to remake the classic game solar jetman. Every time I get to looking at actual windows code, I go into this recursive mode of hmm..what's this do?...press f1...oh, I never heard of any of this terminology, what's this one mean...press f1...and so on until the whole night is over before I've decoded a single instruction for myself, and I end up more bewildered than the night before. That compounded with the horrible factor of being an extremely poor college student, and I've got a rut that's hard to slowly claw out of. I'm at the point right now where my goal is just to draw a single frame of animation with a demo program and try not to get too lost in terminology. I guess DirectX might not be the best place to start learning windows programming, but I've been told from many sources that learning MFC will only complicate things and I'm not planning on resorting using DOS programming so that I can come back and learn Windows programming.

Any book, link, psychiatric, or other suggestions welcome.

Ryan Fenton

P.S. In case you were wondering,the resources I have at my disposal are: An unaccelerated p90 with 1 gig HD 72 megs ram, Vidual C++ 5.0, the DirectX 5.0 CD, an OOP Design theorey/problems book, a VC 4 book, an advanced MFC book, Visual C++ 2.0 for Dummies :^), and pure, raw determination to remake Solar Jetman and perhaps Ultimas 1-7 in one engine :^).

Follow Ups:

  • Re: Help point a newbie(me) to greater awareness.(please) Clay 22:29:48 3/11/98 (6)
    • Thanks a lot! I'm still going to have a long way to go! Ryan Fenton 10:45:11 3/12/98 (5)
      • How to learn Memet Bilgin 15:02:20 3/12/98 (4)
        • My current mad schemes. Ryan Fenton 16:56:47 3/12/98 (3)
          • You also might want to check out... Jay Atkinson 13:24:50 3/18/98 (2)
            • Hey, thanks, a definite "Will-do!" Ryan Fenton 22:09:23 3/18/98 (1)
              • Re: Hey, thanks, a definite "Will-do!" Johnny Rotten 10:17:38 3/19/98 (0)

Post a Followup

Name:


Re: Help point a newbie(me) to greater awareness.(please)

Posted by Clay on March 11, 1998 at 22:29:48:

In Reply to: Help point a newbie(me) to greater awareness.(please) posted by Ryan Fenton on March 11, 1998 at 20:34:51:

I was recently in your position, here's what I did:

Find someone that has experience with Win32 (Win95/NT API), Preferably someone with a lot of patience. Make one of those silly "Hello World" apps for windows (just about every Win32 programming book has them). Ask your "someone" to explain every line of code. Come up with something neat, but simple to do. Mine was loading a 256 color bitmap and rotating it around. When you get stuck, ask questions. Lots of questions.

Other suggestions:

Do NOT try your hand at MFC until you get a firm grasp of what is really going on inside windows. You'll ruin your game programming ability -- C++ is extremely slow for games due to its function call overhead.

I learned more trying to find out why stuff didn't work and asking about it than from any book. Ask ask ask ask etc.

DirectX is like Win32 code on crack. Get a handle on Win32 first!

MFC is like Win32, only drunk -- learn it, but don't use it for any real-time apps.

Good luck!

Follow Ups:

  • Thanks a lot! I'm still going to have a long way to go! Ryan Fenton 10:45:11 3/12/98 (5)
    • How to learn Memet Bilgin 15:02:20 3/12/98 (4)
      • My current mad schemes. Ryan Fenton 16:56:47 3/12/98 (3)
        • You also might want to check out... Jay Atkinson 13:24:50 3/18/98 (2)
          • Hey, thanks, a definite "Will-do!" Ryan Fenton 22:09:23 3/18/98 (1)
            • Re: Hey, thanks, a definite "Will-do!" Johnny Rotten 10:17:38 3/19/98 (0)

Post a Followup

Name:


Animation Data question.

Posted by Zerg on March 12, 1998 at 02:20:32:

Does anyone know if there's a way in Retained mode to to grab the KeyFrame data out of the AnimationSet. Or better question I guess is how to I read 3ds format in immediate mode. I would hate to have to write a 3ds reader.

Thanks.

Follow Ups:

Post a Followup

Name:


How to Display Multiple Overlay Surfaces

Posted by He jiangang on March 12, 1998 at 04:43:30:

I create two overlay surfaces. The first one is displayed as expected when calling lpFirstOverlay->UpdateOverlay(..).
However, the second one can not be displayed as first one. Calling lpSecondOverlay->UpdateOverlay(..) returns an error code DDERR_OUTOFCAPS.

Help!

Follow Ups:

Post a Followup

Name:


Shadows with Immediate Mode

Posted by Wolfgang R�ssler on March 12, 1998 at 06:08:46:

How can I code Shadows on a floor with Immedaite Mode?

Follow Ups:

  • Re: Shadows with Immediate Mode Clay 07:39:08 3/12/98 (0)

Post a Followup

Name:


Re: Shadows with Immediate Mode

Posted by Clay on March 12, 1998 at 07:39:08:

In Reply to: Shadows with Immediate Mode posted by Wolfgang R�ssler on March 12, 1998 at 06:08:46:

: How can I code Shadows on a floor with Immedaite Mode?

The way (I believe) retained mode does it is by defining a plane (the x,y,z coordinates and the normal you pass as params to CreateShadow()). Then projecting the object casting the shadow onto that plane from the light source. Interestingly enough, RM cannot put the shadow literally on the "floor", it must be "above" the floor a little bit or you won't see it very well. This seems to be a polygon intersection problem. Anyhow, the RM shadow is a separate visual that needs to be added to the scene, which leads me to believe that it has its own color, vertices, and normals. Good luck!

Clay

Follow Ups:

Post a Followup

Name:


Re: RayPick Question

Posted by Clay on March 12, 1998 at 07:46:03:

In Reply to: RayPick Question posted by Josh Weier on March 07, 1998 at 21:45:34:

: I've been trying to use RayPick in a editor I'm currently
: working on, and I've run into a problem. Although I'm
: able to call the function, I always get a "bad parameter type"
: on the return. I've passed all the parameters they outlined
: in the documentation.

I never got it to work, either. I'm also working on an editor, and it is not as easy as OpenGL!! I'm not sure what your goal here is, but what I needed was a way to determine where (in 3D-Space) the user clicked the mouse by calculating the intersection between the "mouse click projection ray" and the visuals in my scene. That wasn't too easy -- right now, I'm using Pick() and determining the center of the visual clicked on. Lame, but it gets the job done!

Clay

: Has anyone gotten this function to work? If so, did you have to
: do something weird to make it work?

Follow Ups:

Post a Followup

Name:


Re: Mouse handling

Posted by Clay on March 12, 1998 at 07:50:57:

In Reply to: Re: Mouse handling posted by Brian Shea on March 09, 1998 at 14:36:46:

SetCapture() works, but DirectInput is almost guaranteed to be faster because your app talks almost directly to the driver instead of Windows doing it for you.

Clay

Follow Ups:

Post a Followup

Name:


Re: This DirectX 5.0 is a complete fuck!!!!!

Posted by William E. Irving on March 12, 1998 at 09:25:42:

In Reply to: This DirectX 5.0 is a complete fuck!!!!! posted by Alberto Danilo on February 09, 1998 at 23:04:08:

Gee, what can I say? Such a gentleman. So articulate. And so... literate.
I'm speechless.

: Put this fuckin' program in your ass!! This fuck locks up the system!!!
: How can u build a site about a program which locks ups the system???

Follow Ups:

Post a Followup

Name:


getting dx5 games to work under nt4

Posted by John Evans on March 12, 1998 at 10:21:37:

Does anyone know how to get games that use dx5 to work under nt4? I'v seen some people talking on IRC about a hacked version of dx5 for nt4, and this seems to be working for them, but I haven't beenn able to find it.

Follow Ups:

Post a Followup

Name:


windows protection error on restart

Posted by William E. Irving on March 12, 1998 at 10:40:10:

The good news is that my DirectX 5 games run well.
But... Since installing DirectX 5, on restart I get
"windows protection error... press any key to continue"
After doing so, the machine goes immediately to the
"It is now safe to shutdown..." screen. After which
I just hit reset, the computer reboots and runs fine.

To verify that Direct X is the cause, I reinstalled
Windows, writing over all newer files. I reinstalled all
the updates such as DUN 1.2 etc. Everything worked
OK. Then I reinstalled DirectX 5.0. and Eureka! - the
glitch reappears.

I own a Cyrix/IBM 6x86MX PR233-based machine with 64MB of
SDRAM, an Ensoniq sound card, and a Diamond Fire GL1000
Pro with 8MB VRAM. I suspected the video card, so for
good measure I downloaded and installed the latest drivers
for both sound card and video card. Nothing changed.

This glitch is only mildly annoying. When I hit the reset
button, the computer reboots and runs normally.

But occasionally, since installing DirectX 5, the machine
locks during the shutdown sequence. This is more
serious, and a bit of a pain in the ass.

BTW, DirectX 5.0 would not install at all on my older
Pentium 100 with a Matrox Millenium card. I had to
uninstall and write over it to get my system back to
normal.

I am grateful for any help anyone could offer.

Bill

Follow Ups:

Post a Followup

Name:


Thanks a lot! I'm still going to have a long way to go!

Posted by Ryan Fenton on March 12, 1998 at 10:45:11:

In Reply to: Re: Help point a newbie(me) to greater awareness.(please) posted by Clay on March 11, 1998 at 22:29:48:

Thanks a lot!

A while ago I was fortunate enough to snag a cheap win32 book and read it everywhere I went for a about a week (reseraunts, airport, even explained a few things from a game developer magazine to a kid("that's a 3-d game")) Anyway, it seems this is an area for newbie accessability that has huge market: the basic atomic stuff that allows you to use windows programming concepts. I've seen a lot of books, but have yet to find one that really lets you start from scratch, play around with frames, views, and everything else, and guides you through all the wierd stuff like all the |= and (this | thats) and hungarian notations that are always used (why do they keep calling it HRESULT!?). It all takes a lot of getting used to, and I think a lot of fresh-from-college-ignorance people like me could use a little ground to stand on before tackling a lot of these progressively complex issues. Anyway, thanks a lot for your support, I've gotten a little bit more of a handle on where to go to learn where to go to learn where to go next(yes, I meant all o those), and I think with enough caffine I can push in a little deeper. May I remain conscious long enough! I'm going in!!

Ryan Fenton

Follow Ups:

  • How to learn Memet Bilgin 15:02:20 3/12/98 (4)
    • My current mad schemes. Ryan Fenton 16:56:47 3/12/98 (3)
      • You also might want to check out... Jay Atkinson 13:24:50 3/18/98 (2)
        • Hey, thanks, a definite "Will-do!" Ryan Fenton 22:09:23 3/18/98 (1)
          • Re: Hey, thanks, a definite "Will-do!" Johnny Rotten 10:17:38 3/19/98 (0)

Post a Followup

Name:


Re: Blur-Motion with DirectX5

Posted by morten on March 12, 1998 at 12:19:41:

In Reply to: Re: Blur-Motion with DirectX5 posted by 하광석 on February 26, 1998 at 09:05:09:

: : Does anyone known how code a blur motion effect with DirectX 5?

: : Thank you!

: : Wolfgang

Follow Ups:

Post a Followup

Name:


How to learn

Posted by Memet Bilgin on March 12, 1998 at 15:02:20:

In Reply to: Thanks a lot! I'm still going to have a long way to go! posted by Ryan Fenton on March 12, 1998 at 10:45:11:

I am glad to see I am not the only person to be lost in Windows . One year ago , I was only familiar with Turbo Pascal ( which is actually a good place to start ) . Everything started when my finals exam came , and I had to make a project . I choose a simple clock that ran in windows ( where as everyone programmed in DOS ) , programmed it the day before the deadline and got the best grade . The book that got me kick started was "Schildt's Windows 95 Programming in C and C++" , which is absoluely great .

My suggestion is for you to start by writing a stupid clock , and just fiddle around with it . Make it change color , add a menu ... pretty soon you'll be able to understand how windows works . Just be patient , and you'll see that in no time ( ie 3 months max ) , you'll be able to learn by yourself !
After having understood the basic concepts , the best way to learn is to really write a program . You'll see that in no time , you'll be using DirectX and assembly .

Patience is the thing . Good luck

Follow Ups:

  • My current mad schemes. Ryan Fenton 16:56:47 3/12/98 (3)
    • You also might want to check out... Jay Atkinson 13:24:50 3/18/98 (2)
      • Hey, thanks, a definite "Will-do!" Ryan Fenton 22:09:23 3/18/98 (1)
        • Re: Hey, thanks, a definite "Will-do!" Johnny Rotten 10:17:38 3/19/98 (0)

Post a Followup

Name:


My current mad schemes.

Posted by Ryan Fenton on March 12, 1998 at 16:56:47:

In Reply to: How to learn posted by Memet Bilgin on March 12, 1998 at 15:02:20:

Hey, thanks, I'll have to look for some good generic windows programming books, but also look at the back of them just to be sure :^).

Actually, I've got a very similar idea to that clock thing: first a stupid asteroids-type game (Hey, I could first make the ship go into "clock mode" after I get some sprite rotation down, or just implement it with two lines - spacebar lets the user set the time, left and right.) After I play around with all of that, I'll really sit down and start planning my next idea out on paper for a while: A generic Isometric Ultima Engine to allow people to recreate the Ultimas 1-7, and just keep adding features to see how to program keeping expandability in mind. My goals: I have to get down the aspects of how to manipulate data, sprites, backrounds, scripts, event engines, sprite depth ordering, data type choices, exceptions, object templates Vs live objects & saved objects, map updating, idle actions for on-screen objects, method of dealing with object rotations, whether to attempt tiles or polygons, expandibility of everything, custom in-game editors, screen modes, scalability, and anything else I can cram into my free time. The place I've decided to draw the line is multi-player access - no, Uh uh, I'm being aggressive, but that's going a bit to far for now :^). Ah, the dreams of a lame game programmer. I'll just keep picking away at it, however, and just see what the compiler spits back at me, and some day, I may be able to ask some of the real questions here :^)!

Thanks again for the help!

Ryan Fenton

Follow Ups:

  • You also might want to check out... Jay Atkinson 13:24:50 3/18/98 (2)
    • Hey, thanks, a definite "Will-do!" Ryan Fenton 22:09:23 3/18/98 (1)
      • Re: Hey, thanks, a definite "Will-do!" Johnny Rotten 10:17:38 3/19/98 (0)

Post a Followup

Name:


I think the FAQ link is broken. (NT)

Posted by Ryan Fenton on March 12, 1998 at 21:23:51:

NT

Follow Ups:

Post a Followup

Name:


DirectX/OpenGL

Posted by James Simpson on March 13, 1998 at 07:29:11:

Is it possible to just use D3D (RM or IM) to use the Geomertry funcions only and then extract the transformed data, and use your own functions for drawing, Like in OpenGL you can change RenderMode to GL_FEEDBACK and that then allows you to obtain data, Can it be done in D3D??

Follow Ups:

  • Re: DirectX/OpenGL Clay 08:43:45 3/14/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by David Craig-Smith on March 13, 1998 at 10:25:01:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Darryl Brown on January 25, 1998 at 20:14:54:

: : : Where Can I download DirectX 5.0. I need it for a game.
: I kneed it for the Demo of Age Of Empires

Follow Ups:

  • Re: Where Can I download DirectX 5.0 derrick paul 20:23:20 3/17/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by David Craig-Smith on March 13, 1998 at 10:25:20:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Darryl Brown on January 25, 1998 at 20:14:54:

: : : Where Can I download DirectX 5.0. I need it for a game.
: I kneed it for the Demo of Age Of Empires

Follow Ups:

Post a Followup

Name:


ddraw question

Posted by Romalis on March 13, 1998 at 12:04:43:

I am creating a 2d graphics game using direct draw.
I create 2 surfaces a primary which is the background
and an Offscreen which is the character.
I am having trouble since the background's palette is
different from the character's palette. so when I do
a bltfast of the character to the primary surface the
character's colors are all messed up but not the background.
Do you know how I fix this because the artwork is
bound to have different palettes?

thanks in advance :>
jugg

Follow Ups:

  • Re: ddraw question Brian Shea 12:32:39 3/13/98 (4)
    • Re: ddraw question Ron 13:55:04 3/13/98 (3)
      • Re: ddraw question Brian Shea 15:38:15 3/16/98 (0)
      • Re: ddraw question Clay 08:39:45 3/14/98 (1)
        • Re: ddraw question BoxMan 20:21:06 4/15/98 (0)

Post a Followup

Name:


Re: ddraw question

Posted by Brian Shea on March 13, 1998 at 12:32:39:

In Reply to: ddraw question posted by Romalis on March 13, 1998 at 12:04:43:

Either explicitly set the palette to the desired
one using DirectDrawPalette or load your character
using the GDI functions, which will change your
character to use the closest palette entries that
are available (or add entries to the palette etc).

Brian

  • Journals of a DX Junkie

Follow Ups:

  • Re: ddraw question Ron 13:55:04 3/13/98 (3)
    • Re: ddraw question Brian Shea 15:38:15 3/16/98 (0)
    • Re: ddraw question Clay 08:39:45 3/14/98 (1)
      • Re: ddraw question BoxMan 20:21:06 4/15/98 (0)

Post a Followup

Name:


Re: I get missing decl-spec from dsound.h...how can that be?

Posted by Jacques on March 13, 1998 at 12:49:10:

In Reply to: Re: I get missing decl-spec from dsound.h...how can that be? posted by Brian Shea on March 05, 1998 at 12:32:24:

: That should be (for the last time):
: #include "mmsystem.h"

thanks...I figured it out myself by looking for
WAVEFORMATEX which turned out to be in
which I included...now all is fine
thanks again!

Follow Ups:

Post a Followup

Name:


Re: ddraw question

Posted by Ron on March 13, 1998 at 13:55:04:

In Reply to: Re: ddraw question posted by Brian Shea on March 13, 1998 at 12:32:39:

: Either explicitly set the palette to the desired
: one using DirectDrawPalette or load your character
: using the GDI functions, which will change your
: character to use the closest palette entries that
: are available (or add entries to the palette etc).

: Brian
I don't think you can set the character's palette
to the background palette because if the character's
palette is different from the backgrounds palette
when the draw is performed the characters image
information will map to a totally different color
system. In other words if the first byte in the
character's image data equals 8 which is supposed
to be red based on the images color palette. if you
set the character's palette to equal that of the
background's, a value of 8 might be blue thus funny
looking character on background. If this is a wrong
evaluation please correct :>

Also may I ask what GDI functions are you speaking
of?

Follow Ups:

  • Re: ddraw question Brian Shea 15:38:15 3/16/98 (0)
  • Re: ddraw question Clay 08:39:45 3/14/98 (1)
    • Re: ddraw question BoxMan 20:21:06 4/15/98 (0)

Post a Followup

Name:


DirectX 5.0 SDK cannot be downloaded anymore

Posted by cObBiE on March 13, 1998 at 15:36:14:

can anyone tell me where to download it besides microsoft website?

Follow Ups:

  • Re: DirectX 5.0 SDK cannot be downloaded anymore Chad 16:16:09 3/27/98 (0)
  • Re: DirectX 5.0 SDK cannot be downloaded anymore Mehrab 15:12:59 3/14/98 (19)
    • Re: DirectX 5.0 SDK cannot be downloaded anymore hpayne BERT PAYNE 01:16:05 9/02/98 (0)
    • Re: DirectX 5.0 SDK cannot be downloaded anymore camp bug 11:14:00 6/04/98 (0)
    • Re: DirectX 5.0 SDK cannot be downloaded anymore camp bug 11:12:05 6/04/98 (0)
    • DirectX 5.0 Download Mehrab 15:14:04 3/14/98 (15)
      • Re: DirectX 5.0 Download jhony 02:36:53 6/07/98 (0)
      • Re: This is the URL to get Direct X 5.2 Bigstar2001 01:47:00 6/05/98 (0)
      • Re: DirectX 5.0 Download suhaimi 08:46:54 6/03/98 (1)
        • Re: DirectX 5.0 Download jean sims 21:55:28 9/27/98 (0)
      • Re: DirectX 5.0 Download Thomas Sah 10:02:44 3/28/98 (0)
      • Re: DirectX 5.0 Download Dani Llenas (FacOne) 16:09:59 3/18/98 (2)
        • Re: DirectX 5.0 Download Joe 12:40:16 4/15/98 (0)
        • Re: DirectX 5.0 Download Jorgen olesen 11:39:42 3/31/98 (0)
      • Re: DirectX 5.0 Download Ricardo Balam 15:24:03 3/15/98 (6)
        • Re: DirectX 5.0 Download Lucas 08:41:21 3/16/98 (3)
          • Re: DirectX 5.0 Download mike poliszuk 23:26:25 9/18/98 (0)
          • Re: DirectX 5.0 Download j.boschert 09:52:19 3/18/98 (1)
            • Re: DirectX 5.0 Download ddc; 05:22:42 9/11/98 (0)
        • Re: DirectX 5.0 Download James Hurdle 20:10:44 3/15/98 (1)
          • Re: DirectX 5.0 Download Ahmad Emad 21:15:31 5/29/98 (0)
  • Re: DirectX 5.0 SDK cannot be downloaded anymore John Sabean 11:51:17 3/14/98 (1)
    • Re: DirectX 5.0 SDK cannot be downloaded anymore Dinh Ba 11:30:24 3/25/98 (0)

Post a Followup

Name:


dxsetup not registering diamond viper 330 video card

Posted by Bob Shultz on March 13, 1998 at 15:40:52:

I am not able to run some games due to an error message stating that directx is not registering my video card and my monster sound card. Diamond states that it is a problem with directx. Can anybody help?

Follow Ups:

  • Re: dxsetup not registering diamond viper 330 video card joe manning 17:52:28 9/19/98 (0)

Post a Followup

Name:


PLEASE HELP! ddraw question

Posted by Romalis on March 13, 1998 at 22:49:52:

I am creating a 2d graphics game using direct draw.
I create 2 surfaces, 8bit bmp images,a primary which is
the background and an Offscreen which is the character.
I am having trouble since the background's palette is
different from the character's palette. so when I do
a bltfast of the character to the primary surface the
character's colors are all messed up but not the background
because the direct draw is using the primary surfaces
palette to draw the character which has a differnet palette.
I don't want to use 16bit graphics and want to use full
screen mode. Do you know how I fix this because the artwork is
bound to have different palettes?
Thanks to Brian Shea for his suggestion

thanks in advance :>
jugg

Follow Ups:

  • Re: PLEASE HELP! ddraw question Johnny Rotten 10:24:11 3/18/98 (0)

Post a Followup

Name:


Re: dx5eng

Posted by Peter Brunovsky on March 14, 1998 at 01:10:42:

In Reply to: Re: DirectX Audio Driver posted by John on February 09, 1998 at 23:03:22:

: Hello, I have dx5eng, but It wont play any MPEG
sound clips, when I start to play MPEG sound clips
dx5eng comes up and says COMAND LINE OPTION SYNTAX
ERROR , I even downloaded a MPEG player, but
dx5eng wont let it play, how do I get dx5 to play?

Follow Ups:

Post a Followup

Name:


Loading Textures

Posted by Frank on March 14, 1998 at 01:12:19:

Having a problem wrapping bit maps greater or smaller than 256 colors. Any suggestions as to want I am doing wrong or what to look for?

Thx,
Frank

Follow Ups:

  • Re: Loading Textures Lou 08:24:33 5/16/98 (0)

Post a Followup

Name:


dx5eng can't play MPEG sound clips

Posted by Peter Brunovsky on March 14, 1998 at 01:24:31:

Hello, I have dx5eng, but when I go to play MPEG sound
clips, dx5 comes up and says COMAND LINE OPTION SYNTAX
ERROR, I even downloaded a MPEG player, but dx5 wont
let it play, how can I get dx5 to play MPEG sound clips?
Thank You
Peter Brunovsky
tpsweep@pond.com

Follow Ups:

Post a Followup

Name:


directdraw, help!!!!!!!!!!!!!!!!!!!!!!!!

Posted by mike on March 14, 1998 at 02:24:31:

i have directx 3.0 and i keep getting an error message re: directdraw. it say beta directdraw expired, please update.
ive tried installing it again and again, even installed dx5 and still dont work , please help!!!!!!!!!!!

Follow Ups:

Post a Followup

Name:


Direct3D RM v5.0

Posted by Russell Wild on March 14, 1998 at 04:07:05:

Hello,
I'm new to Direct3D programming and I would be grateful if someone could mail me the minimal code required to get Direct3D RM running in a window. Also, how do I draw a primitive, say a pyramid, manually in RM?

Thanks
Russell

PS - Please email me

Follow Ups:

Post a Followup

Name:


Re: ddraw question

Posted by Clay on March 14, 1998 at 08:39:45:

In Reply to: Re: ddraw question posted by Ron on March 13, 1998 at 13:55:04:

Try using the same palette for all your images. This is hard and time-consuming, but look at Myst...They used the same palette for every "room", but each room had its own palette. The end result was that their artwork look like 16bit colors (or better) and was capable of looking excellent on even the most outdated computer.

Clay

Follow Ups:

  • Re: ddraw question BoxMan 20:21:06 4/15/98 (0)

Post a Followup

Name:


Re: DirectX/OpenGL

Posted by Clay on March 14, 1998 at 08:43:45:

In Reply to: DirectX/OpenGL posted by James Simpson on March 13, 1998 at 07:29:11:

: Is it possible to just use D3D (RM or IM) to use the Geomertry funcions only and then extract the transformed data, and use your own functions for drawing, Like in OpenGL you can change RenderMode to GL_FEEDBACK and that then allows you to obtain data, Can it be done in D3D??

I'm sure there is a way -- D3D can be pretty flexible as to what rendering engine you use (look at MDK!) What you'll need to do is interrupt the rendering pipeline after the "transformation" stage. I've never tried this, but I'm pretty sure it'll get you the data you're looking for.

Clay

Follow Ups:

Post a Followup

Name:


Looking for someone with a fast internet connection.

Posted by Bueller on March 14, 1998 at 11:02:56:

Could someone with a fast internet connection do me a favor and e-mail me the DX5 SDK (Mimimun install preferably)? I just nuked my system and did not realize the Microsoft is no longer offering the SDK as a download. I have a very fast internet connection, so getting the e-mail down will not be a problem.

Thanks in advance,
Bueller

Follow Ups:

Post a Followup

Name:


Blitting a Sprite as a Different Color

Posted by John Sabean on March 14, 1998 at 11:48:35:

I've seen games like Ultima Online and Diablo do this.
I'm wondering how you can use Direct X to take a sprite
and blit it as a different color.

For example, in UO, you can take a white shirt and
dye it different colors (it even gives you a palette
so you can dye it a wide variety of colors).

My question is, are they writing their own routine to
do this, or is there something in direct X that allows
them to do this?

I think it might have something to do with using a
YUV format. However, I've never used this format,
and I have no idea what YUV even stands for!

Any ideas? Any help would be appriciated. Thanks!

Follow Ups:

  • Perhaps a custom blit with an altered transparancy code. (NT) Ryan Fenton 23:55:47 3/26/98 (0)
  • Re: Blitting a Sprite as a Different Color Johnny Rotten 10:15:44 3/18/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 SDK cannot be downloaded anymore

Posted by John Sabean on March 14, 1998 at 11:51:17:

In Reply to: DirectX 5.0 SDK cannot be downloaded anymore posted by cObBiE on March 13, 1998 at 15:36:14:

: can anyone tell me where to download it besides microsoft website?

They'll send you a CD for free if you join the
Direct X beta program. Just send them email
at directx@microsoft.com

(I just got my DX 5.2 CD the other day....
very convinient!)

Follow Ups:

  • Re: DirectX 5.0 SDK cannot be downloaded anymore Dinh Ba 11:30:24 3/25/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 SDK cannot be downloaded anymore

Posted by Mehrab on March 14, 1998 at 15:12:59:

In Reply to: DirectX 5.0 SDK cannot be downloaded anymore posted by cObBiE on March 13, 1998 at 15:36:14:

: can anyone tell me where to download it besides microsoft website?

Follow Ups:

  • Re: DirectX 5.0 SDK cannot be downloaded anymore hpayne BERT PAYNE 01:16:05 9/02/98 (0)
  • Re: DirectX 5.0 SDK cannot be downloaded anymore camp bug 11:14:00 6/04/98 (0)
  • Re: DirectX 5.0 SDK cannot be downloaded anymore camp bug 11:12:05 6/04/98 (0)
  • DirectX 5.0 Download Mehrab 15:14:04 3/14/98 (15)
    • Re: DirectX 5.0 Download jhony 02:36:53 6/07/98 (0)
    • Re: This is the URL to get Direct X 5.2 Bigstar2001 01:47:00 6/05/98 (0)
    • Re: DirectX 5.0 Download suhaimi 08:46:54 6/03/98 (1)
      • Re: DirectX 5.0 Download jean sims 21:55:28 9/27/98 (0)
    • Re: DirectX 5.0 Download Thomas Sah 10:02:44 3/28/98 (0)
    • Re: DirectX 5.0 Download Dani Llenas (FacOne) 16:09:59 3/18/98 (2)
      • Re: DirectX 5.0 Download Joe 12:40:16 4/15/98 (0)
      • Re: DirectX 5.0 Download Jorgen olesen 11:39:42 3/31/98 (0)
    • Re: DirectX 5.0 Download Ricardo Balam 15:24:03 3/15/98 (6)
      • Re: DirectX 5.0 Download Lucas 08:41:21 3/16/98 (3)
        • Re: DirectX 5.0 Download mike poliszuk 23:26:25 9/18/98 (0)
        • Re: DirectX 5.0 Download j.boschert 09:52:19 3/18/98 (1)
          • Re: DirectX 5.0 Download ddc; 05:22:42 9/11/98 (0)
      • Re: DirectX 5.0 Download James Hurdle 20:10:44 3/15/98 (1)
        • Re: DirectX 5.0 Download Ahmad Emad 21:15:31 5/29/98 (0)

Post a Followup

Name:


DirectX 5.0 Download

Posted by Mehrab on March 14, 1998 at 15:14:04:

In Reply to: Re: DirectX 5.0 SDK cannot be downloaded anymore posted by Mehrab on March 14, 1998 at 15:12:59:

: : can anyone tell me where to download it besides microsoft website?

Follow Ups:

  • Re: DirectX 5.0 Download jhony 02:36:53 6/07/98 (0)
  • Re: This is the URL to get Direct X 5.2 Bigstar2001 01:47:00 6/05/98 (0)
  • Re: DirectX 5.0 Download suhaimi 08:46:54 6/03/98 (1)
    • Re: DirectX 5.0 Download jean sims 21:55:28 9/27/98 (0)
  • Re: DirectX 5.0 Download Thomas Sah 10:02:44 3/28/98 (0)
  • Re: DirectX 5.0 Download Dani Llenas (FacOne) 16:09:59 3/18/98 (2)
    • Re: DirectX 5.0 Download Joe 12:40:16 4/15/98 (0)
    • Re: DirectX 5.0 Download Jorgen olesen 11:39:42 3/31/98 (0)
  • Re: DirectX 5.0 Download Ricardo Balam 15:24:03 3/15/98 (6)
    • Re: DirectX 5.0 Download Lucas 08:41:21 3/16/98 (3)
      • Re: DirectX 5.0 Download mike poliszuk 23:26:25 9/18/98 (0)
      • Re: DirectX 5.0 Download j.boschert 09:52:19 3/18/98 (1)
        • Re: DirectX 5.0 Download ddc; 05:22:42 9/11/98 (0)
    • Re: DirectX 5.0 Download James Hurdle 20:10:44 3/15/98 (1)
      • Re: DirectX 5.0 Download Ahmad Emad 21:15:31 5/29/98 (0)

Post a Followup

Name:


Can't have the DX 5 SDK anymore

Posted by Jean-Sebastien Payette on March 14, 1998 at 15:57:19:

I can't download if from the microsoft web site! And I don't wanna order the CD!!! Damn, I don't have a credit card (no i'm not a child or something... it's only that I know what I'll do no good with a credit card) WHERE ELSE CAN I DOWNLOAD IT?
thanx

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by y�ltan deveci on March 14, 1998 at 16:59:19:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


Re: free porn

Posted by Larrys Cunt on March 14, 1998 at 19:22:53:

In Reply to: free porn posted by larry on March 11, 1998 at 19:37:56:

where

Follow Ups:

Post a Followup

Name:


Random (rand()) stinks, need help

Posted by Hank Lee on March 14, 1998 at 19:59:21:

We are creating an rpg online engine, and the rand()
function is failing miserably. It seems to randomly
place a creature (1 of say 10,000) fine, and even assign
random attributes fine, but we then go through a decision
loop and ask each monster to make a decision on which
direction to move.

Our problem is, that after a while, all of our monsters
seem to head to the NorthEast of the world, and get
piled up there. Even when we 'tweak' the settings to
force the creatures to go the opposite way, they STILL
end up in the NE corner.

We seed our program with an srand() in the beginning,
and we get this problem.

We think it has to do with how fast we call the
rand function between monster decisions, but there
has to be a better way. we need to get random
numbers, and we are only getting biased numbers.

Thanks in advance.

Hank

Follow Ups:

  • Re: Random (rand()) stinks, need help Sean 03:43:51 3/15/98 (0)
  • Re: Random (rand()) stinks, need help Roger 20:24:50 3/14/98 (2)
    • seeding Hank Lee 22:57:40 3/14/98 (1)
      • Re: seeding Ryan Geiss 14:38:06 3/26/98 (0)

Post a Followup

Name:


Re: Random (rand()) stinks, need help

Posted by Roger on March 14, 1998 at 20:24:50:

In Reply to: Random (rand()) stinks, need help posted by Hank Lee on March 14, 1998 at 19:59:21:

The rand() function is not based on time. You can test that by printing out all the results of rand(). The numbers should be random. Check to see if your program is taking in the numbers properly.

Follow Ups:

  • seeding Hank Lee 22:57:40 3/14/98 (1)
    • Re: seeding Ryan Geiss 14:38:06 3/26/98 (0)

Post a Followup

Name:


Re: Using a color mouse cursor in directx 5 ???

Posted by Alex Alvarez on March 14, 1998 at 20:36:29:

In Reply to: Re: Using a color mouse cursor in directx 5 ??? posted by Johnny Rotten on March 05, 1998 at 10:13:42:

Well, thanks for the comment.

You can use the system cursor in full screen mode,
as long as you don't set the mouse device as EXCLUSIVE, since it then disappears and you have to do everything via dinput polling and use a sprite engine for the cursor.

Thus, I change my question.

Does anyone have any Libraries for handling a
Color Cursor with dinput?

Thanks, again,

-a

Follow Ups:

Post a Followup

Name:


seeding

Posted by Hank Lee on March 14, 1998 at 22:57:40:

In Reply to: Re: Random (rand()) stinks, need help posted by Roger on March 14, 1998 at 20:24:50:

we made a program that simply uses

direction = rand()%8;

1 is NW
2 is N
3 is NE

etc

The program when it runs, has the creatures randomly
moving around, but they head towards the upper right hand
side of the server, until they are all up there.

We thought it might have to do something with
our seeding. Do you have any recomendations of
how and when to seed for such a rand function?

We seed ours in the first (and only) instance of
the random_utility class (has all our random
functions) is declared. we use:

srand((unsigned)GetTickCount());

we are using the windows.h header file for it

thanks in advance

Follow Ups:

  • Re: seeding Ryan Geiss 14:38:06 3/26/98 (0)

Post a Followup

Name:


Somebody with a fast connection...

Posted by Jean-Sebastien Payette on March 15, 1998 at 00:51:35:

If anybody can be kind enough to send me the DX5 SDK!
I don't know if this break a copyright law... I don't have the sdk to check!

I have a cable modem. So if ANYBODY with something FASTER THAN A MODEM CONNECTION can send it to me...

my ICQ is 4172075
I'm always almost online!

Follow Ups:

Post a Followup

Name:


Re: Random (rand()) stinks, need help

Posted by Sean on March 15, 1998 at 03:43:51:

In Reply to: Random (rand()) stinks, need help posted by Hank Lee on March 14, 1998 at 19:59:21:

Have you considered using an array of numbers from 1 to 8? If you make this array large enough, everything will appear to be random, and it's a lot faster too!

: We are creating an rpg online engine, and the rand()
: function is failing miserably. It seems to randomly
: place a creature (1 of say 10,000) fine, and even assign
: random attributes fine, but we then go through a decision
: loop and ask each monster to make a decision on which
: direction to move.

: Our problem is, that after a while, all of our monsters
: seem to head to the NorthEast of the world, and get
: piled up there. Even when we 'tweak' the settings to
: force the creatures to go the opposite way, they STILL
: end up in the NE corner.

: We seed our program with an srand() in the beginning,
: and we get this problem.

: We think it has to do with how fast we call the
: rand function between monster decisions, but there
: has to be a better way. we need to get random
: numbers, and we are only getting biased numbers.

: Thanks in advance.

: Hank

Follow Ups:

Post a Followup

Name:


Help!!!DirectX Linked List Programming.....

Posted by Yoon on March 15, 1998 at 06:38:51:

Hi.....
My Name is Yoon Sang Ee
Direct X .....
Linked List Programming sample please....

Follow Ups:

  • Re: Help!!!DirectX Linked List Programming..... Niklas Elmqvist 06:33:44 3/17/98 (0)

Post a Followup

Name:


Can someone suggest a Win32 Programming Reference?

Posted by Todd Ogrin on March 15, 1998 at 12:38:41:

Hi...

I'm looking for a decent beginner's guide to Win32 programming
(not necessarily MFC). Can someone suggest a good book?

Follow Ups:

  • Re: Can someone suggest a Win32 Programming Reference? Sean 01:59:40 3/16/98 (1)
    • Re: DirectX and MFC Robert Tomliin 06:36:04 4/09/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Eric on March 15, 1998 at 13:20:09:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Harold on January 18, 1998 at 20:37:49:

: : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Liviu Drugus 01:19:32 3/17/98 (1)
    • Re: Where Can I download DirectX 5.0 Ernesto Ibarra 03:35:03 3/17/98 (0)
  • Re: Where Can I download DirectX 5.0 Liviu Drugus 01:18:36 3/17/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 Download

Posted by Ricardo Balam on March 15, 1998 at 15:24:03:

In Reply to: DirectX 5.0 Download posted by Mehrab on March 14, 1998 at 15:14:04:

: : : can anyone tell me where to download it besides microsoft website?

Follow Ups:

  • Re: DirectX 5.0 Download Lucas 08:41:21 3/16/98 (3)
    • Re: DirectX 5.0 Download mike poliszuk 23:26:25 9/18/98 (0)
    • Re: DirectX 5.0 Download j.boschert 09:52:19 3/18/98 (1)
      • Re: DirectX 5.0 Download ddc; 05:22:42 9/11/98 (0)
  • Re: DirectX 5.0 Download James Hurdle 20:10:44 3/15/98 (1)
    • Re: DirectX 5.0 Download Ahmad Emad 21:15:31 5/29/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 Download

Posted by James Hurdle on March 15, 1998 at 20:10:44:

In Reply to: Re: DirectX 5.0 Download posted by Ricardo Balam on March 15, 1998 at 15:24:03:

: : : : can anyone tell me where I can download directx 5.0

Follow Ups:

  • Re: DirectX 5.0 Download Ahmad Emad 21:15:31 5/29/98 (0)

Post a Followup

Name:


DirectX mutes Presario 2120

Posted by Rey Rito on March 16, 1998 at 00:24:46:

Everytime I load game softwares (ex: Age of Empires,
Barney Under the Sea, The Lost World - Jurassic Park,etc.)
that also contain DirectX, my Presario 2120 becomes mute
(no more sound, even when using other programs that do
not use DirectX). I end up spending much time restoring
my computer's programs to its original settings and
re-installing other softwares just to bring back the
sound. Sometimes, I would spend 1 day to back up my old
files (which would be erased by the Compaq Restore
program) and re-install the other softwares.

What should I do to solve this so I could use the game
softwares with DirectX with sound?

Also, will the sound come back if I use Norton Uninstall
to remove softwares with DirectX, assuming the Presario
2120 is not compatible with DirectX?

Thanks in advance for your help.

Follow Ups:

  • Re: DirectX mutes Presario 2120 V.L. smith 10:18:19 6/28/98 (0)
  • Re: DirectX mutes Presario 2120 EvAcLeAr 05:14:59 4/05/98 (0)

Post a Followup

Name:


Re: Can someone suggest a Win32 Programming Reference?

Posted by Sean on March 16, 1998 at 01:59:40:

In Reply to: Can someone suggest a Win32 Programming Reference? posted by Todd Ogrin on March 15, 1998 at 12:38:41:

Todd,
I use and recommend the two following books:
Win32 Programming API Bible (Waite Group Press)
and
Programming Windows 95 (Microsorf Press)

You should be able to find both books at discount prices. Don't go to a real bookstore, they cost $50 US there.

These books are not MFC and if you want my advice, a directX programmer should run from MFC like it is the devil.

: Hi...

: I'm looking for a decent beginner's guide to Win32 programming
: (not necessarily MFC). Can someone suggest a good book?

Follow Ups:

  • Re: DirectX and MFC Robert Tomliin 06:36:04 4/09/98 (0)

Post a Followup

Name:


DirectDraw - Getcaps init problem??

Posted by Albert Koelmans on March 16, 1998 at 06:26:30:

Hello all,

Background: After installing DX5, my TV card (from Modular Technology)
stopped working. It reports "No suitable DirectDraw provider found - overlay
channel disabled". I have an ATI 3D Rage Pro graphics card.

I ran the software with Numega's Boundschecker program, which reported the
following:

globalrealloc: arg 3 has illegal flags 0x2000
getscrollrange returns failure code 0 (twice)
Invalid interface method argument: DirectDraw::getcaps,
argument 2, Structure field is not initialised (argument count starts with
interface [this] pointer.

Since I'm not a DirectX programmer, I wonder how significant this is - would
such a problem cause DX to report that it couldn't initialise?
Any help much appreciated - Modular Tech are spectacularly unhelpful.

Cheers

Albert

Follow Ups:

  • Re: DirectDraw - Getcaps init problem?? Clay 07:41:16 3/16/98 (0)

Post a Followup

Name:


Re: DirectDraw - Getcaps init problem??

Posted by Clay on March 16, 1998 at 07:41:16:

In Reply to: DirectDraw - Getcaps init problem?? posted by Albert Koelmans on March 16, 1998 at 06:26:30:

: Hello all,

: Background: After installing DX5, my TV card (from Modular Technology)
: stopped working. It reports "No suitable DirectDraw provider found - overlay
: channel disabled". I have an ATI 3D Rage Pro graphics card.

: I ran the software with Numega's Boundschecker program, which reported the
: following:

: globalrealloc: arg 3 has illegal flags 0x2000
: getscrollrange returns failure code 0 (twice)
: Invalid interface method argument: DirectDraw::getcaps,
: argument 2, Structure field is not initialised (argument count starts with
: interface [this] pointer.

: Since I'm not a DirectX programmer, I wonder how significant this is - would
: such a problem cause DX to report that it couldn't initialise?
: Any help much appreciated - Modular Tech are spectacularly unhelpful.

: Cheers

: Albert

I think this could be one of two problems:

1) Your driver is not certified or maybe not compatible with DX5.0. Check for a new version.

2) Your TV card is not compatible with DX5.0, or uses a kludge in its software that causes a problem with your particular video card/driver.

Good luck -- post and let us know the solution!

Clay

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 Download

Posted by Lucas on March 16, 1998 at 08:41:21:

In Reply to: Re: DirectX 5.0 Download posted by Ricardo Balam on March 15, 1998 at 15:24:03:

: : : : can anyone tell me where to download it besides microsoft website?

Follow Ups:

  • Re: DirectX 5.0 Download mike poliszuk 23:26:25 9/18/98 (0)
  • Re: DirectX 5.0 Download j.boschert 09:52:19 3/18/98 (1)
    • Re: DirectX 5.0 Download ddc; 05:22:42 9/11/98 (0)

Post a Followup

Name:


DirectX Type files for VB

Posted by Erik on March 16, 1998 at 11:39:15:

Can someone please tell me where I can get the DirectX
type libraries for Visual Basic 5? It would be a great help.
(ex: Ddraw.tbl)

Follow Ups:

  • Re: DirectX Type files for VB Sietze 08:22:22 3/21/98 (0)

Post a Followup

Name:


D3DRM in fullscreen?

Posted by Niklas Elmqvist on March 16, 1998 at 14:21:49:

I have run into some problems when trying to kick
my D3DRM application into fullscreen mode. I get a
DDERR_NOEXCLUSIVE error when trying to create a
D3DRM device, even though I *have* set my cooperative
levels and updated and shown my main window.
Earlier, when my application was windowed, I used a
DirectDrawClipper to create my device, and I still do,
which I suspect is the source of my problems. Do I
have to create a DirectDraw surface and then use
Direct3DRM::CreateDeviceFromSurface instead of
Direct3DRM::CreateDeviceFromClipper? Or am I doing
some other silly mistake?

Follow Ups:

  • Re: D3DRM in fullscreen? Lou 09:33:21 5/16/98 (0)
  • Re: D3DRM in fullscreen? Sietze 08:19:12 3/21/98 (0)

Post a Followup

Name:


Re: ddraw question

Posted by Brian Shea on March 16, 1998 at 15:38:15:

In Reply to: Re: ddraw question posted by Ron on March 13, 1998 at 13:55:04:

You have a couple of choices.
1. Use the same palette for all of your images
and set the primary surface to use the same.
2. Use higher bit-depths, hence no palette.
3. Use any old palette for everything and go
through the GDI when loading your images.
For examples of this, check out my webpage
or ddutil.cpp that comes with the DX SDK.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Does D.X.5 go to WinNT 4.0??

Posted by CrackHacker on March 16, 1998 at 16:12:43:

Well!! Does it!

Follow Ups:

  • Re: Does D.X.5 go to WinNT 4.0?? Clay 18:44:05 3/16/98 (1)
    • Re: Does D.X.5 go to WinNT 4.0?? Sean 09:35:25 4/08/98 (0)

Post a Followup

Name:


Re: Does D.X.5 go to WinNT 4.0??

Posted by Clay on March 16, 1998 at 18:44:05:

In Reply to: Does D.X.5 go to WinNT 4.0?? posted by CrackHacker on March 16, 1998 at 16:12:43:

: Well!! Does it!
Nope...that is supposed to be in NT 5.0 -- if they ever get it out of beta!

DirectX 3.0 works though

Clay

Follow Ups:

  • Re: Does D.X.5 go to WinNT 4.0?? Sean 09:35:25 4/08/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Liviu Drugus on March 17, 1998 at 01:18:36:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Eric on March 15, 1998 at 13:20:09:

:
: : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Liviu Drugus on March 17, 1998 at 01:19:32:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Eric on March 15, 1998 at 13:20:09:

:
: : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Ernesto Ibarra 03:35:03 3/17/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Ernesto Ibarra on March 17, 1998 at 03:35:03:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Liviu Drugus on March 17, 1998 at 01:19:32:

:
: :
: : : : Where Can I download DirectX 5.0. I need it for a game the Virtual Pool 2 Preview

Follow Ups:

Post a Followup

Name:


Using DirectPlay -- how to specify a PORT

Posted by Derrick Schommer on March 17, 1998 at 04:12:22:

I am new to DirectPlay, and only have "Spells of Fury" using DirectX 2.0 to reference at this point. Does anyone know how to tell a server to specifically watch a port on the system? And to go with this, is there a way to tell the client to send data to that same port number? "Spells of Fury" seems to lack on exactly how this all works.

Thanks in Advance,

Derrick

Follow Ups:

  • Re: Using DirectPlay -- how to specify a PORT Jimbo Bob Briggs 10:07:40 3/17/98 (1)
    • Re: Using DirectPlay -- how to specify a PORT Derrick Schommer 00:51:51 3/18/98 (0)

Post a Followup

Name:


Re: Help!!!DirectX Linked List Programming.....

Posted by Niklas Elmqvist on March 17, 1998 at 06:33:44:

In Reply to: Help!!!DirectX Linked List Programming..... posted by Yoon on March 15, 1998 at 06:38:51:

: Direct X .....
: Linked List Programming sample please....

Linked lists are no different in DirectX than in "normal" programming,
so I don't see what the problem is. Maybe you could clarify
what you mean by this request? (As a side note, using the List
template of the STL is a very good starting point if you're using
C++.)

Follow Ups:

Post a Followup

Name:


IDirect3DRMFrame2::Save()

Posted by Clay on March 17, 1998 at 07:36:51:

Has anyone gotten IDirect3DRMFrame2::Save() to work? I get a not supported error, although the docs mention nothing about it.

Clay

Follow Ups:

  • Re: IDirect3DRMFrame2::Save() Ron Bakker 17:00:35 3/17/98 (2)
    • Re: IDirect3DRMFrame2::Save() menachem 21:29:54 3/17/98 (0)
    • Re: IDirect3DRMFrame2::Save() menachem 21:27:16 3/17/98 (0)

Post a Followup

Name:


Re: Using DirectPlay -- how to specify a PORT

Posted by Jimbo Bob Briggs on March 17, 1998 at 10:07:40:

In Reply to: Using DirectPlay -- how to specify a PORT posted by Derrick Schommer on March 17, 1998 at 04:12:22:

In DX5 you can't specify the port, it is random. I've read that
DX6 will allow this functionality.

Follow Ups:

  • Re: Using DirectPlay -- how to specify a PORT Derrick Schommer 00:51:51 3/18/98 (0)

Post a Followup

Name:


DirectX & Dialogs

Posted by Janne Makela on March 17, 1998 at 15:10:51:

I'm in the process of incorporating normal dialogs to
a program that uses DirectX surfaces. Everything seems
to work just fine. So well actually, that it's making
me suspicious:)

Should I expect anything surprising to happen, and is
there something special to take into consideration
when mixing DirectX and normal windows components?
Will those dialogs work also in full screen mode just
as well?

Hmm... I guess that was all for now. Thanks for all
the potential answers:)

Follow Ups:

  • Re: DirectX & Dialogs Ludovic Tirtiaux 04:53:01 3/18/98 (0)
  • Re: DirectX & Dialogs Greg MacKay 03:43:38 3/18/98 (0)

Post a Followup

Name:


Re: IDirect3DRMFrame2::Save()

Posted by Ron Bakker on March 17, 1998 at 17:00:35:

In Reply to: IDirect3DRMFrame2::Save() posted by Clay on March 17, 1998 at 07:36:51:

: Has anyone gotten IDirect3DRMFrame2::Save() to work? I get a not supported error, although the docs mention nothing about it.
: Clay

It means that it is not implemented yet. Maybe in DirectX6 .. I guess you have to write your own routine like I did. Pick the faces and material (and textures) from a meshbuilder object. Don't forget to add the frame in question to it.

Good luck,
Ron

Follow Ups:

  • Re: IDirect3DRMFrame2::Save() menachem 21:29:54 3/17/98 (0)
  • Re: IDirect3DRMFrame2::Save() menachem 21:27:16 3/17/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Denny on March 17, 1998 at 18:13:25:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Harold on January 18, 1998 at 20:37:49:

: : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Shawn Salerno 16:28:32 6/12/98 (1)
    • Re: Where Can I download DirectX 5.0 Alan Cohen 17:16:52 7/15/98 (0)
  • Re: Where Can I download DirectX 5.0 Matthew G. Czarnecki 16:05:27 3/18/98 (2)
    • Re: Where Can I download DirectX 5.0 Kandi nelson 21:52:00 3/18/98 (1)
      • Re: Where Can I download DirectX 5.0 Kandi 21:57:30 3/18/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by derrick paul on March 17, 1998 at 20:23:20:

In Reply to: Re: Where Can I download DirectX 5.0 posted by David Craig-Smith on March 13, 1998 at 10:25:01:

:
: : : : Where Can I download DirectX 5.0. I need it for a game.
: : I kneed it for the Demo of Age Of Empires

Follow Ups:

Post a Followup

Name:


Re: IDirect3DRMFrame2::Save()

Posted by menachem on March 17, 1998 at 21:27:16:

In Reply to: Re: IDirect3DRMFrame2::Save() posted by Ron Bakker on March 17, 1998 at 17:00:35:

: : Has anyone gotten IDirect3DRMFrame2::Save() to work? I get a not supported error, although the docs mention nothing about it.
: : Clay

: It means that it is not implemented yet. Maybe in DirectX6 .. I guess you have to write your own routine like I did. Pick the faces and material (and textures) from a meshbuilder object. Don't forget to add the frame in question to it.

: Good luck,
: Ron

Follow Ups:

Post a Followup

Name:


Re: IDirect3DRMFrame2::Save()

Posted by menachem on March 17, 1998 at 21:29:54:

In Reply to: Re: IDirect3DRMFrame2::Save() posted by Ron Bakker on March 17, 1998 at 17:00:35:

: : Has anyone gotten IDirect3DRMFrame2::Save() to work? I get a not supported error, although the docs mention nothing about it.
: : Clay

: It means that it is not implemented yet. Maybe in DirectX6 .. I guess you have to write your own routine like I did. Pick the faces and material (and textures) from a meshbuilder object. Don't forget to add the frame in question to it.

: Good luck,
: Ron

Follow Ups:

Post a Followup

Name:


Re: Using DirectPlay -- how to specify a PORT

Posted by Derrick Schommer on March 18, 1998 at 00:51:51:

In Reply to: Re: Using DirectPlay -- how to specify a PORT posted by Jimbo Bob Briggs on March 17, 1998 at 10:07:40:

You don't by any chance know how a client "finds" the server then do you? Seems like a good piece of functionality is being missed in version 5.0 then. Hmm

Derrick

: In DX5 you can't specify the port, it is random. I've read that
: DX6 will allow this functionality.

Follow Ups:

Post a Followup

Name:


Re: DirectX & Dialogs

Posted by Greg MacKay on March 18, 1998 at 03:43:38:

In Reply to: DirectX & Dialogs posted by Janne Makela on March 17, 1998 at 15:10:51:

They work for me.
Here is mine:

MessageBox(hwnd, Text, "Program error", MB_ICONWARNING);

Greg

: I'm in the process of incorporating normal dialogs to
: a program that uses DirectX surfaces. Everything seems
: to work just fine. So well actually, that it's making
: me suspicious:)

: Should I expect anything surprising to happen, and is
: there something special to take into consideration
: when mixing DirectX and normal windows components?
: Will those dialogs work also in full screen mode just
: as well?

: Hmm... I guess that was all for now. Thanks for all
: the potential answers:)

Follow Ups:

Post a Followup

Name:


Re: DirectX & Dialogs

Posted by Ludovic Tirtiaux on March 18, 1998 at 04:53:01:

In Reply to: DirectX & Dialogs posted by Janne Makela on March 17, 1998 at 15:10:51:

: Should I expect anything surprising to happen, and is
: there something special to take into consideration
: when mixing DirectX and normal windows components?
: Will those dialogs work also in full screen mode just
: as well?

I use dialogs (for debugging) in full screen mode. It works, but I have to stop flippering as long as they is displayed, to make them readable.
Is there an easy way to use dialogs in full screen mode without flippering problems?
Thanks for any answer.

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 Download

Posted by j.boschert on March 18, 1998 at 09:52:19:

In Reply to: Re: DirectX 5.0 Download posted by Lucas on March 16, 1998 at 08:41:21:

: : : : : can anyone tell me where to download it besides microsoft website?

Follow Ups:

  • Re: DirectX 5.0 Download ddc; 05:22:42 9/11/98 (0)

Post a Followup

Name:


Re: Blitting a Sprite as a Different Color

Posted by Johnny Rotten on March 18, 1998 at 10:15:44:

In Reply to: Blitting a Sprite as a Different Color posted by John Sabean on March 14, 1998 at 11:48:35:

I'm not quite sure how it's done either, but if you find out, could you let us in on it? I thought at first that they were just doing a fancy palette shifting trick, but UO is "paletteless".

Johnny

Follow Ups:

Post a Followup

Name:


Re: PLEASE HELP! ddraw question

Posted by Johnny Rotten on March 18, 1998 at 10:24:11:

In Reply to: PLEASE HELP! ddraw question posted by Romalis on March 13, 1998 at 22:49:52:

: I am creating a 2d graphics game using direct draw.
: I create 2 surfaces, 8bit bmp images,a primary which is
: the background and an Offscreen which is the character.
: I am having trouble since the background's palette is
: different from the character's palette. so when I do
: a bltfast of the character to the primary surface the
: character's colors are all messed up but not the background
: because the direct draw is using the primary surfaces
: palette to draw the character which has a differnet palette.
: I don't want to use 16bit graphics and want to use full
: screen mode. Do you know how I fix this because the artwork is
: bound to have different palettes?
: Thanks to Brian Shea for his suggestion

: thanks in advance :>
: jugg

Jugg,

I'm afraid that if you are using a paletted mode to display your graphics, your going to have to use the same palette for all of your graphics. Windows is trying its damndest to blit your graphic to the nearest color, but with only 256 colors it's just not going to happen. Why wouldn't you want to use 16bit color? The only reason I wouldn't use 16bit color is if I were coding for a slow machine with no graphic acceleration.

Johnny

Follow Ups:

Post a Followup

Name:


D3D in Desktop Window?

Posted by Andre Hinkenjann on March 18, 1998 at 12:07:00:

Hi,
I want some nice 3D models to rotate on my Desktop
window. Is there a clean way to use the root window
to draw into it with D3D?

Andre

Follow Ups:

  • Re: D3D in Desktop Window? Clay 17:55:21 3/18/98 (1)
    • Re: D3D in Desktop Window? Voisin 07:57:23 3/25/98 (0)

Post a Followup

Name:


Alpha Vertices

Posted by Wolfgang R�ssler on March 18, 1998 at 12:46:34:

How do I create Alpha Vertices?
I am using Direct3D Immediate Mode.

Follow Ups:

Post a Followup

Name:


Re: help running DX w/ STB Velocity128

Posted by Joe Drago on March 18, 1998 at 13:15:55:

In Reply to: help running DX w/ STB Velocity128 posted by John J on March 05, 1998 at 02:33:15:

It definitely has to be a driver problem,
and RIVAZONE is a great place to check it out.

I have the Diamond Viper V330, and it works
perfect for me in DirectX.

Follow Ups:

Post a Followup

Name:


You also might want to check out...

Posted by Jay Atkinson on March 18, 1998 at 13:24:50:

In Reply to: My current mad schemes. posted by Ryan Fenton on March 12, 1998 at 16:56:47:

I'm pretty new to Directx and programming games, but I have a decent grasp of Windows programming(win3.1 that is). I have just recently joined up with some friends(hardcore RPG'ers) over the internet who are programming an Online RPG. Talk about ambitious eh?;) I've found these two books to be very helpful:

Programming in Windows95 (Charles Petzold; Microsoft Press). Gives you the ins and outs of Win32 and Threads (big plus).

Spells of Fury. This book is perfect for someone just learning game programming, or going from DOS to Windows programming. It doesn't go in-depth into Windows, but the basic game concepts are extremely helpful. It has sample games that are developed in the book and on the CD that you can fiddle with to your heart's content!! Even though it's done in Directx 2.0, all the directdraw functions should still work in 5.0. This book is just good, some of the stuff you made not need but you will learn something. I don't care what anyone else says:P.

Jay Atkinson

Follow Ups:

  • Hey, thanks, a definite "Will-do!" Ryan Fenton 22:09:23 3/18/98 (1)
    • Re: Hey, thanks, a definite "Will-do!" Johnny Rotten 10:17:38 3/19/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Matthew G. Czarnecki on March 18, 1998 at 16:05:27:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Denny on March 17, 1998 at 18:13:25:

:
: : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Kandi nelson 21:52:00 3/18/98 (1)
    • Re: Where Can I download DirectX 5.0 Kandi 21:57:30 3/18/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 Download

Posted by Dani Llenas (FacOne) on March 18, 1998 at 16:09:59:

In Reply to: DirectX 5.0 Download posted by Mehrab on March 14, 1998 at 15:14:04:

Please, send me DirectX 5. I have the DirectX 2
and this is a poor DirectX.

Thanx!!!

Follow Ups:

  • Re: DirectX 5.0 Download Joe 12:40:16 4/15/98 (0)
  • Re: DirectX 5.0 Download Jorgen olesen 11:39:42 3/31/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Dale on March 18, 1998 at 17:29:20:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

  • Re: Where Can I download DirectX 5.0 bing 18:52:19 3/20/98 (0)

Post a Followup

Name:


Re: D3D in Desktop Window?

Posted by Clay on March 18, 1998 at 17:55:21:

In Reply to: D3D in Desktop Window? posted by Andre Hinkenjann on March 18, 1998 at 12:07:00:

if you do CreateDeviceFromSurface() on the primary surface (no exclusive mode) and don't do any clipping, you can get D3D through DDraw to render anywhere. Neat idea!

Clay

Follow Ups:

  • Re: D3D in Desktop Window? Voisin 07:57:23 3/25/98 (0)

Post a Followup

Name:


Directx driver for opti930 sound card

Posted by Scott on March 18, 1998 at 19:46:24:

I have been looking everywhere for the directx driver
for the opti930 sound card. Opti's download page is
missing the driver. Does anyone know where I can
find it? I would really appreciate any help!

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Kandi nelson on March 18, 1998 at 21:52:00:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Matthew G. Czarnecki on March 18, 1998 at 16:05:27:

: :
: : : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Kandi 21:57:30 3/18/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Kandi on March 18, 1998 at 21:57:30:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Kandi nelson on March 18, 1998 at 21:52:00:

: someone please help i need to download DirectX5 to play a certain game on my computer please HELP ME someone anyone

: : :
: : : : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


Hey, thanks, a definite "Will-do!"

Posted by Ryan Fenton on March 18, 1998 at 22:09:23:

In Reply to: You also might want to check out... posted by Jay Atkinson on March 18, 1998 at 13:24:50:

I've heard quite a bit about that "Spells of Fury" book (although I was not too terribly impressed with the Gardens of Imagination one) I already have a generic Win32 book, but will have to make getting a generic Windows Programming book first priority. Hey, if you'd like to share, I'd be very interested in keeping up to date with a fellow possible RPG developer, and share e-mails about our (ok, perhaps mostly my) lame exploits into the vast nether-regeons of DirectX and other Windows programming aspects! My e-mail is ryanfenton@hotmail.com. Anyway, Thanks for helping out, and good luck in your endevors!

Ryan Fenton

Follow Ups:

  • Re: Hey, thanks, a definite "Will-do!" Johnny Rotten 10:17:38 3/19/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by jlz on March 19, 1998 at 02:39:10:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Harold on January 18, 1998 at 20:37:49:

: : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 asddd 15:56:07 3/22/98 (0)

Post a Followup

Name:


Re: Hey, thanks, a definite "Will-do!"

Posted by Johnny Rotten on March 19, 1998 at 10:17:38:

In Reply to: Hey, thanks, a definite "Will-do!" posted by Ryan Fenton on March 18, 1998 at 22:09:23:

: I've heard quite a bit about that "Spells of Fury" book (although I was not too terribly impressed with the Gardens of Imagination one) I already have a generic Win32 book, but will have to make getting a generic Windows Programming book first priority. Hey, if you'd like to share, I'd be very interested in keeping up to date with a fellow possible RPG developer, and share e-mails about our (ok, perhaps mostly my) lame exploits into the vast nether-regeons of DirectX and other Windows programming aspects! My e-mail is ryanfenton@hotmail.com. Anyway, Thanks for helping out, and good luck in your endevors!

: Ryan Fenton

I'm a hardcore RPG'r as well and interested in doing a little work on the side. E-mail me sometime!

Johnny

Follow Ups:

Post a Followup

Name:


Re: DirectX and MFC.

Posted by if you read this you are gay on March 19, 1998 at 10:40:41:

In Reply to: DirectX and MFC. posted by Joris Timmermans (Mad Keith) on January 20, 1998 at 12:22:40:

you all suck!!!

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by DANIEL POTVIN on March 19, 1998 at 12:10:15:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Harold on January 18, 1998 at 20:37:49:

: : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 jygf 16:31:53 3/24/98 (0)
  • Re: Where Can I download DirectX 5.0 ewrqe3 15:54:26 3/22/98 (0)

Post a Followup

Name:


How do I get the 'C' samples with winmain to compile as win32 projects?

Posted by Ryan Fenton on March 19, 1998 at 12:54:50:

I'm trying to compile the sample progams in C from the DirectX 5.0 SDK under Visual C++ 5.0, and I have followed all the instructions from earier posts to link in libraries, but how do I get VC to recognize these C programs as windows programs, and not keep complaining about _main all the time? I don't want to have to copy each sample to a new project every time I want to fiddle with it, and the link to the FAQ is still broken.

Thanks a ton,

Ryan Fenton

Follow Ups:

  • Re: How do I get the 'C' samples with winmain to compile as win32 projects? Clay 20:20:51 3/19/98 (3)
    • Darn that's just what I was trying to avoid! Oh well. Ryan Fenton 23:45:37 3/19/98 (2)
      • Re: Darn that's just what I was trying to avoid! Oh well. Clay 07:05:01 3/20/98 (1)
        • Thanks, perhaps I should think of compiling something else. Ryan Fenton 12:52:55 3/20/98 (0)

Post a Followup

Name:


Re: How do I get the 'C' samples with winmain to compile as win32 projects?

Posted by Clay on March 19, 1998 at 20:20:51:

In Reply to: How do I get the 'C' samples with winmain to compile as win32 projects? posted by Ryan Fenton on March 19, 1998 at 12:54:50:

This can be tricky, as all of the necessary source files are not always in the same directory. In MSVC 4.0 and better, it is easier to make a new Application (or Win32 Application in 5.0 (I think)) project. Don't make a "console" application: this gets you the _main error. Add all the necessary source files and libraries. If it can't find a header file (usually because it is not in the right directory), copy the header file(s) to the directory containing your new project. Pain in the butt, I know, but at least MS wasn't so presumptuous as to think everybody has MSVC!

'luck!
Clay

Follow Ups:

  • Darn that's just what I was trying to avoid! Oh well. Ryan Fenton 23:45:37 3/19/98 (2)
    • Re: Darn that's just what I was trying to avoid! Oh well. Clay 07:05:01 3/20/98 (1)
      • Thanks, perhaps I should think of compiling something else. Ryan Fenton 12:52:55 3/20/98 (0)

Post a Followup

Name:


Darn that's just what I was trying to avoid! Oh well.

Posted by Ryan Fenton on March 19, 1998 at 23:45:37:

In Reply to: Re: How do I get the 'C' samples with winmain to compile as win32 projects? posted by Clay on March 19, 1998 at 20:20:51:

I really liked the idea of just double clicking on a source file, pressing cntrl-f5, and testing it. Oh well, I'll just have to new...project...win32 application...take the time to uniquely name it...drag file on top...right click and choose import...and then ctrl-f5 every time. I hate that! Say, I wonder if there would be any way of at least automating it...hmm... have to get the name of the c/cpp file, see if it's main or winmain, make a new project with the imported name if it's a winmain, and then work from there...

Ryan Fenton

Follow Ups:

  • Re: Darn that's just what I was trying to avoid! Oh well. Clay 07:05:01 3/20/98 (1)
    • Thanks, perhaps I should think of compiling something else. Ryan Fenton 12:52:55 3/20/98 (0)

Post a Followup

Name:


Re: Darn that's just what I was trying to avoid! Oh well.

Posted by Clay on March 20, 1998 at 07:05:01:

In Reply to: Darn that's just what I was trying to avoid! Oh well. posted by Ryan Fenton on March 19, 1998 at 23:45:37:

If you have more trouble, I'll email you one of the samples I made "compilable". What compiler are you using?

Since you posted about making RPGs, you might want to look at the "Boids" MS sample. Their swarming algorithm looks to be pretty good!

Clay

Follow Ups:

  • Thanks, perhaps I should think of compiling something else. Ryan Fenton 12:52:55 3/20/98 (0)

Post a Followup

Name:


[Help] simple DirectDraw program

Posted by Chendi Zhang on March 20, 1998 at 12:23:36:

I've been programming in watcom and djgpp for several
years now and I'd like to switch to Win32/DDraw for
graphics. Where can I find some code to just switch
into 640x480x8 and draw to a lfb?

TIA
chendi@caam.rice.edu

Follow Ups:

Post a Followup

Name:


Thanks, perhaps I should think of compiling something else.

Posted by Ryan Fenton on March 20, 1998 at 12:52:55:

In Reply to: Re: Darn that's just what I was trying to avoid! Oh well. posted by Clay on March 20, 1998 at 07:05:01:

Thanks for the comilable code offer, but I'm using a different computer than the one I compile with, and it would be just as easy to just do the whole new project thing. As for the Boids sample, I'll have to look at that, but I've just got done downloading about a hundred web pages of various tutorials out there on the web, and hope to just spend the rest of my spring break exploring those (and finishing up homework, of course.) Speaking of compiling, I think it might be a good idea for me to compile all this beginner info into a meta-tutorial for beginners like me, because despite all the fine resourses out there, it's hard to pick out a good path to take to learn all of this game-development stuff outside of the slow give-and-take of newsgroups and random web-page reading. That is, if I can get a good strategy set for myself while frantically searching for internships in something that might help me get on a path to some game-related C.S. job(I don't care if it pays less, I love game creation!) It's all so uncertain & confusing, but fun!

Ryan Fenton

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by bing on March 20, 1998 at 18:52:19:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Dale on March 18, 1998 at 17:29:20:

: : Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


Re: DirectX5

Posted by nuno on March 20, 1998 at 19:11:41:

In Reply to: Re: DirectX5 posted by serge poirier on February 19, 1998 at 22:09:24:

: : I downloaded a demo version of Curse of Monkey Island
: : with DirectX5 download included and it worked fine.
: : I then purchased the game, uninstalled the demo as per
: : instructions but the purchased game freezes my whole
: : system, screen, keyboard, mouse et al. Checking for
: : compatability with DirectX5 indicates there is no hard-
: : ware support for the Primary Display Driver, Primary
: : sound Driver and Sound System Player. Why did the first
: : DirectX5 download work but this one won't and what do I
: : do about the problem?
: : Thank you, any help would be greatly appreciated.
: : Lois Nicholls

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by me on March 20, 1998 at 23:03:48:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


Traversing frame heirakies of animationsets

Posted by Lee Sandberg on March 21, 1998 at 06:50:14:

I have two problems,
1. I can't load two animationset too run simultainlessly. Theres only one animation running...

2. I want to get too know where the animation ends
up in space, that is i would like to use GetChildren() and the Frame array interface to find a nice frame in my loaded animationset to read its x,y and z values using GetPosition.

But, when I can see the animation moving on my screen
GetChildren and GetSize returns 1 or 0 frame children and when I try to read a whit GetPosition the program
crashes....of course. How is it ment that one can
load a animationset and traverse throught its frames?
Where can I find documents on these artcicles, books and explained with examples and stuff? I got most DX books but they run one animationset, ofcourse! And they don't show how to read a animatied characters position at any time frame etc. Which would be the
foundamentals for using animationsets in game developing etc...

well I hope some whan can direct me, thanx, Lee

Follow Ups:

  • Re: Traversing frame heirakies of animationsets Lee Sandberg 10:54:31 3/22/98 (0)

Post a Followup

Name:


Re: D3DRM in fullscreen?

Posted by Sietze on March 21, 1998 at 08:19:12:

In Reply to: D3DRM in fullscreen? posted by Niklas Elmqvist on March 16, 1998 at 14:21:49:

: I have run into some problems when trying to kick
: my D3DRM application into fullscreen mode. I get a
: DDERR_NOEXCLUSIVE error when trying to create a
: D3DRM device, even though I *have* set my cooperative
: levels and updated and shown my main window.
: Earlier, when my application was windowed, I used a
: DirectDrawClipper to create my device, and I still do,
: which I suspect is the source of my problems. Do I
: have to create a DirectDraw surface and then use
: Direct3DRM::CreateDeviceFromSurface instead of
: Direct3DRM::CreateDeviceFromClipper? Or am I doing
: some other silly mistake?

Yes you do.
You have to create the device from the surface. Which brings me to a question: have you defined a complex surface (a front- and back-buffer)? Because if you didn't, you're going to be in a bucketload of trouble when you start using DirectDraw blt's--> they will be blt'ed to the screen, rather than to a back-buffer, which will look very bad (flickering).

Good luck
Sietze

Follow Ups:

Post a Followup

Name:


Re: DirectX Type files for VB

Posted by Sietze on March 21, 1998 at 08:22:22:

In Reply to: DirectX Type files for VB posted by Erik on March 16, 1998 at 11:39:15:

: Can someone please tell me where I can get the DirectX
: type libraries for Visual Basic 5? It would be a great help.
: (ex: Ddraw.tbl)

Go to www.ourworld.com/pscribe. The author of this site has done a LOT of work on integrating DirectX with VB. Beware though: the version I got (0.4) was still a bit buggy.

Good luck
Sietze

Follow Ups:

Post a Followup

Name:


RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!)

Posted by Sietze on March 21, 1998 at 08:47:11:

Hi All!

I'm having trouble using the IDirect3DRMFrame2:: RayPick function. I've seen two messages about it in this NG, but neither solvers the problem. I'll repeat it, because these are fairly old:
Each and every call to RayPick fails and returns D3DRMERR_BADPARAMS or something.
Am I missing something here, are greater forces at work or am I just plain stupid?

TIA
Sietze

Follow Ups:

  • Re: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!) Clay 07:55:51 3/26/98 (2)
    • Re: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!) Sietze 10:45:07 3/30/98 (1)
      • Re: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!) Clay 11:31:20 3/30/98 (0)

Post a Followup

Name:


Retained Mode, MFC and Fullscreen ??

Posted by Michael Lacher on March 21, 1998 at 09:42:32:

Has anyone used the Direct3D Retained Mode Library for
MFC of Bill Wagner, that he posted in the Visual C++ Developers Journal in December '97 ?
I want to change it so that I can use Fullscreen as well as Windowed Mode, but it doesn't really work out. Has anyone tried this also and got it right ?

  • RM Library and sample by Bill Wagner (VCDJ)

Follow Ups:

  • Re: Retained Mode, MFC and Fullscreen ?? Frank Lomabard 13:58:19 3/21/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Edwina on March 21, 1998 at 13:16:18:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an program game.

Follow Ups:

  • Re: Where Can I download DirectX 5.0 hilary king 16:24:22 3/24/98 (0)
  • Re: Where Can I download DirectX 5.0 Jean-Louis 12:27:23 3/22/98 (0)
  • Re: Where Can I download DirectX 5.0 james Bravo 09:02:32 3/22/98 (0)

Post a Followup

Name:


Re: Retained Mode, MFC and Fullscreen ??

Posted by Frank Lomabard on March 21, 1998 at 13:58:19:

In Reply to: Retained Mode, MFC and Fullscreen ?? posted by Michael Lacher on March 21, 1998 at 09:42:32:

: Has anyone used the Direct3D Retained Mode Library for
: MFC of Bill Wagner, that he posted in the Visual C++ Developers Journal in December '97 ?
: I want to change it so that I can use Fullscreen as well as Windowed Mode, but it doesn't really work out. Has anyone tried this also and got it right ?

Inorder to allow for a Windowed Mode you need to set the CooperativeLevel of the DirectDraw surface to Normal. You then need to add resizing code to reestablish the clipper view. If you like I can show you the code to do this just e-mail me.

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by james Bravo on March 22, 1998 at 09:02:32:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Edwina on March 21, 1998 at 13:16:18:

:
: : Where Can I download DirectX 5.0. I need it for an program game.

Follow Ups:

Post a Followup

Name:


Re: Traversing frame heirakies of animationsets

Posted by Lee Sandberg on March 22, 1998 at 10:54:31:

In Reply to: Traversing frame heirakies of animationsets posted by Lee Sandberg on March 21, 1998 at 06:50:14:

: I have two problems,
: 1. I can't load two animationset too run simultainlessly. Theres only one animation running...

:
: 2. I want to get too know where the animation ends
: up in space, that is i would like to use GetChildren() and the Frame array interface to find a nice frame in my loaded animationset to read its x,y and z values using GetPosition.

: But, when I can see the animation moving on my screen
: GetChildren and GetSize returns 1 or 0 frame children and when I try to read a whit GetPosition the program
: crashes....of course. How is it ment that one can
: load a animationset and traverse throught its frames?
: Where can I find documents on these artcicles, books and explained with examples and stuff? I got most DX books but they run one animationset, ofcourse! And they don't show how to read a animatied characters position at any time frame etc. Which would be the
: foundamentals for using animationsets in game developing etc...

: well I hope some whan can direct me, thanx, Lee

Well this is neet, answering my own questions just
a day after.

Well, dear Lee, you are probably trying to load
the same animation twice. And even if you try to
trick DX by making a copy of your .x file with
another name it still doesn't do the job does it?

Well, try this, use two unic animation files,
this worked for me. Probably there is some
identiefiers inside the x file that collides, when
they are the same.

To your secound question, You use GetChildren
and then GetSize, ofcourse you will get 1 from GetSize because the first frame in the animationset only have 1 child, if you use GetChildren again and so you will perhaps get 3 (Head, arm1, arm2). You where probably expecting to get all the frames in the animationset at once
as the children of the animationset first frame, rember that you have to travers thrue the animationsets frames to access all its frames.

Any questions please email me at:
lee@abcmedia.se

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Jean-Louis on March 22, 1998 at 12:27:23:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Edwina on March 21, 1998 at 13:16:18:

:
: : Where Can I download DirectX 5.0. I need it for an program game.

Follow Ups:

Post a Followup

Name:


Re: Symantec C++ 7.5 and DirectX 5

Posted by info on March 22, 1998 at 14:44:17:

In Reply to: Symantec C++ 7.5 and DirectX 5 posted by Dean Kusler on February 25, 1998 at 22:38:47:

: I'm using Symantec C++, and am trying to make a DirectX-based game. When trying to link my project, it gives me an error saying that the DirectX lib files (ddraw.lib, dxguid.lib, etc.) are not valid library files. If anyone knows why this is or knows any way to use DirectX 5 with Symantec C++, please let me know!
: Thanks,
: Dean Kusler

Follow Ups:

Post a Followup

Name:


Performance problem

Posted by Stiba on March 22, 1998 at 15:51:12:

Direct3D loss of performance

I am programming a Decent-styled 3D-Shooter and I have encountered a heavy loss of performance which I can큧 resolve by myself.

******
* ***
* A B
* ***
******

When I look into the room fromposition A I get the maximum frame rate
of 60 fps. When I now move back to position B the frame rate reduces to 30 fps though there are only 8 Triangles more to render (+2%). I tried to turn off clipping and backbuffering but the problem is still there. My execute-buffers are optimized and all Textures are loaded into the HW-Mem. Is it a bug in DirectX-3 or are there special hints to get
rid of this ? This is a very special problem so I would also be glad if someone could give me some general hints to optimize rendering with Direct3D! (I am using 3Dfx as hardware accelerator)

Mail to: ChristophStiba@gmx.de

Thanks in Previous
Christoph

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by ewrqe3 on March 22, 1998 at 15:54:26:

In Reply to: Re: Where Can I download DirectX 5.0 posted by DANIEL POTVIN on March 19, 1998 at 12:10:15:

: : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by asddd on March 22, 1998 at 15:56:07:

In Reply to: Re: Where Can I download DirectX 5.0 posted by jlz on March 19, 1998 at 02:39:10:

: : : Where Can I download DirectX 5.0. I need it for a game

  • directX 5.0

Follow Ups:

Post a Followup

Name:


Help with Vertex Coloring

Posted by Mark Palange on March 22, 1998 at 17:53:57:

Hi,
I've been exploring the features of Direct3DRM and I can't seem to get vertex coloring to work. Here's what I've done:
Setup D3DRM mode using software emulation.
Created a Mesh builder in the shape of a box.
Called SetColorSource(D3DRMCOLOR_FROMVERTEX).
Applied distinct colors to the verts with
SetVertexColor, and SetVertexColorRGB.
When I call get vertex color on any of the verts, I back the color white.

Help!!!
Thanks, Mark

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by pace on March 22, 1998 at 22:37:47:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

  • Re: Where Can I download DirectX 5.0 dean eccles 08:35:01 9/18/98 (0)
  • Re: Where Can I download DirectX 5.0 Christer Johnson 14:03:03 3/23/98 (3)
    • Re: Where Can I download DirectX 5.0 Micheal antez 12:30:30 7/23/98 (0)
    • download DirectX 5.0 Roman Kaykov 21:14:29 7/16/98 (1)
      • Re: download DirectX 5.0 KEBIR 13:40:54 7/29/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Christer Johnson on March 23, 1998 at 14:03:03:

In Reply to: Re: Where Can I download DirectX 5.0 posted by pace on March 22, 1998 at 22:37:47:

:
: : Where Can I download DirectX 5.0. I need it for an emulator.
And for games

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Micheal antez 12:30:30 7/23/98 (0)
  • download DirectX 5.0 Roman Kaykov 21:14:29 7/16/98 (1)
    • Re: download DirectX 5.0 KEBIR 13:40:54 7/29/98 (0)

Post a Followup

Name:


Performance II

Posted by Stiba on March 23, 1998 at 15:09:42:

Loss of Performance

I have an unexplainable high loss of performance
when D3D has overdraw. When two triangles overlay
the frame rate goes down by 50% though it might
be only one overlay triangle in the whole scene!
Does anyone know if D3D (I'm using 3.0) has an
internal clipping or overdraw algorithm which
takes up so much time? I'm also very interested
in any performance hints concering D3D!

Mail to: ChristophStiba@gmx.de

Thanks in previous
Christoph

Follow Ups:

  • Re: Performance II Clay 20:15:13 3/23/98 (0)

Post a Followup

Name:


Re: Performance II

Posted by Clay on March 23, 1998 at 20:15:13:

In Reply to: Performance II posted by Stiba on March 23, 1998 at 15:09:42:

: Loss of Performance

: I have an unexplainable high loss of performance
: when D3D has overdraw. When two triangles overlay
: the frame rate goes down by 50% though it might
: be only one overlay triangle in the whole scene!
: Does anyone know if D3D (I'm using 3.0) has an
: internal clipping or overdraw algorithm which
: takes up so much time? I'm also very interested
: in any performance hints concering D3D!

: Mail to: ChristophStiba@gmx.de

: Thanks in previous
: Christoph

I have this problem, too. I haven't been able to test this on different 3D cards, but it seems that D3D really needs hardware acceleration when rendering overlaid polygons, either that or a powerful CPU. From the DX5.0 SDK docs:

"You can use the fill-rate test in the D3dtest.exe application that is provided with this SDK to demonstrate overdraw performance for a given driver. (The fill-rate test draws four tunnels from front to back or back to front, depending on the setting you choose.)"

I got a significant fps improvement when I rendered a complicated scene and used a simple bounding box algorithm to determine what to render. I also got some improvement by using RM z-buffers. I think that the performance increase for each method is tied to the nature of your scene. Unfortunately, unless you are a whiz at math (and I am not!), experimentation is your best tool. Also, running in exclusive mode helps (if you aren't already!).

good luck!

Clay

Follow Ups:

Post a Followup

Name:


directx5 needed for download

Posted by THOMAS KURT on March 24, 1998 at 09:13:58:

In Reply to: Re: DirectX5 posted by serge poirier on February 19, 1998 at 22:09:24:

: : I downloaded a demo version of Curse of Monkey Island
: : with DirectX5 download included and it worked fine.
: : I then purchased the game, uninstalled the demo as per
: : instructions but the purchased game freezes my whole
: : system, screen, keyboard, mouse et al. Checking for
: : compatability with DirectX5 indicates there is no hard-
: : ware support for the Primary Display Driver, Primary
: : sound Driver and Sound System Player. Why did the first
: : DirectX5 download work but this one won't and what do I
: : do about the problem?
: : Thank you, any help would be greatly appreciated.
: : Lois Nicholls

Follow Ups:

  • Re: directx5 needed for download mohd amri 19:35:30 9/26/98 (0)
  • Re: directx5 needed for download Matthew Broyles 19:22:06 6/11/98 (0)
  • Re: directx5 needed for download Leon Martin 13:48:53 6/06/98 (0)

Post a Followup

Name:


How to rotate a point

Posted by Navin on March 24, 1998 at 09:29:38:

Who knows how to rotate a point in 3d around
any axis in 3d?

Follow Ups:

  • Re: How to rotate a point Mike Hansen 04:34:52 5/09/98 (0)
  • Re: How to rotate a point Navin 06:43:01 3/26/98 (0)
  • Re: How to rotate a point sss 16:10:24 3/24/98 (0)
  • Re: How to rotate a point Serg 16:08:13 3/24/98 (0)

Post a Followup

Name:


Special effects

Posted by Matti Kosunen on March 24, 1998 at 10:23:38:

Anyone know how to create special effect on D3D
immediate mode (DrawPrimitive method).
I would like to create something like glowing ring
(and other things glowing),fire (like in g-police) and
some other things.. .. and how could i calculate if
some dot is visible on screen plane that i could make
a lens flare (and how could i draw it to surface?)

ps. please dont offer me any those microsofts meltdown
examples.. i have them allready (wont even work on my
computer)

Follow Ups:

Post a Followup

Name:


DDEX2 will not compile correctly for me.

Posted by Ryan Fenton on March 24, 1998 at 12:54:06:

I'm going throught the normal tutorials in DX 5.0 with VC 5.0 and follow the directions on this board to link on all the required libraries in from the right directories, and I've gotten the DDEX1 sample with all the garbled front and back buffer switching to compile and run - But now, I'm trying out the DDEX2 sample, and I've included & inserted ddutil.h and added in ddul.cpp, and finally got the thing to link, (and changed no code at all, just added the directories to search when linking and added ddutil.cpp to the project) but the program does nothing except generate a GP fault and quit, while the precompiled progra in the BIN directory works perfectly. I'm going to move onto the next tutorial, but this one really bothers me.

Ryan Fenton

Follow Ups:

Post a Followup

Name:


Re: How to rotate a point

Posted by Serg on March 24, 1998 at 16:08:13:

In Reply to: How to rotate a point posted by Navin on March 24, 1998 at 09:29:38:

: Who knows how to rotate a point in 3d around
: any axis in 3d?
this method ineffective, but i'm using it
(too lazy to optimize)
i appreciate if somebody post link to really fast
method.
i recomend to use ovrl operators for all 3d calculation
(not only ^ - normalized production)

void Point3d::Rot(Point3d Axis, float deg)
{
Point3d Y, X,Z;
float rad = 2*PI*deg/360;
Z = Axis;
Y = Axis^(*this);
X = Y^Z;
!Z;
float zp =(Z*(*this));
(*this) = (*this) - zp*Z;
(*this) = abs(*this)*(cos(rad)*X + sin(rad)*Y);
(*this) = (*this) + zp*Z;
}

Point3d operator^(Point3d &V1, Point3d &V2)
{
float Nx, Ny, Nz;
Nx= V2.z*V1.y - V1.z*V2.y;
Ny= V2.x*V1.z - V1.x*V2.z;
Nz= V1.x*V2.y - V1.y*V2.x;
if (( Nx*Nx + Ny*Ny + Nz*Nz)<= ZERO )return Point3d(0,0,0);
float a =(float)(1./sqrt((double)( Nx*Nx + Ny*Ny + Nz*Nz)));
return Point3d(a*Nx, a*Ny, a*Nz);
};

Serg

Follow Ups:

Post a Followup

Name:


Re: How to rotate a point

Posted by sss on March 24, 1998 at 16:10:24:

In Reply to: How to rotate a point posted by Navin on March 24, 1998 at 09:29:38:

: Who knows how to rotate a point in 3d around
: any axis in 3d?

test

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by hilary king on March 24, 1998 at 16:24:22:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Edwina on March 21, 1998 at 13:16:18:

:
: : Where Can I download DirectX 5.0. I need it for an program game.

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by jygf on March 24, 1998 at 16:31:53:

In Reply to: Re: Where Can I download DirectX 5.0 posted by DANIEL POTVIN on March 19, 1998 at 12:10:15:

: : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


How can i use Rop in Blt

Posted by Carlos on March 24, 1998 at 20:01:57:

Can anybody tell me how can use fx in blt, like Rop?

Thanks

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Igor on March 25, 1998 at 00:12:52:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Harold on January 18, 1998 at 20:37:49:

: : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 C�sar Arce 12:56:58 9/06/98 (0)
  • Re: Where Can I download DirectX 5.0 answer James Kremer 16:16:51 9/04/98 (0)
  • Re: Where Can I download DirectX 5.0 krupesh 06:40:03 9/01/98 (0)
  • Re: Where Can I download DirectX 5.0 lap hing 03:39:32 7/25/98 (0)
  • Re: Where Can I download DirectX 5.0 fernando i barrola 19:46:09 7/10/98 (4)
    • Re: Where Can I download DirectX 5.0 Dan Cedric T. Delima 11:42:31 7/26/98 (0)
    • Re: Where Can I download DirectX 6.0 Josee Oliviero 10:38:35 7/23/98 (2)
      • Re: Where Can I download DirectX 6.0 Nancy Jaggers 15:04:56 9/07/98 (0)
      • Re: Where Can I download DirectX 6.0 zmc 08:15:56 8/30/98 (0)
  • Re: Where Can I download DirectX 5.0 VICTOR HUERTA 10:21:14 7/10/98 (3)
    • Re: Where Can I download DirectX 5.0 Antonio DaSilva 21:50:08 7/10/98 (2)
      • Re: Where Can I download DirectX 5.0 wu z 22:13:19 7/21/98 (1)
        • Re: Where Can I download DirectX 5.0 Susan Johnson 03:02:21 7/28/98 (0)
  • Re: Where Can I download DirectX 5.0 Fauzea 13:04:34 7/09/98 (1)
    • Re: Where Can I download DirectX 5.0 bo 19:52:24 9/07/98 (0)

Post a Followup

Name:


Re: Problem with S3 Trio64V+

Posted by yuekaihui on March 25, 1998 at 00:18:11:

In Reply to: Problem with S3 Trio64V+ posted by Eduardo on January 26, 1998 at 11:38:49:

: I have a problem with my S3 Trio64V+ and Fifa 98.
: Where I can get the S3 Trio64v+'s driver for DirectX 5.0?

Follow Ups:

Post a Followup

Name:


Re: D3D in Desktop Window?

Posted by Voisin on March 25, 1998 at 07:57:23:

In Reply to: Re: D3D in Desktop Window? posted by Clay on March 18, 1998 at 17:55:21:

This chunk of code answer the previous message of Andre. You can draw everything you
want on the desktop with the help of a direct draw surface(created by you earlier) without fucking up the screen.
In fact, it just do one thing: copy the actual screen into your surface. From this point, you can
do everything you want with it. I just made one thing a bit strange: Two Bitblt was needed to correctly copy the "image"
of the desktop window into the direct draw surface. The SelectObject thing just don't work here. Why? I don't know...
Mayby bitblt have some difficulties to handle the DC of a direct draw surface(?) If any of you can help me to understand
please do it! ;)

HDC hdc, memdc, ddrawhdc;
HBITMAP hbit, oldbit;
RECT rectangle;
HWND hDeskwnd = GetDesktopWindow();

//lpBackBuffer is a Direct Draw surface that we will blit on
//the primary surface later...
if(lpBackBuffer->GetDC(&ddrawhdc) == DD_OK)
{
hdc = GetDC(hDeskwnd);
GetClientRect(hDeskwnd,&rectangle);
memdc = CreateCompatibleDC(hdc);
hbit = CreateCompatibleBitmap(hdc, rectangle.right, rectangle.bottom);
oldbit = (HBITMAP) SelectObject(memdc, hbit);
BitBlt(memdc,0,0,rectangle.right, rectangle.bottom,hdc,0, 0,SRCCOPY);
BitBlt(ddrawhdc,0,0,rectangle.right, rectangle.bottom,memdc,0, 0,SRCCOPY);

SelectObject(memdc, oldbit);
ReleaseDC(hDeskwnd,hdc);
DeleteDC(memdc);
lpBackBuffer->ReleaseDC(ddrawhdc);
DeleteObject(hbit);

}

Follow Ups:

Post a Followup

Name:


DirectInput with Keyboard. How do it?

Posted by Heinz, the bard on March 25, 1998 at 11:03:40:

I'm looking for simple samples with basics to use DirectInput and keyboard... but I'm not finding... I need to see something like that that I can learn. Can you tell me something about samples or how to program with DirectInput and Keyboard (first) or some good link?
Thanx,

Heinz, the bard.

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 SDK cannot be downloaded anymore

Posted by Dinh Ba on March 25, 1998 at 11:30:24:

In Reply to: Re: DirectX 5.0 SDK cannot be downloaded anymore posted by John Sabean on March 14, 1998 at 11:51:17:

You can download these files idx5sdk.exe|idx5sdkm.exe|idk5docs.exe|idk5samp.exe at:
http://194.159.240.196/
http://203.183.255.186/
http://202.27.157.254/
http://mdpau02.ozemail.com.au/
http://msvaus.www.conxion.com/

with the same directories "msdownload/directx/5.0/deve
loperdl/"

: : can anyone tell me where to download it besides microsoft website?
: They'll send you a CD for free if you join the
: Direct X beta program. Just send them email
: at directx@microsoft.com

: (I just got my DX 5.2 CD the other day....
: very convinient!)

--------------

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Luis ALberto Urra on March 25, 1998 at 12:50:38:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

  • Re: Where Can I download DirectX 5.0 victor reyes 19:52:08 3/25/98 (0)

Post a Followup

Name:


DirectInput Mouse Sensitivity

Posted by Matt on March 25, 1998 at 16:23:36:

Is there any way of changing the sensitivity of the
mouse w/ DirectInput?

Follow Ups:

  • Re: DirectInput Mouse Sensitivity Brian Shea 09:24:34 3/26/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by victor reyes on March 25, 1998 at 19:52:08:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Luis ALberto Urra on March 25, 1998 at 12:50:38:

:
: : Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


Can't get blt to work

Posted by Rob on March 25, 1998 at 22:46:48:

I thought I had this all figured out. I create a primary surface with one back buffer. Write a dot to the primary, then write a block of ff's to the back buffer. When I flip, it looks alright, except the backbuffer has garbage where I didn't fill it with ff's. OK. So I try to do a blt colorfill. I tried to lock the surface, but nothing changed.

lpPrimary->Unlock(NULL);

DDBLTFX BltFX;
BltFX.dwSize=sizeof(BltFX);
BltFX.dwFillColor=1;

ddreturn = lpBackbuffer->Lock(NULL,&ddsd,0,NULL);

ddreturn = lpBackbuffer->Blt(NULL,NULL,NULL,DDBLT_COLORFILL,&BltFX);
lpBackbuffer->Unlock(NULL);
ddreturn = lpBackbuffer->Lock(NULL,&ddsd,0,NULL);

Thinking that you can't blt to a locked surface, I did it unlocked and it worked once in a row. Since then, my system hangs with the hourglass and eventually gives me a white screen. Can anybody tell what I'm doing wrong?

Follow Ups:

  • Re: Can't get blt to work Rob 22:07:28 3/26/98 (0)
  • Re: Can't get blt to work Brian Shea 09:19:23 3/26/98 (0)

Post a Followup

Name:


Re: How to rotate a point

Posted by Navin on March 26, 1998 at 06:43:01:

In Reply to: How to rotate a point posted by Navin on March 24, 1998 at 09:29:38:

: Who knows how to rotate a point in 3d around
: any axis in 3d?

Here is the answer I found:
'rotate' rotates the point 'vector' around the axis 'Axis'

void rotate(D3DVECTOR Axis, float angle, D3DVECTOR* vector)
{
D3DVECTOR axis = normalize(Axis); // Axis has to be normalized
float ax = vector->x;
float ay = vector->y;
float az = vector->z;

float x = axis.x;
float y = axis.y;
float z = axis.z;

float c = (float)cos(angle);
float s = (float)sin(angle);

float c1 = 1 - c;
float xx = c1 * x * x;
float yy = c1 * y * y;
float zz = c1 * z * z;
float xy = c1 * x * y;
float xz = c1 * x * z;
float yz = c1 * y * z;
float sx = s * x;
float sy = s * y;
float sz = s * z;

vector->x = (xx + c)*ax + (xy + sz)*ay + (xz - sy)*az;
vector->y = (xy - sz)*ax + (yy + c)*ay + (yz + sx)*az;
vector->z = (xz + sy)*ax + (yz - sx)*ay + (zz + c )*az;
}

Follow Ups:

Post a Followup

Name:


Re: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!)

Posted by Clay on March 26, 1998 at 07:55:51:

In Reply to: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!) posted by Sietze on March 21, 1998 at 08:47:11:

: Hi All!

: I'm having trouble using the IDirect3DRMFrame2:: RayPick function. I've seen two messages about it in this NG, but neither solvers the problem. I'll repeat it, because these are fairly old:
: Each and every call to RayPick fails and returns D3DRMERR_BADPARAMS or something.
: Am I missing something here, are greater forces at work or am I just plain stupid?

: TIA
: Sietze

Probably, you are passing bad parameters! ;-> I had a similar problem with IDirect3DRMFrame2::Save(). Seems that the D3D help gives a decent description of what this is supposed to do, but calling it gets you a NOTSUPPORTED error. Looks like they did the help before they implemented the code...You might ask if anyone who has gotten RayPick() to work will send you a code snippet.

Clay

Follow Ups:

  • Re: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!) Sietze 10:45:07 3/30/98 (1)
    • Re: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!) Clay 11:31:20 3/30/98 (0)

Post a Followup

Name:


Re: Can't get blt to work

Posted by Brian Shea on March 26, 1998 at 09:19:23:

In Reply to: Can't get blt to work posted by Rob on March 25, 1998 at 22:46:48:

You do not need to do any of this locking. And,
yes, a blt to a locked surface would either fail
immediately or wait until the surface was unlocked,
if you passed the DDBLT_WAIT flag.

My page has some of my code if you are interested.
Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: DirectInput Mouse Sensitivity

Posted by Brian Shea on March 26, 1998 at 09:24:34:

In Reply to: DirectInput Mouse Sensitivity posted by Matt on March 25, 1998 at 16:23:36:

: Is there any way of changing the sensitivity of the
: mouse w/ DirectInput?

They call it division. ;-) But, seriously, you
can scale the coordinates you receive to make
the mouse behave like you want.

But as far as automatic things go, DirectInput
completely ignores all the windows settings,
like button swapping and sensitivity.

Brian

  • Journals of a DX Junkie

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Leonardo D. Otero on March 26, 1998 at 11:50:55:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

  • Re: Where Can I download DirectX 5.0 MM 17:56:44 3/27/98 (0)
  • Re: Where Can I download DirectX 5.0 PSMD 08:11:13 3/27/98 (0)

Post a Followup

Name:


Re: seeding

Posted by Ryan Geiss on March 26, 1998 at 14:38:06:

In Reply to: seeding posted by Hank Lee on March 14, 1998 at 22:57:40:

Hmmm... just pointing something out... when you use the % operator, it returns the remainder, which in your case will be 0..7, not 1..8. If 8 is your SW direction, and you're never getting 8, that would explain the bias to the NE over many random numbers. You'd have to use rand()%8 + 1. Hope this helps...

Follow Ups:

Post a Followup

Name:


Re: Where is DirectX5.0

Posted by michelle bacque on March 26, 1998 at 20:33:57:

In Reply to: Re: Where is DirectX5.0 posted by Chen Shen on February 08, 1998 at 04:35:56:

:
: : Where can I get DIRECTX5.0? I keep playing Diablo, and it keeps freezing up. I am told from Battlenet chat that directx5.0 may solve this problem. But where can I download the software from???

: :
: : seanachi@nternet.net
: It comes with a lot game CDs.

Follow Ups:

Post a Followup

Name:


Re: Can't get blt to work

Posted by Rob on March 26, 1998 at 22:07:28:

In Reply to: Can't get blt to work posted by Rob on March 25, 1998 at 22:46:48:

OK, I got it to work. Actually, my biggest problem was making sure the blt was finished before continuing by checking for DD_OK.

Now I try to do a bltto the front buffer to clear it, then one to the back buffer to clear it. One after the other. I set DDBLT_WAIT, but it seems my code plows right through as if it got the OK. Doesn't WAIT wait for the blt to finish before returning OK?

Follow Ups:

Post a Followup

Name:


Perhaps a custom blit with an altered transparancy code. (NT)

Posted by Ryan Fenton on March 26, 1998 at 23:55:47:

In Reply to: Blitting a Sprite as a Different Color posted by John Sabean on March 14, 1998 at 11:48:35:

NT

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by PSMD on March 27, 1998 at 08:11:13:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Leonardo D. Otero on March 26, 1998 at 11:50:55:

:
: : Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


Re: Creating Multiple Instances of an Object

Posted by Lee Sandberg on March 27, 1998 at 08:29:49:

In Reply to: Creating Multiple Instances of an Object posted by Bill Torla on February 23, 1998 at 20:01:35:

: Hi,

: I'm loading X files via AnimationSet::Load(), this
: works great. My problem is creating "copies" of an object
: in memory without loading the same data twice. I've
: tried setting my load options to
: 'D3DRMLOAD_INSTANCEBYREFERENCE' & 'D3DRMLOAD_INSTANCEBYCOPYING
: but niether work. What else could I try?

: Thanks! ~Bill T.

Try the function clone, when you get it to
work please email me how you used it...

good luck Lee

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 SDK cannot be downloaded anymore

Posted by Chad on March 27, 1998 at 16:16:09:

In Reply to: DirectX 5.0 SDK cannot be downloaded anymore posted by cObBiE on March 13, 1998 at 15:36:14:

: can anyone tell me where to download it besides microsoft website?

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by MM on March 27, 1998 at 17:56:44:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Leonardo D. Otero on March 26, 1998 at 11:50:55:

:
: : Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Brian Maurer on March 27, 1998 at 17:59:58:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an f 22 Raptor for the Beta Games

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Piyushgiri 11:27:24 7/08/98 (0)

Post a Followup

Name:


uninstallation of DX5

Posted by Chris Tough on March 28, 1998 at 02:51:38:

I am looking for specific instructions on how to fully unistall DX5. The regular way of uninstallations is not effective. please help.

Follow Ups:

  • Re: uninstallation of DX5 Merlin 18:31:02 4/06/98 (0)
  • HOW TO UNISTALL ALL VERSIONS OF DIRECTX Merlin 18:29:22 4/06/98 (0)
  • Re: uninstallation of DX5 Serg 07:16:02 3/28/98 (0)

Post a Followup

Name:


Re: uninstallation of DX5

Posted by Serg on March 28, 1998 at 07:16:02:

In Reply to: uninstallation of DX5 posted by Chris Tough on March 28, 1998 at 02:51:38:

Then i was moving from debug version to regular
i manually removed all dll which i could find.
Try this and after that correct regisrtry.
Good Luck
Serg

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 Download

Posted by Thomas Sah on March 28, 1998 at 10:02:44:

In Reply to: DirectX 5.0 Download posted by Mehrab on March 14, 1998 at 15:14:04:

: : : can anyone tell me where to download it besides microsoft website?

Follow Ups:

Post a Followup

Name:


Transparency in DirectDraw ?!!?? HELP! HELP!

Posted by Martijn Segers on March 28, 1998 at 11:26:30:

i have some problems with making transparent blits.

for example :

I want to blt an explosion partialy transparent to the back-buffer.
Because this explosion becomes increasingly transparent going from
the inside-out.. I can't use normal colorkeying.. because that would
only make 1 color transparent..

I think I have to use the alpha-channel ( suface?) to establish this effect..

I tried it several ways but I don't seem to get it working.....

Does NE1 knows the way how to work with those ALPHA-channels within
DirectDraw or where you can find any info about it...

Thx,

Martijn Segers (The Netherlands)
mas@ecosystems.nl

Follow Ups:

  • Hope this'll help... Sietze 04:48:47 3/31/98 (2)
    • It didn't...(HEEELP!!) Sietze 18:04:10 4/01/98 (1)
      • Re: It didn't...(HEEELP!!) Doc 13:13:12 5/19/98 (0)

Post a Followup

Name:


3D Math Question (Or Am I Just Plain Stupid?)

Posted by Sietze on March 28, 1998 at 18:57:31:

Hi All!

I'm having what appears to be a basic math problem.
Here's the situation in wonderful ASCII (;)):

Viewer
@-----> dvView
/
/ -dvDelta
|_
X
Target

Ok, now this is the problem: imagine this situation in 3D, where dvView is the direction the viewer (@) is facing, and dvDelta is the relative position of the viewer's target (X). How do I calculate the rotation needed (in U- and V-angles ) to make those two angles align, ie to get the viewer to face his/her/its target?
D3DRM has a function that uses this calculation, IDirect3DRMFrame2::LookAt, but I want to interpolate the rotation in a "Slerp"-like fashion, because even scary aliens need time to turn their spaceships around.
Help. Please.

Sietze Dijkstra

Follow Ups:

  • Hope I answered the right question! Clay 18:43:11 3/29/98 (3)
    • Lemme add a note to that Clay 08:01:19 3/30/98 (2)
      • thanks (I also found another way) Sietze 10:37:19 3/30/98 (1)
        • Re: thanks (I also found another way) Clay 11:21:30 3/30/98 (0)

Post a Followup

Name:


Need Direct X!!

Posted by NightFlyer on March 29, 1998 at 10:52:24:

Where can I get direct x?? I need someone to email me

  • The Brickyard (My Site)

Follow Ups:

  • Re: Need Direct X!! Nirvana 20:39:01 4/06/98 (0)

Post a Followup

Name:


Hope I answered the right question!

Posted by Clay on March 29, 1998 at 18:43:11:

In Reply to: 3D Math Question (Or Am I Just Plain Stupid?) posted by Sietze on March 28, 1998 at 18:57:31:

: Ok, now this is the problem: imagine this situation in 3D, where dvView is the direction the viewer (@) is facing, and dvDelta is the relative position of the viewer's target (X). How do I calculate the rotation needed (in U- and V-angles ) to make those two angles align, ie to get the viewer to face his/her/its target?
: D3DRM has a function that uses this calculation, IDirect3DRMFrame2::LookAt, but I want to interpolate the rotation in a "Slerp"-like fashion, because even scary aliens need time to turn their spaceships around.
: Help. Please.

: Sietze Dijkstra

I'm assuming that you've got a universal coordinate system such that both your viewer and the target have a unique position...
D3DVECTOR SteerViewToTarget
(
// maximum turning velocity
D3DVECTOR vRotationVelocity
// direction your view is facing
D3DVECTOR vViewVect;
// vector from (0,0,0) to your view
D3DVECTOR vViewPosition;
// vector from (0,0,0) to the target
D3DVECTOR vTargPosition;
)
{
D3DVECTOR vViewToTargVect;
D3DVECTOR vTurnVect;

ZeroMemory(&vTurnVect,sizeof(vTurnVect));

// a little pseudocode to save space...
// get a vector from the view to the target
vViewToTargVect = vTargPosition-vViewPosition;
if(vViewToTarg == vViewVect)
{
// were already pointing there!
return(vTurnVect);
}
// we'll make this simple (no pitch or yaw, etc.)
// get the amount to turn in each direction...
vTurnVect.x = (vRotationVelocity.x>vViewToTarg.x) ? vViewToTarg.x : vRotationVelocity.x;

vTurnVect.y = (vRotationVelocity.y>vViewToTarg.y) ? vViewToTarg.y : vRotationVelocity.y;

vTurnVect.z = (vRotationVelocity.z>vViewToTarg.z) ? vViewToTarg.z : vRotationVelocity.z;

// get new direction vector for the view
vTurnVect += vViewVect;

// done
return(vTurnVect);
}

From a cursory inspection, this should get you the desired effect (I think). You might make some adjustments to add pitch, roll, yaw, slip/skid, etc. to add realism!

Clay

Follow Ups:

  • Lemme add a note to that Clay 08:01:19 3/30/98 (2)
    • thanks (I also found another way) Sietze 10:37:19 3/30/98 (1)
      • Re: thanks (I also found another way) Clay 11:21:30 3/30/98 (0)

Post a Followup

Name:


Lemme add a note to that

Posted by Clay on March 30, 1998 at 08:01:19:

In Reply to: Hope I answered the right question! posted by Clay on March 29, 1998 at 18:43:11:

A few notes:

That was a pretty simple algorithm -- you'll probably want to add "mush" to it so that the view accelerates into and out of the turn.

I assumed that the function would be called periodically, so time is not a variable that is used. If you add time to it, you'd probably want to predict where the target will be at the "intercept" time and turn to there. This can lead to preformance problems (particularly on weak FPUs like Cyrixs') so you might make two variants: one with int math and one with float math. Only use the float then the fractions count.

Hope this helps!

Clay

Follow Ups:

  • thanks (I also found another way) Sietze 10:37:19 3/30/98 (1)
    • Re: thanks (I also found another way) Clay 11:21:30 3/30/98 (0)

Post a Followup

Name:


Direct Play and Visual Studio.

Posted by Greg on March 30, 1998 at 08:03:49:

Hello.
I have a big problem with directPlay and Visual C++ 5.0
(under NT4).

With DirectPlayEnumerate, I use a Callback function
BOOL PASCAL Myfunc .... and all is right.
And with EnumSessions I use also a Callback Function like
the other but te compiler says :
error C2664: 'EnumSessions' : cannot convert parameter 3 from 'int (DPSESSIONDESC *,void *,unsigned short *,unsigned long)' to 'int (__stdcall *)(DPSESSIONDESC *,void *,unsigned long *,unsigned long)'

HELP!!!

GREG

Follow Ups:

Post a Followup

Name:


thanks (I also found another way)

Posted by Sietze on March 30, 1998 at 10:37:19:

In Reply to: Lemme add a note to that posted by Clay on March 30, 1998 at 08:01:19:

Thanks for the info. In the last few days I did some additional meddling, and came up with a variation on the same: Let each 'scary alien' have its own 'targeting frame'. Use a LookAt to point it at you (or any other 'friendly' target). Get both their dvDir's, interpolate between them and presto! You have a neat vector with the needed YPR, which you can then round to the specific maximums you require. Using vector-rotates instead of AddRotation, the scary alien goes exactly where you want it to go. Adding inertia was a breeze: slow down when you're turning and add thrust when you're below top speed. (Later I saw the same code show up in M$'s 'bees'-sample, so I guess it's right. Or shouldn't I? >:))

bye
Sietze

Follow Ups:

  • Re: thanks (I also found another way) Clay 11:21:30 3/30/98 (0)

Post a Followup

Name:


Re: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!)

Posted by Sietze on March 30, 1998 at 10:45:07:

In Reply to: Re: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!) posted by Clay on March 26, 1998 at 07:55:51:

Well, I now have several snippets from several _different_ NG's, none of which actually work. I also have more info on my problem: It seems that it has something to do with the Frame2 vs. Frame differences. The grim fact is that I'm using a LOT of callbacks, and the DIRECT3DRMMOVE2CALLBACK (or something), which is mentioned in the AddMoveCallback2 docs, and which is supposedly the only way to _safely_ pass a Frame2 to a callback, DOESN'T EXIST!!! AAAHR! Do you happen to now another way to pass a Frame2 to a callback, without having to resort to globals? (I can't use globals in this particulsr case, because it's dealing with dynamic structures (laser beams).

TIA,
Sietze

Follow Ups:

  • Re: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!) Clay 11:31:20 3/30/98 (0)

Post a Followup

Name:


Re: thanks (I also found another way)

Posted by Clay on March 30, 1998 at 11:21:30:

In Reply to: thanks (I also found another way) posted by Sietze on March 30, 1998 at 10:37:19:

: Thanks for the info. In the last few days I did some additional meddling, and came up with a variation on the same: Let each 'scary alien' have its own 'targeting frame'. Use a LookAt to point it at you (or any other 'friendly' target). Get both their dvDir's, interpolate between them and presto! You have a neat vector with the needed YPR, which you can then round to the specific maximums you require. Using vector-rotates instead of AddRotation, the scary alien goes exactly where you want it to go. Adding inertia was a breeze: slow down when you're turning and add thrust when you're below top speed. (Later I saw the same code show up in M$'s 'bees'-sample, so I guess it's right. Or shouldn't I? >:))

: bye
: Sietze

Cool. MS does come up with some pretty good algorithms. Speaking of, if you want a good swarming alg. (I posted this before, but you may not have seen it) look in the "boids" DX SDK sample.

Clay

Follow Ups:

Post a Followup

Name:


Re: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!)

Posted by Clay on March 30, 1998 at 11:31:20:

In Reply to: Re: RayPick (AAAAAAAAAAAAAAAAAAAAAAAAAAAAA!) posted by Sietze on March 30, 1998 at 10:45:07:

This is a pretty cheesy way to do it, but have you tried using IDirect3DRMFrame::AddMoveCallback() and QueryInterface for IID_IDirect3DRMFrame2 inside the callback?

Clay

Follow Ups:

Post a Followup

Name:


i can not hear my music back!!!!!!!

Posted by wilson suarez on March 30, 1998 at 11:31:27:

I installed the diectx 3.0 from a cd that i got from
a Pc Gamer magazine, but my moden and sound card stop
working, i empty the files win.ini and system.ini and
others things, but i didn't help, could you help me plese?

Wilson Suarez

Follow Ups:

Post a Followup

Name:


Re: How to switch between two Hardwareaccelators

Posted by Mark E. Stanley on March 30, 1998 at 22:41:30:

In Reply to: Re: How to switch between two Hardwareaccelators posted by Brian Shea on January 27, 1998 at 08:57:16:

I just went through the Hello World sample
included with the DirectX 5.0 CD and the
tutorial enumerates the drivers and talks
about the Globally Unique Identifier (GUID)
for each video card.

Mark

: : I have a matrox mystique and a 3dfx card.
: : I just want to know, which changes I have
: : to make in the hello world example of the
: : d3drm tutorial that it works in 3dfx fullscreen
: : mode.

: You have to enumerate the drivers and let the
: user pick which one they would like to use.
: I have not written code to do this, but I am
: sure someone on the DX mailing list has.

: Brian

: BTW, you can join the mailing list via:
: http://www.angelic-coders.com/

Follow Ups:

Post a Followup

Name:


Hope this'll help...

Posted by Sietze on March 31, 1998 at 04:48:47:

In Reply to: Transparency in DirectDraw ?!!?? HELP! HELP! posted by Martijn Segers on March 28, 1998 at 11:26:30:

:
: i have some problems with making transparent blits.

: for example :

: I want to blt an explosion partialy transparent to the back-buffer.
: Because this explosion becomes increasingly transparent going from
: the inside-out.. I can't use normal colorkeying.. because that would
: only make 1 color transparent..

: I think I have to use the alpha-channel ( suface?) to establish this effect..
:
: I tried it several ways but I don't seem to get it working.....

: Does NE1 knows the way how to work with those ALPHA-channels within
: DirectDraw or where you can find any info about it...

: Thx,

: Martijn Segers (The Netherlands)
: mas@ecosystems.nl

I do know a possible solution, if i'm correct in
the assumption you're using DirectX...
Ok, here goes (this only works if you aready using
a Direct3D device):
If you're already using Direct3D Retained Mode, this
should work.
-Make two subframes of the scene, and call them
OpaqueWorld and TransWorld
-Add all objects you want to be Alpha-transparent
to the TransWorld frame and all the others to the
OpaqueWorld frame.
-Use GetDirect3DDevice2 to obtain a Direct3D Immediate
Mode 2 device.
-Inside the rendering loop, render both 'world' frames
_seperately_, and put the TransOn() and TransOff()
functions shown below around the rendering of
TransWorld.
-Done. All objects added to TransWorld will appear
translucent just the way you want it.

Here are the two functions. They have been snipped
from actual working code. If you are using C++
instead of C, remove the ->lpVtbl's and the first
parameter from each function call:

//sceneparams.d3ddev=Direct3D Immediate Mode Device

BOOL TransOn()
{
sceneparams.d3ddev->lpVtbl->SetRenderState(sceneparams.d3ddev,
D3DRENDERSTATE_ALPHABLENDENABLE,TRUE);
sceneparams.d3ddev->lpVtbl->SetRenderState(sceneparams.d3ddev,
D3DRENDERSTATE_SRCBLEND,D3DBLEND_SRCALPHA);
sceneparams.d3ddev->lpVtbl->SetRenderState(sceneparams.d3ddev,
D3DRENDERSTATE_DESTBLEND,D3DBLEND_ONE);
sceneparams.d3ddev->lpVtbl->SetRenderState(sceneparams.d3ddev,
D3DRENDERSTATE_ZWRITEENABLE,FALSE);
return TRUE;
}

BOOL TransOff()
{
sceneparams.d3ddev->lpVtbl->SetRenderState(sceneparams.d3ddev,
D3DRENDERSTATE_ALPHABLENDENABLE,FALSE);
sceneparams.d3ddev->lpVtbl->SetRenderState(sceneparams.d3ddev,
D3DRENDERSTATE_SRCBLEND,D3DBLEND_ONE);
sceneparams.d3ddev->lpVtbl->SetRenderState(sceneparams.d3ddev,
D3DRENDERSTATE_DESTBLEND,D3DBLEND_ZERO);
sceneparams.d3ddev->lpVtbl->SetRenderState(sceneparams.d3ddev,
D3DRENDERSTATE_ZWRITEENABLE,TRUE);
return TRUE;
}

Goodbye and good luck,

Sietze Dijkstra
The Netherlands
sietze@jaytown.com

Follow Ups:

  • It didn't...(HEEELP!!) Sietze 18:04:10 4/01/98 (1)
    • Re: It didn't...(HEEELP!!) Doc 13:13:12 5/19/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 Download

Posted by Jorgen olesen on March 31, 1998 at 11:39:42:

In Reply to: Re: DirectX 5.0 Download posted by Dani Llenas (FacOne) on March 18, 1998 at 16:09:59:

: Please, send me DirectX 5. I have the DirectX 2
: and this is a poor DirectX.

: Thanx!!!

Follow Ups:

Post a Followup

Name:


system lockup on alt-tab when renderer video

Posted by Ben Simanek on March 31, 1998 at 17:22:22:

When I using the Graph Editor to render video from a capture video source, as the video is running, if I alt-tab to another app, my computer locks up and I have to reset. This also happens in the AMCAP sample. Is there a fix?

Follow Ups:

Post a Followup

Name:


HW Blitting FIFO

Posted by dmitry sychov on April 01, 1998 at 10:21:32:

errors expected...
H!.
Does anyone know if there is a key in
DirectX to catch an event when HW FIFO
blitting is empty
Or i see no way to do small (32*32)
blitting operations in
parallel with the main prossessor because
FIFO is *TOO* small
on S3 VIRGE DX,ET6000 -only 2 bitmaps!!!
BltBatch is not emplemented but i almost sure
that it will take all main prossessor time(when it finally
will be implemented in DX7 i suppose)
i have no way to do time checking in my program
if i can be able to set up some int timer to
genetate interrupt every 1000ticks...
Thanks in advance.
Dima

Follow Ups:

Post a Followup

Name:


Dialog Boxes/User Input

Posted by Johnny Rotten on April 01, 1998 at 11:56:34:

This probably isn't a directx question, but this is the only board I know of that get's great responses.

I'm having problems displaying dialog boxes in exclusive window mode. I'm trying to either bring up a text field so that a user can type a file name, or bring up a directory listing so that they can select the file. I think everything's entered correctly, but the dialog box just never appears. I think it may just be that I'm not posting the dialog message correctly? Can someone tell me of an example or show me an example that does this? Are there other ways of getting a file name from a user?

Thanks,

Johnny

Follow Ups:

  • Re: Dialog Boxes/User Input Brian Shea 02:12:49 4/02/98 (3)
    • Dialog Boxes shouldn't be this hard Johnny Rotten 12:33:12 4/02/98 (2)
      • Re: Dialog Boxes shouldn't be this hard Brian Shea 01:27:13 4/04/98 (1)
        • Pseudo Dialog Boxes Johnny Rotten 10:23:10 4/06/98 (0)

Post a Followup

Name:


It didn't...(HEEELP!!)

Posted by Sietze on April 01, 1998 at 18:04:10:

In Reply to: Hope this'll help... posted by Sietze on March 31, 1998 at 04:48:47:

--SNIP!--

In the previous post I provided a possible solution
for Martijn's problem, but he was talking about
2D- and not 'decal-style'-blits. Now I *HOPED* that
would be not much of a problem in a 3D-scene, until
I started working on lensflares. I dug up some
lensflare-code, and guess what? It used 2D-blits.
I then started looking in the docs, where I learned
that, OH HELL, transparent (alpha-blended) blitting
is not supported yet. Xcuse me? Where do all my
alpha blended decals come from? What does the
Direct3D execute buffer do that I'm not supposed or
allowed to do? Anyone?

Sietze Dijkstra
sietze@jaytown.com

Follow Ups:

  • Re: It didn't...(HEEELP!!) Doc 13:13:12 5/19/98 (0)

Post a Followup

Name:


Re: Dialog Boxes/User Input

Posted by Brian Shea on April 02, 1998 at 02:12:49:

In Reply to: Dialog Boxes/User Input posted by Johnny Rotten on April 01, 1998 at 11:56:34:

: I'm having problems displaying dialog boxes
: in exclusive window mode. I'm trying to either
: bring up a text field so that a user can type
: a file name, or bring up a directory listing
: so that they can select the file.

Well, first thing would be to try your dialog
function without doing any of the DirectX stuff.
Then you can tell whether the problem is your
dialog code or with the interaction with DirectX.

If you find that the dialog works, then you want
to check your DX code to make sure that you flip
to the GDI surface before opening up the dialog
and that you do not do any flips until the dialog
is finished. Look up FlipToGDISurface().

Brian

  • Journals of a DirectX Junkie

Follow Ups:

  • Dialog Boxes shouldn't be this hard Johnny Rotten 12:33:12 4/02/98 (2)
    • Re: Dialog Boxes shouldn't be this hard Brian Shea 01:27:13 4/04/98 (1)
      • Pseudo Dialog Boxes Johnny Rotten 10:23:10 4/06/98 (0)

Post a Followup

Name:


How to write in DRM

Posted by Navin on April 02, 1998 at 05:39:54:

How can I get a String (e.g. CString) to be
seen in a scene created with DRM ?

Follow Ups:

  • Re: How to write in DRM Sietze 07:40:22 4/02/98 (0)

Post a Followup

Name:


Re: How to write in DRM

Posted by Sietze on April 02, 1998 at 07:40:22:

In Reply to: How to write in DRM posted by Navin on April 02, 1998 at 05:39:54:

: How can I get a String (e.g. CString) to be
: seen in a scene created with DRM ?

All you have to do is obtain a Device Context handle to
the DirectDraw surface used as the target for your
Retained Mode device. In rmmain.cpp, somewhere, I
believe in the EnumDevices() function, a DirectDraw
surface is created. Store this surface in, eg,
myglobs.lpDDS, and then you can use IDirectDrawSurface->
GetDC to get a DC pointer. You can then use Win32's
TextOut to write strings to you RM scene. (NOTE:
DirectDraw itself doesn't have string functionality).

Good luck!

Sietze Dijkstra
sietze@jaytown.com

Follow Ups:

Post a Followup

Name:


ARGH !!!! DIRECT SOUND 3D HATE ME !!!

Posted by dANIEL on April 02, 1998 at 11:54:16:

I can't set the listener position !! WHY ?!
The return of IDirectSound3DListener::SetPosition is
DS_OK.
I made this:
- DirectSoundCreate
- SetCooperativeLevel
- CreateSoundBuffer (DSBCAPS_PRIMARYBUFFER |DSBCAPS_CTRL3 )
- SetFormat
- QueryInterface (IID_IDirectSound3DListener)

I'm working with WATCOM C/C++ 11
Please call me, mail me, send me some code !!

Follow Ups:

Post a Followup

Name:


Collision Detection in Direct3D RM

Posted by Christian Rahmen on April 02, 1998 at 12:28:48:

Hi there,
(excuse the mistakes in spelling, cause I'm from germany ;-) )
I've got a problem with Direct3D (Direct X 5.0) Retained Mode :

Everything is set up an working. I have a nice little
3D-world with some objects, camera, viewport, lights etc. .
I'm planning to program a Quake like game. Everything is now
looking fine, but now I want to add gravity and with that collision
detection with walls and floors.
One possibility would be to make one variable that stores the current
Y-Position of the floor, but that'll get very difficult, when dealing
with non plain faces (for example hills).
Is there any function in Direct3D Retained mode to which I can
pass the x,y and z coords and get a true if there is a face/mesh
at this position and a false if there is no face/mesh ?

Please help me... thanks Chris
Christian_Rahmen@compuserve.com

Follow Ups:

  • Re: Collision Detection in Direct3D RM Paulo Brasko 00:09:03 4/04/98 (1)
    • Re: Collision Detection in Direct3D RM Marco Pesce 02:07:44 4/09/98 (0)

Post a Followup

Name:


Dialog Boxes shouldn't be this hard

Posted by Johnny Rotten on April 02, 1998 at 12:33:12:

In Reply to: Re: Dialog Boxes/User Input posted by Brian Shea on April 02, 1998 at 02:12:49:

: Well, first thing would be to try your dialog
: function without doing any of the DirectX stuff.
: Then you can tell whether the problem is your
: dialog code or with the interaction with DirectX.

: If you find that the dialog works, then you want
: to check your DX code to make sure that you flip
: to the GDI surface before opening up the dialog
: and that you do not do any flips until the dialog
: is finished. Look up FlipToGDISurface().

: Brian

I'm getting my Dialog Box displayed on the screen now, but it's not showing the actual contents of the box, rather part of the desktop from whatever is on my windows screen is showing through.

Instead of using Dialog Boxes, how can I just get the user to type in the name of a file? Whatever happened to good ol' scanf ("%20s", &input);?

All of the books I have use Dialog Boxes for text input. I don't want to use them because they will make my game look like Windows.

Please fatten my brain.

Johnny

Follow Ups:

  • Re: Dialog Boxes shouldn't be this hard Brian Shea 01:27:13 4/04/98 (1)
    • Pseudo Dialog Boxes Johnny Rotten 10:23:10 4/06/98 (0)

Post a Followup

Name:


Shadows

Posted by CodeX on April 02, 1998 at 20:56:53:

I have a Immedate-Mode object and want a shadow on a plane. How can I do this?

Thanx

Wolfgang "CodeX" R�ssler

Follow Ups:

Post a Followup

Name:


Compress wave files with directsound

Posted by Clinckart Stephane on April 03, 1998 at 04:17:10:

Hello,

How can i play/record compressed wav files and/or mpeg 2-3 files with directsound???

Thank you very much...

Stephane

Follow Ups:

  • Re: Compress wave files with directsound Richard Kvalsvik ( TJ/Crusaders ) 06:53:30 4/22/98 (1)
    • Re: Compress wave files with directsound Noel Carlos 12:23:51 5/07/98 (0)

Post a Followup

Name:


DirectX algorithm help needed.

Posted by Konstantin Koton on April 03, 1998 at 23:46:02:

Hello. I'm new to this board and to DirectX. I started
meddling with DirectDraw and DirectInput and I decided
to create a game with my friend entirely in C++ and
DirectX5. Now I would like some help with things from
time to time. The main questions right now would be:
1) I would like the game to be sycronized on all
computers, so that it would run at the same speed.
We did a bit of a hack by using his computer and FPS
rate as a reference and then multiplying by a contant
to get a constant speed at any computer (Faster
computers have less acceleration). But this is
unprofessional. How would I solve it using a timer
or any other available resources?
2) We also intend to make it a DirectPlay game. How
would we sycronize it between the different systems
over the network? (Modem, Cable, Internet, IPX/SPX
etc...)

Thank you all in advance.
Goodbye. (Untill I have more serious questions) ;)

Follow Ups:

  • Re: DirectPlay - god bless MS :) Shai'tan 19:01:07 4/04/98 (0)

Post a Followup

Name:


Re: Collision Detection in Direct3D RM

Posted by Paulo Brasko on April 04, 1998 at 00:09:03:

In Reply to: Collision Detection in Direct3D RM posted by Christian Rahmen on April 02, 1998 at 12:28:48:

Chris:

Please let me also have any comments you get from your question about collision detection and gravity.

Best Regards

Paulo Brasko
brasko@utkux.utk.edu

Follow Ups:

  • Re: Collision Detection in Direct3D RM Marco Pesce 02:07:44 4/09/98 (0)

Post a Followup

Name:


Here is a site you can download DirectX 5.0 end-user release

Posted by Paulo Brasko Ferreira on April 04, 1998 at 01:00:32:

For playing games that need DirectX 5.0.

Download DirectX 5.0 end-user release at
http://avault.com/hardware/directx.asp

good luck in your game ...

Brasko

Follow Ups:

  • Re: Here is a site you can download DirectX 5.0 end-user release JOE 22:19:53 4/05/98 (0)
  • Re: Here is a site you can download DirectX 5.0 end-user release Joost Brouwer 05:37:44 4/04/98 (2)
    • Re: Here is a site you can download DirectX 5.0 end-user release nusius 16:38:08 5/31/98 (0)
    • Re: Here is a site you can download DirectX 5.0 end-user release chet horne 09:02:08 4/09/98 (0)

Post a Followup

Name:


Re: Dialog Boxes shouldn't be this hard

Posted by Brian Shea on April 04, 1998 at 01:27:13:

In Reply to: Dialog Boxes shouldn't be this hard posted by Johnny Rotten on April 02, 1998 at 12:33:12:

Well, just use the windows WM_KEYDOWN messages
and keep adding whatever they type into a buffer.
When the finish (hit return, mouse click, etc),
you now have a string. Of course, you now have
to draw each letter they type onto the screen,
but you can use the GDI to do this if you want.

  • Journals of a DirectX Junkie

Follow Ups:

  • Pseudo Dialog Boxes Johnny Rotten 10:23:10 4/06/98 (0)

Post a Followup

Name:


Re: Here is a site you can download DirectX 5.0 end-user release

Posted by Joost Brouwer on April 04, 1998 at 05:37:44:

In Reply to: Here is a site you can download DirectX 5.0 end-user release posted by Paulo Brasko Ferreira on April 04, 1998 at 01:00:32:

: For playing games that need DirectX 5.0.

: Download DirectX 5.0 end-user release at
: http://avault.com/hardware/directx.asp

: good luck in your game ...

: Brasko

Follow Ups:

  • Re: Here is a site you can download DirectX 5.0 end-user release nusius 16:38:08 5/31/98 (0)
  • Re: Here is a site you can download DirectX 5.0 end-user release chet horne 09:02:08 4/09/98 (0)

Post a Followup

Name:


D3DRM Texturing!!

Posted by Shai'tan on April 04, 1998 at 06:42:24:

I make a Mesh interface using the MeshBuilder2->CreateMesh thingo, and I tried putting a texture on the MeshBuilder, but the texture does not carry through to the Mesh created by CreateMesh. So how do I texture a simple LPDIRECT3DRMMESH interface? Using AddGroup and then SetGroupTexture I assume....but HOW??? AddGroup is screwing me around...please help!

Follow Ups:

  • Re: D3DRM Texturing!! Jason 23:30:42 4/16/98 (1)
    • Re: D3DRM Texturing!! Lou 09:26:00 5/16/98 (0)

Post a Followup

Name:


3DFXV2 problem

Posted by Clay on April 04, 1998 at 10:16:20:

I'm writing a simple D3D app for 3DFXV2, and I keep getting a page fault in D3DRM.DLL when I try CreateDeviceFromSurface(). Here's my stuff:

I enumerate the DDraw devices and save the 3DFXV2 GUID, then I create all my DDraw stuff (surfaces, etc. from the 3DFXV2 GUID). Finally, I enumerate the D3D drivers and save the HAL GUID. I create a couple of frames and then, when I try CreateDeviceFromSurface with the HAL GUID, I get the aforementioned exception.

Any suggestions?

Clay

Follow Ups:

  • Re: 3DFXV2 problem - nasty exceptions..... Shai'tan 18:53:34 4/04/98 (0)

Post a Followup

Name:


DX SDK!!!

Posted by The Gilb on April 04, 1998 at 11:26:14:

Where in the hell can I download the DirectX SDK???

I have looked all around the MS site, but I cannot find it _anywhere_!!!

I was wondering if there is a mirror site that has the SDK on it or something...

PLEASE PLEASE PLEASE HELP ME!!!

  • My homepage...

Follow Ups:

  • Re: DX SDK!!! Brian P. Shea 19:35:44 4/04/98 (1)
    • The SDK... The Gilb 10:27:22 4/05/98 (0)

Post a Followup

Name:


Transparent blt:ing

Posted by Andr�as K�hne on April 04, 1998 at 12:50:38:

I know that this has already been in this forum, but I have a slightly different question:

I want to create a see-through dialog box class for a game that I am righting in DirectX. I would like the dialog box to have a green background. This can be created by and:ing every pixel with the value 0x07E0 (which is the green part of the pixel value). I have created a routine that does this, but I think that DirectX should be able to do this for me. Also I would like it to be done without Hardware (alpha-blending).

Follow Ups:

  • Re: Transparent blt:ing Selvakumar 23:26:08 6/22/98 (0)
  • Re: Transparent blt:ing Roger 20:04:22 4/09/98 (0)

Post a Followup

Name:


Re: 3DFXV2 problem - nasty exceptions.....

Posted by Shai'tan on April 04, 1998 at 18:53:34:

In Reply to: 3DFXV2 problem posted by Clay on April 04, 1998 at 10:16:20:

Don't know if this helps any - but I find that the COM interface is legendary for spitting out exceptions. You just have to check the parameters OVER and OVER and make sure you ->Release() any temp surfaces etc. Are you using the IDirect3dRM2 interface or IDirect3DRM? It may make a difference.
As ugly and often incorrect as the docs are, they may help... :)

Follow Ups:

Post a Followup

Name:


Re: DirectPlay - god bless MS :)

Posted by Shai'tan on April 04, 1998 at 19:01:07:

In Reply to: DirectX algorithm help needed. posted by Konstantin Koton on April 03, 1998 at 23:46:02:

I think you'll find a lot of the sync stuff is already coded into DirectPlay. I don't know for sure - but DirectPlay is certainly a very cool thing.....almost takes all the fun out of networking! Hehe....
Nah, seriously, using DirectPlay and a client/server model you can simply set up the server to take care of all client decisions, and then broadcast the new client states to the Players. If a client wants to move the client stores it in a variable and then passes it onto the server which should process it in some sort of Server() loop. Then the server sends back the new client state and the Player updates his game and refreshes the view etc etc. I think this takes care of alot of the sync problem.

You have two options: one, you make the server WAIT for ALL clients to 'send in' their client state for processing, thereby making the game the same speed for everyone. Ie, the speed of the slowest player...which is pretty dumb. Cause that is like 'Lag-Heaven'.
OR you can simply process the client information AS it is sent in, and then send it back as soon as possible. Thereby every player runs at an independent speed depending upon the speed of their connection to the server.

Well, hope that helped. For the details of coding it, I suggest you check out the rather cool docs that come with the SDK...just read the DirectPlay section.. :)

Follow Ups:

Post a Followup

Name:


Re: DX SDK!!!

Posted by Brian P. Shea on April 04, 1998 at 19:35:44:

In Reply to: DX SDK!!! posted by The Gilb on April 04, 1998 at 11:26:14:

You have to ask them to send you a CD, you can
no longer download the SDK. It should be on
the DirectX page somewhere.

Here is the root of the DirectX section:
http://www.microsoft.com/directx/default.asp

  • Journals of a DX Junkie

Follow Ups:

  • The SDK... The Gilb 10:27:22 4/05/98 (0)

Post a Followup

Name:


Program freezes with DirectDraw

Posted by David Salsman on April 04, 1998 at 20:14:15:

My program so far is pretty basic. I set the display to 640x480x256 color. I do my drawing whenever there's no messages to be processed. I lock the off screen surface, blit a bitmap to it using my own routine, and unlock. Then I flip it to the primary surface. When I run it (from Visual C++ 4) the first time, it seems okay. When I try to run it the second time, it runs for a second or two, and the freezes. I can close down VC and restart it. When I run it a third time, it seems to freeze almost right away. (The bitmap shows up on the screen however.) Can anyone give me some idea what might be wrong? I've run it in windowed mode, and nothing goes wrong.

Thanks for any help!
Dave

Follow Ups:

  • Re: Program freezes with DirectDraw BoxMan 19:56:27 4/15/98 (0)

Post a Followup

Name:


Re: About DDER_NOEXCLUSIVE

Posted by David Salsman on April 04, 1998 at 21:40:14:

In Reply to: About DDER_NOEXCLUSIVE posted by Chen Shen on February 08, 1998 at 02:29:31:

: I've set the DirectDraw object to be exclusive
: using setcooperativelevel() but when I'm going to create a surface I've got this error.
: Why?
: Thanks for your message
: Chen Shen

I had the same problem. If you set the cooperative level again AFTER you change the display mode then it seems to work when you create the primary surface. If anyone knows if this is the bad way to do it, let me know. It the only way I got it to work. And I found I only needed to do it if I was changing the color depth to something other than what the computer's settings were currently at. I know some people who don't have to do this at all, however.

Follow Ups:

Post a Followup

Name:


MSVC++ 5.0 / Direct X...Im new..please help me.

Posted by AIR_TIME on April 05, 1998 at 01:28:57:

I use MSVC++ 5.0, and I am pretty good with C++ and MFC, but I want to learn game programming..so I bought
"The Awesome Power of Direct3d/DirectX 5"
anyway, this book is good exept it doesnt seem to use MFC or Classes at all..seems like its all in old C code...which I don't like...I am so used to MFC and Visual C++ that this book I got is really hard for me to figure out.

Is there any way to create games using MFC? would I use Appwizard? if so what would I create?..Dialog?..then make it fullscreen with no borders?? is this how I should do it?..and then use the DirectX functions in my MFC app?

Am I making any sence? is this even possible? if it is, does anyone know of a book or a web page that gives an example of how to make a simple game or something with MSVC++ 5.0 and MFC/DIrect X 5.0

Thanks for any help..I am really clueless on how to program games, I know how to use MFC pretty good and make windows programs with it...but Games..I have no idea..I WANT TO Learn though!

Thanks

Follow Ups:

  • Re: MSVC++ 5.0 / Direct X...Im new..please help me. Serg 16:27:16 4/05/98 (0)
  • Re: MSVC++ 5.0 / Direct X...Im new..please help me. Clay 15:42:21 4/05/98 (5)
    • But the problem with this book is...... AIR_TIME 21:13:39 4/05/98 (4)
      • A little explanation Clay 11:44:35 4/07/98 (3)
        • I got a new book...(Spells of Fury) AIR_TIME 23:28:56 4/07/98 (2)
          • Have you checked out "Windows Programming for Dummies?" Ryan Fenton 19:50:53 4/10/98 (1)
            • No I haven't, and I don't think I will need to. AIR_TIME 02:19:08 4/20/98 (0)
  • Re: MSVC++ 5.0 / Direct X...Im new..please help me. Brian Shea 15:38:09 4/05/98 (0)

Post a Followup

Name:


Direct X Sample question.

Posted by EvAcLeAr on April 05, 1998 at 05:05:58:

Ok after about a month of fooling around with this SDK
I finaly got all the path's in my batch files pointing
to the right areas, and Changed the memory limits of dos
so that i could run it with out recieving that annoying "out
of enviornment space" error, and after overwriting the direct X
3 files that came with VC++ 5.0 with the new Direct X 5 so that I
can compile the samples that came with direct x. I've run in to
another problem. I'm trying to use the FoxBear Demo that came with
direct x to create a simple 2 or 3 level game but I can't edit the
sprites you see they happen to be in this thing called FOXBEAR.ART file.
I know that who ever created the demo used Fastfile to compress all those
bmp files into 1 1.6 meg art file, but when I look threw the source there
does not appear to be any way to extract the files and put them back on to
the hard drive. (Gee wonder who would think that idea up? EvAcLeAr slowly
gazes at Bill Gates). Any way can someone give me a hand, or a foot, I'd even
settle for a finger! I've had so many problems with this SDK I'm beginning
to wonder if it was ever worth the HUGE Download time. Thanks in advance

Follow Ups:

Post a Followup

Name:


Re: DirectX mutes Presario 2120

Posted by EvAcLeAr on April 05, 1998 at 05:14:59:

In Reply to: DirectX mutes Presario 2120 posted by Rey Rito on March 16, 1998 at 00:24:46:

: Everytime I load game softwares (ex: Age of Empires,
: Barney Under the Sea, The Lost World - Jurassic Park,etc.)
: that also contain DirectX, my Presario 2120 becomes mute
: (no more sound, even when using other programs that do
: not use DirectX). I end up spending much time restoring
: my computer's programs to its original settings and
: re-installing other softwares just to bring back the
: sound. Sometimes, I would spend 1 day to back up my old
: files (which would be erased by the Compaq Restore
: program) and re-install the other softwares.

: What should I do to solve this so I could use the game
: softwares with DirectX with sound?

: Also, will the sound come back if I use Norton Uninstall
: to remove softwares with DirectX, assuming the Presario
: 2120 is not compatible with DirectX?

: Thanks in advance for your help.

Ray. Your problem sounds like it could be one of 3 things.
When I was having the same problem It was due to the fact that
my voice modem was interfearing with the sound card. So my first
test would be to go in and disable your voice modem in your hard ware profile in the control panel(if you have a voice modem that is).
The second thing I would try is to download the latest version of directX. Your sound card may not be properly supported in the version you have now.
The third course of action is to call the sound card manufacturer and ask for technical assistance. Compaq has always had good tech support. Hope this helps.

Follow Ups:

Post a Followup

Name:


The SDK...

Posted by The Gilb on April 05, 1998 at 10:27:22:

In Reply to: Re: DX SDK!!! posted by Brian P. Shea on April 04, 1998 at 19:35:44:

Yah, I know about the CD... I live in da UK tho, and I dont want to have to wait for so long!!!

Does n y 1 know of a mirror site or anything that actually has the SDK up for download???

Ta anyway Brian!!! I didnt think that n y 1 was going to reply!!!

Follow Ups:

Post a Followup

Name:


Re: MSVC++ 5.0 / Direct X...Im new..please help me.

Posted by Brian Shea on April 05, 1998 at 15:38:09:

In Reply to: MSVC++ 5.0 / Direct X...Im new..please help me. posted by AIR_TIME on April 05, 1998 at 01:28:57:

I do not use MFC, but try: http://www.dxfc.com

  • Journals of a DirectX Junkie

Follow Ups:

Post a Followup

Name:


Re: MSVC++ 5.0 / Direct X...Im new..please help me.

Posted by Clay on April 05, 1998 at 15:42:21:

In Reply to: MSVC++ 5.0 / Direct X...Im new..please help me. posted by AIR_TIME on April 05, 1998 at 01:28:57:

: I use MSVC++ 5.0, and I am pretty good with C++ and MFC, but I want to learn game programming..so I bought
: "The Awesome Power of Direct3d/DirectX 5"

Good choice of books!

: anyway, this book is good exept it doesnt seem to use MFC or Classes at all..seems like its all in old C code...which I don't like...I am so used to MFC and Visual C++ that this book I got is really hard for me to figure out.

There's a good reason for this - read on

: Is there any way to create games using MFC? would I use Appwizard? if so what would I create?..Dialog?..then make it fullscreen with no borders?? is this how I should do it?..and then use the DirectX functions in my MFC app?

: Am I making any sence? is this even possible? if it is, does anyone know of a book or a web page that gives an example of how to make a simple game or something with MSVC++ 5.0 and MFC/DIrect X 5.0

MFC is extremely layered (you should look at the source code sometime, when you have a month to spare!) and sometimes to get one simple thing done, you have to (albeit indirectly) call lots of functions. Remember these are member functions, so you have TWICE the raw function call overhead, as well as the this pointer that gets passed. This can make code really easy to follow, but it also makes it really inefficient.

If you must use MFC (or C++ w/o MFC) I would suggest doing all your setup and initialization "by the book", and separating out your "speedy" code. There is no way that C++ can compare to C when it comes to optimization. Ok enough philosophy, here's what I would do (were I you):

Give yourself a refresher course in C.

Forget the MS samples from the SDK. They are usually hard to scale.

Compile the source code from "The Awesome Power..." one chapter at a time...figure out why he is doing what he is doing.

After he goes through the section on texture wrapping, you might want to create some small, simple apps of your own.

Voila! you're there! well -- practice, practice, practice!

Good luck,

Clay

Follow Ups:

  • But the problem with this book is...... AIR_TIME 21:13:39 4/05/98 (4)
    • A little explanation Clay 11:44:35 4/07/98 (3)
      • I got a new book...(Spells of Fury) AIR_TIME 23:28:56 4/07/98 (2)
        • Have you checked out "Windows Programming for Dummies?" Ryan Fenton 19:50:53 4/10/98 (1)
          • No I haven't, and I don't think I will need to. AIR_TIME 02:19:08 4/20/98 (0)

Post a Followup

Name:


Re: MSVC++ 5.0 / Direct X...Im new..please help me.

Posted by Serg on April 05, 1998 at 16:27:16:

In Reply to: MSVC++ 5.0 / Direct X...Im new..please help me. posted by AIR_TIME on April 05, 1998 at 01:28:57:

In my opinion easiest way - to use app wisard,
manually remove View and docunent and use MainFraim
as your main window. there is a sample among the articls
on this site.

Follow Ups:

Post a Followup

Name:


problems with dinput and joystick

Posted by H.p. on April 05, 1998 at 17:15:12:

i've try to use a joystick with dinput, but it doesn't work. Even with the
donuts example (a input.c file), i don't understand... where can i find a
complete example (in c++) for using a joystick? who can help me?
thanks...
ps:sorry for my english... i'm french...

Follow Ups:

Post a Followup

Name:


Rotation of an object

Posted by Mike on April 05, 1998 at 19:58:50:

Hi,

I tried to rotate an object on the Z axis this way:

m_lpD3DMainObject->AddRotation(
D3DRMCOMBINE_REPLACE, D3DVAL(0), D3DVAL(0), D3DVAL(1), D3DVAL(Angle));

Then, I do a m_lpD3DRM->Tick(1), and a Viewport->ForceUpdate(0,0Width,
Height);

The object still doesn't move. What am I doing wrong?

m_lpD3DMainObject = LPDIRECT3DRMFRAME and the object is correctly loaded
and drawn on the screen.

thanks!

Follow Ups:

Post a Followup

Name:


But the problem with this book is......

Posted by AIR_TIME on April 05, 1998 at 21:13:39:

In Reply to: Re: MSVC++ 5.0 / Direct X...Im new..please help me. posted by Clay on April 05, 1998 at 15:42:21:

Thanks for you're help, but its extremly hard for me to follow this book "Awesome Power of Direct3d/DirectX"
the reason its hard for me to follow is because of a couple reasons.
1. The code that he explains in the book is not the same as what is in the source files for the chapter.
2. He doesnt explan WHERE to put the code, like what section of the program things go in or anything...
3.Also he seems to have functions in there that have no prototype, only a definition. (I looked in the .h file and everything and I cant find where he wrote the prototype.)
4. seems like he just explains what everything is, but doesnt really explain how to use or do anything.

What is the create.cpp file for?
in Chapter 4 he has the Tutorial.cpp, Tutorial.h
and Create.cpp

I can't figure out what or why this create.cpp is there, and what made him choose to put some things in it and othe rthings in the tutorial.cpp

basicly this book in my opinion sucks. (chapter 5 code wont even compile)

got any ideas about my problems?

thanks

: : I use MSVC++ 5.0, and I am pretty good with C++ and MFC, but I want to learn game programming..so I bought
: : "The Awesome Power of Direct3d/DirectX 5"

: Good choice of books!

: : anyway, this book is good exept it doesnt seem to use MFC or Classes at all..seems like its all in old C code...which I don't like...I am so used to MFC and Visual C++ that this book I got is really hard for me to figure out.

: There's a good reason for this - read on

: : Is there any way to create games using MFC? would I use Appwizard? if so what would I create?..Dialog?..then make it fullscreen with no borders?? is this how I should do it?..and then use the DirectX functions in my MFC app?

: : Am I making any sence? is this even possible? if it is, does anyone know of a book or a web page that gives an example of how to make a simple game or something with MSVC++ 5.0 and MFC/DIrect X 5.0

: MFC is extremely layered (you should look at the source code sometime, when you have a month to spare!) and sometimes to get one simple thing done, you have to (albeit indirectly) call lots of functions. Remember these are member functions, so you have TWICE the raw function call overhead, as well as the this pointer that gets passed. This can make code really easy to follow, but it also makes it really inefficient.

: If you must use MFC (or C++ w/o MFC) I would suggest doing all your setup and initialization "by the book", and separating out your "speedy" code. There is no way that C++ can compare to C when it comes to optimization. Ok enough philosophy, here's what I would do (were I you):

: Give yourself a refresher course in C.

: Forget the MS samples from the SDK. They are usually hard to scale.

: Compile the source code from "The Awesome Power..." one chapter at a time...figure out why he is doing what he is doing.

: After he goes through the section on texture wrapping, you might want to create some small, simple apps of your own.

: Voila! you're there! well -- practice, practice, practice!

: Good luck,

: Clay

Follow Ups:

  • A little explanation Clay 11:44:35 4/07/98 (3)
    • I got a new book...(Spells of Fury) AIR_TIME 23:28:56 4/07/98 (2)
      • Have you checked out "Windows Programming for Dummies?" Ryan Fenton 19:50:53 4/10/98 (1)
        • No I haven't, and I don't think I will need to. AIR_TIME 02:19:08 4/20/98 (0)

Post a Followup

Name:


Re: Here is a site you can download DirectX 5.0 end-user release

Posted by JOE on April 05, 1998 at 22:19:53:

In Reply to: Here is a site you can download DirectX 5.0 end-user release posted by Paulo Brasko Ferreira on April 04, 1998 at 01:00:32:

: For playing games that need DirectX 5.0.

: Download DirectX 5.0 end-user release at
: http://avault.com/hardware/directx.asp

: good luck in your game ...

: Brasko

Follow Ups:

Post a Followup

Name:


Direct3D DrawPrimitive

Posted by Andr�as K�hne on April 06, 1998 at 03:07:57:

I am trying to create a simple function that just draws a polygon on the screen. The problem is that the DrawPrimitive function keeps returning "DDERR_INVALIDPARAMS". And that doesn�t say to much. I have checked all of the parameters except the lpVertices parameter, and they are all copied from an example in the SDK. I am trying to use the lighted and transformed vertices (D3DLTVERTEX I think). My question is this:

Could there be a problem within the D3DLTVERTEX structure, some variable that I am initiating incorrectly? If someone could give me code just to draw a triangle (just how to setup the D3DLTVERTEX structures and the call to DrawPrimitive), it would be appreciated!

Regards,

Andr�as

Follow Ups:

  • Re: Direct3D DrawPrimitive Serge Plagnol 10:23:32 5/21/98 (0)

Post a Followup

Name:


Spotlights not lighting flat polygons!

Posted by Andy Capon on April 06, 1998 at 06:25:31:

Hi there,

Ok, I have a mesh to make a wall, I have split this wall up into a collection of smaller squares(20X20).

If I use a point light with linear attenuation I can get a nice lighting affect as I move the light around.

If I use a SpotLight I get absolutely no lighting on this plane, any shaped objects are lit perfectly.

Help!!!

Andy Capon

Follow Ups:

  • Re: Spotlights not lighting flat polygons! Clay 13:51:13 4/06/98 (3)
    • Re: Spotlights not lighting flat polygons! Andy Capon 15:30:31 4/06/98 (2)
      • Re: Spotlights not lighting flat polygons! Fred 18:32:21 5/29/98 (0)
      • Re: Spotlights not lighting flat polygons! Clay 07:38:53 4/07/98 (0)

Post a Followup

Name:


DrawPrimitive HAL

Posted by Greg on April 06, 1998 at 10:01:50:

I'm having problems rendering using my 3D hardware acelleration. I've got a textured cube spinning with a directional light, and I'm using D3DVERTEX. It works perfect in RGB or MMX mode, but when I switch to HEL little dots suddenly appear and then dissappear? Please someone help. I don't even know where to begin.

Follow Ups:

Post a Followup

Name:


Pseudo Dialog Boxes

Posted by Johnny Rotten on April 06, 1998 at 10:23:10:

In Reply to: Re: Dialog Boxes shouldn't be this hard posted by Brian Shea on April 04, 1998 at 01:27:13:

: Well, just use the windows WM_KEYDOWN messages
: and keep adding whatever they type into a buffer.
: When the finish (hit return, mouse click, etc),
: you now have a string. Of course, you now have
: to draw each letter they type onto the screen,
: but you can use the GDI to do this if you want.

Brian,

I've since discovered that you can put Edit controls, Static text, List Boxes, etc. right smack dab into your main window handle without ever having to call a dialog box. All the messages are handled by the main window and the procedure is painless.

Johnny

Follow Ups:

Post a Followup

Name:


Re: Spotlights not lighting flat polygons!

Posted by Clay on April 06, 1998 at 13:51:13:

In Reply to: Spotlights not lighting flat polygons! posted by Andy Capon on April 06, 1998 at 06:25:31:

Spotlights are wierd like that. Try moving the light away from the wall. If the light doesn't "shine" on any vertices, then you will see no light. Also, you might modify the umbra and penumbra.

Clay

Follow Ups:

  • Re: Spotlights not lighting flat polygons! Andy Capon 15:30:31 4/06/98 (2)
    • Re: Spotlights not lighting flat polygons! Fred 18:32:21 5/29/98 (0)
    • Re: Spotlights not lighting flat polygons! Clay 07:38:53 4/07/98 (0)

Post a Followup

Name:


Re: Spotlights not lighting flat polygons!

Posted by Andy Capon on April 06, 1998 at 15:30:31:

In Reply to: Re: Spotlights not lighting flat polygons! posted by Clay on April 06, 1998 at 13:51:13:

Cheers Clay,

I can move the light and sometimes I get some slight effect, the light is definately hitting the vertices (thats wy I've split it into 20*20*2 triangles.

Ive also mucked about with the umbra, penumbra,range and attenuation values.

The changing of the above variables effects other non planar objects I have placed in the scene, so these changes are working.

The light is also enabled at the root frame.

Help!

Andy

: Spotlights are wierd like that. Try moving the light away from the wall. If the light doesn't "shine" on any vertices, then you will see no light. Also, you might modify the umbra and penumbra.

: Clay

Follow Ups:

  • Re: Spotlights not lighting flat polygons! Fred 18:32:21 5/29/98 (0)
  • Re: Spotlights not lighting flat polygons! Clay 07:38:53 4/07/98 (0)

Post a Followup

Name:


MYSTERIOUS BLIT DELAY/WAVE DISTORTION ?? HELP !!

Posted by Martijn Segers on April 06, 1998 at 17:21:09:

DirectDraw (5) Problem :

Res. : 800x600x16

I created a Primary surface + backbuffer
I created a offscreen surface that holds some
sprites.
I use DirectSound to play a wave :

A strange thing happens :

When I blit a sprite (50x30x16) to coordinates
(163,141) I have no problems : The soundwave plays
normaly and I have a fine Framerate (PPro 180)

BUT

When I blit the SAME sprite to the coordinates
(160,140) my framerate decreases significantly
(fact. 3) and the wave sounds heavily destorted.

To make it even stranger :

When I move the sprite back to it's old position
(163,141) the FrameRate imediately goes back to
its fine rate and my wave spontaniously sound
correct again (even when I do this halfway wavelength)

Can NE1 tell me how this can happen.

Martijn Segers (mas@ecosystems.nl)

Follow Ups:

Post a Followup

Name:


Re: uninstallation of DX5

Posted by Merlin on April 06, 1998 at 18:31:02:

In Reply to: uninstallation of DX5 posted by Chris Tough on March 28, 1998 at 02:51:38:

Previous posts instructing how to delete DirectX5 from your system do
not -totally- remove it or let you reinstall (from scratch) any older
version of DirectX. Much more information is stored in the Win95
registry about which version is installed and other parameters/settings
relating to DirectX. The procedure outlined below allows you to totally
remove DirectX and lets you -really- reinstall it...any older version,
all the way down to DirectX1.

Be warned: the following procedure involves deleting certain Win95
registry keys that, if done incorrectly, -could- render your nicely
running Win95 useless and you'll have to reinstall it and all your other
applications. Do the following at your own risk. I won't be held
responsible if you screw up your system. If you don't know about
"regedit" or "regback", you probably shouldn't be doing the procedure.

Using regedit, regback (included on the Win95 cd), or Norton registry
editor, back up your entire registry to a backup folder/disk. Also
backup the all files listed below. If s

Follow Ups:

Post a Followup

Name:


Re: Need Direct X!!

Posted by Nirvana on April 06, 1998 at 20:39:01:

In Reply to: Need Direct X!! posted by NightFlyer on March 29, 1998 at 10:52:24:

you can try to search idx5sdkm.exe (the dll, headers and executables) and
idx5docs.exe (documentation in english and japaneese) in a FTPSEARCH
like : http://ftpsearch.ntnu.no/

Nirvana.

: Where can I get direct x?? I need someone to email me

Follow Ups:

Post a Followup

Name:


spectrum analyzer

Posted by Justin on April 06, 1998 at 21:21:12:

is it possible to make a spectrum anaylzer in VB using DirectX?

Follow Ups:

Post a Followup

Name:


Re: Spotlights not lighting flat polygons!

Posted by Clay on April 07, 1998 at 07:38:53:

In Reply to: Re: Spotlights not lighting flat polygons! posted by Andy Capon on April 06, 1998 at 15:30:31:

Andy,

The only other thing that I can think of is that your vertex normals are pointing "away" from your camera.

Good Luck!
Clay

P.S. don't forget that your non-planar objects are broken up into planar, convex, triangles before they are rendered!

Follow Ups:

Post a Followup

Name:


Triple buffering

Posted by Jon on April 07, 1998 at 09:48:19:

Hi there,

Anyone out there got any experience with initialising a triple buffer?

I have a problem that has been bugging me for ages....

The Microsoft Direct Draw (5.0) overview says to triple buffer you need the following pointers:-

LPDIRECTDRAWSURFACE lpDDSPrimary,lpDDSMiddle,lpDDSBack;

The sample code (Page 69 of the document) goes onto use lpDDSPrimary (to create the primary surface) and lpDDSMiddle (attached surface). However, it doesn't reference lpDDSBack anywhere in the code.

So, I'm wondering, do you need a pointer to each surface?

If so, do you need to attach lpDDSBack to the primary surface, like lpDDSMiddle was?

Jon

Follow Ups:

  • Re: Triple buffering Brian Shea 13:38:07 4/07/98 (0)

Post a Followup

Name:


A little explanation

Posted by Clay on April 07, 1998 at 11:44:35:

In Reply to: But the problem with this book is...... posted by AIR_TIME on April 05, 1998 at 21:13:39:

The tutorial stuff compiled fine for me, what are the errors you're getting?

Create.cpp is where he creates the objects that are specific to his scene. There aren't many comments, I think what he intended is for the chapter in the book to suffice as the coments.

Tutorial.cpp is where he does all the initialization and message processing: basically all the stuff that is relatively the same between the different chapters.

All the prototypes are at the top of the .cpp files :-<

What I did was compile his code and then experiment with it.

I made a MFC thingy a while ago with D3D. I used SDI - my objects being the document and the view was the view (that makes sense, right?)

Good luck -- post any questions I can help you with!

Clay

Follow Ups:

  • I got a new book...(Spells of Fury) AIR_TIME 23:28:56 4/07/98 (2)
    • Have you checked out "Windows Programming for Dummies?" Ryan Fenton 19:50:53 4/10/98 (1)
      • No I haven't, and I don't think I will need to. AIR_TIME 02:19:08 4/20/98 (0)

Post a Followup

Name:


D3DRM textures get upside down

Posted by Pablo de Heras on April 07, 1998 at 12:19:11:

Hi,

When I convert a 3ds animation with conv3ds -A i get a .x animation file. This animation file uses .bmp textures so I load them with lpD3DRM->LoadTexture() function. When I play the animation in D3D I get the textures upside down. The animation was created in 3DS4 and in 3DS4 everything looked ok. To flip the textures on the right side I had to flip the .bmp pictures in Photoshop, and now it looked ok. Why is it like this? Do I have to load the textures upsidedown using my own callback or what? I'm out of ideas...

Follow Ups:

  • Re: D3DRM textures get upside down Brian Shea 13:40:46 4/07/98 (3)
    • Re: D3DRM textures get upside down Pablo de Heras 16:30:38 4/07/98 (2)
      • Re: D3DRM textures get upside down Ludovic Tirtiaux 12:01:00 4/08/98 (1)
        • THANKS! Re: D3DRM textures get upside down Pablo de Heras 12:34:02 4/08/98 (0)

Post a Followup

Name:


Re: Triple buffering

Posted by Brian Shea on April 07, 1998 at 13:38:07:

In Reply to: Triple buffering posted by Jon on April 07, 1998 at 09:48:19:

You do not need an explicit pointer to the middle
surface. It is just in the flipping chain. Besides, what could you possibly do with the middle surface? It is busy being flipped, that is its purpose, so most of the time anything you would want to do to the surface would have to wait for it to finish.

Brian

  • Journals of a DirectX Junkie

Follow Ups:

Post a Followup

Name:


Re: D3DRM textures get upside down

Posted by Brian Shea on April 07, 1998 at 13:40:46:

In Reply to: D3DRM textures get upside down posted by Pablo de Heras on April 07, 1998 at 12:19:11:

Bitmaps are stored last row first in the file, as opposed to many other formats (like PCX) that store the image first row first. I am not sure why a texture loader that understand bitmaps does not get this right, but at least there is a logical explanation for it.

Brian

  • Journals of a DirectX Junkie

Follow Ups:

  • Re: D3DRM textures get upside down Pablo de Heras 16:30:38 4/07/98 (2)
    • Re: D3DRM textures get upside down Ludovic Tirtiaux 12:01:00 4/08/98 (1)
      • THANKS! Re: D3DRM textures get upside down Pablo de Heras 12:34:02 4/08/98 (0)

Post a Followup

Name:


Re: D3DRM textures get upside down

Posted by Pablo de Heras on April 07, 1998 at 16:30:38:

In Reply to: Re: D3DRM textures get upside down posted by Brian Shea on April 07, 1998 at 13:40:46:

: Bitmaps are stored last row first in the file, as opposed to many other formats (like PCX) that store the image first row first. I am not sure why a texture loader that understand bitmaps does not get this right, but at least there is a logical explanation for it.

: Brian

Hmm... it could be that 3DS4 treats the textures as upside down and D3DRM treats them right. I think someone posted a similar question and didn't get answer how to solve this either.

Using bmp textures - Fran Avil�s 18:00:15 3/08/98 (0)

He said something about the bmp got rotated and that's the same problem as being upsidedown I think. Is there an answer out there. I want to beleive .... :)

Follow Ups:

  • Re: D3DRM textures get upside down Ludovic Tirtiaux 12:01:00 4/08/98 (1)
    • THANKS! Re: D3DRM textures get upside down Pablo de Heras 12:34:02 4/08/98 (0)

Post a Followup

Name:


simple DriectDraw question

Posted by Oliver Hauth on April 07, 1998 at 17:43:22:

Hello..

I'm trying to write a DirectDraw program without BMPs.
I stored the images in raw format (one byte one pixel). I want to open the file and read it (C++) with the following line:
file.read((char*)ddsd.lpSurface, 640*480);
But when I compile and start it, the screen is black.
Then I tried the following code:
*ddsd.lpSurface = 15;
But the screen is still black.

I used the Lock and Unlock funktions of LPDIRECCTDRAWSURFACE.

Please help me!

Follow Ups:

  • Re: simple DriectDraw question Brian Shea 00:37:51 4/08/98 (0)

Post a Followup

Name:


Anyone have any good tile-based engine links?

Posted by Ryan Fenton on April 07, 1998 at 21:59:37:

Like most RPG fanatics who start programming games, I'd like to try my hand at creating a tile-based engine of my own design. Does anyone know of any links to tile-based game engines (DirectX prefered, of course, but others joyfully accepted) so that I can see all of the snags inherant in some designs while I formulate my personal design "bible?" I'd be eternally grateful, and plan on releasing all my source code and documentation upon development so that others could advance upon my work.

One hefty thanks in advance,

Ryan Fenton

Follow Ups:

  • Tile based games Johnny Rotten 10:13:36 4/08/98 (3)
    • Cool... Ryan Fenton 12:03:20 4/08/98 (2)
      • Engine Johnny Rotten 12:23:34 4/08/98 (1)
        • Very Cool... Ryan Fenton 23:53:43 4/09/98 (0)
  • Re: Anyone have any good tile-based engine links? Brian Shea 00:40:15 4/08/98 (0)

Post a Followup

Name:


I got a new book...(Spells of Fury)

Posted by AIR_TIME on April 07, 1998 at 23:28:56:

In Reply to: A little explanation posted by Clay on April 07, 1998 at 11:44:35:

The direct3d book was just to confusing and poorly written in my opinion

so I bough Spells of Fury today...it uses DirectX 2.0...but so far just its explinataion on windows API in the first chapter is the most helpfull I have ever read!...seems really easy so far.

ALso I looked at the DX 5.0 SDK tutorials for DirectDraw and totally understood it...

I'll save that Direct3d book for later.

: The tutorial stuff compiled fine for me, what are the errors you're getting?

: Create.cpp is where he creates the objects that are specific to his scene. There aren't many comments, I think what he intended is for the chapter in the book to suffice as the coments.

: Tutorial.cpp is where he does all the initialization and message processing: basically all the stuff that is relatively the same between the different chapters.

: All the prototypes are at the top of the .cpp files :-<

: What I did was compile his code and then experiment with it.

: I made a MFC thingy a while ago with D3D. I used SDI - my objects being the document and the view was the view (that makes sense, right?)

: Good luck -- post any questions I can help you with!

: Clay

Follow Ups:

  • Have you checked out "Windows Programming for Dummies?" Ryan Fenton 19:50:53 4/10/98 (1)
    • No I haven't, and I don't think I will need to. AIR_TIME 02:19:08 4/20/98 (0)

Post a Followup

Name:


Re: simple DriectDraw question

Posted by Brian Shea on April 08, 1998 at 00:37:51:

In Reply to: simple DriectDraw question posted by Oliver Hauth on April 07, 1998 at 17:43:22:

That will not work. You must use the lPitch
of the surface to move from the start of one
row to the start of the next. It should be
something like this:

BYTE* dst = lpSurface;
for (int y = 0 ; y < 480 ; ++y)
{ file.read(dst, 640); dst += lPitch; }

The lPitch can be found in the DDSURFACEDESC
where you got the surface pointer. And, of
course, this will only work if you are in either
8-bit or 24-bit mode. If you are in 16-bit mode
than you need to deal with the bitmasks to create
the WORD to store.

  • Journals of a DirectX Junkie

Follow Ups:

Post a Followup

Name:


How can I check on which 3D card is used by DirectX?

Posted by Greg Kable on April 08, 1998 at 00:38:23:

I have installed a Voodoo2 based 3D card along with
an ET6000 based 2D card and it appears that the 3D card
is being ignored. The 3D card is registered with
DirectX (version 5.0) but I'm seeing no performance or
quality improvement.

My understanding is that Direct3D automagically selects
the card/driver by matching the features requested by
the Direct3D application with the features promised by
the card/driver. What I want to know is - how can I
find out what each card/driver is offering and how
can I determine which card Direct3D selected and
hopefully force it to select the Voodoo2 card.

Thanks,
Greg

Follow Ups:

  • short answer, more questions Clay 09:12:47 4/08/98 (0)

Post a Followup

Name:


Re: Anyone have any good tile-based engine links?

Posted by Brian Shea on April 08, 1998 at 00:40:15:

In Reply to: Anyone have any good tile-based engine links? posted by Ryan Fenton on April 07, 1998 at 21:59:37:

I ran across this one the other day. Not so
much an engine, but a bunch of info on tiles.
http://www.steinke.net/42/

Brian

  • Journals of a DirectX Junkie

Follow Ups:

Post a Followup

Name:


Samples

Posted by Dave on April 08, 1998 at 01:42:20:

I am new to the DirectX world. However, I have not yet managed to find simple, understandable examples/code/guides to using DirectX. I know that there are some out there, I just haven't found them yet...Can someone help me out here? (Yes, I am wishing to eventually be able to utilize all aspects of DirectX 5.0)

Follow Ups:

  • Re: Samples Roger 19:59:16 4/09/98 (0)

Post a Followup

Name:


short answer, more questions

Posted by Clay on April 08, 1998 at 09:12:47:

In Reply to: How can I check on which 3D card is used by DirectX? posted by Greg Kable on April 08, 1998 at 00:38:23:

Greg,

I posed a similar question a few message-days ago - you might take a look at it. Anyhow, DirectX treats the add-on card (in this case the Voodoo2)similarly to the way it treats a separate monitor (if Win95 supported that). You need to enumerate ( DirectDrawEnumerate() ) your devices, the Voodoo2 will show up there. Use that GUID to create your IDirectDraw interface. From there, you need to do CreateDeviceFromSurface() with a 3D driver (enumerate these too). My problem is that I get a page fault in D3DRM.DLL when I CreateDeviceFromSurface() with a non-NULL GUID. However, my Voodoo2 is used with a NULL GUID, I just don't know which driver it is using.

Good Luck!

Clay

Follow Ups:

Post a Followup

Name:


Re: Does D.X.5 go to WinNT 4.0??

Posted by Sean on April 08, 1998 at 09:35:25:

In Reply to: Re: Does D.X.5 go to WinNT 4.0?? posted by Clay on March 16, 1998 at 18:44:05:

: Nope...that is supposed to be in NT 5.0 -- if they ever get it out of beta!

I remember reading somewhere (I'm looking for the references now),
that you could get DX 5.0 to work under NT 4.0 by backing up the old DX 3.0
(if you have SP3 installed) DLLs and replacing them with the DX 5.0 DLLs
(I think you need to install it under Win95 first, then copy over the DLLs
to NT). You may need to do something else as well. If someone else has
seen this done could you please post how to do it? I'd like to do all my
development under Windows NT and rebooting back into 95 for debugging sucks.
If I find the article I read on it, I'll post a link.

- Sean

Follow Ups:

Post a Followup

Name:


Tile based games

Posted by Johnny Rotten on April 08, 1998 at 10:13:36:

In Reply to: Anyone have any good tile-based engine links? posted by Ryan Fenton on April 07, 1998 at 21:59:37:

: Like most RPG fanatics who start programming games, I'd like to try my hand at creating a tile-based engine of my own design. Does anyone know of any links to tile-based game engines (DirectX prefered, of course, but others joyfully accepted) so that I can see all of the snags inherant in some designs while I formulate my personal design "bible?" I'd be eternally grateful, and plan on releasing all my source code and documentation upon development so that others could advance upon my work.

: One hefty thanks in advance,

: Ryan Fenton

Ryan,

I've done quite a bit of work with tile engines, both standard and isometric. If there is anything I can help you with, please ask away. I may have a site up soon... I'll let you know...

Johnny

Follow Ups:

  • Cool... Ryan Fenton 12:03:20 4/08/98 (2)
    • Engine Johnny Rotten 12:23:34 4/08/98 (1)
      • Very Cool... Ryan Fenton 23:53:43 4/09/98 (0)

Post a Followup

Name:


Z-buffer direct Access

Posted by Dorian Averbuh on April 08, 1998 at 11:11:58:

I'm working on Z-buffer aplication presently.
I have a bitmap and I know the Z-coordinate for every pixel.
Is there any way to write this information directly into the Z-buffer?
That is to say, I want to initialize Z-buffer before the drawing(instead of
clearing it).

Thanks for your assistance.
Dorian.
dorian@elbit.co.il

Follow Ups:

Post a Followup

Name:


Z-buffer direct Access

Posted by Dorian Averbuh on April 08, 1998 at 11:19:00:

I'm working on Z-buffer aplication presently.
I have a bitmap and I know the Z-coordinate for every pixel.
Is there any way to write this information directly into the Z-buffer?
That is to say, I want to initialize Z-buffer before the drawing(instead of
clearing it).

Thanks for your assistance.
Dorian.
dorian@elbit.co.il

Follow Ups:

  • Re: Z-buffer direct Access Roger 20:01:26 4/09/98 (0)

Post a Followup

Name:


Re: D3DRM textures get upside down

Posted by Ludovic Tirtiaux on April 08, 1998 at 12:01:00:

In Reply to: Re: D3DRM textures get upside down posted by Pablo de Heras on April 07, 1998 at 16:30:38:

Read the following text:

"Texture behaviour
-----------------
Textures loaded from bmp files in the IDirect3DRM interface were
loaded upside-down. This has been corrected in the IDirect3DRM2
interface."

It comes from d3drm.txt, which is provided with DirectX 5. It's probably related to your problem.

Follow Ups:

  • THANKS! Re: D3DRM textures get upside down Pablo de Heras 12:34:02 4/08/98 (0)

Post a Followup

Name:


Cool...

Posted by Ryan Fenton on April 08, 1998 at 12:03:20:

In Reply to: Tile based games posted by Johnny Rotten on April 08, 1998 at 10:13:36:

Thanks for the help, when I get past the paper stage of development, I'll e-mail you with my thoughts if you'd like an [interesting read/good laugh].

Ryan Fenton

P.S. I'm still looking for any leads on complete tile-based engine code.

Follow Ups:

  • Engine Johnny Rotten 12:23:34 4/08/98 (1)
    • Very Cool... Ryan Fenton 23:53:43 4/09/98 (0)

Post a Followup

Name:


Engine

Posted by Johnny Rotten on April 08, 1998 at 12:23:34:

In Reply to: Cool... posted by Ryan Fenton on April 08, 1998 at 12:03:20:

: Thanks for the help, when I get past the paper stage of development, I'll e-mail you with my thoughts if you'd like an [interesting read/good laugh].

: Ryan Fenton

: P.S. I'm still looking for any leads on complete tile-based engine code.

Ryan,

Let me break out one of the simple engines I created. I'm going to go through it and document as much stuff as I can. Then I'll send you the source code as well as a working executable.

Johnny

Follow Ups:

  • Very Cool... Ryan Fenton 23:53:43 4/09/98 (0)

Post a Followup

Name:


THANKS! Re: D3DRM textures get upside down

Posted by Pablo de Heras on April 08, 1998 at 12:34:02:

In Reply to: Re: D3DRM textures get upside down posted by Ludovic Tirtiaux on April 08, 1998 at 12:01:00:

Yes!

Sometimes I love Microsoft for being so fast to correct their SDK. I hadn't read the docs in the docs directory.

: Read the following text:

: "Texture behaviour
: -----------------
: Textures loaded from bmp files in the IDirect3DRM interface were
: loaded upside-down. This has been corrected in the IDirect3DRM2
: interface."

: It comes from d3drm.txt, which is provided with DirectX 5. It's probably related to your problem.

Once again. Many thanks! :) (happy happy joy joy)

Follow Ups:

Post a Followup

Name:


Borland C++ Builder 3.0 and DirectX

Posted by Jack Strohm on April 08, 1998 at 16:19:32:

Has anyone had this problem.

Run BCB 3.0. Load any DirectX app that goes to full screen mode (Any game). Exit the app and BCB 3.0 dies. I'm not even running any applications in BCB 3.0.

I did try running a DirectX program written for BCB 3.0 and BCB dies there also. It dies when Direct Draw switches from restores the video mode from full screen.

I am doing this on a:

Window 95
Pentium II 233 mhz
64 mb
ATI all-in-wonder video card (4mb)
Diamon Monster 2 (8mb)

Help please . . .

Follow Ups:

  • Me Too but VC++Re: Borland C++ Builder 3.0 and DirectX AIR_TIME 16:48:21 4/08/98 (1)
    • Re: Me Too but VC++Re: Borland C++ Builder 3.0 and DirectX Rodney Martin 17:51:24 4/10/98 (0)

Post a Followup

Name:


Me Too but VC++Re: Borland C++ Builder 3.0 and DirectX

Posted by AIR_TIME on April 08, 1998 at 16:48:21:

In Reply to: Borland C++ Builder 3.0 and DirectX posted by Jack Strohm on April 08, 1998 at 16:19:32:

It does that to me also, Exept I use VC++ 5.0 Enterprixse.
but it doesnt die it just changes it to almos
changes its size and screws up all the VC++ buttons in the menus.: Has anyone had this problem.

: Run BCB 3.0. Load any DirectX app that goes to full screen mode (Any game). Exit the app and BCB 3.0 dies. I'm not even running any applications in BCB 3.0.

: I did try running a DirectX program written for BCB 3.0 and BCB dies there also. It dies when Direct Draw switches from restores the video mode from full screen.

: I am doing this on a:

: Window 95
: Pentium II 233 mhz
: 64 mb
: ATI all-in-wonder video card (4mb)
: Diamon Monster 2 (8mb)

: Help please . . .

Follow Ups:

  • Re: Me Too but VC++Re: Borland C++ Builder 3.0 and DirectX Rodney Martin 17:51:24 4/10/98 (0)

Post a Followup

Name:


CDX question

Posted by Nick Weihs on April 08, 1998 at 18:38:41:

If any of you have CDX, anwswer me this, why is it
causing a fatal link error because of IDD_IDirectDraw2?
It says it is an extern...?

Follow Ups:

  • Where can I get CDX? AIR_TIME 00:29:53 4/09/98 (1)
    • Re: Where can I get CDX? Nick Weihs 09:53:23 4/09/98 (0)

Post a Followup

Name:


Where can I get CDX?

Posted by AIR_TIME on April 09, 1998 at 00:29:53:

In Reply to: CDX question posted by Nick Weihs on April 08, 1998 at 18:38:41:

Sorry I can't answer your question,
but where can I get CDX?
is it free?

I heard about it, but I dont know where to get it.

: If any of you have CDX, anwswer me this, why is it
: causing a fatal link error because of IDD_IDirectDraw2?
: It says it is an extern...?

Follow Ups:

  • Re: Where can I get CDX? Nick Weihs 09:53:23 4/09/98 (0)

Post a Followup

Name:


Re: Collision Detection in Direct3D RM

Posted by Marco Pesce on April 09, 1998 at 02:07:44:

In Reply to: Re: Collision Detection in Direct3D RM posted by Paulo Brasko on April 04, 1998 at 00:09:03:

You can use the "raypick" function to get the intersection with a poligon... this function work very well but is a bit slow if you have many poligons on the screen

Follow Ups:

Post a Followup

Name:


Re: DirectX and MFC

Posted by Robert Tomliin on April 09, 1998 at 06:36:04:

In Reply to: Re: Can someone suggest a Win32 Programming Reference? posted by Sean on March 16, 1998 at 01:59:40:

Tod says run from MFC if doing DirectX like the devil, Why ?

: Todd,
: I use and recommend the two following books:
: Win32 Programming API Bible (Waite Group Press)
: and
: Programming Windows 95 (Microsorf Press)

: You should be able to find both books at discount prices. Don't go to a real bookstore, they cost $50 US there.

: These books are not MFC and if you want my advice, a directX programmer should run from MFC like it is the devil.

: : Hi...

: : I'm looking for a decent beginner's guide to Win32 programming
: : (not necessarily MFC). Can someone suggest a good book?

Follow Ups:

Post a Followup

Name:


DirectX Surfaces and Windows GDI

Posted by Robert Tomlin on April 09, 1998 at 06:47:47:

I have rendered a frame of a video (using Active Movie) to an offscreen DirectX surface. I want to be able to blit from this offscreen DirectX surface to a standard window DC.

I know ideally my app should be using DirectX exclusivly but I have not got time to convert the existing code !!

Thanks in advance
Rob

Follow Ups:

  • Re: DirectX Surfaces and Windows GDI Martijn Segers 17:43:55 4/09/98 (1)
    • Re: DirectX Surfaces and Windows GDI Robert Tomlin 11:47:19 4/30/98 (0)

Post a Followup

Name:


Beginners question about blitting bitmaps

Posted by Red on April 09, 1998 at 08:29:33:

I've just begun moving into programming with DirectDraw, and I can't
find any details about how to blit a bitmap that hasn't just been loaded into
memory from a file. While this is sometimes useful, I want to create bitmaps
that a partially created by in-program code (adding user defined borders and
buttons etc). Can someone help me with this?
Also, is there anyway to change screenmodes from within a win32 program
without using the SetDisplayMode/DirectDraw method?

Follow Ups:

Post a Followup

Name:


Re: Here is a site you can download DirectX 5.0 end-user release

Posted by chet horne on April 09, 1998 at 09:02:08:

In Reply to: Re: Here is a site you can download DirectX 5.0 end-user release posted by Joost Brouwer on April 04, 1998 at 05:37:44:

: : For playing games that need DirectX 5.0.

: : Download DirectX 5.0 end-user release at
: : http://avault.com/hardware/directx.asp

: : good luck in your game ...

: : Brasko

Follow Ups:

Post a Followup

Name:


Re: Where can I get CDX?

Posted by Nick Weihs on April 09, 1998 at 09:53:23:

In Reply to: Where can I get CDX? posted by AIR_TIME on April 09, 1998 at 00:29:53:

yeah, its free

  • CDX

Follow Ups:

Post a Followup

Name:


Quake

Posted by zap on April 09, 1998 at 10:14:33:

I have a problem running Quake over the internet, every time I Quit quake my computer locks up and I have to shut it down does anyone one have a idea what is causing this?

Follow Ups:

Post a Followup

Name:


Need Help on Wraps

Posted by Chris on April 09, 1998 at 12:36:01:

Hi there,
can anyone give me a little help on texture-wraps in direct 3d retained-mode ?

I don't understand what the Z and Y-Axis of the wrap are (destination vertex ?).
Please give me some help/a little example.

Thanks Chris

Follow Ups:

Post a Followup

Name:


Getting DDHelp.exe caused error in 546x.drv!

Posted by Lance on April 09, 1998 at 12:56:51:

Whenever I run my games ( in this case Deer Hunter)I'm
getting of message of "General protection fault,
ddhelp.exe caused a violation in the 546x.drv." I've
uninstalled and reinstalled the directx 2 times now,
and get the same message. Help! Thanks, Lance

Follow Ups:

Post a Followup

Name:


Help, I'm a stupid newbie

Posted by Aron Yu on April 09, 1998 at 16:57:47:

While compiling my directdraw program I get the following error message:

Linking...
ddex2.obj : error LNK2001: unresolved external symbol _DDReLoadBitmap
ddex2.obj : error LNK2001: unresolved external symbol _DDLoadPalette
ddex2.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12
LIBCD.lib(crt0.obj) : error LNK2001: unresolved external symbol _main
Debug/ddex2.exe : fatal error LNK1120: 4 unresolved externals

What is it that I've forgotten to do??

Follow Ups:

  • What compiler? AIR_TIME 22:49:32 4/09/98 (2)
    • Yeah, It was VC++ 5.0, but.... Aron Yu 05:15:56 4/10/98 (1)
      • Re: Yeah, It was VC++ 5.0, but.... AIR_TIME 16:13:58 4/10/98 (0)
  • Re: Help, I'm a stupid newbie Roger 19:52:32 4/09/98 (4)
    • Help David Carter 01:30:55 4/17/98 (0)
    • Re: Help, I'm a stupid newbie Aron Yu 05:12:52 4/10/98 (2)
      • Did you include SDK\SAMPLES\MISC\ AIR_TIME 16:15:53 4/10/98 (0)
      • Also a stupid newbie... Nick Weihs 11:43:34 4/10/98 (0)

Post a Followup

Name:


Re: DirectX Surfaces and Windows GDI

Posted by Martijn Segers on April 09, 1998 at 17:43:55:

In Reply to: DirectX Surfaces and Windows GDI posted by Robert Tomlin on April 09, 1998 at 06:47:47:

You can try this :

// DSurface = directX surface
// Whdc = Windows handle to Device Context
// dWidth = destination width;
// dHeight = destination height;
// dX = destination X;
// dY = destination Y;

HDC hdc;
DDSURFACEDESC ddsd;

ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_HEIGHT | DDSD_WIDTH;
DSurface->GetSurfaceDesc(&ddsd);

if (DSurface->GetDC(&hdc)== DD_OK)
{
StretchBlt(Whdc, dX, dY, dWidth, dHeight, hdc, 0, 0,ddsd.dwWidth, ddsd.dwHeight, SRCCOPY);
DSurface->ReleaseDC(hdc);
}

Follow Ups:

  • Re: DirectX Surfaces and Windows GDI Robert Tomlin 11:47:19 4/30/98 (0)

Post a Followup

Name:


Re: Help, I'm a stupid newbie

Posted by Roger on April 09, 1998 at 19:52:32:

In Reply to: Help, I'm a stupid newbie posted by Aron Yu on April 09, 1998 at 16:57:47:

You need to include the ddraw.lib and ddutil.cpp into your project.

Hope this helps

Roger

Follow Ups:

  • Help David Carter 01:30:55 4/17/98 (0)
  • Re: Help, I'm a stupid newbie Aron Yu 05:12:52 4/10/98 (2)
    • Did you include SDK\SAMPLES\MISC\ AIR_TIME 16:15:53 4/10/98 (0)
    • Also a stupid newbie... Nick Weihs 11:43:34 4/10/98 (0)

Post a Followup

Name:


Re: Samples

Posted by Roger on April 09, 1998 at 19:59:16:

In Reply to: Samples posted by Dave on April 08, 1998 at 01:42:20:

This simplest examples for DirectDraw are ddex1.cpp and ddex2.cpp. All those do is basically setup the video and pageflip. I would start there.

Roger

Follow Ups:

Post a Followup

Name:


Re: Z-buffer direct Access

Posted by Roger on April 09, 1998 at 20:01:26:

In Reply to: Z-buffer direct Access posted by Dorian Averbuh on April 08, 1998 at 11:19:00:

You can access the zbuffer surface just like any other directdraw surface. You Lock it and get a pointer to the surface and now you can directly access the zbuffer.

Roger

Follow Ups:

Post a Followup

Name:


Re: Transparent blt:ing

Posted by Roger on April 09, 1998 at 20:04:22:

In Reply to: Transparent blt:ing posted by Andr�as K�hne on April 04, 1998 at 12:50:38:

DirectDraw does not currently support 2D alpha blending. New 3D cards do it but for 2D you have to manipulate the pixels yourself.

Roger

Follow Ups:

Post a Followup

Name:


What compiler?

Posted by AIR_TIME on April 09, 1998 at 22:49:32:

In Reply to: Help, I'm a stupid newbie posted by Aron Yu on April 09, 1998 at 16:57:47:

If its Visual C++ 5.0
you need to go to
Tools..OPtions..then pick the Directories Tab.
and add the directory to the DX5\SDK\INC (in the include drop down list)
and the directory DX5\SDK\LIB (in the library drop down list)

and also in your current project to to Project..settings...and the Link tab..
and you will see a list of .lib's separated by spaces...go to the end of that list and add
ddraw.lib

: While compiling my directdraw program I get the following error message:

: Linking...
: ddex2.obj : error LNK2001: unresolved external symbol _DDReLoadBitmap
: ddex2.obj : error LNK2001: unresolved external symbol _DDLoadPalette
: ddex2.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12
: LIBCD.lib(crt0.obj) : error LNK2001: unresolved external symbol _main
: Debug/ddex2.exe : fatal error LNK1120: 4 unresolved externals

: What is it that I've forgotten to do??

Follow Ups:

  • Yeah, It was VC++ 5.0, but.... Aron Yu 05:15:56 4/10/98 (1)
    • Re: Yeah, It was VC++ 5.0, but.... AIR_TIME 16:13:58 4/10/98 (0)

Post a Followup

Name:


Very Cool...

Posted by Ryan Fenton on April 09, 1998 at 23:53:43:

In Reply to: Engine posted by Johnny Rotten on April 08, 1998 at 12:23:34:

That would be so...so really cool. Hopefully, we'll be able to help one another - I'm still hacking away (bit by bit) at designing the concepts for an isometric RPG engine with scripting, intelligent "in-game" editors, and other fun stuff. I've been talking with a few people, but still have yet to find (or search exhaustively for - O.K., I'm lazy, I thought I'd ask others if they heard of any good ones first) anything more than the basest design theories on isometric engines. All I've come up with so far on my own is to compress (because exactly 1/2 of an isometric tile is going to be "empty" or transparant, all you have to do is split it into 4 and fold it into a 2X1 rectangle) the tiles I'm not using, and then decompress into a full directx object when it becomes "active" in nearby scenes, thereby saving half the memory for unused tiles...but I'm sure there's got to be some more tricky schemes out there, and I'm looking foreward to seeing any tile mapping schemes of any sort.

Ryan Fenton

Follow Ups:

Post a Followup

Name:


Where can I find Direct X SDK

Posted by Martin Weiner on April 10, 1998 at 02:52:28:

I have the old DX 3 version, but Microsoft now wont
allow a download of 5 (because they're just putting
it on CD). Can somebody email me an address of a copy
of Direct X 5 SDK.

Thanks,
Martin (swman@bcsnet.net)

Follow Ups:

  • Re: Where can I find Direct X SDK Valorian 03:00:09 4/11/98 (0)
  • Re: Where can I find Direct X SDK Nick Weihs 11:47:30 4/10/98 (0)

Post a Followup

Name:


Re: Help, I'm a stupid newbie

Posted by Aron Yu on April 10, 1998 at 05:12:52:

In Reply to: Re: Help, I'm a stupid newbie posted by Roger on April 09, 1998 at 19:52:32:

: You need to include the ddraw.lib and ddutil.cpp into your project.

: Hope this helps

: Roger

I've already done that.......I added the ddraw.lib in the projectsettings....

Follow Ups:

  • Did you include SDK\SAMPLES\MISC\ AIR_TIME 16:15:53 4/10/98 (0)
  • Also a stupid newbie... Nick Weihs 11:43:34 4/10/98 (0)

Post a Followup

Name:


Yeah, It was VC++ 5.0, but....

Posted by Aron Yu on April 10, 1998 at 05:15:56:

In Reply to: What compiler? posted by AIR_TIME on April 09, 1998 at 22:49:32:

: If its Visual C++ 5.0
: you need to go to
: Tools..OPtions..then pick the Directories Tab.
: and add the directory to the DX5\SDK\INC (in the include drop down list)
: and the directory DX5\SDK\LIB (in the library drop down list)

: and also in your current project to to Project..settings...and the Link tab..
: and you will see a list of .lib's separated by spaces...go to the end of that list and add
: ddraw.lib

I've already done all these things, it still generates error messages, could it be something else?

Follow Ups:

  • Re: Yeah, It was VC++ 5.0, but.... AIR_TIME 16:13:58 4/10/98 (0)

Post a Followup

Name:


Also a stupid newbie...

Posted by Nick Weihs on April 10, 1998 at 11:43:34:

In Reply to: Re: Help, I'm a stupid newbie posted by Aron Yu on April 10, 1998 at 05:12:52:

try adding dxguid.lib to your project...that helped me

Follow Ups:

Post a Followup

Name:


Re: Where can I find Direct X SDK

Posted by Nick Weihs on April 10, 1998 at 11:47:30:

In Reply to: Where can I find Direct X SDK posted by Martin Weiner on April 10, 1998 at 02:52:28:

Maybe www.download.com has it

  • download.com

Follow Ups:

Post a Followup

Name:


Re: Yeah, It was VC++ 5.0, but....

Posted by AIR_TIME on April 10, 1998 at 16:13:58:

In Reply to: Yeah, It was VC++ 5.0, but.... posted by Aron Yu on April 10, 1998 at 05:15:56:

Did you also include ddutil.cpp
in your project?

: : If its Visual C++ 5.0
: : you need to go to
: : Tools..OPtions..then pick the Directories Tab.
: : and add the directory to the DX5\SDK\INC (in the include drop down list)
: : and the directory DX5\SDK\LIB (in the library drop down list)

: : and also in your current project to to Project..settings...and the Link tab..
: : and you will see a list of .lib's separated by spaces...go to the end of that list and add
: : ddraw.lib

:
: I've already done all these things, it still generates error messages, could it be something else?

Follow Ups:

Post a Followup

Name:


Did you include SDK\SAMPLES\MISC\

Posted by AIR_TIME on April 10, 1998 at 16:15:53:

In Reply to: Re: Help, I'm a stupid newbie posted by Aron Yu on April 10, 1998 at 05:12:52:

did you include
SDK\SAMPLES\MISC

in your library list (tools..options)

: : You need to include the ddraw.lib and ddutil.cpp into your project.

: : Hope this helps

: : Roger

: I've already done that.......I added the ddraw.lib in the projectsettings....

Follow Ups:

Post a Followup

Name:


Re: Me Too but VC++Re: Borland C++ Builder 3.0 and DirectX

Posted by Rodney Martin on April 10, 1998 at 17:51:24:

In Reply to: Me Too but VC++Re: Borland C++ Builder 3.0 and DirectX posted by AIR_TIME on April 08, 1998 at 16:48:21:

It does it to me on Vc+5.0 also. I think maybe we need to change the resolution in the game before exiting it. I think that is what is confusing the compilers.

: It does that to me also, Exept I use VC++ 5.0 Enterprixse.
: but it doesnt die it just changes it to almos
: changes its size and screws up all the VC++ buttons in the menus.: Has anyone had this problem.

: : Run BCB 3.0. Load any DirectX app that goes to full screen mode (Any game). Exit the app and BCB 3.0 dies. I'm not even running any applications in BCB 3.0.

: : I did try running a DirectX program written for BCB 3.0 and BCB dies there also. It dies when Direct Draw switches from restores the video mode from full screen.

: : I am doing this on a:

: : Window 95
: : Pentium II 233 mhz
: : 64 mb
: : ATI all-in-wonder video card (4mb)
: : Diamon Monster 2 (8mb)

: : Help please . . .

Follow Ups:

Post a Followup

Name:


Memory Access errors (help a stupid newbie)

Posted by Nick Weihs on April 10, 1998 at 18:18:55:

any GDI or bitmap manipulation I use causes an unhandled
memory exception, please help

Follow Ups:

  • Re: Memory Access errors (help a stupid newbie) Mitch Christian 21:48:27 5/17/98 (0)

Post a Followup

Name:


Have you checked out "Windows Programming for Dummies?"

Posted by Ryan Fenton on April 10, 1998 at 19:50:53:

In Reply to: I got a new book...(Spells of Fury) posted by AIR_TIME on April 07, 1998 at 23:28:56:

No, that wasn't an insult, it's actually a most excellent book.
It's by the same guy who did the "Black art of Game Programming" book, and it deals with DirectX 5.0, and only costs around $30 (I got mine for 20 at a local books-a-million.) All I can say is that that book rocks. It probably saved me months in tying all the "big picture" elements together. It only deals with directdraw in depth, but shows how to work with the other DX components after you've learned directdraw. It goes through the process of making one directx wrapper, and one bad (in a good way) game, and does it in a way that doesn't treat the subject as religeon, but makes it (dare I say it?) kinda fun to learn, and easy to alter because you don't have some over-inflated sense of importance with the programs that makes you afraid to just mess with things. I heartily recomend it, if only for a good laugh, and to help get rid of any of those unsettling feelings you might get when ripping into DirectX for the first time, like I was.

Ryan Fenton

Follow Ups:

  • No I haven't, and I don't think I will need to. AIR_TIME 02:19:08 4/20/98 (0)

Post a Followup

Name:


Re: Where can I find Direct X SDK

Posted by Valorian on April 11, 1998 at 03:00:09:

In Reply to: Where can I find Direct X SDK posted by Martin Weiner on April 10, 1998 at 02:52:28:

Microsoft.

  • Microsoft DirectX Developers

Follow Ups:

Post a Followup

Name:


read two key at once

Posted by Sen Tran on April 11, 1998 at 04:14:28:

Hi. I need help setting up joystick or keyboard that could simutaneously read 2 key at once.

Follow Ups:

  • Re: read two key at once Madant 09:52:56 4/19/98 (0)

Post a Followup

Name:


Need help writing Bitmaps from a Direct Draw Surface to file!

Posted by Vlad on April 11, 1998 at 20:40:15:

I am writing a tile and sprite editor that needs to save what is contained on surface to a bitmap file using my 256 color palette. I am lazy and would rather use someone else's code than wade into bitmaps formats. DDUtil and many other places have reading bitmaps from file and blitting them to surfaces, but not the return route. PLEASE HELP ME! Thanks in advance.

Follow Ups:

Post a Followup

Name:


DirectX5 with Visual c++ 4.0

Posted by Mike on April 11, 1998 at 21:46:51:

I won't repeat the title.
Anyway, I don't seem to have MSVCP50.DLL so DirectX5 stuff doesn't link.
Let me guess: its a file only found in MSVC5???
Is there any way to get DirectX5 to link in MSVC4?

Many thanks in advance.

Follow Ups:

  • Re: DirectX5 with Visual c++ 4.0 Falcon 11:02:28 4/12/98 (0)

Post a Followup

Name:


MFC and directx.

Posted by FooSi on April 11, 1998 at 23:23:42:

I am learning mfc but I want to use directx to make a
game. However, many people suggest me not using mfc for directx. But I don't know how to start writing program without mfc. Could you tell me how to write program without mfc or any website related?

Follow Ups:

  • Re: MFC and directx. Joe 13:06:51 4/16/98 (0)

Post a Followup

Name:


JPEG

Posted by Wolfgang R�ssler on April 12, 1998 at 09:37:45:

How can I load JPG Files?
Can anyone give me a description of the file format or sourcecode?

Follow Ups:

  • Re: JPEG Johnny Rotten 10:26:36 4/13/98 (0)

Post a Followup

Name:


Re: DirectX5 with Visual c++ 4.0

Posted by Falcon on April 12, 1998 at 11:02:28:

In Reply to: DirectX5 with Visual c++ 4.0 posted by Mike on April 11, 1998 at 21:46:51:

: I won't repeat the title.
: Anyway, I don't seem to have MSVCP50.DLL so DirectX5 stuff doesn't link.
: Let me guess: its a file only found in MSVC5???
: Is there any way to get DirectX5 to link in MSVC4?

Sure, if you have the DX5SDK installed then you just have to create an empty project,
add the .cpp file (ex. DDEX1.CPP).You also have to add ddraw.lib (or any other
lib needed)

Then choos build.

: Many thanks in advance.

Follow Ups:

Post a Followup

Name:


How do I convert 3dstudioMAX to .x format?

Posted by Christoffer Schr�der on April 13, 1998 at 07:54:41:

How do I convert 3dstudioMAX to .x format?
Any help will be appreciated.

Thanks in advance
Chris.

Follow Ups:

  • Re: How do I convert 3dstudioMAX to .x format? Roger 12:01:02 4/29/98 (0)

Post a Followup

Name:


Re: JPEG

Posted by Johnny Rotten on April 13, 1998 at 10:26:36:

In Reply to: JPEG posted by Wolfgang R�ssler on April 12, 1998 at 09:37:45:

: How can I load JPG Files?
: Can anyone give me a description of the file format or sourcecode?

I don't know if this will help or not, but you can get a whole "kit" from here:

  • Click here to download Jpeg kit

Follow Ups:

Post a Followup

Name:


Blitting DirectDraw surfaces onto Direct3D surfaces

Posted by John on April 13, 1998 at 15:03:51:

Is it possible? I've tried to blit a DirectDraw bitmap surface onto a Direct3D surface, but I failed at every attempt. Does anyone know how to do this?

I need to have some sort of way of displaying text (like a player's score) over a 3D surface.

Please help.
Thank you.

Follow Ups:

  • Re: Blitting DirectDraw surfaces onto Direct3D surfaces Eason 22:15:40 4/17/98 (0)

Post a Followup

Name:


How do I convert POV 3.0 files to *any* other format?

Posted by Jeff Boller on April 13, 1998 at 22:50:10:

Hi everybody,

I am trying to take .pov files (written with POV 3.0)
and convert them into .x files.

I have conv3ds.exe,
which takes a .3ds file and translates it into an .x
file. However, I cannot find a utility which will
convert a .pov 3.0 file into a .3ds file.
The closest I have been able to find is a beta program
called CROSSROADS, yet it does not support the importing
of POV 3.0 (it *does* support POV 2.2).

Any and all help will be appreciated!

Thanks in advance,

Jeff Boller
decorate@westol.com

Follow Ups:

  • Re: How do I convert POV 3.0 files to *any* other format? BoxMan 02:14:22 4/16/98 (0)

Post a Followup

Name:


D3D Retained Mode and BC++ Builder

Posted by Fr�d�ric LUCE on April 14, 1998 at 04:31:56:

I'm trying to use Direct3D retained mode with BC++Builder to
display a height-field (z=f(x,y) function). But it seems
to produce random invalid operation (EInvalidOp) or division by
zero (EDivideByZero). Sometimes, I can recover from these
exceptions, but only for a while.
Using debugger, I found that it crashes during a call to Render()
function (IDirect3DRMViewport method).
I compiled the 'viewer' exemple (with some minor modifications
to compile it properly with BC++Builder). It crashed with the same
error at the very beginning, it can recover and the Microsoft logo
turn in space for 180deg before a new exception.
It seems that some specific angles produce those crash.
Does anybody have the same (or nearly) problem ?
Is it a BC++Builder bug, a direct3D bug or have I done
something wrong ?

I can mail you the source code if you need.

Thanks

Fred

Follow Ups:

Post a Followup

Name:


Screen turns white using DirectDraw

Posted by David Naughton on April 14, 1998 at 11:47:13:

Hi,

I'm new to DirectDraw programming and so have not been able to work out the following problem.

The screen turns completely white at irregular interval. I've checked my program and this happens even when it is just waiting for a keypress. i.e. not doing anything with DirectDraw at all. Needless to say it's very annoying.

Also, if someone could tell me how to get rid of the mouse cursor when in fullscreen mode, that'd be a help too.

Thanks in advance,

Dave

Follow Ups:

  • Re: Screen turns white using DirectDraw Brian Shea 19:42:09 4/14/98 (1)
    • Thanks David Naughton 05:34:43 4/17/98 (0)

Post a Followup

Name:


...

Posted by Rok on April 14, 1998 at 13:55:44:

I've recently encountered people talking about directx 5.0 for nt4.0
being available. If anyone knows anything about it and where it could
be obtained I'd be very grateful.

Follow Ups:

Post a Followup

Name:


Directx 5.0 for NT???

Posted by Rok on April 14, 1998 at 14:00:21:

I've recently encountered people talking about directx 5.0 for nt4.0
being available. If anyone knows anything about it and where it could
be obtained I'd be very grateful.

sorry about this double post, I messed up the subject on the first one

Follow Ups:

  • Re: Directx 5.0 for NT??? Reefer 03:07:13 4/30/98 (0)

Post a Followup

Name:


DelphiX / Blitting

Posted by Ray on April 14, 1998 at 18:02:50:

Im using DelphiX DirectX Components in Delphi 3. And need a sampla on how to blitt from one part of the screen to another part of the screen using doubble buffer. Can somebody please mail me a sample...

Follow Ups:

Post a Followup

Name:


newbie here

Posted by Senan on April 14, 1998 at 18:31:51:

Hi there,
Do I have to have DirectX SDK in order to compile DirectX codes?

  • My Homepage

Follow Ups:

  • Re: newbie here Brian Shea 19:46:25 4/14/98 (0)

Post a Followup

Name:


Re: Screen turns white using DirectDraw

Posted by Brian Shea on April 14, 1998 at 19:42:09:

In Reply to: Screen turns white using DirectDraw posted by David Naughton on April 14, 1998 at 11:47:13:

Some drivers have a bug that cause the white
flash, make sure you have the latest versions
for your graphics card. To minimize the problem,
make sure to always handle window messages. If
you go off into some routine that take a long
time and stop responding, Windows might get the
idea that you have died and redraw your window
for you. Also, you can try setting the background
color for your window to NULL, which makes it
transparent.

As for hiding the mouse, you can set the mouse
pointer to null when you register your window
class or use SetCursor() and/or ShowCursor()
to hide the mouse, depending on your needs.

Brian

  • Journals of a DirectX Junkie

Follow Ups:

  • Thanks David Naughton 05:34:43 4/17/98 (0)

Post a Followup

Name:


Re: newbie here

Posted by Brian Shea on April 14, 1998 at 19:46:25:

In Reply to: newbie here posted by Senan on April 14, 1998 at 18:31:51:

Well, you could get by using whatever version
of DirectX your compiler comes with. But you
really should get the SDK, since it comes with
a ton of sample programs with source that you
can learn from. You can get the SDK from:
http://www.microsoft.com/directx/default.asp
They will send you a CD, which you may have
to spend a few dollars on. Or you can try to
download it from http://www.download.com, search
for "DirectX SDK". Or you can buy a book that
comes with it, like "Windows Game Programming for
Dummies", by Andre LaMothe.

Brian

  • Journals of a DirectX Junkie

Follow Ups:

Post a Followup

Name:


Error on rotating surface when blitting

Posted by Clay on April 14, 1998 at 23:05:43:

When I do this:

lpPrimary->Blt(&DestRect,
lpSrc,
&SrcRect,
DDBLT_KEYSRC|DDBLT_ROP|DDBLT_WAIT|DDBLTFX_NOTEARING|DDBLT_ROTATIONANGLE,
&fx
);
//The rotation angle I specify doesn't seem to matter...

I get a "one of the parameters passed to the function is invlaid" error. Removing the DDBLT_ROTATIONANGLE fixes this.

Any ideas?

Clay

Follow Ups:

  • Re: Error on rotating surface when blitting Madant 09:47:41 4/19/98 (0)

Post a Followup

Name:


I downt want much from DirectX but I need Help

Posted by Caine on April 15, 1998 at 07:40:08:

I havent found a good book abut DirectX .. but I have to Accsess it ..!
so the only thing for the first is that I want to
set the VideoMode .. and then get an poiter to the ViedeMemory..
thats all I need .. I cant use any Libs cause I have to transform 4 BpP images to 8 BpPixel
so .. there is no Lib which can do so .. ! I think ..! ..
Hope someOne can help me...!
Cu Caine..!

Follow Ups:

  • Re: I downt want much from DirectX but I need Help BoxMan 02:08:16 4/16/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 Download

Posted by Joe on April 15, 1998 at 12:40:16:

In Reply to: Re: DirectX 5.0 Download posted by Dani Llenas (FacOne) on March 18, 1998 at 16:09:59:

: Please, send me DirectX 5. I have the DirectX 2
: and this is a poor DirectX.

: Thanx!!!

Follow Ups:

Post a Followup

Name:


How do I use Clone? (object in D3DRM)

Posted by Lee Sandberg on April 15, 1998 at 17:45:56:

Whats a Punktuator???

Help!

Follow Ups:

  • Re: How do I use Clone? (object in D3DRM) Brian Marshall 15:40:57 5/15/98 (0)

Post a Followup

Name:


DirectPlay

Posted by Shane Wheeler on April 15, 1998 at 18:09:09:

Anyone out there have Windows95 Game Developers Guide Using The Game SDK? It seems this is about the only fairly complete reference on implementing DirectPlay. I tried running the TicTacToe game example provided in the book over an IPX network and the connecting players CPlayerSelDlg would never appear.... I checked out the EnumPlayers func call in the dialog and apparently he is calling it wrong.

//The OnInit() function for the dialog
if (m_pDirectPlay->EnumPlayers(0, EnumPlayers, (LPVOID)this,
DPENUMPLAYERS_SESSIONS ) == DP_OK)

use of the DPENUMPLAYERS_SESSION flag with this method must occur after the IDirectPlay2::EnumSessions method has been called, and before any calls to the IDirectPlay2::Close or IDirectPlay2::Open methods. Which if you look at his code in the CGame class this dialog is called in the DPConnectSession() function after the IDirectPlay2::Open method is called. So what gives???

I fixed this in my own application by changing the DPENUMPLAYERS_SESSION flag to DPENUMPLAYERS_ALL and the dialog enumerates the other player just fine. But I think there may be something else wrong as I don't seem to be receiving any messages in my event thread from the remote player and I can't seem to recompile the TicTacToe app with MSVC5.0 so I can't trouble shoot the authors code to see if it is something he overlooked.

Anyone follow me on this? Any help would be greatly appreciated.... that includes other references of DirectPlay samples/books... thanks in advance.

Shane

Follow Ups:

Post a Followup

Name:


Re: Program freezes with DirectDraw

Posted by BoxMan on April 15, 1998 at 19:56:27:

In Reply to: Program freezes with DirectDraw posted by David Salsman on April 04, 1998 at 20:14:15:

:When I run it (from Visual C++ 4) the first time, it seems okay. When I try to run it the second time, it runs for a second or two, and the freezes.

I'm *extremely* new to DirectX so you might not want to listen to me, but I had a similar problem with one of my programs.

The problem was with the Unlock procedure. I had used the memory location of the wrong variable and, in turn returned false information to the procedure so it Unlocked the surface incorrectly. My program locked up tighter than tight several times before I figured it out.

Follow Ups:

Post a Followup

Name:


Re: ddraw question

Posted by BoxMan on April 15, 1998 at 20:21:06:

In Reply to: Re: ddraw question posted by Clay on March 14, 1998 at 08:39:45:

I'd recommend programming your game/whatever in 16-bit color. the only problem with that is you took all that trouble to make 256-color images and you basically get 256-color graphics with the slowed-down 16-bit graphics you'd use. your choice

Follow Ups:

Post a Followup

Name:


My APP locks up with Alt-Tab

Posted by BoxMan on April 15, 1998 at 20:39:12:

I'm a big-time newbie...maybe 2 days of DirectX experience, so please help me out here! :�

I've done a little program that sets up the DirectX environment, creates a primary surface, and blits pixels directly to the surface using lock/unlock.

It works great, but when I try to Alt-Tab out, it generates TONS of error messages and the application eventually performs and illegal operation. How do I stop this??

Thanx! :D

Follow Ups:

  • Re: My APP locks up with Alt-Tab Brian Shea 00:26:33 4/17/98 (0)
  • Re: My APP locks up with Alt-Tab gravedancer 18:09:04 4/16/98 (0)

Post a Followup

Name:


Re: I downt want much from DirectX but I need Help

Posted by BoxMan on April 16, 1998 at 02:08:16:

In Reply to: I downt want much from DirectX but I need Help posted by Caine on April 15, 1998 at 07:40:08:

: I havent found a good book abut DirectX .. but I have to Accsess it ..!
: so the only thing for the first is that I want to
: set the VideoMode .. and then get an poiter to the ViedeMemory..
: thats all I need .. I cant use any Libs cause I have to transform 4 BpP images to 8 BpPixel
: so .. there is no Lib which can do so .. ! I think ..! ..
: Hope someOne can help me...!
: Cu Caine..!

Well, first of all, if you want to use DirectX for programming in any way...you're gonna have to use .lib files. Second of all, what it sounds like you want to do is just capture a screen from one of your games. You can easily do that with many screen capture programs for windows95 out on the market (look hard, you'll find some for free). And, last of all, if all you want to do is get a screenshot, then you can just convert your image from 4 bpp to 8 bpp with any of the more common graphics programs on the market.

Follow Ups:

Post a Followup

Name:


Re: How do I convert POV 3.0 files to *any* other format?

Posted by BoxMan on April 16, 1998 at 02:14:22:

In Reply to: How do I convert POV 3.0 files to *any* other format? posted by Jeff Boller on April 13, 1998 at 22:50:10:

: Hi everybody,

: I am trying to take .pov files (written with POV 3.0)
: and convert them into .x files.

: I have conv3ds.exe,
: which takes a .3ds file and translates it into an .x
: file. However, I cannot find a utility which will
: convert a .pov 3.0 file into a .3ds file.
: The closest I have been able to find is a beta program
: called CROSSROADS, yet it does not support the importing
: of POV 3.0 (it *does* support POV 2.2).

: Any and all help will be appreciated!

: Thanks in advance,

: Jeff Boller
: decorate@westol.com

Well, if you're into *heavy-duty* programming, you could probably find the format of that file here:

  • Wotsit's File Formats

Follow Ups:

Post a Followup

Name:


Re: MFC and directx.

Posted by Joe on April 16, 1998 at 13:06:51:

In Reply to: MFC and directx. posted by FooSi on April 11, 1998 at 23:23:42:

: I am learning mfc but I want to use directx to make a
: game. However, many people suggest me not using mfc for directx. But I don't know how to start writing program without mfc. Could you tell me how to write program without mfc or any website related?

Since Microsoft made DirectX, I would suggest using the
Microsoft Foundation Classes to program your game.

Not that it would be better or worse: just because it
will work and also cause i have found a few helpful
resources.

Check out the link below to see an AppWizard for VC++
which will ease the creation of a DirectDraw program.
(No plug for Mr. Trujillo, but try and get his books
too, they are pretty good overviews with just enough
of the details.)

There is also one for Direct3d applications.

One may also want to check out the Visual C++ Journal
online... sorry, i don't have the URL on me right now.

Good luck.
joe

Follow Ups:

Post a Followup

Name:


Re: NEED HELP!

Posted by Crist�an Torner�a on April 16, 1998 at 14:45:58:

In Reply to: NEED HELP! posted by Matti Kosunen on March 05, 1998 at 16:00:16:

I have the Diamond Stheal 3D 2000 Pro , when i install the Directx 5.0 ...the Direct3D not work ... What i can do?
Sorry for my bad english ... i'm chilean ( Chino Rios #1 of Tennis )
when i install the directx 3.0 from the CD Diamond Stheal 3D 2000 Pro , the Direct3D work
Compatibility? i don't know...
Help meeeee...
Thanks

P.D.: where i can get Directx 5.0 compatibility whit my video card?

Follow Ups:

Post a Followup

Name:


smoke and flames

Posted by gravedancer on April 16, 1998 at 17:59:33:

anyone know of good ways to generate really cool smoke, explosions and skies? the hardware in question is a pentium II/AGP machine with ATI Rage card, so things like alpha blending are no problem.i am using D3DIM - but am not doing my own transf or lighting so am using D3DVERTEXs

Follow Ups:

  • Re: smoke and flames Sheath 16:27:13 4/19/98 (0)

Post a Followup

Name:


Re: My APP locks up with Alt-Tab

Posted by gravedancer on April 16, 1998 at 18:09:04:

In Reply to: My APP locks up with Alt-Tab posted by BoxMan on April 15, 1998 at 20:39:12:

fortunately, ur prob has a simple soln. below is relevant stuff from the help file

Surfaces can lose their memory when the mode of the display card is changed, or when an application receives exclusive access to the display card and frees all of the surface memory currently allocated on the display card.

The IDirectDrawSurface3::IsLost method determines if the surface memory associated with a DirectDrawSurface object has been freed.

HRESULT IsLost();

Return Values

If the method succeeds, the return value is DD_OK because the memory has not been freed.

The IDirectDrawSurface3::Restore method restores a surface that has been lost. This occurs when the surface memory associated with the DirectDrawSurface object has been freed.

HRESULT Restore();

Follow Ups:

Post a Followup

Name:


Re: D3DRM Texturing!!

Posted by Jason on April 16, 1998 at 23:30:42:

In Reply to: D3DRM Texturing!! posted by Shai'tan on April 04, 1998 at 06:42:24:

I'm having the exact same problem. I'm trying to create an inverted sphere (the normals to all the faces point inward instead of outward) to use as a starfield.
I use AddGroup which seems to work along with SetVertices. This adds the faces and their respective positions to the mesh. However, when I use SetGroupTexture,
the texture does not appear on any of the faces, or all the faces change to a solid color that exists in the texture, or weird patterns occur on the faces.

I load the inverted sphere into a MeshBuilder object. I get a FaceArray from the MeshBuilder. I then loop through all the faces and get the vertex data for
each face. I create a temp Mesh object and use AddGroup on each face and then add the Mesh as a visual object to my "starfield" frame.

If anyone knows how to get textures to properly appear on the faces, please let me know.

Thanks

Follow Ups:

  • Re: D3DRM Texturing!! Lou 09:26:00 5/16/98 (0)

Post a Followup

Name:


Re: My APP locks up with Alt-Tab

Posted by Brian Shea on April 17, 1998 at 00:26:33:

In Reply to: My APP locks up with Alt-Tab posted by BoxMan on April 15, 1998 at 20:39:12:

If you are locking the primary surface, you should
probably unlock the surface before you lose focus
and then relock when you regain the focus. Probably
a better idea to lock a system memory surface and
blit that to the primary. Another thing you
should watch out for are lost surfaces, which
you can regain by calling Restore(), as mentioned
in another post. And a final thing is that the
surface pointer is not guarenteed to be the same
forever. So do not lock the surface, grab the
pointer, unlock the surface, and keep on using
the pointer.

  • Journals of a DirectX Junkie

Follow Ups:

Post a Followup

Name:


DirectX input

Posted by David Carter on April 17, 1998 at 01:23:33:

How do I get the mouse to work after I have a Bitmap displayed on the screen using Direct Draw? Hope someone can help.

Follow Ups:

  • Re: DirectX input Johnny Rotten 10:01:30 4/17/98 (1)
    • Re: DirectX input David Carter 02:44:36 4/18/98 (0)

Post a Followup

Name:


Help

Posted by David Carter on April 17, 1998 at 01:30:55:

In Reply to: Re: Help, I'm a stupid newbie posted by Roger on April 09, 1998 at 19:52:32:

Did you include the .rc file? It's the file in the same directory as the .cpp file that you are using, if it's the examples.

Follow Ups:

Post a Followup

Name:


Thanks

Posted by David Naughton on April 17, 1998 at 05:34:43:

In Reply to: Re: Screen turns white using DirectDraw posted by Brian Shea on April 14, 1998 at 19:42:09:

: Some drivers have a bug that cause the white
: flash, make sure you have the latest versions
: for your graphics card. To minimize the problem,
: make sure to always handle window messages. If
: you go off into some routine that take a long
: time and stop responding, Windows might get the
: idea that you have died and redraw your window
: for you. Also, you can try setting the background
: color for your window to NULL, which makes it
: transparent.

: As for hiding the mouse, you can set the mouse
: pointer to null when you register your window
: class or use SetCursor() and/or ShowCursor()
: to hide the mouse, depending on your needs.

: Brian

Thanks,

That seems to clear up my problems

Dave

Follow Ups:

Post a Followup

Name:


Re: DirectX input

Posted by Johnny Rotten on April 17, 1998 at 10:01:30:

In Reply to: DirectX input posted by David Carter on April 17, 1998 at 01:23:33:

: How do I get the mouse to work after I have a Bitmap displayed on the screen using Direct Draw? Hope someone can help.

Can you be a little more specific? What is it you're trying to do. Unless you've hidden the mouse cursor or set it to NULL when you're window is created, you should see it.

Johnny

Follow Ups:

  • Re: DirectX input David Carter 02:44:36 4/18/98 (0)

Post a Followup

Name:


Watcom and DirectX

Posted by Marco on April 17, 1998 at 13:06:40:

There is someone that know if is it possible to
use directx with Watcom c++?
If yes, what version of watcom must I buy?

thank you

Follow Ups:

  • Re: Watcom and DirectX Ron Bakker 17:29:54 4/17/98 (0)

Post a Followup

Name:


MAX material to D3DMATERIAL conversion

Posted by gravedancer on April 17, 1998 at 16:56:06:

i am having problems converting some MAX material properties into their D3D counterparts.

one of them is self-illumination which is an integer from 1 to 100 in the materials floater (or a float from 0 to 1 via the SDK). the D3D counterpart is the emissive member of the D3DMATERIAL struc, but it's not obvious to me how to convert between these two.

another is the specular hilite. MAX has two parameters to control appearance of spec hilites viz shininess and shin. strength but D3DMATERIAL just has power. i think power = shininess but i'm not quite sure.

can anyone help???

Follow Ups:

Post a Followup

Name:


Re: Watcom and DirectX

Posted by Ron Bakker on April 17, 1998 at 17:29:54:

In Reply to: Watcom and DirectX posted by Marco on April 17, 1998 at 13:06:40:

: There is someone that know if is it possible to
: use directx with Watcom c++?

Yes it's possible .... Watcom supports the correct library-format used by DirectX. Although you have to use stack based calling conventions during compilation.

: If yes, what version of watcom must I buy?

I use Watom 11.0 myself .... sure it supports MMX since this version ... but it contains some little bugs in the IDE and help-files. You can get around these ...
Well, that's not that important when linking to DirectX .. all you have to do is make sure that your version of Watcom supports Win32 Applications

: thank you

You're welcome

Ron

Follow Ups:

Post a Followup

Name:


Rotation

Posted by Inf on April 17, 1998 at 18:20:33:

Hello, I've started programming a game for Direct-X.
My problem is: Which is the easiet way to rotate a sprite. I can't have 1 frame for every direction?!

Follow Ups:

  • Re: Rotation Johnny Rotten 16:11:41 4/21/98 (0)

Post a Followup

Name:


How Do I Use IID's (for cloning) In C? Or Can't I?

Posted by sietze on April 17, 1998 at 20:26:33:

Hello All,

I'm having trouble. Big trouble. I'm using C for writing
a cool game (IMHO ;)), and now I want to clone a
MeshBuilder object into several different (asteroids).
Question is: how do I do this in C? I've already seen
how it is done in C++, but i'm using plain (ANSI) C, and
this will not change in the forseeable future. But when
I specify an IID_IDirect3DRMMeshbuilder2 (or any IID),
I get a compiler error stating that I use "incompatible
types". What is happening here?

TIA,

Sietze Dijkstra

Follow Ups:

  • Re: How Do I Use IID's (for cloning) In C? Or Can't I? markus 14:46:52 5/18/98 (0)

Post a Followup

Name:


DirectX 5.0

Posted by Guy Lanzone on April 17, 1998 at 21:57:55:

Where can I download DirectX 5.0?
Can someone please help..

Follow Ups:

  • Re: DirectX 5.0 David 12:07:33 5/01/98 (0)
  • Re: DirectX 5.0 nam ki min 20:19:45 4/21/98 (0)
  • Re: DirectX 5.0 Pavel Bure 21:27:59 4/19/98 (0)
  • Re: DirectX 5.0 Juliano F. Ferreira 22:30:05 4/18/98 (0)
  • Re: DirectX 5.0 Brian Shea 14:55:39 4/18/98 (0)

Post a Followup

Name:


Re: Blitting DirectDraw surfaces onto Direct3D surfaces

Posted by Eason on April 17, 1998 at 22:15:40:

In Reply to: Blitting DirectDraw surfaces onto Direct3D surfaces posted by John on April 13, 1998 at 15:03:51:

: Is it possible? I've tried to blit a DirectDraw bitmap surface onto a Direct3D surface, but I failed at every attempt. Does anyone know how to do this?

: I need to have some sort of way of displaying text (like a player's score) over a 3D surface.

: Please help.
: Thank you.

how about trying to use an overlay surface?

Follow Ups:

Post a Followup

Name:


Re: DirectX input

Posted by David Carter on April 18, 1998 at 02:44:36:

In Reply to: Re: DirectX input posted by Johnny Rotten on April 17, 1998 at 10:01:30:

: : How do I get the mouse to work after I have a Bitmap displayed on the screen using Direct Draw? Hope someone can help.

: Can you be a little more specific? What is it you're trying to do. Unless you've hidden the mouse cursor or set it to NULL when you're window is created, you should see it.

: Johnny

Ok maybe I will just show the code. Then maybe you or someone else can show me what I am missing or doing wrong.

Code is as follows (not including lib and rc file)

#include
#include
#include
#include "resource.h"
#include "ddutil.h"
#include

#define NAME "DDExample5"
#define TITLE "Direct Draw Example 5"
#define WIN32_LEAN_AND_MEAN

#define DINPUT_BUFFERSIZE 16

char szBitmap[] = "ALL";

LPDIRECTDRAW lpDD; // DirectDraw object
LPDIRECTDRAWSURFACE lpDDSPrimary; // DirectDraw primary surface
LPDIRECTDRAWSURFACE lpDDSBack; // DirectDraw back surface
LPDIRECTDRAWSURFACE lpDDSOne; // Offscreen surface 1
LPDIRECTDRAWPALETTE lpDDPal; // The primary surface palette
LPDIRECTINPUT g_pdi;
LPDIRECTINPUTDEVICE g_pMouse;

HANDLE g_hevtMouse;
BOOL bActive, g_fActive; // is application active?

LRESULT CALLBACK WindowProc( HWND hWnd, UINT message,
WPARAM wParam, LPARAM lParam )
{

switch( message )
{
case WM_ACTIVATEAPP:
bActive = wParam;
break;

case WM_CREATE:
break;

case WM_KEYDOWN:
switch( wParam )
{
case VK_ESCAPE:
case VK_F12:
PostMessage(hWnd, WM_CLOSE, 0, 0);
break;
}
break;

case WM_DESTROY:
PostQuitMessage( 0 );
break;
}

return DefWindowProc(hWnd, message, wParam, lParam);

} /* WindowProc */

int WINAPI WinMain( HINSTANCE hInstance, HINSTANCE hPrevInstance,
LPSTR lpCmdLine, int nCmdShow)
{
MSG msg;
HWND hwnd;
WNDCLASS wc;
DDSURFACEDESC ddsd;
DDSCAPS ddscaps;
HRESULT ddrval, hr;

lpCmdLine = lpCmdLine;
hPrevInstance = hPrevInstance;

/*
* set up and register window class
*/
wc.style = CS_HREDRAW | CS_VREDRAW;
wc.lpfnWndProc = WindowProc;
wc.cbClsExtra = 0;
wc.cbWndExtra = 0;
wc.hInstance = hInstance;
wc.hIcon = LoadIcon( hInstance, IDI_APPLICATION );
wc.hCursor = LoadCursor( 0, IDC_ARROW );
wc.hbrBackground = GetStockBrush(BLACK_BRUSH);
wc.lpszMenuName = NAME;
wc.lpszClassName = NAME;

RegisterClass( &wc );

/*
* create a window
*/
hwnd = CreateWindowEx(
0,
NAME,
TITLE,
WS_POPUP,
0,
0,
GetSystemMetrics(SM_CXSCREEN),
GetSystemMetrics(SM_CYSCREEN),
NULL,
NULL,
hInstance,
NULL );

if( !hwnd )
{
return FALSE;
}

ShowWindow( hwnd, nCmdShow );
UpdateWindow( hwnd );
SetFocus( hwnd );

/*
* create the main DirectDraw object
*/
ddrval = DirectDrawCreate( NULL, &lpDD, NULL );

// Get exclusive mode
ddrval = lpDD->SetCooperativeLevel( hwnd, DDSCL_EXCLUSIVE | DDSCL_FULLSCREEN );

// Set the video mode to 640x480x8
ddrval = lpDD->SetDisplayMode( 640, 480, 8);

ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_BACKBUFFERCOUNT;
ddsd.ddsCaps.dwCaps = DDSCAPS_PRIMARYSURFACE |
DDSCAPS_FLIP | DDSCAPS_COMPLEX;

ddsd.dwBackBufferCount = 1;

ddrval = lpDD->CreateSurface(&ddsd, &lpDDSPrimary, NULL);

ddscaps.dwCaps = DDSCAPS_BACKBUFFER;
ddrval = lpDDSPrimary->GetAttachedSurface(&ddscaps, &lpDDSBack);

lpDDPal = DDLoadPalette(lpDD, szBitmap);

ddrval = lpDDSPrimary->SetPalette(lpDDPal);

ddrval = DDReLoadBitmap(lpDDSBack, szBitmap);

ddrval = lpDDSPrimary->Flip(NULL, 0);

hr = DirectInputCreate(hInstance, DIRECTINPUT_VERSION, &g_pdi, NULL);

hr = g_pdi->CreateDevice(GUID_SysMouse, &g_pMouse, NULL);

hr = g_pMouse->SetDataFormat(&c_dfDIMouse);

hr = g_pMouse->SetCooperativeLevel(hwnd,
DISCL_EXCLUSIVE | DISCL_FOREGROUND);

g_hevtMouse = CreateEvent(0, 0, 0, 0);

hr = g_pMouse->SetEventNotification(g_hevtMouse);

DIPROPDWORD dipdw =
{
// the header
{
sizeof(DIPROPDWORD), // diph.dwSize
sizeof(DIPROPHEADER), // diph.dwHeaderSize
0, // diph.dwObj
DIPH_DEVICE, // diph.dwHow
},
// the data
DINPUT_BUFFERSIZE, // dwData
};

hr = g_pMouse->SetProperty(DIPROP_BUFFERSIZE, &dipdw.diph);

hr = g_pMouse->Acquire(); /* Not as in book */

while( 1 )
{

if( PeekMessage( &msg, NULL, 0, 0, PM_NOREMOVE ) )
{
if( !GetMessage( &msg, NULL, 0, 0 ) )
{
return msg.wParam;
}
TranslateMessage(&msg);
DispatchMessage(&msg);
}
else if( bActive )
{
// make sure we go to sleep if we have nothing else to do
WaitMessage();
}

}

} /* WinMain */

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0

Posted by Brian Shea on April 18, 1998 at 14:55:39:

In Reply to: DirectX 5.0 posted by Guy Lanzone on April 17, 1998 at 21:57:55:

: Where can I download DirectX 5.0?
: Can someone please help..

You can order a CD from Microsoft via "http://www.microsoft.com/directx/default.asp".
Or try http://www.download.com and search for "DirectX SDK".

  • Journals of a DirectX Junkie

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0

Posted by Juliano F. Ferreira on April 18, 1998 at 22:30:05:

In Reply to: DirectX 5.0 posted by Guy Lanzone on April 17, 1998 at 21:57:55:

: Where can I download DirectX 5.0?
: Can someone please help..

Follow Ups:

Post a Followup

Name:


unresolved external symbol _main with SDK

Posted by Steve M on April 18, 1998 at 22:33:30:

Hiyas. First, what a wonderful place this is for DX info.
Second: I think it would be extremely helpful if only I could get some of the MS samples to compile...

What am I doing wrong? I have the directories all set up, and I am linking the appropriate libraries (ddraw.lib and dxguid.lib, yet this error is driving me nuts...

Thanks for the help :)

Follow Ups:

  • Re: unresolved external symbol _main with SDK Brian Shea 02:49:45 4/20/98 (1)
    • Thanks I'll check it out Steven M 20:32:03 4/20/98 (0)
  • Re: unresolved external symbol _main with SDK BoxMan 02:20:14 4/20/98 (0)

Post a Followup

Name:


Where to find landscape meshes

Posted by Joe on April 18, 1998 at 23:08:38:

Can anyone out there help me find a landscape generator
that writes mesh/polygonal/object file (like .3ds, .x,
.obj, .anything but 2d images)?

Or are there any large areas where such meshes are
already available for use?

Any suggestions would be helpful. If possible, does
anyone have much experience trying to create 3d "worlds"
(a landscape == world in a sense) which could be made
into meshes? I use 3ds Max 2.5 (the beta version!) and
am not having much luck...

thanks in advance.

Follow Ups:

  • Re: Where to find landscape meshes EvAcLeAr 19:27:00 5/18/98 (0)
  • Re: Where to find landscape meshes Navin 04:59:30 5/18/98 (0)

Post a Followup

Name:


Re: Error on rotating surface when blitting

Posted by Madant on April 19, 1998 at 09:47:41:

In Reply to: Error on rotating surface when blitting posted by Clay on April 14, 1998 at 23:05:43:

It's easy. Rotating doesn't work in DX 5.0.
We can only hope it will work in 6.0.

Follow Ups:

Post a Followup

Name:


Re: read two key at once

Posted by Madant on April 19, 1998 at 09:52:56:

In Reply to: read two key at once posted by Sen Tran on April 11, 1998 at 04:14:28:

: Hi. I need help setting up joystick or keyboard that could simutaneously read 2 key at once.

No problem. Add to your program

case WM_KEYDOWN:
my_key[wParam] = 1;
break;

case WM_KEYUP:
my_key[wParam] = 0;
break;

and then test f.e.
if (my_key['A'] && my_key['B'])

enjoy it

Madant

Follow Ups:

Post a Followup

Name:


Newbie

Posted by Brent on April 19, 1998 at 15:41:52:

A friend of mine has a Hitachi M series lap top that came with windows 95 on it. He then put DirectX 5.0 on it. He gets the error message -- Direct Draw , Requires windows 95 compatible Drivers --- whenever he tries to play any game that requires the DirectX.

Since I am not fully computer literate can anyone give me a few hints on how to get his computer running these game so I can stomp him on some head to head action.

Follow Ups:

  • Re: Newbie Sheath 16:22:57 4/19/98 (1)
    • Re: Newbie BoxMan 02:23:55 4/20/98 (0)

Post a Followup

Name:


Re: Newbie

Posted by Sheath on April 19, 1998 at 16:22:57:

In Reply to: Newbie posted by Brent on April 19, 1998 at 15:41:52:

Your friends problem lies in the system drivers
that came with Windows 95. Somehow, the Direct
Draw drivers were not written to work with
your friends particular set of drivers.
This could happen if his drivers are bad,
corrupted, or tampered with. Try running
a virus checker first. If that doesn't work,
you may want to try reinstalling Win95/DirectX.
If neither of these work, send an email to the
customer support at Microsoft, or the DirectX
support. Tell them the EXACT model of the
computer, the DirectX version, and the exact
error message.

  • Microsoft's Webpage

Follow Ups:

  • Re: Newbie BoxMan 02:23:55 4/20/98 (0)

Post a Followup

Name:


Re: smoke and flames

Posted by Sheath on April 19, 1998 at 16:27:13:

In Reply to: smoke and flames posted by gravedancer on April 16, 1998 at 17:59:33:

That's easy. First of all, find yourself a good
example of a fire generator. These are fairly
easy to find, simply type in "Flames in C++" at
a search engine(Try it at metacrawler.com)
next, you have to change the math a little
(It's not TOO complicated) to do what you need.
For example, for smoke, you could simply
chagne the color palette to use greys. explosions
are easily ported from fire. Finally, for
the skies, this is easiest done by taking animated
sprites and randomly placing/moving them on a
background/color.

Follow Ups:

Post a Followup

Name:


DXF and DirectX

Posted by Frank on April 19, 1998 at 17:36:13:

Does anyone know of any software source code in c or c++ that converts DXF to Directx?

Follow Ups:

Post a Followup

Name:


Snycronisation of 3D-Hardware

Posted by Christoph St�ber on April 19, 1998 at 21:05:04:

Direct3D-Immediate-Mode using 3dfx-accelerator
Visial C++ 5.0

I have a high improvement of performance
when I turn off "Sync Direct 3D to refresh" option
in the Voodoo-Graphics Control panel. (Display Settings)
My program has a higher fps-rate but other programs
like benchmarks or games slow down.

-What does this option mean ?
-How can I improve my program's performance without
turning off that option ?

My front and backbuffer are in HW-Memory and I'm
processing only 3D commands.

-Do I have to change my main-loop?

MainLoop() //called by the message-loop in WinMain
{
ClearBackBuffer();
CalculateVisiblity();
Physics();
DrawPrimitive(); //should I use D3DDP_WAIT?
Flip(); //should I use FLIP_WAIT?
}

Thanks in advance

Christoph St�ber
Hobby Programmer

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0

Posted by Pavel Bure on April 19, 1998 at 21:27:59:

In Reply to: DirectX 5.0 posted by Guy Lanzone on April 17, 1998 at 21:57:55:

: Where can I download DirectX 5.0?
: Can someone please help..

Follow Ups:

Post a Followup

Name:


No I haven't, and I don't think I will need to.

Posted by AIR_TIME on April 20, 1998 at 02:19:08:

In Reply to: Have you checked out "Windows Programming for Dummies?" posted by Ryan Fenton on April 10, 1998 at 19:50:53:

Thanks for the info, however I am rolling right along with this directX stuff.
"Spells of Fury" is a great book, it uses DirectX 2.0, but its so easy to understand the code, and the author explains everything without using a bunch of mumbo jumbo..he just goes right to the point, but yet explains everything in depth.

I have started to make my own DirectDraw CLASS..and its really working so far, so far it creates surfaces, object, pallate, and soon will do blitting and flipping...I think making a class of this stuff is way easier, I just have to type a couple function calls in my Generic win32 code..and its all set...easy..comparied to how the SDK help has stuff.

I'm actually about to start to make a side scrolling shootem up game, but Im really bad at drawing things in photoshop.

: No, that wasn't an insult, it's actually a most excellent book.
: It's by the same guy who did the "Black art of Game Programming" book, and it deals with DirectX 5.0, and only costs around $30 (I got mine for 20 at a local books-a-million.) All I can say is that that book rocks. It probably saved me months in tying all the "big picture" elements together. It only deals with directdraw in depth, but shows how to work with the other DX components after you've learned directdraw. It goes through the process of making one directx wrapper, and one bad (in a good way) game, and does it in a way that doesn't treat the subject as religeon, but makes it (dare I say it?) kinda fun to learn, and easy to alter because you don't have some over-inflated sense of importance with the programs that makes you afraid to just mess with things. I heartily recomend it, if only for a good laugh, and to help get rid of any of those unsettling feelings you might get when ripping into DirectX for the first time, like I was.

: Ryan Fenton

Follow Ups:

Post a Followup

Name:


Re: unresolved external symbol _main with SDK

Posted by BoxMan on April 20, 1998 at 02:20:14:

In Reply to: unresolved external symbol _main with SDK posted by Steve M on April 18, 1998 at 22:33:30:

: What am I doing wrong? I have the directories all set up, and I am linking the appropriate libraries (ddraw.lib and dxguid.lib, yet this error is driving me nuts...

Main() is used (pretty much) strictly by dos programs. If you're programming windows applications, you have to use WinMain().

: Thanks for the help :)

No problem :D

Follow Ups:

Post a Followup

Name:


Re: Newbie

Posted by BoxMan on April 20, 1998 at 02:23:55:

In Reply to: Re: Newbie posted by Sheath on April 19, 1998 at 16:22:57:

If none of that works, try going to the web site of the video card manufacturer. Maybe they have an updated driver for that card.

P.S. Isn't this a programming list?? :)

Follow Ups:

Post a Followup

Name:


2 questions...

Posted by BoxMan on April 20, 1998 at 02:37:59:

I've got two questions:

#1:
I've got my program working so it doesn't lock up
when I press Alt-tab, but (naturally) the surface is lost. So, I call Primary->Restore() to restore the surface. The only problem is, it doesn't work! After I restore the surface, and I call Primary->IsLost() it still returns DDERR_SURFACELOST. Has anyone else had this happen to them?

#2:
I know it's a pain, but would it be inadvisable to release all surfaces and your directdraw object when the application goes inactive, then create each of them again when it becomes active again? I've tested it and it *seems* quite foolproof and Windows will run a lot faster while your program is inactive.
Are there any downfalls to doing this? (other than a little xtra coding?)

Thanx :)

~BoxMan~

Follow Ups:

  • Re: 2 questions... Brian Shea 02:59:07 4/20/98 (0)

Post a Followup

Name:


Re: unresolved external symbol _main with SDK

Posted by Brian Shea on April 20, 1998 at 02:49:45:

In Reply to: unresolved external symbol _main with SDK posted by Steve M on April 18, 1998 at 22:33:30:

I have a page that has a step by step explanation
of all of this. It also has a VC++ workspace
that has projects for all of the sample programs
that come with the SDK (well all but two).
Try starting at:
http://www.angelic-coders.com/bpshea/journal/day02.htm

  • Journals of a DirectX Junkie

Follow Ups:

  • Thanks I'll check it out Steven M 20:32:03 4/20/98 (0)

Post a Followup

Name:


Re: 2 questions...

Posted by Brian Shea on April 20, 1998 at 02:59:07:

In Reply to: 2 questions... posted by BoxMan on April 20, 1998 at 02:37:59:

: #1:
I have not seen this happen.

: #2:
About the only drawback I can see is performance;
creating is slower that restoring. Just make sure
that you are not leaking any objects, since this
will accumulate over time and crash your program.
Also, neither approach should affect other apps.
You main game loop should stop doing work when
you lose focus, unless you are doing some kind of
multi-player game, in which case it should still
be keeping up with game state and so on.

  • Journals of a DirectX Junkie

Follow Ups:

Post a Followup

Name:


DirectX plugins?

Posted by Tommi Prami on April 20, 1998 at 03:52:33:

I heard about DirectX audio plugins an d need more info
abbout it...
So... if you have any info about it mail me (programming
and so on...)

tommi.prami@aedu.kuopio.fi

Follow Ups:

Post a Followup

Name:


Thanks I'll check it out

Posted by Steven M on April 20, 1998 at 20:32:03:

In Reply to: Re: unresolved external symbol _main with SDK posted by Brian Shea on April 20, 1998 at 02:49:45:

: I have a page that has a step by step explanation
: of all of this. It also has a VC++ workspace
: that has projects for all of the sample programs
: that come with the SDK (well all but two).
: Try starting at:
: http://www.angelic-coders.com/bpshea/journal/day02.htm

Thanks I'll have a look at your page. I think it has something to do with (after 5 hours of playing with VC settings) choosing Win32 App vs. Win32 Console when setting up the project. Why, however, is beyond me. Looking at the linker error def could it be VC is linking some library (nothing to do with DX) that doesn't like to be linked with DX?

Follow Ups:

Post a Followup

Name:


Opinions wanted of the best

Opinions wanted of the best <$200 modeler/renderer/animator for Direct3D

[ Follow Ups ] [ Post Followup ] [ the DirectX eXperience Forum ]

Posted by Boller on April 20, 1998 at 20:48:55:

Hi everybody,

Just wondering what programs everyone is using out
there to create their models for Direct3D applications.

I'm looking to buy a modeler/renderer/animator under
$200 to create models and animations for my D3D
programs, and I'm looking for suggestions and opinions...
Ease of use and the ability to export valid .3ds files
(so I can convert them to .X files with conv3ds with
texture maps intact) are my primary concerns. I'd like
a decent animator built in.

I've been looking at websites and demos, but nothing
compares to hearing what people out there are truly
using and why they love/hate it.

Thanks for your help!

Jeff Boller
decorate@westol.com

Follow Ups:

  • Re: Opinions wanted of the best <$200 modeler/renderer/animator for Direct3D EvAcLeAr 19:15:36 5/18/98 (0)
  • Re: Opinions wanted of the best <$200 modeler/renderer/animator for Direct3D Lou 09:16:36 5/16/98 (0)

Post a Followup

Name:


Balance, Harmony, Docs, and Direct X

Posted by Steven M on April 20, 1998 at 20:49:53:

I guess it is simply asking for too much. Microsoft seems to be determined to turn everything into 'the internet' (perhaps a market strategy designed for long term dominance - or maybe some foolhardy programmers have an idyllic notion of this not so perfect medium of information exchange...).

Visual C++ requires IE 3.0, which I learned after a few system crashes due to having IE 4.0 installed. And the docs, ohhhhh the docs... What I wouldn't give for a few solid volumes of large print text, complete with organized chapters and indices, where I can actually LOOK SOMETHING UP and find it, instead of having the 'search' function return me 10^6 useless entries...
The worst part is, I can't even take my PC into the bathroom to have a good read. Is it just me, or doesn't everyone understand fundamental concepts better while taking a dump? Perhaps the Microsoft boys & gals are trying to reduce lap-top prices...

And it could be argued that this is done for the green, the greater good. Save the environment, save the forests and the trees. And instead burn electricity...

No, there is no excuse. I find the docs for VC and ESPECIALLY the Direct X SDK profoundly lacking in everything. Yes, there are some sample applications (otherwise no one would understand this stuff) and a few function references, but - for example: I would like to know which function is in what library. Yes, we can tell the obvious ones - Ddraw functions are supported in the ddraw.lib, Dsound in dsound.lib...but what about the 49 other functions my linker doesn't agree with...which file did I forget to include in my build? Sadly, all of this is undocumented.

Does anyone, anywhere, have a list of functions and their respective libraries/header/source files?

Can anyone help me make sense of Micros**t (tm)'s mess?

Thanks. Sorry for rambling :)

Follow Ups:

  • Re: Balance, Harmony, Docs, and Direct X Johnny Rotten 11:23:27 4/21/98 (0)

Post a Followup

Name:


video cards are not all alike

Posted by Robert Carra on April 21, 1998 at 10:34:21:

I've been testing some code out on several pcs...

Some video cards allow me to change the bits per pixle
(during exlusive, full screen mode, of course) but others
do not. I seem to only be able to change screen width,
and height on those cards.

Is there a secret to get around this problem? I do not
want to have to manually change a desktop to get this to
run.

By the way, for beginners, this may solve a problem you
are having if you have an unlucky video card!

Bob.

Follow Ups:

Post a Followup

Name:


Re: Balance, Harmony, Docs, and Direct X

Posted by Johnny Rotten on April 21, 1998 at 11:23:27:

In Reply to: Balance, Harmony, Docs, and Direct X posted by Steven M on April 20, 1998 at 20:49:53:

I found the documentation to be quite helpful. You just have to read it with a small understanding: it's like they forego all the foreplay and just shag you to death, don't they? They don't waste time with a "Hello World" demo, they just give you the meat of the matter. I wouldn't suggest printing the documentation - you'll only waste time and energy doing that and there isn't an index anyway. Instead, when you are looking for a function or structure, open up the documentation in your favorite word processor and search for the keyword. You may have to hit F3 a couple of times, but you'll eventually come across a big bold FUNCTION NAME and from there you can find what library it's from. Take the time and just skim through all the docs. You won't retain much tecnical mumbo jumbo about DirectX but you'll be amazed at how familiar the structure will become. It's hard starting out, I know, but once you've made a few programs, you'll find that most of the functions in the documentation will be of little use to you. You'll become very familiar with some, others will become "boiler plate", while the others are just a bunch of razamatazz.

Johnny

: I guess it is simply asking for too much. Microsoft seems to be determined to turn everything into 'the internet' (perhaps a market strategy designed for long term dominance - or maybe some foolhardy programmers have an idyllic notion of this not so perfect medium of information exchange...).

: Visual C++ requires IE 3.0, which I learned after a few system crashes due to having IE 4.0 installed. And the docs, ohhhhh the docs... What I wouldn't give for a few solid volumes of large print text, complete with organized chapters and indices, where I can actually LOOK SOMETHING UP and find it, instead of having the 'search' function return me 10^6 useless entries...
: The worst part is, I can't even take my PC into the bathroom to have a good read. Is it just me, or doesn't everyone understand fundamental concepts better while taking a dump? Perhaps the Microsoft boys & gals are trying to reduce lap-top prices...

: And it could be argued that this is done for the green, the greater good. Save the environment, save the forests and the trees. And instead burn electricity...

: No, there is no excuse. I find the docs for VC and ESPECIALLY the Direct X SDK profoundly lacking in everything. Yes, there are some sample applications (otherwise no one would understand this stuff) and a few function references, but - for example: I would like to know which function is in what library. Yes, we can tell the obvious ones - Ddraw functions are supported in the ddraw.lib, Dsound in dsound.lib...but what about the 49 other functions my linker doesn't agree with...which file did I forget to include in my build? Sadly, all of this is undocumented.

: Does anyone, anywhere, have a list of functions and their respective libraries/header/source files?

: Can anyone help me make sense of Micros**t (tm)'s mess?

: Thanks. Sorry for rambling :)

Follow Ups:

Post a Followup

Name:


HELP--PUTTING TEXTURED MESH ON ANOTHER TEXTURED MESH

Posted by Chris on April 21, 1998 at 13:15:17:

I'm just trying to get one textured mesh, for example, a mesh which has a texture of a door, and put it directly on another textured mesh, like a wall.

Right now, I'm creating two independent meshes, which look fine separately, but when I put the Window directly in front of the Wall, the window becomes all "jaggy" and you can see through it in places and see the Wall.

If anyone can help me place one single bmp somewhere on a mesh, where it will rotate with the mesh, I would appreciate it.

BTW, I tried decals, but could not get them to rotate with the Wall mesh.

Follow Ups:

Post a Followup

Name:


DirectDraw in an ActiveX control... Is it possible?

Posted by Scott Prigge on April 21, 1998 at 15:35:17:

I am developing an ActiveX control in VC++ 5.0 that displays some graphics and would like very much to use DirectDraw to help with this. However, I have been having problems with the control after I add ddraw.lib to my project. The project compiles, builds, and links OK, but when it tries to register the control it HANGS VC++ and eventually hangs NT.
Anybody have any experience using DirectDraw in an ActiveX control? Anybody ever had any similar problems? Any comments, ideas, suggestions would be appreciated.

Follow Ups:

Post a Followup

Name:


Re: Rotation

Posted by Johnny Rotten on April 21, 1998 at 16:11:41:

In Reply to: Rotation posted by Inf on April 17, 1998 at 18:20:33:

: Hello, I've started programming a game for Direct-X.
: My problem is: Which is the easiet way to rotate a sprite. I can't have 1 frame for every direction?!

I will assume you're talking about 2d sprites... If you don't want to draw 360 frames (which is unrealistic), draw one frame for your sprite and rotate it as you blit it to your surface. I don't have the code readily available, but I have seen this done. I believe your the DirectX blit function has a rotation parameter. Check the documentation for that, and if I find that code, I'll post it here.

Johnny

Follow Ups:

Post a Followup

Name:


Line of sight

Posted by Johnny Rotten on April 21, 1998 at 16:23:13:

Does anyone have any line of sight algorithms? I'm using an 11x11 grid and my character does not remain in the center. I have been to the Game Tutorials and Tile Games pages, but they only explain some ways of doing it without source code examples.

Johnny

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0

Posted by nam ki min on April 21, 1998 at 20:19:45:

In Reply to: DirectX 5.0 posted by Guy Lanzone on April 17, 1998 at 21:57:55:

: Where can I download DirectX 5.0?
: Can someone please help..

  • munhwa daily newspaper

Follow Ups:

Post a Followup

Name:


Re: IS directX5.0 compatible with the matrox millenium videocard?

Posted by DW on April 21, 1998 at 20:53:44:

In Reply to: IS directX5.0 compatible with the matrox millenium videocard? posted by Davy Weynants on January 24, 1998 at 10:18:23:

: I would like to know something about directX5.0.
: Last month I've bought TOMBRAIDER 2 but when I play
: the quality of the images are very bad. I have a Matrox Millenium videocard. Is directX5.0 compatible with this card??????????????

: P.S.:My system requirements are OK
: (pentium133,48MBram,2MBVRAM)

It works with mine, no problems.

Follow Ups:

Post a Followup

Name:


leaving an extra pixel on the side? (Blt)

Posted by James on April 21, 1998 at 22:06:54:

if i blt a rect like this
a.top=0
a.bottom=9
a.left=0
a.right=9

it will blit a 10x10 square won't it???
it seems like i have to leave an extra pixel on
the right and bottom in order to get it to blt right.
--James
(please respond via email if possible)

Follow Ups:

Post a Followup

Name:


Directx 5.0

Posted by Joshua Lee on April 22, 1998 at 01:19:07:

I need a copy of directx 5.0 and I can't find it, can you help me out? E-mail me.

Follow Ups:

  • Re: D3DRM.DLL David Goss 08:46:23 6/10/98 (0)
  • Re: Directx 5.0 eddie 20:12:09 4/22/98 (0)

Post a Followup

Name:


Re: Compress wave files with directsound

Posted by Richard Kvalsvik ( TJ/Crusaders ) on April 22, 1998 at 06:53:30:

In Reply to: Compress wave files with directsound posted by Clinckart Stephane on April 03, 1998 at 04:17:10:

I use ADPCM compression. And the way I get the sound output, is to simply play a smaller buffer (3-4 second) in a loop, and decompress the compressed file from memory (to gain speed).
(ADPCM is probably the quickest copression engine I have seen so far, and you get 1:4 compression on every file. )

: How can i play/record compressed wav files and/or mpeg 2-3 files with directsound???

Follow Ups:

  • Re: Compress wave files with directsound Noel Carlos 12:23:51 5/07/98 (0)

Post a Followup

Name:


How use lightmap with non-alphablend !

Posted by NooTe on April 22, 1998 at 10:36:45:

Hi all,
I work on a engine who use RGB lightmaps, I use
alphablend for this (it work on a voodoo) but not
for a permedia2 (don't support alphablend SRC and DEST)
Have you a idea for use only BLENDTEXTURE ?

(reply on mail, please)

Thanx...
NooTe.

Follow Ups:

Post a Followup

Name:


Z-buffer-detection

Posted by Dorian Averbuh on April 22, 1998 at 12:47:51:

Is there any way to detect the minimal and maximal values for Z-buffer?
As I know these values depend on hardware vendore.

Follow Ups:

Post a Followup

Name:


DirectX 5.0 and TB soundcards

Posted by Dave Cook on April 22, 1998 at 15:18:04:

I've been having a problem with newer games
on my P5 200 (64 MB RAM). I am using a
Turtle Beach Tropez Plus soundcard
but am sometimes getting choppy
sound. Some games even crash frequently. Tech
support at the game developers point to the TB
soundcard drivers. My questions are:

The newest drivers I have been able to find for
the TB Tropez Plus are dated long before DirectX 5.0.
I've heard the company is no longer developing new
ones. Is this true? Has anyone found drivers
compatable with DirectX 5.0?
The TB card uses Crystal chips. Do
Crystal drivers work? When the card works, it
sounds great. I am hoping I don't have to
scrap it. Thanks.

Follow Ups:

  • Re: DirectX 5.0 and TB soundcards fere 12:09:13 4/24/98 (0)

Post a Followup

Name:


Late Re: Alpha-blending decals in Retained Mode

Posted by Mr Moo on April 22, 1998 at 15:48:06:

In Reply to: Re: Alpha-blending decals in Retained Mode posted by Roger on February 26, 1998 at 20:26:52:

You CAN do cheap alpha blending in Retained Mode,
and it dead easy too...

It's so easy that you'll probably miss it,
all you need to do is set the meshes colour
with an alpha constant...

i.e
------------- Bit of C++ ------------------

.SetColor (D3DRGBA(1,1,1,0.5))
// The last number in the sequence as being the
// alpha constant you want.

// Remember to set your meshes material mode
// to use the frame.

-------------------------------------------

O.K, it's a constant and doesn't allow you
a proper alpha channel, but it's quick and
easy, also you can change the transparency
on the fly which looks good for fading
explosions and that...

Have a go...

< I.

Follow Ups:

  • Re: Late Re: Alpha-blending decals in Retained Mode boller 02:44:07 9/03/98 (1)
    • Re: Late Re: Alpha-blending decals in Retained Mode Tim Brubaker 22:24:35 9/09/98 (0)

Post a Followup

Name:


Re: Directx 5.0

Posted by eddie on April 22, 1998 at 20:12:09:

In Reply to: Directx 5.0 posted by Joshua Lee on April 22, 1998 at 01:19:07:

: I need a copy of directx 5.0 and I can't find it, can you help me out? E-mail me.

Follow Ups:

Post a Followup

Name:


DirectX and DirectShow Redistrubables

Posted by Robert Tomlin on April 23, 1998 at 06:21:01:

I have utilised DirectX and DirectMedia in an application and want to know about licensing issues surrounding DirectX and DirectMedia. In particular exactly what am I allowed to redistribute and if I need to acknoledge the fact I am using DirectX/Media etc.

Thanks in Advance

Rob Tomlin

Follow Ups:

Post a Followup

Name:


ActiveMovie and IMediaSeeking::SetRate()

Posted by Robert Tomlin on April 23, 1998 at 09:59:09:

I am trying to the playback rate of a movie using ActiveMovie. I am using the SetRate member of the IMediaSeeking interface. This works for lower rates i.e. <5 but greater than this is fails.

Is there a reason for this ?
Does it depend on the type of media ?
Can it be over come?

Thanks in advance

Rob Tomlin

Follow Ups:

Post a Followup

Name:


Windowed Immediate Mode

Posted by Eugene Duvenage on April 24, 1998 at 10:00:10:

Hi,

I am trying to use a windowed Immediate mode.
Just want to know if it's possible to create a complex primary surface i.e. with backbuffers and also flippable. I get a "not in exclusive mode" error when trying to do this with IDirectDraw2::CreateSurface.
Any ideas on how to create backbuffer surfaces in windowed mode

Thanks
Eugene

Follow Ups:

  • Re: Windowed Immediate Mode NooTe 11:05:45 4/24/98 (0)

Post a Followup

Name:


Bitmap Rotation

Posted by Graham P on April 24, 1998 at 10:44:28:

Does anyone know of a simple way of doing bitmap
rotation in DirectX?

I am a complete newbie with DirectX, but am
considering the jump from DOS.

Are there any examples of source code for doing
bitmap rotation, or is it simply a function call?

Ta muchly,
Graham.

Follow Ups:

  • Re: Bitmap Rotation EvAcLeAr 04:53:02 5/25/98 (0)

Post a Followup

Name:


Re: Windowed Immediate Mode

Posted by NooTe on April 24, 1998 at 11:05:45:

In Reply to: Windowed Immediate Mode posted by Eugene Duvenage on April 24, 1998 at 10:00:10:

: Hi,

: I am trying to use a windowed Immediate mode.
: Just want to know if it's possible to create a complex primary surface i.e. with backbuffers and also flippable. I get a "not in exclusive mode" error when trying to do this with IDirectDraw2::CreateSurface.
: Any ideas on how to create backbuffer surfaces in windowed mode

: Thanks
: Eugene
Here the code :

ddrval = lpDD->SetCooperativeLevel (hwnd, DDSCL_NORMAL);

memset (&ddsd, 0, sizeof (ddsd));
ddsd.dwSize = sizeof (ddsd);
ddsd.dwFlags = DDSD_CAPS;
ddsd.ddsCaps.dwCaps = DDSCAPS_PRIMARYSURFACE;

ddrval = lpDD->CreateSurface (&ddsd, &lpDDSPrimary, NULL);
if (ddrval != DD_OK)
sys_fatalerror("GraphicsDDraw16Bit::Open(lpDD->CreateSurface) Can't create windowed primary surface for DirectDraw");

memset(&ddsd, 0, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_WIDTH | DDSD_HEIGHT;
ddsd.dwWidth = FRAME_WIDTH;
ddsd.dwHeight = FRAME_HEIGHT;

ddsd.ddsCaps.dwCaps = DDSCAPS_3DDEVICE | DDSCAPS_OFFSCREENPLAIN | DDSCAPS_VIDEOMEMORY;

ddrval = lpDD->CreateSurface(&ddsd, &lpDDSBack, NULL);
if(FAILED(ddrval))
sys_fatalerror("GraphicsDDraw16Bit::Open(lpDD->CreateSurface) Can't create windowed back surface for DirectDraw");

lpDDSBack->GetSurfaceDesc (&ddsd);

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 and TB soundcards

Posted by fere on April 24, 1998 at 12:09:13:

In Reply to: DirectX 5.0 and TB soundcards posted by Dave Cook on April 22, 1998 at 15:18:04:

: I've been having a problem with newer games
: on my P5 200 (64 MB RAM). I am using a
: Turtle Beach Tropez Plus soundcard
: but am sometimes getting choppy
: sound. Some games even crash frequently. Tech
: support at the game developers point to the TB
: soundcard drivers. My questions are:

: The newest drivers I have been able to find for
: the TB Tropez Plus are dated long before DirectX 5.0.
: I've heard the company is no longer developing new
: ones. Is this true? Has anyone found drivers
: compatable with DirectX 5.0?
: The TB card uses Crystal chips. Do
: Crystal drivers work? When the card works, it
: sounds great. I am hoping I don't have to
: scrap it. Thanks.

Follow Ups:

Post a Followup

Name:


how to transform RGB values to YUV

Posted by Ersin ESEN on April 25, 1998 at 05:33:35:

I have an animation sequence of about 15 seconds
352x288 24bpp(true color). I want to change the RGB
values of each pixel to corresponding YUV values
through a simple transformation(linear:multiplication
and summation)

How can I perform this transformation ?

Best regards.

Follow Ups:

Post a Followup

Name:


12 second sequence to display

Posted by Mehmet Bugra on April 25, 1998 at 19:54:50:

I have 12 second(300 frames) 176x144 (24bpp) raw data
to display in full screen mode. Any help advice or
guidance will be granted , especially when
a sample program in which only pluggin some values
and file names will suffice :)

Best regards...

Follow Ups:

Post a Followup

Name:


Direct3DRM LookAt function: how does it do that?

Posted by Max McCollister on April 26, 1998 at 01:02:20:

Hi,
I am programming a routine in Direct3D Retained Mode in which a Direct3D frame must rotate at a given velocity and then stop facing another given frame. The LookAt functionality provided by the LookAt function is basically what I am looking to achieve but I need to know how it works so I can add stuff to it. If you know the formula that LookAt uses to calculate the correct orientation, I would very grateful if you could enlighten me. Further more if you know another method to calculate orientation required to face another object please drop me an email.

Thanks

Max McCollister
toloquta@ionet.net

Follow Ups:

  • Re: Direct3DRM LookAt function: how does it do that? Brian Marshall 16:11:34 5/15/98 (0)

Post a Followup

Name:


DirectX5.0 in VB5.0

Posted by JP Nachtwey on April 27, 1998 at 18:33:24:

Is it possible to use DirectX in VisualBasic 5.0.
If it is, HOW??
Or is it easier to learn VC++ and try it by this way ???

Follow Ups:

  • Re: DirectX5.0 in VB5.0 GutterPunk 13:10:50 4/30/98 (1)
    • Re: DirectX5.0 in VB5.0 carlos 11:45:46 5/10/98 (0)

Post a Followup

Name:


ZBuffer problem in DirectX5

Posted by SIV on April 28, 1998 at 08:08:24:

Hy

I have a problem with the Z Buffer in Direct3D
I have made a little 3D render engine
This engine works with drawprimitives an it works fine without the ZBuffer
When i enable the renderstate ZENABLE why i have a system crash ?
Are my modelcoordinates to big ?

Sorry about my english
Thanx for your help

Silvan Vogelsanger

Follow Ups:

Post a Followup

Name:


3D `Splitter Window'

Posted by Rainer M. Domingo on April 29, 1998 at 04:42:57:

Does anybody know how to create "splitter windows" using viewports and cameras in Direct3D? I'm interested in creating a full-screen interface that looks like this:

+------------------+
| |
| |
| |
+--------+---------+
| | |
| | |
+--------+---------+

Each window is looking at the same object, but from a different perspective. Does this mean that I have to create a seperate world frame for each view or can I just create 3 cameras and viewports? How would you suggest attaching the "view" to the individual viewports and then transferring the image onto the backbuffer?

Thank you,

Rainer M. Domingo
Honolulu, Hawaii

Follow Ups:

  • Re: 3D `Splitter Window' - Corrected screen Rainer M. Domingo 04:49:20 4/29/98 (0)

Post a Followup

Name:


Re: 3D `Splitter Window' - Corrected screen

Posted by Rainer M. Domingo on April 29, 1998 at 04:49:20:

In Reply to: 3D `Splitter Window' posted by Rainer M. Domingo on April 29, 1998 at 04:42:57:

: +------------------+
: |..................|
: |..................|
: |..................|
: +--------+---------+
: |........|.........|
: |........|.........|
: +--------+---------+

Follow Ups:

Post a Followup

Name:


HELP! My game is choking on its sounds!

Posted by Sietze Dijkstra on April 29, 1998 at 05:07:24:

Hi All!

I'm having trouble with DirectSound. It seems to be
that my sound buffers are not properly released after
playing.
Do I really have to use the notify services, or is
DS supposed to release them itself? From the docs I
understood that IDirectSoundNotify is meant for
_streams_, not for simple sfx. BTW: I'm using a LOT of
samples simultaneously, and I take the default device.

Thanks in advance,

Sietze

Follow Ups:

  • Re: HELP! My game is choking on its sounds! Peter Ohlmann 11:42:36 4/29/98 (2)
    • You're not serious, right? Oh, you are! (AAAAAARGH!) sietze 13:02:33 4/30/98 (1)
      • let me get back on that... sietze 13:06:06 4/30/98 (0)

Post a Followup

Name:


DirectPlay problems after 3-5 h

Posted by Peter Ohlmann on April 29, 1998 at 11:32:28:

Hi,

After 3 to 5 (!) hours playing time, a single client or server crashes, because it's IPX-ID is set to 0.
It's a client/server system, using DirectX 5.0.
I don't understand anything, because the other players are still playing.

Do you know anything about DirectPlay problems with IPX-networks????

Please help...

Greetings
Peter Ohlmann

Follow Ups:

Post a Followup

Name:


Re: HELP! My game is choking on its sounds!

Posted by Peter Ohlmann on April 29, 1998 at 11:42:36:

In Reply to: HELP! My game is choking on its sounds! posted by Sietze Dijkstra on April 29, 1998 at 05:07:24:

: Hi All!

: I'm having trouble with DirectSound. It seems to be
: that my sound buffers are not properly released after
: playing.
: Do I really have to use the notify services, or is
: DS supposed to release them itself? From the docs I
: understood that IDirectSoundNotify is meant for
: _streams_, not for simple sfx. BTW: I'm using a LOT of
: samples simultaneously, and I take the default device.

: Thanks in advance,

: Sietze

Hi Sietze,

You shall store and manage the directsound buffers manually. For example, save 10 pointer to the buffers, and check them sometimes. If there are finished playing, release or replay them.

Bye
Peter Ohlmann

Follow Ups:

  • You're not serious, right? Oh, you are! (AAAAAARGH!) sietze 13:02:33 4/30/98 (1)
    • let me get back on that... sietze 13:06:06 4/30/98 (0)

Post a Followup

Name:


Re: How do I convert 3dstudioMAX to .x format?

Posted by Roger on April 29, 1998 at 12:01:02:

In Reply to: How do I convert 3dstudioMAX to .x format? posted by Christoffer Schr�der on April 13, 1998 at 07:54:41:

Currently DirectX only converts .3ds files to .x so in Max you have to export it to .3ds format then you can you the conv3ds program to convert it.

Follow Ups:

Post a Followup

Name:


Re: Directx 5.0 for NT???

Posted by Reefer on April 30, 1998 at 03:07:13:

In Reply to: Directx 5.0 for NT??? posted by Rok on April 14, 1998 at 14:00:21:

: I've recently encountered people talking about directx 5.0 for nt4.0
: being available. If anyone knows anything about it and where it could
: be obtained I'd be very grateful.

: sorry about this double post, I messed up the subject on the first one

Yes, it is a real program and is out there on the Net. I have a copy
myself, and it works fairly well. I have an older beta, and am looking
for a newer version that will run Need For Speed II SE. This is how I
found this post--searching.

Anyway, I have the file, but it isn't exactly legal, and because of the
new rediculously strict laws here in the US about
distributing illegal software, I'd rather not give it away.
And I do not remember where I got it, otherwise I would post
a URL for you. Good luck, and if I find the site
again, I'll post it here.

Follow Ups:

Post a Followup

Name:


3D Map Editor For Direct3D

Posted by eXact on April 30, 1998 at 06:43:52:

I Really Need A 3D Map Editor For Direct3D
(.x extensions) ....
Can Anybody Help Me Please........

Follow Ups:

Post a Followup

Name:


ActiveMovie flash

Posted by Robert Tomlin on April 30, 1998 at 06:56:30:

When I play a movie using ActiveMovie the video flashes before the first frame appears. Why is this and how do I stop this ? This also happens when I set the video to a paused state.

Thanks in advance

Rob Tomlin

Follow Ups:

  • Re: ActiveMovie flash related point Robert Tomlin 11:49:56 4/30/98 (0)

Post a Followup

Name:


Out of Video Memory??

Posted by Clay on April 30, 1998 at 09:45:27:

I'm making a simple DD/D3D program that runs in full screen (640X480 and 16 bpp). I create a complex front 3-D capable surface (with one back buffer), attach a 16-bit z-buffer to the back buffer, and create one 640x480 16bpp off screen surface. I get a "out of video memory" error when I try to create the aforementioned off screen surface. I need it in video memory because video-video blits are a lot faster than system-video blits.

I'd appreciate any advice: I'm using a CL 12M Voodoo2 (4M frame buffer) and all my surfaces should not use more than 2.5M...where's the other 1.5M going??

Clay

Follow Ups:

  • ah ha! Clay 09:32:46 5/02/98 (0)
  • Re: Out of Video Memory?? Robert 10:28:51 5/01/98 (0)
  • same problem, different symptoms sietze 07:41:28 5/01/98 (1)
    • have you tried... Clay 12:33:53 5/01/98 (0)

Post a Followup

Name:


Re: DirectX Surfaces and Windows GDI

Posted by Robert Tomlin on April 30, 1998 at 11:47:19:

In Reply to: Re: DirectX Surfaces and Windows GDI posted by Martijn Segers on April 09, 1998 at 17:43:55:

Thanks this works fine, Isn't it always the way that you cannot see the obvious answers when they are right in front of you !!!!!!!!!!!

: You can try this :

: // DSurface = directX surface
: // Whdc = Windows handle to Device Context
: // dWidth = destination width;
: // dHeight = destination height;
: // dX = destination X;
: // dY = destination Y;

: HDC hdc;
: DDSURFACEDESC ddsd;

: ddsd.dwSize = sizeof(ddsd);
: ddsd.dwFlags = DDSD_HEIGHT | DDSD_WIDTH;
: DSurface->GetSurfaceDesc(&ddsd);

: if (DSurface->GetDC(&hdc)== DD_OK)
: {
: StretchBlt(Whdc, dX, dY, dWidth, dHeight, hdc, 0, 0,ddsd.dwWidth, ddsd.dwHeight, SRCCOPY);
: DSurface->ReleaseDC(hdc);
: }

Follow Ups:

Post a Followup

Name:


Re: ActiveMovie flash related point

Posted by Robert Tomlin on April 30, 1998 at 11:49:56:

In Reply to: ActiveMovie flash posted by Robert Tomlin on April 30, 1998 at 06:56:30:

Is this due to the background of the IVideoWindow being redrawn, if so how can I set the color of it to transparent.

: When I play a movie using ActiveMovie the video flashes before the first frame appears. Why is this and how do I stop this ? This also happens when I set the video to a paused state.

: Thanks in advance

: Rob Tomlin

Follow Ups:

Post a Followup

Name:


DirectShow doesn't get the message...

Posted by sietze on April 30, 1998 at 12:57:58:

Hi,

I have just rendered one of those amazing 3DSMAX intro
scenes and am integrating it into my game. Problem is:
when I go sit and wait for the message that the video
renderer is done, nothing happens! The WM_GRAPHNOTIFY
message never comes, and I seem to be stranded with
chunks of loose code that don't do what they're supposed
to: clean up the AVI surface and get on with the program.
Help. Please.

Sietze

Follow Ups:

Post a Followup

Name:


You're not serious, right? Oh, you are! (AAAAAARGH!)

Posted by sietze on April 30, 1998 at 13:02:33:

In Reply to: Re: HELP! My game is choking on its sounds! posted by Peter Ohlmann on April 29, 1998 at 11:42:36:

:
: : I'm having trouble with DirectSound. It seems to be
: : that my sound buffers are not properly released after
: : playing.

: You shall store and manage the directsound buffers manually. For example, save 10 pointer to the buffers, and check them sometimes. If there are finished playing, release or replay them.

Uhh, really? <=(

So I have to MANUALLY check literally HUNDREDS of
different buffers? COM rules! (not). Oh well, thanks
for the info anyway!

Sietze

Follow Ups:

  • let me get back on that... sietze 13:06:06 4/30/98 (0)

Post a Followup

Name:


let me get back on that...

Posted by sietze on April 30, 1998 at 13:06:06:

In Reply to: You're not serious, right? Oh, you are! (AAAAAARGH!) posted by sietze on April 30, 1998 at 13:02:33:

: :
: : : I'm having trouble with DirectSound. It seems to be
: : : that my sound buffers are not properly released after
: : : playing.

:
: : You shall store and manage the directsound buffers manually. For example, save 10 pointer to the buffers, and check them sometimes. If there are finished playing, release or replay them.

: Uhh, really? <=(

: So I have to MANUALLY check literally HUNDREDS of
: different buffers? COM rules! (not). Oh well, thanks
: for the info anyway!

: Sietze

Do you mean I will have to write some sort of
"GetMeAFreeBufferOrDie" function, with a
little stack associated with it?

TIA,

Sietze

Follow Ups:

Post a Followup

Name:


Re: DirectX5.0 in VB5.0

Posted by GutterPunk on April 30, 1998 at 13:10:50:

In Reply to: DirectX5.0 in VB5.0 posted by JP Nachtwey on April 27, 1998 at 18:33:24:

: Is it possible to use DirectX in VisualBasic 5.0.
: If it is, HOW??
: Or is it easier to learn VC++ and try it by this way ???

I only have 1 thing to say!

http://ourworld.compuserve.com/homepages/pscribe/vb_us.htm

Follow Ups:

  • Re: DirectX5.0 in VB5.0 carlos 11:45:46 5/10/98 (0)

Post a Followup

Name:


dxsetup can't see my card...

Posted by Shep Ryen on April 30, 1998 at 23:27:45:

I recently installed a new Cirrus Logic 5464 card on my Dell PC. The old card was an S3 Trio that's part of the motherboard.

Now, the old card is disabled, and the new one is working great. But dxsetup continues to install the primary display driver for the S3 card.
Anyone know why? Or how I might bypass this problem?

Sincerely,
Shep Ryen

Follow Ups:

  • Re: dxsetup can't see my card... EvAcLeAr 04:28:40 5/25/98 (0)

Post a Followup

Name:


Re: DJGPP with DirectX?

Posted by odie on April 30, 1998 at 23:41:20:

In Reply to: DJGPP with DirectX? posted by Pierpa on January 15, 1998 at 10:27:27:

: It is possible to use the Direct3D with the DJGPP C++ compiler?
: If yes, where I can found all the necessary tool and documentation to start?

yeah, you can do it, i'm not sure how, but if you've ever used allegro game programming library for your games, go to that page, somewhere there, there's a link to some DJGPP directX stuff.

Follow Ups:

Post a Followup

Name:


same problem, different symptoms

Posted by sietze on May 01, 1998 at 07:41:28:

In Reply to: Out of Video Memory?? posted by Clay on April 30, 1998 at 09:45:27:

: I'm making a simple DD/D3D program that runs in
full screen (640X480 and 16 bpp).
I create a complex front 3-D capable surface
(with one back buffer), attach a 16-bit z-buffer
to the back buffer, and create one 640x480 16bpp
off screen surface. I get a "out of video memory"
error when I try to create the aforementioned
off screen surface.
I need it in video memory because video-video blits are a lot faster than system-video blits.

: I'd appreciate any advice: I'm using a CL 12M Voodoo2 (4M frame buffer) and all my surfaces should not use more than 2.5M...where's the other 1.5M going??

: Clay

Have you set BOTH the DDSCAPS_LOCALVIDMEM and
DDSCAPS_VIDEOMEMORY flags? If you did, this is
indeed a strange situation, because I am doing
exactly the same on a StealthII with 4mb RAM, and
when I specify the vidmem surfaces they work just
fine. What DOESN'T seem to work, however, is when
I, having gone to the Retained Mode, start using
textures. I am using 3x640x480x2= about 1.8 Megs
for my front- and backbuffers and the Z-buffer,
so I should have about 1.2 Megs left (which is
enough for all my textures),
but when I set the DirectX debug level to
'flood-me-with-the-gory-details', NONE of my
textures have either VIDMEM-flag set. Is there a
way to tell RM that it should try videomemory first?

bye

Sietze

Follow Ups:

  • have you tried... Clay 12:33:53 5/01/98 (0)

Post a Followup

Name:


Re: Out of Video Memory??

Posted by Robert on May 01, 1998 at 10:28:51:

In Reply to: Out of Video Memory?? posted by Clay on April 30, 1998 at 09:45:27:

Small chance that your SetDisplayMode is not succeeding,
I have similar problem on Jatan video card, but not on Matrox.

Query Free video storage before and after each step via GetCaps().

Another trick: Change your desktop manually beforehand to
640x480x16. If it works you know your SetDisplayMode was not
successful, even though the return code may have been DD_OK.

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0

Posted by David on May 01, 1998 at 12:07:33:

In Reply to: DirectX 5.0 posted by Guy Lanzone on April 17, 1998 at 21:57:55:

: Where can I download DirectX 5.0?
: Can someone please help..

Follow Ups:

Post a Followup

Name:


have you tried...

Posted by Clay on May 01, 1998 at 12:33:53:

In Reply to: same problem, different symptoms posted by sietze on May 01, 1998 at 07:41:28:

Have you tried creating surfaces (in local vid. memory) and using them as your textures? It's something like "CreateTextureFromSurface(pSurf,&pTexture)"?

Clay

: : I'm making a simple DD/D3D program that runs in
: full screen (640X480 and 16 bpp).
: I create a complex front 3-D capable surface
: (with one back buffer), attach a 16-bit z-buffer
: to the back buffer, and create one 640x480 16bpp
: off screen surface. I get a "out of video memory"
: error when I try to create the aforementioned
: off screen surface.
: I need it in video memory because video-video blits are a lot faster than system-video blits.

: : I'd appreciate any advice: I'm using a CL 12M Voodoo2 (4M frame buffer) and all my surfaces should not use more than 2.5M...where's the other 1.5M going??

: : Clay

: Have you set BOTH the DDSCAPS_LOCALVIDMEM and
: DDSCAPS_VIDEOMEMORY flags? If you did, this is
: indeed a strange situation, because I am doing
: exactly the same on a StealthII with 4mb RAM, and
: when I specify the vidmem surfaces they work just
: fine. What DOESN'T seem to work, however, is when
: I, having gone to the Retained Mode, start using
: textures. I am using 3x640x480x2= about 1.8 Megs
: for my front- and backbuffers and the Z-buffer,
: so I should have about 1.2 Megs left (which is
: enough for all my textures),
: but when I set the DirectX debug level to
: 'flood-me-with-the-gory-details', NONE of my
: textures have either VIDMEM-flag set. Is there a
: way to tell RM that it should try videomemory first?

: bye

: Sietze

Follow Ups:

Post a Followup

Name:


Help! I can't build the dsshow3d example.

Posted by Chris Derry on May 02, 1998 at 03:32:51:

Hello,
I've been trying to get the dsshow3d example in the
DX5 examples directory, but always get in excess of 140 errors. I'm trying to buid from within MS VC++ 5.0, and am pulling my hair out. I can get it to build from DOS(with nmake) no problem, and can also get the ddex examples to build in DOS and in VC.

Anyone have any suggestions?

Thanks

Follow Ups:

  • Oops (Help! I can't build the dsshow3d example) Chris Derry 03:40:00 5/02/98 (1)
    • Re: Oops (Help! I can't build the dsshow3d example) Brian Shea 01:43:37 5/03/98 (0)

Post a Followup

Name:


Oops (Help! I can't build the dsshow3d example)

Posted by Chris Derry on May 02, 1998 at 03:40:00:

In Reply to: Help! I can't build the dsshow3d example. posted by Chris Derry on May 02, 1998 at 03:32:51:

I forgot to mention that I added the DX include and lib directories (although I can't even get to the link stage yet!), and included various combinations of source files from the dsshow3d and misc directories, but to no avail.

I get the feeling that I need to add some defines to the project options, but beyond DEBUG (which helps a tad), I don't know which ones. There are tons in the DOS makefile, but adding all or some of them doesn't help at all.

Follow Ups:

  • Re: Oops (Help! I can't build the dsshow3d example) Brian Shea 01:43:37 5/03/98 (0)

Post a Followup

Name:


ah ha!

Posted by Clay on May 02, 1998 at 09:32:46:

In Reply to: Out of Video Memory?? posted by Clay on April 30, 1998 at 09:45:27:

After much trial and error, I think I found the problem: I don't think that the Voodoo2 is capable of DDSCAPS_OFFSCREENPLAIN surfaces in video memory! I looked in the "surface caps" section of the DirectX Viewer, and the DDSCAPS_OFFSCREENPLAIN flag is not set for the Voodoo2, but it is for my Mystique! Any ideas if this is a driver issue, or if the hardware is actually not capable?

Clay

Follow Ups:

Post a Followup

Name:


C++ Builder/Delphi and DirectDraw hint

Posted by Jack Strohm on May 02, 1998 at 20:47:41:

Having difficulty understanding all of the giverish of DirectX. But want to be able to have direct memory access to video buffers. Try doing this.

Init Direct Draw, create an offscreen buffer of the size and bit depth you want. Even if your card doesn't support 24 bit you can create offscreen buffers any way you want.

lock the offscreen buffer and draw on it. Then unlock it.

Create a TCanvas. Use the GetDC function to get the DC of the offscreen buffer. Set the TCanvas DC to be that of the offscreen buffer. Now copy that canvas to a TImage.

Tada . . . easy direct draw in delphi.

Play around with this method. I hope to have an example of how to do this on my web site soon.

Any questions, just email me. BTW - I deal mostly with DirectDraw. If you have any Direct3D samples in BCB 3.0 I'd be glad try them out.

Later to all.

Follow Ups:

  • Direct Draw Memory Levi Womack 13:05:11 9/04/98 (0)

Post a Followup

Name:


Re: Oops (Help! I can't build the dsshow3d example)

Posted by Brian Shea on May 03, 1998 at 01:43:37:

In Reply to: Oops (Help! I can't build the dsshow3d example) posted by Chris Derry on May 02, 1998 at 03:40:00:

I wrote a page that details the process of building
some of the common SDK sample programs in VC++ and
explains how to overcome some of the more common
pitfalls. You can find the page at:
http://www.angelic-coders.com/bpshea/journal/day02.htm

This might be too basic for you, so feel free to
email me with the exact error message that you
are getting. Also, I have a VC++ workspace that
has projects for almost all of the SDK example
programs which may save you some busy work. You
can find it via the above page.

Good luck!

  • Journals of a DirectX Junkie

Follow Ups:

Post a Followup

Name:


Exclusive mode

Posted by navin on May 04, 1998 at 06:24:30:

How do I request exclusive mode when programming
Direct3D using Visual C++? Do I need to have a
primary and a back surface ?
Thanks for helping.

Follow Ups:

  • Re: Exclusive mode Clay 07:40:33 5/04/98 (5)
    • Still.... Navin 05:21:37 5/06/98 (0)
    • Still.... Navin 05:21:20 5/06/98 (3)
      • Hmmm.... Clay 07:51:36 5/06/98 (2)
        • Re: Hmmm.... Navin 07:37:36 5/09/98 (1)
          • E-Mail Navin 07:41:56 5/09/98 (0)

Post a Followup

Name:


Re: Exclusive mode

Posted by Clay on May 04, 1998 at 07:40:33:

In Reply to: Exclusive mode posted by navin on May 04, 1998 at 06:24:30:

The usual order that I do it is this:
CreateWindow() // plain old window
// ALWAYS show/update before doing DirectDraw
// stuff!!
ShowWindow()
UpdateWndow()
// get DD interface
DirectDrawCreate()
// set exclusivemode
SetCooperativeLevel()
// set resolution
SetDisplayMode()
// create surfaces
...

You can use Blt/BltFast with exclusivemode, but page flipping can be a lot faster. Also, inorder to page flip, your "flipping structure" (surfaces, that is) must be in video memory.

Good Luck!

Clay

: How do I request exclusive mode when programming
: Direct3D using Visual C++? Do I need to have a
: primary and a back surface ?
: Thanks for helping.

Follow Ups:

  • Still.... Navin 05:21:37 5/06/98 (0)
  • Still.... Navin 05:21:20 5/06/98 (3)
    • Hmmm.... Clay 07:51:36 5/06/98 (2)
      • Re: Hmmm.... Navin 07:37:36 5/09/98 (1)
        • E-Mail Navin 07:41:56 5/09/98 (0)

Post a Followup

Name:


Overlays with Direct - X

Posted by David Johnson on May 05, 1998 at 14:47:04:

Hi. I need dome help. How can I implement an 8-bit overlay on top of a 16-bit underlay. My Direct draw application runs in the 16-bit underlay, but I want to use the overlay for regular window graphics, e.g. text, ines etc, that appear on top of the underlay 16 bits.

Please help me by responding by email. Thanks a lot.

Follow Ups:

Post a Followup

Name:


Still....

Posted by Navin on May 06, 1998 at 05:21:20:

In Reply to: Re: Exclusive mode posted by Clay on May 04, 1998 at 07:40:33:

: The usual order that I do it is this:
: CreateWindow() // plain old window
: // ALWAYS show/update before doing DirectDraw
: // stuff!!
: ShowWindow()
: UpdateWndow()
: // get DD interface
: DirectDrawCreate()
: // set exclusivemode
: SetCooperativeLevel()
: // set resolution
: SetDisplayMode()
: // create surfaces
: ...

That works fine. But when I then want to create a device:

DIRECT3DRM::CreateDeviceFromClipper...

I always get errors. (Device and renderer are not compatible...)
I even tried to use

LPDIRECT3DRM::CreateDeviceFromSurface...
still errors.

What do I do wrong ?

Follow Ups:

  • Hmmm.... Clay 07:51:36 5/06/98 (2)
    • Re: Hmmm.... Navin 07:37:36 5/09/98 (1)
      • E-Mail Navin 07:41:56 5/09/98 (0)

Post a Followup

Name:


Still....

Posted by Navin on May 06, 1998 at 05:21:37:

In Reply to: Re: Exclusive mode posted by Clay on May 04, 1998 at 07:40:33:

: The usual order that I do it is this:
: CreateWindow() // plain old window
: // ALWAYS show/update before doing DirectDraw
: // stuff!!
: ShowWindow()
: UpdateWndow()
: // get DD interface
: DirectDrawCreate()
: // set exclusivemode
: SetCooperativeLevel()
: // set resolution
: SetDisplayMode()
: // create surfaces
: ...

That works fine. But when I then want to create a device:

DIRECT3DRM::CreateDeviceFromClipper...

I always get errors. (Device and renderer are not compatible...)
I even tried to use

LPDIRECT3DRM::CreateDeviceFromSurface...
still errors.

What do I do wrong ?

Follow Ups:

Post a Followup

Name:


Hmmm....

Posted by Clay on May 06, 1998 at 07:51:36:

In Reply to: Still.... posted by Navin on May 06, 1998 at 05:21:20:

Are you using a add-on 3D card? (DX treats this sort of like a separate monitor)

When you do DirectDrawCreate()/CreateDeviceFromSurface() are you passing a non-null GUID?

Are you setting the hWnd for the clipper?

Just some suggestions...if you still have problems, I wrote some wrapper code if you want. I'll have to put some comments in it, though :->

Clay

Follow Ups:

  • Re: Hmmm.... Navin 07:37:36 5/09/98 (1)
    • E-Mail Navin 07:41:56 5/09/98 (0)

Post a Followup

Name:


trident / jaton video cards and dd

Posted by Robert on May 06, 1998 at 15:45:19:

Has anyone implemented direct draw on a system that
has a Trident (providia 9685- or other) or Jaton
(video 67p- or other) video card? I am really stuck.

When I change mode from 24 bit to 16 bit I get a DD_OK
return code, but the mode does not really change.

I have to set the desktop to 16 bit before running
program.

I have tried updated drivers, and various direct draw
versions, even the latest SDK.

Follow Ups:

Post a Followup

Name:


clipping: at what stage to do it?

Posted by gravedancer on May 06, 1998 at 17:37:44:

given that the input consists of a list of vertices and a list of faces each of which has three indices into the vertex list (the kind of data structure you would submit to DrawIndexedPrimitive) which of the following approaches is better?

1. give these lists to the clipper which produces similar lists of clipped vertices and faces and then give these to the rasterizer

2. take each face in the original list, clip it, draw it and then move on to the next face

each approach has it's own problems but it seems to me that the second is cleaner to implement. which approach is normally followed by graphics engines?

Follow Ups:

Post a Followup

Name:


Retained Mode: AddGroup?? #!@#$!!! please help!

Posted by Shai'tan on May 07, 1998 at 06:25:45:

Hi,
I have created a Mesh using a meshbuilder2 interface and ->CreateMesh. I want to use AddGroup to get a group so I can apply a texture.

How the hell do I do it??
I microsoft docs are pretty much useless as far as I can tell, and everyone seems to be silent!

Someone please help a newbie!

Follow Ups:

  • Re: Retained Mode: AddGroup?? #!@#$!!! please help! Lou 09:03:59 5/16/98 (0)

Post a Followup

Name:


Re: Compress wave files with directsound

Posted by Noel Carlos on May 07, 1998 at 12:23:51:

In Reply to: Re: Compress wave files with directsound posted by Richard Kvalsvik ( TJ/Crusaders ) on April 22, 1998 at 06:53:30:

Can you please e-mail me some source code about using compressed sound formats with direct sound, for example ADPCM. I have an ACM codec for MPEG Layer 3, and I want to mix it with another sounds efects at runtime. The MPEG file is 10 MB length and decoded to PCM is about 100 MB, so I don't want to decode in memory.

Any contibutions will be apreciated, thank in advance.

Follow Ups:

Post a Followup

Name:


directX5

Posted by mike on May 07, 1998 at 13:50:12:

my directx seems not to be working i can play certain games like monster truck maddness but no games that use directx5 i was wondering if i can reload or down load from another source iam new at computing so if anyone can help that would be greati dont know if this is important but i have a fairly new 233 gateway pent.2 thanks agin mike

Follow Ups:

  • Re: directX5 Mr.Goodbar 01:09:50 5/23/98 (1)
    • Re: directX5 Matt 17:10:24 6/06/98 (0)
  • Re: directX5 Mr.Goodbar 01:08:15 5/23/98 (5)
    • Re: directX5 �s�� 21:45:08 7/03/98 (1)
      • Re: directX5 �s�� 21:48:27 7/03/98 (0)
    • Re: directX5 �s�� 21:44:48 7/03/98 (0)
    • Re: directX5 �s�� 21:44:16 7/03/98 (0)
    • Re: directX5 n 07:21:39 6/24/98 (0)
  • Re: directX5 mike 13:52:58 5/07/98 (0)

Post a Followup

Name:


Re: directX5

Posted by mike on May 07, 1998 at 13:52:58:

In Reply to: directX5 posted by mike on May 07, 1998 at 13:50:12:

: my directx seems not to be working i can play certain games like monster truck maddness but no games that use directx5 i was wondering if i can reload or down load from another source iam new at computing so if anyone can help that would be great i dont know if this is important but i have a fairly new 233 gateway pent.2 thanks agin mike

Follow Ups:

Post a Followup

Name:


AlphaSrcConstOverride...

Posted by Jonathan Klein on May 07, 1998 at 19:48:41:

Hi there!

I've got the following problem:

I want to blit some letters on the screen, which
fortunately works already. But I want to make them
transparent. I tried to use the
DDBLT_ALPHASOURCECONSTOVERRIDE/DDBLT_ALPHADESTCONSTOVERRIDE
in every imaginable manner. But it wasn't blended,
it was still the same boring white letter printed
on the coloured screen.

H횸P! :)

CU

Jon

Follow Ups:

  • Re: AlphaSrcConstOverride... Brian Shea 12:23:49 5/08/98 (0)

Post a Followup

Name:


8bpp24bpp

Posted by cappa luca on May 08, 1998 at 07:32:14:

how does it work undex DirectX5?
if i blit a 8bpp image on a 24bpp, will the DirectX do
the conversion for me? And 24bpp to 8bpp?
I tried and the pictures were well drawed, but doing
such thing will slow down the performance?

thanks in advance,
luca

Follow Ups:

  • Re: 8bpp24bpp Brian Shea 12:25:36 5/08/98 (1)
    • Re: 8bpp24bpp cappa luca 12:48:09 5/22/98 (0)

Post a Followup

Name:


alpha blending in RM

Posted by Clay on May 08, 1998 at 08:04:03:

I have a model of the solar system that I want to use alpha-blending in. The problem is, the only way I've been able to get any sort of transparent effect is by keeping the IDirect3DDevice I use for creating my IDirect3DRMDevice and calling SetRenderState(). This seems to ignore the alpha component of my colors and make everything equally transparent. If any of you have a way to selectively choose which visuals are rendered transparently, and control how transparent they are, I'd really appreciate it!

Clay

Follow Ups:

  • Been there (, allmost jumped off a tall building), done that sietze 12:10:44 5/08/98 (2)
    • Retained mode translucency Al 04:26:39 7/06/98 (0)
    • Re: Been there (, allmost jumped off a tall building), done that Clay 17:00:23 5/08/98 (0)

Post a Followup

Name:


Been there (, allmost jumped off a tall building), done that

Posted by sietze on May 08, 1998 at 12:10:44:

In Reply to: alpha blending in RM posted by Clay on May 08, 1998 at 08:04:03:

: I have a model of the solar system that I want to use alpha-blending in. The problem is,
the only way I've been able to get any sort of transparent effect is by keeping the IDirect3DDevice
I use for creating my IDirect3DRMDevice and calling SetRenderState(). This seems to ignore the
alpha component of my colors and make everything equally transparent. If any of you have a way to
selectively choose which visuals are rendered transparently, and control how transparent they are,
I'd really appreciate it!

: Clay

Hi,

You are very close to the jackpot, you are only missing one thing: you should have TWO scene frames,
ie one called OpaqueWorld and one called TransWorld, attached to the 'master' scene frame.
Now when you start rendering, instead of rendering the whole scene, render OpaqueWorld first,
then flick the alpha-blend-switch using SetRenderState(), render TransWorld, and flick the switch off
again.
Now you can attach any translucent object to TransWorld, and all opaque ('normal') objects to
OpaqueWorld.

Good luck,

Sietze

PS: this seems pretty obvious, but it took me through HELL finding it out. Mail me if you want the
code for the switches

Follow Ups:

  • Retained mode translucency Al 04:26:39 7/06/98 (0)
  • Re: Been there (, allmost jumped off a tall building), done that Clay 17:00:23 5/08/98 (0)

Post a Followup

Name:


Re: AlphaSrcConstOverride...

Posted by Brian Shea on May 08, 1998 at 12:23:49:

In Reply to: AlphaSrcConstOverride... posted by Jonathan Klein on May 07, 1998 at 19:48:41:

Alpha blits are not supported in DirectDraw.
You can either use color keying or write your
own alpha blending blt function.

  • Journals of a DirectX Junkie

Follow Ups:

Post a Followup

Name:


Re: 8bpp24bpp

Posted by Brian Shea on May 08, 1998 at 12:25:36:

In Reply to: 8bpp24bpp posted by cappa luca on May 08, 1998 at 07:32:14:

No conversion is done when blitting from one
surface to another. You have convert by hand.

  • Journals of a DirectX Junkie

Follow Ups:

  • Re: 8bpp24bpp cappa luca 12:48:09 5/22/98 (0)

Post a Followup

Name:


Re: Been there (, allmost jumped off a tall building), done that

Posted by Clay on May 08, 1998 at 17:00:23:

In Reply to: Been there (, allmost jumped off a tall building), done that posted by sietze on May 08, 1998 at 12:10:44:

I hate to be lazy about it, but I'm sick of the whole DX mess -- Did they intend the documentation to be a reference for people who already know everything about DX or for people like me who want to learn??? Anyhow, I'd really appreciate it if you'd email some source.

Thanks!

Clay
csampson@erols.com

Follow Ups:

Post a Followup

Name:


Fog help!

Posted by Hana on May 08, 1998 at 18:51:16:

The explanation of fog in the DirectX help seems
simple... but I can't get it to work.

In ramp mode, (using lightstate) everything goes black.
In RGB, (using renderstate), all my objects are
solidly filled with the fog color.

What is this fog table that the help refers to?

Follow Ups:

  • Re: Fog help! Robert 14:14:17 5/21/98 (0)

Post a Followup

Name:


Need help for DirectPlay!

Posted by Peter Ohlmann on May 08, 1998 at 22:17:48:

Does anybody knows anything about
errors in DirectPlay 5.0 ?????

My session crashes sometimes after 5-10 hours,
and there's no way to debug.
The player's IPX-Id is set to 0 (?)

Please help!!

Peter

Follow Ups:

Post a Followup

Name:


Re: How to rotate a point

Posted by Mike Hansen on May 09, 1998 at 04:34:52:

In Reply to: How to rotate a point posted by Navin on March 24, 1998 at 09:29:38:

: Who knows how to rotate a point in 3d around
: any axis in 3d?

(1) Translate the axis to intersect the origin of
your world coordinates
(2) rotate the axis to be coincident with one of
the primary axes
(3) perform the desired rotation about that axis
(4) rotate back through the angle in (2)
(5) translate back through the vector in (1)

Follow Ups:

Post a Followup

Name:


Re: Hmmm....

Posted by Navin on May 09, 1998 at 07:37:36:

In Reply to: Hmmm.... posted by Clay on May 06, 1998 at 07:51:36:

: Are you using a add-on 3D card? (DX treats this sort of like a separate monitor)
I tried both.

: When you do DirectDrawCreate()/CreateDeviceFromSurface() are you passing a non-null GUID?
I tried both.

: Are you setting the hWnd for the clipper?
Yes

: Just some suggestions...if you still have problems, I wrote some wrapper code if you want. I'll have to put some comments in it, though :->

It would be nice if you would mail me the code. Maybe
it works better. Thanks for helping!

: Clay

Follow Ups:

  • E-Mail Navin 07:41:56 5/09/98 (0)

Post a Followup

Name:


E-Mail

Posted by Navin on May 09, 1998 at 07:41:56:

In Reply to: Re: Hmmm.... posted by Navin on May 09, 1998 at 07:37:36:

navin@nero.uni-bonn.de

Thanks. Navin.

Follow Ups:

Post a Followup

Name:


Reverse playback of video via DirectShow

Posted by Thomas Krim on May 10, 1998 at 04:53:42:

Hi Guys,

has anybody a suggestion to playback a video in reverse order? Although the doc's say that it is possible to give the IMediaSeeeking Interface a
negative value (-1) via SetRate(), it returns an
INVALID_ARGUMENT. Trying to skip backwards through the avi-file via SetPosition() doesn't help, because this doesn't run smoothly.

Any suggestions are very welcome.

TIA
Thomas Krim

Follow Ups:

  • Re: Reverse playback of video via DirectShow Robert Tomlin 08:54:40 6/17/98 (0)
  • Re: Reverse playback of video via DirectShow Robert Tomlin 05:17:45 5/11/98 (2)
    • Re: Reverse playback of video via DirectShow Thomas Krim 05:06:00 5/21/98 (1)
      • Re: Reverse playback of video via DirectShow Thomas Krim 05:07:33 5/21/98 (0)

Post a Followup

Name:


Soundblaster AWE32 and DirectX 5 problems

Posted by Jesus Giraut on May 10, 1998 at 11:33:06:

I need to know if there is any incompatibility problem between
the Soundblaster AWE32 and the direct X 5 drivers. The reason
of my question is because i큟 having problems with several games
which use directX 5. When i try to play these games i can큧 hear
any sounds.

Follow Ups:

  • Re: Soundblaster AWE32 and DirectX 5 problems Adele 03:18:43 7/11/98 (0)

Post a Followup

Name:


Re: DirectX5.0 in VB5.0

Posted by carlos on May 10, 1998 at 11:45:46:

In Reply to: Re: DirectX5.0 in VB5.0 posted by GutterPunk on April 30, 1998 at 13:10:50:

: : Is it possible to use DirectX in VisualBasic 5.0.
: : If it is, HOW??
: : Or is it easier to learn VC++ and try it by this way ???

: I only have 1 thing to say!

: http://ourworld.compuserve.com/homepages/pscribe/vb_us.htm

Follow Ups:

Post a Followup

Name:


Direct3D: how to create control buttons

Posted by MAgDI on May 11, 1998 at 00:22:32:

I am using Direct3D in my B.Sc. project.
I am creating an animation tool using and supporting
Direct3D.
So i need to create control buttons to complete the
interface.
All my attempts have failed.
can some one help please.

Follow Ups:

Post a Followup

Name:


Re: Reverse playback of video via DirectShow

Posted by Robert Tomlin on May 11, 1998 at 05:17:45:

In Reply to: Reverse playback of video via DirectShow posted by Thomas Krim on May 10, 1998 at 04:53:42:

: Hi Guys,

: has anybody a suggestion to playback a video in reverse order? Although the doc's say that it is possible to give the IMediaSeeeking Interface a
: negative value (-1) via SetRate(), it returns an
: INVALID_ARGUMENT. Trying to skip backwards through the avi-file via SetPosition() doesn't help, because this doesn't run smoothly.

: Any suggestions are very welcome.

: TIA
: Thomas Krim

Sorry this does not help you much but seeing that you are using DirectShow I am wondering if you experience a flash when you first play a movie ?

Thanks in advance

Follow Ups:

  • Re: Reverse playback of video via DirectShow Thomas Krim 05:06:00 5/21/98 (1)
    • Re: Reverse playback of video via DirectShow Thomas Krim 05:07:33 5/21/98 (0)

Post a Followup

Name:


Directx 5.2 SDK

Posted by iguane on May 11, 1998 at 09:13:21:

I'm looking for the 5.2 directx sdk, and i don't want to buy the cd.
If someone can tel me where i can download it
(if some one have a site with it), it would be very cool.

Please answer me with my mail.

Bye

Follow Ups:

  • Re: Directx 5.2 SDK 뗌┳갤 05:19:27 5/15/98 (1)
    • Re: Directx 5.2 SDK Ulle 09:21:20 6/06/98 (0)

Post a Followup

Name:


Antialiasing Enable

Posted by Dorian Averbuh on May 11, 1998 at 10:41:34:

I've got recently Fire GL Pro 1000 cards, 8MB.
It suppors anialiasing in hardware.
Hence I can't enable this feature.
I use immidiate mode
SetRenderState(D3DRENDERSTATE_ANIALIAS,
D3DANIALIAS_SORTINDEPENDANT);
Please Help!

Follow Ups:

Post a Followup

Name:


How do you get a console apps window handle

Posted by E. J. Thayer on May 11, 1998 at 12:24:06:

MS requires the passing of a window handle to their
DirectX functions. They did this for the most part to
force people to use DirectX with windows or we could
simply use the SDK under DOS and eliminate windows
overhead. My questions is this. When you create a
console application with MS Visual C how do you get
the window handle of the window it creates? If this is
possible then you could eliminate almost all the the
windows overhead and still have the multi tasking
environment.

  • An old game I wrote, a little about DirectX

Follow Ups:

Post a Followup

Name:


D3D gives floating point errors for no detecable reason

Posted by Luke Ryan on May 13, 1998 at 01:29:56:

I have based my code on the example programs
that came with eh DirectX3 SDK. I am using
Intermediate mode. I have no harware acrelleration
enabled. I am using Borland Builder C++

The program runs perfectly in all available graphic
modes in wireframe mode. But in solid mode it only
works at 24 bit colour deapths. At 16 bit and 8 bit
it crashes at certain vewing angles.

The only expenation for this I could think of was that
I was not clipping correctly. But I turned clipping of\
with the entire seen all in view and it still crashed.

My only other explenation is some incompatibity between
the complier and the SDK.

Any assistace would be creatly apreasiated.

Follow Ups:

  • Re: D3D gives floating point errors for no detecable reason Clay 07:41:18 5/22/98 (0)

Post a Followup

Name:


DirectDraw and video Overlay

Posted by Michael Uman on May 13, 1998 at 13:39:45:

Hello,

I need to be able to determine if the surface I am rendering to is obscured by other windows so I can xfer only the pixels which are visible.

I believe that there is a way using DirectX to obtain a cliplist. Has anyone had any experience with this.

Please reply....

Thanks,

Mike Uman

Follow Ups:

Post a Followup

Name:


>

Posted by Heddwyn A. Jones on May 14, 1998 at 07:26:45:

Hi,
To make sure there are no major gliches,
I decided to use Microsoft Visual C++
for my final year project in Compsci.

The versions I've heard of are:

MSVC++5 Learning edition (found listed and can obtain)
MSVC++5 Standard edition (can't find retailer)
MSVC++5 Enterprise edition (too bloody expensive!)

Can someone tell me if I can get away with
the Learning edition? If so, are there any
workarounds I may require? If not, anyone
know where to get the Standard edition?

Thanks in advance,
Heddwyn A. Jones

P.S. Troubles with e-mail, so replies not to this board may bounce..

Follow Ups:

  • Re: > Clay 14:10:47 5/15/98 (0)

Post a Followup

Name:


Help!

Posted by Chris and Terry, Homeschoolers on May 14, 1998 at 11:33:12:

I'm Terry - I'm the teacher/mom - and I'm a computer
twit.
My son bought a game and it won't play. DirectX 5.0
is needed and our HP8160 doesn't seem to be capable.
Can someone give a bit of (kind) advice?
Are there some things I can ask my computer to solve this problem? Is there no hope?
Thanks!

Follow Ups:

  • Re: Help! fog 16:08:17 6/08/98 (0)
  • Re: Help! Fred 08:58:20 5/15/98 (0)

Post a Followup

Name:


Re: Directx 5.2 SDK

Posted by 뗌┳갤 on May 15, 1998 at 05:19:27:

In Reply to: Directx 5.2 SDK posted by iguane on May 11, 1998 at 09:13:21:

: I'm looking for the 5.2 directx sdk, and i don't want to buy the cd.
: If someone can tel me where i can download it
: (if some one have a site with it), it would be very cool.

: Please answer me with my mail.

: Bye

Follow Ups:

  • Re: Directx 5.2 SDK Ulle 09:21:20 6/06/98 (0)

Post a Followup

Name:


Re: Help!

Posted by Fred on May 15, 1998 at 08:58:20:

In Reply to: Help! posted by Chris and Terry, Homeschoolers on May 14, 1998 at 11:33:12:

What sort of computer is 'HP8160'?, is it a pentium /pentium2 machine?. what Operating System you are using? Windows95 or DOS/Windows3.x?? If you want to play DirectX5 game, you need a machine running Windows95. If you are using Win95, you can install DirectX5 on it(mostly likely comes with your game CD, if not, you can download from http://www.microsoft.com/directx/ ) but if your machine is too slow to run Win95, then you can't play that game unless you upgrade your computer.

Follow Ups:

Post a Followup

Name:


Problem with the IDirect3DRMAnimationSet::Load

Posted by Fred on May 15, 1998 at 09:25:51:

Does any one know how to use the IDirect3DRMAnimationSet::Load function to load the same animation file more then once? The following is part of my code:
....
lpD3DRM->CreateFrame(lpScene, &lptmpFrame);
LPDIRECT3DRMANIMATIONSET lpAniSet;
lpD3DRM->CreateAnimationSet(&lpAniSet);
lpAniSet->Load("myAni.x", NULL,D3DRMLOAD_FROMFILE, NULL, NULL, lptmpFrame);
lptmpFrame->SetPosition(......)
.... callback function etc etc

It works fine in this way, However, if i add the following:

lpD3DRM->CreateFrame(lpScene, &lptmpFrame2);
LPDIRECT3DRMANIMATIONSET lpAniSet2;
lpD3DRM->CreateAnimationSet(&lpAniSet2);
lpAniSet2->Load("myAni.x", NULL,D3DRMLOAD_FROMFILE, NULL, NULL, lptmpFrame2);
lptmFrame->SetPosition(... to different postion);
... callback... etc etc

It suppose to show up TWO same animating objects at different positions, but it didnt! It only shows the one that loaded 1st. The second load animation only showup after i comment out the first Load actoin!

Can anyone explain why this happen? How should i suppost to do to load the same animation twice? What i really want to do is to create Two/Three SAME animations in one scene. Any suggest or walkaround?

Thx in Advance

Fred

Follow Ups:

  • Re: Problem with the IDirect3DRMAnimationSet::Load Andreas 20:28:47 6/30/98 (1)
    • Re: Problem with the IDirect3DRMAnimationSet::Load Fred 12:35:07 8/18/98 (0)
  • Re: Problem with the IDirect3DRMAnimationSet::Load Lee 18:47:02 5/27/98 (0)
  • Re: Problem with the IDirect3DRMAnimationSet::Load Larry Velasquez 01:06:05 5/23/98 (0)
  • Re: Problem with the IDirect3DRMAnimationSet::Load Larry Velasquez 01:05:40 5/23/98 (0)
  • Re: Problem with the IDirect3DRMAnimationSet::Load Larry Velasquez 01:03:48 5/23/98 (0)
  • Re: Problem with the IDirect3DRMAnimationSet::Load Larry Velasquez 01:02:45 5/23/98 (0)

Post a Followup

Name:


Re: >

Posted by Clay on May 15, 1998 at 14:10:47:

In Reply to: > posted by Heddwyn A. Jones on May 14, 1998 at 07:26:45:

I have MSVC 4.0 standard, and it works fine. Thing is, the only real difference (from a programmer's perspective) between the development environments is the compiler's capabilities. You can use any editor you want and link any libraries you want (MS-format libraries!) and end up with a working exe. The main difference is how smart the compiler is and how good it is at optimization. If you wanted to (you'd need the libraries and header files though) you could code up a directX app with the freeware GNU compiler. I would go with the most expensive compiler you budget allows for, but don't worry about it if you can't afford the enterprise edition -- your brain is a better optimizer than a compiler will ever be!

Clay

Follow Ups:

Post a Followup

Name:


DPID_SERVERPLAYER doesn't change

Posted by Peter Ohlmann on May 15, 1998 at 14:19:14:

I have trouble with DirectPlay, because the DPID_SERVERPLAYER doesn't refresh after the host leave the session. One player gets the message DPMSGS_HOST, but the other players continue sending their messages to the previous server.

What can I do?

Updating session description doesn't help.

Bye
PETER

Follow Ups:

  • Re: DPID_SERVERPLAYER doesn't change Dominic Mathers 04:04:22 6/30/98 (0)
  • Re: DPID_SERVERPLAYER doesn't change Dominic Mathers 04:00:59 6/30/98 (0)
  • Re: DPID_SERVERPLAYER doesn't change Dominic Mathers 04:00:13 6/30/98 (0)

Post a Followup

Name:


Re: How do I use Clone? (object in D3DRM)

Posted by Brian Marshall on May 15, 1998 at 15:40:57:

In Reply to: How do I use Clone? (object in D3DRM) posted by Lee Sandberg on April 15, 1998 at 17:45:56:

: Whats a Punktuator???

I assume you're refering to pUnkOuter, the first param to the Clone() method. This is used for COM aggregation. If you're not using aggregation, pass a NULL here. You can find out more on aggregation at the MS web site. Basically, COM aggregation is a way to have have one object build on top of another in a way that allows QueryInterface() to work completely on both the inner and outer object. It's useful when you need it, but if you don't use NULL and ignore it.

Follow Ups:

Post a Followup

Name:


Re: Direct3DRM LookAt function: how does it do that?

Posted by Brian Marshall on May 15, 1998 at 16:11:34:

In Reply to: Direct3DRM LookAt function: how does it do that? posted by Max McCollister on April 26, 1998 at 01:02:20:

It's actually a very simple vector manipulation. Take the differences of the X, Y and Z components of the positions of the frames, normalize, and you have a the direction vector needed to get Frame1 to point to Frame2. Now you can calculate the direction vector (direction of z axis) and up vector (direction of y axis) required to get the frame to appear to look at the other frame. Call Frame3::SetOrientation() with this data and you've got LookAt(). The math isn't trivial, but it is based on basic geometry and there are plenty of reference books out there that cover this. I'm sure it's in one of the volumes of graphics gems...

: Hi,
: I am programming a routine in Direct3D Retained Mode in which a Direct3D frame must rotate at a given velocity and then stop facing another given frame. The LookAt functionality provided by the LookAt function is basically what I am looking to achieve but I need to know how it works so I can add stuff to it. If you know the formula that LookAt uses to calculate the correct orientation, I would very grateful if you could enlighten me. Further more if you know another method to calculate orientation required to face another object please drop me an email.

: Thanks

: Max McCollister
: toloquta@ionet.net

Follow Ups:

Post a Followup

Name:


Direct X pixel plotting

Posted by menasius on May 15, 1998 at 23:41:32:

how do you go about ploting a single pixel onto a DXsurface?

Follow Ups:

  • Re: Direct X pixel plotting qIz 05:07:02 5/18/98 (0)

Post a Followup

Name:


Re: Loading Textures

Posted by Lou on May 16, 1998 at 08:24:33:

In Reply to: Loading Textures posted by Frank on March 14, 1998 at 01:12:19:

: Having a problem wrapping bit maps greater or smaller than 256 colors. Any suggestions as to want I am doing wrong or what to look for?

:
: Thx,
: Frank

checks:
1. Maybe your device doesn't support other texture formats.
use EnumTextureFormats to check
2. If possible, convert at load time all your
textures to 8-bit.

Follow Ups:

Post a Followup

Name:


Re: Retained Mode: AddGroup?? #!@#$!!! please help!

Posted by Lou on May 16, 1998 at 09:03:59:

In Reply to: Retained Mode: AddGroup?? #!@#$!!! please help! posted by Shai'tan on May 07, 1998 at 06:25:45:

: Hi,
: I have created a Mesh using a meshbuilder2 interface and ->CreateMesh. I want to use AddGroup to get a group so I can apply a texture.

: How the hell do I do it??
: I microsoft docs are pretty much useless as far as I can tell, and everyone seems to be silent!

: Someone please help a newbie!

If you have created a mesh out of a meshbuilder,
you use GetGroup not AddGroup.

STEP 1:
HRESULT GetGroup(
D3DRMGROUPINDEX id,
unsigned *vCount,
unsigned *fCount,
unsigned *vPerFace,
DWORD *fDataSize,
unsigned *fData
);

parameters:
id -> 0
vcount, fcount ->addresses of variables to contain
vertexcount and facecount respectively.
vPerFace ->address of variable to contain # of
vertices per face.
fDataSize ->address of variable to contain the
size of facedata (a list of vertex indices w/c
depends on the facecount.
fData -> set this to 0

unsigned vcount, fcount, *fData;
DWORD fDataSize;

ex. mesh->GetGroup( 0, &vcount, &fcount,
&fDataSize, 0);

STEP2:
allocate data for fData:
fData = new unsigned[ fDataSize];

STEP3:
call GetGroup again:
mesh->GetGroup( 0, 0, 0, &fDataSize, fData)

STEP4:
call mesh->GetVertices to get your D3DRMVERTEX's
based on the vertex indices from fData.

modify the texture coords in you D3DRMVERTEX's.

call mesh->SetVertices to record you modifications.

-END-

Follow Ups:

Post a Followup

Name:


Re: Opinions wanted of the best

Re: Opinions wanted of the best <$200 modeler/renderer/animator for Direct3D

[ Follow Ups ] [ Post Followup ] [ the DirectX eXperience Forum ]

Posted by Lou on May 16, 1998 at 09:16:36:

In Reply to: Opinions wanted of the best <$200 modeler/renderer/animator for Direct3D posted by Boller on April 20, 1998 at 20:48:55:

: Hi everybody,

: Just wondering what programs everyone is using out
: there to create their models for Direct3D applications.

: I'm looking to buy a modeler/renderer/animator under
: $200 to create models and animations for my D3D
: programs, and I'm looking for suggestions and opinions...
: Ease of use and the ability to export valid .3ds files
: (so I can convert them to .X files with conv3ds with
: texture maps intact) are my primary concerns. I'd like
: a decent animator built in.

: I've been looking at websites and demos, but nothing
: compares to hearing what people out there are truly
: using and why they love/hate it.

: Thanks for your help!

: Jeff Boller
: decorate@westol.com

There is one very good product that I know and
it is very cheap (<200$) but maybe it's not yet in the U.S. market. It's called 3DAtelier and
it is currently selling like hotcakes in Japan.
It comes with a more than decent motion editor and a very good 3D file format converter. By the way, it was developed using DirectX and VB.

Follow Ups:

Post a Followup

Name:


Re: D3DRM Texturing!!

Posted by Lou on May 16, 1998 at 09:26:00:

In Reply to: Re: D3DRM Texturing!! posted by Jason on April 16, 1998 at 23:30:42:

: I'm having the exact same problem. I'm trying to create an inverted sphere (the normals to all the faces point inward instead of outward) to use as a starfield.
: I use AddGroup which seems to work along with SetVertices. This adds the faces and their respective positions to the mesh. However, when I use SetGroupTexture,
: the texture does not appear on any of the faces, or all the faces change to a solid color that exists in the texture, or weird patterns occur on the faces.

: I load the inverted sphere into a MeshBuilder object. I get a FaceArray from the MeshBuilder. I then loop through all the faces and get the vertex data for
: each face. I create a temp Mesh object and use AddGroup on each face and then add the Mesh as a visual object to my "starfield" frame.

: If anyone knows how to get textures to properly appear on the faces, please let me know.

: Thanks

Problem:
Texture coordinates not set properly.

Options:
1. You modify the texture coords (tu,tv) yourself
using GetVertices and SetVertices.
2. Use a LPDIRECT3DRWRAP to do it for you.

Follow Ups:

Post a Followup

Name:


Re: D3DRM in fullscreen?

Posted by Lou on May 16, 1998 at 09:33:21:

In Reply to: D3DRM in fullscreen? posted by Niklas Elmqvist on March 16, 1998 at 14:21:49:

: I have run into some problems when trying to kick
: my D3DRM application into fullscreen mode. I get a
: DDERR_NOEXCLUSIVE error when trying to create a
: D3DRM device, even though I *have* set my cooperative
: levels and updated and shown my main window.
: Earlier, when my application was windowed, I used a
: DirectDrawClipper to create my device, and I still do,
: which I suspect is the source of my problems. Do I
: have to create a DirectDraw surface and then use
: Direct3DRM::CreateDeviceFromSurface instead of
: Direct3DRM::CreateDeviceFromClipper? Or am I doing
: some other silly mistake?

1. Your window must be top level ( cannot be a
picture box)
2. You must set cooperative level to "DDSCL_NORMAL"
3. You may use createdevicefromclipper.
4. Resize your window to fullscreen.

Follow Ups:

Post a Followup

Name:


Re: MeshBuilder problems

Posted by Lou on May 16, 1998 at 09:42:02:

In Reply to: MeshBuilder problems posted by Eugene Polonsky on March 03, 1998 at 20:57:35:

: I'm not sure if you guys want me to go into the nitty gritty of what's going on. I'll try to phrase the question concisely first, then elaborate. That way if you don't want ot read any further you won't have to.

: I need to be able to select a group of vertices in a meshbuilder landscape and change them. How do I do that?

:
: Nitty gritty:

: I've got two data structures controlling the landscape. One is a land x by y array with Z values. I've got an algorithm that'll take that array and convert it to triangles, and put out a vertices and faces arrays so that I can use AddFaces call on the meshbuilder. The catch is the array is (hypothetically) 88X88 units, and the final output is (88*sampling)X(88*sampling). That way I can make the final square of land as large as I want.

: Now, I've got a shot fired at a section of this landscape. It'll be a spherical shot, with a certain radius, say 25. I need to 1) make a spherical indentation in the landscape at the point the shot is fired, and 2) change the texture of all the triangles affected. I figured to do that I need to use AddGroup, but I don't know how to gather the faces data out of the structures I already have.

: I've already figured out the mechanism for changing the vertices. I'll create a square array of value modifiers, so that all I got to do is add the modifier to the Z value of the vertice. That's not a problem. Basically I need to some way to loop through the coordinates involved and apply the values from that array to every vertice. Then I need to change their texture.

: If anyone could help me (preferably email, or here's fine too) I'd really appreciate it.

: Also, if anyone is interested in making this game together with me, that's fine too. I'm only making this game as a way to impress a potential employer, I have no commercial interest in it. If anyone wants to help, email me.

: Thanks.

One possible solution.

1. MeshBuilders are a pain to modify.

2. Create a Mesh out of a MeshBuilder.
MeshBuilder->CreateMesh( &Mesh);
The Mesh created will already have one group- group 0.

3. Modify the Mesh using GetGroup, GetVertices,
and SetVertices.

4. If you need texturing, you may use an
LPDIRECT3DRMWRAP or modify the D3DRMVERTEX's tu
and tv yourself.

5. Release your old MeshBuilder.

6. Create a new MeshBuilder.

7. add the mesh to the new MeshBuilder.
MeshBuilder->AddMesh( Mesh);

NOTES:
modifying the meshbuilder directly may be
slower than the process shown above.

hope it helped you and not too late.

Follow Ups:

Post a Followup

Name:


releasing DDraw objects causes hang

Posted by morris on May 17, 1998 at 00:36:43:

I am trying to learn DirectDraw.
so far, I have coded operational routines which
render flat-colored polygons with ZBuffering.
my problem is, I can run the program just fine in
the Micro$oft Visual C++ 4.2 environment, but running
it from the desktop causes the system to hang when
going from fullscreen mode back to GDI. the code I
use is
lpPrimarySurface->Release();
lpDirectDraw->Release();

the screen goes back to GDI just fine, but then the
mouse freezes up and the system hangs. I also see
colorful garbage, perhaps a highly distorted version of
my DirectDraw screen, in the upperleft corner of the screen.
How do I prevent this? Thank you for your time.
please mail me back at mslutsky@umich.edu
I will happily send out my drawing code on request
if it would help anybody. comes with some nice
rotation routines too.

Follow Ups:

  • Re: releasing DDraw objects causes hang Clay 07:48:35 5/22/98 (1)
    • One more thing Clay 07:49:48 5/22/98 (0)

Post a Followup

Name:


ddraw linkin error please help

Posted by menasius on May 17, 1998 at 16:45:30:

I get this error whenever I try to compile any DirectDraw sample
error LNK2001: unresolved external symbol _main
how do I fix this?

Follow Ups:

  • Re: ddraw linkin error please help Ravi Joshi 09:04:36 6/02/98 (0)
  • Re: ddraw linkin error please help EvAcLeAr 19:01:10 5/18/98 (1)
    • Re: ddraw linkin error please help C1pher 22:17:42 5/23/98 (0)

Post a Followup

Name:


Re: Memory Access errors (help a stupid newbie)

Posted by Mitch Christian on May 17, 1998 at 21:48:27:

In Reply to: Memory Access errors (help a stupid newbie) posted by Nick Weihs on April 10, 1998 at 18:18:55:

: any GDI or bitmap manipulation I use causes an unhandled
: memory exception, please help

I had the same trouble when compiling the DirectX samples using Visual C++ v4.0. I finally figured out that I hadn't included the resource (.rc) files in the project.

Try inserting any .rc files and recompiling

Follow Ups:

Post a Followup

Name:


Re: Where to find landscape meshes

Posted by Navin on May 18, 1998 at 04:59:30:

In Reply to: Where to find landscape meshes posted by Joe on April 18, 1998 at 23:08:38:

The only thing I could help you with are simple geometric objects like cylinder, cone, cube, pyramide, sphere.
If you need something like this just let me know..

Follow Ups:

Post a Followup

Name:


Re: Direct X pixel plotting

Posted by qIz on May 18, 1998 at 05:07:02:

In Reply to: Direct X pixel plotting posted by menasius on May 15, 1998 at 23:41:32:

: how do you go about ploting a single pixel onto a DXsurface?

This is a slow way to do it but it's easy to understand.

UINT PlotPixel( UINT x, UINT y, UINT colorValue )
{
UINT bitsIndex;
DDSURFACEDESC DDSDesc;
LPSTR lpDstBits;
HRESULT ddrval;

DDSDesc.dwSize = sizeof(DDSDesc);

// First lock the surface you want to plot to.
// in this case my Backbuffer
while(1)
{
ddrval = lpDDSBack->Lock(NULL, &DDSDesc, 0, NULL);

if(ddrval == DD_OK)
break;
if(ddrval != DDERR_WASSTILLDRAWING)
return 0;

}
// set the destination pixel
// in this case resolution is 640 * 480 * 8
lpDstBits = (LPSTR) DDSDesc.lpSurface;
bitsIndex = (640 * y) + x;

// now fill that "destination" with a color value
// and you have plotted a pixel on the surface
// If you are using 8 bit color res. you can use // BYTE instead of UINT
lpDstBits[bitsIndex] = colorValue;

// now ulock the surface
lpDDSBack->Unlock(NULL);
return colorValue;
}

I think you can just paste this code into your own and it will work.
If there is any problem or for a faster version feel free to mail me at qiz@algonet.se

Follow Ups:

Post a Followup

Name:


Re: How Do I Use IID's (for cloning) In C? Or Can't I?

Posted by markus on May 18, 1998 at 14:46:52:

In Reply to: How Do I Use IID's (for cloning) In C? Or Can't I? posted by sietze on April 17, 1998 at 20:26:33:

Try to encapsulate all your directx in a c++ wrapper.
I do it so with my 3D-Stuff (Rendering and 3D Routines are
comnpletely c). using this way, it was no problem to
port my 3d-stuff from linux-svga to directx.
If you want some source, contact me !

regards

markus

Follow Ups:

Post a Followup

Name:


Re: ddraw linkin error please help

Posted by EvAcLeAr on May 18, 1998 at 19:01:10:

In Reply to: ddraw linkin error please help posted by menasius on May 17, 1998 at 16:45:30:

: I get this error whenever I try to compile any DirectDraw sample
: error LNK2001: unresolved external symbol _main
: how do I fix this?

Your probably using Visual C++ 5.0, when you install VC++ 5 it installs Directx 3 so all the DX 5 samples you compile are looking at the older versions of directx. I fixed the problem by copying all the directx 5 include/lib/media etc... over to the visual c directory overwriting the older files.

Follow Ups:

  • Re: ddraw linkin error please help C1pher 22:17:42 5/23/98 (0)

Post a Followup

Name:


Re: Opinions wanted of the best

Re: Opinions wanted of the best <$200 modeler/renderer/animator for Direct3D

[ Follow Ups ] [ Post Followup ] [ the DirectX eXperience Forum ]

Posted by EvAcLeAr on May 18, 1998 at 19:15:36:

In Reply to: Opinions wanted of the best <$200 modeler/renderer/animator for Direct3D posted by Boller on April 20, 1998 at 20:48:55:

: Hi everybody,

: Just wondering what programs everyone is using out
: there to create their models for Direct3D applications.

: I'm looking to buy a modeler/renderer/animator under
: $200 to create models and animations for my D3D
: programs, and I'm looking for suggestions and opinions...
: Ease of use and the ability to export valid .3ds files
: (so I can convert them to .X files with conv3ds with
: texture maps intact) are my primary concerns. I'd like
: a decent animator built in.

: I've been looking at websites and demos, but nothing
: compares to hearing what people out there are truly
: using and why they love/hate it.

: Thanks for your help!

: Jeff Boller
: decorate@westol.com

Well I don't know of any good ones for under $200, but you might want to save up a little more $$ and give truespace 3 a try it runs about $350. It's quite easy to use, you minipulate primitive objects such as spheres and cubes to create your 3d images, and animation is a breeze. It has a built in direct x exporter and is well supported. If you want you could also try RHINO 3d it's a 3d render in beta format therefore its free, you can give it a shot. You can also download a demo of truespace 3 from calgari.

Follow Ups:

Post a Followup

Name:


Re: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help?

Posted by EvAcLeAr on May 18, 1998 at 19:21:18:

In Reply to: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help? posted by Jeff on January 22, 1998 at 23:27:23:

: Hey guys and girls, I've got this really horrible problem. I hope somebody knows the solution to this, or has had this happen to them before. Here is the problem:
: Ever since I installed Direct X 5.0, my computer keeps locking up. I'm not sure if it is locked up, because it keeps playing the same sound effect over and over again. Say I'm playing Diablo, and I click on something. I hear the sword swinging, but that's ALL I hear. It keeps repeating the sword's sound effect over and over and over...until I have to turn my volume down. And also, my screen freezes, and I can't do anything about it. I don't know what's wrong...but here is my system info:
: Pentium 233 MMX, Sound Blaster 16, and S3 ViRGE Video Card, with 32 Mb RAM and 4.3 GB Hard Drive.
: Can anyone tell me how to fix this problem?? My computer cost so much, like $1400 and I thought it would be really good. But I think there's something wrong with Direct X 5. Can anyone help me??? Maybe someone had this happen to them, and will help me fix it. Or else, if nothing works, can anyone tell me how to Uninstall Direct X 5, because when I go to Add/Remove Programs in the Control Panel, I click on "Uninstall DirectX". It brings me up to a menu that says "Restore Audio/Display Drivers" I restored both of them, but my computer keeps freezing still. And Direct X 5.0 is not uninstalled!! If anyone can help me, please respond!! Thanks

Hmm that sounds like an actual system problem. Try to run scandisk on the drive and if you have norton utilities run WinDoctor. You may have something somewhere in windows pointing at the wrong thing. You may have also chosen the wrong drivers for your vidcard, soundblaster, etc..... when you installed direct x. You can goto your vidcard and soundcard co's web page & see if they have an updated driver for use with directx. (most likely they will) this may solve the problem.

Follow Ups:

Post a Followup

Name:


Re: Where to find landscape meshes

Posted by EvAcLeAr on May 18, 1998 at 19:27:00:

In Reply to: Where to find landscape meshes posted by Joe on April 18, 1998 at 23:08:38:

:
: Can anyone out there help me find a landscape generator
: that writes mesh/polygonal/object file (like .3ds, .x,
: .obj, .anything but 2d images)?

: Or are there any large areas where such meshes are
: already available for use?

: Any suggestions would be helpful. If possible, does
: anyone have much experience trying to create 3d "worlds"
: (a landscape == world in a sense) which could be made
: into meshes? I use 3ds Max 2.5 (the beta version!) and
: am not having much luck...

: thanks in advance.

Well you could try Bryce 3d, but sence your already using 3ds Max 2.5 you at least goto www.3dcafe.com & look threw their tutorials. They have one on how to create landscapes using diffrent 3d programs including max.

Follow Ups:

Post a Followup

Name:


Re: It didn't...(HEEELP!!)

Posted by Doc on May 19, 1998 at 13:13:12:

In Reply to: It didn't...(HEEELP!!) posted by Sietze on April 01, 1998 at 18:04:10:

: --SNIP!--

: In the previous post I provided a possible solution
: for Martijn's problem, but he was talking about
: 2D- and not 'decal-style'-blits. Now I *HOPED* that
: would be not much of a problem in a 3D-scene, until
: I started working on lensflares. I dug up some
: lensflare-code, and guess what? It used 2D-blits.
: I then started looking in the docs, where I learned
: that, OH HELL, transparent (alpha-blended) blitting
: is not supported yet. Xcuse me? Where do all my
: alpha blended decals come from? What does the
: Direct3D execute buffer do that I'm not supposed or
: allowed to do? Anyone?

: Sietze Dijkstra
: sietze@jaytown.com

It's very simple, you must Lock() your Back-Surface and Code the Effect on your own.
If you're using 16bpp you can simple add some
color-keys to the existing Bitmap and result
will be a very funny Color-Effect. Not so hard isn't it ?? ;-)
I, for example, use this way to add some nice shadows to my game. I simple Add a Color-Key
(RGB 20/20/20) to the Surface using my own
Blitting-Function ( The Hard Way )

CU - Doc

Follow Ups:

Post a Followup

Name:


How do I uninstall DirectX?

Posted by A. Chan on May 20, 1998 at 19:12:10:

Does anyone know how to uninstall DirectX on a laptop?
I just spoke with the folks at Toshiba and I was
informed that DirectX is not compatible with a
laptop. My screen won't go back to its original size,
and in order for it to do so, I have to uninstall
DirectX. Please advise.

Thanks in advance for the help.

AC

Follow Ups:

  • Re: How do I uninstall DirectX? EvAcLeAr 04:10:45 5/25/98 (0)

Post a Followup

Name:


Meshes

Posted by Herbert Schuster on May 21, 1998 at 04:51:28:

Can someone help me ?

I need a Tool for building Meshes

Thanks

Follow Ups:

  • Re: Meshes MAgDI 21:16:03 7/06/98 (0)

Post a Followup

Name:


Re: Reverse playback of video via DirectShow

Posted by Thomas Krim on May 21, 1998 at 05:06:00:

In Reply to: Re: Reverse playback of video via DirectShow posted by Robert Tomlin on May 11, 1998 at 05:17:45:

:
: : Hi Guys,

: : has anybody a suggestion to playback a video in reverse order? Although the doc's say that it is possible to give the IMediaSeeeking Interface a
: : negative value (-1) via SetRate(), it returns an
: : INVALID_ARGUMENT. Trying to skip backwards through the avi-file via SetPosition() doesn't help, because this doesn't run smoothly.

: : Any suggestions are very welcome.

: : TIA
: : Thomas Krim

: Sorry this does not help you much but seeing that you are using DirectShow I am wondering if you experience a flash when you first play a movie ?

: Thanks in advance

Hi, Robert,

no, i have no flash. After rendering a file a give a Pause/StopWhenReady that the first frames is rendering on screen. After a Play command playback is smooth with any flash.
Thomas

Follow Ups:

  • Re: Reverse playback of video via DirectShow Thomas Krim 05:07:33 5/21/98 (0)

Post a Followup

Name:


Re: Reverse playback of video via DirectShow

Posted by Thomas Krim on May 21, 1998 at 05:07:33:

In Reply to: Re: Reverse playback of video via DirectShow posted by Thomas Krim on May 21, 1998 at 05:06:00:

: :
: : : Hi Guys,

: : : has anybody a suggestion to playback a video in reverse order? Although the doc's say that it is possible to give the IMediaSeeeking Interface a
: : : negative value (-1) via SetRate(), it returns an
: : : INVALID_ARGUMENT. Trying to skip backwards through the avi-file via SetPosition() doesn't help, because this doesn't run smoothly.

: : : Any suggestions are very welcome.

: : : TIA
: : : Thomas Krim

: : Sorry this does not help you much but seeing that you are using DirectShow I am wondering if you experience a flash when you first play a movie ?

: : Thanks in advance

: Hi, Robert,

: no, i have no flash. After rendering a file a give a Pause/StopWhenReady that the first frames is rendering on screen. After a Play command playback is smooth with any flash.
: Thomas
Last sentence should be "without any flash"!!

Follow Ups:

Post a Followup

Name:


Re: Direct3D DrawPrimitive

Posted by Serge Plagnol on May 21, 1998 at 10:23:32:

In Reply to: Direct3D DrawPrimitive posted by Andr�as K�hne on April 06, 1998 at 03:07:57:

My guess is that most likely you haven't set (or haven't even created) a viewport.

You have do to something like this:

hRes = lpd3d->CreateViewport(&lpd3dViewport, NULL);
if (FAILED(hRes))
return hRes;
hRes = lpd3dDevice->AddViewport(lpd3dViewport);
if (FAILED(hRes))
return hRes;
hRes = lpd3dDevice->SetCurrentViewport(lpd3dViewport);
if (FAILED(hRes))
return hRes;

Follow Ups:

Post a Followup

Name:


D3DTLVERTEX sz & rhw fields

Posted by Serge Plagnol on May 21, 1998 at 10:34:02:

I have a problem using D3DTLVERTEX.
I have my own 3D engine and don't use D3D to do transform, lighting and projection. This is all done in my own code. I just use Drawprimitive with D3DTLVERTEX.
I read many times the DirectX 5 but I can't get the Z-buffer to work properly. Objects don't intersect properly. I must do something wrong with the sz and rhw fields. Or maybe with my viewport.
Anybody could help?

Follow Ups:

  • Re: D3DTLVERTEX sz & rhw fields Robert 14:01:32 5/21/98 (0)

Post a Followup

Name:


Re: D3DTLVERTEX sz & rhw fields

Posted by Robert on May 21, 1998 at 14:01:32:

In Reply to: D3DTLVERTEX sz & rhw fields posted by Serge Plagnol on May 21, 1998 at 10:34:02:

: I have a problem using D3DTLVERTEX.
: I have my own 3D engine and don't use D3D to do transform, lighting and projection. This is all done in my own code. I just use Drawprimitive with D3DTLVERTEX.
: I read many times the DirectX 5 but I can't get the Z-buffer to work properly. Objects don't intersect properly. I must do something wrong with the sz and rhw fields. Or maybe with my viewport.
: Anybody could help?

I have had the same problems lately :)
check out how your view ports z clipping is put!
viewData.dvMinZ = 0.0f;
viewData.dvMaxZ = 1.0f;
that means that you can only have a value in your D3DTLVERTEX sz=0.0 up to 0.9999
any values above 1.0 will be clipped!! or below 0.0
Now I havent't tested to rize the viewData.dvMaxZ = 1000.0 to a higher value yet??

Then your rhw is simply 1/sz that used to work.

if you are using 4x4 matrices with a common perspective matrix you'll get your rhw value in the [XYZW]W entry W=1/rhw rhw=1/W => W=Z*konstant (scaling) (this used to work just fine for me)
depends on how you want to calculate it.
Otherwise test your self!! like i did when nothing worked :) huh hard work. But #�%#��"#�#"� for 3dfx still nothing. when I use another vertex type and draw primitive mode it works just fine that pisses me off really badly!

But for some reason I can't get my Engine to work for a 3dfx ?????????????????
but other hardware works just fine with the D3DTL VERTEX? so I allso thought I have messed up my viewports ????
I NEED ALSO HELP!!

Follow Ups:

Post a Followup

Name:


Re: Fog help!

Posted by Robert on May 21, 1998 at 14:14:17:

In Reply to: Fog help! posted by Hana on May 08, 1998 at 18:51:16:

: The explanation of fog in the DirectX help seems
: simple... but I can't get it to work.

: In ramp mode, (using lightstate) everything goes black.
: In RGB, (using renderstate), all my objects are
: solidly filled with the fog color.

: What is this fog table that the help refers to?

Damn I had just the same problem!!but As I explored I used lightstate for (RGB) (MMX) (HAL) that seems to work just fine
use the render states for enabling the fog and setting the fog colour , let the lightstates to do the rest seting fog start and fog end positions
se to it that these positions are also the same as you get out from your screen coordinates in Z otherwise you'll have a hard time to find them :)
the render table mode ???? haven't worked for me at all??? and these fog stuff could be a problem combined with some hardware like s3 virge never works properly as you want it to???????????
also note that use only the linear fog because the others are not enabled yet.
If you use the D3DVERTEXTYPE for draw primitive mode then calculate the fog for you self and disable the state fogs, and thing will work better then :)

i hope this helps
//Robert

Follow Ups:

Post a Followup

Name:


HELP! my lights don't work properly!

Posted by sietze on May 21, 1998 at 17:02:07:

hi,

I'm writing a 'doom-style' game in d3drm and everything is OK, but at about 100 units distance, the walls
suddenly turn very bright, almost completely white, although I only use stationary light sources (point
sources, that is). Could someone please 'enlighten' me?

Thanks in advance,

Sietze.

Follow Ups:

  • Re: HELP! my lights don't work properly! Clay 07:35:21 5/22/98 (1)
    • OK shoot me, i'm stupid Sietze 06:34:21 5/23/98 (0)

Post a Followup

Name:


Sprite Collisions

Posted by Eduardo Meza on May 21, 1998 at 18:59:22:

How do you detect sprite collisions. Currently I have come up with two different functions to do this, but one is too slow and the other one has poor graphical effects. In other words, only the rectangle enclosing my sprite collides, but the actual sprite doesn't collide. This is fast, but it doesn't look right. I'll apreciate any help that I can get. Thanks

Follow Ups:

  • Re: Sprite Collisions EvAcLeAr 03:34:33 5/30/98 (0)
  • Re: Sprite Collisions EvAcLeAr 05:01:38 5/25/98 (0)

Post a Followup

Name:


Re: HELP! my lights don't work properly!

Posted by Clay on May 22, 1998 at 07:35:21:

In Reply to: HELP! my lights don't work properly! posted by sietze on May 21, 1998 at 17:02:07:

This could be a video card issue. I've tried some of my D3D code on different cards (namely a Mystique, Rage Pro 3D, and Voodoo2) and gotten different results for each. Most of the time, there was a way of getting the effect I wanted that was consistent across all three. Try switching between the HAL, HEL, RGB, Ramp, and MMX drivers and looking at the results.

Clay

: hi,

: I'm writing a 'doom-style' game in d3drm and everything is OK, but at about 100 units distance, the walls
: suddenly turn very bright, almost completely white, although I only use stationary light sources (point
: sources, that is). Could someone please 'enlighten' me?

: Thanks in advance,

: Sietze.

Follow Ups:

  • OK shoot me, i'm stupid Sietze 06:34:21 5/23/98 (0)

Post a Followup

Name:


Re: D3D gives floating point errors for no detecable reason

Posted by Clay on May 22, 1998 at 07:41:18:

In Reply to: D3D gives floating point errors for no detecable reason posted by Luke Ryan on May 13, 1998 at 01:29:56:

Sounds like one of two things is happening. Either you're not initializing some of your COM objects correctly, or you're allocating memory that overlaps some DX memory -- could be a compiler problem or you are overwriting the bounds of an array.

Clay

Follow Ups:

Post a Followup

Name:


Re: releasing DDraw objects causes hang

Posted by Clay on May 22, 1998 at 07:48:35:

In Reply to: releasing DDraw objects causes hang posted by morris on May 17, 1998 at 00:36:43:

Switching to/from fullscreen can be a tricky thing. When going back to the windows desktop from fullscreen, you need to call
FlipToGDISurface();
Also, order matters when you are Releasing() objects. You should not release any objects that were used to create other objects (like surfaces are created from an IDirectDraw object) until the "child" objects are Release()d.

Clay

Follow Ups:

  • One more thing Clay 07:49:48 5/22/98 (0)

Post a Followup

Name:


One more thing

Posted by Clay on May 22, 1998 at 07:49:48:

In Reply to: Re: releasing DDraw objects causes hang posted by Clay on May 22, 1998 at 07:48:35:

Oops -- you also need to call RestoreDisplayMode()!

Clay

Follow Ups:

Post a Followup

Name:


polygon near klipping

Posted by Robert on May 22, 1998 at 09:18:15:

I have a huge problems with polygon nearest the screen they have a tendency to make some really ugly clipping ???
And this does only for D3DTLVERTEX for draw primitive mode.

For D3DVERTEX works just fine!.

I NEED URGENT HELP what should I do?? polygon divide perspective correct polygons near the screen ???? (that would be wierd? but would perhaps work)..
//Robert

Follow Ups:

Post a Followup

Name:


Re: 8bpp24bpp

Posted by cappa luca on May 22, 1998 at 12:48:09:

In Reply to: Re: 8bpp24bpp posted by Brian Shea on May 08, 1998 at 12:25:36:

so if i load on a 16bit surface a picture from
disk, whatever is the pixel format of the image, using the LoadImage of Win32 API, it's converted for us in the pixel format of the 16bpp surface: it's ok?

Follow Ups:

Post a Followup

Name:


Re: Problem with the IDirect3DRMAnimationSet::Load

Posted by Larry Velasquez on May 23, 1998 at 01:02:45:

In Reply to: Problem with the IDirect3DRMAnimationSet::Load posted by Fred on May 15, 1998 at 09:25:51:

: Does any one know how to use the IDirect3DRMAnimationSet::Load function to load the same animation file more then once? The following is part of my code:
: ....
: lpD3DRM->CreateFrame(lpScene, &lptmpFrame);
: LPDIRECT3DRMANIMATIONSET lpAniSet;
: lpD3DRM->CreateAnimationSet(&lpAniSet);
: lpAniSet->Load("myAni.x", NULL,D3DRMLOAD_FROMFILE, NULL, NULL, lptmpFrame);
: lptmpFrame->SetPosition(......)
: .... callback function etc etc

: It works fine in this way, However, if i add the following:

: lpD3DRM->CreateFrame(lpScene, &lptmpFrame2);
: LPDIRECT3DRMANIMATIONSET lpAniSet2;
: lpD3DRM->CreateAnimationSet(&lpAniSet2);
: lpAniSet2->Load("myAni.x", NULL,D3DRMLOAD_FROMFILE, NULL, NULL, lptmpFrame2);
: lptmFrame->SetPosition(... to different postion);
: ... callback... etc etc

: It suppose to show up TWO same animating objects at different positions, but it didnt! It only shows the one that loaded 1st. The second load animation only showup after i comment out the first Load actoin!

: Can anyone explain why this happen? How should i suppost to do to load the same animation twice? What i really want to do is to create Two/Three SAME animations in one scene. Any suggest or walkaround?

: Thx in Advance

: Fred

Follow Ups:

Post a Followup

Name:


Re: Problem with the IDirect3DRMAnimationSet::Load

Posted by Larry Velasquez on May 23, 1998 at 01:03:48:

In Reply to: Problem with the IDirect3DRMAnimationSet::Load posted by Fred on May 15, 1998 at 09:25:51:

: Does any one know how to use the IDirect3DRMAnimationSet::Load function to load the same animation file more then once? The following is part of my code:
: ....
: lpD3DRM->CreateFrame(lpScene, &lptmpFrame);
: LPDIRECT3DRMANIMATIONSET lpAniSet;
: lpD3DRM->CreateAnimationSet(&lpAniSet);
: lpAniSet->Load("myAni.x", NULL,D3DRMLOAD_FROMFILE, NULL, NULL, lptmpFrame);
: lptmpFrame->SetPosition(......)
: .... callback function etc etc

: It works fine in this way, However, if i add the following:

: lpD3DRM->CreateFrame(lpScene, &lptmpFrame2);
: LPDIRECT3DRMANIMATIONSET lpAniSet2;
: lpD3DRM->CreateAnimationSet(&lpAniSet2);
: lpAniSet2->Load("myAni.x", NULL,D3DRMLOAD_FROMFILE, NULL, NULL, lptmpFrame2);
: lptmFrame->SetPosition(... to different postion);
: ... callback... etc etc

: It suppose to show up TWO same animating objects at different positions, but it didnt! It only shows the one that loaded 1st. The second load animation only showup after i comment out the first Load actoin!

: Can anyone explain why this happen? How should i suppost to do to load the same animation twice? What i really want to do is to create Two/Three SAME animations in one scene. Any suggest or walkaround?

: Thx in Advance

: Fred

Follow Ups:

Post a Followup

Name:


Re: Problem with the IDirect3DRMAnimationSet::Load

Posted by Larry Velasquez on May 23, 1998 at 01:05:40:

In Reply to: Problem with the IDirect3DRMAnimationSet::Load posted by Fred on May 15, 1998 at 09:25:51:

I want to install the Directx 5.0 adio video player.
:Does any one know how to use the IDirect3DRMAnimationSet::Load function to load the same animation file more then once? The following is part of my code:
: ....
: lpD3DRM->CreateFrame(lpScene, &lptmpFrame);
: LPDIRECT3DRMANIMATIONSET lpAniSet;
: lpD3DRM->CreateAnimationSet(&lpAniSet);
: lpAniSet->Load("myAni.x", NULL,D3DRMLOAD_FROMFILE, NULL, NULL, lptmpFrame);
: lptmpFrame->SetPosition(......)
: .... callback function etc etc

: It works fine in this way, However, if i add the following:

: lpD3DRM->CreateFrame(lpScene, &lptmpFrame2);
: LPDIRECT3DRMANIMATIONSET lpAniSet2;
: lpD3DRM->CreateAnimationSet(&lpAniSet2);
: lpAniSet2->Load("myAni.x", NULL,D3DRMLOAD_FROMFILE, NULL, NULL, lptmpFrame2);
: lptmFrame->SetPosition(... to different postion);
: ... callback... etc etc

: It suppose to show up TWO same animating objects at different positions, but it didnt! It only shows the one that loaded 1st. The second load animation only showup after i comment out the first Load actoin!

: Can anyone explain why this happen? How should i suppost to do to load the same animation twice? What i really want to do is to create Two/Three SAME animations in one scene. Any suggest or walkaround?

: Thx in Advance

: Fred

Follow Ups:

Post a Followup

Name:


Re: Problem with the IDirect3DRMAnimationSet::Load

Posted by Larry Velasquez on May 23, 1998 at 01:06:05:

In Reply to: Problem with the IDirect3DRMAnimationSet::Load posted by Fred on May 15, 1998 at 09:25:51:

I want to install the Directx 5.0 adio video player.
:Does any one know how to use the IDirect3DRMAnimationSet::Load function to load the same animation file more then once? The following is part of my code:
: ....
: lpD3DRM->CreateFrame(lpScene, &lptmpFrame);
: LPDIRECT3DRMANIMATIONSET lpAniSet;
: lpD3DRM->CreateAnimationSet(&lpAniSet);
: lpAniSet->Load("myAni.x", NULL,D3DRMLOAD_FROMFILE, NULL, NULL, lptmpFrame);
: lptmpFrame->SetPosition(......)
: .... callback function etc etc

: It works fine in this way, However, if i add the following:

: lpD3DRM->CreateFrame(lpScene, &lptmpFrame2);
: LPDIRECT3DRMANIMATIONSET lpAniSet2;
: lpD3DRM->CreateAnimationSet(&lpAniSet2);
: lpAniSet2->Load("myAni.x", NULL,D3DRMLOAD_FROMFILE, NULL, NULL, lptmpFrame2);
: lptmFrame->SetPosition(... to different postion);
: ... callback... etc etc

: It suppose to show up TWO same animating objects at different positions, but it didnt! It only shows the one that loaded 1st. The second load animation only showup after i comment out the first Load actoin!

: Can anyone explain why this happen? How should i suppost to do to load the same animation twice? What i really want to do is to create Two/Three SAME animations in one scene. Any suggest or walkaround?

: Thx in Advance

: Fred

Follow Ups:

Post a Followup

Name:


Re: directX5

Posted by Mr.Goodbar on May 23, 1998 at 01:08:15:

In Reply to: directX5 posted by mike on May 07, 1998 at 13:50:12:

: my directx seems not to be working i can play certain games like monster truck maddness but no games that use directx5 i was wondering if i can reload or down load from another source iam new at computing so if anyone can help that would be greati dont know if this is important but i have a fairly new 233 gateway pent.2 thanks agin mike

Follow Ups:

  • Re: directX5 �s�� 21:45:08 7/03/98 (1)
    • Re: directX5 �s�� 21:48:27 7/03/98 (0)
  • Re: directX5 �s�� 21:44:48 7/03/98 (0)
  • Re: directX5 �s�� 21:44:16 7/03/98 (0)
  • Re: directX5 n 07:21:39 6/24/98 (0)

Post a Followup

Name:


Re: directX5

Posted by Mr.Goodbar on May 23, 1998 at 01:09:50:

In Reply to: directX5 posted by mike on May 07, 1998 at 13:50:12:

I want to install the DirectX5 so I can use what I want to use.

Follow Ups:

  • Re: directX5 Matt 17:10:24 6/06/98 (0)

Post a Followup

Name:


Re: IS directX5.0 compatible with the matrox millenium videocard?

Posted by Mr.Goodbar on May 23, 1998 at 01:12:32:

In Reply to: IS directX5.0 compatible with the matrox millenium videocard? posted by Davy Weynants on January 24, 1998 at 10:18:23:

: I would like to know something about directX5.0.
: Last month I've bought TOMBRAIDER 2 but when I play
: the quality of the images are very bad. I have a Matrox Millenium videocard. Is directX5.0 compatible with this card??????????????

: P.S.:My system requirements are OK
: (pentium133,48MBram,2MBVRAM)

Follow Ups:

Post a Followup

Name:


OK shoot me, i'm stupid

Posted by Sietze on May 23, 1998 at 06:34:21:

In Reply to: Re: HELP! my lights don't work properly! posted by Clay on May 22, 1998 at 07:35:21:

It's not a video card issue.
It's not freaky behaviourby Direct3D.
It's lil' ol' me mistaking fog for moving lights!
I appear to have placed my point light sources _inside_ a wall. This, in combination with fog,
apperently gives very strange effects. Thanks for the info though. When I see something
odd again, I'll keep it in mind.

Sietze

: This could be a video card issue. I've tried some of my D3D code on different cards (namely a Mystique, Rage Pro 3D, and Voodoo2) and gotten different results for each. Most of the time, there was a way of getting the effect I wanted that was consistent across all three. Try switching between the HAL, HEL, RGB, Ramp, and MMX drivers and looking at the results.

: Clay

: : hi,

: : I'm writing a 'doom-style' game in d3drm and everything is OK, but at about 100 units distance, the walls
: : suddenly turn very bright, almost completely white, although I only use stationary light sources (point
: : sources, that is). Could someone please 'enlighten' me?

: : Thanks in advance,

: : Sietze.

Follow Ups:

Post a Followup

Name:


help with directx and presario 2220.....!!!

Posted by Jim W. on May 23, 1998 at 12:53:58:

when i run starfleet academy i get a "d3d hardware initalization error".....my video driver isnt certified for direct x and compaq doesnt offer a certified driver for it.......

does anyone know how to fix this error???

Follow Ups:

  • Re: help with directx and presario 2220.....!!! EvAcLeAr 04:31:33 5/25/98 (2)
    • Re: my star trek game wont work please help Kent Peterson 23:19:48 7/07/98 (1)
      • Re: my star trek game wont work please help Kent Peterson 23:20:59 7/07/98 (0)

Post a Followup

Name:


Re: ddraw linkin error please help

Posted by C1pher on May 23, 1998 at 22:17:42:

In Reply to: Re: ddraw linkin error please help posted by EvAcLeAr on May 18, 1998 at 19:01:10:

While it could be an out dated Direct X file or .DLL
the problem sounds very similiar to what happens when
you attempt to compile a Direct X sample with out setting
your compiler's target to a WIN32 application when you
are creating a project workspace in Visual C++.

Follow Ups:

Post a Followup

Name:


Alpha-Blending / Lens-Flare

Posted by Chris on May 24, 1998 at 06:00:23:

Hi,
is it possible to implement alpha-blending and lens-flare
effects into my programs by using Direct X 5 (without GL or Glide) ?

I'm programming with Direct 3D Retained Mode and don't want to
use Immediate Mode.

Thanks for your support,
Chris ;-)

Follow Ups:

  • Re: Alpha-Blending / Lens-Flare Sietze 11:17:08 6/02/98 (0)

Post a Followup

Name:


Compiler

Posted by Torin on May 24, 1998 at 13:08:50:

I need a 32-bit compiler. What is the best one for using directx? Thanks!

Follow Ups:

  • Re: Compiler EvAcLeAr 04:20:36 5/25/98 (0)

Post a Followup

Name:


Texture Wrapping Function What is it for

Posted by Sajid Khan on May 25, 1998 at 03:29:13:

I can not understand what CreateWrap function does
besides how can I know the values of the parameters
in it?

Follow Ups:

Post a Followup

Name:


DX 5.0 & AVI Troubles (Examples Don't Work Well at all!!)

Posted by EvAcLeAr on May 25, 1998 at 03:59:47:

Ok, I've read the articles & downloaded the demos that are available on the net. But I still havent found a way to get AVI's to play using direct x and actually play normal. Every time i use one of the examples from MS or anywhere else I get one hell of a choppy picture as well as skipping sound, but when I play the same AVI using win95's built in AVI player it plays normaly. I'm extreemly frustrated can anyone help? I'm using DX 5.0 SDK and Vc++5.0 if it makes any diffrence. Thanks in advance

Follow Ups:

  • Re: DX 5.0 & AVI Troubles (Examples Don't Work Well at all!!) BoxMan 21:02:25 6/08/98 (0)

Post a Followup

Name:


Re: All my DirectX games won't run. HELP!!

Posted by EvAcLeAr on May 25, 1998 at 04:08:23:

In Reply to: All my DirectX games won't run. HELP!! posted by Chester on January 25, 1998 at 15:40:01:

: All of my games that use DirectX won't run.Red Alert,JediKnight, Motoracer..
: When I click to run the game it begins to load, screen goes black, and then returns to windows again
: , no error message or anything.. Like I never done it... If anyone can help, Please e mail me

Sounds like your directx is not set up correctly. Uninstall it by going to add/remove programs then highlight directx. Then reboot and reinstall Directx. That should solve your problems. Most likely your vidcard did not get detected correctly.

Follow Ups:

Post a Followup

Name:


Re: How do I uninstall DirectX?

Posted by EvAcLeAr on May 25, 1998 at 04:10:45:

In Reply to: How do I uninstall DirectX? posted by A. Chan on May 20, 1998 at 19:12:10:

: Does anyone know how to uninstall DirectX on a laptop?
: I just spoke with the folks at Toshiba and I was
: informed that DirectX is not compatible with a
: laptop. My screen won't go back to its original size,
: and in order for it to do so, I have to uninstall
: DirectX. Please advise.

: Thanks in advance for the help.

: AC

All you need to do is go into my computer/control panel/add remove programs and highlight directx then press the add/remove button below. Reboot your computer & you should be all set.

Follow Ups:

Post a Followup

Name:


Re: Compiler

Posted by EvAcLeAr on May 25, 1998 at 04:20:36:

In Reply to: Compiler posted by Torin on May 24, 1998 at 13:08:50:

: I need a 32-bit compiler. What is the best one for using directx? Thanks!

Well are you programming in c++, c, or pascal?
If you are using c++ or c I would suggest Watcom or visual c++ 4.0 & up. (just because you can find more examples that work with these compilers with out having to make too many modifications)
If your a pascal user get your self DELPHI, it uses the same compiler as Borland's c++ and your still using the pascal/delphi programming language (The draw back is that your not going to find too many examples that will run with out modification)
Hope this helps.

Follow Ups:

Post a Followup

Name:


Re: dxsetup can't see my card...

Posted by EvAcLeAr on May 25, 1998 at 04:28:40:

In Reply to: dxsetup can't see my card... posted by Shep Ryen on April 30, 1998 at 23:27:45:

: I recently installed a new Cirrus Logic 5464 card on my Dell PC. The old card was an S3 Trio that's part of the motherboard.

: Now, the old card is disabled, and the new one is working great. But dxsetup continues to install the primary display driver for the S3 card.
: Anyone know why? Or how I might bypass this problem?

: Sincerely,
: Shep Ryen

Direct X is a fairly stupid program, you need to tell it you changed your vid card other wise it will use the old driver on the new card. In order to do that you have to go into control panel/control pannel & look for a yellow X on blue background & click on that. Then remove the old drivers & let it detect new ones. If this doesn't work make sure windows 95 isn't also accessing your new video card using the old s3's drivers (Win 95 is more stupid than direct x is). And if that fails I would remove all the vid drivers attached to win95 & reboot the pc to let it detect the one still in the computer. Hope this helps. If not I've got a base ball bat I'll lend you....

Follow Ups:

Post a Followup

Name:


Re: help with directx and presario 2220.....!!!

Posted by EvAcLeAr on May 25, 1998 at 04:31:33:

In Reply to: help with directx and presario 2220.....!!! posted by Jim W. on May 23, 1998 at 12:53:58:

: when i run starfleet academy i get a "d3d hardware initalization error".....my video driver isnt certified for direct x and compaq doesnt offer a certified driver for it.......

: does anyone know how to fix this error???

Well if compaq doesn't support the video card in there, try to find out from them what kind of vid card is in the system. Then go to the companies web site & see if they offer an updated driver (Most update drivers 1ce every 3 or 4 months). Or you could just wait another month or so until Directx 6 comes out. From what I hear DirectX 6 will support more hardware including more vid cards.

Follow Ups:

  • Re: my star trek game wont work please help Kent Peterson 23:19:48 7/07/98 (1)
    • Re: my star trek game wont work please help Kent Peterson 23:20:59 7/07/98 (0)

Post a Followup

Name:


Re: Bitmap Rotation

Posted by EvAcLeAr on May 25, 1998 at 04:53:02:

In Reply to: Bitmap Rotation posted by Graham P on April 24, 1998 at 10:44:28:

: Does anyone know of a simple way of doing bitmap
: rotation in DirectX?

: I am a complete newbie with DirectX, but am
: considering the jump from DOS.

: Are there any examples of source code for doing
: bitmap rotation, or is it simply a function call?

: Ta muchly,
: Graham.

I'm unsure of exactly what you are asking. Are you looking for a sample of a program that does simple 2d sprite animation reading information from a BMP or other type of pictrue file? Or are you refering to something else? Please ellaborate & If I can help out I will point you in the direction of some samples. :)

Follow Ups:

Post a Followup

Name:


Re: Sprite Collisions

Posted by EvAcLeAr on May 25, 1998 at 05:01:38:

In Reply to: Sprite Collisions posted by Eduardo Meza on May 21, 1998 at 18:59:22:

: How do you detect sprite collisions. Currently I have come up with two different functions to do this, but one is too slow and the other one has poor graphical effects. In other words, only the rectangle enclosing my sprite collides, but the actual sprite doesn't collide. This is fast, but it doesn't look right. I'll apreciate any help that I can get. Thanks

I'm experiancing the same problem. Hopefully I will come up with a better algorithem to do this If I do I'll let you know. Do me a favor if you come across one before let me know ok? :)

Follow Ups:

Post a Followup

Name:


Retained Mode Texture Loading

Posted by Larry Weinstein on May 25, 1998 at 09:34:35:

I use IDirect3DRM::LoadTexture to load textures from files. I have found that there is a pause when the Mesh associated with these textures enters the viewport. Once this initial pause is over, the objects can leave and re-enter the viewport without the pause occuring. I suspect that the textures are not being placed in video memory until they are "needed." Can anyone tell me what is going on -- and how to eliminate this pause? Is there any way to control which textures are stored in video memory (if this is the problem?)

Follow Ups:

  • Re: Retained Mode Texture Loading Fred 08:25:57 5/28/98 (0)

Post a Followup

Name:


How to rotate a point around another point in 2-D space

Posted by Emil Diego on May 25, 1998 at 23:19:11:

I have a list of points which represents a polygon
and i want to rotate the points around another point.
This is all done in 2D space. I need an algorithm to
do that. I haven;t had any luck so far coming up
with my own :(

Thanx in advance for the help
Emil Diego
ediego@bccom.com

Follow Ups:

  • Re: How to rotate a point around another point in 2-D space Captain Conan 00:26:53 6/24/98 (0)

Post a Followup

Name:


DirectX 5.0 problems

Posted by Barry on May 26, 1998 at 09:59:25:

I can not delete DirectX 5.0 and reset my computer to original configuration without reformatting it. Do you know how to help me.

Follow Ups:

  • Re: DirectX 5.0 problems Joel Morgovsky 09:07:11 6/15/98 (0)
  • Re: DirectX 5.0 problems EvAcLeAr 23:57:45 5/28/98 (0)

Post a Followup

Name:


Multimedia Streaming

Posted by robert tomlin on May 26, 1998 at 11:11:12:

I wish to create a windows thread which will render frames of a video to a DD surface. I have am using MSVC++ 5. I have so far created a CWinThread object to create the thread for the video.
I have opened the mulitmedia stream and created the sample which I want to update.

I can get the video to render to the surface but as I want to blit the video frames to a Window DC I need to know when the sample has been updated. I have attempted to use an APC to be called when the update has completed. This however does not appear to work ?

Any suggestions would be greatly appriated,

Rob Tomlin

PS The following is how I am trying to achieve the updates :

void CALLBACK APCUpdate(DWORD dwParam)
{
// set the update again with this as the call back
// until the video has completed ??
}

HRESULT CDirectMediaMovie::PlayVideo(CDC *aPort)
{
// mark as playing
m_CurrentState = 1;

// update the sample asyncrounously
HRESULT hr = m_pIAMMultiMediaStream->SetState(STREAMSTATE_RUN);

// APCUpdate never called ???
hr = m_pIDirectDrawSample->Update(SSUPDATE_ASYNC, NULL, APCUpdate, 0);

return(hr);
}

Follow Ups:

  • Re: Multimedia Streaming Laurent TAUPIN 10:39:21 6/18/98 (0)

Post a Followup

Name:


Direct Show "How can I play a movie in full-screen?"

Posted by Seong Wan Kim on May 26, 1998 at 22:59:13:

I've tried play a AVI movie in full-screen mode.
But It doesn't work.

I've tried with SDK sample source cplay.c

I inserted some code for full-screen mode play.

such as

IVideoWindow::get_FullScreenMode(..) IVideoWindow::put_FullScreenMode(..) etc..

My every efforts to play movie in full-screen mode are failed.
SDK document is very poor. I can't find any exact info.

Is anybody knows how to play AVI movie in full-screen mode using Direct Show?

Thanks

IFullScreenVideo..

Follow Ups:

  • Re: Direct Show "How can I play a movie in full-screen?" Laurent TAUPIN 10:35:47 6/18/98 (0)

Post a Followup

Name:


Where can I get DirectX5.0 SDK. OR Microsoft Suck.

Posted by Crispin Wellington on May 27, 1998 at 08:09:29:

Does anyone now where of how I can download the 5.0 SDK. Microsoft
have taken it off line requiring you to buy a CD off them giving them
all your info (inc CC#). They suck.
Thankyou in advance

Follow Ups:

  • Get DirectX 5.0 SDK here. Anybody know where to get 5.2? M. Wagner 00:56:21 5/28/98 (10)
    • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? R.JONES 19:09:12 7/06/98 (0)
    • thank you Cesar 14:04:40 6/29/98 (0)
    • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? Steven Weesner 08:47:23 6/29/98 (0)
    • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? Robert Vaillancourt 22:18:07 6/28/98 (0)
    • I know where to get 5.2 Ashley Fisher 03:12:45 6/28/98 (0)
    • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? Jay (the answer) 23:40:11 6/23/98 (0)
    • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? chris peters 01:14:58 6/07/98 (1)
      • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? karen 18:06:40 6/28/98 (0)
    • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? chris peters 01:13:34 6/07/98 (0)
    • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? chris peters 01:09:45 6/07/98 (0)

Post a Followup

Name:


Delphi DirectX articles wanted!

Posted by Dean Ellis on May 27, 1998 at 10:56:48:

Im putting together a web page dedicated to using
DirectX in Delphi and using the DGC components. I'm
looking for any tips or tricks and articles delphi
developers have and wish to pass on to others.

Any information would be helpfull.

Thanks

Follow Ups:

  • Re: Delphi DirectX articles wanted! Christopher �zbek 08:00:13 6/24/98 (0)

Post a Followup

Name:


Scrolling TeXt

Posted by Damon on May 27, 1998 at 15:07:38:

Just stumbled onto this site. Does anyone know if I can and more important, would it perform well, to use DirectX. I am trying to scroll the contents of a richtext (rtf) vertically on the screen. I am doing this in delphi at the moment with native components and properties, but the performance is not quite where it needs to be. A panel watches mouse position and adjusts a var in a time-critical timer to do the actuall scrolling. I've been trying to use a DC and bitblt but haven't got it working yet. Would DirectDraw be faster?

Follow Ups:

Post a Followup

Name:


Help with Direct X?

Posted by Ben Mangus on May 27, 1998 at 16:17:02:

You must understane that I am not computer literate. So, with that in mind I must ask the following with a little background info on my equipment. I have a Pent-133, the latest win-95, a Trident vga card tied to a new canopus 3d card.
My c drive shows a direct-x folder but when I click on it all I see is a setup folder and when I click on it nothing happens. Is direct x installed when I installe win-95 or when I installed the canopus card or do I have to go to a microsoft site to install it thru a download? I really don't know if I am asking the right questions but I would appreciate any help? Please e-mail me at mangus@bellatlantic.net. Thanks
Ben

Follow Ups:

Post a Followup

Name:


PNG file format with DirectX

Posted by Cyrille Wagner on May 27, 1998 at 17:57:47:

I would like to start a new section about how to use
PNG file format with DirectX 5.0.

I wonder why .PNG are not more used since they offer
better compression as .GIF and are royalties free.
They have no damaged quality not as .JPEG and are
available for all color modes. What's more .PNG should
be the new standard ?

Has someone already start developping classes about
.PNG for Direct X ? Has someone informations about
these files ?

Thanks.

Follow Ups:

Post a Followup

Name:


Re: Problem with the IDirect3DRMAnimationSet::Load

Posted by Lee on May 27, 1998 at 18:47:02:

In Reply to: Problem with the IDirect3DRMAnimationSet::Load posted by Fred on May 15, 1998 at 09:25:51:

: Does any one know how to use the IDirect3DRMAnimationSet::Load function to load the same animation file more then once? The following is part of my code:
: ....
: lpD3DRM->CreateFrame(lpScene, &lptmpFrame);
: LPDIRECT3DRMANIMATIONSET lpAniSet;
: lpD3DRM->CreateAnimationSet(&lpAniSet);
: lpAniSet->Load("myAni.x", NULL,D3DRMLOAD_FROMFILE, NULL, NULL, lptmpFrame);
: lptmpFrame->SetPosition(......)
: .... callback function etc etc

: It works fine in this way, However, if i add the following:

: lpD3DRM->CreateFrame(lpScene, &lptmpFrame2);
: LPDIRECT3DRMANIMATIONSET lpAniSet2;
: lpD3DRM->CreateAnimationSet(&lpAniSet2);
: lpAniSet2->Load("myAni.x", NULL,D3DRMLOAD_FROMFILE, NULL, NULL, lptmpFrame2);
: lptmFrame->SetPosition(... to different postion);
: ... callback... etc etc

: It suppose to show up TWO same animating objects at different positions, but it didnt! It only shows the one that loaded 1st. The second load animation only showup after i comment out the first Load actoin!

: Can anyone explain why this happen? How should i suppost to do to load the same animation twice? What i really want to do is to create Two/Three SAME animations in one scene. Any suggest or walkaround?

: Thx in Advance

: Fred

Well, Fred it doesn't help to make a copy of the
animation file and have another name to the
copy, becouse its some internal names that collide
inside the code, however I have succeded in loading two totaly different animated bipeds.
But what DX people have in mind is that you only load one animationset once and then make copies of this "Object" using the object command clone
in direct X. The PunCtuator might be just NULL
i would guess I haven't treid it my self yet
I have full house tring to navigate my first two
animations. Getting to know where they are how they have turned and so on and directing them
by changing their animations, just finding the correct frames to was hard, so good luck!

Lee

Follow Ups:

Post a Followup

Name:


directNT

Posted by as1 on May 28, 1998 at 00:09:00:

any news on directX5.0 for windows NT

Follow Ups:

  • Re: directNT Steve 02:02:57 5/31/98 (0)

Post a Followup

Name:


Get DirectX 5.0 SDK here. Anybody know where to get 5.2?

Posted by M. Wagner on May 28, 1998 at 00:56:21:

In Reply to: Where can I get DirectX5.0 SDK. OR Microsoft Suck. posted by Crispin Wellington on May 27, 1998 at 08:09:29:

: Does anyone now where of how I can download the :5.0 SDK. Microsoft have taken it off line :requiring you to buy a CD off them giving them :all your info (inc CC#). They suck.

The following site has a list of links that will let you download DirectX SDK 5.0

http://www.triax.com/ben/dx5/index.html

I wouldn't be surprised if Microsoft eventually turned it into a commercial products. They suck.
:)

  • DirectX 5.0 SDK

Follow Ups:

  • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? R.JONES 19:09:12 7/06/98 (0)
  • thank you Cesar 14:04:40 6/29/98 (0)
  • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? Steven Weesner 08:47:23 6/29/98 (0)
  • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? Robert Vaillancourt 22:18:07 6/28/98 (0)
  • I know where to get 5.2 Ashley Fisher 03:12:45 6/28/98 (0)
  • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? Jay (the answer) 23:40:11 6/23/98 (0)
  • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? chris peters 01:14:58 6/07/98 (1)
    • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? karen 18:06:40 6/28/98 (0)
  • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? chris peters 01:13:34 6/07/98 (0)
  • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? chris peters 01:09:45 6/07/98 (0)

Post a Followup

Name:


DirectDraw and Overlay Surfaces

Posted by Jagmohan S Nanaware on May 28, 1998 at 02:52:19:

Dear Friends,

In my application I need to play an AVI file. Currently I am using normal surfacess Primary surface and seconday surface of DirectDraw to play the video. I want to change to overlay surfaces for playback of the same as overlay surfaces do not ask for Lock. Although the documentation of DirectDraw 5.0 boldly says that overlay surfaces are frequently used to display live video, recorded video, nowhere I have seen a sample or tutorial or guidelines to actually do it. I hope on this there will be sombody who can help me more than microsoft.

Follow Ups:

  • Re: DirectDraw and Overlay Surfaces Angie Kucmierz 22:07:30 7/13/98 (0)

Post a Followup

Name:


Re: 4:2:2 video display under directX

Posted by Jagmohan S Nanaware on May 28, 1998 at 05:48:18:

In Reply to: 4:2:2 video display under directX posted by mike Johnson on January 30, 1998 at 18:17:03:

Mike,

: Can directX display 4:2:2 YUV file in 30 frame or 24 frame/sec plus audio (48k, 16bit)?

A straight answer to your question is yes. But I would like to make a few comments and a checklist before you try it out.

Comments -
1. The possibility of playing 4:2:2 YUV file depends upon the card you have. Few of the cards have color conversion capability all that you have to do is rearrange the data in a format recognised by the card (FOURCC code is the technical term for the format). If not you have to write a piece of code which converts 4:2:2 YUV data into 8/16/24 bit RGB.

2. Speed at which you can display depends upon the card and platform again (processor). Also on the image size (qsif/sif/4-sif), bus type (AGP/PCI).

Checklist
1. Color conversion support
2. Bus type
3. Processor type
4. Image size

Is the audio associated with the video? How do you keep the timing info? If no time info how are you going to achieve lip synchronization

regards

Follow Ups:

Post a Followup

Name:


Re: Retained Mode Texture Loading

Posted by Fred on May 28, 1998 at 08:25:57:

In Reply to: Retained Mode Texture Loading posted by Larry Weinstein on May 25, 1998 at 09:34:35:

I will tend to think that is because you load the texture from the file, so everytime your program needs that texture into the scene, it loads from your harddisk, which will give you a short pause [depends on your texture size, wrap...etcetc]

One [possible] way to solve the problem is to create a ddraw surface in your system memory, load texture on it, and return a texture handle to your program.[or use the "CreateTextureFromSurface" appraoch]. (remember to release the surface once you dont need that texture anymore.} In this way, the texture only need to be loaded once during the init stage.

Follow Ups:

Post a Followup

Name:


TLVERTEX supporting FOG???

Posted by LeeKafka on May 28, 1998 at 14:53:29:

Can I use FOG with TLVERTEX??? How???
Please I need your help... ;)

Follow Ups:

Post a Followup

Name:


Bad Z-BUFFER...

Posted by LeeKafka on May 28, 1998 at 14:57:21:

I'm using TLVERTEX and my viewport are ok using MinZ = 0.0f and MaxZ = 1.0f values. The point is that a 16bit z-buffer is working bad for my 1/z values (low precision cullings)... WHY??? What's the most commom z-buffer depth for commercial applications (with a 3DMonster 4mb)???

Follow Ups:

Post a Followup

Name:


Getting a DirectSoundNotify Interface

Posted by Footh on May 28, 1998 at 15:52:34:

I am getting an annoying problem while trying to obtain a DirectSoundNotify interface. I am using the exact code from the SDK documentation which looks like this:

HRESULT hr = lpDsbSecondary->QueryInterface(
IID_IDirectSoundNotify,
(LPVOID *)&lpDsNotify)

Note that I had to add the LPVOID * typecast in the second parameter to get it to compile (why, I don't know, but I can live with it). Anyway, linking is another story. The linker claims that the first parameter (IID_IDirectSoundNotify) is an unresolved external. I thought I had the correct libraries attached and all the necessary header files, but perhaps not. I'm new to Win32 and DirectX programming so I'm hoping that there is something really simple that I missed. Any help would be appreciated.

Thanks in advance,

-Footh

Follow Ups:

  • Re: Getting a DirectSoundNotify Interface Gilles Pommereuil 13:50:36 8/13/98 (0)
  • Re: Getting a DirectSoundNotify Interface syn 14:57:23 7/27/98 (0)

Post a Followup

Name:


Picking in D3DIM D3DVERTEX

Posted by Ken Chan on May 28, 1998 at 22:52:46:

Can someone tell me if there is any way to find out the screen coordinates passed to the rasteriser when one uses D3DVERTEX to draw a polygon. To elaborate, I am writing a 3D terrain engine with units moving around. I can see I would need the screen coordinates of my texture-mapped sprites for mouse hit-testing, and screen coordinates of my terrain polygons so that when the user clicks a point in my terrain, I will know where to send his units to.
Using D3DTLVERTEX will make these easier, but I prefer the simplicity of D3DVERTEX, when it comes to transformation and particularly, lighting. Can anyone offer some advice? Should I change to D3DTLVERTEX or is there any other way to perform mouse hit-testing? I know there is a Pick function in Retained Mode as well as execute buffers in IM, but a similar funtion for DrawPrimitives is unfortunately lacking.
I have also tried to multiply the world-coordinates of my polygons with the view and projection matrices, but the resultant coordinates is nowhere near the real screen coordinates. It seems that when you use D3DVERTEX, the D3D engine doesn't use just the view and projection matrices in computing the screen coordinates. Can someone please help?

Thanks a lot.

Ken

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 problems

Posted by EvAcLeAr on May 28, 1998 at 23:57:45:

In Reply to: DirectX 5.0 problems posted by Barry on May 26, 1998 at 09:59:25:

: I can not delete DirectX 5.0 and reset my computer to original configuration without reformatting it. Do you know how to help me.

Barry, I suggest going into my computer/ control pannel/ add remove programs & search the list for DIRECT X Drivers. Then click remove. Good Bye Direct x...

Follow Ups:

Post a Followup

Name:


Re: Spotlights not lighting flat polygons!

Posted by Fred on May 29, 1998 at 18:32:21:

In Reply to: Re: Spotlights not lighting flat polygons! posted by Andy Capon on April 06, 1998 at 15:30:31:

I think you might need to use GOURAUD shadding mode. in Flat mode, the whole triangle is filled with its 1st vertex's color, so if your triangle's 1st vertex can't receive the light, the whole triangle/polygon can't be lighted.

Fred

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 Download

Posted by Ahmad Emad on May 29, 1998 at 21:15:31:

In Reply to: Re: DirectX 5.0 Download posted by James Hurdle on March 15, 1998 at 20:10:44:

: : : : : can anyone tell me where I can download directx 5.0

Follow Ups:

Post a Followup

Name:


Re: I know where you can download DIRECTX 5.0 !!!!

Posted by kmc on May 29, 1998 at 22:31:09:

In Reply to: I know where you can download DIRECTX 5.0 !!!! posted by Luiz Guilherme Krause de Salles on February 10, 1998 at 15:21:57:

: U can download rthe DIRECTX 5.0 in this site:
: "http://microsoft.com/directx/download.asp"!!!
: It was my pleasure!!!

Follow Ups:

Post a Followup

Name:


Re: Sprite Collisions

Posted by EvAcLeAr on May 30, 1998 at 03:34:33:

In Reply to: Sprite Collisions posted by Eduardo Meza on May 21, 1998 at 18:59:22:

: How do you detect sprite collisions. Currently I have come up with two different functions to do this, but one is too slow and the other one has poor graphical effects. In other words, only the rectangle enclosing my sprite collides, but the actual sprite doesn't collide. This is fast, but it doesn't look right. I'll apreciate any help that I can get. Thanks

Well I haven't yet tried to implement this. But I found an extreemly well written page on sprite collisions, it has 3 examples as well as a detailed explanation behind each of the three examples. The page is located at http://www.ddj.com/ddsbk/1995/1995.05/roberts.htm Hope this helps.

Follow Ups:

Post a Followup

Name:


force feed back

Posted by Sv�b, S�ndor on May 30, 1998 at 05:30:34:

Hi!

Please send me programming specifications of force feed back
in DirectX.

From Budapest, Hungary

Follow Ups:

Post a Followup

Name:


Protein Data Bank (PDB) conversion to DXF or 3DS

Posted by Jared Kuemmerle on May 30, 1998 at 12:35:40:

Is there anyone out there that wants do a valuable service for the science community and the 3d community and create a utility that will convert Protein Data Bank (PDB) files to DXF and 3DS (windows 95 or NT platform)? There are literally tons of "free" molecular coordinates out there waiting to be converted to Space-filling, ball and stick, and polytube models. I found one program (Molpov) that will convert to POV 3.0 format... but let's face it... The front end program for POV SUCKS! who wants to use it? I found another program (MOlDXFw) that will convert PDB files to DXF format, but it only creates space-filling models (very limited). Please... will someone please please do this? there are tons of people that will be totally appreciative. Thanks. Jared.

Follow Ups:

Post a Followup

Name:


Creating 3d images for direct x

Posted by Lloyd Nickens on May 30, 1998 at 19:27:29:

How do I create a X file for direct x to read if i do not have one of those high priced 3d modelers????

Follow Ups:

  • Re: Creating 3d images for direct x marino 11:09:50 6/02/98 (0)

Post a Followup

Name:


Re: directNT

Posted by Steve on May 31, 1998 at 02:02:57:

In Reply to: directNT posted by as1 on May 28, 1998 at 00:09:00:

DirectX 5.0 isnt being developed anymore, MS has been working on DirectX 6, which is being built into NT so it will be legit with it :)

-Steve

Follow Ups:

Post a Followup

Name:


Re: Here is a site you can download DirectX 5.0 end-user release

Posted by nusius on May 31, 1998 at 16:38:08:

In Reply to: Re: Here is a site you can download DirectX 5.0 end-user release posted by Joost Brouwer on April 04, 1998 at 05:37:44:

: : For playing games that need DirectX 5.0.

: : Download DirectX 5.0 end-user release at
: : http://avault.com/hardware/directx.asp

: : good luck in your game ...

: : Brasko

Follow Ups:

Post a Followup

Name:


TIP: Don't use default texture loads with Load() (D3DRM)

Posted by Mike on May 31, 1998 at 18:07:21:

If you are loading meshes or frames with the Load() API, you need to take special care of loading the textures associated with them.

If you don't register your own callback (or if you use the one that the documentation outlines), you are going to hemmorhage memory. The problem is that RM doesn't appear to bother keeping track of textures that have already loaded.

You need to manually keep track of textures that you have loaded and just increment their reference count.

This probably should have been obvious, but for some reason I expected RM to handle it. Hah!

Also, I'd like to take this opportunity to bash the worst computer book I've ever read : "The Awesome Power of Direct3D/DirectX". I thought that it was arcane until I realized that the author must not have known anything about Direct3D when he wrote it. The code he presents is lifted directly from the MS sample code. He does the benefit of adding a few comments, my favorite of which was:

// Allocate a rectange.
RECT rect;

If he was going to steal sample code for his book, he should have taken it from "Rockem3d" which was at least understandable.

--Mike

Follow Ups:

Post a Followup

Name:


Does D3DRMLOAD_INSTANCEBYREFERENCE actually do anything?

Posted by Mike on May 31, 1998 at 18:09:54:

As far as I can tell it doesn't... anyone have confirmation?

I'm loading some fairly large objects multiple times, and my memory image looks the same with this flag as without.

Follow Ups:

Post a Followup

Name:


Creating DLL's in VC++ for VBasic

Posted by Rob Pemberton on June 01, 1998 at 09:16:37:

I'm having problems creating DLL's, the DLL when created dosn't use the Function name given, the name given was RGB16 when checked with DumpBin the function name then becomes ?RGB16@@YAJEEE@Z and when call'd gives a'Bad DLL Calling Convention' Error...

Can anyone Help?
Thanks
Rob

  • The Home of ADV, SSKiller & Chalice

Follow Ups:

  • Re: Creating DLL's in VC++ for VBasic Cyber Optik 18:35:33 6/02/98 (0)

Post a Followup

Name:


and assembly language

Posted by Rob on June 01, 1998 at 12:12:26:

Does anyone know how to use assembly with directx or know how to do the equivalent?

Follow Ups:

  • Re: and assembly language Sietze 10:51:26 6/02/98 (0)

Post a Followup

Name:


Anyone else get messed up TEXTURES on CLIPPED polygons in HAL mode?

Posted by Hana on June 02, 1998 at 00:37:03:

When running in HAL mode, all my clipped polygons
are messed up. It seems that the texture coordinates
of the clipped vertices are being set to zero.

This only happens in HAL mode. (works fine in RAMP
and RGB)

Any ideas?

Follow Ups:

  • Re: Anyone else get messed up TEXTURES on CLIPPED polygons in HAL mode? sietze 11:03:38 6/02/98 (0)

Post a Followup

Name:


DDERR_NOEXCLUSIVEMODE

Posted by Sajid Khan on June 02, 1998 at 05:43:04:

I keep getting this error while creating my primary
surface although i have set the cooperative level to
EXCLUSIVE and FULL SCREEN.

Follow Ups:

  • Check this!! Clay 09:06:59 6/02/98 (0)

Post a Followup

Name:


Re: ddraw linkin error please help

Posted by Ravi Joshi on June 02, 1998 at 09:04:36:

In Reply to: ddraw linkin error please help posted by menasius on May 17, 1998 at 16:45:30:

What you need to do is to go to project settings.
Press the "link" property sheet.
go to "object/library module" edit control.
you will find a lot of files with extn .lib,
all you have to do is to add one more lib file.
ddraw.lib to the list.

Now the next thing comes into the picture.
How does the dev studio know there this lib is?
For that you have to go to the Tools menu in the
studio and select the "options" item.
In the directories tab select the include
directories.
Here you will provide dev studio with the path
where your ddraw.h file exists.
Add a new path to the list of
existing paths. Most importantly move the newly
created path to the top of all paths.

You repeat this procedure for the lib files option.
and then compile the program. You will find that
you will have no errors.

Follow Ups:

Post a Followup

Name:


Check this!!

Posted by Clay on June 02, 1998 at 09:06:59:

In Reply to: DDERR_NOEXCLUSIVEMODE posted by Sajid Khan on June 02, 1998 at 05:43:04:

Before you set the cooperative level to exclusive, you have to do CreateWindow(), ShowWindow() and UpdateWindow() for the hWnd passed to the DirectX functions. If you don't, sometimes it will work, sometimes not.

Clay

Follow Ups:

Post a Followup

Name:


(no) AlphaBLT in DX6 (OH NO, NOT AGAIN!!!)

Posted by Sietze on June 02, 1998 at 10:40:12:

Hi, All!

When I was moseying about the Microsoft DirectX site, I came about some very disturbing information. Believe it or not: Microsoft now says that Alpha BLT's, the main reason to even CONSIDER upgrading to DX6, WILL NOT BE SUPPORTED in release 6.0 of the DirectX SDK. If I'm not mistaking, most hardware supported this feature way back in the dark ages of VESA programming. So why doesn't this stupendously easy feature show up in DX6? Anyway, what I'm trying to say is: don't wait for a DirectX AlphaBLT, 'cause there WON'T BE a DirectX AlphaBLT function (not until early 1999, when to my knowledge DX7 is due). Hope anyone can use this info (or, better yet, disprove it ;)).

G'day y'all!

Sietze Dijkstra

Follow Ups:

  • Re: (no) AlphaBLT in DX6 (OH NO, NOT AGAIN!!!) Tim Astle 23:08:56 6/04/98 (0)

Post a Followup

Name:


Re: and assembly language

Posted by Sietze on June 02, 1998 at 10:51:26:

In Reply to: and assembly language posted by Rob on June 01, 1998 at 12:12:26:

Sure you can!!!

In DirectX, you can 'Lock' a DirectDraw surface, giving you a contiguous block of RAM (on-screen or off-screen), to do whatever brute-force stuff to you had in mind.
Assembly language in C(++) is used with
__asm{} blocks, inside which you are ablsolutely free to do whatever you want (ie what one could do in DOS five years ago, on a 486...sigh.... ;)).
I used it myself in a crude Alpha-blitter that I wrote, because DirectX has no such functionality. If you send me an email, I'll send you the code I used for this.

Happy coding,

Sietze Dijkstra

BTW: IMHO, if you look at the code BCC or MSVC put out, though, one can't help wondering if using asm still is really necessary.

: Does anyone know how to use assembly with directx or know how to do the equivalent?

Follow Ups:

Post a Followup

Name:


Invert display on windows 95 / directdraw / dirvid

Posted by Bigjohn on June 02, 1998 at 10:51:36:

Does any function or any shareware / tools can invert
video output on windows 95 with directx 5.0?

Follow Ups:

  • Re: Invert display on windows 95 / directdraw / dirvid Ravi Joshi 03:56:32 6/25/98 (0)

Post a Followup

Name:


Re: Anyone else get messed up TEXTURES on CLIPPED polygons in HAL mode?

Posted by sietze on June 02, 1998 at 11:03:38:

In Reply to: Anyone else get messed up TEXTURES on CLIPPED polygons in HAL mode? posted by Hana on June 02, 1998 at 00:37:03:

: When running in HAL mode, all my clipped polygons
: are messed up. It seems that the texture coordinates
: of the clipped vertices are being set to zero.

: This only happens in HAL mode. (works fine in RAMP
: and RGB)

: Any ideas?

Try this: turn on Perspective Correction. My polys were messed up as well in HAL mode, but now I use persp. correction (which is implemented in EVERY HAL device), everything looks OK. Depending on whether you use RM or IM, this is done by calling the IDirect3DRMMeshBuilder2::SetPerspective or IDirect3DDevice2::SetRenderState functions with the appropriate parameters (see:dox).

Good Luck!

Sietze Dijkstra

Follow Ups:

Post a Followup

Name:


Re: Creating 3d images for direct x

Posted by marino on June 02, 1998 at 11:09:50:

In Reply to: Creating 3d images for direct x posted by Lloyd Nickens on May 30, 1998 at 19:27:29:

: How do I create a X file for direct x to read if i do not have one of those high priced 3d modelers????
So I can Publish my 3D Image on the web and permit my user to rotate,pan and zoom my image?

Follow Ups:

Post a Followup

Name:


Re: Alpha-Blending / Lens-Flare

Posted by Sietze on June 02, 1998 at 11:17:08:

In Reply to: Alpha-Blending / Lens-Flare posted by Chris on May 24, 1998 at 06:00:23:

: Hi,
: is it possible to implement alpha-blending and lens-flare
: effects into my programs by using Direct X 5 (without GL or Glide) ?

: I'm programming with Direct 3D Retained Mode and don't want to
: use Immediate Mode.

: Thanks for your support,
: Chris ;-)

Chris,

I posted a followup on a similar question about two months ago. You should look it up, it also contains some code. It's quite a lot of txt, so I don't really feel like typing it all again. If you still have questions, please let me know.

Good luck,

Sietze Dijkstra

Follow Ups:

Post a Followup

Name:


.x files

Posted by zain on June 02, 1998 at 14:45:10:

How can i convert animated file created by 3d studio for directx. i have used this command but it gives the error message while loading .x file.

Command:
conv3ds -a -x myfile.3ds

thanks in advance.

Follow Ups:

  • Re: .x files fred 12:14:15 6/21/98 (0)

Post a Followup

Name:


DDraw Rotation Code

Posted by Dallas Nutsc on June 02, 1998 at 15:37:06:

Want to rotate a surface by a number of degrees, scale
it, and put it on another surface, as fast as possible all while doing transparency?

Now You Can!!!!!

Find my sample code and compiled example at
www.door.net/arrowhead

Follow Ups:

Post a Followup

Name:


info on IDirect3DViewport2::TransformVertices?????

Posted by Fragmo on June 02, 1998 at 17:06:39:

i need to be able to transform vertices to screenspace
in my application before polygons are drawn, but i
can't find any useful info on how to use the
TransformVertices function. does d3d allocate the list
of transformed verts or do i need to pass in an array
for it to put them in. also, does this function even
transform verts to screenspace at all??? a code
example for this would be a lifesaver!!

Follow Ups:

  • Re: info on IDirect3DViewport2::TransformVertices????? frodo 07:48:08 6/04/98 (2)
    • Re: info on IDirect3DViewport2::TransformVertices????? Fragmo 17:11:52 6/07/98 (1)
      • Re: info on IDirect3DViewport2::TransformVertices????? Ken Chan 04:37:52 6/12/98 (0)

Post a Followup

Name:


high pitch noise in Direct Sound

Posted by Fragmo on June 02, 1998 at 17:15:42:

when i play a sound in DirectSound i get a high
pitch noise that isn't there when i play the sound with
any other application. the sound plays ok, except for
the noise. anyone got any idea what would cause this?

Follow Ups:

Post a Followup

Name:


Re: Creating DLL's in VC++ for VBasic

Posted by Cyber Optik on June 02, 1998 at 18:35:33:

In Reply to: Creating DLL's in VC++ for VBasic posted by Rob Pemberton on June 01, 1998 at 09:16:37:

Try specifying the offsets in VC++ directly (RGB16 @1) in the .DEF file. Then, from VB, name it by the offset, not the name. The syntax is something like (sorry, don't have the manual handy):

DECLARE RGB16 "my.dll" ALIAS #1 ()

-Morgan

: I'm having problems creating DLL's, the DLL when created dosn't use the Function name given, the name given was RGB16 when checked with DumpBin the function name then becomes ?RGB16@@YAJEEE@Z and when call'd gives a'Bad DLL Calling Convention' Error...

: Can anyone Help?
: Thanks
: Rob

Follow Ups:

Post a Followup

Name:


Re: DirectX5

Posted by head hunter on June 03, 1998 at 05:33:46:

In Reply to: Re: DirectX5 posted by serge poirier on February 19, 1998 at 22:09:24:

: : I downloaded a demo version of Curse of Monkey Island
: : with DirectX5 download included and it worked fine.
: : I then purchased the game, uninstalled the demo as per
: : instructions but the purchased game freezes my whole
: : system, screen, keyboard, mouse et al. Checking for
: : compatability with DirectX5 indicates there is no hard-
: : ware support for the Primary Display Driver, Primary
: : sound Driver and Sound System Player. Why did the first
: : DirectX5 download work but this one won't and what do I
: : do about the problem?
: : Thank you, any help would be greatly appreciated.
: : Lois Nicholls

Follow Ups:

  • Re: DirectX5 Ratchet 15:38:41 9/13/98 (0)

Post a Followup

Name:


Visual Basic 5.0 and DirectX ( DirectInput )

Posted by robert diosi on June 03, 1998 at 06:57:35:

Hi there !

I searching OCX-Controls for programming FORCE FEEDBACK
COMMANDS in VB5.0

To read out every button is no problem !!!
But to send force feedback commands - it is

anybody know something about it ?

Follow Ups:

Post a Followup

Name:


Visual Basic 5.0 and DirectX ( DirectInput )

Posted by robert diosi on June 03, 1998 at 06:58:52:

Hi there !

I searching OCX-Controls for programming FORCE FEEDBACK
COMMANDS in VB5.0

To read out every button is no problem !!!
But to send force feedback commands - it is

anybody know something about it ?

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 Download

Posted by suhaimi on June 03, 1998 at 08:46:54:

In Reply to: DirectX 5.0 Download posted by Mehrab on March 14, 1998 at 15:14:04:

: : : can anyone tell me where to download it besides microsoft website?

Follow Ups:

  • Re: DirectX 5.0 Download jean sims 21:55:28 9/27/98 (0)

Post a Followup

Name:


directX5.0 please

Posted by mie on June 03, 1998 at 08:56:31:

i have problem with my andretti racing (game. i can't
play the games with out directX5.0. where can i download the directX5.0

Follow Ups:

  • Re: directX5.0 please Marc Curiel 16:03:26 6/08/98 (0)
  • Re: directX5.0 please Rick 21:02:14 6/05/98 (1)
    • Re: directX5.0 please Bill 09:23:33 9/25/98 (0)

Post a Followup

Name:


Re: info on IDirect3DViewport2::TransformVertices?????

Posted by frodo on June 04, 1998 at 07:48:08:

In Reply to: info on IDirect3DViewport2::TransformVertices????? posted by Fragmo on June 02, 1998 at 17:06:39:

: i need to be able to transform vertices to screenspace
: in my application before polygons are drawn, but i
: can't find any useful info on how to use the
: TransformVertices function. does d3d allocate the list
: of transformed verts or do i need to pass in an array
: for it to put them in. also, does this function even
: transform verts to screenspace at all??? a code
: example for this would be a lifesaver!!

check this out:

void SomeFunc()
{
D3DVECTOR vin[3];
D3DTLVERTEX vout[3];
D3DHVERTEX hout[3];
D3DTRANSFORMDATA td;
DWORD offscreen = 0;

ZeroMemory( &td, sizeof(td));
td.dwSize = sizeof(td);
td.lpIn = vin;
td.dwInSize = sizeof(D3DVECTOR);
td.lpOut = vout;
td.dwOutSize = sizeof(D3DTLVERTEX);
td.lpHOut = hout;
immview->TransformVertices( 3, &td, D3DTRANSFORM_CLIPPED, &offscreen);

Follow Ups:

  • Re: info on IDirect3DViewport2::TransformVertices????? Fragmo 17:11:52 6/07/98 (1)
    • Re: info on IDirect3DViewport2::TransformVertices????? Ken Chan 04:37:52 6/12/98 (0)

Post a Followup

Name:


Accessing DX objects in a VC++ DLL from VB

Posted by D.R.Pemberton on June 04, 1998 at 09:07:33:

Hi
Ok here's one for all you C++/VB boffins out there

I've written a VC++ DLL, at present it only works with none DX stuff, I'm trying to get the VC++ side
to recognise VBasic DirectDrawSurface3 objects, the code I've tried is included below,
the VC++ code works when the DX objects are set up in VC++ but not when call'd with the VBasic
Objects?

Dose anyone know if there is a difference and if so how to get around it?
or am I going about it the wrong way? if so could you point me in the right direction?

The Sub draws a Horizontal line on any DirectDrawSurface3 Object, with Right and Bottom edge clipping
X1= X position Start
Y1= Y position
X2 = X position End.

VBasic Part

Public Declare Sub Hline Lib "ADVDLL" Alias "_Hline@28" (ByVal X1 As Integer, ByVal Y1 As Integer, ByVal X2 As Integer, ByVal Col As Long, ByVal ClipRight As Integer, ByVal ClipBottom As Integer, Buffer As DirectDrawSurface3)

Hline 10, 10, 100, RGB16(100,100,100), 640, 480, lpDDBackBuffer

VC++ Part

extern "C" _OUT void Hline(short X1, short Y1, short X2, long Col, int ClipRight, int ClipBottom, struct IDirectDrawSurface3 *lpBuffer)
{
if(X1==X2)
goto skip;

short X3;
if(X1>X2)
{
X3=X1;
X1=X2;
X2=X3;
}

RECT R;
R.top= Y1;
R.left= X1;
R.right = X2;
R.bottom = Y1 + 1;

if(X1+X2= ClipRight || Y1 >= ClipBottom)
goto skip;

if(X1 = ClipRight)
R.right = ClipRight;

DDBLTFX fx;
fx.dwSize= sizeof(fx);
fx.dwFillColor = Col;

HRESULT ddrval;

ddrval = lpBuffer->Blt(&R, NULL, NULL, DDBLT_COLORFILL, &fx);

skip:;
}

both versions, written only in VB or VC work.
can anyone help with the crossover?

Thanks
Rob.

Follow Ups:

  • Re: Accessing DX objects in a VC++ DLL from VB D.R.Pemberton 09:11:27 6/04/98 (0)

Post a Followup

Name:


Re: Accessing DX objects in a VC++ DLL from VB

Posted by D.R.Pemberton on June 04, 1998 at 09:11:27:

In Reply to: Accessing DX objects in a VC++ DLL from VB posted by D.R.Pemberton on June 04, 1998 at 09:07:33:

Sorry Forgot to say
the DLL
crashes at this point.

ddrval = lpBuffer->Blt(&R, NULL, NULL, DDBLT_COLORFILL, &fx);

thanks
Rob.

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 SDK cannot be downloaded anymore

Posted by camp bug on June 04, 1998 at 11:12:05:

In Reply to: Re: DirectX 5.0 SDK cannot be downloaded anymore posted by Mehrab on March 14, 1998 at 15:12:59:

: : can anyone tell me where to download it besides microsoft website?

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 SDK cannot be downloaded anymore

Posted by camp bug on June 04, 1998 at 11:14:00:

In Reply to: Re: DirectX 5.0 SDK cannot be downloaded anymore posted by Mehrab on March 14, 1998 at 15:12:59:

Will directx 5sdk be availible in the near future to download?

Follow Ups:

Post a Followup

Name:


Direct Play: DirectPlayCreate call

Posted by Paul Hunter on June 04, 1998 at 12:19:41:

Hi there,

I am having a bit of difficulty with what I suspect should be a straightforward piece of Direct Play code (DX5). I have copied some code from the "override" project which comes with the SDK samples as follows:

LPDIRECTPLAY lpDPlay1 = NULL;
GUID guidServiceProvider = DPSPGUID_MODEM;
HRESULT hr;

// Get a DirectPlay interface for a specific service provider
hr = DirectPlayCreate( &guidServiceProvider, &lpDPlay1, NULL );

Now the problem is that in my project this function call returns a result which is mapped onto "DPERR_UNAVAILABLE", whereas executing the function in the "override" project returns "DP_OK". Apparently this means that the function is not available at the moment, so the object could not be created. I can't see why though.

I have tracked back the code in "override" to see if there is some other initialisation which takes place before this which would affect the success of this function call, but cannot find anything. Besides there is nothing documented that suggests this call should be anything but straightforward.

Can anybody shed some light on the problem? I have been going around in circles for days, and I'm now asking that questiona again, "Why did I ever become a programmer?". ;-)

Thanking you,
Paul.

ps. Are there any forums that are DirectPlay specific? When I get stuck with the documentation and cannot find any samples to look into I never know where to go next.

Follow Ups:

  • Re: Direct Play: DirectPlayCreate call Paul Hunter 08:32:11 6/09/98 (0)

Post a Followup

Name:


32bit surfaces

Posted by HBios on June 04, 1998 at 14:59:17:

Hi,
i search for source code about how to use
32bits color surface

If you have some, please E-mail me.

aklim@interlinx.qc.ca

Follow Ups:

Post a Followup

Name:


DirectX vs. OpenGL

Posted by Matt on June 04, 1998 at 15:21:28:

I am doing some research on DirectX and OpenGL. I need to find out what the advantages and disadvantages of each are. I have found out suitable info on OpenGL, but I am having trouble finding any information on DirectX. If anyone has a site they could point me to, I would appreciate it. I have already checked out Microsoft's site and it does not have the type of info that I need. What I am looking for is information similar to what is on SGI's site (http://www.sgi.com/Technology/openGL/). Thank you for the help.

Follow Ups:

  • Re: DirectX vs. OpenGL Tim Astle 23:14:44 6/04/98 (2)
    • Re: DirectX vs. OpenGL Andy Sy 14:12:06 6/07/98 (0)
    • Re: DirectX vs. OpenGL Matt 10:26:00 6/05/98 (0)

Post a Followup

Name:


Re: (no) AlphaBLT in DX6 (OH NO, NOT AGAIN!!!)

Posted by Tim Astle on June 04, 1998 at 23:08:56:

In Reply to: (no) AlphaBLT in DX6 (OH NO, NOT AGAIN!!!) posted by Sietze on June 02, 1998 at 10:40:12:

There are many pluses to DirectX 6.0, however, due to the fact that Microsoft has
overlooked the time constraints that developers have when trying to implement DX6
into the products ready for the christmas lineup, a lot of stuff has been left out.
I looked at the Beta copy of DX6 a month ago. Direct Music is the big push,
focusing on Midi music. You read right, midi. Microsoft has a new standard in
midi quality that is equal to CD quality sound. (redbook audio) The bonus to using
midi in games is that with directX, you can change the style of music on the fly and
provide awesome sound transitions in games. Don't worry about the AlphaBLT, it's not
a big thing. (The big thing is the Microsoft is only doing a single Beta test....
CRINGE!) Something else of note about DX6... Microsoft is giving a big push to developers
to make apps for NT 5.0, since DX6 will run on it. NT 5.0 is the real OS coming out,
unlike win98.

Oh well, that's all I wish to say on this topic.

L8tr,

Tim Astle
Derailed Productions

Follow Ups:

Post a Followup

Name:


Re: DirectX vs. OpenGL

Posted by Tim Astle on June 04, 1998 at 23:14:44:

In Reply to: DirectX vs. OpenGL posted by Matt on June 04, 1998 at 15:21:28:

I'm no expert on DirectX, but I know DirectX covers more than just 3D graphics. DirectX consists of: DirectDraw (2D), DirectSound (audio), DirectInput (input), DirectPlay (networking), and Direct3D (3D). I had a guy from SGI bitch at me for not using openGL for 2D, but since openGL is a 3D library, leads me to think that
most SGI people have a serious "Know how" problem. Oh well, I might be wrong. :-)

Follow Ups:

  • Re: DirectX vs. OpenGL Andy Sy 14:12:06 6/07/98 (0)
  • Re: DirectX vs. OpenGL Matt 10:26:00 6/05/98 (0)

Post a Followup

Name:


Re: This is the URL to get Direct X 5.2

Posted by Bigstar2001 on June 05, 1998 at 01:47:00:

In Reply to: DirectX 5.0 Download posted by Mehrab on March 14, 1998 at 15:14:04:

http://www.microsoft.com/directx/resources/dx5end.htm

Just pick the version you want

Follow Ups:

Post a Followup

Name:


Re: DirectX vs. OpenGL

Posted by Matt on June 05, 1998 at 10:26:00:

In Reply to: Re: DirectX vs. OpenGL posted by Tim Astle on June 04, 1998 at 23:14:44:

Thanks alot.

Matt

Follow Ups:

Post a Followup

Name:


Direct3D in STEREOSCOPIC modes

Posted by Wes Thierry on June 05, 1998 at 15:19:37:

Does anyone know if direct3d supports the stereo Modes for video? I know it has a couple calls built in, but not even MICROSOFT can tell me what ENIGMA is, and what type of stereo does it support?
Please help, it will make a lot of game players with HMD's happy. Thank you

Follow Ups:

Post a Followup

Name:


ActiveMovie 2.0

Posted by Ken Moore on June 05, 1998 at 19:16:01:

I'm using an ActiveMovie 2.0 control inside a Visual C++ app. When I bring the properties up in the resource editor I can't get to the design-time only properties. If I click on the All tab, it just says there are no browseable properties. How can I set the design time properties like AutoStart? I have installed the DirectMedia 5.2 SDK.

Thanks,
Ken

Follow Ups:

  • Re: ActiveMovie 2.0 fog 16:10:03 6/08/98 (1)
    • Re: ActiveMovie 2.0 Ken Moore 20:46:49 6/10/98 (0)

Post a Followup

Name:


Re: directX5.0 please

Posted by Rick on June 05, 1998 at 21:02:14:

In Reply to: directX5.0 please posted by mie on June 03, 1998 at 08:56:31:

Need it so I can play my games.

Follow Ups:

  • Re: directX5.0 please Bill 09:23:33 9/25/98 (0)

Post a Followup

Name:


How do you get two D3D meshes to scale the same?

Posted by Boller on June 06, 1998 at 05:37:14:

Hi everybody,

I've been working on a D3D app which has meshes that, although their transforms are different sizes, must be scaled the same.

I found that if you take two similar .x meshes (one mesh was "derived" from the other) which have transforms which look like this (top view looking downward)...

Transform A Transform B
__ _________
| | | |
| | | |
| | | |
| | |_________| ---| Notice Transform B's y
| | ---| value is *shorter* than
|__| ---| Transform A's value.

...and you scale both meshes equally (we'll say, by a factor of 10), the mesh inside Transform B seems to be "wider" (again, top view looking downward) than Transform A.

I haven't found this anywhere in the SDK documentation (or the D3D books I have), but I take this to mean that D3D looks at the mesh, figures out the transform, and then when you tell it to scale the mesh equally by a factor of 10, it somehow does the scaling BASED ON THE OBJECT'S SIZE rather than in a predictable, consistent way on all objects.

I found this is true because if I put a 2nd visible dummy object in Transform B (in the modeling program) which stretches the y value downwards and makes it equal to Transform A's y value, Transform B scales correctly. The problem is, I can't have a bunch of extra polygons floating around in the air just so the scaling is correct! (I'm sure this experiment applies with X and Z values too, but I haven't tried them.)

Here's a visual example of putting a dummy object in and having them scale correctly (again, top view looking downward at the transforms)...

Transform A Transform B (With an extra mesh
thrown in to stretch the y
value to the same value as
Transform A)
__ _________
| | | |
| | | |
| | | |
| | | dummy | _o_| <--| mesh. It scales correctly!

I have been wracking my brain for the past few days to develop a programming strategy to deal with this... I *NEED* all of the objects I am going to incorporate to scale exactly the same, no matter the size of the transform. What do I have to do to make this work? A ratio of some sort? Matrix math? Help!!!!

Thanks in advance,

Jeff Boller
decorate@westol.com

Follow Ups:

Post a Followup

Name:


Re: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help?

Posted by Bob on June 06, 1998 at 05:37:54:

In Reply to: Ever since I installed Direct X 5.0, my computer was screwed up, can anyone help? posted by Jeff on January 22, 1998 at 23:27:23:

: Hey guys and girls, I've got this really horrible problem. I hope somebody knows the solution to this, or has had this happen to them before. Here is the problem:
: Ever since I installed Direct X 5.0, my computer keeps locking up. I'm not sure if it is locked up, because it keeps playing the same sound effect over and over again. Say I'm playing Diablo, and I click on something. I hear the sword swinging, but that's ALL I hear. It keeps repeating the sword's sound effect over and over and over...until I have to turn my volume down. And also, my screen freezes, and I can't do anything about it. I don't know what's wrong...but here is my system info:
: Pentium 233 MMX, Sound Blaster 16, and S3 ViRGE Video Card, with 32 Mb RAM and 4.3 GB Hard Drive.
: Can anyone tell me how to fix this problem?? My computer cost so much, like $1400 and I thought it would be really good. But I think there's something wrong with Direct X 5. Can anyone help me??? Maybe someone had this happen to them, and will help me fix it. Or else, if nothing works, can anyone tell me how to Uninstall Direct X 5, because when I go to Add/Remove Programs in the Control Panel, I click on "Uninstall DirectX". It brings me up to a menu that says "Restore Audio/Display Drivers" I restored both of them, but my computer keeps freezing still. And Direct X 5.0 is not uninstalled!! If anyone can help me, please respond!! Thanks

Hey Jeff, I have exactly the same problem.I have a technician at ATI working on it for me at the moment.Please email me and I will send you the info you need as soon as I get it myself.Hope I can get it sorted because it`s been really annoying me as well.
Bob

Follow Ups:

Post a Followup

Name:


Re: Directx 5.2 SDK

Posted by Ulle on June 06, 1998 at 09:21:20:

In Reply to: Re: Directx 5.2 SDK posted by 뗌┳갤 on May 15, 1998 at 05:19:27:

: : I'm looking for the 5.2 directx sdk, and i don't want to buy the cd.
: : If someone can tel me where i can download it
: : (if some one have a site with it), it would be very cool.

: : Please answer me with my mail.

: : Bye

Follow Ups:

Post a Followup

Name:


Re: directx5 needed for download

Posted by Leon Martin on June 06, 1998 at 13:48:53:

In Reply to: directx5 needed for download posted by THOMAS KURT on March 24, 1998 at 09:13:58:

: : : I downloaded a demo version of Curse of Monkey Island
: : : with DirectX5 download included and it worked fine.
: : : I then purchased the game, uninstalled the demo as per
: : : instructions but the purchased game freezes my whole
: : : system, screen, keyboard, mouse et al. Checking for
: : : compatability with DirectX5 indicates there is no hard-
: : : ware support for the Primary Display Driver, Primary
: : : sound Driver and Sound System Player. Why did the first
: : : DirectX5 download work but this one won't and what do I
: : : do about the problem?
: : : Thank you, any help would be greatly appreciated.
: : : Lois Nicholls

Follow Ups:

Post a Followup

Name:


Re: directX5

Posted by Matt on June 06, 1998 at 17:10:24:

In Reply to: Re: directX5 posted by Mr.Goodbar on May 23, 1998 at 01:09:50:

: I want to install the DirectX5 so I can use what I want to use.
Tomb Raider. Where can i download it. Matt.

Follow Ups:

Post a Followup

Name:


RE: How do you load multiple meshes?

Posted by Me on June 06, 1998 at 22:13:31:

I am working in Direct 3D Retained Mode. I need to know how to load a *.x file that contains multiple meshes. I always get an error when I try to load them with the meshbuilders load function.

Follow Ups:

  • Re: RE: How do you load multiple meshes? Joe Michael 16:01:54 7/01/98 (0)

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by saiyan2000 on June 06, 1998 at 23:30:22:

In Reply to: Re: where can I download direct X 5.0 posted by cheng on February 07, 1998 at 11:31:51:

: : where I can get direct X 5.0 please a answer

Follow Ups:

Post a Followup

Name:


Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2?

Posted by chris peters on June 07, 1998 at 01:09:45:

In Reply to: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? posted by M. Wagner on May 28, 1998 at 00:56:21:

: : Does anyone now where of how I can download the :5.0 SDK. Microsoft have taken it off line :requiring you to buy a CD off them giving them :all your info (inc CC#). They suck.

: The following site has a list of links that will let you download DirectX SDK 5.0

: http://www.triax.com/ben/dx5/index.html

: I wouldn't be surprised if Microsoft eventually turned it into a commercial products. They suck.
: :)

Follow Ups:

Post a Followup

Name:


Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2?

Posted by chris peters on June 07, 1998 at 01:13:34:

In Reply to: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? posted by M. Wagner on May 28, 1998 at 00:56:21:

Here is the download site for microsoft directx 5.2.

www.microsoft.com/msdownload/directx/dxf/enduser5.2/dx5ing.asp

Follow Ups:

Post a Followup

Name:


Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2?

Posted by chris peters on June 07, 1998 at 01:14:58:

In Reply to: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? posted by M. Wagner on May 28, 1998 at 00:56:21:

Here is the download site for microsoft directx 5.2.

www.microsoft.com/msdownload/directx/dxf/enduser5.2/dx5eng.asp

Follow Ups:

  • Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? karen 18:06:40 6/28/98 (0)

Post a Followup

Name:


Forcing DDPIXELFORMAT 8bpp on CreateSurface?

Posted by Ed Halley on June 07, 1998 at 02:11:14:

I can force DDPIXELFORMAT to 24bpp RGB while doing a CreateSurface to system memory or offscreen, but I get a DDERR_INVALIDPIXELFORMAT if I try to force an 8bpp.

I want to make lots of 8bpp system memory surfaces, each with their own associated palette.

Follow Ups:

  • Re: Forcing DDPIXELFORMAT 8bpp on CreateSurface? Doug Wheeler 14:29:18 6/09/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 Download

Posted by jhony on June 07, 1998 at 02:36:53:

In Reply to: DirectX 5.0 Download posted by Mehrab on March 14, 1998 at 15:14:04:

: : : can anyone tell me where to download it besides microsoft website?

Follow Ups:

Post a Followup

Name:


directX5.0

Posted by jhony on June 07, 1998 at 02:43:37:

풡onde puedo encontrar directX5.0 download?
where i can download it directX5.0 ?

Follow Ups:

  • Re: directX5.0 Jacques Wolf 17:44:11 6/14/98 (0)
  • Re: directX5.0 Tom Goody 22:09:43 6/08/98 (0)

Post a Followup

Name:


Re: DirectX5

Posted by warren goodman on June 07, 1998 at 05:26:15:

In Reply to: DirectX5 posted by Lois Nicholls on February 17, 1998 at 16:15:39:

: I downloaded a demo version of Curse of Monkey Island
: with DirectX5 download included and it worked fine.
: I then purchased the game, uninstalled the demo as per
: instructions but the purchased game freezes my whole
: system, screen, keyboard, mouse et al. Checking for
: compatability with DirectX5 indicates there is no hard-
: ware support for the Primary Display Driver, Primary
: sound Driver and Sound System Player. Why did the first
: DirectX5 download work but this one won't and what do I
: do about the problem?
: Thank you, any help would be greatly appreciated.
: Lois Nicholls

Follow Ups:

Post a Followup

Name:


Re: DirectX vs. OpenGL

Posted by Andy Sy on June 07, 1998 at 14:12:06:

In Reply to: Re: DirectX vs. OpenGL posted by Tim Astle on June 04, 1998 at 23:14:44:

: I'm no expert on DirectX, but I know DirectX covers more than just 3D graphics. DirectX consists of: DirectDraw (2D), DirectSound (audio), DirectInput (input), DirectPlay (networking), and Direct3D (3D). I had a guy from SGI bitch at me for not using openGL for 2D, but since openGL is a 3D library, leads me to think that
: most SGI people have a serious "Know how" problem. Oh well, I might be wrong. :-)

OpenGL has some sophisticated 2D routines for
manipulating bitmaps, but I do think it would
be silly to use it for bit-blit type arcade
animation.

Follow Ups:

Post a Followup

Name:


How do you load a Direct3D *.x file?

Posted by Me on June 07, 1998 at 15:26:41:

I am working with Direct3D Retained Mode. I would like to know how to load a *.x file which contains multiple meshes. I am using the meshbuilder's load function. is there something eles I need to do? Please help. Thanks in advance.

Follow Ups:

  • Re: How do you load a Direct3D *.x file? ding@ 22:36:34 6/07/98 (0)

Post a Followup

Name:


Mixing Triangle Colors and RGB Lighting

Posted by Fragmo on June 07, 1998 at 15:28:36:

does anyone know what formula d3d uses to mix triangle
colors with the lighting. i'm forced to do the lighting
in software and i need to know!!

Follow Ups:

Post a Followup

Name:


first IDirectDrawSurface3::Lock is slow?

Posted by Anthony Steele on June 07, 1998 at 16:04:10:

Hi there

Can anyone here help with a problem that I am having.

I am writing a program in Delphi 3, using the DirectDraw COM API. The program is multithreaded and generates screen images in memory.

The problem is that the first call to IDirectDrawSurface3::Lock on a screen-sized surface is slow. In some cases I have timed it taking over 100 seconds. Yup, more than a minute and a half. Subsequent calls complete quickly.

I have tried just about all the combinations of the flags to Lock, but it doesn't help. Any suggestions?

Anthony

Follow Ups:

Post a Followup

Name:


Re: info on IDirect3DViewport2::TransformVertices?????

Posted by Fragmo on June 07, 1998 at 17:11:52:

In Reply to: Re: info on IDirect3DViewport2::TransformVertices????? posted by frodo on June 04, 1998 at 07:48:08:

: : i need to be able to transform vertices to screenspace
: : in my application before polygons are drawn, but i
: : can't find any useful info on how to use the
: : TransformVertices function. does d3d allocate the list
: : of transformed verts or do i need to pass in an array
: : for it to put them in. also, does this function even
: : transform verts to screenspace at all??? a code
: : example for this would be a lifesaver!!

: check this out:

:
: void SomeFunc()
: {
: D3DVECTOR vin[3];
: D3DTLVERTEX vout[3];
: D3DHVERTEX hout[3];
: D3DTRANSFORMDATA td;
: DWORD offscreen = 0;

: ZeroMemory( &td, sizeof(td));
: td.dwSize = sizeof(td);
: td.lpIn = vin;
: td.dwInSize = sizeof(D3DVECTOR);
: td.lpOut = vout;
: td.dwOutSize = sizeof(D3DTLVERTEX);
: td.lpHOut = hout;
: immview->TransformVertices( 3, &td, D3DTRANSFORM_CLIPPED, &offscreen);

when i draw polygons that should have been clipped by this function, it
messes up the drawing. is there something i need to do to
handle clipping? and if it clips a polygon, shouldn't it produce more
vertices than there were in the original, e.g. a clipped triangle should
contain at least 4 vertices. how do you know how many vertices there are after
clipping, and where are the clipped vertices?

Follow Ups:

  • Re: info on IDirect3DViewport2::TransformVertices????? Ken Chan 04:37:52 6/12/98 (0)

Post a Followup

Name:


Direct

Posted by alan on June 07, 1998 at 17:15:23:

Is Directx 6 on the web as beta yet or
where can i get hold of it as a download or on cd

Follow Ups:

Post a Followup

Name:


Re: How do you load a Direct3D *.x file?

Posted by ding@ on June 07, 1998 at 22:36:34:

In Reply to: How do you load a Direct3D *.x file? posted by Me on June 07, 1998 at 15:26:41:

maybe you should use 'Frame' to load yoru .x file, You can try that by using the Direct3D viewer in DXSDK, See if you can open that file by 'open frame', or 'open mesh' or 'open animation', etc etc.

Follow Ups:

Post a Followup

Name:


PLEASE HELP!! Direct3D is wierd!

Posted by Sanghyun Lee on June 08, 1998 at 10:26:55:

I don't have the money to buy anything but I'm trying
to make something with d3drm. I have the DirectX 3 sdk
(I know it's outdated)

When I create a polygon mesh and display it, (face &
vertex data from .scn file truespace 2 demo)
I made a little scnconverter thing..
the polygons from the back and front are both
visible and-it's weird. Sometimes the polygons toward
you are not drawn and the polygons in the back are...
What's going on?
Does this happen if
two or more faces share a vertex (as in the .scn files)?

Also, how can I convert .3ds to .x

I downloaded Rhino3d and exported to 3ds
and ran conv3ds but it just crashes.

Please help. Please e-mail also if possible.

Follow Ups:

  • Re: PLEASE HELP!! Direct3D is wierd! Fred 12:45:12 6/21/98 (0)

Post a Followup

Name:


DirectSound and Input Focus

Posted by John Croft on June 08, 1998 at 11:27:01:

I need to have my program continue to play sound
while it does not have input focus, but I can't seem
to get it to work. Which cooperative level is supposed
to do what I want? Can anyone help me out?

Follow Ups:

Post a Followup

Name:


I need directx 6.0--my uin is 6042905

Posted by wicked on June 08, 1998 at 14:37:22:

Follow Ups:

  • Re: I need directx 6.0--my uin is 6042905 marc 16:11:41 6/08/98 (0)
  • Re: I need directx 6.0--my uin is 6042905 Marc Curiel 16:01:25 6/08/98 (0)

Post a Followup

Name:


Re: I need directx 6.0--my uin is 6042905

Posted by Marc Curiel on June 08, 1998 at 16:01:25:

In Reply to: I need directx 6.0--my uin is 6042905 posted by wicked on June 08, 1998 at 14:37:22:

Follow Ups:

Post a Followup

Name:


Re: directX5.0 please

Posted by Marc Curiel on June 08, 1998 at 16:03:26:

In Reply to: directX5.0 please posted by mie on June 03, 1998 at 08:56:31:

Follow Ups:

Post a Followup

Name:


Re: Help!

Posted by fog on June 08, 1998 at 16:08:17:

In Reply to: Help! posted by Chris and Terry, Homeschoolers on May 14, 1998 at 11:33:12:

I've a question,
do you need to have directX 5.0 if you have DirectX 6.0?? I don't have any idea.

Follow Ups:

Post a Followup

Name:


Re: ActiveMovie 2.0

Posted by fog on June 08, 1998 at 16:10:03:

In Reply to: ActiveMovie 2.0 posted by Ken Moore on June 05, 1998 at 19:16:01:

bla bla

Follow Ups:

  • Re: ActiveMovie 2.0 Ken Moore 20:46:49 6/10/98 (0)

Post a Followup

Name:


Re: I need directx 6.0--my uin is 6042905

Posted by marc on June 08, 1998 at 16:11:41:

In Reply to: I need directx 6.0--my uin is 6042905 posted by wicked on June 08, 1998 at 14:37:22:

i need 6.0 as quick as it's possible

Follow Ups:

Post a Followup

Name:


Draw Primitive Please Help

Posted by Karl Fisher on June 08, 1998 at 18:54:10:

I am strictly an amateur, and totally new to draw primitive, but I have been
able to progress fairly well with Direct X features other than immediate
mode with a lot of help from others who really know what they are doing.

I am using code from the MS example program d_light. In d_light.cpp there
is a routine to generate a sphere. I was able to get it to generate the
sphere, but I am only able to render it as a flat, black sphere.

I created an ambient light and set it, but that didn't seem to help.

The code for sphere generation is similar to that on page 51 of the MSN
Journal for February 1998.

I am obviously missing something, but I can't seem to figure out what.

Any and hints, tips, suggestions, or examples would be greatly appreciated.

Thanks much

Karl

karl_fisher@msn.com

Follow Ups:

  • Re: Draw Primitive Please Help Fragmo 21:38:38 6/09/98 (0)

Post a Followup

Name:


Re: DX 5.0 & AVI Troubles (Examples Don't Work Well at all!!)

Posted by BoxMan on June 08, 1998 at 21:02:25:

In Reply to: DX 5.0 & AVI Troubles (Examples Don't Work Well at all!!) posted by EvAcLeAr on May 25, 1998 at 03:59:47:

Maybe the examples from Microsoft (and who knows else?) work on only certain types of AVI files? (just a guess) I'd try several AVI files on the example they gave you and see if one of many will work...

Follow Ups:

Post a Followup

Name:


Re: directX5.0

Posted by Tom Goody on June 08, 1998 at 22:09:43:

In Reply to: directX5.0 posted by jhony on June 07, 1998 at 02:43:37:

: 풡onde puedo encontrar directX5.0 download?
: where i can download it directX5.0 ?

Follow Ups:

Post a Followup

Name:


Re: Direct Play: DirectPlayCreate call

Posted by Paul Hunter on June 09, 1998 at 08:32:11:

In Reply to: Direct Play: DirectPlayCreate call posted by Paul Hunter on June 04, 1998 at 12:19:41:

And the answer, I was amazed to find, was simply that in the link project settings it should have been:

dplayx.lib dplay.lib

instead of:

dplay.lib dplayx.lib

Crap huh!
: Paul.

: ps. Are there any forums that are DirectPlay specific? When I get stuck with the documentation and cannot find any samples to look into I never know where to go next.

Follow Ups:

Post a Followup

Name:


Surfaces with different pixel formats

Posted by Ravi Joshi on June 09, 1998 at 09:36:07:

Is it possible to have Direct Draw surfaces with different
pixel formats.
This is needed for multiple platform compatibility.
If you have got any solution, pl post the answers
to joshiobjects@hotmail.com
Thanx

Follow Ups:

Post a Followup

Name:


Re: Forcing DDPIXELFORMAT 8bpp on CreateSurface?

Posted by Doug Wheeler on June 09, 1998 at 14:29:18:

In Reply to: Forcing DDPIXELFORMAT 8bpp on CreateSurface? posted by Ed Halley on June 07, 1998 at 02:11:14:

:
: I can force DDPIXELFORMAT to 24bpp RGB while doing a CreateSurface to system memory or offscreen, but I get a DDERR_INVALIDPIXELFORMAT if I try to force an 8bpp.

: I want to make lots of 8bpp system memory surfaces, each with their own associated palette.

Make sure you specify 8bpp *AND* RGB. The RGB flag isn't just for true-color modes.

--Doug

Follow Ups:

Post a Followup

Name:


To Merlin or anybody: DirectX uninstall

Posted by Mike on June 09, 1998 at 16:03:17:

I saw the message posted here by Merlin on how to uninstall
DirectX, and for some reason it is incomplete. I need this
information pretty badly. If anyone knows how to do this,
please contact me by mail or ICQ: 7490264
And please do not write about going to Add/Remove software
and doing it from there, it does not work. You need to
play with registry and system files quite a bit.

Follow Ups:

Post a Followup

Name:


Re: WHICH COMPILER IS BEST 4 DIRECTX5?

Posted by JORGE on June 09, 1998 at 16:04:32:

In Reply to: Re: WHICH COMPILER IS BEST 4 DIRECTX5? posted by Wolfgang R�ssler on March 11, 1998 at 06:25:35:

:
: : : OK guys simple one.... Which is the best, most compatable compiler for DIRECT X 5?

: I'm using Watcom C/C++ 11.0. In my opinion the Watcom-Compiler is the best one. It generates the fastest code I've ever seen.

Follow Ups:

Post a Followup

Name:


DirectX 5 and Borland C++

Posted by Adrian Hirst on June 09, 1998 at 16:49:25:

Does anyone know if it is possible to code DirectX 5
SDK with Borland C++? If so what alterations are needed
or patches?

Follow Ups:

  • Re: DirectX 5 and Borland C++ 0x1CE 18:00:42 6/11/98 (0)

Post a Followup

Name:


Re: Draw Primitive Please Help

Posted by Fragmo on June 09, 1998 at 21:38:38:

In Reply to: Draw Primitive Please Help posted by Karl Fisher on June 08, 1998 at 18:54:10:

: I am strictly an amateur, and totally new to draw primitive, but I have been
: able to progress fairly well with Direct X features other than immediate
: mode with a lot of help from others who really know what they are doing.

: I am using code from the MS example program d_light. In d_light.cpp there
: is a routine to generate a sphere. I was able to get it to generate the
: sphere, but I am only able to render it as a flat, black sphere.

: I created an ambient light and set it, but that didn't seem to help.

: The code for sphere generation is similar to that on page 51 of the MSN
: Journal for February 1998.

: I am obviously missing something, but I can't seem to figure out what.

: Any and hints, tips, suggestions, or examples would be greatly appreciated.

: Thanks much

: Karl

: karl_fisher@msn.com

i had a similar problem when i started using d3d.
in my case, i forgot to set the specular component
for the D3DLVERTEX.
try disabling specular highlights.

d3dDevice->SetRenderState(D3DRENDERSTATE_SPECULARENABLE,FALSE);

also make sure you set the color for the light.

Follow Ups:

Post a Followup

Name:


IDirect3DDevice2::EndScene

Posted by Fragmo on June 09, 1998 at 21:50:00:

does anyone know how EndScene works? i'm cursious
to know if polygons rendered between BeginScene and
EndScene are stored then drawn when EndScene is called
or if they are drawn with each DrawPrimitive call.
would performance be improved by cutting down on
the number of calls to DrawPrimitive?

thanks,
Dave http://www.public.iastate.edu/~jtilton/gamepage.html

Follow Ups:

  • Re: IDirect3DDevice2::EndScene Clay 08:30:55 6/11/98 (0)

Post a Followup

Name:


Visual Basic and Direct X

Posted by David on June 09, 1998 at 22:27:41:

Ok, how do I make animation in Visual Basic (any version) with Direct X. Actually I dont care if it's Direct X or Not. Dp you know a link or anything that i can find out. THank you sooo much for even reading this far.�

Follow Ups:

  • Re: Visual Basic and Direct X Frenchy FADGE 11:42:39 6/24/98 (0)
  • Re: Visual Basic and Direct X Gustavo Herrera Molina 19:46:51 6/17/98 (0)

Post a Followup

Name:


OWL and Direct Draw

Posted by Mehmet Gokturk on June 10, 1998 at 00:57:06:

Hi,
Anyone using Direct Draw with OWL? How do you set up the
windows? I cannot open a TWindow and use DirectX on it.
Do I have to do it with Win32 API only?

I am using BorlandC++ 5.02 with OWL.

Follow Ups:

Post a Followup

Name:


Clipper:Help,Help, I Desperately need help

Posted by Ravi Joshi on June 10, 1998 at 05:29:35:

Hi I am Ravi Joshi.

I want to implement a clipper in the directdraw surface
can any one help me do this.
I am trying hard to get some clipping. but can anyone
send some sample source code and help me write a simple
clipper code..
Thanx..

Follow Ups:

  • Re: Clipper:Help,Help, I Desperately need help 0x1CE 18:17:17 6/11/98 (3)
    • Re: Clipper:Help,Help, I Desperately need help Ravi Joshi 00:29:01 6/16/98 (2)
      • Re: Clipper:Help,Help, I Desperately need help 0x1CE 03:36:17 6/18/98 (1)
        • Re: Clipper:Help,Help, I Desperately need help 0x1CE 19:02:12 6/18/98 (0)

Post a Followup

Name:


Re: D3DRM.DLL

Posted by David Goss on June 10, 1998 at 08:46:23:

In Reply to: Directx 5.0 posted by Joshua Lee on April 22, 1998 at 01:19:07:

: I need a copy of D3DRM.DLL and I can't find it, can you help me out? E-mail me.

Follow Ups:

Post a Followup

Name:


Rotating in DirectDraw

Posted by Peter on June 10, 1998 at 10:44:54:

Is there a function for rotating 2d bitmaps in dd?
If not, how can it be done?

Follow Ups:

Post a Followup

Name:


Help with in Memory DIBs

Posted by Allen Pauna on June 10, 1998 at 12:48:25:

I have been trying to load a 24 bit in memory dib into a DirectDraw surface and get only a black screen. Does anyone have an example of that type of DIB.

Follow Ups:

Post a Followup

Name:


D3D Faces

Posted by Me on June 10, 1998 at 18:03:56:

How do I apply a texture to a face of a mesh? When I use the LPDIRECT3DRMFACE SetTexture() function all that happens is it takes the upper left point's color, and fills the whole face that color.

Follow Ups:

  • Re: D3D Faces Clay 08:20:25 6/11/98 (5)
    • Re:D3D Faces Me 17:14:37 6/11/98 (4)
      • Re:D3D Faces Clay 20:44:17 6/11/98 (3)
        • Re:D3D Faces Me 19:13:49 6/12/98 (2)
          • Re:D3D Faces Clay 21:19:51 6/12/98 (1)
            • Re:D3D Faces Me 20:39:14 6/13/98 (0)

Post a Followup

Name:


D3D Collision detection

Posted by Me on June 10, 1998 at 19:07:47:

Does anyone know anything about 3d collision detection. How can I tell if the camera (you in a 3d game) has colided with one of the meshes? Or do you know a place that I can find this out?

Follow Ups:

Post a Followup

Name:


D3D GetBox()

Posted by Me on June 10, 1998 at 19:10:37:

What does the meshbuilders GetBox() function give you? I thought it gave you the max and min for all of the the verticies of the mesh.

Follow Ups:

Post a Followup

Name:


Re: ActiveMovie 2.0

Posted by Ken Moore on June 10, 1998 at 20:46:49:

In Reply to: Re: ActiveMovie 2.0 posted by fog on June 08, 1998 at 16:10:03:

Thanks for your helpful response. It's nice to know there are experts like yourself willing to help newcomers like myself. I hope I didn't take up too much of your time.

Follow Ups:

Post a Followup

Name:


Re: DirectX5

Posted by ziv on June 11, 1998 at 06:21:01:

In Reply to: DirectX5 posted by Lois Nicholls on February 17, 1998 at 16:15:39:

: i need directx5 for the game UBIK. where can i find it?

Follow Ups:

Post a Followup

Name:


Re: D3D Faces

Posted by Clay on June 11, 1998 at 08:20:25:

In Reply to: D3D Faces posted by Me on June 10, 1998 at 18:03:56:

You need to set texture coordinates for the vertices -- either directly or through the IDirect3DRMWrap interface.

Clay

: How do I apply a texture to a face of a mesh? When I use the LPDIRECT3DRMFACE SetTexture() function all that happens is it takes the upper left point's color, and fills the whole face that color.

Follow Ups:

  • Re:D3D Faces Me 17:14:37 6/11/98 (4)
    • Re:D3D Faces Clay 20:44:17 6/11/98 (3)
      • Re:D3D Faces Me 19:13:49 6/12/98 (2)
        • Re:D3D Faces Clay 21:19:51 6/12/98 (1)
          • Re:D3D Faces Me 20:39:14 6/13/98 (0)

Post a Followup

Name:


Re: IDirect3DDevice2::EndScene

Posted by Clay on June 11, 1998 at 08:30:55:

In Reply to: IDirect3DDevice2::EndScene posted by Fragmo on June 09, 1998 at 21:50:00:

According to the SDK docs, DrawPrimitive() sends polys directly to the card and returns when they are sent, not rendered (you can change this behavior). I haven't checked this out yet, but I suspect DrawIndexedPrimitive() is faster for large poly counts that DrawPrimitive() (PCI bus likes fewer, bigger transfers). I also suspect that Begin/End Scene() is like a notification to the card or driver that polys are coming and it should do some preparaion. To really find out, you probably need to link with the debug libraries and step through the disassembly, and see what functions are being called (function names are usually indicitive of purpose!). Hopefully your compiler will let you do that. An easier solution would be to ask someone in the video card industry that has worked on the card/driver. If you find out, please post!

Clay

: does anyone know how EndScene works? i'm cursious
: to know if polygons rendered between BeginScene and
: EndScene are stored then drawn when EndScene is called
: or if they are drawn with each DrawPrimitive call.
: would performance be improved by cutting down on
: the number of calls to DrawPrimitive?

: thanks,
: Dave http://www.public.iastate.edu/~jtilton/gamepage.html

Follow Ups:

Post a Followup

Name:


Won't Run Old Game...

Posted by Dave on June 11, 1998 at 14:39:51:

I've got this free game that won't run. It keeps jumping back to the Win95 screen without running. I've tried re-loading DirectX several times but no joy.
My PC is brand new but the game only needs DirectX3.0A, are newer versions of DirectX compatible with older ones?

Follow Ups:

Post a Followup

Name:


Desperately Seeking Good Examples

Posted by knoone on June 11, 1998 at 16:39:18:

I'm newish to d3d and I need some good examples to really get started.
I've found a million d3d examples that load objects and spin them around and stuff, but I want to see some code for a room or some other realistic environment that a user can walk around in.

Follow Ups:

Post a Followup

Name:


Re:D3D Faces

Posted by Me on June 11, 1998 at 17:14:37:

In Reply to: Re: D3D Faces posted by Clay on June 11, 1998 at 08:20:25:

Clay- Or anyone

Thank you, it worked, but: How do I save the mesh once I have the faces textured the way I want them?

: You need to set texture coordinates for the vertices -- either directly or through the IDirect3DRMWrap interface.

: Clay

: : How do I apply a texture to a face of a mesh? When I use the LPDIRECT3DRMFACE SetTexture() function all that happens is it takes the upper left point's color, and fills the whole face that color.

Follow Ups:

  • Re:D3D Faces Clay 20:44:17 6/11/98 (3)
    • Re:D3D Faces Me 19:13:49 6/12/98 (2)
      • Re:D3D Faces Clay 21:19:51 6/12/98 (1)
        • Re:D3D Faces Me 20:39:14 6/13/98 (0)

Post a Followup

Name:


Re: DirectX 5 and Borland C++

Posted by 0x1CE on June 11, 1998 at 18:00:42:

In Reply to: DirectX 5 and Borland C++ posted by Adrian Hirst on June 09, 1998 at 16:49:25:

: Does anyone know if it is possible to code DirectX 5
: SDK with Borland C++? If so what alterations are needed
: or patches?

Yes, you can code DX with Borland. The .lib files
included with the SDK are for VC++, so you will have
to make new ones out of the existing .dll's (or if
you have the latest SDK (which Micro$oft only ships on
CD) you will find Borland .lib's on the disk). Add your
new .lib's to your project. At the top of your file,
before you #include any DX files, you have to add the
following code:
#if defined (_BORLANDC_)&&defined(_WIN32_)
#define _WIN32
#endif
And if you want to use DirectInput, you will have to
add:
#define INITGUID
In the readme's that come witht he SDK, it says that
you don't have to define initguid if you link with
the xguid.lib (or whatever it's called), but Micro$oft
made the Borland .lib's weaker than the VC++ ones.
Next, you will have to setup your project's path to
the DX .inc's. Under options>project>directories
add the pathname to the DX SDK to the beginning of the
include section, for example:
c:\dxsdk\sdk\inc; c:\bc5\include
You don't have to change the .lib directory because
you are linking directly to the .lib's by adding them
to your project.
Also, you will have to change your project's framework
from OWL to MFC (either when you create a new project
or if you already have a project right click on your
.exe file and choose target expert from the popup menu).
That's about it;)

Follow Ups:

Post a Followup

Name:


Re: Clipper:Help,Help, I Desperately need help

Posted by 0x1CE on June 11, 1998 at 18:17:17:

In Reply to: Clipper:Help,Help, I Desperately need help posted by Ravi Joshi on June 10, 1998 at 05:29:35:

Unless you are running in windowed mode, you don't
need a clipper. DirectX clippers don't prevent you
from writing past the edge of the screen, they prevent
you from writing outside of your app's window. If
you're running in full screen mode and want a way
to prevent your sprites from trying to write past
the edge of the screen (and thus causing your game
to come to a screeching halt) you will have to
incorperate collision detecting into your sprites
to see if they have gone past the edge of the screen
and adjust their Blit RECT accordingly (or don't draw
them if they are completely off screen). If you
are running in windowed mode and need a clipper,
you can create one like this:
LPDIRECTDRAWCLIPPER lpDDClipper;
And you can initialize it like this:
HRESULT ddrval;
ddrval = CreateClipper (0, &lpDDClipper, NULL);
if (FAILED(ddrval))
{
//Whatever you want your app to do if it can't
//create a clipper
}
You can then give your clipper a handle to your
window (hwnd):
ddrval = lpDDClipper->SetHwnd(0,hwnd);
if (FAILED(ddrval))
{
//stuff
}
Assuming that you have a DDraw object called lpDD
and a primary surface called lpDDSPrimary, you
can attach you clipper to the primary surface like
so:
ddrval = lpDDSPrimary->SetClipper(lpDDClipper);
if (FAILED(ddrval))
{
//stuff
}
That's all there is to it.

: Hi I am Ravi Joshi.

: I want to implement a clipper in the directdraw surface
: can any one help me do this.
: I am trying hard to get some clipping. but can anyone
: send some sample source code and help me write a simple
: clipper code..
: Thanx..

Follow Ups:

  • Re: Clipper:Help,Help, I Desperately need help Ravi Joshi 00:29:01 6/16/98 (2)
    • Re: Clipper:Help,Help, I Desperately need help 0x1CE 03:36:17 6/18/98 (1)
      • Re: Clipper:Help,Help, I Desperately need help 0x1CE 19:02:12 6/18/98 (0)

Post a Followup

Name:


Re: directx5 needed for download

Posted by Matthew Broyles on June 11, 1998 at 19:22:06:

In Reply to: directx5 needed for download posted by THOMAS KURT on March 24, 1998 at 09:13:58:

: : : I downloaded a demo version of Curse of Monkey Island
: : : with DirectX5 download included and it worked fine.
: : : I then purchased the game, uninstalled the demo as per
: : : instructions but the purchased game freezes my whole
: : : system, screen, keyboard, mouse et al. Checking for
: : : compatability with DirectX5 indicates there is no hard-
: : : ware support for the Primary Display Driver, Primary
: : : sound Driver and Sound System Player. Why did the first
: : : DirectX5 download work but this one won't and what do I
: : : do about the problem?
: : : Thank you, any help would be greatly appreciated.
: : : Lois Nicholls

Follow Ups:

Post a Followup

Name:


Re:D3D Faces

Posted by Clay on June 11, 1998 at 20:44:17:

In Reply to: Re:D3D Faces posted by Me on June 11, 1998 at 17:14:37:

If you want to save it to a file, you can insert the mesh into a meshbuilder and use IDirect3DRMMeshbuilder->Save(). Don't forget to specify the texture save flag! When you load the meshbuilder (IDirect3DRMMeshbuilder->Load()), it will remember the texture coordinates, but you need a texture callback function to reload the texture. (RM doesn't know where your .bmp or .ppm texture files is!) Also, you can manually load the texture when you load the meshbuilder, don't forget to SetTexture() it!

Clay

: Clay- Or anyone

: Thank you, it worked, but: How do I save the mesh once I have the faces textured the way I want them?

:
: : You need to set texture coordinates for the vertices -- either directly or through the IDirect3DRMWrap interface.

: : Clay

: : : How do I apply a texture to a face of a mesh? When I use the LPDIRECT3DRMFACE SetTexture() function all that happens is it takes the upper left point's color, and fills the whole face that color.

Follow Ups:

  • Re:D3D Faces Me 19:13:49 6/12/98 (2)
    • Re:D3D Faces Clay 21:19:51 6/12/98 (1)
      • Re:D3D Faces Me 20:39:14 6/13/98 (0)

Post a Followup

Name:


Re: info on IDirect3DViewport2::TransformVertices?????

Posted by Ken Chan on June 12, 1998 at 04:37:52:

In Reply to: Re: info on IDirect3DViewport2::TransformVertices????? posted by Fragmo on June 07, 1998 at 17:11:52:

Also, can anyone tell me the purpose of the three parameters dwClip, dwClipIntersection, and dwClipUnion in the D3DTRANSFORMDATA structure?

If I want my vertices to be clipped by the whole view frustrum, what values should I set these three flags to?

Follow Ups:

Post a Followup

Name:


help with DirectDraw2::SetDisplayMode()

Posted by Pontus Lundwall on June 12, 1998 at 12:12:50:

I need to open a screen with a fixed refresh rate, so that the game im working on will run equaly fast on every computer.

I know that you're supposed to be able to request a refreshrate with that function, but it always returns with a DDER_INVALIDMODE, nomatter what i set the frequency to.

so, how to you guys do it? :)

Follow Ups:

  • Re: help with DirectDraw2::SetDisplayMode() Ravi Joshi 01:37:32 6/16/98 (1)
    • Re: help with DirectDraw2::SetDisplayMode() Pontus Lundwall 12:29:56 6/16/98 (0)

Post a Followup

Name:


Program crashes when an object leaves viewport

Posted by KC on June 12, 1998 at 13:46:54:

I set up a frame with a mesh that moves across the screen, but when it leaves the viewport, the program crashes. It happens all the time in full screen mode, and when it's not run from the debugger in windowed mode. In fullscreen mode, I thik the program ends (I can shut down my computer thru the start menu using the windows key and arrow keys), but the screen freezes at the point where the program crashes. In windowed mode, the illeagel operation dialog box comes up, and takes a few times to shut down the program.

Any help would be appreciated.

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Shawn Salerno on June 12, 1998 at 16:28:32:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Denny on March 17, 1998 at 18:13:25:

:
: : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Alan Cohen 17:16:52 7/15/98 (0)

Post a Followup

Name:


Direct 3D modes

Posted by Me on June 12, 1998 at 17:09:07:

Do you need to use the Direct 3D Intermideate mode in order to use harderware acceleration? If not how do you do it in retained mode? Thnaks in advance!

Follow Ups:

  • some sample code Clay 21:27:36 6/12/98 (5)
    • Clay? Are you still there buddy? Please help me... Me 00:19:28 6/19/98 (2)
      • busy at work... Clay 07:22:16 6/23/98 (1)
        • Re: busy at work... Me 23:32:12 7/05/98 (0)
    • Re: some sample code Me 22:03:05 6/13/98 (0)
    • an addendum Clay 21:29:38 6/12/98 (0)

Post a Followup

Name:


Converting files

Posted by Me on June 12, 1998 at 19:06:54:

Is there a convdxf utility, similar to the conv3ds included in the DirectX 5 SDK? I need to convert *.DXF files straight to *.X files. Is there a graphics converter that anyone can recommend? Is there a CHEAPER 3D program that will Save and Load 3DS files?

Thanks to cayone in advance who can answer any of these questions.

Follow Ups:

  • Re: Converting files fred 12:11:21 6/21/98 (2)
    • Re: Converting files Me 16:54:07 6/23/98 (1)
      • Re: Converting files KC 17:10:52 7/06/98 (0)

Post a Followup

Name:


Re:D3D Faces

Posted by Me on June 12, 1998 at 19:13:49:

In Reply to: Re:D3D Faces posted by Clay on June 11, 1998 at 20:44:17:

Why, and how, do I tell RM where the .bmp file is? Do I have to make another texture object, load the texture, and re apply it? When you put a texture on the whole mesh, save it, and reload it you don't have to tell RM where the file is. Is it different when you do it with faces. Also is using the D3DRMXOFSAVE_ALL flag going to save the texture coordinates for me?

: If you want to save it to a file, you can insert the mesh into a meshbuilder and use IDirect3DRMMeshbuilder->Save(). Don't forget to specify the texture save flag! When you load the meshbuilder (IDirect3DRMMeshbuilder->Load()), it will remember the texture coordinates, but you need a texture callback function to reload the texture. (RM doesn't know where your .bmp or .ppm texture files is!) Also, you can manually load the texture when you load the meshbuilder, don't forget to SetTexture() it!

: Clay

:
: : Clay- Or anyone

: : Thank you, it worked, but: How do I save the mesh once I have the faces textured the way I want them?

: :
: : : You need to set texture coordinates for the vertices -- either directly or through the IDirect3DRMWrap interface.

: : : Clay

: : : : How do I apply a texture to a face of a mesh? When I use the LPDIRECT3DRMFACE SetTexture() function all that happens is it takes the upper left point's color, and fills the whole face that color.

Follow Ups:

  • Re:D3D Faces Clay 21:19:51 6/12/98 (1)
    • Re:D3D Faces Me 20:39:14 6/13/98 (0)

Post a Followup

Name:


help: capture card - image processing algorithm

Posted by James A.T. Rice on June 12, 1998 at 21:04:41:

Hi, I need some help with an imageprocessing app I'm trying to write. I have VC++ and all the SDK's in the world, i just need to know how to go about this problem.

I have some imageprocessing code (in C) that will take a single frame, and do some pretty processor intensive work on it. So what I need is something that will grab a frame from my capture card (in windows), I think DirectShow is the way to go here ? And puts it into a buffer so that the imageprocessing code can work on it. I want to grab a single frame at a time, not an avi, and i want to write as little code as possible.

Where do i start ?

Many Thanks
James

Follow Ups:

Post a Followup

Name:


Re:D3D Faces

Posted by Clay on June 12, 1998 at 21:19:51:

In Reply to: Re:D3D Faces posted by Me on June 12, 1998 at 19:13:49:

Hmmm...I could be wrong about RM remembering where the .bmp/.ppm texture file is. If you successfully saved and loaded the meshbuilder without losing the actual texture, then RM must store the texture name in the .x file. I never tried it: I always re-load my textures when I load the meshbuilder. Oops, I seem to have been caught making an assumption! Thanks for pointing that out (seriously!).

Clay

: Why, and how, do I tell RM where the .bmp file is? Do I have to make another texture object, load the texture, and re apply it? When you put a texture on the whole mesh, save it, and reload it you don't have to tell RM where the file is. Is it different when you do it with faces. Also is using the D3DRMXOFSAVE_ALL flag going to save the texture coordinates for me?

: : If you want to save it to a file, you can insert the mesh into a meshbuilder and use IDirect3DRMMeshbuilder->Save(). Don't forget to specify the texture save flag! When you load the meshbuilder (IDirect3DRMMeshbuilder->Load()), it will remember the texture coordinates, but you need a texture callback function to reload the texture. (RM doesn't know where your .bmp or .ppm texture files is!) Also, you can manually load the texture when you load the meshbuilder, don't forget to SetTexture() it!

: : Clay

: :
: : : Clay- Or anyone

: : : Thank you, it worked, but: How do I save the mesh once I have the faces textured the way I want them?

: : :
: : : : You need to set texture coordinates for the vertices -- either directly or through the IDirect3DRMWrap interface.

: : : : Clay

: : : : : How do I apply a texture to a face of a mesh? When I use the LPDIRECT3DRMFACE SetTexture() function all that happens is it takes the upper left point's color, and fills the whole face that color.

Follow Ups:

  • Re:D3D Faces Me 20:39:14 6/13/98 (0)

Post a Followup

Name:


some sample code

Posted by Clay on June 12, 1998 at 21:27:36:

In Reply to: Direct 3D modes posted by Me on June 12, 1998 at 17:09:07:

The following code works, but I didn't follow my naming convention completely. Some of the interfaces (e.g. LPDIRECT3DRM2) are named lpD3DRM instead of lpD3DRM2...

Clay

P.S. this gets a hardware device, then, if HW acceleration is not available, it gets a RGB device.

BOOL D3DWindowClass::Init(COLORREF Color)
{
HRESULT Error;
LPDIRECT3DRM pD3DRM;

bD3DReady = FALSE;

// init DD

if(!DDWindowClass::Init(Color,TRUE,TRUE))
{
return(FALSE);
}

// enumerate D3D drivers/devices
// this is not necessary anymore because
// of the way the interfaces are created

Display3DCaps();

// create RM API

Error = Direct3DRMCreate(&pD3DRM);
if(FAILED(Error))
{
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"Error on RM Create",MB_OK);
ShutdownDD();
return(FALSE);
}

// get RM2 API

Error = pD3DRM->QueryInterface(IID_IDirect3DRM2,(void**)&pD3DRetainedModeAPI);
if(FAILED(Error))
{
pD3DRM->Release();
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"RM query interface",MB_OK);
ShutdownDD();
return(FALSE);
}

// don't need this anymore

pD3DRM->Release();

// get D3D2 interface

Error = lpDD->QueryInterface(IID_IDirect3D2,(void**)&lpD3D);

if(FAILED(Error))
{
pD3DRetainedModeAPI->Release();
pD3DRetainedModeAPI = NULL;
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"Error on query interface",MB_OK);
ShutdownDD();
return FALSE; // Failed creation
}

// use HAL for D3D device

Error = lpD3D->CreateDevice(IID_IDirect3DHALDevice,
lpBackSurf,
&lpD3DDevice
);

if(FAILED(Error))
{
Error = lpD3D->CreateDevice(IID_IDirect3DRGBDevice,
lpBackSurf,
&lpD3DDevice
);
if(FAILED(Error))
{
lpD3D->Release();
pD3DRetainedModeAPI->Release();
pD3DRetainedModeAPI = NULL;
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"Error on create D3D device",MB_OK);
ShutdownDD();
return FALSE; // Failed creation
}
}

// turn on anti-aliasing

lpD3DDevice->SetRenderState(D3DRENDERSTATE_ANTIALIAS,D3DANTIALIAS_SORTINDEPENDENT);

// get RM device

Error = pD3DRetainedModeAPI->CreateDeviceFromD3D(lpD3D,//&DriverGUID[iPreferredIndex],
lpD3DDevice,
&pD3DRMDeviceAPI
);

if(FAILED(Error))
{
lpD3DDevice->Release();
lpD3D->Release();
pD3DRetainedModeAPI->Release();
pD3DRetainedModeAPI = NULL;
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"Error on device Create",MB_OK);
ShutdownDD();
return FALSE; // Failed creation
}

// set quality for textures

pD3DRMDeviceAPI->SetTextureQuality(D3DRMTEXTURE_LINEAR);

// make scene, camera, viewport, background color here

return(TRUE);
}

Follow Ups:

  • Clay? Are you still there buddy? Please help me... Me 00:19:28 6/19/98 (2)
    • busy at work... Clay 07:22:16 6/23/98 (1)
      • Re: busy at work... Me 23:32:12 7/05/98 (0)
  • Re: some sample code Me 22:03:05 6/13/98 (0)
  • an addendum Clay 21:29:38 6/12/98 (0)

Post a Followup

Name:


an addendum

Posted by Clay on June 12, 1998 at 21:29:38:

In Reply to: some sample code posted by Clay on June 12, 1998 at 21:27:36:

I'm not an advocate of using C++ for real-time stuff, but you can't beat it for initialization and reuseability...

Clay

Follow Ups:

Post a Followup

Name:


How do I create a command bar

Posted by Jeroen Bulters on June 13, 1998 at 06:33:25:

Hi. I am creating a strategy game but I ran into a problem.
I want a command bar(sidebar ala C&C), but how do I set the
size(main screen 600x480, sidebar 80x480 for example) of the two surfaces ?????
Hope someone can help me.
Jeroen Bulters
UIN : 10110176

Follow Ups:

Post a Followup

Name:


DirectX 6.0

Posted by Major Tom on June 13, 1998 at 12:30:25:

Hi everybody
can someone tell me: where can I get DirectX 6.0 ??

Thanks

Follow Ups:

  • Re: DirectX 6.0 Max Kovacs 06:00:00 6/27/98 (1)
    • Re: DirectX 6.0 hj 04:37:12 7/07/98 (0)
  • Re: DirectX 6.0 Michael 19:22:46 6/19/98 (0)
  • Re: DirectX 6.0 KENG 00:50:31 6/16/98 (0)

Post a Followup

Name:


My First DirectX Program

Posted by Dodit W on June 13, 1998 at 17:11:08:

How to use DirectX object in Delphi Language
with no component if I already have the DirectX
units?

Follow Ups:

Post a Followup

Name:


Re:D3D Faces

Posted by Me on June 13, 1998 at 20:39:14:

In Reply to: Re:D3D Faces posted by Clay on June 12, 1998 at 21:19:51:

Maybe RM doesn't save the location of the .bmp/.ppm file unless the whole mesh is covered. I don't know, but how do you reload the mesh (it might work). Would I have to apply the textures to the specific faces again?

Thanks for all your help so far!

: Hmmm...I could be wrong about RM remembering where the .bmp/.ppm texture file is. If you successfully saved and loaded the meshbuilder without losing the actual texture, then RM must store the texture name in the .x file. I never tried it: I always re-load my textures when I load the meshbuilder. Oops, I seem to have been caught making an assumption! Thanks for pointing that out (seriously!).

: Clay

Follow Ups:

Post a Followup

Name:


Does DirectX a storage file format?

Posted by Anthony Villena on June 13, 1998 at 21:03:24:

I've heard that DirectX has a feature where you can add all your bitmaps, models, sounds and whatnot in one file and access each component individually through your program. Would you happen to have any information or references you can give me? Thanks.

Follow Ups:

Post a Followup

Name:


Does DirectX have a storage file format?

Posted by Anthony Villena on June 13, 1998 at 21:04:05:

I've heard that DirectX has a feature where you can add all your bitmaps, models, sounds and whatnot in one file and access each component individually through your program. Would you happen to have any information or references you can give me? Thanks.

Follow Ups:

Post a Followup

Name:


Re: some sample code

Posted by Me on June 13, 1998 at 22:03:05:

In Reply to: some sample code posted by Clay on June 12, 1998 at 21:27:36:

Thank you for all your help! Don't take this the wrong way, but do you have any files I could copy right into the compiler (VC++ 4.0) and compile. I have only been programing in RM for a few months. I like to start with examples, change things, take things out, and just work through the code and see how it all works. If it wouldn't be too much trouble please include coments explaining what is happening.

Once again thanks for all your help!

Follow Ups:

Post a Followup

Name:


D3D Books

Posted by Me on June 14, 1998 at 13:23:55:

Can anyone reccommend a good Direct3DRM book. I worked through Cutting Edge Direct3D Programming By: Stan Trujillo. It was agreat book, but it never went in depth on advanced subjects, such as collision detection and terrain mapping. Can anyone reccommend a more advanced book on Direct3DRM?

Thanks in advance!

Follow Ups:

Post a Followup

Name:


Scaling meshes

Posted by Me on June 14, 1998 at 13:52:24:

When you are scaling meshes in D3DRM is there a way to manually tell it what size you want the size, instead of scaling them?

Thanks in advance!

Follow Ups:

Post a Followup

Name:


Re: directX5.0

Posted by Jacques Wolf on June 14, 1998 at 17:44:11:

In Reply to: directX5.0 posted by jhony on June 07, 1998 at 02:43:37:

Espanol:
Puedes bajar DirectX 5.2 (5.0 no esta disponible) en la pagina de Microsoft. Teclea la direccion http://www.microsoft.com/msdownload/directx/dxf/enduser5.2/dx5spa.asp
Luego haz click en cualquier locacion que quieras para bajarlo (ojo! No hagas click en el icono de conexion!).
English:
You can download DirectX 5.2 (5.0 isn't available)
at Microsoft's Web Page. Just type the adress http://www.microsoft.com/msdownload/directx/dxf/enduser5.2/dx5eng.asp
Then click on whatever location you want to download it (watch out! Don't click on the conexion icon!)

Follow Ups:

Post a Followup

Name:


Is non-alpha transparency possible?

Posted by Fragmo on June 15, 1998 at 00:47:03:

is there a way to do transparency without using alpha blending
in d3d? my 3d card doesn't support alpha blending

Follow Ups:

  • Re: Is non-alpha transparency possible? Fred 11:46:46 6/21/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 problems

Posted by Joel Morgovsky on June 15, 1998 at 09:07:11:

In Reply to: DirectX 5.0 problems posted by Barry on May 26, 1998 at 09:59:25:

Your problem sounds a little like mine.
Once, as a result of loading MS Deadly Tide, my
Dell Dimension D300 video system hung up so badly
that I had to delete Windows and reinstall all of
my drivers and software. I think it was caused
by DirectX interacting badly with my 8mb AGP Matrox
video card. Since then, I have not been willing
to install a DirectX program for fear of a repeat
of that terrible experience.
Are you using an AGP card too?
Is there any documented trouble of this sort that
you know of or can point me to?

Thanks,

Joel Morgovsky

Follow Ups:

Post a Followup

Name:


Games

Posted by Me on June 15, 1998 at 13:51:25:

Has anyone actually made a quake style game in D3D? Is it even possible given the funtions we have to work with?

Follow Ups:

  • Re: Games chump 16:21:29 7/06/98 (0)
  • Re: Games 0x1CE 03:43:15 6/18/98 (2)
    • Re: Games Fred 12:18:45 6/21/98 (1)
      • Re: Games 0x1CE 23:25:43 6/22/98 (0)
  • Re: Games fragmo 03:07:05 6/16/98 (0)

Post a Followup

Name:


Retained Mode Texture Loading, Part II

Posted by Larry Weinstein on June 15, 1998 at 21:14:12:

I asked about loading textures in RM a few weeks ago and receive a reply from "Fred" (thanks) indicating that creating a surface and then using CreateTextureFromSurface was the way to go. This matched my own thinking. There was even a routine to do just this in the SDK (DDLoadBitmap.) The problem is that textures created in this way do not behave properly in all situations, at least when a hardware driver is being used. For example, the command to SetDecalTransparency does not work on decals generated in this manner. The problems come about only when my STB Velocity / Riva 128 hardware driver is being used. So, here are the questions. What is the best way to load textures into video card memory and system memory when working in RM? Has anyone else seen this behavior on any video cards (STB or otherwise?) Is anyone using this method successfully with other hardware?

Follow Ups:

  • Re: Retained Mode Texture Loading, Part II Fred 12:01:05 6/21/98 (1)
    • Re: Retained Mode Texture Loading, Part II Larry Weinstein 09:41:51 6/26/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 and MSVC 5 pro

Posted by Richard Drennen on June 15, 1998 at 22:55:31:

In Reply to: Re: DirectX 5.0 and MSVC 5 pro posted by Scott on January 26, 1998 at 13:52:59:

: I had exactly that problem, I needed to put,
: #define INITGUID at the top of your main cpp file,
: and I was getting other 2001 link errors, so I just
: some of the lib file and shuved them in my project
: directory, and added the file dxguid.lib, to the cpp
: folder in my project with the rest of the cpp files...

: worked for me,

Follow Ups:

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by Gunyruss on June 15, 1998 at 23:20:14:

In Reply to: Re: where can I download direct X 5.0 posted by cheng on February 07, 1998 at 11:31:51:

: : where I can get direct X 5.0 please a answer

Follow Ups:

Post a Followup

Name:


Re: Clipper:Help,Help, I Desperately need help

Posted by Ravi Joshi on June 16, 1998 at 00:29:01:

In Reply to: Re: Clipper:Help,Help, I Desperately need help posted by 0x1CE on June 11, 1998 at 18:17:17:

Thanx for the message and advice.
You said clippers are of not much use if used in
full screen mode. IF I use my own version of
LineDraw algorithm, is there any way of trying to
stop the application from writing past the surface
(not mathematically). Can the clippers be used for
this purpose?
And is it absolutely neccessary to attach the
clipper to the window. If I attach the clipper to
the surface, is it possible to blit beyond the
limits of the surafce?
Pl let me know.
Thanx..
Ravi Joshi.
India.

Follow Ups:

  • Re: Clipper:Help,Help, I Desperately need help 0x1CE 03:36:17 6/18/98 (1)
    • Re: Clipper:Help,Help, I Desperately need help 0x1CE 19:02:12 6/18/98 (0)

Post a Followup

Name:


Re: DirectX 6.0

Posted by KENG on June 16, 1998 at 00:50:31:

In Reply to: DirectX 6.0 posted by Major Tom on June 13, 1998 at 12:30:25:

: Hi everybody
: can someone tell me: where can I get DirectX 6.0 ??

: Thanks

Follow Ups:

Post a Followup

Name:


FAST Input Read from Mouse

Posted by Mehmet Gokturk on June 16, 1998 at 01:21:47:

Hi,
I am trying to get mouse samples as fast as possible.
The regular GetCursorPos(POINT) of win32 gives me no better
than 30 milliseocnds with serial standrd mouse.
I need to sample at 10millisecond or less.
question : Does DirectX enable it? (Scrawl seems to use
events ???)
Does anybody know ANY OTHER method to speed up the
cursor readout.
I am using it for my research topic, any input welcomed
(also mail me the answer since i may not read here everyday)

Follow Ups:

  • Re: FAST Input Read from Mouse 0x1CE 03:38:50 6/18/98 (1)
    • Re: FAST Input Read from Mouse Gunnar Holm 08:42:25 7/05/98 (0)

Post a Followup

Name:


Re: help with DirectDraw2::SetDisplayMode()

Posted by Ravi Joshi on June 16, 1998 at 01:37:32:

In Reply to: help with DirectDraw2::SetDisplayMode() posted by Pontus Lundwall on June 12, 1998 at 12:12:50:

This is the problem even I am facing.
I am trying to search for the solution.
If I get the answer, i shall post it on the
forum. If you happen to find the answer before
I do( highly unlikely),Just put on the forum.
Thanx.
Ravi Joshi.

Follow Ups:

  • Re: help with DirectDraw2::SetDisplayMode() Pontus Lundwall 12:29:56 6/16/98 (0)

Post a Followup

Name:


Re: Games

Posted by fragmo on June 16, 1998 at 03:07:05:

In Reply to: Games posted by Me on June 15, 1998 at 13:51:25:

: Has anyone actually made a quake style game in D3D? Is it even possible given the funtions we have to work with?

there's source code that will load and display quake levels
at http://www.microsoft.com/directx/resources/d3dquake.htm

Follow Ups:

Post a Followup

Name:


Re: Can't get DirectSound to link

Posted by jason lucking on June 16, 1998 at 10:35:56:

In Reply to: Can't get DirectSound to link posted by James on February 07, 1998 at 17:17:04:

: Im having a problem getting the DirectSound library
: to link correctly. i linked DSound.lib into my project
: and #include but it starts out by saying:
: 'LPWAVEFORMATEX' : missing decl-specifiers
: and then goes on to do 46 more errors many of which
: look like D3D stuff. im compiling with VC++4 using MFC.
: Any help would be greatly appreciated.
: Also i can't find many plases to find stuff on
: DirectSound on the web... anyone got any URLs or good
: books?
: Thanks a LOT,
: --James

Follow Ups:

Post a Followup

Name:


Re: Can't get DirectSound to link

Posted by jason lucking on June 16, 1998 at 10:35:58:

In Reply to: Can't get DirectSound to link posted by James on February 07, 1998 at 17:17:04:

: Im having a problem getting the DirectSound library
: to link correctly. i linked DSound.lib into my project
: and #include but it starts out by saying:
: 'LPWAVEFORMATEX' : missing decl-specifiers
: and then goes on to do 46 more errors many of which
: look like D3D stuff. im compiling with VC++4 using MFC.
: Any help would be greatly appreciated.
: Also i can't find many plases to find stuff on
: DirectSound on the web... anyone got any URLs or good
: books?
: Thanks a LOT,
: --James

Follow Ups:

Post a Followup

Name:


Re: help with DirectDraw2::SetDisplayMode()

Posted by Pontus Lundwall on June 16, 1998 at 12:29:56:

In Reply to: Re: help with DirectDraw2::SetDisplayMode() posted by Ravi Joshi on June 16, 1998 at 01:37:32:

: If you happen to find the answer before
: I do( highly unlikely),Just put on the forum.
: Thanx.
: Ravi Joshi.

;)
Yeah, I'll do that. There _has_to_be a solution to this problem, it is just to common..

Follow Ups:

Post a Followup

Name:


The GetVertices function

Posted by Me on June 16, 1998 at 20:59:03:

How the heck do you use the GetVertices function? I'm talking about the one that is a member of the IDirect3DRMMeshBuilder structure. Not the IDirect3DRMMesh one. I know how to use that. I can't figure out what all of the variables it's wants are! I don't have a clue how to use it. The SDK doumentation is NO help. It tells you it wants the address of a D3DVECTOR array for one of the parameters, but if you give it the adress of an array it is considered an invalid parameter. What is going on?!? I am getting pretty frustrated, because I need the the vertices for my collision detection, but I don't know how to get all of them. Can ANYONE help me???? Please!!!

Thanks in advance if you can help!

Follow Ups:

  • Re: The GetVertices function Billy 00:24:58 6/19/98 (0)

Post a Followup

Name:


from rm to rm2

Posted by Eric Fournier on June 17, 1998 at 00:16:24:

I programmed an application in rm mode and now i would like to pass to direct3drm2 mode.
I tried to change the names of the device and everything b adding a "2"
to the classes specified in the docs, but obviously, it does not work!
Can someone tell me what steps I should follow to do that?

Thanks in advance

Follow Ups:

  • Re: from rm to rm2 Fred 12:35:03 6/21/98 (0)

Post a Followup

Name:


Re: Reverse playback of video via DirectShow

Posted by Robert Tomlin on June 17, 1998 at 08:54:40:

In Reply to: Reverse playback of video via DirectShow posted by Thomas Krim on May 10, 1998 at 04:53:42:

: Hi Guys,

: has anybody a suggestion to playback a video in reverse order? Although the doc's say that it is possible to give the IMediaSeeeking Interface a
: negative value (-1) via SetRate(), it returns an
: INVALID_ARGUMENT. Trying to skip backwards through the avi-file via SetPosition() doesn't help, because this doesn't run smoothly.

: Any suggestions are very welcome.

: TIA
: Thomas Krim

According to KB article Q157060 the ActiveMovie
1.0 SDK has among other bugs no support for negative
playrates using the IMediaSeeking interface !!

Ain't Microsoft great !!!!
I am unsure if this has been fixed for DirectShow ?

Hope this helped

Rob Tomlin

Follow Ups:

Post a Followup

Name:


Re: Visual Basic and Direct X

Posted by Gustavo Herrera Molina on June 17, 1998 at 19:46:51:

In Reply to: Visual Basic and Direct X posted by David on June 09, 1998 at 22:27:41:

: Ok, how do I make animation in Visual Basic (any version) with Direct X. Actually I dont care if it's Direct X or Not. Dp you know a link or anything that i can find out. THank you sooo much for even reading this far.�

Follow Ups:

Post a Followup

Name:


Re: WHICH COMPILER IS BEST 4 DIRECTX5?

Posted by PAULO MARTINHO on June 17, 1998 at 20:24:00:

In Reply to: Re: WHICH COMPILER IS BEST 4 DIRECTX5? posted by Wolfgang R�ssler on March 11, 1998 at 06:25:35:

:
: : : OK guys simple one.... Which is the best, most compatable compiler for DIRECT X 5?

: I'm using Watcom C/C++ 11.0. In my opinion the Watcom-Compiler is the best one. It generates the fastest code I've ever seen.

Follow Ups:

Post a Followup

Name:


I need drivers!!!!

Posted by Wade on June 17, 1998 at 20:24:54:

I have an "Opti Plug-N-Play Sound System" sound card and I'm looking for DirectX 5-certified drivers so that I can play Panzer Commanders. Can anyone help me?

Follow Ups:

Post a Followup

Name:


Dialog Boxes in DirectX

Posted by Dan on June 17, 1998 at 23:01:35:

What's the best way to dialog boxes in DirectX?
I've tried using FlipToGDISurface() but that doesn't
work so great.

Thanks in advance.

Follow Ups:

  • Re: Dialog Boxes in DirectX Andreas 15:27:49 7/07/98 (0)

Post a Followup

Name:


Installing Jaton Video 77TV card and having problems

Posted by PK on June 18, 1998 at 01:49:00:

I've been trying to install a Jaton card with 4mb sgram and I'm having problems. My on board S3 Trio64V+ seems to keep on eating resourses from my new card. What I want to know is how to disable the card totally in WIN 95. Thanx

Follow Ups:

Post a Followup

Name:


Re: Clipper:Help,Help, I Desperately need help

Posted by 0x1CE on June 18, 1998 at 03:36:17:

In Reply to: Re: Clipper:Help,Help, I Desperately need help posted by Ravi Joshi on June 16, 1998 at 00:29:01:

Actually, clippers are of NO use in full screen mode.
The only reason they exist is to prevent apps running
in windowed mode from writing outside of their window.
The only way to keep your line writing algorithm from
writing outside of the screen is to incorporate some
sort of collision testing with the edges of the screen.
The best way to do this might be to leave your algorithm
alone and have your line drawing function test to make
sure the line's endpoints are within the bounds of the
screen. If the endpoints fall outside of the screen
you just have to set them equal to the screen limits and
draw your line as usual. Hope that made sense;)

: Thanx for the message and advice.
: You said clippers are of not much use if used in
: full screen mode. IF I use my own version of
: LineDraw algorithm, is there any way of trying to
: stop the application from writing past the surface
: (not mathematically). Can the clippers be used for
: this purpose?
: And is it absolutely neccessary to attach the
: clipper to the window. If I attach the clipper to
: the surface, is it possible to blit beyond the
: limits of the surafce?
: Pl let me know.
: Thanx..
: Ravi Joshi.
: India.

Follow Ups:

  • Re: Clipper:Help,Help, I Desperately need help 0x1CE 19:02:12 6/18/98 (0)

Post a Followup

Name:


Re: FAST Input Read from Mouse

Posted by 0x1CE on June 18, 1998 at 03:38:50:

In Reply to: FAST Input Read from Mouse posted by Mehmet Gokturk on June 16, 1998 at 01:21:47:

Use DirectInput. That's what it's there for.

: Hi,
: I am trying to get mouse samples as fast as possible.
: The regular GetCursorPos(POINT) of win32 gives me no better
: than 30 milliseocnds with serial standrd mouse.
: I need to sample at 10millisecond or less.
: question : Does DirectX enable it? (Scrawl seems to use
: events ???)
: Does anybody know ANY OTHER method to speed up the
: cursor readout.
: I am using it for my research topic, any input welcomed
: (also mail me the answer since i may not read here everyday)

Follow Ups:

  • Re: FAST Input Read from Mouse Gunnar Holm 08:42:25 7/05/98 (0)

Post a Followup

Name:


Re: Games

Posted by 0x1CE on June 18, 1998 at 03:43:15:

In Reply to: Games posted by Me on June 15, 1998 at 13:51:25:

I believe that Unreal was written in D3D. In addition
to being a "Quake killer", it is also supposedly Micro$oft's
answer to OpenGL.

: Has anyone actually made a quake style game in D3D? Is it even possible given the funtions we have to work with?

Follow Ups:

  • Re: Games Fred 12:18:45 6/21/98 (1)
    • Re: Games 0x1CE 23:25:43 6/22/98 (0)

Post a Followup

Name:


Re: Direct Show "How can I play a movie in full-screen?"

Posted by Laurent TAUPIN on June 18, 1998 at 10:35:47:

In Reply to: Direct Show "How can I play a movie in full-screen?" posted by Seong Wan Kim on May 26, 1998 at 22:59:13:

if you create a
IGraphBuilder *piGB;

Test to call it with this syntax :

pigb->Put_FullScreenMode(true);

just after your

piGB->RenderFile(...);

It will work properly (it does with me). ;-)

By the way, did you know how to play video
AND controlling all the streams (buffers) : header,
data, end ??

Thanks....

If someone know, thanks to mail me at :

fearless@imaginet.fr

Follow Ups:

Post a Followup

Name:


Re: Multimedia Streaming

Posted by Laurent TAUPIN on June 18, 1998 at 10:39:21:

In Reply to: Multimedia Streaming posted by robert tomlin on May 26, 1998 at 11:11:12:

Sorry, I can't answer your question, but I've
one for you ;-)
Do you how to play video while controlling
everything in a stream (header, data, end)
(never mind if I can't play it on a DC...).
I'm lookin for a really runable example that
will explain that, because I want to put my
own header before, by example, a MPEG header.

Thanks by advance..

fearless@imaginet.fr

Follow Ups:

Post a Followup

Name:


How do you use Hardware Acceleration?

Posted by Snowman on June 18, 1998 at 13:53:29:

How do you use Hardware Acelleration in RM? Does anyone have sample code? Is it even possible? Or do you have to use intermediate mode?

Also is there a way to use 3DFX commands with Direct3D, or do you have to program with glide?

Thanks for any help.

-Snowman

Follow Ups:

  • Re: How do you use Hardware Acceleration? Fred 12:52:13 6/21/98 (2)
    • Re: How do you use Hardware Acceleration? Snowman 14:13:37 6/21/98 (1)
      • Re: How do you use Hardware Acceleration? Fred 01:36:23 6/22/98 (0)

Post a Followup

Name:


How can I load Same Animation Multiple times from *.x file

Posted by zain on June 18, 1998 at 16:13:28:

The above subject is my only question.

Thanks in advance.

Follow Ups:

Post a Followup

Name:


Re: Clipper:Help,Help, I Desperately need help

Posted by 0x1CE on June 18, 1998 at 19:02:12:

In Reply to: Re: Clipper:Help,Help, I Desperately need help posted by 0x1CE on June 18, 1998 at 03:36:17:

Just found out you can use a clipper for what you need.
You just have to setup a cliplist and attach it to
your clipper. For a good tutorial on this go the the
"Journals of a Direct X Junkie" website. Easy enough
to understand, but I couldn't get it to work. Hope
you have better luck than I did.

: Actually, clippers are of NO use in full screen mode.
: The only reason they exist is to prevent apps running
: in windowed mode from writing outside of their window.
: The only way to keep your line writing algorithm from
: writing outside of the screen is to incorporate some
: sort of collision testing with the edges of the screen.
: The best way to do this might be to leave your algorithm
: alone and have your line drawing function test to make
: sure the line's endpoints are within the bounds of the
: screen. If the endpoints fall outside of the screen
: you just have to set them equal to the screen limits and
: draw your line as usual. Hope that made sense;)

:
: : Thanx for the message and advice.
: : You said clippers are of not much use if used in
: : full screen mode. IF I use my own version of
: : LineDraw algorithm, is there any way of trying to
: : stop the application from writing past the surface
: : (not mathematically). Can the clippers be used for
: : this purpose?
: : And is it absolutely neccessary to attach the
: : clipper to the window. If I attach the clipper to
: : the surface, is it possible to blit beyond the
: : limits of the surafce?
: : Pl let me know.
: : Thanx..
: : Ravi Joshi.
: : India.

Follow Ups:

Post a Followup

Name:


DirectSound crashes in MFC

Posted by Daniel on June 18, 1998 at 20:58:31:

I am coding DirectSound demo program in MFC using VC++
version5.0. The program keeps crashing when it
executes the Stop method. Does anyone have any ideas
on how to fix this problem?

Thanks

Follow Ups:

Post a Followup

Name:


Re: DirectX5

Posted by ZAMIR FAQIRYAR on June 18, 1998 at 21:54:57:

In Reply to: Re: DirectX5 posted by serge poirier on February 19, 1998 at 22:07:28:

: : I downloaded a demo version of BUBLESHOOTER97
: : with DirectX5 download included and it worked fine.
: : I then purchased the game, uninstalled the demo as per
: : instructions but the purchased game freezes my whole
: : system, screen, keyboard, mouse et al. Checking for
: : compatability with DirectX5 indicates there is no hard-
: : ware support for the Primary Display Driver, Primary
: : sound Driver and Sound System Player. Why did the first
: : DirectX5 download work but this one won't and what do I
: : do about the problem?
: : Thank you, any help would be greatly appreciated.
: : Lois Nicholls

Follow Ups:

Post a Followup

Name:


Clay? Are you still there buddy? Please help me...

Posted by Me on June 19, 1998 at 00:19:28:

In Reply to: some sample code posted by Clay on June 12, 1998 at 21:27:36:

Umm...Clay I need some help here. I went through all of your code, and It turns out that I don't have a 3D Accellerator. I have a Voodo Rush based card. (I have an Adrenaline Rush 3D) When I use the code that you gave me It skips past the HAL device and goes to the RGB device. I don't know what I'm doing wrong. The examples in the DirectX5 SDK can use HAL devices, but I can't. What am I doing wrong?

In your code you have a part that says:

// enumerate D3D drivers/devices
// this is not necessary anymore because
// of the way the interfaces are created

Display3DCaps();

Am I supposed to do something there, because there sure isn't any function called:
Display3DCaps();

I hope that part isn't important (I left it out of my code.)

Please help me Clay!

-Snowman (Me)

Follow Ups:

  • busy at work... Clay 07:22:16 6/23/98 (1)
    • Re: busy at work... Me 23:32:12 7/05/98 (0)

Post a Followup

Name:


Probs with Lobby

Posted by Gayathri.Kamath on June 19, 1998 at 00:23:04:

I could never run the lobby related samples of Directx
properly.Though the lobby server was run,the client was
not able to get Connection settings from Server.I tried
running bellhop,dplaunch .According to Directx these
client apps should not show up any dialogs to enter the
ip address or other settings,if they are connected using lobby server.
But i am getting all these dialogs.I could debug and find that
these are purely working like any other Directplay applcn and
are not working like the way the readme for these applications say.
Has anyone got such a problem..

Follow Ups:

Post a Followup

Name:


Re: The GetVertices function

Posted by Billy on June 19, 1998 at 00:24:58:

In Reply to: The GetVertices function posted by Me on June 16, 1998 at 20:59:03:

Use the CreateMesh function (IDirect3DRMMeshBuilder) to create a regular mesh, you said that you know how to use the function with the IDirect3DRMMesh object. Glad I could help.

Follow Ups:

Post a Followup

Name:


About DPID struct

Posted by Gayathri.Kamath on June 19, 1998 at 00:43:36:

Hi,
I would like to hide the DPID struct used in the DPlay.
But no information is available on how this is created or
what are elements of this structure?
How would i generate a GUID without using a uuidgen.exe
or CoCreateInstance function.Is it possible to read the network
card number,ip address and fill the GUID structure.If so ,
what is the format for doing that.

Follow Ups:

Post a Followup

Name:


Any DirectX...

Posted by Johnny on June 19, 1998 at 08:53:27:

I need DirectX with Creative 3D Blaster Woodoo2 support.

Thaks.

Follow Ups:

Post a Followup

Name:


Re: DirectX 6.0

Posted by Michael on June 19, 1998 at 19:22:46:

In Reply to: DirectX 6.0 posted by Major Tom on June 13, 1998 at 12:30:25:

: Hi everybody
: can someone tell me: where can I get DirectX 6.0 ??

: Thanks

Follow Ups:

Post a Followup

Name:


DirecT3D, Vertices

Posted by JS on June 20, 1998 at 08:09:25:

Hello,
Does anyone know how to create a 3D object by
adding vertices into the meshbuilder.
I have tried but i end up with nothing.

If someone has the answer please respond.
Thank you.

Follow Ups:

Post a Followup

Name:


Re: Is non-alpha transparency possible?

Posted by Fred on June 21, 1998 at 11:46:46:

In Reply to: Is non-alpha transparency possible? posted by Fragmo on June 15, 1998 at 00:47:03:

You can use ColorKey transparency.

: is there a way to do transparency without using alpha blending
: in d3d? my 3d card doesn't support alpha blending

Follow Ups:

Post a Followup

Name:


Re: Retained Mode Texture Loading, Part II

Posted by Fred on June 21, 1998 at 12:01:05:

In Reply to: Retained Mode Texture Loading, Part II posted by Larry Weinstein on June 15, 1998 at 21:14:12:

Hi, me again
Sorry i didnt check this page for a while, i was busying at the DX6 beta testing in the past 2 weeks. Recently, I discovered the same problem (as yours) on one of our testing machine, [a pII233 +Riva128]. I haven't figured it out yet, but [as a suggestion] you can try set the colorkey when you creating your texture ddraw surface.

I m still playing around with the latest RIVA driver [enable this, disable that, enable that, disable this, why the hell they got too many thing to set in the driver]. One of the possiblity is the program use the incorrect texture format. Try your program on different cards see if it work and try with different texture format (ARGB4444, ARGB1555, RGB565..etc).

[We have tried ours on voodoo/voodoo2/i740, it works perfectly, just not work with RIVA! :-( ]

Regards

Fred

//************************
: I asked about loading textures in RM a few weeks ago and receive a reply from "Fred" (thanks) indicating that creating a surface and then using CreateTextureFromSurface was the way to go. This matched my own thinking. There was even a routine to do just this in the SDK (DDLoadBitmap.) The problem is that textures created in this way do not behave properly in all situations, at least when a hardware driver is being used. For example, the command to SetDecalTransparency does not work on decals generated in this manner. The problems come about only when my STB Velocity / Riva 128 hardware driver is being used. So, here are the questions. What is the best way to load textures into video card memory and system memory when working in RM? Has anyone else seen this behavior on any video cards (STB or otherwise?) Is anyone using this method successfully with other hardware?

Follow Ups:

  • Re: Retained Mode Texture Loading, Part II Larry Weinstein 09:41:51 6/26/98 (0)

Post a Followup

Name:


Re: Converting files

Posted by fred on June 21, 1998 at 12:11:21:

In Reply to: Converting files posted by Me on June 12, 1998 at 19:06:54:

Have you tried "PolyTrans"?? (only cost around US$500.)

: Is there a convdxf utility, similar to the conv3ds included in the DirectX 5 SDK? I need to convert *.DXF files straight to *.X files. Is there a graphics converter that anyone can recommend? Is there a CHEAPER 3D program that will Save and Load 3DS files?

: Thanks to cayone in advance who can answer any of these questions.

Follow Ups:

  • Re: Converting files Me 16:54:07 6/23/98 (1)
    • Re: Converting files KC 17:10:52 7/06/98 (0)

Post a Followup

Name:


Re: .x files

Posted by fred on June 21, 1998 at 12:14:15:

In Reply to: .x files posted by zain on June 02, 1998 at 14:45:10:

you should use " -A" , NOT "-a".

: How can i convert animated file created by 3d studio for directx. i have used this command but it gives the error message while loading .x file.

: Command:
: conv3ds -a -x myfile.3ds

: thanks in advance.

Follow Ups:

Post a Followup

Name:


Re: Games

Posted by Fred on June 21, 1998 at 12:18:45:

In Reply to: Re: Games posted by 0x1CE on June 18, 1998 at 03:43:15:

Up to now, 'Unreal' is using the native 3D APIs, either Glide (for 3dfx) or PowerSGL (for powerVR). The openGL version is coming in the next few weeks. no sign for its D3D version yet.

: I believe that Unreal was written in D3D. In addition
: to being a "Quake killer", it is also supposedly Micro$oft's
: answer to OpenGL.

: : Has anyone actually made a quake style game in D3D? Is it even possible given the funtions we have to work with?

Follow Ups:

  • Re: Games 0x1CE 23:25:43 6/22/98 (0)

Post a Followup

Name:


Re: from rm to rm2

Posted by Fred on June 21, 1998 at 12:35:03:

In Reply to: from rm to rm2 posted by Eric Fournier on June 17, 1998 at 00:16:24:

To obtain a pointer to IDirect3DRM2, you need to query interface from IDirect3DRM. (query for 'IID_IDirect3DRM2', check DXSDK docs for more detail).

I have no idea how you init D3D/DDraw device in your program, so i can't really help. [changing all the device pointer to the new interface is not enough to port your program to the new interface. be sure to double check EVERY CALL you made to the new interface [ the parameters, the return value...etc].

: I programmed an application in rm mode and now i would like to pass to direct3drm2 mode.
: I tried to change the names of the device and everything b adding a "2"
: to the classes specified in the docs, but obviously, it does not work!
: Can someone tell me what steps I should follow to do that?

: Thanks in advance

Follow Ups:

Post a Followup

Name:


Re: PLEASE HELP!! Direct3D is wierd!

Posted by Fred on June 21, 1998 at 12:45:12:

In Reply to: PLEASE HELP!! Direct3D is wierd! posted by Sanghyun Lee on June 08, 1998 at 10:26:55:

The *DEMO* version of 'PolyTrans' would delete one polygon in every five polygons. Therefore, you would not get any correct result.

I though the polyTran can directly convert the Truespace file to .X format ??[can it??]

if you want 3ds file, better put your money on 3ds R4 then on the stupid Truespace.

[i assume you are using "demo" version of polytran because you said *download*. Sorry if i am wrong]

if you want to use conv3ds to get a frame:
use conv3ds myFile.3ds
if you want to get a mesh
use conv3ds -m myFile.3ds
if you want to get a animation
use conv3ds -A myFile.3ds
[assume you have a 3ds file call myFile.3ds]

: I don't have the money to buy anything but I'm trying
: to make something with d3drm. I have the DirectX 3 sdk
: (I know it's outdated)

: When I create a polygon mesh and display it, (face &
: vertex data from .scn file truespace 2 demo)
: I made a little scnconverter thing..
: the polygons from the back and front are both
: visible and-it's weird. Sometimes the polygons toward
: you are not drawn and the polygons in the back are...
: What's going on?
: Does this happen if
: two or more faces share a vertex (as in the .scn files)?

: Also, how can I convert .3ds to .x

: I downloaded Rhino3d and exported to 3ds
: and ran conv3ds but it just crashes.

: Please help. Please e-mail also if possible.

Follow Ups:

Post a Followup

Name:


Re: How do you use Hardware Acceleration?

Posted by Fred on June 21, 1998 at 12:52:13:

In Reply to: How do you use Hardware Acceleration? posted by Snowman on June 18, 1998 at 13:53:29:

: How do you use Hardware Acelleration in RM? Does anyone have sample code? Is it even possible? Or do you have to use intermediate mode?

take a look at DXSDK samples, they tell you how to use HAL in RM/IM, Windowed/Full Screen

: Also is there a way to use 3DFX commands with Direct3D, or do you have to program with glide?

what is a *3DFX command* you are refering to?

Follow Ups:

  • Re: How do you use Hardware Acceleration? Snowman 14:13:37 6/21/98 (1)
    • Re: How do you use Hardware Acceleration? Fred 01:36:23 6/22/98 (0)

Post a Followup

Name:


Re: How do you use Hardware Acceleration?

Posted by Snowman on June 21, 1998 at 14:13:37:

In Reply to: Re: How do you use Hardware Acceleration? posted by Fred on June 21, 1998 at 12:52:13:

: take a look at DXSDK samples, they tell you how to use HAL in RM/IM, Windowed/Full Screen

They don't even have the source code for some of their examples. I have tried looking through it, but I don't know where they setup the devices. Is there a specific example that you can reccommend I look at?

: what is a *3DFX command* you are refering to?

I am talking about optimizing the games to use Voodoo and Voodoo2 cards. Is there a special way to use that? Does 3DFX have specific functions that are used to optimize the specific 3D accelerators?

Thanks
-Snowman

Follow Ups:

  • Re: How do you use Hardware Acceleration? Fred 01:36:23 6/22/98 (0)

Post a Followup

Name:


How do you sav the texture on a face?

Posted by Snowman on June 21, 1998 at 14:21:39:

When I use the meshbuilder's Save function (using the SAVEALL parameter) RM doesn't save the texture on the faces. I made a program that allows you to pick a face with the mouse, and apply a texture or a color to it. When I save the mesh, and reload it the colors are on the right faces, but the faces that had textures on them are blank now! how do you save the textures, and not just the colors?

Any help is appreciated! Thanks!

-Snowman

Follow Ups:

Post a Followup

Name:


Writing ActiveX ctrl:DirectSound, DirectShow on NT4.

Posted by andrew on June 22, 1998 at 01:29:13:

Hi All
I'm writing ActiveX Control that should implement the
following functionality:
play and record wav files
fast forward and rewind
change playback and winding speed
voice operated recording
I'm newer in DirectX and i'm looking for advice.
Is it possible to implement such functionality using
DirectSound or DirectShow? What is better to use for that
task?
This control should work on NT4 box.
TIA
Andrew

Follow Ups:

  • Re: Writing ActiveX ctrl:DirectSound, DirectShow on NT4. Ken Moore 16:15:26 6/28/98 (0)

Post a Followup

Name:


Re: How do you use Hardware Acceleration?

Posted by Fred on June 22, 1998 at 01:36:23:

In Reply to: Re: How do you use Hardware Acceleration? posted by Snowman on June 21, 1998 at 14:13:37:

The first tutorial in DXSDK on D3DRM will use HAL whenever it is available. This is the most simplest sample code and with a lot of explaination and comment for the source code. [take a look at 'HELWORLD' example in DXSDK Docs]

The sample codes come with DXSDK have everything you need to understand/program DirectX. [the problem of those sample code is they don't have enough documentation/comment]

If you really want to optimize the voodooo/v2 cards, forget about D3D, go with Glide. Up to now, the 3dfx D3D drivers is kinda suck, [suck in performance, lack in features..etc] To get the most out of voodoo, you will need Glide.

: They don't even have the source code for some of their examples. I have tried looking through it, but I don't know where they setup the devices. Is there a specific example that you can reccommend I look at?
: I am talking about optimizing the games to use Voodoo and Voodoo2 cards. Is there a special way to use that? Does 3DFX have specific functions that are used to optimize the specific 3D accelerators?

: Thanks
: -Snowman

Follow Ups:

Post a Followup

Name:


dx5 notworking

Posted by bb on June 22, 1998 at 22:01:13:

need to fin directx5 compatible with cirrus logic 5430PCI and soundlllw/SWT can anyone help

Follow Ups:

Post a Followup

Name:


Re: Games

Posted by 0x1CE on June 22, 1998 at 23:25:43:

In Reply to: Re: Games posted by Fred on June 21, 1998 at 12:18:45:

Hmmm....Could've sworn I saw an article somewhere saying that some head honcho from Micro$oft was working with the makers of Unreal. Oh, well. The OpenGL/DirectX debate hardly matters anymore anyway.

: Up to now, 'Unreal' is using the native 3D APIs, either Glide (for 3dfx) or PowerSGL (for powerVR). The openGL version is coming in the next few weeks. no sign for its D3D version yet.

: : I believe that Unreal was written in D3D. In addition
: : to being a "Quake killer", it is also supposedly Micro$oft's
: : answer to OpenGL.

: : : Has anyone actually made a quake style game in D3D? Is it even possible given the funtions we have to work with?

Follow Ups:

Post a Followup

Name:


Re: Transparent blt:ing

Posted by Selvakumar on June 22, 1998 at 23:26:08:

In Reply to: Transparent blt:ing posted by Andr�as K�hne on April 04, 1998 at 12:50:38:

You can create a see-through dialog by making each alternate pixel in the dialogs background bitmap into transparent. This will look very similar to alpha-blending. And its simple.

But remember, if you start with ODD pixel,as transparent, in first row, then you have to start with EVEN pixel in the second row and so on.

-Selva

: I know that this has already been in this forum, but I have a slightly different question:

: I want to create a see-through dialog box class for a game that I am righting in DirectX. I would like the dialog box to have a green background. This can be created by and:ing every pixel with the value 0x07E0 (which is the green part of the pixel value). I have created a routine that does this, but I think that DirectX should be able to do this for me. Also I would like it to be done without Hardware (alpha-blending).

Follow Ups:

Post a Followup

Name:


Changing the resolution in D3D??

Posted by Shai'tan on June 22, 1998 at 23:51:39:

How do you change from the default resolution ( 800x600 I think ) to 320x200 or whatever?

Any help would be hugely appreciated, as 800x600 is way slow....

Also, any optimization tips for making d3d faster??

Follow Ups:

  • Re: Changing the resolution in D3D?? Clay 06:33:34 6/24/98 (3)
    • I always forget something! Clay 06:35:15 6/24/98 (2)
      • Thanks dude! Shai'tan 20:59:43 6/24/98 (1)
        • Re: Thanks dude! Clay 07:22:37 6/29/98 (0)

Post a Followup

Name:


busy at work...

Posted by Clay on June 23, 1998 at 07:22:16:

In Reply to: Clay? Are you still there buddy? Please help me... posted by Me on June 19, 1998 at 00:19:28:

I'll get back to you on this. Here is a caveat I found last week: If the code I gave you uses the RGB device (vice the HAL), it will not run. The reason is because with the HEL, the Z-Buffer needs to be in system memory. I'm fixing that, time permitting.

I'll post the Display3DCaps() function later today or tomorrow. What it does is enumerate the device drivers on your system and pick one to use, it also used to display them in a dialog.

Anyhow, if you want, send an email and I'll zip up a bunch of stuff I wrote (it is pretty well commented) and send it to you.

Clay

Follow Ups:

  • Re: busy at work... Me 23:32:12 7/05/98 (0)

Post a Followup

Name:


RM / IM : DRAW PRIMITIVES

Posted by Frenchy FADGE on June 23, 1998 at 09:22:45:

Hello,
I try to use Immediate mode inside a complete source in retained mode.
All works as long I don't use draw primitives.
I found a sample but it uses execute buffers.

Is there a sample using Draw Primitives in Retained Mode ?

Thanks.

Follow Ups:

  • Re: RM / IM : DRAW PRIMITIVES Doug 20:44:26 6/28/98 (0)

Post a Followup

Name:


Z BUFFER Precision ?????

Posted by Frenchy FADGE on June 23, 1998 at 09:30:34:

Hello,
Is there a way to modify the Z Buffer Precision ?

Indeed I habe problems with my application: Objects which are closed are bad rendered (sometimes we saw One and others times the other, depend on the point of view).

If you understand my problem, Please tell me a way to bring my researches .

Thanks.

(FRANCE will win the football cup)

Follow Ups:

  • Re: Z BUFFER Precision ????? Frenchy FADGE 09:31:34 6/23/98 (2)
    • Re: Z BUFFER Precision ????? Sietze 16:04:56 6/23/98 (1)
      • Thanks but ... Frenchy FADGE 08:33:21 6/24/98 (0)

Post a Followup

Name:


Re: Z BUFFER Precision ?????

Posted by Frenchy FADGE on June 23, 1998 at 09:31:34:

In Reply to: Z BUFFER Precision ????? posted by Frenchy FADGE on June 23, 1998 at 09:30:34:

: Hello,
: Is there a way to modify the Z Buffer Precision ?

: Indeed I have problems with my application: Objects which are closed are bad rendered (sometimes we saw One and others times the other, depend on the point of view).

: If you understand my problem, Please tell me a way to bring my researches .

: Thanks.

: (FRANCE will win the football cup)

Follow Ups:

  • Re: Z BUFFER Precision ????? Sietze 16:04:56 6/23/98 (1)
    • Thanks but ... Frenchy FADGE 08:33:21 6/24/98 (0)

Post a Followup

Name:


PROGRESSIVE MESHES & TEXTURE MAPPING

Posted by Frenchy FADGE on June 23, 1998 at 09:41:08:

Hello,

I can't reach to apply a texture to a progressive mesh.
If someone know the answer.

An other problem:
As i saw that the load of a progressive mesh is very faster than a common mesh, I tried to save my meshes directly in progressive meshes.
The problem is that I can't find the way to describe the transformations in the .X file format.

Thanks for your understood.

(FRANCE will win the football world cup)

Follow Ups:

Post a Followup

Name:


Re: Z BUFFER Precision ?????

Posted by Sietze on June 23, 1998 at 16:04:56:

In Reply to: Re: Z BUFFER Precision ????? posted by Frenchy FADGE on June 23, 1998 at 09:31:34:

Hello,

You probably didn't attach the Z-Buffer properly
to the rendering target.
Also, did you create it with DDSCAPS_ZBUFFER
enabled?
I don't think that the precision is the problem here,
but that it simply doesn't work at all, as the
Z-Buffer defaults to 16 bits, which is more than
enough for games (1/65536 to be precise...;)).
I don't have the dox here, but you should have a
look at them, because that's where I got my
information and my Z-Buffer works...

Good luck,

Sietze Dijkstra

PS...HOLLAND (PAYS-BAS) WILL WIN THE WORLD CUP!!

: : Hello,
: : Is there a way to modify the Z Buffer Precision ?

: : Indeed I have problems with my application: Objects which are closed are bad rendered (sometimes we saw One and others times the other, depend on the point of view).

: : If you understand my problem, Please tell me a way to bring my researches .

: : Thanks.

: : (FRANCE will win the football cup)

Follow Ups:

  • Thanks but ... Frenchy FADGE 08:33:21 6/24/98 (0)

Post a Followup

Name:


UGH PLEASE QUIT!

Posted by Rod on June 23, 1998 at 16:48:08:

You guys are driving me nuts... please quit replying
to messages without actually replying... I am seeing
many message replies with just a quote of the orginal.
I know this has to but other people other than me.

Follow Ups:

Post a Followup

Name:


Re: Converting files

Posted by Me on June 23, 1998 at 16:54:07:

In Reply to: Re: Converting files posted by fred on June 21, 1998 at 12:11:21:

That's the problem, it cost $500!!! I do this as a hobby. I have looked into PolyTrans, it is $395. But I don't have that much to spend. Are there any cheaper ones?

Thanks

: Have you tried "PolyTrans"?? (only cost around US$500.)

Follow Ups:

  • Re: Converting files KC 17:10:52 7/06/98 (0)

Post a Followup

Name:


ESS drivers

Posted by Karen D. on June 23, 1998 at 19:21:56:

How can I get my drivers certified for DirectX?
I have a game that the tech help told me wouldn't play because my drivers weren't certified?
I'm not very savvy about this kind of stuff so any help would be appreciated.
They told me to update my driver 1868 but I'm at a loss as to how.
Help???????????????????

Follow Ups:

Post a Followup

Name:


ESS drivers

Posted by Karen D. on June 23, 1998 at 19:30:36:

How can I get my drivers certified for DirectX?
I have a game that the tech help told me wouldn't play because my drivers weren't certified?
I'm not very savvy about this kind of stuff so any help would be appreciated.
They told me to update my driver 1868 but I'm at a loss as to how.
Help???????????????????

Follow Ups:

Post a Followup

Name:


I can't get Borland C++ to work with the DirectX SDK!

Posted by Jonathan on June 23, 1998 at 19:35:25:

I'm using Borland C++ 4.5 and everytime I try to compile a sample from the SDK I get 28 linker errors that say something like this:

Linker Error: Unresolved external '_g_lpD3DRM' referenced from module RM.CPP

I copied the Borland C++ LIB files from the CD, and added them to the project. But I still get the same results.

Thanks for any help :)

Follow Ups:

  • Re: I can't get Borland C++ to work with the DirectX SDK! Doug 20:33:01 6/28/98 (0)

Post a Followup

Name:


Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2?

Posted by Jay (the answer) on June 23, 1998 at 23:40:11:

In Reply to: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? posted by M. Wagner on May 28, 1998 at 00:56:21:

http://microsoft.com/directx/download.asp

Follow Ups:

Post a Followup

Name:


Re: How to rotate a point around another point in 2-D space

Posted by Captain Conan on June 24, 1998 at 00:26:53:

In Reply to: How to rotate a point around another point in 2-D space posted by Emil Diego on May 25, 1998 at 23:19:11:

: I have a list of points which represents a polygon
: and i want to rotate the points around another point.
: This is all done in 2D space. I need an algorithm to
: do that. I haven;t had any luck so far coming up
: with my own :(

: Thanx in advance for the help
: Emil Diego
: ediego@bccom.com

Here's some VB code for rotating a set of points around the origin
this example only works for a four-point polygon, but it shouldn't be hard to modify

Public Sub Rotate(points() As clsPoint, theta As Double)

'theta is the angle(in radians) of rotation

Dim i As Integer
Dim t As clsPoint
For i = 0 To 3

'create a temporary point object
Set t = New clsPoint

'store rotated coordinates in t
t.x = points(i).x * Cos(theta) - points(i).y * Sin(theta)
t.y = points(i).x * Sin(theta) + points(i).y * Cos(theta)

'set the current points' new coordinates
Set points(i) = t

'clear t
Set t = Nothing

Next i

End Sub

Follow Ups:

Post a Followup

Name:


Re: Changing the resolution in D3D??

Posted by Clay on June 24, 1998 at 06:33:34:

In Reply to: Changing the resolution in D3D?? posted by Shai'tan on June 22, 1998 at 23:51:39:

Use IDirectDraw2::SetDisplayMode()

: How do you change from the default resolution ( 800x600 I think ) to 320x200 or whatever?

There's a default?

: Also, any optimization tips for making d3d faster??

1) Software rendering of visual effects (gouraud shading, fog, alpha-transparency, etc.) is slow. Don't use it unless you have to.

2) IM is a lot faster than RM. DrawPrimitive() is relatively easy to use (more so than an execute buffer anyway) and you can better control the capabilities you use. Snag a good linear algebra book and use IM for speed.

3) if you're using IM, group "similar" polygons together so you use SetRenderState(), Begin/EndScene() and DrawPrimitive() as few times as possible.

4) if you really need speed (even on a Cyrix!) make a fixed point library and use fixed point math instead of floating point.

5) Use C (vice C++) for your rendering routines. The triple de-reference for virtual functions is death for real-time apps.

Clay

Follow Ups:

  • I always forget something! Clay 06:35:15 6/24/98 (2)
    • Thanks dude! Shai'tan 20:59:43 6/24/98 (1)
      • Re: Thanks dude! Clay 07:22:37 6/29/98 (0)

Post a Followup

Name:


I always forget something!

Posted by Clay on June 24, 1998 at 06:35:15:

In Reply to: Re: Changing the resolution in D3D?? posted by Clay on June 24, 1998 at 06:33:34:

6) a good design is the best optimization you can ever make.

Follow Ups:

  • Thanks dude! Shai'tan 20:59:43 6/24/98 (1)
    • Re: Thanks dude! Clay 07:22:37 6/29/98 (0)

Post a Followup

Name:


Re: directX5

Posted by n on June 24, 1998 at 07:21:39:

In Reply to: Re: directX5 posted by Mr.Goodbar on May 23, 1998 at 01:08:15:

: : my directx seems not to be working i can play certain games like monster truck maddness but no games that use directx5 i was wondering if i can reload or down load from another source iam new at computing so if anyone can help that would be greati dont know if this is important but i have a fairly new 233 gateway pent.2 thanks agin mike

Follow Ups:

Post a Followup

Name:


Re: Delphi DirectX articles wanted!

Posted by Christopher �zbek on June 24, 1998 at 08:00:13:

In Reply to: Delphi DirectX articles wanted! posted by Dean Ellis on May 27, 1998 at 10:56:48:

Hi I'm just programming in Delphi for Direct X and I'm using the Header Unit out of the DGC Kit. I have stumbled across a japanese Site which provided a DirectX sample and learned from this one... I forgot the adress. Mail me and I can send you this sample and perhaps also my own small code pieces.

Christopher

Follow Ups:

Post a Followup

Name:


Thanks but ...

Posted by Frenchy FADGE on June 24, 1998 at 08:33:21:

In Reply to: Re: Z BUFFER Precision ????? posted by Sietze on June 23, 1998 at 16:04:56:

Hello,
Thanks for the answer. Indeed i didn't create a ZBuffer surface at all.

But have you a little example to include Drawprimitive() Immediate mode in retained mode.

The problem is that I have to maintain a big program totally written in RM.

Thanks.

(FRANCE will win the football cup)

Follow Ups:

Post a Followup

Name:


Re: Visual Basic and Direct X

Posted by Frenchy FADGE on June 24, 1998 at 11:42:39:

In Reply to: Visual Basic and Direct X posted by David on June 09, 1998 at 22:27:41:

The best way is to make a DLL C++ or C with your DirectX code.
Then you call the DLL in your VB application with an handle to the window where the animation wil be displayed.
The problem is to have a shared memory of the same size (in VB and VC) to be able to communicate.

Ciao

(FRANCE will win the world football cup)

Follow Ups:

Post a Followup

Name:


Thanks dude!

Posted by Shai'tan on June 24, 1998 at 20:59:43:

In Reply to: I always forget something! posted by Clay on June 24, 1998 at 06:35:15:

Hey, thanks heaps for the tips. Hey, the only big difference between C++ and C in this sort of thing in the Vtbl or whatever isn't it? How much work will it take to put it back into C?

Thanks again!

Follow Ups:

  • Re: Thanks dude! Clay 07:22:37 6/29/98 (0)

Post a Followup

Name:


Re: Invert display on windows 95 / directdraw / dirvid

Posted by Ravi Joshi on June 25, 1998 at 03:56:32:

In Reply to: Invert display on windows 95 / directdraw / dirvid posted by Bigjohn on June 02, 1998 at 10:51:36:

You can perhaps try with StretchBlt in which I
think you have got some option of inverting the
bitmaps.
What you can do is to stretchblt the primary
surface to the backbuffer with inverted falg on
and then flip it onto the primary surface.

: Does any function or any shareware / tools can invert
: video output on windows 95 with directx 5.0?

Follow Ups:

Post a Followup

Name:


Getting DC on Offscreen surf doesn't work, Why?

Posted by Ravi Joshi on June 25, 1998 at 06:13:43:

HI to all.
I have a primary surface and a back buffer.
I also have an offscreen surface.
If I try to GetDC for the primary surface and back
surface, it works perfectly fine.
On the other hand, if I try the same with the offscreen
surface, the machine just hangs.
The control just doesn't seem to come out of GetDC. why?
Any of you folks have got the answer?
Pl post it on this forum.

Thanx..
Ravi Joshi.

Follow Ups:

  • Re: Getting DC on Offscreen surf doesn't work, Why? Doug 20:21:41 6/28/98 (2)
    • Re: How about BltFast? Ravi Joshi 05:27:00 6/29/98 (1)
      • Re: How about BltFast? Ravi Joshi 05:42:12 6/29/98 (0)

Post a Followup

Name:


Midi files, DirectMusic, Header files

Posted by Johnny Rotten on June 25, 1998 at 17:39:03:

How can I make all of my midi files a resource and still play them? Everytime I import a midi file as a resource, all I see is a bunch of raw data and any attempt to play the resource using multimedia libs doesn't work. Has anyone done this that can help? Will DirectMusic solve this problem and when will it be available?

Also, I am using a map that it generated at runtime from a very large array that I have put into a .h file so that it doesn't make my main .cpp file so darn big - the problem is when I select Make, it keeps recompiling the .h file everytime even though nothing has changed. How can I prevent the compiler from doing this without making my map file into a .cpp file and linking it in?

Thanks,

Johnny

Follow Ups:

Post a Followup

Name:


GetSurfaceDesc on offscreen surfaces

Posted by Ravi Joshi on June 26, 1998 at 04:54:09:

Hi to all.
I have a primary surface, a backbuffer and an offscreen surface.
The GetSurfaceDesc() function when called should take a ddsd as
parameter and fill it will the information about the surface.
I tried this on the offscreen surface. But after the function is
called the lpSurface in the ddsc in comming out to be NULL.
Now I want to find out why it is happening and I also want to
find out if this function is entirely implemented in DirectX at all.

If you the answer, pl post it or send me a mail at
joshiobjects@hotmail.com

Thanx..
Ravi Joshi

Follow Ups:

Post a Followup

Name:


Re: Retained Mode Texture Loading, Part II

Posted by Larry Weinstein on June 26, 1998 at 09:41:51:

In Reply to: Re: Retained Mode Texture Loading, Part II posted by Fred on June 21, 1998 at 12:01:05:

Fred:

This is getting strange. I discovered what the missing element was with regard to the RIVA 128, but have found that I can't get surface based textures to work with voodoo2. For the RIVA, specifying the PIXELFORMAT solved the problem. (Note: on one computer, this wasn't necessary, but was on another, though both had the same STB card/drivers, etc.) I would dearly like to see the code to get this to work with the voodoo2 and other chips. Can you e-mail something to me? I can send you what I am doing with the RIVA in reply. (Your suggestion about the texture format may be on the money, since that is part of PIXELFORMAT.)
I had thought that using GetSurfaceDesc on the primary surface to set up DDSURFACEDESC would be a good approach, but so far that hasn't worked.

: Hi, me again
: Sorry i didnt check this page for a while, i was busying at the DX6 beta testing in the past 2 weeks. Recently, I discovered the same problem (as yours) on one of our testing machine, [a pII233 +Riva128]. I haven't figured it out yet, but [as a suggestion] you can try set the colorkey when you creating your texture ddraw surface.

: I m still playing around with the latest RIVA driver [enable this, disable that, enable that, disable this, why the hell they got too many thing to set in the driver]. One of the possiblity is the program use the incorrect texture format. Try your program on different cards see if it work and try with different texture format (ARGB4444, ARGB1555, RGB565..etc).

: [We have tried ours on voodoo/voodoo2/i740, it works perfectly, just not work with RIVA! :-( ]

:
: Regards

: Fred

:
: //************************
: : I asked about loading textures in RM a few weeks ago and receive a reply from "Fred" (thanks) indicating that creating a surface and then using CreateTextureFromSurface was the way to go. This matched my own thinking. There was even a routine to do just this in the SDK (DDLoadBitmap.) The problem is that textures created in this way do not behave properly in all situations, at least when a hardware driver is being used. For example, the command to SetDecalTransparency does not work on decals generated in this manner. The problems come about only when my STB Velocity / Riva 128 hardware driver is being used. So, here are the questions. What is the best way to load textures into video card memory and system memory when working in RM? Has anyone else seen this behavior on any video cards (STB or otherwise?) Is anyone using this method successfully with other hardware?

Follow Ups:

Post a Followup

Name:


Finding Screen Coordinates of Mesh Vertices

Posted by Tycho on June 26, 1998 at 18:47:26:

I've been able to define a mesh, render it, and draw
it to a window using DirectX 3. Now I was wondering
if there was a simple way to find the screen coordinates of the mesh so that when the the user clicks in the window, I could find which (if any) polygon face he had clicked on.

Better yet, is there a function that handles this type of problem specifically? Like a function to which I pass the coordinates of the mouse click, and the appropriate surface, and it returns the ID of the polygon that was selected. I know OpenGL has one, but maybe DirectX is lax in this area...

Follow Ups:

  • Re: Finding Screen Coordinates of Mesh Vertices Doug 19:24:33 6/28/98 (0)

Post a Followup

Name:


Textures in Immediate Mode

Posted by Shai'tan on June 27, 1998 at 02:52:13:

All the example code I can find loads a texture from a resource, using a surface to create the Texture2 interface. Is there any way to still use the surface method, but instead load the texture from a file??
Ie, not using MFC?

Any help hugely appreciated !!

Follow Ups:

  • Re: Textures in Immediate Mode Doug 20:05:17 6/28/98 (0)

Post a Followup

Name:


Re: DirectX 6.0

Posted by Max Kovacs on June 27, 1998 at 06:00:00:

In Reply to: DirectX 6.0 posted by Major Tom on June 13, 1998 at 12:30:25:

: Hi everybody
: can someone tell me: where can I get DirectX 6.0 ??

: Thanks

Follow Ups:

  • Re: DirectX 6.0 hj 04:37:12 7/07/98 (0)

Post a Followup

Name:


IDirect3DDevice2 No Pick(), Mouse To World?

Posted by Doug on June 27, 1998 at 19:04:08:

Does anyone know of a way to take mouse coords and change them to world coords?

I'm using DX5 IDirect3DDevice2 Draw Primitive and it does not use execute buffers and does not support Pick() or GetPickRecords() methods.

Any help would be great...

Doug

Follow Ups:

Post a Followup

Name:


speed of DirecSound mixing ?

Posted by Pontus Lundwall on June 27, 1998 at 19:23:39:

Is something very slow with DirectSound Play? When i issue a sample to start playing, the whole game is slowed down (like it is missing a frame or something). I only set the primbuffer to 11khz 8 bit 1 channel??!

It can't be that slow, can it? ( Im using an SB AWE32 )

Follow Ups:

Post a Followup

Name:


I know where to get 5.2

Posted by Ashley Fisher on June 28, 1998 at 03:12:45:

In Reply to: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? posted by M. Wagner on May 28, 1998 at 00:56:21:

I want to get DirectX5.0 cause I wanna uninstall
it cause it stuffs up the graphics.
You can get version 5.2 at this site:

www.microsoft.com/directx/resources/dx5end.htm

Follow Ups:

Post a Followup

Name:


DirectX 5.0 Control Panel that will not die!

Posted by Dave on June 28, 1998 at 04:00:42:

Hello all,
A few months back, I downloaded and installed the
DirectX 5.0 Control Panel from Microsoft's page.
Now I want to uninstall it. To my dismay, doing so
gave me an illegl operation error saying "ISUNINST
caused a stack fault in module ISUNINST.EXE at
016f:0040fbfd....etc..etc."

I did use Norton RegEdit to first save my registry.
Then I manually took out all keys relating to the DX
Control Panel. Unfortunately, the DX Control Panel
is still fully functional and is still accessible in
the Win95 Control Panel. I've tried to find the files
that run this thing but can't find them either.

Also, the Control
Panel Program doesn't seem to be Microsoft's page
anymore. Anyone know if its still available? I was
thinking of re-installing and then uninstall again.

Anyone have an idea of what's wrong?
Thanks ALL for any help!

Follow Ups:

  • Re: DirectX 5.0 Control Panel that will not die! MOGA ALEXANDRU 13:40:29 7/15/98 (0)

Post a Followup

Name:


Re: DirectX mutes Presario 2120

Posted by V.L. smith on June 28, 1998 at 10:18:19:

In Reply to: DirectX mutes Presario 2120 posted by Rey Rito on March 16, 1998 at 00:24:46:

: Everytime I load game softwares (ex: Age of Empires,
: Barney Under the Sea, The Lost World - Jurassic Park,etc.)
: that also contain DirectX, my Presario 2120 becomes mute
: (no more sound, even when using other programs that do
: not use DirectX). I end up spending much time restoring
: my computer's programs to its original settings and
: re-installing other softwares just to bring back the
: sound. Sometimes, I would spend 1 day to back up my old
: files (which would be erased by the Compaq Restore
: program) and re-install the other softwares.

: What should I do to solve this so I could use the game
: softwares with DirectX with sound?
I'm having the same problems. I just loaded Windows 98. It didn't solve the problem. Awaiting answer from Compaq. Here anything yell.
: Also, will the sound come back if I use Norton Uninstall
: to remove softwares with DirectX, assuming the Presario
: 2120 is not compatible with DirectX?

: Thanks in advance for your help.

Follow Ups:

Post a Followup

Name:


I need DirectX5

Posted by Denton Duncan on June 28, 1998 at 12:41:27:

I downloaded a demo but I need directX5. Can I download it for free?. Where can I get it?

Follow Ups:

  • Re: I need DirectX5 Shah Smith 06:13:42 8/22/98 (1)
    • Re: I need DirectX5 eric 02:24:17 8/23/98 (0)
  • Re: I need DirectX5 MOGA 13:45:39 7/15/98 (0)
  • Re: I need DirectX5 LYNN FOWLER 00:13:02 7/07/98 (2)
    • Re: I need DirectX5 shawn lee harvey 17:52:58 7/20/98 (1)
      • Re: I need DirectX5 Shawn lee Harvey 17:54:36 7/20/98 (0)
  • Re: I need DirectX5 Roger Perez 03:09:15 7/02/98 (1)
    • Re: I need DirectX5 퀂�� 21:51:42 7/03/98 (0)
  • Re: I need DirectX5 terri 21:01:06 6/29/98 (0)
  • Re: I need DirectX5 Julian Thatcher 22:30:27 6/28/98 (0)
  • Re: I need DirectX5 Doug 19:29:33 6/28/98 (0)

Post a Followup

Name:


Re: Writing ActiveX ctrl:DirectSound, DirectShow on NT4.

Posted by Ken Moore on June 28, 1998 at 16:15:26:

In Reply to: Writing ActiveX ctrl:DirectSound, DirectShow on NT4. posted by andrew on June 22, 1998 at 01:29:13:

Andrew,

I don't know how much help I'll be because I'm also new to this DirectX stuff. I can tell you this. I am currently developing an ActiveX control that we are using for video playback. I need some functionality that ActiveMovie doesn't provide so I'm writing my own control with DirectShow. I had some initial trouble getting the project to link (I'm using VC++) but once resolved, things seem to be going ok.

: Hi All
: I'm writing ActiveX Control that should implement the
: following functionality:
: play and record wav files
: fast forward and rewind
: change playback and winding speed
: voice operated recording
: I'm newer in DirectX and i'm looking for advice.
: Is it possible to implement such functionality using
: DirectSound or DirectShow? What is better to use for that
: task?
: This control should work on NT4 box.
: TIA
: Andrew

Follow Ups:

Post a Followup

Name:


Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2?

Posted by karen on June 28, 1998 at 18:06:40:

In Reply to: Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? posted by chris peters on June 07, 1998 at 01:14:58:

: Here is the download site for microsoft directx 5.2.

: www.microsoft.com/msdownload/directx/dxf/enduser5.2/dx5eng.asp

Follow Ups:

Post a Followup

Name:


Re: Finding Screen Coordinates of Mesh Vertices

Posted by Doug on June 28, 1998 at 19:24:33:

In Reply to: Finding Screen Coordinates of Mesh Vertices posted by Tycho on June 26, 1998 at 18:47:26:

I assume your talking about Direct3D v3.

Check out methods IDirect3DDevice::Pick() and IDirect3DDevice::GetPickRecords().

I have never used them, I'm using DX5 D3D Draw Primitive ( no execute buffers ).

Follow Ups:

Post a Followup

Name:


Re: I need DirectX5

Posted by Doug on June 28, 1998 at 19:29:33:

In Reply to: I need DirectX5 posted by Denton Duncan on June 28, 1998 at 12:41:27:

Get it from Microsoft...

http://www.microsoft.com/directx/download.asp

: I downloaded a demo but I need directX5. Can I download it for free?. Where can I get it?

Follow Ups:

Post a Followup

Name:


Re: Textures in Immediate Mode

Posted by Doug on June 28, 1998 at 20:05:17:

In Reply to: Textures in Immediate Mode posted by Shai'tan on June 27, 1998 at 02:52:13:

Yep, Check out FilpCube3D sample in the DX5 SDK it uses the following in D3DTEX.CPP. It's also used in other samples.

// Load from file *.bmp
hBitmap = (HBITMAP)LoadImage(NULL,filename,IMAGE_BITMAP,0,0,LR_LOADFROMFILE|LR_CREATEDIBSECTION);

When you create your texture surface, make sure the size is in power of 2, Scale bitmap to fit if needed.

Follow Ups:

Post a Followup

Name:


Re: Getting DC on Offscreen surf doesn't work, Why?

Posted by Doug on June 28, 1998 at 20:21:41:

In Reply to: Getting DC on Offscreen surf doesn't work, Why? posted by Ravi Joshi on June 25, 1998 at 06:13:43:

I had almost the same problem...

I move the offscreen surface to system memory and GetDC() worked fine.

Follow Ups:

  • Re: How about BltFast? Ravi Joshi 05:27:00 6/29/98 (1)
    • Re: How about BltFast? Ravi Joshi 05:42:12 6/29/98 (0)

Post a Followup

Name:


Re: I can't get Borland C++ to work with the DirectX SDK!

Posted by Doug on June 28, 1998 at 20:33:01:

In Reply to: I can't get Borland C++ to work with the DirectX SDK! posted by Jonathan on June 23, 1998 at 19:35:25:

Copy the headers too? where? project search path?
It should look at new directx headers and libs before bc4.5 header and libs. I use bc5.2.

Follow Ups:

Post a Followup

Name:


Re: RM / IM : DRAW PRIMITIVES

Posted by Doug on June 28, 1998 at 20:44:26:

In Reply to: RM / IM : DRAW PRIMITIVES posted by Frenchy FADGE on June 23, 1998 at 09:22:45:

None that I know of. To use Draw Primitive in RM, RM device needs to be IDirect3DRMDevice2 to support IDirect3DDevice2 (Draw Primitive).

Follow Ups:

Post a Followup

Name:


Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2?

Posted by Robert Vaillancourt on June 28, 1998 at 22:18:07:

In Reply to: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? posted by M. Wagner on May 28, 1998 at 00:56:21:

: : Does anyone now where of how I can download the :5.0 SDK. Microsoft have taken it off line :requiring you to buy a CD off them giving them :all your info (inc CC#). They suck.

: The following site has a list of links that will let you download DirectX SDK 5.0

: http://www.triax.com/ben/dx5/index.html

: I wouldn't be surprised if Microsoft eventually turned it into a commercial products. They suck.
: :)

Follow Ups:

Post a Followup

Name:


Re: I need DirectX5

Posted by Julian Thatcher on June 28, 1998 at 22:30:27:

In Reply to: I need DirectX5 posted by Denton Duncan on June 28, 1998 at 12:41:27:

: I downloaded a demo but I need directX5. Can I download it for free?. Where can I get it?

Follow Ups:

Post a Followup

Name:


Re: Delphi DirectX Examples

Posted by Joakim Strom on June 29, 1998 at 03:21:32:

In Reply to: Delphi DirectX Examples posted by George Pasparakis on January 13, 1998 at 15:07:44:

: I try to compile the examples and i get Fatal error
: ddirectdraw.pas not found.
: I searched for this file but I cant find it.

:
: Any help?

Hello,
You must make sure that the file is in your
delphi lib directory. Also make sure that the
name of the file is correct.
Try typing DDraw.pas instead of DDdirectdraw.pas.

I hope that this helps you.

Follow Ups:

Post a Followup

Name:


MessageBoard Archiving

Posted by Yo on June 29, 1998 at 04:54:53:

Shouldn't some of the old messages be archived?
The 230k download for this page is kind of extreme.

Follow Ups:

  • Re: MessageBoard Archiving Clay 07:32:38 6/29/98 (0)

Post a Followup

Name:


Re: How about BltFast?

Posted by Ravi Joshi on June 29, 1998 at 05:27:00:

In Reply to: Re: Getting DC on Offscreen surf doesn't work, Why? posted by Doug on June 28, 1998 at 20:21:41:

HI doug,
Thanks for the valuable suggestion you've given.
I tried making the offscreen surface created in
the System memory. It worked fine. I was able to
Get the DC to the memory. But then it brings with
it some associated problems like I have not been
able to blit the offscreen surface to the back
buffer. The backbuffer is created in the VDO mem.
I shall try it with just Blt function.
The reason for the failure on the part of BltFast
may be due to the difference in the memories they
respectively represent.

One more logical question that comes to my mind is
that when you can get a dc to the primary surface
or the back buffer, why can't on the offscreen
surfaces?

Thanks again Doug.
Please send if you have got other imp info. to
joshiobjects@hotmail.com
Bye...

Follow Ups:

  • Re: How about BltFast? Ravi Joshi 05:42:12 6/29/98 (0)

Post a Followup

Name:


Re: How about BltFast?

Posted by Ravi Joshi on June 29, 1998 at 05:42:12:

In Reply to: Re: How about BltFast? posted by Ravi Joshi on June 29, 1998 at 05:27:00:

Hey the BltFast too works.
Great...
Thanks doug.

Follow Ups:

Post a Followup

Name:


DirectShow - IBasicVideo->GetCurrentImage

Posted by Avner on June 29, 1998 at 07:06:41:

I want to do some manipulation on EACH frame before
it is displayed on the destination window.
If I use GetCurrentImage, I have to PAUSE before and it takes a lot of time.
Can I asked the DirectShow, NOT to display the frames on a window, but on some DirectDrawSurface or in memory bitmap, and get notification when a frame is ready ? I will blt the picture to some window or any other output device.
Thanks,
Avner.

Follow Ups:

Post a Followup

Name:


Re: Thanks dude!

Posted by Clay on June 29, 1998 at 07:22:37:

In Reply to: Thanks dude! posted by Shai'tan on June 24, 1998 at 20:59:43:

just adding a lpVtbl to your function calls should do it (and use the .c file extension): lpD3DRM->lpVtbl->SomeFunction(). You'll still get the double-dereference hit, though. The big thing is that you don't use virtual functions in your code. They cost a lot (comparatively) in function call overhead (3X what a 'c' call uses). By the way, if you really want to get tricky, you can do this:

(HRESULT*) MyCreateMesh = lpD3DRM->CreateMesh;

and use the MyCreateMesh() "function". This will call CreateMesh() as a 'c' function. I'd do the function pointer thing last, though. It can cause a lot of debuging problems.

Clay

Follow Ups:

Post a Followup

Name:


DirectPlay lobby servers

Posted by Dominic Mathers on June 29, 1998 at 07:29:44:

Does anyone know where I can get info on how to program a DirectPlay lobby server ?

Thanks alot.

Follow Ups:

Post a Followup

Name:


Re: MessageBoard Archiving

Posted by Clay on June 29, 1998 at 07:32:38:

In Reply to: MessageBoard Archiving posted by Yo on June 29, 1998 at 04:54:53:

I'm with you. I sent an email to the author about this last week. Perhaps a few more letters will convince him... ;)

Clay

: Shouldn't some of the old messages be archived?
: The 230k download for this page is kind of extreme.

Follow Ups:

Post a Followup

Name:


Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2?

Posted by Steven Weesner on June 29, 1998 at 08:47:23:

In Reply to: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? posted by M. Wagner on May 28, 1998 at 00:56:21:

: : Does anyone now where of how I can download the :5.0 SDK. Microsoft have taken it off line :requiring you to buy a CD off them giving them :all your info (inc CC#). They suck.

: The following site has a list of links that will let you download DirectX SDK 5.0

: http://www.triax.com/ben/dx5/index.html

: I wouldn't be surprised if Microsoft eventually turned it into a commercial products. They suck.
: :)

Follow Ups:

Post a Followup

Name:


DirectPlay player targetted messages

Posted by Dominic Mathers on June 29, 1998 at 09:43:48:

Does anybody know how to send messages / data to a specific player ?
I've tried setting the id's, but every player still receives it ?
How do you send messages / data to a specific player in a session ?

Thanks alot.

Follow Ups:

Post a Followup

Name:


DrawPrimitives ???

Posted by Frenchy FADGE on June 29, 1998 at 10:29:57:

Hello,
I've a problem using DrawPrimitives.

I want to include a specific rendering with DrawPrimitive to an object,
in an application written in Retained Mode.
So, I create an UserVisual with a Callback rendering function using
DrawPrimitive,(like the SDK sample UVIS with executive buffers), but it doesn't work.

If someone have an idea ...

The source is something like that (for the render callback):

LPDIRECT3DDEVICE2 lpD3DDev = NULL;

lpD3DRMDevice2->GetDirect3DDevice2(&lpD3DDev);
lpD3DDev->SetRenderState(blabla...) );
lpD3DDev->DrawPrimitive(D3DPT_LINELIST,D3DVT_LVERTEX,lpTLvector,2,NULL);

DrawPrimitive fails.
Did I forget something ?
Is it possible, or i have to use execute buffers ?

Thanks for your replies.
Frenchy FADGE ( fadge1er@hol.fr )

Follow Ups:

  • Re: DrawPrimitives ??? Clay 11:39:58 6/29/98 (5)
    • Re: DrawPrimitives ??? Frenchy FADGE 04:50:59 6/30/98 (4)
      • Re: DrawPrimitives ??? Clay 07:15:34 6/30/98 (3)
        • Re: DrawPrimitives ??? Frenchy FADGE 09:00:28 6/30/98 (2)
          • Re: DrawPrimitives ??? Clay 07:29:55 7/01/98 (1)
            • THE solution Frenchy FADGE 17:00:01 7/01/98 (0)

Post a Followup

Name:


Re: DrawPrimitives ???

Posted by Clay on June 29, 1998 at 11:39:58:

In Reply to: DrawPrimitives ??? posted by Frenchy FADGE on June 29, 1998 at 10:29:57:

You need to bracket DrawPrimitive() with BeginScene() and EndScene()

Clay

:
: Hello,
: I've a problem using DrawPrimitives.

: I want to include a specific rendering with DrawPrimitive to an object,
: in an application written in Retained Mode.
: So, I create an UserVisual with a Callback rendering function using
: DrawPrimitive,(like the SDK sample UVIS with executive buffers), but it doesn't work.

: If someone have an idea ...

: The source is something like that (for the render callback):

: LPDIRECT3DDEVICE2 lpD3DDev = NULL;
:
: lpD3DRMDevice2->GetDirect3DDevice2(&lpD3DDev);
: lpD3DDev->SetRenderState(blabla...) );
: lpD3DDev->DrawPrimitive(D3DPT_LINELIST,D3DVT_LVERTEX,lpTLvector,2,NULL);

: DrawPrimitive fails.
: Did I forget something ?
: Is it possible, or i have to use execute buffers ?

: Thanks for your replies.
: Frenchy FADGE ( fadge1er@hol.fr )

Follow Ups:

  • Re: DrawPrimitives ??? Frenchy FADGE 04:50:59 6/30/98 (4)
    • Re: DrawPrimitives ??? Clay 07:15:34 6/30/98 (3)
      • Re: DrawPrimitives ??? Frenchy FADGE 09:00:28 6/30/98 (2)
        • Re: DrawPrimitives ??? Clay 07:29:55 7/01/98 (1)
          • THE solution Frenchy FADGE 17:00:01 7/01/98 (0)

Post a Followup

Name:


thank you

Posted by Cesar on June 29, 1998 at 14:04:40:

In Reply to: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? posted by M. Wagner on May 28, 1998 at 00:56:21:

thank you,
I spent a long time looking for it
those bastard make you order it.

Follow Ups:

Post a Followup

Name:


DirectX with VC++ 2.1??

Posted by Laurent on June 29, 1998 at 16:10:22:

I only have version 2.1 of Visual C++ on windows 95 and
I've been trying to learn to program with DirectX on
it, but I can't get the samples to work, nor my own
code for that matter. Every time I try to build a
makefile from the samples, I get a fatal error U1045
spawn failed, and it tells me it's missing MSPDB50.DLL
Can anyone tell me what my problem is? is it linked to
the fact that I only have VC++ 2.1 or is it something
else? When I try to compile my own code, I get a
dxsdk\include\wtypes.h error C2371 BSTR redefinition
different basic types.
If anyone can tell me what's going on, I would
appreciate it a lot.
Laurent.

Follow Ups:

  • Re: DirectX with VC++ 2.1?? Clay 15:01:08 6/30/98 (0)

Post a Followup

Name:


Fill a color to a directdraw surface

Posted by Bob on June 29, 1998 at 18:34:36:

Hi there,
How to fill a color to a directdraw surface?? Thanks.

Follow Ups:

  • Re: Fill a color to a directdraw surface Ravi Joshi 02:29:15 6/30/98 (0)

Post a Followup

Name:


Re: I need DirectX5

Posted by terri on June 29, 1998 at 21:01:06:

In Reply to: I need DirectX5 posted by Denton Duncan on June 28, 1998 at 12:41:27:

: I downloaded a demo but I need directX5. Can I download it for free?. Where can I get it?

Follow Ups:

Post a Followup

Name:


Re: getting hooked up w/ directx

Posted by Juanita Garcia on June 29, 1998 at 23:51:26:

In Reply to: getting hooked up w/ directx posted by tommy on February 03, 1998 at 17:31:23:

: I am trying to run a game that I bought and it says that I need directx to run it. What do I have to do to get it and what do I do to install it?

I have just installed Catz II and cannot detect any sound. I was told to download the direct x sound drivers by visiting this web site. Please help!!!!!!!!!!!!!!

Follow Ups:

Post a Followup

Name:


DirectDraw Beginner Problems

Posted by Tails on June 30, 1998 at 02:06:59:

Hiya everyone, thanks for reading this post.

I thought I had the hang of this DirectDraw thing until I sat down to test out the knowledge I picked up from the samples, different web pages, and a book whose name I won't mention (since I wouldn't recommend it).

I'm having troubles blitting from an off-screen surface to the back surface to be flipped to the primary surface. I'm guessing that the bitmap is being loaded incorrectly, because while the code blits the appropriate size rectangle and everything, it comes out looking like random hunks of GDI display memory.

I really have no idea what I'm doing wrong, and any help would be IMMENSELY appreciated. Attached is the code, crude as it is (apologies for loading time). If you have any ideas, please drop me an E-Mail at tails@tidalwave.net if you have the time.

Thanks in advance for your time, effort, and cooperation;
-- Tails (tails@tidalwave.net)

#define WIN32_LEAN_AND_MEAN
#define INITGUID

#define NAME "ddrawtst"
#define TITLE "DirectDraw Test Application"
#define BUFFERS 2

#include
#include
#include
#include
#include

// Globals yunnun; in the final they'll be class members and so
// easily accessable...

LPDIRECTDRAW lpDD;
LPDIRECTDRAW2 lpDD2;
LPDIRECTDRAWSURFACE lpDDSFront,
lpDDSBack;

long FAR PASCAL WindowProc (HWND hwnd, UINT message,
WPARAM wParam, LPARAM lParam)
{

switch (message)
{
case WM_SETCURSOR:
SetCursor(NULL);
return TRUE;
}

return DefWindowProc(hwnd, message, wParam, lParam);

}

BOOL InitDirectDraw (HWND hwnd)

{

if FAILED(DirectDrawCreate(NULL, &lpDD, NULL)) return FALSE;
if FAILED(lpDD->QueryInterface(IID_IDirectDraw2, (LPVOID *)&lpDD2)) return FALSE;
lpDD->Release(); // we done with you.

DWORD dwFlags = DDSCL_FULLSCREEN | DDSCL_EXCLUSIVE | DDSCL_NOWINDOWCHANGES;

if FAILED(lpDD2->SetCooperativeLevel(hwnd, dwFlags)) return FALSE;
if FAILED(lpDD2->SetDisplayMode(640, 480, 16, 0, 0)) return FALSE;

DDSURFACEDESC ddsd;
ZeroMemory(&ddsd, sizeof(ddsd));

ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_BACKBUFFERCOUNT;
ddsd.ddsCaps.dwCaps = DDSCAPS_PRIMARYSURFACE |
DDSCAPS_FLIP |
DDSCAPS_COMPLEX;
ddsd.dwBackBufferCount = BUFFERS;

if FAILED(lpDD2->CreateSurface(&ddsd, &lpDDSFront, NULL)) return FALSE;

DDSCAPS ddscaps;
ddscaps.dwCaps = DDSCAPS_BACKBUFFER;
if FAILED(lpDDSFront->GetAttachedSurface(&ddscaps, &lpDDSBack)) return FALSE;

DDSURFACEDESC ddsd2;
ZeroMemory(&ddsd2, sizeof(ddsd2));
ddsd2.dwSize = sizeof(ddsd2);
if FAILED(lpDDSBack->GetSurfaceDesc(&ddsd2)) return FALSE;

/*
* Let's try loading an image now...
*/

HBITMAP hbm;
BITMAP bm;
DDSURFACEDESC ddsd3;
LPCSTR szBitmap = "tailsasc.bmp";
LPDIRECTDRAWSURFACE lpDDSOff;

hbm = (HBITMAP)LoadImage(NULL, szBitmap, IMAGE_BITMAP, 0, 0,
LR_LOADFROMFILE | LR_CREATEDIBSECTION);
if (hbm == NULL) MessageBox(hwnd, "Error loading image.", "Error", MB_OK);

GetObject(hbm, sizeof(bm), &bm);
ZeroMemory(&ddsd3, sizeof(ddsd3));
ddsd3.dwSize = sizeof(ddsd3);
ddsd3.dwFlags = DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH;
ddsd3.ddsCaps.dwCaps = DDSCAPS_OFFSCREENPLAIN;
ddsd3.dwWidth = bm.bmWidth;
ddsd3.dwHeight = bm.bmHeight;

if FAILED(lpDD2->CreateSurface(&ddsd3, &lpDDSOff, NULL)) return FALSE;

lpDDSOff->Restore(); // just for good measure;

HDC hdc, hdcImage;

hdcImage = CreateCompatibleDC(NULL);
SelectObject(hdcImage, hdc);

if FAILED(lpDDSOff->GetDC(&hdc)) {DeleteDC(hdcImage); return FALSE;}
else
{
if (BitBlt(hdc, 0, 0, 291, 239, hdcImage,
0, 0, SRCCOPY) == FALSE)
{
lpDDSOff->ReleaseDC(hdc);
return FALSE;
}
lpDDSOff->ReleaseDC(hdc);
}

DeleteDC(hdcImage);
DeleteObject(hbm);

for (register int x = 0; x BltFast(x*2, x*2, lpDDSOff, NULL, 0)) return FALSE;
if FAILED(lpDDSBack->BltFast(640-291-x*2, x*2, lpDDSOff, NULL, 0)) return FALSE;
if FAILED(lpDDSFront->Flip(NULL, DDFLIP_WAIT)) return FALSE;
}

return TRUE;

}

int PASCAL WinMain (HINSTANCE hInstance, HINSTANCE hPrevInstance,
LPSTR lpCmdLine, int nCmdShow)
{

//create the window...

HWND hwnd;
WNDCLASS wc;

//set up and register window class

wc.style = CS_HREDRAW | CS_VREDRAW;
wc.lpfnWndProc = WindowProc;
wc.cbClsExtra = 0;
wc.cbWndExtra = 0;
wc.hInstance = hInstance;
wc.hIcon = LoadIcon(hInstance, IDI_APPLICATION);
wc.hCursor = LoadCursor(NULL, IDC_ARROW);
wc.hbrBackground = NULL;
wc.lpszMenuName = NAME;
wc.lpszClassName = NAME;

RegisterClass(&wc);

// instanciate the window

hwnd = CreateWindowEx(
WS_EX_TOPMOST,
NAME,
TITLE,
WS_POPUP,
0, 0,
GetSystemMetrics(SM_CXSCREEN),
GetSystemMetrics(SM_CYSCREEN),
NULL,
NULL,
hInstance,
NULL);

ShowWindow(hwnd, nCmdShow);
UpdateWindow(hwnd);

BOOL result = InitDirectDraw(hwnd);

lpDD2->RestoreDisplayMode();
lpDD2->Release();

return 0;

}

Follow Ups:

  • Re: DirectDraw Beginner Problems Fragmo 06:35:04 6/30/98 (1)
    • Re: DirectDraw Beginner Problems (still) Tails 12:38:17 6/30/98 (0)

Post a Followup

Name:


FlipToGDISurface : How to use this function?

Posted by Ravi Joshi on June 30, 1998 at 02:22:34:

Can anyone please tell me why this function is used
and under what circumstances this is used.
Thanks..
Ravi..

Follow Ups:

Post a Followup

Name:


Re: Fill a color to a directdraw surface

Posted by Ravi Joshi on June 30, 1998 at 02:29:15:

In Reply to: Fill a color to a directdraw surface posted by Bob on June 29, 1998 at 18:34:36:

A direct draw surface can be colored using the code
given below.

DDBLTFX fx;
memset(&fx, 0, sizeof(fx));
fx.dwSize = sizeof(DDBLTFX);
fx.dwFillColor = RGB(r,g,b);
HRESULT hr;
pDDSurf->Blt(&rc, NULL, NULL, DDBLT_COLORFILL | DDBLT_WAIT,&fx);

If you find any better method, pl post it on this
site or email me to "joshiobjects@hotmail.com"

Follow Ups:

Post a Followup

Name:


Re: DPID_SERVERPLAYER doesn't change

Posted by Dominic Mathers on June 30, 1998 at 04:00:13:

In Reply to: DPID_SERVERPLAYER doesn't change posted by Peter Ohlmann on May 15, 1998 at 14:19:14:

: I have trouble with DirectPlay, because the DPID_SERVERPLAYER doesn't refresh after the host leave the session. One player gets the message DPMSGS_HOST, but the other players continue sending their messages to the previous server.

: What can I do?

In order for DPID_SERVERPLAYER to change you must set the DPSESSION_MIGRATEHOST flag when calling the Open method.

Hope this helps.

Follow Ups:

Post a Followup

Name:


Re: DPID_SERVERPLAYER doesn't change

Posted by Dominic Mathers on June 30, 1998 at 04:00:59:

In Reply to: DPID_SERVERPLAYER doesn't change posted by Peter Ohlmann on May 15, 1998 at 14:19:14:

: I have trouble with DirectPlay, because the DPID_SERVERPLAYER doesn't refresh after the host leave the session. One player gets the message DPMSGS_HOST, but the other players continue sending their messages to the previous server.

: What can I do?

In order for DPID_SERVERPLAYER to change you must set the DPSESSION_MIGRATEHOST flag when calling the Open method.

Hope this helps.

Follow Ups:

Post a Followup

Name:


Re: DPID_SERVERPLAYER doesn't change

Posted by Dominic Mathers on June 30, 1998 at 04:04:22:

In Reply to: DPID_SERVERPLAYER doesn't change posted by Peter Ohlmann on May 15, 1998 at 14:19:14:

: I have trouble with DirectPlay, because the DPID_SERVERPLAYER doesn't refresh after the host leave the session. One player gets the message DPMSGS_HOST, but the other players continue sending their messages to the previous server.

: What can I do?

In order for DPID_SERVERPLAYER to change you must set the DPSESSION_MIGRATEHOST flag in the DPSESSIONDESC2 structure before creating the game, i.e. whoever hosts the game must set this before creating the game.

Hope this helps. If you want it in more detail then just send me a mail.

Follow Ups:

Post a Followup

Name:


Re: DrawPrimitives ???

Posted by Frenchy FADGE on June 30, 1998 at 04:50:59:

In Reply to: Re: DrawPrimitives ??? posted by Clay on June 29, 1998 at 11:39:58:

Thanks for the clue, but the BeginScene fails ??

Here's my code:

// Specific rendering for the user visual
LPDIRECT3DDEVICE2 lpD3DDev = NULL;
LPDIRECT3DVIEWPORT2 lpD3DView = NULL;
D3DLVERTEX* TLvector;

// Get the Device & Viewport IMMEDIATE MODE
track->deviceRM)->GetDirect3DDevice2(&lpD3DDev);
track->viewportRM)->GetDirect3DViewport((LPDIRECT3DVIEWPORT *)&lpD3DView);

// Set as the current viewport
hr+= lpD3DDev->SetCurrentViewport( lpD3DView ) ;

// Set the render states
lpD3DDev->SetRenderState(...) ;

// Draw a line
lpD3DDev->BeginScene() ;
lpD3DDev->DrawPrimitive(D3DPT_LINELIST,D3DVT_LVERTEX,TLvector,2,NULL); // One Segment
lpD3DDev->EndScene() ;

What's wrong ?
Thanks for your replies.
FADGE

Follow Ups:

  • Re: DrawPrimitives ??? Clay 07:15:34 6/30/98 (3)
    • Re: DrawPrimitives ??? Frenchy FADGE 09:00:28 6/30/98 (2)
      • Re: DrawPrimitives ??? Clay 07:29:55 7/01/98 (1)
        • THE solution Frenchy FADGE 17:00:01 7/01/98 (0)

Post a Followup

Name:


Re: DirectDraw Beginner Problems

Posted by Fragmo on June 30, 1998 at 06:35:04:

In Reply to: DirectDraw Beginner Problems posted by Tails on June 30, 1998 at 02:06:59:

I've had the same trouble, and i believe the pixel format of the bitmap must be
the same as the surface you are blitting to. i.e. in your code, you are blitting to a
16 bit surface, so your bitmap should be stored as a 16 bit surface as well.

Fragmo
www.public.iastate.edu/~jtilton/gamepage.html

: Hiya everyone, thanks for reading this post.

: I thought I had the hang of this DirectDraw thing until I sat down to test out the knowledge I picked up from the samples, different web pages, and a book whose name I won't mention (since I wouldn't recommend it).

: I'm having troubles blitting from an off-screen surface to the back surface to be flipped to the primary surface. I'm guessing that the bitmap is being loaded incorrectly, because while the code blits the appropriate size rectangle and everything, it comes out looking like random hunks of GDI display memory.

: I really have no idea what I'm doing wrong, and any help would be IMMENSELY appreciated. Attached is the code, crude as it is (apologies for loading time). If you have any ideas, please drop me an E-Mail at tails@tidalwave.net if you have the time.

: Thanks in advance for your time, effort, and cooperation;
: -- Tails (tails@tidalwave.net)

:
: #define WIN32_LEAN_AND_MEAN
: #define INITGUID

: #define NAME "ddrawtst"
: #define TITLE "DirectDraw Test Application"
: #define BUFFERS 2

: #include
: #include
: #include
: #include
: #include

: // Globals yunnun; in the final they'll be class members and so
: // easily accessable...

: LPDIRECTDRAW lpDD;
: LPDIRECTDRAW2 lpDD2;
: LPDIRECTDRAWSURFACE lpDDSFront,
: lpDDSBack;

: long FAR PASCAL WindowProc (HWND hwnd, UINT message,
: WPARAM wParam, LPARAM lParam)
: {

: switch (message)
: {
: case WM_SETCURSOR:
: SetCursor(NULL);
: return TRUE;
: }
:
: return DefWindowProc(hwnd, message, wParam, lParam);

: }

: BOOL InitDirectDraw (HWND hwnd)

: {

: if FAILED(DirectDrawCreate(NULL, &lpDD, NULL)) return FALSE;
: if FAILED(lpDD->QueryInterface(IID_IDirectDraw2, (LPVOID *)&lpDD2)) return FALSE;
: lpDD->Release(); // we done with you.

: DWORD dwFlags = DDSCL_FULLSCREEN | DDSCL_EXCLUSIVE | DDSCL_NOWINDOWCHANGES;
:
: if FAILED(lpDD2->SetCooperativeLevel(hwnd, dwFlags)) return FALSE;
: if FAILED(lpDD2->SetDisplayMode(640, 480, 16, 0, 0)) return FALSE;
:
: DDSURFACEDESC ddsd;
: ZeroMemory(&ddsd, sizeof(ddsd));

: ddsd.dwSize = sizeof(ddsd);
: ddsd.dwFlags = DDSD_CAPS | DDSD_BACKBUFFERCOUNT;
: ddsd.ddsCaps.dwCaps = DDSCAPS_PRIMARYSURFACE |
: DDSCAPS_FLIP |
: DDSCAPS_COMPLEX;
: ddsd.dwBackBufferCount = BUFFERS;

: if FAILED(lpDD2->CreateSurface(&ddsd, &lpDDSFront, NULL)) return FALSE;

: DDSCAPS ddscaps;
: ddscaps.dwCaps = DDSCAPS_BACKBUFFER;
: if FAILED(lpDDSFront->GetAttachedSurface(&ddscaps, &lpDDSBack)) return FALSE;

: DDSURFACEDESC ddsd2;
: ZeroMemory(&ddsd2, sizeof(ddsd2));
: ddsd2.dwSize = sizeof(ddsd2);
: if FAILED(lpDDSBack->GetSurfaceDesc(&ddsd2)) return FALSE;
:
: /*
: * Let's try loading an image now...
: */
:
: HBITMAP hbm;
: BITMAP bm;
: DDSURFACEDESC ddsd3;
: LPCSTR szBitmap = "tailsasc.bmp";
: LPDIRECTDRAWSURFACE lpDDSOff;

: hbm = (HBITMAP)LoadImage(NULL, szBitmap, IMAGE_BITMAP, 0, 0,
: LR_LOADFROMFILE | LR_CREATEDIBSECTION);
: if (hbm == NULL) MessageBox(hwnd, "Error loading image.", "Error", MB_OK);

: GetObject(hbm, sizeof(bm), &bm);
: ZeroMemory(&ddsd3, sizeof(ddsd3));
: ddsd3.dwSize = sizeof(ddsd3);
: ddsd3.dwFlags = DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH;
: ddsd3.ddsCaps.dwCaps = DDSCAPS_OFFSCREENPLAIN;
: ddsd3.dwWidth = bm.bmWidth;
: ddsd3.dwHeight = bm.bmHeight;
:
: if FAILED(lpDD2->CreateSurface(&ddsd3, &lpDDSOff, NULL)) return FALSE;

: lpDDSOff->Restore(); // just for good measure;

: HDC hdc, hdcImage;

: hdcImage = CreateCompatibleDC(NULL);
: SelectObject(hdcImage, hdc);

: if FAILED(lpDDSOff->GetDC(&hdc)) {DeleteDC(hdcImage); return FALSE;}
: else
: {
: if (BitBlt(hdc, 0, 0, 291, 239, hdcImage,
: 0, 0, SRCCOPY) == FALSE)
: {
: lpDDSOff->ReleaseDC(hdc);
: return FALSE;
: }
: lpDDSOff->ReleaseDC(hdc);
: }

: DeleteDC(hdcImage);
: DeleteObject(hbm);

: for (register int x = 0; x BltFast(x*2, x*2, lpDDSOff, NULL, 0)) return FALSE;
: if FAILED(lpDDSBack->BltFast(640-291-x*2, x*2, lpDDSOff, NULL, 0)) return FALSE;
: if FAILED(lpDDSFront->Flip(NULL, DDFLIP_WAIT)) return FALSE;
: }
:
: return TRUE;

: }

: int PASCAL WinMain (HINSTANCE hInstance, HINSTANCE hPrevInstance,
: LPSTR lpCmdLine, int nCmdShow)
: {

: //create the window...

: HWND hwnd;
: WNDCLASS wc;

: //set up and register window class

: wc.style = CS_HREDRAW | CS_VREDRAW;
: wc.lpfnWndProc = WindowProc;
: wc.cbClsExtra = 0;
: wc.cbWndExtra = 0;
: wc.hInstance = hInstance;
: wc.hIcon = LoadIcon(hInstance, IDI_APPLICATION);
: wc.hCursor = LoadCursor(NULL, IDC_ARROW);
: wc.hbrBackground = NULL;
: wc.lpszMenuName = NAME;
: wc.lpszClassName = NAME;
:
: RegisterClass(&wc);

: // instanciate the window
:
: hwnd = CreateWindowEx(
: WS_EX_TOPMOST,
: NAME,
: TITLE,
: WS_POPUP,
: 0, 0,
: GetSystemMetrics(SM_CXSCREEN),
: GetSystemMetrics(SM_CYSCREEN),
: NULL,
: NULL,
: hInstance,
: NULL);

: ShowWindow(hwnd, nCmdShow);
: UpdateWindow(hwnd);

: BOOL result = InitDirectDraw(hwnd);

: lpDD2->RestoreDisplayMode();
: lpDD2->Release();

: return 0;

: }

Follow Ups:

  • Re: DirectDraw Beginner Problems (still) Tails 12:38:17 6/30/98 (0)

Post a Followup

Name:


Re: DrawPrimitives ???

Posted by Clay on June 30, 1998 at 07:15:34:

In Reply to: Re: DrawPrimitives ??? posted by Frenchy FADGE on June 30, 1998 at 04:50:59:

What is the error that BeginScene() returns?

Clay

: Thanks for the clue, but the BeginScene fails ??

: Here's my code:

: // Specific rendering for the user visual
: LPDIRECT3DDEVICE2 lpD3DDev = NULL;
: LPDIRECT3DVIEWPORT2 lpD3DView = NULL;
: D3DLVERTEX* TLvector;

: // Get the Device & Viewport IMMEDIATE MODE
: track->deviceRM)->GetDirect3DDevice2(&lpD3DDev);
: track->viewportRM)->GetDirect3DViewport((LPDIRECT3DVIEWPORT *)&lpD3DView);

: // Set as the current viewport
: hr+= lpD3DDev->SetCurrentViewport( lpD3DView ) ;

: // Set the render states
: lpD3DDev->SetRenderState(...) ;

: // Draw a line
: lpD3DDev->BeginScene() ;
: lpD3DDev->DrawPrimitive(D3DPT_LINELIST,D3DVT_LVERTEX,TLvector,2,NULL); // One Segment
: lpD3DDev->EndScene() ;

:
: What's wrong ?
: Thanks for your replies.
: FADGE

Follow Ups:

  • Re: DrawPrimitives ??? Frenchy FADGE 09:00:28 6/30/98 (2)
    • Re: DrawPrimitives ??? Clay 07:29:55 7/01/98 (1)
      • THE solution Frenchy FADGE 17:00:01 7/01/98 (0)

Post a Followup

Name:


Re: DrawPrimitives ???

Posted by Frenchy FADGE on June 30, 1998 at 09:00:28:

In Reply to: Re: DrawPrimitives ??? posted by Clay on June 30, 1998 at 07:15:34:

Hello, and thank you very much for your support

BeginScene() returns
HRESULT= -2005531912
ERROR Unknown error

And when the hand is given to the render Retained Mode, SceneFrame->Render() fails and returns:

ERROR Device is not compatible with renderer

What's wrong ?
I checked the device and viewport immediate mode with the functions GetViewport2(&data) and GetRenderState(Type,State) and the values seems correct.

Thanks
FADGE ( fadge1er@hol.fr )

Follow Ups:

  • Re: DrawPrimitives ??? Clay 07:29:55 7/01/98 (1)
    • THE solution Frenchy FADGE 17:00:01 7/01/98 (0)

Post a Followup

Name:


Frame Orientation

Posted by Greger Ohlson on June 30, 1998 at 09:41:39:

Hi all!

Does anyone have a code snippet that could
explain how frame orientation is performed.
I'd like, for instance, to have a camera
follow another object. That is, i want the
camera to point to a specific point in the
3D world.

Any answers are very appreciated.

(And by the way, if you know if DestBlitting
is supposed to work on all types of hardware,
please let me know. I get it to work on one
computer, but not the other.)

Follow Ups:

Post a Followup

Name:


Re: DirectDraw Beginner Problems (still)

Posted by Tails on June 30, 1998 at 12:38:17:

In Reply to: Re: DirectDraw Beginner Problems posted by Fragmo on June 30, 1998 at 06:35:04:

: I've had the same trouble, and i believe the pixel format of the bitmap must be
: the same as the surface you are blitting to. i.e. in your code, you are blitting to a
: 16 bit surface, so your bitmap should be stored as a 16 bit surface as well.

Thanks for the suggestion, I'll be sure to give it a shot. =^_^= On the other hand, is there any way to get around this limitation? For example, I really shouldn't have any problem blitting a palettized image to a 16-bit surface, since the 16-bit color should be able to represent the palette easily, right? Or is it different because the pixel color information is stored differently in palette and high-color modes?

Unfortunately, I changed the bitmap into RGB mode (24-bit) and it didn't work, so I tried changing the primary surface to 24-bit just for kicks and that didn't work, either... is there any chance I'm blitting incorrectly? Is it that the off-screen surface is being created as a palettized surface or something other than my primary surface?

Thanks for your time, though!
-- Tails (tails@tidalwave.net)

Follow Ups:

Post a Followup

Name:


Re: DirectX with VC++ 2.1??

Posted by Clay on June 30, 1998 at 15:01:08:

In Reply to: DirectX with VC++ 2.1?? posted by Laurent on June 29, 1998 at 16:10:22:

Sounds like your VC++ installation has gotten hosed up. The spawn error can happen if the IDE (editor) can't launch the cl.exe program (a separate exe compiles code). If the spawn error is linked to the MSPDB50.DLL error, try rebuilding without using a program database for debug info. If all else failes, try reinstalling VC++.

Clay

: I only have version 2.1 of Visual C++ on windows 95 and
: I've been trying to learn to program with DirectX on
: it, but I can't get the samples to work, nor my own
: code for that matter. Every time I try to build a
: makefile from the samples, I get a fatal error U1045
: spawn failed, and it tells me it's missing MSPDB50.DLL
: Can anyone tell me what my problem is? is it linked to
: the fact that I only have VC++ 2.1 or is it something
: else? When I try to compile my own code, I get a
: dxsdk\include\wtypes.h error C2371 BSTR redefinition
: different basic types.
: If anyone can tell me what's going on, I would
: appreciate it a lot.
: Laurent.

Follow Ups:

Post a Followup

Name:


D3D Help!

Posted by Marc on June 30, 1998 at 15:55:40:

I have a problem with my directx d3d..
When I start Moto Racer and I choose D3D...It crash my computer....
I can't play with Shadow of the empire...it crash too.
I have a diamond monster 3d...all the drivers are installed..
Help me...
Thanks
Marc

Follow Ups:

  • Re: D3D Help! Roger Schuttelaar 07:24:47 9/02/98 (0)

Post a Followup

Name:


Re: Problem with the IDirect3DRMAnimationSet::Load

Posted by Andreas on June 30, 1998 at 20:28:47:

In Reply to: Problem with the IDirect3DRMAnimationSet::Load posted by Fred on May 15, 1998 at 09:25:51:

I figured out a solution to this problem. Although it's quite a cheap trick, I think!

I use:
pGameScreen->GetD3DRM2Object()->EnumerateObjects(EnumObjs, NULL);

to Remove the object names from all frame and meshbuilder objects!!
Note: pGameScreen is a pointer to my "Screen"-Object.

The EnumObjs function looks like this:
void CObjectList::EnumObjs(LPDIRECT3DRMOBJECT pObj, LPVOID pArg)
{
char szName[64];
char szClassName[64];
DWORD dwSize = sizeof(szName);

pObj->GetName(&dwSize, szName);
pObj->GetClassName(&dwSize, szClassName);

if (!strcmp(szClassName, "Frame") || !strcmp(szClassName, "Builder")) {
pObj->SetName("Unnamed");
}
}

If anybody has a better solution for this problem, I would be very interested!!!

Bye, Andreas.

Follow Ups:

  • Re: Problem with the IDirect3DRMAnimationSet::Load Fred 12:35:07 8/18/98 (0)

Post a Followup

Name:


DDERR_NOEXLCUSIVE??? WHY???

Posted by Doug Linley on June 30, 1998 at 21:33:10:

I have no idea why my code won't work in Win95. It works fine in Win98 but when creating the primary surface it fails returning DDERR_NOEXCLUSIVEMODE. I've had every other DX programmer I know look at the code and we can't figure out what's wrong with it. Can someone take a look at my code below and see if they don't see the problem. I've been stumped for days!!

Thanks in advance for your help!
Doug Linley

if you would like to just download the VC++ 5.0 project you can access it here: http://home.columbus.rr.com/fpigames/files/surface.zip

Here's the code:

#define WIN32_LEAN_AND_MEAN
#define INITGUID

#include
#include
#include

#define NAME "Surface Tutorial"
#define TITLE "Surface Tutorial"

LPDIRECTDRAW2 lpDD = NULL; // the main DirectDraw object
LPDIRECTDRAWSURFACE lpDDSPrimary = NULL; // primary buffer(video screen)
LPDIRECTDRAWSURFACE lpDDSBack = NULL; // back buffer for flipping

HWND g_hwnd; // the main window handle
HINSTANCE g_hInstance; // handle to the main instance of the application
BOOL g_bActive; // true when application has the focus
int g_nCol = 1; // the current color to fill the display with

// declaration
void DDRelease();
void CheckResult( HRESULT );

/*
* this function is to run when something "Fails"
*/
void Fail( LPCTSTR str)
{
MessageBox( g_hwnd, str, "ERROR", MB_OK );
DDRelease();
DestroyWindow( g_hwnd );
}
/*
* this function simply sets up the DirectDraw Object and sets
* the video mode
*/

HRESULT DDSetup( DWORD dwWidth, DWORD dwHeight, DWORD dwBpp )
{
HRESULT ddrval; // return value for DirectDraw
DDSURFACEDESC ddsd;

// create the DirectDraw interface object
CoInitialize( NULL );

ddrval = CoCreateInstance( CLSID_DirectDraw, NULL, CLSCTX_ALL, IID_IDirectDraw2, ( LPVOID * )&lpDD );
if( FAILED( ddrval ) )
{
MessageBox( g_hwnd, "Failed on CoCreateInstance(...)", "ERROR", MB_OK );
CheckResult( ddrval );
return ddrval;
}

ddrval = lpDD->Initialize( NULL );
if( FAILED( ddrval ) )
{
MessageBox( g_hwnd, "Failed on lpDD->Initialize(...)", "ERROR", MB_OK );
CheckResult( ddrval );
return ddrval;
}

// set the cooperation level with windows. We want a fullscreen application
ddrval = lpDD->SetCooperativeLevel( g_hwnd, DDSCL_EXCLUSIVE | DDSCL_FULLSCREEN);
if( FAILED( ddrval ) )
{
MessageBox( g_hwnd, "Couldn't set Cooperative level 2nd time", "ERROR", MB_OK );
CheckResult( ddrval );
return ddrval;
}

ZeroMemory( &ddsd, sizeof( ddsd ) );
ddsd.dwSize = sizeof( ddsd );

ddrval = lpDD->GetDisplayMode( &ddsd );
if( FAILED( ddrval ) )
{
MessageBox( g_hwnd, "Failed on GetDisplayMode", "ERROR", MB_OK );
CheckResult( ddrval );
return ddrval;
}

ddrval = lpDD->SetDisplayMode( ddsd.dwWidth, ddsd.dwHeight, ddsd.ddpfPixelFormat.dwRGBBitCount, ddsd.dwRefreshRate, 0 );
if( FAILED( ddrval ) )
{
MessageBox( g_hwnd, "Failed Setting Current Display Mode", "ERROR", MB_OK );
CheckResult( ddrval );
return ddrval;
}

// now it's time to set the display mode
ddrval = lpDD->SetDisplayMode( dwWidth, dwHeight, dwBpp, ddsd.dwRefreshRate, 0 );
if( FAILED( ddrval ) )
{
MessageBox( g_hwnd, "Couldn't SetDisplayMode", "ERROR", MB_OK );
CheckResult( ddrval );
return ddrval;
}

return ddrval;
}

/*
* here is the surface creating function. It creates your
* primary and secondary surfaces
*/
HRESULT CreateMainSurfaces( void )
{
HRESULT ddrval; // DirectDraw return value
DDSURFACEDESC ddsd; // this is the surface description
DDSCAPS ddscaps; // surface capabilities

// zero out the structure
ZeroMemory( &ddsd, sizeof( ddsd ) );

// you MUST manually set the size
ddsd.dwSize = sizeof( ddsd );

// set the flags for a surface that will use a back buffer
ddsd.dwFlags = DDSD_CAPS | DDSD_BACKBUFFERCOUNT;

// set the capablities for a complex flippable surface
ddsd.ddsCaps.dwCaps = DDSCAPS_PRIMARYSURFACE | DDSCAPS_FLIP | DDSCAPS_COMPLEX;

// set the backbuffer count to the amount of backbuffers that you want. In our case 1.
ddsd.dwBackBufferCount = 1;

// now let's create the primary surface
ddrval = lpDD->CreateSurface( &ddsd, &lpDDSPrimary, NULL );
if( FAILED( ddrval ) )
{
MessageBox( g_hwnd, "Failed Creating Primary Surface", "ERROR", MB_OK );
CheckResult( ddrval );
return ddrval;
}

// now lets attatch the back buffer to the primary buffer
ddscaps.dwCaps = DDSCAPS_BACKBUFFER;
ddrval = lpDDSPrimary->GetAttachedSurface( &ddscaps, &lpDDSBack );
if( FAILED( ddrval ) )
{
MessageBox( g_hwnd, "Failed on call to GetAttachedSurface", "ERROR", MB_OK );
CheckResult( ddrval );
return ddrval;
}
return ddrval;
}

/*
* this function will flip surfaces for us
*/
HRESULT DDFlipSurfaces( void )
{
HRESULT ddrval;

ddrval = lpDDSPrimary->Flip( NULL, DDFLIP_WAIT );

/*
* there will be some code here later that will be used
* to check for lost surfaces
*/

// for now just return the value and test it externally
return ddrval;
}

/*
* this function will fill the surface with a certain color
*/

HRESULT DDFillSurface( LPDIRECTDRAWSURFACE lpDDS, DWORD dwColor )
{
HRESULT ddrval;
DDBLTFX ddbltfx;

ZeroMemory( &ddbltfx, sizeof( ddbltfx ) );
ddbltfx.dwSize = sizeof( ddbltfx );

// set the fill color
ddbltfx.dwFillColor = dwColor;

// blit the color to the screen
ddrval = lpDDS->Blt( NULL,
NULL,
NULL,
DDBLT_COLORFILL | DDBLT_WAIT,
&ddbltfx );

return ddrval;
}

/*
* this function will release all of the DirectDraw objects
* and set them to null
*/
void DDRelease( void )
{
if( lpDD )
{
if( lpDDSPrimary )
{
if( lpDDSBack )
{
lpDDSBack->Release();
lpDDSBack = NULL;
}

lpDDSPrimary->Release();
lpDDSPrimary = NULL;
}

lpDD->Release();
lpDD = NULL;
}

CoUninitialize( );
}

/********************************************************************************************/

/*
* this function will be used in WindProc to init all of DirectDraw
*/
HRESULT DDInit( void )
{
HRESULT ddrval;

// set the video mode to 640x480x256
ddrval = DDSetup( 640, 480, 8 );
if( ddrval != DD_OK )
{
MessageBox( g_hwnd, "Failed Failed on DDSetup( 640,480,8 );", "ERROR", MB_OK );
CheckResult( ddrval );
return ddrval;
}

// create some surfaces to draw on
ddrval = CreateMainSurfaces( );
if( ddrval != DD_OK )
{
MessageBox( g_hwnd, "Failed on CreatMainSurfaces( void );", "ERROR", MB_OK );
CheckResult( ddrval );
return ddrval;
}

return ddrval;
}

HRESULT UpdateFrames( )
{
HRESULT ddrval;

ddrval = DDFillSurface( lpDDSBack, g_nCol );
if( FAILED( ddrval ) )
{
MessageBox( g_hwnd, "Failed DDFillSurface", "ERROR", MB_OK );
CheckResult( ddrval );
return ddrval;
}

ddrval = DDFlipSurfaces( );
if( FAILED( ddrval ) )
{
MessageBox( g_hwnd, "Failed on DDFlipSurface", "ERROR", MB_OK );
CheckResult( ddrval );
return ddrval;
}
return ddrval;
}

/***********************************************************************************************/

/* B E L O W A R E T H E W I N D O W S F U N C T I O N S */

long FAR PASCAL WindowProc( HWND hWnd, UINT message,
WPARAM wParam, LPARAM lParam )
{
g_hwnd = hWnd;
switch( message )
{
case WM_ACTIVATEAPP:
g_bActive = TRUE;
OutputDebugString( "Active App!\n ");
break;

case WM_CREATE:
break;

case WM_SETCURSOR:
SetCursor( NULL );

// For the sake of simplicity, we're not using DirectInput but are
// reading the keyboard through the message queue.
case WM_KEYDOWN:
switch( wParam )
{
case VK_SPACE:
g_nCol = rand()%32,000;
break;

case VK_ESCAPE:
PostMessage( hWnd, WM_CLOSE, 0, 0 );
return 0;
}
break;

case WM_PAINT:
// We are redrawing every frame so we don't need
// to process this message. If we were using a
// pause screen, we could paint it here.
break;

case WM_DESTROY:
PostQuitMessage( 0 );
}

return DefWindowProc(hWnd, message, wParam, lParam);
}

static BOOL doInit( HANDLE hInstance, int nCmdShow )
{

HWND hwnd;
WNDCLASS wc;

g_hInstance = hInstance;

/*
* set up and register window class
*/
wc.style = CS_HREDRAW | CS_VREDRAW;
wc.lpfnWndProc = WindowProc;
wc.cbClsExtra = 0;
wc.cbWndExtra = 0;
wc.hInstance = hInstance;
wc.hIcon = LoadIcon( hInstance, IDI_APPLICATION );
wc.hCursor = LoadCursor( NULL, IDC_ARROW );
wc.hbrBackground = (HBRUSH)GetStockObject(BLACK_BRUSH);
wc.lpszMenuName = NAME;
wc.lpszClassName = NAME;
RegisterClass( &wc );

/*
* create a window
*/
hwnd = CreateWindowEx(
0,
NAME,
TITLE,
WS_POPUP,
0,
0,
GetSystemMetrics(SM_CXSCREEN),
GetSystemMetrics(SM_CYSCREEN),
NULL,
NULL,
hInstance,
NULL );

if( !hwnd )
{
return FALSE;
}

if FAILED( DDInit() )
{
Fail( "DirectDraw Init FAILED" );
return FALSE;
}

ShowWindow( hwnd, nCmdShow );
UpdateWindow( hwnd );

return TRUE;
}

int PASCAL WinMain( HINSTANCE hInstance, HINSTANCE hPrevInstance,
LPSTR lpCmdLine, int nCmdShow)
{
MSG msg;

// We'll use CoCreateInstance in this application

CoInitialize( NULL );

if( !doInit( hInstance, nCmdShow ) )
{
return FALSE;
}

while( 1 )
{
if( PeekMessage( &msg, NULL, 0, 0, PM_NOREMOVE ) )
{
if( !GetMessage( &msg, NULL, 0, 0 ) )
{
return msg.wParam;
}
TranslateMessage(&msg);
DispatchMessage(&msg);
}
else
{
if FAILED( UpdateFrames( ) )
{
DDRelease( );
return FALSE;
}
}
}
}

////////////////////////////////////////////////////
void CheckResult( HRESULT result )
{
switch ( result )
{
case DD_OK:
break;
case DDERR_ALREADYINITIALIZED:
Fail("DDERR_ALREADYINITIALIZED\n");
break;
case DDERR_BLTFASTCANTCLIP:
Fail("DDERR_BLTFASTCANTCLIP\n");
break;
case DDERR_CANNOTATTACHSURFACE:
Fail("DDERR_CANNOTATTACHSURFACE\n");
break;
case DDERR_CANNOTDETACHSURFACE:
Fail("DDERR_CANNOTDETACHSURFACE\n");
break;
case DDERR_CANTCREATEDC:
Fail("DDERR_CANTCREATEDC\n");
break;
case DDERR_CANTDUPLICATE:
Fail("DDERR_CANTDUPLICATE\n");
break;
case DDERR_CANTLOCKSURFACE:
Fail("DDERR_CANTLOCKSURFACE\n");
break;
case DDERR_CANTPAGELOCK:
Fail("DDERR_CANTPAGELOCK\n");
break;
case DDERR_CANTPAGEUNLOCK:
Fail("DDERR_CANTPAGEUNLOCK\n");
break;
case DDERR_CLIPPERISUSINGHWND:
Fail("DDERR_CLIPPERISUSINGHWND\n");
break;
case DDERR_COLORKEYNOTSET:
Fail("DDERR_COLORKEYNOTSET\n");
break;
case DDERR_CURRENTLYNOTAVAIL:
Fail("DDERR_CURRENTLYNOTAVAIL\n");
break;
case DDERR_DCALREADYCREATED:
Fail("DDERR_DCALREADYCREATED\n");
break;
case DDERR_DIRECTDRAWALREADYCREATED:
Fail("DDERR_DIRECTDRAWALREADYCREATED\n");
break;
case DDERR_EXCEPTION:
Fail("DDERR_EXCEPTION\n");
break;
case DDERR_EXCLUSIVEMODEALREADYSET:
Fail("DDERR_EXCLUSIVEMODEALREADYSET\n");
break;
case DDERR_GENERIC:
Fail("DDERR_GENERIC\n");
break;
case DDERR_HEIGHTALIGN:
Fail("DDERR_HEIGHTALIGN\n");
break;
case DDERR_HWNDALREADYSET:
Fail("DDERR_HWNDALREADYSET\n");
break;
case DDERR_HWNDSUBCLASSED:
Fail("DDERR_HWNDSUBCLASSED\n");
break;
case DDERR_IMPLICITLYCREATED:
Fail("DDERR_IMPLICITLYCREATED\n");
break;
case DDERR_INCOMPATIBLEPRIMARY:
Fail("Incampatible Primary\n");
break;
case DDERR_INVALIDCAPS:
Fail("DDERR_INVALIDCAPS\n");
break;
case DDERR_INVALIDCLIPLIST:
Fail("DDERR_INVALIDCLIPLIST\n");
break;
case DDERR_INVALIDDIRECTDRAWGUID:
Fail("DDERR_INVALIDDIRECTDRAWGUID\n");
break;
case DDERR_INVALIDMODE:
Fail("DDERR_INVALIDMODE\n");
break;
case DDERR_INVALIDOBJECT:
Fail("DDERR_INVALIDOBJECT\n");
break;
case DDERR_INVALIDPARAMS:
Fail("DDERR_INVALIDPARAMS\n");
break;
case DDERR_INVALIDPIXELFORMAT:
Fail("DDERR_INVALIDPIXELFORMAT\n");
break;
case DDERR_INVALIDPOSITION:
Fail("DDERR_INVALIDPOSITION\n");
break;
case DDERR_INVALIDRECT:
Fail("DDERR_INVALIDRECT\n");
break;
case DDERR_INVALIDSURFACETYPE:
Fail("DDERR_INVALIDSURFACETYPE\n");
break;
case DDERR_LOCKEDSURFACES:
Fail("DDERR_LOCKEDSURFACES\n");
break;
// case DDERR_MOREDATA:
// Fail("DDERR_MOREDATA\n");
// break;
case DDERR_NO3D:
Fail("DDERR_NO3D\n");
break;
case DDERR_NOALPHAHW:
Fail("DDERR_NOALPHAHW\n");
break;
case DDERR_NOBLTHW:
Fail("DDERR_NOBLTHW\n");
break;
case DDERR_NOCLIPLIST:
Fail("DDERR_NOCLIPLIST\n");
break;
case DDERR_NOCLIPPERATTACHED:
Fail("DDERR_NOCLIPPERATTACHED\n");
break;
case DDERR_NOCOLORCONVHW:
Fail("DDERR_NOCOLORCONVHW\n");
break;
case DDERR_NOCOLORKEY:
Fail("DDERR_NOCOLORKEY\n");
break;
case DDERR_NOCOLORKEYHW:
Fail("no colorkey hardware\n");
break;
case DDERR_NOCOOPERATIVELEVELSET:
Fail("DDERR_NOCOOPERATIVELEVELSET\n");
break;
case DDERR_NODC:
Fail("DDERR_NODC\n");
break;
case DDERR_NODDROPSHW:
Fail("DDERR_NODDROPSHW\n");
break;
case DDERR_NODIRECTDRAWHW:
Fail("DDERR_NODIRECTDRAWHW\n");
break;
case DDERR_NODIRECTDRAWSUPPORT:
Fail("DDERR_NODIRECTDRAWSUPPORT\n");
break;
case DDERR_NOEMULATION:
Fail("DDERR_NOEMULATION\n");
break;
case DDERR_NOEXCLUSIVEMODE:
Fail("DDERR_NOEXCLUSIVEMODE\n");
break;
case DDERR_NOFLIPHW:
Fail("DDERR_NOFLIPHW\n");
break;
case DDERR_NOGDI:
Fail("DDERR_NOGDI\n");
break;
case DDERR_NOHWND:
Fail("DDERR_NOHWND\n");
break;
case DDERR_NOMIPMAPHW:
Fail("DDERR_NOMIPMAPHW\n");
break;
case DDERR_NOMIRRORHW:
Fail("DDERR_NOMIRRORHW\n");
break;
case DDERR_NOOVERLAYDEST:
Fail("DDERR_NOOVERLAYDEST\n");
break;
case DDERR_NOOVERLAYHW:
Fail("DDERR_NOOVERLAYHW\n");
break;
case DDERR_NOPALETTEATTACHED:
Fail("DDERR_NOPALETTEATTACHED\n");
break;
case DDERR_NOPALETTEHW:
Fail("DDERR_NOPALETTEHW\n");
break;
case DDERR_NORASTEROPHW:
Fail("DDERR_NORASTEROPHW\n");
break;
case DDERR_NOROTATIONHW:
Fail("DDERR_NOROTATIONHW\n");
break;
case DDERR_NOSTRETCHHW:
Fail("DDERR_NOSTRETCHHW\n");
break;
case DDERR_NOT4BITCOLOR:
Fail("DDERR_NOT4BITCOLOR\n");
break;
case DDERR_NOT4BITCOLORINDEX:
Fail("DDERR_NOT4BITCOLORINDEX\n");
break;
case DDERR_NOT8BITCOLOR:
Fail("DDERR_NOT8BITCOLOR\n");
break;
case DDERR_NOTAOVERLAYSURFACE:
Fail("DDERR_NOTAOVERLAYSURFACE\n");
break;
case DDERR_NOTEXTUREHW:
Fail("DDERR_NOTEXTUREHW\n");
break;
case DDERR_NOTFLIPPABLE:
Fail("DDERR_NOTFLIPPABLE\n");
break;
case DDERR_NOTFOUND:
Fail("DDERR_NOTFOUND\n");
break;
case DDERR_NOTINITIALIZED:
Fail("DDERR_NOTINITIALIZED\n");
break;
case DDERR_NOTLOCKED:
Fail("DDERR_NOTLOCKED\n");
break;
case DDERR_NOTPAGELOCKED:
Fail("DDERR_NOTPAGELOCKED\n");
break;
case DDERR_NOTPALETTIZED:
Fail("DDERR_NOTPALETTIZED\n");
break;
case DDERR_NOVSYNCHW:
Fail("DDERR_NOVSYNCHW\n");
break;
case DDERR_NOZBUFFERHW:
Fail("DDERR_NOZBUFFERHW\n");
break;
case DDERR_NOZOVERLAYHW:
Fail("DDERR_NOZOVERLAYHW\n");
break;
case DDERR_OUTOFCAPS:
Fail("DDERR_OUTOFCAPS\n");
break;
case DDERR_OUTOFMEMORY:
Fail("Out of Memory\n");
break;
case DDERR_OUTOFVIDEOMEMORY:
Fail("DDERR_OUTOFVIDEOMEMORY\n");
break;
case DDERR_OVERLAYCANTCLIP:
Fail("DDERR_OVERLAYCANTCLIP\n");
break;
case DDERR_OVERLAYCOLORKEYONLYONEACTIVE:
Fail("DDERR_OVERLAYCOLORKEYONLYONEACTIVE\n");
break;
case DDERR_OVERLAYNOTVISIBLE:
Fail("DDERR_OVERLAYNOTVISIBLE\n");
break;
case DDERR_PALETTEBUSY:
Fail("DDERR_PALETTEBUSY\n");
break;
case DDERR_PRIMARYSURFACEALREADYEXISTS:
Fail("DDERR_PRIMARYSURFACEALREADYEXISTS\n");
break;
case DDERR_REGIONTOOSMALL:
Fail("DDERR_REGIONTOOSMALL\n");
break;
case DDERR_SURFACEALREADYATTACHED:
Fail("DDERR_SURFACEALREADYATTACHED\n");
break;
case DDERR_SURFACEALREADYDEPENDENT:
Fail("DDERR_SURFACEALREADYDEPENDENT\n");
break;
case DDERR_SURFACEBUSY:
Fail("DDERR_SURFACEBUSY\n");
break;
case DDERR_SURFACEISOBSCURED:
Fail("DDERR_SURFACEISOBSCURED\n");
break;
case DDERR_SURFACELOST:
Fail("DDERR_SURFACELOST\n");
break;
case DDERR_SURFACENOTATTACHED:
Fail("DDERR_SURFACENOTATTACHED\n");
break;
case DDERR_TOOBIGHEIGHT:
Fail("DDERR_TOOBIGHEIGHT\n");
break;
case DDERR_TOOBIGSIZE:
Fail("DDERR_TOOBIGSIZE\n");
break;
case DDERR_TOOBIGWIDTH:
Fail("DDERR_TOOBIGWIDTH\n");
break;
case DDERR_UNSUPPORTED:
Fail("DDERR_UNSUPPORTED\n");
break;
case DDERR_UNSUPPORTEDFORMAT:
Fail("DDERR_UNSUPPORTEDFORMAT\n");
break;
case DDERR_UNSUPPORTEDMASK:
Fail("DDERR_UNSUPPORTEDMASK\n");
break;
case DDERR_UNSUPPORTEDMODE:
Fail("DDERR_UNSUPPORTEDMODE\n");
break;
case DDERR_VERTICALBLANKINPROGRESS:
Fail("DDERR_VERTICALBLANKINPROGRESS\n");
break;
// case DDERR_VIDEONOTACTIVE:
// Fail("DDERR_VIDEONOTACTIVE\n");
// break;
case DDERR_WASSTILLDRAWING:
Fail("DDERR_WASSTILLDRAWING\n");
break;
case DDERR_WRONGMODE:
Fail("DDERR_WRONGMODE\n");
break;
case DDERR_XALIGN:
Fail("DDERR_XALIGN\n");
break;
default:
Fail("Unknown return value\n");
break;
}
}

Follow Ups:

  • Re: DDERR_NOEXLCUSIVE??? WHY??? Clay 07:33:49 7/01/98 (1)
    • Re: DDERR_NOEXLCUSIVE??? WHY??? Doug Linley 08:48:01 7/01/98 (0)

Post a Followup

Name:


DrawPrimitive Mouse To World?

Posted by Doug on June 30, 1998 at 21:52:36:

I moved from RM to IM DrawPrimitive. In RM I could get user mouse coords to select objects with Pick() and GetPick() methods.

How can I do this with DrawPrimitive? Matrix (World, View, Projection)?

Any help please...

Doug,

Follow Ups:

Post a Followup

Name:


How do you save the texture on a face?

Posted by Snowman on June 30, 1998 at 22:28:36:

If you set a texture to a face in an object, then save the object (using the SAVEALL flag), when you reload it you don't see the textures anymore. Why? Is there anything I can do to fix it? When I fill the whole mesh with a texture (in one call from the meshbuilder pointer, not filling in all of the faces) it all works fine. And if I color a face and save it, the face will come up the right color.

Thanks to anyone who can help in advance

-Snowman

Follow Ups:

Post a Followup

Name:


Re: DrawPrimitives ???

Posted by Clay on July 01, 1998 at 07:29:55:

In Reply to: Re: DrawPrimitives ??? posted by Frenchy FADGE on June 30, 1998 at 09:00:28:

Are you using a different device for RM and IM?
BeginScene() will fail if you missed a step in initialization. Other than that, I don't know.

Clay

: Hello, and thank you very much for your support

: BeginScene() returns
: HRESULT= -2005531912
: ERROR Unknown error

: And when the hand is given to the render Retained Mode, SceneFrame->Render() fails and returns:

: ERROR Device is not compatible with renderer

: What's wrong ?
: I checked the device and viewport immediate mode with the functions GetViewport2(&data) and GetRenderState(Type,State) and the values seems correct.

: Thanks
: FADGE ( fadge1er@hol.fr )

Follow Ups:

  • THE solution Frenchy FADGE 17:00:01 7/01/98 (0)

Post a Followup

Name:


Re: DDERR_NOEXLCUSIVE??? WHY???

Posted by Clay on July 01, 1998 at 07:33:49:

In Reply to: DDERR_NOEXLCUSIVE??? WHY??? posted by Doug Linley on June 30, 1998 at 21:33:10:

You absolutely have to do ShowWindow() and UpdateWindow() before you try SetCooperativeLevel(). The symptoms you describe are typical if your window is not completely initialized before you use DDraw.

Clay

Follow Ups:

  • Re: DDERR_NOEXLCUSIVE??? WHY??? Doug Linley 08:48:01 7/01/98 (0)

Post a Followup

Name:


What's with my frame rate??

Posted by Clay on July 01, 1998 at 07:40:50:

I'm using IM to experiment with matrix manipulation. I've got 2 triangles that I'm rotating by various angles around various axes. I'm not waiting for the vertical blank when I Flip() surfaces. When I rotate about one axis, my frame rate is ~170 fps. When I rotate about 3 axes (X then Y then Z, successively) my frame rate is about ~250 fps. I'm using a CL 3dfxV2 w/12M. Can anyone explain this to me? Is it a bus latency (it takes more time to do 3 rotations)?

Clay

Follow Ups:

Post a Followup

Name:


Re: DDERR_NOEXLCUSIVE??? WHY???

Posted by Doug Linley on July 01, 1998 at 08:48:01:

In Reply to: Re: DDERR_NOEXLCUSIVE??? WHY??? posted by Clay on July 01, 1998 at 07:33:49:

Clay -

Thanks for your help! i made the change and it worked! I appreciate your taking the time to look at my code.

--Doug Linley

: You absolutely have to do ShowWindow() and UpdateWindow() before you try SetCooperativeLevel(). The symptoms you describe are typical if your window is not completely initialized before you use DDraw.

: Clay

Follow Ups:

Post a Followup

Name:


How to create a simply filter in Delphi ?

Posted by Laurent TAUPIN on July 01, 1998 at 11:34:16:

Lots of people says (including Microsoft themself)
that we can create filter, source, & renderer
filter with any language supporting COM objects.
Delphi 3 does it... But ??
I just want to know (or have an example) of
how to create a simply filter that take the data
from IN PIN, and put them to OUT PIN.
This filter will be placed between Source Async
Filter & a MPEG Splitter...
If someone knows how to do that (even in C++),
PLEASEEEEEE HEEEELP ME.. Thanks...

:-(

Follow Ups:

Post a Followup

Name:


How to control all the file with a DirectShow Filter

Posted by Laurent TAUPIN on July 01, 1998 at 11:38:08:

I would like to have a simple func who will
have ALL the data loaded by the Async File Filter
(including headers, etc...) do some things on
this data and then send them to... by example
to MPEG Splitter, or AVI Splitter, or anything
else...
Have you an exemple or an explanation ?

Thank you... ;-)

Follow Ups:

Post a Followup

Name:


Windows NT 4.0 Support for Direct X

Posted by Juan on July 01, 1998 at 15:14:23:

When will Windows NT 4.0 Support Direct X 5.0? Does anyone have any information? It supports smoe things , like Age of Empires, but not others like Jedi Knight

Follow Ups:

  • Re: Windows NT 4.0 Support for Direct X G. Bereznicki 14:31:10 7/07/98 (0)

Post a Followup

Name:


Re: RE: How do you load multiple meshes?

Posted by Joe Michael on July 01, 1998 at 16:01:54:

In Reply to: RE: How do you load multiple meshes? posted by Me on June 06, 1998 at 22:13:31:

:
: I am working in Direct 3D Retained Mode. I need to know how to load a *.x file that contains multiple meshes. I always get an error when I try to load them with the meshbuilders load function.

use frame::load , its the same as meshbuilder only it loads the entire frame higherarchy in the file

Follow Ups:

Post a Followup

Name:


I realy need a frame::save()

Posted by Joe Michael on July 01, 1998 at 16:12:25:

I need to save a frame higherarchy textures and all, I
can provide the function the file locations of the
textures or whatever else. Please help. If I have to
write my own save() I will post it here for all to share.
I think it is silly stupid that the writers of d3d couldn't
include a save function for their own file format!!!!

Follow Ups:

Post a Followup

Name:


THE solution

Posted by Frenchy FADGE on July 01, 1998 at 17:00:01:

In Reply to: Re: DrawPrimitives ??? posted by Clay on July 01, 1998 at 07:29:55:

After several attempts (about 1 000 000)
I have found the problem:

When you use a UserVisual to perform a specific IM render inside an appli written in RM(like in the SDK sample UVIS but with DrawPrimitives and not Executte Buffers), DirectX does bracketing the render callback function with BeginScene/EndScene.
So, You don't have to put these functions around your call to Drawprimitive.

In fact, DX calls BeginScene when you do Frame->Render() and EndScene when Clear().
(Or it is the opposite, I don't remenber)

That's all folks.
Enjoy yourself trying to understand capabilities not documented of DirectX.

Ciao

T

Follow Ups:

Post a Followup

Name:


TIP: DrawPrimitive in RM

Posted by Frenchy FADGE on July 01, 1998 at 17:17:25:

YOU have choose Retained Mode but want to use the DrawPrimitive to perform a specific rendering to one specific Object => Read this TIP:

After several attempts (about 1 000 000)
I have found the problem:

When you use a UserVisual to perform a specific IM render inside an appli written in RM(like in the SDK sample UVIS but with DrawPrimitives and not Executte Buffers), DirectX does bracketing the render callback function with BeginScene/EndScene.
So, You don't have to put these functions around your call to Drawprimitive.

In fact, DX calls BeginScene when you do Frame->Render() and EndScene when Clear().
(Or it is the opposite, I don't remenber)

That's all folks.
Enjoy yourself trying to understand capabilities not documented of DirectX.

(Excuses for my bad english speaking; I'am French)

Ciao
Frenchy FADGE (fadge1er@hol.fr)
University Student

Follow Ups:

Post a Followup

Name:


Z-Buffers!!!

Posted by Shai'tan [Nth] on July 02, 1998 at 00:32:57:

Ok, So I get everything working cool, and now I want to do some Z-Buffering for hidden surface removal and all that. I use the Demo code, using a 16bit Z-Buffer, and when I enable ZENABLE everything just disapears. If I only turn on ZWRITEENABLE or whatever, everything is fine. But as soon as ZENABLE goes on, nothing appears. Why????

Please help!

Follow Ups:

Post a Followup

Name:


Re: I need DirectX5

Posted by Roger Perez on July 02, 1998 at 03:09:15:

In Reply to: I need DirectX5 posted by Denton Duncan on June 28, 1998 at 12:41:27:

: I downloaded a demo but I need directX5. Can I download it for free?. Where can I get it?

Follow Ups:

  • Re: I need DirectX5 퀂�� 21:51:42 7/03/98 (0)

Post a Followup

Name:


drawing sprites

Posted by Gabriel on July 02, 1998 at 20:10:30:

latly I've been working on a game using directdraw.
And so far the most dificult problem I have run into
has been drawing the dang sprites. I've been drawing
one and then rotation it 10 degrees and trying to position
it in my main bitmap. If there is a program out there that
can give me a complete list of sprites by only suppling one
it would really save me alot of time.

any response is greatly appriciated, thanks.

Follow Ups:

Post a Followup

Name:


DrawPrimitive InverseTransform?

Posted by Doug on July 02, 1998 at 22:43:26:

Please help...

How can I convert screen coords to model coords using DX5 DrawPrimitive? (So I know exactly what mouse is pointing at in model coords)

Do I have to mess with world,view,projection matrix's? How?

Any help please...

Doug

Follow Ups:

Post a Followup

Name:


Ddrawex.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12

Posted by Spikes on July 03, 1998 at 10:18:39:

Ddrawex.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12

Does anyone know what I can do to fix this error?
It shows when I compile a DirectDraw example.

Please HELP me!

Follow Ups:

  • Re: Ddrawex.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12 arrr 22:28:17 7/03/98 (0)

Post a Followup

Name:


Re: directX5

Posted by �s�� on July 03, 1998 at 21:44:16:

In Reply to: Re: directX5 posted by Mr.Goodbar on May 23, 1998 at 01:08:15:

: : my directx seems not to be working i can play certain games like monster truck maddness but no games that use directx5 i was wondering if i can reload or down load from another source iam new at computing so if anyone can help that would be greati dont know if this is important but i have a fairly new 233 gateway pent.2 thanks agin mike

Follow Ups:

Post a Followup

Name:


Re: directX5

Posted by �s�� on July 03, 1998 at 21:44:48:

In Reply to: Re: directX5 posted by Mr.Goodbar on May 23, 1998 at 01:08:15:

: : my directx seems not to be working i can play certain games like monster truck maddness but no games that use directx5 i was wondering if i can reload or down load from another source iam new at computing so if anyone can help that would be greati dont know if this is important but i have a fairly new 233 gateway pent.2 thanks agin mike

Follow Ups:

Post a Followup

Name:


Re: directX5

Posted by �s�� on July 03, 1998 at 21:45:08:

In Reply to: Re: directX5 posted by Mr.Goodbar on May 23, 1998 at 01:08:15:

: : my directx seems not to be working i can play certain games like monster truck maddness but no games that use directx5 i was wondering if i can reload or down load from another source iam new at computing so if anyone can help that would be greati dont know if this is important but i have a fairly new 233 gateway pent.2 thanks agin mike

Follow Ups:

  • Re: directX5 �s�� 21:48:27 7/03/98 (0)

Post a Followup

Name:


Re: directX5

Posted by �s�� on July 03, 1998 at 21:48:27:

In Reply to: Re: directX5 posted by �s�� on July 03, 1998 at 21:45:08:

: : : my directx seems not to be working i can play certain games like monster truck maddness but no games that use directx5 i was wondering if i can reload or down load from another source iam new at computing so if anyone can help that would be greati dont know if this is important but i have a fairly new 233 gateway pent.2 thanks agin mike

Follow Ups:

Post a Followup

Name:


Re: I need DirectX5

Posted by �s�� on July 03, 1998 at 21:51:42:

In Reply to: Re: I need DirectX5 posted by Roger Perez on July 02, 1998 at 03:09:15:

: : I downloaded a demo but I need directX5. Can I download it for free?. Where can I get it?

Follow Ups:

Post a Followup

Name:


Re: Ddrawex.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12

Posted by arrr on July 03, 1998 at 22:28:17:

In Reply to: Ddrawex.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12 posted by Spikes on July 03, 1998 at 10:18:39:

are you compiling a C file as C++, or vice versa?
that would cause errors like that

: Ddrawex.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12

: Does anyone know what I can do to fix this error?
: It shows when I compile a DirectDraw example.

: Please HELP me!

Follow Ups:

Post a Followup

Name:


x-pert wanted for direct sound

Posted by jobb on July 04, 1998 at 22:44:58:

hello ......

is it possible to trigger a wave-file via midi
and assign different wave files to different audio outputs???

and what language is the best for doing this????
i know only assembler from dos ...!!!

please help me and email me !!!!!!!!!

thanx.....

jobb

Follow Ups:

Post a Followup

Name:


Re: FAST Input Read from Mouse

Posted by Gunnar Holm on July 05, 1998 at 08:42:25:

In Reply to: Re: FAST Input Read from Mouse posted by 0x1CE on June 18, 1998 at 03:38:50:

Just a comment, note that the serial mouse uses
2400-9600 bit/s, and one x-y-button package is
3-5 bytes = let's say 40 bits.
On 2400 it would be 2400/40 = 60Hz = appr 20ms
on 9600 4 times faster but still 5ms.

I guess the mouse also doesn;t send x-y-button bytes full stream.

Try a terminal program to the com port, move the mouse and count
how many bytes you get in a cetain time.

Just some thoughts, wrote a bimodal mouse
irq driver long time ago (DOS 32bit) Gunnar

Follow Ups:

Post a Followup

Name:


DirectShow??

Posted by Snowman on July 05, 1998 at 16:22:10:

What is DirectShow? I keep hearing about it, but I don't know what it is. It's not included in the DirectX 5 SDK Documentation, that I could find. What is it, where do you get info on it, and what is it used for?

Any help would be appritiated Thanks in advance

Follow Ups:

Post a Followup

Name:


Need help with Z-Buffers! Please!!

Posted by Shai'tan on July 05, 1998 at 21:39:10:

I desperately need to use Z-Buffers in a D3D Immediate mode project I'm working on. I am currently using Z-Buffer code I copied from a sample. I create the Z-Buffer using a 16-bit depth flag, and attach it to tbe back buffer with no problems.
Even DirectX agrees nothing is wrong, as everything is DD_OK. But then when I SetRenderstate->( D3DZENABLE, TRUE ) ( or whatever the enum is, the ZENABLE one anyway ) - something really dumb happens. Nothing is displayed. NONE of the primitives are drawn.

What is going on? PLEASE help! Even the smallest suggestion is HIGHLY appreciated. It is driving me INSANE!! :)

Thanks in advance!

Follow Ups:

  • Re: Need help with Z-Buffers! Please!! Fragmo 22:33:59 7/05/98 (3)
    • Re: Thanks, but still need help :) Shai'tan 00:55:12 7/06/98 (2)
      • Re: Thanks, but still need help :) Fragmo 01:12:57 7/06/98 (1)
        • If you still need help Clay 07:48:12 7/06/98 (0)

Post a Followup

Name:


Please help me move the camera in D3DRM?

Posted by LT on July 05, 1998 at 22:19:01:

I've got a simple D3DRM program with a camera at 0,0,0 and a sphere at 0,0,15. I try to move the camera frame with:

m_piCameraFrame->SetPosition ( m_piScene, x, y, z );

but nothing happens no matter what values I use for x, y, and z. What gives?

Follow Ups:

  • Re: Please help me move the camera in D3DRM? Snowman 23:35:07 7/05/98 (2)
    • Re: Please help me move the camera in D3DRM? LT 20:47:47 7/06/98 (1)
      • Solved. LT 00:11:38 7/07/98 (0)

Post a Followup

Name:


Please help with Retained Mode.

Posted by LT on July 05, 1998 at 22:25:28:

I've got a simple retained mode program with a camera at 0, 0, 0, and 8 spheres at the corners of a cube shaped area. The scale and zoom are set so I can see everything perfectly. Whenever I start adding spheres to random locations within the area the zoom and scale gets all screwed up. Since I can see all the extremities of the space I am dealing with why does adding objects within it screw up the viewing frustratum???

Follow Ups:

  • Re: Please help with Retained Mode. LT 20:49:13 7/06/98 (0)

Post a Followup

Name:


Re: Need help with Z-Buffers! Please!!

Posted by Fragmo on July 05, 1998 at 22:33:59:

In Reply to: Need help with Z-Buffers! Please!! posted by Shai'tan on July 05, 1998 at 21:39:10:

what type of vertices are you using to draw? lit, transformed?
check your z values. the z values that are in front of the view will depend on how you setup the
view matrix, you may just need to flip the sign of the vertices. also make sure you clear the z buffer.
if you use transformed vertices, your z values should range from 0 - 1, and will always be positive.
you might check your viewport too. make sure you set the dvMinZ = 0 and dvMaxZ = 1.

www.public.iastate.edu/~jtilton/rpg.htm

:
: I desperately need to use Z-Buffers in a D3D Immediate mode project I'm working on. I am currently using Z-Buffer code I copied from a sample. I create the Z-Buffer using a 16-bit depth flag, and attach it to tbe back buffer with no problems.
: Even DirectX agrees nothing is wrong, as everything is DD_OK. But then when I SetRenderstate->( D3DZENABLE, TRUE ) ( or whatever the enum is, the ZENABLE one anyway ) - something really dumb happens. Nothing is displayed. NONE of the primitives are drawn.

: What is going on? PLEASE help! Even the smallest suggestion is HIGHLY appreciated. It is driving me INSANE!! :)

: Thanks in advance!

Follow Ups:

  • Re: Thanks, but still need help :) Shai'tan 00:55:12 7/06/98 (2)
    • Re: Thanks, but still need help :) Fragmo 01:12:57 7/06/98 (1)
      • If you still need help Clay 07:48:12 7/06/98 (0)

Post a Followup

Name:


Re: busy at work...

Posted by Me on July 05, 1998 at 23:32:12:

In Reply to: busy at work... posted by Clay on June 23, 1998 at 07:22:16:

: Anyhow, if you want, send an email and I'll zip up a bunch of stuff I wrote (it is pretty well commented) and send it to you.

: Clay

What's your email address (I can't just click on your name, because my email is at Yahoo! I would love a sample program. Please post it so that I can get this. Thanks for all of the help so far!

-Me (Snowman)

P.S. I still haven't figured out how to save the texture on a face. Thanks!

Follow Ups:

Post a Followup

Name:


Re: Please help me move the camera in D3DRM?

Posted by Snowman on July 05, 1998 at 23:35:07:

In Reply to: Please help me move the camera in D3DRM? posted by LT on July 05, 1998 at 22:19:01:

Can you move the spheres? Also if you are trying to make a game or anything of the sort, there's a better way to do it. I hope I can help

-Snowman

: I've got a simple D3DRM program with a camera at 0,0,0 and a sphere at 0,0,15. I try to move the camera frame with:

: m_piCameraFrame->SetPosition ( m_piScene, x, y, z );

: but nothing happens no matter what values I use for x, y, and z. What gives?

Follow Ups:

  • Re: Please help me move the camera in D3DRM? LT 20:47:47 7/06/98 (1)
    • Solved. LT 00:11:38 7/07/98 (0)

Post a Followup

Name:


Re: Thanks, but still need help :)

Posted by Shai'tan on July 06, 1998 at 00:55:12:

In Reply to: Re: Need help with Z-Buffers! Please!! posted by Fragmo on July 05, 1998 at 22:33:59:

: what type of vertices are you using to draw? lit, transformed?

I am using transformed vertices. Everything in that regard I believe is working, as before I implemented ( or tried ) the Z-Buffer, everything worked and I could walk around in my world. I am using D3DVT_LVERTEX for the vertices.
: check your z values. the z values that are in front of the view will depend on how you setup the
: view matrix, you may just need to flip the sign of the vertices. also make sure you clear the z buffer.
Yep, done that. My Z values range from 0 to around 20000. Personal choice I suppose :) Yeah, clearing the Z-Buffer. I think my code works...but how to know? How do you do it?

I went to your page, but I see your Doom-style engine uses BSP, not Z-Buffering. Is BSP a significant improvement? Is it faster? If so, I wills crap Z-Buffers and try that :)

Thanks for your help!

Follow Ups:

  • Re: Thanks, but still need help :) Fragmo 01:12:57 7/06/98 (1)
    • If you still need help Clay 07:48:12 7/06/98 (0)

Post a Followup

Name:


Re: Thanks, but still need help :)

Posted by Fragmo on July 06, 1998 at 01:12:57:

In Reply to: Re: Thanks, but still need help :) posted by Shai'tan on July 06, 1998 at 00:55:12:

when you say your z values range from 0 to 20000, is that the value you set in the viewport?
if so, then that is the problem, since those should be the transformed z values, and range 0 - 1.
if all else fails, i suggest just trying a single transformed and lit triangle just to get the
z buffer working, that way you don't have to guess where the transformed verts will be on the screen.
i use sample code for mine too, and mine worked without too much trouble, so i'm running out of suggestions :(

: : what type of vertices are you using to draw? lit, transformed?

: I am using transformed vertices. Everything in that regard I believe is working, as before I implemented ( or tried ) the Z-Buffer, everything worked and I could walk around in my world. I am using D3DVT_LVERTEX for the vertices.
: : check your z values. the z values that are in front of the view will depend on how you setup the
: : view matrix, you may just need to flip the sign of the vertices. also make sure you clear the z buffer.
: Yep, done that. My Z values range from 0 to around 20000. Personal choice I suppose :) Yeah, clearing the Z-Buffer. I think my code works...but how to know? How do you do it?

: I went to your page, but I see your Doom-style engine uses BSP, not Z-Buffering. Is BSP a significant improvement? Is it faster? If so, I wills crap Z-Buffers and try that :)

even using a bsp for your world would leave you with the problem of sorting objects in a scene, which would be easily solved with the
z buffer, so it looks like you probably still have some debugging to do :P

: Thanks for your help!

Follow Ups:

  • If you still need help Clay 07:48:12 7/06/98 (0)

Post a Followup

Name:


Retained mode translucency

Posted by Al on July 06, 1998 at 04:26:39:

In Reply to: Been there (, allmost jumped off a tall building), done that posted by sietze on May 08, 1998 at 12:10:44:

: : I have a model of the solar system that I want to use alpha-blending in. The problem is,
: the only way I've been able to get any sort of transparent effect is by keeping the IDirect3DDevice
: I use for creating my IDirect3DRMDevice and calling SetRenderState(). This seems to ignore the
: alpha component of my colors and make everything equally transparent. If any of you have a way to
: selectively choose which visuals are rendered transparently, and control how transparent they are,
: I'd really appreciate it!

: : Clay

: Hi,

: You are very close to the jackpot, you are only missing

Follow Ups:

Post a Followup

Name:


If you still need help

Posted by Clay on July 06, 1998 at 07:48:12:

In Reply to: Re: Thanks, but still need help :) posted by Fragmo on July 06, 1998 at 01:12:57:

This is background color dependant (At least it seems to be) but when you use D3DVT_LVERTEX or D3D_VERTEX for DrawPrimitive(), you should use IDirect3DViewport2::Clear(NumRect,&Rect,D3DCLEAR_TARGET|D3DCLEAR_ZBUFFER). This is analagous to the RM function Clear(). When I don't use Clear(), it doesn't draw to the screen.

Clay

Follow Ups:

Post a Followup

Name:


Linker Error with Direct Input

Posted by Chris Goetschius on July 06, 1998 at 13:22:20:

ddapp.obj : error LNK2001: unresolved external symbol _GUID_SysMouse
i have all the headers in included, and the dx5 sdk stuff is above the other include directory stuff under options. Does anyone know why i am getting this and how to fix it? Thanx

GoatCheez

Follow Ups:

  • Re: Linker Error with Direct Input Gunnar 19:29:21 7/16/98 (0)

Post a Followup

Name:


Sprites clipping on edge of screen!

Posted by Pet Monster on July 06, 1998 at 13:52:16:

Can anyone tell me how to prevent sprites from clipping
if they are even partially off the screen. I try to
put a 40x40 sprite at coords (0, 620) on a 640x480
fullscreen mode screen. It never displays the sprite
if it is at all off the screen! Can anyone help me or
direct me in the right direction???

Follow Ups:

  • Re: Sprites clipping on edge of screen! michael 01:41:31 7/16/98 (0)
  • Re: Sprites clipping on edge of screen! Pet Monster 11:24:21 7/08/98 (0)
  • Re: Sprites clipping on edge of screen! Johnny Rotten 10:29:36 7/07/98 (0)
  • Re: Sprites clipping on edge of screen! Errant 07:07:45 7/07/98 (0)
  • Re: READ THIS ONE! Pet Monster 13:53:45 7/06/98 (0)

Post a Followup

Name:


Re: READ THIS ONE!

Posted by Pet Monster on July 06, 1998 at 13:53:45:

In Reply to: Sprites clipping on edge of screen! posted by Pet Monster on July 06, 1998 at 13:52:16:

: Can anyone tell me how to prevent sprites from clipping
: if they are even partially off the screen. I try to
: put a 40x40 sprite at coords (620,0) on a 640x480
: fullscreen mode screen. It never displays the sprite
: if it is at all off the screen! Can anyone help me or
: direct me in the right direction???

Follow Ups:

Post a Followup

Name:


DrawPrimitive in user visuals

Posted by Kevin Cline on July 06, 1998 at 15:26:38:

Yesterday I was trying to use DrawPrimitive in a uservisual and ran into a brick wall.

In the callback function, I used the device passed as an argument to query for IDirect3DRMDevice2. This worked. Next I called IDirect3DRMDevice2::GetDirect3DDevice2. The problem arose here: it returned D3DRM_OK, but the pointer to the immediate mode device was null.

Is there anyway around this?

Even if there isn't, it's still interesting that the return value was D3DRM_OK.

Thanks,
Kevin Cline

Follow Ups:

Post a Followup

Name:


Re: Games

Posted by chump on July 06, 1998 at 16:21:29:

In Reply to: Games posted by Me on June 15, 1998 at 13:51:25:

: Has anyone actually made a quake style game in D3D? Is it even possible given the funtions we have to work with?
Forsaken was made in Direct3D.. if you consider that a "quake style" game.

Follow Ups:

Post a Followup

Name:


Re: Converting files

Posted by KC on July 06, 1998 at 17:10:52:

In Reply to: Re: Converting files posted by Me on June 23, 1998 at 16:54:07:

Try Crossroads or 3DWin, both have a few bugs, but are free.

Crossroads is at
http://www.europa.com/~keithr/crossroads/

3DWin is at
http://ourworld.compuserve.com/homepages/thbaier

:
: That's the problem, it cost $500!!! I do this as a hobby. I have looked into PolyTrans, it is $395. But I don't have that much to spend. Are there any cheaper ones?

: Thanks

: : Have you tried "PolyTrans"?? (only cost around US$500.)

Follow Ups:

Post a Followup

Name:


Re: Get DirectX 5.0 SDK here. Anybody know where to get 5.2?

Posted by R.JONES on July 06, 1998 at 19:09:12:

In Reply to: Get DirectX 5.0 SDK here. Anybody know where to get 5.2? posted by M. Wagner on May 28, 1998 at 00:56:21:

: : Does anyone now where of how I can download the :5.0 SDK. Microsoft have taken it off line :requiring you to buy a CD off them giving them :all your info (inc CC#). They suck.

: The following site has a list of links that will let you download DirectX SDK 5.0

: http://www.triax.com/ben/dx5/index.html

: I wouldn't be surprised if Microsoft eventually turned it into a commercial products. They suck.
: :)

Follow Ups:

Post a Followup

Name:


Draw Primitive ZBuffer

Posted by Karl Fisher on July 06, 1998 at 19:42:53:

Help Please,

I am a beginner with Direct 3D and I am stumped on implementing Z Buffering for Immediate Mode.

I am trying to add ZBuffering to the CDX IM example.

It all compiles and runs, but no matter what I do the second draw primitive is always rendered on top of the first draw primitive regardless of there Z Values.

The following is the code I am trying to use, and obviously I am missing something. Any suggestions will be greatly appreciated.

/////////////////////////////////////////////////////////////////////////////////////
// InitApp
/////////////////////////////////////////////////////////////////////////////////////
BOOL InitApp(HINSTANCE hInst, int nCmdShow)
{
HWND hWnd;
HRESULT rval;
WNDCLASS WndClass;

WndClass.style = CS_HREDRAW | CS_VREDRAW;
WndClass.lpfnWndProc = WinProc;
WndClass.cbClsExtra = 0;
WndClass.cbWndExtra = 0;
WndClass.hInstance = hInst;
WndClass.hIcon = LoadIcon(hInst, IDI_APPLICATION);
WndClass.hCursor = LoadCursor(NULL, IDC_ARROW);
WndClass.hbrBackground = NULL;
WndClass.lpszMenuName = "Orbits";
WndClass.lpszClassName = "Orbits";
RegisterClass(&WndClass);

hWnd = CreateWindowEx(
WS_EX_TOPMOST,
"Orbits",
"Orbits",
WS_POPUP,
0,0,
GetSystemMetrics(SM_CXSCREEN),
GetSystemMetrics(SM_CYSCREEN),
NULL,
NULL,
hInst,
NULL);

if(!hWnd) return FALSE;

ShowWindow(hWnd, nCmdShow);
UpdateWindow(hWnd);

DirectDrawEnumerate(EnumDD, &DirectDraw);

// Create the DirectDraw instance
if(!DirectDraw) rval = DirectDrawCreate(NULL, &DirectDraw, NULL);

DirectDraw->SetCooperativeLevel(hWnd, DDSCL_FULLSCREEN | DDSCL_EXCLUSIVE);
DirectDraw->SetDisplayMode(SCREEN_WIDTH, SCREEN_HEIGHT, SCREEN_BPP);

DDSURFACEDESC ddsd;
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_BACKBUFFERCOUNT;
ddsd.ddsCaps.dwCaps = DDSCAPS_PRIMARYSURFACE |
DDSCAPS_FLIP |
DDSCAPS_COMPLEX |
DDSCAPS_3DDEVICE |
DDSCAPS_VIDEOMEMORY;
ddsd.dwBackBufferCount = 1;

// Create the FrontBuffer
DirectDraw->CreateSurface(&ddsd, &FrontBuffer, NULL);

DDSCAPS ddscaps;
ddscaps.dwCaps = DDSCAPS_BACKBUFFER;

// Create the BackBuffer
FrontBuffer->GetAttachedSurface(&ddscaps, &BackBuffer);

// Create the Direct3D instance
DirectDraw->QueryInterface(IID_IDirect3D2, (LPVOID*)&Direct3D);

D3DFINDDEVICESEARCH search;
D3DFINDDEVICERESULT result;

search.dwSize = sizeof(search);
search.dwFlags = D3DFDS_HARDWARE;
search.bHardware = TRUE;
result.dwSize = sizeof(result);

// Create the hardware Device
Direct3D->FindDevice(&search, &result);

/*
///////////////////////// Start ZBuffer //////////////////
*/

ZeroMemory(&ddsd,sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS |
DDSD_WIDTH |
DDSD_HEIGHT |
DDSD_ZBUFFERBITDEPTH;
ddsd.ddsCaps.dwCaps = DDSCAPS_ZBUFFER | DDSCAPS_VIDEOMEMORY;
ddsd.dwWidth = dwWidth;
ddsd.dwHeight = dwHeight;
ddsd.dwZBufferBitDepth = 16;

DirectDraw->CreateSurface(&ddsd, &lpddsZBuff, NULL);

BackBuffer->AddAttachedSurface(lpddsZBuff);

/*
///////////////////////// End ZBuffer //////////////////

*/

Direct3D->CreateDevice(result.guid, BackBuffer, &Device);

HardwareAvailable = TRUE;

if(Device == NULL)
{
HardwareAvailable = FALSE;
search.dwSize = sizeof(search);
search.dwFlags = D3DFDS_HARDWARE;
search.bHardware = FALSE;
result.dwSize = sizeof(result);

// Create the software Device
Direct3D->FindDevice(&search, &result);
Direct3D->CreateDevice(result.guid, BackBuffer, &Device);
}

D3DVIEWPORT2 viewport;
memset(&viewport, 0, sizeof(D3DVIEWPORT2));
viewport.dwSize = sizeof(D3DVIEWPORT2);
viewport.dwX = 0;
viewport.dwY = 0;
viewport.dwWidth = SCREEN_WIDTH;
viewport.dwHeight = SCREEN_HEIGHT;
viewport.dvClipX = -1.0f;
viewport.dvClipWidth = 2.0f;
viewport.dvClipHeight = (D3DVALUE)(SCREEN_HEIGHT * 2.0 / SCREEN_WIDTH);
viewport.dvClipY = viewport.dvClipHeight / 2.0f;

viewport.dvMinZ = 0.0f;

viewport.dvMaxZ = 1.0f;

// Create the Viewport
Direct3D->CreateViewport(&Viewport, NULL);
Device->AddViewport(Viewport);
Viewport->SetViewport2(&viewport);

Device->SetCurrentViewport(Viewport);

World = IdentityMatrix();

View = ViewMatrix(D3DVECTOR(0.0,0.0,-20.0), D3DVECTOR(0.0,0.0,0.0), D3DVECTOR(0,1,0), 0);

Projection = ProjectionMatrix(0.01f, 2000000.0f, (float)(60*PI/180));

Device->SetTransform(D3DTRANSFORMSTATE_WORLD, &World);
Device->SetTransform(D3DTRANSFORMSTATE_VIEW, &View);
Device->SetTransform(D3DTRANSFORMSTATE_PROJECTION, &Projection);

lpSphereMat = new Material(Direct3D, Device);
lpSphereMat->SetDiffuse(D3DVECTOR(1.0f));

// Create the sphere texture and attatch it to the material
Texture.Load(Device, "Texture.bmp");
lpSphereMat->SetTextureHandle(Texture.GetHandle());

Device->SetRenderState(D3DRENDERSTATE_ZENABLE,TRUE);

lpSphere2Mat = new Material(Direct3D, Device2);
lpSphere2Mat->SetDiffuse(D3DVECTOR(1.0f));

D3DVECTOR pLightPosition(0.0f, 5.0f, -18.0f);

lpPointLight = new PointLight(Direct3D, D3DVECTOR(1.0f), pLightPosition);

lpPointLight->SetAttenuation(D3DVECTOR(1.0f, 1.0f, 1.0f));

lpPointLight->SetRange(130.0f);

lpPointLight->AddToViewport(Viewport);

GenerateSphere();

return TRUE;
}

/////////////////////////////////////////////////////////////////////////////////////
// WinMain
/////////////////////////////////////////////////////////////////////////////////////
int PASCAL WinMain(HINSTANCE hInst, HINSTANCE hPrevInst, LPSTR lpCmdLine, int nCmdShow)
{
MSG msg;

if(!InitApp(hInst, nCmdShow)) return FALSE;

while(1)
{
if(PeekMessage(&msg, NULL, 0, 0, PM_NOREMOVE))
{
if(!GetMessage(&msg, NULL, 0, 0 )) return msg.wParam;
TranslateMessage(&msg);
DispatchMessage(&msg);
}
else if(bActive)
{

DDBLTFX ddbltfx;
ddbltfx.dwSize = sizeof(DDBLTFX);
ddbltfx.dwFillColor = 0;

BackBuffer->Blt(NULL, NULL, NULL, DDBLT_WAIT | DDBLT_COLORFILL, &ddbltfx);

d3dRect.lX1 = 0;
d3dRect.lX2 = 800;
d3dRect.lY1 = 0;
d3dRect.lY2 = 600;

Viewport->Clear (1UL, &d3dRect,
D3DCLEAR_TARGET | D3DCLEAR_ZBUFFER);

Device->BeginScene();

lpSphereMat->SetAsCurrent(Device);

World = MatrixMult(TranslateMatrix(D3DVECTOR(-1.0, 0.0, -10.0)), MatrixMult(RotateXMatrix(0), ScaleMatrix (2.5, 2.5, 2.5)));

Device->SetTransform(D3DTRANSFORMSTATE_WORLD, &World);

DrawSphere(Device);

PhiY0 = PhiY0 + 0.02;
if (PhiY0 >= 2.0 * PI)
PhiY0 = 0.0;
World = MatrixMult(TranslateMatrix(D3DVECTOR(0.0, 0.0, 100.0)), MatrixMult(RotateYMatrix(PhiY0), ScaleMatrix (4.5, 4.5, 4.5)));
Device->SetTransform (D3DTRANSFORMSTATE_WORLD, &World);
DrawSphere(Device);

Device->EndScene();

if (DisplayFPS == TRUE)
{
HDC hdc;
BackBuffer->GetDC(&hdc);
SetTextColor(hdc, RGB(255, 0, 0));
SetBkMode(hdc, TRANSPARENT);
TextOut(hdc, 0, 100, szMessage, lstrlen(szMessage));
TextOut(hdc, 130,100, szFPS, lstrlen(szFPS));

if (HardwareAvailable == TRUE)
TextOut(hdc, 0, 140, szHardwareYes, lstrlen(szHardwareYes));
else
TextOut(hdc, 0, 180, szHardwareNo, lstrlen(szHardwareNo));

BackBuffer->ReleaseDC(hdc);
FlipCount = FlipCount + 1;
}

FrontBuffer->Flip(NULL, DDFLIP_WAIT);

}
else WaitMessage();
}
} // End WinMain

Thanks

Karl

Follow Ups:

Post a Followup

Name:


Re: Please help me move the camera in D3DRM?

Posted by LT on July 06, 1998 at 20:47:47:

In Reply to: Re: Please help me move the camera in D3DRM? posted by Snowman on July 05, 1998 at 23:35:07:

The stars, er, spheres move just fine when I call SetPosition on their frame.

Thanks for the help,
LT

Follow Ups:

  • Solved. LT 00:11:38 7/07/98 (0)

Post a Followup

Name:


Re: Please help with Retained Mode.

Posted by LT on July 06, 1998 at 20:49:13:

In Reply to: Please help with Retained Mode. posted by LT on July 05, 1998 at 22:25:28:

Changing the perspective to ortho fixed it.

Follow Ups:

Post a Followup

Name:


Re: Meshes

Posted by MAgDI on July 06, 1998 at 21:16:03:

In Reply to: Meshes posted by Herbert Schuster on May 21, 1998 at 04:51:28:

: I need a Tool for building Meshes

Just use a 3D modeling tool
I read that caligari true space 3.2 support .x
format.

Good luck

Follow Ups:

Post a Followup

Name:


Urgent need help. How to load a mech with hirarchy?

Posted by Magdi on July 06, 1998 at 21:34:01:

I can load a singel mesh.
but i dont know how to load a mech designed
with hirarchy. like the model of a man with multi joints.

It is critical for my Bsc. project.

Thanks for the help.

Follow Ups:

Post a Followup

Name:


Solved.

Posted by LT on July 07, 1998 at 00:11:38:

In Reply to: Re: Please help me move the camera in D3DRM? posted by LT on July 06, 1998 at 20:47:47:

Moving the scene instead of the camera fixed it.

Follow Ups:

Post a Followup

Name:


Re: I need DirectX5

Posted by LYNN FOWLER on July 07, 1998 at 00:13:02:

In Reply to: I need DirectX5 posted by Denton Duncan on June 28, 1998 at 12:41:27:

: I downloaded a demo but I need directX5. Can I download it for free?. Where can I get it?

Follow Ups:

  • Re: I need DirectX5 shawn lee harvey 17:52:58 7/20/98 (1)
    • Re: I need DirectX5 Shawn lee Harvey 17:54:36 7/20/98 (0)

Post a Followup

Name:


Help!How to edit wav file in DirectShow

Posted by andrew on July 07, 1998 at 01:34:46:

I want to record audio data(insert or replace)into already
existing wav file.Does any one know how to do that in DirectShow?
I also would know how to get VU meter values in DirectShow
when I record audio data?
TIA
Andrew

Follow Ups:

Post a Followup

Name:


HELP!!! Writing Wav file in DirectShow

Posted by andrew on July 07, 1998 at 02:44:16:

Is it possible to write captured audio data in wav
file using DirectShow?
Docs says(ICaptureGraphBuilder::SetOutputFileName)
AVI is only supported format.
Have I missed anything?
TIA
Andrew

Follow Ups:

Post a Followup

Name:


Re: DirectX 6.0

Posted by hj on July 07, 1998 at 04:37:12:

In Reply to: Re: DirectX 6.0 posted by Max Kovacs on June 27, 1998 at 06:00:00:

: : Hi everybody
: : can someone tell me: where can I get DirectX 6.0 ??

: : Thanks

Follow Ups:

Post a Followup

Name:


Re: Sprites clipping on edge of screen!

Posted by Errant on July 07, 1998 at 07:07:45:

In Reply to: Sprites clipping on edge of screen! posted by Pet Monster on July 06, 1998 at 13:52:16:

: Can anyone tell me how to prevent sprites from clipping
: if they are even partially off the screen. I try to
: put a 40x40 sprite at coords (0, 620) on a 640x480
: fullscreen mode screen. It never displays the sprite
: if it is at all off the screen! Can anyone help me or
: direct me in the right direction???

You have to simply calculate how much of the
sprite is offscrren, then blit not the whole sprite, but some part of it.
E-mail me for furter explanation if you need it.

Follow Ups:

Post a Followup

Name:


DirectSound 5.0 & MIDI

Posted by Avner on July 07, 1998 at 07:40:11:

1. How do I mix MIDI with WAVE/AVI sound using
DirectSound ?
The CreateSoundBuffer seems to create buffers for
WAV and not for MIDI.

2. Is there a tool (with source code) to convert MIDI
to WAV format.

Thank you
Avner.

Follow Ups:

Post a Followup

Name:


Re: Sprites clipping on edge of screen!

Posted by Johnny Rotten on July 07, 1998 at 10:29:36:

In Reply to: Sprites clipping on edge of screen! posted by Pet Monster on July 06, 1998 at 13:52:16:

: Can anyone tell me how to prevent sprites from clipping
: if they are even partially off the screen. I try to
: put a 40x40 sprite at coords (0, 620) on a 640x480
: fullscreen mode screen. It never displays the sprite
: if it is at all off the screen! Can anyone help me or
: direct me in the right direction???

Have you attached a clipper to your surface? The documentation shows you how to do this under DirectDraw and is actually one of the clearest parts of the whole damned thing. Once you attach the clipper, no further code is needed. DirectDraw handles all of the clipping for you, but there is one drawback. You can no longer use BltFast() functions on that surface because it doesn't handle clipping. That's why the aforementioned procedure from Errant is probably the best because you can continue to use the BltFast() function instead of Blt(). And if you've ever compared the two speed-wise, you will have seen how much faster BltFast() is.

Hope that helps.

Follow Ups:

Post a Followup

Name:


HELP!!!! How do you use DrawPrimitive in user visuals?

Posted by Kevin Cline on July 07, 1998 at 13:31:05:

If anyone out there knows how to use DrawPrimitive in a user visual, PLEASE let me know.

Thanks,
Kevin Cline

Follow Ups:

Post a Followup

Name:


Re: Windows NT 4.0 Support for Direct X

Posted by G. Bereznicki on July 07, 1998 at 14:31:10:

In Reply to: Windows NT 4.0 Support for Direct X posted by Juan on July 01, 1998 at 15:14:23:

: When will Windows NT 4.0 Support Direct X 5.0? Does anyone have any information? It supports smoe things , like Age of Empires, but not others like Jedi Knight

MS people say:
"Q. When will DirectX 5 be released for Windows NT?

A. The short answer is : When NT 5.0 is released.
The longer answer: DirectX is an operating system upgrade, requiring kernel-level changes. Releasing
DirectX for each of our operating system platforms (Windows 95, Windows 98, Windows NT, Windows
CE) is an involved process, requiring much more effort than just updating drivers and API-level code.
Windows 98 and future releases of Windows NT will include DirectX as baseline functionality. For
Windows NT 4.0, we were able to provide DirectX 3 functionality with Service Pack 3. By the time
DirectX 5 was under development, work had been initiated on Windows NT 5.0 and there was no
opportunity to make changes to Windows NT 4.0 to support DirectX 5. DirectX 5 is currently integrated
into Windows NT 5.0 and is functional in the Beta 1 release of Windows NT 5.0. DirectX 6 will be included
as baseline functionality in Beta 2 and the final released version of Windows NT 5.0.
We also have a page explaining which versions of DirectX are supported by the various Microsoft
Windows operating systems."

  • Microsoft DirectX FAQ

Follow Ups:

Post a Followup

Name:


Re: Dialog Boxes in DirectX

Posted by Andreas on July 07, 1998 at 15:27:49:

In Reply to: Dialog Boxes in DirectX posted by Dan on June 17, 1998 at 23:01:35:

: What's the best way to dialog boxes in DirectX?
: I've tried using FlipToGDISurface() but that doesn't
: work so great.

: Thanks in advance.

It depends on what kind of dialog box you want to show. I've been able to show dialogs (MessageBox's) if I do not use the hwnd parameter, that is set it to NULL, then the dialog is visible.

The same thing should work on DialogBox (I think). Set the owner parameter to NULL and it should show!

Hope this helps.

/ Andr�as

Follow Ups:

Post a Followup

Name:


DirectX 6.0 Beta and Alpha blitting

Posted by Andreas K�hne on July 07, 1998 at 15:31:15:

In the beta version of the DirectX 6.0 library the software device (HEL) is capable of alpha-blitting. The problem is that the lpDirectDrawSurface4->Blt and lpDirectDrawSurface4->BltFast functions are not capable of alpha-blitting. My question is:

Is there anyone who knows if the blt functions will be able to do alpha-blitting in software in the release version?

Regards,

Andreas

Follow Ups:

  • Re: DirectX 6.0 Beta and Alpha blitting fred 06:44:53 7/08/98 (0)

Post a Followup

Name:


Mmmm....RGB, HAL, MMX or Ramp?

Posted by Shai'tan on July 07, 1998 at 19:52:20:

When choosing my device, whether I enumerate them or not, I end up with the following scenario:
Using HAL: Returns errors, cause I don't have hardware. Thats expected.
Using RGB: Everything works perfectly. All primitives are textured, but lighting is screwed.
Using MMX: Docs say MMX should replace RGB on MMX machines, like mine, but in this mode all I see is one of the sets of primitives, in an untextured white.
Using Ramp: Same result as MMX.

Could someone please tell me what is going on? I can't keep using RGB cause it is SLOOOOOWWW......

Thanks in advance!

Follow Ups:

Post a Followup

Name:


File writer filter in DirectShow

Posted by andrew on July 07, 1998 at 21:25:33:

I want to use DirectShow for capturing audio and recording to wav file.Ive found in the docs that
1.file writer filter's output will have the same format as input
2.currently file writer filter can be connected only to AVI MUX filter
Do I need to create my own file writer filter that will take wav format as input or Can I just write transformer
filter with wav output and connect it to file writer filter which is shipped with DirectShow.
TIA
Andrew

Follow Ups:

Post a Followup

Name:


D3D Sample Tunnel Source code

Posted by Shai'tan on July 07, 1998 at 21:37:35:

While SOME source code comes with the SDK, I don't believe the source to the Tunnel example does. Why not? Why didn't they include ALL the source code...seems pretty slack to me. But hey, if anyone has the source code, could they email it to me at murfet@onthenet.com.au??

Follow Ups:

Post a Followup

Name:


Re: my star trek game wont work please help

Posted by Kent Peterson on July 07, 1998 at 23:19:48:

In Reply to: Re: help with directx and presario 2220.....!!! posted by EvAcLeAr on May 25, 1998 at 04:31:33:

: : when i run starfleet academy i get a "d3d hardware initalization error".....my video driver isnt certified for direct x and compaq doesnt offer a certified driver for it.......

: : does anyone know how to fix this error???

: Well if compaq doesn't support the video card in there, try to find out from them what kind of vid card is in the system. Then go to the companies web site & see if they offer an updated driver (Most update drivers 1ce every 3 or 4 months). Or you could just wait another month or so until Directx 6 comes out. From what I hear DirectX 6 will support more hardware including more vid cards.

Does anybody know why,when i try to play Star Trek:Starfleet Academy it always says insert CD 1 but i have the CD in so why wont it work,please answer my question?

Follow Ups:

  • Re: my star trek game wont work please help Kent Peterson 23:20:59 7/07/98 (0)

Post a Followup

Name:


Re: my star trek game wont work please help

Posted by Kent Peterson on July 07, 1998 at 23:20:59:

In Reply to: Re: my star trek game wont work please help posted by Kent Peterson on July 07, 1998 at 23:19:48:

:
: : :
:
: Does anybody know why,when i try to play Star Trek:Starfleet Academy it always says insert CD 1 but i have the CD in so why wont it work,please answer my question?

Follow Ups:

Post a Followup

Name:


Ok, Z-Buffer works...but transformed verts are now WAY off

Posted by Shai'tan on July 08, 1998 at 03:47:35:

Phew! Thanks Fragmo and Clay! I finally got this Z-Buffer to work! Ok, so I tested it using TLVERTEX vertices, and it works perfectly, one nice triangle going behind the other. But when I try and use LVERTEX vertices, everything goes to crap.

Shouldn't it, in theory, be exactly the same as BEFORE implementation of the Z-Buffer, except with HSR? So things shouldn't move, in theory? I managed to 'find' my vertices by walking around for ages, and they're way wacked, really stretched out, and theres artifact stuff everywhere. I'm doing some MAJORLY wrong here....if you guys have some spare time, please help me out :)

Shai'tan-[Nth]

Follow Ups:

  • Re: Ok, Z-Buffer works...but transformed verts are now WAY off Clay 08:09:55 7/08/98 (3)
    • Re: Ok, Z-Buffer works...but transformed verts are now WAY off Shai'tan 08:29:11 7/08/98 (2)
      • Re: Ok, Z-Buffer works...but transformed verts are now WAY off Fragmo 19:26:31 7/08/98 (0)
      • Re: Ok, Z-Buffer works...but transformed verts are now WAY off Shai'tan 09:35:39 7/08/98 (0)

Post a Followup

Name:


Re: DirectX 6.0 Beta and Alpha blitting

Posted by fred on July 08, 1998 at 06:44:53:

In Reply to: DirectX 6.0 Beta and Alpha blitting posted by Andreas K�hne on July 07, 1998 at 15:31:15:

i think you should post this to DX6beta private web site. under the NDA, anything about Dx6beta is not subjected to public discussion

Follow Ups:

Post a Followup

Name:


Re: Ok, Z-Buffer works...but transformed verts are now WAY off

Posted by Clay on July 08, 1998 at 08:09:55:

In Reply to: Ok, Z-Buffer works...but transformed verts are now WAY off posted by Shai'tan on July 08, 1998 at 03:47:35:

If you were using TL vertices before and are using L vertices now, don't forget that a TL vertex is already transformed (in screen coordinates like the GDI); the L vertices are in "world coordinates" and will be transformed by the system to "screen coordinates" via the transformation matrix.

Clay

Follow Ups:

  • Re: Ok, Z-Buffer works...but transformed verts are now WAY off Shai'tan 08:29:11 7/08/98 (2)
    • Re: Ok, Z-Buffer works...but transformed verts are now WAY off Fragmo 19:26:31 7/08/98 (0)
    • Re: Ok, Z-Buffer works...but transformed verts are now WAY off Shai'tan 09:35:39 7/08/98 (0)

Post a Followup

Name:


Re: Ok, Z-Buffer works...but transformed verts are now WAY off

Posted by Shai'tan on July 08, 1998 at 08:29:11:

In Reply to: Re: Ok, Z-Buffer works...but transformed verts are now WAY off posted by Clay on July 08, 1998 at 08:09:55:

: If you were using TL vertices before and are using L vertices now, don't forget that a TL vertex is already transformed (in screen coordinates like the GDI); the L vertices are in "world coordinates" and will be transformed by the system to "screen coordinates" via the transformation matrix.

Yeah, I realise that. But whatever I do I still have that problem. Using your Z-Buffer and Init code, what are the verts for a reasonable triangle within the screen??

Follow Ups:

  • Re: Ok, Z-Buffer works...but transformed verts are now WAY off Fragmo 19:26:31 7/08/98 (0)
  • Re: Ok, Z-Buffer works...but transformed verts are now WAY off Shai'tan 09:35:39 7/08/98 (0)

Post a Followup

Name:


To Clay, Fragmo, Shai'tan

Posted by Karl Fisher on July 08, 1998 at 08:58:36:

I noticed your messages regarding problems Shai'tan has been having with Z-Buffers.

My problem is not quite the same. The objects get rendered ok, but it is just as if there is no ZBuffer.

In one of the messages there was mention of some code sent to Shai'tan, and I thought that may help if I could receive a copy.

The following is a message I have posted on several forums that describes my problem and the code I am trying to get to work.

I really am stumped, and would appreciate anything you can tell me.

Help Please,

I am a beginner with Direct 3D and I am stumped on implementing Z Buffering
for Immediate Mode.

I am trying to add ZBuffering to the CDX IM example.

It all compiles and runs, but no matter what I do the second draw primitive
is always rendered on top of the first draw primitive regardless of their Z
Values.

The following is the code I am trying to use, and obviously I am missing
something. Any suggestions will be greatly appreciated.

////////////////////////////////////////////////////////////////////////////
/////////
// InitApp
////////////////////////////////////////////////////////////////////////////
/////////
BOOL InitApp(HINSTANCE hInst, int nCmdShow)
{
HWND hWnd;
HRESULT rval;
WNDCLASS WndClass;

WndClass.style = CS_HREDRAW | CS_VREDRAW;
WndClass.lpfnWndProc = WinProc;
WndClass.cbClsExtra = 0;
WndClass.cbWndExtra = 0;
WndClass.hInstance = hInst;
WndClass.hIcon = LoadIcon(hInst, IDI_APPLICATION);
WndClass.hCursor = LoadCursor(NULL, IDC_ARROW);
WndClass.hbrBackground = NULL;
WndClass.lpszMenuName = "Orbits";
WndClass.lpszClassName = "Orbits";
RegisterClass(&WndClass);

hWnd = CreateWindowEx(
WS_EX_TOPMOST,
"Orbits",
"Orbits",
WS_POPUP,
0,0,
GetSystemMetrics(SM_CXSCREEN),
GetSystemMetrics(SM_CYSCREEN),
NULL,
NULL,
hInst,
NULL);

if(!hWnd) return FALSE;

ShowWindow(hWnd, nCmdShow);
UpdateWindow(hWnd);

DirectDrawEnumerate(EnumDD, &DirectDraw);

// Create the DirectDraw instance
if(!DirectDraw) rval = DirectDrawCreate(NULL, &DirectDraw, NULL);

DirectDraw->SetCooperativeLevel(hWnd, DDSCL_FULLSCREEN | DDSCL_EXCLUSIVE);
DirectDraw->SetDisplayMode(SCREEN_WIDTH, SCREEN_HEIGHT, SCREEN_BPP);

DDSURFACEDESC ddsd;
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS | DDSD_BACKBUFFERCOUNT;
ddsd.ddsCaps.dwCaps = DDSCAPS_PRIMARYSURFACE |
DDSCAPS_FLIP |
DDSCAPS_COMPLEX |
DDSCAPS_3DDEVICE |
DDSCAPS_VIDEOMEMORY;
ddsd.dwBackBufferCount = 1;

// Create the FrontBuffer
DirectDraw->CreateSurface(&ddsd, &FrontBuffer, NULL);

DDSCAPS ddscaps;
ddscaps.dwCaps = DDSCAPS_BACKBUFFER;

// Create the BackBuffer
FrontBuffer->GetAttachedSurface(&ddscaps, &BackBuffer);

// Create the Direct3D instance
DirectDraw->QueryInterface(IID_IDirect3D2, (LPVOID*)&Direct3D);

D3DFINDDEVICESEARCH search;
D3DFINDDEVICERESULT result;

search.dwSize = sizeof(search);
search.dwFlags = D3DFDS_HARDWARE;
search.bHardware = TRUE;
result.dwSize = sizeof(result);

// Create the hardware Device
Direct3D->FindDevice(&search, &result);

/*
///////////////////////// Start ZBuffer //////////////////
*/

ZeroMemory(&ddsd,sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS |
DDSD_WIDTH |
DDSD_HEIGHT |
DDSD_ZBUFFERBITDEPTH;
ddsd.ddsCaps.dwCaps = DDSCAPS_ZBUFFER | DDSCAPS_VIDEOMEMORY;
ddsd.dwWidth = dwWidth;
ddsd.dwHeight = dwHeight;
ddsd.dwZBufferBitDepth = 16;

DirectDraw->CreateSurface(&ddsd, &lpddsZBuff, NULL);

BackBuffer->AddAttachedSurface(lpddsZBuff);

/*
///////////////////////// End ZBuffer //////////////////

*/

Direct3D->CreateDevice(result.guid, BackBuffer, &Device);

HardwareAvailable = TRUE;

if(Device == NULL)
{
HardwareAvailable = FALSE;
search.dwSize = sizeof(search);
search.dwFlags = D3DFDS_HARDWARE;
search.bHardware = FALSE;
result.dwSize = sizeof(result);

// Create the software Device
Direct3D->FindDevice(&search, &result);
Direct3D->CreateDevice(result.guid, BackBuffer, &Device);
}

D3DVIEWPORT2 viewport;
memset(&viewport, 0, sizeof(D3DVIEWPORT2));
viewport.dwSize = sizeof(D3DVIEWPORT2);
viewport.dwX = 0;
viewport.dwY = 0;
viewport.dwWidth = SCREEN_WIDTH;
viewport.dwHeight = SCREEN_HEIGHT;
viewport.dvClipX = -1.0f;
viewport.dvClipWidth = 2.0f;
viewport.dvClipHeight = (D3DVALUE)(SCREEN_HEIGHT * 2.0 / SCREEN_WIDTH);
viewport.dvClipY = viewport.dvClipHeight / 2.0f;

viewport.dvMinZ = 0.0f;

viewport.dvMaxZ = 1.0f;

// Create the Viewport
Direct3D->CreateViewport(&Viewport, NULL);
Device->AddViewport(Viewport);
Viewport->SetViewport2(&viewport);

Device->SetCurrentViewport(Viewport);

World = IdentityMatrix();

View = ViewMatrix(D3DVECTOR(0.0,0.0,-20.0), D3DVECTOR(0.0,0.0,0.0),
D3DVECTOR(0,1,0), 0);

Projection = ProjectionMatrix(0.01f, 2000000.0f, (float)(60*PI/180));

Device->SetTransform(D3DTRANSFORMSTATE_WORLD, &World);
Device->SetTransform(D3DTRANSFORMSTATE_VIEW, &View);
Device->SetTransform(D3DTRANSFORMSTATE_PROJECTION, &Projection);

lpSphereMat = new Material(Direct3D, Device);
lpSphereMat->SetDiffuse(D3DVECTOR(1.0f));

// Create the sphere texture and attatch it to the material
Texture.Load(Device, "Texture.bmp");
lpSphereMat->SetTextureHandle(Texture.GetHandle());

Device->SetRenderState(D3DRENDERSTATE_ZENABLE,TRUE);

lpSphere2Mat = new Material(Direct3D, Device2);
lpSphere2Mat->SetDiffuse(D3DVECTOR(1.0f));

D3DVECTOR pLightPosition(0.0f, 5.0f, -18.0f);

lpPointLight = new PointLight(Direct3D, D3DVECTOR(1.0f), pLightPosition);

lpPointLight->SetAttenuation(D3DVECTOR(1.0f, 1.0f, 1.0f));

lpPointLight->SetRange(130.0f);

lpPointLight->AddToViewport(Viewport);

GenerateSphere();

return TRUE;
}

////////////////////////////////////////////////////////////////////////////
/////////
// WinMain
////////////////////////////////////////////////////////////////////////////
/////////
int PASCAL WinMain(HINSTANCE hInst, HINSTANCE hPrevInst, LPSTR lpCmdLine,
int nCmdShow)
{
MSG msg;

if(!InitApp(hInst, nCmdShow)) return FALSE;

while(1)
{
if(PeekMessage(&msg, NULL, 0, 0, PM_NOREMOVE))
{
if(!GetMessage(&msg, NULL, 0, 0 )) return msg.wParam;
TranslateMessage(&msg);
DispatchMessage(&msg);
}
else if(bActive)
{

DDBLTFX ddbltfx;
ddbltfx.dwSize = sizeof(DDBLTFX);
ddbltfx.dwFillColor = 0;

BackBuffer->Blt(NULL, NULL, NULL, DDBLT_WAIT | DDBLT_COLORFILL, &ddbltfx);

d3dRect.lX1 = 0;
d3dRect.lX2 = 800;
d3dRect.lY1 = 0;
d3dRect.lY2 = 600;

Viewport->Clear (1UL, &d3dRect,
D3DCLEAR_TARGET | D3DCLEAR_ZBUFFER);

Device->BeginScene();

lpSphereMat->SetAsCurrent(Device);

World = MatrixMult(TranslateMatrix(D3DVECTOR(-1.0, 0.0, -10.0)),
MatrixMult(RotateXMatrix(0), ScaleMatrix (2.5, 2.5, 2.5)));

Device->SetTransform(D3DTRANSFORMSTATE_WORLD, &World);

DrawSphere(Device);

PhiY0 = PhiY0 + 0.02;
if (PhiY0 >= 2.0 * PI)
PhiY0 = 0.0;
World = MatrixMult(TranslateMatrix(D3DVECTOR(0.0, 0.0, 100.0)),
MatrixMult(RotateYMatrix(PhiY0), ScaleMatrix (4.5, 4.5, 4.5)));
Device->SetTransform (D3DTRANSFORMSTATE_WORLD, &World);
DrawSphere(Device);

Device->EndScene();

if (DisplayFPS == TRUE)
{
HDC hdc;
BackBuffer->GetDC(&hdc);
SetTextColor(hdc, RGB(255, 0, 0));
SetBkMode(hdc, TRANSPARENT);
TextOut(hdc, 0, 100, szMessage, lstrlen(szMessage));
TextOut(hdc, 130,100, szFPS, lstrlen(szFPS));

if (HardwareAvailable == TRUE)
TextOut(hdc, 0, 140, szHardwareYes, lstrlen(szHardwareYes));
else
TextOut(hdc, 0, 180, szHardwareNo, lstrlen(szHardwareNo));

BackBuffer->ReleaseDC(hdc);
FlipCount = FlipCount + 1;
}

FrontBuffer->Flip(NULL, DDFLIP_WAIT);

}
else WaitMessage();
}
} // End WinMain

Thanks

Karl

Follow Ups:

  • Re: To Clay, Fragmo, Shai'tan Fragmo 19:11:45 7/08/98 (8)
    • Re: To Fragmo Karl Fisher 22:03:05 7/08/98 (7)
      • Re: To Fragmo Fragmo 02:36:05 7/09/98 (1)
        • Re: To Fragmo Fragmo 02:48:03 7/09/98 (0)
      • Re: What the hell is going on? Shai'tan 22:44:59 7/08/98 (0)
      • Re: Hehe...online development :) Shai'tan 22:36:16 7/08/98 (3)
        • Re: Hehe...online development :) Karl Fisher 19:57:47 7/09/98 (2)
          • Re: Z-Buffer code in SDK samples Shai'tan 02:16:59 7/10/98 (1)
            • Re: Z-Buffer code in SDK samples Karl Fisher 12:44:37 7/10/98 (0)

Post a Followup

Name:


Re: Ok, Z-Buffer works...but transformed verts are now WAY off

Posted by Shai'tan on July 08, 1998 at 09:35:39:

In Reply to: Re: Ok, Z-Buffer works...but transformed verts are now WAY off posted by Shai'tan on July 08, 1998 at 08:29:11:

Ok, why did you simply repost that? To draw attention?? :)

Follow Ups:

Post a Followup

Name:


Re: Sprites clipping on edge of screen!

Posted by Pet Monster on July 08, 1998 at 11:24:21:

In Reply to: Sprites clipping on edge of screen! posted by Pet Monster on July 06, 1998 at 13:52:16:

Hey thanx! Those are both great ideas, and i'll
be busy trying them out! :)

Errant I understand what you are saying about only
blting part of the sprite

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Piyushgiri on July 08, 1998 at 11:27:24:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Brian Maurer on March 27, 1998 at 17:59:58:

: : Where Can I download DirectX 5.0. I need it for an f 22 Raptor for the Beta Games

Follow Ups:

Post a Followup

Name:


DrawPrimitive returns -2005531937

Posted by Kevin Cline on July 08, 1998 at 14:41:01:

I've been trying to use DrawPrimitive in a user visual for the past couple of days now, and have tremendous bad luck. the first problem was getting the im device.

Now, I finally got past setting up the im device only to have DrawPrimitive fail. it returns -2005531937. (HRESULT's work fine if you know which error to expect, but otherwise they mean practically nothing.)
If anyone wants to help, please do. Even which error -2005531937 is would be nice, at least that would be someplace to start.

Thanks,
Kevin Cline
cline@chatnet.com

Follow Ups:

  • Re: Create youself an error handler. Jason G 16:42:56 7/08/98 (1)
    • Re: D3DERR_INVALIDCURRENTVIEWPORT Kevin Cline 22:38:59 7/08/98 (0)

Post a Followup

Name:


Alpha Blending source code

Posted by Doug Linley on July 08, 1998 at 16:08:07:

Does anyone know where I can find some good Alpha-blending source code?

Thanks
Doug Linley

  • FPi Development

Follow Ups:

Post a Followup

Name:


Re: Create youself an error handler.

Posted by Jason G on July 08, 1998 at 16:42:56:

In Reply to: DrawPrimitive returns -2005531937 posted by Kevin Cline on July 08, 1998 at 14:41:01:

Create yourself an error handler. Which basically inputs one of those crazy numbers and pops up a msgbox displaying the result.

Even if you look through the DX5 example source you get with DX5SDK there is one there used in a couple of places.

Follow Ups:

  • Re: D3DERR_INVALIDCURRENTVIEWPORT Kevin Cline 22:38:59 7/08/98 (0)

Post a Followup

Name:


Re: To Clay, Fragmo, Shai'tan

Posted by Fragmo on July 08, 1998 at 19:11:45:

In Reply to: To Clay, Fragmo, Shai'tan posted by Karl Fisher on July 08, 1998 at 08:58:36:

you didn't attach the z buffer for the software device
if you aren't using hardware, then that's the problem
also, you could test to make sure that the z buffer is attaching properly

: I noticed your messages regarding problems Shai'tan has been having with Z-Buffers.

: My problem is not quite the same. The objects get rendered ok, but it is just as if there is no ZBuffer.

: In one of the messages there was mention of some code sent to Shai'tan, and I thought that may help if I could receive a copy.

: The following is a message I have posted on several forums that describes my problem and the code I am trying to get to work.

: I really am stumped, and would appreciate anything you can tell me.

: Help Please,

: I am a beginner with Direct 3D and I am stumped on implementing Z Buffering
: for Immediate Mode.

: I am trying to add ZBuffering to the CDX IM example.

: It all compiles and runs, but no matter what I do the second draw primitive
: is always rendered on top of the first draw primitive regardless of their Z
: Values.

: The following is the code I am trying to use, and obviously I am missing
: something. Any suggestions will be greatly appreciated.

: ////////////////////////////////////////////////////////////////////////////
: /////////
: // InitApp
: ////////////////////////////////////////////////////////////////////////////
: /////////
: BOOL InitApp(HINSTANCE hInst, int nCmdShow)
: {
: HWND hWnd;
: HRESULT rval;
: WNDCLASS WndClass;

: WndClass.style = CS_HREDRAW | CS_VREDRAW;
: WndClass.lpfnWndProc = WinProc;
: WndClass.cbClsExtra = 0;
: WndClass.cbWndExtra = 0;
: WndClass.hInstance = hInst;
: WndClass.hIcon = LoadIcon(hInst, IDI_APPLICATION);
: WndClass.hCursor = LoadCursor(NULL, IDC_ARROW);
: WndClass.hbrBackground = NULL;
: WndClass.lpszMenuName = "Orbits";
: WndClass.lpszClassName = "Orbits";
: RegisterClass(&WndClass);

: hWnd = CreateWindowEx(
: WS_EX_TOPMOST,
: "Orbits",
: "Orbits",
: WS_POPUP,
: 0,0,
: GetSystemMetrics(SM_CXSCREEN),
: GetSystemMetrics(SM_CYSCREEN),
: NULL,
: NULL,
: hInst,
: NULL);

: if(!hWnd) return FALSE;

: ShowWindow(hWnd, nCmdShow);
: UpdateWindow(hWnd);

: DirectDrawEnumerate(EnumDD, &DirectDraw);

: // Create the DirectDraw instance
: if(!DirectDraw) rval = DirectDrawCreate(NULL, &DirectDraw, NULL);

: DirectDraw->SetCooperativeLevel(hWnd, DDSCL_FULLSCREEN | DDSCL_EXCLUSIVE);
: DirectDraw->SetDisplayMode(SCREEN_WIDTH, SCREEN_HEIGHT, SCREEN_BPP);

: DDSURFACEDESC ddsd;
: ddsd.dwSize = sizeof(ddsd);
: ddsd.dwFlags = DDSD_CAPS | DDSD_BACKBUFFERCOUNT;
: ddsd.ddsCaps.dwCaps = DDSCAPS_PRIMARYSURFACE |
: DDSCAPS_FLIP |
: DDSCAPS_COMPLEX |
: DDSCAPS_3DDEVICE |
: DDSCAPS_VIDEOMEMORY;
: ddsd.dwBackBufferCount = 1;

: // Create the FrontBuffer
: DirectDraw->CreateSurface(&ddsd, &FrontBuffer, NULL);

: DDSCAPS ddscaps;
: ddscaps.dwCaps = DDSCAPS_BACKBUFFER;

: // Create the BackBuffer
: FrontBuffer->GetAttachedSurface(&ddscaps, &BackBuffer);

: // Create the Direct3D instance
: DirectDraw->QueryInterface(IID_IDirect3D2, (LPVOID*)&Direct3D);

: D3DFINDDEVICESEARCH search;
: D3DFINDDEVICERESULT result;

: search.dwSize = sizeof(search);
: search.dwFlags = D3DFDS_HARDWARE;
: search.bHardware = TRUE;
: result.dwSize = sizeof(result);

: // Create the hardware Device
: Direct3D->FindDevice(&search, &result);

:
: /*
: ///////////////////////// Start ZBuffer //////////////////
: */

: ZeroMemory(&ddsd,sizeof(ddsd));
: ddsd.dwSize = sizeof(ddsd);
: ddsd.dwFlags = DDSD_CAPS |
: DDSD_WIDTH |
: DDSD_HEIGHT |
: DDSD_ZBUFFERBITDEPTH;
: ddsd.ddsCaps.dwCaps = DDSCAPS_ZBUFFER | DDSCAPS_VIDEOMEMORY;
: ddsd.dwWidth = dwWidth;
: ddsd.dwHeight = dwHeight;
: ddsd.dwZBufferBitDepth = 16;

: DirectDraw->CreateSurface(&ddsd, &lpddsZBuff, NULL);

: BackBuffer->AddAttachedSurface(lpddsZBuff);

: /*
: ///////////////////////// End ZBuffer //////////////////

: */

:
: Direct3D->CreateDevice(result.guid, BackBuffer, &Device);

: HardwareAvailable = TRUE;

:
: if(Device == NULL)
: {
: HardwareAvailable = FALSE;
: search.dwSize = sizeof(search);
: search.dwFlags = D3DFDS_HARDWARE;
: search.bHardware = FALSE;
: result.dwSize = sizeof(result);

: // Create the software Device
: Direct3D->FindDevice(&search, &result);
: Direct3D->CreateDevice(result.guid, BackBuffer, &Device);
: }

:
: D3DVIEWPORT2 viewport;
: memset(&viewport, 0, sizeof(D3DVIEWPORT2));
: viewport.dwSize = sizeof(D3DVIEWPORT2);
: viewport.dwX = 0;
: viewport.dwY = 0;
: viewport.dwWidth = SCREEN_WIDTH;
: viewport.dwHeight = SCREEN_HEIGHT;
: viewport.dvClipX = -1.0f;
: viewport.dvClipWidth = 2.0f;
: viewport.dvClipHeight = (D3DVALUE)(SCREEN_HEIGHT * 2.0 / SCREEN_WIDTH);
: viewport.dvClipY = viewport.dvClipHeight / 2.0f;

: viewport.dvMinZ = 0.0f;

: viewport.dvMaxZ = 1.0f;

: // Create the Viewport
: Direct3D->CreateViewport(&Viewport, NULL);
: Device->AddViewport(Viewport);
: Viewport->SetViewport2(&viewport);

: Device->SetCurrentViewport(Viewport);

:
: World = IdentityMatrix();

:
: View = ViewMatrix(D3DVECTOR(0.0,0.0,-20.0), D3DVECTOR(0.0,0.0,0.0),
: D3DVECTOR(0,1,0), 0);

:
: Projection = ProjectionMatrix(0.01f, 2000000.0f, (float)(60*PI/180));

:
: Device->SetTransform(D3DTRANSFORMSTATE_WORLD, &World);
: Device->SetTransform(D3DTRANSFORMSTATE_VIEW, &View);
: Device->SetTransform(D3DTRANSFORMSTATE_PROJECTION, &Projection);

:
: lpSphereMat = new Material(Direct3D, Device);
: lpSphereMat->SetDiffuse(D3DVECTOR(1.0f));

:
: // Create the sphere texture and attatch it to the material
: Texture.Load(Device, "Texture.bmp");
: lpSphereMat->SetTextureHandle(Texture.GetHandle());

: Device->SetRenderState(D3DRENDERSTATE_ZENABLE,TRUE);

:
: lpSphere2Mat = new Material(Direct3D, Device2);
: lpSphere2Mat->SetDiffuse(D3DVECTOR(1.0f));

:
: D3DVECTOR pLightPosition(0.0f, 5.0f, -18.0f);

: lpPointLight = new PointLight(Direct3D, D3DVECTOR(1.0f), pLightPosition);

: lpPointLight->SetAttenuation(D3DVECTOR(1.0f, 1.0f, 1.0f));

: lpPointLight->SetRange(130.0f);

: lpPointLight->AddToViewport(Viewport);

: GenerateSphere();

: return TRUE;
: }

: ////////////////////////////////////////////////////////////////////////////
: /////////
: // WinMain
: ////////////////////////////////////////////////////////////////////////////
: /////////
: int PASCAL WinMain(HINSTANCE hInst, HINSTANCE hPrevInst, LPSTR lpCmdLine,
: int nCmdShow)
: {
: MSG msg;

: if(!InitApp(hInst, nCmdShow)) return FALSE;

: while(1)
: {
: if(PeekMessage(&msg, NULL, 0, 0, PM_NOREMOVE))
: {
: if(!GetMessage(&msg, NULL, 0, 0 )) return msg.wParam;
: TranslateMessage(&msg);
: DispatchMessage(&msg);
: }
: else if(bActive)
: {

:
: DDBLTFX ddbltfx;
: ddbltfx.dwSize = sizeof(DDBLTFX);
: ddbltfx.dwFillColor = 0;

: BackBuffer->Blt(NULL, NULL, NULL, DDBLT_WAIT | DDBLT_COLORFILL, &ddbltfx);

: d3dRect.lX1 = 0;
: d3dRect.lX2 = 800;
: d3dRect.lY1 = 0;
: d3dRect.lY2 = 600;

:
: Viewport->Clear (1UL, &d3dRect,
: D3DCLEAR_TARGET | D3DCLEAR_ZBUFFER);

: Device->BeginScene();

:
: lpSphereMat->SetAsCurrent(Device);

:
: World = MatrixMult(TranslateMatrix(D3DVECTOR(-1.0, 0.0, -10.0)),
: MatrixMult(RotateXMatrix(0), ScaleMatrix (2.5, 2.5, 2.5)));

: Device->SetTransform(D3DTRANSFORMSTATE_WORLD, &World);

: DrawSphere(Device);

:
: PhiY0 = PhiY0 + 0.02;
: if (PhiY0 >= 2.0 * PI)
: PhiY0 = 0.0;
: World = MatrixMult(TranslateMatrix(D3DVECTOR(0.0, 0.0, 100.0)),
: MatrixMult(RotateYMatrix(PhiY0), ScaleMatrix (4.5, 4.5, 4.5)));
: Device->SetTransform (D3DTRANSFORMSTATE_WORLD, &World);
: DrawSphere(Device);

:
: Device->EndScene();

: if (DisplayFPS == TRUE)
: {
: HDC hdc;
: BackBuffer->GetDC(&hdc);
: SetTextColor(hdc, RGB(255, 0, 0));
: SetBkMode(hdc, TRANSPARENT);
: TextOut(hdc, 0, 100, szMessage, lstrlen(szMessage));
: TextOut(hdc, 130,100, szFPS, lstrlen(szFPS));

: if (HardwareAvailable == TRUE)
: TextOut(hdc, 0, 140, szHardwareYes, lstrlen(szHardwareYes));
: else
: TextOut(hdc, 0, 180, szHardwareNo, lstrlen(szHardwareNo));

: BackBuffer->ReleaseDC(hdc);
: FlipCount = FlipCount + 1;
: }

:
: FrontBuffer->Flip(NULL, DDFLIP_WAIT);

:
: }
: else WaitMessage();
: }
: } // End WinMain

:
: Thanks

: Karl

Follow Ups:

  • Re: To Fragmo Karl Fisher 22:03:05 7/08/98 (7)
    • Re: To Fragmo Fragmo 02:36:05 7/09/98 (1)
      • Re: To Fragmo Fragmo 02:48:03 7/09/98 (0)
    • Re: What the hell is going on? Shai'tan 22:44:59 7/08/98 (0)
    • Re: Hehe...online development :) Shai'tan 22:36:16 7/08/98 (3)
      • Re: Hehe...online development :) Karl Fisher 19:57:47 7/09/98 (2)
        • Re: Z-Buffer code in SDK samples Shai'tan 02:16:59 7/10/98 (1)
          • Re: Z-Buffer code in SDK samples Karl Fisher 12:44:37 7/10/98 (0)

Post a Followup

Name:


Re: Ok, Z-Buffer works...but transformed verts are now WAY off

Posted by Fragmo on July 08, 1998 at 19:26:31:

In Reply to: Re: Ok, Z-Buffer works...but transformed verts are now WAY off posted by Shai'tan on July 08, 1998 at 08:29:11:

sounds like one of your matrices is messed up
try setting the view and world to identity, then the center of the screen will be {0,0,0}
the z values in front of the screen depend on which coordinate system you use
(left or right handed) i don't know how much help that will be, but you should at least
see the triangles drawn properly

: : If you were using TL vertices before and are using L vertices now, don't forget that a TL vertex is already transformed (in screen coordinates like the GDI); the L vertices are in "world coordinates" and will be transformed by the system to "screen coordinates" via the transformation matrix.

: Yeah, I realise that. But whatever I do I still have that problem. Using your Z-Buffer and Init code, what are the verts for a reasonable triangle within the screen??

Follow Ups:

Post a Followup

Name:


Re: To Fragmo

Posted by Karl Fisher on July 08, 1998 at 22:03:05:

In Reply to: Re: To Clay, Fragmo, Shai'tan posted by Fragmo on July 08, 1998 at 19:11:45:

Thanks much for your reply Fragmo

You got me on the right track, but I still can't get it to work.

The ZBuffer AddAttachedSurface was failing, so looked ay the DX5 Help and it appeared that the AddAttachedSurface is a method of IDirectDrawSurface3. I declared an IDirectDrawSurface, but then I received compile errors regarding conversion of the structures.

I can use the code in the sdk samples such as the Light Demo, but I was hoping to get it to work in a less complicated program for the purpose of better understanding how all these things work.

I will keep trying, and woud appreciate hearing about anything you may think of that might get me straightened out.

Thanks Again

Karl

: you didn't attach the z buffer for the software device
: if you aren't using hardware, then that's the problem
: also, you could test to make sure that the z buffer is attaching properly

: : I noticed your messages regarding problems Shai'tan has been having with Z-Buffers.

: : My problem is not quite the same. The objects get rendered ok, but it is just as if there is no ZBuffer.

: : In one of the messages there was mention of some code sent to Shai'tan, and I thought that may help if I could receive a copy.

: : The following is a message I have posted on several forums that describes my problem and the code I am trying to get to work.

: : I really am stumped, and would appreciate anything you can tell me.

:
: : Help Please,

: : I am a beginner with Direct 3D and I am stumped on implementing Z Buffering
: : for Immediate Mode.

: : I am trying to add ZBuffering to the CDX IM example.

: : It all compiles and runs, but no matter what I do the second draw primitive
: : is always rendered on top of the first draw primitive regardless of their Z
: : Values.

: : The following is the code I am trying to use, and obviously I am missing
: : something. Any suggestions will be greatly appreciated.

: : ////////////////////////////////////////////////////////////////////////////
: : /////////
: : // InitApp
: : ////////////////////////////////////////////////////////////////////////////
: : /////////
: : BOOL InitApp(HINSTANCE hInst, int nCmdShow)
: : {
: : HWND hWnd;
: : HRESULT rval;
: : WNDCLASS WndClass;

: : WndClass.style = CS_HREDRAW | CS_VREDRAW;
: : WndClass.lpfnWndProc = WinProc;
: : WndClass.cbClsExtra = 0;
: : WndClass.cbWndExtra = 0;
: : WndClass.hInstance = hInst;
: : WndClass.hIcon = LoadIcon(hInst, IDI_APPLICATION);
: : WndClass.hCursor = LoadCursor(NULL, IDC_ARROW);
: : WndClass.hbrBackground = NULL;
: : WndClass.lpszMenuName = "Orbits";
: : WndClass.lpszClassName = "Orbits";
: : RegisterClass(&WndClass);

: : hWnd = CreateWindowEx(
: : WS_EX_TOPMOST,
: : "Orbits",
: : "Orbits",
: : WS_POPUP,
: : 0,0,
: : GetSystemMetrics(SM_CXSCREEN),
: : GetSystemMetrics(SM_CYSCREEN),
: : NULL,
: : NULL,
: : hInst,
: : NULL);

: : if(!hWnd) return FALSE;

: : ShowWindow(hWnd, nCmdShow);
: : UpdateWindow(hWnd);

: : DirectDrawEnumerate(EnumDD, &DirectDraw);

: : // Create the DirectDraw instance
: : if(!DirectDraw) rval = DirectDrawCreate(NULL, &DirectDraw, NULL);

: : DirectDraw->SetCooperativeLevel(hWnd, DDSCL_FULLSCREEN | DDSCL_EXCLUSIVE);
: : DirectDraw->SetDisplayMode(SCREEN_WIDTH, SCREEN_HEIGHT, SCREEN_BPP);

: : DDSURFACEDESC ddsd;
: : ddsd.dwSize = sizeof(ddsd);
: : ddsd.dwFlags = DDSD_CAPS | DDSD_BACKBUFFERCOUNT;
: : ddsd.ddsCaps.dwCaps = DDSCAPS_PRIMARYSURFACE |
: : DDSCAPS_FLIP |
: : DDSCAPS_COMPLEX |
: : DDSCAPS_3DDEVICE |
: : DDSCAPS_VIDEOMEMORY;
: : ddsd.dwBackBufferCount = 1;

: : // Create the FrontBuffer
: : DirectDraw->CreateSurface(&ddsd, &FrontBuffer, NULL);

: : DDSCAPS ddscaps;
: : ddscaps.dwCaps = DDSCAPS_BACKBUFFER;

: : // Create the BackBuffer
: : FrontBuffer->GetAttachedSurface(&ddscaps, &BackBuffer);

:
: : // Create the Direct3D instance
: : DirectDraw->QueryInterface(IID_IDirect3D2, (LPVOID*)&Direct3D);

: : D3DFINDDEVICESEARCH search;
: : D3DFINDDEVICERESULT result;

: : search.dwSize = sizeof(search);
: : search.dwFlags = D3DFDS_HARDWARE;
: : search.bHardware = TRUE;
: : result.dwSize = sizeof(result);

:
: : // Create the hardware Device
: : Direct3D->FindDevice(&search, &result);

: :
: : /*
: : ///////////////////////// Start ZBuffer //////////////////
: : */

: : ZeroMemory(&ddsd,sizeof(ddsd));
: : ddsd.dwSize = sizeof(ddsd);
: : ddsd.dwFlags = DDSD_CAPS |
: : DDSD_WIDTH |
: : DDSD_HEIGHT |
: : DDSD_ZBUFFERBITDEPTH;
: : ddsd.ddsCaps.dwCaps = DDSCAPS_ZBUFFER | DDSCAPS_VIDEOMEMORY;
: : ddsd.dwWidth = dwWidth;
: : ddsd.dwHeight = dwHeight;
: : ddsd.dwZBufferBitDepth = 16;

: : DirectDraw->CreateSurface(&ddsd, &lpddsZBuff, NULL);

: : BackBuffer->AddAttachedSurface(lpddsZBuff);

: : /*
: : ///////////////////////// End ZBuffer //////////////////

: : */

:
: :
: : Direct3D->CreateDevice(result.guid, BackBuffer, &Device);

: : HardwareAvailable = TRUE;

: :
: : if(Device == NULL)
: : {
: : HardwareAvailable = FALSE;
: : search.dwSize = sizeof(search);
: : search.dwFlags = D3DFDS_HARDWARE;
: : search.bHardware = FALSE;
: : result.dwSize = sizeof(result);

: : // Create the software Device
: : Direct3D->FindDevice(&search, &result);
: : Direct3D->CreateDevice(result.guid, BackBuffer, &Device);
: : }

: :
: : D3DVIEWPORT2 viewport;
: : memset(&viewport, 0, sizeof(D3DVIEWPORT2));
: : viewport.dwSize = sizeof(D3DVIEWPORT2);
: : viewport.dwX = 0;
: : viewport.dwY = 0;
: : viewport.dwWidth = SCREEN_WIDTH;
: : viewport.dwHeight = SCREEN_HEIGHT;
: : viewport.dvClipX = -1.0f;
: : viewport.dvClipWidth = 2.0f;
: : viewport.dvClipHeight = (D3DVALUE)(SCREEN_HEIGHT * 2.0 / SCREEN_WIDTH);
: : viewport.dvClipY = viewport.dvClipHeight / 2.0f;

: : viewport.dvMinZ = 0.0f;

: : viewport.dvMaxZ = 1.0f;

: : // Create the Viewport
: : Direct3D->CreateViewport(&Viewport, NULL);
: : Device->AddViewport(Viewport);
: : Viewport->SetViewport2(&viewport);

: : Device->SetCurrentViewport(Viewport);

:
: :
: : World = IdentityMatrix();

: :
: : View = ViewMatrix(D3DVECTOR(0.0,0.0,-20.0), D3DVECTOR(0.0,0.0,0.0),
: : D3DVECTOR(0,1,0), 0);

: :
: : Projection = ProjectionMatrix(0.01f, 2000000.0f, (float)(60*PI/180));

: :
: : Device->SetTransform(D3DTRANSFORMSTATE_WORLD, &World);
: : Device->SetTransform(D3DTRANSFORMSTATE_VIEW, &View);
: : Device->SetTransform(D3DTRANSFORMSTATE_PROJECTION, &Projection);

: :
: : lpSphereMat = new Material(Direct3D, Device);
: : lpSphereMat->SetDiffuse(D3DVECTOR(1.0f));

: :
: : // Create the sphere texture and attatch it to the material
: : Texture.Load(Device, "Texture.bmp");
: : lpSphereMat->SetTextureHandle(Texture.GetHandle());

: : Device->SetRenderState(D3DRENDERSTATE_ZENABLE,TRUE);

: :
: : lpSphere2Mat = new Material(Direct3D, Device2);
: : lpSphere2Mat->SetDiffuse(D3DVECTOR(1.0f));

: :
: : D3DVECTOR pLightPosition(0.0f, 5.0f, -18.0f);

: : lpPointLight = new PointLight(Direct3D, D3DVECTOR(1.0f), pLightPosition);

: : lpPointLight->SetAttenuation(D3DVECTOR(1.0f, 1.0f, 1.0f));

: : lpPointLight->SetRange(130.0f);

: : lpPointLight->AddToViewport(Viewport);

: : GenerateSphere();

: : return TRUE;
: : }

: : ////////////////////////////////////////////////////////////////////////////
: : /////////
: : // WinMain
: : ////////////////////////////////////////////////////////////////////////////
: : /////////
: : int PASCAL WinMain(HINSTANCE hInst, HINSTANCE hPrevInst, LPSTR lpCmdLine,
: : int nCmdShow)
: : {
: : MSG msg;

: : if(!InitApp(hInst, nCmdShow)) return FALSE;

: : while(1)
: : {
: : if(PeekMessage(&msg, NULL, 0, 0, PM_NOREMOVE))
: : {
: : if(!GetMessage(&msg, NULL, 0, 0 )) return msg.wParam;
: : TranslateMessage(&msg);
: : DispatchMessage(&msg);
: : }
: : else if(bActive)
: : {

: :
: : DDBLTFX ddbltfx;
: : ddbltfx.dwSize = sizeof(DDBLTFX);
: : ddbltfx.dwFillColor = 0;

: : BackBuffer->Blt(NULL, NULL, NULL, DDBLT_WAIT | DDBLT_COLORFILL, &ddbltfx);

:
: : d3dRect.lX1 = 0;
: : d3dRect.lX2 = 800;
: : d3dRect.lY1 = 0;
: : d3dRect.lY2 = 600;

: :
: : Viewport->Clear (1UL, &d3dRect,
: : D3DCLEAR_TARGET | D3DCLEAR_ZBUFFER);

: : Device->BeginScene();

: :
: : lpSphereMat->SetAsCurrent(Device);

: :
: : World = MatrixMult(TranslateMatrix(D3DVECTOR(-1.0, 0.0, -10.0)),
: : MatrixMult(RotateXMatrix(0), ScaleMatrix (2.5, 2.5, 2.5)));

: : Device->SetTransform(D3DTRANSFORMSTATE_WORLD, &World);

: : DrawSphere(Device);

: :
: : PhiY0 = PhiY0 + 0.02;
: : if (PhiY0 >= 2.0 * PI)
: : PhiY0 = 0.0;
: : World = MatrixMult(TranslateMatrix(D3DVECTOR(0.0, 0.0, 100.0)),
: : MatrixMult(RotateYMatrix(PhiY0), ScaleMatrix (4.5, 4.5, 4.5)));
: : Device->SetTransform (D3DTRANSFORMSTATE_WORLD, &World);
: : DrawSphere(Device);

: :
: : Device->EndScene();

:
: : if (DisplayFPS == TRUE)
: : {
: : HDC hdc;
: : BackBuffer->GetDC(&hdc);
: : SetTextColor(hdc, RGB(255, 0, 0));
: : SetBkMode(hdc, TRANSPARENT);
: : TextOut(hdc, 0, 100, szMessage, lstrlen(szMessage));
: : TextOut(hdc, 130,100, szFPS, lstrlen(szFPS));

: : if (HardwareAvailable == TRUE)
: : TextOut(hdc, 0, 140, szHardwareYes, lstrlen(szHardwareYes));
: : else
: : TextOut(hdc, 0, 180, szHardwareNo, lstrlen(szHardwareNo));

: : BackBuffer->ReleaseDC(hdc);
: : FlipCount = FlipCount + 1;
: : }

: :
: : FrontBuffer->Flip(NULL, DDFLIP_WAIT);

: :
: : }
: : else WaitMessage();
: : }
: : } // End WinMain

: :
: : Thanks

: : Karl

Follow Ups:

  • Re: To Fragmo Fragmo 02:36:05 7/09/98 (1)
    • Re: To Fragmo Fragmo 02:48:03 7/09/98 (0)
  • Re: What the hell is going on? Shai'tan 22:44:59 7/08/98 (0)
  • Re: Hehe...online development :) Shai'tan 22:36:16 7/08/98 (3)
    • Re: Hehe...online development :) Karl Fisher 19:57:47 7/09/98 (2)
      • Re: Z-Buffer code in SDK samples Shai'tan 02:16:59 7/10/98 (1)
        • Re: Z-Buffer code in SDK samples Karl Fisher 12:44:37 7/10/98 (0)

Post a Followup

Name:


Re: Hehe...online development :)

Posted by Shai'tan on July 08, 1998 at 22:36:16:

In Reply to: Re: To Fragmo posted by Karl Fisher on July 08, 1998 at 22:03:05:

: The ZBuffer AddAttachedSurface was failing, so looked ay the DX5 Help and it appeared that the AddAttachedSurface is a method of IDirectDrawSurface3. I declared an IDirectDrawSurface, but then I received compile errors regarding conversion of the structures.

Yeah, from your 'tips' I got to exactly the same stage, and I am assuming since the IDirectDraw2::CreateSurface method returns a LPBLAHBLAHSURFACE, you have to use queryinterface to get the SURFACE3? What is the GUID for that?

Yeah, be good to hear from you if you get it figured out Karl :)
Oh, yeah, btw, my ICQ is 2273950 if anyone is interested...be good to share ideas Karl :)

Follow Ups:

  • Re: Hehe...online development :) Karl Fisher 19:57:47 7/09/98 (2)
    • Re: Z-Buffer code in SDK samples Shai'tan 02:16:59 7/10/98 (1)
      • Re: Z-Buffer code in SDK samples Karl Fisher 12:44:37 7/10/98 (0)

Post a Followup

Name:


Re: D3DERR_INVALIDCURRENTVIEWPORT

Posted by Kevin Cline on July 08, 1998 at 22:38:59:

In Reply to: Re: Create youself an error handler. posted by Jason G on July 08, 1998 at 16:42:56:

Thanks for the tip, I did't want to have to do it, but that's what it took.

Now that I know what it is, how do I get a valid viewport?

Thanks,
Kevin Cline
cline@chatnet.com

: Create yourself an error handler. Which basically inputs one of those crazy numbers and pops up a msgbox displaying the result.

: Even if you look through the DX5 example source you get with DX5SDK there is one there used in a couple of places.

Follow Ups:

Post a Followup

Name:


Re: What the hell is going on?

Posted by Shai'tan on July 08, 1998 at 22:44:59:

In Reply to: Re: To Fragmo posted by Karl Fisher on July 08, 1998 at 22:03:05:

What is with DirectX? Yes, I also looked up AddAttachedSurface in the DirectX Help file. And yes, it is supposed to only be a member function of IDirectDrawSurface3. So why does, in all the samples, a IDirectDrawSurface have the ability to attach a surface? Without errors? I noticed that I was using IDirectDrawSurface, and I can attach a back buffer. But, in theory, I shouldn't be able to. Why is this? Is the AddAttachedSurface thing part of IDirectDrawSurface as well?

If so, then what are we doing wrong? I am getting REALLY sick of this :)

Follow Ups:

Post a Followup

Name:


This Z-Buffer is going to KILLLL me!

Posted by Shai'tan on July 09, 1998 at 00:47:46:

Ok, the Z-Buffer WORKS! Sorta. It sorts TLVERTEX's PERFECTLY - putting them in the right order and everything. But when I try and render LVERTEX's it doesn't do anything - just lets them render in the order they are specified, so 4 goes over 3 goes over 2 etc. Why does it work when I use D3DVT_TLVERTEX in the DrawPrimitive, but not when I use D3DVT_LVERTEX?

The only thing I can think of is a problem with the viewport? View matrix? Why would it work for TL and not for L? Logically it must have something to do with the T ( transformation ) then. So either World, View, Projection are responsible?

Here is what I have for View, World, Projection:

mWorld = IdentityMatrix();
mView = IdentityMatrix();
mProjection = ProjectionMatrix( 0.01f, 2000000.0f, (float)(60*PI/180)); // 60 degree FOV

Is there anything wrong with that??

Oh, and also - whenever I move the view THROUGH a polygon, it obviously writes its Z-coordinate ( 0.01, just before it clips ) into the Z-Buffer, because after that nothing gets rendered. So obviously it IS doing Z-buffering, and checking against the Z-Buffer....but why then do the other primitives not sort?? Hmmm....strange things happenning....

Once again, would it be possible for ANY of you legends who have a working Z-BUffer to post the code? That would be a HUGE help to us poor bastards :)

A very desperate Shai'tan-[Nth] :)

Follow Ups:

  • Re: This Z-Buffer is going to KILLLL me! Fragmo 02:13:06 7/09/98 (0)

Post a Followup

Name:


What will happen?

Posted by James Martin on July 09, 1998 at 01:46:47:

HI all.
I have a question.

If you try to release a surface when the surface is busy,
what happens? Atleast my program crashes.
How do I make sure before releasing a surface that it is not busy?

If you happen to know the answer, Pl respond.
Thanks in advance.
Bye
James Martin.

Follow Ups:

  • Re: You need to WAIT Shai'tan 02:16:32 7/09/98 (2)
    • Re: You need to WAIT Fragmo 23:45:05 7/09/98 (1)
      • Need some more info Ravi Joshi 02:42:37 7/10/98 (0)

Post a Followup

Name:


Re: This Z-Buffer is going to KILLLL me!

Posted by Fragmo on July 09, 1998 at 02:13:06:

In Reply to: This Z-Buffer is going to KILLLL me! posted by Shai'tan on July 09, 1998 at 00:47:46:

if i'm not mistaken, you were using a 16 bit z buffer, which doesn't give very good results
if you map the z values to a huge range, try shrinking the range from .01 - 2000000 to .1 - 1000.0

: Ok, the Z-Buffer WORKS! Sorta. It sorts TLVERTEX's PERFECTLY - putting them in the right order and everything. But when I try and render LVERTEX's it doesn't do anything - just lets them render in the order they are specified, so 4 goes over 3 goes over 2 etc. Why does it work when I use D3DVT_TLVERTEX in the DrawPrimitive, but not when I use D3DVT_LVERTEX?

: The only thing I can think of is a problem with the viewport? View matrix? Why would it work for TL and not for L? Logically it must have something to do with the T ( transformation ) then. So either World, View, Projection are responsible?

: Here is what I have for View, World, Projection:

: mWorld = IdentityMatrix();
: mView = IdentityMatrix();
: mProjection = ProjectionMatrix( 0.01f, 2000000.0f, (float)(60*PI/180)); // 60 degree FOV

: Is there anything wrong with that??

: Oh, and also - whenever I move the view THROUGH a polygon, it obviously writes its Z-coordinate ( 0.01, just before it clips ) into the Z-Buffer, because after that nothing gets rendered. So obviously it IS doing Z-buffering, and checking against the Z-Buffer....but why then do the other primitives not sort?? Hmmm....strange things happenning....

: Once again, would it be possible for ANY of you legends who have a working Z-BUffer to post the code? That would be a HUGE help to us poor bastards :)

: A very desperate Shai'tan-[Nth] :)

Follow Ups:

Post a Followup

Name:


Re: You need to WAIT

Posted by Shai'tan on July 09, 1998 at 02:16:32:

In Reply to: What will happen? posted by James Martin on July 09, 1998 at 01:46:47:

: If you try to release a surface when the surface is busy,
: what happens? Atleast my program crashes.
: How do I make sure before releasing a surface that it is not busy?

Well, assuming that the only action you are doing on the surface is Blting to it ( or from it ). If this is the case, and you are using some form of page-flipping ( also likely ) then all you have to do is make sure you use DDFLIP_WAIT flag when you are Flipping...for instance, if your primary surface is sPrimary:

sPrimary->Flip( NULL, DDFLIP_WAIT );

That way you won't be allowed to do anything to the surface until it has finished - or so I believe. Clay or Fragmo will probably be able to clarify this....

Shai'tan-[Nth]

Follow Ups:

  • Re: You need to WAIT Fragmo 23:45:05 7/09/98 (1)
    • Need some more info Ravi Joshi 02:42:37 7/10/98 (0)

Post a Followup

Name:


Re: To Fragmo

Posted by Fragmo on July 09, 1998 at 02:36:05:

In Reply to: Re: To Fragmo posted by Karl Fisher on July 08, 1998 at 22:03:05:

AddAttachedSurface should work fine, i believe the problem you mentioned is just a stupidity in the documentation ;)
test the return code of AddAttachedSurface, the most probable cause would be an out of memory error
since you are using 3 800x600x16 surfaces (unless i read it wrong)

: Thanks much for your reply Fragmo

: You got me on the right track, but I still can't get it to work.

: The ZBuffer AddAttachedSurface was failing, so looked ay the DX5 Help and it appeared that the AddAttachedSurface is a method of IDirectDrawSurface3. I declared an IDirectDrawSurface, but then I received compile errors regarding conversion of the structures.

: I can use the code in the sdk samples such as the Light Demo, but I was hoping to get it to work in a less complicated program for the purpose of better understanding how all these things work.

: I will keep trying, and woud appreciate hearing about anything you may think of that might get me straightened out.

: Thanks Again

: Karl

:
: : you didn't attach the z buffer for the software device
: : if you aren't using hardware, then that's the problem
: : also, you could test to make sure that the z buffer is attaching properly

: : : I noticed your messages regarding problems Shai'tan has been having with Z-Buffers.

: : : My problem is not quite the same. The objects get rendered ok, but it is just as if there is no ZBuffer.

: : : In one of the messages there was mention of some code sent to Shai'tan, and I thought that may help if I could receive a copy.

: : : The following is a message I have posted on several forums that describes my problem and the code I am trying to get to work.

: : : I really am stumped, and would appreciate anything you can tell me.

: :
: : : Help Please,

: : : I am a beginner with Direct 3D and I am stumped on implementing Z Buffering
: : : for Immediate Mode.

: : : I am trying to add ZBuffering to the CDX IM example.

: : : It all compiles and runs, but no matter what I do the second draw primitive
: : : is always rendered on top of the first draw primitive regardless of their Z
: : : Values.

: : : The following is the code I am trying to use, and obviously I am missing
: : : something. Any suggestions will be greatly appreciated.

Follow Ups:

  • Re: To Fragmo Fragmo 02:48:03 7/09/98 (0)

Post a Followup

Name:


Re: To Fragmo

Posted by Fragmo on July 09, 1998 at 02:48:03:

In Reply to: Re: To Fragmo posted by Fragmo on July 09, 1998 at 02:36:05:

oops, AddAttachedSurface cant return an out of memory error, check the CreateSurface return code for that.
attaching an invalid surface would cause it too fail. it would be a wise practice to just
check all return codes (of critical functions anyway) in the future, and place error messages
in the appropriate locations to help solve problems like this

: AddAttachedSurface should work fine, i believe the problem you mentioned is just a stupidity in the documentation ;)
: test the return code of AddAttachedSurface, the most probable cause would be an out of memory error
: since you are using 3 800x600x16 surfaces (unless i read it wrong)

: : Thanks much for your reply Fragmo

: : You got me on the right track, but I still can't get it to work.

: : The ZBuffer AddAttachedSurface was failing, so looked ay the DX5 Help and it appeared that the AddAttachedSurface is a method of IDirectDrawSurface3. I declared an IDirectDrawSurface, but then I received compile errors regarding conversion of the structures.

: : I can use the code in the sdk samples such as the Light Demo, but I was hoping to get it to work in a less complicated program for the purpose of better understanding how all these things work.

: : I will keep trying, and woud appreciate hearing about anything you may think of that might get me straightened out.

: : Thanks Again

: : Karl

: :
: : : you didn't attach the z buffer for the software device
: : : if you aren't using hardware, then that's the problem
: : : also, you could test to make sure that the z buffer is attaching properly

: : : : I noticed your messages regarding problems Shai'tan has been having with Z-Buffers.

: : : : My problem is not quite the same. The objects get rendered ok, but it is just as if there is no ZBuffer.

: : : : In one of the messages there was mention of some code sent to Shai'tan, and I thought that may help if I could receive a copy.

: : : : The following is a message I have posted on several forums that describes my problem and the code I am trying to get to work.

: : : : I really am stumped, and would appreciate anything you can tell me.

: : :
: : : : Help Please,

: : : : I am a beginner with Direct 3D and I am stumped on implementing Z Buffering
: : : : for Immediate Mode.

: : : : I am trying to add ZBuffering to the CDX IM example.

: : : : It all compiles and runs, but no matter what I do the second draw primitive
: : : : is always rendered on top of the first draw primitive regardless of their Z
: : : : Values.

: : : : The following is the code I am trying to use, and obviously I am missing
: : : : something. Any suggestions will be greatly appreciated.

Follow Ups:

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by jeff1 on July 09, 1998 at 08:44:34:

In Reply to: where can I download direct X 5.0 posted by Yves Lavoie on February 06, 1998 at 23:01:14:

: where I can get direct X 5.0 please a answer

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Fauzea on July 09, 1998 at 13:04:34:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Igor on March 25, 1998 at 00:12:52:

: : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 bo 19:52:24 9/07/98 (0)

Post a Followup

Name:


DrawPrimitive in RM. READ THIS!!!!!

Posted by Kevin Cline on July 09, 1998 at 16:18:45:

I've finally got DrawPrimitive to work!!... sorta...
It still has a few setbacks.

Problem 1.
I added a cube mesh in the normal RM way, and you can see it when I comment out the uservisual, but with the uservisual, DrawPrimitive draws the triangle its supposed to, but it clips everything else in the scene, you can't see the cube.

Problem 2.
If the the part of the window with the triangle leaves the screen (i.e. minimizing the window, moving it, etc...) the triangle disappears, but everything is still clipped and DrawPrimitive keeps returning DD_OK.

Problem 3.
Depending which frame I attach the uservisual to, the triangle is drawn in a different place on the screen, so the RM does do a little to help. But when I move the frame the uservisual is attached to, the triangle doesn't move. I don't know if this is related to Problem 2 or what, but the triangle just doesn't move.

Problem 4.
This isn't really a problem, just other info. If I attach the uservisual to the camera frame, it is never drawn, even if the vertices are right in front of it.

That's all I can remember right now, but I'm sure something else will pop up. Any help on any of the problems would be appreciated.

Thanks,
Kevin Cline

Follow Ups:

Post a Followup

Name:


Loading DXF files in DirectX

Posted by chump on July 09, 1998 at 18:33:37:

Is there any way to load DXF files in DirectX, like for
levels of a game or something.

Thanx in advance,

chump

Follow Ups:

  • Re: Loading DXF files in DirectX MAgDI 22:45:52 7/11/98 (0)

Post a Followup

Name:


Re: Hehe...online development :)

Posted by Karl Fisher on July 09, 1998 at 19:57:47:

In Reply to: Re: Hehe...online development :) posted by Shai'tan on July 08, 1998 at 22:36:16:

Hi Shai'tan
Thanks for the reply. I am going to try again tonight, but at this point I am not very optimistic. I don't have any problems with Z-Buffering in the SDK Examples, and I have been trying to use the code from the Light example in my program. I am sure someone will discover the solution evevntually.

Thanks
Karl
karl_fisher@msn.com

: : The ZBuffer AddAttachedSurface was failing, so looked ay the DX5 Help and it appeared that the AddAttachedSurface is a method of IDirectDrawSurface3. I declared an IDirectDrawSurface, but then I received compile errors regarding conversion of the structures.

: Yeah, from your 'tips' I got to exactly the same stage, and I am assuming since the IDirectDraw2::CreateSurface method returns a LPBLAHBLAHSURFACE, you have to use queryinterface to get the SURFACE3? What is the GUID for that?

: Yeah, be good to hear from you if you get it figured out Karl :)
: Oh, yeah, btw, my ICQ is 2273950 if anyone is interested...be good to share ideas Karl :)

Follow Ups:

  • Re: Z-Buffer code in SDK samples Shai'tan 02:16:59 7/10/98 (1)
    • Re: Z-Buffer code in SDK samples Karl Fisher 12:44:37 7/10/98 (0)

Post a Followup

Name:


Re: You need to WAIT

Posted by Fragmo on July 09, 1998 at 23:45:05:

In Reply to: Re: You need to WAIT posted by Shai'tan on July 09, 1998 at 02:16:32:

the docs indicate that the surface is busy because it has been locked.
make sure to unlock the surface before trying to release it.

Fragmo
www.public.iastate.edu/~jtilton/rpg.htm

: : If you try to release a surface when the surface is busy,
: : what happens? Atleast my program crashes.
: : How do I make sure before releasing a surface that it is not busy?

: Well, assuming that the only action you are doing on the surface is Blting to it ( or from it ). If this is the case, and you are using some form of page-flipping ( also likely ) then all you have to do is make sure you use DDFLIP_WAIT flag when you are Flipping...for instance, if your primary surface is sPrimary:

: sPrimary->Flip( NULL, DDFLIP_WAIT );

: That way you won't be allowed to do anything to the surface until it has finished - or so I believe. Clay or Fragmo will probably be able to clarify this....

: Shai'tan-[Nth]

Follow Ups:

  • Need some more info Ravi Joshi 02:42:37 7/10/98 (0)

Post a Followup

Name:


Re: Z-Buffer code in SDK samples

Posted by Shai'tan on July 10, 1998 at 02:16:59:

In Reply to: Re: Hehe...online development :) posted by Karl Fisher on July 09, 1998 at 19:57:47:

: Hi Shai'tan
: Thanks for the reply. I am going to try again tonight, but at this point I am not very optimistic. I don't have any problems with Z-Buffering in the SDK Examples, and I have been trying to use the code from the Light example in my program. I am sure someone will discover the solution evevntually.

Yeah, which SDK samples contain Z-Buffer code? Or which is the one you are looking at? Cause I don't think I have all the SDK samples - as my download was pretty corrupted :)

Thanks!

Shai'tan-[Nth]

Follow Ups:

  • Re: Z-Buffer code in SDK samples Karl Fisher 12:44:37 7/10/98 (0)

Post a Followup

Name:


Need some more info

Posted by Ravi Joshi on July 10, 1998 at 02:42:37:

In Reply to: Re: You need to WAIT posted by Fragmo on July 09, 1998 at 23:45:05:

Hi all,

I want to know if the "GetBltStatus" and "GetFlipStatus" find out if a surface is
being written to or writing to some other surface.
Or do these functions return the status DDERR_WASSTILLDRAWING irrespective of
whether the surface is writing or is being written to.

If you happen to know a solution,
Pl post
Thanks in advance..
Ravi Joshi.

Follow Ups:

Post a Followup

Name:


Only DDraw, not D3D. How?

Posted by Ravi Joshi on July 10, 1998 at 03:07:45:

Hi to all, especially Fragmo, Shaitan, Clay, 0x1CE and Doug.
If one tries to write a 3d game/ engine, only with DirectDraw ,without the support of Direct3D,
1.How effective will it be?.
2.What flexibility will it offer?
3.What flexibility will it take away?

What care he has to take to do it?
If you have any suggestions, please post those.
Thanks in advance..
Ravi Joshi.

Follow Ups:

  • Re: Only DDraw, not D3D. How? 0x1CE 17:26:08 7/10/98 (0)
  • take us back to 1980s! Clay 10:14:34 7/10/98 (2)
    • Where do I get info on Hardware Acceleration? Ravi Joshi 03:04:46 7/13/98 (1)
      • Re: Where do I get info on Hardware Acceleration? 0x1CE 21:51:44 7/13/98 (0)

Post a Followup

Name:


take us back to 1980s!

Posted by Clay on July 10, 1998 at 10:14:34:

In Reply to: Only DDraw, not D3D. How? posted by Ravi Joshi on July 10, 1998 at 03:07:45:

You could write all of your own 3D rendering routines (there are a LOT of books on the subject) but you would need a very fast computer to get good frame rates (>20 fps or so). The reason being this: you're implementing all of the hidden surface removal, shading, etc. in software. D3D does that if there is no hardware support, and we all know how slow the RGB and MMX (to a lesser degree) drivers are when compared to the HAL. Software rendering with hardware-specific routines was what developers had to do in the 80s. DirectX and OpenGL are supposed to allow the developer to write hardware-independent programs and allow DirectX/OpenGL to use hardware acceleration (if it is available).

That being said, I would suggest to give yourself a crash course in linear algebra, and get some books with algorithms for shading, z-buffering/hidden surface removal, filling, texture mapping, and lighting. Pick out the features you want and do your design. Since you have only the stuff you want, you can optimize it for what you want it to do. You'll probably be able to make it faster than the "generic" stuff in D3D, but probably not faster than a $100-$200 3D hardware accelerator.

Good luck,

Clay

P.S. by the way, when you complete the engine make sure to put it on your resume :->

Follow Ups:

  • Where do I get info on Hardware Acceleration? Ravi Joshi 03:04:46 7/13/98 (1)
    • Re: Where do I get info on Hardware Acceleration? 0x1CE 21:51:44 7/13/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by VICTOR HUERTA on July 10, 1998 at 10:21:14:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Igor on March 25, 1998 at 00:12:52:

: : : Where Can I download DirectX 5.0. I need it for a game
hola pendejo.........

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Antonio DaSilva 21:50:08 7/10/98 (2)
    • Re: Where Can I download DirectX 5.0 wu z 22:13:19 7/21/98 (1)
      • Re: Where Can I download DirectX 5.0 Susan Johnson 03:02:21 7/28/98 (0)

Post a Followup

Name:


Re: Z-Buffer code in SDK samples

Posted by Karl Fisher on July 10, 1998 at 12:44:37:

In Reply to: Re: Z-Buffer code in SDK samples posted by Shai'tan on July 10, 1998 at 02:16:59:

: : Hi Shai'tan
: : Thanks for the reply. I am going to try again tonight, but at this point I am not very optimistic. I don't have any problems with Z-Buffering in the SDK Examples, and I have been trying to use the code from the Light example in my program. I am sure someone will discover the solution evevntually.

: Yeah, which SDK samples contain Z-Buffer code? Or which is the one you are looking at? Cause I don't think I have all the SDK samples - as my download was pretty corrupted :)

: Thanks!

: Shai'tan-[Nth]

Hi Shai'tan,

The Zbbuffer code is in the file pplane.cpp. If you don't have that let me know and I'll send it to you.

Thanks
Karl

Follow Ups:

Post a Followup

Name:


RayPick

Posted by Michael Crowns on July 10, 1998 at 14:08:25:

I can't get raypick to work.

LPDIRECT3DRMPICKED2ARRAY pickedArray = NULL;
DWORD flags;
D3DRMRAY ray;

flags = D3DRMRAYPICK_IGNOREFURTHERPRIMITIVES/* | D3DRMRAYPICK_INTERPOLATEUV*/;

ray.dvDir.x = 0.0f;
ray.dvDir.y = 0.0f;
ray.dvDir.z = 1.0f;

ray.dvPos.x = 0.0f;
ray.dvPos.y = 0.0f;
ray.dvPos.z = 0.0f;

HRESULT ret = m_scene->RayPick(m_camera, &ray, flags, &pickedArray);

if (ret != D3DRM_OK)
{
AfxMessageBox(CDDHelper::TraceError(ret));
return;
}

I am consistently getting bad params message. Any ideas?

Follow Ups:

  • Re: RayPick MAgDI 22:25:11 7/11/98 (1)
    • Re: RayPick Michael Crowns 10:33:30 7/14/98 (0)

Post a Followup

Name:


Re: Only DDraw, not D3D. How?

Posted by 0x1CE on July 10, 1998 at 17:26:08:

In Reply to: Only DDraw, not D3D. How? posted by Ravi Joshi on July 10, 1998 at 03:07:45:

You're a braver man than I. I can't really see the benefiets of
writing your own DDraw based 3d engine outwaying the time/effor/frustration,
but if you're hell bent on doing it I suggest you take the time
to familiarize yourself with hardware acceleration. As for the
quality/flexibility, it's only going to be as good as you make it,
but if you want it as flexible as D3D, expect to put ALOT of effort
into it. Have fun;)

: Hi to all, especially Fragmo, Shaitan, Clay, 0x1CE and Doug.
: If one tries to write a 3d game/ engine, only with DirectDraw ,without the support of Direct3D,
: 1.How effective will it be?.
: 2.What flexibility will it offer?
: 3.What flexibility will it take away?

: What care he has to take to do it?
: If you have any suggestions, please post those.
: Thanks in advance..
: Ravi Joshi.
:

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by fernando i barrola on July 10, 1998 at 19:46:09:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Igor on March 25, 1998 at 00:12:52:

: : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Dan Cedric T. Delima 11:42:31 7/26/98 (0)
  • Re: Where Can I download DirectX 6.0 Josee Oliviero 10:38:35 7/23/98 (2)
    • Re: Where Can I download DirectX 6.0 Nancy Jaggers 15:04:56 9/07/98 (0)
    • Re: Where Can I download DirectX 6.0 zmc 08:15:56 8/30/98 (0)

Post a Followup

Name:


Is there a way to specify the length of sides of an object?

Posted by Snowman on July 10, 1998 at 20:12:11:

Can I tell D3DRM what I want it to scale my meshs too? Is there a way to specify the exact length, instead of using a scale factor?

Thanks in advance!

-Snowman

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Antonio DaSilva on July 10, 1998 at 21:50:08:

In Reply to: Re: Where Can I download DirectX 5.0 posted by VICTOR HUERTA on July 10, 1998 at 10:21:14:

: : : : Where Can I download DirectX 5.0. I need it for a game
: hola pendejo.........

Follow Ups:

  • Re: Where Can I download DirectX 5.0 wu z 22:13:19 7/21/98 (1)
    • Re: Where Can I download DirectX 5.0 Susan Johnson 03:02:21 7/28/98 (0)

Post a Followup

Name:


!!!! Z-BUFFER PROBLEM SOLVED !!!!

Posted by Shai'tan on July 11, 1998 at 00:16:05:

I can't believe it! I fixed my Z-Buffer! Jeez...I can't believe it was so simple. All the time I was initialising it just fine - BUT I WASN'T CLEARING THE Z-BUFFER EVERY RENDERFRAME.

Man, I didn't know you had to! But now I do, I guess, and everything is going great....but a HUGE thanks to everyone who helped, especially Clay and Fragmo - man, you guys deserve medals :)

Well, until the next major problem!

Shai'tan-[Nth]

Follow Ups:

  • Re: Shai'tan !!!! Z-BUFFER PROBLEM SOLVED !!!! Karl Fisher 12:28:53 7/11/98 (0)

Post a Followup

Name:


Re: Soundblaster AWE32 and DirectX 5 problems

Posted by Adele on July 11, 1998 at 03:18:43:

In Reply to: Soundblaster AWE32 and DirectX 5 problems posted by Jesus Giraut on May 10, 1998 at 11:33:06:

: I need to know if there is any incompatibility problem between
: the Soundblaster AWE32 and the direct X 5 drivers. The reason
: of my question is because i큟 having problems with several games
: which use directX 5. When i try to play these games i can큧 hear
: any sounds.

Follow Ups:

Post a Followup

Name:


why doesn't it work?

Posted by JOshua Karjala on July 11, 1998 at 06:58:16:

All my games using directx 5.0 somtimes stop with out me touching anything. and the video's alsso get all sorts of different colors.
i run win95 with s3 trio 32/64 video card

Follow Ups:

Post a Followup

Name:


My Screen isn't centered !?!?!?

Posted by Phil on July 11, 1998 at 09:43:57:

I recently installed Windows 98 (DirectX 5.2) and now when I run Games (NBA Live 98) the picture is smaller and not centered on the screen, a portion isn't even visible ! My drivers worked fine in Windows 95 but now it's stuffed. I've got a Diamond Stealth 64 DRAM (a low budget card), DirectDraw 1.0 only. Is there any way to control where the picture is on the screen ???
Phil
(Can u please respond directly to me...genius@fast.net.au)

Follow Ups:

Post a Followup

Name:


DirectX's other versions

Posted by Augusto Guedes on July 11, 1998 at 10:33:33:

Where can I get DirectX 3.0?

Follow Ups:

Post a Followup

Name:


Re: Shai'tan !!!! Z-BUFFER PROBLEM SOLVED !!!!

Posted by Karl Fisher on July 11, 1998 at 12:28:53:

In Reply to: !!!! Z-BUFFER PROBLEM SOLVED !!!! posted by Shai'tan on July 11, 1998 at 00:16:05:

Congratulations Shai'tan

I still don't have my Z Buffer working, and I have been clearing the Z Buffer each farme. Of course my problem seems to be ahead of that since I get an Invalid Parameter error when I call AddAttachedSurface, and the parameter I am Passing is a DirectDraw Surface, so I am stiil stumped.

If you could send me your code it would be greatly appreciated.

Thanks Karl
karl_fisher@msn.com

: I can't believe it! I fixed my Z-Buffer! Jeez...I can't believe it was so simple. All the time I was initialising it just fine - BUT I WASN'T CLEARING THE Z-BUFFER EVERY RENDERFRAME.

: Man, I didn't know you had to! But now I do, I guess, and everything is going great....but a HUGE thanks to everyone who helped, especially Clay and Fragmo - man, you guys deserve medals :)

: Well, until the next major problem!

: Shai'tan-[Nth]

Follow Ups:

Post a Followup

Name:


Please help...Newbie question about DDraw SDK samples

Posted by Newbie on July 11, 1998 at 19:21:59:

I am a newbie at all of this so please be gentle. When I try and build the ddex1.cpp it compiles fine but I get a linker error. I am new at both VC++ 5 as well as DirectX...could someone help please...it would be much appreciated....

Follow Ups:

  • Welcome Aboard Ravi Joshi 02:33:57 7/13/98 (0)
  • Re: Please help...Newbie question about DDraw SDK samples Fragmo 19:34:38 7/11/98 (7)
    • Re: Please help...Newbie question about DDraw SDK samples newbie 19:50:05 7/11/98 (6)
      • Re: Please help...Newbie question about DDraw SDK samples Carlos2 00:11:11 7/16/98 (0)
      • Re: Please help...Newbie question about DDraw SDK samples Fragmo 21:53:51 7/11/98 (4)
        • Re: Please help...Newbie question about DDraw SDK samples Shai'tan 05:36:26 7/12/98 (3)
          • Re: Please help...Newbie question about DDraw SDK samples 0x1CE 00:39:08 7/14/98 (0)
          • Re: Please help...Newbie question about DDraw SDK samples GettinThere 17:46:00 7/13/98 (1)
            • Re: Please help...Newbie question about DDraw SDK samples Carlos 23:55:50 7/15/98 (0)

Post a Followup

Name:


Re: Please help...Newbie question about DDraw SDK samples

Posted by Fragmo on July 11, 1998 at 19:34:38:

In Reply to: Please help...Newbie question about DDraw SDK samples posted by Newbie on July 11, 1998 at 19:21:59:

did you specify the path to the SDK libraries and include files?

: I am a newbie at all of this so please be gentle. When I try and build the ddex1.cpp it compiles fine but I get a linker error. I am new at both VC++ 5 as well as DirectX...could someone help please...it would be much appreciated....

Follow Ups:

  • Re: Please help...Newbie question about DDraw SDK samples newbie 19:50:05 7/11/98 (6)
    • Re: Please help...Newbie question about DDraw SDK samples Carlos2 00:11:11 7/16/98 (0)
    • Re: Please help...Newbie question about DDraw SDK samples Fragmo 21:53:51 7/11/98 (4)
      • Re: Please help...Newbie question about DDraw SDK samples Shai'tan 05:36:26 7/12/98 (3)
        • Re: Please help...Newbie question about DDraw SDK samples 0x1CE 00:39:08 7/14/98 (0)
        • Re: Please help...Newbie question about DDraw SDK samples GettinThere 17:46:00 7/13/98 (1)
          • Re: Please help...Newbie question about DDraw SDK samples Carlos 23:55:50 7/15/98 (0)

Post a Followup

Name:


Re: Please help...Newbie question about DDraw SDK samples

Posted by newbie on July 11, 1998 at 19:50:05:

In Reply to: Re: Please help...Newbie question about DDraw SDK samples posted by Fragmo on July 11, 1998 at 19:34:38:

: did you specify the path to the SDK libraries and include files?

: : I am a newbie at all of this so please be gentle. When I try and build the ddex1.cpp it compiles fine but I get a linker error. I am new at both VC++ 5 as well as DirectX...could someone help please...it would be much appreciated....

yes, i added ddraw.lib into the link, and also added the inc and lib directories...still getting the error

ddex1.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12
Debug/ddex1.exe : fatal error LNK1120: 1 unresolved externals
Error executing link.exe.

really need some help....

ps...using VC++ 5..if that matters i am not sure...

Follow Ups:

  • Re: Please help...Newbie question about DDraw SDK samples Carlos2 00:11:11 7/16/98 (0)
  • Re: Please help...Newbie question about DDraw SDK samples Fragmo 21:53:51 7/11/98 (4)
    • Re: Please help...Newbie question about DDraw SDK samples Shai'tan 05:36:26 7/12/98 (3)
      • Re: Please help...Newbie question about DDraw SDK samples 0x1CE 00:39:08 7/14/98 (0)
      • Re: Please help...Newbie question about DDraw SDK samples GettinThere 17:46:00 7/13/98 (1)
        • Re: Please help...Newbie question about DDraw SDK samples Carlos 23:55:50 7/15/98 (0)

Post a Followup

Name:


need help with display driver

Posted by Zak on July 11, 1998 at 20:05:53:

Hi,
Ok, here's my problem:
I was initializing my direct draw with this command:
directdrawcreate(NULL,&lpdd,NULL) and everything worked fine until I realized that I wasn't using my hardware acceleration. I have a monster3d.

I programmed a procedure listing my driver and display device. I have 2 device: the primary display device and the 3DMonster display device. My primary display device support ramp and rgb mode. My 3dmonster display support ramp, rgb and HAL.

What I'm trying to do is using 3DMonster display device to be able to function with the HAL.

So, I stored the guid of the 3Dmonster display and used it in my directdrawcreate(&guidof3dmonster, &lpDD, NULL). But it fails to do anything, my screen become black, my mouse disappear, and I have to reboot my machine.

So please, if someone could tell me what I'm doing wrong, I'd be eternally grateful!

Zak

Follow Ups:

  • Re: need help with display driver Konrad 11:47:58 7/12/98 (0)
  • Re: need help with display driver Konrad 11:43:19 7/12/98 (0)

Post a Followup

Name:


Re: Please help...Newbie question about DDraw SDK samples

Posted by Fragmo on July 11, 1998 at 21:53:51:

In Reply to: Re: Please help...Newbie question about DDraw SDK samples posted by newbie on July 11, 1998 at 19:50:05:

i'm not sure, but i remember seeing a similar error when i started using directX.
it was caused when i tried to compile a C file as C++
if that isn't it, try adding this statement before any of the include files

#ifndef INITGUID
#define INITGUID
#endif

and if that still doesn't work, recheck to make sure your library path is correct

: : did you specify the path to the SDK libraries and include files?

: : : I am a newbie at all of this so please be gentle. When I try and build the ddex1.cpp it compiles fine but I get a linker error. I am new at both VC++ 5 as well as DirectX...could someone help please...it would be much appreciated....

: yes, i added ddraw.lib into the link, and also added the inc and lib directories...still getting the error

: ddex1.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12
: Debug/ddex1.exe : fatal error LNK1120: 1 unresolved externals
: Error executing link.exe.

: really need some help....

: ps...using VC++ 5..if that matters i am not sure...

Follow Ups:

  • Re: Please help...Newbie question about DDraw SDK samples Shai'tan 05:36:26 7/12/98 (3)
    • Re: Please help...Newbie question about DDraw SDK samples 0x1CE 00:39:08 7/14/98 (0)
    • Re: Please help...Newbie question about DDraw SDK samples GettinThere 17:46:00 7/13/98 (1)
      • Re: Please help...Newbie question about DDraw SDK samples Carlos 23:55:50 7/15/98 (0)

Post a Followup

Name:


Re: RayPick

Posted by MAgDI on July 11, 1998 at 22:25:11:

In Reply to: RayPick posted by Michael Crowns on July 10, 1998 at 14:08:25:

If what you want is to pick an object (mesh) from a viewport.
I am afraid that you are using a very bad technike

Were did you read this??? Please let me know.

I am using a very good book."cutting edge 3d programing" by Stan Trojillo

my ges the problem is in here
ray.dvDir.x = 0.0f;
ray.dvDir.y = 0.0f;
ray.dvDir.z = 1.0f;

ray.dvPos.x = d3dvalue (0);
ray.dvPos.y = d3dvalue (0);
ray.dvPos.z = d3dvalue (1);

Follow Ups:

  • Re: RayPick Michael Crowns 10:33:30 7/14/98 (0)

Post a Followup

Name:


Re: Loading DXF files in DirectX

Posted by MAgDI on July 11, 1998 at 22:45:52:

In Reply to: Loading DXF files in DirectX posted by chump on July 09, 1998 at 18:33:37:

Is there any way to load DXF files in DirectX, like for
levels of a game or something.

use somthing like 3d studio to convert from dxf to 3ds
Then us the converter that comes withe directx sdk

Any more details e-mail me.

good luck.

Follow Ups:

Post a Followup

Name:


Re: Please help...Newbie question about DDraw SDK samples

Posted by Shai'tan on July 12, 1998 at 05:36:26:

In Reply to: Re: Please help...Newbie question about DDraw SDK samples posted by Fragmo on July 11, 1998 at 21:53:51:

Yeah, sounds very much like initial errors I used to have :)

I think INITGUID is to do with RM?? but I agree with Fragmo, it should be cleaned up if you link to ddraw.lib, all I can suggest is to make sure you have the dxsdk include directory BEFORE all other includes..this was a problem for MSVC++ 4.2 users...don't think it affects VC5, but hey, worth a try.

Other than that...try doing a complete Rebuild??
A related problem I had with DInput was that I had to link to dxguid.lib - but I don't think that would be your problem...if that doesn't fix it, I'll load ddex1 myself and try get it working :)

Unless of course the legendary Fragmo or Clay have already cleared it up :)

Follow Ups:

  • Re: Please help...Newbie question about DDraw SDK samples 0x1CE 00:39:08 7/14/98 (0)
  • Re: Please help...Newbie question about DDraw SDK samples GettinThere 17:46:00 7/13/98 (1)
    • Re: Please help...Newbie question about DDraw SDK samples Carlos 23:55:50 7/15/98 (0)

Post a Followup

Name:


HELP!! Texture perspective correction

Posted by Konrad on July 12, 1998 at 11:32:15:

A square out of two triangles wrapped with a texture
appears corrupted when rotated so that it points to the back. i assume its to do with perspective correction not applied. Is there a way to avoid this?

Follow Ups:

Post a Followup

Name:


Re: need help with display driver

Posted by Konrad on July 12, 1998 at 11:43:19:

In Reply to: need help with display driver posted by Zak on July 11, 1998 at 20:05:53:

: Hi,
: Ok, here's my problem:
: I was initializing my direct draw with this command:
: directdrawcreate(NULL,&lpdd,NULL) and everything worked fine until I realized that I wasn't using my hardware acceleration. I have a monster3d.

: I programmed a procedure listing my driver and display device. I have 2 device: the primary display device and the 3DMonster display device. My primary display device support ramp and rgb mode. My 3dmonster display support ramp, rgb and HAL.

: What I'm trying to do is using 3DMonster display device to be able to function with the HAL.

: So, I stored the guid of the 3Dmonster display and used it in my directdrawcreate(&guidof3dmonster, &lpDD, NULL). But it fails to do anything, my screen become black, my mouse disappear, and I have to reboot my machine.

: So please, if someone could tell me what I'm doing wrong, I'd be eternally grateful!

: Zak

I m not that experienced so my only suggestion is:
isnt monster3d using 3dfx? i think you have to access the board through glide library. http://www.devgames.com/BlackArt/ offers a glide tuttorial.
http://www.3dfx.com the sdk.

Follow Ups:

Post a Followup

Name:


Re: need help with display driver

Posted by Konrad on July 12, 1998 at 11:47:58:

In Reply to: need help with display driver posted by Zak on July 11, 1998 at 20:05:53:

: Hi,
: Ok, here's my problem:
: I was initializing my direct draw with this command:
: directdrawcreate(NULL,&lpdd,NULL) and everything worked fine until I realized that I wasn't using my hardware acceleration. I have a monster3d.

: I programmed a procedure listing my driver and display device. I have 2 device: the primary display device and the 3DMonster display device. My primary display device support ramp and rgb mode. My 3dmonster display support ramp, rgb and HAL.

: What I'm trying to do is using 3DMonster display device to be able to function with the HAL.

: So, I stored the guid of the 3Dmonster display and used it in my directdrawcreate(&guidof3dmonster, &lpDD, NULL). But it fails to do anything, my screen become black, my mouse disappear, and I have to reboot my machine.

: So please, if someone could tell me what I'm doing wrong, I'd be eternally grateful!

: Zak

I m not that experienced so my only suggestion is:
isnt monster3d using 3dfx? i think you have to access the board through glide library. http://www.devgames.com/BlackArt/ offers a glide tuttorial.
http://www.3dfx.com the sdk.

Follow Ups:

Post a Followup

Name:


IID_IDirect3DHALDevice

Posted by Zak on July 12, 1998 at 20:37:01:

Hi,

In my neverending quest to use my hardware acceleration on a secondary display (A monsters'3dfx add-on card), I've read someone (Clay, was it you?) who was using the constant IID_IDirect3DHALDevice.

It seems simple enough to me to simply put this in argument to my createdevicefromsurface, but the compiler (it HATES me!) will not recognize IID_IDirect3DHALDevice.

So my questions is:
Will this command will be of any help or am I still fighting windmill?
If I can use it, what do I need to include for my compiler to recognize it?

Oh, and in a more general subject, could someone please tell me the relationships between device (primary device, Monster3d display device etc...) and the mode I can use? (ramp, rgb, HAL etc...) Cant I use the HAL with my primary display device?

I'm successfuly retrieving the HAL's GUID, but whenever I try to put it in my createdevicefromsurface, it just doensnt work! Arrggghh!

Well, thanks in advance,

Zak

Follow Ups:

  • Re: IID_IDirect3DHALDevice Dave Burrows 09:43:09 7/13/98 (0)
  • Re: IID_IDirect3DHALDevice Fragmo 02:11:00 7/13/98 (0)

Post a Followup

Name:


Re: IID_IDirect3DHALDevice

Posted by Fragmo on July 13, 1998 at 02:11:00:

In Reply to: IID_IDirect3DHALDevice posted by Zak on July 12, 1998 at 20:37:01:

try putting this code in before any of your includes

#ifndef INITGUID
#define INITGUID
#endif

this should make the compiler shut up :)

http://www.public.iastate.edu/~jtilton/rpg.htm

: Hi,

: In my neverending quest to use my hardware acceleration on a secondary display (A monsters'3dfx add-on card), I've read someone (Clay, was it you?) who was using the constant IID_IDirect3DHALDevice.

: It seems simple enough to me to simply put this in argument to my createdevicefromsurface, but the compiler (it HATES me!) will not recognize IID_IDirect3DHALDevice.

: So my questions is:
: Will this command will be of any help or am I still fighting windmill?
: If I can use it, what do I need to include for my compiler to recognize it?

: Oh, and in a more general subject, could someone please tell me the relationships between device (primary device, Monster3d display device etc...) and the mode I can use? (ramp, rgb, HAL etc...) Cant I use the HAL with my primary display device?

: I'm successfuly retrieving the HAL's GUID, but whenever I try to put it in my createdevicefromsurface, it just doensnt work! Arrggghh!

: Well, thanks in advance,

: Zak

Follow Ups:

Post a Followup

Name:


Welcome Aboard

Posted by Ravi Joshi on July 13, 1998 at 02:33:57:

In Reply to: Please help...Newbie question about DDraw SDK samples posted by Newbie on July 11, 1998 at 19:21:59:

You said your name is NewBie. But you can state your true name too. This is a site of pretty decent people.

As of your question, You have two choices.
1. Include all the lib and header files in the path list and the path for the DirectX files should precede
those of other files. Yes it effects VC5 too.
2. Replace all the directX related files( both lib and .h) from VC directory with those you
get in DirectX SDK.

Bye, have a nice time.
Ravi Joshi....

Follow Ups:

Post a Followup

Name:


Where do I get info on Hardware Acceleration?

Posted by Ravi Joshi on July 13, 1998 at 03:04:46:

In Reply to: take us back to 1980s! posted by Clay on July 10, 1998 at 10:14:34:

HI to all , Ox1CE and Clay.
Thanks for your suggestions. In your message, you talked about "hardware acceleration". Where do
I get more information on this issue.
Pl guide me.
Thanks..
Ravi Joshi.

Follow Ups:

  • Re: Where do I get info on Hardware Acceleration? 0x1CE 21:51:44 7/13/98 (0)

Post a Followup

Name:


MFC and DirectX...

Posted by Nick Weihs on July 13, 1998 at 03:35:38:

I am making a Map Editor for a game, but there seems to be a problem

I have the layout of the Window in 3 split frames like this

________
| |
|______|
|___|__|

the bottom left hand corner is a display of possible tiles from a bmp. There are way too many tiles to fit in there, so I had to use scroll bars. But when you start scrolling down a bit, it will mess up the cursor, then actually start puting all these green lines all over the screen progressivly going up as you scroll down. Is there anyway to fix this, without having to repaint ever frame??

Follow Ups:

Post a Followup

Name:


D3D IM : D3DOP_TEXTURELOAD

Posted by Dave Burrows on July 13, 1998 at 09:35:28:

I'm having problems with the above command inside an execute buffer. It works under
certain cards (Voodoo 1&2, Riva128, i740,G100,...) it does not work on Rendition
2200/2100 or Permedia2.

Therefore does anybody know:-
1. If there is any thing weird about the way these two chip sets handle this command.
2. Is there any thing weird about using the command itself.

Thanks in advance

Follow Ups:

Post a Followup

Name:


Re: IID_IDirect3DHALDevice

Posted by Dave Burrows on July 13, 1998 at 09:43:09:

In Reply to: IID_IDirect3DHALDevice posted by Zak on July 12, 1998 at 20:37:01:

You should really enumerate devices to see what the machine has in it.

If with in the enum function you store the GUID and the device name you could use them to select the device from a menu.

Follow Ups:

Post a Followup

Name:


Using HAL with Monster3D

Posted by Zak on July 13, 1998 at 10:44:55:

Hi!

Interested in my soul? I'll gladly give it to anyone
that successfully used HAL with an add-on card.

I do get the GUID of my monster3d's HAL, but whenever
it put it in my createdevicefromsurface, my screen
blink, return to my VC editor, and I don't even
get an error message. If I create my device with the
NULL parameter, everythings work fine, except I'm using
RAMP emulation instead of HAL.

Also, I can enumerate my display device, but whenever I
try to use the Monster3d display device instead of
the primary display device, my computer lock and I
have to re-boot.

I'm desesperate, so if you know how to use hadware
acceleration with an add-on card, please help me,
you'll make a man darn happy.

Zak

Follow Ups:

  • Re: Using HAL with Monster3D Dave Burrows 11:55:16 7/13/98 (2)
    • Re: Using HAL with Monster3D Zak 14:45:22 7/13/98 (1)
      • Re: Using HAL with Monster3D Dave Burrows 05:52:01 7/15/98 (0)

Post a Followup

Name:


Re: Using HAL with Monster3D

Posted by Dave Burrows on July 13, 1998 at 11:55:16:

In Reply to: Using HAL with Monster3D posted by Zak on July 13, 1998 at 10:44:55:

I haven't used "CreateDeviceFromSurface" I'm a Immediate-Mode user.

But I would think that the call would not like you changing the GUID.

Do you use the same GUID to create the DirectDraw Ojbect and then after use that to create the surface?

If not I would think you would be asking for trouble.

Follow Ups:

  • Re: Using HAL with Monster3D Zak 14:45:22 7/13/98 (1)
    • Re: Using HAL with Monster3D Dave Burrows 05:52:01 7/15/98 (0)

Post a Followup

Name:


Osprey board

Posted by Benjam�n G�mez Tagle on July 13, 1998 at 14:28:19:

We�re developing a videotelephony application and we
decided to use DirectX to interact with the hardware.

We�ve got an Osprey-1000 board, which captures and
compresses audio and video at the same time.
The audio compression formats includes PCM, G.728 and
G.723. We�d like to use the G.728 format because the
low bitrate, however, DirectX doesn�t support formats
different from waveform. The help mentions that in
order to use special hardware capabilities we need a
header file that contains the prototipe calls to the
hardware. Unfortunately we don't get them, how can
we get them?

Follow Ups:

Post a Followup

Name:


Re: Using HAL with Monster3D

Posted by Zak on July 13, 1998 at 14:45:22:

In Reply to: Re: Using HAL with Monster3D posted by Dave Burrows on July 13, 1998 at 11:55:16:

Humm, here's how I see it:

I need to find the GUID of the display driver.
I have 2 choices: Primary Display Driver and
Monster3D display driver.

For the Primary Display Driver, I have the GUID of
the RAMP and of the RGB.
For the Monster3D display driver I have the GUID
of the RAMP, the RGB, and of the HAL.

So, in my probably failing logic, I must:
1) create my DirectDrawCreate with the monster3D
display Driver's GUID
2) Create Device from surface with the HAL's GUID.

Is that so?? Is there something stupid I'm not
aware of? Is there a reason why whenever I
make a DirectDrawCreate with the monster's GUID,
my machine freeze?

Thanks in advance,

Zak

: I haven't used "CreateDeviceFromSurface" I'm a Immediate-Mode user.

: But I would think that the call would not like you changing the GUID.

: Do you use the same GUID to create the DirectDraw Ojbect and then after use that to create the surface?

: If not I would think you would be asking for trouble.

Follow Ups:

  • Re: Using HAL with Monster3D Dave Burrows 05:52:01 7/15/98 (0)

Post a Followup

Name:


Re: Please help...Newbie question about DDraw SDK samples

Posted by GettinThere on July 13, 1998 at 17:46:00:

In Reply to: Re: Please help...Newbie question about DDraw SDK samples posted by Shai'tan on July 12, 1998 at 05:36:26:

well, i have had similar problem, and sometimes
when you change library file paths, and the include
(.h) file paths, you need to do Update Dependencies
to get the compiler to notice, then Rebuild All.
see if that helps.

Follow Ups:

  • Re: Please help...Newbie question about DDraw SDK samples Carlos 23:55:50 7/15/98 (0)

Post a Followup

Name:


Re: Where do I get info on Hardware Acceleration?

Posted by 0x1CE on July 13, 1998 at 21:51:44:

In Reply to: Where do I get info on Hardware Acceleration? posted by Ravi Joshi on July 13, 1998 at 03:04:46:

You can go to the URL I'm attaching to this post
for a rough overview of programming hardware
acceleration in a Windows environment. From there
you should decide whether you want to empliment
HAL or HEL or something similar (this stuff is
way over my head), or if you want to program
video cards individually (which would suck), and
take it from there. I don't know if it's hard to
get books on programming in India, but it would
definately be worth your time if you could track
one down on using hardware acceleration/emulation.
Sorry I couldn't be more helpfull,
0x1CE

: HI to all , Ox1CE and Clay.
: Thanks for your suggestions. In your message, you talked about "hardware acceleration". Where do
: I get more information on this issue.
: Pl guide me.
: Thanks..
: Ravi Joshi.

  • Hardware acceleration overview

Follow Ups:

Post a Followup

Name:


Re: DirectDraw and Overlay Surfaces

Posted by Angie Kucmierz on July 13, 1998 at 22:07:30:

In Reply to: DirectDraw and Overlay Surfaces posted by Jagmohan S Nanaware on May 28, 1998 at 02:52:19:

: Dear Friends,

: In my application I need to play an AVI file. Currently I am using normal surfacess Primary surface and seconday surface of DirectDraw to play the video. I want to change to overlay surfaces for playback of the same as overlay surfaces do not ask for Lock. Although the documentation of DirectDraw 5.0 boldly says that overlay surfaces are frequently used to display live video, recorded video, nowhere I have seen a sample or tutorial or guidelines to actually do it. I hope on this there will be sombody who can help me more than microsoft.

Follow Ups:

Post a Followup

Name:


Re: Please help...Newbie question about DDraw SDK samples

Posted by 0x1CE on July 14, 1998 at 00:39:08:

In Reply to: Re: Please help...Newbie question about DDraw SDK samples posted by Shai'tan on July 12, 1998 at 05:36:26:

Actually, INITGUID is used to initialize all the guids
(hence the name) used in DirectX. These range from
DirectInput to D3DRM. According to the readme.txt file
that comes with ver.5.2 of the SDK, you can link directly
to dxguid.lib instead of #Defining INITGUID (doesn't work
with Borland, Micro$oft apparently forgot to make a compatable
.lib or include the .dll...). When in doubt, INITGUID.

: Yeah, sounds very much like initial errors I used to have :)

: I think INITGUID is to do with RM?? but I agree with Fragmo, it should be cleaned up if you link to ddraw.lib, all I can suggest is to make sure you have the dxsdk include directory BEFORE all other includes..this was a problem for MSVC++ 4.2 users...don't think it affects VC5, but hey, worth a try.

: Other than that...try doing a complete Rebuild??
: A related problem I had with DInput was that I had to link to dxguid.lib - but I don't think that would be your problem...if that doesn't fix it, I'll load ddex1 myself and try get it working :)

: Unless of course the legendary Fragmo or Clay have already cleared it up :)

Follow Ups:

Post a Followup

Name:


Wet behind the ears...

Posted by SstrangeE on July 14, 1998 at 01:08:03:

Well, I'm new to Direct X programming (haven't done a single thing in Direct X programming). What compiler should I use to do my DX programming?

I have Microsoft C++ v5.0 and know C/C++. I hear that Direct X can be a booger, and I'm wondering which is the compiler I need to begin my Direct X endeavor?

Any help would be... helpful!

Thanks! :)

Follow Ups:

  • Re: Wet behind the ears... 0x1CE 01:31:18 7/14/98 (3)
    • Re: Alrighty, heres another question... SstrangeE 02:18:08 7/14/98 (2)
      • Re: Alrighty, heres another question... Dave Burrows 06:04:48 7/15/98 (0)
      • Re: Alrighty, heres another question... 0x1CE 06:11:18 7/14/98 (0)

Post a Followup

Name:


Re: Wet behind the ears...

Posted by 0x1CE on July 14, 1998 at 01:31:18:

In Reply to: Wet behind the ears... posted by SstrangeE on July 14, 1998 at 01:08:03:

You should definately use MSVC++ for DirectX. Microsoft
conviently "forgot" to put some files in the DX sdk to give
MSVC++ an edge over non-Micro$oft compilers. Resisitance is
futile. Prepare to be assimilted.

: Well, I'm new to Direct X programming (haven't done a single thing in Direct X programming). What compiler should I use to do my DX programming?

: I have Microsoft C++ v5.0 and know C/C++. I hear that Direct X can be a booger, and I'm wondering which is the compiler I need to begin my Direct X endeavor?

: Any help would be... helpful!

: Thanks! :)

Follow Ups:

  • Re: Alrighty, heres another question... SstrangeE 02:18:08 7/14/98 (2)
    • Re: Alrighty, heres another question... Dave Burrows 06:04:48 7/15/98 (0)
    • Re: Alrighty, heres another question... 0x1CE 06:11:18 7/14/98 (0)

Post a Followup

Name:


Re: Alrighty, heres another question...

Posted by SstrangeE on July 14, 1998 at 02:18:08:

In Reply to: Re: Wet behind the ears... posted by 0x1CE on July 14, 1998 at 01:31:18:

Since I seem to have Step 1 figured out, I gotta another question.

Where would you guys recommend to start on my DirectX adventure? I've ordered a couple books: "Inside DirectX" and "Windows Games Programming for Dummies." Is this a recommended step? Or should I be looking elsewhere to begin?

Thanks! :)

Follow Ups:

  • Re: Alrighty, heres another question... Dave Burrows 06:04:48 7/15/98 (0)
  • Re: Alrighty, heres another question... 0x1CE 06:11:18 7/14/98 (0)

Post a Followup

Name:


Accessing second display via DirectDraw?

Posted by Nils Frielinghaus on July 14, 1998 at 03:14:57:

Hi,

I need to access a second display with a different
resolution than the first one.
The application should run on Intel and DEC Alpha machines
with WinNT4.0.

Can DirectDraw (Version 3) help me to do this?

The API looks to be capable of managing multiple displays,
but the second screen cannot be seen with dxview in my
configuration with two Millenium II graphic cards.
Does ist help to put two incompatible graphic cards into
the computer?

Thanks, Nils

Follow Ups:

  • Re: Accessing second display via DirectDraw? 0x1CE 06:16:35 7/14/98 (0)

Post a Followup

Name:


Re: Alrighty, heres another question...

Posted by 0x1CE on July 14, 1998 at 06:11:18:

In Reply to: Re: Alrighty, heres another question... posted by SstrangeE on July 14, 1998 at 02:18:08:

Well, first you need a copy of the DirectX SDK (which Micro$oft no
longer has at their site, you'll have to order it from them on CD for
around $12 or find it elsewhere...). I strongly recommend you learn
Windows programming before you start programming for DirectX, it will
make you life much easier. As for info on DX, wherever you can get it
is good. This site has some ok tutorials. And those books you ordered
are probably decent. A good place not to learn DirectX programming
from is the samples that come with the DX SDK. I'm pretty sure that
whoever wrote them was drunk and/or mentally unstable. For a company who
want everybody programming with their SDK, Microsoft sure doesn't seem to
be trying very hard.

: Since I seem to have Step 1 figured out, I gotta another question.

: Where would you guys recommend to start on my DirectX adventure? I've ordered a couple books: "Inside DirectX" and "Windows Games Programming for Dummies." Is this a recommended step? Or should I be looking elsewhere to begin?

: Thanks! :)

Follow Ups:

Post a Followup

Name:


Re: Accessing second display via DirectDraw?

Posted by 0x1CE on July 14, 1998 at 06:16:35:

In Reply to: Accessing second display via DirectDraw? posted by Nils Frielinghaus on July 14, 1998 at 03:14:57:

As far as I know, version 5 was the first to implement
muli-monitor support, and only on the Memphis OS.

: Hi,

: I need to access a second display with a different
: resolution than the first one.
: The application should run on Intel and DEC Alpha machines
: with WinNT4.0.

: Can DirectDraw (Version 3) help me to do this?

: The API looks to be capable of managing multiple displays,
: but the second screen cannot be seen with dxview in my
: configuration with two Millenium II graphic cards.
: Does ist help to put two incompatible graphic cards into
: the computer?

: Thanks, Nils

Follow Ups:

Post a Followup

Name:


Multiplayer games

Posted by Johnny Rotten on July 14, 1998 at 10:28:19:

I now have my game engine mostly done, but I want to start incorporating DirectPlay into it to make it multiplayer. The problem is, I don't know where to begin. I know that I want the server to send/receive all messages to/from the clients, so I have to make some special routines just for the server, right? Is there a website somewhere that explains some of the steps that have to be done... I really don't need code for DirectPlay because I have the manual for it and some sample code. I just need to know how to design my game with DirectPlay in mind. Any help would be greatly appreciated.

Spank-you very much.

Johnny Rotten

Follow Ups:

  • Re: Multiplayer games Ravi Joshi 08:38:40 7/15/98 (0)

Post a Followup

Name:


Re: RayPick

Posted by Michael Crowns on July 14, 1998 at 10:33:30:

In Reply to: Re: RayPick posted by MAgDI on July 11, 1998 at 22:25:11:

: If what you want is to pick an object (mesh) from a viewport.
: I am afraid that you are using a very bad technike

: Were did you read this??? Please let me know.

: I am using a very good book."cutting edge 3d programing" by Stan Trojillo

: my ges the problem is in here
: ray.dvDir.x = 0.0f;
: ray.dvDir.y = 0.0f;
: ray.dvDir.z = 1.0f;

: ray.dvPos.x = d3dvalue (0);
: ray.dvPos.y = d3dvalue (0);
: ray.dvPos.z = d3dvalue (1);

What I am trying to do is to determine which pixel of the texture has been clicked on. Just determining the face or the mesh does not suffice. The RayPick command is found in the documentation in the DirectX 5 or 6 sdk. If you have an atlernative approach that will accomplish the task, I would be grateful to hear it.

Follow Ups:

Post a Followup

Name:


Problem with Exclusive and Windowed

Posted by Sorrow The Prince on July 14, 1998 at 18:40:33:

I have serious problem switching from Exclusive Fullscreen mode and Windowed mode...
In fact in Fullscreen mode remains the menu ans the app bar : i cannot understand why...
And sometimes the menu and the app bar don't appear in Full and also in Windowed...
None have an example about this ?
Thanks

Follow Ups:

  • Re: Problem with Exclusive and Windowed Shai'tan 18:53:02 7/14/98 (2)
    • Re: Problem with Exclusive and Windowed Clay 12:06:36 7/16/98 (0)
    • Re: Problem with Exclusive and Windowed michael 01:38:15 7/16/98 (0)

Post a Followup

Name:


Re: Problem with Exclusive and Windowed

Posted by Shai'tan on July 14, 1998 at 18:53:02:

In Reply to: Problem with Exclusive and Windowed posted by Sorrow The Prince on July 14, 1998 at 18:40:33:

Yep, the 'hanging on' of the menu bar is really
quite a simple problem...you may notice that the
menu bar is no longer active, it is simply the
graphic remaining. This can be fixed by simply
clearing the primary surface ( if you are running
one surface ) or clearing the back buffer and then
Primary->Flip(..).. which clears both the Back and
Primary in one go. That should fix one problem.

However, I have no idea why the menu bar does
not appear in Windowed mode...

Shai'tan-[Nth]

Follow Ups:

  • Re: Problem with Exclusive and Windowed Clay 12:06:36 7/16/98 (0)
  • Re: Problem with Exclusive and Windowed michael 01:38:15 7/16/98 (0)

Post a Followup

Name:


Capture the images Using External Camera with DirectX

Posted by Yogesh M Deshpande on July 15, 1998 at 02:44:17:

hello,

I am DirectX programmer. I want to capture the images using
external camera. I used the VideoPort technology of DirectX
to capture the images but i didn't get the success.

I searched all the maximum websites including microsoft, but i can't
find any answer.

Can you guide me? can you send me any sample code or the Iternet
Site name or help file in which it is explained in details.

Expecting your answer and waiting for your reply.

Thank you very much.

Yogesh Deshpande
PUNE, INDIA

Follow Ups:

Post a Followup

Name:


Re: Using HAL with Monster3D

Posted by Dave Burrows on July 15, 1998 at 05:52:01:

In Reply to: Re: Using HAL with Monster3D posted by Zak on July 13, 1998 at 14:45:22:

: For the Primary Display Driver, I have the GUID of
: the RAMP and of the RGB.
: For the Monster3D display driver I have the GUID
: of the RAMP, the RGB, and of the HAL.

: So, in my probably failing logic, I must:
: 1) create my DirectDrawCreate with the monster3D
: display Driver's GUID
: 2) Create Device from surface with the HAL's GUID.

The Question then becomes how are you getting the Monster3D GUID.
The only way to do this is by using the "DirectDrawEnumerate" function.

Although you could search through the registry, using "regedit" and type it in
by hand. It should be under "HKEY_LOCAL_MACHINE\Enum\PCI" somewhere.

Follow Ups:

Post a Followup

Name:


Re: Alrighty, heres another question...

Posted by Dave Burrows on July 15, 1998 at 06:04:48:

In Reply to: Re: Alrighty, heres another question... posted by SstrangeE on July 14, 1998 at 02:18:08:

I have a copy of Inside DirectX. It's great for beginners and comes with a copy of DX5.2 plus all the code samples by chapter from within the book.

Then again, it does presume you know some window's programming. If you don't then all you'll need are the very basics.

Follow Ups:

Post a Followup

Name:


Re: Multiplayer games

Posted by Ravi Joshi on July 15, 1998 at 08:38:40:

In Reply to: Multiplayer games posted by Johnny Rotten on July 14, 1998 at 10:28:19:

You can incorporate the direct play features in the behavior part of
the world objects.
With regards..
Ravi Joshi.

Follow Ups:

Post a Followup

Name:


Distance between two points?

Posted by LT on July 15, 1998 at 10:07:15:

Could some one please tell me how to calculate the distance between two points in 3d space? For example, what is the distance from (27, 59, 14 ) to (81, 900, 16)?

Thanks!

Follow Ups:

  • smart optimisation, beat it if you can Gunnar 23:06:45 7/16/98 (5)
    • this is a good one... Clay 08:43:45 7/17/98 (4)
      • If that code doesn't look right... Clay 08:49:20 7/17/98 (3)
        • Re: Small optimisation, more accuracy Gunnar 11:23:57 7/17/98 (2)
          • Re: Small optimisation, more accuracy Clay 13:13:04 7/17/98 (1)
            • Re: Pipelines, floats Gunnar 19:24:33 7/17/98 (0)
  • Re: Distance between two points? Dave Burrows 11:17:17 7/15/98 (1)
    • Thanks for the help! LT 17:10:51 7/15/98 (0)
  • Re: Distance between two points? Clay 11:16:26 7/15/98 (3)
    • Re: Distance between two points? Clay 11:26:11 7/15/98 (2)
      • Re: Distance between two points? Dave Burrows 12:27:25 7/15/98 (1)
        • Re: Distance between two points? Clay 09:47:42 7/16/98 (0)

Post a Followup

Name:


Re: Distance between two points?

Posted by Clay on July 15, 1998 at 11:16:26:

In Reply to: Distance between two points? posted by LT on July 15, 1998 at 10:07:15:

P1 (x1,y1,z1)
P2 (x2,y2,z2)

Distance=Sqrt(
(x1^2 + x2^2) +
(y1^2 + y2^2) +
(z1^2 + z2^2)
)

That is very accurate, there are ways to speed up the math but they reduce accuracy.

Clay

: Could some one please tell me how to calculate the distance between two points in 3d space? For example, what is the distance from (27, 59, 14 ) to (81, 900, 16)?

: Thanks!

Follow Ups:

  • Re: Distance between two points? Clay 11:26:11 7/15/98 (2)
    • Re: Distance between two points? Dave Burrows 12:27:25 7/15/98 (1)
      • Re: Distance between two points? Clay 09:47:42 7/16/98 (0)

Post a Followup

Name:


Re: Distance between two points?

Posted by Dave Burrows on July 15, 1998 at 11:17:17:

In Reply to: Distance between two points? posted by LT on July 15, 1998 at 10:07:15:

: Could some one please tell me how to calculate the distance between two points in 3d space? For example, what is the distance from (27, 59, 14 ) to (81, 900, 16)?

: Thanks!

(X1,Y1,Z1) & (X2,Y2,Z2)

Distance = magnitude of vector from Point1 to Point2

Which is just a posh way of saying:-

Distance = sqrt ( ((X2-X1)*(X2-X1)) +
((Y2-Y1)*(Y2-Y1)) +
((Z2-Z1)*(Z2-Z1)) )

Follow Ups:

  • Thanks for the help! LT 17:10:51 7/15/98 (0)

Post a Followup

Name:


Re: Distance between two points?

Posted by Clay on July 15, 1998 at 11:26:11:

In Reply to: Re: Distance between two points? posted by Clay on July 15, 1998 at 11:16:26:

Oops!!!! my fault, Dave has it right. (There are still ways to optimize it, though!)

Clay

Follow Ups:

  • Re: Distance between two points? Dave Burrows 12:27:25 7/15/98 (1)
    • Re: Distance between two points? Clay 09:47:42 7/16/98 (0)

Post a Followup

Name:


Re: Distance between two points?

Posted by Dave Burrows on July 15, 1998 at 12:27:25:

In Reply to: Re: Distance between two points? posted by Clay on July 15, 1998 at 11:26:11:

: Oops!!!! my fault, Dave has it right. (There are still ways to optimize it, though!)

The only optimization you could do is not do the sqrt.

Most of the time you do not want the actual value you just want to know if it is above or below a value.
If this is the case, it is the same thing to say is the square of the value above or below the square of another.
This therefore gives the same yes/no answer with out the sqrt.

If you really want to go hell-for-leather then you can separate it out even more and say is the X portion of the equation greater than the test value.

Follow Ups:

  • Re: Distance between two points? Clay 09:47:42 7/16/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 Control Panel that will not die!

Posted by MOGA ALEXANDRU on July 15, 1998 at 13:40:29:

In Reply to: DirectX 5.0 Control Panel that will not die! posted by Dave on June 28, 1998 at 04:00:42:

: Hello all,
: A few months back, I downloaded and installed the
: DirectX 5.0 Control Panel from Microsoft's page.
: Now I want to uninstall it. To my dismay, doing so
: gave me an illegl operation error saying "ISUNINST
: caused a stack fault in module ISUNINST.EXE at
: 016f:0040fbfd....etc..etc."

: I did use Norton RegEdit to first save my registry.
: Then I manually took out all keys relating to the DX
: Control Panel. Unfortunately, the DX Control Panel
: is still fully functional and is still accessible in
: the Win95 Control Panel. I've tried to find the files
: that run this thing but can't find them either.

: Also, the Control
: Panel Program doesn't seem to be Microsoft's page
: anymore. Anyone know if its still available? I was
: thinking of re-installing and then uninstall again.

: Anyone have an idea of what's wrong?
: Thanks ALL for any help!

Follow Ups:

Post a Followup

Name:


Re: I need DirectX5

Posted by MOGA on July 15, 1998 at 13:45:39:

In Reply to: I need DirectX5 posted by Denton Duncan on June 28, 1998 at 12:41:27:

: I downloaded a demo but I need directX5. Can I download it for free?. Where can I get it?

Follow Ups:

Post a Followup

Name:


Thanks for the help!

Posted by LT on July 15, 1998 at 17:10:51:

In Reply to: Re: Distance between two points? posted by Dave Burrows on July 15, 1998 at 11:17:17:

I appreciate it!

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Alan Cohen on July 15, 1998 at 17:16:52:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Shawn Salerno on June 12, 1998 at 16:28:32:

: :
: : : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by alan cohen on July 15, 1998 at 17:28:32:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

  • Re: Where Can I download DirectX 5.0 shawn lee harvey 17:45:05 7/20/98 (0)
  • Re: Where Can I download DirectX 5.0 Alexander 00:19:43 7/18/98 (0)

Post a Followup

Name:


SIMPLE simple directx

Posted by Goodlife on July 15, 1998 at 21:28:12:

Hi all...
I just started using directx TODAY, and I'm very
frustrated because I can't make one simple thing happen.
Does anyone have a nice, fallthough, simple code fragment
in C, (not C++) that will do the following?

1) Start directx
2) Put it into 320x240x16 mode
3) Get a pointer to that memory
4) memset all of that memory with 255 (presumably turning
the screen white)

If you have a little code snippet, or a simple program,
please post it here or e-mail me at jraptis@flash.net.
I'm getting desperate. My surfaces don't display. I
have no idea how to get that pointer in C (I seem to know
how to in C++)... I'm a wreck.

Thanks.

--John
increasingly desperate programmer

Follow Ups:

Post a Followup

Name:


Re: Please help...Newbie question about DDraw SDK samples

Posted by Carlos on July 15, 1998 at 23:55:50:

In Reply to: Re: Please help...Newbie question about DDraw SDK samples posted by GettinThere on July 13, 1998 at 17:46:00:

I am new to this too. I had the same problem and decide to use "nmake" from a DOS
window. The executable was correctly created.
Maybe this will provide a hint to some of the "brains" in this forum.

Follow Ups:

Post a Followup

Name:


Re: Please help...Newbie question about DDraw SDK samples

Posted by Carlos2 on July 16, 1998 at 00:11:11:

In Reply to: Re: Please help...Newbie question about DDraw SDK samples posted by newbie on July 11, 1998 at 19:50:05:

I played with it some more and got rid of the error.
Make sure you add "Winmm.lib" as well as "Ddraw.lib"
on your Link Tab under SETTINGS.

Follow Ups:

Post a Followup

Name:


Re: Problem with Exclusive and Windowed

Posted by michael on July 16, 1998 at 01:38:15:

In Reply to: Re: Problem with Exclusive and Windowed posted by Shai'tan on July 14, 1998 at 18:53:02:

When the user Alt-Tabs in my games, I just kill DX
and restart it in the new mode. Usually this only
takes 1 or 2 tenths of a second, so it's no big deal.

-Michael

: Yep, the 'hanging on' of the menu bar is really
: quite a simple problem...you may notice that the
: menu bar is no longer active, it is simply the
: graphic remaining. This can be fixed by simply
: clearing the primary surface ( if you are running
: one surface ) or clearing the back buffer and then
: Primary->Flip(..).. which clears both the Back and
: Primary in one go. That should fix one problem.

: However, I have no idea why the menu bar does
: not appear in Windowed mode...

: Shai'tan-[Nth]

Follow Ups:

Post a Followup

Name:


Re: Sprites clipping on edge of screen!

Posted by michael on July 16, 1998 at 01:41:31:

In Reply to: Sprites clipping on edge of screen! posted by Pet Monster on July 06, 1998 at 13:52:16:

An easy way is to change your srcRect based on where
you are blitting it to. In other words, if the sprite
will go 10 pixels off the top of the screen, just take
10 pixels off the top of your srcRect.

: Can anyone tell me how to prevent sprites from clipping
: if they are even partially off the screen. I try to
: put a 40x40 sprite at coords (0, 620) on a 640x480
: fullscreen mode screen. It never displays the sprite
: if it is at all off the screen! Can anyone help me or
: direct me in the right direction???

Follow Ups:

Post a Followup

Name:


Where I Can get a Tracker Player for Direct X 5.0 ?

Posted by Mr_Pooyan on July 16, 1998 at 03:34:29:

I would like to get a source code of a tracker player in Direct X 5.0.
I prefer that player plays S3M, XM or IT !!!
Or MODS !!!
Thanks !

Follow Ups:

Post a Followup

Name:


Where I can get the Direct Music or Direct X 6.0 ?

Posted by Mr_Pooyan on July 16, 1998 at 03:35:26:

The Subject Details my request !!!
Thanks!

Follow Ups:

  • Re: Where I can get the Direct Music or Direct X 6.0 ? Charles Stevens 18:53:48 7/16/98 (0)

Post a Followup

Name:


Re: Distance between two points?

Posted by Clay on July 16, 1998 at 09:47:42:

In Reply to: Re: Distance between two points? posted by Dave Burrows on July 15, 1998 at 12:27:25:

: The only optimization you could do is not do the sqrt.

Not true! The sqrt() can be approximated quickly. There are several algorithms for doing this -- see "Graphics Gems" edited by Andrew S. Glassner.

Also, fixed point math can work wonders for real numbers, particularly if you want your code to run quickly on CPUs with weak FPUs. I get a performance increase of about 4x on a Cyrix pentium clone when I use fixed point math.

Clay

Follow Ups:

Post a Followup

Name:


BITMASK CHANGED VALUE

Posted by Carlo Lentini on July 16, 1998 at 11:14:03:

IS IT POSSIBLE TO MODIFY THE FIELDS RBITMASK,GBITMASK,BBITMASK OF THE PIXELFORMAT STUCTURE?
IF YES, HOW CAN I DO?

EX. ORIGINAL VALUE: 0x00007c00 (RBITMASK)
NEW VALUE: 0x0000F800 (RBITMASK)

DDSURFACEDESC ddsd;

ddsd.dwSize = sizeof (ddsd);
ddrval = m_lpDDMain->GetDisplayMode (& ddsd);

ddsd.dwFlags = DDSD_CAPS | DDSD_PIXELFORMAT;
ddsd.ddsCaps.dwCaps = DDSCAPS_PRIMARYSURFACE;
// DDSCAPS_VIDEOMEMORY;

ddsd.ddpfPixelFormat.dwRGBBitMask=0x0000f800;
ddsd.ddpfPixelFormat.dwRGBBitMask=0x000007e0;
ddsd.ddpfPixelFormat.dwRGBBitMask=0x0000001f;

ddrval = m_lpDDMain->CreateSurface (& ddsd, &m_lpDDPrimary, NULL);

if (ddrval != DD_OK) {
m_lpDDPrimary = NULL;
error (ddrval, "Enable.CreateSurface");
}

THIS FUNCTION RETURN "INVALID PARAMETERS" IF I SET THE FIELD RBITMASK to 0x0000F800

Follow Ups:

  • Re: BITMASK CHANGED VALUE Fragmo 16:58:38 7/16/98 (0)

Post a Followup

Name:


Re: Problem with Exclusive and Windowed

Posted by Clay on July 16, 1998 at 12:06:36:

In Reply to: Re: Problem with Exclusive and Windowed posted by Shai'tan on July 14, 1998 at 18:53:02:

You can use InvalidateRect() to force a redraw of your window. I think there's also a DrawMenu API call to redraw the menu. Either one should get the desired result.

Clay

Follow Ups:

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by steve on July 16, 1998 at 14:12:08:

In Reply to: where can I download direct X 5.0 posted by Yves Lavoie on February 06, 1998 at 23:01:14:

: where I can get direct X 5.0 please a answer

Follow Ups:

  • Re: where can I download direct X 5.0 gui 17:30:25 7/18/98 (1)
    • Re: where can I download direct X 5.0 Gui 3954882 17:32:56 7/18/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Stalker on July 16, 1998 at 14:17:54:

In Reply to: Re: Where Can I download DirectX 5.0 posted by lars on February 25, 1998 at 04:19:20:

: : : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


Re: BITMASK CHANGED VALUE

Posted by Fragmo on July 16, 1998 at 16:58:38:

In Reply to: BITMASK CHANGED VALUE posted by Carlo Lentini on July 16, 1998 at 11:14:03:

i don't know if its necessary for the create surface call,
but you could try filling in the dwSize field of the pixel format

Fragmo
http://www.public.iastate.edu/~jtilton/gamepage.html

: IS IT POSSIBLE TO MODIFY THE FIELDS RBITMASK,GBITMASK,BBITMASK OF THE PIXELFORMAT STUCTURE?
: IF YES, HOW CAN I DO?

: EX. ORIGINAL VALUE: 0x00007c00 (RBITMASK)
: NEW VALUE: 0x0000F800 (RBITMASK)

:
: DDSURFACEDESC ddsd;
:
: ddsd.dwSize = sizeof (ddsd);
: ddrval = m_lpDDMain->GetDisplayMode (& ddsd);

: ddsd.dwFlags = DDSD_CAPS | DDSD_PIXELFORMAT;
: ddsd.ddsCaps.dwCaps = DDSCAPS_PRIMARYSURFACE;
: // DDSCAPS_VIDEOMEMORY;

: ddsd.ddpfPixelFormat.dwRGBBitMask=0x0000f800;
: ddsd.ddpfPixelFormat.dwRGBBitMask=0x000007e0;
: ddsd.ddpfPixelFormat.dwRGBBitMask=0x0000001f;

: ddrval = m_lpDDMain->CreateSurface (& ddsd, &m_lpDDPrimary, NULL);

: if (ddrval != DD_OK) {
: m_lpDDPrimary = NULL;
: error (ddrval, "Enable.CreateSurface");
: }

: THIS FUNCTION RETURN "INVALID PARAMETERS" IF I SET THE FIELD RBITMASK to 0x0000F800

Follow Ups:

Post a Followup

Name:


DirectX 6

Posted by Kevin Cline on July 16, 1998 at 17:04:50:

Does anyone know if Microsoft has announced a release date for DirectX 6 yet?

Thanks,
Kevin Cline

Follow Ups:

Post a Followup

Name:


Re: Where I can get the Direct Music or Direct X 6.0 ?

Posted by Charles Stevens on July 16, 1998 at 18:53:48:

In Reply to: Where I can get the Direct Music or Direct X 6.0 ? posted by Mr_Pooyan on July 16, 1998 at 03:35:26:

: The Subject Details my request !!!
: Thanks!

Follow Ups:

Post a Followup

Name:


Re: Linker Error with Direct Input

Posted by Gunnar on July 16, 1998 at 19:29:21:

In Reply to: Linker Error with Direct Input posted by Chris Goetschius on July 06, 1998 at 13:22:20:

: ddapp.obj : error LNK2001: unresolved external symbol _GUID_SysMouse
: i have all the headers in included, and the dx5 sdk stuff is above the other include directory stuff under options. Does anyone know why i am getting this and how to fix it? Thanx

I just had the problem with the keyboard.
However, I've had so many problems that I'm
not sure what the fix was. What I dimly remember
is adding some dinput.lib to the linker.

The _sys_whatever turned out to be a macro
calling a library function, although it
first looked like a constant ro something
similar??

Wasn;t there a GUID macro infront of it also??

Hate those macros which are 3-4 levels deep..

Gunnar

Follow Ups:

Post a Followup

Name:


Fast keyboard access, directinput ??

Posted by Gunnar on July 16, 1998 at 19:41:09:

I'm working on a realtime application, which I have
done in 32bit DOS earlier.

Basically pumping some 40Mb/s data through the PC,
from PCI bus to video, and SCSI drives.

Q1: Anybody with any suggestions on how to figure out
if a key has been pressed in a couple of cycles??

(in the prot mode DOS version I had to go directly
to the BIOS buffer, could not use standard library
functions)

When I know a key has been pressed, I can wait until
I know have a little slack in buffers, and then
read the actual key pressed.

I've just gotten a directinput thing kind of working
create, etc,etc, set format, etc. based on SDK
sample DI.CPP.

However:

Q2: when I use EXCLUSIVE + FORGROUND properties, I get
and error that it is not yet implementd (?), but
it works. When use NONEXCLUSIVE I get an error
that I have lost it every time I try to get status
or data??

Q3: When running the debugger nothing seem to work,
seem like the debugger (VC++ 5.0) grabs everything??
Any suggestions??

Follow Ups:

Post a Followup

Name:


download DirectX 5.0

Posted by Roman Kaykov on July 16, 1998 at 21:14:29:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Christer Johnson on March 23, 1998 at 14:03:03:

:
: :
: : : Where Can I download DirectX 5.0. I need it for an emulator.
: And for games

Follow Ups:

  • Re: download DirectX 5.0 KEBIR 13:40:54 7/29/98 (0)

Post a Followup

Name:


Can anyone help me with playing a movie?

Posted by Stan Collymore on July 16, 1998 at 22:27:57:

Hi friends, I'm trying hard to stream a movie of some sort onto a DD surface. I've looked around the inet and in the DXSDX and I'm getting nowhere quickly. I using C++ in VC5.

Can you please point me in the direction for some help or please help? The Microsoft site doesnt seem to be of much use on this subject.

Thanks in advance!
S

Follow Ups:

  • Re: Can anyone help me with playing a movie? Snowman 20:48:11 7/27/98 (0)

Post a Followup

Name:


smart optimisation, beat it if you can

Posted by Gunnar on July 16, 1998 at 23:06:45:

In Reply to: Distance between two points? posted by LT on July 15, 1998 at 10:07:15:

One thing I have used in DSP applications is
the "saliga" algoritm ( the guy who showed me)

r = (abs(x) + abs(y)) - min/2

min = min(abs(x), abs(y))

or

r = max + min/2 (same thing)

examples

1,0 -> r = 1 + 0/2 (exact)
1,1 -> r = 1 + 1.2 = 1.5 ( exact = 1.41)

so the error is appr +/- 3% (or 0->6%)

Have not needed a 3-dimensional but it should
go by first doing

abs(all cordinates)

r0 = max(x,y) + min(x,y)/2
r = max(r0,z) + min(r0,z)/2

and the error is doubled.

"Easy" to understand if one draws a circle, and
checks this from 0-45 degree, it kind of
approximates that sector with a straigh line,
shooting a little "too far out" at 45 degree.

Note that integer sqroots take a lot of cycles,
as does integer multiply. (in moron pentiums)

The test-and-jump for min,max stalls the pipeline,
but maybe a PII precalculates both results??

Note also that a good compiler doesn;t do abs
with a test-and-jump-and-stall, but:

temp = rshift32(x) (sign, 0000000 or FFFFFFFF)
abs(x) = (x xor temp) - temp

(same as taking sign , testing it
and inverting x and subtracting 1 when negative)

So the last splendid optimisation is

abs(x) = x xor rshift32(x)

and forget the 1 LSB error (if that's OK)

and when done in assembler, using only
registers as temporaries, properly
interleaved to have both pipes working at
the same time, it beats anything hands down
(if the accuracy is OK)

Any better algoritms??

Mail me at gunnar@surfnet.fi
if you have one!! ( or questions)

PS Used in critical embedded DSP applications from
Finland to USA to Japan

Follow Ups:

  • this is a good one... Clay 08:43:45 7/17/98 (4)
    • If that code doesn't look right... Clay 08:49:20 7/17/98 (3)
      • Re: Small optimisation, more accuracy Gunnar 11:23:57 7/17/98 (2)
        • Re: Small optimisation, more accuracy Clay 13:13:04 7/17/98 (1)
          • Re: Pipelines, floats Gunnar 19:24:33 7/17/98 (0)

Post a Followup

Name:


Please help RE DirectDraw

Posted by Gooze on July 16, 1998 at 23:12:27:

I would really appreciate any help anyone may have
regarding the following problem I've encountered:

I managed to set up a simple program to draw a
texture-mapped triangle using DrawPrimitive, feeding
it transformed and lit vertices (D3DTLVERTEX).
However, when I try to feed it world coordinates
(D3DLVERTEX), DrawPrimitive returns DDERR_SURFACEBUSY.
I first though I screwed up my transformation matrices,
but I tried setting them all to the identity matrix
and feeding DrawPrimitive screen-coordinate vertices.
I got the same thing.

I don't see why a change from screen to world
coordinates can cause a DDERR_SURFACEBUSY error.

Any ideas?

Thanks

Follow Ups:

Post a Followup

Name:


Where Can I download DirectX 5.0

Posted by Matthew Stiller on July 17, 1998 at 04:22:10:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Kevin on January 24, 1998 at 11:18:57:

: : : : Where Can I download DirectX 5.0. I need it for a game.

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Simon Partington 20:58:10 9/01/98 (0)

Post a Followup

Name:


Why is FlipToGDISurface() is used?

Posted by Ravi Joshi on July 17, 1998 at 06:42:12:

Hi to all, and thanks for answering my questions earlier.

I have a query to make. Hope you answer that too.

1) Why is FlipToGDISurface() used?
2) Do all the other applications running along with any of your directX app use the same memory
to display to the screen?

DirectX docs has some info on this issue. The docs says
"This method can be called at the end of a page-flipping application to ensure that the display memory that GDI is writing to is visible to the use"
Now what does that mean?
I want to know why will the GDI which is running parellel to the DirectX, try to draw to the primary surface when actually your DirectX application
has the focus. Moreover, is the primary surface to which you are writing shared by all the other applications?

I would be greatful if you could elaborate on this issue.
Any help would be appriciated.

Thanks in advance..
Ravi Joshi.

Follow Ups:

  • Re: Why is FlipToGDISurface() is used? Clay 08:06:53 7/17/98 (6)
    • The primary surface pointer doesn't change. Ravi Joshi 11:13:36 7/17/98 (5)
      • Re: The primary surface pointer doesn't change. Dave Burrows 05:37:48 7/20/98 (2)
        • Re: The primary surface pointer doesn't change. Clay 11:20:30 7/21/98 (1)
          • The Pointers never change Ravi Joshi 02:10:08 7/23/98 (0)
      • Re: The primary surface pointer doesn't change. Clay 13:06:46 7/17/98 (0)
      • Re: The primary surface pointer doesn't change. Ravi Joshi 11:18:41 7/17/98 (0)

Post a Followup

Name:


Re: Why is FlipToGDISurface() is used?

Posted by Clay on July 17, 1998 at 08:06:53:

In Reply to: Why is FlipToGDISurface() is used? posted by Ravi Joshi on July 17, 1998 at 06:42:12:

When you call Flip(), here's how you can think about what happens: Your video card has two areas in memory that are dedicated to your application. These areas are the surfaces to which you do your rendering. When you call Flip(), the video card changes which surface it is using to send to the monitor. Think of it as a re-assigning a pointer.

The GDI has its own area of video memory that it renders to. The actual address of the GDI surface memory and the primary surface memory that is returned by CreateSurface() (were you to get both pointers) are equal. When you call Flip(), the old primary surface becomes the back buffer and vice-versa. If, when you release exclusive mode, the last Flip() call set the original primary surface to be on-screen, there is no problem. However, if the last Flip() call set the back buffer to be on-screen, the GDI output will still go to the original primary surface, which is off-screen. FlipToGDISurface() ensures that the proper video memory is being displayed on-screen when the GDI is rendering.

Clay

Follow Ups:

  • The primary surface pointer doesn't change. Ravi Joshi 11:13:36 7/17/98 (5)
    • Re: The primary surface pointer doesn't change. Dave Burrows 05:37:48 7/20/98 (2)
      • Re: The primary surface pointer doesn't change. Clay 11:20:30 7/21/98 (1)
        • The Pointers never change Ravi Joshi 02:10:08 7/23/98 (0)
    • Re: The primary surface pointer doesn't change. Clay 13:06:46 7/17/98 (0)
    • Re: The primary surface pointer doesn't change. Ravi Joshi 11:18:41 7/17/98 (0)

Post a Followup

Name:


this is a good one...

Posted by Clay on July 17, 1998 at 08:43:45:

In Reply to: smart optimisation, beat it if you can posted by Gunnar on July 16, 1998 at 23:06:45:

I can't take credit for this, the fast square-root algorithm belongs to Paul Lalonde and Robert Dawson. It is extremely fast: it has no floating point operations, and no integer multiplication/division. However, it is not very accurate. If you want to make it more accurate, you can make the table bigger. For n bits of precision, 2^(n+1) bytes of memory must be used. Note that this can be re-written to use fixed point math. This will get rid of the nasty floating point subtracts and multiplys.

Clay

// do this early in the app -- at init.
BuildRootTable();

Dist = FastSqrt( ((x1-x2) * (x1-x2)) +
((y1-y2) * (y1-y2)) +
((z1-z2) * (z1-z2))
);

static short sqrttab[256];

void BuildRootTable()
{
USHORT i;
float f;
UINT* fi = (UINT*)&f;

for(i=0;i> 16;

//do it again, but with an exponent of 1, stored as 128

*fi=0;
*fi = (i> 16;
}
}

float FastSqrt(float n)
{
UINT * num = (UINT*)&n;
short e; // the exponent

if(e==0) // check for sqrt(0)
{
return(0);
}

e = (*num >> 23) - 127; // get the exponent

if(e & 0x1) // odd exponent, look it up in second half of table
{
*num |= 0x800000;
}

e >>= 1; // div by 2

// do the table lookup and and reconstruct back into a float

*num = ((sqrttab[*num>>16]) >> 16 | ((e + 127) >> 23);

return(n);
}

Follow Ups:

  • If that code doesn't look right... Clay 08:49:20 7/17/98 (3)
    • Re: Small optimisation, more accuracy Gunnar 11:23:57 7/17/98 (2)
      • Re: Small optimisation, more accuracy Clay 13:13:04 7/17/98 (1)
        • Re: Pipelines, floats Gunnar 19:24:33 7/17/98 (0)

Post a Followup

Name:


If that code doesn't look right...

Posted by Clay on July 17, 1998 at 08:49:20:

In Reply to: this is a good one... posted by Clay on July 17, 1998 at 08:43:45:

If the code doesn't look right, I put it in again here. It looked okay when I typed it, but when I read the message it was wrong. If anyone is interested and it is still messed up, I'll email it to you.

Clay

static short sqrttab[256];

void BuildRootTable()
{
USHORT i;
float f;
UINT* fi = (UINT*)&f;

for(i=0;i> 16;

//do it again, but with an exponent of 1, stored as 128

*fi=0;
*fi = (i> 16;
}
}

float FastSqrt(float n)
{
UINT * num = (UINT*)&n;
short e; // the exponent

if(e==0) // check for sqrt(0)
{
return(0);
}

e = (*num >> 23) - 127; // get the exponent

if(e & 0x1) // odd exponent, look it up in second half of table
{
*num |= 0x800000;
}

e >>= 1; // div by 2

// do the table lookup and and reconstruct back into a float

*num = ((sqrttab[*num>>16]) >> 16 | ((e + 127) >> 23);

return(n);
}

Follow Ups:

  • Re: Small optimisation, more accuracy Gunnar 11:23:57 7/17/98 (2)
    • Re: Small optimisation, more accuracy Clay 13:13:04 7/17/98 (1)
      • Re: Pipelines, floats Gunnar 19:24:33 7/17/98 (0)

Post a Followup

Name:


D3D Texture GetDC() troubles

Posted by Steve Dykes on July 17, 1998 at 10:49:08:

I'm having a bit of a problem with a Direct3D (dx5) program I'm working
on, which I'm hoping some of you DX gurus can help with.

Program works like a charm when run using either the HAL, or software
RGB emulation. However, when I try to use the Ramp driver or the MMX
driver, I can no longer get device contexts for my texture surfaces
(when loading the textures, I use GetDC so I can BitBlt the loaded
bitmap onto the surface).

I create the texture surfaces for all software drivers in exactly the same way
(system memory), which is why I'm a bit perplexed as to why it works for
RGB, and not for Ramp or MMX (which is an RGB driver).

I'm pretty new to Win95/DX; does this problem ring any bells for
anybody? Any general things I should be watching out for? I've looked
at many d3d programs (examples in documentation, etc.), and nothing
jumps out at me as something I'm doing wrong (or omitting).

Any help is greatly appreciated!

--Steve Dykes

business: sdykes@s3i.com
home: sdykes@erols.com

Follow Ups:

  • Re: D3D Texture GetDC() troubles jason 23:34:55 9/04/98 (0)

Post a Followup

Name:


The primary surface pointer doesn't change.

Posted by Ravi Joshi on July 17, 1998 at 11:13:36:

In Reply to: Re: Why is FlipToGDISurface() is used? posted by Clay on July 17, 1998 at 08:06:53:

Thanks clay for your answer.
Here is my still persistant doubt.
Please have a look at my code.

void LearnFromFlip()
{
fout.open("flip.cpp", ios::app);
HRESULT ddrval;
DDSURFACEDESC DDSurfaceDesc;
DDSurfaceDesc.dwSize = sizeof( DDSURFACEDESC);
ddrval = lpDDSPrimary->Lock(NULL,&DDSurfaceDesc, DDLOCK_READONLY, NULL);
TraceErrorDD(ddrval);

// now i will redirect the pointer value to a file.
foutUnlock(NULL);
TraceErrorDD(ddrval);
ddrval = lpDDSPrimary->Flip(NULL,0);
TraceErrorDD(ddrval);
fout.close();
}

The above function gets called continously.
Here I am trying to find the address of the VRam to which the lpSurface pointer of ddsd structure
is pointing to. After Flip() the lpSurface should change, Shouldn't it?
It should change because, it is now pointing to the new front buffer that is
the previous back buffer. But in my case I found that it never changes. Why might it be so? Could you please
bother to answer my question?

Thanks clay.
The information you have provided is invaluable to me.
Could you please direct me to some source where I can pick such info which might
be missing from DirectX docs?

Thanks again to clay and everyone.
With Regards..

Ravi Joshi
India.
e-mail: joshiobjects@hotmail.com

Follow Ups:

  • Re: The primary surface pointer doesn't change. Dave Burrows 05:37:48 7/20/98 (2)
    • Re: The primary surface pointer doesn't change. Clay 11:20:30 7/21/98 (1)
      • The Pointers never change Ravi Joshi 02:10:08 7/23/98 (0)
  • Re: The primary surface pointer doesn't change. Clay 13:06:46 7/17/98 (0)
  • Re: The primary surface pointer doesn't change. Ravi Joshi 11:18:41 7/17/98 (0)

Post a Followup

Name:


Re: The primary surface pointer doesn't change.

Posted by Ravi Joshi on July 17, 1998 at 11:18:41:

In Reply to: The primary surface pointer doesn't change. posted by Ravi Joshi on July 17, 1998 at 11:13:36:

There seems to be some mixup in the code.
the code actually looks like this.

void LearnFromFlip()
{
fout.open("flip.cpp", ios::app);

HRESULT ddrval;
DDSURFACEDESC DDSurfaceDesc;
DDSurfaceDesc.dwSize = sizeof( DDSURFACEDESC);

ddrval = lpDDSPrimary->Lock(NULL,&DDSurfaceDesc, DDLOCK_READONLY, NULL);
TraceErrorDD(ddrval);
// now i will redirect the pointer value to a file.
foutUnlock(NULL);
TraceErrorDD(ddrval);

ddrval = lpDDSPrimary->Flip(NULL,0);
TraceErrorDD(ddrval);

fout.close();
}

Follow Ups:

Post a Followup

Name:


Re: Small optimisation, more accuracy

Posted by Gunnar on July 17, 1998 at 11:23:57:

In Reply to: If that code doesn't look right... posted by Clay on July 17, 1998 at 08:49:20:

Thanks, Clay

As I have spent half of my life
saving 2-3 cycles here and there
my "optimize" flag went on here:
(once worked 1 month to save 6 cycles in one
product, to get in a feature)

: if(e & 0x1) // odd exponent, look it up in second half of table
: {
: *num |= 0x800000;
: }

Depending on jump-stalls, shifts this might
be faster

*num |= ( (e & 0x1)> scale)

I ould guess that this increases the accuracy
of your 256 table to maybe 12-13 bits??
(done it for sin-cos tables for many years)

PS what makes the pentium "weird" is that
floating point operations, properly
interleaved, pipelined, without any checks for
overflow,underflow, is faster than regular
integer operations. (mult and div)
One need to make sure ovf,uvf never happens
by pre-testing the variables.

Historically I think it was because Intel
was threathned with anti-trust if they had
implemented DSP style one cycle multiply
and add, so they started with the floating
point unit.

On the other hand it might just have been
a mistake, floating point numbers seem
to be much "better" as one can pretend to
forget about scaling,etc..

(inspired by your trick of going from
floats back to integers)

Follow Ups:

  • Re: Small optimisation, more accuracy Clay 13:13:04 7/17/98 (1)
    • Re: Pipelines, floats Gunnar 19:24:33 7/17/98 (0)

Post a Followup

Name:


Re: The primary surface pointer doesn't change.

Posted by Clay on July 17, 1998 at 13:06:46:

In Reply to: The primary surface pointer doesn't change. posted by Ravi Joshi on July 17, 1998 at 11:13:36:

Do you get "DDERR_WASSTILLDRAWING" errors here?

: ddrval = lpDDSPrimary->Flip(NULL,0);

I don't know whay the pointers don't change. Here is what you might try: do the Flip(), then check the memory pointers for both the front and back surfaces (use GetAttachedSurface() for the back surface). Try to write a few pixels to the front and a few (different!) pixels to the back surface and see which surface is actually being displayed. This is an interesting issue, I'll do some independant investigation (when I get some free time!) and let you know what I find.

Clay

Follow Ups:

Post a Followup

Name:


Re: Small optimisation, more accuracy

Posted by Clay on July 17, 1998 at 13:13:04:

In Reply to: Re: Small optimisation, more accuracy posted by Gunnar on July 17, 1998 at 11:23:57:

How do the Intel clones (Cyrix, etc.) handle pipeline optimizations for the pentium? I've always heard that Cyrix's branch PU is better.

I thought that using floating point instructions stalled the pipeline until they completed!

: PS what makes the pentium "weird" is that
: floating point operations, properly
: interleaved, pipelined, without any checks for
: overflow,underflow, is faster than regular
: integer operations. (mult and div)

That wasn't really my trick. I snagged the code from the "Graphics Gems" book. I'm with you, though. the float/int conversion is handy and speedy.
: (inspired by your trick of going from
: floats back to integers)

Clay

Follow Ups:

  • Re: Pipelines, floats Gunnar 19:24:33 7/17/98 (0)

Post a Followup

Name:


Modem-Question

Posted by Chris on July 17, 1998 at 13:13:50:

Hi there,
i've a question on direct-play (Direct X 5.0).
I'm programming an application, which communicates with other
PCs over a modem-connection.
The question is :
If i host a session (service provider is modem-connection) the
auto-answer-LED is off (S0 Register seems to be set to 0).
Will the modem answer an incoming call (from a client of the
application who wants to join) anyway ?
Thanks,
cu Chris

Follow Ups:

Post a Followup

Name:


Re: Pipelines, floats

Posted by Gunnar on July 17, 1998 at 19:24:33:

In Reply to: Re: Small optimisation, more accuracy posted by Clay on July 17, 1998 at 13:13:04:

On Cyrix,etc I have no idea, I have only heard
that Cyrix first did a fast integer (DSP-like)
one-cycle multiplier, and not the huge,
expensive floating point machine in the pentium.

I did some really detailed floating point
coding on the Pentium 3 years ago, the
idea was that you can start one
multiply (in theory) every cycle, and the
result is ready in three cycles (latency).

start 1
start 2
start 3
start 4
wait
wait
read result

or

start 1
start 2
start 3
get 1
start 4
get 2
get 3
get 4

However, loading the "stack" is a pain, as
it originally was a stack, compared to a bunch
of registers. Intel then "fixed" it in a
compatible way by introducing a 0-cycle
swap (STn,STm) instruction.

Load the stack ST0
swap ST0 to STn (invisible cycle)
something else

However, it is only 0-cycle if inbetween
two float instructions. ( trick of decoding
many instructions at the same time)

And as one also need to get the data,
one float mult per 2-3 cycles is a good
average.

The key to figure out all of this is to use the
RDTC = Read Timing Counter instruction, I guess
same as queryperformancecounters() ??

However, however, to use RDTC one need to be in
ring 0 (??) so I havn't yet really checked how
QueryP..() works, how much it takes cycles in
itself, and stalls (instruction) pipelines.

I would say the clue to everything is to
read the assembly, step through it,
and use queryperf() with a system of
storing and displaying the results when
running fullspeed.

One example, I had some strange additional
cycles compared to "theory", until I noticed
I didnt have data aligned according to
dwords, this added one cycle to data reads.

Caching is then the last problem, if data
is not in the cache, reads suddenly
goes 2-3 times slower, and if out in the
DRAM, it is 10-20 times slower.

(one then need to get into 2,4-way associative
caches, cache-lines,etc )

Gunnar

PS Since I worked on the pentium I have done
similar stuff for a RISC, so I'm not
"uptodate" on pentium, and with the RISC
I had full documentation on cache and everything.
However, Pentium is largly the same.

Follow Ups:

Post a Followup

Name:


Directsound 3D support under NT?

Posted by Ben Buckwalter on July 17, 1998 at 19:41:27:

I am a developer using NT 4.0 trying to use the 3D sound capabilities in DirectX 3. I have all the service packs installed, but there is no reference to any of the 3D stuff in the header file "dsound.h". If anyone knows why, I would really appreciate some help.

Thanks!

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Jessica Andrews on July 17, 1998 at 21:30:27:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Harold on January 18, 1998 at 20:37:49:

: : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Alexander on July 18, 1998 at 00:19:43:

In Reply to: Re: Where Can I download DirectX 5.0 posted by alan cohen on July 15, 1998 at 17:28:32:

: : Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


New Direct3D Site

Posted by Wolfgang Engel on July 18, 1998 at 03:28:33:

There's a new Direct3D Site at http://www.netit.net/direct3d/. You can find a tutorial on Direct3D 6.0 Immediate Mode, a discussion forum like this, an up to date news page and soon a listserver.

  • Netit Direct3D site

Follow Ups:

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by gui on July 18, 1998 at 17:30:25:

In Reply to: Re: where can I download direct X 5.0 posted by steve on July 16, 1998 at 14:12:08:

: : where I can get direct X 5.0 please a answer

Follow Ups:

  • Re: where can I download direct X 5.0 Gui 3954882 17:32:56 7/18/98 (0)

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by Gui 3954882 on July 18, 1998 at 17:32:56:

In Reply to: Re: where can I download direct X 5.0 posted by gui on July 18, 1998 at 17:30:25:

: : : where I can get direct X 5.0 please a answer

Follow Ups:

Post a Followup

Name:


I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!!

Posted by Jumicor on July 19, 1998 at 12:16:38:

I bought a book called Cutting Edge Direct 3d programming. I am a novice programmer, but have experience with C++ and MFC. When compiling the demos that came with the book I got two errors. Number one: my compiler (Visual c++ 4.0) says that it does not support static linking which is necessary. The book clearly said that all you needed was Windows 95, visual c++ 4.0 or higher, and directx 2.0. I later found out that you need the professional edition though it didn't say so in the book(I have the standard edition). Then I got an error message saying that ddraw.h could not be found. I searched my entire hard drive for this file, along with my visual c++ cd, the cd that came with the book but ddraw.h did not exist on any of those media.
Now I am considering buying a new compiler (Visual c++ 5.0 PRO Edition). I would like to know if the .h files needed for the demos (the directx .h files) will come with Visual c++ 5.0 and if I will be able to compile the demos.

Follow Ups:

  • Re: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!! Wolfgang Engel 18:14:49 7/19/98 (2)
    • Re: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!! Clay 18:45:26 7/19/98 (1)
      • Re: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!! Jumicor 23:13:19 7/19/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Brian Stanger on July 19, 1998 at 12:22:35:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Harold on January 18, 1998 at 20:37:49:

: : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 bmone 15:21:44 7/19/98 (1)
    • Re: Where Can I download DirectX 5.0 justin 07:21:17 7/28/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by bmone on July 19, 1998 at 15:21:44:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Brian Stanger on July 19, 1998 at 12:22:35:

: : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

  • Re: Where Can I download DirectX 5.0 justin 07:21:17 7/28/98 (0)

Post a Followup

Name:


Re: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!!

Posted by Wolfgang Engel on July 19, 1998 at 18:14:49:

In Reply to: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!! posted by Jumicor on July 19, 1998 at 12:16:38:

: I bought a book called Cutting Edge Direct 3d programming. I am a novice programmer, but have experience with C++ and MFC. When compiling the demos that came with the book I got two errors. Number one: my compiler (Visual c++ 4.0) says that it does not support static linking which is necessary. The book clearly said that all you needed was Windows 95, visual c++ 4.0 or higher, and directx 2.0. I later found out that you need the professional edition though it didn't say so in the book(I have the standard edition). Then I got an error message saying that ddraw.h could not be found. I searched my entire hard drive for this file, along with my visual c++ cd, the cd that came with the book but ddraw.h did not exist on any of those media.
: Now I am considering buying a new compiler (Visual c++ 5.0 PRO Edition). I would like to know if the .h files needed for the demos (the directx .h files) will come with Visual c++ 5.0 and if I will be able to compile the demos.
You could find the headers in the directX sdk. As far as I know, you could download it from microsoft or could get it with several books available at the stores.

Follow Ups:

  • Re: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!! Clay 18:45:26 7/19/98 (1)
    • Re: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!! Jumicor 23:13:19 7/19/98 (0)

Post a Followup

Name:


Re: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!!

Posted by Clay on July 19, 1998 at 18:45:26:

In Reply to: Re: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!! posted by Wolfgang Engel on July 19, 1998 at 18:14:49:

This sounds like a configuration problem. If you cannot link static libs, then how do you use Win32 API/stdlib calls?

If you can't find any of the DirectX header files, you need to re-install the DirectX SDK.

Clay

Follow Ups:

  • Re: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!! Jumicor 23:13:19 7/19/98 (0)

Post a Followup

Name:


Re: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!!

Posted by Jumicor on July 19, 1998 at 23:13:19:

In Reply to: Re: I just bought a book and I need some help!!!!!!!!!PLEASE HELP!!!!!!!!! posted by Clay on July 19, 1998 at 18:45:26:

: This sounds like a configuration problem. If you cannot link static libs, then how do you use Win32 API/stdlib calls?

: If you can't find any of the DirectX header files, you need to re-install the DirectX SDK.

clay

Well, like I said, my compiler does not support static linking. I found out after buying the book that I needed the PRO edition, not the standard edition of Visual c++ 4.0. The book never clarified this - that's a shame. I guess I'm going to have to buy the PRO edition of visual c++ 5.0 (there goes more of my all-too-hard earned cash). As for the Directx sdk - I thought that when I installed from the cd that all of those files would be installed, but I was mistaken.

Follow Ups:

Post a Followup

Name:


alternatives to downloading the sdk

Posted by Jumicor on July 19, 1998 at 23:16:05:

Is there any other way to get the directx sdk for free other than downloading? That sure is a lot of megabytes!!!

Follow Ups:

  • Re: alternatives to downloading the sdk 0x1CE 23:52:12 7/19/98 (0)

Post a Followup

Name:


Re: alternatives to downloading the sdk

Posted by 0x1CE on July 19, 1998 at 23:52:12:

In Reply to: alternatives to downloading the sdk posted by Jumicor on July 19, 1998 at 23:16:05:

: Is there any other way to get the directx sdk for free other than downloading? That sure is a lot of megabytes!!!

You can get it from Microsoft on CD, all you have to pay is the shipping (around $12).

Follow Ups:

Post a Followup

Name:


Re: The primary surface pointer doesn't change.

Posted by Dave Burrows on July 20, 1998 at 05:37:48:

In Reply to: The primary surface pointer doesn't change. posted by Ravi Joshi on July 17, 1998 at 11:13:36:

Why should it!

Don't forget the pointer you see is a virtual/linear one that goes through several layers of mapping to get to the physical pointer.

A minor change in the Local Descriptor Table will change the indirection of any pointer.

Follow Ups:

  • Re: The primary surface pointer doesn't change. Clay 11:20:30 7/21/98 (1)
    • The Pointers never change Ravi Joshi 02:10:08 7/23/98 (0)

Post a Followup

Name:


Fast Plot / fade in truecolor ? DirectX

Posted by Junior Mcmillan on July 20, 1998 at 06:17:35:

Anyone know of a fast way to plot and fade screens
in 16bpp 24bpp modes ??

I have an idea, but i'm not sure it is the fastest

call the Fade() function every frame.

Fade() will use timeslicing to fade pixels in an inter
leaved fashion, so as not to hogg cpu time when locking
the surface etc. the more "leaves" there are the less smooth the fade
but the faster it is... you could also apply some filtering...

Is this the *normal* fast way of fading 16/24/32bpp??

any help appreciated

Follow Ups:

  • Re: Fast Plot / fade in truecolor ? DirectX Dave Burrows 04:36:11 7/21/98 (0)
  • Re: Fast Plot / fade in truecolor ? DirectX FunkSlice 19:30:08 7/20/98 (2)
    • Re: Don;t read one pixel at a time?? Gunnar 11:46:39 7/25/98 (1)
      • Re: Don;t read one pixel at a time?? Junior McMillan 08:56:09 7/29/98 (0)

Post a Followup

Name:


IDirect3DRMViewportArray

Posted by Eric Fournier on July 20, 1998 at 11:23:05:

Can anyone tell me how to access the IDirect3DRMViewportArray
with the QueryInterface ?? I use these settings

my viewport name is view, I use the D3DRM2 and the
D3DRMdevice2.

Follow Ups:

Post a Followup

Name:


Implementing Directx(DirectDraw) into a MFC

Posted by Sphire on July 20, 1998 at 13:28:12:

I'm currently learning to implement directx into a MFC program, mostly in C++. But I'm stuck right in the beginning already, encountering several dreadful problems. Furthermore, I'm just a amatuer in Directx, but I need urgently to learn toprogram it in an MFC application. If any of you have any kind of help like samples, instructions, or of any kind, please do EMAIL ME. I will be sincerely utmost grateful to you. Thanx.

Follow Ups:

  • Re: Implementing Directx(DirectDraw) into a MFC Mr. Mike 03:16:19 9/01/98 (0)
  • I'm a newbie too - but I know the perfect resource for you Jumicor 22:21:23 7/20/98 (1)
    • Re: I'm a newbie too - but I know the perfect resource for you Sphire 00:18:01 7/21/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by shawn lee harvey on July 20, 1998 at 17:45:05:

In Reply to: Re: Where Can I download DirectX 5.0 posted by alan cohen on July 15, 1998 at 17:28:32:

: : Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


Re: I need DirectX5

Posted by shawn lee harvey on July 20, 1998 at 17:52:58:

In Reply to: Re: I need DirectX5 posted by LYNN FOWLER on July 07, 1998 at 00:13:02:

:
: : I downloaded a demo but I need directX5. Can I download it for free?. Where can I get it?

Follow Ups:

  • Re: I need DirectX5 Shawn lee Harvey 17:54:36 7/20/98 (0)

Post a Followup

Name:


Re: I need DirectX5

Posted by Shawn lee Harvey on July 20, 1998 at 17:54:36:

In Reply to: Re: I need DirectX5 posted by shawn lee harvey on July 20, 1998 at 17:52:58:

: :
: : : I downloaded a demo but I need directX5. Can I download it for free?. Where can I get it?

Follow Ups:

Post a Followup

Name:


Re: Fast Plot / fade in truecolor ? DirectX

Posted by FunkSlice on July 20, 1998 at 19:30:08:

In Reply to: Fast Plot / fade in truecolor ? DirectX posted by Junior Mcmillan on July 20, 1998 at 06:17:35:

Allright, first of all, the reason most people don't fade in anything but 256 colors, is that you don't have a
palette that you can realistically edit each entry of. What you need to do to fade the screen in 16/24/32 bpp
is to write a function that checks the RGB value of each pixel by getting a pointer to your surface and
retrieving from X, Y. Next you apply a percentage to each value so that the R, G, and B are reduced proportionatly(SP)
to each other. It's slower the heigher your resolution, but it's the only way i can think of to do it.

Follow Ups:

  • Re: Don;t read one pixel at a time?? Gunnar 11:46:39 7/25/98 (1)
    • Re: Don;t read one pixel at a time?? Junior McMillan 08:56:09 7/29/98 (0)

Post a Followup

Name:


HELP!!! I REALLY NEED SOME HELP!!! AND FAST!!

Posted by Randy on July 20, 1998 at 19:53:27:

Hey everyone!
I really need to find out how or where I can get DirectX 5.0. I need because my new laptop's games have like, over say, 300 games that need DirectX 5.0! So, It would besuch a waste if I didn't have it!
PLEASE, e-mail me some info.
Thanx =o)

Follow Ups:

  • Re: HELP!!! I REALLY NEED SOME HELP!!! AND FAST!! Dave Burrows 04:39:56 7/21/98 (0)

Post a Followup

Name:


HELP!!! I REALLY NEED SOME HELP!!! AND FAST!!

Posted by Randy on July 20, 1998 at 19:53:31:

Hey everyone!
I really need to find out how or where I can get DirectX 5.0. I need because my new laptop's games have like, over say, 300 games that need DirectX 5.0! So, It would besuch a waste if I didn't have it!
PLEASE, e-mail me some info.
Thanx =o)

Follow Ups:

  • Re: HELP!!! I REALLY NEED SOME HELP!!! AND FAST!! Jumicor 22:06:58 7/20/98 (1)
    • Re: DirectX 5.2 Doug 22:23:20 7/20/98 (0)

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by Luke Halley on July 20, 1998 at 19:55:50:

In Reply to: where can I download direct X 5.0 posted by Yves Lavoie on February 06, 1998 at 23:01:14:

: where I can get direct X 5.0 please a answer

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by gail on July 20, 1998 at 20:27:29:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

  • Re: Where Can I download DirectX 5.0 orlando rodriguez 00:27:13 7/22/98 (0)

Post a Followup

Name:


Re: HELP!!! I REALLY NEED SOME HELP!!! AND FAST!!

Posted by Jumicor on July 20, 1998 at 22:06:58:

In Reply to: HELP!!! I REALLY NEED SOME HELP!!! AND FAST!! posted by Randy on July 20, 1998 at 19:53:31:

Whoa, settle down - it's real easy to find. Do you want the end user Directx or the programmer's sdk? It sounds like you want the end user's directx. I think you can get it from www.microsoft.com

Follow Ups:

  • Re: DirectX 5.2 Doug 22:23:20 7/20/98 (0)

Post a Followup

Name:


Difference between dynamic and static linking- Save me some money please!

Posted by Jumicor on July 20, 1998 at 22:15:22:

Hello, I am a newbie so please be easy on me. This question is kind of related to a question that I posted below. I just bought a book about direct 3d. When I load the demo .mdp files that came with the book I get a message saying that the project uses static linking and that Visual c++ 4.0 standard edition does not suppport static linking. Here's the cool part: although the settings were changed to use dynamic linking every demo compiled, linked, and executed properly. Sooooo, I want to know what is the difference b/n dynamic and static linking, what effect will substituting dynamic linking for static linking have, and would it be worth it to buy the professional edition of Visual c++ to get static linking.

Follow Ups:

  • Re: Difference between dynamic and static linking- Save me some money please! 0x1CE 23:13:54 7/20/98 (2)
    • Thanks! and I'm still curious Jumicor 01:23:28 7/21/98 (1)
      • Re: Thanks! and I'm still curious 0x1CE 02:19:43 7/21/98 (0)

Post a Followup

Name:


Directx 6

Posted by Weising on July 20, 1998 at 22:17:27:

Is directx 6 out yet? Can I download them?
Email me for the Address, Thnaks a lot

Follow Ups:

  • Re: Directx 6 Shamsul A. Khan. 21:48:13 9/25/98 (0)
  • Re: Directx 6 Doug 22:31:51 7/20/98 (1)
    • Re: Directx 6 choris 13:15:09 7/21/98 (0)

Post a Followup

Name:


I'm a newbie too - but I know the perfect resource for you

Posted by Jumicor on July 20, 1998 at 22:21:23:

In Reply to: Implementing Directx(DirectDraw) into a MFC posted by Sphire on July 20, 1998 at 13:28:12:

If you want a great reference for using directx with mfc, pick up a copy of Cutting-Edge Direct 3D programming from your local bookstore

Follow Ups:

  • Re: I'm a newbie too - but I know the perfect resource for you Sphire 00:18:01 7/21/98 (0)

Post a Followup

Name:


Re: DirectX 5.2

Posted by Doug on July 20, 1998 at 22:23:20:

In Reply to: Re: HELP!!! I REALLY NEED SOME HELP!!! AND FAST!! posted by Jumicor on July 20, 1998 at 22:06:58:

You can get DirectX 5.2 from:

http://www.microsoft.com/directx/download.asp

It's going to be changing soon to DirectX 6.0

Doug

Follow Ups:

Post a Followup

Name:


Re: Directx 6

Posted by Doug on July 20, 1998 at 22:31:51:

In Reply to: Directx 6 posted by Weising on July 20, 1998 at 22:17:27:

: Is directx 6 out yet? Can I download them?
: Email me for the Address, Thnaks a lot

It's not out yet, I just checked. But keep checking at:

http://www.microsoft.com/directx

Doug

Follow Ups:

  • Re: Directx 6 choris 13:15:09 7/21/98 (0)

Post a Followup

Name:


Re: Difference between dynamic and static linking- Save me some money please!

Posted by 0x1CE on July 20, 1998 at 23:13:54:

In Reply to: Difference between dynamic and static linking- Save me some money please! posted by Jumicor on July 20, 1998 at 22:15:22:

A dynamically liked app won't run on other people's machines unless they have the .dll's that come with you compiler.

: Hello, I am a newbie so please be easy on me. This question is kind of related to a question that I posted below. I just bought a book about direct 3d. When I load the demo .mdp files that came with the book I get a message saying that the project uses static linking and that Visual c++ 4.0 standard edition does not suppport static linking. Here's the cool part: although the settings were changed to use dynamic linking every demo compiled, linked, and executed properly. Sooooo, I want to know what is the difference b/n dynamic and static linking, what effect will substituting dynamic linking for static linking have, and would it be worth it to buy the professional edition of Visual c++ to get static linking.

Follow Ups:

  • Thanks! and I'm still curious Jumicor 01:23:28 7/21/98 (1)
    • Re: Thanks! and I'm still curious 0x1CE 02:19:43 7/21/98 (0)

Post a Followup

Name:


Re: I'm a newbie too - but I know the perfect resource for you

Posted by Sphire on July 21, 1998 at 00:18:01:

In Reply to: I'm a newbie too - but I know the perfect resource for you posted by Jumicor on July 20, 1998 at 22:21:23:

Thanx. I'll go look upon this book. Do you know any sites or further resources which may have workable samples or help?

Follow Ups:

Post a Followup

Name:


Thanks! and I'm still curious

Posted by Jumicor on July 21, 1998 at 01:23:28:

In Reply to: Re: Difference between dynamic and static linking- Save me some money please! posted by 0x1CE on July 20, 1998 at 23:13:54:

: A dynamically liked app won't run on other people's machines unless they have the .dll's

Thanks!

I dont need it to run on anyone else's machine yet anyway.

I'm still curious as to what is the actual difference between the two.

Follow Ups:

  • Re: Thanks! and I'm still curious 0x1CE 02:19:43 7/21/98 (0)

Post a Followup

Name:


Re: Thanks! and I'm still curious

Posted by 0x1CE on July 21, 1998 at 02:19:43:

In Reply to: Thanks! and I'm still curious posted by Jumicor on July 21, 1998 at 01:23:28:

The only difference is that when you link something statically, it includes all those .dll's in your .exe. When you link it dynamically, it doesn't.

: : A dynamically liked app won't run on other people's machines unless they have the .dll's

: Thanks!

: I dont need it to run on anyone else's machine yet anyway.

: I'm still curious as to what is the actual difference between the two.

Follow Ups:

Post a Followup

Name:


Re: Fast Plot / fade in truecolor ? DirectX

Posted by Dave Burrows on July 21, 1998 at 04:36:11:

In Reply to: Fast Plot / fade in truecolor ? DirectX posted by Junior Mcmillan on July 20, 1998 at 06:17:35:

You could try using GetDC & MaskBlt.

Follow Ups:

Post a Followup

Name:


Re: HELP!!! I REALLY NEED SOME HELP!!! AND FAST!!

Posted by Dave Burrows on July 21, 1998 at 04:39:56:

In Reply to: HELP!!! I REALLY NEED SOME HELP!!! AND FAST!! posted by Randy on July 20, 1998 at 19:53:27:

You Can download the run time dlls from
www.microsoft.com\directx

OR

You could buy a copy of "Inside DirectX" from Microsoft Press. This comes with the SDK and run times on a disk.

Follow Ups:

Post a Followup

Name:


Helpp !!! Directx 6 with win98 Problems....

Posted by Roal Jhonson on July 21, 1998 at 10:03:54:

Hi, I installed directx 6 on win98... but i have many trouble!!

I erased all files about directx 6 ... but at control panel in Directx Panel say..

Direct3d version directx 6
Directdraw version directx 6
directinput not found
directplay not found
direct sound version directx 5

So. I cant play Mortal Kombat 4... because directx isnt installed correctly...

Do you Know some unistall for directx 6...

Please give infromation!!!

Thanks Roal Jhonson

Follow Ups:

  • Re: Helpp !!! Directx 6 with win98 Problems.... laporte 14:05:26 8/26/98 (0)
  • Re: Helpp !!! Directx 6 with win98 Problems.... ding@ 10:25:22 7/21/98 (2)
    • Re: Helpp !!! Directx 6 with win98 Problems.... Juan Luis Aguilar Alamo 19:46:16 9/04/98 (0)
    • Re: Helpp !!! Directx 6 with win98 Problems.... Roal Jhonson 10:30:50 7/21/98 (0)

Post a Followup

Name:


Re: Helpp !!! Directx 6 with win98 Problems....

Posted by ding@ on July 21, 1998 at 10:25:22:

In Reply to: Helpp !!! Directx 6 with win98 Problems.... posted by Roal Jhonson on July 21, 1998 at 10:03:54:

well, its call beta, which means its not ready for release!. the DX6's uninstall part is yet to implement. you can try your luck on reinstalling the DirectX5.2. if it doesn't help, wait 3 more weeks for the DX6 final release!.

Think this is a small lesson for you??, hah, "later the better"??, its a joke!

: Hi, I installed directx 6 on win98... but i have many trouble!!

: I erased all files about directx 6 ... but at control panel in Directx Panel say..

: Direct3d version directx 6
: Directdraw version directx 6
: directinput not found
: directplay not found
: direct sound version directx 5

: So. I cant play Mortal Kombat 4... because directx isnt installed correctly...

: Do you Know some unistall for directx 6...

: Please give infromation!!!

: Thanks Roal Jhonson

Follow Ups:

  • Re: Helpp !!! Directx 6 with win98 Problems.... Juan Luis Aguilar Alamo 19:46:16 9/04/98 (0)
  • Re: Helpp !!! Directx 6 with win98 Problems.... Roal Jhonson 10:30:50 7/21/98 (0)

Post a Followup

Name:


Re: Helpp !!! Directx 6 with win98 Problems....

Posted by Roal Jhonson on July 21, 1998 at 10:30:50:

In Reply to: Re: Helpp !!! Directx 6 with win98 Problems.... posted by ding@ on July 21, 1998 at 10:25:22:

: well, its call beta, which means its not ready for release!. the DX6's uninstall part is yet to implement. you can try your luck on reinstalling the DirectX5.2. if it doesn't help, wait 3 more weeks for the DX6 final release!.

: Think this is a small lesson for you??, hah, "later the better"??, its a joke!

: : Hi, I installed directx 6 on win98... but i have many trouble!!

: : I erased all files about directx 6 ... but at control panel in Directx Panel say..

: : Direct3d version directx 6
: : Directdraw version directx 6
: : directinput not found
: : directplay not found
: : direct sound version directx 5

: : So. I cant play Mortal Kombat 4... because directx isnt installed correctly...

: : Do you Know some unistall for directx 6...

: : Please give infromation!!!

: : Thanks Roal Jhonson

Follow Ups:

Post a Followup

Name:


Is there a DirectX course i can take?

Posted by Chris Crane on July 21, 1998 at 10:45:45:

Hi..I am looking for a course in Directx that i can take.
Does anyone know if such a course exists, and if so where.\
Thanks.

Chris Crane

Follow Ups:

  • Re: Is there a DirectX course i can take? Jumicor 23:06:46 7/23/98 (0)

Post a Followup

Name:


Re: The primary surface pointer doesn't change.

Posted by Clay on July 21, 1998 at 11:20:30:

In Reply to: Re: The primary surface pointer doesn't change. posted by Dave Burrows on July 20, 1998 at 05:37:48:

: Why should it!

It seemed to make sense at the time! :->

: Don't forget the pointer you see is a virtual/linear one that goes through several layers of mapping to get to the physical pointer.

I've never done OS level assembly for x86, but it seems to me that in order to drectly access video memory, the data has to go to a port. Can "mov" do that? I was under the impression that "out" was needed. Thinking along those lines, it seems that when the application directly accesses video memory, it does it through shadowed video memory. Long story short, it makes perfect sense that the surface memory pointers don't change because the shadowed memory doesn't change...read on...

: A minor change in the Local Descriptor Table will change the indirection of any pointer.

The Flip() function probably sends a command to the video card (or driver) that tells it to switch memory banks. At least thats how it was done back in the days of DOS. This would explain how the primary and back surfaces get exchanged while the pointers (remember -- to shadowed memory) remain the same. In this respect, I don't think that the LDT or GDT need any modification when Flip() is called. They would need to be modified when the application initializes to map the shadowed memory into the address space.

Anyhow, this is (as usual) my opinion. If anyone has more information/ideas, post them! As I said, this is a pretty interesting topic of discussion, and probably worth some time.

Clay

BTW, questions to be answered...what happens to the surface memory pointers if you: 1) release and regain exclusive mode? 2) shutdown and re-init DirectDraw?

Follow Ups:

  • The Pointers never change Ravi Joshi 02:10:08 7/23/98 (0)

Post a Followup

Name:


3DFX DDER_OUTOFVIDEOMEMORY - HELP!

Posted by Marc Palma on July 21, 1998 at 12:31:38:

Hi.. im trying to set up a small DX application using my 3DFX. I cannon allocate a backbuffer. It keeps returning the out of video ram error...

This is what i do:

1. DirectDrawEnumerate to find the 3dfx which is does fine.

2. SetCooperativeLevel to full screen and exclusive.

3. SetDisplayMode to 640x480 16bit

4. Create pimary surface in either system of video ram, i've tried both.

5. try to create a backbuffer.. and boom. out of video mem..

Can anyone tell me why? PLEASE?? :(

Follow Ups:

  • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Clay 13:41:54 7/21/98 (4)
    • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Marc Palma 15:30:08 7/21/98 (3)
      • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Clay 18:21:26 7/21/98 (2)
        • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Marc Palma 22:04:52 7/21/98 (1)
          • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Clay 07:50:35 7/22/98 (0)

Post a Followup

Name:


Putting Labels on 3d Objects?

Posted by LT on July 21, 1998 at 12:42:06:

I'm working on a Direct 3D Retained Mode Game and would like to use Decals to put text labels beneath the mesh objects.

I think the best way to do it is:

1. Create a memory bitmap.
2. Make it transparent and monochrome.
3. Use TextOut to write the text label.
4. Create a D3DRM Decal based on the bitmap.

Does anyone know what API calls I could use from an MFC application to accomplish this? I suppose, I could create all the bitmaps in advance, but it would be better if I could generate the text on the fly.

Any suggestions would be appreciated.

Follow Ups:

Post a Followup

Name:


Re: Directx 6

Posted by choris on July 21, 1998 at 13:15:09:

In Reply to: Re: Directx 6 posted by Doug on July 20, 1998 at 22:31:51:

: : Is directx 6 out yet? Can I download them?
: : Email me for the Address, Thnaks a lot

: It's not out yet, I just checked. But keep checking at:

: http://www.microsoft.com/directx

: Doug

Follow Ups:

Post a Followup

Name:


Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP!

Posted by Clay on July 21, 1998 at 13:41:54:

In Reply to: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! posted by Marc Palma on July 21, 1998 at 12:31:38:

3dfx doesn't do DirectDraw stuff very well -- its pretty much only good for 3D. What you should do is CreateSurface() for your primary (in video memory) with BackBufferCount = 1 and then GetAttachedSurface() for the back buffer.

Clay

Follow Ups:

  • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Marc Palma 15:30:08 7/21/98 (3)
    • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Clay 18:21:26 7/21/98 (2)
      • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Marc Palma 22:04:52 7/21/98 (1)
        • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Clay 07:50:35 7/22/98 (0)

Post a Followup

Name:


Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP!

Posted by Marc Palma on July 21, 1998 at 15:30:08:

In Reply to: Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! posted by Clay on July 21, 1998 at 13:41:54:

: 3dfx doesn't do DirectDraw stuff very well -- its pretty much only good for 3D. What you should do is CreateSurface() for your primary (in video memory) with BackBufferCount = 1 and then GetAttachedSurface() for the back buffer.

: Clay

So basically you only have 1 buffer? That is an option I suppose.

But I should still be able to create a backbuffer?
It just seems like a strange error. I can't believe its out of memory.???

I actually want it for D3D. I have a shell set up and running fine in software and with my Riva128. It just seems to be funky with the 3DFX...

Follow Ups:

  • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Clay 18:21:26 7/21/98 (2)
    • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Marc Palma 22:04:52 7/21/98 (1)
      • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Clay 07:50:35 7/22/98 (0)

Post a Followup

Name:


Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP!

Posted by Clay on July 21, 1998 at 18:21:26:

In Reply to: Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! posted by Marc Palma on July 21, 1998 at 15:30:08:

: So basically you only have 1 buffer? That is an option I suppose.

You can use as many back buffers as you want, up to your available frame video memory (if it is a voodoo2, that is 4Meg)

: But I should still be able to create a backbuffer?
: It just seems like a strange error. I can't believe its out of memory.???

It's not, but the 3dfx card won't let you CreateSurface() for a off-screen surface in video memory when you are using 3D (is that redundant?).

:
: I actually want it for D3D. I have a shell set up and running fine in software and with my Riva128. It just seems to be funky with the 3DFX...

Don't forget that the nVidia chip is a 2D/3D combo and the 3dfx card is a dedicated 3D card.

Clay

Follow Ups:

  • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Marc Palma 22:04:52 7/21/98 (1)
    • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Clay 07:50:35 7/22/98 (0)

Post a Followup

Name:


Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP!

Posted by Marc Palma on July 21, 1998 at 22:04:52:

In Reply to: Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! posted by Clay on July 21, 1998 at 18:21:26:

: It's not, but the 3dfx card won't let you CreateSurface() for a off-screen surface in video memory when you are using 3D (is that redundant?).

Hmmm.. I havent even set up any D3D stuff by the time this is being funky.

I tried CreateSurface for Primary and using the BACKBUFFER caps.. and that enabled me to create them without the error! (thanks for the tip earlier!)...

So even if the 3DFX is a 3D card only. I still have to grab a DD surface on it then look for available D3D devices right?

Thanks for your help Clay.

Follow Ups:

  • Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! Clay 07:50:35 7/22/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by wu z on July 21, 1998 at 22:13:19:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Antonio DaSilva on July 10, 1998 at 21:50:08:

: : : : : Where Can I download DirectX 5.0. I need it for a game
: : hola pendejo.........

Follow Ups:

  • Re: Where Can I download DirectX 5.0 Susan Johnson 03:02:21 7/28/98 (0)

Post a Followup

Name:


A Little AI question: How to predict the next position?

Posted by Jones on July 21, 1998 at 22:41:35:

Hi, everybody:
I'm working on DX5 Retained mode for a game demo. Here is the question?
If I have the target's last position and current position(IDirect3DRMFrame:GetPosition), then I can
calculate the speed and moving direction vector. How do I use those infomation above to predict the next possible position with an optimized code?
Thanx.

Follow Ups:

  • Re: A Little AI question: How to predict the next position? Clay 10:55:33 7/22/98 (2)
    • Re:Re: A Little AI question: How to predict the next position? Jones 01:08:27 7/23/98 (1)
      • Re:Re: A Little AI question: How to predict the next position? Clay 13:29:31 7/23/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by orlando rodriguez on July 22, 1998 at 00:27:13:

In Reply to: Re: Where Can I download DirectX 5.0 posted by gail on July 20, 1998 at 20:27:29:

:
: : Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


Why aren't you all rich software developers?

Posted by Jumicor on July 22, 1998 at 01:19:20:

You guys seem eXperienced enough. Why aren't you all working on the newest blockbuster game? Gosh, maybe I don't have a chance...... :(

Follow Ups:

  • Re: Why aren't you all rich software developers? Clay 07:44:57 7/22/98 (0)

Post a Followup

Name:


ListServer at New Direct3D site is up and running

Posted by Wolfgang Engel on July 22, 1998 at 06:59:41:

The ListServer at http://www.netit.net is up and running. You could subscribe for a free e-mail newsletter on ASP, Direct3D and PowerRender.

  • Netit Direct3D ListServer

Follow Ups:

Post a Followup

Name:


Re: Why aren't you all rich software developers?

Posted by Clay on July 22, 1998 at 07:44:57:

In Reply to: Why aren't you all rich software developers? posted by Jumicor on July 22, 1998 at 01:19:20:

Some of us think its a fun hobby.

Clay

: You guys seem eXperienced enough. Why aren't you all working on the newest blockbuster game? Gosh, maybe I don't have a chance...... :(

Follow Ups:

Post a Followup

Name:


Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP!

Posted by Clay on July 22, 1998 at 07:50:35:

In Reply to: Re: 3DFX DDER_OUTOFVIDEOMEMORY - HELP! posted by Marc Palma on July 21, 1998 at 22:04:52:

Yea, there's a catch 22 in DirectX: you need to init DD before you init D3D, but you need D3D info to decide how to init DD. Look in the boids sample (from the DX SDK) for a good sample of how to do this (if you can wade through the tons of source!).

:
: : It's not, but the 3dfx card won't let you CreateSurface() for a off-screen surface in video memory when you are using 3D (is that redundant?).

: Hmmm.. I havent even set up any D3D stuff by the time this is being funky.

if you look in the 3dfx caps (available in the DirectX viewer app.), 3dfx doesn't support off-screen, non-flipping surfaces :-<

: I tried CreateSurface for Primary and using the BACKBUFFER caps.. and that enabled me to create them without the error! (thanks for the tip earlier!)...

: So even if the 3DFX is a 3D card only. I still have to grab a DD surface on it then look for available D3D devices right?

Yep!

Clay

BTW: boids also has a really neat swarming algorithm in it.

Follow Ups:

Post a Followup

Name:


Re: A Little AI question: How to predict the next position?

Posted by Clay on July 22, 1998 at 10:55:33:

In Reply to: A Little AI question: How to predict the next position? posted by Jones on July 21, 1998 at 22:41:35:

: If I have the target's last position and current position(IDirect3DRMFrame:GetPosition), then I can
: calculate the speed and moving direction vector. How do I use those infomation above to predict the next possible position with an optimized code?

Speed is in distance/time. If you know the last position and the difference in time (DeltaT), then multiply the speed vector by the time and you'll get the delta position vector (DeltaP). Add DeltaP to CurrentP (the current position) to get the position at future time TLast+DeltaT. If you want to add acceleration, the equation becomes a little hairy:

P = current position vector, V = velocity vector, A = acceleration vector (assumed constant here).

Pnext = P + DeltaP
DeltaP = Integral from 0 to DeltaT of V + DeltaV
DeltaV = Integral from 0 to DeltaT of A
DeltaV = DeltaT*A (remember, constant acceleration)
:. DeltaP = (A * 1/2 DeltaT^2) + (V * DeltaT)

================================================
:. Pnext = P + (A * 1/2 DeltaT^2) + (V * DeltaT)
================================================
Optimizations:

Multiply by 0.5 instead of divide by 2. If these are integers (not floats), right shift by 1 instead of divide by 2.

Replace DeltaT^2 with DeltaT*DeltaT

Use fixed point math instead of floating point math in your game. Do you really need more than 16 bits of precision?

Clay

Follow Ups:

  • Re:Re: A Little AI question: How to predict the next position? Jones 01:08:27 7/23/98 (1)
    • Re:Re: A Little AI question: How to predict the next position? Clay 13:29:31 7/23/98 (0)

Post a Followup

Name:


Q: How do I render with D3D and ramp mode

Posted by Joe Chang on July 22, 1998 at 14:10:26:

I seem to have all of the initialization handled properly. I am definitely
using the Primary Display Driver's Mono (Ramp) software emulation when I
create the D3D device2. I'm wondering if I'm missing some crucial render
states. I do have the D3DRENDERSTATE_MONOENABLE set to TRUE and
D3DLIGHTSTATE_COLORMODEL set to D3DCOLOR_MONO. Is there anything else I
need to set?

BTW, it's set to 320x240x8 and full screen exclusive. I know the ddraw is
working because I was able to blt my 8 bit texture to the back buffer and
flip it onto the screen. I can't even draw a single TL triangle. As a side
note, I was able to get it to work in 640x480x16 with HAL as well as RGB s/w
emulation.

Any info would be very helpful.
Thanks,
joe

Follow Ups:

  • Re: Q: How do I render with D3D and ramp mode Steve Dykes 14:58:45 7/23/98 (1)
    • Re: Q: How do I render with D3D and ramp mode Steve Dykes 15:01:18 7/23/98 (0)

Post a Followup

Name:


16 bit alpha-blit here

Posted by michaelb on July 22, 1998 at 14:46:46:

I know somebody was asking about source code for a 16-bit
alpha blit.

Well, here's mine. Now, this assumes that the video is
doing 555 bits, and this is a no-no. But hey, this is free!

Some of the variables may not make sense to you, but all of the
important stuff should be easy to figure out.

-Michael Black
michaelb@rga.com

BOOL CDirDraw::BlitToBackAlpha(CPoint* point, UINT surfaceSrc, CRect* rect) {
// Check for a valid surface number.
if ((surfaceSrc > m_currentSurfaceNum) || (surfaceSrc == 0))
return FALSE;

// Get a pointer to the requested surface.
DDSURFACEDESC ddsd;
unsigned char* bSrc;
unsigned char* bDes;
int sw, dw;
LPDIRECTDRAWSURFACE pSurface = m_surfacePointers[surfaceSrc];
memset(&ddsd, 0, sizeof(DDSURFACEDESC));
ddsd.dwSize = sizeof(DDSURFACEDESC);
pSurface->Lock(NULL, &ddsd, DDLOCK_SURFACEMEMORYPTR | DDLOCK_WAIT, NULL);
sw = ddsd.lPitch;
bSrc = (unsigned char*) ddsd.lpSurface;
m_pBackBuffer->Lock(NULL, &ddsd, DDLOCK_SURFACEMEMORYPTR | DDLOCK_WAIT, NULL);
dw = ddsd.lPitch;
bDes = (unsigned char*) ddsd.lpSurface;

for (int y=0;yHeight();y++) {
for (int x=0;xWidth();x++) {
WORD s;
memcpy(&s, bSrc + ((rect->TopLeft().y+y)*sw) + ((rect->TopLeft().x+x)*2), 2);
// green pixel is transparent
if (s == 0x3e0) continue;

WORD d;
memcpy(&d, bDes + (dw*(point->y+y)) + (2*(point->x+x)), 2);
d = ((alphaKey[(s & 0x7c00) >> 10][(d & 0x7c00) >> 10])> 5][(d & 0x3e0) >> 5])y+y)) + (2*(point->x+x)), &d, 2);
}
}

pSurface->Unlock(NULL);
m_pBackBuffer->Unlock(NULL);

return TRUE;
}

Follow Ups:

  • This is it, honest! Michael Black 14:56:31 7/22/98 (0)
  • 3'rd times a charm Michael Black 14:55:13 7/22/98 (0)
  • Well, that didn't work! TRY HERE. Michael Black 14:53:55 7/22/98 (0)

Post a Followup

Name:


Well, that didn't work! TRY HERE.

Posted by Michael Black on July 22, 1998 at 14:53:55:

In Reply to: 16 bit alpha-blit here posted by michaelb on July 22, 1998 at 14:46:46:

Ok, just go here.
-Michael

Follow Ups:

Post a Followup

Name:


3'rd times a charm

Posted by Michael Black on July 22, 1998 at 14:55:13:

In Reply to: 16 bit alpha-blit here posted by michaelb on July 22, 1998 at 14:46:46:

ok, so 'optional link URL' doesn't do anything...

Try this:

CLICK HERE FOR BLIT

Follow Ups:

Post a Followup

Name:


This is it, honest!

Posted by Michael Black on July 22, 1998 at 14:56:31:

In Reply to: 16 bit alpha-blit here posted by michaelb on July 22, 1998 at 14:46:46:

http://199.2.242.218/blit.html

If this doesn't work, I give up! Just email me.

michaelb@rga.com

Follow Ups:

Post a Followup

Name:


directdrawsurface2, 3, what is the difference?

Posted by michaelb on July 22, 1998 at 15:55:52:

Can anyone tell me why there are all these different things like:
LPDIRECTDRAWSURFACE
LPDIRECTDRAWSURFACE2
LPDIRECTDRAWSURFACE3
?

And what are the differences? Which ones should I be using?
The only thing that I've ever figured out is that I need to use
a DIRECTDRAW2 object to find how much video memory is left on my card.

Any help would be greatly appreciated.

-Michael

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Chris on July 22, 1998 at 23:18:30:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


Re:Re: A Little AI question: How to predict the next position?

Posted by Jones on July 23, 1998 at 01:08:27:

In Reply to: Re: A Little AI question: How to predict the next position? posted by Clay on July 22, 1998 at 10:55:33:

Thanks, Clay:
The problem has been solved.
Another question is that I found there is some
delay when reading texture. And I heard that this
can be solved using CreateTextureFromSurface.
Can you show me some more details about how to
use this?

Thanks in advance,

Jones 23/7/98

Follow Ups:

  • Re:Re: A Little AI question: How to predict the next position? Clay 13:29:31 7/23/98 (0)

Post a Followup

Name:


The Pointers never change

Posted by Ravi Joshi on July 23, 1998 at 02:10:08:

In Reply to: Re: The primary surface pointer doesn't change. posted by Clay on July 21, 1998 at 11:20:30:

Hi to all.
::BTW, questions to be answered...what happens to the surface memory pointers if you: 1) release and regain exclusive mode? 2) shutdown and re-init DirectDraw?

I tried doing this. I created a direct draw object, created a primary and a back surface. Read the pointer values. Flipped and then read the pointer values again.
The surface pointer values remain the same.
Then I released the direct draw object and created it again, and repeated the same procedure. The pointer values don't change at all.

I am beginning to think that there is some point in what Dave has said.
Pl do some research and let me know the results. I am working on it too.

Thanks..
Ravi..

Follow Ups:

Post a Followup

Name:


Where Can I Download DirectX 5.0? I need it for Microsoft Flight Simulator 98

Posted by KB on July 23, 1998 at 06:37:59:

In Reply to: where can I download direct X 5.0 posted by Yves Lavoie on February 06, 1998 at 23:01:14:

That is one of the most important thing that I want. So please whomever, e-mail me back so I can download it so I can be happier.

Thank You
K.B. of Yokota AB, Japan

Follow Ups:

Post a Followup

Name:


Colors System, Palettes in VGA RAM??

Posted by Gunnar on July 23, 1998 at 09:41:54:

I havn't done much windows programming, more
embedded systems, so this high-level stuff is
confucing.

My problem is as follows:

- I'm plotting some scientific real time plots, pixels
using DirectX, by writing directly to VGA RAM, in
16 bit mode. ( at speeds up to 10 Mpixel/s, must
be fast)

- Need to automatically set N curves to colors which
differ from each other and background as much as possible.

- Have no idea what palettes,etc do (just
tables of in-out values??)

Question:

Q1: What is the connection between the 16 bit word and the
actual color on the screen??

Q2: is there actually some kind of (hardware) table,
palette in the VGA hardware, which translates "my" 16 bit
word to whatever color??
(I've always though this was just windows software
stuff?? any difference 4 bit,8 bit and 16 bit mode??)

Any comments or pointers appreciated! Gunnar

Follow Ups:

Post a Followup

Name:


Where Can I find the dialer that works with NO MODEM ?

Posted by Johnny Kim on July 23, 1998 at 09:43:36:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Harold on January 18, 1998 at 20:37:49:

Where Can I find the dialer that works with NO MODEM ?

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 6.0

Posted by Josee Oliviero on July 23, 1998 at 10:38:35:

In Reply to: Re: Where Can I download DirectX 5.0 posted by fernando i barrola on July 10, 1998 at 19:46:09:

Where Can I download DirectX 6.0 (or latest versions)

Follow Ups:

  • Re: Where Can I download DirectX 6.0 Nancy Jaggers 15:04:56 9/07/98 (0)
  • Re: Where Can I download DirectX 6.0 zmc 08:15:56 8/30/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Micheal antez on July 23, 1998 at 12:30:30:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Christer Johnson on March 23, 1998 at 14:03:03:

:
: :
: : : Where Can I download DirectX 5.0. I need it for an emulator.
: And for games

Follow Ups:

Post a Followup

Name:


DIRECT INPUT PROBLEM!

Posted by Martin K. on July 23, 1998 at 13:24:30:

If i compile the code i wrote, it says:
dinput.lib(dilib2.obj) : error LNK 2001: unresolved external object _GUID_Key

have an idea what could be wrong? plese help!

Follow Ups:

  • Re: DIRECT INPUT PROBLEM! 0x1CE 14:59:48 7/23/98 (2)
    • Re: DIRECT INPUT PROBLEM! Martin K. 13:43:03 7/24/98 (1)
      • Re: DIRECT INPUT PROBLEM! 0x1CE 14:14:51 7/24/98 (0)

Post a Followup

Name:


Re:Re: A Little AI question: How to predict the next position?

Posted by Clay on July 23, 1998 at 13:29:31:

In Reply to: Re:Re: A Little AI question: How to predict the next position? posted by Jones on July 23, 1998 at 01:08:27:

I did some experimentation with CreateTextureFromSurface() and LoadTexture() some time ago. What I found was that D3D (in DirectX 5.0) didn't always use local video memory for the texture. When I created a surface with the texture flag set and used CreateTextureFromSurface(), it used video memory. But, when I used LoadTexture() (I hope that function name is right, its been a while) it always used system memory. This was strange to me, because I was using the HAL driver for my 3dfx Voodoo2 12M. I know I had tons of texture memory, but D3D wouldn't use it unless I specifically told it to. Anyhow, the point is this: use local video memory for textures whenever possible (unless the texture image changes often). This means that you have to manage bit depths, etc. for your textures, but it allows the video card to use the texture locally (read: quickly). The speed benefit from using video memory vice system memory is greatly lessened when you use an AGP card.

Clay

Follow Ups:

Post a Followup

Name:


Re: Q: How do I render with D3D and ramp mode

Posted by Steve Dykes on July 23, 1998 at 14:58:45:

In Reply to: Q: How do I render with D3D and ramp mode posted by Joe Chang on July 22, 1998 at 14:10:26:

: I seem to have all of the initialization handled properly. I am definitely
: using the Primary Display Driver's Mono (Ramp) software emulation when I
: create the D3D device2. I'm wondering if I'm missing some crucial render
: states. I do have the D3DRENDERSTATE_MONOENABLE set to TRUE and
: D3DLIGHTSTATE_COLORMODEL set to D3DCOLOR_MONO. Is there anything else I
: need to set?

: BTW, it's set to 320x240x8 and full screen exclusive. I know the ddraw is
: working because I was able to blt my 8 bit texture to the back buffer and
: flip it onto the screen. I can't even draw a single TL triangle. As a side
: note, I was able to get it to work in 640x480x16 with HAL as well as RGB s/w
: emulation.

: Any info would be very helpful.
: Thanks,
: joe

Follow Ups:

  • Re: Q: How do I render with D3D and ramp mode Steve Dykes 15:01:18 7/23/98 (0)

Post a Followup

Name:


Re: DIRECT INPUT PROBLEM!

Posted by 0x1CE on July 23, 1998 at 14:59:48:

In Reply to: DIRECT INPUT PROBLEM! posted by Martin K. on July 23, 1998 at 13:24:30:

If your using MSVC++ you need to link with xguid.lib, if you're not you'll have to add #define INITGUID to the top of your code.

: If i compile the code i wrote, it says:
: dinput.lib(dilib2.obj) : error LNK 2001: unresolved external object _GUID_Key

: have an idea what could be wrong? plese help!

Follow Ups:

  • Re: DIRECT INPUT PROBLEM! Martin K. 13:43:03 7/24/98 (1)
    • Re: DIRECT INPUT PROBLEM! 0x1CE 14:14:51 7/24/98 (0)

Post a Followup

Name:


Re: Q: How do I render with D3D and ramp mode

Posted by Steve Dykes on July 23, 1998 at 15:01:18:

In Reply to: Re: Q: How do I render with D3D and ramp mode posted by Steve Dykes on July 23, 1998 at 14:58:45:

Are you specifying a material? It's not required in RGB modes, but in Ramp mode you must (or, I assume, nothing appears).

Look up Materials in your dx documentation (or better yet, check out the sample apps for an example of how to specify one).

--Steve

: : I seem to have all of the initialization handled properly. I am definitely
: : using the Primary Display Driver's Mono (Ramp) software emulation when I
: : create the D3D device2. I'm wondering if I'm missing some crucial render
: : states. I do have the D3DRENDERSTATE_MONOENABLE set to TRUE and
: : D3DLIGHTSTATE_COLORMODEL set to D3DCOLOR_MONO. Is there anything else I
: : need to set?

: : BTW, it's set to 320x240x8 and full screen exclusive. I know the ddraw is
: : working because I was able to blt my 8 bit texture to the back buffer and
: : flip it onto the screen. I can't even draw a single TL triangle. As a side
: : note, I was able to get it to work in 640x480x16 with HAL as well as RGB s/w
: : emulation.

: : Any info would be very helpful.
: : Thanks,
: : joe

Follow Ups:

Post a Followup

Name:


gamming DIRECTX

Posted by Zack on July 23, 1998 at 21:00:37:

I have an idea for a game and I wanted to program it
using DirectX and C++ but don't know what I need to know
to start programming it. I have done C++ programs before
but I never wrote a game and I have no expierence with
DirectX. Can someone please explain to me how you program
a 3D game engine with C++ and DirectX?

Follow Ups:

  • Re: gaming DIRECTX Jumicor 22:59:13 7/23/98 (1)
    • Re: gaming DIRECTX Snowman 14:30:34 7/24/98 (0)

Post a Followup

Name:


Re: gaming DIRECTX

Posted by Jumicor on July 23, 1998 at 22:59:13:

In Reply to: gamming DIRECTX posted by Zack on July 23, 1998 at 21:00:37:

Hello, I'm also a newbie at directx, though I have written games before in other languages. I suggest that you go to a local bookstore and pick up a copy of "Cutting-Edge Direct 3D Programming" by Stan Trujillo. I just got the book, and Direct 3D is BLOWING ME AWAY! It's actually a lot simpler than you would think. Sooooo, I highly recommend you pick up this book. As for the fundamental concepts behind "games" (to distinguish from just "graphics") there are so many great books that any would be acceptable. You will need Microsoft Visual c++ 4.0 or greater to use the book and directx, and the directx sdk (available from www.microsoft.com). Hope this helps. Feel free to email me.

Jumicor

P.S. Programmers need to learn to spell properly =) =) =) =) =) =) =) =) =)

Follow Ups:

  • Re: gaming DIRECTX Snowman 14:30:34 7/24/98 (0)

Post a Followup

Name:


I need help wrapping a texture properly to a box. PLEASE HELP!!

Posted by Jumicor on July 23, 1998 at 23:03:55:

I want to use a spherical wrap to apply a texture to a simple cube. I want all of the faces of the cube to look basically the same. Can someone give me the parameters to the d3drm->CreateWrap function?
Help would be much appreciated.

Follow Ups:

Post a Followup

Name:


Re: Is there a DirectX course i can take?

Posted by Jumicor on July 23, 1998 at 23:06:46:

In Reply to: Is there a DirectX course i can take? posted by Chris Crane on July 21, 1998 at 10:45:45:

Yeah, there are courses available all over the United States. They come in the form of books. You might be able to take courses somewhere, but books are easier IMO =).

Follow Ups:

Post a Followup

Name:


DirectSound... ALT-TAB... other apps say "Another app is using audio"

Posted by Nathanael Weiss on July 24, 1998 at 02:02:42:

I use DirectSound at the NORMAL compatibilty level. When the user ALT-TABs out of my app, I wrote some code to completely release all of DirectSound. But still, any other audio app will say "Audio is in use my another application."

What do I do to be able to play sounds while my DirectSound app is running in the background?

Follow Ups:

Post a Followup

Name:


Releasing Back Buff and COM part of DirectX

Posted by Ravi Joshi on July 24, 1998 at 02:40:22:

Hi to all,

Can you tell me what happens here and why does it happen?

I have created a primary surface with a backbuffer.
Both the interfaces are of type LPDIRECTDRAWSURFACE, namely lpDDSPrimary and lpDDSBack.
I, then query for LPDIRECTDRAWSURFACE3 type of interfaces for both the surfaces.
The new interface pointers are lpDDSPrimary3 and lpDDSBack3.

Now that I have latest interfaces, I try to release the earlier ones.
When I release the lpDDSPrimary, I get DD_OK as the return value. But when I try to release the lpDDSBack, the app gives
unkown error, the error is none of the listed return values including DD_OK.
The application terminates if I try to run and if I try to debug the app, the machine hangs.

1.Why does this happen. Can't I release the interface to the backbuffer as one does with any other COM interface?
2.Does the DirectDraw subsystem automatically release the backbuffer interface upon releasing the interface
to the primary one?

Furthermore, Can any one enlighten me about the way in which the DirectX handles the COM part of the entire subsystem?
If you happen to know the answer, Pl post.
Thanks to all in advance. Any help will be appriciated.

Ravi Joshi.

Follow Ups:

  • Re: Releasing Back Buff and COM part of DirectX Clay 08:29:18 7/24/98 (0)

Post a Followup

Name:


Re: Releasing Back Buff and COM part of DirectX

Posted by Clay on July 24, 1998 at 08:29:18:

In Reply to: Releasing Back Buff and COM part of DirectX posted by Ravi Joshi on July 24, 1998 at 02:40:22:

: I, then query for LPDIRECTDRAWSURFACE3 type of interfaces for both the surfaces.
: The new interface pointers are lpDDSPrimary3 and lpDDSBack3.

: When I release the lpDDSPrimary, I get DD_OK as the return value. But when I try to release the lpDDSBack, the app gives
: unkown error, the error is none of the listed return values including DD_OK.

: 1.Why does this happen. Can't I release the interface to the backbuffer as one does with any other COM interface?

It depends. If you created the primary with the BackBufferCount >=1, you shouldn't release the back buffer. It is automatically released when you release the front buffer. If you created the primary and back buffer(s) separately, then you should release them individually.

: 2.Does the DirectDraw subsystem automatically release the backbuffer interface upon releasing the interface
: to the primary one?

See above

: Furthermore, Can any one enlighten me about the way in which the DirectX handles the COM part of the entire subsystem?

From the VC++ 5.0 docs:

"COM is a technology that allows objects to interact across process and machine boundaries as easily as objects within a single process interact. COM enables this by specifying that the only way to manipulate the data associated with an object is through what is called an interface on the object. When this term is used, it refers to an implementation in code of a COM binary-compliant interface that is associated with an object.

Talking about an object that implements an interface means that the object uses code that implements each method of the interface and provides COM binary-compliant pointers to those functions to the COM library. COM then makes those functions available to any client who asks for a pointer to the interface, whether the client is inside or outside of the process that implements those functions."

That doesn't mean much (at least to me!) but it does mean that DirectX was written, at least partly, in C++ but we can access functions (or interfaces -- whatever) with C. The reference counter information in the DirectX SDK gave me some insight into how it works.

Clay

Follow Ups:

Post a Followup

Name:


Q: How make 3D game tool?

Posted by Chang on July 24, 1998 at 12:59:59:

I want make 3D game tool.
Sprite,Map,Mission editor so on.
It loads 3DS file, it create game info.
But I haven't a infomation.
I will use MFC and Direct 3DRM.
I want Bookname,site,source so on.
Please help me.

Follow Ups:

Post a Followup

Name:


Direct3D, DirectDraw and Win98 shutdown

Posted by Karl Fisher on July 24, 1998 at 13:42:35:

I have a strange condition occurring and would appreciate any help I can
get.

I have a direct 3D application in which I am using DrawPrimitive to display
two rotating spheres, with one of them orbiting the other. The program runs
fine with a nominal frame rate of 60 FPS, and everything seems to be working
just as it should.

The problem is that after executing the program, when I shutdown Win98 the
"Windows is shutting down" screen , and the "It's now safe to turn of your
computer" screen both display in Black & White.

I can run another program after running the Direct3D program and it will run
ok, but I will still get the Black & White displays when I shutdown Win98.

I am applying Textures, Material, and A single point light but I am deleting
all of those, and releasing Directdraw, Direct3D, Viewport, etc. before
exiting the program.

Any suggestions would be greatly appreciated.

Thanks
Karl
karl_fisher@msn.com

Follow Ups:

Post a Followup

Name:


Re: DIRECT INPUT PROBLEM!

Posted by Martin K. on July 24, 1998 at 13:43:03:

In Reply to: Re: DIRECT INPUT PROBLEM! posted by 0x1CE on July 23, 1998 at 14:59:48:

: If your using MSVC++ you need to link with xguid.lib, if you're not you'll have to add #define INITGUID to the top of your code.

Where can i get xguid.lib from? i searched for it, but know one has it.

: : If i compile the code i wrote, it says:
: : dinput.lib(dilib2.obj) : error LNK 2001: unresolved external object _GUID_Key

: : have an idea what could be wrong? plese help!

Follow Ups:

  • Re: DIRECT INPUT PROBLEM! 0x1CE 14:14:51 7/24/98 (0)

Post a Followup

Name:


Re: DIRECT INPUT PROBLEM!

Posted by 0x1CE on July 24, 1998 at 14:14:51:

In Reply to: Re: DIRECT INPUT PROBLEM! posted by Martin K. on July 24, 1998 at 13:43:03:

Sorry, I meant dxguid.lib. It should come with the sdk.

: Where can i get xguid.lib from? i searched for it, but know one has it.

Follow Ups:

Post a Followup

Name:


Re: gaming DIRECTX

Posted by Snowman on July 24, 1998 at 14:30:34:

In Reply to: Re: gaming DIRECTX posted by Jumicor on July 23, 1998 at 22:59:13:

I would reccommend that you get a book entitled "The awesome power of Direct3D/DirectX" I found this book to be more helpful than the one mentioned before (I own a copy of both.) My book actually builds a little game (sound included). It contains the SDK on the CD, so there is no need to purchase that from MS. This book even goes into collision detection. It is more Game orriented that Cutting edge is.

I hope this will help.

-Snowman

Follow Ups:

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by asdfasdf on July 24, 1998 at 15:14:01:

In Reply to: where can I download direct X 5.0 posted by Yves Lavoie on February 06, 1998 at 23:01:14:

: where I can get direct X 5.0 please a answer

Follow Ups:

  • Re: where can I download direct X 5.0 Carlos 14:47:31 7/27/98 (0)

Post a Followup

Name:


Direct 3D hardware question!

Posted by Jumicor on July 24, 1998 at 17:26:58:

How can I tell if my program is using my 3dfx direct 3d accelerated card? I have been programming with direct 3d for a couple of weeks...I believe that my programs are not using my 3dfx card because the textures are not blended. I need to know how to get the texture blending working. I have a Matrox Mystique for 2D and 3dfx Voodoo 1 for 3d. Is it possible that my program does not recognize the 3dfx card and only uses the matrox card. If so what do I have to do to make it find my 3dfx card.

Follow Ups:

  • Re: Direct 3D hardware question! Mman1118 23:18:23 8/27/98 (0)

Post a Followup

Name:


To: Clay

Posted by Snowman on July 24, 1998 at 19:13:48:

A while ago you were helping me with hardware accelleration. You said if I emailed you, you would send me a sample program, well I tried many times but I was unable to Email you. Please email me back with the program Thanks!!

-Snowman

Ps I signed "me" back then.

Follow Ups:

Post a Followup

Name:


How do you use fog?

Posted by Snowman on July 24, 1998 at 19:19:08:

I am using D3DRM. The following line works great in windowed mode, but in Fullscreen modeit doesn't work!

/**********************************/
//Add Some FOG!!!
/**********************************/

D3DCOLOR color = D3DRMCreateColorRGB( D3DVALUE(0), D3DVALUE(0), D3DVALUE(0) );

//Set background to that of fog
scene->SetSceneBackground( color );
scene->SetSceneFogMode(D3DRMFOG_LINEAR);
scene->SetSceneFogParams( D3DVALUE(0), D3DVALUE(200), D3DVALUE(0.5) );
scene->SetSceneFogColor(color);
scene->SetSceneFogEnable(TRUE);

Is there any where else I need to add code? (like the render function) Please help me!

Thanks in advance!

-Snowman

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by lap hing on July 25, 1998 at 03:39:32:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Igor on March 25, 1998 at 00:12:52:

: : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


Selecting video card

Posted by Jumicor on July 25, 1998 at 11:46:09:

Most D3D programs let the user choose between software or hardware, and often allow them to choose a specific video card. How is this implemented?

Follow Ups:

Post a Followup

Name:


Re: Don;t read one pixel at a time??

Posted by Gunnar on July 25, 1998 at 11:46:39:

In Reply to: Re: Fast Plot / fade in truecolor ? DirectX posted by FunkSlice on July 20, 1998 at 19:30:08:

I havn't yet gotten into the PCI bus read
problems, but there is a high possibilty
that reading-writing-reading-writing makes
the PCI bus (AGP??) perform at it's worst.
(buffering, etc)

To me the best solution would be to blit the
screen to system memory, write a tight
optimised, unrolled loop (8 pixels at time),
preferably using some few right shifts instead of
multiplies, and then blit back to the screen??

As this amount of data will be larger than the
internal L1 data cache, it might be faster to
blit in 8kb (16kb) chunks, so that the data
fits the internal cache??

well..

To avoid the reads I would actually first
take a copy of the screen, and then fade
it in system meory, while starting a blit
every time a fade is done.

There is also another reason for this, that
decreasing the RGB values when they are only
5 bits won't work in integer math, due to
truncation. P(n+1)=0.9*P(n) or rather
P(n+1)=15/16*P(n) or P(n+1)= P(n)-P(n)/16
will stop decreasing at P(n)=16.

The general "trick" is to use a higher bit
accuracy, scale the stored value to let's say
16 bits with a left shift, fade it as such,
and scale it down before blitting it out the
screen.

One more, just noticed that most cards buffer up
to 4 blit commands, something causing some strange
behavior if one doesn;t take it into consideration.
(if the card does the blit in "hardware", actually
VGA firmware)

Btw, sometimes a blit done in software is faster
than a "hardware" blit, but the pointis to do
something else (fading next blit) while the
hardware blits (just like DMAs)

Hope this helps?? Gunnar

Follow Ups:

  • Re: Don;t read one pixel at a time?? Junior McMillan 08:56:09 7/29/98 (0)

Post a Followup

Name:


I need Urgent Help with DirectX and Windows 98- Please Read

Posted by Craig Edelstein on July 25, 1998 at 18:46:24:

Hi Everyone
I was just wondering if anyone knew how to Uninstall DirectX, the one that comes with Windows 98? I have searched everywhere, its not listed in Add/Remove Programs, and noone seems to beable to help me. I was told to Reinstall DirectX because I am having problems with a game called "Quake2". Everytime I try to run it I get a weird looking grey Window and then my computer just freezes up and I have to reset. I am sure this is due to DirectX and Win98 because it worked fine on my other computer with Windows95, and I was told to Reinstall DirectX. I have a Pentium 233 MMX with 32 Megs of ram and a Trident TGUI9680 2 MB Video Card(Which DirectX 5.0 should support) I need any bit of advice, I just purchased this computer and really want to fix this problem. If someone here has the expertise to help me, please do so. Please direct all answers to my E-mail or its thats to big of a trouble just post it.
Thanks A lot

Craig Edelstein

Follow Ups:

  • Re: I need Urgent Help with DirectX and Windows 98- Please Read fred 01:43:26 7/26/98 (2)
    • Re: I need Urgent Help with DirectX and Windows 98- Please Read Craig Edelstein 14:53:37 7/26/98 (1)
      • Re: I need Urgent Help with DirectX and Windows 98- Please Read fred 10:41:18 7/29/98 (0)

Post a Followup

Name:


Snowman:

Posted by Jumicor on July 26, 1998 at 00:21:09:

Hey snowman, since you have cutting-edge direct 3d programming by stan trujillo too, I was wondering if I could email you to get some help. It does not appear that I am getting any response to some recent messages that I have posted. I have some questions about hardware acceleration and the demos in the afforementioned book(see posts for more info). After reading those posts I would appreciate if you would give me ANY info you have related to those subjects. I am especially interested in determining why the programs do not take advantage of my 3dfx card's texture blending capabilities.

Thanks,
Jumicor

Follow Ups:

  • Re: Snowman: Snowman 20:47:56 7/26/98 (5)
    • Re: Snowman: Jumicor 00:51:50 7/27/98 (4)
      • Re: Snowman: Snowman 13:58:42 7/27/98 (2)
        • Re: Snowman: Jumicor 14:07:50 7/27/98 (1)
          • Re: Snowman: Snowman 20:09:13 7/27/98 (0)
      • Oops Clay 07:20:32 7/27/98 (0)

Post a Followup

Name:


Re: I need Urgent Help with DirectX and Windows 98- Please Read

Posted by fred on July 26, 1998 at 01:43:26:

In Reply to: I need Urgent Help with DirectX and Windows 98- Please Read posted by Craig Edelstein on July 25, 1998 at 18:46:24:

was told to Reinstall DirectX because I am having problems with a game called "Quake2". Everytime I try to run it I get a weird looking grey Window and then my computer just freezes up and I have to reset.

Quake2 don't use directdraw/direc3D at all, it use OpenGL with the normal window DC, so it *may* NOT be the problem of DirectX.

[try use other openGL driver if you are using hardware accl,]

I am sure this is due to DirectX and Win98 because it worked fine on my other computer with Windows95,

Maybe your two computers have different hardware config?, different software config???.. The game runs well on other computers doesn't necessarily means your computer with win98 have problem on directX, tho.

if your computer [win98/directX] can run other games well, i won't say it have problem on directX. Rather, i think the Quake2 installation _maybe_ a problem. [_maybe_ you should ask id for help,... LoL]

basically you can't uninstall DirectX, what you can do is restore the original video/audio driver. or install the newer version of DX onto the old one, your last chance is REINSTALL your win98 [guess you don't want to do that.. hehe]

Follow Ups:

  • Re: I need Urgent Help with DirectX and Windows 98- Please Read Craig Edelstein 14:53:37 7/26/98 (1)
    • Re: I need Urgent Help with DirectX and Windows 98- Please Read fred 10:41:18 7/29/98 (0)

Post a Followup

Name:


CAN ANYONE DIRECT ME TO DIRECTPLAY INFO?

Posted by Fragmo on July 26, 1998 at 02:12:56:

I NEED TO FIND SOME INFORMATION ABOUT DIRECTPLAY THAT WASN'T
WRITTEN BY MICROSOFT. SAMPLES WOULD BE NICE TOO.

Fragmo
http://www.public.iastate.edu/~jtilton/gamepage.html

Follow Ups:

Post a Followup

Name:


Re: DJGPP with DirectX?

Posted by Dominik Scherer on July 26, 1998 at 08:24:03:

In Reply to: DJGPP with DirectX? posted by Pierpa on January 15, 1998 at 10:27:27:

: It is possible to use the Direct3D with the DJGPP C++ compiler?
: If yes, where I can found all the necessary tool and documentation to start?

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Dan Cedric T. Delima on July 26, 1998 at 11:42:31:

In Reply to: Re: Where Can I download DirectX 5.0 posted by fernando i barrola on July 10, 1998 at 19:46:09:

: : : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


Re: I need Urgent Help with DirectX and Windows 98- Please Read

Posted by Craig Edelstein on July 26, 1998 at 14:53:37:

In Reply to: Re: I need Urgent Help with DirectX and Windows 98- Please Read posted by fred on July 26, 1998 at 01:43:26:

: was told to Reinstall DirectX because I am having problems with a game called "Quake2". Everytime I try to run it I get a weird looking grey Window and then my computer just freezes up and I have to reset.

: Quake2 don't use directdraw/direc3D at all, it use OpenGL with the normal window DC, so it *may* NOT be the problem of DirectX.

: [try use other openGL driver if you are using hardware accl,]

: I am sure this is due to DirectX and Win98 because it worked fine on my other computer with Windows95,

: Maybe your two computers have different hardware config?, different software config???.. The game runs well on other computers doesn't necessarily means your computer with win98 have problem on directX, tho.

: if your computer [win98/directX] can run other games well, i won't say it have problem on directX. Rather, i think the Quake2 installation _maybe_ a problem. [_maybe_ you should ask id for help,... LoL]

:
: basically you can't uninstall DirectX, what you can do is restore the original video/audio driver. or install the newer version of DX onto the old one, your last chance is REINSTALL your win98 [guess you don't want to do that.. hehe]

Thats a good point and thanks for your help, you're probably right about DirectX because I play a game called StarCraft just fine and that requires DirectX..It won't let me restore original Video/audio and I thought Windows98 came with a updated version of DirectX(5.2) so there are no upgrades after that, I also did download it again and installed it. So you just think I should reinstall Windows98? :(
Or is there anything else I can do? I do not have a graphics accelerator at the moment, I play on getting one if I can get it to work now, no point in buying one if it won't work with my video card at the moment.
Thank You

Follow Ups:

  • Re: I need Urgent Help with DirectX and Windows 98- Please Read fred 10:41:18 7/29/98 (0)

Post a Followup

Name:


Re: Snowman:

Posted by Snowman on July 26, 1998 at 20:47:56:

In Reply to: Snowman: posted by Jumicor on July 26, 1998 at 00:21:09:

I would help you out, except that I'm having the same problems that you are! I can't get hardware to work either. Clay was helping me before with it, but he has stopped talking to me! I even wrote a message (like the one you wrote directed to him)!

About selecting a video card, all you need to do is use the EnumDevices() (I think that's what the function is called.) It's a member of your Direct3DRM device.If you still need help I can post the function (and function call) for you.

And about link errors, do you have the SDK? If you don't you need to. I would reccommend buying it from Microsoft. If you can't do that then I can give you a site to download it from !!WARNING!! It's 31.5 megs!!! Once you do that you need to put all of the .Lib file in you VC++ lib directory, then you need to go to the Insert menu and choose the Files into Project choice. From there you need to select the Direct3D libraries.

Hope this helps!

-Snowman

Follow Ups:

  • Re: Snowman: Jumicor 00:51:50 7/27/98 (4)
    • Re: Snowman: Snowman 13:58:42 7/27/98 (2)
      • Re: Snowman: Jumicor 14:07:50 7/27/98 (1)
        • Re: Snowman: Snowman 20:09:13 7/27/98 (0)
    • Oops Clay 07:20:32 7/27/98 (0)

Post a Followup

Name:


Re: Snowman:

Posted by Jumicor on July 27, 1998 at 00:51:50:

In Reply to: Re: Snowman: posted by Snowman on July 26, 1998 at 20:47:56:

Yes, of course I now have the sdk, when I put those first posts up a while back I was under the impression that those files would be installed from the cd that came with the book(Cutting-Edge), it'd been many months since I'd had VC++ on my hard drive.
The book says that all of the sample programs will take advantage of hardware acceleration whenever available. It is very hard for me to tell if it is using my hardware acceleration. I know for sure that the programs are not taking advantage of the blending feature of my 3dfx card, but I cant tell if the framerate is being improved because I dont know how to switch between hardware and software. What kind of video card do you have? Does yours support blending? If so, does the blending work in your direct 3d programs?

I think it's possible that the windowed samples in the book dont use my 3dfx card, but the fullscreen one might. I havent really studied this yet. I think this because the full screen program uses a different method of creating the device.

YES!!!! Give me more info on EnumDevices() and the parameters (how do I set it to software, matrox ( my 2d card ) , 3dfx(my direct 3d card))

Follow Ups:

  • Re: Snowman: Snowman 13:58:42 7/27/98 (2)
    • Re: Snowman: Jumicor 14:07:50 7/27/98 (1)
      • Re: Snowman: Snowman 20:09:13 7/27/98 (0)
  • Oops Clay 07:20:32 7/27/98 (0)

Post a Followup

Name:


ALIENS HAVE LANDED ON THE MOON AND ARE PLOTTING THEIR ATTACK AGAINST EARTH!!

Posted by Jumicor on July 27, 1998 at 00:57:46:

Now that I have your attention, could someone PLEEEEAAAAASSEEE help me with some of the questions I posted below!!!!!!!!!!!!

Follow Ups:

Post a Followup

Name:


Oops

Posted by Clay on July 27, 1998 at 07:20:32:

In Reply to: Re: Snowman: posted by Jumicor on July 27, 1998 at 00:51:50:

Sorry 'bout dropping the ball guys. Usually I check the board daily, but sometimes I get wrapped up in other stuff (mainly work) and lose track of whats going on here. I'll get back to ya.

Clay

Follow Ups:

Post a Followup

Name:


Problems with Watcomc++ and directx 5.0

Posted by H�lmut on July 27, 1998 at 08:35:24:

HI.
I have downloaded he newest SDK for DirectX, but there
are massive problems as i am using Watcom c++ 11.
The SDK says, that i should check out www.sybase.com for
up2date include files 4 watcom c++, but i can't find any.
Could any1 out there help me ?
Thanx in advance,

c ya, H�lmut.

Follow Ups:

Post a Followup

Name:


Lost Surface and failing restore command! Help Needed! Thx

Posted by bardya on July 27, 1998 at 09:39:23:

Hello,

I lose the pointer to my surfaces! (The function 'islost' confirms that) When I use Restore function on the surface I get "DDERR_WRONGMODE This surface cannot be restored because it was created in a different mode." Why does this happen? And how can I prevent/fix it?

Thx

Follow Ups:

  • Re: Lost Surface and failing restore command! Help Needed! Thx Dave Burrows 04:44:10 7/28/98 (0)

Post a Followup

Name:


Need help to dynamically Create Sprites

Posted by Jason Millard on July 27, 1998 at 09:53:54:

Hello.. I am working on an emulator and I would like
to dynamically create sprites. My sprites would be
8 pixels x 8 pixels. The sprites get generated by
looking at bytes values.

For example

10001000 = 0x88
10000001 = 0x81
00000010 = 0x02

Do I have to using GDI set pixel commands? I figure I
would pixel them in to an 8x8 buffer and then blit it
to main screen.

However, this approach seems very slow to me, so is
theere a faster drawing approach availiable to me?

Thank you,
Jason Millard

Follow Ups:

Post a Followup

Name:


Not a DirectX question! Basic C help

Posted by Johnny Rotten on July 27, 1998 at 11:26:39:

I know this is not a DirectX question, but you people are so damned smart and so good at replying that I figured I would start here. I'm just trying to speed up my code a little and wondered if there was an a faster way to set an entire array to zero at runtime. I'm using a loop like this:

---------------------------------------
int array[256][256] ={0};

//fill array with info
//use array info

//clear array
for (j = 0; j < 256; j++)
{
for (i = 0; i < 256; i++)
{
array[j][i] = 0;
}
}
---------------------------------------
Is there a faster way to set an entire array to zero? Loops sure are slow especially when this is in my main game loop! Also, is there a way to copy an entire array to an equal array without using loops?

Thanks for any help!

Johnny

Follow Ups:

  • Re: Not a DirectX question! Basic C help Dave Burrows 04:49:47 7/28/98 (0)
  • Re: Not a DirectX question! Basic C help Jumicor 23:58:26 7/27/98 (1)
    • Setting array to 0 during main loop Johnny Rotten 10:41:55 7/28/98 (0)
  • Re: Not a DirectX question! Basic C help Bardya 11:33:53 7/27/98 (0)

Post a Followup

Name:


Re: Not a DirectX question! Basic C help

Posted by Bardya on July 27, 1998 at 11:33:53:

In Reply to: Not a DirectX question! Basic C help posted by Johnny Rotten on July 27, 1998 at 11:26:39:

: I know this is not a DirectX question, but you people are so damned smart and so good at replying that I figured I would start here. I'm just trying to speed up my code a little and wondered if there was an a faster way to set an entire array to zero at runtime. I'm using a loop like this:

: ---------------------------------------
: int array[256][256] ={0};

: //fill array with info
: //use array info

: //clear array
: for (j = 0; j < 256; j++)
: {
: for (i = 0; i < 256; i++)
: {
: array[j][i] = 0;
: }
: }
: ---------------------------------------
: Is there a faster way to set an entire array to zero? Loops sure are slow especially when this is in my main game loop! Also, is there a way to copy an entire array to an equal array without using loops?

: Thanks for any help!

: Johnny

Try to use "ZeroMemory" function!

Follow Ups:

Post a Followup

Name:


Re: Snowman:

Posted by Snowman on July 27, 1998 at 13:58:42:

In Reply to: Re: Snowman: posted by Jumicor on July 27, 1998 at 00:51:50:

I must say, that I don't think I have ever seen anyone use that tactic before, "Aliens have landed on the moon and are plotting their attackagainst Earth?" I was actually quite amussed. I should try it out.

Anyway heres the deal. None of the apps with the book use your wonderfull Voodo card. (They don't use my Voodo card either don't worry.) I have an Adrenaline Rush 3D card. Yes it support texture blending, no it doesn't work with D3D. However it can be done. there are two samples in the SDK (twist and tunnel) that actually aquire a HAL device (and use it), how ever Microsoft was kind enough to exclude those to samples when they put together the source code. Since you have an add on 3D card then you won't be able to use 3D accelleration in a window (I think that's true.)

I am right with you. I have not yet made a program that will use Direct 3D HAL. Clay has told me he knows what to do, but he has not responded to my questions lately.

I have found so many things wierd things with the book, like FOG only works with the windowed apps. It actually looks pretty cool too. When you use the Fullscreen app the FOG won't work.

Moving along, the enum devices function is called like this:

// Enumerate the drivers,
// Setting CurrDriver to -1 initializes the
// driver selection code in enumDeviceFunc
CurrDriver = -1;
rval = lpD3D->EnumDevices(&enumDeviceFunc, &CurrDriver);

if (rval != DD_OK)
return FALSE;

Once you have made that function call, the enumDeviceFunc function is executed (I made that function. It is shown below. I didn't put any code in there because I don't know what to put there! Here it is:

//Here are some variables you will need:
GUID DriverGUID[MAX_DRIVERS]; // GUIDs for the valid D3D drivers
char DriverName[MAX_DRIVERS][50]; // The name of the valid D3D drivers

// The callback function which get the D3D driver's name and GUID.
// Pick the one we want
static HRESULT WINAPI enumDeviceFunc(LPGUID lpGuid, LPSTR lpDeviceDescription, LPSTR lpDeviceName, LPD3DDEVICEDESC lpHWDesc, LPD3DDEVICEDESC lpHELDesc, LPVOID lpContext)
{

//To get the driver, copy it into an array of type GUID
//That is shown below
memcpy(&DriverGUID[NumDrivers], lpGuid, sizeof(GUID));

//The description is copied as follows:
strcpy(&DriverName[NumDrivers][0], lpDeviceName);

//When you are done you need to continue
NumDrivers++;
if (NumDrivers == MAX_DRIVERS)
{
Msg("Reached max drivers");
return (D3DENUMRET_CANCEL);
}
return (D3DENUMRET_OK);
}

Now you can do what ever you want with the two arrays. They contain a short description, and the GUID.

I hope this helps. If there's anything I missed let me know and I'll try and help you.

-Snowman

Follow Ups:

  • Re: Snowman: Jumicor 14:07:50 7/27/98 (1)
    • Re: Snowman: Snowman 20:09:13 7/27/98 (0)

Post a Followup

Name:


Re: Snowman:

Posted by Jumicor on July 27, 1998 at 14:07:50:

In Reply to: Re: Snowman: posted by Snowman on July 27, 1998 at 13:58:42:

Well my matrox card is direct 3d too - will the programs just use that for direct 3d hal? I hope clay helps me because I definetly want to get that blending working. Thanks for the info.

Follow Ups:

  • Re: Snowman: Snowman 20:09:13 7/27/98 (0)

Post a Followup

Name:


HELP! PALETTES!

Posted by Anton on July 27, 1998 at 14:46:51:

hello.

when I create a DirectDrawPalette object

and then when I need to set a new palette during my game,

nothing happens: the screen still black and nothing is changed.
can you give me a solution how to REALLY replace colors???
i use a DirectDrawPalette.SetEntries method to change palettes...

With respect, Anton

Follow Ups:

  • Re: HELP! PALETTES! Nathanael Weiss 18:00:48 8/25/98 (0)

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by Carlos on July 27, 1998 at 14:47:31:

In Reply to: Re: where can I download direct X 5.0 posted by asdfasdf on July 24, 1998 at 15:14:01:

: : where I can get direct X 5.0 please a answer

Follow Ups:

Post a Followup

Name:


Re: Getting a DirectSoundNotify Interface

Posted by syn on July 27, 1998 at 14:57:23:

In Reply to: Getting a DirectSoundNotify Interface posted by Footh on May 28, 1998 at 15:52:34:

i'm having the exact same problem. IID_IDirectSoundNotify does not resolve. All help appreciated

syn

: I am getting an annoying problem while trying to obtain a DirectSoundNotify interface. I am using the exact code from the SDK documentation which looks like this:

: HRESULT hr = lpDsbSecondary->QueryInterface(
: IID_IDirectSoundNotify,
: (LPVOID *)&lpDsNotify)

: Note that I had to add the LPVOID * typecast in the second parameter to get it to compile (why, I don't know, but I can live with it). Anyway, linking is another story. The linker claims that the first parameter (IID_IDirectSoundNotify) is an unresolved external. I thought I had the correct libraries attached and all the necessary header files, but perhaps not. I'm new to Win32 and DirectX programming so I'm hoping that there is something really simple that I missed. Any help would be appreciated.

: Thanks in advance,

: -Footh

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by chris wilson on July 27, 1998 at 15:44:37:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


Newbie with a problem with DCs

Posted by Eas-man on July 27, 1998 at 16:16:56:

Hi, I'm a newbie in DirectX programming, and I have a
very confusing problem, here's the story:

In almost all of the programs that I write that uses
Direct Draw, I always seem to run into a problem when
creating a Device context. At first, my program will
run fine, and creates the DC successfuly when calling
DDColorMatch() or when drawing a bitmap onto my
surface. But after some time and changes, when I
execute my program, It will stop right when I create
a DC, without giving any error messages or anything.
I don't know what I changed in my program that causes
this. All I know is that this problem occurs in my
sprite class, which I have tested extensively, and
which I do not modify. Is there any defines that affect
this?

I'm desperate for a solution

Thanks in advance

Follow Ups:

  • Re: Newbie with a problem with DCs Dave Burrows 04:52:28 7/28/98 (1)
    • Re: Newbie with a problem with DCs Eas-man 19:56:13 7/28/98 (0)

Post a Followup

Name:


Re: Snowman:

Posted by Snowman on July 27, 1998 at 20:09:13:

In Reply to: Re: Snowman: posted by Jumicor on July 27, 1998 at 14:07:50:

: Well my matrox card is direct 3d too - will the programs just use that for direct 3d hal?

I really couldn't tell you. I wish I knew, but I don't. When Clay helps us out, you can always try it out. Sorry I can't help you!

I agree, I also want to get the blending working. I was messing around with some of the SDK samples, The HAL device runs faster (I think) then the Ramp device, and it looks as good as the RGB device.

Did you get the Enumeration of the Device drivers working? I think I put all of the necceserry info on the board for it. I might have missed something though. Just let me know and I'll fix it.

-Snowman

Follow Ups:

Post a Followup

Name:


Help with 2D scrolling

Posted by Jason Rego on July 27, 1998 at 20:21:21:

I must warn everyone that I'm very new to game programming so please excuse me if my question seems stupid :)

I'm trying to write a game which has a large map with
objects moving around it and the player's object runs around this map. The player's object will stay in the
center of the screen with everything scrolling around
him (both horizontally and vertically). I'm looking for help on how to accomplish this scrolling.

My first thought was to draw the whole map into a system memory surface then blit the appropiate rectangle that the player is in to the backbuffer. This seems like it would be too inefficient, having to draw the whole map with all the objects everytime.

Can anyone give me some tips on how to program 2D scrolling or suggest where I can find aticles discussing these things or other gaming algorithms.

Thanks.

Follow Ups:

  • Source code on the way! Johnny Rotten 10:54:42 7/29/98 (0)
  • Re: Help with 2D scrolling Johnny Rotten 10:19:14 7/28/98 (0)
  • Re: Help with 2D scrolling Clay 10:02:12 7/28/98 (0)

Post a Followup

Name:


Re: Can anyone help me with playing a movie?

Posted by Snowman on July 27, 1998 at 20:48:11:

In Reply to: Can anyone help me with playing a movie? posted by Stan Collymore on July 16, 1998 at 22:27:57:

Go to the articles part of the DirectX eXperience, and you will see some source code, and a short article explaining how this is implemented.

Hope this helps

-Snowman

Follow Ups:

Post a Followup

Name:


Please help with D3D HAL Device

Posted by Snowman on July 27, 1998 at 21:14:25:

I can't get it to work. I am getting so sick of this. I've been stuck on this problem for soooo long that I don't even enumerate my devices anymore!!

I have a 3DFX Adrenaline Rush 3D. I've gotten to the point where I am doing this:

//For returns
HRESULT rval;

GUID gu;
gu = IID_IDirect3DHALDevice;

//Create it
rval = lpD3DRM2->CreateDeviceFromSurface(&gu,
lpDD, lpDDSBack, &dev);

Does this work, of course not!! If I use a Ramp or RGB device it works fine. But using a HAL device the function won't even return!! If I use a MMX device (I don't have an MMX system) the function won't return either. This leads me to believe that D3D doesn't think I have a 3D accelerator. Yet there are multipile things that shoot this theory down. One, I will get the Direct3D HAL device if I enumerate them all. (It still won't return if do this first). And two two D3D samples that come with the SDK (tunnel and twist) can both use the Direct 3D HAL device. But of course Microsoft doesn't include the source for these two programs.

I have set up all of the surfaces, and other items already. I am trying to run at 640x480x16. Is there anything else I need to do. What's wrong??

Please help me out here. Thank you in advance if you can help.

-Snowman

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by GREG GREULING on July 27, 1998 at 22:29:29:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Harold on January 18, 1998 at 20:37:49:

: : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


Re: Not a DirectX question! Basic C help

Posted by Jumicor on July 27, 1998 at 23:58:26:

In Reply to: Not a DirectX question! Basic C help posted by Johnny Rotten on July 27, 1998 at 11:26:39:

Why are you setting all the values in an array such as the one you mentioned to zero during your main game loop? Probably the answer is to think of a different way to do whatever you're trying to do.

Follow Ups:

  • Setting array to 0 during main loop Johnny Rotten 10:41:55 7/28/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Susan Johnson on July 28, 1998 at 03:02:21:

In Reply to: Re: Where Can I download DirectX 5.0 posted by wu z on July 21, 1998 at 22:13:19:

: : : : : : Where Can I download DirectX 5.0. I need it for a game
: : : hola pendejo.........

Follow Ups:

Post a Followup

Name:


Re: Lost Surface and failing restore command! Help Needed! Thx

Posted by Dave Burrows on July 28, 1998 at 04:44:10:

In Reply to: Lost Surface and failing restore command! Help Needed! Thx posted by bardya on July 27, 1998 at 09:39:23:

It sounds like you are trying to restore the primary surface after a "SetDisplayMode".

This will not work! You will have to release the surface then create a new one.

Follow Ups:

Post a Followup

Name:


Re: Not a DirectX question! Basic C help

Posted by Dave Burrows on July 28, 1998 at 04:49:47:

In Reply to: Not a DirectX question! Basic C help posted by Johnny Rotten on July 27, 1998 at 11:26:39:

Jumicor is quite right. But just in case.

To clear memory :-
memset(array,0,sizeof(array));
To copy memory :-
memcpy(pointer1,pointer2,sizeofmemory);

will do what you want to do.

Follow Ups:

Post a Followup

Name:


Re: Newbie with a problem with DCs

Posted by Dave Burrows on July 28, 1998 at 04:52:28:

In Reply to: Newbie with a problem with DCs posted by Eas-man on July 27, 1998 at 16:16:56:

Are you releaseing the DC?

Follow Ups:

  • Re: Newbie with a problem with DCs Eas-man 19:56:13 7/28/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by justin on July 28, 1998 at 07:21:17:

In Reply to: Re: Where Can I download DirectX 5.0 posted by bmone on July 19, 1998 at 15:21:44:

:
: : : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


Direct Animation

Posted by SANDAL on July 28, 1998 at 07:43:14:

Where can I find good, additional information on Direct Animation? I'm stuck and need help and there are no good books around.

SANDAL

Follow Ups:

  • Re: Direct Animation mikael 11:16:48 8/09/98 (0)

Post a Followup

Name:


Re: Help with 2D scrolling

Posted by Clay on July 28, 1998 at 10:02:12:

In Reply to: Help with 2D scrolling posted by Jason Rego on July 27, 1998 at 20:21:21:

There are a lot of ways to accomplish this. The best one depends on how much memory you want to use. Since a lot of video cards won't let you create a off-screen surface in video memory that is bigger than the primary surface, you have to create it in system memory. That, of course, means slower blits. Here's what I'd try:

Use full-screen mode so that the primary surface and back buffer are in video memory. When the player moves, you need to draw to the back buffer, so blit the stuff that changes position on screen but doesn't otherwise change appearance from the primary surface to the back buffer.

Here's the tough part: a lot of video cards (notably 3dfx) don't let you make surfaces bigger than the primary surface in video memory OR in system memory. To get around this, make your own "surface" in system memory (an array of bytes works) and build the image that was not on screen before, but needs to be on screen for the next frame in the array. Get a surface memory pointer to your back buffer and do a custom blit from your array to the back buffer. Voila! You're ready to Flip().

This is the memory intensive method, but if you make your custom blitting routines efficient, it will still be pretty fast.

Clay

Follow Ups:

Post a Followup

Name:


Re: Help with 2D scrolling

Posted by Johnny Rotten on July 28, 1998 at 10:19:14:

In Reply to: Help with 2D scrolling posted by Jason Rego on July 27, 1998 at 20:21:21:

Jason,

I have a (mostly) complete 2D engine that uses simple two dimmensional arrays to store maps. The engine has a switch that can toggle between World mode or Boundary mode. In world mode, the player is always in the middle of the screen and the map wraps infinitely. In boundary mode, the player moves toward the edge of the screen when there is no more map to be displayed. Several people have looked at my engine and were very pleased with it's simplicity. It is heavily commented and I would be happy to further explain any algorithms if you need help. E-mail me at jwood@cyberstation.net if you want the source code. That goes for anybody that wants to know more about 2D map programming.

Johnny

: I must warn everyone that I'm very new to game programming so please excuse me if my question seems stupid :)

: I'm trying to write a game which has a large map with
: objects moving around it and the player's object runs around this map. The player's object will stay in the
: center of the screen with everything scrolling around
: him (both horizontally and vertically). I'm looking for help on how to accomplish this scrolling.

: My first thought was to draw the whole map into a system memory surface then blit the appropiate rectangle that the player is in to the backbuffer. This seems like it would be too inefficient, having to draw the whole map with all the objects everytime.

: Can anyone give me some tips on how to program 2D scrolling or suggest where I can find aticles discussing these things or other gaming algorithms.

: Thanks.

Follow Ups:

Post a Followup

Name:


Setting array to 0 during main loop

Posted by Johnny Rotten on July 28, 1998 at 10:41:55:

In Reply to: Re: Not a DirectX question! Basic C help posted by Jumicor on July 27, 1998 at 23:58:26:

I agree that there is definitely a better way - this is temporary at best...

I'm using an Object Array to keep track of characters and items on a map. The array get's its information from a series of linked lists and then is merged with the map array. The reason I have to clear the array is that it gets its information from linked lists and all character's movements are updated... I have to clean up after them or you would see every place that character has been... cloned with every step! Like I said, this is temporary. Eventually the information will come directly from the linked list.

: Why are you setting all the values in an array such as the one you mentioned to zero during your main game loop? Probably the answer is to think of a different way to do whatever you're trying to do.

Follow Ups:

Post a Followup

Name:


Where is DirectX5.0 That will not conflict with Diamond video card

Posted by Stoney Cook on July 28, 1998 at 12:09:22:

I want to know where to download Direct X 5.0 that will not conflict with my diamond 4mb S3 video card

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Jay Carnegie on July 28, 1998 at 12:52:32:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Harold on January 18, 1998 at 20:37:49:

: : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


Transparent Bitmaps in 16, 24 or 32bit colour

Posted by Ragman on July 28, 1998 at 15:33:33:

Can anyone tell me what colour is used for transparency in direct x 16, 24 or 32bit colour depth. In 8bit I know it is 0.

Thanks much

Follow Ups:

  • You specify the color yourself, in any color Depth. HeXeR 00:48:07 7/29/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by wayne hansen on July 28, 1998 at 19:10:48:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


Re: Newbie with a problem with DCs

Posted by Eas-man on July 28, 1998 at 19:56:13:

In Reply to: Re: Newbie with a problem with DCs posted by Dave Burrows on July 28, 1998 at 04:52:28:

: Are you releaseing the DC?

This is the first time creation of the DC

Follow Ups:

Post a Followup

Name:


Intro to DirectX 5.0

Posted by Defender on July 28, 1998 at 20:33:00:

Okay. I am a new student interesting in learning DirectX
programming and uses MSVC 5.0 as a primary programming language
So, what is DirectX and is there any VC++ library that I could download
and use it in my program?

Any recommandation on any good DirectX books is appreciated.
Thanks.

Follow Ups:

Post a Followup

Name:


Hey Jumicor!

Posted by Snowman on July 28, 1998 at 21:07:51:

I think I am getting a step further in your problem (unfortunetly not mine). Since you have an add-on 3D card, you need to enumerate your Direct Draw GUIDs. You do this by calling the DirectDrawEnumerate() function. This will help you, because your 2D and 3D cards both have seperate GUIDs. My card is an all in one solution, so there is one GUID.

Have you gotten any further on the problem?

I am still stuck with my problem, and no one is responding to my posts. I am starting to get frustrated. Oh well, there's not much I can do. I get all excited, and try something new, but it doesn't work. I have found nothing but dead ends.

Anyway, I hope this will help you.

-Snowman

Follow Ups:

  • Re: Hey Jumicor! Jumicor 01:42:15 7/29/98 (1)
    • Re: Hey Jumicor! Snowman 14:19:46 7/29/98 (0)

Post a Followup

Name:


Hello...Clay....Are you there...

Posted by Snowman on July 28, 1998 at 21:30:39:

I don't mean to be rude or pushy or anything like that, but I'm frustrated. Can you please help me get HAL working. I have been stuck on this problem for a month or so. Everything I try leads to a dead end. The wrong Bit depth, the wrong DirectDraw device, not the right GUID... but no matter what happens, I still can't get it to work. Please take a look at my post entitled: "Please help with D3D HAL" It contains other neccesary information. Please talk to me. I am getting so frustrated with this stuff.

Thank you for your time.

-Snowman

Follow Ups:

  • Re: Hello...Clay....Are you there... Jumicor 01:23:05 7/29/98 (1)
    • Re: Hello...Clay....Are you there... Snowman 14:55:26 7/29/98 (0)

Post a Followup

Name:


Offscreen Plain Surfaces: Is it fast? Or is is dumb?

Posted by HeXeR on July 29, 1998 at 00:29:45:

I have recently read a book by Andre LaMothe about
DirectX and game programming (I recommend it to any
beginner in DirectX.)
Anyways, I remember one part where he introuces the
offscreen plain surfaces, which are surfaces that are
used to store bitmap sprites etc... In there he says
that the advantage of using these surfaces is that
DirectDraw will put them in VRAM if available and
use hardware blitter.
Now, I though, one of my friends told me, what if there
is not enough VRAM and Blitter will have to constantly
cross the BUS, 100 times a frame, to blit each sprite?
Is that a problem? Or does DirectX take care of that
and assembles the images in system memory then copies?
Thanks, hopefully I can hear from some DirectXperts..
If its true or not...

Follow Ups:

  • Re: Offscreen Plain Surfaces: Is it fast? Or is is dumb? Clay 07:49:52 7/29/98 (0)

Post a Followup

Name:


You specify the color yourself, in any color Depth.

Posted by HeXeR on July 29, 1998 at 00:48:07:

In Reply to: Transparent Bitmaps in 16, 24 or 32bit colour posted by Ragman on July 28, 1998 at 15:33:33:

It's called Color Keying, here is how it's done:

DDCOLORKEY key; // Color key structure

key.dwColorSpaceLowValue = 0; // (THis is a DoubleWord RGB 0
key.dwColorSPaceHighValue = 0; //(Also DoubleWord)

source_surface->SetColorKey(DDKEY_SRCBLT, &key);

The next time you call Blt() to blit from source_surface
into primary or backbuffer, it will not blit the RGB 0 colors...
Also, you can set a range of color key values, for example
low RGB 0,0,0 and high RGB 255,0,0 will not blit any kind of red...

Hopefully that helps..

Follow Ups:

Post a Followup

Name:


Re: Hello...Clay....Are you there...

Posted by Jumicor on July 29, 1998 at 01:23:05:

In Reply to: Hello...Clay....Are you there... posted by Snowman on July 28, 1998 at 21:30:39:

He's been contacting me by email. You should fill out your email address when you make your post.

Follow Ups:

  • Re: Hello...Clay....Are you there... Snowman 14:55:26 7/29/98 (0)

Post a Followup

Name:


How does one write text on the screen in a windowed application with directdraw and direct3d initialised?

Posted by Jumicor on July 29, 1998 at 01:36:33:

see subject

Follow Ups:

  • Re: How does one write text on the screen in a windowed application with directdraw and direct3d initialised? Jumicor 10:43:44 7/29/98 (1)
    • Oooops... The previous post is from Johnny, not Jumicor! Johnny 10:45:58 7/29/98 (0)

Post a Followup

Name:


Re: Hey Jumicor!

Posted by Jumicor on July 29, 1998 at 01:42:15:

In Reply to: Hey Jumicor! posted by Snowman on July 28, 1998 at 21:07:51:

I'm a real newbie at direct x. It's gonna take me some time just to try out all the new things I've learned from you and Clay(btw I really appreciate your help and I hope you'll stick around in this forum as I progress). It's going slow right now because of......work.

Follow Ups:

  • Re: Hey Jumicor! Snowman 14:19:46 7/29/98 (0)

Post a Followup

Name:


Re: Offscreen Plain Surfaces: Is it fast? Or is is dumb?

Posted by Clay on July 29, 1998 at 07:49:52:

In Reply to: Offscreen Plain Surfaces: Is it fast? Or is is dumb? posted by HeXeR on July 29, 1998 at 00:29:45:

Yes and no: it depends on the hardware manufacturer. I think it is possible to "cache" a series of blits from system memory into one big bus transfer, but I have no idea what (if any) hardware/driver is capable of doing it. I would store the sprites separately; that is, not even on a surface, just put them in their own array in memory and custom blit that to the off-screen (system memory or not) surface and do a source color keyed blit to the screen/backbuffer. Most newer hardware supports source color keying directly.

Clay

Follow Ups:

Post a Followup

Name:


Sharing Code

Posted by Clay on July 29, 1998 at 07:59:30:

All,

There seems to be more participants than ever on the forum. A lot of us are new to DirectX, new to C/C++, or new to game programming in general.

In light of that, I sent an email to the author asking him to set up a FTP site to make sharing code easier (some of us are not able to receive attachments through email). I think we'd all agree that it is easier to talk about code you can see!

POSSIBLE ADVANTAGES:
1) I'd rather send code to one place than to 10
2) It makes it possible for anyone who needs the code to get it
3) "Old" code can be archived, un-cluttering the ftp site (unlike the Forum is now -- HUGE)

POSSIBLE DISADVANTAGES:
1) We'd be more open to crappy code (authentication may help -- see 2) )
2) It should have some kind of authentication to prevent general use
3) I hope it can be made free

Any takers?

Clay

Follow Ups:

  • Sharing Code and knowledge Ravi Joshi 02:17:44 7/30/98 (0)
  • Re: Sharing Code Snowman 15:06:25 7/29/98 (0)

Post a Followup

Name:


Re: Don;t read one pixel at a time??

Posted by Junior McMillan on July 29, 1998 at 08:56:09:

In Reply to: Re: Don;t read one pixel at a time?? posted by Gunnar on July 25, 1998 at 11:46:39:

:
: I havn't yet gotten into the PCI bus read
: problems, but there is a high possibilty
: that reading-writing-reading-writing makes
: the PCI bus (AGP??) perform at it's worst.
: (buffering, etc)

: To me the best solution would be to blit the
: screen to system memory, write a tight
: optimised, unrolled loop (8 pixels at time),
: preferably using some few right shifts instead of
: multiplies, and then blit back to the screen??

why loop at 8 pixels at a time? cache reasons??

I have a workbuffer in System memory, and a clut.
and am fading blitting this *every* frame at the moment.
I will be looking into timeslicing thiswhen the
fade works ok.
I am already shifting the rgb values to fit into
bytes then placing in a table. problems I can see
are just memory usage. 800*600*16bpp = 1.4 meg lookup table
and then if you buffer the screen in system memmory,
that's another 938k.

: As this amount of data will be larger than the
: internal L1 data cache, it might be faster to
: blit in 8kb (16kb) chunks, so that the data
: fits the internal cache??
do you mean: fade 8k portions, then blit those 8k
portions? and would that mean on the first read
8k gets stuffed on the cache, so that software
blitting would be almost transparent (time wise) ??

: Hope this helps?? Gunnar
thanx for that. it has given me a couple of new ideas!

Junior

Follow Ups:

Post a Followup

Name:


Re: I need Urgent Help with DirectX and Windows 98- Please Read

Posted by fred on July 29, 1998 at 10:41:18:

In Reply to: Re: I need Urgent Help with DirectX and Windows 98- Please Read posted by Craig Edelstein on July 26, 1998 at 14:53:37:

: So you just think I should reinstall Windows98? :(

guess you dont want to do that, a bit of hassle on reinstalling win98, [consider you might need to reinstall all of your apps as well]

: Or is there anything else I can do? I do not have a graphics accelerator at the moment, I play on getting one if I can get it to work now, no point in buying one if it won't work with my video card at the moment.

directX6 will be release within a week,

I don't know much about Quake2, [i persionally hate this game, makes me dizzy]. As far as i remember, at first, it brings up a window, where show some moving game scene. and you have menu on this window which allow you 'start a new game' 'option' ...etc etc. if you can get this window, go into option, try different OpenGL driver in the video config. [well, it _may_ help, i dont know] however, if you can't even get into this window, maybe 'Quake2' don't like your video card/video driver. [or _maybe_ your video driver got somekind of problem, hehe]

A p5-233mmx +Trident video card is far from enough for quake2,[ consider people have pII-233+voodoo2 still crying for the frame rate]. And honestly [no offensive], a Trident 9680 video card is CRAPPY enough!

Follow Ups:

Post a Followup

Name:


Re: How does one write text on the screen in a windowed application with directdraw and direct3d initialised?

Posted by Jumicor on July 29, 1998 at 10:43:44:

In Reply to: How does one write text on the screen in a windowed application with directdraw and direct3d initialised? posted by Jumicor on July 29, 1998 at 01:36:33:

: see subject

Jumicor,

You have to get a handle to a DC (I think it's GetDC()) and then you can write to the screen using just about any screen printing method. However, this is not recommended because it will slow your application. Write an algorithm (or use the on provided in the space donuts game) to blit the desired letters to your back buffer and then flip(). This is a much faster method and you'll probably be a lot happier with the look.

Johnny

Follow Ups:

  • Oooops... The previous post is from Johnny, not Jumicor! Johnny 10:45:58 7/29/98 (0)

Post a Followup

Name:


Oooops... The previous post is from Johnny, not Jumicor!

Posted by Johnny on July 29, 1998 at 10:45:58:

In Reply to: Re: How does one write text on the screen in a windowed application with directdraw and direct3d initialised? posted by Jumicor on July 29, 1998 at 10:43:44:

Sorry!

Follow Ups:

Post a Followup

Name:


Source code on the way!

Posted by Johnny Rotten on July 29, 1998 at 10:54:42:

In Reply to: Help with 2D scrolling posted by Jason Rego on July 27, 1998 at 20:21:21:

For every one that's mailed me asking for the source code, it will hopefully be in your mail boxes tonight. I am in the middle of a move and my computer at home is not set up. It should be tonight and I'll send it on it's way.

Sorry about the wait!

Johnny

Follow Ups:

Post a Followup

Name:


Re: where can I download direct X 5.0

Posted by IP Freely on July 29, 1998 at 13:14:13:

In Reply to: where can I download direct X 5.0 posted by Yves Lavoie on February 06, 1998 at 23:01:14:

You can download Direct X 5.0, the porno version from www.phukfriends.com

Follow Ups:

Post a Followup

Name:


Re: download DirectX 5.0

Posted by KEBIR on July 29, 1998 at 13:40:54:

In Reply to: download DirectX 5.0 posted by Roman Kaykov on July 16, 1998 at 21:14:29:

: :
: : :
: : : : Where Can I download DirectX 5.0. I need it for an emulator.
: : And for games

Follow Ups:

Post a Followup

Name:


Re: Hey Jumicor!

Posted by Snowman on July 29, 1998 at 14:19:46:

In Reply to: Re: Hey Jumicor! posted by Jumicor on July 29, 1998 at 01:42:15:

There it is. A while back Clay gave me his email, but it didn't work. I really hope you will Email me Clay (If you are reading this). Feel free to send me your questions Jumicor. I will help you if I can. Next time you send some Email to Clay, could you mention I need some help too. My Email address is: snowman_83@yahoo.com. Thank you!

-Snowman

Follow Ups:

Post a Followup

Name:


Re: Hello...Clay....Are you there...

Posted by Snowman on July 29, 1998 at 14:55:26:

In Reply to: Re: Hello...Clay....Are you there... posted by Jumicor on July 29, 1998 at 01:23:05:

There it is. A while back Clay gave me his email, but it didn't work. I really hope you will Email me Clay (If you are reading this). Feel free to send me your questions Jumicor. I will help you if I can. Next time you send some Email to Clay, could you mention I need some help too. My Email address is: snowman_83@yahoo.com. Thank you!

-Snowman

Follow Ups:

Post a Followup

Name:


Re: Sharing Code

Posted by Snowman on July 29, 1998 at 15:06:25:

In Reply to: Sharing Code posted by Clay on July 29, 1998 at 07:59:30:

I agree with you Clay. If there was an FTP site then a lot of the questions would but cut down, thus uncluttering the forum and in the long run making it easier to use.

You wouldn't have people asking how to use HAL devices or fog, they would just go get an example. Then they would only ask if they had a problem with that example. Also, people wouldn't ask the same question a month later. Because the answer would always be there.

-Snowman

Follow Ups:

Post a Followup

Name:


off topic - anyone tried gamepc.com

Posted by John on July 29, 1998 at 17:29:10:

Hi I was wondering if anyone had tried the computer
retailer GamePC at gamepc.com Is it a good place or
is it just another internet scam?
-John

Follow Ups:

Post a Followup

Name:


How do I create DD surfaces out of array buffer?

Posted by HeXeR on July 29, 1998 at 17:52:05:

As I know, creating surfaces to store sprites in VRAM is a bad idea, also
assembling images in VRAM could cost prformance as you would have to cross
the BUS for each sprite blit. Especuially with scrolling
also some cards dont allow creating backbuffer bigger
than primary.. SO the solution is to create an array
and attch the surface pointer..
but how do I make a surface out of an array buffer
that os om system memory?

Follow Ups:

Post a Followup

Name:


Sharing Code and knowledge

Posted by Ravi Joshi on July 30, 1998 at 02:17:44:

In Reply to: Sharing Code posted by Clay on July 29, 1998 at 07:59:30:

HI to all,
I agree with Clay that the site is becoming huge.
Setting up an FTP would make sharing code simpler
and will help uncluttering this site.
This site should be ideally a forum and the ftp
site should work basically as a knowledge base.
Anyone who has a question will first look at the FTP
and only if he doesn't find it there, he could post a
question. This can be done by collectively sharing
the responsibility of making this site better.
Thanks
Ravi Joshi.
India

Follow Ups:

Post a Followup

Name:


I am the biggest debutant you have ever seen

Posted by Joachim Sene on July 30, 1998 at 05:28:33:

Hello.

I want to know how to begin direct X programming.
books, developper kit etc.

I am not a winker for programmation, but I have NEVER
programming things with direct X, and moreover, NOTHING
for WindoWs.

Thank you all,
-JoachiM

Follow Ups:

Post a Followup

Name:


Question about Visual C++ and DirectX

Posted by Bob on July 30, 1998 at 11:08:32:

things u might need to know

- i am pretty sure i have directx 5 sdk and visual c++ setup okay

- i am a programmer with very little windows programming exp (mostly unix and vb, go figure)

basically when i try to creat a minimal app with directx, i know that my app compiles ok, but it runs into a linking error LNK2001 unresolved symbol _main. in the help it has a host of possible causes, but i was wondering if someone knew right away so i could get started.

bob

Follow Ups:

  • Re: Question - I may have the solution Travis 14:37:09 9/07/98 (0)
  • Re: Question about Visual C++ and DirectX Dave Burrows 04:14:52 8/03/98 (0)
  • Re: Question about Visual C++ and DirectX Rob 21:10:41 7/31/98 (0)
  • Re: Question about Visual C++ and DirectX David Naughton 14:50:24 7/31/98 (0)
  • Re: Question about Visual C++ and DirectX Nat 16:32:46 7/30/98 (1)
    • Re: Question about Visual C++ and DirectX bob 10:22:30 8/05/98 (0)

Post a Followup

Name:


HELP! DirectShow lousy from CD-ROM!

Posted by John Giors on July 30, 1998 at 15:01:32:

I'm having a terrible time getting DirectShow to run
on our "lower-end" systems (up to 200 MHz CPUs). On
most systems, the audio plays fine, but the video
either: (1) gets horribly out-of-sync, or (2) drops
way too many frames--some systems only display one
frame every few seconds!

Slide shows are not exciting.

The problems ONLY occur when using DirectShow with
CD-ROM (The same animation played properly from
hard-disk).

If I play the file using the ActiveMovie control, it
plays just fine (with a few frame drops, which is
acceptable).

I'm using the Cinepak video CODEC and ADPCM audio
CODEC. The data rate is approximately 550 KB/Sec,
which should be well within the capabilities
of our 8X and higher CD-ROMs.

If anyone can help, many thanks...

-- John Giors
Software Engineer
Eagle Interactive

Follow Ups:

Post a Followup

Name:


3D Objects

Posted by Emil Diego on July 30, 1998 at 16:18:05:

Are there any good shareware utilities out there for createing 3D Objects that can be easily included into a directx application.

Follow Ups:

  • Re: 3D Objects mikael 11:14:35 8/09/98 (0)

Post a Followup

Name:


Re: Question about Visual C++ and DirectX

Posted by Nat on July 30, 1998 at 16:32:46:

In Reply to: Question about Visual C++ and DirectX posted by Bob on July 30, 1998 at 11:08:32:

DO you have a WinMain??

: things u might need to know

: - i am pretty sure i have directx 5 sdk and visual c++ setup okay

: - i am a programmer with very little windows programming exp (mostly unix and vb, go figure)

: basically when i try to creat a minimal app with directx, i know that my app compiles ok, but it runs into a linking error LNK2001 unresolved symbol _main. in the help it has a host of possible causes, but i was wondering if someone knew right away so i could get started.

: bob

Follow Ups:

  • Re: Question about Visual C++ and DirectX bob 10:22:30 8/05/98 (0)

Post a Followup

Name:


DirectShow Destroys Window

Posted by Ken Moore on July 30, 1998 at 18:04:43:

I'm writing an app that used direct show to play a predefined list of video files. The problem I'm having is when I've been playing a file and I render a new file. When I render the new file the current rendering window is automatically destroyed. This creates an undesirable screen flash when transitioning between files. Can anybody recommend a workaround for this?

Thanks,
Ken

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by mauricio rojas on July 30, 1998 at 22:16:45:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

  • Re: Where Can I download DirectX 5.0 mauricio rojas 22:21:16 7/30/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by mauricio rojas on July 30, 1998 at 22:21:16:

In Reply to: Re: Where Can I download DirectX 5.0 posted by mauricio rojas on July 30, 1998 at 22:16:45:

: : Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


DirectX6 FINAL RELEASE!

Posted by A DX6 beta tester on July 31, 1998 at 00:30:54:

The FINAL version of DirectX6/SDK will be released with in 24 hours!

Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

  • DirectX6 FINAL RELEASE! ttt 17:38:47 9/24/98 (0)
  • Re: DirectX6 FINAL RELEASE! michael d. henning 22:11:16 9/22/98 (0)
  • Re: DirectX6 FINAL RELEASE! dxptt 01:00:14 8/28/98 (2)
    • Re: DirectX6 FINAL RELEASE! t.sato 09:25:18 8/28/98 (1)
      • Re: DirectX6 FINAL RELEASE! vincenzo 07:08:37 9/08/98 (0)
  • Re: DirectX6 FINAL RELEASE! Pujanias 12:04:17 8/27/98 (0)
  • Re: DirectX6 FINAL RELEASE! mikael 11:12:52 8/09/98 (10)
    • Re: DirectX6 FINAL RELEASE! Rick Larew 15:16:59 9/30/98 (0)
    • Re: DirectX6 FINAL RELEASE! rtr 17:36:31 9/24/98 (0)
    • Re: DirectX6 FINAL RELEASE! Vladimir Mitev 16:29:20 9/02/98 (2)
      • Re: DirectX6 FINAL RELEASE! David Mendes 15:40:18 9/28/98 (0)
      • Re: DirectX6 FINAL RELEASE! Niki 17:55:01 9/03/98 (0)
    • Re: DirectX6 FINAL RELEASE! JOHN 21:03:11 9/01/98 (1)
      • Re: DirectX6 FINAL RELEASE! john reece 22:56:55 9/01/98 (0)
    • Re: DirectX6 FINAL RELEASE! STAS MIDURA 14:20:46 9/01/98 (0)
    • Re: DirectX6 FINAL RELEASE! Steve Borman 06:34:57 8/29/98 (1)
      • Re: DirectX6 FINAL RELEASE! Roxanne Bryant 14:56:03 8/30/98 (0)

Post a Followup

Name:


2D Tile Game Source Code

Posted by Johnny Rotten on July 31, 1998 at 01:25:52:

Thanks to everyone that wrote to me asking for the 2D Tile Game source code. I was surprised to see so many people write! Instead of mailing the code to everyone, I have put up a temporary site at http://www.cyberstation.net/~jwood/. I'm not sure if it will become permanent, but for now it will stay and I would be happy to put other 2D source code on there.
Sorry about the delay on this...

Johnny

  • Get the source code here

Follow Ups:

  • Source Code Page back up!! Johnny 15:44:45 8/05/98 (0)

Post a Followup

Name:


Newbie needs DirectDraw help

Posted by Jeremy on July 31, 1998 at 01:31:12:

Hi. I was hoping someone might be able to help with
what I hope is a simple problem. All I'm trying to do
is get a sprite to rotate. I've successfully blitted
the image using Blt(), but when I add the control flag,
DDBLT_ROTATIONANGLE, the image is no longer displayed.
It doesn't matter what I set dwRotationAngle to. I set
up the size of the DDBLTFX structure and cleared the
memory before using Blt(). Any ideas what I may be
doing wrong. Any help is greatly appreciated.

Follow Ups:

  • Re: Newbie needs DirectDraw help Clay 20:26:31 8/03/98 (0)

Post a Followup

Name:


Re: Question about Visual C++ and DirectX

Posted by David Naughton on July 31, 1998 at 14:50:24:

In Reply to: Question about Visual C++ and DirectX posted by Bob on July 30, 1998 at 11:08:32:

You are probably used to starting your programs with something like 'void main()'. In Win32 applications the code starts with something like:

int WINAPI WinMain(HINSTANCE hInstance, HINSTANCE hPrevInstance, LPSTR lpCmdLine, int nCmdShow)

try replacing your 'void main()' with what's given above (and don't forget a return value in your code)

: things u might need to know

: - i am pretty sure i have directx 5 sdk and visual c++ setup okay

: - i am a programmer with very little windows programming exp (mostly unix and vb, go figure)

: basically when i try to creat a minimal app with directx, i know that my app compiles ok, but it runs into a linking error LNK2001 unresolved symbol _main. in the help it has a host of possible causes, but i was wondering if someone knew right away so i could get started.

: bob

Follow Ups:

Post a Followup

Name:


Re: Question about Visual C++ and DirectX

Posted by Rob on July 31, 1998 at 21:10:41:

In Reply to: Question about Visual C++ and DirectX posted by Bob on July 30, 1998 at 11:08:32:

Actually, you're missing a .lib file. Seems everybody who starts in this forgets including me. I don't remember which one, but it's probably ddraw.lib. Makesure it'sin your /lib directory.

Follow Ups:

Post a Followup

Name:


IM vs RM

Posted by Snowman on August 01, 1998 at 18:55:08:

Which Direct3D mode would you recommend? Is RM powerful enough to make games? Is it worth it to give up the easy interface of RM to get the speed of IM?

If you have an oppinion please let me know, or if you just have information on the subject. Thanks!

-Snowman

Follow Ups:

Post a Followup

Name:


Help Me Now Please

Posted by Tyler Smith on August 01, 1998 at 21:13:23:

Can sombody tell me where I can get DirectX 5.0 or better.

Follow Ups:

  • Re: Help Me Now Please Tobias Minich 22:10:47 8/01/98 (0)

Post a Followup

Name:


Re: Help Me Now Please

Posted by Tobias Minich on August 01, 1998 at 22:10:47:

In Reply to: Help Me Now Please posted by Tyler Smith on August 01, 1998 at 21:13:23:

: Can sombody tell me where I can get DirectX 5.0 or better.
Try http://www.microsoft.com/directx/resources/dx5end.htm

Follow Ups:

Post a Followup

Name:


PLEASE HELP ME!!!!!!!!!!

Posted by Tex Murphy on August 02, 1998 at 01:33:32:

I have been trying to get Direct X 5 to work on my computer for a long time.

I have it on my hard drive but when I psh install on any game that needs it (to re-install Direct X 5) it gives me this message:

DirectX Setup Initialization Failed

DirectX Setup error -9

I need to know what I need to do.

And also, when I am tryin to start Tex Murphy: Overseer, it gives me this message:

DirectDraw Init Failed

PLEASE HELP ME!!!

Follow Ups:

Post a Followup

Name:


How to loop samples from an offset

Posted by Qinglai on August 02, 1998 at 12:01:59:

I am writing a mod player using directx.
The main problem I faced is how to loop samples from an
offset. There is a flag DSB_LOOP to set the sound buffer
looping. However, it loops from the start of the sample
and there is no way to specify how to loop it from an
offset. Any help and suggestions are welcomed. Thanx.

Follow Ups:

  • Re: How to loop samples from an offset Jonas 21:38:21 8/03/98 (0)

Post a Followup

Name:


BIG FUCKING DIRECTX 5.2 PROBLEM

Posted by Donald Ames on August 02, 1998 at 13:58:04:

I need help!

I just bought the game Tex Murphy: Overseer and it requires DirectX 5 to play. The problem is that I can't install DirectX 5.2 because when I try, these messages pop up and say DirectX Initialization Failed and DirectX setup error -9.

Can anyone tell me what to do?

Follow Ups:

Post a Followup

Name:


Re: Question about Visual C++ and DirectX

Posted by Dave Burrows on August 03, 1998 at 04:14:52:

In Reply to: Question about Visual C++ and DirectX posted by Bob on July 30, 1998 at 11:08:32:

: things u might need to know

: - i am pretty sure i have directx 5 sdk and visual c++ setup okay

: - i am a programmer with very little windows programming exp (mostly unix and vb, go figure)

: basically when i try to creat a minimal app with directx, i know that my app compiles ok, but it runs into a linking error LNK2001 unresolved symbol _main. in the help it has a host of possible causes, but i was wondering if someone knew right away so i could get started.

: bob

Have you chosen a "Console Application" by mistake. This would mean the linker is looking for a "_main" function instead of a "_winmain".

Follow Ups:

Post a Followup

Name:


Call for online editors

Posted by Wolfgang Engel on August 03, 1998 at 05:53:43:

http://www.netit.net/direct3d/ the Direct3D IM site and http://www.netit.net/powerr the PowerRender site are searching for online editors. You could edit online the news section. Write tutorials for the tutorials section and ... whatever you want. Every article will take your name and whatever you like (URL of Webserver etc.).
Please contact me at wengel4u@aol.com.

Follow Ups:

Post a Followup

Name:


How to use colorkey between Overlay surface and Primary surface?

Posted by Bond Chen on August 03, 1998 at 06:21:32:

I use an overlay surface to display my work.
The overlay surface is always on top as many guys
know. However, I need it to act as ordinary windows
since I attach it with a window. I think the color
key can solve my problem. But I have difficulty in
use color key applied in such case. Would any body
have any idea about that? Or is there any sample
can be found?

Any help would be appreciated. Thanx in advance.

bond@ccca.nctu.edu.tw

Follow Ups:

Post a Followup

Name:


Error loading DirectDraw... PLEASE HELP!! :)

Posted by DirectX-=nEwBiE=- on August 03, 1998 at 12:45:57:

When I load a program that requires DirectDraw, it gives me a message box saying "beta DirectDraw expired, please update"

CAN SOMEONE HELP ME WIT' THIS?

Follow Ups:

  • Re: Error loading DirectDraw... PLEASE HELP!! :) Sompong Rattanasang 07:48:48 8/31/98 (0)

Post a Followup

Name:


I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT*

Posted by Tex Murphy on August 03, 1998 at 19:54:59:

*NT*

Follow Ups:

  • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* Clay 20:33:08 8/03/98 (7)
    • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* Dave Burrows 04:17:27 8/04/98 (0)
    • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* Tex Murphy 21:23:19 8/03/98 (5)
      • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* ding@ 01:01:47 8/04/98 (4)
        • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* Tex Murphy 13:22:59 8/04/98 (3)
          • advice for newbie owlsley 00:06:12 8/07/98 (2)
            • Re: advice for newbie Tex Murphy 12:09:06 8/07/98 (1)
              • Re: advice for newbie satan 15:22:41 8/10/98 (0)

Post a Followup

Name:


Re: Newbie needs DirectDraw help

Posted by Clay on August 03, 1998 at 20:26:31:

In Reply to: Newbie needs DirectDraw help posted by Jeremy on July 31, 1998 at 01:31:12:

That flag is not supported in DirectX 5. Go figure. I had the same problem a few months ago, but that post is somewhere near the bottom of this huge page.

Clay

Follow Ups:

Post a Followup

Name:


Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT*

Posted by Clay on August 03, 1998 at 20:33:08:

In Reply to: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* posted by Tex Murphy on August 03, 1998 at 19:54:59:

Easy there, Beavis! Most of us don't check the page hourly!!! There could be several problems:

1) You need a video card and driver that are DirectX compatible (with the version of DirectX you need to use!). Check with your card manufacturer to make sure.

2) Do you have the right version of DirectX? It probably comes with the game, so this usually isn't a problem.

3) There may be a problem with your DirectX installation. Try uninstalling and reinstalling DirectX.

Also, it helps to know the specific hardware configuration you're having trouble with. It is pretty rare, but some hardware conflicts may exist.

Clay

Follow Ups:

  • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* Dave Burrows 04:17:27 8/04/98 (0)
  • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* Tex Murphy 21:23:19 8/03/98 (5)
    • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* ding@ 01:01:47 8/04/98 (4)
      • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* Tex Murphy 13:22:59 8/04/98 (3)
        • advice for newbie owlsley 00:06:12 8/07/98 (2)
          • Re: advice for newbie Tex Murphy 12:09:06 8/07/98 (1)
            • Re: advice for newbie satan 15:22:41 8/10/98 (0)

Post a Followup

Name:


Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT*

Posted by Tex Murphy on August 03, 1998 at 21:23:19:

In Reply to: Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* posted by Clay on August 03, 1998 at 20:33:08:

: Easy there, Beavis! Most of us don't check the page hourly!!! There could be several problems:

: 1) You need a video card and driver that are DirectX compatible (with the version of DirectX you need to use!). Check with your card manufacturer to make sure.

: 2) Do you have the right version of DirectX? It probably comes with the game, so this usually isn't a problem.

: 3) There may be a problem with your DirectX installation. Try uninstalling and reinstalling DirectX.

: Also, it helps to know the specific hardware configuration you're having trouble with. It is pretty rare, but some hardware conflicts may exist.

: Clay

These are the messages I am getting.

DirectX setup Initiation failed when I am trying to install it and after that, this message shows up, DirectX setup error -9

When I thought I had it on my computer, I tried to start the game Tex Murphy: Overseer and this message popped up, DirectDraw init failed.

What is the problem? I need to know

Follow Ups:

  • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* ding@ 01:01:47 8/04/98 (4)
    • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* Tex Murphy 13:22:59 8/04/98 (3)
      • advice for newbie owlsley 00:06:12 8/07/98 (2)
        • Re: advice for newbie Tex Murphy 12:09:06 8/07/98 (1)
          • Re: advice for newbie satan 15:22:41 8/10/98 (0)

Post a Followup

Name:


Re: How to loop samples from an offset

Posted by Jonas on August 03, 1998 at 21:38:21:

In Reply to: How to loop samples from an offset posted by Qinglai on August 02, 1998 at 12:01:59:

: I am writing a mod player using directx.
: The main problem I faced is how to loop samples from an
: offset. There is a flag DSB_LOOP to set the sound buffer
: looping. However, it loops from the start of the sample
: and there is no way to specify how to loop it from an
: offset. Any help and suggestions are welcomed. Thanx.

The First thing that you have to do is make sure that all DirectSound and DirectSoundBuffer code are kept seperate from your actual MOD code. Why? Simple, your MOD player's code has one function only; Play MOD Files! Most Importantly, is how you are loading the MOD samples. Do you keep them 8bit unsigned or convert them to 16bit signed? I convert mine to 16bit signed filter them to eliminate clipping and then lastly load them into a direct sound Buffer by default, but can also handle 8bit samples without changeing a sngle line of existing code. When hardware mixing is available i actually keep two coppies of the sample in a parralell list. Why? what happens if I run out of Hardware Buffers and I nd to duplicate that sample because I have to play it with out stopping the current one and it is in Hardware? the call fails, so I use the software one instead. Any wasy, getting back to your original ? In my sample structure i set certain flags like if it is a looping Sample, if so where does it start looping from and where does it end? Along with my Dynamic MOD Effects structure(only allocates one per channel instead of a static array) I have a seperate Dynamic DirectSound Effect Structure (again one for each channel) that tells me how to interpret the sample that is being requested to be played. Well I'll let you figure out the details but the gist of it is if you have a looping sample that is playing, you must use IDirectSoundBuffer::GetCurrentPosition() method and after you have decided what to do with the Position you then set the position with IDirectSoundBuffer::SetCurrentPosition() . it is that simple. any more questions please feel to e-mail me.

Follow Ups:

Post a Followup

Name:


DirectX 6 totally screwed my Monster 3dII accelerator card

Posted by Monster 3d II owner on August 03, 1998 at 22:43:37:

I downloaded DirectX 6 and now I cant play any games that require a 3d card. They all used to work fine before I downloaded it. I tried re-installing directX 5 but that didnt help. Can one of you all tell me how to fix my problem? ANY advice would be greatly appreciated.

Follow Ups:

  • Re: DirectX 6 totally screwed my Monster 3dII accelerator card ding@ 00:56:18 8/04/98 (4)
    • Re: DirectX 6 totally screwed my Monster 3dII accelerator card Monster 3d II owner 02:13:54 8/04/98 (3)
      • Re: DirectX 6 totally screwed my Monster 3dII accelerator card ding@ 06:46:50 8/04/98 (2)
        • I tried all that stuff :( Monster 3d II owner 07:35:52 8/04/98 (1)
          • Re: I tried all that stuff :( Matthew Wright 04:11:28 9/06/98 (0)

Post a Followup

Name:


Re: DirectX 6 totally screwed my Monster 3dII accelerator card

Posted by ding@ on August 04, 1998 at 00:56:18:

In Reply to: DirectX 6 totally screwed my Monster 3dII accelerator card posted by Monster 3d II owner on August 03, 1998 at 22:43:37:

what version have you downloaded??,

DX5 can not be installed over DX6 because the installer in DX5 finds NEWER version of DX on your computer.

Try RE-download and reinstall DX6 when it is OFFICALLY out.

[installing a beta is NO help at all]

Follow Ups:

  • Re: DirectX 6 totally screwed my Monster 3dII accelerator card Monster 3d II owner 02:13:54 8/04/98 (3)
    • Re: DirectX 6 totally screwed my Monster 3dII accelerator card ding@ 06:46:50 8/04/98 (2)
      • I tried all that stuff :( Monster 3d II owner 07:35:52 8/04/98 (1)
        • Re: I tried all that stuff :( Matthew Wright 04:11:28 9/06/98 (0)

Post a Followup

Name:


Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT*

Posted by ding@ on August 04, 1998 at 01:01:47:

In Reply to: Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* posted by Tex Murphy on August 03, 1998 at 21:23:19:

: These are the messages I am getting.

: DirectX setup Initiation failed when I am trying to install it and after that, this message shows up, DirectX setup error -9

: When I thought I had it on my computer, I tried to start the game Tex Murphy: Overseer and this message popped up, DirectDraw init failed.

: What is the problem? I need to know

You need to provide your computer's configu, for example, what is your video card, processer, ram. window version. and so on.. in more detail.

NO one could give you an answer without any knowledge on your computer

[and pls, before you shout out for 'FUCKING BRAIN' to the people in this forum. NO one has a 'Fucking' brain here, they have brain, but not 'fucking']

If you dont respect other people, how the FUCK can you expect they help you??. [do me a fravour, give yourself a fuck]

Follow Ups:

  • Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* Tex Murphy 13:22:59 8/04/98 (3)
    • advice for newbie owlsley 00:06:12 8/07/98 (2)
      • Re: advice for newbie Tex Murphy 12:09:06 8/07/98 (1)
        • Re: advice for newbie satan 15:22:41 8/10/98 (0)

Post a Followup

Name:


Re: DirectX 6 totally screwed my Monster 3dII accelerator card

Posted by Monster 3d II owner on August 04, 1998 at 02:13:54:

In Reply to: Re: DirectX 6 totally screwed my Monster 3dII accelerator card posted by ding@ on August 04, 1998 at 00:56:18:

Ok I just downloaded the release version. Still didnt help. Doh! Is there any way to remove directx from my system?

Follow Ups:

  • Re: DirectX 6 totally screwed my Monster 3dII accelerator card ding@ 06:46:50 8/04/98 (2)
    • I tried all that stuff :( Monster 3d II owner 07:35:52 8/04/98 (1)
      • Re: I tried all that stuff :( Matthew Wright 04:11:28 9/06/98 (0)

Post a Followup

Name:


Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT*

Posted by Dave Burrows on August 04, 1998 at 04:17:27:

In Reply to: Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* posted by Clay on August 03, 1998 at 20:33:08:

I had this a long time ago and found the only way to solve it was to reinstall windows.

The problem I believe (OK it's a total guess) is some registry setting.
DX stores all the video configs you've had on your machine since the year dot.
On thinking about it, I think I saw a list of unactive drivers inside the control panel when your in SAFE mode.
You may be able to remove the ones your not using.

Follow Ups:

Post a Followup

Name:


Re: DirectX 6 totally screwed my Monster 3dII accelerator card

Posted by ding@ on August 04, 1998 at 06:46:50:

In Reply to: Re: DirectX 6 totally screwed my Monster 3dII accelerator card posted by Monster 3d II owner on August 04, 1998 at 02:13:54:

:Is there any way to remove directx from my system?

reinstall windows may help

have you tried the latest 3dfx reference driver(7/20/98)??, have you enable the '3d hardware acce' option in dx setup?? have you tried the latest monster3d2 driver(v201)?

if you did all those, goto 'program files'->'directx'->'setup', run 'DXDIAG', click on 'display2'(or display3) tab, should be your monster3d2, click on direct3d test, see if it can pass the test???

Follow Ups:

  • I tried all that stuff :( Monster 3d II owner 07:35:52 8/04/98 (1)
    • Re: I tried all that stuff :( Matthew Wright 04:11:28 9/06/98 (0)

Post a Followup

Name:


direct 3d header

Posted by udi on August 04, 1998 at 07:33:37:

Hi

I would like someone to tell me how to find the
writing header for direct3d files with animation.
I have the sdk and yes I saw the notepad but I need
more information please fill free to help me.

udi.

Follow Ups:

Post a Followup

Name:


I tried all that stuff :(

Posted by Monster 3d II owner on August 04, 1998 at 07:35:52:

In Reply to: Re: DirectX 6 totally screwed my Monster 3dII accelerator card posted by ding@ on August 04, 1998 at 06:46:50:

Thanks for the advice. I have the latest Monster 3d II drivers. I have the 3d accel. enabled. Unfortunately it failed the test. I sure hope they get a patch out for directx 6 because this is happening to alot of people i hear. I have tried re-installing windows also. I sure wish I would have made a back-up of my hard drive. But since I dont have a tape drive installed on this computer (ironic,,I have tape drives on the other 2 computers) its hard to back up.

Follow Ups:

  • Re: I tried all that stuff :( Matthew Wright 04:11:28 9/06/98 (0)

Post a Followup

Name:


OH COME ON GUYS, HELP ME WITH MY DIRECTDRAW PROBLEM!!!!!!!!!!!!!!!!!! IT SHOULD BE VERY SIMPLE FOR YOU eXPERTS OUT THERE!!!!!!

Posted by DirectX-=NeWbIe=- on August 04, 1998 at 12:23:40:

when ever I load a program that needs to use directdraw, a message box pops out saying "Beta DirectDraw expired, please update" I tried to install DX6 but still doesn't WORK!!!!!! PLEASE HELP!!!!!!!!!! :) ;( :)

Follow Ups:

  • Re: OH COME ON GUYS, HELP ME WITH MY DIRECTDRAW PROBLEM!!!!!!!!!!!!!!!!!! IT SHOULD BE VERY SIMPLE FOR YOU eXPERTS OUT THERE!!!!!! Walla Walla 23:03:02 8/18/98 (0)
  • Re: OH COME ON GUYS, HELP ME WITH MY DIRECTDRAW PROBLEM!!!!!!!!!!!!!!!!!! IT SHOULD BE VERY SIMPLE FOR YOU eXPERTS OUT THERE!!!!!! Snowman 14:07:11 8/04/98 (0)

Post a Followup

Name:


Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT*

Posted by Tex Murphy on August 04, 1998 at 13:22:59:

In Reply to: Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* posted by ding@ on August 04, 1998 at 01:01:47:

This is what my computer is:

Pentium 75, 40 megs of RAM, I don't know the version of Windows because when I bought my computer I was never givin the Win95 CD, SVGA.

If you need other info, reply to this message

Follow Ups:

  • advice for newbie owlsley 00:06:12 8/07/98 (2)
    • Re: advice for newbie Tex Murphy 12:09:06 8/07/98 (1)
      • Re: advice for newbie satan 15:22:41 8/10/98 (0)

Post a Followup

Name:


|=-Not about DirectX-=|

Posted by Clay on August 04, 1998 at 13:29:40:

Alright. Enough already with the SCREAMING in posts. If you want to flame, go to the newsgroups. If you want to contribute to the discussions or post here, QUIT FUCKING SCREAMING BECAUSE IT DOES NO GOOD AND IS HARD TO READ. Aside from that, it isn't very polite ;->

Clay

Follow Ups:

  • Bad Language and Filtering. Ravi Joshi 01:50:37 8/05/98 (2)
    • ftp site Clay 14:56:16 8/05/98 (1)
      • Re: ftp site why only direct-acces on warezpagez to DirectX 6.0 22:25:57 8/08/98 (0)
  • Re: |=-Not about DirectX-=| Snowman 21:50:26 8/04/98 (0)

Post a Followup

Name:


Re: OH COME ON GUYS, HELP ME WITH MY DIRECTDRAW PROBLEM!!!!!!!!!!!!!!!!!! IT SHOULD BE VERY SIMPLE FOR YOU eXPERTS OUT THERE!!!!!!

Posted by Snowman on August 04, 1998 at 14:07:11:

In Reply to: OH COME ON GUYS, HELP ME WITH MY DIRECTDRAW PROBLEM!!!!!!!!!!!!!!!!!! IT SHOULD BE VERY SIMPLE FOR YOU eXPERTS OUT THERE!!!!!! posted by DirectX-=NeWbIe=- on August 04, 1998 at 12:23:40:

The reason people don't help you out is because they can't!! You need to give us a lot more information than that, like what kind of computer you have (CPU, video card...) You need to say ecxactly what happened with DirectX 6.

So before you start yelling at us, you need to realize that your question may not supply enough info to be answered. You can't just come running around here like you own the place!!

Follow Ups:

Post a Followup

Name:


Need Advice....Newto Windows programming

Posted by Fritz on August 04, 1998 at 19:56:27:

I am fairly proficient in c/c++ programming and am wanting to expand into the world of Windows programming. Anyone out there have any advice on where I can go to get started in Windows programming? Or know of any good books on the subject?

Follow Ups:

Post a Followup

Name:


Re: |=-Not about DirectX-=|

Posted by Snowman on August 04, 1998 at 21:50:26:

In Reply to: |=-Not about DirectX-=| posted by Clay on August 04, 1998 at 13:29:40:

Could we all cut with profanity? I don't mind it, but there is a time and place for it. That's not here. This site was put up so that people could get responses to their questions about DirectX, not so they could yell and cuss each other out.

-Snowman

Follow Ups:

Post a Followup

Name:


Does Anyone HERE HAVE A IBM MWAVE AUDIO FOR YOUR AUDIO DRIVER? IF SO, PLEASE HELP!!!!!

Posted by dIRECTxSuCKEr on August 04, 1998 at 22:25:54:

If you have a Ibm Mwave audio driver your Directx probably can't detect it right? BUT IF IT DOES GET DETECTED TELL ME, cause mine can never get detected, I wondor why microsoft can make a good directx that can detect all kinds of sound cards.

Follow Ups:

Post a Followup

Name:


Bad Language and Filtering.

Posted by Ravi Joshi on August 05, 1998 at 01:50:37:

In Reply to: |=-Not about DirectX-=| posted by Clay on August 04, 1998 at 13:29:40:

Hi to all.
It is heartening to see that a lot of people have been taking help from this forum. But some are using bad language
when they get frustrated with DirectX. By throwing anger on the site, their DirectX programs are not going to run.
We must collectively stop this trend here itself. One way of effectively doing it is to filter such
messages. Can this be done?
I request all of you not to respond to such messages.
...
To clay..
What happened to the ftp site you requested with the authour of this site?
Any positive response?
Ravi Joshi.

Follow Ups:

  • ftp site Clay 14:56:16 8/05/98 (1)
    • Re: ftp site why only direct-acces on warezpagez to DirectX 6.0 22:25:57 8/08/98 (0)

Post a Followup

Name:


Q: How Can I read DirectX6.0 Help File???

Posted by Soph on August 05, 1998 at 04:59:42:

I just downloaded DirectX 6.0 SDK, but I can't open

Help File. a new 'HHCTRL.OCX' file??? Where can I get it? How Can I read this 'Compiled HTML' format???

Help me. ^^

Follow Ups:

  • Re: Q: How Can I read DirectX6.0 Help File??? John Giors 16:26:48 8/05/98 (0)

Post a Followup

Name:


Re: Question about Visual C++ and DirectX

Posted by bob on August 05, 1998 at 10:22:30:

In Reply to: Re: Question about Visual C++ and DirectX posted by Nat on July 30, 1998 at 16:32:46:

yes i do have winmain and the ddraw.lib is included in object libraries

bob

thanks for the response, any help would be greatly appreciated

: DO you have a WinMain??

:
: : things u might need to know

: : - i am pretty sure i have directx 5 sdk and visual c++ setup okay

: : - i am a programmer with very little windows programming exp (mostly unix and vb, go figure)

: : basically when i try to creat a minimal app with directx, i know that my app compiles ok, but it runs into a linking error LNK2001 unresolved symbol _main. in the help it has a host of possible causes, but i was wondering if someone knew right away so i could get started.

: : bob

Follow Ups:

Post a Followup

Name:


ftp site

Posted by Clay on August 05, 1998 at 14:56:16:

In Reply to: Bad Language and Filtering. posted by Ravi Joshi on August 05, 1998 at 01:50:37:

No word from the ftp site request.

Clay

Follow Ups:

  • Re: ftp site why only direct-acces on warezpagez to DirectX 6.0 22:25:57 8/08/98 (0)

Post a Followup

Name:


Source Code Page back up!!

Posted by Johnny on August 05, 1998 at 15:44:45:

In Reply to: 2D Tile Game Source Code posted by Johnny Rotten on July 31, 1998 at 01:25:52:

If you tried to get the 2D tile game source code and got a message that the page didn't exist on the server, please try it again. My ISP has been putting in a new server and the page has been down from time to time. Sorry about the inconvenience.

  • Get the source code here!

Follow Ups:

Post a Followup

Name:


About the ftp site...

Posted by Snowman on August 05, 1998 at 15:45:41:

Clay-

Is there any way that we (those interested) could send a big e-mail to the developer of this page? I was thinking like the one sent to Microsoft about OpenGL.

Just a thought!

-Snowman

Follow Ups:

Post a Followup

Name:


Re: Q: How Can I read DirectX6.0 Help File???

Posted by John Giors on August 05, 1998 at 16:26:48:

In Reply to: Q: How Can I read DirectX6.0 Help File??? posted by Soph on August 05, 1998 at 04:59:42:

I believe Internet Explorer 4.0 is required to read the help files. Try installing it. If you're using Netscape for Internet browsing, it should still work, too.

: I just downloaded DirectX 6.0 SDK, but I can't open

: Help File. a new 'HHCTRL.OCX' file??? Where can I get it? How Can I read this 'Compiled HTML' format???

: Help me. ^^

Follow Ups:

Post a Followup

Name:


Special effects, help meeee :- ( !!!!!!!!

Posted by Pauline on August 06, 1998 at 11:49:48:

I should know how to create special effects, like explosion or flame, into DirectX game (Direct3dRM Mode). Specially for transparence (use of Alpha Blending and Alpha Channel)

Follow Ups:

  • Re: Special effects, help meeee :- ( !!!!!!!! Snowman 13:14:22 8/06/98 (0)

Post a Followup

Name:


Re: Special effects, help meeee :- ( !!!!!!!!

Posted by Snowman on August 06, 1998 at 13:14:22:

In Reply to: Special effects, help meeee :- ( !!!!!!!! posted by Pauline on August 06, 1998 at 11:49:48:

: I should know how to create special effects, like explosion or flame, into DirectX game (Direct3dRM Mode). Specially for transparence (use of Alpha Blending and Alpha Channel)

You can use decals to do that. You can set a transparency color, and use bitmaps to display your flame or explosion.

-Snowman

Follow Ups:

Post a Followup

Name:


This board is waaaaaaay to long.

Posted by 0x1CE on August 06, 1998 at 15:33:38:

C'mon webmaster(s), don't you think it's about time
to start archiving messages or something? This page
takes forever to load.

Follow Ups:

Post a Followup

Name:


Where is "DirectMusic Producer"

Posted by Kentamanos on August 06, 1998 at 17:19:31:

The DirectX6 documentation mentions a program called "DirectMusic Producer". The documentation says that it comes with the SDK...

Has anyone found this program?

Am I just completely blind?

Follow Ups:

  • Re: Where is "DirectMusic Producer" Kentamanos 21:06:14 8/06/98 (0)

Post a Followup

Name:


Re: Where is "DirectMusic Producer"

Posted by Kentamanos on August 06, 1998 at 21:06:14:

In Reply to: Where is "DirectMusic Producer" posted by Kentamanos on August 06, 1998 at 17:19:31:

: The DirectX6 documentation mentions a program called "DirectMusic Producer". The documentation says that it comes with the SDK...

: Has anyone found this program?

: Am I just completely blind?

I am completely blind...found it in extras.

Follow Ups:

Post a Followup

Name:


advice for newbie

Posted by owlsley on August 07, 1998 at 00:06:12:

In Reply to: Re: I WAS JUST WONDERING WHY THE FUCK NO-ONE HAS EVEN TRIED TO REPLY TO MY PREVIOUS MESSAGE! IS THERE NO-ONE OUT THERE WHO HAS MORE FUCKING BRAINS THAN ME THAT CAN HELP ME OUT? IF YOU KNOW THE ANSWER TO MY PROBLEM THAN PLEASE REPLY TO MY OTHER MESSAGE! *NT* posted by Tex Murphy on August 04, 1998 at 13:22:59:

so, who makes your SVGA card? that is
a pretty generic classification- it ISN'T
a brand name. if DirectX doesn't like it-
check with the card manufacturer, if they still
exist. if it isn't compatibile,you
can't play DirectX games. thats it.

get another video card. if it is soldered to the
motherboard (like Packard Bell does) you
bought a shitty computer and got gypped. you
are fucked. get a better computer, they get
cheaper all the time.

oh, by the way, changing video cards will
require a Windows reinstall maybe,
certainly you will need a Windows CD to do it.

but if you do have a good DirectX compatible
video card, the fault is probably that
Windows has become corrupted. it just does that.
newer builds of 95 are more stable- the beta
98's were terrible- and i know nothing about
the current 98 as i don't run it.

if you don't have the
fucking Win95 CD, you can't reinstall windows.
and Win95 is well known for fucking up and
needing a reinstall every now and again.
then you would need to reinstall DirectX.
oh, well, here is my advice, if you want it.

1) buy a copy of win95 or win98. win98 has
DirectX 5.2 built right into it. or get someone
to burn you a copy on CD-R. much cheaper.

2) backup your data. beats me how you can,
cause you don't have a CD burner or tape drive.

if you don't need any data, or can fit it all
on floppy, and you can reinstall your applications
(boy, if you didn't get the INSTALL disks
for your applications, just enjoy the computer
while you can. one day it will fuck up beyond
all repair. don't install anything else,
be glad of what you have, it won't last forever)

then what you do is

put your DOS CD-ROM drivers on a floppy disk,
along with MSCDEX, and create an autoexec.bat
and a config.sys for a boot disk which will
bring up Win95 command prompt with FUNCTIONAL
CD drive. if you don't know how, go
get help from a local fucking brain. i'm
not gonna be responsible for the ruination
of your computer when you can't reload Windows
and the machine is basically dead.

so if you couldn't do that, stop right here.

well, if you could, at the A:/ prompt
do DELTREE C:/WINDOWS and destroy all your
windows operating system!!! ha ha ha!!!
this will leave all your data intact
except that on the desktop- MOVE IT FIRST!!
and it will mess up most- not all, but most-
applications so they need a reinstall.

then, as you DO have a working CD Drive,
install a new copy of windows 95 or 98
and all your applications.

then try to install DirectX again.

have fun!!

PS: you fucking probably think i am pranking you
but i am totally fucking serious. i own a CD-R
burner. and i have copies of all my apps on CD.
and i backup my data. and i have a 11.8
gig drive and the C: partition is only 2.0 gigs
and i can just delete it with impunity and
not even touch my data.

and i destroy windows and do a reinstall every
3 or 4 months, as soon as it gets crashy.

i do a lot of programming and assorted wierd shit
so i crash my system often. and the power in
my building is unstable. so i really do
have to go through this. the good side is,
my computer runs fast and clean.
i consider it maintainence. many people think
that computers don't need maintainence. they
usually lose their big project at an inappropriate
time.

and fuck fuck fuck fuck fuck fuck fuck fuck
fuck fuck fuck fuck fuck fuck fuck fuck fuck

Follow Ups:

  • Re: advice for newbie Tex Murphy 12:09:06 8/07/98 (1)
    • Re: advice for newbie satan 15:22:41 8/10/98 (0)

Post a Followup

Name:


Re: advice for newbie

Posted by Tex Murphy on August 07, 1998 at 12:09:06:

In Reply to: advice for newbie posted by owlsley on August 07, 1998 at 00:06:12:

I have to say that I don't think you are fucking with me because it sounds so much like my computer status now.

I don't need to worry about DirectX right now because I am taking my computer into a local computer store to get a new CD-ROM and I will ask them to install it for me.

Thanks anyway and if the local store can't help, I'll take your advice

Follow Ups:

  • Re: advice for newbie satan 15:22:41 8/10/98 (0)

Post a Followup

Name:


Direct Play Lobby Server

Posted by Michael Dauria on August 07, 1998 at 14:19:46:

Can anyone point me to any docs that tell how to creat
a lobby server???? The direct X docs tell how to make
an app lobby aware, but they do not mention anything
about creating a lobby server

Follow Ups:

Post a Followup

Name:


Help Please Direct 3D

Posted by Karl Fisher on August 07, 1998 at 15:32:04:

I am using Direct3D Immediate Mode draw primitive.

The View and Projection matrices are set as follows:
View = ViewMatrix(D3DVECTOR(0.0,0.0, -10.0), D3DVECTOR(0.0,0.0,0.0), D3DVECTOR(0,1,0), 0);
Projection = ProjectionMatrix(0.01f, 1000.0f, (float)(60*PI/180));

X1 = 0.0f;
Y1 = 0.0f;
Z1 = 19.0f;

I have a sphere1 positioned at (X1, Y1, Z1)

I have sphere2 orbiting about sphere1 as follows:

R3 = 1.0f;

ThetaR3 = ThetaR3 + 0.04f;

if(ThetaR3 >= 2.0 * pi)
{
ThetaR3 = 0;
}

X2 = X1 + 4 * R3 * cos(ThetaR3);
Y2 = Y1;
Z2 = Z1 + R3 * sin(ThetaR3);

This works fine for Values of Z1 less than or equal to 19.0f, but if I increase Z1 to 20, sphere 2 then appears in front of sphere1 throughout the orbit.

It appears that the maximum separation in Z that I can get the Z-Buffering to hide sphere2 is 29.

I must be doing something wrong, but I cannot figure it out.

Any help would be greatly appreciated.

Thanks
Karl

karl_fisher@msn.com

Follow Ups:

  • Re: Help Please Direct 3D Dave Burrows 05:37:11 8/10/98 (0)
  • Re: Help Please Direct 3D Fragmo 17:27:26 8/07/98 (6)
    • Re: Help Please Direct 3D Karl Fisher 09:06:11 8/08/98 (5)
      • Re: Help Please Direct 3D Fragmo 16:53:46 8/08/98 (4)
        • Re: Help Please Direct 3D Shai'tan [ Nth ] 16:57:19 8/09/98 (3)
          • Re: Help Please Direct 3D Fragmo 20:30:48 8/09/98 (2)
            • correct me if I'm wrong... Clay 08:04:41 8/11/98 (1)
              • Re: correct me if I'm wrong... Fragmo 21:07:57 8/11/98 (0)

Post a Followup

Name:


Re: Help Please Direct 3D

Posted by Fragmo on August 07, 1998 at 17:27:26:

In Reply to: Help Please Direct 3D posted by Karl Fisher on August 07, 1998 at 15:32:04:

if you are using a 16 bit z buffer you can expect less than perfect results
for objects farther away from the screen. the radius at which the second sphere
is orbiting is probably the source of the problem, since it is only 1 unit away.
The only ways to fix this are to either switch to a 24 bit z buffer, or simply to
know when the z buffer will be crappy for what you are doing, and change the projection
matrix to shrink the z range to the values likely to be used. your z range (.01 - 1000) is a good
general range, but if you know you will only be using z values in a smaller range (say .01 - 100) you
can improve the results if you reduce the range to cover only what you will use.

Fragmo
www.public.iastate.edu/~jtilton/rpg.htm

: I am using Direct3D Immediate Mode draw primitive.

: The View and Projection matrices are set as follows:
: View = ViewMatrix(D3DVECTOR(0.0,0.0, -10.0), D3DVECTOR(0.0,0.0,0.0), D3DVECTOR(0,1,0), 0);
: Projection = ProjectionMatrix(0.01f, 1000.0f, (float)(60*PI/180));

: X1 = 0.0f;
: Y1 = 0.0f;
: Z1 = 19.0f;

: I have a sphere1 positioned at (X1, Y1, Z1)

: I have sphere2 orbiting about sphere1 as follows:

: R3 = 1.0f;

: ThetaR3 = ThetaR3 + 0.04f;

: if(ThetaR3 >= 2.0 * pi)
: {
: ThetaR3 = 0;
: }

:
: X2 = X1 + 4 * R3 * cos(ThetaR3);
: Y2 = Y1;
: Z2 = Z1 + R3 * sin(ThetaR3);

: This works fine for Values of Z1 less than or equal to 19.0f, but if I increase Z1 to 20, sphere 2 then appears in front of sphere1 throughout the orbit.

: It appears that the maximum separation in Z that I can get the Z-Buffering to hide sphere2 is 29.

: I must be doing something wrong, but I cannot figure it out.

: Any help would be greatly appreciated.

: Thanks
: Karl

: karl_fisher@msn.com

Follow Ups:

  • Re: Help Please Direct 3D Karl Fisher 09:06:11 8/08/98 (5)
    • Re: Help Please Direct 3D Fragmo 16:53:46 8/08/98 (4)
      • Re: Help Please Direct 3D Shai'tan [ Nth ] 16:57:19 8/09/98 (3)
        • Re: Help Please Direct 3D Fragmo 20:30:48 8/09/98 (2)
          • correct me if I'm wrong... Clay 08:04:41 8/11/98 (1)
            • Re: correct me if I'm wrong... Fragmo 21:07:57 8/11/98 (0)

Post a Followup

Name:


Re: Help Please Direct 3D

Posted by Karl Fisher on August 08, 1998 at 09:06:11:

In Reply to: Re: Help Please Direct 3D posted by Fragmo on August 07, 1998 at 17:27:26:

Hi Fragmo,

Thanks much for the help. When I set ddsd.dwZBufferBitDepth = 24; the program immediately exits to VC5. Do I have to change the display mode to 24 BPP also? I have tried changing the Projection matrix, and the viewport.dvMaxZ = 1.0f; values. At times this will increase the apparent range of Z values by one unit. I can get a range of 30 rather than 29. Could this be something to do with Hardware?

I did not seem to have this problem with Retained Mode where apparently RM takes care of the Z-Buffering. It just doesn't seem much like 3D if I can't get Z- Buffering with a greater range than this.

I will keep at it, but if you do have any more suggestions I will sure appreciate hearing.

Thanks again
Karl

Karl_fisher@msn.com

: if you are using a 16 bit z buffer you can expect less than perfect results
: for objects farther away from the screen. the radius at which the second sphere
: is orbiting is probably the source of the problem, since it is only 1 unit away.
: The only ways to fix this are to either switch to a 24 bit z buffer, or simply to
: know when the z buffer will be crappy for what you are doing, and change the projection
: matrix to shrink the z range to the values likely to be used. your z range (.01 - 1000) is a good
: general range, but if you know you will only be using z values in a smaller range (say .01 - 100) you
: can improve the results if you reduce the range to cover only what you will use.

: Fragmo
: www.public.iastate.edu/~jtilton/rpg.htm

:
: : I am using Direct3D Immediate Mode draw primitive.

: : The View and Projection matrices are set as follows:
: : View = ViewMatrix(D3DVECTOR(0.0,0.0, -10.0), D3DVECTOR(0.0,0.0,0.0), D3DVECTOR(0,1,0), 0);
: : Projection = ProjectionMatrix(0.01f, 1000.0f, (float)(60*PI/180));

: : X1 = 0.0f;
: : Y1 = 0.0f;
: : Z1 = 19.0f;

: : I have a sphere1 positioned at (X1, Y1, Z1)

: : I have sphere2 orbiting about sphere1 as follows:

: : R3 = 1.0f;

: : ThetaR3 = ThetaR3 + 0.04f;

: : if(ThetaR3 >= 2.0 * pi)
: : {
: : ThetaR3 = 0;
: : }

: :
: : X2 = X1 + 4 * R3 * cos(ThetaR3);
: : Y2 = Y1;
: : Z2 = Z1 + R3 * sin(ThetaR3);

: : This works fine for Values of Z1 less than or equal to 19.0f, but if I increase Z1 to 20, sphere 2 then appears in front of sphere1 throughout the orbit.

: : It appears that the maximum separation in Z that I can get the Z-Buffering to hide sphere2 is 29.

: : I must be doing something wrong, but I cannot figure it out.

: : Any help would be greatly appreciated.

: : Thanks
: : Karl

: : karl_fisher@msn.com

Follow Ups:

  • Re: Help Please Direct 3D Fragmo 16:53:46 8/08/98 (4)
    • Re: Help Please Direct 3D Shai'tan [ Nth ] 16:57:19 8/09/98 (3)
      • Re: Help Please Direct 3D Fragmo 20:30:48 8/09/98 (2)
        • correct me if I'm wrong... Clay 08:04:41 8/11/98 (1)
          • Re: correct me if I'm wrong... Fragmo 21:07:57 8/11/98 (0)

Post a Followup

Name:


Re: Help Please Direct 3D

Posted by Fragmo on August 08, 1998 at 16:53:46:

In Reply to: Re: Help Please Direct 3D posted by Karl Fisher on August 08, 1998 at 09:06:11:

: Hi Fragmo,

: Thanks much for the help. When I set ddsd.dwZBufferBitDepth = 24; the program immediately exits to VC5. Do I have to change the display mode to 24 BPP also? I have tried changing the Projection matrix, and the viewport.dvMaxZ = 1.0f; values. At times this will increase the apparent range of Z values by one unit. I can get a range of 30 rather than 29. Could this be something to do with Hardware?

your 3d card probably doesn't support 24 bit z buffers, that's why it was exiting. And the max and min z values in the projection matrix represent world z values, so if your sphere is at 20 units away, you could try a range of 1 - 50 or so. this should fix the problem, but for the most part, 16 bit z buffers just plain suck for accuracy.

: I did not seem to have this problem with Retained Mode where apparently RM takes care of the Z-Buffering. It just doesn't seem much like 3D if I can't get Z- Buffering with a greater range than this.

i don't know much about retained mode, but if the results were much better, then i would guess that it was using a 32 bit software z buffer. (which might explain why so many people comment on how much faster immediate mode is)

: I will keep at it, but if you do have any more suggestions I will sure appreciate hearing.

: Thanks again
: Karl

: Karl_fisher@msn.com

Fragmo
www.public.iastate.edu/~jtilton/rpg.htm

Follow Ups:

  • Re: Help Please Direct 3D Shai'tan [ Nth ] 16:57:19 8/09/98 (3)
    • Re: Help Please Direct 3D Fragmo 20:30:48 8/09/98 (2)
      • correct me if I'm wrong... Clay 08:04:41 8/11/98 (1)
        • Re: correct me if I'm wrong... Fragmo 21:07:57 8/11/98 (0)

Post a Followup

Name:


Re: ftp site

Posted by why only direct-acces on warezpagez to DirectX 6.0 on August 08, 1998 at 22:25:57:

In Reply to: ftp site posted by Clay on August 05, 1998 at 14:56:16:

: WE WAITING TO DOWNLOD (if wanted) Direct X6.0
Microsoft !!

  • all for 100.000 subscribers

Follow Ups:

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by mikael on August 09, 1998 at 11:12:52:

In Reply to: DirectX6 FINAL RELEASE! posted by A DX6 beta tester on July 31, 1998 at 00:30:54:

: The FINAL version of DirectX6/SDK will be released with in 24 hours!

: Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

  • Re: DirectX6 FINAL RELEASE! Rick Larew 15:16:59 9/30/98 (0)
  • Re: DirectX6 FINAL RELEASE! rtr 17:36:31 9/24/98 (0)
  • Re: DirectX6 FINAL RELEASE! Vladimir Mitev 16:29:20 9/02/98 (2)
    • Re: DirectX6 FINAL RELEASE! David Mendes 15:40:18 9/28/98 (0)
    • Re: DirectX6 FINAL RELEASE! Niki 17:55:01 9/03/98 (0)
  • Re: DirectX6 FINAL RELEASE! JOHN 21:03:11 9/01/98 (1)
    • Re: DirectX6 FINAL RELEASE! john reece 22:56:55 9/01/98 (0)
  • Re: DirectX6 FINAL RELEASE! STAS MIDURA 14:20:46 9/01/98 (0)
  • Re: DirectX6 FINAL RELEASE! Steve Borman 06:34:57 8/29/98 (1)
    • Re: DirectX6 FINAL RELEASE! Roxanne Bryant 14:56:03 8/30/98 (0)

Post a Followup

Name:


Re: 3D Objects

Posted by mikael on August 09, 1998 at 11:14:35:

In Reply to: 3D Objects posted by Emil Diego on July 30, 1998 at 16:18:05:

: Are there any good shareware utilities out there for createing 3D Objects that can be easily included into a directx application.

Follow Ups:

Post a Followup

Name:


Re: Direct Animation

Posted by mikael on August 09, 1998 at 11:16:48:

In Reply to: Direct Animation posted by SANDAL on July 28, 1998 at 07:43:14:

: Where can I find good, additional information on Direct Animation? I'm stuck and need help and there are no good books around.

: SANDAL

Follow Ups:

Post a Followup

Name:


Help Iam not so good as you are!! Evrything is fucked like earth..

Posted by ExTaZ on August 09, 1998 at 13:18:09:

Iam very new on Dx programing.
So where is the sites for beginers ??
Evry time I download an Exempel with source codes,
I dont get the headers.

Where can I download headers Dinput.h, CDX.H

Please help

Follow Ups:

Post a Followup

Name:


Turning left, right, etc

Posted by Seve Bryndin on August 09, 1998 at 15:16:02:

Hi.

I am newbie.
I just finished book Win95 game SDK strategy guide.
There was code for the Aztec advenure. It the game you can only face 4 directions.
Is there any way to change this, so you can look at
360 directions without killing the performance (like in quake)?

Thanks

Follow Ups:

Post a Followup

Name:


Re: Help Please Direct 3D

Posted by Shai'tan [ Nth ] on August 09, 1998 at 16:57:19:

In Reply to: Re: Help Please Direct 3D posted by Fragmo on August 08, 1998 at 16:53:46:

: : Hi Fragmo,

:16 bit z buffers just plain suck for accuracy.

Well, my 16 bit ZBuffer can handle distances far greater than 29. So I am tending to think that there is perhaps something else wrong? My near clip plane is set at 1 and my far clip plane is at 1000. It depends what sort of game your doing I suppose...for terrain / ground games you don't really need a very large far clip plane...just try 1 to 1000 until you get it working?

Shai'tan - [ Nth ]
murfet@onthenet.com.au

Follow Ups:

  • Re: Help Please Direct 3D Fragmo 20:30:48 8/09/98 (2)
    • correct me if I'm wrong... Clay 08:04:41 8/11/98 (1)
      • Re: correct me if I'm wrong... Fragmo 21:07:57 8/11/98 (0)

Post a Followup

Name:


I NEED HELP ON DDRAW and D3D, PLEASE!!

Posted by Kovax on August 09, 1998 at 18:19:56:

i'm curently programming a D3D driver for the famous PSX emulator PSemu PRO, but i need help to modify a source which load a texture from a file, to make a load
texture from a *char[] (texture size: 256*256 and 256colors).
if you need the complete example wich make a triangle flat,gouraud shaded,textured, textured+gouraud shaded,to help me, E-mail me:

HERE IS THE PIECE OF THE SOURCE TO MODIFY:

BOOL D3DTexture::Load(IDirect3DDevice2 *Device, char *BitmapName)
{
BITMAP bm;
DDSURFACEDESC ddsd;
HBITMAP Bitmap;
IDirectDraw * DirectDraw;

DPF("D3DTexture::Load(%s)", BitmapName);

//
// we need a IDirectDraw so we can create a surface.
//
if ((DirectDraw = GetDD(Device)) == NULL)
return FALSE;

//
// load the bitmap from a resource or file.
//
Bitmap = (HBITMAP)LoadImage(GetModuleHandle(NULL), BitmapName, IMAGE_BITMAP, 0, 0, LR_CREATEDIBSECTION);

if (Bitmap == NULL)
Bitmap = (HBITMAP)LoadImage(NULL, BitmapName, IMAGE_BITMAP, 0, 0, LR_LOADFROMFILE|LR_CREATEDIBSECTION);

if (Bitmap == NULL)
return FALSE;

// free any existing texture.
Release();

GetObject(Bitmap, sizeof(bm), &bm); // get size of bitmap

//
// find the best texture format to use.
//
ZeroMemory(&ddsd, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ChooseTextureFormat(Device, bm.bmBitsPixel, &ddsd.ddpfPixelFormat);
ddsd.dwFlags |= DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT;
ddsd.dwWidth = bm.bmWidth;
ddsd.dwHeight = bm.bmHeight;

//
// create a video memory texture
//
// if we are dealing with a HAL create in video memory, else
// create in system memory.
//
D3DDEVICEDESC hal, hel;
ZeroMemory(&hal, sizeof(hal));
hal.dwSize = sizeof(hal);
ZeroMemory(&hel, sizeof(hel));
hel.dwSize = sizeof(hel);
Device->GetCaps(&hal, &hel);

// BUGBUG should we check for texture caps?
if (hal.dcmColorModel)
ddsd.ddsCaps.dwCaps = DDSCAPS_VIDEOMEMORY | DDSCAPS_TEXTURE | DDSCAPS_ALLOCONLOAD;
else
ddsd.ddsCaps.dwCaps = DDSCAPS_SYSTEMMEMORY| DDSCAPS_TEXTURE;

if (DirectDraw->CreateSurface(&ddsd, &DeviceSurface, NULL) != DD_OK)
goto error;

//
// create a system memory surface for the texture.
//
// we use this system memory surface for the ::Load call
// and this surface does not get lost.
//
if (hal.dcmColorModel)
{
ddsd.ddsCaps.dwCaps = DDSCAPS_SYSTEMMEMORY | DDSCAPS_TEXTURE;

if (DirectDraw->CreateSurface(&ddsd, &MemorySurface, NULL) != DD_OK)
goto error;
}
else
{
//
// when dealing with a SW rasterizer we dont need to make two
// surfaces.
//
MemorySurface = DeviceSurface;
DeviceSurface->AddRef();
}

//
// create a palette for the texture
//
if (ddsd.ddpfPixelFormat.dwRGBBitCount SetPalette(Palette);
DeviceSurface->SetPalette(Palette);
}

//
// copy the bitmap to our surface
//
if (!Copy(Bitmap))
goto error;

//
// get the texture handle
//
IDirect3DTexture2 * Texture;
DeviceSurface->QueryInterface(IID_IDirect3DTexture2, (void**)&Texture);
Texture->GetHandle(Device, &Handle);
Texture->Release();

//
// we are done, delete the bitmap (we made a copy) and return.
//
DeleteObject(Bitmap);
return TRUE;

error:
if (Bitmap)
DeleteObject(Bitmap);
Release();
return FALSE;
}

Follow Ups:

Post a Followup

Name:


I NEED HELP ON DDRAW and D3D, PLEASE!!

Posted by Kovax on August 09, 1998 at 18:20:35:

i'm curently programming a D3D driver for the famous PSX emulator PSemu PRO, but i need help to modify a source which load a texture from a file, to make a load
texture from a *char[] (texture size: 256*256 and 256colors).
if you need the complete example wich make a triangle flat,gouraud shaded,textured, textured+gouraud shaded,to help me, E-mail me:

HERE IS THE PIECE OF THE SOURCE TO MODIFY:

BOOL D3DTexture::Load(IDirect3DDevice2 *Device, char *BitmapName)
{
BITMAP bm;
DDSURFACEDESC ddsd;
HBITMAP Bitmap;
IDirectDraw * DirectDraw;

DPF("D3DTexture::Load(%s)", BitmapName);

//
// we need a IDirectDraw so we can create a surface.
//
if ((DirectDraw = GetDD(Device)) == NULL)
return FALSE;

//
// load the bitmap from a resource or file.
//
Bitmap = (HBITMAP)LoadImage(GetModuleHandle(NULL), BitmapName, IMAGE_BITMAP, 0, 0, LR_CREATEDIBSECTION);

if (Bitmap == NULL)
Bitmap = (HBITMAP)LoadImage(NULL, BitmapName, IMAGE_BITMAP, 0, 0, LR_LOADFROMFILE|LR_CREATEDIBSECTION);

if (Bitmap == NULL)
return FALSE;

// free any existing texture.
Release();

GetObject(Bitmap, sizeof(bm), &bm); // get size of bitmap

//
// find the best texture format to use.
//
ZeroMemory(&ddsd, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
ChooseTextureFormat(Device, bm.bmBitsPixel, &ddsd.ddpfPixelFormat);
ddsd.dwFlags |= DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT;
ddsd.dwWidth = bm.bmWidth;
ddsd.dwHeight = bm.bmHeight;

//
// create a video memory texture
//
// if we are dealing with a HAL create in video memory, else
// create in system memory.
//
D3DDEVICEDESC hal, hel;
ZeroMemory(&hal, sizeof(hal));
hal.dwSize = sizeof(hal);
ZeroMemory(&hel, sizeof(hel));
hel.dwSize = sizeof(hel);
Device->GetCaps(&hal, &hel);

// BUGBUG should we check for texture caps?
if (hal.dcmColorModel)
ddsd.ddsCaps.dwCaps = DDSCAPS_VIDEOMEMORY | DDSCAPS_TEXTURE | DDSCAPS_ALLOCONLOAD;
else
ddsd.ddsCaps.dwCaps = DDSCAPS_SYSTEMMEMORY| DDSCAPS_TEXTURE;

if (DirectDraw->CreateSurface(&ddsd, &DeviceSurface, NULL) != DD_OK)
goto error;

//
// create a system memory surface for the texture.
//
// we use this system memory surface for the ::Load call
// and this surface does not get lost.
//
if (hal.dcmColorModel)
{
ddsd.ddsCaps.dwCaps = DDSCAPS_SYSTEMMEMORY | DDSCAPS_TEXTURE;

if (DirectDraw->CreateSurface(&ddsd, &MemorySurface, NULL) != DD_OK)
goto error;
}
else
{
//
// when dealing with a SW rasterizer we dont need to make two
// surfaces.
//
MemorySurface = DeviceSurface;
DeviceSurface->AddRef();
}

//
// create a palette for the texture
//
if (ddsd.ddpfPixelFormat.dwRGBBitCount SetPalette(Palette);
DeviceSurface->SetPalette(Palette);
}

//
// copy the bitmap to our surface
//
if (!Copy(Bitmap))
goto error;

//
// get the texture handle
//
IDirect3DTexture2 * Texture;
DeviceSurface->QueryInterface(IID_IDirect3DTexture2, (void**)&Texture);
Texture->GetHandle(Device, &Handle);
Texture->Release();

//
// we are done, delete the bitmap (we made a copy) and return.
//
DeleteObject(Bitmap);
return TRUE;

error:
if (Bitmap)
DeleteObject(Bitmap);
Release();
return FALSE;
}

Follow Ups:

Post a Followup

Name:


Re: Help Please Direct 3D

Posted by Fragmo on August 09, 1998 at 20:30:48:

In Reply to: Re: Help Please Direct 3D posted by Shai'tan [ Nth ] on August 09, 1998 at 16:57:19:

: : : Hi Fragmo,

: :16 bit z buffers just plain suck for accuracy.

perhaps i should add, for large ranges of z values, they suck for accuracy ;)

: Well, my 16 bit ZBuffer can handle distances far greater than 29. So I am tending to think that there is perhaps something else wrong? My near clip plane is set at 1 and my far clip plane is at 1000. It depends what sort of game your doing I suppose...for terrain / ground games you don't really need a very large far clip plane...just try 1 to 1000 until you get it working?

i think you missed my point, the reason the z buffer isn't performing well is because the separation between the 2 objects is 1 unit.
anything that close together won't be drawn properly unless it's very close to the viewpoint. and the only way to fix this is to shrink the
range of possible z values, or to use a more accurate z buffer

Fragmo
www.public.iastate.edu/~jtilton/gamepage.html

Follow Ups:

  • correct me if I'm wrong... Clay 08:04:41 8/11/98 (1)
    • Re: correct me if I'm wrong... Fragmo 21:07:57 8/11/98 (0)

Post a Followup

Name:


Direct3D 6.0 IM Framework tutorial

Posted by Wolfgang Engel on August 10, 1998 at 04:25:35:

There's a new tutorial on the brand new Direct3D 6.0 IM Framework at http://www.netit.net/direct3d/.

Follow Ups:

Post a Followup

Name:


Re: Help Please Direct 3D

Posted by Dave Burrows on August 10, 1998 at 05:37:11:

In Reply to: Help Please Direct 3D posted by Karl Fisher on August 07, 1998 at 15:32:04:

The near clipping value is far to small.

Don't forget that these numbers have to be converted into 16bit by some means.

This means that a value of 0.01 gives 0 in 16bits and a value of 1000 gives 65535 in 16bits.
(depending on the z-buffer formular).

This sounds fine and seems that it would give you a buffer resolution of 0.01525 ((1000-0.01)/65535).
But it doesn't.

The reason being is that most z-buffers formulars or non-linear. The buffers store 1/z instead.
(the main reason for this is that you can linearly propergate 1/z along a scan line,
there are other reasons which other people will mention).

As its a 1/z formular 0.01 will give us 65535 and 1000 will give us 0.
There fore the equation becomes
ZB value = C / Z
giving us
C = ZB Value * Z
This would then give a value of C=655.35 (65535/0.01)

There fore putting your Z values come out as
Z=19 ZB Value = 34.49 (655.35/19)
Z=20 ZB Value = 32.76 (655.35/20)

This comes down to hardly no change at all.
Do not forget that this is a quick formular and would have other values in it.

The end result is that the Z-Buffer being non-linear tends to push all its values up towards the near clip region.
This tends not to be a problem as this is where the object are largest and you want more definition.

Therefore the problem you have is that anything after a Z distance of about 3 will only be using the last 8 bits of the Z-Buffer.
And anything after 40 Z units will only be using a 4bit buffer.

There fore the question is:-
If you are working within the 10s and 20s area why do you need the clipping to be done at 0.01 units.

I would surgest using a near clipping distance of (Far clipping)/256 as a reasonable value.

PS. I would like to point out that all the above equations are purly approximate.
The ideas and units are about right but in no way are they the final versions.
Therefore do not respond to this with statments like "you havent added the "blar blar" value"
if that value wouldn't have changed the overall idea of an parabolic output for the Z formular.

Follow Ups:

Post a Followup

Name:


Need help with a 3dsmax to DX converter for meshes

Posted by Leathrewulfe on August 10, 1998 at 13:53:44:

I need to convert a 3dsmax animated model directly to .x format for use with D3D. I can't convert to .3ds format then to .x format either, because the model gets screwed up in the conversion to .3ds. Besides .3ds format is garbage :) Anyone have a plugin or know where one is to fix my problem?

Follow Ups:

Post a Followup

Name:


Re: advice for newbie

Posted by satan on August 10, 1998 at 15:22:41:

In Reply to: Re: advice for newbie posted by Tex Murphy on August 07, 1998 at 12:09:06:

1. before you learn how to program in c/c++ with directx, you need to learn how to become a civilized adult. there is plenty of good literature on the topic, you should start off with "english for dummies", then "not furthering the antisocial programmer for dummies", and finally if your up to it "sex for dummies".

2. next, play with friends, or if you don't have any (i wouldn't be shocked), play with some gi joes (the ones under your bed). remember the most important thing is gameplay.

3. third, like you said, go to compusa and ask THEM to write the program for you after they install directx for you. you are obviously incompetent.

4. i'll be waiting for you in hell, little man child.

-satan

Follow Ups:

Post a Followup

Name:


Rotating bitmaps using DirectX6

Posted by Jeremy on August 10, 1998 at 15:50:35:

Hello, I recently posted a question about trying to rotate
bitmaps using DirectDraw. The general concensus seems to
be that the feature just plain didn't work in DirectX5.
I just installed the DirectX6 SDK (release not Beta) and
tried again to rotate bitmaps using the same code. Still
didn't work. Does anyone know if this has been addressed
with version 6? Right now I'm attempting to Blit using
the DDBLT_ROTATIONANGLE flag. Is there a new function
or flag that I need to be aware of? It seems to me that
rotating a bitmap is a basic enough requirement that the
issue would have been resolved in DX6. Any help would be
appreciate. Thanks

Follow Ups:

Post a Followup

Name:


Unresolved external symbol

Posted by Luey on August 10, 1998 at 19:42:07:

When setting up my environment, I can compile my programs without errors, but when I try to link my programs, I get an unresolved external symbol _
DirectDrawCreate@12. I cannot figure out how or why. It seems to find the ddraw.h file fine, but cannot find the function in the lib file. I just started using Microsoft Visual C++ 5.0 and DirectX SDK 5.2. I copied all of the include files and library files from the DirectX SDK into the Microsoft Visual C++ lib and inc directories. This obviously overwrote the DirectX 3.0 files that came with the compiler. Does anyone have any idea on how I can resolve the link conflict ??

Follow Ups:

  • Re: Unresolved external symbol Jeremy 21:44:24 8/10/98 (1)
    • Sorry, goofed Jeremy 21:47:24 8/10/98 (0)

Post a Followup

Name:


Re: Unresolved external symbol

Posted by Jeremy on August 10, 1998 at 21:44:24:

In Reply to: Unresolved external symbol posted by Luey on August 10, 1998 at 19:42:07:

Being new to VC++ myself, this problem drove me nuts
for quite a while. After you create a project for your
program, go to the Project menu item and choose
Settings. From here, select the Link tab. Where it
says "Object/library modules" click in the text box
and go to the end of the list of libraries and type
in the name of the library that you need, i.e.
"ddraw.h". As I said, I'm new to this too, but I'm
pretty sure this will solve your problem. Good luck

Follow Ups:

  • Sorry, goofed Jeremy 21:47:24 8/10/98 (0)

Post a Followup

Name:


Sorry, goofed

Posted by Jeremy on August 10, 1998 at 21:47:24:

In Reply to: Re: Unresolved external symbol posted by Jeremy on August 10, 1998 at 21:44:24:

: Being new to VC++ myself, this problem drove me nuts
: for quite a while. After you create a project for your
: program, go to the Project menu item and choose
: Settings. From here, select the Link tab. Where it
: says "Object/library modules" click in the text box
: and go to the end of the list of libraries and type
: in the name of the library that you need, i.e.
: "ddraw.h". As I said, I'm new to this too, but I'm
: pretty sure this will solve your problem. Good luck

You should enter "ddraw.lib" not "ddraw.h" You
probably caught that, but just in case :)

Follow Ups:

Post a Followup

Name:


correct me if I'm wrong...

Posted by Clay on August 11, 1998 at 08:04:41:

In Reply to: Re: Help Please Direct 3D posted by Fragmo on August 09, 1998 at 20:30:48:

I could be mistaken about this, but I thought that Z-Buffers were linear from front to back. If that is true, then a depth range from 1 to 1000 with a 16 bit Z-Buffer has 2^16 (65536) possible "depth bins". This would mean that unless two objects were separated by less than 1000/65536 (0.015) they would appear properly.

Clay

Follow Ups:

  • Re: correct me if I'm wrong... Fragmo 21:07:57 8/11/98 (0)

Post a Followup

Name:


Re: correct me if I'm wrong...

Posted by Fragmo on August 11, 1998 at 21:07:57:

In Reply to: correct me if I'm wrong... posted by Clay on August 11, 1998 at 08:04:41:

: I could be mistaken about this, but I thought that Z-Buffers were linear from front to back. If that is true, then a depth range from 1 to 1000 with a 16 bit Z-Buffer has 2^16 (65536) possible "depth bins". This would mean that unless two objects were separated by less than 1000/65536 (0.015) they would appear properly.

: Clay

if the 0.015 separation is a 1/z value (which is what is stored in the z buffer)
then what you said is correct, but in world space, the separation would need to get larger
as you move away from the view in order to keep the proper sorting

read dave burrows message above for a better explanation

Follow Ups:

Post a Followup

Name:


How can i use d3d primary surface in retained mode

Posted by Flipper on August 12, 1998 at 04:09:05:

sorry for my english (french canadian) !!!

how can i have a pointer to all the surface used by d3d in retained mode (for movie background or for adding some sprite effects)
thank's

Follow Ups:

Post a Followup

Name:


Format of BMP files

Posted by Pet Monster on August 12, 1998 at 18:33:12:

Can anyone tell me the format of BMP files, not the header part just the main data part.

I've run into a problem where when I try to load the BMP in manually, there are some extra characters at the end of each line. Can anyone tell me what those characters mean????
Help!

Follow Ups:

  • Re: Format of BMP files Fragmo 03:39:49 8/13/98 (0)

Post a Followup

Name:


DirectDraw 5 Problem! Please Help

Posted by As Evil As They Come on August 12, 1998 at 19:42:26:

I am having problems with DirectDraw and DirectX 5 all-together.

I own some games that require DirectX 5 and I tried to install it but I get error messages like "DirectX Initiation Failed" and "DirectX Setup Error -9"

I wonder if anyone could help me and tell me and tell me what to do. I read the messages from Tex Murphy and you some of you guys didn't help him at all so I hope that you will help me.

Follow Ups:

Post a Followup

Name:


I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT???

Posted by Tex Murphy on August 13, 1998 at 01:07:17:

<

Follow Ups:

  • Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? Walla Walla 22:58:43 8/18/98 (0)
  • Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? Ha ha, a dead meat 06:44:17 8/13/98 (2)
    • Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? Tex Murphy 13:08:44 8/13/98 (1)
      • Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? Ha ha ha, what a dumb ass 09:40:57 8/15/98 (0)

Post a Followup

Name:


Re: Format of BMP files

Posted by Fragmo on August 13, 1998 at 03:39:49:

In Reply to: Format of BMP files posted by Pet Monster on August 12, 1998 at 18:33:12:

: Can anyone tell me the format of BMP files, not the header part just the main data part.

: I've run into a problem where when I try to load the BMP in manually, there are some extra characters at the end of each line. Can anyone tell me what those characters mean????
: Help!

i believe those extra characters are just padding and should be ignored,
that's how pcx files work anyway

Fragmo
www.public.iastate.edu/~jtilton/rpg.htm

Follow Ups:

Post a Followup

Name:


Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT???

Posted by Ha ha, a dead meat on August 13, 1998 at 06:44:17:

In Reply to: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? posted by Tex Murphy on August 13, 1998 at 01:07:17:

: <
The following is what you said before:
//======
I have to say that I don't think you are fucking with me because it sounds so much like my computer status now.

I don't need to worry about DirectX right now because I am taking my computer into a local computer store
//=======

I don't think anyone here should give you any help after you said _fu$k_ to them.

[i have to say that, i m glad to see you computer stuff up, and wish it never work again]

Regards... LoL

Follow Ups:

  • Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? Tex Murphy 13:08:44 8/13/98 (1)
    • Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? Ha ha ha, what a dumb ass 09:40:57 8/15/98 (0)

Post a Followup

Name:


international versions of the DirectShow runtime

Posted by Gregg Plummer on August 13, 1998 at 10:27:40:

I'm looking for the international versions of the DirectShow (QUARTZ.DLL) v5.2a runtime as well as the international versions of the COMCTL32.DLL v4.72. Does anybody know where to go about located these items?

Please reply to my email address.

greggp@sonicfoundry.com

Thanks.

Follow Ups:

Post a Followup

Name:


Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT???

Posted by Tex Murphy on August 13, 1998 at 13:08:44:

In Reply to: Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? posted by Ha ha, a dead meat on August 13, 1998 at 06:44:17:

FUCK YOU, YOU SON OF A WHORE!

CAN YOU HELP ME OR NOT?

Follow Ups:

  • Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? Ha ha ha, what a dumb ass 09:40:57 8/15/98 (0)

Post a Followup

Name:


Re: Getting a DirectSoundNotify Interface

Posted by Gilles Pommereuil on August 13, 1998 at 13:50:36:

In Reply to: Getting a DirectSoundNotify Interface posted by Footh on May 28, 1998 at 15:52:34:

I have had exactly the same problem as yours. I "resolved" it by linking my project with the dxguid.lib library from the dxsdk.
Now it compiles, but however, the QueryInterface method returns me the E_NOINTERFACE error code. If you achieve the compilation of your project, can you tell me if the QueryInterface method succeeds ?

Follow Ups:

Post a Followup

Name:


Getting DirectSoundBuffer Notification Interface

Posted by Gilles Pommereuil on August 13, 1998 at 13:57:41:

My calls to the QueryInterface methods to get the Notification interface of a DirectSoundBuffer always return the E_NOINTERFACE method. I don't know if it comes from :
- the current DirectX version
- my problems (apparently resolved) for linking DirectX using Borland C++
- my soundcard driver
- others...

If you use the Notification interface, any help welcome !

Follow Ups:

  • Re: Getting DirectSoundBuffer Notification Interface Denny Bromley 14:51:52 9/02/98 (0)

Post a Followup

Name:


DDSurface Locking?

Posted by Nick Weihs on August 13, 1998 at 14:34:45:

I'm trying to make a prog that will track the path of the mouse with a small rectangle, but when I try lock the surface, it freezes my comp (terminates with code 0 if I'm debugging). I can't get the device context either. Can someone tell me how to fix this please?

Follow Ups:

  • Re: DDSurface Locking? Ravi Joshi 12:00:09 8/14/98 (0)
  • Re: DDSurface Locking? Fragmo 15:56:19 8/13/98 (0)

Post a Followup

Name:


Re: DDSurface Locking?

Posted by Fragmo on August 13, 1998 at 15:56:19:

In Reply to: DDSurface Locking? posted by Nick Weihs on August 13, 1998 at 14:34:45:

DDSURFACEDESC ddsd;
ddsd.dwSize = sizeof(DDSURFACEDESC);
if (YOUR_SCREEN->Lock(NULL,&ddsd,DDLOCK_WAIT,NULL) == DD_OK)

if your lock statement looks something like this, then make sure you are setting
up the surface properly

Fragmo
www.public.iastate.edu/~jtilton/rpg.htm

Follow Ups:

Post a Followup

Name:


Error Handling in DirectDraw

Posted by Berk on August 13, 1998 at 16:27:07:

I know it's good practice to check for DD_OK when making
directdraw function calls but how do you interpret the
return value if it's anything else but DD_OK. I've written
a short routine which prints out the binary value of the
error code but cannot find anything in the references which
tell what the values of the DDERRs are. I've looked in the
ddraw.h file but it looks as if the values are changed there
as they do not coincide with the values I'm getting. Any
ideas? Thanks for any help you can offer.

Follow Ups:

  • Re: Error Handling in DirectDraw Ludovic Tirtiaux 09:51:26 8/18/98 (0)

Post a Followup

Name:


Problems with Direct3dRM in direct X 6

Posted by Travis on August 13, 1998 at 16:55:45:

I'm using borland C++ builder 1 and the new direct x sdk and am having problems unallocating directdraw surfaces. I copied the code from the samples...(rmmain.h). I have not tryed to rebuild the libraries, I just used the ones that were shipped under borland. I recall that in the previous version the borland libraries were screwed up! Could this be the case again. Looking at the debug output, it says:
DDraw:Memory still allocated! Alloc count = 15
DDraw:Current Process (pid) = fff7aaa7
DDraw:8329e00c: dwSize=00000008, lpAddr=baaf30fe (pid=fffd18d3)
DDraw:8329ee4c: dwSize=00000008, lpAddr=baaf30fe (pid=fff7aaa7)
DDraw:8329ee70: dwSize=0000001d, lpAddr=bab37a2e (pid=fff7aaa7)
DDraw:8329eeac: dwSize=00000019, lpAddr=bab37a2e (pid=fff7aaa7)
etc.
Now I have not worked too much with the debugger and am uncertain where these objects have come from! Could they be just pointers? Because it seems that everything else was released! any advice would be greatly apprectiated! If you know of any Direct3dRm tutorials using the Meshbuilder interface I would also be grateful.

Thanx Travis

Follow Ups:

Post a Followup

Name:


DOES ANYBODY NOW HOW TO FIX MY DIRECT SOURCE MEDIA??? NT

Posted by Tex Murphy on August 13, 1998 at 20:52:42:

>

Follow Ups:

  • Re: DOES ANYBODY NOW HOW TO FIX MY DIRECT SOURCE MEDIA??? NT ding@ 09:42:30 8/15/98 (0)

Post a Followup

Name:


How to programm a DirectShow Application in Visual C++ ?

Posted by Jochen on August 13, 1998 at 23:17:39:

How to programm a DirectShow Application in Visual C++ ?
Or do anybody know some realy good book about DirectShow ?

Jochen

Follow Ups:

  • Re: How to programm a DirectShow Application in Visual C++ ? John Giors 15:03:38 8/17/98 (0)

Post a Followup

Name:


I'VE MODIFIED AN EXISTING CLASS TO MAKE TEXTURE, BUT THAT DON'T WORK?????????????

Posted by kovax on August 14, 1998 at 09:09:43:

Here is my modified source, the original source load the texture from a file and now i would to load the texture from an existing array char *[], see this source, and help me please!!!!!!

BOOL D3DTexture::Load(IDirect3DDevice2 *Device, int dat)
{
DDSURFACEDESC ddsd;
IDirectDraw * DirectDraw;
char *targets;
target=0;

//
// we need a IDirectDraw so we can create a surface.
//
if ((DirectDraw = GetDD(Device)) == NULL)
return FALSE;

// HERE, I THINK THAT IT MISSED INFORMATION IN THE PIXEL FORMAT , BUT WHAT???????????????

ZeroMemory(&ddsd, sizeof(ddsd));
ddsd.dwSize = sizeof(ddsd);
// ChooseTextureFormat(Device, bm.bmBitsPixel, &ddsd.ddpfPixelFormat);
ddsd.dwFlags |= DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT | DDSD_LPSURFACE;
ddsd.ddpfPixelFormat.dwRGBBitCount=8;
ddsd.dwWidth = 256;
ddsd.dwHeight = 256;

D3DDEVICEDESC hal, hel;
ZeroMemory(&hal, sizeof(hal));
hal.dwSize = sizeof(hal);
ZeroMemory(&hel, sizeof(hel));
hel.dwSize = sizeof(hel);
Device->GetCaps(&hal, &hel);

ddsd.ddsCaps.dwCaps = DDSCAPS_SYSTEMMEMORY| DDSCAPS_TEXTURE | DDSD_PIXELFORMAT ;

if (DirectDraw->CreateSurface(&ddsd, &DeviceSurface, NULL) != DD_OK) goto error;

// load palette
clutid=(gpuData[2]>>16);
if(CachedClutId!=clutid){
CachedClutId=clutid;
LoadPalette(1,((gpuData[2]>>12) & 0x3f0), ((gpuData[2]>>22) & 0x1ff));
}

textt->GetPixelFormat(&ddsd.ddpfPixelFormat);
// HERE , IS THE COPY FUNCTION, FROM THE FAMOUS ARRAY TO THE TEXTURE SURFACE PREVIOUSLY CREATED?????

textt->Lock(NULL,&ddsd,DDLOCK_SURFACEMEMORYPTR,NULL);
targets=(char *)ddsd.lpSurface;
switch (dat){
case 0:
break;
case 1:
for(column=0;columnUnlock(NULL)!=DD_OK;
//
// get the texture handle
//
IDirect3DTexture2 * Texture;
DeviceSurface->QueryInterface(IID_IDirect3DTexture2, (void**)&Texture);
Texture->GetHandle(Device, &Handle);
Texture->Release();
return TRUE;

error:
Release();
return FALSE;
}

Follow Ups:

  • Re: I'VE MODIFIED AN EXISTING CLASS TO MAKE TEXTURE, BUT THAT DON'T WORK????????????? Fragmo 22:01:25 8/14/98 (0)

Post a Followup

Name:


How to properly minimize a full screen directX app?

Posted by Karsten Wilson on August 14, 1998 at 11:47:40:

I am writing a simple vb5 test program to learn about direct X. I am able to get into direct X and do what I want to do, however, if a user presses Alt-TAB and goes to a different application, I don't get an icon in the taskbar for my app! This seems to be because my form has no border. If I add a border, I get an icon, but I don't want a border.

Any ideas?

Follow Ups:

  • Re: How to properly minimize a full screen directX app? BoxMan 16:34:30 8/19/98 (0)

Post a Followup

Name:


Re: DDSurface Locking?

Posted by Ravi Joshi on August 14, 1998 at 12:00:09:

In Reply to: DDSurface Locking? posted by Nick Weihs on August 13, 1998 at 14:34:45:

IT is generally difficult to lock a perticular area on the screen. It is possible to lock the entire
screen with Lock(NULL,&ddsd,DDLOCK_WAIT,NULL) statement. But if you try to lock a perticular area on the
screen with Lock( &rect, &ddsd,DDLOCK_WAIT,NULL); chances are that the comp will hang. Atleast mine hangs.

Follow Ups:

Post a Followup

Name:


DX6 RM. Where are the docs?

Posted by Pablo de Heras on August 14, 1998 at 12:36:30:

Hi,

I've been looking for the Retained Mode DirectX 6.0 documentation but haven't found anything on the subject in the 90 MB file SDK. DX5 has docs on RM but DX6 hasn't. Why? Is it so obvoius that you only have to look at the .h file to use the new interfaces, IDirect3DRM3 for example?

Is it me? / Pablo de Heras

PS. Chop this file into months please :) It is quit long now.

Follow Ups:

  • Re: DX6 RM. Where are the docs? ding@ 09:44:14 8/15/98 (0)

Post a Followup

Name:


DIRECTX.CPL : file is missing

Posted by Gary on August 14, 1998 at 19:51:52:

:After d/ling directx 6.o, i opened the dxinfo.exe file to see the results.
Under the section called Components correctly loaded in c:\WINDOWS\SYSTEMS, it has : file is missing for DIRECTX.CPL
Is this importtant or not? If it is not a biggy to have DIRECTX.CPL missing, let me know at chandler@bookmark.com please? If it is a file which is mandatory for Directx6.0, tell me how to implant it and from where?

Follow Ups:

  • Re: DIRECTX.CPL : file is missing ding@ 09:48:43 8/15/98 (1)
    • Re: DIRECTX 5.0 : file is missing KENT COUSINS 15:25:53 8/17/98 (0)

Post a Followup

Name:


Re: I'VE MODIFIED AN EXISTING CLASS TO MAKE TEXTURE, BUT THAT DON'T WORK?????????????

Posted by Fragmo on August 14, 1998 at 22:01:25:

In Reply to: I'VE MODIFIED AN EXISTING CLASS TO MAKE TEXTURE, BUT THAT DON'T WORK????????????? posted by kovax on August 14, 1998 at 09:09:43:

: ZeroMemory(&ddsd, sizeof(ddsd));

**** try adding the following line ******
ddsd.ddpfPixelFormat.dwSize = sizeof(DDPIXELFORMAT);

: ddsd.dwSize = sizeof(ddsd);
: // ChooseTextureFormat(Device, bm.bmBitsPixel, &ddsd.ddpfPixelFormat);
: ddsd.dwFlags |= DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT | DDSD_LPSURFACE;
: ddsd.ddpfPixelFormat.dwRGBBitCount=8;
: ddsd.dwWidth = 256;
: ddsd.dwHeight = 256;

Fragmo
www.public.iastate.edu/~jtilton/rpg.htm

Follow Ups:

Post a Followup

Name:


voodoo2 and fill rate

Posted by Clay on August 15, 1998 at 09:36:05:

Does anybody know how the voodoo2 handles fill rate and clipping. I'm using GetClipStatus() to figure out when on the screen I'm drawing with DrawPrimitive(). It always says that I'm using drawing to the whole screen (640x480), even when I know I'm not.

Given the voodoo2 fill rate of 90,000,000 pixels/second, the fastest full-screen frame rate should be ~292 fps. With simple shapes (like 3,6, or 18 polygons) I get frame rates from between 150 fps when my polygons completely fill the screen (close to camera) to 350 fps when my polygons are small (far from the camera). Can anyone explain this? If I draw (a la GetClipStatus()) to the entire screen every frame, where is the optimization coming from that I can get 350 fps?

Clay

Follow Ups:

Post a Followup

Name:


Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT???

Posted by Ha ha ha, what a dumb ass on August 15, 1998 at 09:40:57:

In Reply to: Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? posted by Tex Murphy on August 13, 1998 at 13:08:44:

: CAN YOU HELP ME OR NOT?
Ha ha ha ha

Of cause i CAN help you. No doubt about that, [if i can't , who else can??, (a joke)], but the Question remains SHOULD i help you, [ because you are a such idiot]

I personaly don't think i should help a dickhead in anyway, neither should anyone else.

Hahaha.

Eat that!!

btw, enjoy your fucking broken computer!! la la la

Follow Ups:

Post a Followup

Name:


Re: DOES ANYBODY NOW HOW TO FIX MY DIRECT SOURCE MEDIA??? NT

Posted by ding@ on August 15, 1998 at 09:42:30:

In Reply to: DOES ANYBODY NOW HOW TO FIX MY DIRECT SOURCE MEDIA??? NT posted by Tex Murphy on August 13, 1998 at 20:52:42:

what media??

Follow Ups:

Post a Followup

Name:


Re: DX6 RM. Where are the docs?

Posted by ding@ on August 15, 1998 at 09:44:14:

In Reply to: DX6 RM. Where are the docs? posted by Pablo de Heras on August 14, 1998 at 12:36:30:

: I've been looking for the Retained Mode DirectX 6.0 documentation but haven't found anything on the subject in the 90 MB file SDK. DX5 has docs on RM but DX6 hasn't. Why? Is it so obvoius that you only have to look at the .h file to use the new interfaces, IDirect3DRM3 for example?

hmm.. interesting... The RM docs are in the SDK help along with other RM tutorial and samples.
[under the DirectX media]

: PS. Chop this file into months please :) It is quit long now.

Follow Ups:

Post a Followup

Name:


Re: DIRECTX.CPL : file is missing

Posted by ding@ on August 15, 1998 at 09:48:43:

In Reply to: DIRECTX.CPL : file is missing posted by Gary on August 14, 1998 at 19:51:52:

Is this importtant or not? If it is not a biggy to have DIRECTX.CPL missing, let me know at chandler@bookmark.com please? If it is a file which is mandatory for Directx6.0, tell me how to implant it and from where?
//------------------------------
Are you using SDK or enduser run-time??,

If you are using the run-time only, the directx.cpl is not important to you at all. DirectX team doesn't pack it into the enduser download. because they believe the cpl will just confusing the end-user

however, if you r a developer using SDK, you better to have such thing inside your control panel. it tells you your system's directX config, for example, the GUID for D3DHAL, ddraw memory/capabilities... etc etc...

Follow Ups:

  • Re: DIRECTX 5.0 : file is missing KENT COUSINS 15:25:53 8/17/98 (0)

Post a Followup

Name:


Small Problem With Direct Draw Surfaces...

Posted by Laikos on August 15, 1998 at 16:32:40:

Hello, here is my problem... And I dont know much about programming in DirectX because this is my friend's program im trying to get help with.. He is to busy to post this himself.. heh...

OK The problem is - Whenever we minimize (Alt-Esc) the program, it crashes and gives an error... :
"Run-Time error '-2005532222 (887601c2)':
Automation error"

Does anyone know how we can fix this? He knows that its something to do with the Reloading of the Direct Draw surfaces... But he has no clue how to fix it...

Any help is greatly appreciated, Please E-Mail me a reply as I wont be on till late tonight..

Laik

Follow Ups:

Post a Followup

Name:


DirectX 5.0

Posted by Luke on August 15, 1998 at 21:32:35:

I just purchased Need for Speed II SE and tried installing the DirectX 5.0 software for video and sound cards that came with it. Unfortunately, I was unable to run the game after installation. I have the Lightspeed 128 video card as well as Ensoniq Vivo PnP sound card. Am I doing something wrong?

Follow Ups:

  • Re: DirectX 5.0 Martin 14:09:22 9/27/98 (1)
    • Re: DirectX 5.0 Greg 04:07:41 9/28/98 (0)

Post a Followup

Name:


Re: How to programm a DirectShow Application in Visual C++ ?

Posted by John Giors on August 17, 1998 at 15:03:38:

In Reply to: How to programm a DirectShow Application in Visual C++ ? posted by Jochen on August 13, 1998 at 23:17:39:

I recently added a DirectShow interface to our flight-sim game. It's for playing the intro anim, between-missions anims, etc. To tell the truth, I needed a lot of aspirin!

The DirectShow interface can really behave poorly when the computer has trouble keeping up the data rate. Rather than just dropping one or two frames, it may completely unsync the video from the audio, or it may drop large numbers of frames, displaying only one frame every few seconds.

On higher-end systems (300 MHz and above), you probably won't have many problems if you stick to animations no larger than 640 x 480 (24 bit is okay). I only had problems on systems 200 MHz and below.

I was able to get acceptable performance on 200 MHz and lower systems by rendering the .AVI file without keyframes (there is only one keyframe at the begining of the file). The video quality is poor without additional keyframes, but I am now experimenting with higher data rates.

I also found that the Cinepak video CODEC was the least problematic, although it does not have the best video output quality (the Intel Indeo CODEC had better video quality, but I ran into more performance issues with it).

The audio CODEC is not nearly as critical--I chose the ADPCM codec for our application because of the simplicity of its algorithm (it doesn't steal much processor tiem).

Now, after all my warnings about using DirectShow, if you still want to use it, I recommend checking the documentation that comes with the DirectX Media SDK. Most likely, you will need to render to a DirectDraw surface, in which case, the "showstrm.cpp" example file is the one you'll want to check out. If you only need to display to the Desktop/GDI surface, you might want to consider using the ActiveMovie control as your interface.

There's much more that I could write, but this should easily be enough to get you started.

Good luck!

: How to programm a DirectShow Application in Visual C++ ?
: Or do anybody know some realy good book about DirectShow ?

: Jochen

Follow Ups:

Post a Followup

Name:


Re: DIRECTX 5.0 : file is missing

Posted by KENT COUSINS on August 17, 1998 at 15:25:53:

In Reply to: Re: DIRECTX.CPL : file is missing posted by ding@ on August 15, 1998 at 09:48:43:

: Is this importtant or not? If it is not a biggy to have DIRECTX.CPL missing, let me know at chandler@bookmark.com please? If it is a file which is mandatory for Directx6.0, tell me how to implant it and from where?
: //------------------------------
: Are you using SDK or enduser run-time??,

: If you are using the run-time only, the directx.cpl is not important to you at all. DirectX team doesn't pack it into the enduser download. because they believe the cpl will just confusing the end-user

: however, if you r a developer using SDK, you better to have such thing inside your control panel. it tells you your system's directX config, for example, the GUID for D3DHAL, ddraw memory/capabilities... etc etc...

Follow Ups:

Post a Followup

Name:


A ready to compile sample ... please

Posted by Guillaume APOSTOLY on August 18, 1998 at 03:36:43:

Hi,
I'm just starting with DirectX6 (especially Direct 3D), and I can't compile any of the samples provided with the SDK. If someone could send me a project for MSVC 5 ,that just want to compile and draw a triangle on a specified 3D device, I'll be very pleased !
Tnx a lot 8�)

Follow Ups:

  • Re: A ready to compile sample ... please EvAcLeAr 22:48:55 8/18/98 (2)
    • Re: A ready to compile sample ... please Snowman 17:00:44 8/20/98 (1)
      • Re: A ready to compile sample ... please EvAcLeAr 03:30:56 8/21/98 (0)

Post a Followup

Name:


Re: Error Handling in DirectDraw

Posted by Ludovic Tirtiaux on August 18, 1998 at 09:51:26:

In Reply to: Error Handling in DirectDraw posted by Berk on August 13, 1998 at 16:27:07:

For debugging purpose, I have written a very simple function that interprets DD functions return codes. It's mainly a switch. It can then display the result on the screen, or write it in a file (not good for fps rate).
It is not optimized, because it will not be present in final application.

Basically, it looks like that:

int TestDD(HRESULT result)
{
char *errname;

switch (result) {
case DD_OK:
return 0;
case DDERR_EXCLUSIVEMODEALREADYSET:
errname = "DDERR_EXCLUSIVEMODEALREADYSET ";
// Some code here
break;
case DDERR_HWNDALREADYSET:
errname = "DDERR_HWNDALREADYSET ";
// Some code here
break;
case DDERR_HWNDSUBCLASSED:
errname = "DDERR_HWNDSUBCLASSED";
// Some code here
break;
case DDERR_GENERIC:
errname = "DDERR_GENERIC";
// Some code here
break;

// A lot of other cases here

default:
errname = "Unknown error";
// Some code here. Probably, a new case has to be added in the list
}
// Here, display/print/write the error name and some other useful information
return -1;
}

I have added in the error list all return values that may be returned by DD functions I use.

I hope it helps.

Follow Ups:

Post a Followup

Name:


Re: Problem with the IDirect3DRMAnimationSet::Load

Posted by Fred on August 18, 1998 at 12:35:07:

In Reply to: Re: Problem with the IDirect3DRMAnimationSet::Load posted by Andreas on June 30, 1998 at 20:28:47:

I got an answer for Microsoft's _private_ directx newsgroup.

The overall idea is about the same as yours, Load & rename. but it is not necessary to rename the mesh/meshbuilder objects, what you need is to rename all the frame to NULL.

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Tuesday Assassin on August 18, 1998 at 21:27:17:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0.

Follow Ups:

Post a Followup

Name:


Re: A ready to compile sample ... please

Posted by EvAcLeAr on August 18, 1998 at 22:48:55:

In Reply to: A ready to compile sample ... please posted by Guillaume APOSTOLY on August 18, 1998 at 03:36:43:

: Hi,
: I'm just starting with DirectX6 (especially Direct 3D), and I can't compile any of the samples provided with the SDK. If someone could send me a project for MSVC 5 ,that just want to compile and draw a triangle on a specified 3D device, I'll be very pleased !
: Tnx a lot 8�)

The samples that came with the SDK will compile but you can't just open one of the *.CPP files & goto compile, you have to open the *.MAK file (there is only 1 i think) and compile that! It took me a long time to figure that one out.... the problem with compiling that make file is that it will compile every single sample that came with directX. But I'm sure you can modify it or create your own once you open it & see what's inside. Good luck.

Follow Ups:

  • Re: A ready to compile sample ... please Snowman 17:00:44 8/20/98 (1)
    • Re: A ready to compile sample ... please EvAcLeAr 03:30:56 8/21/98 (0)

Post a Followup

Name:


Re: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT???

Posted by Walla Walla on August 18, 1998 at 22:58:43:

In Reply to: I AM HAVING THE SAME PROBLEM AS BEFORE BUT I'VE NARROWED IT DOWN. THE NEW MESSAGE I GET IS DIRECT MEDIA CORRUPT. HOW DO I FIX IT??? posted by Tex Murphy on August 13, 1998 at 01:07:17:

: <

Have you checked out the web page that linked you here? It's a developers web page for people who make programs that use directX to run (Mostly Games). I believe that's what this web board was put here for us developers. We do how ever take time to answer some questions relating to directX problems out of the pure kindness of our hearts. Personaly I refuse to answer any question asked in all capital letters because it just proves to everyone you should not be touching a computer let alone on the internet. If you want a real answer to this question of yours why not try going to www.microsoft.com they make direct X and you can post your question in their directX news groups and maybe if you stop with all the Capital Letters & your rudeness you'll get a reply

Follow Ups:

Post a Followup

Name:


Re: OH COME ON GUYS, HELP ME WITH MY DIRECTDRAW PROBLEM!!!!!!!!!!!!!!!!!! IT SHOULD BE VERY SIMPLE FOR YOU eXPERTS OUT THERE!!!!!!

Posted by Walla Walla on August 18, 1998 at 23:03:02:

In Reply to: OH COME ON GUYS, HELP ME WITH MY DIRECTDRAW PROBLEM!!!!!!!!!!!!!!!!!! IT SHOULD BE VERY SIMPLE FOR YOU eXPERTS OUT THERE!!!!!! posted by DirectX-=NeWbIe=- on August 04, 1998 at 12:23:40:

: when ever I load a program that needs to use directdraw, a message box pops out saying "Beta DirectDraw expired, please update" I tried to install DX6 but still doesn't WORK!!!!!! PLEASE HELP!!!!!!!!!! :) ;( :)

Umm BETA DIRECT DRAW EXPIRED? Gee that tells me your using a beta version of direct X 6.0 that expired!!! So UNINSTALL it and download the new version of direct X 6.0 that is not beta! The Keyword here is UNINSTALL.

P.S. Save our eyes no more caps K?

Follow Ups:

Post a Followup

Name:


I can't get colorkeying working with texturing !

Posted by St�phane Pouyet on August 19, 1998 at 10:01:37:

I have my 3D engine working. I use 8bits texture (palettized...) and gouraud, all being rendered thanks to DrawPrimitive. The problem is when I set some colorkeing : I set colorkey in the renderstate, I specify what is the color key via SetColorKey, and it gives me some weird rendering (Some gourauds are missing). More weird : when i change the colorkey, from 2 to 1, it trashes even more faces. However, I can see the colorkeying is done, but all the others faces are screwed up.
I already have read a lot of documentation all over the net, and all I do is perferct (according to all these docs). What could be the problem ???

Follow Ups:

Post a Followup

Name:


BltFast

Posted by Bardya on August 19, 1998 at 10:37:17:

Does anyone know if there is a problem with BltFast from an off surface to a 1280x1024 surface?

It works fine for lower resolutions but not for 1280x1024 and higher! It doesn't seem that it is copying properly?

Thx

Follow Ups:

  • Re: BltFast Jonas 21:06:26 8/19/98 (0)

Post a Followup

Name:


DirectSound won't work in a DLL -- NT problem

Posted by Lance Durham on August 19, 1998 at 11:30:01:

Our customer requires a DLL that takes care of all of the details of DirectSound. The DLL must be linked explicitly using LoadLibrary(). The DirectSound objects and all buffers are created by the DLL.

When I try to call DirectSoundCreate(), the process locks up. The DLL and test program both work fine under Win95, but other aspects of the project require NT4.

I am using VC5 on NT4WS, SP3.

Any help would be greatly appreciated,
Lance Durham

Follow Ups:

Post a Followup

Name:


Re: How to properly minimize a full screen directX app?

Posted by BoxMan on August 19, 1998 at 16:34:30:

In Reply to: How to properly minimize a full screen directX app? posted by Karsten Wilson on August 14, 1998 at 11:47:40:

: If I add a border, I get an icon, but I don't want a border.

: Any ideas?

Well you could always try adding and removing the border during run-time -- like...when your application minimizes, add a border to your form. When it's maximized once again, remove the border. That's kind of a hacker's way out of things, but it should work. Then again, there's probably an easier way out of things -- I just don't know vb5 all that well.

  • The Programmer's Ultimate Resource

Follow Ups:

Post a Followup

Name:


Palettes and Lost surfaces

Posted by Mike Lindegarde on August 19, 1998 at 19:27:01:

I am makeing an effort to learn how to use palitized display modes with DirectX 5, and I have come across an odd problem. In the program I first create a primary surface and I then attach a palette to it ( I load the palette with DDLoadPalette ). From there I simply create an Offscreen surface and I load an image onto it. I then try to bltfast the image to the primary surface. When I do this bltfast returns a lost surface error. I have no idea why. Any help would be apriciated. If you would like to look at the source code simple ask me for it, and I will send it.

Follow Ups:

Post a Followup

Name:


Re: BltFast

Posted by Jonas on August 19, 1998 at 21:06:26:

In Reply to: BltFast posted by Bardya on August 19, 1998 at 10:37:17:

: Does anyone know if there is a problem with BltFast from an off surface to a 1280x1024 surface?

: It works fine for lower resolutions but not for 1280x1024 and higher! It doesn't seem that it is copying properly?

: Thx

First, I am going to assume you are in fullscreen mode and at a Bit depth of 8 and using page flipping. With that said the amount of vid mem need just to hold the primary and backbuffer surface is at least 2.62 megs. Then you would need an additional 1.31 (total of 3.93) megs of vid mem to create the surface. Remeber BltFast only works on surfaces in Video Memory. With that said you need to have video card with at least 4Megs of ram if not more for what you are trying to do to work. any ?'s

Jonas

Follow Ups:

Post a Followup

Name:


CreateDevice doesn't work with Voodoo2???

Posted by Dark Blade on August 20, 1998 at 11:15:18:

I have create huge 3dlibrary (dll) and im really proud
of it =).. (i don't know yet if it will be released
because it was created for the game of ours..)

but there is a problem in it. It works on HAL nicely
with Riva128 and voodoo and other cards but not on
voodoo2 cards =(
anyone has any ideas what is up.
i use immediate mode and drawprimitive method with
D3D2 and D3DDevice2. Call is this.
(rval = lpD3D->CreateDevice(IID_IDirect3DHALDevice,bsurface,&device);)
why this call fails on Voodoo2 cards and works with
others? And in d3d examples executebuffer interface
D3DDevice can detect and use guids. Why can't them be
used in CreateDevice call? (or can them?)

and another problem is this when i render stuff with
DrawPrimitive call.. BegicScene,DrawPrimitive,EndScene
and after that when i try to free the array of vertices
sended to DrawPrimitive, the free() call fails and error
occures..
so does DrawPrimitive free array itself or is memory
locked or what is the problem. There will not come
error if i translate the vertex array and render it
again.. but that free wont work and windows error
comes..

PLEASE HELP ME!!

Follow Ups:

  • Re: CreateDevice doesn't work with Voodoo2??? Clay 07:05:34 8/21/98 (0)

Post a Followup

Name:


vbasic 6.0 and directx support

Posted by peter harrison on August 20, 1998 at 11:28:15:

do you know if vbasic6.0 will support directx?

Follow Ups:

Post a Followup

Name:


Re: A ready to compile sample ... please

Posted by Snowman on August 20, 1998 at 17:00:44:

In Reply to: Re: A ready to compile sample ... please posted by EvAcLeAr on August 18, 1998 at 22:48:55:

What are you talking about? There's a MAK file for everyone of the samples! It's in the directory with the source. If you still can't get the samples to compile, tell us what kind of errors you're getting, and we'll help you out.

-Snowman

Follow Ups:

  • Re: A ready to compile sample ... please EvAcLeAr 03:30:56 8/21/98 (0)

Post a Followup

Name:


What does this error messga mean?

Posted by Jones on August 21, 1998 at 03:29:53:

Hi, all guys:

I just ported my game to DX6.
Can anyone know the following error message:

Direct3DRM:D3DRMERR object not found in specified place

Can someone explain why this is happening and is there any answer to this problem?
Thanx,

Jones at ITRI/CCL

Follow Ups:

  • Re: What does this error messga mean? Snowman 20:55:46 8/22/98 (0)

Post a Followup

Name:


Re: A ready to compile sample ... please

Posted by EvAcLeAr on August 21, 1998 at 03:30:56:

In Reply to: Re: A ready to compile sample ... please posted by Snowman on August 20, 1998 at 17:00:44:

: What are you talking about? There's a MAK file for everyone of the samples! It's in the directory with the source. If you still can't get the samples to compile, tell us what kind of errors you're getting, and we'll help you out.

: -Snowman

My Bad, I was thinking of the wrong SDK :) DOH!!!

Follow Ups:

Post a Followup

Name:


C++/DirectX Programmierer gesucht

Posted by Glamus GmbH Ulrich Santo on August 21, 1998 at 04:03:03:

Hallo,

wir suchen weitere C++/DirectX Programmierer
zur Verst�rkung unseres Teams. Wir entwicklen im Moment
ein Simulation mit ISO-Darstellung zum Thema Verkehr.

http://www.glamus.de/jobs.de.html

Gr廻e,

Ulrich Santo
santo@glamus.de

Follow Ups:

Post a Followup

Name:


Re: CreateDevice doesn't work with Voodoo2???

Posted by Clay on August 21, 1998 at 07:05:34:

In Reply to: CreateDevice doesn't work with Voodoo2??? posted by Dark Blade on August 20, 1998 at 11:15:18:

This works for my Voodoo2. The first part does DD initialization (not shown: create surfaces) Then D3D init. It was originally made for RM, but I added stuff for IM. Its kludgey, and won't work if no 3d hardware is present, but here it is:

// enumerate all DD drivers
DisplayDDCaps();

// if a add-on card is present, this will use it.
// change DDEnumCallback() to modify this
// behaviour

if(bFullScreen)
{
Error = DirectDrawCreate(&DDPreferredGUID,&pDD,NULL);
}
else
{
Error = DirectDrawCreate(NULL,&pDD,NULL);
}
if(FAILED(Error))
{
MessageBox(hWnd,MyErrorToString(Error),"Error on DirectDrawCreate",MB_OK);
return(FALSE);
}

// get DD2 interface

Error = pDD->QueryInterface(IID_IDirectDraw2,(PVOID*)&lpDD);

if(FAILED(Error))
{
pDD->Release();
return(FALSE);
}

// don't need this anymore

pDD->Release();

// do D3D init...

Error = Direct3DRMCreate(&pD3DRM);
if(FAILED(Error))
{
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"Error on RM Create",MB_OK);
ShutdownDD();
return(FALSE);
}

// get RM2 API

Error = pD3DRM->QueryInterface(IID_IDirect3DRM2,(void**)&pD3DRetainedModeAPI);
if(FAILED(Error))
{
pD3DRM->Release();
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"RM query interface",MB_OK);
ShutdownDD();
return(FALSE);
}

// don't need this anymore

pD3DRM->Release();

// get D3D2 interface

Error = lpDD->QueryInterface(IID_IDirect3D2,(void**)&lpD3D);

if(FAILED(Error))
{
pD3DRetainedModeAPI->Release();
pD3DRetainedModeAPI = NULL;
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"Error on query interface",MB_OK);
ShutdownDD();
return FALSE; // Failed creation
}

// use HAL for D3D device
Error = lpD3D->CreateDevice(IID_IDirect3DHALDevice,
lpBackSurf,
&lpD3DDevice
);

if(FAILED(Error))
{
if(Error == D3DERR_ZBUFF_NEEDS_SYSTEMMEMORY)
{
// release this, we'll need to re-create it
dpr("[Init (D3D)] releasing lpD3D\n");
lpD3D->Release();
lpD3D = NULL;
pD3DRetainedModeAPI->Release();
pD3DRetainedModeAPI = NULL;

if(MakeZBuffSystem(Color,TRUE,TRUE,FALSE))
{
// create another RM API

Error = Direct3DRMCreate(&pD3DRM);
if(FAILED(Error))
{
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"Error on RM Create",MB_OK);
ShutdownDD();
return(FALSE);
}

// get RM2 API

Error = pD3DRM->QueryInterface(IID_IDirect3DRM2,(void**)&pD3DRetainedModeAPI);
if(FAILED(Error))
{
pD3DRM->Release();
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"RM query interface",MB_OK);
ShutdownDD();
return(FALSE);
}

// don't need this anymore

pD3DRM->Release();

// get another D3D2 interface

dpr("[Init (D3D)] getting new lpD3D\n");
Error = lpDD->QueryInterface(IID_IDirect3D2,(void**)&lpD3D);
if(FAILED(Error))
{
pD3DRetainedModeAPI->Release();
pD3DRetainedModeAPI = NULL;
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"Error on query interface (RGB)",MB_OK);
ShutdownDD();
return FALSE; // Failed creation
}
Error = lpD3D->CreateDevice(IID_IDirect3DRGBDevice,
lpBackSurf,
&lpD3DDevice
);
}
else
{
Error = D3DERR_ZBUFF_NEEDS_SYSTEMMEMORY;
}
}
if(FAILED(Error))
{
lpD3D->Release();
pD3DRetainedModeAPI->Release();
pD3DRetainedModeAPI = NULL;
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"Error on create D3D device",MB_OK);
ShutdownDD();
return FALSE; // Failed creation
}
}

// get RM device

Error = pD3DRetainedModeAPI->CreateDeviceFromD3D(lpD3D,//&DriverGUID[iPreferredIndex],
lpD3DDevice,
&pD3DRMDeviceAPI
);

if(FAILED(Error))
{
lpD3DDevice->Release();
lpD3D->Release();
pD3DRetainedModeAPI->Release();
pD3DRetainedModeAPI = NULL;
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"Error on device Create",MB_OK);
ShutdownDD();
return FALSE; // Failed creation
}

// set quality for textures

pD3DRMDeviceAPI->SetTextureQuality(D3DRMTEXTURE_LINEAR);

// make scene, camera, viewport, background color

Error = pD3DRetainedModeAPI->CreateFrame(NULL,&pD3DSceneAPI);
if(FAILED(Error))
{
pD3DRetainedModeAPI->Release();
pD3DRetainedModeAPI = NULL;
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"Error on scene frame Create",MB_OK);
ShutdownDD();
return(FALSE);
}

Error = pD3DRetainedModeAPI->CreateFrame(pD3DSceneAPI, &pD3DCameraAPI);
if(FAILED(Error))
{
pD3DSceneAPI->Release();
pD3DSceneAPI = NULL;
pD3DRetainedModeAPI->Release();
pD3DRetainedModeAPI = NULL;
SetExclusiveMode(FALSE);
MessageBox(hWnd,MyErrorToString(Error),"Error on scene frame Create",MB_OK);
ShutdownDD();
return(FALSE);
}
if(pD3DRMDeviceAPI)
{
pD3DRMDeviceAPI->Release();
}
if(pD3DRetainedModeAPI)
{
pD3DRetainedModeAPI->Release();
}

Gook Luck,
Clay

Follow Ups:

Post a Followup

Name:


DX6 graphics chat transcript: Copies of animationsets

Posted by Pablo de Heras on August 21, 1998 at 12:44:34:

Some of us have tried to have multiple copies of animationstes in D3DRM and have found solutions which were not documented. The Microsoft certified :) solution and is what we all have used. Change the names of the frames that make up the animationsets when you load them. I first thought this was a hacked solution and that IDirect3DRMObject::Clone was the way to go, but no no.

I'm glad it's all sorted out :)

Follow Ups:

  • Re: DX6 graphics chat transcript: Copies of animationsets fred 10:17:02 8/22/98 (0)

Post a Followup

Name:


DirectX 6 texture handles

Posted by jnz on August 21, 1998 at 14:53:15:

i am trying to get the handle of a texture surface
(a IDirectDrawSurface4) using GetHandle. the problem
is that after i query for the IDirect3DTexture2
interface of the surface object, i have to call
GetHandle to get the texture handle. it wants, for the
first parameter, a IDirect3DDevice2 object, but i am
using an IDirect3DDevice3. typecasting it to a v2
object obviously doesn't work, as it crashes. i would
appreciate help. thanx.

Follow Ups:

  • Re: DirectX 6 texture handles Clay 06:38:47 8/27/98 (1)
    • oops Clay 06:39:52 8/27/98 (0)

Post a Followup

Name:


Re: I need DirectX5

Posted by Shah Smith on August 22, 1998 at 06:13:42:

In Reply to: I need DirectX5 posted by Denton Duncan on June 28, 1998 at 12:41:27:

: I downloaded a demo but I need directX5. Can I download it for free?. Where can I get it?

Follow Ups:

  • Re: I need DirectX5 eric 02:24:17 8/23/98 (0)

Post a Followup

Name:


Re: DX6 graphics chat transcript: Copies of animationsets

Posted by fred on August 22, 1998 at 10:17:02:

In Reply to: DX6 graphics chat transcript: Copies of animationsets posted by Pablo de Heras on August 21, 1998 at 12:44:34:

just look down a bit , you can find the solution for animationset multiple loading

hehe, I m m3D_ during the DX6 chat

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by mike on August 22, 1998 at 20:36:18:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Dave Schweiger on January 25, 1998 at 10:27:05:

thats a good question uf you find out let me know too, in need it for madden 98....
:
: : Where Can I download DirectX 5.0. I need it for NHL97.

Follow Ups:

Post a Followup

Name:


Re: What does this error messga mean?

Posted by Snowman on August 22, 1998 at 20:55:46:

In Reply to: What does this error messga mean? posted by Jones on August 21, 1998 at 03:29:53:

What were you doing when you got this error? What function call were you making?

You need to give us more information so that we can help.

-Snowman

Follow Ups:

Post a Followup

Name:


Re: I need DirectX5

Posted by eric on August 23, 1998 at 02:24:17:

In Reply to: Re: I need DirectX5 posted by Shah Smith on August 22, 1998 at 06:13:42:

: : I downloaded a demo but I need directX5. Can I download it for free?. Where can I get it?

Follow Ups:

Post a Followup

Name:


D3DRM and multipass texturing

Posted by Pablo de Heras on August 23, 1998 at 10:30:39:

Hi,

I want to be able to have a wall which is lit by a torch. I immediate mode one can use light maps with multitexture or multipass texturing to achieve the effect without having to divide the wall into numerous amounts of faces. Can this be achieved in RM? Our whole rendering engine is based upon RM and I would not want to use the harder to code IM. Is there a way?

Thanks in advance.

PS: Any views are welcome.

Follow Ups:

  • Re: D3DRM and multipass texturing fred 11:13:35 8/23/98 (1)
    • Re: D3DRM and multipass texturing Pablo de Heras 15:29:41 8/23/98 (0)

Post a Followup

Name:


Re: D3DRM and multipass texturing

Posted by fred on August 23, 1998 at 11:13:35:

In Reply to: D3DRM and multipass texturing posted by Pablo de Heras on August 23, 1998 at 10:30:39:

maybe you should wait for DX7, D3DRM in DX6 doesn't support the ddraw surface 4, so there is no multitexture in RM

Follow Ups:

  • Re: D3DRM and multipass texturing Pablo de Heras 15:29:41 8/23/98 (0)

Post a Followup

Name:


Re: D3DRM and multipass texturing

Posted by Pablo de Heras on August 23, 1998 at 15:29:41:

In Reply to: Re: D3DRM and multipass texturing posted by fred on August 23, 1998 at 11:13:35:

: maybe you should wait for DX7, D3DRM in DX6 doesn't support the ddraw surface 4, so there is no multitexture in RM

Thanks for the information. We are now adding more faces to the levels instead. More faces makes more CPU-work but not if you make it with our special solution (which our 3D artist came up with when I explained how Gouraud shading works).

/Pablo de Heras

Follow Ups:

Post a Followup

Name:


DirectX/Quicktime 3

Posted by Greg Smith on August 23, 1998 at 18:14:08:

Hi,

Has anybody been able to get Quicktime 3 and DirectX working together. I want to be able to stick Quicktime panoramas into my application but don't seem to have any success getting the two API's working together

Follow Ups:

Post a Followup

Name:


Anyone could help me to resolve a problem With D3D immediate mode,please?

Posted by Kovax on August 24, 1998 at 09:00:26:

I'm curently making a Video driver using Direct3D for a Playstation emulator called PSemu Pro!

My problem is that Texture are stored in the Video Memory of the Playstation which is emulated by an array

which is defined as that:� char젨 psxVideo[1024*1024];젨젨젨젨젨 /* yes there's 1Mb of video memory */

Texture can be 4,8 or 16 bit colors, and Palette for 4 and 8 bits colors are stored in psxVideo too!

so My question is:젨 How to handle a texture stored in 'psxVideo' , with its palette for 4 and 8 bits.

is it really possible???????

thanks.

Kovax.

Follow Ups:

  • Re: Anyone could help me to resolve a problem With D3D immediate mode,please? Nat 17:53:41 8/25/98 (1)
    • Re: Anyone could help me to resolve a problem With D3D immediate mode,please? Kovax 19:32:59 8/25/98 (0)

Post a Followup

Name:


How do I rotate a bitmap with Blt?

Posted by Jay Bee on August 25, 1998 at 07:11:40:

I can't get Blt to work when I use the DDBLT_ROTATIONANGLE. I specify the dwRotationAngle in a DDBLTFX structure but nothing happens, it doesn't draw anything. What's wrong?? Would appreciate some samplecode on bitmap rotation using Blt.

Thanks!

Follow Ups:

  • Re: How do I rotate a bitmap with Blt? Jonas Eriksson 06:42:22 8/26/98 (2)
    • Re: How do I rotate a bitmap with Blt? Jay Bee 11:13:10 8/26/98 (1)
      • Re: How do I rotate a bitmap with Blt? Clay 06:36:43 8/27/98 (0)
  • Re: How do I rotate a bitmap with Blt? Jeremy 03:43:14 8/26/98 (0)

Post a Followup

Name:


Z Buffering problem (simmilar to earlier sz/rhw prob.)

Posted by Matthew Cloy on August 25, 1998 at 11:27:26:

I have a problem... I have written my own transformation/clipping engine, using DirectX DrawPrimitive() to render triangles to the screen.

I use the following calculation to work out the screen sx,sy,sz,rhw coordinates, where x,y,z are the 3D coordiates.... and n is a field of view multiplier...

sx = (x*n)/(z+d)
sy = (y*n)/(z+d)
sz = z/farPlaneDist
rhw = 1/sz
.. or ..

rhw = 1/z ..
I tried both..

I have also tried calculating Z using roots to find the distance from the camera, but that didn't work either.

The problem I have is not one of ZBuffer accuracy, as objects Z Clip through each other with
good precision... the problem I have is that my Z values seem to go wrong in a more subtle way,
say I have two boxes that touch each other side by side.... one slightly smaller than the other. When viewed side by side, they jut up,
but, as the camera is rotated the smaller one, (as viewed from a slightly elevated angle) starts to Z-Buffer through the top faces of the larger...

I have looked just a bout everywhere for a solution... I tried messing with my dvMinZ & dvMaxZ values in my viewport, All to no avail...
If anyone has a solution they could mail me, and post here, then I would be very gratefull. (I dont get on the web too much).

Thanks

Matt.

Follow Ups:

Post a Followup

Name:


To Anybody who knows JAVA.. ?!

Posted by SDK Novice on August 25, 1998 at 15:01:08:

I am a beginner in DirectX stuffs and I have this
stupid question for your guys.
If you know Java, you must know the Sun's API page
on the web, that you refer to when program in Java.
Is there any online document API for DirectX too?
If so, where is that?
If not, how can I know what kind of built-in classes
the DirectX SDK library has?
I don't even know my question makes sense to you.. but
if there is anybody out there who understands my
question, would you please answer me?
I will really appreciate in advance... =)
Thanks for your time!!!

Follow Ups:

  • This had nothing to do with Java but hey who cares... William Gate 02:22:34 8/29/98 (1)
    • Re: This had nothing to do with Java but hey who cares... Pablo de Heras 12:58:25 8/29/98 (0)
  • Re: To Anybody who knows JAVA.. ?! Pablo de Heras 15:23:31 8/25/98 (0)

Post a Followup

Name:


24bit rendering in D3DRM

Posted by Pablo de Herad on August 25, 1998 at 15:16:29:

> Thus I have to throw into the code that when BPP
> is 24 or more RGB is the only choice for rendering. All the texures are
BMP
> 24bit textures.

Hmmm... I think this is the root of all evil

16 bit mode works well
case 16:
mypDevice->SetShades(32);
mypD3DRM->SetDefaultTextureColors(64);
mypD3DRM->SetDefaultTextureShades(32);
mypDevice->SetDither(FALSE);

when changing to
mypD3DRM->SetDefaultTextureColors(256);
everything became darker and colours not in the textures appeared.

mypD3DRM->SetDefaultTextureColors(128); made strange colour artifacts too

It seems as if 64 colours in a texture is the most one can have. Also when
changing the amount of shades evereything went wrong (128 shades or 64 for
example).

So this means that one can only have 64 texturecolours and 32 shades in
MONO Direct3DRM.

Am I right? (I don't want to be)
/Pablo de Heras

Follow Ups:

Post a Followup

Name:


Re: To Anybody who knows JAVA.. ?!

Posted by Pablo de Heras on August 25, 1998 at 15:23:31:

In Reply to: To Anybody who knows JAVA.. ?! posted by SDK Novice on August 25, 1998 at 15:01:08:

: Is there any online document API for DirectX too?
: If so, where is that?

MS only supports DX3 in Java but you'll find the reference here.
http://herakles.zcu.cz/local/manuals/Java/JavaSDK15/x/default.htm

PS. I don't know Java.... yet :)

Follow Ups:

Post a Followup

Name:


AWE32 and direct-x 5 don't work together ??

Posted by Kristel on August 25, 1998 at 15:29:31:

Dear sir,

I've got troubles with my P.C.

I am an owner of a sondcard from creative labs (AWE32 PNP).

My PC:- Pentium 233 PRO
- Videocard VIPER 330 with Bios 1.62 (nVIDIA RIVA 128, DAC 230 MHz, 4 Mb Ram, driver version 4.10.01.0014)
- ASUS Motherboard P/I-P6NP5 with 80 Mb EDO-Ram
- Modem Zoltrix FM-VOC336I 33.600 (Int. Voice)
- Soundcard Soundblaster AWE 32 with 2 Mb Ram on the Card.
- Windows 95 (Ver 4.00.1111)

The problem is as follows.

I bought myself a game ( an adventure). The needs of this game are that I've got to install Direct-X 5 at least. I did install the drivers who where given with my VideocardCD-rom , and then every time I started the game or an *.AVI with sound or an *.WAV my PC crashes (even CTRL-ALT DEL dousn't work). I r�installed my PC after a format because I thought I did something wrong.So I r�installed the game and also the direct-X 5. Then it all happened again. I thought maybe I didn't have the recent drivers. So I downloaded from your adress the most recent drivers. And I also downloaded the Direct-x 6.0 from somewhere. This didn't changed anithing. My P.C. still stops everytime I use software with sound. Then I removed all my sound-drivers in the section system of Control panel and everithing worked again.

Is there a possibility that the drivers I use aren't good or is it normal that the soundcard is having problems with Direct-X ???
Is there a solutions for my problems ???

Best regards ,

Kristel de Backer,
Belgium

Follow Ups:

  • Re: AWE32 and direct-x 5 don't work together ?? Gilly 07:47:09 9/08/98 (0)

Post a Followup

Name:


Re: Anyone could help me to resolve a problem With D3D immediate mode,please?

Posted by Nat on August 25, 1998 at 17:53:41:

In Reply to: Anyone could help me to resolve a problem With D3D immediate mode,please? posted by Kovax on August 24, 1998 at 09:00:26:

: Texture can be 4,8 or 16 bit colors, and Palette for 4 and 8 bits colors are stored in psxVideo too!
: so My question is:젨 How to handle a texture stored in 'psxVideo' , with its palette for 4 and 8 bits.

Do you know the format for placing a 4-bit or 8-bit texture into psxVideo? Or do you manage the memory yourself and improvise a method for placing palette and texture into the memory?

Yes it's possible. I would say just store the palette, then the texture data.

Follow Ups:

  • Re: Anyone could help me to resolve a problem With D3D immediate mode,please? Kovax 19:32:59 8/25/98 (0)

Post a Followup

Name:


Re: HELP! PALETTES!

Posted by Nathanael Weiss on August 25, 1998 at 18:00:48:

In Reply to: HELP! PALETTES! posted by Anton on July 27, 1998 at 14:46:51:

: and then when I need to set a new palette during my game,

: nothing happens: the screen still black and nothing is changed.
: can you give me a solution how to REALLY replace colors???
: i use a DirectDrawPalette.SetEntries method to change palettes...

You must first use DirectDrawSurface.SetPalette. Also, make sure when you create the palette you are using the flag "ALLOW256COLORS"

Follow Ups:

Post a Followup

Name:


Re: Anyone could help me to resolve a problem With D3D immediate mode,please?

Posted by Kovax on August 25, 1998 at 19:32:59:

In Reply to: Re: Anyone could help me to resolve a problem With D3D immediate mode,please? posted by Nat on August 25, 1998 at 17:53:41:

: Do you know the format for placing a 4-bit or 8-bit texture into psxVideo? Or do you manage the memory yourself and improvise a method for placing palette and texture into the memory?

Yes surely i know the offset in psxVideo and the format used By texture and palette, but could you show me how to handle for example one texture place at offset 'zero' wich size is 256x256 (linear) and 256 colors, and its palette place at offset 65536 (256 u_long), please?!?

thanks.

kovax.

Follow Ups:

Post a Followup

Name:


Re: How do I rotate a bitmap with Blt?

Posted by Jeremy on August 26, 1998 at 03:43:14:

In Reply to: How do I rotate a bitmap with Blt? posted by Jay Bee on August 25, 1998 at 07:11:40:

I too have been restling with this problem for
some time with little luck. The two most probable
answers I've gotten so far are 1) The rotate ability
of Blt() just doesn't work, or 2) Your hardware
doesn't support bitmap rotation. This second one
puzzles me as I was under the impression that whatever
wasn't handled by hardware was taken care of with
software, but I've yet to get it to work. One thing
to check out is the Direct Draw Caps Utility that
ships with the DirectX SDK. When you run this, choose
the Hel menu item and select Hel FX Caps. This will
show you the capabilities of your DirectX driver. When
I run this on my system it shows that I do NOT have
the ability to do Blt Rotations. The solution may be
in getting an updated DirectX driver for the video
card being used but I'm not sure. I know none of
this really solves your problem but maybe it'll at
least point you in the right direction. Let me know
if you find an answer as I'm pretty frustrated myself
at this point. Goodluck.
berklee@bellatlantic.net

ever find a solution

Follow Ups:

Post a Followup

Name:


Re: How do I rotate a bitmap with Blt?

Posted by Jonas Eriksson on August 26, 1998 at 06:42:22:

In Reply to: How do I rotate a bitmap with Blt? posted by Jay Bee on August 25, 1998 at 07:11:40:

First of all you should check the Caps to see if
the gfx card can handle blt rotations. There are
only a few cards around that can actually do
rotation blit in hardware.

Also to remember is that even if the Caps tells
you that the card supports hardware rotation
it doesn't mean that you can to an arbitary
rotation with it. Most card that do support it
can only rotate in a 90/180/270 degree angle.

Hope this helps.
/Wizzie

Follow Ups:

  • Re: How do I rotate a bitmap with Blt? Jay Bee 11:13:10 8/26/98 (1)
    • Re: How do I rotate a bitmap with Blt? Clay 06:36:43 8/27/98 (0)

Post a Followup

Name:


Re: How do I rotate a bitmap with Blt?

Posted by Jay Bee on August 26, 1998 at 11:13:10:

In Reply to: Re: How do I rotate a bitmap with Blt? posted by Jonas Eriksson on August 26, 1998 at 06:42:22:

: First of all you should check the Caps to see if
: the gfx card can handle blt rotations. There are
: only a few cards around that can actually do
: rotation blit in hardware.

Yes, but if the card doesn't support it shouldn't it
be emulated in software? Or maybe "they" forgot to code
it :)

Follow Ups:

  • Re: How do I rotate a bitmap with Blt? Clay 06:36:43 8/27/98 (0)

Post a Followup

Name:


No direct X setup.( DSETUP.DLL)

Posted by Clifton Peirce on August 26, 1998 at 13:38:25:

I want to play Return Fire but I get this error window when I put in the CD..I downloaded Directx.6 with no luck..running windows98 on 300mhz with a Rage2 3D if anyone can help ....thanks

Follow Ups:

Post a Followup

Name:


DirectShow - Reverse Play?

Posted by Kjell on August 26, 1998 at 13:38:40:

I'm trying to play AVI files in reverse using
DirectShow, and have failed miserably at finding
any related information in the SDK 5.2 docs. Has MicroSoft missed the boat, or am I the one standing
on the shore?
I would appreciate any information regarding this.
Thanks,
Kjell

Follow Ups:

Post a Followup

Name:


Re: Helpp !!! Directx 6 with win98 Problems....

Posted by laporte on August 26, 1998 at 14:05:26:

In Reply to: Helpp !!! Directx 6 with win98 Problems.... posted by Roal Jhonson on July 21, 1998 at 10:03:54:

: Hi, I installed directx 6 on win98... but i have many trouble!!

: I erased all files about directx 6 ... but at control panel in Directx Panel say..

: Direct3d version directx 6
: Directdraw version directx 6
: directinput not found
: directplay not found
: direct sound version directx 5

: So. I cant play Mortal Kombat 4... because directx isnt installed correctly...

: Do you Know some unistall for directx 6...

: Please give infromation!!!

: Thanks Roal Jhonson

Follow Ups:

Post a Followup

Name:


Re: How do I rotate a bitmap with Blt?

Posted by Clay on August 27, 1998 at 06:36:43:

In Reply to: Re: How do I rotate a bitmap with Blt? posted by Jay Bee on August 26, 1998 at 11:13:10:

At least in DirectX 5, blt rotations were not supported. It is in the docs, but somewhere in the comments section it tells you this. Leave it to MS to list features they don't support!

Clay

Follow Ups:

Post a Followup

Name:


Re: DirectX 6 texture handles

Posted by Clay on August 27, 1998 at 06:38:47:

In Reply to: DirectX 6 texture handles posted by jnz on August 21, 1998 at 14:53:15:

Have you tried QueryInterface(IID_IDirectDraw2,(PVOID*)pDD2);?

Follow Ups:

  • oops Clay 06:39:52 8/27/98 (0)

Post a Followup

Name:


oops

Posted by Clay on August 27, 1998 at 06:39:52:

In Reply to: Re: DirectX 6 texture handles posted by Clay on August 27, 1998 at 06:38:47:

That should be QueryInterface(IID_IDirectDraw2,(PVOID*)&pDD2);

: Have you tried QueryInterface(IID_IDirectDraw2,(PVOID*)pDD2);?

Follow Ups:

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by Pujanias on August 27, 1998 at 12:04:17:

In Reply to: DirectX6 FINAL RELEASE! posted by A DX6 beta tester on July 31, 1998 at 00:30:54:

: The FINAL version of DirectX6/SDK will be released with in 24 hours!

: Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

Post a Followup

Name:


Custom made blt problem... please help

Posted by Martin on August 27, 1998 at 14:46:22:

I'm trying to code a custom made blt function, everything was going fine until i tested it, damn... it's slow!!!
can somebody please tell me what's wrong with this code, thanks

(I have a screen res of 640x480x16)

void test(LPDIRECTDRAWSURFACE dst, LPDIRECTDRAWSURFACE src)
{
DDSURFACEDESC ddsd1, ddsd2;

SHORT *dest;
SHORT *source;
int r, c;

long dpitch;
long spitch;

ddsd1.dwSize = sizeof(ddsd1);
ddsd2.dwSize = sizeof(ddsd2);

if (dst -> Lock(NULL, &ddsd1, DDLOCK_SURFACEMEMORYPTR | DDLOCK_WAIT, NULL) != DD_OK)
return;

if (src -> Lock(NULL, &ddsd2, DDLOCK_SURFACEMEMORYPTR | DDLOCK_WAIT, NULL) != DD_OK)
{
dst -> Unlock(&ddsd1);
return;
}

dpitch = (ddsd1.lPitch / 2) - 640;
spitch = (ddsd2.lPitch / 2) - 640;

dest = (SHORT *)ddsd1.lpSurface;
source = (SHORT *)ddsd2.lpSurface;

r = 0;
c = 0;

do
{
do
{
*dest++ = *source++;
c++;
} while (c Unlock(&ddsd1);
src -> Unlock(&ddsd2);
}

Follow Ups:

  • Re: Custom made blt problem... please help Clay 16:46:50 8/27/98 (1)
    • Re: Custom made blt problem... please help Martin 07:28:44 8/28/98 (0)

Post a Followup

Name:


Re: Custom made blt problem... please help

Posted by Clay on August 27, 1998 at 16:46:50:

In Reply to: Custom made blt problem... please help posted by Martin on August 27, 1998 at 14:46:22:

Copying one SHORT at a time is slow. Try using memcpy(). Another big slowdown is if any of the memory you are using is actually on the video card. PCI/AGP transfer speeds are extremely slow when compared to main memory.

Clay

char* pSrc,pDest;
UINT uPitchSrc, uPitchDest, uSurfaceHeight, uSurfaceWidth;
UINT uSurfaceWidthBytes;

// do surface locking/validation here (and Bytes/Pixel stuff)

// blt

while(uSurfaceHeight)
{
memcpy(pDest,pSrc,uSurfaceWidthBytes);
pSrc += uPitchSrc;
pDest+= uPitchDest;
--uSurfaceHeight;
}

// unlock here

Follow Ups:

  • Re: Custom made blt problem... please help Martin 07:28:44 8/28/98 (0)

Post a Followup

Name:


lpVtbl is not a member of 'IDirect3DRM'?!?!?!?!?!?!?!

Posted by Jonathan on August 27, 1998 at 18:12:00:

I'm trying to get a sample application from the DirectX 5 SDK to work with Borland C++ 4.5, and all I get is an error message that says something like:

"Error GLOBE.C 43: 'lpVtbl' is not a member of 'IDirect3DRMAnimation' in function cleanupPath..." over and over.

I've defined _WIN32, made it use the DirectX headers first, and replaced all the MVC++ LIBs with the BC++ versions.

Thanks in advance for any help.

Follow Ups:

  • Re: lpVtbl is not a member of 'IDirect3DRM'?!?!?!?!?!?!?! Jeremy 00:29:50 8/28/98 (0)

Post a Followup

Name:


Direct X and Watcom

Posted by Chuck Wardlaw on August 27, 1998 at 18:50:57:

Hello all,

I'd like to try to get Direct X and watcom 10.6 working. I know that there is a patch to fix direct x 3's SDK to work with Watcom 11, and I figure that's a good place to start. However, I can no longer find a copy of the direct X 3 SDK anywhere on the net. If anybody knows of a place I can download it (or if anybody is crazy enough to e-mail me a copy of it), please let me know over private e-mail (I don't check this list all that often). As well, anybody who has any information on getting direct x to work with watcom -- any version -- please drop me a line.

Thanx in advance,

- Chuck Wardlaw

Follow Ups:

Post a Followup

Name:


Re: Direct 3D hardware question!

Posted by Mman1118 on August 27, 1998 at 23:18:23:

In Reply to: Direct 3D hardware question! posted by Jumicor on July 24, 1998 at 17:26:58:

: How can I tell if my program is using my 3dfx direct 3d accelerated card? I have been programming with direct 3d for a couple of weeks...I believe that my programs are not using my 3dfx card because the textures are not blended. I need to know how to get the texture blending working. I have a Matrox Mystique for 2D and 3dfx Voodoo 1 for 3d. Is it possible that my program does not recognize the 3dfx card and only uses the matrox card. If so what do I have to do to make it find my 3dfx card.

Follow Ups:

Post a Followup

Name:


Re: lpVtbl is not a member of 'IDirect3DRM'?!?!?!?!?!?!?!

Posted by Jeremy on August 28, 1998 at 00:29:50:

In Reply to: lpVtbl is not a member of 'IDirect3DRM'?!?!?!?!?!?!?! posted by Jonathan on August 27, 1998 at 18:12:00:

The samples you're attempting to compile are written
in C. Since you're using C++ the way the functions
are called are different. Just eliminate the lpVtbl
part from the function call. So for example, if you
see lpD3DRM->lpVtbl->CreateFrame(...), change it so
it reads lpD3DRD->CreateFrame. You'll also probably
get errors saying that the wrong number of parameters
is being passed. If so, eliminate the 1st parameter
from the arguement list. Hope this helps.

Follow Ups:

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by dxptt on August 28, 1998 at 01:00:14:

In Reply to: DirectX6 FINAL RELEASE! posted by A DX6 beta tester on July 31, 1998 at 00:30:54:

: The FINAL version of DirectX6/SDK will be released with in 24 hours!

: Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

  • Re: DirectX6 FINAL RELEASE! t.sato 09:25:18 8/28/98 (1)
    • Re: DirectX6 FINAL RELEASE! vincenzo 07:08:37 9/08/98 (0)

Post a Followup

Name:


Re: Custom made blt problem... please help

Posted by Martin on August 28, 1998 at 07:28:44:

In Reply to: Re: Custom made blt problem... please help posted by Clay on August 27, 1998 at 16:46:50:

The SHORT thing was only temporary,

the problem was that I accidentaly created the surfaces in videomemory,
I recoded it in assembler and it works great now,
(DWORD copy)

thanks a bunch

/Martin

Follow Ups:

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by t.sato on August 28, 1998 at 09:25:18:

In Reply to: Re: DirectX6 FINAL RELEASE! posted by dxptt on August 28, 1998 at 01:00:14:

:
: : The FINAL version of DirectX6/SDK will be released with in 24 hours!

: : Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

  • Re: DirectX6 FINAL RELEASE! vincenzo 07:08:37 9/08/98 (0)

Post a Followup

Name:


Does anyone If DirectX6 will work on Borland v4.5?

Posted by Narshe on August 28, 1998 at 14:13:37:

Ok Im a newbie at programming, but I try to compile ym code and it gives me errors in the .h file about a type GUID not being defined. So far I can't do a thing.. ive linked the dirs of lib and h. I dont know what to change if I have to change something.

Thnx.. NARSHE

Follow Ups:

  • Re: Does anyone If DirectX6 will work on Borland v4.5? MainFrame 00:53:22 9/06/98 (0)

Post a Followup

Name:


Meshbuilder

Posted by Travis on August 28, 1998 at 20:07:03:

Question:
Does anyone know if when you add a meshbuilder object to a meshbuilder object if it will automatically be released when you release the meshbuilder object containing other MB objects?

Does anyone know of any samples using the meshbuilder interface.

Travis

Follow Ups:

  • Re: Meshbuilder Clay 09:27:11 8/30/98 (0)

Post a Followup

Name:


Is it possible to get sound data directly from mic using DirectSound ?

Posted by Wing Ho Leung on August 28, 1998 at 22:52:53:

I'm new to DirectSound. I need to use VC++ to get sound data directly from the mic. Is it possible to use DirectSound to achieve this ? I appreciate any help.

Wing

Follow Ups:

  • Re: Is it possible to get sound data directly from mic using DirectSound ? William Gate 02:13:17 8/29/98 (0)

Post a Followup

Name:


Re: Is it possible to get sound data directly from mic using DirectSound ?

Posted by William Gate on August 29, 1998 at 02:13:17:

In Reply to: Is it possible to get sound data directly from mic using DirectSound ? posted by Wing Ho Leung on August 28, 1998 at 22:52:53:

: I'm new to DirectSound. I need to use VC++ to get sound data directly from the mic. Is it possible to use DirectSound to achieve this ? I appreciate any help.

: Wing

Quoted from www.microsoft.com

The audio component of Microsoft� DirectX�, Microsoft� DirectSound� uses features such as
low-latency mixing playback, accelerated hardware, and 3-D positioning to achieve
professional-quality audio performance. With DirectSound, multiple audio signals can be mixed and
played at the same time; sound card features are automatically engaged or emulated in the
software if not supported by the existing hardware; and custom mixing engines can directly
access the sound hardware. DirectSound also enables applications to change volume, frequency,
and panning, and to simulate 3-D effects such as rolloff and Doppler shift.

New DirectSound features in DirectX 5 include audio capture (applications can now record as well
as play back) and extended services using specific sound cards. Essentially a sound mixing
engine, DirectSound places sets of sounds in secondary buffers, combines them and writes them
into primary buffers. Only the available processing time limits the number of buffers that
DirectSound can mix.

Follow Ups:

Post a Followup

Name:


This had nothing to do with Java but hey who cares...

Posted by William Gate on August 29, 1998 at 02:22:34:

In Reply to: To Anybody who knows JAVA.. ?! posted by SDK Novice on August 25, 1998 at 15:01:08:

DirectX does not have any "ON-LINE" Documentation that I have been able to locate. The SDK does how ever come with all the API documentation you'll need in WORD and HTML format. If that doesn't help you there is one last thing to do. Print out the DirectX Header files, Library files and don't forget any others and start reading!

Follow Ups:

  • Re: This had nothing to do with Java but hey who cares... Pablo de Heras 12:58:25 8/29/98 (0)

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by Steve Borman on August 29, 1998 at 06:34:57:

In Reply to: Re: DirectX6 FINAL RELEASE! posted by mikael on August 09, 1998 at 11:12:52:

Will it be an improvement on the Beta DX6 concerning
3dfx video cards? I sure hope so!

I'm asking because the Beta DX6 version really messed
up the performance of my 3DFX (Orchid) card.

If the final release of DX6 is not an improvement
over Dx5 is there a way of uninstalling DirectX6
completely from ones system? I've been playing
dx6beta corrupted games for 2 months now because
allegedly one can not safely remove the beta dx6
from a system. So says one Microsoft tech I
spoke to.

Steve

Follow Ups:

  • Re: DirectX6 FINAL RELEASE! Roxanne Bryant 14:56:03 8/30/98 (0)

Post a Followup

Name:


Re: This had nothing to do with Java but hey who cares...

Posted by Pablo de Heras on August 29, 1998 at 12:58:25:

In Reply to: This had nothing to do with Java but hey who cares... posted by William Gate on August 29, 1998 at 02:22:34:

: DirectX does not have any "ON-LINE" Documentation that I have been able to locate.

DirectXMedia docs
http://www.microsoft.com/directx/dxm/default.htm

Not DDraw, Dsound, and D3DIM ofcourse, which are the ones one would really have on the net.

/Pablo de Heras

Follow Ups:

Post a Followup

Name:


I NEED HELP WITH DIRECT3D IMMEDIATE MODE, IT'S URGENT!!!!!!!!!!!!!

Posted by Kovax on August 29, 1998 at 14:40:11:

my problem is that i need a HANDLE from a texture previoulsy initialised to add texture to my flat polygon, and i don't know how to initialise a texture wich is already in memory stored in a array defined like that: BYTE Texture[256*256*2];

this texture is 256 height, 256 width and 16 BITS.

so could you give me an example which does that:

- initialise a Surface
- copying the texture from "Texture" to the new surface; /* Texture is defined as that: BYTE Texture[256*256*2]; */
- initialise this surface as a Texture.
- get a handle for this texture.
.
.
.
- erase this Texture (surely the surface, but i think Texture too???).

if you know how to do this, please you're my last chance!!

Thanks.

kovax

Follow Ups:

Post a Followup

Name:


Viewing files in Direct X object files

Posted by Luey on August 30, 1998 at 03:24:21:

I am using MVC 5 with DirectX 5.2.
How do I view previously created .x files?

Follow Ups:

Post a Followup

Name:


Problem with DirectDraw setup

Posted by Red on August 30, 1998 at 06:28:46:

I have a problem with initialising directdraw.
After defining :

LPDIRECTDRAW lpDirectDrawObject;
(as a global)

I use ddResult = DirectDrawCreate(NULL, &lpDirectDrawObject, NULL) to create an object

this returns with no errors
However, if I try to use this object, like :
ddResult = lpDirectDrawObject->SetCooperativeLevel(hMainWindow, DDSCL_EXCLUSIVE | DDSCL_FULLSCREEN | DDSCL_ALLOWREBOOT);
Or// using get caps
I get an invalid parameter error every time.

I'm using Borland 5.0, with DirectX 5.0 sdk libraries implib'd
and using DirectX 5.0 with a Matrox Mystique 220 card.

Can you help?

Thanks,
Red.

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 6.0

Posted by zmc on August 30, 1998 at 08:15:56:

In Reply to: Re: Where Can I download DirectX 6.0 posted by Josee Oliviero on July 23, 1998 at 10:38:35:

: Where Can I download DirectX 6.0 (or latest versions)

Follow Ups:

Post a Followup

Name:


Re: Meshbuilder

Posted by Clay on August 30, 1998 at 09:27:11:

In Reply to: Meshbuilder posted by Travis on August 28, 1998 at 20:07:03:

I've never tested throughly tested this, but if you add a meshbuilder to meshbuilder then Release() the first, the 'other' meshbuilder will still contain the first's data. This would indicate that RM copies the data when you add a meshbuilder to another. Golden Rule: release all your interfaces when you're done with them.

Clay

Follow Ups:

Post a Followup

Name:


HELP!!

Posted by Nick on August 30, 1998 at 13:57:22:

Is there anyway to make a Directx bitmap surface that is bigger than the screen??

Follow Ups:

  • Re: HELP!! Clay 07:30:14 8/31/98 (0)

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by Roxanne Bryant on August 30, 1998 at 14:56:03:

In Reply to: Re: DirectX6 FINAL RELEASE! posted by Steve Borman on August 29, 1998 at 06:34:57:

: Will it be an improvement on the Beta DX6 concerning
: 3dfx video cards? I sure hope so!

: I'm asking because the Beta DX6 version really messed
: up the performance of my 3DFX (Orchid) card.

: If the final release of DX6 is not an improvement
: over Dx5 is there a way of uninstalling DirectX6
: completely from ones system? I've been playing
: dx6beta corrupted games for 2 months now because
: allegedly one can not safely remove the beta dx6
: from a system. So says one Microsoft tech I
: spoke to.

: Steve

I put the directx6 on my system and now my sound studders. It didnt'
do it to start but has done it in progression. I want it off or the fix for this
problem.. Help....

Follow Ups:

Post a Followup

Name:


Re: HELP!!

Posted by Clay on August 31, 1998 at 07:30:14:

In Reply to: HELP!! posted by Nick on August 30, 1998 at 13:57:22:

Yes and no. Many graphics cards do not support surfaces larger than the primary surface (notably Voodoo and Voodoo 2). Some support the so-called "large" surfaces, but only in system memory. You have to check the DirectDraw capabilities to be sure.

Clay

Follow Ups:

Post a Followup

Name:


Re: Error loading DirectDraw... PLEASE HELP!! :)

Posted by Sompong Rattanasang on August 31, 1998 at 07:48:48:

In Reply to: Error loading DirectDraw... PLEASE HELP!! :) posted by DirectX-=nEwBiE=- on August 03, 1998 at 12:45:57:

: When I load a program that requires DirectDraw, it gives me a message box saying "beta DirectDraw expired, please update"

: CAN SOMEONE HELP ME WIT' THIS?

Follow Ups:

Post a Followup

Name:


DirectPlay Lobby Client Help

Posted by Gary Mace on August 31, 1998 at 10:41:03:

Greetings,

I was wandering if anyone could help me learn how to make my game act as a lobby client. Looking for:

- Sample Code in VB4 or VB5
- Known VB toolkits for DX lobby
- Known books to get
- Links to tutorials
- Folks to contact

Basically anything you think would help intermediate VB hobby coders learn how to do this. I would prefer sample code if anyone has it, but I know that is asking a lot. Don't mind paying reasonable fee for working VB code!!

Regards,

Gary Mace
garymace@intrepid.net

  • Current Project

Follow Ups:

Post a Followup

Name:


Re: Implementing Directx(DirectDraw) into a MFC

Posted by Mr. Mike on September 01, 1998 at 03:16:19:

In Reply to: Implementing Directx(DirectDraw) into a MFC posted by Sphire on July 20, 1998 at 13:28:12:

I have the same problem with mfc.

Did you buy the suggested book?

I have bought a few books, but none
provide a simple DirectX/mfc example.

Have you found any good examples yet?
Mike

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by krupesh on September 01, 1998 at 06:40:03:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Igor on March 25, 1998 at 00:12:52:

: : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


DirectX beginner...

Posted by Ed Fear on September 01, 1998 at 07:17:06:

Hi everyone,

Does anyone know if Inside DirectX is good? I'm having trouble
with a load_bitmap() function - I don't understand it!
Does anyone know of a good book that guides you thru
loading a bitmap? It's a shame MS didn't include a basic
one, which you dodn't have to use...

(I'll get my head bitten off for that one, I can tell)

Ed :)

Follow Ups:

  • Re: DirectX beginner... That Guy 22:46:54 9/03/98 (1)
    • Re: DirectX beginner... WGPDummies Ed Fear 04:37:03 9/04/98 (0)
  • Re: DirectX beginner... champi 15:23:27 9/01/98 (0)

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by STAS MIDURA on September 01, 1998 at 14:20:46:

In Reply to: Re: DirectX6 FINAL RELEASE! posted by mikael on August 09, 1998 at 11:12:52:

: : The FINAL version of DirectX6/SDK will be released with in 24 hours!

: : Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

Post a Followup

Name:


Re: DirectX beginner...

Posted by champi on September 01, 1998 at 15:23:27:

In Reply to: DirectX beginner... posted by Ed Fear on September 01, 1998 at 07:17:06:

: Hi everyone,

: Does anyone know if Inside DirectX is good? I'm having trouble
: with a load_bitmap() function - I don't understand it!
: Does anyone know of a good book that guides you thru
: loading a bitmap? It's a shame MS didn't include a basic
: one, which you dodn't have to use...

: (I'll get my head bitten off for that one, I can tell)

: Ed :)

try to compile including ddutil.cpp in your workspace, ddutil have the function that loads a bmp

Follow Ups:

Post a Followup

Name:


Im working on final fight type game and i need help

Posted by champi on September 01, 1998 at 15:38:14:

hi everyone !
im programing a final fight type game but im begginer so i need some serius help in the follow deparments:
collision detection ( i dont use the best )
sound ( multiple wavs how implement? )
scrolling large bitmaps or make a tile ( like the fox bear demo).
play an avi in fullscreen with directx
help me and i send you my demo.

Follow Ups:

  • Re: Im working on final fight type game and i need help Tim Wright(MainFrame) 00:00:24 9/06/98 (0)
  • Re: Im working on final fight type game and i need help Agent X 04:11:40 9/03/98 (0)

Post a Followup

Name:


DirectX+Assembler?

Posted by Spikes on September 01, 1998 at 16:40:04:

umm.. DDraw is slow. So I want to make it faster
with som asm. How long are to pointers in MVC++?
how do I load a pointer ?

les di,screenpointer <- DOs , but how do I do it in Win95?

Follow Ups:

  • Re: DirectX+Assembler? Dave Burrows 04:25:53 9/02/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Simon Partington on September 01, 1998 at 20:58:10:

In Reply to: Where Can I download DirectX 5.0 posted by Matthew Stiller on July 17, 1998 at 04:22:10:

:
: : : : : Where Can I download DirectX 5.0. I need it for a game.

Follow Ups:

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by JOHN on September 01, 1998 at 21:03:11:

In Reply to: Re: DirectX6 FINAL RELEASE! posted by mikael on August 09, 1998 at 11:12:52:

: : The FINAL version of DirectX6/SDK will be released with in 24 hours!

: : Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

  • Re: DirectX6 FINAL RELEASE! john reece 22:56:55 9/01/98 (0)

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by john reece on September 01, 1998 at 22:56:55:

In Reply to: Re: DirectX6 FINAL RELEASE! posted by JOHN on September 01, 1998 at 21:03:11:

:
: : : The FINAL version of DirectX6/SDK will be released with in 24 hours!

: : : Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 SDK cannot be downloaded anymore

Posted by hpayne BERT PAYNE on September 02, 1998 at 01:16:05:

In Reply to: Re: DirectX 5.0 SDK cannot be downloaded anymore posted by Mehrab on March 14, 1998 at 15:12:59:

: : can anyone tell me where to download it besides microsoft website?

go to antagonist keyword ant

Follow Ups:

Post a Followup

Name:


Re: DirectX+Assembler?

Posted by Dave Burrows on September 02, 1998 at 04:25:53:

In Reply to: DirectX+Assembler? posted by Spikes on September 01, 1998 at 16:40:04:

: umm.. DDraw is slow. So I want to make it faster
: with som asm. How long are to pointers in MVC++?
: how do I load a pointer ?

: les di,screenpointer <- DOs , but how do I do it in Win95?

You first need to look into doing some 32bit asm.

Then the easiest way to do it is in-line.

Follow Ups:

Post a Followup

Name:


Re: D3D Help!

Posted by Roger Schuttelaar on September 02, 1998 at 07:24:47:

In Reply to: D3D Help! posted by Marc on June 30, 1998 at 15:55:40:

: I have a problem with my directx d3d..
: When I start Moto Racer and I choose D3D...It crash my computer....
: I can't play with Shadow of the empire...it crash too.
: I have a diamond monster 3d...all the drivers are installed..
: Help me...
: Thanks
: Marc

Dear Marc,

I'm writing to you not because I have a solution..
But because I have the same problem as you have.
Have you fixed it already????
(by the way: 3d games using openglide work fine)

Yours sincerely,
Roger Schuttelaar

Follow Ups:

Post a Followup

Name:


Re: Getting DirectSoundBuffer Notification Interface

Posted by Denny Bromley on September 02, 1998 at 14:51:52:

In Reply to: Getting DirectSoundBuffer Notification Interface posted by Gilles Pommereuil on August 13, 1998 at 13:57:41:

This code works for me. So enjoy. but then read the following text...

//=============================
hr = input->CreateCaptureBuffer(&bufDesc,&captureBuffer,NULL);
if(FAILED(hr)){Error::error("Cannot create capture buffer.");input->Release();input=NULL;return;}

//Notify
hr = captureBuffer->QueryInterface(IID_IDirectSoundNotify,(void**)¬ify);
if(FAILED(hr)){
Error::error("Cannot create the notification interface.");
captureBuffer->Release();
captureBuffer=NULL;
input->Release();
input=NULL;
return;
}
//==================================

I get the interface ok, but the following code fails (taken from July '98 msdn)

//==============================
notificationArray = new DSBPOSITIONNOTIFY[numReadsPerBuffer];
for(int i=0;iRelease();
notify=NULL;
captureBuffer->Release();
captureBuffer=NULL;
input->Release();
input=NULL;
return;
}
}

hr = notify->SetNotificationPositions(numReadsPerBuffer,notificationArray);
if(FAILED(hr)){
Error::error("Cannot create notifications.");
notify->Release();
notify=NULL;
captureBuffer->Release();
captureBuffer=NULL;
input->Release();
input=NULL;
return;
}
//==============================

Any advice. I'd love it!
-Denny

Follow Ups:

Post a Followup

Name:


Its possible scale and rotate a sprite with blt? how?

Posted by champi on September 02, 1998 at 15:23:35:

hi again
somebody know if its possible scale a sprite captured by bltfast? how?

Follow Ups:

  • It's not possible Myopic Rhino 12:16:11 9/04/98 (0)

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by Vladimir Mitev on September 02, 1998 at 16:29:20:

In Reply to: Re: DirectX6 FINAL RELEASE! posted by mikael on August 09, 1998 at 11:12:52:

: : The FINAL version of DirectX6/SDK will be released with in 24 hours!

: : Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

  • Re: DirectX6 FINAL RELEASE! David Mendes 15:40:18 9/28/98 (0)
  • Re: DirectX6 FINAL RELEASE! Niki 17:55:01 9/03/98 (0)

Post a Followup

Name:


Re: I know where you can download DIRECTX 5.0 !!!!

Posted by joe on September 02, 1998 at 18:13:47:

In Reply to: I know where you can download DIRECTX 5.0 !!!! posted by Luiz Guilherme Krause de Salles on February 10, 1998 at 15:21:57:

: U can download rthe DIRECTX 5.0 in this site:
: "http://microsoft.com/directx/download.asp"!!!
: It was my pleasure!!!

Follow Ups:

Post a Followup

Name:


Why does d3drm alpha blending look so awful?

Posted by Boller on September 02, 1998 at 21:34:57:

Hi everybody,

I think I am finally close to getting alpha blending
to work (I am using DirectX 5.1).

I've switched the whole program over to d3drm2, set
the D3DRMRENDERMODE_BLENDEDTRANSPARENCY and
D3DRMRENDERMODE_SORTEDTRANSPARENCY flags.

I've set the alpha blending like this:

meshbuilder -> SetColor(D3DRGBA(1, 1, 1, D3DVALUE(0.5)));

However, I've hit onto a couple snags. First, the
rendered image looks suspiciously like how the shadow
stuff is implemented in D3D -- just like a bunch of
little pixels, the density determined by the 4th
parameter of D3DRGBA. If you know what effect I am
talking about, then you know how lousy it looks. It's
not alpha blending... Is this some sort of wimpy
software-emulated alpha blending? (I know my video
card supports alpha blending -- I've seen it with my
own eyes on the Microsoft Flipa demo... *That's* the
kind of alpha blending I want!)

The second problem might be more serious... When I
apply a wrap to the pseudo-alpha-blended mesh, the
whole wrap takes over and it doesn't even do that
pseudo-alpha blending. In other words, when I put a
texture onto the mesh, it totally ignores the alpha
blending thing, and it was as if I never applied the
alpha SetColor thingee to begin with.

So my questions are,
1) How do I get an alpha blending thing
happening in retained mode that looks like the MS
Flipa demo?
2) And, assuming I get things looking like
the Flipa demo, is there anything special I need to do
with applying textures so the textures will *also* be
see-through?

Thanks in advance,

Jeff Boller
jjbst62+@pitt.edu

Please post your response, as I don't think my e-mail
account is working properly.

Follow Ups:

Post a Followup

Name:


Re: Late Re: Alpha-blending decals in Retained Mode

Posted by boller on September 03, 1998 at 02:44:07:

In Reply to: Late Re: Alpha-blending decals in Retained Mode posted by Mr Moo on April 22, 1998 at 15:48:06:

: .SetColor (D3DRGBA(1,1,1,0.5))
: // The last number in the sequence as being the
: // alpha constant you want.

: // Remember to set your meshes material mode
: // to use the frame.

What do you mean by setting the mesh's material
mode to use the frame? I tried doing a bunch of
stuff with specular, emissive, vpower, etc. and
the mesh did not look like it was alpha blending...
It looked like it was dithered in some way...

It looked like the shadow stuff in D3D --
neatly-arranged pixels in a "grid":

. . . .
. . . .
. . . .
. . . .

Is there something I'm missing in order to
set the alpha blending to work?

Thanks in advance,

Jeff Boller

P.S.: Please post your response -- don't send
me e-mail, as my account is currently messed up. :-(

Follow Ups:

  • Re: Late Re: Alpha-blending decals in Retained Mode Tim Brubaker 22:24:35 9/09/98 (0)

Post a Followup

Name:


Re: Im working on final fight type game and i need help

Posted by Agent X on September 03, 1998 at 04:11:40:

In Reply to: Im working on final fight type game and i need help posted by champi on September 01, 1998 at 15:38:14:

: hi everyone !
: im programing a final fight type game but im begginer so i need some serius help in the follow deparments:
: collision detection ( i dont use the best )
: sound ( multiple wavs how implement? )
: scrolling large bitmaps or make a tile ( like the fox bear demo).
: play an avi in fullscreen with directx
: help me and i send you my demo.

I am also learning DirectX programming and im reading a book called "Windows game programming for dummies." It is really well written it has very good reveiws at amazon.com about ****1/2 stars out of 5. I was interested in looking at the demo and maybe once im done with the book and i understand how to do some the the stuff you need i can help...
-Agent X
ps do you have icq? if so whats your #, mines 14472561.

Follow Ups:

Post a Followup

Name:


Having a problem whne trying to link SDK example. unresolvable external symbol...

Posted by Direct X Newbie... on September 03, 1998 at 08:54:02:

I have recently got a copy of MS Visual Studio 97 and have been trying learn about Direct X. Its been a while since I programmed in C (like 5 years) and the whole Visual thing seems weird, but I can get basic C programs to work fine.

My problem so far is trying to run any of the SDK examples. They compile fine but when I go to build the .EXE (link) I get a bunch of error messages.

Im Using Visual C5.0 and Direct X 5.0

When using the Donut example I recieve:

--------------------Configuration: Donut - Win32 Debug--------------------
Compiling...
Donut.cpp
Linking...
Donut.obj : error LNK2001: unresolved external symbol _DDReLoadBitmap
Donut.obj : error LNK2001: unresolved external symbol _DDSetColorKey
Donut.obj : error LNK2001: unresolved external symbol _DDLoadBitmap
Donut.obj : error LNK2001: unresolved external symbol _DDLoadPalette
Donut.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12
LIBCD.lib(crt0.obj) : error LNK2001: unresolved external symbol _main
Debug/Donut.exe : fatal error LNK1120: 6 unresolved externals
Error executing link.exe.

Donut.exe - 7 error(s), 0 warning(s)

Thanks for the your help.

Follow Ups:

  • Re: Having a problem whne trying to link SDK example. unresolvable external symbol... champi 11:17:41 9/03/98 (0)
  • Re: Having a problem whne trying to link SDK example. unresolvable external symbol... Dark Blade 11:09:29 9/03/98 (0)

Post a Followup

Name:


THIS IS URGENT PLEASE READ !!!!!

Posted by .oOGrimm ReaperOo. on September 03, 1998 at 10:01:46:

I have a problem with Direct X i installed it but no games
on my hd can find it? what shell i do... Can't find drivers
I have old drivers but i dont know?
I tried to install Direct X 6 without success?
E-Mail me: Pia.nordin@mbox301.swipnet.se

Follow Ups:

Post a Followup

Name:


Direct X 6 Book coming out soon?

Posted by Dwight Yachuk on September 03, 1998 at 10:04:54:

Anyone know when a DirectX 6 book is being published? Should I buy a Direct X 5 or wait?

Follow Ups:

  • Re: Direct X 6 Book coming out soon? Myopic Rhino 15:29:46 9/04/98 (0)

Post a Followup

Name:


Re: Having a problem whne trying to link SDK example. unresolvable external symbol...

Posted by Dark Blade on September 03, 1998 at 11:09:29:

In Reply to: Having a problem whne trying to link SDK example. unresolvable external symbol... posted by Direct X Newbie... on September 03, 1998 at 08:54:02:

You must link dx libs (d3drm.lib etc..) with that
example.

Follow Ups:

Post a Followup

Name:


Re: Having a problem whne trying to link SDK example. unresolvable external symbol...

Posted by champi on September 03, 1998 at 11:17:41:

In Reply to: Having a problem whne trying to link SDK example. unresolvable external symbol... posted by Direct X Newbie... on September 03, 1998 at 08:54:02:

: I have recently got a copy of MS Visual Studio 97 and have been trying learn about Direct X. Its been a while since I programmed in C (like 5 years) and the whole Visual thing seems weird, but I can get basic C programs to work fine.

: My problem so far is trying to run any of the SDK examples. They compile fine but when I go to build the .EXE (link) I get a bunch of error messages.

:
: Im Using Visual C5.0 and Direct X 5.0

: When using the Donut example I recieve:

: --------------------Configuration: Donut - Win32 Debug--------------------
: Compiling...
: Donut.cpp
: Linking...
: Donut.obj : error LNK2001: unresolved external symbol _DDReLoadBitmap
: Donut.obj : error LNK2001: unresolved external symbol _DDSetColorKey
: Donut.obj : error LNK2001: unresolved external symbol _DDLoadBitmap
: Donut.obj : error LNK2001: unresolved external symbol _DDLoadPalette
: Donut.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12
: LIBCD.lib(crt0.obj) : error LNK2001: unresolved external symbol _main
: Debug/Donut.exe : fatal error LNK1120: 6 unresolved externals
: Error executing link.exe.

: Donut.exe - 7 error(s), 0 warning(s)

: Thanks for the your help.

you most go to settings in project and select the link tab and include the follow libs : ddraw.lib winmm.lib
after that select files in workspace and include the file ddutil.cpp
if you do this and your paths to the header files and lib are right i guarante no problem compiling.
good luck.

Follow Ups:

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by Niki on September 03, 1998 at 17:55:01:

In Reply to: Re: DirectX6 FINAL RELEASE! posted by Vladimir Mitev on September 02, 1998 at 16:29:20:

: : : The FINAL version of DirectX6/SDK will be released with in 24 hours!

: : : Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

Post a Followup

Name:


Blitting sprites

Posted by That Guy on September 03, 1998 at 22:41:54:

Ok, DX newbie here. So far I've got to the point where I can:

get a basic Window up
create a direct draw object
create a primary surface
open a bitmap file
use Blt() to blit the bitmap onto the screen

I can even take portions of the bitmap and blit them on too. But now I need to create surfaces that are not the entire size of the screen - just big enough to hold a 32X32 sprite. The book I'm working with calls them bobs (for bitmapped objects). I've tried several different ways and none of them work. I'm checking return codes and everything seems to be "working" but I still see no sprite on the screen. What gives?

Follow Ups:

Post a Followup

Name:


Re: DirectX beginner...

Posted by That Guy on September 03, 1998 at 22:46:54:

In Reply to: DirectX beginner... posted by Ed Fear on September 01, 1998 at 07:17:06:

: Hi everyone,

: Does anyone know if Inside DirectX is good? I'm having trouble
: with a load_bitmap() function - I don't understand it!
: Does anyone know of a good book that guides you thru
: loading a bitmap?

I'm working with Windows Game Programming for Dummies and he lays the code out for Load_Bitmap in detail. The book isn't bad - a few irritating typos here and there but pretty good on the whole.

That Guy

Follow Ups:

  • Re: DirectX beginner... WGPDummies Ed Fear 04:37:03 9/04/98 (0)

Post a Followup

Name:


Got milk?

Posted by Schitz on September 04, 1998 at 02:56:59:

Hi,

Im just getting my feet wet in DirectX. So far no major problems, except one. Im writing in VB5 which hasnt been too rough, but i need the value of the constant DIRECTINPUT_VERSION used in DirectInputCreate. I'm using DX6. I've aquired the type libraries, from the web, easing the use of directX in VB5, but DIRECTINPUT_VERSION wasn't defined.

Thanks for any help.

Follow Ups:

Post a Followup

Name:


Re: DirectX beginner... WGPDummies

Posted by Ed Fear on September 04, 1998 at 04:37:03:

In Reply to: Re: DirectX beginner... posted by That Guy on September 03, 1998 at 22:46:54:

: : Hi everyone,

: : Does anyone know if Inside DirectX is good? I'm having trouble
: : with a load_bitmap() function - I don't understand it!
: : Does anyone know of a good book that guides you thru
: : loading a bitmap?

: I'm working with Windows Game Programming for Dummies and he lays the code out for Load_Bitmap in detail. The book isn't bad - a few irritating typos here and there but pretty good on the whole.

: That Guy

I'm using it too, he doesn't give the code for his Load_Bitmap function! Only on the CD!

Follow Ups:

Post a Followup

Name:


It's not possible

Posted by Myopic Rhino on September 04, 1998 at 12:16:11:

In Reply to: Its possible scale and rotate a sprite with blt? how? posted by champi on September 02, 1998 at 15:23:35:

BltFast does not allow scaling, or any other effects. If you want to scale, you have to use Blt

  • Myopic Rhino's Game Programming Savanna

Follow Ups:

Post a Followup

Name:


Direct Draw Memory

Posted by Levi Womack on September 04, 1998 at 13:05:11:

In Reply to: C++ Builder/Delphi and DirectDraw hint posted by Jack Strohm on May 02, 1998 at 20:47:41:

I just bought this game called F1 Racing. It loads fine. But when the game starts to play it gives me a error saying that Direct Draw doesn't have enough memory.
I have a Pentium 200 MMX, 64M SDRAM, and a Diamond Stealth 2000 3D with 2MB. What can I do to solve this problem or do I need a different video card?

Follow Ups:

Post a Followup

Name:


Re: Direct X 6 Book coming out soon?

Posted by Myopic Rhino on September 04, 1998 at 15:29:46:

In Reply to: Direct X 6 Book coming out soon? posted by Dwight Yachuk on September 03, 1998 at 10:04:54:

: Anyone know when a DirectX 6 book is being published? Should I buy a Direct X 5 or wait?

Well, I haven't HEARD of one (and I have looked around), although I would assume that one is in the works. I know that Andr� LaMothe is working on a book titled Tricks of the 3D Graphics Programming Gurus, which I would assume will use DirectX 6.0, although it will probably focus on Direct3D.

I don't see any reason why you couldn't read a book on 5.0. There are some differences between 5.0 and 6.0, but the basics are still pretty much the same. Once you know 5.0, learning the new things in 6.0 will be as easy as reading the docs that come with it.

  • Myopic Rhino's Game Programming Savanna

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0 answer

Posted by James Kremer on September 04, 1998 at 16:16:51:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Igor on March 25, 1998 at 00:12:52:

go to www.microsoft.com
click downloads at top of page under search
click utilities
click Hardware Utilities on right
Click Browse the Hardware Utilities Library
scroll to bottom of list
click Hits 26-50
click Microsoft DirectX v6.0
click Download Now

Follow Ups:

Post a Followup

Name:


Getting Started

Posted by AKBishop on September 04, 1998 at 16:25:20:

How do I get started in DirectX programming? Where can i find tutorials, etc.? any good books? I use MS VC++ 5.0.

Thanks!

Follow Ups:

  • Re: Getting Started Myopic Rhino 18:18:50 9/04/98 (1)
    • DirectX 6.0 Myopic Rhino 18:24:24 9/04/98 (0)
  • Re: Getting Started - Book Advice That Guy 18:06:01 9/04/98 (0)

Post a Followup

Name:


Re: Getting Started - Book Advice

Posted by That Guy on September 04, 1998 at 18:06:01:

In Reply to: Getting Started posted by AKBishop on September 04, 1998 at 16:25:20:

: How do I get started in DirectX programming? Where can i find tutorials, etc.? any good books? I use MS VC++ 5.0.

: Thanks!

After browsing through all the books on DirectX and graphics programming at the local book store, I recommend Windows Game Programming for Dummies as a book resource. Yep - a Dummies book! I figure when you're learning about something as complex as Windows and DirectX, it's best to take baby step and not get too frustrated. Plus, it's specifically geared for VC++ 5. I've got it and so far it's working out pretty good although I'm stumped on the Blt() routine at the moment.

Cheers!

Follow Ups:

Post a Followup

Name:


Re: Getting Started

Posted by Myopic Rhino on September 04, 1998 at 18:18:50:

In Reply to: Getting Started posted by AKBishop on September 04, 1998 at 16:25:20:

: How do I get started in DirectX programming? Where can i find tutorials, etc.? any good books? I use MS VC++ 5.0.

: Thanks!

I really think DirectX is too complicated a subject to learn using just tutorials, although there are some good ones in the articles section here. As far as books go, I'd say you will get the most bang for your buck from Andr� LaMothe's Windows 95 Game Programming For Dummies. It covers all the basics of DirectX (except for Direct3D, but you can and should wait until you understand the rest of DX better). All of the samples and libraries that come with it are written for MSVC++, so you should have no problems with it. The best thing is that it is only about $30.

Of course, you will also need to get the DirectX SDK. Version 5.0 comes with the book I just mentioned. If you want version 6.0, you're probably best off buying it from Microsoft for less than $10. The only place I know of that you can still download it is here. It's in the lobby/download area, I believe.

It will help if you know a little Windows programming before you dive into DirectX, but you don't need much. In fact, Andr�'s book covers all you really need. Eventually, it would be a good idea to learn as much Windows programming as you can, but you can really just learn it as you need it.

If you need anything else, feel free to contact me.

  • Myopic Rhino's Game Programming Savanna

Follow Ups:

  • DirectX 6.0 Myopic Rhino 18:24:24 9/04/98 (0)

Post a Followup

Name:


DirectX 6.0

Posted by Myopic Rhino on September 04, 1998 at 18:24:24:

In Reply to: Re: Getting Started posted by Myopic Rhino on September 04, 1998 at 18:18:50:

Hmm... I guess this board doesn't support HTML. Oh well, you can download DirectX 6.0 from http://www.ideasoftware.com/

Follow Ups:

Post a Followup

Name:


Re: Helpp !!! Directx 6 with win98 Problems....

Posted by Juan Luis Aguilar Alamo on September 04, 1998 at 19:46:16:

In Reply to: Re: Helpp !!! Directx 6 with win98 Problems.... posted by ding@ on July 21, 1998 at 10:25:22:

: well, its call beta, which means its not ready for release!. the DX6's uninstall part is yet to implement. you can try your luck on reinstalling the DirectX5.2. if it doesn't help, wait 3 more weeks for the DX6 final release!.

: Think this is a small lesson for you??, hah, "later the better"??, its a joke!

: : Hi, I installed directx 6 on win98... but i have many trouble!!

: : I erased all files about directx 6 ... but at control panel in Directx Panel say..

: : Direct3d version directx 6
: : Directdraw version directx 6
: : directinput not found
: : directplay not found
: : direct sound version directx 5

: : So. I cant play Mortal Kombat 4... because directx isnt installed correctly...

: : Do you Know some unistall for directx 6...

: : Please give infromation!!!

: : Thanks Roal Jhonson

Follow Ups:

Post a Followup

Name:


3ds max for VC++

Posted by difabs on September 04, 1998 at 20:52:11:

i want to use 3d studio max model that i created(for a game)....instead of the directx sdk's .x file in VC++5. i wanted to know if VC++ supports this...and if i use directx to do so ??

Follow Ups:

  • Re: 3ds max for VC++ tim 10:31:24 9/08/98 (0)

Post a Followup

Name:


Re: D3D Texture GetDC() troubles

Posted by jason on September 04, 1998 at 23:34:55:

In Reply to: D3D Texture GetDC() troubles posted by Steve Dykes on July 17, 1998 at 10:49:08:

: I'm having a bit of a problem with a Direct3D (dx5) program I'm working
: on, which I'm hoping some of you DX gurus can help with.

: Program works like a charm when run using either the HAL, or software
: RGB emulation. However, when I try to use the Ramp driver or the MMX
: driver, I can no longer get device contexts for my texture surfaces
: (when loading the textures, I use GetDC so I can BitBlt the loaded
: bitmap onto the surface).

: I create the texture surfaces for all software drivers in exactly the same way
: (system memory), which is why I'm a bit perplexed as to why it works for
: RGB, and not for Ramp or MMX (which is an RGB driver).

: I'm pretty new to Win95/DX; does this problem ring any bells for
: anybody? Any general things I should be watching out for? I've looked
: at many d3d programs (examples in documentation, etc.), and nothing
: jumps out at me as something I'm doing wrong (or omitting).

: Any help is greatly appreciated!

: --Steve Dykes

: business: sdykes@s3i.com
: home: sdykes@erols.com

Follow Ups:

Post a Followup

Name:


Re: Im working on final fight type game and i need help

Posted by Tim Wright(MainFrame) on September 06, 1998 at 00:00:24:

In Reply to: Im working on final fight type game and i need help posted by champi on September 01, 1998 at 15:38:14:

: hi everyone !
: im programing a final fight type game but im begginer so i need some serius help in the follow deparments:
: collision detection ( i dont use the best )
: sound ( multiple wavs how implement? )
: scrolling large bitmaps or make a tile ( like the fox bear demo).
: play an avi in fullscreen with directx
: help me and i send you my demo.

Greetings champi,
I'm pretty new to DirectX as well, but i can help you with DirectSound and TileBased scrolling.
There are a few DirectDraw AVI classes around and I could give you a copy of the one's I've found.
I'm not messing with D3D yet, so perhaps you could help me with that later.
I have a game on the net including source that might help as well.
Give me a yell if you need my help. ICQ# 8305639

  • MRAKS

Follow Ups:

Post a Followup

Name:


Re: Does anyone If DirectX6 will work on Borland v4.5?

Posted by MainFrame on September 06, 1998 at 00:53:22:

In Reply to: Does anyone If DirectX6 will work on Borland v4.5? posted by Narshe on August 28, 1998 at 14:13:37:

: Ok Im a newbie at programming, but I try to compile ym code and it gives me errors in the .h file about a type GUID not being defined. So far I can't do a thing.. ive linked the dirs of lib and h. I dont know what to change if I have to change something.

: Thnx.. NARSHE

I know for a fact that DirectX will work with Borland C++ 5.0 and I assume it will work on BC4.
Make sure your linking directly to the lib's and they are the borland lib's. A lot of people,
including myself, have accidentally deleted the borland lib's. They're in dxsdk\lib\borland dir.
If that doesn't work, or thats what you've done, try adding #define GUID in your code. It's a long
shot, but it might work. If it still doesn't work give a yell and meybe I can help.
I use Borland C++ 5.0, by the way, and I might be able to send you some compileable source code.
My includes are in odd dirs, but I can fix that.

MainFrame ICQ# 8305639 AOL IM crono537

Follow Ups:

Post a Followup

Name:


Re: I tried all that stuff :(

Posted by Matthew Wright on September 06, 1998 at 04:11:28:

In Reply to: I tried all that stuff :( posted by Monster 3d II owner on August 04, 1998 at 07:35:52:

1) Back up your registry! Just incase you missed that, back up your registry!
Also, now would be a good time to goto your DISPLAY PROPERTIES in the CONTROL PANEL
and change your display to VGA. Reboot and continue to step two.
2) Run RegEDIT. It can be found in your Windows directory. Goto
HKEY_LOCAL_MACHINE/Software/Microsoft/ section and delete the DirectX, DirectPlay, Direct3D and
DirectDraw entries.
3) Now run Windows Explorer. It should be found by clicking START then PROGRAMS and you should see it
near the bottom of the list.
4) Now in Windows Explorer, goto your Windows/System/ directory and move the DirectX files to a seperate
directory like c:\DirectOld. Here are the files you are looking for: ddraw*.*, dsound*.*, dinput*.*, d3d*.*,
dplayx.dll, dpmodemx.dll, dpwsocks.dll, vjoyd.vxd and joy.cpl.
5) Reboot again.
6) Your done!!!

Follow Ups:

Post a Followup

Name:


GetNamedObject and RM3

Posted by Pablo de Heras on September 06, 1998 at 11:39:01:

Hi,

I have this level that I load with RMFrame3->Load. It displays ok. I have a
mesh that uses a texture that has the blue colour as transparent. I have to
find this mesh, locate the texture and set blue as the transparent texture
colour. Here's the code that I use.

// LPDIRECT3DRM3 lpD3DRM;

LPDIRECT3DRMOBJECT pObject=0;
lpD3DRM->GetNamedObject("chains",&pObject);
if (pObject!=0)
{
LPDIRECT3DRMMESH pMesh=(LPDIRECT3DRMMESH)pObject;
LPDIRECT3DRMTEXTURE pTexture=0;
pMesh->GetGroupTexture(0,&pTexture);
pTexture->SetDecalTransparentColor(RGB_MAKE(0,0,255));
// The colour in the texture that will be transparent
pTexture->SetDecalTransparency(TRUE);
}
else
{
pParallell->SetColorRGB(D3DVAL(1),D3DVAL(0),D3DVAL(0));
// Set the light in the scene to blue to show that we didn't find
// the mesh
}

Well the code never finds any object with the name "chains". The level is
converted from 3ds with "conv3ds -T level.3ds". The level is loaded with

pLoadFrame->Load("level.x",NULL,D3DRMLOAD_FROMFILE,NULL,NULL);

I have looked into the level.x file and there is a mesh called chains. Even
if I look for "x3ds_top_level" which is definitely there but is a frame, it
won't find this frame.

There are no samples for the GetNamedObject method in DX6 only in DX5. Does
this mean that this method is not supported anymore ;)?

I have tried with enumerateobjects but this doesn't find any object with
any name either.

Is it because theses methods only return Object and not Object2? If so what
are the alternative methods to find an object by name?

WHAT TO DO???????????????

I really need help on this one. /Pablo de Heras

Follow Ups:

  • Re: GetNamedObject and RM3 Fred 12:01:27 9/07/98 (0)
  • email adress corrected Pablo de Heras 11:42:03 9/06/98 (0)

Post a Followup

Name:


email adress corrected

Posted by Pablo de Heras on September 06, 1998 at 11:42:03:

In Reply to: GetNamedObject and RM3 posted by Pablo de Heras on September 06, 1998 at 11:39:01:

I didn't submit the correct e-mail.

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by C�sar Arce on September 06, 1998 at 12:56:58:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Igor on March 25, 1998 at 00:12:52:

: : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


errr message when compiling

Posted by Agent X on September 06, 1998 at 20:38:31:

i just recently compiled some of Andre' Lamothes code from his book "Windows game programming for dummies" but it gave me some errors when i compiled it.

--------------------Configuration: Prog9_1 - Win32 Debug--------------------
Compiling...
Prog9_1.cpp
C:\DevStudio\Lenni\Dxgame\Prog9_1.cpp(193) : warning C4101: 'ps' : unreferenced local variable
C:\DevStudio\Lenni\Dxgame\Prog9_1.cpp(193) : warning C4101: 'hdc' : unreferenced local variable
Linking...
Prog9_1.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12
LIBCD.lib(crt0.obj) : error LNK2001: unresolved external symbol _main
Debug/Prog9_1.exe : fatal error LNK1120: 2 unresolved externals
Error executing link.exe.

Prog9_1.exe - 3 error(s), 2 warning(s)

-Agent X

Follow Ups:

  • Re: errr message when compiling Clay 08:50:23 9/07/98 (0)

Post a Followup

Name:


Learning DirectX

Posted by Qwertie on September 06, 1998 at 22:23:15:

Let me tell you a story. Last year I wanted to move from DOS game programming (Mode X/Mode Q/Mode 0x13) to DirectX, so I called around and found that the only book I could find on it was "Win32 Game Developer's Guide with DirectX 3". So I got that book and was appaled. There was hardly anything in it about the important technical aspects of DirectX--it starts the first chapter by explaining what pixels are, (wtf?!) and explaining how a 2-dimensional array is stored. Other discussions included "what's a palette?", "how sound is stored in a computer", and "sprite basics".

A damn game programming book for non-game programmers. Obviously, being a REAL game programmer (albeit a non-profit one so far), I want to be able to do more than simply load a .BMP file and put it in a window, or load a .WAV file and play it.

So I tried to figure out DirectX using its documentation, but the DX3 docs I found were too incomplete and had too many references to seemingly obscure parts of the Win32 API. Well, that's my sad story. But after a time I have come to realize that I can't keep developing for DOS, so can anyone reccommend a book that will tell me how to use DirectX effectively? A book designed for seasoned game developers on non-Windows platforms?

What I'd like to do is write both the game itself and the map/object editors for Windows, which means I need a book that covers DirectX, Win32, and GDI.

Another sad story: I read a book on the Win32 API, and also read the API reference for many of the common controls. So then I tried to start writing a little MDI editor program. After having found Microsoft's mammoth, cumbersome API to be a loathsome burden on the programmer, AND taking exceptional dislike to all Microsoft's conventions, such as hungarian notation or whatever it is (szId? lpszId? lplpszId? What ever happened to char *Id?), and the other convention of having at least two totally separate versions of every set of APIs (which one do I use? What's the difference between them?), and having altogether too many constants (WS_OVERLAPPED? WS_OVERLAPPEDWINDOW? WS_POPUP? WS_POPUPWINDOW? WS_TILED? WS_TILEDWINDOW? WS_EX_CLIENTEDGE? WS_EX_OVERLAPPEDWINDOW? WS_EX_TOOLWINDOW? WS_EX_WINDOWEDGE? Which ones do I choose?????? Goddammit, all I want to do is make a window!!!!!!!) and then even if you do what the documentation says you get weird error codes, plus after you finally figure it out you have to deal with all those coordinate systems, and common controls refused to work in the .RC files, and, ... oh sorry, I guess I started rambling there. So to continue my story, I spent tens of ours on this MDI app, and finally, I had managed to get a *blank* MDI window with a menu bar and status bar, and a tool box with BS_PUSHLIKE buttons with lovely icons and stuff, but decided if I had to spend 20 hours making a toolbox, it would probably take me over a hundred hours to get down to business, so I started attempting to make a "wrapper" API that would let me get away from the hassles of most of the error codes, strange conventions, constants, and multiple coordinate systems, font size calculations etc etc etc etc. Well, after toiling many hours I had a preliminary version of my wrapper functions, and I tried a simple test program that was supposed to put an empty overlapped non-MDI window with nothing but an empty status bar on it, ran the program and GUESS WHAT HAPPENED? It didn't work!!!!!! The goddamn thing refused to work for no good reason.

Shortly thereafter I just said "to hell with it" and wrote a custom Win95 lookalike GUI in DOS for my Super Nintendo Emulator, SNEqr.

So I guess what I want to say is, is there an easier way to write a windows program? Can anyone help?

BTW, is the new DirectX able to play .MOD files?

Follow Ups:

Post a Followup

Name:


Hi Can I Complain Some More?

Posted by Qwertie on September 06, 1998 at 23:14:21:

Why do windows programming tutorials and books always contain identifiers that suddenly pop out of nowhere? Like take this snippet from one of the better tutorial authors, Mark Feldman.
LPDIRECTDRAWSURFACE m_pPrimary;
LPDIRECTDRAWSURFACE m_pBackBuffer;

yahoo, this author explained beforehand what these two were for. If only everything was explained.

// Get the primary display surface
TRACE("DrawPrim Demo: Creating the primary surface\n");

hmm, where did that function come from?

ZeroMemory(&ddsd, sizeof(ddsd));

ddsd? Just one example of a variable that just appears out of nowhere.

ddsd.dwSize = sizeof(ddsd);
ddsd.dwFlags = DDSD_CAPS;
ddsd.ddsCaps.dwCaps = DDSCAPS_PRIMARYSURFACE;
if (m_pDD->CreateSurface(&ddsd, &m_pPrimary, NULL) != DD_OK) return FALSE;

You know, I really wish someone would go over the reasons for all these functions failing. The docs say "This function returns xxxx or xxxx if it fails." Now if only they would list all the CAUSES for failures and heaven forbid, solutions! (it seems that, when programming Windows, EVERY function will fail once in a while.)

Tootaloo, until I think of something else to get mad about :)

Follow Ups:

Post a Followup

Name:


Re: errr message when compiling

Posted by Clay on September 07, 1998 at 08:50:23:

In Reply to: errr message when compiling posted by Agent X on September 06, 1998 at 20:38:31:

: C:\DevStudio\Lenni\Dxgame\Prog9_1.cpp(193) : warning C4101: 'ps' : unreferenced local variable
: C:\DevStudio\Lenni\Dxgame\Prog9_1.cpp(193) : warning C4101: 'hdc' : unreferenced local variable

The warnings are because a local variable was declared and never used. These generally don't cause problems, but you should remove them before your final release version is compiled.

: Linking...
: Prog9_1.obj : error LNK2001: unresolved external symbol _DirectDrawCreate@12

This one is probably because you didn't tell it to link the ddraw.lib file. The way you add library files is compiler/IDE dependant but is usually easy.

: LIBCD.lib(crt0.obj) : error LNK2001: unresolved external symbol _main

You probably tried to make a Windows app, but told the IDE to create a make file for a console app. You'll need to make a new make file for a windows app.

: Debug/Prog9_1.exe : fatal error LNK1120: 2 unresolved externals
: Error executing link.exe.

: Prog9_1.exe - 3 error(s), 2 warning(s)

Clay

Follow Ups:

Post a Followup

Name:


Getting sound for Nascar Racing Game

Posted by Jeannie on September 07, 1998 at 09:52:01:

I cannont get the sound to come on now that I am on the internet for the Nascar Racing 2 game. When I go to Autodectect sound- it freezes my screen and I have to abort. Someone suggested that I find out what sound card I have but I don't know how. Please help me- my husband is driving me crazy- since this is his favorite game!!! Thanks- Jeannie

Follow Ups:

  • Re: Getting sound for Nascar Racing Game Shannon 22:15:36 9/07/98 (0)

Post a Followup

Name:


Re: GetNamedObject and RM3

Posted by Fred on September 07, 1998 at 12:01:27:

In Reply to: GetNamedObject and RM3 posted by Pablo de Heras on September 06, 1998 at 11:39:01:

hmm... just a suggestion, maybe you can do the texture transparent thing in the loadtexture callback., simply compare the current texture file name to the _target_ file name, if match, set the colorkey for that texture, if not,bussiness as usual.

There are some different kind of name in the .x file, it can be a 3d object name, a class name, or a frame name, or some funny name generated by conv3ds. make sure you look for the currect one.

Or you can use a recursive loop to travasal the whole frame hiarchy to get the match named frame/object by calling GetName().

Follow Ups:

Post a Followup

Name:


Re: Question - I may have the solution

Posted by Travis on September 07, 1998 at 14:37:09:

In Reply to: Question about Visual C++ and DirectX posted by Bob on July 30, 1998 at 11:08:32:

: things u might need to know

: - i am pretty sure i have directx 5 sdk and visual c++ setup okay

: - i am a programmer with very little windows programming exp (mostly unix and vb, go figure)

: basically when i try to creat a minimal app with directx, i know that my app compiles ok, but it runs into a linking error LNK2001 unresolved symbol _main. in the help it has a host of possible causes, but i was wondering if someone knew right away so i could get started.

: bob

-- I'm not sure which version of tthe compiler you are using but in Visual C++ 6.0 I came across the same problem and here is how I fixed it:

First: Go into the Porject Settings.

Second: Find the Tab which is called 'Link', it as it implies has all of the linker options.

Third: Theres an edit box which lists a bunch of different libraries, the heading is 'Object/library modules'. In that edit box type in ddraw.lib and make sure it has a space between it and the other libraries. Then click OK and it should add it to your project options field.

Finally: Compile and if this was your problem it will link successfully

Good Luck

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 6.0

Posted by Nancy Jaggers on September 07, 1998 at 15:04:56:

In Reply to: Re: Where Can I download DirectX 6.0 posted by Josee Oliviero on July 23, 1998 at 10:38:35:

: Where Can I download DirectX 6.0 (or latest versions)

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by bo on September 07, 1998 at 19:52:24:

In Reply to: Re: Where Can I download DirectX 5.0 posted by Fauzea on July 09, 1998 at 13:04:34:

: : : : Where Can I download DirectX 5.0. I need it for a game

Follow Ups:

Post a Followup

Name:


Re: Getting sound for Nascar Racing Game

Posted by Shannon on September 07, 1998 at 22:15:36:

In Reply to: Getting sound for Nascar Racing Game posted by Jeannie on September 07, 1998 at 09:52:01:

Hi,
I've had the game for a while and have ran across just about every problem possible and have found the fixes. I mainly need to know your operating system: DOS, Windows 95/98/NT, etc. From there I can tell you how to find out your sound card type and setting you will need to know. My email is currently screwed up, so just post another message here and I'll follow up.

Follow Ups:

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by vincenzo on September 08, 1998 at 07:08:37:

In Reply to: Re: DirectX6 FINAL RELEASE! posted by t.sato on August 28, 1998 at 09:25:18:

: :
: : : The FINAL version of DirectX6/SDK will be released with in 24 hours!

: : : Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

Post a Followup

Name:


Re: AWE32 and direct-x 5 don't work together ??

Posted by Gilly on September 08, 1998 at 07:47:09:

In Reply to: AWE32 and direct-x 5 don't work together ?? posted by Kristel on August 25, 1998 at 15:29:31:

I have the same problem as Kristel !!

Especially in the games
Motocross Madness
and
Conflict: Freespace !

Both games start with music but when chosing anything in the menu, my machine hangs up !
Sound is always repeating a small section and the
computer can only be switched off !!!
Throwing the SB16/32 P&P out of the Control Panel
let's the game work without sound !
Updating the drivers didnt lead to anything !

May configuration:
P200 MMX
64 MB SD-Ram
Matrox-Mystique 4MB
Orchid Righteous 3dFX 4MB
SB AWE 32 4MB
USR Sportster Flash
MS Force-Feedbak-Joystick
HP 850c Printer

Help would be nice !!!
Gilly

Follow Ups:

Post a Followup

Name:


problems with games $%�"&%/(

Posted by Gilly on September 08, 1998 at 08:12:02:

I have Problems with several games !

Motocross madness
conflict freespace
jedi knight

the games hang up with sound always repeating a short
part....computer can only be switched off then...
&�$%/�$/�&/(

when deinstalling the sondcard (awe32)
the games work but logically without sound....

my configuration:
p200 mmx
64 mb sd-ram
matrox mystique 4mb
orchid righteous 3dfx
soundblaster awe32
...

help would be nice !!!

Follow Ups:

Post a Followup

Name:


Re: 3ds max for VC++

Posted by tim on September 08, 1998 at 10:31:24:

In Reply to: 3ds max for VC++ posted by difabs on September 04, 1998 at 20:52:11:

well the answer is yes and no. DirectX dosent support this itself, and it will work with VC++, BUT yu have to write the function to read the .3ds file and stuff yourself. If you really want to go this route, look on the web for i believe its called the 3ds toolkit it has functions for loading the info from 3ds files.
: i want to use 3d studio max model that i created(for a game)....instead of the directx sdk's .x file in VC++5. i wanted to know if VC++ supports this...and if i use directx to do so ??

Follow Ups:

Post a Followup

Name:


Loading Bitmaps from the samples included with DX5SDK

Posted by Chris Clements on September 08, 1998 at 12:39:06:

The only way I can learn DX is to take apart the examples and fiddle with them. I have tried to load another bitmap of the same size and from the same directory as the "Back" bitmap used in DDEX2 example. The program always crashes and shows the Direct X init failed message box. After debugging I found that the program cannot seem to load a bitmap other than the one that the code already includes. I have made all the nessicary changes in the code that I can think of. I have created a bitmap of the same size and formAT(16 BIT). Is there something I'm missing? I could do this all dy long not using DX. Why am I having this problem?

Follow Ups:

Post a Followup

Name:


Loading Bitmaps from the samples included with DX5SDK

Posted by Chris Clements on September 08, 1998 at 12:40:38:

The only way I can learn DX is to take apart the examples and fiddle with them. I have tried to load another bitmap of the same size and from the same directory as the "Back" bitmap used in DDEX2 example. The program always crashes and shows the Direct X init failed message box. After debugging I found that the program cannot seem to load a bitmap other than the one that the code already includes. I have made all the nessicary changes in the code that I can think of. I have created a bitmap of the same size and formAT(16 BIT). Is there something I'm missing? I could do this all dy long not using DX. Why am I having this problem?

Follow Ups:

  • Re: Loading Bitmaps from the samples included with DX5SDK Ravi Joshi 00:48:09 9/14/98 (0)

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by Keith Peaerson on September 08, 1998 at 14:59:20:

In Reply to: Where Can I download DirectX 5.0 posted by Michale Chambers on January 17, 1998 at 15:35:17:

: Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


HeLp

Posted by Eugene V. on September 08, 1998 at 16:19:27:

Please, send me dx 5.0 or 6.0 libraries,header files, and
files ddutil.cpp and ddutil.h by E-mail.

My adress is evgw@cyberax.ru

Follow Ups:

  • Yeah, right Myopic Rhino 11:12:10 9/09/98 (0)

Post a Followup

Name:


Yeah, right

Posted by Myopic Rhino on September 09, 1998 at 11:12:10:

In Reply to: HeLp posted by Eugene V. on September 08, 1998 at 16:19:27:

: Please, send me dx 5.0 or 6.0 libraries,header files, and
: files ddutil.cpp and ddutil.h by E-mail.

: My adress is evgw@cyberax.ru

Look, even zipped, the files you are asking for take over 30 MB for 5.0 or 91 MB for 6.0. I doubt any e-mail servers will accept attachments that large. Instead, try these links.

For 6.0: http://www.ideasoftware.com/lobby_downloads.htm

For 5.0: http://www.triax.com/ben/directx/

  • Myopic Rhino's Game Programming Savanna

Follow Ups:

Post a Followup

Name:


DirectX 6 and Diamond Monster 3d II

Posted by Karl Fisher on September 09, 1998 at 21:59:11:

I am using the Boids sample from DX6 and working on transparency . I have
two spheres, one inside the other, and the outer (larger) sphere is textured
with a bitmap of clouds. The area between the clouds is all Black
RGB(0,0,0). The cloud color varies from white to very light blue.

This works fine with my ATI All in Wonder Rage II driver, and the
transparency looks great using the following:

pd3dDevice ->SetRenderState(D3DRENDERSTATE_BLENDENABLE, TRUE);

pd3dDevice->SetRenderState(D3DRENDERSTATE_SRCBLEND, D3DBLEND_SRCCOLOR);
pd3dDevice->SetRenderState(D3DRENDERSTATE_DESTBLEND, D3DBLEND_ONE);

My problem is when I switch to the Diamond Monster 3d II driver, the screen
goes black. The program doesn't crash, and I can switch back to the ATI
driver and every thing is fine.

If I comment out the first of the three statements above it works fine with
either driver except no transparency. I do get a very substantial
improvement in FPS with the Monster 3d II driver.

Any help wil be greatly appreciated.
Thanks

Karl
karl_fisher@msn.com

Follow Ups:

  • Re: DirectX 6 and Diamond Monster 3d II Clay 11:25:08 9/10/98 (1)
    • Re: DirectX 6 and Diamond Monster 3d II THANKS CLAY Karl Fisher 15:17:48 9/10/98 (0)

Post a Followup

Name:


Re: Late Re: Alpha-blending decals in Retained Mode

Posted by Tim Brubaker on September 09, 1998 at 22:24:35:

In Reply to: Re: Late Re: Alpha-blending decals in Retained Mode posted by boller on September 03, 1998 at 02:44:07:

I've been able to get simple alpha blended color to work
in retained mode only in DirectX 5.0 and higher.

You do it like this:
Create an IDirect3DRMDevice2. This is the new
interface from 5.0.

Enable blending for the device2 with the
following method:
IDirect3DRMDevice2::SetRenderMode(
D3DRMRENDERMODE_BLENDEDTRANSPARENCY |
D3DRMRENDERMODE_SORTEDTRANSPARENCY );

(or save yourself some typing with
SetRenderMode(3) - it means the same thing!)

Once this is turned on, you can set mesh colors
with alpha components and they fade in and out
real nice. You can even put colorkey transparent
textures overtop and the visible part of the
texture will become translucent as well.

Now, I should warn you, this doesn't work 100% perfectly.
It took me a long time get even this working because for
some reason Microsoft won't put out proper manuals
on Direct3D. Whether this works or not might depend
on things like whether a z buffer is enabled (Mine is),
whether you're using a HAL device (I am, Riva128),
the lighing mode (I always use RGB) etc.

One thing I simply can't figure out (and
just spent all night surfing for without success)
is a marked inconsistency in the alpha transparency
with regards to other transparent objects
in the scene. My scenes look good until I
steer myself until I'm looking through one
translucent object at another translucent object.
Then I sometimes see the second object through the
first one, and sometimes I don't, even though solid
non-blended objects are always visible. I suspect this
has something to do with setting up the second pass
buffer properly, but I can't find any info on that.
Anyone know?

As far as true per-texel alpha transparency
goes, I can't figure that out in retained mode.
It's possible to create a DDraw surface dedicated to
Alpha information, but there's nothing in the help
files about what you might do with such a surface.
I'd be happy if I could get the simple per-face
alpha transparency working well.

Follow Ups:

Post a Followup

Name:


Disabling taskbar in directdraw

Posted by Fred Fol on September 10, 1998 at 08:18:25:

I need disable taskbar in an directdraw application using full screen.
You can help me?

Follow Ups:

Post a Followup

Name:


Re: DirectX5

Posted by William on September 10, 1998 at 09:06:31:

In Reply to: DirectX5 posted by Lois Nicholls on February 17, 1998 at 16:15:39:

: My system requires DirectX5.0 in order to run
Age of Empires and other games.
Please can you tell me the address where I
can download it from. All help would be greatly
appreciated.

Follow Ups:

Post a Followup

Name:


Re: DirectX 6 and Diamond Monster 3d II

Posted by Clay on September 10, 1998 at 11:25:08:

In Reply to: DirectX 6 and Diamond Monster 3d II posted by Karl Fisher on September 09, 1998 at 21:59:11:

Run the boids sample using both the ATI and Diamond cards. The revolving spheres will appear very different. It looks as though the 3dfx card makes things more transparent than the ATI given a quantitative amount of transparency (at least this has been my experience).

Anyhow, one thing that may help is making your textured sphere white instead of black.

: I am using the Boids sample from DX6 and working on transparency . I have
: two spheres, one inside the other, and the outer (larger) sphere is textured
: with a bitmap of clouds. The area between the clouds is all Black
: RGB(0,0,0). The cloud color varies from white to very light blue.

: This works fine with my ATI All in Wonder Rage II driver, and the
: transparency looks great using the following:

: pd3dDevice ->SetRenderState(D3DRENDERSTATE_BLENDENABLE, TRUE);

: pd3dDevice->SetRenderState(D3DRENDERSTATE_SRCBLEND, D3DBLEND_SRCCOLOR);
: pd3dDevice->SetRenderState(D3DRENDERSTATE_DESTBLEND, D3DBLEND_ONE);

: My problem is when I switch to the Diamond Monster 3d II driver, the screen
: goes black. The program doesn't crash, and I can switch back to the ATI
: driver and every thing is fine.

: If I comment out the first of the three statements above it works fine with
: either driver except no transparency. I do get a very substantial
: improvement in FPS with the Monster 3d II driver.

: Any help wil be greatly appreciated.
: Thanks

: Karl
: karl_fisher@msn.com

Follow Ups:

  • Re: DirectX 6 and Diamond Monster 3d II THANKS CLAY Karl Fisher 15:17:48 9/10/98 (0)

Post a Followup

Name:


What's a .X file and How create?

Posted by Younger on September 10, 1998 at 13:23:03:

What's a .X file and How create?

Follow Ups:

  • Re: What's a .X file and How create? zipht 23:08:26 9/14/98 (0)
  • Re: What's a .X file and How create? Takahiko Watanabe 17:04:45 9/12/98 (0)
  • Re: What's a .X file and How create? Younger 13:27:59 9/10/98 (1)
    • Re: What's a .X file and How create? Lennard Feddersen 19:31:20 9/21/98 (0)

Post a Followup

Name:


Re: What's a .X file and How create?

Posted by Younger on September 10, 1998 at 13:27:59:

In Reply to: What's a .X file and How create? posted by Younger on September 10, 1998 at 13:23:03:

: What's a .X file and How create?

Follow Ups:

  • Re: What's a .X file and How create? Lennard Feddersen 19:31:20 9/21/98 (0)

Post a Followup

Name:


Re: DirectX 6 and Diamond Monster 3d II THANKS CLAY

Posted by Karl Fisher on September 10, 1998 at 15:17:48:

In Reply to: Re: DirectX 6 and Diamond Monster 3d II posted by Clay on September 10, 1998 at 11:25:08:

: Run the boids sample using both the ATI and Diamond cards. The revolving spheres will appear very different. It looks as though the 3dfx card makes things more transparent than the ATI given a quantitative amount of transparency (at least this has been my experience).

: Anyhow, one thing that may help is making your textured sphere white instead of black.

: : I am using the Boids sample from DX6 and working on transparency . I have
: : two spheres, one inside the other, and the outer (larger) sphere is textured
: : with a bitmap of clouds. The area between the clouds is all Black
: : RGB(0,0,0). The cloud color varies from white to very light blue.

: : This works fine with my ATI All in Wonder Rage II driver, and the
: : transparency looks great using the following:

:
: : pd3dDevice ->SetRenderState(D3DRENDERSTATE_BLENDENABLE, TRUE);

: : pd3dDevice->SetRenderState(D3DRENDERSTATE_SRCBLEND, D3DBLEND_SRCCOLOR);
: : pd3dDevice->SetRenderState(D3DRENDERSTATE_DESTBLEND, D3DBLEND_ONE);

: : My problem is when I switch to the Diamond Monster 3d II driver, the screen
: : goes black. The program doesn't crash, and I can switch back to the ATI
: : driver and every thing is fine.

: : If I comment out the first of the three statements above it works fine with
: : either driver except no transparency. I do get a very substantial
: : improvement in FPS with the Monster 3d II driver.

: : Any help wil be greatly appreciated.
: : Thanks

: : Karl
: : karl_fisher@msn.com

Hi Clay,

Thanks so much for your reply. I was able to solve the main problem with the kind help of Robert Dunlop.

I initialized with (D3DRENDERSTATE_BLENDENABLE, FALSE), set it to TRUE just
prior to rendering the outer sphere, and back to FALSE immediately following
the rendering of the outer sphere.

Also I had to change the other two SetRenderState statements as follows:

pd3dDevice->SetRenderState(D3DRENDERSTATE_SRCBLEND, 0.0f);
pd3dDevice->SetRenderState(D3DRENDERSTATE_DESTBLEND, D3DBLEND_ONE);

I did notice that the non black pixels (clouds) were somewhat translucent, so I will experiment with the colors as you suggested to see how that effects it. It does appear, as you mentioned, that the Monster 3D II does produce transparency somewhat different than my ATI.

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0 Download

Posted by ddc; on September 11, 1998 at 05:22:42:

In Reply to: Re: DirectX 5.0 Download posted by j.boschert on March 18, 1998 at 09:52:19:

: : : : : : can anyone tell me where to download it besides microsoft website?

Follow Ups:

Post a Followup

Name:


Help!

Posted by Angeon on September 12, 1998 at 14:39:39:

Where can I get the very very very basics of DirectX programming? I have no clue what to do.
hehe. Thanks!

Follow Ups:

  • Re: Help! Snowman 16:23:13 9/12/98 (0)

Post a Followup

Name:


Re: Help!

Posted by Snowman on September 12, 1998 at 16:23:13:

In Reply to: Help! posted by Angeon on September 12, 1998 at 14:39:39:

I think that you should get a book on the subject. They're very helpful, and they'll teach you the basics.

-Snowman

Follow Ups:

Post a Followup

Name:


Re: What's a .X file and How create?

Posted by Takahiko Watanabe on September 12, 1998 at 17:04:45:

In Reply to: What's a .X file and How create? posted by Younger on September 10, 1998 at 13:23:03:

: What's a .X file and How create?

Follow Ups:

Post a Followup

Name:


Linking Error

Posted by X Newbie on September 12, 1998 at 23:25:10:

Hey, i'm new here ehh...

How do i take care of this error?

Linking...
blit.obj : error LNK2001: unresolved external symbol _DirectInputCreateA@16
blit.obj : error LNK2001: unresolved external symbol _GUID_SysMouse
Debug/blit.exe : fatal error LNK1120: 2 unresolved externals
Error executing link.exe.

Follow Ups:

  • Re: Linking Error Snowman 16:27:56 9/13/98 (1)
    • Re: Linking Error X Newbie 19:27:31 9/13/98 (0)

Post a Followup

Name:


new programming web page

Posted by Hexman on September 13, 1998 at 01:23:43:

I have recently created a new programming web page in an effort to
"pay back" for all that I've taken from the programming community. I
remember when I didn't know a thing about programming and people were
kind enough to help me on IRC or to write tutorials on various topics.
This web page contains tutorials or will contain very soon tutorials on
the following topics: DirectX, Assembly, Demo effects, 3D programming,
analog electronics, digital electronics. The url to the page is:
http://come.to/hexman

If you have time, please visit the page and check it out. If you
notice any errors such as typos or you think I haven't explained
something clearly, please let me know and I'll fix it asap. With your
help we can make this the best coding page on the net!

Thanks for your time,

hexman99@yahoo.com

  • Hexman's Place

Follow Ups:

Post a Followup

Name:


i need help

Posted by Jason Wilkens on September 13, 1998 at 02:38:02:

I have a Compaq 8760 and one day I was installing this game and it told me to install DirectX 5.0 so i did it and now some applications dont work. When i try to start them i get a blue screen that says "fatal exception error" and then the sound doesnt work. I tried getting DirectX 6.0 but it still didnt work please help me

Follow Ups:

  • Re: i need help Shannon 03:48:10 9/13/98 (0)

Post a Followup

Name:


Re: i need help

Posted by Shannon on September 13, 1998 at 03:48:10:

In Reply to: i need help posted by Jason Wilkens on September 13, 1998 at 02:38:02:

Make sure you have the latest drivers for your video and sound card. Sometimes upgrading DirectX wont do the job without using the latest drivers for your hardware.

Follow Ups:

Post a Followup

Name:


I can't get DirectX to work!

Posted by Neil on September 13, 1998 at 13:48:39:

I have a Hitachi PC laptop which came with its own display driver, called a Neomagic Magicgraph128 PCI. When I try to run applications using DirectX, It says that DirectX can not run because my display driver is not a Windows 95 compatible display driver. How can I fix this problem? I have already tried using a standard display driver; when I attempt to use any others, my computer boots up in safe mode. Please help!!!!

Follow Ups:

  • Re: I can't get DirectX to work! Clay 12:07:32 9/14/98 (0)

Post a Followup

Name:


Re: DirectX5

Posted by Ratchet on September 13, 1998 at 15:38:41:

In Reply to: Re: DirectX5 posted by head hunter on June 03, 1998 at 05:33:46:

:
: : : I downloaded a demo version of Curse of Monkey Island
: : : with DirectX5 download included and it worked fine.
: : : I then purchased the game, uninstalled the demo as per
: : : instructions but the purchased game freezes my whole
: : : system, screen, keyboard, mouse et al. Checking for
: : : compatability with DirectX5 indicates there is no hard-
: : : ware support for the Primary Display Driver, Primary
: : : sound Driver and Sound System Player. Why did the first
: : : DirectX5 download work but this one won't and what do I
: : : do about the problem?
: : : Thank you, any help would be greatly appreciated.
: : : Lois Nicholls

Follow Ups:

Post a Followup

Name:


Re: Linking Error

Posted by Snowman on September 13, 1998 at 16:27:56:

In Reply to: Linking Error posted by X Newbie on September 12, 1998 at 23:25:10:

Hi there-

Let's take a look:

: Linking...
: blit.obj : error LNK2001: unresolved external symbol _DirectInputCreateA@16

This means that the linker could not find the function DirectInputCreate. Chances are that you haven't included the Direct Input Library.

: blit.obj : error LNK2001: unresolved external symbol _GUID_SysMouse
: Debug/blit.exe : fatal error LNK1120: 2 unresolved externals
: Error executing link.exe.

Most likely the second error here will be cleared up by the previous answer. If not try insertering the Winmm library. If that doesn't work, try DxGUID.lib.

Hope this helps!

-Snowman

Follow Ups:

  • Re: Linking Error X Newbie 19:27:31 9/13/98 (0)

Post a Followup

Name:


Rotation

Posted by Snowman on September 13, 1998 at 17:57:22:

Does any one know how to rotate an array of D3DLVERTEX? I need to be able to rotate all of the verticies. Thanks for any help!

-Snowman

Follow Ups:

Post a Followup

Name:


direct draw

Posted by PegLeg on September 13, 1998 at 19:06:46:

My Program (direct draw) runs on my old computer (windows 95) but when I run it on my new one (windows 98) the screen goes black. What the Hell?!?!

Follow Ups:

  • Re: direct draw Fred Fol 06:07:56 9/14/98 (4)
    • Re: Update DX6 Pegleg 20:25:43 9/14/98 (3)
      • Re: Update DX6 Clay 09:00:41 9/16/98 (2)
        • Re: Thanks Clay Pegleg 20:25:11 9/19/98 (0)
        • Re: Update DX6 gfdgdfg 10:21:40 9/18/98 (0)
  • My program runs fine on my old PC but not my new one Pegleg 19:12:21 9/13/98 (0)

Post a Followup

Name:


My program runs fine on my old PC but not my new one

Posted by Pegleg on September 13, 1998 at 19:12:21:

In Reply to: direct draw posted by PegLeg on September 13, 1998 at 19:06:46:

: My Program (direct draw) runs on my old computer (windows 95) but when I run it on my new one (windows 98) the screen goes black. What the Hell?!?!

Follow Ups:

Post a Followup

Name:


Re: Linking Error

Posted by X Newbie on September 13, 1998 at 19:27:31:

In Reply to: Re: Linking Error posted by Snowman on September 13, 1998 at 16:27:56:

Many thanks, dxguid.lib cleared it right up.

You're my hero!!

: Hi there-

: Let's take a look:

: : Linking...
: : blit.obj : error LNK2001: unresolved external symbol _DirectInputCreateA@16

: This means that the linker could not find the function DirectInputCreate. Chances are that you haven't included the Direct Input Library.

: : blit.obj : error LNK2001: unresolved external symbol _GUID_SysMouse
: : Debug/blit.exe : fatal error LNK1120: 2 unresolved externals
: : Error executing link.exe.

: Most likely the second error here will be cleared up by the previous answer. If not try insertering the Winmm library. If that doesn't work, try DxGUID.lib.

: Hope this helps!

: -Snowman

Follow Ups:

Post a Followup

Name:


direct x fatal error

Posted by john on September 13, 1998 at 22:03:08:

what can i do?

Follow Ups:

Post a Followup

Name:


Re: Loading Bitmaps from the samples included with DX5SDK

Posted by Ravi Joshi on September 14, 1998 at 00:48:09:

In Reply to: Loading Bitmaps from the samples included with DX5SDK posted by Chris Clements on September 08, 1998 at 12:40:38:

I guess you are trying to create the bitmap in the 16 bit format.
One possible problem you may have is the incampatibility in the bits per pixel between the surfaces and the bitmaps.
Go to the desktop / settings and see the displaymode and color palette.
Typically the color palette is 256 colors.
When you create a bitmap in the resource editor, the color palette of the bmp should match that of surface.
Only then you can be able to call DDLoadBitmap on a surface.

Follow Ups:

Post a Followup

Name:


Re: direct draw

Posted by Fred Fol on September 14, 1998 at 06:07:56:

In Reply to: direct draw posted by PegLeg on September 13, 1998 at 19:06:46:

You can try update directx6 from microsoft, select te file dx6core.exe (and no other) for download. Update drivers of video and sound cards to last version.

Follow Ups:

  • Re: Update DX6 Pegleg 20:25:43 9/14/98 (3)
    • Re: Update DX6 Clay 09:00:41 9/16/98 (2)
      • Re: Thanks Clay Pegleg 20:25:11 9/19/98 (0)
      • Re: Update DX6 gfdgdfg 10:21:40 9/18/98 (0)

Post a Followup

Name:


Re: I can't get DirectX to work!

Posted by Clay on September 14, 1998 at 12:07:32:

In Reply to: I can't get DirectX to work! posted by Neil on September 13, 1998 at 13:48:39:

Try contacting Hitachi to see if they have a DirectX compatible driver for your particular laptop.

Clay

Follow Ups:

Post a Followup

Name:


Alpha Blending w/ DX5.0

Posted by Owen Davis on September 14, 1998 at 18:36:05:

Hello, does anyone know how to use the alpha blending options in dx5? I haven't been able to find crap about this accept for d3d and I'm doing a 2d game....thanks so much and if you have any source or articles etc. please email me! Thanks...

  • Fire Storm Entertainment

Follow Ups:

  • Re: Alpha Blending w/ DX5.0 Yang Huan 21:50:41 9/19/98 (3)
    • Re: Alpha Blending w/ DX5.0 Owen Davis 18:04:34 9/20/98 (0)
    • Re: Alpha Blending w/ DX5.0 Owen Davis 18:04:23 9/20/98 (0)
    • Re: Alpha Blending w/ DX5.0 Owen Davis 18:03:28 9/20/98 (0)

Post a Followup

Name:


Re: Update DX6

Posted by Pegleg on September 14, 1998 at 20:25:43:

In Reply to: Re: direct draw posted by Fred Fol on September 14, 1998 at 06:07:56:

That's not really the answer I was looking for, I was actually looking for more of an explanation (if it's not to much trouble), and then a solution.

Here's a more detailed discription of my problem:

I made two programs: a soon-to-be game and a game editor (nothing fancy, it's just a tool for me). The editor uses the same data and bitmap files as the game does and has near identical code (in the grphics dept.). On my old system (win95), both programs run great. On my new system (win98) the editor runs fine, but when I run the game, the screen goes black and I think I get an error message (It's hard to tell with a black screen, I hear some sort of beep though). After that it seems my only option is to reset.

The game does some things that the editor does not:
-It uses a back surface and page flipping
-It loads an extra wide bitmap (into system mem)
-It uses DirectInput
-The screen to go black when I run it

Is it Win98?
Is it my video card?
Is it me?

I can't use the debugger, it just does't seem to work well with DirectDraw.

Can you help me?

By the way, I'm using VC4 and DX5 sdk.

Follow Ups:

  • Re: Update DX6 Clay 09:00:41 9/16/98 (2)
    • Re: Thanks Clay Pegleg 20:25:11 9/19/98 (0)
    • Re: Update DX6 gfdgdfg 10:21:40 9/18/98 (0)

Post a Followup

Name:


Re: What's a .X file and How create?

Posted by zipht on September 14, 1998 at 23:08:26:

In Reply to: What's a .X file and How create? posted by Younger on September 10, 1998 at 13:23:03:

: What's a .X file and How create?

well, first think up something werd...
then do something with that idea to get the fbi to look u up....
next dont let then know the truth cause they dont beleve in your idea...
if your idea has something to do w/ ufo or killing cats and cowleyan rites this will help u to geting your own X file...
o' dont do this if u like your freedom...

zipht A. pHrrk

-head organizer for Cthulhu Campus Crusade New York

  • Den of tHe Dispossessed

Follow Ups:

Post a Followup

Name:


Setecting a Voodoo2 Driver in code

Posted by Karl Fisher on September 15, 1998 at 19:08:18:

I recently installed a Voodoo2 card, and it works great on the DX6 demos.
What I cannot figure out is how to set the Voodoo2 Driver in code, and how
to set it as the default driver.

It is listed as the Secondary HAL device in the demo menus, and I can select
it manually from the menu, but I would like to set it as the current driver
when the app initializes.

I have looked at the enumeration code, but I cannot see how I can identify
the Voodoo 2 driver.

I would appreciate any help you may provide.

Thanks very much

Karl
karl_fisher@msn.com
Hot Springs Village, Arkansas

Follow Ups:

Post a Followup

Name:


Re: Update DX6

Posted by Clay on September 16, 1998 at 09:00:41:

In Reply to: Re: Update DX6 posted by Pegleg on September 14, 1998 at 20:25:43:

What video card(s)/driver(s)are you using in both systems? Many don't support larger-than-primary surfaces. It's unfortuante that the debugger can't take over (everybody's probably had that problem) but you can fopen() file and print where you are in the code at every step of the way. Just remember to fflush() after every fprintf() because the stdio library buffers the data and if you crash before the buffers are flushed, you won't get to see the data. This technique has proven invaluable (to me anyway).

Clay

Follow Ups:

  • Re: Thanks Clay Pegleg 20:25:11 9/19/98 (0)
  • Re: Update DX6 gfdgdfg 10:21:40 9/18/98 (0)

Post a Followup

Name:


Question on DirectSound !!!

Posted by JImmy on September 17, 1998 at 10:45:43:

Does DirectSound support MIDI file?
I read this book, and it says MIDI playback is not
supported in DirectSound. If so, is there any way to
mix MIDI file and some WAVE files to play?
I am trying to play MIDI file for the background music
and play various WAVE sounds occasionally in the middle.
Any suggestions?
Thanks in advance.... =)

Follow Ups:

Post a Followup

Name:


Re: DirectX5

Posted by eduard on September 17, 1998 at 16:59:13:

In Reply to: DirectX5 posted by Lois Nicholls on February 17, 1998 at 16:15:39:

: I downloaded a demo version of Curse of Monkey Island
: with DirectX5 download included and it worked fine.
: I then purchased the game, uninstalled the demo as per
: instructions but the purchased game freezes my whole
: system, screen, keyboard, mouse et al. Checking for
: compatability with DirectX5 indicates there is no hard-
: ware support for the Primary Display Driver, Primary
: sound Driver and Sound System Player. Why did the first
: DirectX5 download work but this one won't and what do I
: do about the problem?
: Thank you, any help would be greatly appreciated.
: Lois Nicholls

Follow Ups:

Post a Followup

Name:


Problem Linking Digital FX Demo.

Posted by Mark on September 17, 1998 at 17:19:32:

I found this really cool Blit library called Digital FX and when I try to compile the demo I get a single error.

Linking...
Demo.obj : error LNK2001: unresolved external symbol _IID_IDirectDraw2

In the past I got this error when I forgot to link in the ddraw.lib and ddraw.h but eveerything seems to be in place.

Has anyone see an error like this before ?

Thanks for the help.

Mark...

Follow Ups:

Post a Followup

Name:


windowed and mfc

Posted by Marco Trive on September 17, 1998 at 18:52:07:

Is it possible to use MFC and DirectX using the same window?

Follow Ups:

  • Re: windowed and mfc Clay 22:15:32 9/23/98 (0)

Post a Followup

Name:


Where is all the direct play info?

Posted by Jeff on September 18, 1998 at 00:59:11:

I've been looking backwards and forwards for more info on programming with Direct Play but have found next to none.

Follow Ups:

Post a Followup

Name:


DirectX Media (Direct Show) and Borland C++ Builder 3.0

Posted by Mihail Mouhlov on September 18, 1998 at 07:11:04:

I want to use DirectX Media 5.2b (especialy Direct Show) with C++ Bulder 3.0. I'm using succesfuly DirectX 6. But unfortunatlly there is no Borland Libraries for DirectX Media (I download it from Microsoft siste). I read a lot of using ImpLib and so on. I recompile library strmbase.lib, but I can't find any way to produce more than a half of other lib files. I kindly ask somebody who has Borland library files to send it to me.

Regards to everybody
Mike

Follow Ups:

Post a Followup

Name:


DirectX Media (Direct Show) and Borland C++ Builder 3.0

Posted by Mihail Mouhlov on September 18, 1998 at 07:12:49:

I want to use DirectX Media 5.2b (especially Direct Show) with C++ Bulder 3.0. I'm using successfully DirectX 6. But unfortunately there is no Borland Libraries for DirectX Media (I download it from Microsoft site). I read a lot of using ImpLib and so on. I recompile library strmbase.lib, but I can't find any way to produce more than a half of other lib files. I kindly ask somebody who has Borland library files to send it to me.

Regards to everybody
Mike

Follow Ups:

Post a Followup

Name:


Re: Where Can I download DirectX 5.0

Posted by dean eccles on September 18, 1998 at 08:35:01:

In Reply to: Re: Where Can I download DirectX 5.0 posted by pace on March 22, 1998 at 22:37:47:

:
: : Where Can I download DirectX 5.0. I need it for an emulator.

Follow Ups:

Post a Followup

Name:


Re: Update DX6

Posted by gfdgdfg on September 18, 1998 at 10:21:40:

In Reply to: Re: Update DX6 posted by Clay on September 16, 1998 at 09:00:41:

: What video card(s)/driver(s)are you using in both systems? Many don't support larger-than-primary surfaces. It's unfortuante that the debugger can't take over (everybody's probably had that problem) but you can fopen() file and print where you are in the code at every step of the way. Just remember to fflush() after every fprintf() because the stdio library buffers the data and if you crash before the buffers are flushed, you won't get to see the data. This technique has proven invaluable (to me anyway).

: Clay

Follow Ups:

Post a Followup

Name:


Learning DirectX programming in C

Posted by Andrew Ritchie on September 18, 1998 at 21:24:06:

Hi all,

I was after information regarding how to use the DirectX
API in C programming. As I don't know anything about DirectX as yet, basic information would be most helpful (ie, information on DirectDraw etc.). Thanks for your time,

Andrew Ritchie.

Follow Ups:

  • Re: Learning DirectX programming in C David Wright 00:58:00 9/30/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 Download

Posted by mike poliszuk on September 18, 1998 at 23:26:25:

In Reply to: Re: DirectX 5.0 Download posted by Lucas on March 16, 1998 at 08:41:21:

: : : : : can anyone tell me where to download it besides microsoft website?

Follow Ups:

Post a Followup

Name:


Re: dxsetup not registering diamond viper 330 video card

Posted by joe manning on September 19, 1998 at 17:52:28:

In Reply to: dxsetup not registering diamond viper 330 video card posted by Bob Shultz on March 13, 1998 at 15:40:52:

: I am not able to run some games due to an error message stating that directx is not registering my video card and my monster sound card. Diamond states that it is a problem with directx. Can anybody help?

What game(s) are you having trouble with. I have had a problem with triple play 99 from easports. I have a v330 and a monster 3d2. I have been in contact with diamond and easports with no luck yet. I'll get back if i get any useful info. please infom me if you get any results.
thanks

Follow Ups:

Post a Followup

Name:


Re: Thanks Clay

Posted by Pegleg on September 19, 1998 at 20:25:11:

In Reply to: Re: Update DX6 posted by Clay on September 16, 1998 at 09:00:41:

Clay:

Prior to reading you message I found that my problem had nothing to do with direct draw. I found that I was using a pointer to a structure before assigning it to anything. I don't know why this didn't cause the same problem on my other machine, so I took an ax to it for not notifying me of this error.

Anyway, thanks for the "fopen() advice", its sure to prove useful.

:Pegleg

Follow Ups:

Post a Followup

Name:


Shouldn't 300Mhz make things a little faster?

Posted by Pegleg on September 19, 1998 at 20:39:42:

For all those who have read my original cry for help have probably guessed that I receantly got a new computer, if not, you know now, if not, your stupid.

Anyway, I'm making a very simple Arcade-Style "airplane" game (like Raptor, Galiga, etc.). The plane move one pixel at a time, and then I pull a page-flip. Why does it seem to run on my PII300 at the same speed it did on my P75 (some-what slow). Can I change this? How?

By the way, I've thought about moving more pixels at a time but thing begin to look choppy.

Follow Ups:

  • It's Page-Flipping, but why so slow? Pegleg 22:30:10 9/22/98 (6)
    • Re: It's Page-Flipping, but why so slow? Clay 22:18:41 9/23/98 (5)
      • Re: Use while....WASSTILLDRAWING Pegleg 17:40:49 9/26/98 (4)
        • Re: Use while....WASSTILLDRAWING Clay 22:19:29 9/27/98 (3)
          • Re: Use while....WASSTILLDRAWING Pegleg 20:42:08 9/28/98 (2)
            • Re: Use while....WASSTILLDRAWING Clay 15:29:15 9/29/98 (1)
              • Re: Use while....WASSTILLDRAWING Pegleg 01:08:08 9/30/98 (0)

Post a Followup

Name:


Re: Alpha Blending w/ DX5.0

Posted by Yang Huan on September 19, 1998 at 21:50:41:

In Reply to: Alpha Blending w/ DX5.0 posted by Owen Davis on September 14, 1998 at 18:36:05:

Oh no,Dx5 not support Alpha Blending by HEL?
Sorry.

Follow Ups:

  • Re: Alpha Blending w/ DX5.0 Owen Davis 18:04:34 9/20/98 (0)
  • Re: Alpha Blending w/ DX5.0 Owen Davis 18:04:23 9/20/98 (0)
  • Re: Alpha Blending w/ DX5.0 Owen Davis 18:03:28 9/20/98 (0)

Post a Followup

Name:


BACKBUFFER problem

Posted by Michel Lequim on September 20, 1998 at 14:31:50:

Hi,
When I do program in 640X480 X 16 BPP mode, and I try to load picture BMP in the BACKBUFFER it only work if picture has a size of 640 pixels. The program also hangs when the height of the picture is to big.

I also would like to know if there is a maximum size for the BACKBUFFER?

Thank for your help

Follow Ups:

  • Re: BACKBUFFER problem Clay 07:39:39 9/21/98 (1)
    • Re: BACKBUFFER problem Michel Lequim 16:45:38 9/23/98 (0)

Post a Followup

Name:


Re: Alpha Blending w/ DX5.0

Posted by Owen Davis on September 20, 1998 at 18:03:28:

In Reply to: Re: Alpha Blending w/ DX5.0 posted by Yang Huan on September 19, 1998 at 21:50:41:

Ok, is it supported by dx6? I don't have it yet and I'm not sure if I feel like ordering a copy if it doesn't support the few "extra" things I need? Thanks for your response btw in case your reading this!
:
: Oh no,Dx5 not support Alpha Blending by HEL?
: Sorry.

  • Fire Storm Entertainment

Follow Ups:

Post a Followup

Name:


Re: Alpha Blending w/ DX5.0

Posted by Owen Davis on September 20, 1998 at 18:04:23:

In Reply to: Re: Alpha Blending w/ DX5.0 posted by Yang Huan on September 19, 1998 at 21:50:41:

Ok, is it supported by dx6? I don't have it yet and I'm not sure if I feel like ordering a copy if it doesn't support the few "extra" things I need? Thanks for your response btw in case your reading this!
:
: Oh no,Dx5 not support Alpha Blending by HEL?
: Sorry.

  • Fire Storm Entertainment

Follow Ups:

Post a Followup

Name:


Re: Alpha Blending w/ DX5.0

Posted by Owen Davis on September 20, 1998 at 18:04:34:

In Reply to: Re: Alpha Blending w/ DX5.0 posted by Yang Huan on September 19, 1998 at 21:50:41:

Ok, is it supported by dx6? I don't have it yet and I'm not sure if I feel like ordering a copy if it doesn't support the few "extra" things I need? Thanks for your response btw in case your reading this!
:
: Oh no,Dx5 not support Alpha Blending by HEL?
: Sorry.

  • Fire Storm Entertainment

Follow Ups:

Post a Followup

Name:


Re: BACKBUFFER problem

Posted by Clay on September 21, 1998 at 07:39:39:

In Reply to: BACKBUFFER problem posted by Michel Lequim on September 20, 1998 at 14:31:50:

Check the caps on your video card. Many do not support larger than primary surfaces. This might possibly explain your hang.

Clay

Follow Ups:

  • Re: BACKBUFFER problem Michel Lequim 16:45:38 9/23/98 (0)

Post a Followup

Name:


Locking when Cooperative level is NORMAL!?

Posted by Bardya on September 21, 1998 at 10:23:02:

I have set my cooperative level (in direct draw) to Normal and I am trying to lock to the primary surface! This causes to crash my computer! Is there a way to lock to the surface?

Follow Ups:

Post a Followup

Name:


Debugging with DIRECT DRAW! 2 Monitors

Posted by Bardya on September 21, 1998 at 10:26:47:

Can I use two monitors to debug my direct draw codes?
(So that I see the codes on one monitor and the program on the other) I am using FULLSCREEN and EXCLUSIVE mode. Thx (I use W98)

Follow Ups:

  • Re: Debugging with DIRECT DRAW! 2 Monitors Myopic Rhino 18:02:32 9/21/98 (0)

Post a Followup

Name:


Re: Debugging with DIRECT DRAW! 2 Monitors

Posted by Myopic Rhino on September 21, 1998 at 18:02:32:

In Reply to: Debugging with DIRECT DRAW! 2 Monitors posted by Bardya on September 21, 1998 at 10:26:47:

Andr� LaMothe explains how to do this in detail on his web page.

Here's the direct link: http://www.xgames3d.com/articles/xdebug/areadxdb.htm

  • Myopic Rhino's Game Programming Savanna

Follow Ups:

Post a Followup

Name:


Re: What's a .X file and How create?

Posted by Lennard Feddersen on September 21, 1998 at 19:31:20:

In Reply to: Re: What's a .X file and How create? posted by Younger on September 10, 1998 at 13:27:59:

Take a look at conv3ds which should take a .3ds file and create a .X file for you.

Follow Ups:

Post a Followup

Name:


OffscreenPlain backbuffer for 3DDevice fails with 8-bit color

Posted by Luke on September 22, 1998 at 13:51:13:

Hi,

I have a problem trying to support windowed 256 color mode.

Everything works fine with 16-bit color (both hardware and software drivers).

When I move to 8-bit color, I cannot create a 3D backbuffer with
3DDevice, OffscreenPlain and VideoMemory options.

I get InvalidPixelFormat, no matter what pixel formats I try.
It seems a red herring, since dropping the 3DDevice requirement removes
the problem. Of course.

It appears impossible to run a fully hardware-accelerated Direct3D app
in windowed-mode under 8 bit color.

Any advice (or similar experiences) is very welcome.

Thanks, in advance.

Follow Ups:

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by michael d. henning on September 22, 1998 at 22:11:16:

In Reply to: DirectX6 FINAL RELEASE! posted by A DX6 beta tester on July 31, 1998 at 00:30:54:

: The FINAL version of DirectX6/SDK will be released with in 24 hours!

: Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

Post a Followup

Name:


It's Page-Flipping, but why so slow?

Posted by Pegleg on September 22, 1998 at 22:30:10:

In Reply to: Shouldn't 300Mhz make things a little faster? posted by Pegleg on September 19, 1998 at 20:39:42:

I've done a series of small experiments to find out what the hold up is. It's the Page-Flipping, is there away to speed it up. What's going on?

When I use the DDFLIP_WAIT option, the program works...slow. When I don't (argument 0), there are unpredictable results: No visuals; No (noticable) movement; ?!?!?!?; etc. When I take out the Flipping, everything runs great (except for sprite flicker). I'm thinking of using no flipping, and just using a simple Double Buffer.

Follow Ups:

  • Re: It's Page-Flipping, but why so slow? Clay 22:18:41 9/23/98 (5)
    • Re: Use while....WASSTILLDRAWING Pegleg 17:40:49 9/26/98 (4)
      • Re: Use while....WASSTILLDRAWING Clay 22:19:29 9/27/98 (3)
        • Re: Use while....WASSTILLDRAWING Pegleg 20:42:08 9/28/98 (2)
          • Re: Use while....WASSTILLDRAWING Clay 15:29:15 9/29/98 (1)
            • Re: Use while....WASSTILLDRAWING Pegleg 01:08:08 9/30/98 (0)

Post a Followup

Name:


Need some answers!!!

Posted by JBarrett on September 23, 1998 at 10:05:41:

Will someone please respond to "windowed and mfc" and
"question on directsound!!!" from 9/17/98! I'd really
like to know the answers.
Thanks.

Follow Ups:

Post a Followup

Name:


Q: RIVA TNT

Posted by Pablo de Heras on September 23, 1998 at 16:26:41:

Hi,

I'm buying a TNT card and I haven't found any info on if the TNT can do windowed hardware accelleration for DX. Does it do that or not?

Thanks in advance

Pablo de Heras

Follow Ups:

  • Re: Q: RIVA TNT Clay 18:53:56 9/23/98 (0)

Post a Followup

Name:


Re: BACKBUFFER problem

Posted by Michel Lequim on September 23, 1998 at 16:45:38:

In Reply to: Re: BACKBUFFER problem posted by Clay on September 21, 1998 at 07:39:39:

Thank you for your help Clay,
Michel

Follow Ups:

Post a Followup

Name:


Re: Q: RIVA TNT

Posted by Clay on September 23, 1998 at 18:53:56:

In Reply to: Q: RIVA TNT posted by Pablo de Heras on September 23, 1998 at 16:26:41:

Since it is a 2D/3D combo card, I expect that it does do windowed.

Clay

Follow Ups:

Post a Followup

Name:


DirectSound & ACM

Posted by Ben Lazo on September 23, 1998 at 20:59:42:

Okay...in the DirectX documentation it is
hinted that there is a way to use the output
from the Audio Compression Manager to
decode a compressed WAV straight into
a DirectSound buffer...but doesn't say
how. Being that I can't seem to locate
any information on using the ACM, could
someone assist me in learning how to do this?
Any help would be greatly appreciated! :)

Deathy
aka
Ben Lazo
deathlok@uslink.net

Follow Ups:

Post a Followup

Name:


Re: windowed and mfc

Posted by Clay on September 23, 1998 at 22:15:32:

In Reply to: windowed and mfc posted by Marco Trive on September 17, 1998 at 18:52:07:

Yes. What you need to do is handle all the client area (view) painting yourself. You can double buffer with an off-screen surface, but you have to keep track of where and how big your client area is.

Clay

Follow Ups:

Post a Followup

Name:


Re: It's Page-Flipping, but why so slow?

Posted by Clay on September 23, 1998 at 22:18:41:

In Reply to: It's Page-Flipping, but why so slow? posted by Pegleg on September 22, 1998 at 22:30:10:

Hmmm. Page flipping should be extremely fast. We had some discussion here some time ago about it and I think that the general consensus was that Flip() is about instantaneous. What video card are you using? You might try this:

while(pSurf->Flip() == DDERR_WASSTILLDRAWING)
{
// do nothing, just "spin"
}

Clay

Follow Ups:

  • Re: Use while....WASSTILLDRAWING Pegleg 17:40:49 9/26/98 (4)
    • Re: Use while....WASSTILLDRAWING Clay 22:19:29 9/27/98 (3)
      • Re: Use while....WASSTILLDRAWING Pegleg 20:42:08 9/28/98 (2)
        • Re: Use while....WASSTILLDRAWING Clay 15:29:15 9/29/98 (1)
          • Re: Use while....WASSTILLDRAWING Pegleg 01:08:08 9/30/98 (0)

Post a Followup

Name:


Direct3D IM Framework Tutorials

Posted by Wolfgang Engel on September 24, 1998 at 02:46:41:

Has anyone tested the Direct3D IM Framework Tutorials at http://www.netit.net/direct3d/ ?

I'd like to make a lot of improvements on them. There will be tutorials on

transformation
lightning
texture mapping (there will be a few)

Any comments would be appreciated.

Ohhh don't forget to subscribe for the new e-mail newsletter on Direct3D programming. Ahh yeaahh there's also a
online discussion forum on Direct3D programming.

  • Netit Direct3D

Follow Ups:

Post a Followup

Name:


Direct3D RM Alpha blending

Posted by David Adams on September 24, 1998 at 12:32:03:

I started playing around w/3D for the first time yesterday, and decided to use RM. I had problems getting alpha blending to work in RM and read a couple of solutions on this forum... I have found a pretty easy one and thought I would share it...

All you have to do is ->SetColor(R,G,B,A) on the mesh that you want to alpha.. (of course there are some device flags you have to set properly so that it will be true alpha and not just skip every other pixel alpha)

This works great for solid colors AND texture mapped meshes (if you ->SetColor(1.0f, 1.0f, 1.0f, A) you will alpha the model WITH texture map and not change the color of the texture map on the mesh.)

Just thought I would let any interested parties know.

David Adams

Follow Ups:

  • Anyone knows how to do 2D transparency with DD?? Crusader X 09:53:48 9/29/98 (0)

Post a Followup

Name:


Need info on compatible sound cards

Posted by Steve on September 24, 1998 at 12:36:45:

I need to find a list of compatible sound cards or someone who can tell me about mine. I have OPTi 82c931 sound card and I can't run Monkey Island (with Directx5). The troubleshooter/installer does not "certify" 2 items-they are blank: 1)Primary Sound Dr. 4.0 2)OPTi Direct Soun. 4.0; I can't find any updated drivers and the companies involved are giving me serious run-around. Please tell me how to solve this or if I need a different/compatible sound card.

Follow Ups:

Post a Followup

Name:


Ever used Dialogs in exclusive-mode?

Posted by Danny Oneway on September 24, 1998 at 15:32:57:

Hy there,

I'm worried about sum' uncool effects :

- create a fullscreen primary-surface, exclusive-mode
(no backbuffers, something stupid simple)
- create a moveable window (child or not - no difference)

now the problem : the hdc recievied by BeginPaint in the
WM_PAINT-message causes a "no valid DirectDraw hdc", no
operations will be performed. If you instead take an
hdc get by primary->GetDC, and perform the operation
with this DC, the window (even own class aso!) will
be overdrawn by any operation done with this hdc
(DirectDraw-specific like primary->blit AND! GDI-
operations like LineTo!)

Is there anybody who already had that problem?

All tries to correct this failed... perhaps anybody
has an idea ...

c ya!
Danny

Follow Ups:

  • Re: Ever used Dialogs in exclusive-mode? Clay 21:51:20 9/24/98 (0)
  • Re: Ever used Dialogs in exclusive-mode? Clay 21:49:58 9/24/98 (0)

Post a Followup

Name:


Locking and blting

Posted by Septim on September 24, 1998 at 17:01:06:

I got a little Directdraw performance problem here:)..

As far as I know DirectDraw::Blt works by locking a surface
plotting and then unlocking it every time the Blt function
is called. This constant locking/unlocking slows down my
program ALOT. I've made a little test program that does
over 100 blts every frame and its painfuly slow. Is there
any way to force blt to lock and unlock surfaces only once
per program loop?

Follow Ups:

  • Re: Locking and blting Danny Oneway 19:03:32 9/24/98 (4)
    • Re: Locking and blting Septim 19:54:57 9/24/98 (3)
      • Re: Locking and blting Clay 22:10:08 9/24/98 (2)
        • Re: Locking and blting Danny Oneway 07:07:23 9/28/98 (1)
          • Re: Locking and blting+ asm32 Spikes 08:29:11 9/28/98 (0)

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by rtr on September 24, 1998 at 17:36:31:

In Reply to: Re: DirectX6 FINAL RELEASE! posted by mikael on August 09, 1998 at 11:12:52:

: : The FINAL version of DirectX6/SDK will be released with in 24 hours!

: : Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

Post a Followup

Name:


DirectX6 FINAL RELEASE!

Posted by ttt on September 24, 1998 at 17:38:47:

In Reply to: DirectX6 FINAL RELEASE! posted by A DX6 beta tester on July 31, 1998 at 00:30:54:

: The FINAL version of DirectX6/SDK will be released with in 24 hours!

: Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

Post a Followup

Name:


Re: Locking and blting

Posted by Danny Oneway on September 24, 1998 at 19:03:32:

In Reply to: Locking and blting posted by Septim on September 24, 1998 at 17:01:06:

: I got a little Directdraw performance problem here:)..

: As far as I know DirectDraw::Blt works by locking a surface
: plotting and then unlocking it every time the Blt function
: is called. This constant locking/unlocking slows down my
: program ALOT. I've made a little test program that does
: over 100 blts every frame and its painfuly slow. Is there
: any way to force blt to lock and unlock surfaces only once
: per program loop?

Hmmm.Due to "Inside DirectX" by Bradley Bargan you
cant. But in which way do you use the Blit? Are there
any other operations proceeded than a simple copy?
(No stretching, no color-keying aso)

If you have a simple Blit on a known surface (means
fullscreen+exclusiv, you set the mode and know the
pixelformat of the mode) you can write an own copy-
routine. So you lock the surface, perform all copies
and afterward you unlock.

Internally, even DirectDraw has to follow (it's own)
rules, so you can only change the surface when you
have a valid pointer to the screen-address aso. And
the only way to get that is to lock the surface.

If you use windowed mode, or the pixelformat can
be anything but cool, you would have to write some
optimized routines for standard-modes (8bpp,15bpp,24bpp,32bpp)
and a routine for non-standard modes.

c ya,
Danny Oneway

Follow Ups:

  • Re: Locking and blting Septim 19:54:57 9/24/98 (3)
    • Re: Locking and blting Clay 22:10:08 9/24/98 (2)
      • Re: Locking and blting Danny Oneway 07:07:23 9/28/98 (1)
        • Re: Locking and blting+ asm32 Spikes 08:29:11 9/28/98 (0)

Post a Followup

Name:


Re: Locking and blting

Posted by Septim on September 24, 1998 at 19:54:57:

In Reply to: Re: Locking and blting posted by Danny Oneway on September 24, 1998 at 19:03:32:

: Hmmm.Due to "Inside DirectX" by Bradley Bargan you
: cant. But in which way do you use the Blit? Are there
: any other operations proceeded than a simple copy?
: (No stretching, no color-keying aso)

: If you have a simple Blit on a known surface (means
: fullscreen+exclusiv, you set the mode and know the
: pixelformat of the mode) you can write an own copy-
: routine. So you lock the surface, perform all copies
: and afterward you unlock.

: Internally, even DirectDraw has to follow (it's own)
: rules, so you can only change the surface when you
: have a valid pointer to the screen-address aso. And
: the only way to get that is to lock the surface.

: If you use windowed mode, or the pixelformat can
: be anything but cool, you would have to write some
: optimized routines for standard-modes (8bpp,15bpp,24bpp,32bpp)
: and a routine for non-standard modes.

:
: c ya,
: Danny Oneway

Hmm thanks, so basicly what you're telling me is that if
I want fast performance I have to write my own blitting
routines right? If I do that the only useful part of
DirectDraw will be the initilization part:)

Ah well. Do you maybe know where I can get some
premade directdraw routines? Like fastblt with
and without transperancies. And maybe even alpha-blending
blt:) I really dont want to make those myself:)

Follow Ups:

  • Re: Locking and blting Clay 22:10:08 9/24/98 (2)
    • Re: Locking and blting Danny Oneway 07:07:23 9/28/98 (1)
      • Re: Locking and blting+ asm32 Spikes 08:29:11 9/28/98 (0)

Post a Followup

Name:


Re: Ever used Dialogs in exclusive-mode?

Posted by Clay on September 24, 1998 at 21:49:58:

In Reply to: Ever used Dialogs in exclusive-mode? posted by Danny Oneway on September 24, 1998 at 15:32:57:

I'm not sure I fully understand the problem. It sounds like you're mixing GDI and DirectDraw in exclusive mode. Most of the time, this is a no-no. Even though the GDI operates faster on an DD surface, real DD is much faster. Granted, you don't get the nicities of GDI, but that's not what DD is for. You can still do this, though. Also, I'm not sure that it will work on add-on accelerators (like Voodoo2). Anyhow, please repost and let us know more details about the problem.

Clay

Follow Ups:

Post a Followup

Name:


Re: Ever used Dialogs in exclusive-mode?

Posted by Clay on September 24, 1998 at 21:51:20:

In Reply to: Ever used Dialogs in exclusive-mode? posted by Danny Oneway on September 24, 1998 at 15:32:57:

I'm not sure I fully understand the problem. It sounds like you're mixing GDI and DirectDraw in exclusive mode. Most of the time, this is a no-no. Even though the GDI operates faster on an DD surface, real DD is much faster. Granted, you don't get the nicities of GDI, but that's not what DD is for. You can still do this, though. Also, I'm not sure that it will work on add-on accelerators (like Voodoo2). Anyhow, please repost and let us know more details about the problem.

Clay

Follow Ups:

Post a Followup

Name:


Re: Locking and blting

Posted by Clay on September 24, 1998 at 22:10:08:

In Reply to: Re: Locking and blting posted by Septim on September 24, 1998 at 19:54:57:

You're right about DD taking lots of time to do multiple blits. (what ever happened to BltBatch()??) The solution is to separate out the stuff that can be done in hardware (like alpha and color keying) and do only 2 or 3 DD blits per frame. You probably will want to make your own custom blitting routines for alpha, etc. in case you need them. The idea here is that you shouldn't rely on DD to do a lot for you. Remember, DD was originally created to allow programmers direct access to vid. memory in Windows! Try doing everything that won't be hardware accelerated yourself; arrange your scenes outside of DD then blit once. If needs be, do one "regular" blit then one color-keyed blit, then one alpha blit. I guess what I'm trying to say (apparently very poorly -- sorry about the "preachiness"!) is this: know the limitations of DD and work around them.

Clay

: : Hmmm.Due to "Inside DirectX" by Bradley Bargan you
: : cant. But in which way do you use the Blit? Are there
: : any other operations proceeded than a simple copy?
: : (No stretching, no color-keying aso)

: : If you have a simple Blit on a known surface (means
: : fullscreen+exclusiv, you set the mode and know the
: : pixelformat of the mode) you can write an own copy-
: : routine. So you lock the surface, perform all copies
: : and afterward you unlock.

: : Internally, even DirectDraw has to follow (it's own)
: : rules, so you can only change the surface when you
: : have a valid pointer to the screen-address aso. And
: : the only way to get that is to lock the surface.

: : If you use windowed mode, or the pixelformat can
: : be anything but cool, you would have to write some
: : optimized routines for standard-modes (8bpp,15bpp,24bpp,32bpp)
: : and a routine for non-standard modes.

: :
: : c ya,
: : Danny Oneway

: Hmm thanks, so basicly what you're telling me is that if
: I want fast performance I have to write my own blitting
: routines right? If I do that the only useful part of
: DirectDraw will be the initilization part:)

: Ah well. Do you maybe know where I can get some
: premade directdraw routines? Like fastblt with
: and without transperancies. And maybe even alpha-blending
: blt:) I really dont want to make those myself:)

Follow Ups:

  • Re: Locking and blting Danny Oneway 07:07:23 9/28/98 (1)
    • Re: Locking and blting+ asm32 Spikes 08:29:11 9/28/98 (0)

Post a Followup

Name:


"Ever used dialogs in exclusive-mode" it continues

Posted by Danny Oneway on September 25, 1998 at 04:58:11:

Hy there,

you wanted to know more details : here they come.

I have to code an editor for editing bigger graphics
by arranging small graphic-pieces. The resolution must
be changeable during runtime without restarting the
editor (mode selection and -switching happens in my
code, not externally in the display-settings). The
ccoperative-level is exclusive/fullscreen/allowreboot.

I have to display two things on the primary-surface :
the "map" of arranged graphics (solved by using an offscreen-surface)
and a selector in which you can choose the small graphic
block which you want to place in the map (is a bar with
n small blocks out of m, through which you can scroll,
the bar with the n blocks is also an offscreen-surface).

I create that those two things in the offscreen-surfaces and
blit them onto the primary surface (no backbuffers, blit-
operator is the DDBLT_ROP/SRCCOPY). That works fine so far.
But I also have to display various moveable toolbars
(like in Photoshop) to select different functions.

The first problem is : if I recieve a WM_PAINT-message
in my WinMainFunc (toolbars have own message-functions,
are non-modal), I cannot use the HDC returned to me
by using the hdc=BeginPaint(..)-function, because my
return-value-checker informs me about an invalid device-
context which cannot be used for operations on that
surface. The same effect have HDCs from OWNERDRAW-structs.

So I have to request an valid by calling primary->GetDC (..).
Due to the fact that I get DD_OK as return-value, the HDC from
the paintstruct can't be valid, because if he would be,
the returnvalue must be DDERR_DCALREADYCREATED. But it
is DD_OK. Don't know to what the HDC refers to, but not to
my primary surface.

The rectangle I shall update I can get from the paintstruct
filled by BeginPaint (ps.rcPaint). So there should be
no problem at all. But the effect I earn is, that if
I use this DD-HDC, all operations performed will overwrite
the dialog-box-gfx if they intersect. And that happens
with DD-operations like ->Blt and also "normal" GDI-
operations like LineTo.

That means : if I have a DD-fullscreen/exclusive surface,
create a dialog and e.g. ->Blt onto the whole primary surface
the dialog won't be visible any longer. But you still
can click it's elements, move it aso.

Workarounds I already tried :

- send a WM_PAINT-message to the child windows (dialogs)
after refreshing/updating the primary surface, works
but sux because it looks worse and is a lame workaround
- I opened an invisible popup-window exactly on that
position I want to display the map, created a DD-Clipper-Obj
and used it on that window, thinking that if the map also
has an own (child)-window the GDI might clip. But that also
fails.

I don't know why the GDI seems not to clip operations
perfomed on the primary surface if there are other
windows (from my process/thread) over the surface (even if they
have WS_EX_TOPMOST as stlye).

I'm not sure by 100% that I make no mistakes, but the
possibility is very small, because I test every return
value and dump it into a textfile. There are no errors,
and I test all possible errors defined in ddraw.h.

So, who has an idea or has experience with such things?

read ya l8ter,
Danny O.

Follow Ups:

Post a Followup

Name:


DDraw/Dialog-Problem particular solved

Posted by Danny Oneway on September 25, 1998 at 09:00:11:

Hy there,

the problem is particular solved. The problem was a misinterpretation
of what was written in "Inside DirectX". I thought, that if you want
to prevent a (child)-window from beiing overpainted you have to
create a clipper and attach him to the (child)-window. That's wrong!

You only have to create a Clipper and attach him to the primary buffer!
(That means one clipper if no n-buffering is used). After that change
the dialogs are save from being overpainted.

I think I also might explain the other effect : (GDI-operation overpaints
dialog)

- due to the fact that the paintstruct-hdc is invalid and I have to
use the ->GetDC hdc, there are no clipping-regions defined, and certainly
he overpaints everything!

If the second part (which I now only suppose) is right, I will write another
message and post it here...

c ya!
Danny O.

Follow Ups:

Post a Followup

Name:


Re: directX5.0 please

Posted by Bill on September 25, 1998 at 09:23:33:

In Reply to: Re: directX5.0 please posted by Rick on June 05, 1998 at 21:02:14:

: Need it so I can play my games.

Follow Ups:

Post a Followup

Name:


Re: Directx 6

Posted by Shamsul A. Khan. on September 25, 1998 at 21:48:13:

In Reply to: Directx 6 posted by Weising on July 20, 1998 at 22:17:27:

: Is directx 6 out yet? Can I download them?
: Email me for the Address, Thnaks a lot

Follow Ups:

Post a Followup

Name:


Announcement: New DirectX Library

Posted by Matt Fausey on September 26, 1998 at 01:44:33:

Chilkat Software is a startup company
developing DirectX-based C++ libraries for
game developers. The Chilkat Library provides
DirectX-based visual components used for constructing
a game's control panels and user-interfaces.
The Beta version will be available October 1.

Visit http://www.chilkatsoft.com for more information.

Follow Ups:

Post a Followup

Name:


Re: Use while....WASSTILLDRAWING

Posted by Pegleg on September 26, 1998 at 17:40:49:

In Reply to: Re: It's Page-Flipping, but why so slow? posted by Clay on September 23, 1998 at 22:18:41:

I'm using a Matrox Something-or-Other (Not Mystique or Millenium)

In response to using

while (pSurf->Flip()==DDERR_WASSTILLDRAWING)

Shouldn't DDFLIP_WAIT have the same effect?
(By the way, I haven't tried it yet)

Anyway I'm now using the ol' "Double Buffer" technique and it runs a hell of a lot faster.

Follow Ups:

  • Re: Use while....WASSTILLDRAWING Clay 22:19:29 9/27/98 (3)
    • Re: Use while....WASSTILLDRAWING Pegleg 20:42:08 9/28/98 (2)
      • Re: Use while....WASSTILLDRAWING Clay 15:29:15 9/29/98 (1)
        • Re: Use while....WASSTILLDRAWING Pegleg 01:08:08 9/30/98 (0)

Post a Followup

Name:


link errors

Posted by Fragmo on September 26, 1998 at 19:24:00:

can anyone tell me what library contains these functions
i'm compiling the dpchat sample with vc++ 5.0, and the
direct x inc and lib paths are set correctly, but it
keeps giving me these errors

Linking...
dpchat.obj : error LNK2001: unresolved external symbol __imp__DialogBoxParamA@20
dialog.obj : error LNK2001: unresolved external symbol __imp__DialogBoxParamA@20
dpchat.obj : error LNK2001: unresolved external symbol __imp__EndDialog@8
dialog.obj : error LNK2001: unresolved external symbol __imp__EndDialog@8
dpchat.obj : error LNK2001: unresolved external symbol __imp__SendDlgItemMessageA@20
dialog.obj : error LNK2001: unresolved external symbol __imp__SendDlgItemMessageA@20
dpchat.obj : error LNK2001: unresolved external symbol __imp__PostMessageA@16
dpchat.obj : error LNK2001: unresolved external symbol __imp__wsprintfA
dpchat.obj : error LNK2001: unresolved external symbol __imp__SetDlgItemTextA@12
dpchat.obj : error LNK2001: unresolved external symbol __imp__GetDlgItemTextA@16
dpchat.obj : error LNK2001: unresolved external symbol __imp__MessageBoxA@16
dialog.obj : error LNK2001: unresolved external symbol __imp__MessageBoxA@16
dialog.obj : error LNK2001: unresolved external symbol __imp__GetUserNameA@8
dialog.obj : error LNK2001: unresolved external symbol __imp__SetTimer@16
dialog.obj : error LNK2001: unresolved external symbol __imp__KillTimer@8
dialog.obj : error LNK2001: unresolved external symbol __imp__EnableWindow@8
dialog.obj : error LNK2001: unresolved external symbol __imp__GetDlgItem@8
MSVCRTD.lib(crtexe.obj) : error LNK2001: unresolved external symbol _main
Debug/dpchat.exe : fatal error LNK1120: 14 unresolved externals
Error executing link.exe.

dpchat.exe - 19 error(s), 0 warning(s)

www.public.iastate.edu/~jtilton/gamepage.html

Follow Ups:

Post a Followup

Name:


Re: directx5 needed for download

Posted by mohd amri on September 26, 1998 at 19:35:30:

In Reply to: directx5 needed for download posted by THOMAS KURT on March 24, 1998 at 09:13:58:

: : : I downloaded a demo version of Curse of Monkey Island
: : : with DirectX5 download included and it worked fine.
: : : I then purchased the game, uninstalled the demo as per
: : : instructions but the purchased game freezes my whole
: : : system, screen, keyboard, mouse et al. Checking for
: : : compatability with DirectX5 indicates there is no hard-
: : : ware support for the Primary Display Driver, Primary
: : : sound Driver and Sound System Player. Why did the first
: : : DirectX5 download work but this one won't and what do I
: : : do about the problem?
: : : Thank you, any help would be greatly appreciated.
: : : Lois Nicholls

Follow Ups:

Post a Followup

Name:


Newbie at Direct3D

Posted by BJ Neilsen on September 27, 1998 at 02:31:05:

Does anyone have any links to good sites about D3D Immediate Mode?

Thanx,
BJ N

Follow Ups:

Post a Followup

Name:


Re: DirectX 5.0

Posted by Martin on September 27, 1998 at 14:09:22:

In Reply to: DirectX 5.0 posted by Luke on August 15, 1998 at 21:32:35:

Can you send me directX 5.0 or 6.0

Follow Ups:

  • Re: DirectX 5.0 Greg 04:07:41 9/28/98 (0)

Post a Followup

Name:


Re: DirectX 5.0 Download

Posted by jean sims on September 27, 1998 at 21:55:28:

In Reply to: Re: DirectX 5.0 Download posted by suhaimi on June 03, 1998 at 08:46:54:

: : : : can anyone tell me where to download it besides microsoft website?

Follow Ups:

Post a Followup

Name:


Re: Use while....WASSTILLDRAWING

Posted by Clay on September 27, 1998 at 22:19:29:

In Reply to: Re: Use while....WASSTILLDRAWING posted by Pegleg on September 26, 1998 at 17:40:49:

Well, It should have the same effect but you never know. Most of the MS demo programs use the "while" technique. Ive tried both and they seem to be about the same. Just an idea.

Clay

Follow Ups:

  • Re: Use while....WASSTILLDRAWING Pegleg 20:42:08 9/28/98 (2)
    • Re: Use while....WASSTILLDRAWING Clay 15:29:15 9/29/98 (1)
      • Re: Use while....WASSTILLDRAWING Pegleg 01:08:08 9/30/98 (0)

Post a Followup

Name:


Re: DirectX 5.0

Posted by Greg on September 28, 1998 at 04:07:41:

In Reply to: Re: DirectX 5.0 posted by Martin on September 27, 1998 at 14:09:22:

: Can you send me directX 5.0 or 6.0

Seems too be problem with my server to get it down

Follow Ups:

Post a Followup

Name:


Re: Locking and blting

Posted by Danny Oneway on September 28, 1998 at 07:07:23:

In Reply to: Re: Locking and blting posted by Clay on September 24, 1998 at 22:10:08:

: : Hmm thanks, so basicly what you're telling me is that if
: : I want fast performance I have to write my own blitting
: : routines right? If I do that the only useful part of
: : DirectDraw will be the initilization part:)

In some cases this is true :) But in other cases
DirectDraw saves a lot of time.

: : Ah well. Do you maybe know where I can get some
: : premade directdraw routines? Like fastblt with
: : and without transperancies. And maybe even alpha-blending
: : blt:) I really dont want to make those myself:)

Hmmm. No, sorry. I even don't know if you have a
fixed mode (e.g. 8 bits only, or 24/32 Bits only)
so I don't know... but I can tell you another
quite excellent page where you can get tons of
information of such things... try this one :

"http://www.angelic-coders.com"

c ya!
Danny O.

PS : are you able to code 32-bit ASM? If, why
not doing that copy-routs in inline-asm?

Follow Ups:

  • Re: Locking and blting+ asm32 Spikes 08:29:11 9/28/98 (0)

Post a Followup

Name:


Re: Locking and blting+ asm32

Posted by Spikes on September 28, 1998 at 08:29:11:

In Reply to: Re: Locking and blting posted by Danny Oneway on September 28, 1998 at 07:07:23:

: PS : are you able to code 32-bit ASM? If, why
: not doing that copy-routs in inline-asm?

=) How do I load a 32 bit pointer??
I've done some assembler coding in dos,
ans I know who to write gfx stuff for dos in asm.
But I don't know who to load a 32bit pointer
in win95! In do I used les di,??
and lds si,??
But the program krashes when I try to do the same
in vc++.

HELP!

Follow Ups:

Post a Followup

Name:


Dinput and Ddraw

Posted by Stevie W. on September 28, 1998 at 09:13:06:

I hope some one can help me, I've been trying to use
Dinput with Ddraw but I keep ending up with two windows
instead of just one. I've tried passing the Hinstance
of the window created for Ddraw and I've also tried
passing the Hinstance of the app itself (the same one
as used to open the Ddraw window), but on both ocassions
I've ended up with 2 windows.

How do I get a Ddraw window opened with Dinput attached
to it?

BTW, I'm using DirectX 5.2

Follow Ups:

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by David Mendes on September 28, 1998 at 15:40:18:

In Reply to: Re: DirectX6 FINAL RELEASE! posted by Vladimir Mitev on September 02, 1998 at 16:29:20:

: : : The FINAL version of DirectX6/SDK will be released with in 24 hours!

: : : Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

Post a Followup

Name:


Re: Use while....WASSTILLDRAWING

Posted by Pegleg on September 28, 1998 at 20:42:08:

In Reply to: Re: Use while....WASSTILLDRAWING posted by Clay on September 27, 1998 at 22:19:29:

Clay:

Well, I tried your tecnique and got the same results...slow. I also tried no "waiting" what-so ever and I still get faster results by copying that back-buffer to the primary instead of flipping. Any idea why?

I found out that about my video card, it's a Matrox G100 Productiva. It's especially designed for 2D so I don't think the card should be the problem. Any suggestions? Comments? Beatings?

Follow Ups:

  • Re: Use while....WASSTILLDRAWING Clay 15:29:15 9/29/98 (1)
    • Re: Use while....WASSTILLDRAWING Pegleg 01:08:08 9/30/98 (0)

Post a Followup

Name:


Anyone knows how to do 2D transparency with DD??

Posted by Crusader X on September 29, 1998 at 09:53:48:

In Reply to: Direct3D RM Alpha blending posted by David Adams on September 24, 1998 at 12:32:03:

Thanks for the info man! :)

I'm wondering if anyone can tell me how to do see-through transparent sprites with Direct Draw. Does it have something to do with the alpha properties in the DD surfaces???

Please drop a mail if you know anything at all!

: I started playing around w/3D for the first time yesterday, and decided to use RM. I had problems getting alpha blending to work in RM and read a couple of solutions on this forum... I have found a pretty easy one and thought I would share it...

: All you have to do is ->SetColor(R,G,B,A) on the mesh that you want to alpha.. (of course there are some device flags you have to set properly so that it will be true alpha and not just skip every other pixel alpha)

: This works great for solid colors AND texture mapped meshes (if you ->SetColor(1.0f, 1.0f, 1.0f, A) you will alpha the model WITH texture map and not change the color of the texture map on the mesh.)

: Just thought I would let any interested parties know.

: David Adams

Follow Ups:

Post a Followup

Name:


C or C++

Posted by Pegleg on September 29, 1998 at 13:10:40:

Is there any advantage to using C as opposed to C++ for Direct3D? I've been looking over the samples and C just seems like a big pain in the ass, unlike the DirectDraw C++ examples.

Follow Ups:

  • Re: C or C++ Clay 15:33:29 9/29/98 (0)

Post a Followup

Name:


Moving Around

Posted by dolce on September 29, 1998 at 14:50:49:

Using D3DRM: In a first person point of view type simulation, how should I handle player movement? I have been doing a transform/rotate on the camera frame to move around, but it is very slow (it's a room containing various objects). Should I be moving the scene around the camera, or perhaps doing something with the viewport?

Follow Ups:

Post a Followup

Name:


Re: Use while....WASSTILLDRAWING

Posted by Clay on September 29, 1998 at 15:29:15:

In Reply to: Re: Use while....WASSTILLDRAWING posted by Pegleg on September 28, 1998 at 20:42:08:

The only other thing I can think of is to completely isolate the problem. Yeah, it sucks. You said that this was not a problem under '95 on your old computer. Was that with the G100 or another card? If so, try '95 with the G100. Then try the new machine with the old card. Then if that still doesn't work, (gulp) try the new machine with '95 and the old machine with '98. Its gonna be time consuming, but you'll definately isolate the cause.

Other suggestions are welcome!

Clay

Follow Ups:

  • Re: Use while....WASSTILLDRAWING Pegleg 01:08:08 9/30/98 (0)

Post a Followup

Name:


Re: C or C++

Posted by Clay on September 29, 1998 at 15:33:29:

In Reply to: C or C++ posted by Pegleg on September 29, 1998 at 13:10:40:

Are you doing IM or RM? If you are doing RM, its going to be comparitively slow anyway so C++ won't hurt. If you are doing IM, a very nice touch is to do all your one-time-only code in C++ (re-usable) and do your rendering code in C/assembly.

Clay

: Is there any advantage to using C as opposed to C++ for Direct3D? I've been looking over the samples and C just seems like a big pain in the ass, unlike the DirectDraw C++ examples.

Follow Ups:

Post a Followup

Name:


3D math

Posted by Clay on September 29, 1998 at 18:14:20:

Anybody know where I can get a **good** description of how quaternions work. There's lots of web pages about 3D math and quaternions, but I don't exactly have a PhD in math!

Clay

Follow Ups:

  • Re: 3D math Fragmo 02:24:25 9/30/98 (0)

Post a Followup

Name:


Re: Learning DirectX programming in C

Posted by David Wright on September 30, 1998 at 00:58:00:

In Reply to: Learning DirectX programming in C posted by Andrew Ritchie on September 18, 1998 at 21:24:06:

Hey Andrew,

It's me, David Wright...from Pacoima. Small world finding you here. How's it going? I'm fairly new to DirectX as well, but I get by. Your request is kind of vague, so I don't no how much help I can give you. First of all, you should be very familiar with C\C++, otherwise your gonna have problems for a very long time. Also what compiler are you using, I'm using VC++.
Basically the way I figured things out was by copying and studying the samples, at least DDraw. Now I know enough to make a simple "Sprite" game, which I'm doing now. As for D3D, DSound, etc... I don't know jack.

(God I hope your the same Andrew I knew)

Follow Ups:

Post a Followup

Name:


Re: Use while....WASSTILLDRAWING

Posted by Pegleg on September 30, 1998 at 01:08:08:

In Reply to: Re: Use while....WASSTILLDRAWING posted by Clay on September 29, 1998 at 15:29:15:

I don't think you fully understood my pain. My old computer (win95,75MHz,Diamond somethin') seems to flip at the same speed as my new one (win98,300MHz,Matrox G100) or vica versa.
Two completly different systems, same damn speed!!!

But, thanks for the suggestions.

I have a suggestion for you Clay, write a simple program to see what is faster:
-flipping the two surfaces
-copying one to the other

If flipping is faster, than I know somethings screwed up with my program, my system, me, etc, etc.

Follow Ups:

Post a Followup

Name:


New Programmer

Posted by Matt Rogers on September 30, 1998 at 02:16:40:

Hi, I'm learning Visual Basic in College, but I'd like to learn how to make games with it using Direct X. I know VB isn't the best language for games, but everyone has to learn it first year. If anyone can email me or post a reply here about where I can learn to use VB/DX together it would be greatly appreciated! :) :)

Thanks!

Matt

Follow Ups:

Post a Followup

Name:


Re: 3D math

Posted by Fragmo on September 30, 1998 at 02:24:25:

In Reply to: 3D math posted by Clay on September 29, 1998 at 18:14:20:

dunno how good it is, but I didn't think it was too horrible

http://www.gamasutra.com/features/programming/19980703/quaternions_01.htm

: Anybody know where I can get a **good** description of how quaternions work. There's lots of web pages about 3D math and quaternions, but I don't exactly have a PhD in math!

: Clay

Follow Ups:

Post a Followup

Name:


DirectSound news group

Posted by Udo Giacomozzi on September 30, 1998 at 12:05:51:

Could you tell me please if there is a mailing list / newsgroup dedicated to DirectSound around? There are several DirectX mailings around but I need only DirectSound.
PLEASE REPLY VIA E-MAIL AT udo_giacomozzi@rolmail.net

Follow Ups:

Post a Followup

Name:


Re: DirectX6 FINAL RELEASE!

Posted by Rick Larew on September 30, 1998 at 15:16:59:

In Reply to: Re: DirectX6 FINAL RELEASE! posted by mikael on August 09, 1998 at 11:12:52:

: : The FINAL version of DirectX6/SDK will be released with in 24 hours!

: : Keep an eye on http://www.microsoft.com/directx/. check http://www.betanews.com for more news on DX6!

Follow Ups:

Post a Followup

Name:


Teleport Pro Messages

 .

http://www.geocities.com/~directx/index.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.geocities.com/~directx/new.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.geocities.com/~directx/articles.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.geocities.com/~directx/store.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.geocities.com/~directx/forum.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.geocities.com/~directx/resources.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.geocities.com/~directx/tips.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.geocities.com/~directx/contribute.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.geocities.com/~directx/about.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.geocities.com/~directx/feedback.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.geocities.com/~directx/sponsors.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.sgi.net/kmrbbyo/directx/faq.html: This file was not retrieved by Teleport Pro, because the server reports that this file cannot be found.

.

http://www.netit.net/direct3d/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.jps.net/mrhino: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.fire-storm.com/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.geocities.com/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://come.to/hexman: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://den.ontheweb.nu/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.fwb.gulf.net/~wrightdavid/mraks.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://macesoft.simplenet.com/hexxwars/index.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.geocities.com/SiliconValley/Haven/3803/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.lockergnome.com/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.cyberstation.net/~jwood/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.netit.net/direct3D/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.cs.wpi.edu/~matt/courses/cs563/talks/hwaccwin.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://home.columbus.rr.com/fpigames: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.microsoft.com/directx/resources/faq.htm: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://home.clara.net/deadly/index.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.triax.com/ben/dx5/index.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.execpc.com/~ejthayer/index.htm: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.angelic-coders.com/bpshea/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.microsoft.com/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://members.aol.com/bobyang: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://wotsit.simsware.com/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

ftp://ftp.uu.net/graphics/jpeg/jpegsrc.v6b.tar.gz: This file was not retrieved by Teleport Pro, because it is addressed using an unsupported protocol (e.g., gopher or ftp).

.

http://www.microsoft.com/directx: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.download.com/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.maidex.demon.co.uk/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://freespace.virgin.net/roger.gilbert/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.frontiernet.net/~rmd/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.vcdj.com/vcdj/dec97/3dprog.htm: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.weberaser.com/directx/index.html: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.desktopzx.com/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://redwood.stomped.com/quake/jc122396.txt: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.geocities.com/southbeach/cove/8022: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://home.braunschweig.netsurf.de/~benjamin.lippelt/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://home.braunschweig.netsurf.de/~benjamin.lippelt: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.dsg.dds.uni-de/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.microsoft.com/directx/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.

.

http://www.sgi.net/kmrbbyo/directx/messages/;;www.munhwa.co.kr: This file was not retrieved by Teleport Pro, because the server reports that this file cannot be found.